Schema Set

Namespaces
 | Element | Description
Namespace | http://smath.info/schemas/entries/1.0 |
Namespace | http://smath.info/schemas/worksheet/1.0 |
Send comments on this topic to support@smath.com


http://smath.info/schemas/entries/1.0 Namespace

Root Schemas
 | Element | Description
Schema | Entries.xsd |
Root Elements
 | Element | Description
Element | entries |
Schemas
 | Element | Description
Schema | Entries.xsd |
Elements
 | Element | Description
Element | entries |
Attributes
 | Element | Description
Attribute | ara |
Attribute | bel |
Attribute | bul |
Attribute | cat |
Attribute | chs |
Attribute | cht |
Attribute | cpp |
Attribute | cze |
Attribute | dan |
Attribute | default |
Attribute | dut |
Attribute | fas |
Attribute | fin |
Attribute | fre |
Attribute | ger |
Attribute | gre |
Attribute | heb |
Attribute | hun |
Attribute | ind |
Attribute | isl |
Attribute | ita |
Attribute | jpn |
Attribute | kor |
Attribute | lav |
Attribute | lth |
Attribute | nor |
Attribute | pol |
Attribute | por |
Attribute | ron |
Attribute | rus |
Attribute | scc |
Attribute | scr |
Attribute | slk |
Attribute | slv |
Attribute | spa |
Attribute | srp |
Attribute | swe |
Attribute | tha |
Attribute | tur |
Attribute | ukr |
Simple Types
 | Element | Description
Simple Type | factor-of-unit |
Simple Type | NonEmptyString |
Simple Type | NumericEquation |
Simple Type | prefix-of-unit |
Simple Type | system-of-measurement |
Complex Types
 | Element | Description
Complex Type | add-dimension |
Complex Type | add-prefix |
Complex Type | compoundunit |
Complex Type | compoundunits |
Complex Type | constant |
Complex Type | constant-alone |
Complex Type | constants |
Complex Type | dimensions |
Complex Type | entry-base |
Complex Type | exclude-extension |
Complex Type | extension |
Complex Type | override |
Complex Type | prefixes |
Complex Type | prefix-extension |
Complex Type | property-compoundunit |
Complex Type | property-constant |
Complex Type | property-unit |
Complex Type | synonym |
Complex Type | unit |
Complex Type | unit-alone |
Complex Type | units |


Root Schemas

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Root Schemas
 | Element | Description
Schema | Entries.xsd |


Root Elements

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Root Elements
 | Element | Description
Element | entries |


Schemas

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Schemas
 | Element | Description
Schema | Entries.xsd |


Entries.xsd Schema

Namespace: http://smath.info/schemas/entries/1.0

Elements
 | Element | Description
Element | entries |
Attributes
 | Element | Description
Attribute | ara |
Attribute | bel |
Attribute | bul |
Attribute | cat |
Attribute | chs |
Attribute | cht |
Attribute | cpp |
Attribute | cze |
Attribute | dan |
Attribute | default |
Attribute | dut |
Attribute | fas |
Attribute | fin |
Attribute | fre |
Attribute | ger |
Attribute | gre |
Attribute | heb |
Attribute | hun |
Attribute | ind |
Attribute | isl |
Attribute | ita |
Attribute | jpn |
Attribute | kor |
Attribute | lav |
Attribute | lth |
Attribute | nor |
Attribute | pol |
Attribute | por |
Attribute | ron |
Attribute | rus |
Attribute | scc |
Attribute | scr |
Attribute | slk |
Attribute | slv |
Attribute | spa |
Attribute | srp |
Attribute | swe |
Attribute | tha |
Attribute | tur |
Attribute | ukr |
Simple Types
 | Element | Description
Simple Type | factor-of-unit |
Simple Type | NonEmptyString |
Simple Type | NumericEquation |
Simple Type | prefix-of-unit |
Simple Type | system-of-measurement |
Complex Types
 | Element | Description
Complex Type | add-dimension |
Complex Type | add-prefix |
Complex Type | compoundunit |
Complex Type | compoundunits |
Complex Type | constant |
Complex Type | constant-alone |
Complex Type | constants |
Complex Type | dimensions |
Complex Type | entry-base |
Complex Type | exclude-extension |
Complex Type | extension |
Complex Type | override |
Complex Type | prefixes |
Complex Type | prefix-extension |
Complex Type | property-compoundunit |
Complex Type | property-constant |
Complex Type | property-unit |
Complex Type | synonym |
Complex Type | unit |
Complex Type | unit-alone |
Complex Type | units |


Elements

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Elements
 | Element | Description
Element | entries |


entries Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element prefixes | [0, 1] |
Element dimensions | [0, 1] |
Choice Choice |  |
Element compoundunits | [0, *] |
Element constants | [0, *] |
Element units | [0, *] |
Attributes
Name | Type | Required | Description
Any Attribute Any |  |  |
Constraints
 | Type | Description | Selector | Fields
Keyref Constraint | Key Reference |  | mstns:units/mstns:property | @dimension
Key Constraint | Key |  | mstns:dimensions/mstns:add | @id
Unique Constraint | Unique |  | mstns:dimensions/mstns:add | @baseunit
Syntax
Copy
<xs:element name="entries" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element minOccurs="0" maxOccurs="1" name="prefixes" type="mstns:prefixes" />
      <xs:element minOccurs="0" maxOccurs="1" name="dimensions" type="mstns:dimensions" />
      <xs:choice>
        <xs:element minOccurs="0" maxOccurs="unbounded" name="units" type="mstns:units" />
        <xs:element minOccurs="0" maxOccurs="unbounded" name="constants" type="mstns:constants" />
        <xs:element minOccurs="0" maxOccurs="unbounded" name="compoundunits" type="mstns:compoundunits" />
      </xs:choice>
    </xs:sequence>
    <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
  </xs:complexType>
  <xs:keyref name="prodNumKeyRef" refer="mstns:prodNumKey">
    <xs:selector xpath="mstns:units/mstns:property" />
    <xs:field xpath="@dimension" />
  </xs:keyref>
  <xs:key name="prodNumKey">
    <xs:selector xpath="mstns:dimensions/mstns:add" />
    <xs:field xpath="@id" />
  </xs:key>
  <xs:unique name="uniqueFieldId2">
    <xs:selector xpath="mstns:dimensions/mstns:add" />
    <xs:field xpath="@baseunit" />
  </xs:unique>
</xs:element>
See Also

Reference

http://smath.info/schemas/entries/1.0


prefixes Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type prefixes
Parents
Element entries
Children
Name | Occurrences | Description
Element add | [1, *] |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="prefixes" type="mstns:prefixes" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entries
http://smath.info/schemas/entries/1.0


dimensions Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type dimensions
Parents
Element entries
Children
Name | Occurrences | Description
Element add | [1, *] |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="dimensions" type="mstns:dimensions" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entries
http://smath.info/schemas/entries/1.0


units Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type units
Parents
Element entries
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="units" type="mstns:units" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entries
http://smath.info/schemas/entries/1.0


constants Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type constants
Parents
Element entries
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="constants" type="mstns:constants" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entries
http://smath.info/schemas/entries/1.0


compoundunits Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type compoundunits
Parents
Element entries
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="compoundunits" type="mstns:compoundunits" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entries
http://smath.info/schemas/entries/1.0


Attributes

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Attributes
 | Element | Description
Attribute | ara |
Attribute | bel |
Attribute | bul |
Attribute | cat |
Attribute | chs |
Attribute | cht |
Attribute | cpp |
Attribute | cze |
Attribute | dan |
Attribute | default |
Attribute | dut |
Attribute | fas |
Attribute | fin |
Attribute | fre |
Attribute | ger |
Attribute | gre |
Attribute | heb |
Attribute | hun |
Attribute | ind |
Attribute | isl |
Attribute | ita |
Attribute | jpn |
Attribute | kor |
Attribute | lav |
Attribute | lth |
Attribute | nor |
Attribute | pol |
Attribute | por |
Attribute | ron |
Attribute | rus |
Attribute | scc |
Attribute | scr |
Attribute | slk |
Attribute | slv |
Attribute | spa |
Attribute | srp |
Attribute | swe |
Attribute | tha |
Attribute | tur |
Attribute | ukr |


ara Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ara" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


bel Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="bel" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


bul Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="bul" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


cat Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="cat" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


chs Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="chs" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


cht Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="cht" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


cpp Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="cpp" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


cze Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="cze" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


dan Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="dan" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


default Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="default" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


dut Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="dut" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


fas Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="fas" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


fin Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="fin" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


fre Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="fre" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


ger Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ger" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


gre Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="gre" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


heb Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="heb" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


hun Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="hun" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


ind Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ind" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


isl Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="isl" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


ita Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ita" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


jpn Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="jpn" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


kor Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="kor" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


lav Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="lav" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


lth Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="lth" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


nor Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="nor" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


pol Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="pol" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


por Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="por" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


ron Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ron" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


rus Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="rus" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


scc Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="scc" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


scr Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="scr" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


slk Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="slk" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


slv Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="slv" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


spa Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="spa" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


srp Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="srp" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


swe Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="swe" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


tha Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="tha" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


tur Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="tur" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


ukr Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type anySimpleType
Syntax
Copy
<xs:attribute name="ukr" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

http://smath.info/schemas/entries/1.0


Simple Types

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Simple Types
 | Element | Description
Simple Type | factor-of-unit |
Simple Type | NonEmptyString |
Simple Type | NumericEquation |
Simple Type | prefix-of-unit |
Simple Type | system-of-measurement |


factor-of-unit Simple Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Item | Facet Value | Description
Union Union |  |
Restriction string |  |
Facet Enumeration | 1 | Unit will be used as base unit for the whole dimension.
Restriction string |  |
Facet Pattern | .{1,} |
Syntax
Copy
<xs:simpleType name="factor-of-unit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:union>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="1"></xs:enumeration>
      </xs:restriction>
    </xs:simpleType>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:pattern value=".{1,}" />
      </xs:restriction>
    </xs:simpleType>
  </xs:union>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/entries/1.0


NonEmptyString Simple Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Item | Facet Value | Description
Restriction string |  |
Facet Pattern | ^(?!\s*$).+ |
Usages
Attribute baseunit Attribute baseunit Attribute connection Attribute connection Attribute for Attribute name Attribute name Attribute name Attribute offset Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute title Attribute value
Syntax
Copy
<xs:simpleType name="NonEmptyString" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:pattern value="^(?!\s*$).+" />
  </xs:restriction>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/entries/1.0


NumericEquation Simple Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Item | Facet Value | Description
Restriction string |  |
Facet Pattern | ^[0-9\.πei/\-\*\^\{\}\(\)]+ |
Usages
Attribute factor Attribute factor Attribute factor
Syntax
Copy
<xs:simpleType name="NumericEquation" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:pattern value="^[0-9\.πei/\-\*\^\{\}\(\)]+" />
  </xs:restriction>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/entries/1.0


prefix-of-unit Simple Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction Name |  |
Facet Enumeration | y |
Facet Enumeration | z |
Facet Enumeration | a |
Facet Enumeration | f |
Facet Enumeration | p |
Facet Enumeration | n |
Facet Enumeration | μ |
Facet Enumeration | m |
Facet Enumeration | c |
Facet Enumeration | d |
Facet Enumeration | da |
Facet Enumeration | h |
Facet Enumeration | k |
Facet Enumeration | M |
Facet Enumeration | G |
Facet Enumeration | T |
Facet Enumeration | P |
Facet Enumeration | E |
Facet Enumeration | Z |
Facet Enumeration | Y |
Facet Enumeration | yocto |
Facet Enumeration | zepto |
Facet Enumeration | atto |
Facet Enumeration | femto |
Facet Enumeration | pico |
Facet Enumeration | nano |
Facet Enumeration | micro |
Facet Enumeration | milli |
Facet Enumeration | centi |
Facet Enumeration | deci |
Facet Enumeration | deka |
Facet Enumeration | hecto |
Facet Enumeration | kilo |
Facet Enumeration | mega |
Facet Enumeration | giga |
Facet Enumeration | tera |
Facet Enumeration | peta |
Facet Enumeration | exa |
Facet Enumeration | zetta |
Facet Enumeration | yotta |
Facet Enumeration | ki |
Facet Enumeration | Mi |
Facet Enumeration | Gi |
Facet Enumeration | Ti |
Facet Enumeration | kibi |
Facet Enumeration | mebi |
Facet Enumeration | gibi |
Facet Enumeration | tebi |
Usages
Attribute name Attribute name Attribute prefix
Syntax
Copy
<xs:simpleType name="prefix-of-unit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:Name">
        <xs:enumeration value="y" />
        <xs:enumeration value="z" />
        <xs:enumeration value="a" />
        <xs:enumeration value="f" />
        <xs:enumeration value="p" />
        <xs:enumeration value="n" />
        <xs:enumeration value="μ" />
        <xs:enumeration value="m" />
        <xs:enumeration value="c" />
        <xs:enumeration value="d" />
        <xs:enumeration value="da" />
        <xs:enumeration value="h" />
        <xs:enumeration value="k" />
        <xs:enumeration value="M" />
        <xs:enumeration value="G" />
        <xs:enumeration value="T" />
        <xs:enumeration value="P" />
        <xs:enumeration value="E" />
        <xs:enumeration value="Z" />
        <xs:enumeration value="Y" />
        <xs:enumeration value="yocto" />
        <xs:enumeration value="zepto" />
        <xs:enumeration value="atto" />
        <xs:enumeration value="femto" />
        <xs:enumeration value="pico" />
        <xs:enumeration value="nano" />
        <xs:enumeration value="micro" />
        <xs:enumeration value="milli" />
        <xs:enumeration value="centi" />
        <xs:enumeration value="deci" />
        <xs:enumeration value="deka" />
        <xs:enumeration value="hecto" />
        <xs:enumeration value="kilo" />
        <xs:enumeration value="mega" />
        <xs:enumeration value="giga" />
        <xs:enumeration value="tera" />
        <xs:enumeration value="peta" />
        <xs:enumeration value="exa" />
        <xs:enumeration value="zetta" />
        <xs:enumeration value="yotta" />
        <xs:enumeration value="ki" />
        <xs:enumeration value="Mi" />
        <xs:enumeration value="Gi" />
        <xs:enumeration value="Ti" />
        <xs:enumeration value="kibi" />
        <xs:enumeration value="mebi" />
        <xs:enumeration value="gibi" />
        <xs:enumeration value="tebi" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/entries/1.0


system-of-measurement Simple Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction NonEmptyString |  |
Facet Enumeration | All |
Facet Enumeration | Metric |
Facet Enumeration | Imperial |
Usages
Attribute system Attribute system
Syntax
Copy
<xs:simpleType name="system-of-measurement" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="mstns:NonEmptyString">
        <xs:enumeration value="All" />
        <xs:enumeration value="Metric" />
        <xs:enumeration value="Imperial" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/entries/1.0


Complex Types

The http://smath.info/schemas/entries/1.0 namespace exposes the following members.

Complex Types
 | Element | Description
Complex Type | add-dimension |
Complex Type | add-prefix |
Complex Type | compoundunit |
Complex Type | compoundunits |
Complex Type | constant |
Complex Type | constant-alone |
Complex Type | constants |
Complex Type | dimensions |
Complex Type | entry-base |
Complex Type | exclude-extension |
Complex Type | extension |
Complex Type | override |
Complex Type | prefixes |
Complex Type | prefix-extension |
Complex Type | property-compoundunit |
Complex Type | property-constant |
Complex Type | property-unit |
Complex Type | synonym |
Complex Type | unit |
Complex Type | unit-alone |
Complex Type | units |


add-dimension Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element add
Attributes
Name | Type | Required | Description
Attribute baseunit | Simple Type NonEmptyString |  |
Attribute connection | Simple Type NonEmptyString |  |
Attribute id | Simple Type positiveInteger | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="add-dimension" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="baseunit" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="connection" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="id" type="xs:positiveInteger" use="required" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


baseunit Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Complex Type add-dimension
Syntax
Copy
<xs:attribute name="baseunit" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-dimension
http://smath.info/schemas/entries/1.0


connection Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Complex Type add-dimension
Syntax
Copy
<xs:attribute name="connection" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-dimension
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Complex Type add-dimension
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-dimension
http://smath.info/schemas/entries/1.0


id Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element add Complex Type add-dimension
Syntax
Copy
<xs:attribute name="id" type="xs:positiveInteger" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-dimension
http://smath.info/schemas/entries/1.0


add-prefix Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element add
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute name | Simple Type prefix-of-unit | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="add-prefix" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="name" type="mstns:prefix-of-unit" use="required" />
  <xs:attribute name="factor" type="mstns:NumericEquation" use="required" />
  <xs:attribute name="exp" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


name Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type prefix-of-unit
Parents
Element add Complex Type add-prefix
Syntax
Copy
<xs:attribute name="name" type="mstns:prefix-of-unit" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-prefix
http://smath.info/schemas/entries/1.0


factor Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NumericEquation
Parents
Element add Complex Type add-prefix
Syntax
Copy
<xs:attribute name="factor" type="mstns:NumericEquation" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-prefix
http://smath.info/schemas/entries/1.0


exp Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Element add Complex Type add-prefix
Syntax
Copy
<xs:attribute name="exp" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

add-prefix
http://smath.info/schemas/entries/1.0


compoundunit Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element add Element add
Attributes
Name | Type | Required | Description
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Attribute value | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="compoundunit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="value" type="mstns:NonEmptyString" use="required" />
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="system" type="mstns:system-of-measurement" use="required" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


value Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Element add Complex Type compoundunit
Syntax
Copy
<xs:attribute name="value" type="mstns:NonEmptyString" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunit
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Element add Complex Type compoundunit
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunit
http://smath.info/schemas/entries/1.0


system Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type system-of-measurement
Parents
Element add Element add Complex Type compoundunit
Syntax
Copy
<xs:attribute name="system" type="mstns:system-of-measurement" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunit
http://smath.info/schemas/entries/1.0


compoundunits Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element compoundunits
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="compoundunits" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:choice>
      <xs:element maxOccurs="unbounded" name="property" type="mstns:property-compoundunit" />
      <xs:element maxOccurs="unbounded" name="add" type="mstns:compoundunit" />
    </xs:choice>
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


property Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type property-compoundunit
Parents
Complex Type compoundunits Element compoundunits
Children
Name | Occurrences | Description
Element add | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="property" type="mstns:property-compoundunit" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunits
http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type compoundunit
Parents
Complex Type compoundunits Element compoundunits
Attributes
Name | Type | Required | Description
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Attribute value | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:compoundunit" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunits
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type compoundunits Element compoundunits
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunits
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Complex Type compoundunits Element compoundunits
Syntax
Copy
<xs:attribute name="dimension" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

compoundunits
http://smath.info/schemas/entries/1.0


constant Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element add Complex Type constant-alone
Children
Name | Occurrences | Description
Element synonym | [1, *] |
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="constant" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element minOccurs="1" maxOccurs="unbounded" name="synonym" type="mstns:synonym" />
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="id" type="xs:positiveInteger" use="optional" />
  <xs:attribute name="factor" type="mstns:NumericEquation" use="required" />
  <xs:attribute name="exp" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


synonym Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type synonym
Parents
Element add Element add Complex Type constant
Attributes
Name | Type | Required | Description
Attribute name | Simple Type NonEmptyString | Yes |
Attribute prefix | Simple Type prefix-of-unit |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="1" maxOccurs="unbounded" name="synonym" type="mstns:synonym" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Element add Complex Type constant
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant
http://smath.info/schemas/entries/1.0


id Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element add Element add Complex Type constant
Syntax
Copy
<xs:attribute name="id" type="xs:positiveInteger" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant
http://smath.info/schemas/entries/1.0


factor Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NumericEquation
Parents
Element add Element add Complex Type constant
Syntax
Copy
<xs:attribute name="factor" type="mstns:NumericEquation" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant
http://smath.info/schemas/entries/1.0


exp Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Element add Element add Complex Type constant
Syntax
Copy
<xs:attribute name="exp" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant
http://smath.info/schemas/entries/1.0


constant-alone Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Base Type
Complex Type constant
Usages
Element add
Children
Name | Occurrences | Description
Element synonym | [1, *] |
Attributes
Name | Type | Required | Description
Attribute connection | Simple Type NonEmptyString |  |
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="constant-alone" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent mixed="false">
    <xs:extension base="mstns:constant">
      <xs:attribute name="connection" type="mstns:NonEmptyString" use="optional" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


connection Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Complex Type constant-alone
Syntax
Copy
<xs:attribute name="connection" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constant-alone
http://smath.info/schemas/entries/1.0


constants Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element constants
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="constants" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:choice>
      <xs:element maxOccurs="unbounded" name="property" type="mstns:property-constant" />
      <xs:element maxOccurs="unbounded" name="add" type="mstns:constant-alone" />
    </xs:choice>
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


property Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type property-constant
Parents
Complex Type constants Element constants
Children
Name | Occurrences | Description
Element add | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="property" type="mstns:property-constant" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constants
http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type constant-alone
Parents
Complex Type constants Element constants
Children
Name | Occurrences | Description
Element synonym | [1, *] |
Attributes
Name | Type | Required | Description
Attribute connection | Simple Type NonEmptyString |  |
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:constant-alone" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constants
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type constants Element constants
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constants
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Complex Type constants Element constants
Syntax
Copy
<xs:attribute name="dimension" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

constants
http://smath.info/schemas/entries/1.0


dimensions Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element dimensions
Children
Name | Occurrences | Description
Element add | [1, *] |
Syntax
Copy
<xs:complexType name="dimensions" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element name="add" type="mstns:add-dimension" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type add-dimension
Parents
Complex Type dimensions Element dimensions
Attributes
Name | Type | Required | Description
Attribute baseunit | Simple Type NonEmptyString |  |
Attribute connection | Simple Type NonEmptyString |  |
Attribute id | Simple Type positiveInteger | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element name="add" type="mstns:add-dimension" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

dimensions
http://smath.info/schemas/entries/1.0


entry-base Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Complex Type override Complex Type unit
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="entry-base" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element minOccurs="1" maxOccurs="unbounded" name="synonym" type="mstns:synonym" />
    <xs:element minOccurs="0" maxOccurs="unbounded" name="extension" type="mstns:extension" />
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="id" type="xs:positiveInteger" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


synonym Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type synonym
Parents
Element add Element add Complex Type entry-base Element override
Attributes
Name | Type | Required | Description
Attribute name | Simple Type NonEmptyString | Yes |
Attribute prefix | Simple Type prefix-of-unit |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="1" maxOccurs="unbounded" name="synonym" type="mstns:synonym" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entry-base
http://smath.info/schemas/entries/1.0


extension Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type extension
Parents
Element add Element add Complex Type entry-base Element override
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element prefix | [0, 1] |
Element exclude | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute for | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Constraints
 | Type | Description | Selector | Fields
Unique Constraint | Unique |  | mstns:prefix | @name
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="extension" type="mstns:extension" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:unique name="uniqueFieldId">
    <xs:selector xpath="mstns:prefix" />
    <xs:field xpath="@name" />
  </xs:unique>
</xs:element>
See Also

Reference

entry-base
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Element add Complex Type entry-base Element override
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entry-base
http://smath.info/schemas/entries/1.0


id Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element add Element add Complex Type entry-base Element override
Syntax
Copy
<xs:attribute name="id" type="xs:positiveInteger" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

entry-base
http://smath.info/schemas/entries/1.0


exclude-extension Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element exclude
Attributes
Name | Type | Required | Description
Attribute name | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="exclude-extension" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="name" type="mstns:NonEmptyString" use="required" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


name Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element exclude Complex Type exclude-extension
Syntax
Copy
<xs:attribute name="name" type="mstns:NonEmptyString" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

exclude-extension
http://smath.info/schemas/entries/1.0


extension Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element extension
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element prefix | [0, 1] |
Element exclude | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute for | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="extension" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence minOccurs="1" maxOccurs="unbounded">
    <xs:element minOccurs="0" name="prefix" type="mstns:prefix-extension" />
    <xs:element minOccurs="0" name="exclude" type="mstns:exclude-extension" />
  </xs:sequence>
  <xs:attribute name="for" type="mstns:NonEmptyString" use="required" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


prefix Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type prefix-extension
Parents
Complex Type extension Element extension
Attributes
Name | Type | Required | Description
Attribute id | Simple Type positiveInteger |  |
Attribute name | Simple Type prefix-of-unit | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" name="prefix" type="mstns:prefix-extension" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

extension
http://smath.info/schemas/entries/1.0


exclude Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type exclude-extension
Parents
Complex Type extension Element extension
Attributes
Name | Type | Required | Description
Attribute name | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" name="exclude" type="mstns:exclude-extension" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

extension
http://smath.info/schemas/entries/1.0


for Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type extension Element extension
Syntax
Copy
<xs:attribute name="for" type="mstns:NonEmptyString" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

extension
http://smath.info/schemas/entries/1.0


override Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Base Type
Complex Type entry-base
Usages
Element override
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute id | Simple Type positiveInteger |  |
Attribute name | Simple Type NonEmptyString | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="override" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent mixed="false">
    <xs:extension base="mstns:entry-base">
      <xs:attribute name="name" type="mstns:NonEmptyString" use="required" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


name Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type override Element override
Syntax
Copy
<xs:attribute name="name" type="mstns:NonEmptyString" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

override
http://smath.info/schemas/entries/1.0


prefixes Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element prefixes
Children
Name | Occurrences | Description
Element add | [1, *] |
Syntax
Copy
<xs:complexType name="prefixes" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element name="add" type="mstns:add-prefix" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type add-prefix
Parents
Complex Type prefixes Element prefixes
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute name | Simple Type prefix-of-unit | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element name="add" type="mstns:add-prefix" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

prefixes
http://smath.info/schemas/entries/1.0


prefix-extension Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element prefix
Attributes
Name | Type | Required | Description
Attribute id | Simple Type positiveInteger |  |
Attribute name | Simple Type prefix-of-unit | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="prefix-extension" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="name" type="mstns:prefix-of-unit" use="required" />
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="id" type="xs:positiveInteger" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


name Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type prefix-of-unit
Parents
Element prefix Complex Type prefix-extension
Syntax
Copy
<xs:attribute name="name" type="mstns:prefix-of-unit" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

prefix-extension
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element prefix Complex Type prefix-extension
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

prefix-extension
http://smath.info/schemas/entries/1.0


id Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element prefix Complex Type prefix-extension
Syntax
Copy
<xs:attribute name="id" type="xs:positiveInteger" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

prefix-extension
http://smath.info/schemas/entries/1.0


property-compoundunit Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element property
Children
Name | Occurrences | Description
Element add | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="property-compoundunit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element maxOccurs="unbounded" name="add" type="mstns:compoundunit" />
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:positiveInteger" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type compoundunit
Parents
Element property Complex Type property-compoundunit
Attributes
Name | Type | Required | Description
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Attribute value | Simple Type NonEmptyString | Yes |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:compoundunit" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-compoundunit
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element property Complex Type property-compoundunit
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-compoundunit
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element property Complex Type property-compoundunit
Syntax
Copy
<xs:attribute name="dimension" type="xs:positiveInteger" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-compoundunit
http://smath.info/schemas/entries/1.0


property-constant Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element property
Children
Name | Occurrences | Description
Element add | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="property-constant" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:element maxOccurs="unbounded" name="add" type="mstns:constant" />
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type constant
Parents
Element property Complex Type property-constant
Children
Name | Occurrences | Description
Element synonym | [1, *] |
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:constant" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-constant
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element property Complex Type property-constant
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-constant
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Element property Complex Type property-constant
Syntax
Copy
<xs:attribute name="dimension" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-constant
http://smath.info/schemas/entries/1.0


property-unit Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element property
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element override | [0, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="property-unit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:choice>
      <xs:element maxOccurs="unbounded" name="add" type="mstns:unit" />
      <xs:element minOccurs="0" maxOccurs="unbounded" name="override" type="mstns:override" />
    </xs:choice>
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:integer" use="optional" />
  <xs:attribute name="id" type="xs:positiveInteger" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type unit
Parents
Element property Complex Type property-unit
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute offset | Simple Type NonEmptyString |  |
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:unit" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-unit
http://smath.info/schemas/entries/1.0


override Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type override
Parents
Element property Complex Type property-unit
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute id | Simple Type positiveInteger |  |
Attribute name | Simple Type NonEmptyString | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="override" type="mstns:override" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-unit
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element property Complex Type property-unit
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-unit
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Element property Complex Type property-unit
Syntax
Copy
<xs:attribute name="dimension" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-unit
http://smath.info/schemas/entries/1.0


id Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type positiveInteger
Parents
Element property Complex Type property-unit
Syntax
Copy
<xs:attribute name="id" type="xs:positiveInteger" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

property-unit
http://smath.info/schemas/entries/1.0


synonym Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element synonym Element synonym
Attributes
Name | Type | Required | Description
Attribute name | Simple Type NonEmptyString | Yes |
Attribute prefix | Simple Type prefix-of-unit |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="synonym" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:attribute name="name" type="mstns:NonEmptyString" use="required" />
  <xs:attribute name="prefix" type="mstns:prefix-of-unit" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


name Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type synonym Element synonym Element synonym
Syntax
Copy
<xs:attribute name="name" type="mstns:NonEmptyString" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

synonym
http://smath.info/schemas/entries/1.0


prefix Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type prefix-of-unit
Parents
Complex Type synonym Element synonym Element synonym
Syntax
Copy
<xs:attribute name="prefix" type="mstns:prefix-of-unit" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

synonym
http://smath.info/schemas/entries/1.0


unit Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Base Type
Complex Type entry-base
Usages
Element add Complex Type unit-alone
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute offset | Simple Type NonEmptyString |  |
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="unit" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent mixed="false">
    <xs:extension base="mstns:entry-base">
      <xs:attribute name="system" type="mstns:system-of-measurement" use="required" />
      <xs:attribute name="factor" type="mstns:NumericEquation" use="required" />
      <xs:attribute name="offset" type="mstns:NonEmptyString" use="optional" />
      <xs:attribute name="exp" type="xs:integer" use="optional" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


system Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type system-of-measurement
Parents
Element add Element add Complex Type unit
Syntax
Copy
<xs:attribute name="system" type="mstns:system-of-measurement" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

unit
http://smath.info/schemas/entries/1.0


factor Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NumericEquation
Parents
Element add Element add Complex Type unit
Syntax
Copy
<xs:attribute name="factor" type="mstns:NumericEquation" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

unit
http://smath.info/schemas/entries/1.0


offset Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Element add Complex Type unit
Syntax
Copy
<xs:attribute name="offset" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

unit
http://smath.info/schemas/entries/1.0


exp Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Element add Element add Complex Type unit
Syntax
Copy
<xs:attribute name="exp" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

unit
http://smath.info/schemas/entries/1.0


unit-alone Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Base Type
Complex Type unit
Usages
Element add
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute baseunit | Simple Type NonEmptyString |  |
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute offset | Simple Type NonEmptyString |  |
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="unit-alone" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexContent mixed="false">
    <xs:extension base="mstns:unit">
      <xs:attribute name="baseunit" type="mstns:NonEmptyString" use="optional" />
    </xs:extension>
  </xs:complexContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


baseunit Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Element add Complex Type unit-alone
Syntax
Copy
<xs:attribute name="baseunit" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

unit-alone
http://smath.info/schemas/entries/1.0


units Complex Type

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Usages
Element units
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element property | [1, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:complexType name="units" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence maxOccurs="unbounded">
    <xs:choice>
      <xs:element maxOccurs="unbounded" name="property" type="mstns:property-unit" />
      <xs:element maxOccurs="unbounded" name="add" type="mstns:unit-alone" />
    </xs:choice>
  </xs:sequence>
  <xs:attribute name="title" type="mstns:NonEmptyString" use="optional" />
  <xs:attribute name="dimension" type="xs:integer" use="optional" />
  <xs:anyAttribute namespace="http://smath.info/schemas/entries/1.0" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/entries/1.0


property Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type property-unit
Parents
Complex Type units Element units
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element add | [1, *] |
Element override | [0, *] |
Attributes
Name | Type | Required | Description
Attribute dimension | Simple Type integer |  |
Attribute id | Simple Type positiveInteger |  |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="property" type="mstns:property-unit" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

units
http://smath.info/schemas/entries/1.0


add Element

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Type
Complex Type unit-alone
Parents
Complex Type units Element units
Children
Name | Occurrences | Description
Sequence Sequence | [1, *] |
Element synonym | [1, *] |
Element extension | [0, *] |
Attributes
Name | Type | Required | Description
Attribute baseunit | Simple Type NonEmptyString |  |
Attribute exp | Simple Type integer |  |
Attribute factor | Simple Type NumericEquation | Yes |
Attribute id | Simple Type positiveInteger |  |
Attribute offset | Simple Type NonEmptyString |  |
Attribute system | Simple Type system-of-measurement | Yes |
Attribute title | Simple Type NonEmptyString |  |
Any Attribute Any |  |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="add" type="mstns:unit-alone" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

units
http://smath.info/schemas/entries/1.0


title Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type NonEmptyString
Parents
Complex Type units Element units
Syntax
Copy
<xs:attribute name="title" type="mstns:NonEmptyString" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

units
http://smath.info/schemas/entries/1.0


dimension Attribute

Namespace: http://smath.info/schemas/entries/1.0

Schema: Entries.xsd

Content Type
Simple Type integer
Parents
Complex Type units Element units
Syntax
Copy
<xs:attribute name="dimension" type="xs:integer" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

units
http://smath.info/schemas/entries/1.0


http://smath.info/schemas/worksheet/1.0 Namespace

Root Schemas
 | Element | Description
Schema | Worksheet.xsd |
Root Elements
 | Element | Description
Element | worksheet | Worksheet data container. This is the root element of the XML file.
Schemas
 | Element | Description
Schema | Worksheet.xsd |
Elements
 | Element | Description
Element | worksheet | Worksheet data container. This is the root element of the XML file.
Simple Types
 | Element | Description
Simple Type | background-image-size |
Simple Type | boolean-options |
Simple Type | fractions-string |
Simple Type | guid-string |
Simple Type | non-empty-string |
Simple Type | print-orientation |
Simple Type | regions-list-kind |
Complex Types
 | Element | Description
Complex Type | assembly |
Complex Type | author |
Complex Type | back |
Complex Type | backgrounds |
Complex Type | calculation | Container for the local calculation options used on by Worksheet generator.
Complex Type | company |
Complex Type | dependences |
Complex Type | description |
Complex Type | editable |
Complex Type | exponentialThreshold |
Complex Type | footer |
Complex Type | fractions |
Complex Type | header |
Complex Type | home |
Complex Type | id |
Complex Type | identity | Container for the Worksheet identification information.
Complex Type | image |
Complex Type | keywords |
Complex Type | margins |
Complex Type | metadata-region | Container for the Region meta-data.
Complex Type | metadata-worksheet | Container for the Worksheet meta-data needed to describe a document.
Complex Type | pageModel |
Complex Type | paper |
Complex Type | precision |
Complex Type | region | Container for the Region and it's content.
Complex Type | regions | Regions container of the Worksheet.
Complex Type | revision |
Complex Type | settings | Container for the local settings used on by Worksheet generator.
Complex Type | shortcut |
Complex Type | title |
Complex Type | translator |
Complex Type | value |


Root Schemas

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Root Schemas
 | Element | Description
Schema | Worksheet.xsd |


Root Elements

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Root Elements
 | Element | Description
Element | worksheet | Worksheet data container. This is the root element of the XML file.


Schemas

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Schemas
 | Element | Description
Schema | Worksheet.xsd |


Worksheet.xsd Schema

Namespace: http://smath.info/schemas/worksheet/1.0

Elements
 | Element | Description
Element | worksheet | Worksheet data container. This is the root element of the XML file.
Simple Types
 | Element | Description
Simple Type | background-image-size |
Simple Type | boolean-options |
Simple Type | fractions-string |
Simple Type | guid-string |
Simple Type | non-empty-string |
Simple Type | print-orientation |
Simple Type | regions-list-kind |
Complex Types
 | Element | Description
Complex Type | assembly |
Complex Type | author |
Complex Type | back |
Complex Type | backgrounds |
Complex Type | calculation | Container for the local calculation options used on by Worksheet generator.
Complex Type | company |
Complex Type | dependences |
Complex Type | description |
Complex Type | editable |
Complex Type | exponentialThreshold |
Complex Type | footer |
Complex Type | fractions |
Complex Type | header |
Complex Type | home |
Complex Type | id |
Complex Type | identity | Container for the Worksheet identification information.
Complex Type | image |
Complex Type | keywords |
Complex Type | margins |
Complex Type | metadata-region | Container for the Region meta-data.
Complex Type | metadata-worksheet | Container for the Worksheet meta-data needed to describe a document.
Complex Type | pageModel |
Complex Type | paper |
Complex Type | precision |
Complex Type | region | Container for the Region and it's content.
Complex Type | regions | Regions container of the Worksheet.
Complex Type | revision |
Complex Type | settings | Container for the local settings used on by Worksheet generator.
Complex Type | shortcut |
Complex Type | title |
Complex Type | translator |
Complex Type | value |


Elements

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Elements
 | Element | Description
Element | worksheet | Worksheet data container. This is the root element of the XML file.


worksheet Element

Worksheet data container. This is the root element of the XML file.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Children
Name | Occurrences | Description
Sequence Sequence |  |
Element settings |  | Container for the local settings used on by Worksheet generator.
Element regions | [1, *] | Regions container of the Worksheet.
Syntax
Copy
<xs:element name="worksheet" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element maxOccurs="1" name="settings" type="settings" />
      <xs:element maxOccurs="unbounded" name="regions" type="regions" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


settings Element

Container for the local settings used on by Worksheet generator.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type settings
Parents
Element worksheet
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element editable | [0, 1] |
Element home | [0, 1] |
Element back | [0, 1] |
Element shortcut | [0, 1] |
Element identity |  | Container for the Worksheet identification information.
Element metadata | [0, *] | Container for the Worksheet meta-data needed to describe a document.
Element calculation |  | Container for the local calculation options used on by Worksheet generator.
Element pageModel |  |
Choice Choice |  |
Element dependences |  |
Element dependencies |  |
Attributes
Name | Type | Required | Description
Attribute ppi | Simple Type integer | Yes |
Syntax
Copy
<xs:element maxOccurs="1" name="settings" type="settings" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

worksheet
http://smath.info/schemas/worksheet/1.0


regions Element

Regions container of the Worksheet.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type regions
Parents
Element worksheet
Children
Name | Occurrences | Description
Element region | [1, *] | Container for the Region and it's content.
Attributes
Name | Type | Required | Description
Attribute type | Simple Type regions-list-kind | Yes |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="regions" type="regions" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

worksheet
http://smath.info/schemas/worksheet/1.0


Simple Types

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Simple Types
 | Element | Description
Simple Type | background-image-size |
Simple Type | boolean-options |
Simple Type | fractions-string |
Simple Type | guid-string |
Simple Type | non-empty-string |
Simple Type | print-orientation |
Simple Type | regions-list-kind |


background-image-size Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction string |  |
Facet Enumeration | fit |
Facet Enumeration | stretch |
Facet Enumeration | fill |
Usages
Attribute size
Syntax
Copy
<xs:simpleType name="background-image-size" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="fit" />
        <xs:enumeration value="stretch" />
        <xs:enumeration value="fill" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


boolean-options Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction string |  |
Facet Enumeration | true |
Facet Enumeration | false |
Facet Enumeration | True |
Facet Enumeration | False |
Usages
Attribute active Attribute border Complex Type editable Attribute printAreas Attribute printBackgroundImages Attribute printGrid Attribute showInputData Element significantDigitsMode Attribute simpleEqualsOnly Element trailingZeros
Syntax
Copy
<xs:simpleType name="boolean-options" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="true" />
        <xs:enumeration value="false" />
        <xs:enumeration value="True" />
        <xs:enumeration value="False" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


fractions-string Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction string |  |
Facet Enumeration | auto |
Facet Enumeration | fraction |
Facet Enumeration | decimal |
Usages
Element fractions
Syntax
Copy
<xs:simpleType name="fractions-string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="auto" />
        <xs:enumeration value="fraction" />
        <xs:enumeration value="decimal" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


guid-string Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
Restriction string |  |
Facet Pattern | [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12} |
Usages
Attribute guid Complex Type id
Syntax
Copy
<xs:simpleType name="guid-string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
  </xs:restriction>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


non-empty-string Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
Restriction string |  |
Facet Min Length | 1 |
Usages
Attribute name Attribute name Attribute version
Syntax
Copy
<xs:simpleType name="non-empty-string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:restriction base="xs:string">
    <xs:minLength value="1" />
  </xs:restriction>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


print-orientation Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction string |  |
Facet Enumeration | Portrait |
Facet Enumeration | Landscape |
Usages
Attribute orientation
Syntax
Copy
<xs:simpleType name="print-orientation" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="Portrait" />
        <xs:enumeration value="Landscape" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


regions-list-kind Simple Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Item | Facet Value | Description
List List |  |
Restriction string |  |
Facet Enumeration | header |
Facet Enumeration | content |
Facet Enumeration | footer |
Usages
Attribute type
Syntax
Copy
<xs:simpleType name="regions-list-kind" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:list>
    <xs:simpleType>
      <xs:restriction base="xs:string">
        <xs:enumeration value="header" />
        <xs:enumeration value="content" />
        <xs:enumeration value="footer" />
      </xs:restriction>
    </xs:simpleType>
  </xs:list>
</xs:simpleType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


Complex Types

The http://smath.info/schemas/worksheet/1.0 namespace exposes the following members.

Complex Types
 | Element | Description
Complex Type | assembly |
Complex Type | author |
Complex Type | back |
Complex Type | backgrounds |
Complex Type | calculation | Container for the local calculation options used on by Worksheet generator.
Complex Type | company |
Complex Type | dependences |
Complex Type | description |
Complex Type | editable |
Complex Type | exponentialThreshold |
Complex Type | footer |
Complex Type | fractions |
Complex Type | header |
Complex Type | home |
Complex Type | id |
Complex Type | identity | Container for the Worksheet identification information.
Complex Type | image |
Complex Type | keywords |
Complex Type | margins |
Complex Type | metadata-region | Container for the Region meta-data.
Complex Type | metadata-worksheet | Container for the Worksheet meta-data needed to describe a document.
Complex Type | pageModel |
Complex Type | paper |
Complex Type | precision |
Complex Type | region | Container for the Region and it's content.
Complex Type | regions | Regions container of the Worksheet.
Complex Type | revision |
Complex Type | settings | Container for the local settings used on by Worksheet generator.
Complex Type | shortcut |
Complex Type | title |
Complex Type | translator |
Complex Type | value |


assembly Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element assembly
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute guid | Simple Type guid-string | Yes |
Attribute name | Simple Type non-empty-string | Yes |
Attribute version | Simple Type non-empty-string | Yes |
Syntax
Copy
<xs:complexType name="assembly" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence />
  <xs:attribute name="name" type="non-empty-string" use="required" />
  <xs:attribute name="version" type="non-empty-string" use="required" />
  <xs:attribute name="guid" type="guid-string" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


name Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type non-empty-string
Parents
Complex Type assembly Element assembly
Syntax
Copy
<xs:attribute name="name" type="non-empty-string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

assembly
http://smath.info/schemas/worksheet/1.0


version Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type non-empty-string
Parents
Complex Type assembly Element assembly
Syntax
Copy
<xs:attribute name="version" type="non-empty-string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

assembly
http://smath.info/schemas/worksheet/1.0


guid Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type guid-string
Parents
Complex Type assembly Element assembly
Syntax
Copy
<xs:attribute name="guid" type="guid-string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

assembly
http://smath.info/schemas/worksheet/1.0


author Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element author
Syntax
Copy
<xs:complexType name="author" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


back Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element back
Syntax
Copy
<xs:complexType name="back" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


backgrounds Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element backgrounds
Children
Name | Occurrences | Description
Element image | [0, *] |
Syntax
Copy
<xs:complexType name="backgrounds" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element minOccurs="0" maxOccurs="unbounded" name="image" type="image" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


image Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type image
Content Type
Simple Type string
Parents
Complex Type backgrounds Element backgrounds
Attributes
Name | Type | Required | Description
Attribute fullPage | Simple Type boolean |  |
Attribute page | Simple Type int |  |
Attribute size | Simple Type background-image-size |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="image" type="image" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

backgrounds
http://smath.info/schemas/worksheet/1.0


calculation Complex Type

Container for the local calculation options used on by Worksheet generator.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element calculation
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element precision | [0, 1] |
Element exponentialThreshold | [0, 1] |
Element trailingZeros | [0, 1] |
Element significantDigitsMode | [0, 1] |
Element roundingMode | [0, 1] |
Element fractions | [0, 1] |
Syntax
Copy
<xs:complexType name="calculation" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element minOccurs="0" maxOccurs="1" name="precision" type="precision" />
    <xs:element minOccurs="0" maxOccurs="1" name="exponentialThreshold" type="exponentialThreshold" />
    <xs:element minOccurs="0" maxOccurs="1" name="trailingZeros" type="boolean-options" />
    <xs:element minOccurs="0" maxOccurs="1" name="significantDigitsMode" type="boolean-options" />
    <xs:element minOccurs="0" maxOccurs="1" name="roundingMode" type="xs:integer" />
    <xs:element minOccurs="0" maxOccurs="1" name="fractions" type="fractions-string" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


precision Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type precision
Content Type
Simple Type integer
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="precision" type="precision" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


exponentialThreshold Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type exponentialThreshold
Content Type
Simple Type integer
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="exponentialThreshold" type="exponentialThreshold" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


trailingZeros Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="trailingZeros" type="boolean-options" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


significantDigitsMode Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="significantDigitsMode" type="boolean-options" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


roundingMode Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type integer
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="roundingMode" type="xs:integer" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


fractions Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type fractions-string
Parents
Complex Type calculation Element calculation
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="fractions" type="fractions-string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

calculation
http://smath.info/schemas/worksheet/1.0


company Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element company
Syntax
Copy
<xs:complexType name="company" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


dependences Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element dependences Element dependencies
Children
Name | Occurrences | Description
Element assembly | [1, *] |
Syntax
Copy
<xs:complexType name="dependences" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element maxOccurs="unbounded" name="assembly" type="assembly" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


assembly Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type assembly
Parents
Complex Type dependences Element dependences Element dependencies
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute guid | Simple Type guid-string | Yes |
Attribute name | Simple Type non-empty-string | Yes |
Attribute version | Simple Type non-empty-string | Yes |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="assembly" type="assembly" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

dependences
http://smath.info/schemas/worksheet/1.0


description Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element description
Syntax
Copy
<xs:complexType name="description" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


editable Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type boolean-options
Content Type
Simple Type boolean-options
Usages
Element editable
Syntax
Copy
<xs:complexType name="editable" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="boolean-options" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


exponentialThreshold Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type integer
Content Type
Simple Type integer
Usages
Element exponentialThreshold
Syntax
Copy
<xs:complexType name="exponentialThreshold" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:integer" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


footer Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element footer
Attributes
Name | Type | Required | Description
Attribute alignment | Simple Type string | Yes |
Attribute color | Simple Type string | Yes |
Syntax
Copy
<xs:complexType name="footer" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="alignment" type="xs:string" use="required" />
      <xs:attribute name="color" type="xs:string" use="required" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


alignment Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type footer Element footer
Syntax
Copy
<xs:attribute name="alignment" type="xs:string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

footer
http://smath.info/schemas/worksheet/1.0


color Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type footer Element footer
Syntax
Copy
<xs:attribute name="color" type="xs:string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

footer
http://smath.info/schemas/worksheet/1.0


fractions Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type integer
Content Type
Simple Type integer
Syntax
Copy
<xs:complexType name="fractions" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:integer" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


header Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element header
Attributes
Name | Type | Required | Description
Attribute alignment | Simple Type string | Yes |
Attribute color | Simple Type string | Yes |
Syntax
Copy
<xs:complexType name="header" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="alignment" type="xs:string" use="required" />
      <xs:attribute name="color" type="xs:string" use="required" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


alignment Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type header Element header
Syntax
Copy
<xs:attribute name="alignment" type="xs:string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

header
http://smath.info/schemas/worksheet/1.0


color Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type header Element header
Syntax
Copy
<xs:attribute name="color" type="xs:string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

header
http://smath.info/schemas/worksheet/1.0


home Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element home
Syntax
Copy
<xs:complexType name="home" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


id Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type guid-string
Content Type
Simple Type guid-string
Usages
Element id
Syntax
Copy
<xs:complexType name="id" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="guid-string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


identity Complex Type

Container for the Worksheet identification information.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element identity
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element id |  |
Element revision |  |
Syntax
Copy
<xs:complexType name="identity" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element maxOccurs="1" name="id" type="id" />
    <xs:element maxOccurs="1" name="revision" type="xs:string" />
  </xs:sequence>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


id Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type id
Content Type
Simple Type guid-string
Parents
Complex Type identity Element identity
Syntax
Copy
<xs:element maxOccurs="1" name="id" type="id" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

identity
http://smath.info/schemas/worksheet/1.0


revision Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type identity Element identity
Syntax
Copy
<xs:element maxOccurs="1" name="revision" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

identity
http://smath.info/schemas/worksheet/1.0


image Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element image
Attributes
Name | Type | Required | Description
Attribute fullPage | Simple Type boolean |  |
Attribute page | Simple Type int |  |
Attribute size | Simple Type background-image-size |  |
Syntax
Copy
<xs:complexType name="image" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="page" type="xs:int" use="optional" />
      <xs:attribute name="fullPage" type="xs:boolean" use="optional" />
      <xs:attribute name="size" type="background-image-size" use="optional" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


page Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type image Element image
Syntax
Copy
<xs:attribute name="page" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

image
http://smath.info/schemas/worksheet/1.0


fullPage Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean
Parents
Complex Type image Element image
Syntax
Copy
<xs:attribute name="fullPage" type="xs:boolean" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

image
http://smath.info/schemas/worksheet/1.0


size Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type background-image-size
Parents
Complex Type image Element image
Syntax
Copy
<xs:attribute name="size" type="background-image-size" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

image
http://smath.info/schemas/worksheet/1.0


keywords Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element keywords
Syntax
Copy
<xs:complexType name="keywords" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


margins Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element margins
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute bottom | Simple Type int | Yes |
Attribute left | Simple Type int | Yes |
Attribute right | Simple Type int | Yes |
Attribute top | Simple Type int | Yes |
Syntax
Copy
<xs:complexType name="margins" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence />
  <xs:attribute name="left" type="xs:int" use="required" />
  <xs:attribute name="right" type="xs:int" use="required" />
  <xs:attribute name="top" type="xs:int" use="required" />
  <xs:attribute name="bottom" type="xs:int" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


left Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type margins Element margins
Syntax
Copy
<xs:attribute name="left" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

margins
http://smath.info/schemas/worksheet/1.0


right Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type margins Element margins
Syntax
Copy
<xs:attribute name="right" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

margins
http://smath.info/schemas/worksheet/1.0


top Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type margins Element margins
Syntax
Copy
<xs:attribute name="top" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

margins
http://smath.info/schemas/worksheet/1.0


bottom Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type margins Element margins
Syntax
Copy
<xs:attribute name="bottom" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

margins
http://smath.info/schemas/worksheet/1.0


metadata-region Complex Type

Container for the Region meta-data.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element metadata
Children
Name | Occurrences | Description
Element value | [0, *] |
Syntax
Copy
<xs:complexType name="metadata-region" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice maxOccurs="unbounded">
    <xs:element minOccurs="0" maxOccurs="1" name="value" type="value" />
  </xs:choice>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


value Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type value
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-region
Attributes
Name | Type | Required | Description
Attribute lang | Simple Type string |  |
Attribute name | Simple Type non-empty-string | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="value" type="value" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-region
http://smath.info/schemas/worksheet/1.0


metadata-worksheet Complex Type

Container for the Worksheet meta-data needed to describe a document.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element metadata
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element author | [0, 1] |
Element company | [0, 1] |
Element description | [0, 1] |
Element keywords | [0, 1] |
Element title | [0, 1] |
Element translator | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute lang | Simple Type string | Yes |
Syntax
Copy
<xs:complexType name="metadata-worksheet" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:choice maxOccurs="unbounded">
    <xs:element minOccurs="0" maxOccurs="1" name="title" type="title" />
    <xs:element minOccurs="0" maxOccurs="1" name="author" type="author" />
    <xs:element minOccurs="0" maxOccurs="1" name="translator" type="translator" />
    <xs:element minOccurs="0" maxOccurs="1" name="description" type="description" />
    <xs:element minOccurs="0" maxOccurs="1" name="company" type="company" />
    <xs:element minOccurs="0" maxOccurs="1" name="keywords" type="keywords" />
  </xs:choice>
  <xs:attribute name="lang" type="xs:string" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


title Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type title
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="title" type="title" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


author Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type author
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="author" type="author" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


translator Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type translator
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="translator" type="translator" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


description Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type description
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="description" type="description" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


company Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type company
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="company" type="company" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


keywords Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type keywords
Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="keywords" type="keywords" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


lang Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Element metadata Complex Type metadata-worksheet
Syntax
Copy
<xs:attribute name="lang" type="xs:string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

metadata-worksheet
http://smath.info/schemas/worksheet/1.0


pageModel Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element pageModel
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element paper | [0, 1] |
Element margins | [0, 1] |
Element header | [0, 1] |
Element footer | [0, 1] |
Element backgrounds | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute active | Simple Type boolean-options |  |
Attribute printAreas | Simple Type boolean-options | Yes |
Attribute printBackgroundImages | Simple Type boolean-options | Yes |
Attribute printGrid | Simple Type boolean-options | Yes |
Attribute simpleEqualsOnly | Simple Type boolean-options | Yes |
Attribute viewMode | Simple Type int | Yes |
Syntax
Copy
<xs:complexType name="pageModel" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element minOccurs="0" maxOccurs="1" name="paper" type="paper" />
    <xs:element minOccurs="0" maxOccurs="1" name="margins" type="margins" />
    <xs:element minOccurs="0" maxOccurs="1" name="header" type="header" />
    <xs:element minOccurs="0" maxOccurs="1" name="footer" type="footer" />
    <xs:element minOccurs="0" maxOccurs="1" name="backgrounds" type="backgrounds" />
  </xs:sequence>
  <xs:attribute name="active" type="boolean-options" use="optional" />
  <xs:attribute name="viewMode" type="xs:int" use="required" />
  <xs:attribute name="printGrid" type="boolean-options" use="required" />
  <xs:attribute name="printAreas" type="boolean-options" use="required" />
  <xs:attribute name="simpleEqualsOnly" type="boolean-options" use="required" />
  <xs:attribute name="printBackgroundImages" type="boolean-options" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


paper Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type paper
Parents
Complex Type pageModel Element pageModel
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute height | Simple Type int | Yes |
Attribute id | Simple Type int | Yes |
Attribute orientation | Simple Type print-orientation | Yes |
Attribute width | Simple Type int | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="paper" type="paper" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


margins Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type margins
Parents
Complex Type pageModel Element pageModel
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute bottom | Simple Type int | Yes |
Attribute left | Simple Type int | Yes |
Attribute right | Simple Type int | Yes |
Attribute top | Simple Type int | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="margins" type="margins" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


header Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type header
Content Type
Simple Type string
Parents
Complex Type pageModel Element pageModel
Attributes
Name | Type | Required | Description
Attribute alignment | Simple Type string | Yes |
Attribute color | Simple Type string | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="header" type="header" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


footer Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type footer
Content Type
Simple Type string
Parents
Complex Type pageModel Element pageModel
Attributes
Name | Type | Required | Description
Attribute alignment | Simple Type string | Yes |
Attribute color | Simple Type string | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="footer" type="footer" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


backgrounds Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type backgrounds
Parents
Complex Type pageModel Element pageModel
Children
Name | Occurrences | Description
Element image | [0, *] |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="backgrounds" type="backgrounds" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


active Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="active" type="boolean-options" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


viewMode Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="viewMode" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


printGrid Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="printGrid" type="boolean-options" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


printAreas Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="printAreas" type="boolean-options" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


simpleEqualsOnly Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="simpleEqualsOnly" type="boolean-options" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


printBackgroundImages Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type pageModel Element pageModel
Syntax
Copy
<xs:attribute name="printBackgroundImages" type="boolean-options" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

pageModel
http://smath.info/schemas/worksheet/1.0


paper Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element paper
Children
Name | Occurrences | Description
Sequence Sequence |  |
Attributes
Name | Type | Required | Description
Attribute height | Simple Type int | Yes |
Attribute id | Simple Type int | Yes |
Attribute orientation | Simple Type print-orientation | Yes |
Attribute width | Simple Type int | Yes |
Syntax
Copy
<xs:complexType name="paper" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence />
  <xs:attribute name="id" type="xs:int" use="required" />
  <xs:attribute name="orientation" type="print-orientation" use="required" />
  <xs:attribute name="width" type="xs:int" use="required" />
  <xs:attribute name="height" type="xs:int" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


id Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type paper Element paper
Syntax
Copy
<xs:attribute name="id" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

paper
http://smath.info/schemas/worksheet/1.0


orientation Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type print-orientation
Parents
Complex Type paper Element paper
Syntax
Copy
<xs:attribute name="orientation" type="print-orientation" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

paper
http://smath.info/schemas/worksheet/1.0


width Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type paper Element paper
Syntax
Copy
<xs:attribute name="width" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

paper
http://smath.info/schemas/worksheet/1.0


height Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type paper Element paper
Syntax
Copy
<xs:attribute name="height" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

paper
http://smath.info/schemas/worksheet/1.0


precision Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type integer
Content Type
Simple Type integer
Usages
Element precision
Syntax
Copy
<xs:complexType name="precision" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:integer" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


region Complex Type

Container for the Region and it's content.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element region Element region
Children
Name | Occurrences | Description
Sequence Sequence |  |
Any Element Any |  |
Element region | [0, *] | Container for the Region and it's content.
Element metadata | [0, 1] | Container for the Region meta-data.
Attributes
Name | Type | Required | Description
Attribute bgColor | Simple Type string |  |
Attribute border | Simple Type boolean-options |  |
Attribute color | Simple Type string |  |
Attribute fontSize | Simple Type int |  |
Attribute height | Simple Type int |  |
Attribute id | Simple Type int |  |
Attribute left | Simple Type int |  |
Attribute showInputData | Simple Type boolean-options |  |
Attribute top | Simple Type int | Yes |
Attribute width | Simple Type int |  |
Syntax
Copy
<xs:complexType name="region" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:any minOccurs="1" maxOccurs="1" processContents="skip" />
    <xs:element minOccurs="0" maxOccurs="unbounded" name="region" type="region" />
    <xs:element minOccurs="0" maxOccurs="1" name="metadata" type="metadata-region" />
  </xs:sequence>
  <xs:attribute name="id" type="xs:int" use="optional" />
  <xs:attribute name="left" type="xs:int" use="optional" />
  <xs:attribute name="top" type="xs:int" use="required" />
  <xs:attribute name="width" type="xs:int" use="optional" />
  <xs:attribute name="height" type="xs:int" use="optional" />
  <xs:attribute name="color" type="xs:string" use="optional" />
  <xs:attribute name="bgColor" type="xs:string" use="optional" />
  <xs:attribute name="fontSize" type="xs:int" use="optional" />
  <xs:attribute name="border" type="boolean-options" use="optional" />
  <xs:attribute name="showInputData" type="boolean-options" use="optional" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


region Element

Container for the Region and it's content.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type region
Parents
Complex Type region Element region Element region
Children
Name | Occurrences | Description
Sequence Sequence |  |
Any Element Any |  |
Element region | [0, *] | Container for the Region and it's content.
Element metadata | [0, 1] | Container for the Region meta-data.
Attributes
Name | Type | Required | Description
Attribute bgColor | Simple Type string |  |
Attribute border | Simple Type boolean-options |  |
Attribute color | Simple Type string |  |
Attribute fontSize | Simple Type int |  |
Attribute height | Simple Type int |  |
Attribute id | Simple Type int |  |
Attribute left | Simple Type int |  |
Attribute showInputData | Simple Type boolean-options |  |
Attribute top | Simple Type int | Yes |
Attribute width | Simple Type int |  |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="region" type="region" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


metadata Element

Container for the Region meta-data.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type metadata-region
Parents
Complex Type region Element region Element region
Children
Name | Occurrences | Description
Element value | [0, *] |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="metadata" type="metadata-region" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


id Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="id" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


left Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="left" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


top Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="top" type="xs:int" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


width Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="width" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


height Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="height" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


color Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="color" type="xs:string" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


bgColor Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="bgColor" type="xs:string" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


fontSize Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type int
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="fontSize" type="xs:int" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


border Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="border" type="boolean-options" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


showInputData Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type boolean-options
Parents
Complex Type region Element region Element region
Syntax
Copy
<xs:attribute name="showInputData" type="boolean-options" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

region
http://smath.info/schemas/worksheet/1.0


regions Complex Type

Regions container of the Worksheet.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element regions
Children
Name | Occurrences | Description
Element region | [1, *] | Container for the Region and it's content.
Attributes
Name | Type | Required | Description
Attribute type | Simple Type regions-list-kind | Yes |
Syntax
Copy
<xs:complexType name="regions" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element maxOccurs="unbounded" name="region" type="region" />
  </xs:sequence>
  <xs:attribute name="type" type="regions-list-kind" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


region Element

Container for the Region and it's content.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type region
Parents
Complex Type regions Element regions
Children
Name | Occurrences | Description
Sequence Sequence |  |
Any Element Any |  |
Element region | [0, *] | Container for the Region and it's content.
Element metadata | [0, 1] | Container for the Region meta-data.
Attributes
Name | Type | Required | Description
Attribute bgColor | Simple Type string |  |
Attribute border | Simple Type boolean-options |  |
Attribute color | Simple Type string |  |
Attribute fontSize | Simple Type int |  |
Attribute height | Simple Type int |  |
Attribute id | Simple Type int |  |
Attribute left | Simple Type int |  |
Attribute showInputData | Simple Type boolean-options |  |
Attribute top | Simple Type int | Yes |
Attribute width | Simple Type int |  |
Syntax
Copy
<xs:element maxOccurs="unbounded" name="region" type="region" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

regions
http://smath.info/schemas/worksheet/1.0


type Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type regions-list-kind
Parents
Complex Type regions Element regions
Syntax
Copy
<xs:attribute name="type" type="regions-list-kind" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

regions
http://smath.info/schemas/worksheet/1.0


revision Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type integer
Content Type
Simple Type integer
Syntax
Copy
<xs:complexType name="revision" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:integer" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


settings Complex Type

Container for the local settings used on by Worksheet generator.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Usages
Element settings
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element editable | [0, 1] |
Element home | [0, 1] |
Element back | [0, 1] |
Element shortcut | [0, 1] |
Element identity |  | Container for the Worksheet identification information.
Element metadata | [0, *] | Container for the Worksheet meta-data needed to describe a document.
Element calculation |  | Container for the local calculation options used on by Worksheet generator.
Element pageModel |  |
Choice Choice |  |
Element dependences |  |
Element dependencies |  |
Attributes
Name | Type | Required | Description
Attribute ppi | Simple Type integer | Yes |
Syntax
Copy
<xs:complexType name="settings" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element minOccurs="0" maxOccurs="1" name="editable" type="editable" />
    <xs:element minOccurs="0" maxOccurs="1" name="home" type="home" />
    <xs:element minOccurs="0" maxOccurs="1" name="back" type="back" />
    <xs:element minOccurs="0" maxOccurs="1" name="shortcut" type="shortcut" />
    <xs:element maxOccurs="1" name="identity" type="identity" />
    <xs:element minOccurs="0" maxOccurs="unbounded" name="metadata" type="metadata-worksheet" />
    <xs:element maxOccurs="1" name="calculation" type="calculation" />
    <xs:element maxOccurs="1" name="pageModel" type="pageModel" />
    <xs:choice maxOccurs="1">
      <xs:element maxOccurs="1" name="dependences" type="dependences" />
      <xs:element maxOccurs="1" name="dependencies" type="dependences" />
    </xs:choice>
  </xs:sequence>
  <xs:attribute name="ppi" type="xs:integer" use="required" />
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


editable Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type editable
Content Type
Simple Type boolean-options
Parents
Complex Type settings Element settings
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="editable" type="editable" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


home Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type home
Content Type
Simple Type string
Parents
Complex Type settings Element settings
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="home" type="home" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


back Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type back
Content Type
Simple Type string
Parents
Complex Type settings Element settings
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="back" type="back" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


shortcut Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type shortcut
Content Type
Simple Type string
Parents
Complex Type settings Element settings
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="1" name="shortcut" type="shortcut" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


identity Element

Container for the Worksheet identification information.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type identity
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element id |  |
Element revision |  |
Syntax
Copy
<xs:element maxOccurs="1" name="identity" type="identity" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


metadata Element

Container for the Worksheet meta-data needed to describe a document.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type metadata-worksheet
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Choice Choice | [1, *] |
Element author | [0, 1] |
Element company | [0, 1] |
Element description | [0, 1] |
Element keywords | [0, 1] |
Element title | [0, 1] |
Element translator | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute lang | Simple Type string | Yes |
Syntax
Copy
<xs:element minOccurs="0" maxOccurs="unbounded" name="metadata" type="metadata-worksheet" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


calculation Element

Container for the local calculation options used on by Worksheet generator.

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type calculation
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element precision | [0, 1] |
Element exponentialThreshold | [0, 1] |
Element trailingZeros | [0, 1] |
Element significantDigitsMode | [0, 1] |
Element roundingMode | [0, 1] |
Element fractions | [0, 1] |
Syntax
Copy
<xs:element maxOccurs="1" name="calculation" type="calculation" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


pageModel Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type pageModel
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Sequence Sequence |  |
Element paper | [0, 1] |
Element margins | [0, 1] |
Element header | [0, 1] |
Element footer | [0, 1] |
Element backgrounds | [0, 1] |
Attributes
Name | Type | Required | Description
Attribute active | Simple Type boolean-options |  |
Attribute printAreas | Simple Type boolean-options | Yes |
Attribute printBackgroundImages | Simple Type boolean-options | Yes |
Attribute printGrid | Simple Type boolean-options | Yes |
Attribute simpleEqualsOnly | Simple Type boolean-options | Yes |
Attribute viewMode | Simple Type int | Yes |
Syntax
Copy
<xs:element maxOccurs="1" name="pageModel" type="pageModel" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


dependences Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type dependences
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Element assembly | [1, *] |
Syntax
Copy
<xs:element maxOccurs="1" name="dependences" type="dependences" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


dependencies Element

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Type
Complex Type dependences
Parents
Complex Type settings Element settings
Children
Name | Occurrences | Description
Element assembly | [1, *] |
Syntax
Copy
<xs:element maxOccurs="1" name="dependencies" type="dependences" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


ppi Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type integer
Parents
Complex Type settings Element settings
Syntax
Copy
<xs:attribute name="ppi" type="xs:integer" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

settings
http://smath.info/schemas/worksheet/1.0


shortcut Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element shortcut
Syntax
Copy
<xs:complexType name="shortcut" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


title Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element title
Syntax
Copy
<xs:complexType name="title" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


translator Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element translator
Syntax
Copy
<xs:complexType name="translator" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string" />
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


value Complex Type

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Base Type
Simple Type string
Content Type
Simple Type string
Usages
Element value
Attributes
Name | Type | Required | Description
Attribute lang | Simple Type string |  |
Attribute name | Simple Type non-empty-string | Yes |
Syntax
Copy
<xs:complexType name="value" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleContent>
    <xs:extension base="xs:string">
      <xs:attribute name="name" type="non-empty-string" use="required" />
      <xs:attribute name="lang" type="xs:string" use="optional" />
    </xs:extension>
  </xs:simpleContent>
</xs:complexType>
See Also

Reference

http://smath.info/schemas/worksheet/1.0


name Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type non-empty-string
Parents
Complex Type value Element value
Syntax
Copy
<xs:attribute name="name" type="non-empty-string" use="required" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

value
http://smath.info/schemas/worksheet/1.0


lang Attribute

Namespace: http://smath.info/schemas/worksheet/1.0

Schema: Worksheet.xsd

Content Type
Simple Type string
Parents
Complex Type value Element value
Syntax
Copy
<xs:attribute name="lang" type="xs:string" use="optional" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also

Reference

value
http://smath.info/schemas/worksheet/1.0


SMath.Controls Namespace

Classes
 | Class | Description
Public class | ChangeRequestContext | Abstract class to help store and manage the first evaluable Region of the Worksheet.
Public class | ChildrenRegionsList |
Public class | ClipboardManager | Default clipboard manager implementation.Реализация менеджера буфера обмена по-умолчанию.
Public class | CursorStatus |
Public class | DataFile | Stores detailed information about worksheet file.Хранит подробную информацию о файле расчётов.
Public class | DataFiles | Data file types manager.Менеджер по типам файлов с данными.
Public class | DocumentPage | Single page of the Document.Страница документа.
Public class | DocumentPointer |
Public class | DocumentScalerT |
Public class | DragAndDropFileType |
Public class | ExportContext |
Public class | FileContext | File managing context.Контекст для работы с файлами сохранения.
Public class | FileParsingContext |
Public class | FileType | Class to store meta-data of the file type.Класс для хранения мета-данных типа файла.
Public class | FloatingButtonInfo |
Public class | GlobalMatchingOptions |
Public class | HistoryManager | Worksheet changes history utility.
Public class | HistoryManagerRegionChange | Stores single change of the Region.
Public class | HistoryManagerTransaction | Transaction of changes history.Транзакция истории изменений.
Public class | HistoryStepBase | History step storing of the Region.Хранение данных шага истории изменений элемента листа.
Public class | HistoryStepEvaluable | History step storing of the Evaluable Region.Хранение данных шага истории изменений вычисляемого элемента листа.
Public class | InteractiveWorksheet |
Public class | ListBoxItem |
Public class | MainMenu |
Public class | MainMenuItem |
Public class | MatchingContext |
Public class | MatchingOptions |
Public class | MenuButton |
Public class | MenuButtonArgs |
Public class | MenuButtonComparer | Provide complex comparison mechanisms to IComparable collections of MenuButton items.
Public class | MenuContext |
Public class | MenuExtenders |
Public class | MissingRegion | Region which is shown instead of incorrectly loaded one to indicate existence of it.Элемент листа, отображаемый вместо элемента, для которого не было найдено подходящего обработчика. Демонстрирует пользователю существование элемента листа и его статус.
Public class | NonInteractiveWorksheet | Non-interactive implementation of the Worksheet. Simplest possible implementation which does not require any overriden methods or properties.
Public class | ObjectsEnumeratorT |
Public class | ObjectsListT |
Public class | ObjectsManagerT |
Public class | PagesEnumeratorT | Enumerator to iterate through available Document Pages.Объект для перечисления доступных страниц документа.
Public class | PropertiesReader | Provides interface to read Region properties during import.
Public class | PropertiesWriter | Provides interface to write Region properties during export.
Public class | RegionBase | Base class for every worksheet Region.Базовый класс всех элементов листа расчётов.
Public class | RegionBaseRegionMetaData |
Public class | RegionEvaluable | Base class for every worksheet Region that supports evaluation.Базовый класс всех элементов листа расчётов, поддерживающих вычисление.
Public class | RegionHolderT | Region Holder class that implements support for custom Region canvas to be wrapped by the Evaluable Region which supports all the features of the program. It provides built-in Math Region located next to the custom Region.
Public class | RegionsEnumerator | Enumerator to iterate through available Worksheet Regions.Объект для перечисления доступных элементов листа.
Public class | RegionsList |
Public class | RegionsManager |
Public class | RegionsManagerInternal |
Public class | RegionTranslatable | Allows a Region to be translatable.Позволяет элементу листа реализовать встроенную поддержку мультиязычности.
Public class | SelectDialogInfo |
Public class | SelectFunctionDialogInfo |
Public class | SelectOperatorDialogInfo |
Public class | SelectUnitDialogInfo |
Public class | StorageReader | Region content import manager.
Public class | StorageWriter | Region content export manager.
Public class | ToolboxItemInfo |
Public class | Worksheet | Worksheet Control of the program.Элемент управления рабочего листа программы.
Public class | WorksheetEditor |
Public class | WorksheetInfo |
Public class | WorksheetParams |
Public class | WorksheetSearch |
Public class | WorksheetStatus |
Structures
 | Structure | Description
Public structure | ExtendedSearchEntry |
Interfaces
 | Interface | Description
Public interface | IAutoComplete |
Public interface | IClipboardManager | Clipboard manager to work within Worksheet.Менеджер буфера обмена для использования на листе расчёта.
Public interface | IDocumentT |
Public interface | IDocumentObject |
Public interface | IEvaluable |
Public interface | IEvaluableObject |
Public interface | IInteractiveScrollbar |
Public interface | IObjectsManagerT |
Public interface | IPluginCustomRegion | Allow to add a new Region to the program by plug-in.Позволяет добавить пользовательский элемент листа к программе через плагин.
Public interface | IPluginDataInputOutput |
Public interface | IPluginHandleFileTypes | Base File Types handler Interface for SMath Studio Plug-ins.Базовый интерфейс поддержки сторонних типов файлов в виде дополнений для SMath Studio.
Public interface | IPluginMenuExtender | Interface to extend menu-items.
Public interface | IPluginOpenFileTypes | Open File Types handler interface.Интерфейс для поддержки открытия типов файлов.
Public interface | IPluginSaveFileTypes | Save File Types handler interface.Интерфейс для поддержки сохранения типов файлов.
Public interface | IRegionFormatable |
Public interface | IRegionFormatableExtended |
Public interface | IRegionForViewer |
Public interface | IRegionsContainer |
Public interface | IRegionWithEditableText |
Public interface | IRegionWithExtendedSearch |
Public interface | IRegionWithInputData | Extends Region with ability to show/hide input data.
Public interface | IRegionWithLineBreaks | Allows a Region to be splitted between pages by lines.
Public interface | IRegionWithMath |
Public interface | IRegionWithTooltip | Allows a Region to display custom ToolTip on the Worksheet surface.
Public interface | ISeparatorObject |
Public interface | ITranslationNotification |
Delegates
 | Delegate | Description
Public delegate | AreaCollapseChangedEventHandler |
Public delegate | ButtonAction |
Public delegate | DragAndDropAction |
Public delegate | ErrorOccuredEventHandler | Сообщает местоположение элемента математической формулы в котором найдена ошибка.
Public delegate | EvaluateActionEventHandler |
Public delegate | EvaluationEventHandler |
Public delegate | InvalidateRectRequestedDelegate |
Public delegate | InvalidateRequestedDelegate |
Public delegate | IOActionCompletedEventHandler |
Public delegate | MainMenuCreateClick |
Public delegate | MoveDelegate |
Public delegate | OnMouseDelegate |
Public delegate | OnPaintRequestDelegate |
Public delegate | PaintEventHandler | Делегат необходимости перерисовки элемента.
Public delegate | PasswordRequestEventHandler |
Public delegate | ProgressEventHandler |
Public delegate | RegionEvaluationStateEventHandler |
Public delegate | RegionEventHandler |
Public delegate | RegionSelectDelegate |
Public delegate | ResizeDelegate |
Public delegate | ResultPreparedEventHandler |
Public delegate | SimpleTouchDelegate |
Public delegate | StatusEventHandler |
Public delegate | ValueLanguageChanged |
Public delegate | WorksheetFileContextLoadDelegate |
Public delegate | WorksheetCancelEventHandler |
Public delegate | WorksheetGraphicsEventHandler |
Public delegate | WorksheetStatusChangedEventHandler |
Public delegate | ZoomDelegate |
Enumerations
 | Enumeration | Description
Public enumeration | ClipboardStatus | Clipboard status.Статус буфера обмена.
Public enumeration | CursorAction |
Public enumeration | CursorType | Cursor type.Вид курсора.
Public enumeration | DebuggerMode | Built-in debugger mode.Режим работы встроенного отладчика.
Public enumeration | DocumentStatus | Document status.Состояние документа.
Public enumeration | ElementPosition |
Public enumeration | FileBehavior | Behaviors that can be applied to the file type.Возможности, применимые к типу файла.
Public enumeration | FileRequestType | Type of the files related operation.Тип операции по работе с файлами.
Public enumeration | FloatingButtonType |
Public enumeration | HistoryManagerRegionChangeType | History step type.Тип шага истории изменений.
Public enumeration | HistoryManagerStepType | Page history status.Статус истории изменений.
Public enumeration | LineAlignment |
Public enumeration | LocationCorrectionMode |
Public enumeration | MenuButtonBehavior |
Public enumeration | MenuButtonLocation |
Public enumeration | MenuItems |
Public enumeration | PresentationMode |
Public enumeration | RegionSelectionStatus | Selection into the current Region.Выделение внутри элемента листа.
Public enumeration | ScaleMode |
Public enumeration | ScrollBehavior |
Public enumeration | SelectionType | Определяет то, какие элементы необходимо выделить при использовании метода SelectRegions(...).
Public enumeration | ToolboxItemType |
Public enumeration | TouchSelectionType |
Public enumeration | WorksheetSelectionStatus | On page selection.Выделение на листе.


AreaCollapseChangedEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void AreaCollapseChangedEventHandler(
    RegionBase sender,
    ref string password
)
Public Delegate Sub AreaCollapseChangedEventHandler (
    sender As RegionBase,
    ByRef password As String
)
public delegate void AreaCollapseChangedEventHandler(
    RegionBase^ sender,
    String^% password
)
type AreaCollapseChangedEventHandler =
    delegate of
        sender : RegionBase *
        password : string byref -> unit

Parameters

sender
Type: SMath.ControlsRegionBase
password
Type: SystemString
See Also

Reference

SMath.Controls Namespace


ButtonAction Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ButtonAction(
    MenuButtonArgs args
)
Public Delegate Sub ButtonAction (
    args As MenuButtonArgs
)
public delegate void ButtonAction(
    MenuButtonArgs^ args
)
type ButtonAction =
    delegate of
        args : MenuButtonArgs -> unit

Parameters

args
Type: SMath.ControlsMenuButtonArgs
See Also

Reference

SMath.Controls Namespace


ChangeRequestContext Class

Abstract class to help store and manage the first evaluable Region of the Worksheet.
Inheritance Hierarchy
SystemObject
SMath.ControlsChangeRequestContext
SMath.ControlsHistoryManagerTransaction

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ChangeRequestContext
Public MustInherit Class ChangeRequestContext
public ref class ChangeRequestContext abstract
[<AbstractClassAttribute>]
type ChangeRequestContext =  class end

The ChangeRequestContext type exposes the following members.

Constructors
 | Name | Description
Public method | ChangeRequestContext | Initializes evaluation requests store.
Top
Properties
 | Name | Description
Protected property | EvaluationRequested | Determines whether change was requested.
Protected property | SortingRequested |
Protected property | SourceLocation |
Protected property | SourceRegion | The first Region of the Worksheet requested evaluation.
Top
Methods
 | Name | Description
Protected method | CompareLocations |
Public method | CopyStatus |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeUpdate | Updates currently stored first evaluable Region with specified one if required.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetUpdates | Reset updates to prepare for next round.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


ChangeRequestContext Constructor

Initializes evaluation requests store.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ChangeRequestContext()
Public Sub New
public:
ChangeRequestContext()
new : unit -> ChangeRequestContext
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext Properties

The ChangeRequestContext type exposes the following members.

Properties
 | Name | Description
Protected property | EvaluationRequested | Determines whether change was requested.
Protected property | SortingRequested |
Protected property | SourceLocation |
Protected property | SourceRegion | The first Region of the Worksheet requested evaluation.
Top
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.EvaluationRequested Property

SMath Studio Core documentation

ChangeRequestContextEvaluationRequested Property

Determines whether change was requested.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool EvaluationRequested { get; }
Protected ReadOnly Property EvaluationRequested As Boolean
    Get
protected:
property bool EvaluationRequested {
    bool get ();
}
member EvaluationRequested : bool with get

Property Value

Type: Boolean
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.SortingRequested Property

ChangeRequestContextSortingRequested Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool SortingRequested { get; }
Protected ReadOnly Property SortingRequested As Boolean
    Get
protected:
property bool SortingRequested {
    bool get ();
}
member SortingRequested : bool with get

Property Value

Type: Boolean
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.SourceLocation Property

ChangeRequestContextSourceLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Point SourceLocation { get; }
Protected ReadOnly Property SourceLocation As Point
    Get
protected:
property Point SourceLocation {
    Point get ();
}
member SourceLocation : Point with get

Property Value

Type: Point
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.SourceRegion Property

ChangeRequestContextSourceRegion Property

The first Region of the Worksheet requested evaluation.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected RegionBase SourceRegion { get; }
Protected ReadOnly Property SourceRegion As RegionBase
    Get
protected:
property RegionBase^ SourceRegion {
    RegionBase^ get ();
}
member SourceRegion : RegionBase with get

Property Value

Type: RegionBase
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext Methods

The ChangeRequestContext type exposes the following members.

Methods
 | Name | Description
Protected method | CompareLocations |
Public method | CopyStatus |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeUpdate | Updates currently stored first evaluable Region with specified one if required.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetUpdates | Reset updates to prepare for next round.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.CompareLocations Method

ChangeRequestContextCompareLocations Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool CompareLocations(
    Point minLocation,
    Point maxLocation
)
Protected Function CompareLocations (
    minLocation As Point,
    maxLocation As Point
) As Boolean
protected:
bool CompareLocations(
    Point minLocation,
    Point maxLocation
)
member CompareLocations :
        minLocation : Point *
        maxLocation : Point -> bool

Parameters

minLocation
Type: System.DrawingPoint
maxLocation
Type: System.DrawingPoint

Return Value

Type: Boolean
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.CopyStatus Method

ChangeRequestContextCopyStatus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CopyStatus(
    ChangeRequestContext ctx
)
Public Sub CopyStatus (
    ctx As ChangeRequestContext
)
public:
void CopyStatus(
    ChangeRequestContext^ ctx
)
member CopyStatus :
        ctx : ChangeRequestContext -> unit

Parameters

ctx
Type: SMath.ControlsChangeRequestContext
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.MakeUpdate Method

ChangeRequestContextMakeUpdate Method

Updates currently stored first evaluable Region with specified one if required.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void MakeUpdate(
    RegionBase region,
    Point location,
    bool evaluationSupported,
    bool evaluationRequired,
    bool sortingRequired
)
Protected Sub MakeUpdate (
    region As RegionBase,
    location As Point,
    evaluationSupported As Boolean,
    evaluationRequired As Boolean,
    sortingRequired As Boolean
)
protected:
void MakeUpdate(
    RegionBase^ region,
    Point location,
    bool evaluationSupported,
    bool evaluationRequired,
    bool sortingRequired
)
member MakeUpdate :
        region : RegionBase *
        location : Point *
        evaluationSupported : bool *
        evaluationRequired : bool *
        sortingRequired : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
location
Type: System.DrawingPoint
evaluationSupported
Type: SystemBoolean
evaluationRequired
Type: SystemBoolean
sortingRequired
Type: SystemBoolean
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChangeRequestContext.ResetUpdates Method

ChangeRequestContextResetUpdates Method

Reset updates to prepare for next round.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void ResetUpdates()
Protected Sub ResetUpdates
protected:
void ResetUpdates()
member ResetUpdates : unit -> unit
See Also

Reference

ChangeRequestContext Class
SMath.Controls Namespace


ChildrenRegionsList Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsList RegionBase
SMath.ControlsRegionsList
SMath.ControlsChildrenRegionsList

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ChildrenRegionsList : RegionsList
Public Class ChildrenRegionsList
    Inherits RegionsList
public ref class ChildrenRegionsList : public RegionsList
type ChildrenRegionsList =
    class
        inherit RegionsList
    end

The ChildrenRegionsList type exposes the following members.

Constructors
 | Name | Description
Public method | ChildrenRegionsList(RegionBase) | Initializes a new instance of the ChildrenRegionsList class
Public method | ChildrenRegionsList(ChildrenRegionsList, RegionBase) | Initializes a new instance of the ChildrenRegionsList class
Top
Properties
 | Name | Description
Public property | IsActivated |
Public property | IsEmpty |
Public property | PagesCount | (Inherited from ObjectsListT.)
Public property | Placement | (Inherited from ObjectsListT.)
Public property | StartingFromPage | (Inherited from ObjectsListT.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentStore |
Public method | GetEnumerator | (Inherited from RegionsList.)
Public method | GetEnumerator(RegionsEnumerator) | (Inherited from RegionsList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) | (Inherited from ObjectsListT.)
Public method | IsApplicable(Int32, Int32) | (Inherited from ObjectsListT.)
Public method | IsRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | (Overrides ObjectsListTPush(T).)
Public method | ReviseByRef |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetExternalRef |
Public method | TryResolveRef |
Top
See Also

Reference

SMath.Controls Namespace


ChildrenRegionsList Constructor

Overload List
 | Name | Description
Public method | ChildrenRegionsList(RegionBase) | Initializes a new instance of the ChildrenRegionsList class
Public method | ChildrenRegionsList(ChildrenRegionsList, RegionBase) | Initializes a new instance of the ChildrenRegionsList class
Top
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList Constructor (RegionBase)

Initializes a new instance of the ChildrenRegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ChildrenRegionsList(
    RegionBase parent
)
Public Sub New (
    parent As RegionBase
)
public:
ChildrenRegionsList(
    RegionBase^ parent
)
new :
        parent : RegionBase -> ChildrenRegionsList

Parameters

parent
Type: SMath.ControlsRegionBase
See Also

Reference

ChildrenRegionsList Class
ChildrenRegionsList Overload
SMath.Controls Namespace


ChildrenRegionsList Constructor (ChildrenRegionsList, RegionBase)

Initializes a new instance of the ChildrenRegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ChildrenRegionsList(
    ChildrenRegionsList list,
    RegionBase parent
)
Public Sub New (
    list As ChildrenRegionsList,
    parent As RegionBase
)
public:
ChildrenRegionsList(
    ChildrenRegionsList^ list,
    RegionBase^ parent
)
new :
        list : ChildrenRegionsList *
        parent : RegionBase -> ChildrenRegionsList

Parameters

list
Type: SMath.ControlsChildrenRegionsList
parent
Type: SMath.ControlsRegionBase
See Also

Reference

ChildrenRegionsList Class
ChildrenRegionsList Overload
SMath.Controls Namespace


ChildrenRegionsList Properties

The ChildrenRegionsList type exposes the following members.

Properties
 | Name | Description
Public property | IsActivated |
Public property | IsEmpty |
Public property | PagesCount | (Inherited from ObjectsListT.)
Public property | Placement | (Inherited from ObjectsListT.)
Public property | StartingFromPage | (Inherited from ObjectsListT.)
Top
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.IsActivated Property

ChildrenRegionsListIsActivated Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsActivated { get; set; }
Public Property IsActivated As Boolean
    Get
    Set
public:
property bool IsActivated {
    bool get ();
    void set (bool value);
}
member IsActivated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.IsEmpty Property

ChildrenRegionsListIsEmpty Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Type: Boolean
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList Methods

The ChildrenRegionsList type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentStore |
Public method | GetEnumerator | (Inherited from RegionsList.)
Public method | GetEnumerator(RegionsEnumerator) | (Inherited from RegionsList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) | (Inherited from ObjectsListT.)
Public method | IsApplicable(Int32, Int32) | (Inherited from ObjectsListT.)
Public method | IsRef |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | (Overrides ObjectsListTPush(T).)
Public method | ReviseByRef |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetExternalRef |
Public method | TryResolveRef |
Top
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.Add Method

ChildrenRegionsListAdd Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Add(
    RegionBase region
)
Public Function Add (
    region As RegionBase
) As String
public:
String^ Add(
    RegionBase^ region
)
member Add :
        region : RegionBase -> string

Parameters

region
Type: SMath.ControlsRegionBase

Return Value

Type: String
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.AddRange Method

ChildrenRegionsListAddRange Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddRange(
    IEnumerable<RegionBase> regions
)
Public Sub AddRange (
    regions As IEnumerable(Of RegionBase)
)
public:
void AddRange(
    IEnumerable<RegionBase^>^ regions
)
member AddRange :
        regions : IEnumerable<RegionBase> -> unit

Parameters

regions
Type: System.Collections.GenericIEnumerableRegionBase
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.GetCurrentStore Method

ChildrenRegionsListGetCurrentStore Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store GetCurrentStore()
Public Function GetCurrentStore As Store
public:
Store^ GetCurrentStore()
member GetCurrentStore : unit -> Store

Return Value

Type: Store
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.IsRef Method

ChildrenRegionsListIsRef Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsRef(
    string encodedText,
    out string id
)
Public Function IsRef (
    encodedText As String,
    <OutAttribute> ByRef id As String
) As Boolean
public:
bool IsRef(
    String^ encodedText,
    [OutAttribute] String^% id
)
member IsRef :
        encodedText : string *
        id : string byref -> bool

Parameters

encodedText
Type: SystemString
id
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.Push Method

ChildrenRegionsListPush Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Push(
    RegionBase region
)
Public Overrides Sub Push (
    region As RegionBase
)
public:
virtual void Push(
    RegionBase^ region
) override
abstract Push :
        region : RegionBase -> unit
override Push :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.ReviseByRef Method

ChildrenRegionsListReviseByRef Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ReviseByRef(
    string encodedText,
    PointF location,
    Nullable<float> fontHeight,
    Nullable<Color> textColor,
    Nullable<Color> backColor
)
Public Sub ReviseByRef (
    encodedText As String,
    location As PointF,
    fontHeight As Nullable(Of Single),
    textColor As Nullable(Of Color),
    backColor As Nullable(Of Color)
)
public:
void ReviseByRef(
    String^ encodedText,
    PointF location,
    Nullable<float> fontHeight,
    Nullable<Color> textColor,
    Nullable<Color> backColor
)
member ReviseByRef :
        encodedText : string *
        location : PointF *
        fontHeight : Nullable<float32> *
        textColor : Nullable<Color> *
        backColor : Nullable<Color> -> unit

Parameters

encodedText
Type: SystemString
location
Type: System.DrawingPointF
fontHeight
Type: SystemNullableSingle
textColor
Type: SystemNullableColor
backColor
Type: SystemNullableColor
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.TryGetExternalRef Method

ChildrenRegionsListTryGetExternalRef Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetExternalRef(
    string encodedText,
    out string extRef
)
Public Function TryGetExternalRef (
    encodedText As String,
    <OutAttribute> ByRef extRef As String
) As Boolean
public:
bool TryGetExternalRef(
    String^ encodedText,
    [OutAttribute] String^% extRef
)
member TryGetExternalRef :
        encodedText : string *
        extRef : string byref -> bool

Parameters

encodedText
Type: SystemString
extRef
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ChildrenRegionsList.TryResolveRef Method

ChildrenRegionsListTryResolveRef Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryResolveRef(
    string encodedText,
    out Size size,
    out float middleLine
)
Public Function TryResolveRef (
    encodedText As String,
    <OutAttribute> ByRef size As Size,
    <OutAttribute> ByRef middleLine As Single
) As Boolean
public:
bool TryResolveRef(
    String^ encodedText,
    [OutAttribute] Size% size,
    [OutAttribute] float% middleLine
)
member TryResolveRef :
        encodedText : string *
        size : Size byref *
        middleLine : float32 byref -> bool

Parameters

encodedText
Type: SystemString
size
Type: System.DrawingSize
middleLine
Type: SystemSingle

Return Value

Type: Boolean
See Also

Reference

ChildrenRegionsList Class
SMath.Controls Namespace


ClipboardManager Class

Default clipboard manager implementation.Реализация менеджера буфера обмена по-умолчанию.
Inheritance Hierarchy
SystemObject
SMath.ControlsClipboardManager

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ClipboardManager : IClipboardManager
Public MustInherit Class ClipboardManager
    Implements IClipboardManager
public ref class ClipboardManager abstract : IClipboardManager
[<AbstractClassAttribute>]
type ClipboardManager =
    class
        interface IClipboardManager
    end

The ClipboardManager type exposes the following members.

Constructors
 | Name | Description
Protected method | ClipboardManager | Initializes a new instance of the ClipboardManager class
Top
Properties
 | Name | Description
Public property | ContainsAny |
Protected property | SupportedClipboardFormats | Determines full list of clipboard data types can be handled.Определяет полный список поддерживаемых типов данных для работы через буфер обмена.
Top
Methods
 | Name | Description
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegions |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData(Object, String) |
Public method | SetData(Object, String) |
Public method | SetRegions |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
BytesRegionsListDataFormat | Name of the new data format for Worksheet Regions.Имя нового формата данных для элементов листа расчётов.
RegionsListDataFormat | Name of the data format for Worksheet Regions.Имя формата данных для элементов листа расчётов.
Top
See Also

Reference

SMath.Controls Namespace


ClipboardManager Constructor

Initializes a new instance of the ClipboardManager class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ClipboardManager()
Protected Sub New
protected:
ClipboardManager()
new : unit -> ClipboardManager
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager Properties

The ClipboardManager type exposes the following members.

Properties
 | Name | Description
Public property | ContainsAny |
Protected property | SupportedClipboardFormats | Determines full list of clipboard data types can be handled.Определяет полный список поддерживаемых типов данных для работы через буфер обмена.
Top
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.ContainsAny Property

ClipboardManagerContainsAny Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsAny { get; }
Public ReadOnly Property ContainsAny As Boolean
    Get
public:
virtual property bool ContainsAny {
    bool get () sealed;
}
abstract ContainsAny : bool with get
override ContainsAny : bool with get

Property Value

Type: Boolean

Implements

IClipboardManagerContainsAny
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.SupportedClipboardFormats Property

ClipboardManagerSupportedClipboardFormats Property

Determines full list of clipboard data types can be handled.Определяет полный список поддерживаемых типов данных для работы через буфер обмена.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected string[] SupportedClipboardFormats { get; }
Protected ReadOnly Property SupportedClipboardFormats As String()
    Get
protected:
property array<String^>^ SupportedClipboardFormats {
    array<String^>^ get ();
}
member SupportedClipboardFormats : string[] with get

Property Value

Type: String
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager Methods

The ClipboardManager type exposes the following members.

Methods
 | Name | Description
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegions |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetData(Object, String) |
Public method | SetData(Object, String) |
Public method | SetRegions |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.Contains Method

ClipboardManagerContains Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool Contains(
    params string[] formats
)
Public MustOverride Function Contains (
    ParamArray formats As String()
) As Boolean
public:
virtual bool Contains(
    ... array<String^>^ formats
) abstract
abstract Contains :
        formats : string[] -> bool

Parameters

formats
Type: SystemString

Return Value

Type: Boolean

Implements

IClipboardManagerContains(String)
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.GetData Method

ClipboardManagerGetData Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract Object GetData(
    string format
)
Public MustOverride Function GetData (
    format As String
) As Object
public:
virtual Object^ GetData(
    String^ format
) abstract
abstract GetData :
        format : string -> Object

Parameters

format
Type: SystemString

Return Value

Type: Object

Implements

IClipboardManagerGetData(String)
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.GetRegions Method

ClipboardManagerGetRegions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void GetRegions(
    Worksheet worksheet
)
Public Sub GetRegions (
    worksheet As Worksheet
)
public:
virtual void GetRegions(
    Worksheet^ worksheet
) sealed
abstract GetRegions :
        worksheet : Worksheet -> unit
override GetRegions :
        worksheet : Worksheet -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet

Implements

IClipboardManagerGetRegions(Worksheet)
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.SetData Method

ClipboardManagerSetData Method

Overload List
 | Name | Description
Public method | SetData(Object, String) |
Public method | SetData(Object, String) |
Top
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.SetData Method (Object, String)

ClipboardManagerSetData Method (Object, String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetData(
    Object obj,
    string format
)
Public Sub SetData (
    obj As Object,
    format As String
)
public:
virtual void SetData(
    Object^ obj,
    String^ format
) sealed
abstract SetData :
        obj : Object *
        format : string -> unit
override SetData :
        obj : Object *
        format : string -> unit

Parameters

obj
Type: SystemObject
format
Type: SystemString

Implements

IClipboardManagerSetData(Object, String)
See Also

Reference

ClipboardManager Class
SetData Overload
SMath.Controls Namespace


ClipboardManager.SetData Method (Object[], String[])

ClipboardManagerSetData Method (Object, String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void SetData(
    Object[] obj,
    string[] format
)
Public MustOverride Sub SetData (
    obj As Object(),
    format As String()
)
public:
virtual void SetData(
    array<Object^>^ obj,
    array<String^>^ format
) abstract
abstract SetData :
        obj : Object[] *
        format : string[] -> unit

Parameters

obj
Type: SystemObject
format
Type: SystemString

Implements

IClipboardManagerSetData(Object, String)
See Also

Reference

ClipboardManager Class
SetData Overload
SMath.Controls Namespace


ClipboardManager.SetRegions Method

ClipboardManagerSetRegions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetRegions(
    Worksheet worksheet
)
Public Sub SetRegions (
    worksheet As Worksheet
)
public:
virtual void SetRegions(
    Worksheet^ worksheet
) sealed
abstract SetRegions :
        worksheet : Worksheet -> unit
override SetRegions :
        worksheet : Worksheet -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet

Implements

IClipboardManagerSetRegions(Worksheet)
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager Fields

The ClipboardManager type exposes the following members.

Fields
Name | Description
BytesRegionsListDataFormat | Name of the new data format for Worksheet Regions.Имя нового формата данных для элементов листа расчётов.
RegionsListDataFormat | Name of the data format for Worksheet Regions.Имя формата данных для элементов листа расчётов.
Top
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.BytesRegionsListDataFormat Field

ClipboardManagerBytesRegionsListDataFormat Field

Name of the new data format for Worksheet Regions.Имя нового формата данных для элементов листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BytesRegionsListDataFormat = "ByteArray"
Public Const BytesRegionsListDataFormat As String = "ByteArray"
public:
literal String^ BytesRegionsListDataFormat = "ByteArray"
static val mutable BytesRegionsListDataFormat: string

Field Value

Type: String
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardManager.RegionsListDataFormat Field

ClipboardManagerRegionsListDataFormat Field

Name of the data format for Worksheet Regions.Имя формата данных для элементов листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string RegionsListDataFormat = "MemoryStream"
Public Const RegionsListDataFormat As String = "MemoryStream"
public:
literal String^ RegionsListDataFormat = "MemoryStream"
static val mutable RegionsListDataFormat: string

Field Value

Type: String
See Also

Reference

ClipboardManager Class
SMath.Controls Namespace


ClipboardStatus Enumeration

Clipboard status.Статус буфера обмена.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ClipboardStatus
Public Enumeration ClipboardStatus
public enum class ClipboardStatus
type ClipboardStatus
Members
Member name | Value | Description
Empty | 0 | Clipboard is empty or cannot be handled.Пусто или данные из буфера обмена не могут быть интерпретированы.
HasData | 1 | Clipboard contains supported data.Буфер обмена заполнен поддерживаемыми данными.
See Also

Reference

SMath.Controls Namespace


CursorAction Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum CursorAction
Public Enumeration CursorAction
public enum class CursorAction
type CursorAction
Members
Member name | Value | Description
None | 0 |
Dragging | 1 |
SelectionRectangle | 2 |
Selection | 3 |
See Also

Reference

SMath.Controls Namespace


CursorStatus Class

Inheritance Hierarchy
SystemObject
SMath.ControlsCursorStatus

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class CursorStatus
Public Class CursorStatus
public ref class CursorStatus
type CursorStatus =  class end

The CursorStatus type exposes the following members.

Constructors
 | Name | Description
Public method | CursorStatus | Initializes a new instance of the CursorStatus class
Top
Properties
 | Name | Description
Public property | CursorType |
Public property | ErrorText |
Public property | RegionIndex |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


CursorStatus Constructor

Initializes a new instance of the CursorStatus class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public CursorStatus(
    int regionIndex,
    CursorType cursorType
)
Public Sub New (
    regionIndex As Integer,
    cursorType As CursorType
)
public:
CursorStatus(
    int regionIndex,
    CursorType cursorType
)
new :
        regionIndex : int *
        cursorType : CursorType -> CursorStatus

Parameters

regionIndex
Type: SystemInt32
cursorType
Type: SMath.ControlsCursorType
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorStatus Properties

The CursorStatus type exposes the following members.

Properties
 | Name | Description
Public property | CursorType |
Public property | ErrorText |
Public property | RegionIndex |
Top
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorStatus.CursorType Property

CursorStatusCursorType Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public CursorType CursorType { get; set; }
Public Property CursorType As CursorType
    Get
    Set
public:
property CursorType CursorType {
    CursorType get ();
    void set (CursorType value);
}
member CursorType : CursorType with get, set

Property Value

Type: CursorType
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorStatus.ErrorText Property

CursorStatusErrorText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Property Value

Type: String
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorStatus.RegionIndex Property

CursorStatusRegionIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int RegionIndex { get; set; }
Public Property RegionIndex As Integer
    Get
    Set
public:
property int RegionIndex {
    int get ();
    void set (int value);
}
member RegionIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorStatus Methods

The CursorStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CursorStatus Class
SMath.Controls Namespace


CursorType Enumeration

Cursor type.Вид курсора.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum CursorType
Public Enumeration CursorType
public enum class CursorType
type CursorType
Members
Member name | Value | Description
Default | 0 | Not defined.Не задано.
Arrow | 1 | Arrow - standard type.Стрелка - стандартный вид.
Pointer | 2 | Pointer - cursor over the link.Указатель - курсор над ссылкой.
Text | 3 | Text cursor.Текстовый курсор.
Move | 4 | Location change cursor type.Курсор изменения положения.
Moving | 5 | Changing (when in progress) location cursor type.Курсор при перетаскивании.
MovingAdd | 6 | Copy Regions after drop cursor type (when Ctrl key pressed while selected Regions moving).Курсор добавления при перетаскивании.
SizeH | 7 | Changing width cursor type.Изменение размера по горизонтали.
SizeV | 8 | Changing height cursor type.Изменение размера по вертикали.
SizeNWSE | 9 | Changing diagonal size cursor type from bottom left to top right.Изменение размера по диагонали.
SizeNESW | 10 | Changing diagonal size cursor type from top left to bottom right.Изменение размера по диагонали.
See Also

Reference

SMath.Controls Namespace


DataFile Class

Stores detailed information about worksheet file.Хранит подробную информацию о файле расчётов.
Inheritance Hierarchy
SystemObject
SMath.ControlsDataFile

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DataFile : IComparable
Public Class DataFile
    Implements IComparable
public ref class DataFile : IComparable
type DataFile =
    class
        interface IComparable
    end

The DataFile type exposes the following members.

Constructors
 | Name | Description
Public method | DataFile | Data File information class.Конструктор класса с информацией о файле данных.
Top
Properties
 | Name | Description
Public property | FileName | Full path to the file.Полный путь к файлу.
Public property | Guid | Gets or sets Guid of the document.Возвращает или задаёт идентификационный номер документа.
Public property | MetaInfo | Current language worksheet meta-data.Мета-данные листа для текущего языка.
Public property | Revision | Gets or sets revision of the document.Возвращает или задаёт номер ревизии документа.
Public property | Shortcut | Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.
Public property | Text | File title represented for current language.Заголовок файла, представленный для текущего языка интерфейса.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of the Data File.Строковое значение файла данных. (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

SMath.Controls Namespace


DataFile Constructor

Data File information class.Конструктор класса с информацией о файле данных.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DataFile(
    string text,
    string fileName,
    WorksheetInfo metaInfo,
    string shortcut,
    int revision,
    Guid guid
)
Public Sub New (
    text As String,
    fileName As String,
    metaInfo As WorksheetInfo,
    shortcut As String,
    revision As Integer,
    guid As Guid
)
public:
DataFile(
    String^ text,
    String^ fileName,
    WorksheetInfo^ metaInfo,
    String^ shortcut,
    int revision,
    Guid guid
)
new :
        text : string *
        fileName : string *
        metaInfo : WorksheetInfo *
        shortcut : string *
        revision : int *
        guid : Guid -> DataFile

Parameters

text
Type: SystemString
File title represented for current language.Заголовок файла, представленный для текущего языка интерфейса.
fileName
Type: SystemString
Full path to the file.Полный путь к файлу.
metaInfo
Type: SMath.ControlsWorksheetInfo
Current language worksheet meta-data.Мета-данные листа для текущего языка.
shortcut
Type: SystemString
Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.
revision
Type: SystemInt32
guid
Type: SystemGuid
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile Properties

The DataFile type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Full path to the file.Полный путь к файлу.
Public property | Guid | Gets or sets Guid of the document.Возвращает или задаёт идентификационный номер документа.
Public property | MetaInfo | Current language worksheet meta-data.Мета-данные листа для текущего языка.
Public property | Revision | Gets or sets revision of the document.Возвращает или задаёт номер ревизии документа.
Public property | Shortcut | Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.
Public property | Text | File title represented for current language.Заголовок файла, представленный для текущего языка интерфейса.
Top
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.FileName Property

DataFileFileName Property

Full path to the file.Полный путь к файлу.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.Guid Property

DataFileGuid Property

Gets or sets Guid of the document.Возвращает или задаёт идентификационный номер документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.MetaInfo Property

DataFileMetaInfo Property

Current language worksheet meta-data.Мета-данные листа для текущего языка.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetInfo MetaInfo { get; set; }
Public Property MetaInfo As WorksheetInfo
    Get
    Set
public:
property WorksheetInfo^ MetaInfo {
    WorksheetInfo^ get ();
    void set (WorksheetInfo^ value);
}
member MetaInfo : WorksheetInfo with get, set

Property Value

Type: WorksheetInfo
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.Revision Property

DataFileRevision Property

Gets or sets revision of the document.Возвращает или задаёт номер ревизии документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
member Revision : int with get, set

Property Value

Type: Int32
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.Shortcut Property

DataFileShortcut Property

Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Shortcut { get; set; }
Public Property Shortcut As String
    Get
    Set
public:
property String^ Shortcut {
    String^ get ();
    void set (String^ value);
}
member Shortcut : string with get, set

Property Value

Type: String
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.Text Property

DataFileText Property

File title represented for current language.Заголовок файла, представленный для текущего языка интерфейса.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile Methods

The DataFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of the Data File.Строковое значение файла данных. (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.IComparable.CompareTo Method

DataFileIComparableCompareTo Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int IComparable.CompareTo(
    Object obj
)
Private Function CompareTo (
    obj As Object
) As Integer Implements IComparable.CompareTo
private:
virtual int CompareTo(
    Object^ obj
) sealed = IComparable::CompareTo
private abstract CompareTo :
        obj : Object -> int
private override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFile.ToString Method

DataFileToString Method

String representation of the Data File.Строковое значение файла данных.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Returns string representation of the Data File.Возвращает строковое значение файла данных.
See Also

Reference

DataFile Class
SMath.Controls Namespace


DataFiles Class

Data file types manager.Менеджер по типам файлов с данными.
Inheritance Hierarchy
SystemObject
SMath.ControlsDataFiles

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class DataFiles
Public NotInheritable Class DataFiles
public ref class DataFiles abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataFiles =  class end

The DataFiles type exposes the following members.

Properties
Name | Description
HandleDataInputOutputPlugins |
Top
Methods
Name | Description
GetFileTypeDescriptionByExtension | Description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.Описание типа файла по его расширению (только для типов файлов, которые могут быть открыты). В противном случае возвращает пустую строку.
GetOpenFileTypeFilter | Open file types filter formatted to use into Open File Dialogs.Фильтр типов файлов доступных для открытия, составленный для использования в диалоге открытия файлов.
GetOpenFileTypesExtensions |
GetSaveFileTypeFilter | Save file types filter formatted to use into Save File Dialogs.Фильтр типов файлов доступных для сохранения, сформированный для использования в диалоге сохранения файлов.
GetSaveFileTypes | Returns the list of file types available for Save.Возвращает список типов файлов, доступных для сохранения.
GetSupportedBehavior | Supported behaviors of the file type by extension.Действия, поддерживаемые для типа файла, по его расширению.
LoadFilesInfo(SessionProfile, IListString) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
LoadFilesInfo(SessionProfile, String) | Loads detailed information about all worksheet files exists in the directory.Загружает подробную информацию обо всех файлов расчётов находящихся в папке.
LoadFilesInfo(SessionProfile, IListString, Boolean) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
OpenFileType(Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
OpenFileType(Stream, Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
ResetHandleFileTypesPlugins | Reset list of file types plug-ins for future usage.Сбросить список дополнений типов файлов для последующего использования.
SaveFileType(Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
SaveFileType(Stream, Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
Top
See Also

Reference

SMath.Controls Namespace


DataFiles Properties

The DataFiles type exposes the following members.

Properties
Name | Description
HandleDataInputOutputPlugins |
Top
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.HandleDataInputOutputPlugins Property

DataFilesHandleDataInputOutputPlugins Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<PluginInfo> HandleDataInputOutputPlugins { get; }
Public Shared ReadOnly Property HandleDataInputOutputPlugins As IEnumerable(Of PluginInfo)
    Get
public:
static property IEnumerable<PluginInfo^>^ HandleDataInputOutputPlugins {
    IEnumerable<PluginInfo^>^ get ();
}
static member HandleDataInputOutputPlugins : IEnumerable<PluginInfo> with get

Property Value

Type: IEnumerablePluginInfo
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles Methods

The DataFiles type exposes the following members.

Methods
Name | Description
GetFileTypeDescriptionByExtension | Description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.Описание типа файла по его расширению (только для типов файлов, которые могут быть открыты). В противном случае возвращает пустую строку.
GetOpenFileTypeFilter | Open file types filter formatted to use into Open File Dialogs.Фильтр типов файлов доступных для открытия, составленный для использования в диалоге открытия файлов.
GetOpenFileTypesExtensions |
GetSaveFileTypeFilter | Save file types filter formatted to use into Save File Dialogs.Фильтр типов файлов доступных для сохранения, сформированный для использования в диалоге сохранения файлов.
GetSaveFileTypes | Returns the list of file types available for Save.Возвращает список типов файлов, доступных для сохранения.
GetSupportedBehavior | Supported behaviors of the file type by extension.Действия, поддерживаемые для типа файла, по его расширению.
LoadFilesInfo(SessionProfile, IListString) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
LoadFilesInfo(SessionProfile, String) | Loads detailed information about all worksheet files exists in the directory.Загружает подробную информацию обо всех файлов расчётов находящихся в папке.
LoadFilesInfo(SessionProfile, IListString, Boolean) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
OpenFileType(Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
OpenFileType(Stream, Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
ResetHandleFileTypesPlugins | Reset list of file types plug-ins for future usage.Сбросить список дополнений типов файлов для последующего использования.
SaveFileType(Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
SaveFileType(Stream, Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
Top
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetFileTypeDescriptionByExtension Method

DataFilesGetFileTypeDescriptionByExtension Method

Description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.Описание типа файла по его расширению (только для типов файлов, которые могут быть открыты). В противном случае возвращает пустую строку.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetFileTypeDescriptionByExtension(
    string extension
)
Public Shared Function GetFileTypeDescriptionByExtension (
    extension As String
) As String
public:
static String^ GetFileTypeDescriptionByExtension(
    String^ extension
)
static member GetFileTypeDescriptionByExtension :
        extension : string -> string

Parameters

extension
Type: SystemString
File extension to search.Расширение файла для поиска описания.

Return Value

Type: String
Returns a description of the file type.Возвращает описание типа файлов.
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetOpenFileTypeFilter Method

DataFilesGetOpenFileTypeFilter Method

Open file types filter formatted to use into Open File Dialogs.Фильтр типов файлов доступных для открытия, составленный для использования в диалоге открытия файлов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetOpenFileTypeFilter(
    SessionProfile sessionProfile
)
Public Shared Function GetOpenFileTypeFilter (
    sessionProfile As SessionProfile
) As String
public:
static String^ GetOpenFileTypeFilter(
    SessionProfile^ sessionProfile
)
static member GetOpenFileTypeFilter :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
Returns open file types filter.Возвращает фильтр доступных к открытию типов файлов.
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetOpenFileTypesExtensions Method

DataFilesGetOpenFileTypesExtensions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> GetOpenFileTypesExtensions()
Public Shared Function GetOpenFileTypesExtensions As List(Of String)
public:
static List<String^>^ GetOpenFileTypesExtensions()
static member GetOpenFileTypesExtensions : unit -> List<string>

Return Value

Type: ListString
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetSaveFileTypeFilter Method

DataFilesGetSaveFileTypeFilter Method

Save file types filter formatted to use into Save File Dialogs.Фильтр типов файлов доступных для сохранения, сформированный для использования в диалоге сохранения файлов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetSaveFileTypeFilter()
Public Shared Function GetSaveFileTypeFilter As String
public:
static String^ GetSaveFileTypeFilter()
static member GetSaveFileTypeFilter : unit -> string

Return Value

Type: String
Returns save file types filter.Возвращает фильтр доступных к сохранению типов файлов.
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetSaveFileTypes Method

DataFilesGetSaveFileTypes Method

Returns the list of file types available for Save.Возвращает список типов файлов, доступных для сохранения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<FileType> GetSaveFileTypes()
Public Shared Function GetSaveFileTypes As IEnumerable(Of FileType)
public:
static IEnumerable<FileType^>^ GetSaveFileTypes()
static member GetSaveFileTypes : unit -> IEnumerable<FileType>

Return Value

Type: IEnumerableFileType
The list of file types available for Save.Список типов файлов, доступных для сохранения.
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.GetSupportedBehavior Method

DataFilesGetSupportedBehavior Method

Supported behaviors of the file type by extension.Действия, поддерживаемые для типа файла, по его расширению.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static FileBehavior GetSupportedBehavior(
    string extension
)
Public Shared Function GetSupportedBehavior (
    extension As String
) As FileBehavior
public:
static FileBehavior GetSupportedBehavior(
    String^ extension
)
static member GetSupportedBehavior :
        extension : string -> FileBehavior

Parameters

extension
Type: SystemString
File extension to search.Расширение файла для поиска описания.

Return Value

Type: FileBehavior
Returns supported behaviors of the file type.Возвращает поддерживаемые действия для типа файлов.
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.LoadFilesInfo Method

DataFilesLoadFilesInfo Method

Overload List
Name | Description
LoadFilesInfo(SessionProfile, IListString) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
LoadFilesInfo(SessionProfile, String) | Loads detailed information about all worksheet files exists in the directory.Загружает подробную информацию обо всех файлов расчётов находящихся в папке.
LoadFilesInfo(SessionProfile, IListString, Boolean) | Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.
Top
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.LoadFilesInfo Method (SessionProfile, IList(String))

DataFilesLoadFilesInfo Method (SessionProfile, IListString)

Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<DataFile> LoadFilesInfo(
    SessionProfile sessionProfile,
    IList<string> files
)
Public Shared Function LoadFilesInfo (
    sessionProfile As SessionProfile,
    files As IList(Of String)
) As List(Of DataFile)
public:
static List<DataFile^>^ LoadFilesInfo(
    SessionProfile^ sessionProfile,
    IList<String^>^ files
)
static member LoadFilesInfo :
        sessionProfile : SessionProfile *
        files : IList<string> -> List<DataFile>

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
files
Type: System.Collections.GenericIListString
List of full paths to files.Список полных путей к файлам расчётов.

Return Value

Type: ListDataFile
Returns detailed information about all specified worksheet files.Возвращает подробную информацию обо всех заданных файлов расчётов.
See Also

Reference

DataFiles Class
LoadFilesInfo Overload
SMath.Controls Namespace


DataFiles.LoadFilesInfo Method (SessionProfile, String)

DataFilesLoadFilesInfo Method (SessionProfile, String)

Loads detailed information about all worksheet files exists in the directory.Загружает подробную информацию обо всех файлов расчётов находящихся в папке.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<DataFile> LoadFilesInfo(
    SessionProfile sessionProfile,
    string directoryName
)
Public Shared Function LoadFilesInfo (
    sessionProfile As SessionProfile,
    directoryName As String
) As List(Of DataFile)
public:
static List<DataFile^>^ LoadFilesInfo(
    SessionProfile^ sessionProfile,
    String^ directoryName
)
static member LoadFilesInfo :
        sessionProfile : SessionProfile *
        directoryName : string -> List<DataFile>

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
directoryName
Type: SystemString
Full path to the directory (including last slash at the end).Полный путь к папке с файлами расчётов (в конце должен быть указан слеш).

Return Value

Type: ListDataFile
Returns detailed information about all files exists in directory.Возвращает подробную информацию обо всех файлах расчётов, содержащихся в папке.
See Also

Reference

DataFiles Class
LoadFilesInfo Overload
SMath.Controls Namespace


DataFiles.LoadFilesInfo Method (SessionProfile, IList(String), Boolean)

DataFilesLoadFilesInfo Method (SessionProfile, IListString, Boolean)

Loads detailed information about all specified worksheet files.Загружает подробную информацию обо всех заданных файлов расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<DataFile> LoadFilesInfo(
    SessionProfile sessionProfile,
    IList<string> files,
    bool useSessionManager
)
Public Shared Function LoadFilesInfo (
    sessionProfile As SessionProfile,
    files As IList(Of String),
    useSessionManager As Boolean
) As List(Of DataFile)
public:
static List<DataFile^>^ LoadFilesInfo(
    SessionProfile^ sessionProfile,
    IList<String^>^ files,
    bool useSessionManager
)
static member LoadFilesInfo :
        sessionProfile : SessionProfile *
        files : IList<string> *
        useSessionManager : bool -> List<DataFile>

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
files
Type: System.Collections.GenericIListString
List of full paths to files.Список полных путей к файлам расчётов.
useSessionManager
Type: SystemBoolean

Return Value

Type: ListDataFile
Returns detailed information about all specified worksheet files.Возвращает подробную информацию обо всех заданных файлов расчётов.
See Also

Reference

DataFiles Class
LoadFilesInfo Overload
SMath.Controls Namespace


DataFiles.OpenFileType Method

DataFilesOpenFileType Method

Overload List
Name | Description
OpenFileType(Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
OpenFileType(Stream, Worksheet, FileContext) | Open file of the specific type.Открытие файла указанного типа.
Top
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.OpenFileType Method (Worksheet, FileContext)

DataFilesOpenFileType Method (Worksheet, FileContext)

Open file of the specific type.Открытие файла указанного типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool OpenFileType(
    Worksheet worksheet,
    FileContext context
)
Public Shared Function OpenFileType (
    worksheet As Worksheet,
    context As FileContext
) As Boolean
public:
static bool OpenFileType(
    Worksheet^ worksheet,
    FileContext^ context
)
static member OpenFileType :
        worksheet : Worksheet *
        context : FileContext -> bool

Parameters

worksheet
Type: SMath.ControlsWorksheet
Worksheet to open data in.Лист, в котором будет производиться отображение результатов открытия.
context
Type: SMath.ControlsFileContext
File opening context.Контекст для открытия файла сохранения.

Return Value

Type: Boolean
Defines if file opened correctly.Определяет корректно ли завершилась операция по открытию файла.
See Also

Reference

DataFiles Class
OpenFileType Overload
SMath.Controls Namespace


DataFiles.OpenFileType Method (Stream, Worksheet, FileContext)

DataFilesOpenFileType Method (Stream, Worksheet, FileContext)

Open file of the specific type.Открытие файла указанного типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool OpenFileType(
    Stream stream,
    Worksheet worksheet,
    FileContext context
)
Public Shared Function OpenFileType (
    stream As Stream,
    worksheet As Worksheet,
    context As FileContext
) As Boolean
public:
static bool OpenFileType(
    Stream^ stream,
    Worksheet^ worksheet,
    FileContext^ context
)
static member OpenFileType :
        stream : Stream *
        worksheet : Worksheet *
        context : FileContext -> bool

Parameters

stream
Type: System.IOStream
File stream to open file from.Файловый поток для открытия файла.
worksheet
Type: SMath.ControlsWorksheet
Worksheet to open data in.Лист, в котором будет производиться отображение результатов открытия.
context
Type: SMath.ControlsFileContext
File opening context.Контекст для открытия файла сохранения.

Return Value

Type: Boolean
Defines if file opened correctly.Определяет корректно ли завершилась операция по открытию файла.
See Also

Reference

DataFiles Class
OpenFileType Overload
SMath.Controls Namespace


DataFiles.ResetHandleFileTypesPlugins Method

DataFilesResetHandleFileTypesPlugins Method

Reset list of file types plug-ins for future usage.Сбросить список дополнений типов файлов для последующего использования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ResetHandleFileTypesPlugins()
Public Shared Sub ResetHandleFileTypesPlugins
public:
static void ResetHandleFileTypesPlugins()
static member ResetHandleFileTypesPlugins : unit -> unit
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.SaveFileType Method

DataFilesSaveFileType Method

Overload List
Name | Description
SaveFileType(Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
SaveFileType(Stream, Worksheet, FileContext) | Save file to the specific type.Сохранение файла указанного типа.
Top
See Also

Reference

DataFiles Class
SMath.Controls Namespace


DataFiles.SaveFileType Method (Worksheet, FileContext)

DataFilesSaveFileType Method (Worksheet, FileContext)

Save file to the specific type.Сохранение файла указанного типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void SaveFileType(
    Worksheet worksheet,
    FileContext context
)
Public Shared Sub SaveFileType (
    worksheet As Worksheet,
    context As FileContext
)
public:
static void SaveFileType(
    Worksheet^ worksheet,
    FileContext^ context
)
static member SaveFileType :
        worksheet : Worksheet *
        context : FileContext -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet
Canvas to save data from.Лист, из которого будет производиться сохранение.
context
Type: SMath.ControlsFileContext
File saving context.Контекст для сохранения файла.
See Also

Reference

DataFiles Class
SaveFileType Overload
SMath.Controls Namespace


DataFiles.SaveFileType Method (Stream, Worksheet, FileContext)

DataFilesSaveFileType Method (Stream, Worksheet, FileContext)

Save file to the specific type.Сохранение файла указанного типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool SaveFileType(
    Stream stream,
    Worksheet worksheet,
    FileContext context
)
Public Shared Function SaveFileType (
    stream As Stream,
    worksheet As Worksheet,
    context As FileContext
) As Boolean
public:
static bool SaveFileType(
    Stream^ stream,
    Worksheet^ worksheet,
    FileContext^ context
)
static member SaveFileType :
        stream : Stream *
        worksheet : Worksheet *
        context : FileContext -> bool

Parameters

stream
Type: System.IOStream
File stream to save file to.Файловый поток для сохранения файла.
worksheet
Type: SMath.ControlsWorksheet
Worksheet to save data from.Лист, из которого будет производиться сохранение.
context
Type: SMath.ControlsFileContext
File saving context.Контекст для сохранения файла.

Return Value

Type: Boolean
Defines if file saved correctly.Определяет корректно ли завершилась операция по сохранению файла.
See Also

Reference

DataFiles Class
SaveFileType Overload
SMath.Controls Namespace


DebuggerMode Enumeration

Built-in debugger mode.Режим работы встроенного отладчика.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum DebuggerMode
Public Enumeration DebuggerMode
public enum class DebuggerMode
type DebuggerMode
Members
Member name | Value | Description
BreakOnNextBreakpoint | 0 | Set debugger to break on next registered breakpoint.Устанавливает отладчик на остановку на следующей зарегистрированной точке останова.
BreakOnNextEvaluationStep | 1 | Set debugger to break on next detected evaluation step.Устанавливает отладчик на остановку на следующем найденном шаге вычисления.
TerminateExecution | 2 | Terminates calculations execution.Полностью прерывает выполнение вычислений.
See Also

Reference

SMath.Controls Namespace


DocumentPage Class

Single page of the Document.Страница документа.
Inheritance Hierarchy
SystemObject
SMath.ControlsDocumentPage

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DocumentPage
Public Class DocumentPage
public ref class DocumentPage
type DocumentPage =  class end

The DocumentPage type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentPage | Default сonstructor of the Page object.Конструктор объекта страницы по-умолчанию.
Public method | DocumentPage(Int32, Rectangle, Rectangle, Boolean, Int32, Point, Point, Int32, Boolean) | Constructor of the Page object.Конструктор объекта страницы.
Top
Properties
 | Name | Description
Public property | ActiveBounds | Active bounds of the current page in the scope of the Document.Границы активной области текущей страницы относительно документа.
Public property | ContentWidth | Real width of the content on the Document Page.Реальная ширина контента страницы документа.
Public property | InactiveBottom | Inactive space at the bottom of the page.Неактивная область внизу страницы.
Public property | Index | Index of current page on the Document.Номер страницы в текущем документе.
Public property | InnerBounds | Inner bounds of the current page in the scope of the Document.Границы текущей страницы относительно документа.
Public property | IsVisible | Whether current page is visible on the screen or not (takes into account vertical scrollbar of the Document).Определяет видна ли текущая страница документа или нет (работает с учётом вертикальной каретки прокрутки документа).
Public property | LogicalOffset | Offset for the Document page.Смещение для страницы документа.
Public property | OuterBounds | Outer bounds (including print margins) of the current page in the scope of the Document.Внешние границы (включая поля печати) текущей страницы относительно документа.
Public property | PhysicalOffset | Offset from the left top screen corner.Смещение относительно верхнего левого угла экрана.
Public property | StaticSize | Whether document page must be rendered fully (usually for export or when in has a background set).Определяет необходимость отрисовки страницы полностью (в случае экспорта или наличия заданного фона).
Top
Methods
 | Name | Description
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


DocumentPage Constructor

Overload List
 | Name | Description
Public method | DocumentPage | Default сonstructor of the Page object.Конструктор объекта страницы по-умолчанию.
Public method | DocumentPage(Int32, Rectangle, Rectangle, Boolean, Int32, Point, Point, Int32, Boolean) | Constructor of the Page object.Конструктор объекта страницы.
Top
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage Constructor

Default сonstructor of the Page object.Конструктор объекта страницы по-умолчанию.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage()
Public Sub New
public:
DocumentPage()
new : unit -> DocumentPage
See Also

Reference

DocumentPage Class
DocumentPage Overload
SMath.Controls Namespace


DocumentPage Constructor (Int32, Rectangle, Rectangle, Boolean, Int32, Point, Point, Int32, Boolean)

Constructor of the Page object.Конструктор объекта страницы.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage(
    int index,
    Rectangle innerBounds,
    Rectangle outerBounds,
    bool isVisible,
    int inactiveBottom,
    Point logicalOffset,
    Point physicalOffset,
    int contentWidth,
    bool staticSize
)
Public Sub New (
    index As Integer,
    innerBounds As Rectangle,
    outerBounds As Rectangle,
    isVisible As Boolean,
    inactiveBottom As Integer,
    logicalOffset As Point,
    physicalOffset As Point,
    contentWidth As Integer,
    staticSize As Boolean
)
public:
DocumentPage(
    int index,
    Rectangle innerBounds,
    Rectangle outerBounds,
    bool isVisible,
    int inactiveBottom,
    Point logicalOffset,
    Point physicalOffset,
    int contentWidth,
    bool staticSize
)
new :
        index : int *
        innerBounds : Rectangle *
        outerBounds : Rectangle *
        isVisible : bool *
        inactiveBottom : int *
        logicalOffset : Point *
        physicalOffset : Point *
        contentWidth : int *
        staticSize : bool -> DocumentPage

Parameters

index
Type: SystemInt32
Page indes.Номер страницы.
innerBounds
Type: System.DrawingRectangle
Bounds of the page.Границы страницы.
outerBounds
Type: System.DrawingRectangle
Outer bounds (including print margins) of the current page in the scope of the Document.Внешние границы (включая поля печати) текущей страницы относительно документа.
isVisible
Type: SystemBoolean
Whether page is visible on the view port or not.Определяет находится ли страница в пределах видимости.
inactiveBottom
Type: SystemInt32
Height of the inactive area at the bottom of the page.Высота неактивной зоны страницы снизу.
logicalOffset
Type: System.DrawingPoint
Offset for the Document page.Смещение для страницы документа.
physicalOffset
Type: System.DrawingPoint
Offset from the left top screen corner.Смещение относительно верхнего левого угла экрана.
contentWidth
Type: SystemInt32
Real width of the content on the Document Page.Реальная ширина контента страницы документа.
staticSize
Type: SystemBoolean
Whether document page must be rendered fully (usually for export or when in has a background set).Определяет необходимость отрисовки страницы полностью (в случае экспорта или наличия заданного фона).
See Also

Reference

DocumentPage Class
DocumentPage Overload
SMath.Controls Namespace


DocumentPage Properties

The DocumentPage type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBounds | Active bounds of the current page in the scope of the Document.Границы активной области текущей страницы относительно документа.
Public property | ContentWidth | Real width of the content on the Document Page.Реальная ширина контента страницы документа.
Public property | InactiveBottom | Inactive space at the bottom of the page.Неактивная область внизу страницы.
Public property | Index | Index of current page on the Document.Номер страницы в текущем документе.
Public property | InnerBounds | Inner bounds of the current page in the scope of the Document.Границы текущей страницы относительно документа.
Public property | IsVisible | Whether current page is visible on the screen or not (takes into account vertical scrollbar of the Document).Определяет видна ли текущая страница документа или нет (работает с учётом вертикальной каретки прокрутки документа).
Public property | LogicalOffset | Offset for the Document page.Смещение для страницы документа.
Public property | OuterBounds | Outer bounds (including print margins) of the current page in the scope of the Document.Внешние границы (включая поля печати) текущей страницы относительно документа.
Public property | PhysicalOffset | Offset from the left top screen corner.Смещение относительно верхнего левого угла экрана.
Public property | StaticSize | Whether document page must be rendered fully (usually for export or when in has a background set).Определяет необходимость отрисовки страницы полностью (в случае экспорта или наличия заданного фона).
Top
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.ActiveBounds Property

DocumentPageActiveBounds Property

Active bounds of the current page in the scope of the Document.Границы активной области текущей страницы относительно документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle ActiveBounds { get; }
Public ReadOnly Property ActiveBounds As Rectangle
    Get
public:
property Rectangle ActiveBounds {
    Rectangle get ();
}
member ActiveBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.ContentWidth Property

DocumentPageContentWidth Property

Real width of the content on the Document Page.Реальная ширина контента страницы документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ContentWidth { get; }
Public ReadOnly Property ContentWidth As Integer
    Get
public:
property int ContentWidth {
    int get ();
}
member ContentWidth : int with get

Property Value

Type: Int32
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.InactiveBottom Property

DocumentPageInactiveBottom Property

Inactive space at the bottom of the page.Неактивная область внизу страницы.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int InactiveBottom { get; }
Public ReadOnly Property InactiveBottom As Integer
    Get
public:
property int InactiveBottom {
    int get ();
}
member InactiveBottom : int with get

Property Value

Type: Int32
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.Index Property

DocumentPageIndex Property

Index of current page on the Document.Номер страницы в текущем документе.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.InnerBounds Property

DocumentPageInnerBounds Property

Inner bounds of the current page in the scope of the Document.Границы текущей страницы относительно документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle InnerBounds { get; }
Public ReadOnly Property InnerBounds As Rectangle
    Get
public:
property Rectangle InnerBounds {
    Rectangle get ();
}
member InnerBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.IsVisible Property

DocumentPageIsVisible Property

Whether current page is visible on the screen or not (takes into account vertical scrollbar of the Document).Определяет видна ли текущая страница документа или нет (работает с учётом вертикальной каретки прокрутки документа).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsVisible { get; }
Public ReadOnly Property IsVisible As Boolean
    Get
public:
property bool IsVisible {
    bool get ();
}
member IsVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.LogicalOffset Property

DocumentPageLogicalOffset Property

Offset for the Document page.Смещение для страницы документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point LogicalOffset { get; }
Public ReadOnly Property LogicalOffset As Point
    Get
public:
property Point LogicalOffset {
    Point get ();
}
member LogicalOffset : Point with get

Property Value

Type: Point
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.OuterBounds Property

DocumentPageOuterBounds Property

Outer bounds (including print margins) of the current page in the scope of the Document.Внешние границы (включая поля печати) текущей страницы относительно документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle OuterBounds { get; }
Public ReadOnly Property OuterBounds As Rectangle
    Get
public:
property Rectangle OuterBounds {
    Rectangle get ();
}
member OuterBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.PhysicalOffset Property

DocumentPagePhysicalOffset Property

Offset from the left top screen corner.Смещение относительно верхнего левого угла экрана.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point PhysicalOffset { get; }
Public ReadOnly Property PhysicalOffset As Point
    Get
public:
property Point PhysicalOffset {
    Point get ();
}
member PhysicalOffset : Point with get

Property Value

Type: Point
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.StaticSize Property

DocumentPageStaticSize Property

Whether document page must be rendered fully (usually for export or when in has a background set).Определяет необходимость отрисовки страницы полностью (в случае экспорта или наличия заданного фона).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool StaticSize { get; }
Public ReadOnly Property StaticSize As Boolean
    Get
public:
property bool StaticSize {
    bool get ();
}
member StaticSize : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage Methods

The DocumentPage type exposes the following members.

Methods
 | Name | Description
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPage.Contains Method

DocumentPageContains Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Point value,
    bool multiColumnPages
)
Public Function Contains (
    value As Point,
    multiColumnPages As Boolean
) As Boolean
public:
bool Contains(
    Point value,
    bool multiColumnPages
)
member Contains :
        value : Point *
        multiColumnPages : bool -> bool

Parameters

value
Type: System.DrawingPoint
multiColumnPages
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

DocumentPage Class
SMath.Controls Namespace


DocumentPointer Class

Inheritance Hierarchy
SystemObject
SMath.ControlsDocumentPointer

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DocumentPointer
Public Class DocumentPointer
public ref class DocumentPointer
type DocumentPointer =  class end

The DocumentPointer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAction |
Public property | CurrentLocation |
Public property | IsVisible |
Public property | Location |
Public property | PhysicalLocation |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Hide | Если крестик виден, то отрисовывает место, на котором он нарисован, дабы удалить его. Так же, если есть выделенные элементы, безопасно снимает с них выделение.
Public method | Invalidate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToCursor |
Public method | SetLocation |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


DocumentPointer Properties

The DocumentPointer type exposes the following members.

Properties
 | Name | Description
Public property | CurrentAction |
Public property | CurrentLocation |
Public property | IsVisible |
Public property | Location |
Public property | PhysicalLocation |
Top
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.CurrentAction Property

DocumentPointerCurrentAction Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public CursorAction CurrentAction { get; set; }
Public Property CurrentAction As CursorAction
    Get
    Set
public:
property CursorAction CurrentAction {
    CursorAction get ();
    void set (CursorAction value);
}
member CurrentAction : CursorAction with get, set

Property Value

Type: CursorAction
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.CurrentLocation Property

DocumentPointerCurrentLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point CurrentLocation { get; set; }
Public Property CurrentLocation As Point
    Get
    Set
public:
property Point CurrentLocation {
    Point get ();
    void set (Point value);
}
member CurrentLocation : Point with get, set

Property Value

Type: Point
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.IsVisible Property

DocumentPointerIsVisible Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsVisible { get; }
Public ReadOnly Property IsVisible As Boolean
    Get
public:
property bool IsVisible {
    bool get ();
}
member IsVisible : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.Location Property

DocumentPointerLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point Location { get; }
Public ReadOnly Property Location As Point
    Get
public:
property Point Location {
    Point get ();
}
member Location : Point with get

Property Value

Type: Point
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.PhysicalLocation Property

DocumentPointerPhysicalLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point PhysicalLocation { get; }
Public ReadOnly Property PhysicalLocation As Point
    Get
public:
property Point PhysicalLocation {
    Point get ();
}
member PhysicalLocation : Point with get

Property Value

Type: Point
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer Methods

The DocumentPointer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Hide | Если крестик виден, то отрисовывает место, на котором он нарисован, дабы удалить его. Так же, если есть выделенные элементы, безопасно снимает с них выделение.
Public method | Invalidate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToCursor |
Public method | SetLocation |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.GetRectangle Method

DocumentPointerGetRectangle Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle GetRectangle()
Public Function GetRectangle As Rectangle
public:
Rectangle GetRectangle()
member GetRectangle : unit -> Rectangle

Return Value

Type: Rectangle
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.Hide Method

DocumentPointerHide Method

Если крестик виден, то отрисовывает место, на котором он нарисован, дабы удалить его. Так же, если есть выделенные элементы, безопасно снимает с них выделение.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Hide(
    bool handleSelection = true
)
Public Sub Hide (
    Optional handleSelection As Boolean = true
)
public:
void Hide(
    bool handleSelection = true
)
member Hide :
        ?handleSelection : bool
(* Defaults:
        let _handleSelection = defaultArg handleSelection true
*)
-> unit

Parameters

handleSelection (Optional)
Type: SystemBoolean
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.Invalidate Method

DocumentPointerInvalidate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Invalidate()
Public Sub Invalidate
public:
void Invalidate()
member Invalidate : unit -> unit
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.ScrollToCursor Method

DocumentPointerScrollToCursor Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToCursor()
Public Sub ScrollToCursor
public:
void ScrollToCursor()
member ScrollToCursor : unit -> unit
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentPointer.SetLocation Method

DocumentPointerSetLocation Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetLocation(
    Point value
)
Public Sub SetLocation (
    value As Point
)
public:
void SetLocation(
    Point value
)
member SetLocation :
        value : Point -> unit

Parameters

value
Type: System.DrawingPoint
See Also

Reference

DocumentPointer Class
SMath.Controls Namespace


DocumentScaler(T) Class

DocumentScalerT Class

Inheritance Hierarchy
SystemObject
SMath.ControlsDocumentScalerT

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DocumentScaler<T>
where T : IDocumentObject

Public Class DocumentScaler(Of T As IDocumentObject)
generic<typename T>
where T : IDocumentObject
public ref class DocumentScaler
type DocumentScaler<'T when 'T : IDocumentObject> =  class end

Type Parameters

T

The DocumentScalerT type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentScalerT | Initializes a new instance of the DocumentScalerT class
Top
Properties
 | Name | Description
Public property | BottomExtraMargin | Extra margin on bottom of the Document.
Public property | HasSelection |
Public property | InitialOffset |
Public property | ScaleFactor |
Public property | ScaleFactorFull |
Public property | ScaleMode |
Public property | TouchControlsVisible |
Top
Methods
 | Name | Description
Public method | DoMove |
Public method | DoZoom |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicBounds |
Public method | GetLogicPoint |
Public method | GetLogicSize |
Public method | GetScreenPoint |
Public method | GetScreenSize |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVisibleDocumentBounds |
Public method | HandleEndMove |
Public method | HandleMove |
Public method | HandleStartMove |
Public method | IsFocused |
Public method | IsSelectionEnd |
Public method | IsSelectionStart |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Paint |
Public method | ResetPosition |
Public method | SetDocumentStatus |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


DocumentScaler(T) Constructor

DocumentScalerT Constructor

Initializes a new instance of the DocumentScalerT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentScaler(
    IDocument<T> doc,
    float initialScale,
    Point initialOffset
)
Public Sub New (
    doc As IDocument(Of T),
    initialScale As Single,
    initialOffset As Point
)
public:
DocumentScaler(
    IDocument<T>^ doc,
    float initialScale,
    Point initialOffset
)
new :
        doc : IDocument<'T> *
        initialScale : float32 *
        initialOffset : Point -> DocumentScaler

Parameters

doc
Type: SMath.ControlsIDocument T
initialScale
Type: SystemSingle
initialOffset
Type: System.DrawingPoint
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T) Properties

DocumentScalerT Properties

The DocumentScalerT generic type exposes the following members.

Properties
 | Name | Description
Public property | BottomExtraMargin | Extra margin on bottom of the Document.
Public property | HasSelection |
Public property | InitialOffset |
Public property | ScaleFactor |
Public property | ScaleFactorFull |
Public property | ScaleMode |
Public property | TouchControlsVisible |
Top
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).BottomExtraMargin Property

DocumentScalerTBottomExtraMargin Property

Extra margin on bottom of the Document.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float BottomExtraMargin { get; }
Public ReadOnly Property BottomExtraMargin As Single
    Get
public:
property float BottomExtraMargin {
    float get ();
}
member BottomExtraMargin : float32 with get

Property Value

Type: Single
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).HasSelection Property

DocumentScalerTHasSelection Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasSelection { get; }
Public ReadOnly Property HasSelection As Boolean
    Get
public:
property bool HasSelection {
    bool get ();
}
member HasSelection : bool with get

Property Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).InitialOffset Property

DocumentScalerTInitialOffset Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF InitialOffset { get; }
Public ReadOnly Property InitialOffset As PointF
    Get
public:
property PointF InitialOffset {
    PointF get ();
}
member InitialOffset : PointF with get

Property Value

Type: PointF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).ScaleFactor Property

DocumentScalerTScaleFactor Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float ScaleFactor { get; set; }
Public Property ScaleFactor As Single
    Get
    Set
public:
property float ScaleFactor {
    float get ();
    void set (float value);
}
member ScaleFactor : float32 with get, set

Property Value

Type: Single
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).ScaleFactorFull Property

DocumentScalerTScaleFactorFull Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float ScaleFactorFull { get; }
Public ReadOnly Property ScaleFactorFull As Single
    Get
public:
property float ScaleFactorFull {
    float get ();
}
member ScaleFactorFull : float32 with get

Property Value

Type: Single
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).ScaleMode Property

DocumentScalerTScaleMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ScaleMode ScaleMode { get; set; }
Public Property ScaleMode As ScaleMode
    Get
    Set
public:
property ScaleMode ScaleMode {
    ScaleMode get ();
    void set (ScaleMode value);
}
member ScaleMode : ScaleMode with get, set

Property Value

Type: ScaleMode
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).TouchControlsVisible Property

DocumentScalerTTouchControlsVisible Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TouchControlsVisible { get; set; }
Public Property TouchControlsVisible As Boolean
    Get
    Set
public:
property bool TouchControlsVisible {
    bool get ();
    void set (bool value);
}
member TouchControlsVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T) Methods

DocumentScalerT Methods

The DocumentScalerT generic type exposes the following members.

Methods
 | Name | Description
Public method | DoMove |
Public method | DoZoom |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicBounds |
Public method | GetLogicPoint |
Public method | GetLogicSize |
Public method | GetScreenPoint |
Public method | GetScreenSize |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVisibleDocumentBounds |
Public method | HandleEndMove |
Public method | HandleMove |
Public method | HandleStartMove |
Public method | IsFocused |
Public method | IsSelectionEnd |
Public method | IsSelectionStart |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Paint |
Public method | ResetPosition |
Public method | SetDocumentStatus |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).DoMove Method

DocumentScalerTDoMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DoMove(
    float distanceX,
    float distanceY,
    RectangleF viewBounds,
    RectangleF contentBounds
)
Public Sub DoMove (
    distanceX As Single,
    distanceY As Single,
    viewBounds As RectangleF,
    contentBounds As RectangleF
)
public:
void DoMove(
    float distanceX,
    float distanceY,
    RectangleF viewBounds,
    RectangleF contentBounds
)
member DoMove :
        distanceX : float32 *
        distanceY : float32 *
        viewBounds : RectangleF *
        contentBounds : RectangleF -> unit

Parameters

distanceX
Type: SystemSingle
distanceY
Type: SystemSingle
viewBounds
Type: System.DrawingRectangleF
contentBounds
Type: System.DrawingRectangleF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).DoZoom Method

DocumentScalerTDoZoom Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DoZoom(
    float factor,
    float focusX,
    float focusY,
    RectangleF viewBounds,
    bool doubleTap
)
Public Sub DoZoom (
    factor As Single,
    focusX As Single,
    focusY As Single,
    viewBounds As RectangleF,
    doubleTap As Boolean
)
public:
void DoZoom(
    float factor,
    float focusX,
    float focusY,
    RectangleF viewBounds,
    bool doubleTap
)
member DoZoom :
        factor : float32 *
        focusX : float32 *
        focusY : float32 *
        viewBounds : RectangleF *
        doubleTap : bool -> unit

Parameters

factor
Type: SystemSingle
focusX
Type: SystemSingle
focusY
Type: SystemSingle
viewBounds
Type: System.DrawingRectangleF
doubleTap
Type: SystemBoolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetLogicBounds Method

DocumentScalerTGetLogicBounds Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF GetLogicBounds(
    float left,
    float top,
    float width,
    float height
)
Public Function GetLogicBounds (
    left As Single,
    top As Single,
    width As Single,
    height As Single
) As RectangleF
public:
RectangleF GetLogicBounds(
    float left,
    float top,
    float width,
    float height
)
member GetLogicBounds :
        left : float32 *
        top : float32 *
        width : float32 *
        height : float32 -> RectangleF

Parameters

left
Type: SystemSingle
top
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Return Value

Type: RectangleF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetLogicPoint Method

DocumentScalerTGetLogicPoint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF GetLogicPoint(
    float x,
    float y
)
Public Function GetLogicPoint (
    x As Single,
    y As Single
) As PointF
public:
PointF GetLogicPoint(
    float x,
    float y
)
member GetLogicPoint :
        x : float32 *
        y : float32 -> PointF

Parameters

x
Type: SystemSingle
y
Type: SystemSingle

Return Value

Type: PointF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetLogicSize Method

DocumentScalerTGetLogicSize Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SizeF GetLogicSize(
    float width,
    float height
)
Public Function GetLogicSize (
    width As Single,
    height As Single
) As SizeF
public:
SizeF GetLogicSize(
    float width,
    float height
)
member GetLogicSize :
        width : float32 *
        height : float32 -> SizeF

Parameters

width
Type: SystemSingle
height
Type: SystemSingle

Return Value

Type: SizeF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetScreenPoint Method

DocumentScalerTGetScreenPoint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF GetScreenPoint(
    float x,
    float y
)
Public Function GetScreenPoint (
    x As Single,
    y As Single
) As PointF
public:
PointF GetScreenPoint(
    float x,
    float y
)
member GetScreenPoint :
        x : float32 *
        y : float32 -> PointF

Parameters

x
Type: SystemSingle
y
Type: SystemSingle

Return Value

Type: PointF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetScreenSize Method

DocumentScalerTGetScreenSize Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SizeF GetScreenSize(
    float width,
    float height
)
Public Function GetScreenSize (
    width As Single,
    height As Single
) As SizeF
public:
SizeF GetScreenSize(
    float width,
    float height
)
member GetScreenSize :
        width : float32 *
        height : float32 -> SizeF

Parameters

width
Type: SystemSingle
height
Type: SystemSingle

Return Value

Type: SizeF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).GetVisibleDocumentBounds Method

DocumentScalerTGetVisibleDocumentBounds Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF GetVisibleDocumentBounds()
Public Function GetVisibleDocumentBounds As RectangleF
public:
RectangleF GetVisibleDocumentBounds()
member GetVisibleDocumentBounds : unit -> RectangleF

Return Value

Type: RectangleF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).HandleEndMove Method

DocumentScalerTHandleEndMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HandleEndMove(
    PointF pnt
)
Public Function HandleEndMove (
    pnt As PointF
) As Boolean
public:
bool HandleEndMove(
    PointF pnt
)
member HandleEndMove :
        pnt : PointF -> bool

Parameters

pnt
Type: System.DrawingPointF

Return Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).HandleMove Method

DocumentScalerTHandleMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TouchSelectionType HandleMove(
    PointF pnt,
    float distanceX,
    float distanceY,
    out Point pnt1,
    out Point pnt2
)
Public Function HandleMove (
    pnt As PointF,
    distanceX As Single,
    distanceY As Single,
    <OutAttribute> ByRef pnt1 As Point,
    <OutAttribute> ByRef pnt2 As Point
) As TouchSelectionType
public:
TouchSelectionType HandleMove(
    PointF pnt,
    float distanceX,
    float distanceY,
    [OutAttribute] Point% pnt1,
    [OutAttribute] Point% pnt2
)
member HandleMove :
        pnt : PointF *
        distanceX : float32 *
        distanceY : float32 *
        pnt1 : Point byref *
        pnt2 : Point byref -> TouchSelectionType

Parameters

pnt
Type: System.DrawingPointF
distanceX
Type: SystemSingle
distanceY
Type: SystemSingle
pnt1
Type: System.DrawingPoint
pnt2
Type: System.DrawingPoint

Return Value

Type: TouchSelectionType
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).HandleStartMove Method

DocumentScalerTHandleStartMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void HandleStartMove(
    PointF pnt
)
Public Sub HandleStartMove (
    pnt As PointF
)
public:
void HandleStartMove(
    PointF pnt
)
member HandleStartMove :
        pnt : PointF -> unit

Parameters

pnt
Type: System.DrawingPointF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).IsFocused Method

DocumentScalerTIsFocused Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsFocused(
    PointF pnt
)
Public Function IsFocused (
    pnt As PointF
) As Boolean
public:
bool IsFocused(
    PointF pnt
)
member IsFocused :
        pnt : PointF -> bool

Parameters

pnt
Type: System.DrawingPointF

Return Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).IsSelectionEnd Method

DocumentScalerTIsSelectionEnd Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectionEnd(
    PointF pnt
)
Public Function IsSelectionEnd (
    pnt As PointF
) As Boolean
public:
bool IsSelectionEnd(
    PointF pnt
)
member IsSelectionEnd :
        pnt : PointF -> bool

Parameters

pnt
Type: System.DrawingPointF

Return Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).IsSelectionStart Method

DocumentScalerTIsSelectionStart Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSelectionStart(
    PointF pnt
)
Public Function IsSelectionStart (
    pnt As PointF
) As Boolean
public:
bool IsSelectionStart(
    PointF pnt
)
member IsSelectionStart :
        pnt : PointF -> bool

Parameters

pnt
Type: System.DrawingPointF

Return Value

Type: Boolean
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).Paint Method

DocumentScalerTPaint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Paint(
    IGraphics g,
    RectangleF bounds
)
Public Sub Paint (
    g As IGraphics,
    bounds As RectangleF
)
public:
void Paint(
    IGraphics^ g,
    RectangleF bounds
)
member Paint :
        g : IGraphics *
        bounds : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
bounds
Type: System.DrawingRectangleF
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).ResetPosition Method

DocumentScalerTResetPosition Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ResetPosition()
Public Sub ResetPosition
public:
void ResetPosition()
member ResetPosition : unit -> unit
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentScaler(T).SetDocumentStatus Method

DocumentScalerTSetDocumentStatus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetDocumentStatus(
    Rectangle objectBounds,
    Rectangle selectionBounds,
    string errorText,
    Point errorLocation
)
Public Sub SetDocumentStatus (
    objectBounds As Rectangle,
    selectionBounds As Rectangle,
    errorText As String,
    errorLocation As Point
)
public:
void SetDocumentStatus(
    Rectangle objectBounds,
    Rectangle selectionBounds,
    String^ errorText,
    Point errorLocation
)
member SetDocumentStatus :
        objectBounds : Rectangle *
        selectionBounds : Rectangle *
        errorText : string *
        errorLocation : Point -> unit

Parameters

objectBounds
Type: System.DrawingRectangle
selectionBounds
Type: System.DrawingRectangle
errorText
Type: SystemString
errorLocation
Type: System.DrawingPoint
See Also

Reference

DocumentScalerT Class
SMath.Controls Namespace


DocumentStatus Enumeration

Document status.Состояние документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum DocumentStatus
Public Enumeration DocumentStatus
public enum class DocumentStatus
type DocumentStatus
Members
Member name | Value | Description
Editable | 0 | Editable document.Редактируемый документ.
ReadOnly | 1 | Read-only document.Документ только для чтения.
Calculation | 2 | When evaluation in progress document cannot be modified, but document is look like in standard mode.В процессе вычисления. Т.е. можно просматривать, как в стандартном состоянии, но при этом нельзя редактировать.
Opening | 3 | Opening operation is in progress.Операция открытия в процессе.
Saving | 4 | Saving operation is in progress.Операция сохранения в процессе.
See Also

Reference

SMath.Controls Namespace


DragAndDropAction Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate RegionBase DragAndDropAction(
    SessionProfile sessionProfile,
    string args
)
Public Delegate Function DragAndDropAction (
    sessionProfile As SessionProfile,
    args As String
) As RegionBase
public delegate RegionBase^ DragAndDropAction(
    SessionProfile^ sessionProfile,
    String^ args
)
type DragAndDropAction =
    delegate of
        sessionProfile : SessionProfile *
        args : string -> RegionBase

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
args
Type: SystemString

Return Value

Type: RegionBase
See Also

Reference

SMath.Controls Namespace


DragAndDropFileType Class

Inheritance Hierarchy
SystemObject
SMath.ControlsFileType
SMath.ControlsDragAndDropFileType

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DragAndDropFileType : FileType
Public Class DragAndDropFileType
    Inherits FileType
public ref class DragAndDropFileType : public FileType
type DragAndDropFileType =
    class
        inherit FileType
    end

The DragAndDropFileType type exposes the following members.

Constructors
 | Name | Description
Public method | DragAndDropFileType | Initializes a new instance of the DragAndDropFileType class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Behavior | Applied to the file type behaviors.Возможности, применимые к текущему типу файла. (Inherited from FileType.)
Public property | Description | Description of the file type.Описание типа файла. (Inherited from FileType.)
Public property | Extensions | Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла. (Inherited from FileType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | JoinExtensions | Merging all the extensions in one string with ";" delimiter.Запись вместе всех расширений типа файла с символом ";" в качестве разделителя. (Inherited from FileType.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


DragAndDropFileType Constructor

Initializes a new instance of the DragAndDropFileType class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DragAndDropFileType(
    string[] extensions,
    DragAndDropAction action
)
Public Sub New (
    extensions As String(),
    action As DragAndDropAction
)
public:
DragAndDropFileType(
    array<String^>^ extensions,
    DragAndDropAction^ action
)
new :
        extensions : string[] *
        action : DragAndDropAction -> DragAndDropFileType

Parameters

extensions
Type: SystemString
action
Type: SMath.ControlsDragAndDropAction
See Also

Reference

DragAndDropFileType Class
SMath.Controls Namespace


DragAndDropFileType Properties

The DragAndDropFileType type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Behavior | Applied to the file type behaviors.Возможности, применимые к текущему типу файла. (Inherited from FileType.)
Public property | Description | Description of the file type.Описание типа файла. (Inherited from FileType.)
Public property | Extensions | Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла. (Inherited from FileType.)
Top
See Also

Reference

DragAndDropFileType Class
SMath.Controls Namespace


DragAndDropFileType.Action Property

DragAndDropFileTypeAction Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DragAndDropAction Action { get; }
Public ReadOnly Property Action As DragAndDropAction
    Get
public:
property DragAndDropAction^ Action {
    DragAndDropAction^ get ();
}
member Action : DragAndDropAction with get

Property Value

Type: DragAndDropAction
See Also

Reference

DragAndDropFileType Class
SMath.Controls Namespace


DragAndDropFileType Methods

The DragAndDropFileType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | JoinExtensions | Merging all the extensions in one string with ";" delimiter.Запись вместе всех расширений типа файла с символом ";" в качестве разделителя. (Inherited from FileType.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DragAndDropFileType Class
SMath.Controls Namespace


ElementPosition Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ElementPosition
Public Enumeration ElementPosition
public enum class ElementPosition
type ElementPosition
Members
Member name | Value | Description
Top | 1 |
Right | 2 |
Left | 4 |
See Also

Reference

SMath.Controls Namespace


ErrorOccuredEventHandler Delegate

Сообщает местоположение элемента математической формулы в котором найдена ошибка.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorOccuredEventHandler(
    Exception e,
    int position,
    IPrimitive value,
    RegionEvaluable sender
)
Public Delegate Sub ErrorOccuredEventHandler (
    e As Exception,
    position As Integer,
    value As IPrimitive,
    sender As RegionEvaluable
)
public delegate void ErrorOccuredEventHandler(
    Exception^ e,
    int position,
    IPrimitive^ value,
    RegionEvaluable^ sender
)
type ErrorOccuredEventHandler =
    delegate of
        e : Exception *
        position : int *
        value : IPrimitive *
        sender : RegionEvaluable -> unit

Parameters

e
Type: SystemException
Ошибка.
position
Type: SystemInt32
Позиция ошибочного элемента в массиве.
value
Type: SMath.ManagerIPrimitive
Ошибочный элемент (для проверки).
sender
Type: SMath.ControlsRegionEvaluable
Ссылка на элемент, в котором производится вычисление.
See Also

Reference

SMath.Controls Namespace


EvaluateActionEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void EvaluateActionEventHandler(
    RegionEvaluable sender,
    bool immediate
)
Public Delegate Sub EvaluateActionEventHandler (
    sender As RegionEvaluable,
    immediate As Boolean
)
public delegate void EvaluateActionEventHandler(
    RegionEvaluable^ sender,
    bool immediate
)
type EvaluateActionEventHandler =
    delegate of
        sender : RegionEvaluable *
        immediate : bool -> unit

Parameters

sender
Type: SMath.ControlsRegionEvaluable
immediate
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


EvaluationEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void EvaluationEventHandler(
    string action
)
Public Delegate Sub EvaluationEventHandler (
    action As String
)
public delegate void EvaluationEventHandler(
    String^ action
)
type EvaluationEventHandler =
    delegate of
        action : string -> unit

Parameters

action
Type: SystemString
See Also

Reference

SMath.Controls Namespace


ExportContext Class

Inheritance Hierarchy
SystemObject
SMath.ControlsExportContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ExportContext
Public Class ExportContext
public ref class ExportContext
type ExportContext =  class end

The ExportContext type exposes the following members.

Constructors
 | Name | Description
Public method | ExportContext(Worksheet) | Initializes a new instance of the ExportContext class
Public method | ExportContext(Worksheet, PageModel) | Initializes a new instance of the ExportContext class
Public method | ExportContext(SessionProfile, MetaContext, RegionsManager, PageModel, PagesOptions, DictionaryString, WorksheetInfo) | Initializes a new instance of the ExportContext class
Top
Properties
 | Name | Description
Public property | CurrentPageIndex |
Public property | DocParams |
Public property | HasBuiltInHeaderFooter |
Public property | MetaData |
Public property | PageModel |
Public property | Pages |
Public property | PagesOptions |
Public property | SessionProfile |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePageModel |
Top
See Also

Reference

SMath.Controls Namespace


ExportContext Constructor

Overload List
 | Name | Description
Public method | ExportContext(Worksheet) | Initializes a new instance of the ExportContext class
Public method | ExportContext(Worksheet, PageModel) | Initializes a new instance of the ExportContext class
Public method | ExportContext(SessionProfile, MetaContext, RegionsManager, PageModel, PagesOptions, DictionaryString, WorksheetInfo) | Initializes a new instance of the ExportContext class
Top
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext Constructor (Worksheet)

Initializes a new instance of the ExportContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ExportContext(
    Worksheet worksheet
)
Public Sub New (
    worksheet As Worksheet
)
public:
ExportContext(
    Worksheet^ worksheet
)
new :
        worksheet : Worksheet -> ExportContext

Parameters

worksheet
Type: SMath.ControlsWorksheet
See Also

Reference

ExportContext Class
ExportContext Overload
SMath.Controls Namespace


ExportContext Constructor (Worksheet, PageModel)

Initializes a new instance of the ExportContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ExportContext(
    Worksheet worksheet,
    PageModel pageModel
)
Public Sub New (
    worksheet As Worksheet,
    pageModel As PageModel
)
public:
ExportContext(
    Worksheet^ worksheet,
    PageModel^ pageModel
)
new :
        worksheet : Worksheet *
        pageModel : PageModel -> ExportContext

Parameters

worksheet
Type: SMath.ControlsWorksheet
pageModel
Type: SMath.ManagerPageModel
See Also

Reference

ExportContext Class
ExportContext Overload
SMath.Controls Namespace


ExportContext Constructor (SessionProfile, MetaContext, RegionsManager, PageModel, PagesOptions, Dictionary(String, WorksheetInfo))

ExportContext Constructor (SessionProfile, MetaContext, RegionsManager, PageModel, PagesOptions, DictionaryString, WorksheetInfo)

Initializes a new instance of the ExportContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ExportContext(
    SessionProfile sessionProfile,
    MetaContext metaContext,
    RegionsManager manager,
    PageModel pageModel,
    PagesOptions pagesOptions,
    Dictionary<string, WorksheetInfo> metaData
)
Public Sub New (
    sessionProfile As SessionProfile,
    metaContext As MetaContext,
    manager As RegionsManager,
    pageModel As PageModel,
    pagesOptions As PagesOptions,
    metaData As Dictionary(Of String, WorksheetInfo)
)
public:
ExportContext(
    SessionProfile^ sessionProfile,
    MetaContext^ metaContext,
    RegionsManager^ manager,
    PageModel^ pageModel,
    PagesOptions^ pagesOptions,
    Dictionary<String^, WorksheetInfo^>^ metaData
)
new :
        sessionProfile : SessionProfile *
        metaContext : MetaContext *
        manager : RegionsManager *
        pageModel : PageModel *
        pagesOptions : PagesOptions *
        metaData : Dictionary<string, WorksheetInfo> -> ExportContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
metaContext
Type: SMath.ManagerMetaContext
manager
Type: SMath.ControlsRegionsManager
pageModel
Type: SMath.ManagerPageModel
pagesOptions
Type: SMath.ManagerPagesOptions
metaData
Type: System.Collections.GenericDictionaryString, WorksheetInfo
See Also

Reference

ExportContext Class
ExportContext Overload
SMath.Controls Namespace


ExportContext Properties

The ExportContext type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPageIndex |
Public property | DocParams |
Public property | HasBuiltInHeaderFooter |
Public property | MetaData |
Public property | PageModel |
Public property | Pages |
Public property | PagesOptions |
Public property | SessionProfile |
Public property | Title |
Top
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.CurrentPageIndex Property

ExportContextCurrentPageIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentPageIndex { get; }
Public ReadOnly Property CurrentPageIndex As Integer
    Get
public:
property int CurrentPageIndex {
    int get ();
}
member CurrentPageIndex : int with get

Property Value

Type: Int32
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.DocParams Property

ExportContextDocParams Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentParams DocParams { get; }
Public ReadOnly Property DocParams As DocumentParams
    Get
public:
property DocumentParams^ DocParams {
    DocumentParams^ get ();
}
member DocParams : DocumentParams with get

Property Value

Type: DocumentParams
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.HasBuiltInHeaderFooter Property

ExportContextHasBuiltInHeaderFooter Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasBuiltInHeaderFooter { get; }
Public ReadOnly Property HasBuiltInHeaderFooter As Boolean
    Get
public:
property bool HasBuiltInHeaderFooter {
    bool get ();
}
member HasBuiltInHeaderFooter : bool with get

Property Value

Type: Boolean
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.MetaData Property

ExportContextMetaData Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, WorksheetInfo> MetaData { get; }
Public ReadOnly Property MetaData As Dictionary(Of String, WorksheetInfo)
    Get
public:
property Dictionary<String^, WorksheetInfo^>^ MetaData {
    Dictionary<String^, WorksheetInfo^>^ get ();
}
member MetaData : Dictionary<string, WorksheetInfo> with get

Property Value

Type: DictionaryString, WorksheetInfo
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.PageModel Property

ExportContextPageModel Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel PageModel { get; }
Public ReadOnly Property PageModel As PageModel
    Get
public:
property PageModel^ PageModel {
    PageModel^ get ();
}
member PageModel : PageModel with get

Property Value

Type: PageModel
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.Pages Property

ExportContextPages Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator<RegionBase> Pages { get; }
Public ReadOnly Property Pages As PagesEnumerator(Of RegionBase)
    Get
public:
property PagesEnumerator<RegionBase^>^ Pages {
    PagesEnumerator<RegionBase^>^ get ();
}
member Pages : PagesEnumerator<RegionBase> with get

Property Value

Type: PagesEnumerator RegionBase
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.PagesOptions Property

ExportContextPagesOptions Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesOptions PagesOptions { get; }
Public ReadOnly Property PagesOptions As PagesOptions
    Get
public:
property PagesOptions^ PagesOptions {
    PagesOptions^ get ();
}
member PagesOptions : PagesOptions with get

Property Value

Type: PagesOptions
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.SessionProfile Property

ExportContextSessionProfile Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; }
Public ReadOnly Property SessionProfile As SessionProfile
    Get
public:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
}
member SessionProfile : SessionProfile with get

Property Value

Type: SessionProfile
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.Title Property

ExportContextTitle Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext Methods

The ExportContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePageModel |
Top
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExportContext.UpdatePageModel Method

ExportContextUpdatePageModel Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UpdatePageModel()
Public Sub UpdatePageModel
public:
void UpdatePageModel()
member UpdatePageModel : unit -> unit
See Also

Reference

ExportContext Class
SMath.Controls Namespace


ExtendedSearchEntry Structure

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct ExtendedSearchEntry
Public Structure ExtendedSearchEntry
public value class ExtendedSearchEntry
[<SealedAttribute>]
type ExtendedSearchEntry =  struct end

The ExtendedSearchEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedSearchEntry | Initializes a new instance of the ExtendedSearchEntry class
Top
Properties
 | Name | Description
Public property | Bounds |
Public property | CursorPosition |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
Name | Description
Empty |
Top
See Also

Reference

SMath.Controls Namespace


ExtendedSearchEntry Constructor

Initializes a new instance of the ExtendedSearchEntry class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ExtendedSearchEntry(
    int cursorPosition,
    RectangleF bounds
)
Public Sub New (
    cursorPosition As Integer,
    bounds As RectangleF
)
public:
ExtendedSearchEntry(
    int cursorPosition,
    RectangleF bounds
)
new :
        cursorPosition : int *
        bounds : RectangleF -> ExtendedSearchEntry

Parameters

cursorPosition
Type: SystemInt32
bounds
Type: System.DrawingRectangleF
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry Properties

The ExtendedSearchEntry type exposes the following members.

Properties
 | Name | Description
Public property | Bounds |
Public property | CursorPosition |
Top
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry.Bounds Property

ExtendedSearchEntryBounds Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF Bounds { get; }
Public ReadOnly Property Bounds As RectangleF
    Get
public:
property RectangleF Bounds {
    RectangleF get ();
}
member Bounds : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry.CursorPosition Property

ExtendedSearchEntryCursorPosition Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CursorPosition { get; }
Public ReadOnly Property CursorPosition As Integer
    Get
public:
property int CursorPosition {
    int get ();
}
member CursorPosition : int with get

Property Value

Type: Int32
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry Methods

The ExtendedSearchEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry Fields

The ExtendedSearchEntry type exposes the following members.

Fields
Name | Description
Empty |
Top
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


ExtendedSearchEntry.Empty Field

ExtendedSearchEntryEmpty Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ExtendedSearchEntry Empty
Public Shared Empty As ExtendedSearchEntry
public:
static ExtendedSearchEntry Empty
static val mutable Empty: ExtendedSearchEntry

Field Value

Type: ExtendedSearchEntry
See Also

Reference

ExtendedSearchEntry Structure
SMath.Controls Namespace


FileBehavior Enumeration

Behaviors that can be applied to the file type.Возможности, применимые к типу файла.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FileBehavior
<FlagsAttribute>
Public Enumeration FileBehavior
[FlagsAttribute]
public enum class FileBehavior
[<FlagsAttribute>]
type FileBehavior
Members
Member name | Value | Description
Open | 1 | File type can be opened only.Тип файла может быть только открыт.
Save | 2 | File type can be saved only.Тип файла может быть только сохранён.
Update | 4 | File type can be silently updated without file type confirmation.Тип файла может быть сохранён без предложения выбрать тип файла.
Undefined | 8 | File type cannot be handled.Тип файла не может быть обработан.
See Also

Reference

SMath.Controls Namespace


FileContext Class

File managing context.Контекст для работы с файлами сохранения.
Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ManagerActionContext
SMath.ControlsFileContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FileContext : ActionContext
Public Class FileContext
    Inherits ActionContext
public ref class FileContext : public ActionContext
type FileContext =
    class
        inherit ActionContext
    end

The FileContext type exposes the following members.

Constructors
 | Name | Description
Public method | FileContext(FileContext, String) | File context Class constructor.Конструктор класса файлового контекста.
Public method | FileContext(SessionProfile, String) | File context Class constructor.Конструктор класса файлового контекста.
Top
Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | Async | Determines if operations with files should be asynchronous or not.Определяет должны ли операции с файлами проводиться асинхронно или нет.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | Extension | File extension (in lower case).Расширение файла (в нижнем регистре).
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | LockedSource | Determines if peration should not affect on the source Worksheet.Определяет должны ли операции с файлами быть незначимыми для исходного расчёта или нет.
Public property | MetaData | Worksheet meta-data.Мета-данные листа.
Public property | Mode |
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов.
Public property | PagesOptions | Worksheets' options.Свойства листов расчётов.
Public property | ReadOnlySource | Determines if source file is read-only, so the user should not be able to save changes back to it.Определяет возможность сохранения изменений, сделанных в файле, обратно в исходный файл.
Public property | RegionsBounds |
Public property | RequestType |
Public property | Revision | (Inherited from DocumentParams.)
Public property | SaveFileName | Full path to the file saving should be performed to (can be temporary one).Полный путь к файлу, куда будет производиться сохранение (может быть временным).
Public property | SaveInTempFile | Determines if file should be saved in temporary file first.Определяет должно ли проводится сохранение предворительно во временный файл.
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Public property | WorksheetSize | Current worksheet canvas Size.Размер полотна текущего листа.
Top
Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateMetaContext |
 | GenerateMetaContext(SessionProfile, DocumentParams, DictionaryString, WorksheetInfo) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateFileName |
Public method | UpdateStatus |
Top
Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | OnActionCompleted | Raises on input/output operation completed.Вызывается при завершения операции ввода/вывода.
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
Fields
 | Name | Description
Public field | backFile | Obsolete.
Public field | homeFile | Obsolete.
Public field | Shortcut | Obsolete.
Public field | worksheetStatus | Obsolete.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose | (Inherited from ActionContext.)
Top
See Also

Reference

SMath.Controls Namespace


FileContext Constructor

Overload List
 | Name | Description
Public method | FileContext(FileContext, String) | File context Class constructor.Конструктор класса файлового контекста.
Public method | FileContext(SessionProfile, String) | File context Class constructor.Конструктор класса файлового контекста.
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext Constructor (FileContext, String)

File context Class constructor.Конструктор класса файлового контекста.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileContext(
    FileContext context,
    string fullName
)
Public Sub New (
    context As FileContext,
    fullName As String
)
public:
FileContext(
    FileContext^ context,
    String^ fullName
)
new :
        context : FileContext *
        fullName : string -> FileContext

Parameters

context
Type: SMath.ControlsFileContext
Context to copy parameters from.Контекст для копирования свойств.
fullName
Type: SystemString
Full path to the file.Полный путь к файлу.
See Also

Reference

FileContext Class
FileContext Overload
SMath.Controls Namespace


FileContext Constructor (SessionProfile, String)

File context Class constructor.Конструктор класса файлового контекста.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileContext(
    SessionProfile sessionProfile,
    string fullName
)
Public Sub New (
    sessionProfile As SessionProfile,
    fullName As String
)
public:
FileContext(
    SessionProfile^ sessionProfile,
    String^ fullName
)
new :
        sessionProfile : SessionProfile *
        fullName : string -> FileContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
fullName
Type: SystemString
Full path to the file.Полный путь к файлу.
See Also

Reference

FileContext Class
FileContext Overload
SMath.Controls Namespace


FileContext Properties

The FileContext type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | Async | Determines if operations with files should be asynchronous or not.Определяет должны ли операции с файлами проводиться асинхронно или нет.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | Extension | File extension (in lower case).Расширение файла (в нижнем регистре).
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | LockedSource | Determines if peration should not affect on the source Worksheet.Определяет должны ли операции с файлами быть незначимыми для исходного расчёта или нет.
Public property | MetaData | Worksheet meta-data.Мета-данные листа.
Public property | Mode |
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов.
Public property | PagesOptions | Worksheets' options.Свойства листов расчётов.
Public property | ReadOnlySource | Determines if source file is read-only, so the user should not be able to save changes back to it.Определяет возможность сохранения изменений, сделанных в файле, обратно в исходный файл.
Public property | RegionsBounds |
Public property | RequestType |
Public property | Revision | (Inherited from DocumentParams.)
Public property | SaveFileName | Full path to the file saving should be performed to (can be temporary one).Полный путь к файлу, куда будет производиться сохранение (может быть временным).
Public property | SaveInTempFile | Determines if file should be saved in temporary file first.Определяет должно ли проводится сохранение предворительно во временный файл.
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Public property | WorksheetSize | Current worksheet canvas Size.Размер полотна текущего листа.
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.AbsoluteDefinitions Property

FileContextAbsoluteDefinitions Property

Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Definition> AbsoluteDefinitions { get; set; }
Public Property AbsoluteDefinitions As List(Of Definition)
    Get
    Set
public:
property List<Definition^>^ AbsoluteDefinitions {
    List<Definition^>^ get ();
    void set (List<Definition^>^ value);
}
member AbsoluteDefinitions : List<Definition> with get, set

Property Value

Type: ListDefinition
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.Async Property

FileContextAsync Property

Determines if operations with files should be asynchronous or not.Определяет должны ли операции с файлами проводиться асинхронно или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Async { get; set; }
Public Property Async As Boolean
    Get
    Set
public:
property bool Async {
    bool get ();
    void set (bool value);
}
member Async : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.Extension Property

FileContextExtension Property

File extension (in lower case).Расширение файла (в нижнем регистре).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Extension { get; }
Public ReadOnly Property Extension As String
    Get
public:
property String^ Extension {
    String^ get ();
}
member Extension : string with get

Property Value

Type: String
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.LockedSource Property

FileContextLockedSource Property

Determines if peration should not affect on the source Worksheet.Определяет должны ли операции с файлами быть незначимыми для исходного расчёта или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool LockedSource { get; set; }
Public Property LockedSource As Boolean
    Get
    Set
public:
property bool LockedSource {
    bool get ();
    void set (bool value);
}
member LockedSource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.MetaData Property

FileContextMetaData Property

Worksheet meta-data.Мета-данные листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, WorksheetInfo> MetaData { get; set; }
Public Property MetaData As Dictionary(Of String, WorksheetInfo)
    Get
    Set
public:
property Dictionary<String^, WorksheetInfo^>^ MetaData {
    Dictionary<String^, WorksheetInfo^>^ get ();
    void set (Dictionary<String^, WorksheetInfo^>^ value);
}
member MetaData : Dictionary<string, WorksheetInfo> with get, set

Property Value

Type: DictionaryString, WorksheetInfo
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.Mode Property

FileContextMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PresentationMode Mode { get; set; }
Public Property Mode As PresentationMode
    Get
    Set
public:
property PresentationMode Mode {
    PresentationMode get ();
    void set (PresentationMode value);
}
member Mode : PresentationMode with get, set

Property Value

Type: PresentationMode
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.PageModel Property

FileContextPageModel Property

Print out worksheet parameters.Параметры печати листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel PageModel { get; set; }
Public Property PageModel As PageModel
    Get
    Set
public:
property PageModel^ PageModel {
    PageModel^ get ();
    void set (PageModel^ value);
}
member PageModel : PageModel with get, set

Property Value

Type: PageModel
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.PagesOptions Property

FileContextPagesOptions Property

Worksheets' options.Свойства листов расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesOptions PagesOptions { get; set; }
Public Property PagesOptions As PagesOptions
    Get
    Set
public:
property PagesOptions^ PagesOptions {
    PagesOptions^ get ();
    void set (PagesOptions^ value);
}
member PagesOptions : PagesOptions with get, set

Property Value

Type: PagesOptions
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.ReadOnlySource Property

FileContextReadOnlySource Property

Determines if source file is read-only, so the user should not be able to save changes back to it.Определяет возможность сохранения изменений, сделанных в файле, обратно в исходный файл.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnlySource { get; set; }
Public Property ReadOnlySource As Boolean
    Get
    Set
public:
property bool ReadOnlySource {
    bool get ();
    void set (bool value);
}
member ReadOnlySource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.RegionsBounds Property

FileContextRegionsBounds Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle RegionsBounds { get; set; }
Public Property RegionsBounds As Rectangle
    Get
    Set
public:
property Rectangle RegionsBounds {
    Rectangle get ();
    void set (Rectangle value);
}
member RegionsBounds : Rectangle with get, set

Property Value

Type: Rectangle
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.RequestType Property

FileContextRequestType Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileRequestType RequestType { get; set; }
Public Property RequestType As FileRequestType
    Get
    Set
public:
property FileRequestType RequestType {
    FileRequestType get ();
    void set (FileRequestType value);
}
member RequestType : FileRequestType with get, set

Property Value

Type: FileRequestType
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.SaveFileName Property

FileContextSaveFileName Property

Full path to the file saving should be performed to (can be temporary one).Полный путь к файлу, куда будет производиться сохранение (может быть временным).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string SaveFileName { get; }
Public ReadOnly Property SaveFileName As String
    Get
public:
property String^ SaveFileName {
    String^ get ();
}
member SaveFileName : string with get

Property Value

Type: String
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.SaveInTempFile Property

FileContextSaveInTempFile Property

Determines if file should be saved in temporary file first.Определяет должно ли проводится сохранение предворительно во временный файл.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SaveInTempFile { get; set; }
Public Property SaveInTempFile As Boolean
    Get
    Set
public:
property bool SaveInTempFile {
    bool get ();
    void set (bool value);
}
member SaveInTempFile : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.WorksheetSize Property

FileContextWorksheetSize Property

Current worksheet canvas Size.Размер полотна текущего листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size WorksheetSize { get; set; }
Public Property WorksheetSize As Size
    Get
    Set
public:
property Size WorksheetSize {
    Size get ();
    void set (Size value);
}
member WorksheetSize : Size with get, set

Property Value

Type: Size
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext Methods

The FileContext type exposes the following members.

Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateMetaContext |
 | GenerateMetaContext(SessionProfile, DocumentParams, DictionaryString, WorksheetInfo) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateFileName |
Public method | UpdateStatus |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose | (Inherited from ActionContext.)
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.GenerateMetaContext Method

FileContextGenerateMetaContext Method

Overload List
 | Name | Description
Public method | GenerateMetaContext |
 | GenerateMetaContext(SessionProfile, DocumentParams, DictionaryString, WorksheetInfo) |
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.GenerateMetaContext Method

FileContextGenerateMetaContext Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MetaContext GenerateMetaContext()
Public Function GenerateMetaContext As MetaContext
public:
MetaContext^ GenerateMetaContext()
member GenerateMetaContext : unit -> MetaContext

Return Value

Type: MetaContext
See Also

Reference

FileContext Class
GenerateMetaContext Overload
SMath.Controls Namespace


FileContext.GenerateMetaContext Method (SessionProfile, DocumentParams, Dictionary(String, WorksheetInfo))

FileContextGenerateMetaContext Method (SessionProfile, DocumentParams, DictionaryString, WorksheetInfo)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static MetaContext GenerateMetaContext(
    SessionProfile sessionProfile,
    DocumentParams docParams,
    Dictionary<string, WorksheetInfo> metaData
)
Public Shared Function GenerateMetaContext (
    sessionProfile As SessionProfile,
    docParams As DocumentParams,
    metaData As Dictionary(Of String, WorksheetInfo)
) As MetaContext
public:
static MetaContext^ GenerateMetaContext(
    SessionProfile^ sessionProfile,
    DocumentParams^ docParams,
    Dictionary<String^, WorksheetInfo^>^ metaData
)
static member GenerateMetaContext :
        sessionProfile : SessionProfile *
        docParams : DocumentParams *
        metaData : Dictionary<string, WorksheetInfo> -> MetaContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
docParams
Type: SMath.ManagerDocumentParams
metaData
Type: System.Collections.GenericDictionaryString, WorksheetInfo

Return Value

Type: MetaContext
See Also

Reference

FileContext Class
GenerateMetaContext Overload
SMath.Controls Namespace


FileContext.UpdateFileName Method

FileContextUpdateFileName Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UpdateFileName(
    string fullName
)
Public Sub UpdateFileName (
    fullName As String
)
public:
void UpdateFileName(
    String^ fullName
)
member UpdateFileName :
        fullName : string -> unit

Parameters

fullName
Type: SystemString
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.UpdateStatus Method

FileContextUpdateStatus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UpdateStatus(
    Worksheet sheet,
    bool success
)
Public Sub UpdateStatus (
    sheet As Worksheet,
    success As Boolean
)
public:
void UpdateStatus(
    Worksheet^ sheet,
    bool success
)
member UpdateStatus :
        sheet : Worksheet *
        success : bool -> unit

Parameters

sheet
Type: SMath.ControlsWorksheet
success
Type: SystemBoolean
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext Events

The FileContext type exposes the following members.

Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | OnActionCompleted | Raises on input/output operation completed.Вызывается при завершения операции ввода/вывода.
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.OnActionCompleted Event

FileContextOnActionCompleted Event

Raises on input/output operation completed.Вызывается при завершения операции ввода/вывода.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event IOActionCompletedEventHandler OnActionCompleted
Public Event OnActionCompleted As IOActionCompletedEventHandler
public:
 event IOActionCompletedEventHandler^ OnActionCompleted {
    void add (IOActionCompletedEventHandler^ value);
    void remove (IOActionCompletedEventHandler^ value);
}
member OnActionCompleted : IEvent<IOActionCompletedEventHandler,
    EventArgs>

Value

Type: SMath.ControlsIOActionCompletedEventHandler
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext Fields

The FileContext type exposes the following members.

Fields
 | Name | Description
Public field | backFile | Obsolete.
Public field | homeFile | Obsolete.
Public field | Shortcut | Obsolete.
Public field | worksheetStatus | Obsolete.
Top
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.backFile Field

FileContextbackFile Field

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)]
public string backFile
<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>
Public backFile As String
public:
[ObsoleteAttribute(L"Only for internal use! Will be removed in future.",
    false)]
String^ backFile
[<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>]
val mutable backFile: string

Field Value

Type: String
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.homeFile Field

FileContexthomeFile Field

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)]
public string homeFile
<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>
Public homeFile As String
public:
[ObsoleteAttribute(L"Only for internal use! Will be removed in future.",
    false)]
String^ homeFile
[<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>]
val mutable homeFile: string

Field Value

Type: String
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.Shortcut Field

FileContextShortcut Field

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)]
public string Shortcut
<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>
Public Shortcut As String
public:
[ObsoleteAttribute(L"Only for internal use! Will be removed in future.",
    false)]
String^ Shortcut
[<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>]
val mutable Shortcut: string

Field Value

Type: String
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileContext.worksheetStatus Field

FileContextworksheetStatus Field

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)]
public DocumentStatus worksheetStatus
<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>
Public worksheetStatus As DocumentStatus
public:
[ObsoleteAttribute(L"Only for internal use! Will be removed in future.",
    false)]
DocumentStatus worksheetStatus
[<ObsoleteAttribute("Only for internal use! Will be removed in future.",
    false)>]
val mutable worksheetStatus: DocumentStatus

Field Value

Type: DocumentStatus
See Also

Reference

FileContext Class
SMath.Controls Namespace


FileParsingContext Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ManagerActionContext
SMath.ControlsFileParsingContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FileParsingContext : ActionContext
Public Class FileParsingContext
    Inherits ActionContext
public ref class FileParsingContext : public ActionContext
type FileParsingContext =
    class
        inherit ActionContext
    end

The FileParsingContext type exposes the following members.

Constructors
 | Name | Description
Public method | FileParsingContext(SessionProfile) | Initializes a new instance of the FileParsingContext class
Public method | FileParsingContext(SessionProfile, Boolean) | Initializes a new instance of the FileParsingContext class
Top
Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | DecimalPlaces |
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | ExponentialThreshold |
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | FractionType |
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | Language |
Public property | Revision | (Inherited from DocumentParams.)
Public property | Rounding |
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SignificantDigitsMode |
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Public property | TrailingZeros |
Public property | Version |
Top
Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose | (Inherited from ActionContext.)
Top
See Also

Reference

SMath.Controls Namespace


FileParsingContext Constructor

Overload List
 | Name | Description
Public method | FileParsingContext(SessionProfile) | Initializes a new instance of the FileParsingContext class
Public method | FileParsingContext(SessionProfile, Boolean) | Initializes a new instance of the FileParsingContext class
Top
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext Constructor (SessionProfile)

Initializes a new instance of the FileParsingContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileParsingContext(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
FileParsingContext(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> FileParsingContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

FileParsingContext Class
FileParsingContext Overload
SMath.Controls Namespace


FileParsingContext Constructor (SessionProfile, Boolean)

Initializes a new instance of the FileParsingContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileParsingContext(
    SessionProfile sessionProfile,
    bool useProfile
)
Public Sub New (
    sessionProfile As SessionProfile,
    useProfile As Boolean
)
public:
FileParsingContext(
    SessionProfile^ sessionProfile,
    bool useProfile
)
new :
        sessionProfile : SessionProfile *
        useProfile : bool -> FileParsingContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
useProfile
Type: SystemBoolean
See Also

Reference

FileParsingContext Class
FileParsingContext Overload
SMath.Controls Namespace


FileParsingContext Properties

The FileParsingContext type exposes the following members.

Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | DecimalPlaces |
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | ExponentialThreshold |
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | FractionType |
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | Language |
Public property | Revision | (Inherited from DocumentParams.)
Public property | Rounding |
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SignificantDigitsMode |
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Public property | TrailingZeros |
Public property | Version |
Top
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.DecimalPlaces Property

FileParsingContextDecimalPlaces Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int DecimalPlaces { get; set; }
Public Property DecimalPlaces As Integer
    Get
    Set
public:
property int DecimalPlaces {
    int get ();
    void set (int value);
}
member DecimalPlaces : int with get, set

Property Value

Type: Int32
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.ExponentialThreshold Property

FileParsingContextExponentialThreshold Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ExponentialThreshold { get; set; }
Public Property ExponentialThreshold As Integer
    Get
    Set
public:
property int ExponentialThreshold {
    int get ();
    void set (int value);
}
member ExponentialThreshold : int with get, set

Property Value

Type: Int32
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.FractionType Property

FileParsingContextFractionType Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FractionsType FractionType { get; set; }
Public Property FractionType As FractionsType
    Get
    Set
public:
property FractionsType FractionType {
    FractionsType get ();
    void set (FractionsType value);
}
member FractionType : FractionsType with get, set

Property Value

Type: FractionsType
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.Language Property

FileParsingContextLanguage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.Rounding Property

FileParsingContextRounding Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MidpointRounding Rounding { get; set; }
Public Property Rounding As MidpointRounding
    Get
    Set
public:
property MidpointRounding Rounding {
    MidpointRounding get ();
    void set (MidpointRounding value);
}
member Rounding : MidpointRounding with get, set

Property Value

Type: MidpointRounding
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.SignificantDigitsMode Property

FileParsingContextSignificantDigitsMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SignificantDigitsMode { get; set; }
Public Property SignificantDigitsMode As Boolean
    Get
    Set
public:
property bool SignificantDigitsMode {
    bool get ();
    void set (bool value);
}
member SignificantDigitsMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.TrailingZeros Property

FileParsingContextTrailingZeros Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TrailingZeros { get; set; }
Public Property TrailingZeros As Boolean
    Get
    Set
public:
property bool TrailingZeros {
    bool get ();
    void set (bool value);
}
member TrailingZeros : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext.Version Property

FileParsingContextVersion Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Version Version { get; set; }
Public Property Version As Version
    Get
    Set
public:
property Version^ Version {
    Version^ get ();
    void set (Version^ value);
}
member Version : Version with get, set

Property Value

Type: Version
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext Methods

The FileParsingContext type exposes the following members.

Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose | (Inherited from ActionContext.)
Top
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileParsingContext Events

The FileParsingContext type exposes the following members.

Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
See Also

Reference

FileParsingContext Class
SMath.Controls Namespace


FileRequestType Enumeration

Type of the files related operation.Тип операции по работе с файлами.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum FileRequestType
Public Enumeration FileRequestType
public enum class FileRequestType
type FileRequestType
Members
Member name | Value | Description
Unknown | 0 | Operation to open/save file data.
MetaData | 1 | Operation to read meta-data of the document with no content handling.
Objects | 2 | Operation to read document objects with no content handling.
Document | 3 | Operation to open/save file data.
SandboxedObjects | 6 | Operation to handle objects with no regards to the overall document.
See Also

Reference

SMath.Controls Namespace


FileType Class

Class to store meta-data of the file type.Класс для хранения мета-данных типа файла.
Inheritance Hierarchy
SystemObject
SMath.ControlsFileType
SMath.ControlsDragAndDropFileType

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FileType
Public Class FileType
public ref class FileType
type FileType =  class end

The FileType type exposes the following members.

Constructors
 | Name | Description
Public method | FileType | File type constructor.Конструктор типа файла.
Top
Properties
 | Name | Description
Public property | Behavior | Applied to the file type behaviors.Возможности, применимые к текущему типу файла.
Public property | Description | Description of the file type.Описание типа файла.
Public property | Extensions | Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | JoinExtensions | Merging all the extensions in one string with ";" delimiter.Запись вместе всех расширений типа файла с символом ";" в качестве разделителя.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


FileType Constructor

File type constructor.Конструктор типа файла.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileType(
    string description,
    string[] extensions,
    FileBehavior behavior
)
Public Sub New (
    description As String,
    extensions As String(),
    behavior As FileBehavior
)
public:
FileType(
    String^ description,
    array<String^>^ extensions,
    FileBehavior behavior
)
new :
        description : string *
        extensions : string[] *
        behavior : FileBehavior -> FileType

Parameters

description
Type: SystemString
Description of the file type.Описание типа файла.
extensions
Type: SystemString
Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла.
behavior
Type: SMath.ControlsFileBehavior
Applied to the file type behaviors.Возможности, применимые к текущему типу файла.
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType Properties

The FileType type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Applied to the file type behaviors.Возможности, применимые к текущему типу файла.
Public property | Description | Description of the file type.Описание типа файла.
Public property | Extensions | Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла.
Top
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType.Behavior Property

FileTypeBehavior Property

Applied to the file type behaviors.Возможности, применимые к текущему типу файла.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FileBehavior Behavior { get; }
Public ReadOnly Property Behavior As FileBehavior
    Get
public:
property FileBehavior Behavior {
    FileBehavior get ();
}
member Behavior : FileBehavior with get

Property Value

Type: FileBehavior
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType.Description Property

FileTypeDescription Property

Description of the file type.Описание типа файла.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType.Extensions Property

FileTypeExtensions Property

Array of the extensions associated with current file type.Массив расширений, ассоциированных с типом файла.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] Extensions { get; }
Public ReadOnly Property Extensions As String()
    Get
public:
property array<String^>^ Extensions {
    array<String^>^ get ();
}
member Extensions : string[] with get

Property Value

Type: String
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType Methods

The FileType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | JoinExtensions | Merging all the extensions in one string with ";" delimiter.Запись вместе всех расширений типа файла с символом ";" в качестве разделителя.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileType Class
SMath.Controls Namespace


FileType.JoinExtensions Method

FileTypeJoinExtensions Method

Merging all the extensions in one string with ";" delimiter.Запись вместе всех расширений типа файла с символом ";" в качестве разделителя.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string JoinExtensions()
Public Function JoinExtensions As String
public:
String^ JoinExtensions()
member JoinExtensions : unit -> string

Return Value

Type: String
Returns string contains all the file type extensions.Возвращает строку, содержащую все расширения типа файлов.
See Also

Reference

FileType Class
SMath.Controls Namespace


FloatingButtonInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsFloatingButtonInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FloatingButtonInfo
Public Class FloatingButtonInfo
public ref class FloatingButtonInfo
type FloatingButtonInfo =  class end

The FloatingButtonInfo type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingButtonInfo | Initializes a new instance of the FloatingButtonInfo class
Top
Methods
 | Name | Description
Public method | Draw |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBottomRightBounds |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


FloatingButtonInfo Constructor

Initializes a new instance of the FloatingButtonInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FloatingButtonInfo(
    FloatingButtonType type
)
Public Sub New (
    type As FloatingButtonType
)
public:
FloatingButtonInfo(
    FloatingButtonType type
)
new :
        type : FloatingButtonType -> FloatingButtonInfo

Parameters

type
Type: SMath.ControlsFloatingButtonType
See Also

Reference

FloatingButtonInfo Class
SMath.Controls Namespace


FloatingButtonInfo Methods

The FloatingButtonInfo type exposes the following members.

Methods
 | Name | Description
Public method | Draw |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBottomRightBounds |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FloatingButtonInfo Class
SMath.Controls Namespace


FloatingButtonInfo.Draw Method

FloatingButtonInfoDraw Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    IGraphics g,
    float width,
    float height
)
Public Sub Draw (
    g As IGraphics,
    width As Single,
    height As Single
)
public:
void Draw(
    IGraphics^ g,
    float width,
    float height
)
member Draw :
        g : IGraphics *
        width : float32 *
        height : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
width
Type: SystemSingle
height
Type: SystemSingle
See Also

Reference

FloatingButtonInfo Class
SMath.Controls Namespace


FloatingButtonInfo.GetBottomRightBounds Method

FloatingButtonInfoGetBottomRightBounds Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF GetBottomRightBounds()
Public Function GetBottomRightBounds As RectangleF
public:
RectangleF GetBottomRightBounds()
member GetBottomRightBounds : unit -> RectangleF

Return Value

Type: RectangleF
See Also

Reference

FloatingButtonInfo Class
SMath.Controls Namespace


FloatingButtonType Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum FloatingButtonType
Public Enumeration FloatingButtonType
public enum class FloatingButtonType
type FloatingButtonType
Members
Member name | Value | Description
Main | 0 |
Toolboxes | 1 |
See Also

Reference

SMath.Controls Namespace


GlobalMatchingOptions Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMatchingOptions
SMath.ControlsGlobalMatchingOptions

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class GlobalMatchingOptions : MatchingOptions
Public Class GlobalMatchingOptions
    Inherits MatchingOptions
public ref class GlobalMatchingOptions : public MatchingOptions
type GlobalMatchingOptions =
    class
        inherit MatchingOptions
    end

The GlobalMatchingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalMatchingOptions | Initializes a new instance of the GlobalMatchingOptions class
Top
Properties
 | Name | Description
Public property | CaseSensitive | (Inherited from MatchingOptions.)
Public property | ExcludeDisabled |
Public property | ExcludeInvisible |
Public property | WholeWord | (Inherited from MatchingOptions.)
Top
Methods
 | Name | Description
Public method | ApplyRegex | (Inherited from MatchingOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


GlobalMatchingOptions Constructor

Initializes a new instance of the GlobalMatchingOptions class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public GlobalMatchingOptions()
Public Sub New
public:
GlobalMatchingOptions()
new : unit -> GlobalMatchingOptions
See Also

Reference

GlobalMatchingOptions Class
SMath.Controls Namespace


GlobalMatchingOptions Properties

The GlobalMatchingOptions type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | (Inherited from MatchingOptions.)
Public property | ExcludeDisabled |
Public property | ExcludeInvisible |
Public property | WholeWord | (Inherited from MatchingOptions.)
Top
See Also

Reference

GlobalMatchingOptions Class
SMath.Controls Namespace


GlobalMatchingOptions.ExcludeDisabled Property

GlobalMatchingOptionsExcludeDisabled Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ExcludeDisabled { get; set; }
Public Property ExcludeDisabled As Boolean
    Get
    Set
public:
property bool ExcludeDisabled {
    bool get ();
    void set (bool value);
}
member ExcludeDisabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GlobalMatchingOptions Class
SMath.Controls Namespace


GlobalMatchingOptions.ExcludeInvisible Property

GlobalMatchingOptionsExcludeInvisible Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ExcludeInvisible { get; set; }
Public Property ExcludeInvisible As Boolean
    Get
    Set
public:
property bool ExcludeInvisible {
    bool get ();
    void set (bool value);
}
member ExcludeInvisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

GlobalMatchingOptions Class
SMath.Controls Namespace


GlobalMatchingOptions Methods

The GlobalMatchingOptions type exposes the following members.

Methods
 | Name | Description
Public method | ApplyRegex | (Inherited from MatchingOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalMatchingOptions Class
SMath.Controls Namespace


HistoryManager Class

Worksheet changes history utility.
Inheritance Hierarchy
SystemObject
SMath.ControlsHistoryManager

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class HistoryManager
Public Class HistoryManager
public ref class HistoryManager
type HistoryManager =  class end

The HistoryManager type exposes the following members.

Constructors
 | Name | Description
Public method | HistoryManager | Initializes a new Changes History object for specified Worksheet.
Top
Properties
 | Name | Description
Public property | IsSaved | Defines if the worksheet is edited or not.Определяет отредактирован ли лист или нет.
Public property | Status | Worksheet history status.
Top
Methods
 | Name | Description
Public method | CreateTransaction | Creates history transaction. Allows to register all changes made within current transaction as a single bunch of changes for a single history step (including for nested transactions).Создаёт транзакцию истории изменений. Позволяет зарегистрировать все происходящие изменения в качестве единого шага в истории изменений листа расчётов (в том числе для вложенных транзакций).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MarkAsInitial | Marks current history step as an initial one (no backward history will be available for user).
Public method | MarkAsSaved | Marks current history step as a saved one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Отмена последнего в стеке возврата на шаг назад в истории.
Public method | RegisterRegion | Register Region within current History object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Возврат состояния листа в истории на один шаг назад.
Public method | UnregisterRegion | Unregister Region within current History object.
Top
See Also

Reference

SMath.Controls Namespace


HistoryManager Constructor

Initializes a new Changes History object for specified Worksheet.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManager(
    Worksheet sheet
)
Public Sub New (
    sheet As Worksheet
)
public:
HistoryManager(
    Worksheet^ sheet
)
new :
        sheet : Worksheet -> HistoryManager

Parameters

sheet
Type: SMath.ControlsWorksheet
Worksheet current Changes History object belongs to.
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager Properties

The HistoryManager type exposes the following members.

Properties
 | Name | Description
Public property | IsSaved | Defines if the worksheet is edited or not.Определяет отредактирован ли лист или нет.
Public property | Status | Worksheet history status.
Top
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.IsSaved Property

HistoryManagerIsSaved Property

Defines if the worksheet is edited or not.Определяет отредактирован ли лист или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSaved { get; }
Public ReadOnly Property IsSaved As Boolean
    Get
public:
property bool IsSaved {
    bool get ();
}
member IsSaved : bool with get

Property Value

Type: Boolean
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.Status Property

HistoryManagerStatus Property

Worksheet history status.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManagerStepType Status { get; }
Public ReadOnly Property Status As HistoryManagerStepType
    Get
public:
property HistoryManagerStepType Status {
    HistoryManagerStepType get ();
}
member Status : HistoryManagerStepType with get

Property Value

Type: HistoryManagerStepType
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager Methods

The HistoryManager type exposes the following members.

Methods
 | Name | Description
Public method | CreateTransaction | Creates history transaction. Allows to register all changes made within current transaction as a single bunch of changes for a single history step (including for nested transactions).Создаёт транзакцию истории изменений. Позволяет зарегистрировать все происходящие изменения в качестве единого шага в истории изменений листа расчётов (в том числе для вложенных транзакций).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MarkAsInitial | Marks current history step as an initial one (no backward history will be available for user).
Public method | MarkAsSaved | Marks current history step as a saved one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redo | Отмена последнего в стеке возврата на шаг назад в истории.
Public method | RegisterRegion | Register Region within current History object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Возврат состояния листа в истории на один шаг назад.
Public method | UnregisterRegion | Unregister Region within current History object.
Top
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.CreateTransaction Method

HistoryManagerCreateTransaction Method

Creates history transaction. Allows to register all changes made within current transaction as a single bunch of changes for a single history step (including for nested transactions).Создаёт транзакцию истории изменений. Позволяет зарегистрировать все происходящие изменения в качестве единого шага в истории изменений листа расчётов (в том числе для вложенных транзакций).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManagerTransaction CreateTransaction(
    bool ignore = false
)
Public Function CreateTransaction (
    Optional ignore As Boolean = false
) As HistoryManagerTransaction
public:
HistoryManagerTransaction^ CreateTransaction(
    bool ignore = false
)
member CreateTransaction :
        ?ignore : bool
(* Defaults:
        let _ignore = defaultArg ignore false
*)
-> HistoryManagerTransaction

Parameters

ignore (Optional)
Type: SystemBoolean

Return Value

Type: HistoryManagerTransaction
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.MarkAsInitial Method

HistoryManagerMarkAsInitial Method

Marks current history step as an initial one (no backward history will be available for user).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MarkAsInitial()
Public Sub MarkAsInitial
public:
void MarkAsInitial()
member MarkAsInitial : unit -> unit
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.MarkAsSaved Method

HistoryManagerMarkAsSaved Method

Marks current history step as a saved one.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MarkAsSaved()
Public Sub MarkAsSaved
public:
void MarkAsSaved()
member MarkAsSaved : unit -> unit
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.Redo Method

HistoryManagerRedo Method

Отмена последнего в стеке возврата на шаг назад в истории.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Redo()
Public Sub Redo
public:
void Redo()
member Redo : unit -> unit

Return Value

Type:
Index of the Region Worksheet evaluation must be started from.Возвращает номер элемента, с которого необходимо начать пересчёт.
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.RegisterRegion Method

HistoryManagerRegisterRegion Method

Register Region within current History object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RegisterRegion(
    RegionBase region,
    bool makeCurrent
)
Public Sub RegisterRegion (
    region As RegionBase,
    makeCurrent As Boolean
)
public:
void RegisterRegion(
    RegionBase^ region,
    bool makeCurrent
)
member RegisterRegion :
        region : RegionBase *
        makeCurrent : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
makeCurrent
Type: SystemBoolean
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.Undo Method

HistoryManagerUndo Method

Возврат состояния листа в истории на один шаг назад.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Undo()
Public Sub Undo
public:
void Undo()
member Undo : unit -> unit

Return Value

Type:
Index of the Region Worksheet evaluation must be started from.Возвращает номер элемента, с которого необходимо начать пересчёт.
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.UnregisterRegion Method

HistoryManagerUnregisterRegion Method

Unregister Region within current History object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UnregisterRegion(
    RegionBase region
)
Public Sub UnregisterRegion (
    region As RegionBase
)
public:
void UnregisterRegion(
    RegionBase^ region
)
member UnregisterRegion :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

HistoryManager Class
SMath.Controls Namespace


HistoryManager.RegionChange Class

HistoryManagerRegionChange Class

Stores single change of the Region.
Inheritance Hierarchy
SystemObject
SMath.ControlsHistoryManagerRegionChange

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RegionChange
Public Class RegionChange
public ref class RegionChange
type RegionChange =  class end

The HistoryManagerRegionChange type exposes the following members.

Constructors
 | Name | Description
Public method | HistoryManagerRegionChange | Initializes a new instance of the HistoryManagerRegionChange class
Top
Properties
 | Name | Description
Public property | Backward |
Public property | Forward |
Public property | Region |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


HistoryManager.RegionChange Constructor

HistoryManagerRegionChange Constructor

Initializes a new instance of the HistoryManagerRegionChange class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionChange(
    RegionBase Region,
    HistoryStepBase Change,
    HistoryManagerRegionChangeType Type
)
Public Sub New (
    Region As RegionBase,
    Change As HistoryStepBase,
    Type As HistoryManagerRegionChangeType
)
public:
RegionChange(
    RegionBase^ Region,
    HistoryStepBase^ Change,
    HistoryManagerRegionChangeType Type
)
new :
        Region : RegionBase *
        Change : HistoryStepBase *
        Type : HistoryManagerRegionChangeType -> RegionChange

Parameters

Region
Type: SMath.ControlsRegionBase
Change
Type: SMath.ControlsHistoryStepBase
Type
Type: SMath.ControlsHistoryManagerRegionChangeType
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


RegionChange Properties

The HistoryManagerRegionChange type exposes the following members.

Properties
 | Name | Description
Public property | Backward |
Public property | Forward |
Public property | Region |
Public property | Type |
Top
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


HistoryManager.RegionChange.Backward Property

HistoryManagerRegionChangeBackward Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryStepBase Backward { get; set; }
Public Property Backward As HistoryStepBase
    Get
    Set
public:
property HistoryStepBase^ Backward {
    HistoryStepBase^ get ();
    void set (HistoryStepBase^ value);
}
member Backward : HistoryStepBase with get, set

Property Value

Type: HistoryStepBase
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


HistoryManager.RegionChange.Forward Property

HistoryManagerRegionChangeForward Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryStepBase Forward { get; set; }
Public Property Forward As HistoryStepBase
    Get
    Set
public:
property HistoryStepBase^ Forward {
    HistoryStepBase^ get ();
    void set (HistoryStepBase^ value);
}
member Forward : HistoryStepBase with get, set

Property Value

Type: HistoryStepBase
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


HistoryManager.RegionChange.Region Property

HistoryManagerRegionChangeRegion Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase Region { get; }
Public ReadOnly Property Region As RegionBase
    Get
public:
property RegionBase^ Region {
    RegionBase^ get ();
}
member Region : RegionBase with get

Property Value

Type: RegionBase
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


HistoryManager.RegionChange.Type Property

HistoryManagerRegionChangeType Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManagerRegionChangeType Type { get; }
Public ReadOnly Property Type As HistoryManagerRegionChangeType
    Get
public:
property HistoryManagerRegionChangeType Type {
    HistoryManagerRegionChangeType get ();
}
member Type : HistoryManagerRegionChangeType with get

Property Value

Type: HistoryManagerRegionChangeType
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


RegionChange Methods

The HistoryManagerRegionChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HistoryManagerRegionChange Class
SMath.Controls Namespace


HistoryManager.RegionChangeType Enumeration

HistoryManagerRegionChangeType Enumeration

History step type.Тип шага истории изменений.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum RegionChangeType
Public Enumeration RegionChangeType
public enum class RegionChangeType
type RegionChangeType
Members
Member name | Value | Description
Edit | 0 | Change in Region's properties.Изменения в свойствах элемента.
Add | 1 | Region added to worksheet.Элемент добавлен на лист.
Remove | 2 | Region removed from worksheet.Элемент удалён с листа.
See Also

Reference

SMath.Controls Namespace


HistoryManager.StepType Enumeration

HistoryManagerStepType Enumeration

Page history status.Статус истории изменений.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum StepType
<FlagsAttribute>
Public Enumeration StepType
[FlagsAttribute]
public enum class StepType
[<FlagsAttribute>]
type StepType
Members
Member name | Value | Description
Empty | 0 | No history available.Нет истории изменений.
Backward | 1 | Undo is available.Отмена доступна.
Forward | 2 | Redo is available.Возврат доступен.
See Also

Reference

SMath.Controls Namespace


HistoryManager.Transaction Class

HistoryManagerTransaction Class

Transaction of changes history.Транзакция истории изменений.
Inheritance Hierarchy
SystemObject
SMath.ControlsChangeRequestContext
SMath.ControlsHistoryManagerTransaction

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Transaction : ChangeRequestContext,
    IDisposable
Public Class Transaction
    Inherits ChangeRequestContext
    Implements IDisposable
public ref class Transaction : public ChangeRequestContext,
    IDisposable
type Transaction =
    class
        inherit ChangeRequestContext
        interface IDisposable
    end

The HistoryManagerTransaction type exposes the following members.

Constructors
 | Name | Description
Public method | HistoryManagerTransaction | Initializes a new instance of the HistoryManagerTransaction class
Top
Properties
 | Name | Description
Public property | Changes | Cached history changes.
Public property | EvaluationApproved |
Protected property | EvaluationRequested | Determines whether change was requested. (Inherited from ChangeRequestContext.)
Public property | Ignore |
Protected property | SortingRequested | (Inherited from ChangeRequestContext.)
Protected property | SourceLocation | (Inherited from ChangeRequestContext.)
Protected property | SourceRegion | The first Region of the Worksheet requested evaluation. (Inherited from ChangeRequestContext.)
Top
Methods
 | Name | Description
Protected method | CompareLocations | (Inherited from ChangeRequestContext.)
Public method | CopyStatus | (Inherited from ChangeRequestContext.)
Public method | Dispose | Dispose history transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeUpdate | Updates currently stored first evaluable Region with specified one if required. (Inherited from ChangeRequestContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareRegionsHash |
Protected method | ResetUpdates | Reset updates to prepare for next round. (Inherited from ChangeRequestContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
See Also

Reference

SMath.Controls Namespace


HistoryManager.Transaction Constructor

HistoryManagerTransaction Constructor

Initializes a new instance of the HistoryManagerTransaction class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Transaction(
    HistoryManager history,
    bool ignore
)
Public Sub New (
    history As HistoryManager,
    ignore As Boolean
)
public:
Transaction(
    HistoryManager^ history,
    bool ignore
)
new :
        history : HistoryManager *
        ignore : bool -> Transaction

Parameters

history
Type: SMath.ControlsHistoryManager
ignore
Type: SystemBoolean
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


Transaction Properties

The HistoryManagerTransaction type exposes the following members.

Properties
 | Name | Description
Public property | Changes | Cached history changes.
Public property | EvaluationApproved |
Protected property | EvaluationRequested | Determines whether change was requested. (Inherited from ChangeRequestContext.)
Public property | Ignore |
Protected property | SortingRequested | (Inherited from ChangeRequestContext.)
Protected property | SourceLocation | (Inherited from ChangeRequestContext.)
Protected property | SourceRegion | The first Region of the Worksheet requested evaluation. (Inherited from ChangeRequestContext.)
Top
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.Changes Property

HistoryManagerTransactionChanges Property

Cached history changes.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<HistoryManagerRegionChange> Changes { get; }
Public ReadOnly Property Changes As List(Of HistoryManagerRegionChange)
    Get
public:
property List<HistoryManagerRegionChange^>^ Changes {
    List<HistoryManagerRegionChange^>^ get ();
}
member Changes : List<HistoryManagerRegionChange> with get

Property Value

Type: ListHistoryManagerRegionChange
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.EvaluationApproved Property

HistoryManagerTransactionEvaluationApproved Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool EvaluationApproved { get; set; }
Public Property EvaluationApproved As Boolean
    Get
    Set
public:
property bool EvaluationApproved {
    bool get ();
    void set (bool value);
}
member EvaluationApproved : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.Ignore Property

HistoryManagerTransactionIgnore Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Ignore { get; }
Public ReadOnly Property Ignore As Boolean
    Get
public:
property bool Ignore {
    bool get ();
}
member Ignore : bool with get

Property Value

Type: Boolean
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


Transaction Methods

The HistoryManagerTransaction type exposes the following members.

Methods
 | Name | Description
Protected method | CompareLocations | (Inherited from ChangeRequestContext.)
Public method | CopyStatus | (Inherited from ChangeRequestContext.)
Public method | Dispose | Dispose history transaction.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeUpdate | Updates currently stored first evaluable Region with specified one if required. (Inherited from ChangeRequestContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareRegionsHash |
Protected method | ResetUpdates | Reset updates to prepare for next round. (Inherited from ChangeRequestContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.Dispose Method

HistoryManagerTransactionDispose Method

Dispose history transaction.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.PrepareRegionsHash Method

HistoryManagerTransactionPrepareRegionsHash Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void PrepareRegionsHash()
Public Sub PrepareRegionsHash
public:
void PrepareRegionsHash()
member PrepareRegionsHash : unit -> unit
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryManager.Transaction.Update Method

HistoryManagerTransactionUpdate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    RegionBase region,
    Point location,
    bool evaluationRequired,
    bool sortingRequired
)
Public Sub Update (
    region As RegionBase,
    location As Point,
    evaluationRequired As Boolean,
    sortingRequired As Boolean
)
public:
void Update(
    RegionBase^ region,
    Point location,
    bool evaluationRequired,
    bool sortingRequired
)
member Update :
        region : RegionBase *
        location : Point *
        evaluationRequired : bool *
        sortingRequired : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
location
Type: System.DrawingPoint
evaluationRequired
Type: SystemBoolean
sortingRequired
Type: SystemBoolean
See Also

Reference

HistoryManagerTransaction Class
SMath.Controls Namespace


HistoryStepBase Class

History step storing of the Region.Хранение данных шага истории изменений элемента листа.
Inheritance Hierarchy
SystemObject
SMath.ControlsHistoryStepBase
SMath.ControlsHistoryStepEvaluable

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class HistoryStepBase
Public Class HistoryStepBase
public ref class HistoryStepBase
type HistoryStepBase =  class end

The HistoryStepBase type exposes the following members.

Constructors
 | Name | Description
Public method | HistoryStepBase | Initializes a new instance of the HistoryStepBase class
Top
Methods
 | Name | Description
Public method | Apply | Применение параметров шага истории к элементу.
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BackColor |
Public field | Border |
Public field | Focused |
Public field | FontHeight |
Public field | Location |
Public field | TextColor |
Top
See Also

Reference

SMath.Controls Namespace


HistoryStepBase Constructor

Initializes a new instance of the HistoryStepBase class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryStepBase(
    RegionBase region
)
Public Sub New (
    region As RegionBase
)
public:
HistoryStepBase(
    RegionBase^ region
)
new :
        region : RegionBase -> HistoryStepBase

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase Methods

The HistoryStepBase type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Применение параметров шага истории к элементу.
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.Apply Method

HistoryStepBaseApply Method

Применение параметров шага истории к элементу.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Apply(
    RegionBase region
)
Public Overridable Sub Apply (
    region As RegionBase
)
public:
virtual void Apply(
    RegionBase^ region
)
abstract Apply :
        region : RegionBase -> unit
override Apply :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.Equals Method

HistoryStepBaseEquals Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.GetHashCode Method

HistoryStepBaseGetHashCode Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase Fields

The HistoryStepBase type exposes the following members.

Fields
 | Name | Description
Public field | BackColor |
Public field | Border |
Public field | Focused |
Public field | FontHeight |
Public field | Location |
Public field | TextColor |
Top
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.BackColor Field

HistoryStepBaseBackColor Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color BackColor
Public BackColor As Color
public:
Color BackColor
val mutable BackColor: Color

Field Value

Type: Color
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.Border Field

HistoryStepBaseBorder Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Border
Public Border As Boolean
public:
bool Border
val mutable Border: bool

Field Value

Type: Boolean
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.Focused Field

HistoryStepBaseFocused Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Focused
Public Focused As Boolean
public:
bool Focused
val mutable Focused: bool

Field Value

Type: Boolean
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.FontHeight Field

HistoryStepBaseFontHeight Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float FontHeight
Public FontHeight As Single
public:
float FontHeight
val mutable FontHeight: float32

Field Value

Type: Single
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.Location Field

HistoryStepBaseLocation Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point Location
Public Location As Point
public:
Point Location
val mutable Location: Point

Field Value

Type: Point
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepBase.TextColor Field

HistoryStepBaseTextColor Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color TextColor
Public TextColor As Color
public:
Color TextColor
val mutable TextColor: Color

Field Value

Type: Color
See Also

Reference

HistoryStepBase Class
SMath.Controls Namespace


HistoryStepEvaluable Class

History step storing of the Evaluable Region.Хранение данных шага истории изменений вычисляемого элемента листа.
Inheritance Hierarchy
SystemObject
SMath.ControlsHistoryStepBase
SMath.ControlsHistoryStepEvaluable

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class HistoryStepEvaluable : HistoryStepBase
Public Class HistoryStepEvaluable
    Inherits HistoryStepBase
public ref class HistoryStepEvaluable : public HistoryStepBase
type HistoryStepEvaluable =
    class
        inherit HistoryStepBase
    end

The HistoryStepEvaluable type exposes the following members.

Constructors
 | Name | Description
Public method | HistoryStepEvaluable | Initializes a new instance of the HistoryStepEvaluable class
Top
Methods
 | Name | Description
Public method | Apply | (Overrides HistoryStepBaseApply(RegionBase).)
Public method | Equals | (Overrides HistoryStepBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides HistoryStepBaseGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BackColor | (Inherited from HistoryStepBase.)
Public field | Border | (Inherited from HistoryStepBase.)
Public field | CurrentTermIndexes |
Public field | DescriptionLocation |
Public field | Evaluable |
Public field | Focused | (Inherited from HistoryStepBase.)
Public field | FontHeight | (Inherited from HistoryStepBase.)
Public field | Location | (Inherited from HistoryStepBase.)
Public field | Optimization |
Public field | SelectedTermsIndexes |
Public field | ShowDescription |
Public field | Terms |
Public field | TextColor | (Inherited from HistoryStepBase.)
Top
See Also

Reference

SMath.Controls Namespace


HistoryStepEvaluable Constructor

Initializes a new instance of the HistoryStepEvaluable class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryStepEvaluable(
    RegionEvaluable region
)
Public Sub New (
    region As RegionEvaluable
)
public:
HistoryStepEvaluable(
    RegionEvaluable^ region
)
new :
        region : RegionEvaluable -> HistoryStepEvaluable

Parameters

region
Type: SMath.ControlsRegionEvaluable
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable Methods

The HistoryStepEvaluable type exposes the following members.

Methods
 | Name | Description
Public method | Apply | (Overrides HistoryStepBaseApply(RegionBase).)
Public method | Equals | (Overrides HistoryStepBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides HistoryStepBaseGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.Apply Method

HistoryStepEvaluableApply Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Apply(
    RegionBase region
)
Public Overrides Sub Apply (
    region As RegionBase
)
public:
virtual void Apply(
    RegionBase^ region
) override
abstract Apply :
        region : RegionBase -> unit
override Apply :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.Equals Method

HistoryStepEvaluableEquals Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.GetHashCode Method

HistoryStepEvaluableGetHashCode Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable Fields

The HistoryStepEvaluable type exposes the following members.

Fields
 | Name | Description
Public field | BackColor | (Inherited from HistoryStepBase.)
Public field | Border | (Inherited from HistoryStepBase.)
Public field | CurrentTermIndexes |
Public field | DescriptionLocation |
Public field | Evaluable |
Public field | Focused | (Inherited from HistoryStepBase.)
Public field | FontHeight | (Inherited from HistoryStepBase.)
Public field | Location | (Inherited from HistoryStepBase.)
Public field | Optimization |
Public field | SelectedTermsIndexes |
Public field | ShowDescription |
Public field | Terms |
Public field | TextColor | (Inherited from HistoryStepBase.)
Top
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.CurrentTermIndexes Field

HistoryStepEvaluableCurrentTermIndexes Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int[] CurrentTermIndexes
Public CurrentTermIndexes As Integer()
public:
array<int>^ CurrentTermIndexes
val mutable CurrentTermIndexes: int[]

Field Value

Type: Int32
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.DescriptionLocation Field

HistoryStepEvaluableDescriptionLocation Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ElementPosition DescriptionLocation
Public DescriptionLocation As ElementPosition
public:
ElementPosition DescriptionLocation
val mutable DescriptionLocation: ElementPosition

Field Value

Type: ElementPosition
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.Evaluable Field

HistoryStepEvaluableEvaluable Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Evaluable
Public Evaluable As Boolean
public:
bool Evaluable
val mutable Evaluable: bool

Field Value

Type: Boolean
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.Optimization Field

HistoryStepEvaluableOptimization Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OptimizationType Optimization
Public Optimization As OptimizationType
public:
OptimizationType Optimization
val mutable Optimization: OptimizationType

Field Value

Type: OptimizationType
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.SelectedTermsIndexes Field

HistoryStepEvaluableSelectedTermsIndexes Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int[] SelectedTermsIndexes
Public SelectedTermsIndexes As Integer()
public:
array<int>^ SelectedTermsIndexes
val mutable SelectedTermsIndexes: int[]

Field Value

Type: Int32
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.ShowDescription Field

HistoryStepEvaluableShowDescription Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowDescription
Public ShowDescription As Boolean
public:
bool ShowDescription
val mutable ShowDescription: bool

Field Value

Type: Boolean
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


HistoryStepEvaluable.Terms Field

HistoryStepEvaluableTerms Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] Terms
Public Terms As Term()
public:
array<Term^>^ Terms
val mutable Terms: Term[]

Field Value

Type: Term
See Also

Reference

HistoryStepEvaluable Class
SMath.Controls Namespace


IAutoComplete Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IAutoComplete
Public Interface IAutoComplete
public interface class IAutoComplete
type IAutoComplete =  interface end

The IAutoComplete type exposes the following members.

Methods
 | Name | Description
Public method | AttachEvent |
Public method | DetachEvent |
Public method | HandleInput |
Public method | HandleWheel |
Public method | Hide |
Public method | ScrollChanged |
Public method | ShowIfNeed(Term) |
Public method | ShowIfNeed(RegionBase, Boolean) |
Top
See Also

Reference

SMath.Controls Namespace


IAutoComplete Methods

The IAutoComplete type exposes the following members.

Methods
 | Name | Description
Public method | AttachEvent |
Public method | DetachEvent |
Public method | HandleInput |
Public method | HandleWheel |
Public method | Hide |
Public method | ScrollChanged |
Public method | ShowIfNeed(Term) |
Public method | ShowIfNeed(RegionBase, Boolean) |
Top
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.AttachEvent Method

IAutoCompleteAttachEvent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void AttachEvent(
    RegionBase region
)
Sub AttachEvent (
    region As RegionBase
)
void AttachEvent(
    RegionBase^ region
)
abstract AttachEvent :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.DetachEvent Method

IAutoCompleteDetachEvent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DetachEvent(
    RegionBase region
)
Sub DetachEvent (
    region As RegionBase
)
void DetachEvent(
    RegionBase^ region
)
abstract DetachEvent :
        region : RegionBase -> unit

Parameters

region
Type: SMath.ControlsRegionBase
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.HandleInput Method

IAutoCompleteHandleInput Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool HandleInput(
    string value
)
Function HandleInput (
    value As String
) As Boolean
bool HandleInput(
    String^ value
)
abstract HandleInput :
        value : string -> bool

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.HandleWheel Method

IAutoCompleteHandleWheel Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool HandleWheel(
    int wheelDelta
)
Function HandleWheel (
    wheelDelta As Integer
) As Boolean
bool HandleWheel(
    int wheelDelta
)
abstract HandleWheel :
        wheelDelta : int -> bool

Parameters

wheelDelta
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.Hide Method

IAutoCompleteHide Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Hide()
Sub Hide
void Hide()
abstract Hide : unit -> unit
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.ScrollChanged Method

IAutoCompleteScrollChanged Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ScrollChanged(
    int horizontalOffset,
    int verticalOffset
)
Sub ScrollChanged (
    horizontalOffset As Integer,
    verticalOffset As Integer
)
void ScrollChanged(
    int horizontalOffset,
    int verticalOffset
)
abstract ScrollChanged :
        horizontalOffset : int *
        verticalOffset : int -> unit

Parameters

horizontalOffset
Type: SystemInt32
verticalOffset
Type: SystemInt32
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.ShowIfNeed Method

IAutoCompleteShowIfNeed Method

Overload List
 | Name | Description
Public method | ShowIfNeed(Term) |
Public method | ShowIfNeed(RegionBase, Boolean) |
Top
See Also

Reference

IAutoComplete Interface
SMath.Controls Namespace


IAutoComplete.ShowIfNeed Method (Term)

IAutoCompleteShowIfNeed Method (Term)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ShowIfNeed(
    Term term
)
Sub ShowIfNeed (
    term As Term
)
void ShowIfNeed(
    Term^ term
)
abstract ShowIfNeed :
        term : Term -> unit

Parameters

term
Type: SMath.ManagerTerm
See Also

Reference

IAutoComplete Interface
ShowIfNeed Overload
SMath.Controls Namespace


IAutoComplete.ShowIfNeed Method (RegionBase, Boolean)

IAutoCompleteShowIfNeed Method (RegionBase, Boolean)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ShowIfNeed(
    RegionBase region,
    bool mainRegion
)
Sub ShowIfNeed (
    region As RegionBase,
    mainRegion As Boolean
)
void ShowIfNeed(
    RegionBase^ region,
    bool mainRegion
)
abstract ShowIfNeed :
        region : RegionBase *
        mainRegion : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
mainRegion
Type: SystemBoolean
See Also

Reference

IAutoComplete Interface
ShowIfNeed Overload
SMath.Controls Namespace


IClipboardManager Interface

Clipboard manager to work within Worksheet.Менеджер буфера обмена для использования на листе расчёта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IClipboardManager
Public Interface IClipboardManager
public interface class IClipboardManager
type IClipboardManager =  interface end

The IClipboardManager type exposes the following members.

Properties
 | Name | Description
Public property | ContainsAny | Checks if clipboard contains data in any supported format.
Top
Methods
 | Name | Description
Public method | Contains | Checks if clipboard contains data in specified format.
Public method | GetData | Retrieves data from clipboard in specified format.
Public method | GetRegions | Retrieves Worksheet Regions from clipboard and put it on specified position.
Public method | SetData(Object, String) | Stores data of specified format in clipboard.
Public method | SetData(Object, String) | Stores data of specified formats in clipboard.
Public method | SetRegions | Stores Worksheet Regions in clipboard.
Top
See Also

Reference

SMath.Controls Namespace


IClipboardManager Properties

The IClipboardManager type exposes the following members.

Properties
 | Name | Description
Public property | ContainsAny | Checks if clipboard contains data in any supported format.
Top
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.ContainsAny Property

IClipboardManagerContainsAny Property

Checks if clipboard contains data in any supported format.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool ContainsAny { get; }
ReadOnly Property ContainsAny As Boolean
    Get
property bool ContainsAny {
    bool get ();
}
abstract ContainsAny : bool with get

Property Value

Type: Boolean
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager Methods

The IClipboardManager type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Checks if clipboard contains data in specified format.
Public method | GetData | Retrieves data from clipboard in specified format.
Public method | GetRegions | Retrieves Worksheet Regions from clipboard and put it on specified position.
Public method | SetData(Object, String) | Stores data of specified format in clipboard.
Public method | SetData(Object, String) | Stores data of specified formats in clipboard.
Public method | SetRegions | Stores Worksheet Regions in clipboard.
Top
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.Contains Method

IClipboardManagerContains Method

Checks if clipboard contains data in specified format.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    params string[] formats
)
Function Contains (
    ParamArray formats As String()
) As Boolean
bool Contains(
    ... array<String^>^ formats
)
abstract Contains :
        formats : string[] -> bool

Parameters

formats
Type: SystemString
Clipboard data format.

Return Value

Type: Boolean
Returns true if clipboard contains data in requested format.
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.GetData Method

IClipboardManagerGetData Method

Retrieves data from clipboard in specified format.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Object GetData(
    string format
)
Function GetData (
    format As String
) As Object
Object^ GetData(
    String^ format
)
abstract GetData :
        format : string -> Object

Parameters

format
Type: SystemString
Clipboard data format.

Return Value

Type: Object
Returns data of requested format from clipboard.
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.GetRegions Method

IClipboardManagerGetRegions Method

Retrieves Worksheet Regions from clipboard and put it on specified position.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void GetRegions(
    Worksheet worksheet
)
Sub GetRegions (
    worksheet As Worksheet
)
void GetRegions(
    Worksheet^ worksheet
)
abstract GetRegions :
        worksheet : Worksheet -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet
Worksheet to put Regions on.
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.SetData Method

IClipboardManagerSetData Method

Overload List
 | Name | Description
Public method | SetData(Object, String) | Stores data of specified format in clipboard.
Public method | SetData(Object, String) | Stores data of specified formats in clipboard.
Top
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IClipboardManager.SetData Method (Object, String)

IClipboardManagerSetData Method (Object, String)

Stores data of specified format in clipboard.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SetData(
    Object obj,
    string format
)
Sub SetData (
    obj As Object,
    format As String
)
void SetData(
    Object^ obj,
    String^ format
)
abstract SetData :
        obj : Object *
        format : string -> unit

Parameters

obj
Type: SystemObject
Value to store in clipboard.
format
Type: SystemString
Clipboard data format.
See Also

Reference

IClipboardManager Interface
SetData Overload
SMath.Controls Namespace


IClipboardManager.SetData Method (Object[], String[])

IClipboardManagerSetData Method (Object, String)

Stores data of specified formats in clipboard.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SetData(
    Object[] obj,
    string[] format
)
Sub SetData (
    obj As Object(),
    format As String()
)
void SetData(
    array<Object^>^ obj,
    array<String^>^ format
)
abstract SetData :
        obj : Object[] *
        format : string[] -> unit

Parameters

obj
Type: SystemObject
Values to store in clipboard.
format
Type: SystemString
Clipboard data formats.
See Also

Reference

IClipboardManager Interface
SetData Overload
SMath.Controls Namespace


IClipboardManager.SetRegions Method

IClipboardManagerSetRegions Method

Stores Worksheet Regions in clipboard.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SetRegions(
    Worksheet worksheet
)
Sub SetRegions (
    worksheet As Worksheet
)
void SetRegions(
    Worksheet^ worksheet
)
abstract SetRegions :
        worksheet : Worksheet -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet
Worksheet to handle Regions from.
See Also

Reference

IClipboardManager Interface
SMath.Controls Namespace


IDocument(T) Interface

IDocumentT Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IDocument<T>
where T : IDocumentObject

Public Interface IDocument(Of T As IDocumentObject)
generic<typename T>
where T : IDocumentObject
public interface class IDocument
type IDocument<'T when 'T : IDocumentObject> =  interface end

Type Parameters

T

The IDocumentT type exposes the following members.

Properties
 | Name | Description
Public property | ContentSize |
Public property | DrawGrid |
Public property | Focused |
Public property | MetaContext |
Public property | Mode |
Public property | MultiplePages |
Public property | ObjectsManager |
Public property | PageModel |
Public property | PagesOptions |
Public property | Pointer |
Public property | ScrollSize |
Public property | SessionProfile |
Public property | Size |
Public property | Status |
Top
Methods
 | Name | Description
Public method | HideError |
Public method | Invalidate |
Public method | RefreshUI |
Public method | UpdateScrollBars |
Top
See Also

Reference

SMath.Controls Namespace


IDocument(T) Properties

IDocumentT Properties

The IDocumentT generic type exposes the following members.

Properties
 | Name | Description
Public property | ContentSize |
Public property | DrawGrid |
Public property | Focused |
Public property | MetaContext |
Public property | Mode |
Public property | MultiplePages |
Public property | ObjectsManager |
Public property | PageModel |
Public property | PagesOptions |
Public property | Pointer |
Public property | ScrollSize |
Public property | SessionProfile |
Public property | Size |
Public property | Status |
Top
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).ContentSize Property

IDocumentTContentSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Size ContentSize { get; set; }
Property ContentSize As Size
    Get
    Set
property Size ContentSize {
    Size get ();
    void set (Size value);
}
abstract ContentSize : Size with get, set

Property Value

Type: Size
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).DrawGrid Property

IDocumentTDrawGrid Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool DrawGrid { get; }
ReadOnly Property DrawGrid As Boolean
    Get
property bool DrawGrid {
    bool get ();
}
abstract DrawGrid : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Focused Property

IDocumentTFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Focused { get; }
ReadOnly Property Focused As Boolean
    Get
property bool Focused {
    bool get ();
}
abstract Focused : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).MetaContext Property

IDocumentTMetaContext Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
MetaContext MetaContext { get; }
ReadOnly Property MetaContext As MetaContext
    Get
property MetaContext^ MetaContext {
    MetaContext^ get ();
}
abstract MetaContext : MetaContext with get

Property Value

Type: MetaContext
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Mode Property

IDocumentTMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
PresentationMode Mode { get; }
ReadOnly Property Mode As PresentationMode
    Get
property PresentationMode Mode {
    PresentationMode get ();
}
abstract Mode : PresentationMode with get

Property Value

Type: PresentationMode
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).MultiplePages Property

IDocumentTMultiplePages Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool MultiplePages { get; }
ReadOnly Property MultiplePages As Boolean
    Get
property bool MultiplePages {
    bool get ();
}
abstract MultiplePages : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).ObjectsManager Property

IDocumentTObjectsManager Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IObjectsManager<T> ObjectsManager { get; }
ReadOnly Property ObjectsManager As IObjectsManager(Of T)
    Get
property IObjectsManager<T>^ ObjectsManager {
    IObjectsManager<T>^ get ();
}
abstract ObjectsManager : IObjectsManager<'T> with get

Property Value

Type: IObjectsManager T
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).PageModel Property

IDocumentTPageModel Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
PageModel PageModel { get; }
ReadOnly Property PageModel As PageModel
    Get
property PageModel^ PageModel {
    PageModel^ get ();
}
abstract PageModel : PageModel with get

Property Value

Type: PageModel
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).PagesOptions Property

IDocumentTPagesOptions Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
PagesOptions PagesOptions { get; }
ReadOnly Property PagesOptions As PagesOptions
    Get
property PagesOptions^ PagesOptions {
    PagesOptions^ get ();
}
abstract PagesOptions : PagesOptions with get

Property Value

Type: PagesOptions
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Pointer Property

IDocumentTPointer Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DocumentPointer Pointer { get; }
ReadOnly Property Pointer As DocumentPointer
    Get
property DocumentPointer^ Pointer {
    DocumentPointer^ get ();
}
abstract Pointer : DocumentPointer with get

Property Value

Type: DocumentPointer
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).ScrollSize Property

IDocumentTScrollSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Size ScrollSize { get; set; }
Property ScrollSize As Size
    Get
    Set
property Size ScrollSize {
    Size get ();
    void set (Size value);
}
abstract ScrollSize : Size with get, set

Property Value

Type: Size
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).SessionProfile Property

IDocumentTSessionProfile Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
SessionProfile SessionProfile { get; }
ReadOnly Property SessionProfile As SessionProfile
    Get
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
}
abstract SessionProfile : SessionProfile with get

Property Value

Type: SessionProfile
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Size Property

IDocumentTSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Size Size { get; }
ReadOnly Property Size As Size
    Get
property Size Size {
    Size get ();
}
abstract Size : Size with get

Property Value

Type: Size
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Status Property

IDocumentTStatus Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DocumentStatus Status { get; }
ReadOnly Property Status As DocumentStatus
    Get
property DocumentStatus Status {
    DocumentStatus get ();
}
abstract Status : DocumentStatus with get

Property Value

Type: DocumentStatus
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T) Methods

IDocumentT Methods

The IDocumentT generic type exposes the following members.

Methods
 | Name | Description
Public method | HideError |
Public method | Invalidate |
Public method | RefreshUI |
Public method | UpdateScrollBars |
Top
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).HideError Method

IDocumentTHideError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void HideError()
Sub HideError
void HideError()
abstract HideError : unit -> unit
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).Invalidate Method

IDocumentTInvalidate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Invalidate()
Sub Invalidate
void Invalidate()
abstract Invalidate : unit -> unit
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).RefreshUI Method

IDocumentTRefreshUI Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void RefreshUI()
Sub RefreshUI
void RefreshUI()
abstract RefreshUI : unit -> unit
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocument(T).UpdateScrollBars Method

IDocumentTUpdateScrollBars Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void UpdateScrollBars()
Sub UpdateScrollBars
void UpdateScrollBars()
abstract UpdateScrollBars : unit -> unit
See Also

Reference

IDocumentT Interface
SMath.Controls Namespace


IDocumentObject Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IDocumentObject
Public Interface IDocumentObject
public interface class IDocumentObject
type IDocumentObject =  interface end

The IDocumentObject type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight |
Public property | CurrentMetaContext |
Public property | CurrentPageOffsets |
Public property | Focused |
Public property | IsActivated |
Public property | Location |
Public property | Selected |
Public property | Size |
Top
Methods
 | Name | Description
Public method | Draw |
Top
See Also

Reference

SMath.Controls Namespace


IDocumentObject Properties

The IDocumentObject type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight |
Public property | CurrentMetaContext |
Public property | CurrentPageOffsets |
Public property | Focused |
Public property | IsActivated |
Public property | Location |
Public property | Selected |
Public property | Size |
Top
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.CurrentCollapsedHeight Property

IDocumentObjectCurrentCollapsedHeight Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int CurrentCollapsedHeight { get; set; }
Property CurrentCollapsedHeight As Integer
    Get
    Set
property int CurrentCollapsedHeight {
    int get ();
    void set (int value);
}
abstract CurrentCollapsedHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.CurrentMetaContext Property

IDocumentObjectCurrentMetaContext Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ContextVariables CurrentMetaContext { get; set; }
Property CurrentMetaContext As ContextVariables
    Get
    Set
property ContextVariables^ CurrentMetaContext {
    ContextVariables^ get ();
    void set (ContextVariables^ value);
}
abstract CurrentMetaContext : ContextVariables with get, set

Property Value

Type: ContextVariables
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.CurrentPageOffsets Property

IDocumentObjectCurrentPageOffsets Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ParallelList<Point> CurrentPageOffsets { get; set; }
Property CurrentPageOffsets As ParallelList(Of Point)
    Get
    Set
property ParallelList<Point>^ CurrentPageOffsets {
    ParallelList<Point>^ get ();
    void set (ParallelList<Point>^ value);
}
abstract CurrentPageOffsets : ParallelList<Point> with get, set

Property Value

Type: ParallelList Point
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.Focused Property

IDocumentObjectFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Focused { get; }
ReadOnly Property Focused As Boolean
    Get
property bool Focused {
    bool get ();
}
abstract Focused : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.IsActivated Property

IDocumentObjectIsActivated Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsActivated { get; }
ReadOnly Property IsActivated As Boolean
    Get
property bool IsActivated {
    bool get ();
}
abstract IsActivated : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.Location Property

IDocumentObjectLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Point Location { get; set; }
Property Location As Point
    Get
    Set
property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set

Property Value

Type: Point
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.Selected Property

IDocumentObjectSelected Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Selected { get; }
ReadOnly Property Selected As Boolean
    Get
property bool Selected {
    bool get ();
}
abstract Selected : bool with get

Property Value

Type: Boolean
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.Size Property

IDocumentObjectSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Size Size { get; set; }
Property Size As Size
    Get
    Set
property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set

Property Value

Type: Size
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject Methods

The IDocumentObject type exposes the following members.

Methods
 | Name | Description
Public method | Draw |
Top
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IDocumentObject.Draw Method

IDocumentObjectDraw Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Draw(
    PaintEventOptions args,
    PageModel pageModel,
    bool exportMode
)
Sub Draw (
    args As PaintEventOptions,
    pageModel As PageModel,
    exportMode As Boolean
)
void Draw(
    PaintEventOptions^ args,
    PageModel^ pageModel,
    bool exportMode
)
abstract Draw :
        args : PaintEventOptions *
        pageModel : PageModel *
        exportMode : bool -> unit

Parameters

args
Type: SMath.ManagerPaintEventOptions
pageModel
Type: SMath.ManagerPageModel
exportMode
Type: SystemBoolean
See Also

Reference

IDocumentObject Interface
SMath.Controls Namespace


IEvaluable Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IEvaluable
Public Interface IEvaluable
public interface class IEvaluable
type IEvaluable =  interface end

The IEvaluable type exposes the following members.

Properties
 | Name | Description
Public property | Evaluable |
Top
See Also

Reference

SMath.Controls Namespace


IEvaluable Properties

The IEvaluable type exposes the following members.

Properties
 | Name | Description
Public property | Evaluable |
Top
See Also

Reference

IEvaluable Interface
SMath.Controls Namespace


IEvaluable.Evaluable Property

IEvaluableEvaluable Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Evaluable { get; set; }
Property Evaluable As Boolean
    Get
    Set
property bool Evaluable {
    bool get ();
    void set (bool value);
}
abstract Evaluable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEvaluable Interface
SMath.Controls Namespace


IEvaluableObject Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IEvaluableObject : IDocumentObject,
    IEvaluable
Public Interface IEvaluableObject
    Inherits IDocumentObject, IEvaluable
public interface class IEvaluableObject : IDocumentObject,
    IEvaluable
type IEvaluableObject =
    interface
        interface IDocumentObject
        interface IEvaluable
    end

The IEvaluableObject type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | Location | (Inherited from IDocumentObject.)
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Size | (Inherited from IDocumentObject.)
Top
Methods
 | Name | Description
Public method | Draw | (Inherited from IDocumentObject.)
Top
See Also

Reference

SMath.Controls Namespace


IEvaluableObject Properties

The IEvaluableObject type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | Location | (Inherited from IDocumentObject.)
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Size | (Inherited from IDocumentObject.)
Top
See Also

Reference

IEvaluableObject Interface
SMath.Controls Namespace


IEvaluableObject Methods

The IEvaluableObject type exposes the following members.

Methods
 | Name | Description
Public method | Draw | (Inherited from IDocumentObject.)
Top
See Also

Reference

IEvaluableObject Interface
SMath.Controls Namespace


IInteractiveScrollbar Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IInteractiveScrollbar
Public Interface IInteractiveScrollbar
public interface class IInteractiveScrollbar
type IInteractiveScrollbar =  interface end

The IInteractiveScrollbar type exposes the following members.

Properties
 | Name | Description
Public property | MaximumEx |
Public property | ValueEx |
Top
See Also

Reference

SMath.Controls Namespace


IInteractiveScrollbar Properties

The IInteractiveScrollbar type exposes the following members.

Properties
 | Name | Description
Public property | MaximumEx |
Public property | ValueEx |
Top
See Also

Reference

IInteractiveScrollbar Interface
SMath.Controls Namespace


IInteractiveScrollbar.MaximumEx Property

IInteractiveScrollbarMaximumEx Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float MaximumEx { get; set; }
Property MaximumEx As Single
    Get
    Set
property float MaximumEx {
    float get ();
    void set (float value);
}
abstract MaximumEx : float32 with get, set

Property Value

Type: Single
See Also

Reference

IInteractiveScrollbar Interface
SMath.Controls Namespace


IInteractiveScrollbar.ValueEx Property

IInteractiveScrollbarValueEx Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float ValueEx { get; set; }
Property ValueEx As Single
    Get
    Set
property float ValueEx {
    float get ();
    void set (float value);
}
abstract ValueEx : float32 with get, set

Property Value

Type: Single
See Also

Reference

IInteractiveScrollbar Interface
SMath.Controls Namespace


InteractiveWorksheet Class

Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheet
SMath.ControlsInteractiveWorksheet

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class InteractiveWorksheet : Worksheet
Public Class InteractiveWorksheet
    Inherits Worksheet
public ref class InteractiveWorksheet : public Worksheet
type InteractiveWorksheet =
    class
        inherit Worksheet
    end

The InteractiveWorksheet type exposes the following members.

Constructors
 | Name | Description
Public method | InteractiveWorksheet(InteractiveWorksheet, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(InteractiveWorksheet, Single, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(SessionProfile, PresentationMode, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(SessionProfile, PresentationMode, Single, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Top
Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов. (Inherited from Worksheet.)
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена. (Inherited from Worksheet.)
Public property | ContentSize | (Inherited from Worksheet.)
Public property | CurrentColumnsCount | (Inherited from Worksheet.)
Public property | CurrentContentPlacement | (Inherited from Worksheet.)
Public property | CurrentPage | (Inherited from Worksheet.)
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта. (Inherited from Worksheet.)
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка. (Inherited from Worksheet.)
Public property | Editor | (Inherited from Worksheet.)
Public property | ErrorSize |
Public property | Examples |
Public property | Focused | (Overrides WorksheetFocused.)
Public property | GridSize | (Inherited from Worksheet.)
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет. (Inherited from Worksheet.)
Public property | History | Worksheet changes history.История изменений листа расчётов. (Inherited from Worksheet.)
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода. (Inherited from Worksheet.)
Public property | InvokeRequired | (Inherited from Worksheet.)
Public property | IsDifferentInPlacement | (Inherited from Worksheet.)
Public property | IsInEvalution | Obsolete. (Inherited from Worksheet.)
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке. (Inherited from Worksheet.)
Public property | MetaContext | (Inherited from Worksheet.)
Public property | MetaData | Worksheet meta-data.Мета-данные листа. (Inherited from Worksheet.)
Public property | Mode | (Inherited from Worksheet.)
Public property | MultiplePages | (Inherited from Worksheet.)
Public property | ObjectsManager | (Inherited from Worksheet.)
Public property | PageIndex | (Inherited from Worksheet.)
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов. (Inherited from Worksheet.)
Public property | PagesCount | (Inherited from Worksheet.)
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта. (Inherited from Worksheet.)
Public property | Params | (Inherited from Worksheet.)
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте. (Inherited from Worksheet.)
Public property | ScrollSize | (Inherited from Worksheet.)
Public property | Search | (Inherited from Worksheet.)
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from Worksheet.)
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа. (Inherited from Worksheet.)
Public property | Status | Status of the worksheet.Статус листа расчётов. (Inherited from Worksheet.)
Top
Methods
 | Name | Description
Public method | AddBreakpoint | (Inherited from Worksheet.)
Public method | ApplyInitialDefinitions | (Inherited from Worksheet.)
Public method | Clear | (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт. (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete. (Inherited from Worksheet.)
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) | (Inherited from Worksheet.)
Public method | CreateStore | (Inherited from Worksheet.)
Public method | Dispose | (Inherited from Worksheet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | (Inherited from Worksheet.)
Public method | GetAboutText |
Public method | GetCollapsedHeight(Int32) | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(RegionsList, Int32) | (Inherited from Worksheet.)
Public method | GetCurrentStore | (Inherited from Worksheet.)
Public method | GetCurrentTooltip | (Inherited from Worksheet.)
Public method | GetCursorType | (Overrides WorksheetGetCursorType(MouseEventOptions).)
Public method | GetEvaluationContext | (Inherited from Worksheet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams | (Inherited from Worksheet.)
Public method | GetPreviouslyDefinedParamsAll | (Inherited from Worksheet.)
Public method | GetRegionIndex | (Inherited from Worksheet.)
Public method | GetRegionsBounds | Calculates bounds of the selected Regions. (Inherited from Worksheet.)
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа. (Inherited from Worksheet.)
Public method | GetScreenPoint |
Public method | GetStaticContextMenuItems | (Inherited from Worksheet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionsList, Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GotFocus | (Inherited from Worksheet.)
Public method | HandleButtonCommand |
Public method | HideCursorIfRequired | (Inherited from Worksheet.)
Public method | HideError | (Overrides WorksheetHideError.)
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов. (Inherited from Worksheet.)
Public method | Insert(ButtonAction) | (Inherited from Worksheet.)
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region. (Inherited from Worksheet.)
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Public method | Invoke | (Inherited from Worksheet.)
Public method | LayoutChanged |
Public method | LayoutChanged(Int32, Int32) |
Public method | LockRegion | (Inherited from Worksheet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown(MouseEventOptions) | Mouse button down event handler.Реакция на событие нажатия клавиши мыши. (Inherited from Worksheet.)
Public method | MouseDown(MouseInputButtons, Single, Single, Int32) |
Protected method | MouseMove(MouseEventOptions) | Mouse cursor move event handler.Реакция на событие движения курсора мыши. (Inherited from Worksheet.)
Public method | MouseMove(Single, Single, Int32) |
Protected method | MouseUp(MouseEventOptions) | Mouse button up event handler.Реакция на событие отпускания клавиши мыши. (Inherited from Worksheet.)
Public method | MouseUp(MouseInputButtons, Single, Single, Int32) |
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши. (Inherited from Worksheet.)
Public method | MoveEx |
Public method | OpenFile(String, SizeF) |
Public method | OpenFile(Stream, String, SizeF) |
Protected method | PageStatusManager | (Inherited from Worksheet.)
Public method | RefreshContent | (Inherited from Worksheet.)
Public method | RefreshUI | (Inherited from Worksheet.)
Public method | RemoveRegions(RegionBase) | (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа. (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) | (Inherited from Worksheet.)
Public method | Renew |
Public method | ResetPosition |
Protected method | Resize | Изменение размеров элемента. (Inherited from Worksheet.)
Public method | ResumeLayout | (Inherited from Worksheet.)
Public method | Scroll | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required. (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region. (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, RectangleF) | (Inherited from Worksheet.)
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента. (Inherited from Worksheet.)
Public method | SetDebuggerMode | (Inherited from Worksheet.)
Public method | SetRegionBorder | (Inherited from Worksheet.)
Public method | SetRegionColor | (Inherited from Worksheet.)
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings. (Inherited from Worksheet.)
Public method | SetRegionFontFamily | (Inherited from Worksheet.)
Public method | SetRegionFontSize | (Inherited from Worksheet.)
Public method | ShowCursorIfRequired | (Inherited from Worksheet.)
Public method | ShowError | (Overrides WorksheetShowError(RegionEvaluable, Boolean).)
Protected method | SnapToGrid | (Inherited from Worksheet.)
Public method | SortRegions | (Inherited from Worksheet.)
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа. (Inherited from Worksheet.)
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время. (Inherited from Worksheet.)
Public method | SuppressLayout | (Inherited from Worksheet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов. (Inherited from Worksheet.)
Public method | UnfocusRegions | (Inherited from Worksheet.)
Public method | UnlockRegion | (Inherited from Worksheet.)
Public method | UpdatePageModel | (Inherited from Worksheet.)
Public method | UpdateScrollBars | (Inherited from Worksheet.)
Public method | VerifyLanguageNotifier | (Inherited from Worksheet.)
Public method | Zoom |
Top
Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad | (Inherited from Worksheet.)
Public event | OnCurrentRegionChanged | (Inherited from Worksheet.)
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки. (Inherited from Worksheet.)
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки. (Inherited from Worksheet.)
Public event | OnFileContextLoad | (Inherited from Worksheet.)
Public event | OnMenuButtonEmulated | (Inherited from Worksheet.)
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля. (Inherited from Worksheet.)
Public event | OnProgressChanged | (Inherited from Worksheet.)
Public event | OnRegionCreated | (Inherited from Worksheet.)
Public event | OnStatusChanged | (Inherited from Worksheet.)
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа. (Inherited from Worksheet.)
Top
Fields
 | Name | Description
Public field | drawer |
Protected field | ErrorLocation |
Protected field | ErrorText |
Public field | HasClipData |
Public field | OnInvalidateRectRequested |
Public field | OnInvalidateRequested |
Top
See Also

Reference

SMath.Controls Namespace


InteractiveWorksheet Constructor

Overload List
 | Name | Description
Public method | InteractiveWorksheet(InteractiveWorksheet, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(InteractiveWorksheet, Single, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(SessionProfile, PresentationMode, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Public method | InteractiveWorksheet(SessionProfile, PresentationMode, Single, Boolean, Boolean) | Initializes a new instance of the InteractiveWorksheet class
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet Constructor (InteractiveWorksheet, Boolean, Boolean)

Initializes a new instance of the InteractiveWorksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InteractiveWorksheet(
    InteractiveWorksheet worksheet,
    bool overlayOnTop,
    bool touchControlsVisible
)
Public Sub New (
    worksheet As InteractiveWorksheet,
    overlayOnTop As Boolean,
    touchControlsVisible As Boolean
)
public:
InteractiveWorksheet(
    InteractiveWorksheet^ worksheet,
    bool overlayOnTop,
    bool touchControlsVisible
)
new :
        worksheet : InteractiveWorksheet *
        overlayOnTop : bool *
        touchControlsVisible : bool -> InteractiveWorksheet

Parameters

worksheet
Type: SMath.ControlsInteractiveWorksheet
overlayOnTop
Type: SystemBoolean
touchControlsVisible
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
InteractiveWorksheet Overload
SMath.Controls Namespace


InteractiveWorksheet Constructor (InteractiveWorksheet, Single, Boolean, Boolean)

Initializes a new instance of the InteractiveWorksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InteractiveWorksheet(
    InteractiveWorksheet worksheet,
    float initialScale,
    bool overlayOnTop,
    bool touchControlsVisible
)
Public Sub New (
    worksheet As InteractiveWorksheet,
    initialScale As Single,
    overlayOnTop As Boolean,
    touchControlsVisible As Boolean
)
public:
InteractiveWorksheet(
    InteractiveWorksheet^ worksheet,
    float initialScale,
    bool overlayOnTop,
    bool touchControlsVisible
)
new :
        worksheet : InteractiveWorksheet *
        initialScale : float32 *
        overlayOnTop : bool *
        touchControlsVisible : bool -> InteractiveWorksheet

Parameters

worksheet
Type: SMath.ControlsInteractiveWorksheet
initialScale
Type: SystemSingle
overlayOnTop
Type: SystemBoolean
touchControlsVisible
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
InteractiveWorksheet Overload
SMath.Controls Namespace


InteractiveWorksheet Constructor (SessionProfile, PresentationMode, Boolean, Boolean)

Initializes a new instance of the InteractiveWorksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InteractiveWorksheet(
    SessionProfile sessionProfile,
    PresentationMode mode,
    bool overlayOnTop,
    bool touchControlsVisible
)
Public Sub New (
    sessionProfile As SessionProfile,
    mode As PresentationMode,
    overlayOnTop As Boolean,
    touchControlsVisible As Boolean
)
public:
InteractiveWorksheet(
    SessionProfile^ sessionProfile,
    PresentationMode mode,
    bool overlayOnTop,
    bool touchControlsVisible
)
new :
        sessionProfile : SessionProfile *
        mode : PresentationMode *
        overlayOnTop : bool *
        touchControlsVisible : bool -> InteractiveWorksheet

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
mode
Type: SMath.ControlsPresentationMode
overlayOnTop
Type: SystemBoolean
touchControlsVisible
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
InteractiveWorksheet Overload
SMath.Controls Namespace


InteractiveWorksheet Constructor (SessionProfile, PresentationMode, Single, Boolean, Boolean)

Initializes a new instance of the InteractiveWorksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InteractiveWorksheet(
    SessionProfile sessionProfile,
    PresentationMode mode,
    float initialScale,
    bool overlayOnTop,
    bool touchControlsVisible
)
Public Sub New (
    sessionProfile As SessionProfile,
    mode As PresentationMode,
    initialScale As Single,
    overlayOnTop As Boolean,
    touchControlsVisible As Boolean
)
public:
InteractiveWorksheet(
    SessionProfile^ sessionProfile,
    PresentationMode mode,
    float initialScale,
    bool overlayOnTop,
    bool touchControlsVisible
)
new :
        sessionProfile : SessionProfile *
        mode : PresentationMode *
        initialScale : float32 *
        overlayOnTop : bool *
        touchControlsVisible : bool -> InteractiveWorksheet

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
mode
Type: SMath.ControlsPresentationMode
initialScale
Type: SystemSingle
overlayOnTop
Type: SystemBoolean
touchControlsVisible
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
InteractiveWorksheet Overload
SMath.Controls Namespace


InteractiveWorksheet Properties

The InteractiveWorksheet type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов. (Inherited from Worksheet.)
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена. (Inherited from Worksheet.)
Public property | ContentSize | (Inherited from Worksheet.)
Public property | CurrentColumnsCount | (Inherited from Worksheet.)
Public property | CurrentContentPlacement | (Inherited from Worksheet.)
Public property | CurrentPage | (Inherited from Worksheet.)
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта. (Inherited from Worksheet.)
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка. (Inherited from Worksheet.)
Public property | Editor | (Inherited from Worksheet.)
Public property | ErrorSize |
Public property | Examples |
Public property | Focused | (Overrides WorksheetFocused.)
Public property | GridSize | (Inherited from Worksheet.)
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет. (Inherited from Worksheet.)
Public property | History | Worksheet changes history.История изменений листа расчётов. (Inherited from Worksheet.)
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода. (Inherited from Worksheet.)
Public property | InvokeRequired | (Inherited from Worksheet.)
Public property | IsDifferentInPlacement | (Inherited from Worksheet.)
Public property | IsInEvalution | Obsolete. (Inherited from Worksheet.)
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке. (Inherited from Worksheet.)
Public property | MetaContext | (Inherited from Worksheet.)
Public property | MetaData | Worksheet meta-data.Мета-данные листа. (Inherited from Worksheet.)
Public property | Mode | (Inherited from Worksheet.)
Public property | MultiplePages | (Inherited from Worksheet.)
Public property | ObjectsManager | (Inherited from Worksheet.)
Public property | PageIndex | (Inherited from Worksheet.)
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов. (Inherited from Worksheet.)
Public property | PagesCount | (Inherited from Worksheet.)
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта. (Inherited from Worksheet.)
Public property | Params | (Inherited from Worksheet.)
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте. (Inherited from Worksheet.)
Public property | ScrollSize | (Inherited from Worksheet.)
Public property | Search | (Inherited from Worksheet.)
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from Worksheet.)
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа. (Inherited from Worksheet.)
Public property | Status | Status of the worksheet.Статус листа расчётов. (Inherited from Worksheet.)
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.ErrorSize Property

InteractiveWorksheetErrorSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Size ErrorSize { get; }
Public Overridable ReadOnly Property ErrorSize As Size
    Get
public:
virtual property Size ErrorSize {
    Size get ();
}
abstract ErrorSize : Size with get
override ErrorSize : Size with get

Property Value

Type: Size
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.Examples Property

InteractiveWorksheetExamples Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<DataFile> Examples { get; }
Public ReadOnly Property Examples As List(Of DataFile)
    Get
public:
property List<DataFile^>^ Examples {
    List<DataFile^>^ get ();
}
member Examples : List<DataFile> with get

Property Value

Type: ListDataFile
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.Focused Property

InteractiveWorksheetFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Focused { get; }
Public Overrides ReadOnly Property Focused As Boolean
    Get
public:
virtual property bool Focused {
    bool get () override;
}
abstract Focused : bool with get
override Focused : bool with get

Property Value

Type: Boolean

Implements

IDocumentTFocused
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet Methods

The InteractiveWorksheet type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | (Inherited from Worksheet.)
Public method | ApplyInitialDefinitions | (Inherited from Worksheet.)
Public method | Clear | (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт. (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete. (Inherited from Worksheet.)
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) | (Inherited from Worksheet.)
Public method | CreateStore | (Inherited from Worksheet.)
Public method | Dispose | (Inherited from Worksheet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | (Inherited from Worksheet.)
Public method | GetAboutText |
Public method | GetCollapsedHeight(Int32) | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(RegionsList, Int32) | (Inherited from Worksheet.)
Public method | GetCurrentStore | (Inherited from Worksheet.)
Public method | GetCurrentTooltip | (Inherited from Worksheet.)
Public method | GetCursorType | (Overrides WorksheetGetCursorType(MouseEventOptions).)
Public method | GetEvaluationContext | (Inherited from Worksheet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams | (Inherited from Worksheet.)
Public method | GetPreviouslyDefinedParamsAll | (Inherited from Worksheet.)
Public method | GetRegionIndex | (Inherited from Worksheet.)
Public method | GetRegionsBounds | Calculates bounds of the selected Regions. (Inherited from Worksheet.)
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа. (Inherited from Worksheet.)
Public method | GetScreenPoint |
Public method | GetStaticContextMenuItems | (Inherited from Worksheet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionsList, Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GotFocus | (Inherited from Worksheet.)
Public method | HandleButtonCommand |
Public method | HideCursorIfRequired | (Inherited from Worksheet.)
Public method | HideError | (Overrides WorksheetHideError.)
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов. (Inherited from Worksheet.)
Public method | Insert(ButtonAction) | (Inherited from Worksheet.)
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region. (Inherited from Worksheet.)
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Public method | Invoke | (Inherited from Worksheet.)
Public method | LayoutChanged |
Public method | LayoutChanged(Int32, Int32) |
Public method | LockRegion | (Inherited from Worksheet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown(MouseEventOptions) | Mouse button down event handler.Реакция на событие нажатия клавиши мыши. (Inherited from Worksheet.)
Public method | MouseDown(MouseInputButtons, Single, Single, Int32) |
Protected method | MouseMove(MouseEventOptions) | Mouse cursor move event handler.Реакция на событие движения курсора мыши. (Inherited from Worksheet.)
Public method | MouseMove(Single, Single, Int32) |
Protected method | MouseUp(MouseEventOptions) | Mouse button up event handler.Реакция на событие отпускания клавиши мыши. (Inherited from Worksheet.)
Public method | MouseUp(MouseInputButtons, Single, Single, Int32) |
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши. (Inherited from Worksheet.)
Public method | MoveEx |
Public method | OpenFile(String, SizeF) |
Public method | OpenFile(Stream, String, SizeF) |
Protected method | PageStatusManager | (Inherited from Worksheet.)
Public method | RefreshContent | (Inherited from Worksheet.)
Public method | RefreshUI | (Inherited from Worksheet.)
Public method | RemoveRegions(RegionBase) | (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа. (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) | (Inherited from Worksheet.)
Public method | Renew |
Public method | ResetPosition |
Protected method | Resize | Изменение размеров элемента. (Inherited from Worksheet.)
Public method | ResumeLayout | (Inherited from Worksheet.)
Public method | Scroll | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required. (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region. (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, RectangleF) | (Inherited from Worksheet.)
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента. (Inherited from Worksheet.)
Public method | SetDebuggerMode | (Inherited from Worksheet.)
Public method | SetRegionBorder | (Inherited from Worksheet.)
Public method | SetRegionColor | (Inherited from Worksheet.)
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings. (Inherited from Worksheet.)
Public method | SetRegionFontFamily | (Inherited from Worksheet.)
Public method | SetRegionFontSize | (Inherited from Worksheet.)
Public method | ShowCursorIfRequired | (Inherited from Worksheet.)
Public method | ShowError | (Overrides WorksheetShowError(RegionEvaluable, Boolean).)
Protected method | SnapToGrid | (Inherited from Worksheet.)
Public method | SortRegions | (Inherited from Worksheet.)
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа. (Inherited from Worksheet.)
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время. (Inherited from Worksheet.)
Public method | SuppressLayout | (Inherited from Worksheet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов. (Inherited from Worksheet.)
Public method | UnfocusRegions | (Inherited from Worksheet.)
Public method | UnlockRegion | (Inherited from Worksheet.)
Public method | UpdatePageModel | (Inherited from Worksheet.)
Public method | UpdateScrollBars | (Inherited from Worksheet.)
Public method | VerifyLanguageNotifier | (Inherited from Worksheet.)
Public method | Zoom |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.GetAboutText Method

InteractiveWorksheetGetAboutText Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetAboutText(
    string version
)
Public Function GetAboutText (
    version As String
) As String
public:
String^ GetAboutText(
    String^ version
)
member GetAboutText :
        version : string -> string

Parameters

version
Type: SystemString

Return Value

Type: String
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.GetCursorType Method

InteractiveWorksheetGetCursorType Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override CursorStatus GetCursorType(
    MouseEventOptions e
)
Public Overrides Function GetCursorType (
    e As MouseEventOptions
) As CursorStatus
public:
virtual CursorStatus^ GetCursorType(
    MouseEventOptions^ e
) override
abstract GetCursorType :
        e : MouseEventOptions -> CursorStatus
override GetCursorType :
        e : MouseEventOptions -> CursorStatus

Parameters

e
Type: SMath.ManagerMouseEventOptions

Return Value

Type: CursorStatus
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.GetScreenPoint Method

InteractiveWorksheetGetScreenPoint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point GetScreenPoint(
    RegionBase sender,
    int left,
    int top
)
Public Function GetScreenPoint (
    sender As RegionBase,
    left As Integer,
    top As Integer
) As Point
public:
Point GetScreenPoint(
    RegionBase^ sender,
    int left,
    int top
)
member GetScreenPoint :
        sender : RegionBase *
        left : int *
        top : int -> Point

Parameters

sender
Type: SMath.ControlsRegionBase
left
Type: SystemInt32
top
Type: SystemInt32

Return Value

Type: Point
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.HandleButtonCommand Method

InteractiveWorksheetHandleButtonCommand Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemInfo[] HandleButtonCommand(
    string text
)
Public Function HandleButtonCommand (
    text As String
) As ToolboxItemInfo()
public:
array<ToolboxItemInfo^>^ HandleButtonCommand(
    String^ text
)
member HandleButtonCommand :
        text : string -> ToolboxItemInfo[]

Parameters

text
Type: SystemString

Return Value

Type: ToolboxItemInfo
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.HideError Method

InteractiveWorksheetHideError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void HideError()
Public Overrides Sub HideError
public:
virtual void HideError() override
abstract HideError : unit -> unit
override HideError : unit -> unit

Implements

IDocumentTHideError
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.Invalidate Method

InteractiveWorksheetInvalidate Method

Overload List
 | Name | Description
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.Invalidate Method

InteractiveWorksheetInvalidate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Invalidate()
Public Overrides Sub Invalidate
public:
virtual void Invalidate() override
abstract Invalidate : unit -> unit
override Invalidate : unit -> unit

Implements

IDocumentTInvalidate
See Also

Reference

InteractiveWorksheet Class
Invalidate Overload
SMath.Controls Namespace


InteractiveWorksheet.Invalidate Method (Rectangle)

InteractiveWorksheetInvalidate Method (Rectangle)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Invalidate(
    Rectangle rect
)
Public Overrides Sub Invalidate (
    rect As Rectangle
)
public:
virtual void Invalidate(
    Rectangle rect
) override
abstract Invalidate :
        rect : Rectangle -> unit
override Invalidate :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
See Also

Reference

InteractiveWorksheet Class
Invalidate Overload
SMath.Controls Namespace


InteractiveWorksheet.LayoutChanged Method

InteractiveWorksheetLayoutChanged Method

Overload List
 | Name | Description
Public method | LayoutChanged |
Public method | LayoutChanged(Int32, Int32) |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.LayoutChanged Method

InteractiveWorksheetLayoutChanged Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LayoutChanged()
Public Sub LayoutChanged
public:
void LayoutChanged()
member LayoutChanged : unit -> unit
See Also

Reference

InteractiveWorksheet Class
LayoutChanged Overload
SMath.Controls Namespace


InteractiveWorksheet.LayoutChanged Method (Int32, Int32)

InteractiveWorksheetLayoutChanged Method (Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LayoutChanged(
    int width,
    int height
)
Public Sub LayoutChanged (
    width As Integer,
    height As Integer
)
public:
void LayoutChanged(
    int width,
    int height
)
member LayoutChanged :
        width : int *
        height : int -> unit

Parameters

width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

InteractiveWorksheet Class
LayoutChanged Overload
SMath.Controls Namespace


InteractiveWorksheet.MouseDown Method

InteractiveWorksheetMouseDown Method

Overload List
 | Name | Description
Protected method | MouseDown(MouseEventOptions) | Mouse button down event handler.Реакция на событие нажатия клавиши мыши. (Inherited from Worksheet.)
Public method | MouseDown(MouseInputButtons, Single, Single, Int32) |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.MouseDown Method (MouseInputButtons, Single, Single, Int32)

InteractiveWorksheetMouseDown Method (MouseInputButtons, Single, Single, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MouseDown(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
Public Sub MouseDown (
    buttons As MouseInputButtons,
    x As Single,
    y As Single,
    count As Integer
)
public:
void MouseDown(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
member MouseDown :
        buttons : MouseInputButtons *
        x : float32 *
        y : float32 *
        count : int -> unit

Parameters

buttons
Type: SMath.ManagerMouseInputButtons
x
Type: SystemSingle
y
Type: SystemSingle
count
Type: SystemInt32
See Also

Reference

InteractiveWorksheet Class
MouseDown Overload
SMath.Controls Namespace


InteractiveWorksheet.MouseMove Method

InteractiveWorksheetMouseMove Method

Overload List
 | Name | Description
Protected method | MouseMove(MouseEventOptions) | Mouse cursor move event handler.Реакция на событие движения курсора мыши. (Inherited from Worksheet.)
Public method | MouseMove(Single, Single, Int32) |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.MouseMove Method (Single, Single, Int32)

InteractiveWorksheetMouseMove Method (Single, Single, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MouseMove(
    float x,
    float y,
    int count
)
Public Sub MouseMove (
    x As Single,
    y As Single,
    count As Integer
)
public:
void MouseMove(
    float x,
    float y,
    int count
)
member MouseMove :
        x : float32 *
        y : float32 *
        count : int -> unit

Parameters

x
Type: SystemSingle
y
Type: SystemSingle
count
Type: SystemInt32
See Also

Reference

InteractiveWorksheet Class
MouseMove Overload
SMath.Controls Namespace


InteractiveWorksheet.MouseUp Method

InteractiveWorksheetMouseUp Method

Overload List
 | Name | Description
Protected method | MouseUp(MouseEventOptions) | Mouse button up event handler.Реакция на событие отпускания клавиши мыши. (Inherited from Worksheet.)
Public method | MouseUp(MouseInputButtons, Single, Single, Int32) |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.MouseUp Method (MouseInputButtons, Single, Single, Int32)

InteractiveWorksheetMouseUp Method (MouseInputButtons, Single, Single, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MouseUp(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
Public Sub MouseUp (
    buttons As MouseInputButtons,
    x As Single,
    y As Single,
    count As Integer
)
public:
void MouseUp(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
member MouseUp :
        buttons : MouseInputButtons *
        x : float32 *
        y : float32 *
        count : int -> unit

Parameters

buttons
Type: SMath.ManagerMouseInputButtons
x
Type: SystemSingle
y
Type: SystemSingle
count
Type: SystemInt32
See Also

Reference

InteractiveWorksheet Class
MouseUp Overload
SMath.Controls Namespace


InteractiveWorksheet.MoveEx Method

InteractiveWorksheetMoveEx Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TouchSelectionType MoveEx(
    PointF pnt,
    float distanceX,
    float distanceY
)
Public Function MoveEx (
    pnt As PointF,
    distanceX As Single,
    distanceY As Single
) As TouchSelectionType
public:
TouchSelectionType MoveEx(
    PointF pnt,
    float distanceX,
    float distanceY
)
member MoveEx :
        pnt : PointF *
        distanceX : float32 *
        distanceY : float32 -> TouchSelectionType

Parameters

pnt
Type: System.DrawingPointF
distanceX
Type: SystemSingle
distanceY
Type: SystemSingle

Return Value

Type: TouchSelectionType
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.OpenFile Method

InteractiveWorksheetOpenFile Method

Overload List
 | Name | Description
Public method | OpenFile(String, SizeF) |
Public method | OpenFile(Stream, String, SizeF) |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.OpenFile Method (String, SizeF)

InteractiveWorksheetOpenFile Method (String, SizeF)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void OpenFile(
    string fileName,
    SizeF canvasSize
)
Public Sub OpenFile (
    fileName As String,
    canvasSize As SizeF
)
public:
void OpenFile(
    String^ fileName,
    SizeF canvasSize
)
member OpenFile :
        fileName : string *
        canvasSize : SizeF -> unit

Parameters

fileName
Type: SystemString
canvasSize
Type: System.DrawingSizeF
See Also

Reference

InteractiveWorksheet Class
OpenFile Overload
SMath.Controls Namespace


InteractiveWorksheet.OpenFile Method (Stream, String, SizeF)

InteractiveWorksheetOpenFile Method (Stream, String, SizeF)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void OpenFile(
    Stream stream,
    string fileName,
    SizeF canvasSize
)
Public Sub OpenFile (
    stream As Stream,
    fileName As String,
    canvasSize As SizeF
)
public:
void OpenFile(
    Stream^ stream,
    String^ fileName,
    SizeF canvasSize
)
member OpenFile :
        stream : Stream *
        fileName : string *
        canvasSize : SizeF -> unit

Parameters

stream
Type: System.IOStream
fileName
Type: SystemString
canvasSize
Type: System.DrawingSizeF
See Also

Reference

InteractiveWorksheet Class
OpenFile Overload
SMath.Controls Namespace


InteractiveWorksheet.Renew Method

InteractiveWorksheetRenew Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Renew()
Public Function Renew As Boolean
public:
bool Renew()
member Renew : unit -> bool

Return Value

Type: Boolean
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.ResetPosition Method

InteractiveWorksheetResetPosition Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ResetPosition(
    int width,
    int height
)
Public Sub ResetPosition (
    width As Integer,
    height As Integer
)
public:
void ResetPosition(
    int width,
    int height
)
member ResetPosition :
        width : int *
        height : int -> unit

Parameters

width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.ShowError Method

InteractiveWorksheetShowError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void ShowError(
    RegionEvaluable region,
    bool v
)
Public Overrides Sub ShowError (
    region As RegionEvaluable,
    v As Boolean
)
public:
virtual void ShowError(
    RegionEvaluable^ region,
    bool v
) override
abstract ShowError :
        region : RegionEvaluable *
        v : bool -> unit
override ShowError :
        region : RegionEvaluable *
        v : bool -> unit

Parameters

region
Type: SMath.ControlsRegionEvaluable
v
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.Zoom Method

InteractiveWorksheetZoom Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Zoom(
    float scaleFactor,
    float focusX,
    float focusY,
    SizeF size,
    bool doubleTap
)
Public Sub Zoom (
    scaleFactor As Single,
    focusX As Single,
    focusY As Single,
    size As SizeF,
    doubleTap As Boolean
)
public:
void Zoom(
    float scaleFactor,
    float focusX,
    float focusY,
    SizeF size,
    bool doubleTap
)
member Zoom :
        scaleFactor : float32 *
        focusX : float32 *
        focusY : float32 *
        size : SizeF *
        doubleTap : bool -> unit

Parameters

scaleFactor
Type: SystemSingle
focusX
Type: SystemSingle
focusY
Type: SystemSingle
size
Type: System.DrawingSizeF
doubleTap
Type: SystemBoolean
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet Events

The InteractiveWorksheet type exposes the following members.

Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad | (Inherited from Worksheet.)
Public event | OnCurrentRegionChanged | (Inherited from Worksheet.)
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки. (Inherited from Worksheet.)
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки. (Inherited from Worksheet.)
Public event | OnFileContextLoad | (Inherited from Worksheet.)
Public event | OnMenuButtonEmulated | (Inherited from Worksheet.)
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля. (Inherited from Worksheet.)
Public event | OnProgressChanged | (Inherited from Worksheet.)
Public event | OnRegionCreated | (Inherited from Worksheet.)
Public event | OnStatusChanged | (Inherited from Worksheet.)
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа. (Inherited from Worksheet.)
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet Fields

The InteractiveWorksheet type exposes the following members.

Fields
 | Name | Description
Public field | drawer |
Protected field | ErrorLocation |
Protected field | ErrorText |
Public field | HasClipData |
Public field | OnInvalidateRectRequested |
Public field | OnInvalidateRequested |
Top
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.drawer Field

InteractiveWorksheetdrawer Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentScaler<RegionBase> drawer
Public drawer As DocumentScaler(Of RegionBase)
public:
DocumentScaler<RegionBase^>^ drawer
val mutable drawer: DocumentScaler<RegionBase>

Field Value

Type: DocumentScaler RegionBase
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.ErrorLocation Field

InteractiveWorksheetErrorLocation Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Point ErrorLocation
Protected ErrorLocation As Point
protected:
Point ErrorLocation
val mutable ErrorLocation: Point

Field Value

Type: Point
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.ErrorText Field

InteractiveWorksheetErrorText Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected string ErrorText
Protected ErrorText As String
protected:
String^ ErrorText
val mutable ErrorText: string

Field Value

Type: String
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.HasClipData Field

InteractiveWorksheetHasClipData Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasClipData
Public HasClipData As Boolean
public:
bool HasClipData
val mutable HasClipData: bool

Field Value

Type: Boolean
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.OnInvalidateRectRequested Field

InteractiveWorksheetOnInvalidateRectRequested Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InvalidateRectRequestedDelegate OnInvalidateRectRequested
Public OnInvalidateRectRequested As InvalidateRectRequestedDelegate
public:
InvalidateRectRequestedDelegate^ OnInvalidateRectRequested
val mutable OnInvalidateRectRequested: InvalidateRectRequestedDelegate

Field Value

Type: InvalidateRectRequestedDelegate
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InteractiveWorksheet.OnInvalidateRequested Field

InteractiveWorksheetOnInvalidateRequested Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InvalidateRequestedDelegate OnInvalidateRequested
Public OnInvalidateRequested As InvalidateRequestedDelegate
public:
InvalidateRequestedDelegate^ OnInvalidateRequested
val mutable OnInvalidateRequested: InvalidateRequestedDelegate

Field Value

Type: InvalidateRequestedDelegate
See Also

Reference

InteractiveWorksheet Class
SMath.Controls Namespace


InvalidateRectRequestedDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void InvalidateRectRequestedDelegate(
    Rectangle rect
)
Public Delegate Sub InvalidateRectRequestedDelegate (
    rect As Rectangle
)
public delegate void InvalidateRectRequestedDelegate(
    Rectangle rect
)
type InvalidateRectRequestedDelegate =
    delegate of
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
See Also

Reference

SMath.Controls Namespace


InvalidateRequestedDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void InvalidateRequestedDelegate()
Public Delegate Sub InvalidateRequestedDelegate
public delegate void InvalidateRequestedDelegate()
type InvalidateRequestedDelegate =
    delegate of unit -> unit
See Also

Reference

SMath.Controls Namespace


IOActionCompletedEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void IOActionCompletedEventHandler(
    Worksheet sheet,
    bool success
)
Public Delegate Sub IOActionCompletedEventHandler (
    sheet As Worksheet,
    success As Boolean
)
public delegate void IOActionCompletedEventHandler(
    Worksheet^ sheet,
    bool success
)
type IOActionCompletedEventHandler =
    delegate of
        sheet : Worksheet *
        success : bool -> unit

Parameters

sheet
Type: SMath.ControlsWorksheet
success
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


IObjectsManager(T) Interface

IObjectsManagerT Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IObjectsManager<T>
where T : IDocumentObject

Public Interface IObjectsManager(Of T As IDocumentObject)
generic<typename T>
where T : IDocumentObject
public interface class IObjectsManager
type IObjectsManager<'T when 'T : IDocumentObject> =  interface end

Type Parameters

T

The IObjectsManagerT type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу.
Public property | HasHeaderFooter | Determines if Header/Footer specified directly on the Document.Определяет заданы ли колонтитулы прямо на страницах документа или нет.
Public property | PagesCount |
Top
Methods
 | Name | Description
Public method | IsChanged |
Public method | TryGetEnumerator |
Top
See Also

Reference

SMath.Controls Namespace


IObjectsManager(T) Properties

IObjectsManagerT Properties

The IObjectsManagerT generic type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу.
Public property | HasHeaderFooter | Determines if Header/Footer specified directly on the Document.Определяет заданы ли колонтитулы прямо на страницах документа или нет.
Public property | PagesCount |
Top
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).ColumnsCount Property

IObjectsManagerTColumnsCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int ColumnsCount { get; set; }
Property ColumnsCount As Integer
    Get
    Set
property int ColumnsCount {
    int get ();
    void set (int value);
}
abstract ColumnsCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).CurrentContentPlacement Property

IObjectsManagerTCurrentContentPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ContentPlacement CurrentContentPlacement { get; set; }
Property CurrentContentPlacement As ContentPlacement
    Get
    Set
property ContentPlacement CurrentContentPlacement {
    ContentPlacement get ();
    void set (ContentPlacement value);
}
abstract CurrentContentPlacement : ContentPlacement with get, set

Property Value

Type: ContentPlacement
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).CurrentPage Property

IObjectsManagerTCurrentPage Property

Gets the current page.Возвращает текущую страницу.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DocumentPage CurrentPage { get; set; }
Property CurrentPage As DocumentPage
    Get
    Set
property DocumentPage^ CurrentPage {
    DocumentPage^ get ();
    void set (DocumentPage^ value);
}
abstract CurrentPage : DocumentPage with get, set

Property Value

Type: DocumentPage
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).HasHeaderFooter Property

IObjectsManagerTHasHeaderFooter Property

Determines if Header/Footer specified directly on the Document.Определяет заданы ли колонтитулы прямо на страницах документа или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool HasHeaderFooter { get; }
ReadOnly Property HasHeaderFooter As Boolean
    Get
property bool HasHeaderFooter {
    bool get ();
}
abstract HasHeaderFooter : bool with get

Property Value

Type: Boolean
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).PagesCount Property

IObjectsManagerTPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int PagesCount { get; set; }
Property PagesCount As Integer
    Get
    Set
property int PagesCount {
    int get ();
    void set (int value);
}
abstract PagesCount : int with get, set

Property Value

Type: Int32
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T) Methods

IObjectsManagerT Methods

The IObjectsManagerT generic type exposes the following members.

Methods
 | Name | Description
Public method | IsChanged |
Public method | TryGetEnumerator |
Top
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).IsChanged Method

IObjectsManagerTIsChanged Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsChanged(
    int pagesCount,
    int fullHeight,
    int hiddenHeight
)
Function IsChanged (
    pagesCount As Integer,
    fullHeight As Integer,
    hiddenHeight As Integer
) As Boolean
bool IsChanged(
    int pagesCount,
    int fullHeight,
    int hiddenHeight
)
abstract IsChanged :
        pagesCount : int *
        fullHeight : int *
        hiddenHeight : int -> bool

Parameters

pagesCount
Type: SystemInt32
fullHeight
Type: SystemInt32
hiddenHeight
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IObjectsManager(T).TryGetEnumerator Method

IObjectsManagerTTryGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    out ObjectsEnumerator<T> objects
)
Function TryGetEnumerator (
    placement As ContentPlacement,
    pageIndex As Integer,
    <OutAttribute> ByRef objects As ObjectsEnumerator(Of T)
) As Boolean
bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    [OutAttribute] ObjectsEnumerator<T>^% objects
)
abstract TryGetEnumerator :
        placement : ContentPlacement *
        pageIndex : int *
        objects : ObjectsEnumerator<'T> byref -> bool

Parameters

placement
Type: SMath.ManagerContentPlacement
pageIndex
Type: SystemInt32
objects
Type: SMath.ControlsObjectsEnumerator T

Return Value

Type: Boolean
See Also

Reference

IObjectsManagerT Interface
SMath.Controls Namespace


IPluginCustomRegion Interface

Allow to add a new Region to the program by plug-in.Позволяет добавить пользовательский элемент листа к программе через плагин.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginCustomRegion : IPlugin,
    IDisposable
Public Interface IPluginCustomRegion
    Inherits IPlugin, IDisposable
public interface class IPluginCustomRegion : IPlugin,
    IDisposable
type IPluginCustomRegion =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginCustomRegion type exposes the following members.

Properties
 | Name | Description
Public property | DragAndDropFileTypes | List of file types Region can handle on drag'n'drop.Список типов файлов, которые могут быть обработаны элементом листа при операциях drag'n'drop.
Public property | RegionType | Region type supported by the plug-in.Тип элемента листа, поддерживаемый дополнением.
Public property | SupportedClipboardFormats | Determines list of clipboard data types can be handled by Region.Определяет список поддерживаемых типов данных для работы через буфера обмена.
Public property | TagName | Name of the XML tag to represent Region on serialize/deserialize operations.Имя XML тега для использования при операциях сериализации/десериализации.
Top
Methods
 | Name | Description
Public method | CreateNew | Creates a new instance of the Region.Создаёт новый экземпляр элемента листа.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetContextMenuItems | Returns context menu items for currently chosen Region(s).Возвращает элементы контекстного меню для выбранных элементов листа.
Public method | GetMenuItems | Gets a set of menu buttons to act with a Region.Определяет набор кнопок меню для работы с элементом листа.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Controls Namespace


IPluginCustomRegion Properties

The IPluginCustomRegion type exposes the following members.

Properties
 | Name | Description
Public property | DragAndDropFileTypes | List of file types Region can handle on drag'n'drop.Список типов файлов, которые могут быть обработаны элементом листа при операциях drag'n'drop.
Public property | RegionType | Region type supported by the plug-in.Тип элемента листа, поддерживаемый дополнением.
Public property | SupportedClipboardFormats | Determines list of clipboard data types can be handled by Region.Определяет список поддерживаемых типов данных для работы через буфера обмена.
Public property | TagName | Name of the XML tag to represent Region on serialize/deserialize operations.Имя XML тега для использования при операциях сериализации/десериализации.
Top
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.DragAndDropFileTypes Property

IPluginCustomRegionDragAndDropFileTypes Property

List of file types Region can handle on drag'n'drop.Список типов файлов, которые могут быть обработаны элементом листа при операциях drag'n'drop.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DragAndDropFileType[] DragAndDropFileTypes { get; }
ReadOnly Property DragAndDropFileTypes As DragAndDropFileType()
    Get
property array<DragAndDropFileType^>^ DragAndDropFileTypes {
    array<DragAndDropFileType^>^ get ();
}
abstract DragAndDropFileTypes : DragAndDropFileType[] with get

Property Value

Type: DragAndDropFileType
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.RegionType Property

IPluginCustomRegionRegionType Property

Region type supported by the plug-in.Тип элемента листа, поддерживаемый дополнением.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Type RegionType { get; }
ReadOnly Property RegionType As Type
    Get
property Type^ RegionType {
    Type^ get ();
}
abstract RegionType : Type with get

Property Value

Type: Type
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.SupportedClipboardFormats Property

IPluginCustomRegionSupportedClipboardFormats Property

Determines list of clipboard data types can be handled by Region.Определяет список поддерживаемых типов данных для работы через буфера обмена.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string[] SupportedClipboardFormats { get; }
ReadOnly Property SupportedClipboardFormats As String()
    Get
property array<String^>^ SupportedClipboardFormats {
    array<String^>^ get ();
}
abstract SupportedClipboardFormats : string[] with get

Property Value

Type: String
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.TagName Property

IPluginCustomRegionTagName Property

Name of the XML tag to represent Region on serialize/deserialize operations.Имя XML тега для использования при операциях сериализации/десериализации.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string TagName { get; }
ReadOnly Property TagName As String
    Get
property String^ TagName {
    String^ get ();
}
abstract TagName : string with get

Property Value

Type: String
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion Methods

The IPluginCustomRegion type exposes the following members.

Methods
 | Name | Description
Public method | CreateNew | Creates a new instance of the Region.Создаёт новый экземпляр элемента листа.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetContextMenuItems | Returns context menu items for currently chosen Region(s).Возвращает элементы контекстного меню для выбранных элементов листа.
Public method | GetMenuItems | Gets a set of menu buttons to act with a Region.Определяет набор кнопок меню для работы с элементом листа.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.CreateNew Method

IPluginCustomRegionCreateNew Method

Creates a new instance of the Region.Создаёт новый экземпляр элемента листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RegionBase CreateNew(
    SessionProfile sessionProfile
)
Function CreateNew (
    sessionProfile As SessionProfile
) As RegionBase
RegionBase^ CreateNew(
    SessionProfile^ sessionProfile
)
abstract CreateNew :
        sessionProfile : SessionProfile -> RegionBase

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: RegionBase
Returns an instance of the Region.Возвращает экземпляр элемента листа.
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.GetContextMenuItems Method

IPluginCustomRegionGetContextMenuItems Method

Returns context menu items for currently chosen Region(s).Возвращает элементы контекстного меню для выбранных элементов листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
MenuButton[] GetContextMenuItems(
    MenuContext context
)
Function GetContextMenuItems (
    context As MenuContext
) As MenuButton()
array<MenuButton^>^ GetContextMenuItems(
    MenuContext^ context
)
abstract GetContextMenuItems :
        context : MenuContext -> MenuButton[]

Parameters

context
Type: SMath.ControlsMenuContext
operation context.Контекст операции.

Return Value

Type: MenuButton
Returns context menu items.Возвращает элементы контекстного меню.
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginCustomRegion.GetMenuItems Method

IPluginCustomRegionGetMenuItems Method

Gets a set of menu buttons to act with a Region.Определяет набор кнопок меню для работы с элементом листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
MenuButton[] GetMenuItems(
    SessionProfile sessionProfile
)
Function GetMenuItems (
    sessionProfile As SessionProfile
) As MenuButton()
array<MenuButton^>^ GetMenuItems(
    SessionProfile^ sessionProfile
)
abstract GetMenuItems :
        sessionProfile : SessionProfile -> MenuButton[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: MenuButton
See Also

Reference

IPluginCustomRegion Interface
SMath.Controls Namespace


IPluginDataInputOutput Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginDataInputOutput : IPlugin,
    IDisposable
Public Interface IPluginDataInputOutput
    Inherits IPlugin, IDisposable
public interface class IPluginDataInputOutput : IPlugin,
    IDisposable
type IPluginDataInputOutput =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginDataInputOutput type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | OpenInitialData |
Public method | SaveResultData |
Top
See Also

Reference

SMath.Controls Namespace


IPluginDataInputOutput Methods

The IPluginDataInputOutput type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | OpenInitialData |
Public method | SaveResultData |
Top
See Also

Reference

IPluginDataInputOutput Interface
SMath.Controls Namespace


IPluginDataInputOutput.OpenInitialData Method

IPluginDataInputOutputOpenInitialData Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void OpenInitialData(
    Stream stream,
    List<Definition> defs,
    Store context
)
Sub OpenInitialData (
    stream As Stream,
    defs As List(Of Definition),
    context As Store
)
void OpenInitialData(
    Stream^ stream,
    List<Definition^>^ defs,
    Store^ context
)
abstract OpenInitialData :
        stream : Stream *
        defs : List<Definition> *
        context : Store -> unit

Parameters

stream
Type: System.IOStream
defs
Type: System.Collections.GenericListDefinition
context
Type: SMath.MathStore
See Also

Reference

IPluginDataInputOutput Interface
SMath.Controls Namespace


IPluginDataInputOutput.SaveResultData Method

IPluginDataInputOutputSaveResultData Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SaveResultData(
    Stream stream,
    ObjectsEnumerator<RegionBase> regions,
    FileContext context
)
Sub SaveResultData (
    stream As Stream,
    regions As ObjectsEnumerator(Of RegionBase),
    context As FileContext
)
void SaveResultData(
    Stream^ stream,
    ObjectsEnumerator<RegionBase^>^ regions,
    FileContext^ context
)
abstract SaveResultData :
        stream : Stream *
        regions : ObjectsEnumerator<RegionBase> *
        context : FileContext -> unit

Parameters

stream
Type: System.IOStream
regions
Type: SMath.ControlsObjectsEnumerator RegionBase
context
Type: SMath.ControlsFileContext
See Also

Reference

IPluginDataInputOutput Interface
SMath.Controls Namespace


IPluginHandleFileTypes Interface

Base File Types handler Interface for SMath Studio Plug-ins.Базовый интерфейс поддержки сторонних типов файлов в виде дополнений для SMath Studio.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginHandleFileTypes : IPlugin,
    IDisposable
Public Interface IPluginHandleFileTypes
    Inherits IPlugin, IDisposable
public interface class IPluginHandleFileTypes : IPlugin,
    IDisposable
type IPluginHandleFileTypes =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginHandleFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Controls Namespace


IPluginHandleFileTypes Properties

The IPluginHandleFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением.
Top
See Also

Reference

IPluginHandleFileTypes Interface
SMath.Controls Namespace


IPluginHandleFileTypes.FileTypesHandled Property

IPluginHandleFileTypesFileTypesHandled Property

Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
FileType[] FileTypesHandled { get; }
ReadOnly Property FileTypesHandled As FileType()
    Get
property array<FileType^>^ FileTypesHandled {
    array<FileType^>^ get ();
}
abstract FileTypesHandled : FileType[] with get

Property Value

Type: FileType
See Also

Reference

IPluginHandleFileTypes Interface
SMath.Controls Namespace


IPluginHandleFileTypes Methods

The IPluginHandleFileTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginHandleFileTypes Interface
SMath.Controls Namespace


IPluginMenuExtender Interface

Interface to extend menu-items.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginMenuExtender : IPlugin,
    IDisposable
Public Interface IPluginMenuExtender
    Inherits IPlugin, IDisposable
public interface class IPluginMenuExtender : IPlugin,
    IDisposable
type IPluginMenuExtender =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginMenuExtender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetMenuItem | Gets a menu button to act.Определяет кнопку меню для работы.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Controls Namespace


IPluginMenuExtender Methods

The IPluginMenuExtender type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetMenuItem | Gets a menu button to act.Определяет кнопку меню для работы.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginMenuExtender Interface
SMath.Controls Namespace


IPluginMenuExtender.GetMenuItem Method

IPluginMenuExtenderGetMenuItem Method

Gets a menu button to act.Определяет кнопку меню для работы.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
MenuButton[] GetMenuItem(
    SessionProfile sessionProfile
)
Function GetMenuItem (
    sessionProfile As SessionProfile
) As MenuButton()
array<MenuButton^>^ GetMenuItem(
    SessionProfile^ sessionProfile
)
abstract GetMenuItem :
        sessionProfile : SessionProfile -> MenuButton[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: MenuButton
See Also

Reference

IPluginMenuExtender Interface
SMath.Controls Namespace


IPluginOpenFileTypes Interface

Open File Types handler interface.Интерфейс для поддержки открытия типов файлов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginOpenFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
Public Interface IPluginOpenFileTypes
    Inherits IPluginHandleFileTypes, IPlugin, IDisposable
public interface class IPluginOpenFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
type IPluginOpenFileTypes =
    interface
        interface IPluginHandleFileTypes
        interface IPlugin
        interface IDisposable
    end

The IPluginOpenFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением. (Inherited from IPluginHandleFileTypes.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | OpenFileType | Requests to open file of specified type.Запрашивает открытие файла определённого типа.
Top
See Also

Reference

SMath.Controls Namespace


IPluginOpenFileTypes Properties

The IPluginOpenFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением. (Inherited from IPluginHandleFileTypes.)
Top
See Also

Reference

IPluginOpenFileTypes Interface
SMath.Controls Namespace


IPluginOpenFileTypes Methods

The IPluginOpenFileTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | OpenFileType | Requests to open file of specified type.Запрашивает открытие файла определённого типа.
Top
See Also

Reference

IPluginOpenFileTypes Interface
SMath.Controls Namespace


IPluginOpenFileTypes.OpenFileType Method

IPluginOpenFileTypesOpenFileType Method

Requests to open file of specified type.Запрашивает открытие файла определённого типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool OpenFileType(
    Stream stream,
    List<RegionsList> regionsLists,
    FileContext context
)
Function OpenFileType (
    stream As Stream,
    regionsLists As List(Of RegionsList),
    context As FileContext
) As Boolean
bool OpenFileType(
    Stream^ stream,
    List<RegionsList^>^ regionsLists,
    FileContext^ context
)
abstract OpenFileType :
        stream : Stream *
        regionsLists : List<RegionsList> *
        context : FileContext -> bool

Parameters

stream
Type: System.IOStream
File stream to read data from.Поток, из которого будет производится чтение.
regionsLists
Type: System.Collections.GenericListRegionsList
Lists of the Controls currently exists on the worksheet.Списки элементов, содержащихся на текущем листе расчётов.
context
Type: SMath.ControlsFileContext
Current file open context.Контекст текущей операции открытия файла.

Return Value

Type: Boolean
Returns condition of the file open operation.Возвращает статус проведения текущей операции по открытию файла.
See Also

Reference

IPluginOpenFileTypes Interface
SMath.Controls Namespace


IPluginSaveFileTypes Interface

Save File Types handler interface.Интерфейс для поддержки сохранения типов файлов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginSaveFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
Public Interface IPluginSaveFileTypes
    Inherits IPluginHandleFileTypes, IPlugin, IDisposable
public interface class IPluginSaveFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
type IPluginSaveFileTypes =
    interface
        interface IPluginHandleFileTypes
        interface IPlugin
        interface IDisposable
    end

The IPluginSaveFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением. (Inherited from IPluginHandleFileTypes.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | SaveFileType | Requests to save file of specified type.Запрашивает сохранение файла определённого типа.
Top
See Also

Reference

SMath.Controls Namespace


IPluginSaveFileTypes Properties

The IPluginSaveFileTypes type exposes the following members.

Properties
 | Name | Description
Public property | FileTypesHandled | Array of the file types, handled by Plug-in.Массив типов файлов, поддерживаемых дополнением. (Inherited from IPluginHandleFileTypes.)
Top
See Also

Reference

IPluginSaveFileTypes Interface
SMath.Controls Namespace


IPluginSaveFileTypes Methods

The IPluginSaveFileTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | SaveFileType | Requests to save file of specified type.Запрашивает сохранение файла определённого типа.
Top
See Also

Reference

IPluginSaveFileTypes Interface
SMath.Controls Namespace


IPluginSaveFileTypes.SaveFileType Method

IPluginSaveFileTypesSaveFileType Method

Requests to save file of specified type.Запрашивает сохранение файла определённого типа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool SaveFileType(
    Stream stream,
    RegionsManager manager,
    FileContext context
)
Function SaveFileType (
    stream As Stream,
    manager As RegionsManager,
    context As FileContext
) As Boolean
bool SaveFileType(
    Stream^ stream,
    RegionsManager^ manager,
    FileContext^ context
)
abstract SaveFileType :
        stream : Stream *
        manager : RegionsManager *
        context : FileContext -> bool

Parameters

stream
Type: System.IOStream
File stream to write data to.Поток, в который будет производится сохранение.
manager
Type: SMath.ControlsRegionsManager
Manager of the Controls currently exists on the worksheet.Менеджер элементов, содержащихся на текущем листе расчётов.
context
Type: SMath.ControlsFileContext
Current file save context.Контекст текущей операции сохранения файла.

Return Value

Type: Boolean
Returns condition of the file save operation.Возвращает статус проведения текущей операции по сохранению файла.
See Also

Reference

IPluginSaveFileTypes Interface
SMath.Controls Namespace


IRegionFormatable Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionFormatable
Public Interface IRegionFormatable
public interface class IRegionFormatable
type IRegionFormatable =  interface end

The IRegionFormatable type exposes the following members.

Properties
 | Name | Description
Public property | Bold |
Public property | FontName |
Public property | Italic |
Public property | Underline |
Top
See Also

Reference

SMath.Controls Namespace


IRegionFormatable Properties

The IRegionFormatable type exposes the following members.

Properties
 | Name | Description
Public property | Bold |
Public property | FontName |
Public property | Italic |
Public property | Underline |
Top
See Also

Reference

IRegionFormatable Interface
SMath.Controls Namespace


IRegionFormatable.Bold Property

IRegionFormatableBold Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Bold { get; set; }
Property Bold As Boolean
    Get
    Set
property bool Bold {
    bool get ();
    void set (bool value);
}
abstract Bold : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatable Interface
SMath.Controls Namespace


IRegionFormatable.FontName Property

IRegionFormatableFontName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string FontName { get; set; }
Property FontName As String
    Get
    Set
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
abstract FontName : string with get, set

Property Value

Type: String
See Also

Reference

IRegionFormatable Interface
SMath.Controls Namespace


IRegionFormatable.Italic Property

IRegionFormatableItalic Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Italic { get; set; }
Property Italic As Boolean
    Get
    Set
property bool Italic {
    bool get ();
    void set (bool value);
}
abstract Italic : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatable Interface
SMath.Controls Namespace


IRegionFormatable.Underline Property

IRegionFormatableUnderline Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Underline { get; set; }
Property Underline As Boolean
    Get
    Set
property bool Underline {
    bool get ();
    void set (bool value);
}
abstract Underline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatable Interface
SMath.Controls Namespace


IRegionFormatableExtended Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionFormatableExtended : IRegionFormatable
Public Interface IRegionFormatableExtended
    Inherits IRegionFormatable
public interface class IRegionFormatableExtended : IRegionFormatable
type IRegionFormatableExtended =
    interface
        interface IRegionFormatable
    end

The IRegionFormatableExtended type exposes the following members.

Properties
 | Name | Description
Public property | Bold | (Inherited from IRegionFormatable.)
Public property | FontName | (Inherited from IRegionFormatable.)
Public property | Italic | (Inherited from IRegionFormatable.)
Public property | LineHeight |
Public property | OrderedList |
Public property | PaddingLeft |
Public property | ShowAllCharacters |
Public property | TextAlignment |
Public property | TextIndent |
Public property | Underline | (Inherited from IRegionFormatable.)
Public property | UnorderedList |
Top
See Also

Reference

SMath.Controls Namespace


IRegionFormatableExtended Properties

The IRegionFormatableExtended type exposes the following members.

Properties
 | Name | Description
Public property | Bold | (Inherited from IRegionFormatable.)
Public property | FontName | (Inherited from IRegionFormatable.)
Public property | Italic | (Inherited from IRegionFormatable.)
Public property | LineHeight |
Public property | OrderedList |
Public property | PaddingLeft |
Public property | ShowAllCharacters |
Public property | TextAlignment |
Public property | TextIndent |
Public property | Underline | (Inherited from IRegionFormatable.)
Public property | UnorderedList |
Top
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.LineHeight Property

IRegionFormatableExtendedLineHeight Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float LineHeight { get; set; }
Property LineHeight As Single
    Get
    Set
property float LineHeight {
    float get ();
    void set (float value);
}
abstract LineHeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.OrderedList Property

IRegionFormatableExtendedOrderedList Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool OrderedList { get; set; }
Property OrderedList As Boolean
    Get
    Set
property bool OrderedList {
    bool get ();
    void set (bool value);
}
abstract OrderedList : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.PaddingLeft Property

IRegionFormatableExtendedPaddingLeft Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float PaddingLeft { get; set; }
Property PaddingLeft As Single
    Get
    Set
property float PaddingLeft {
    float get ();
    void set (float value);
}
abstract PaddingLeft : float32 with get, set

Property Value

Type: Single
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.ShowAllCharacters Property

IRegionFormatableExtendedShowAllCharacters Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool ShowAllCharacters { get; set; }
Property ShowAllCharacters As Boolean
    Get
    Set
property bool ShowAllCharacters {
    bool get ();
    void set (bool value);
}
abstract ShowAllCharacters : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.TextAlignment Property

IRegionFormatableExtendedTextAlignment Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
LineAlignment TextAlignment { get; set; }
Property TextAlignment As LineAlignment
    Get
    Set
property LineAlignment TextAlignment {
    LineAlignment get ();
    void set (LineAlignment value);
}
abstract TextAlignment : LineAlignment with get, set

Property Value

Type: LineAlignment
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.TextIndent Property

IRegionFormatableExtendedTextIndent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float TextIndent { get; set; }
Property TextIndent As Single
    Get
    Set
property float TextIndent {
    float get ();
    void set (float value);
}
abstract TextIndent : float32 with get, set

Property Value

Type: Single
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionFormatableExtended.UnorderedList Property

IRegionFormatableExtendedUnorderedList Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool UnorderedList { get; set; }
Property UnorderedList As Boolean
    Get
    Set
property bool UnorderedList {
    bool get ();
    void set (bool value);
}
abstract UnorderedList : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionFormatableExtended Interface
SMath.Controls Namespace


IRegionForViewer Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionForViewer
Public Interface IRegionForViewer
public interface class IRegionForViewer
type IRegionForViewer =  interface end

The IRegionForViewer type exposes the following members.

Methods
 | Name | Description
Public method | CreateControlContent |
Public method | UpdateLayout |
Top
See Also

Reference

SMath.Controls Namespace


IRegionForViewer Methods

The IRegionForViewer type exposes the following members.

Methods
 | Name | Description
Public method | CreateControlContent |
Public method | UpdateLayout |
Top
See Also

Reference

IRegionForViewer Interface
SMath.Controls Namespace


IRegionForViewer.CreateControlContent Method

IRegionForViewerCreateControlContent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool CreateControlContent(
    Control control,
    ref bool showOrdinal
)
Function CreateControlContent (
    control As Control,
    ByRef showOrdinal As Boolean
) As Boolean
bool CreateControlContent(
    Control^ control,
    bool% showOrdinal
)
abstract CreateControlContent :
        control : Control *
        showOrdinal : bool byref -> bool

Parameters

control
Type: System.Windows.FormsControl
showOrdinal
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

IRegionForViewer Interface
SMath.Controls Namespace


IRegionForViewer.UpdateLayout Method

IRegionForViewerUpdateLayout Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void UpdateLayout()
Sub UpdateLayout
void UpdateLayout()
abstract UpdateLayout : unit -> unit
See Also

Reference

IRegionForViewer Interface
SMath.Controls Namespace


IRegionsContainer Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionsContainer
Public Interface IRegionsContainer
public interface class IRegionsContainer
type IRegionsContainer =  interface end

The IRegionsContainer type exposes the following members.

Properties
 | Name | Description
Public property | PageBreaks |
Top
See Also

Reference

SMath.Controls Namespace


IRegionsContainer Properties

The IRegionsContainer type exposes the following members.

Properties
 | Name | Description
Public property | PageBreaks |
Top
See Also

Reference

IRegionsContainer Interface
SMath.Controls Namespace


IRegionsContainer.PageBreaks Property

IRegionsContainerPageBreaks Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ParallelList<int> PageBreaks { get; }
ReadOnly Property PageBreaks As ParallelList(Of Integer)
    Get
property ParallelList<int>^ PageBreaks {
    ParallelList<int>^ get ();
}
abstract PageBreaks : ParallelList<int> with get

Property Value

Type: ParallelList Int32
See Also

Reference

IRegionsContainer Interface
SMath.Controls Namespace


IRegionWithEditableText Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithEditableText
Public Interface IRegionWithEditableText
public interface class IRegionWithEditableText
type IRegionWithEditableText =  interface end

The IRegionWithEditableText type exposes the following members.

Properties
 | Name | Description
Public property | SerializedValue |
Top
Methods
 | Name | Description
Public method | SetPreviousChar |
Public method | TryGetPreviousChar |
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithEditableText Properties

The IRegionWithEditableText type exposes the following members.

Properties
 | Name | Description
Public property | SerializedValue |
Top
See Also

Reference

IRegionWithEditableText Interface
SMath.Controls Namespace


IRegionWithEditableText.SerializedValue Property

IRegionWithEditableTextSerializedValue Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string SerializedValue { get; set; }
Property SerializedValue As String
    Get
    Set
property String^ SerializedValue {
    String^ get ();
    void set (String^ value);
}
abstract SerializedValue : string with get, set

Property Value

Type: String
See Also

Reference

IRegionWithEditableText Interface
SMath.Controls Namespace


IRegionWithEditableText Methods

The IRegionWithEditableText type exposes the following members.

Methods
 | Name | Description
Public method | SetPreviousChar |
Public method | TryGetPreviousChar |
Top
See Also

Reference

IRegionWithEditableText Interface
SMath.Controls Namespace


IRegionWithEditableText.SetPreviousChar Method

IRegionWithEditableTextSetPreviousChar Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool SetPreviousChar(
    char letter
)
Function SetPreviousChar (
    letter As Char
) As Boolean
bool SetPreviousChar(
    wchar_t letter
)
abstract SetPreviousChar :
        letter : char -> bool

Parameters

letter
Type: SystemChar

Return Value

Type: Boolean
See Also

Reference

IRegionWithEditableText Interface
SMath.Controls Namespace


IRegionWithEditableText.TryGetPreviousChar Method

IRegionWithEditableTextTryGetPreviousChar Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TryGetPreviousChar(
    out char letter
)
Function TryGetPreviousChar (
    <OutAttribute> ByRef letter As Char
) As Boolean
bool TryGetPreviousChar(
    [OutAttribute] wchar_t% letter
)
abstract TryGetPreviousChar :
        letter : char byref -> bool

Parameters

letter
Type: SystemChar

Return Value

Type: Boolean
See Also

Reference

IRegionWithEditableText Interface
SMath.Controls Namespace


IRegionWithExtendedSearch Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithExtendedSearch
Public Interface IRegionWithExtendedSearch
public interface class IRegionWithExtendedSearch
type IRegionWithExtendedSearch =  interface end

The IRegionWithExtendedSearch type exposes the following members.

Properties
 | Name | Description
Public property | CursorPosition |
Top
Methods
 | Name | Description
Public method | TrySearch |
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithExtendedSearch Properties

The IRegionWithExtendedSearch type exposes the following members.

Properties
 | Name | Description
Public property | CursorPosition |
Top
See Also

Reference

IRegionWithExtendedSearch Interface
SMath.Controls Namespace


IRegionWithExtendedSearch.CursorPosition Property

IRegionWithExtendedSearchCursorPosition Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int CursorPosition { get; }
ReadOnly Property CursorPosition As Integer
    Get
property int CursorPosition {
    int get ();
}
abstract CursorPosition : int with get

Property Value

Type: Int32
See Also

Reference

IRegionWithExtendedSearch Interface
SMath.Controls Namespace


IRegionWithExtendedSearch Methods

The IRegionWithExtendedSearch type exposes the following members.

Methods
 | Name | Description
Public method | TrySearch |
Top
See Also

Reference

IRegionWithExtendedSearch Interface
SMath.Controls Namespace


IRegionWithExtendedSearch.TrySearch Method

IRegionWithExtendedSearchTrySearch Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TrySearch(
    string value,
    MatchingOptions options,
    out List<ExtendedSearchEntry> entries
)
Function TrySearch (
    value As String,
    options As MatchingOptions,
    <OutAttribute> ByRef entries As List(Of ExtendedSearchEntry)
) As Boolean
bool TrySearch(
    String^ value,
    MatchingOptions^ options,
    [OutAttribute] List<ExtendedSearchEntry>^% entries
)
abstract TrySearch :
        value : string *
        options : MatchingOptions *
        entries : List<ExtendedSearchEntry> byref -> bool

Parameters

value
Type: SystemString
options
Type: SMath.ControlsMatchingOptions
entries
Type: System.Collections.GenericListExtendedSearchEntry

Return Value

Type: Boolean
See Also

Reference

IRegionWithExtendedSearch Interface
SMath.Controls Namespace


IRegionWithInputData Interface

Extends Region with ability to show/hide input data.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithInputData
Public Interface IRegionWithInputData
public interface class IRegionWithInputData
type IRegionWithInputData =  interface end

The IRegionWithInputData type exposes the following members.

Properties
 | Name | Description
Public property | InputDataVisibility | Gets or sets status of the input data visibility.
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithInputData Properties

The IRegionWithInputData type exposes the following members.

Properties
 | Name | Description
Public property | InputDataVisibility | Gets or sets status of the input data visibility.
Top
See Also

Reference

IRegionWithInputData Interface
SMath.Controls Namespace


IRegionWithInputData.InputDataVisibility Property

IRegionWithInputDataInputDataVisibility Property

Gets or sets status of the input data visibility.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool InputDataVisibility { get; set; }
Property InputDataVisibility As Boolean
    Get
    Set
property bool InputDataVisibility {
    bool get ();
    void set (bool value);
}
abstract InputDataVisibility : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionWithInputData Interface
SMath.Controls Namespace


IRegionWithLineBreaks Interface

Allows a Region to be splitted between pages by lines.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithLineBreaks
Public Interface IRegionWithLineBreaks
public interface class IRegionWithLineBreaks
type IRegionWithLineBreaks =  interface end

The IRegionWithLineBreaks type exposes the following members.

Properties
 | Name | Description
Public property | IsBreakable |
Public property | LineBreaks |
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithLineBreaks Properties

The IRegionWithLineBreaks type exposes the following members.

Properties
 | Name | Description
Public property | IsBreakable |
Public property | LineBreaks |
Top
See Also

Reference

IRegionWithLineBreaks Interface
SMath.Controls Namespace


IRegionWithLineBreaks.IsBreakable Property

IRegionWithLineBreaksIsBreakable Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsBreakable { get; set; }
Property IsBreakable As Boolean
    Get
    Set
property bool IsBreakable {
    bool get ();
    void set (bool value);
}
abstract IsBreakable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IRegionWithLineBreaks Interface
SMath.Controls Namespace


IRegionWithLineBreaks.LineBreaks Property

IRegionWithLineBreaksLineBreaks Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ParallelList<int> LineBreaks { get; }
ReadOnly Property LineBreaks As ParallelList(Of Integer)
    Get
property ParallelList<int>^ LineBreaks {
    ParallelList<int>^ get ();
}
abstract LineBreaks : ParallelList<int> with get

Property Value

Type: ParallelList Int32
See Also

Reference

IRegionWithLineBreaks Interface
SMath.Controls Namespace


IRegionWithMath Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithMath : IEvaluableObject,
    IDocumentObject, IEvaluable
Public Interface IRegionWithMath
    Inherits IEvaluableObject, IDocumentObject, IEvaluable
public interface class IRegionWithMath : IEvaluableObject,
    IDocumentObject, IEvaluable
type IRegionWithMath =
    interface
        interface IEvaluableObject
        interface IDocumentObject
        interface IEvaluable
    end

The IRegionWithMath type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | IsSpecCharsMode |
Public property | LastStore |
Public property | Location | (Inherited from IDocumentObject.)
Public property | Rename |
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Size | (Inherited from IDocumentObject.)
Public property | TermChangingIndex |
Top
Methods
 | Name | Description
Public method | Draw | (Inherited from IDocumentObject.)
Public method | GetSelectedItems |
Public method | GetSideElements |
Public method | SetSpecCharsMode |
Public method | SetTermText |
Public method | StartRename |
Public method | StopRename |
Public method | TryConvertToText |
Public method | Update |
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithMath Properties

The IRegionWithMath type exposes the following members.

Properties
 | Name | Description
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | IsSpecCharsMode |
Public property | LastStore |
Public property | Location | (Inherited from IDocumentObject.)
Public property | Rename |
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Size | (Inherited from IDocumentObject.)
Public property | TermChangingIndex |
Top
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.IsSpecCharsMode Property

IRegionWithMathIsSpecCharsMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsSpecCharsMode { get; }
ReadOnly Property IsSpecCharsMode As Boolean
    Get
property bool IsSpecCharsMode {
    bool get ();
}
abstract IsSpecCharsMode : bool with get

Property Value

Type: Boolean
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.LastStore Property

IRegionWithMathLastStore Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Store LastStore { get; set; }
Property LastStore As Store
    Get
    Set
property Store^ LastStore {
    Store^ get ();
    void set (Store^ value);
}
abstract LastStore : Store with get, set

Property Value

Type: Store
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.Rename Property

IRegionWithMathRename Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Rename { get; }
ReadOnly Property Rename As Boolean
    Get
property bool Rename {
    bool get ();
}
abstract Rename : bool with get

Property Value

Type: Boolean
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.TermChangingIndex Property

IRegionWithMathTermChangingIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int TermChangingIndex { get; set; }
Property TermChangingIndex As Integer
    Get
    Set
property int TermChangingIndex {
    int get ();
    void set (int value);
}
abstract TermChangingIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath Methods

The IRegionWithMath type exposes the following members.

Methods
 | Name | Description
Public method | Draw | (Inherited from IDocumentObject.)
Public method | GetSelectedItems |
Public method | GetSideElements |
Public method | SetSpecCharsMode |
Public method | SetTermText |
Public method | StartRename |
Public method | StopRename |
Public method | TryConvertToText |
Public method | Update |
Top
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.GetSelectedItems Method

IRegionWithMathGetSelectedItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Term[] GetSelectedItems()
Function GetSelectedItems As Term()
array<Term^>^ GetSelectedItems()
abstract GetSelectedItems : unit -> Term[]

Return Value

Type: Term
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.GetSideElements Method

IRegionWithMathGetSideElements Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Term[] GetSideElements()
Function GetSideElements As Term()
array<Term^>^ GetSideElements()
abstract GetSideElements : unit -> Term[]

Return Value

Type: Term
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.SetSpecCharsMode Method

IRegionWithMathSetSpecCharsMode Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SetSpecCharsMode(
    bool value
)
Sub SetSpecCharsMode (
    value As Boolean
)
void SetSpecCharsMode(
    bool value
)
abstract SetSpecCharsMode :
        value : bool -> unit

Parameters

value
Type: SystemBoolean
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.SetTermText Method

IRegionWithMathSetTermText Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SetTermText(
    Term[] value,
    string text
)
Sub SetTermText (
    value As Term(),
    text As String
)
void SetTermText(
    array<Term^>^ value,
    String^ text
)
abstract SetTermText :
        value : Term[] *
        text : string -> unit

Parameters

value
Type: SMath.ManagerTerm
text
Type: SystemString
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.StartRename Method

IRegionWithMathStartRename Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void StartRename()
Sub StartRename
void StartRename()
abstract StartRename : unit -> unit
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.StopRename Method

IRegionWithMathStopRename Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void StopRename()
Sub StopRename
void StopRename()
abstract StopRename : unit -> unit
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.TryConvertToText Method

IRegionWithMathTryConvertToText Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TryConvertToText(
    ref string value,
    out RegionBase newRegion
)
Function TryConvertToText (
    ByRef value As String,
    <OutAttribute> ByRef newRegion As RegionBase
) As Boolean
bool TryConvertToText(
    String^% value,
    [OutAttribute] RegionBase^% newRegion
)
abstract TryConvertToText :
        value : string byref *
        newRegion : RegionBase byref -> bool

Parameters

value
Type: SystemString
newRegion
Type: SMath.ControlsRegionBase

Return Value

Type: Boolean
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithMath.Update Method

IRegionWithMathUpdate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Update(
    Term[] answer
)
Sub Update (
    answer As Term()
)
void Update(
    array<Term^>^ answer
)
abstract Update :
        answer : Term[] -> unit

Parameters

answer
Type: SMath.ManagerTerm
See Also

Reference

IRegionWithMath Interface
SMath.Controls Namespace


IRegionWithTooltip Interface

Allows a Region to display custom ToolTip on the Worksheet surface.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IRegionWithTooltip
Public Interface IRegionWithTooltip
public interface class IRegionWithTooltip
type IRegionWithTooltip =  interface end

The IRegionWithTooltip type exposes the following members.

Methods
 | Name | Description
Public method | TryGetTooltip | Draws a ToolTip image of the Region.
Top
See Also

Reference

SMath.Controls Namespace


IRegionWithTooltip Methods

The IRegionWithTooltip type exposes the following members.

Methods
 | Name | Description
Public method | TryGetTooltip | Draws a ToolTip image of the Region.
Top
See Also

Reference

IRegionWithTooltip Interface
SMath.Controls Namespace


IRegionWithTooltip.TryGetTooltip Method

IRegionWithTooltipTryGetTooltip Method

Draws a ToolTip image of the Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TryGetTooltip(
    out IBitmap bmp
)
Function TryGetTooltip (
    <OutAttribute> ByRef bmp As IBitmap
) As Boolean
bool TryGetTooltip(
    [OutAttribute] IBitmap^% bmp
)
abstract TryGetTooltip :
        bmp : IBitmap byref -> bool

Parameters

bmp
Type: SMath.DrawingIBitmap
Image of the ToolTip to show.

Return Value

Type: Boolean
Returns true if ToolTip can be shown; false otherwise.
See Also

Reference

IRegionWithTooltip Interface
SMath.Controls Namespace


ISeparatorObject Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface ISeparatorObject : IDocumentObject,
    IEvaluable
Public Interface ISeparatorObject
    Inherits IDocumentObject, IEvaluable
public interface class ISeparatorObject : IDocumentObject,
    IEvaluable
type ISeparatorObject =
    interface
        interface IDocumentObject
        interface IEvaluable
    end

The ISeparatorObject type exposes the following members.

Properties
 | Name | Description
Public property | Collapsed |
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | Label |
Public property | LabelBounds |
Public property | LabelRegion |
Public property | Location | (Inherited from IDocumentObject.)
Public property | Password |
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Single |
Public property | Size | (Inherited from IDocumentObject.)
Public property | Top |
Top
Methods
 | Name | Description
Public method | CloneProtected |
Public method | Collapse |
Public method | Draw | (Inherited from IDocumentObject.)
Top
Events
 | Name | Description
Public event | CollapsedChanged |
Top
See Also

Reference

SMath.Controls Namespace


ISeparatorObject Properties

The ISeparatorObject type exposes the following members.

Properties
 | Name | Description
Public property | Collapsed |
Public property | CurrentCollapsedHeight | (Inherited from IDocumentObject.)
Public property | CurrentMetaContext | (Inherited from IDocumentObject.)
Public property | CurrentPageOffsets | (Inherited from IDocumentObject.)
Public property | Evaluable | (Inherited from IEvaluable.)
Public property | Focused | (Inherited from IDocumentObject.)
Public property | IsActivated | (Inherited from IDocumentObject.)
Public property | Label |
Public property | LabelBounds |
Public property | LabelRegion |
Public property | Location | (Inherited from IDocumentObject.)
Public property | Password |
Public property | Selected | (Inherited from IDocumentObject.)
Public property | Single |
Public property | Size | (Inherited from IDocumentObject.)
Public property | Top |
Top
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Collapsed Property

ISeparatorObjectCollapsed Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Collapsed { get; }
ReadOnly Property Collapsed As Boolean
    Get
property bool Collapsed {
    bool get ();
}
abstract Collapsed : bool with get

Property Value

Type: Boolean
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Label Property

ISeparatorObjectLabel Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Label { get; set; }
Property Label As String
    Get
    Set
property String^ Label {
    String^ get ();
    void set (String^ value);
}
abstract Label : string with get, set

Property Value

Type: String
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.LabelBounds Property

ISeparatorObjectLabelBounds Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RectangleF LabelBounds { get; }
ReadOnly Property LabelBounds As RectangleF
    Get
property RectangleF LabelBounds {
    RectangleF get ();
}
abstract LabelBounds : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.LabelRegion Property

ISeparatorObjectLabelRegion Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RegionTranslatable LabelRegion { get; }
ReadOnly Property LabelRegion As RegionTranslatable
    Get
property RegionTranslatable^ LabelRegion {
    RegionTranslatable^ get ();
}
abstract LabelRegion : RegionTranslatable with get

Property Value

Type: RegionTranslatable
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Password Property

ISeparatorObjectPassword Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Password { get; set; }
Property Password As String
    Get
    Set
property String^ Password {
    String^ get ();
    void set (String^ value);
}
abstract Password : string with get, set

Property Value

Type: String
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Single Property

ISeparatorObjectSingle Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Single { get; set; }
Property Single As Boolean
    Get
    Set
property bool Single {
    bool get ();
    void set (bool value);
}
abstract Single : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Top Property

ISeparatorObjectTop Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Top { get; set; }
Property Top As Boolean
    Get
    Set
property bool Top {
    bool get ();
    void set (bool value);
}
abstract Top : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject Methods

The ISeparatorObject type exposes the following members.

Methods
 | Name | Description
Public method | CloneProtected |
Public method | Collapse |
Public method | Draw | (Inherited from IDocumentObject.)
Top
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.CloneProtected Method

ISeparatorObjectCloneProtected Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IDocumentObject CloneProtected()
Function CloneProtected As IDocumentObject
IDocumentObject^ CloneProtected()
abstract CloneProtected : unit -> IDocumentObject

Return Value

Type: IDocumentObject
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.Collapse Method

ISeparatorObjectCollapse Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Collapse(
    bool collapsed
)
Sub Collapse (
    collapsed As Boolean
)
void Collapse(
    bool collapsed
)
abstract Collapse :
        collapsed : bool -> unit

Parameters

collapsed
Type: SystemBoolean
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject Events

The ISeparatorObject type exposes the following members.

Events
 | Name | Description
Public event | CollapsedChanged |
Top
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ISeparatorObject.CollapsedChanged Event

ISeparatorObjectCollapsedChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
event AreaCollapseChangedEventHandler CollapsedChanged
Event CollapsedChanged As AreaCollapseChangedEventHandler
 event AreaCollapseChangedEventHandler^ CollapsedChanged {
    void add (AreaCollapseChangedEventHandler^ value);
    void remove (AreaCollapseChangedEventHandler^ value);
}
abstract CollapsedChanged : IEvent<AreaCollapseChangedEventHandler,
    EventArgs>

Value

Type: SMath.ControlsAreaCollapseChangedEventHandler
See Also

Reference

ISeparatorObject Interface
SMath.Controls Namespace


ITranslationNotification Interface

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface ITranslationNotification
Public Interface ITranslationNotification
public interface class ITranslationNotification
type ITranslationNotification =  interface end

The ITranslationNotification type exposes the following members.

Methods
 | Name | Description
Public method | AttachEvent |
Public method | DetachEvent |
Public method | Restart |
Top
See Also

Reference

SMath.Controls Namespace


ITranslationNotification Methods

The ITranslationNotification type exposes the following members.

Methods
 | Name | Description
Public method | AttachEvent |
Public method | DetachEvent |
Public method | Restart |
Top
See Also

Reference

ITranslationNotification Interface
SMath.Controls Namespace


ITranslationNotification.AttachEvent Method

ITranslationNotificationAttachEvent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void AttachEvent(
    RegionTranslatable region
)
Sub AttachEvent (
    region As RegionTranslatable
)
void AttachEvent(
    RegionTranslatable^ region
)
abstract AttachEvent :
        region : RegionTranslatable -> unit

Parameters

region
Type: SMath.ControlsRegionTranslatable
See Also

Reference

ITranslationNotification Interface
SMath.Controls Namespace


ITranslationNotification.DetachEvent Method

ITranslationNotificationDetachEvent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DetachEvent(
    RegionTranslatable region
)
Sub DetachEvent (
    region As RegionTranslatable
)
void DetachEvent(
    RegionTranslatable^ region
)
abstract DetachEvent :
        region : RegionTranslatable -> unit

Parameters

region
Type: SMath.ControlsRegionTranslatable
See Also

Reference

ITranslationNotification Interface
SMath.Controls Namespace


ITranslationNotification.Restart Method

ITranslationNotificationRestart Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Restart(
    RegionTranslatable region,
    bool restartHint
)
Sub Restart (
    region As RegionTranslatable,
    restartHint As Boolean
)
void Restart(
    RegionTranslatable^ region,
    bool restartHint
)
abstract Restart :
        region : RegionTranslatable *
        restartHint : bool -> unit

Parameters

region
Type: SMath.ControlsRegionTranslatable
restartHint
Type: SystemBoolean
See Also

Reference

ITranslationNotification Interface
SMath.Controls Namespace


LineAlignment Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum LineAlignment
Public Enumeration LineAlignment
public enum class LineAlignment
type LineAlignment
Members
Member name | Value | Description
Left | 0 |
Right | 1 |
Center | 2 |
Justify | 3 |
See Also

Reference

SMath.Controls Namespace


ListBoxItem Class

Inheritance Hierarchy
SystemObject
SMath.ControlsListBoxItem

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ListBoxItem : IComparable<ListBoxItem>,
    IEquatable<ListBoxItem>
Public Class ListBoxItem
    Implements IComparable(Of ListBoxItem), IEquatable(Of ListBoxItem)
public ref class ListBoxItem : IComparable<ListBoxItem^>,
    IEquatable<ListBoxItem^>
type ListBoxItem =
    class
        interface IComparable<ListBoxItem>
        interface IEquatable<ListBoxItem>
    end

The ListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | ListBoxItem(String, String, Int32, Int32) | Initializes a new instance of the ListBoxItem class
Public method | ListBoxItem(String, String, String, Int32, Int32) | Initializes a new instance of the ListBoxItem class
Top
Properties
 | Name | Description
Public property | Text |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | ArgsCount |
Public field | Description |
Public field | DrawChildCount |
Public field | ExampleIndex |
Public field | Name |
Public field | Title |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableListBoxItemCompareTo |
Explicit interface implementation | IEquatableListBoxItemEquals |
Top
See Also

Reference

SMath.Controls Namespace


ListBoxItem Constructor

Overload List
 | Name | Description
Public method | ListBoxItem(String, String, Int32, Int32) | Initializes a new instance of the ListBoxItem class
Public method | ListBoxItem(String, String, String, Int32, Int32) | Initializes a new instance of the ListBoxItem class
Top
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem Constructor (String, String, Int32, Int32)

Initializes a new instance of the ListBoxItem class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ListBoxItem(
    string name,
    string description,
    int childCount,
    int exampleIndex
)
Public Sub New (
    name As String,
    description As String,
    childCount As Integer,
    exampleIndex As Integer
)
public:
ListBoxItem(
    String^ name,
    String^ description,
    int childCount,
    int exampleIndex
)
new :
        name : string *
        description : string *
        childCount : int *
        exampleIndex : int -> ListBoxItem

Parameters

name
Type: SystemString
description
Type: SystemString
childCount
Type: SystemInt32
exampleIndex
Type: SystemInt32
See Also

Reference

ListBoxItem Class
ListBoxItem Overload
SMath.Controls Namespace


ListBoxItem Constructor (String, String, String, Int32, Int32)

Initializes a new instance of the ListBoxItem class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ListBoxItem(
    string name,
    string title,
    string description,
    int childCount,
    int exampleIndex
)
Public Sub New (
    name As String,
    title As String,
    description As String,
    childCount As Integer,
    exampleIndex As Integer
)
public:
ListBoxItem(
    String^ name,
    String^ title,
    String^ description,
    int childCount,
    int exampleIndex
)
new :
        name : string *
        title : string *
        description : string *
        childCount : int *
        exampleIndex : int -> ListBoxItem

Parameters

name
Type: SystemString
title
Type: SystemString
description
Type: SystemString
childCount
Type: SystemInt32
exampleIndex
Type: SystemInt32
See Also

Reference

ListBoxItem Class
ListBoxItem Overload
SMath.Controls Namespace


ListBoxItem Properties

The ListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | Text |
Top
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.Text Property

ListBoxItemText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem Methods

The ListBoxItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableListBoxItemCompareTo |
Explicit interface implementation | IEquatableListBoxItemEquals |
Top
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.IComparable(ListBoxItem).CompareTo Method

ListBoxItemIComparableListBoxItemCompareTo Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int IComparable<ListBoxItem>.CompareTo(
    ListBoxItem obj
)
Private Function CompareTo (
    obj As ListBoxItem
) As Integer Implements IComparable(Of ListBoxItem).CompareTo
private:
virtual int CompareTo(
    ListBoxItem^ obj
) sealed = IComparable<ListBoxItem^>::CompareTo
private abstract CompareTo :
        obj : ListBoxItem -> int
private override CompareTo :
        obj : ListBoxItem -> int

Parameters

obj
Type: SMath.ControlsListBoxItem

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.IEquatable(ListBoxItem).Equals Method

ListBoxItemIEquatableListBoxItemEquals Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IEquatable<ListBoxItem>.Equals(
    ListBoxItem obj
)
Private Function Equals (
    obj As ListBoxItem
) As Boolean Implements IEquatable(Of ListBoxItem).Equals
private:
virtual bool Equals(
    ListBoxItem^ obj
) sealed = IEquatable<ListBoxItem^>::Equals
private abstract Equals :
        obj : ListBoxItem -> bool
private override Equals :
        obj : ListBoxItem -> bool

Parameters

obj
Type: SMath.ControlsListBoxItem

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.ToString Method

ListBoxItemToString Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem Fields

The ListBoxItem type exposes the following members.

Fields
 | Name | Description
Public field | ArgsCount |
Public field | Description |
Public field | DrawChildCount |
Public field | ExampleIndex |
Public field | Name |
Public field | Title |
Top
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.ArgsCount Field

ListBoxItemArgsCount Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ArgsCount
Public ArgsCount As Integer
public:
int ArgsCount
val mutable ArgsCount: int

Field Value

Type: Int32
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.Description Field

ListBoxItemDescription Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description
Public Description As String
public:
String^ Description
val mutable Description: string

Field Value

Type: String
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.DrawChildCount Field

ListBoxItemDrawChildCount Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool DrawChildCount
Public DrawChildCount As Boolean
public:
bool DrawChildCount
val mutable DrawChildCount: bool

Field Value

Type: Boolean
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.ExampleIndex Field

ListBoxItemExampleIndex Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ExampleIndex
Public ExampleIndex As Integer
public:
int ExampleIndex
val mutable ExampleIndex: int

Field Value

Type: Int32
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.Name Field

ListBoxItemName Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string

Field Value

Type: String
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


ListBoxItem.Title Field

ListBoxItemTitle Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title
Public Title As String
public:
String^ Title
val mutable Title: string

Field Value

Type: String
See Also

Reference

ListBoxItem Class
SMath.Controls Namespace


LocationCorrectionMode Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum LocationCorrectionMode
Public Enumeration LocationCorrectionMode
public enum class LocationCorrectionMode
type LocationCorrectionMode
Members
Member name | Value | Description
PreserveOriginal | 1 | No correction of original values.
CorrectOriginal | 2 | Correct locations depending on collapsed Area Regions already existing on the Worksheet.
CorrectWithCursor | 3 | Correct locations depending on existing collapsed Area Regions and relatively to Cursor position.
See Also

Reference

SMath.Controls Namespace


MainMenu Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMainMenu

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MainMenu
Public Class MainMenu
public ref class MainMenu
type MainMenu =  class end

The MainMenu type exposes the following members.

Constructors
 | Name | Description
Public method | MainMenu | Initializes a new instance of the MainMenu class
Top
Methods
 | Name | Description
 | CreateInsertMenuItems |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMenuItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MainMenu Constructor

Initializes a new instance of the MainMenu class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MainMenu()
Public Sub New
public:
MainMenu()
new : unit -> MainMenu
See Also

Reference

MainMenu Class
SMath.Controls Namespace


MainMenu Methods

The MainMenu type exposes the following members.

Methods
 | Name | Description
 | CreateInsertMenuItems |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMenuItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MainMenu Class
SMath.Controls Namespace


MainMenu.CreateInsertMenuItems Method

MainMenuCreateInsertMenuItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void CreateInsertMenuItems(
    SessionProfile sessionProfile,
    MainMenuItem menuItem,
    MainMenuCreateClick createClick
)
Public Shared Sub CreateInsertMenuItems (
    sessionProfile As SessionProfile,
    menuItem As MainMenuItem,
    createClick As MainMenuCreateClick
)
public:
static void CreateInsertMenuItems(
    SessionProfile^ sessionProfile,
    MainMenuItem^ menuItem,
    MainMenuCreateClick^ createClick
)
static member CreateInsertMenuItems :
        sessionProfile : SessionProfile *
        menuItem : MainMenuItem *
        createClick : MainMenuCreateClick -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
menuItem
Type: SMath.ControlsMainMenuItem
createClick
Type: SMath.ControlsMainMenuCreateClick
See Also

Reference

MainMenu Class
SMath.Controls Namespace


MainMenu.GetMenuItems Method

MainMenuGetMenuItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void GetMenuItems(
    SessionProfile sessionProfile,
    Dictionary<string, MenuButton> menuItems
)
Public Shared Sub GetMenuItems (
    sessionProfile As SessionProfile,
    menuItems As Dictionary(Of String, MenuButton)
)
public:
static void GetMenuItems(
    SessionProfile^ sessionProfile,
    Dictionary<String^, MenuButton^>^ menuItems
)
static member GetMenuItems :
        sessionProfile : SessionProfile *
        menuItems : Dictionary<string, MenuButton> -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
menuItems
Type: System.Collections.GenericDictionaryString, MenuButton
See Also

Reference

MainMenu Class
SMath.Controls Namespace


MainMenu.CreateClick Delegate

MainMenuCreateClick Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate EventHandler CreateClick(
    MenuButton item
)
Public Delegate Function CreateClick (
    item As MenuButton
) As EventHandler
public delegate EventHandler^ CreateClick(
    MenuButton^ item
)
type CreateClick =
    delegate of
        item : MenuButton -> EventHandler

Parameters

item
Type: SMath.ControlsMenuButton

Return Value

Type: EventHandler
See Also

Reference

SMath.Controls Namespace


MainMenuItem Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMainMenuItem

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MainMenuItem
Public Class MainMenuItem
public ref class MainMenuItem
type MainMenuItem =  class end

The MainMenuItem type exposes the following members.

Constructors
 | Name | Description
Public method | MainMenuItem | Initializes a new instance of the MainMenuItem class
Top
Properties
 | Name | Description
Public property | Checked |
Public property | Click |
Public property | Enabled |
Public property | Image |
Public property | Items |
Public property | Name |
Public property | ShortcutKey |
Public property | ShortcutKeyDisplayString |
Public property | Size |
Public property | Tag |
Public property | Text |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MainMenuItem Constructor

Initializes a new instance of the MainMenuItem class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MainMenuItem()
Public Sub New
public:
MainMenuItem()
new : unit -> MainMenuItem
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem Properties

The MainMenuItem type exposes the following members.

Properties
 | Name | Description
Public property | Checked |
Public property | Click |
Public property | Enabled |
Public property | Image |
Public property | Items |
Public property | Name |
Public property | ShortcutKey |
Public property | ShortcutKeyDisplayString |
Public property | Size |
Public property | Tag |
Public property | Text |
Top
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Checked Property

MainMenuItemChecked Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Click Property

MainMenuItemClick Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EventHandler Click { get; set; }
Public Property Click As EventHandler
    Get
    Set
public:
property EventHandler^ Click {
    EventHandler^ get ();
    void set (EventHandler^ value);
}
member Click : EventHandler with get, set

Property Value

Type: EventHandler
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Enabled Property

MainMenuItemEnabled Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Image Property

MainMenuItemImage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap Image { get; set; }
Public Property Image As IBitmap
    Get
    Set
public:
property IBitmap^ Image {
    IBitmap^ get ();
    void set (IBitmap^ value);
}
member Image : IBitmap with get, set

Property Value

Type: IBitmap
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Items Property

MainMenuItemItems Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<MainMenuItem> Items { get; set; }
Public Property Items As List(Of MainMenuItem)
    Get
    Set
public:
property List<MainMenuItem^>^ Items {
    List<MainMenuItem^>^ get ();
    void set (List<MainMenuItem^>^ value);
}
member Items : List<MainMenuItem> with get, set

Property Value

Type: ListMainMenuItem
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Name Property

MainMenuItemName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.ShortcutKey Property

MainMenuItemShortcutKey Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InputKeys ShortcutKey { get; set; }
Public Property ShortcutKey As InputKeys
    Get
    Set
public:
property InputKeys ShortcutKey {
    InputKeys get ();
    void set (InputKeys value);
}
member ShortcutKey : InputKeys with get, set

Property Value

Type: InputKeys
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.ShortcutKeyDisplayString Property

MainMenuItemShortcutKeyDisplayString Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ShortcutKeyDisplayString { get; set; }
Public Property ShortcutKeyDisplayString As String
    Get
    Set
public:
property String^ ShortcutKeyDisplayString {
    String^ get ();
    void set (String^ value);
}
member ShortcutKeyDisplayString : string with get, set

Property Value

Type: String
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Size Property

MainMenuItemSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
property Size Size {
    Size get ();
    void set (Size value);
}
member Size : Size with get, set

Property Value

Type: Size
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Tag Property

MainMenuItemTag Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
member Tag : Object with get, set

Property Value

Type: Object
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem.Text Property

MainMenuItemText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MainMenuItem Methods

The MainMenuItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MainMenuItem Class
SMath.Controls Namespace


MatchingContext Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMatchingContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MatchingContext : IEnumerator<ExtendedSearchEntry>,
    IDisposable, IEnumerator
Public Class MatchingContext
    Implements IEnumerator(Of ExtendedSearchEntry), IDisposable,
    IEnumerator
public ref class MatchingContext : IEnumerator<ExtendedSearchEntry>,
    IDisposable, IEnumerator
type MatchingContext =
    class
        interface IEnumerator<ExtendedSearchEntry>
        interface IDisposable
        interface IEnumerator
    end

The MatchingContext type exposes the following members.

Constructors
 | Name | Description
Public method | MatchingContext | Initializes a new instance of the MatchingContext class
Top
Properties
 | Name | Description
Public property | Current |
Public property | EntriesCount |
Public property | FoundIndex |
Public property | InnerOffset |
Public property | Offset |
Public property | Selected |
Public property | SelectedEntry |
Top
Methods
 | Name | Description
Public method | Append |
Public method | Dispose | Releases all resources used by the MatchingContext
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Reset(Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorCurrent |
Top
See Also

Reference

SMath.Controls Namespace


MatchingContext Constructor

Initializes a new instance of the MatchingContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MatchingContext(
    int foundIndex
)
Public Sub New (
    foundIndex As Integer
)
public:
MatchingContext(
    int foundIndex
)
new :
        foundIndex : int -> MatchingContext

Parameters

foundIndex
Type: SystemInt32
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext Properties

The MatchingContext type exposes the following members.

Properties
 | Name | Description
Public property | Current |
Public property | EntriesCount |
Public property | FoundIndex |
Public property | InnerOffset |
Public property | Offset |
Public property | Selected |
Public property | SelectedEntry |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorCurrent |
Top
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.IEnumerator.Current Property

MatchingContextIEnumeratorCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Object

Implements

IEnumeratorCurrent
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Current Property

MatchingContextCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ExtendedSearchEntry Current { get; }
Public ReadOnly Property Current As ExtendedSearchEntry
    Get
public:
virtual property ExtendedSearchEntry Current {
    ExtendedSearchEntry get () sealed;
}
abstract Current : ExtendedSearchEntry with get
override Current : ExtendedSearchEntry with get

Property Value

Type: ExtendedSearchEntry

Implements

IEnumeratorTCurrent
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.EntriesCount Property

MatchingContextEntriesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int EntriesCount { get; }
Public ReadOnly Property EntriesCount As Integer
    Get
public:
property int EntriesCount {
    int get ();
}
member EntriesCount : int with get

Property Value

Type: Int32
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.FoundIndex Property

MatchingContextFoundIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int FoundIndex { get; }
Public ReadOnly Property FoundIndex As Integer
    Get
public:
property int FoundIndex {
    int get ();
}
member FoundIndex : int with get

Property Value

Type: Int32
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.InnerOffset Property

MatchingContextInnerOffset Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF InnerOffset { get; }
Public ReadOnly Property InnerOffset As PointF
    Get
public:
property PointF InnerOffset {
    PointF get ();
}
member InnerOffset : PointF with get

Property Value

Type: PointF
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Offset Property

MatchingContextOffset Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Offset { get; }
Public ReadOnly Property Offset As PointF
    Get
public:
property PointF Offset {
    PointF get ();
}
member Offset : PointF with get

Property Value

Type: PointF
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Selected Property

MatchingContextSelected Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; }
Public ReadOnly Property Selected As Boolean
    Get
public:
property bool Selected {
    bool get ();
}
member Selected : bool with get

Property Value

Type: Boolean
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.SelectedEntry Property

MatchingContextSelectedEntry Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SelectedEntry { get; }
Public ReadOnly Property SelectedEntry As Boolean
    Get
public:
property bool SelectedEntry {
    bool get ();
}
member SelectedEntry : bool with get

Property Value

Type: Boolean
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext Methods

The MatchingContext type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | Reset(Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Append Method

MatchingContextAppend Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Append(
    List<ExtendedSearchEntry> entries,
    PointF offset,
    PointF innerOffset
)
Public Function Append (
    entries As List(Of ExtendedSearchEntry),
    offset As PointF,
    innerOffset As PointF
) As Integer
public:
int Append(
    List<ExtendedSearchEntry>^ entries,
    PointF offset,
    PointF innerOffset
)
member Append :
        entries : List<ExtendedSearchEntry> *
        offset : PointF *
        innerOffset : PointF -> int

Parameters

entries
Type: System.Collections.GenericListExtendedSearchEntry
offset
Type: System.DrawingPointF
innerOffset
Type: System.DrawingPointF

Return Value

Type: Int32
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Dispose Method

MatchingContextDispose Method

Releases all resources used by the MatchingContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.MoveNext Method

MatchingContextMoveNext Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Boolean

Implements

IEnumeratorMoveNext
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Reset Method

MatchingContextReset Method

Overload List
 | Name | Description
Public method | Reset |
Public method | Reset(Int32, Int32) |
Top
See Also

Reference

MatchingContext Class
SMath.Controls Namespace


MatchingContext.Reset Method

MatchingContextReset Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
See Also

Reference

MatchingContext Class
Reset Overload
SMath.Controls Namespace


MatchingContext.Reset Method (Int32, Int32)

MatchingContextReset Method (Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Reset(
    int currentRegionIndex,
    int currentRegionExtendedIndex
)
Public Sub Reset (
    currentRegionIndex As Integer,
    currentRegionExtendedIndex As Integer
)
public:
void Reset(
    int currentRegionIndex,
    int currentRegionExtendedIndex
)
member Reset :
        currentRegionIndex : int *
        currentRegionExtendedIndex : int -> unit

Parameters

currentRegionIndex
Type: SystemInt32
currentRegionExtendedIndex
Type: SystemInt32
See Also

Reference

MatchingContext Class
Reset Overload
SMath.Controls Namespace


MatchingOptions Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMatchingOptions
SMath.ControlsGlobalMatchingOptions

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MatchingOptions
Public Class MatchingOptions
public ref class MatchingOptions
type MatchingOptions =  class end

The MatchingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MatchingOptions | Initializes a new instance of the MatchingOptions class
Top
Properties
 | Name | Description
Public property | CaseSensitive |
Public property | WholeWord |
Top
Methods
 | Name | Description
Public method | ApplyRegex |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MatchingOptions Constructor

Initializes a new instance of the MatchingOptions class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MatchingOptions()
Public Sub New
public:
MatchingOptions()
new : unit -> MatchingOptions
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MatchingOptions Properties

The MatchingOptions type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive |
Public property | WholeWord |
Top
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MatchingOptions.CaseSensitive Property

MatchingOptionsCaseSensitive Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
    Get
    Set
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
member CaseSensitive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MatchingOptions.WholeWord Property

MatchingOptionsWholeWord Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool WholeWord { get; set; }
Public Property WholeWord As Boolean
    Get
    Set
public:
property bool WholeWord {
    bool get ();
    void set (bool value);
}
member WholeWord : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MatchingOptions Methods

The MatchingOptions type exposes the following members.

Methods
 | Name | Description
Public method | ApplyRegex |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MatchingOptions.ApplyRegex Method

MatchingOptionsApplyRegex Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<int> ApplyRegex(
    string text,
    string value
)
Public Function ApplyRegex (
    text As String,
    value As String
) As List(Of Integer)
public:
List<int>^ ApplyRegex(
    String^ text,
    String^ value
)
member ApplyRegex :
        text : string *
        value : string -> List<int>

Parameters

text
Type: SystemString
value
Type: SystemString

Return Value

Type: ListInt32
See Also

Reference

MatchingOptions Class
SMath.Controls Namespace


MenuButton Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMenuButton

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MenuButton
Public Class MenuButton
public ref class MenuButton
type MenuButton =  class end

The MenuButton type exposes the following members.

Constructors
 | Name | Description
Public method | MenuButton(String) | Initializes a new instance of the MenuButton class
Public method | MenuButton(MenuButton) | Initializes a new instance of the MenuButton class
Public method | MenuButton(String, ButtonAction) | Initializes a new instance of the MenuButton class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Behavior |
Public property | Checked |
Public property | Children |
Public property | Data |
Public property | Enabled |
Public property | Icon |
Public property | Index |
Public property | Location |
Public property | Name |
Public property | OpenFileFilter |
Public property | SaveFileFilter |
Public property | ShortcutKey |
Public property | ShortcutKeyDisplayString |
Public property | Text |
Public property | Visible |
Top
Methods
 | Name | Description
Public method | AppendChild(MenuButton) |
Public method | AppendChild(String, ButtonAction) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MenuButton Constructor

Overload List
 | Name | Description
Public method | MenuButton(String) | Initializes a new instance of the MenuButton class
Public method | MenuButton(MenuButton) | Initializes a new instance of the MenuButton class
Public method | MenuButton(String, ButtonAction) | Initializes a new instance of the MenuButton class
Top
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton Constructor (String)

Initializes a new instance of the MenuButton class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton(
    string text
)
Public Sub New (
    text As String
)
public:
MenuButton(
    String^ text
)
new :
        text : string -> MenuButton

Parameters

text
Type: SystemString
See Also

Reference

MenuButton Class
MenuButton Overload
SMath.Controls Namespace


MenuButton Constructor (MenuButton)

Initializes a new instance of the MenuButton class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton(
    MenuButton item
)
Public Sub New (
    item As MenuButton
)
public:
MenuButton(
    MenuButton^ item
)
new :
        item : MenuButton -> MenuButton

Parameters

item
Type: SMath.ControlsMenuButton
See Also

Reference

MenuButton Class
MenuButton Overload
SMath.Controls Namespace


MenuButton Constructor (String, ButtonAction)

Initializes a new instance of the MenuButton class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton(
    string text,
    ButtonAction action
)
Public Sub New (
    text As String,
    action As ButtonAction
)
public:
MenuButton(
    String^ text,
    ButtonAction^ action
)
new :
        text : string *
        action : ButtonAction -> MenuButton

Parameters

text
Type: SystemString
action
Type: SMath.ControlsButtonAction
See Also

Reference

MenuButton Class
MenuButton Overload
SMath.Controls Namespace


MenuButton Properties

The MenuButton type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Behavior |
Public property | Checked |
Public property | Children |
Public property | Data |
Public property | Enabled |
Public property | Icon |
Public property | Index |
Public property | Location |
Public property | Name |
Public property | OpenFileFilter |
Public property | SaveFileFilter |
Public property | ShortcutKey |
Public property | ShortcutKeyDisplayString |
Public property | Text |
Public property | Visible |
Top
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Action Property

MenuButtonAction Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ButtonAction Action { get; set; }
Public Property Action As ButtonAction
    Get
    Set
public:
property ButtonAction^ Action {
    ButtonAction^ get ();
    void set (ButtonAction^ value);
}
member Action : ButtonAction with get, set

Property Value

Type: ButtonAction
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Behavior Property

MenuButtonBehavior Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButtonBehavior Behavior { get; set; }
Public Property Behavior As MenuButtonBehavior
    Get
    Set
public:
property MenuButtonBehavior Behavior {
    MenuButtonBehavior get ();
    void set (MenuButtonBehavior value);
}
member Behavior : MenuButtonBehavior with get, set

Property Value

Type: MenuButtonBehavior
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Checked Property

MenuButtonChecked Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}
member Checked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Children Property

MenuButtonChildren Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<MenuButton> Children { get; }
Public ReadOnly Property Children As List(Of MenuButton)
    Get
public:
property List<MenuButton^>^ Children {
    List<MenuButton^>^ get ();
}
member Children : List<MenuButton> with get

Property Value

Type: ListMenuButton
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Data Property

MenuButtonData Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Object Data { get; set; }
Public Property Data As Object
    Get
    Set
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}
member Data : Object with get, set

Property Value

Type: Object
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Enabled Property

MenuButtonEnabled Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Icon Property

MenuButtonIcon Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap Icon { get; set; }
Public Property Icon As IBitmap
    Get
    Set
public:
property IBitmap^ Icon {
    IBitmap^ get ();
    void set (IBitmap^ value);
}
member Icon : IBitmap with get, set

Property Value

Type: IBitmap
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Index Property

MenuButtonIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Location Property

MenuButtonLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButtonLocation Location { get; set; }
Public Property Location As MenuButtonLocation
    Get
    Set
public:
property MenuButtonLocation Location {
    MenuButtonLocation get ();
    void set (MenuButtonLocation value);
}
member Location : MenuButtonLocation with get, set

Property Value

Type: MenuButtonLocation
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Name Property

MenuButtonName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.OpenFileFilter Property

MenuButtonOpenFileFilter Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string OpenFileFilter { get; set; }
Public Property OpenFileFilter As String
    Get
    Set
public:
property String^ OpenFileFilter {
    String^ get ();
    void set (String^ value);
}
member OpenFileFilter : string with get, set

Property Value

Type: String
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.SaveFileFilter Property

MenuButtonSaveFileFilter Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string SaveFileFilter { get; set; }
Public Property SaveFileFilter As String
    Get
    Set
public:
property String^ SaveFileFilter {
    String^ get ();
    void set (String^ value);
}
member SaveFileFilter : string with get, set

Property Value

Type: String
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.ShortcutKey Property

MenuButtonShortcutKey Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InputKeys ShortcutKey { get; set; }
Public Property ShortcutKey As InputKeys
    Get
    Set
public:
property InputKeys ShortcutKey {
    InputKeys get ();
    void set (InputKeys value);
}
member ShortcutKey : InputKeys with get, set

Property Value

Type: InputKeys
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.ShortcutKeyDisplayString Property

MenuButtonShortcutKeyDisplayString Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ShortcutKeyDisplayString { get; set; }
Public Property ShortcutKeyDisplayString As String
    Get
    Set
public:
property String^ ShortcutKeyDisplayString {
    String^ get ();
    void set (String^ value);
}
member ShortcutKeyDisplayString : string with get, set

Property Value

Type: String
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Text Property

MenuButtonText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.Visible Property

MenuButtonVisible Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton Methods

The MenuButton type exposes the following members.

Methods
 | Name | Description
Public method | AppendChild(MenuButton) |
Public method | AppendChild(String, ButtonAction) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.AppendChild Method

MenuButtonAppendChild Method

Overload List
 | Name | Description
Public method | AppendChild(MenuButton) |
Public method | AppendChild(String, ButtonAction) |
Top
See Also

Reference

MenuButton Class
SMath.Controls Namespace


MenuButton.AppendChild Method (MenuButton)

MenuButtonAppendChild Method (MenuButton)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton AppendChild(
    MenuButton child
)
Public Function AppendChild (
    child As MenuButton
) As MenuButton
public:
MenuButton^ AppendChild(
    MenuButton^ child
)
member AppendChild :
        child : MenuButton -> MenuButton

Parameters

child
Type: SMath.ControlsMenuButton

Return Value

Type: MenuButton
See Also

Reference

MenuButton Class
AppendChild Overload
SMath.Controls Namespace


MenuButton.AppendChild Method (String, ButtonAction)

MenuButtonAppendChild Method (String, ButtonAction)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton AppendChild(
    string text,
    ButtonAction action
)
Public Function AppendChild (
    text As String,
    action As ButtonAction
) As MenuButton
public:
MenuButton^ AppendChild(
    String^ text,
    ButtonAction^ action
)
member AppendChild :
        text : string *
        action : ButtonAction -> MenuButton

Parameters

text
Type: SystemString
action
Type: SMath.ControlsButtonAction

Return Value

Type: MenuButton
See Also

Reference

MenuButton Class
AppendChild Overload
SMath.Controls Namespace


MenuButtonArgs Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMenuButtonArgs

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MenuButtonArgs
Public Class MenuButtonArgs
public ref class MenuButtonArgs
type MenuButtonArgs =  class end

The MenuButtonArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MenuButtonArgs | Initializes a new instance of the MenuButtonArgs class
Top
Properties
 | Name | Description
Public property | Cancel |
Public property | Content |
Public property | CurrentRegion |
Public property | CurrentRegions |
Public property | DialogPath |
Public property | MenuButton |
Public property | SessionProfile |
Public property | Worksheet |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegionsEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SubscribeOnChanges |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MenuButtonArgs Constructor

Initializes a new instance of the MenuButtonArgs class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButtonArgs(
    Worksheet sheet
)
Public Sub New (
    sheet As Worksheet
)
public:
MenuButtonArgs(
    Worksheet^ sheet
)
new :
        sheet : Worksheet -> MenuButtonArgs

Parameters

sheet
Type: SMath.ControlsWorksheet
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs Properties

The MenuButtonArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel |
Public property | Content |
Public property | CurrentRegion |
Public property | CurrentRegions |
Public property | DialogPath |
Public property | MenuButton |
Public property | SessionProfile |
Public property | Worksheet |
Top
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.Cancel Property

MenuButtonArgsCancel Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.Content Property

MenuButtonArgsContent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Content { get; set; }
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
member Content : string with get, set

Property Value

Type: String
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.CurrentRegion Property

MenuButtonArgsCurrentRegion Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase CurrentRegion { get; set; }
Public Property CurrentRegion As RegionBase
    Get
    Set
public:
property RegionBase^ CurrentRegion {
    RegionBase^ get ();
    void set (RegionBase^ value);
}
member CurrentRegion : RegionBase with get, set

Property Value

Type: RegionBase
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.CurrentRegions Property

MenuButtonArgsCurrentRegions Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase[] CurrentRegions { get; set; }
Public Property CurrentRegions As RegionBase()
    Get
    Set
public:
property array<RegionBase^>^ CurrentRegions {
    array<RegionBase^>^ get ();
    void set (array<RegionBase^>^ value);
}
member CurrentRegions : RegionBase[] with get, set

Property Value

Type: RegionBase
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.DialogPath Property

MenuButtonArgsDialogPath Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string DialogPath { get; set; }
Public Property DialogPath As String
    Get
    Set
public:
property String^ DialogPath {
    String^ get ();
    void set (String^ value);
}
member DialogPath : string with get, set

Property Value

Type: String
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.MenuButton Property

MenuButtonArgsMenuButton Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton MenuButton { get; set; }
Public Property MenuButton As MenuButton
    Get
    Set
public:
property MenuButton^ MenuButton {
    MenuButton^ get ();
    void set (MenuButton^ value);
}
member MenuButton : MenuButton with get, set

Property Value

Type: MenuButton
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.SessionProfile Property

MenuButtonArgsSessionProfile Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; }
Public ReadOnly Property SessionProfile As SessionProfile
    Get
public:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
}
member SessionProfile : SessionProfile with get

Property Value

Type: SessionProfile
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.Worksheet Property

MenuButtonArgsWorksheet Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Worksheet Worksheet { get; }
Public ReadOnly Property Worksheet As Worksheet
    Get
public:
property Worksheet^ Worksheet {
    Worksheet^ get ();
}
member Worksheet : Worksheet with get

Property Value

Type: Worksheet
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs Methods

The MenuButtonArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegionsEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SubscribeOnChanges |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.GetRegionsEnumerator Method

MenuButtonArgsGetRegionsEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator GetRegionsEnumerator()
Public Function GetRegionsEnumerator As RegionsEnumerator
public:
RegionsEnumerator^ GetRegionsEnumerator()
member GetRegionsEnumerator : unit -> RegionsEnumerator

Return Value

Type: RegionsEnumerator
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonArgs.SubscribeOnChanges Method

MenuButtonArgsSubscribeOnChanges Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SubscribeOnChanges(
    WorksheetStatusChangedEventHandler handler
)
Public Sub SubscribeOnChanges (
    handler As WorksheetStatusChangedEventHandler
)
public:
void SubscribeOnChanges(
    WorksheetStatusChangedEventHandler^ handler
)
member SubscribeOnChanges :
        handler : WorksheetStatusChangedEventHandler -> unit

Parameters

handler
Type: SMath.ControlsWorksheetStatusChangedEventHandler
See Also

Reference

MenuButtonArgs Class
SMath.Controls Namespace


MenuButtonBehavior Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MenuButtonBehavior
<FlagsAttribute>
Public Enumeration MenuButtonBehavior
[FlagsAttribute]
public enum class MenuButtonBehavior
[<FlagsAttribute>]
type MenuButtonBehavior
Members
Member name | Value | Description
AlwaysEnabled | 1 |
DisableWhenInsideRegion | 2 |
DisableWhenOutsideRegion | 4 |
DisableWhenNoSelection | 8 |
DocumentModeOnly | 16 |
SingleExecutionForAll | 32 |
See Also

Reference

SMath.Controls Namespace


MenuButtonComparer Class

Provide complex comparison mechanisms to IComparable collections of MenuButton items.
Inheritance Hierarchy
SystemObject
SMath.ControlsMenuButtonComparer

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MenuButtonComparer : IComparer<MenuButton>
Public Class MenuButtonComparer
    Implements IComparer(Of MenuButton)
public ref class MenuButtonComparer : IComparer<MenuButton^>
type MenuButtonComparer =
    class
        interface IComparer<MenuButton>
    end

The MenuButtonComparer type exposes the following members.

Constructors
 | Name | Description
Public method | MenuButtonComparer | Initializes a new instance of the MenuButtonComparer class
Top
Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MenuButtonComparer Constructor

Initializes a new instance of the MenuButtonComparer class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButtonComparer()
Public Sub New
public:
MenuButtonComparer()
new : unit -> MenuButtonComparer
See Also

Reference

MenuButtonComparer Class
SMath.Controls Namespace


MenuButtonComparer Methods

The MenuButtonComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MenuButtonComparer Class
SMath.Controls Namespace


MenuButtonComparer.Compare Method

MenuButtonComparerCompare Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    MenuButton a,
    MenuButton b
)
Public Function Compare (
    a As MenuButton,
    b As MenuButton
) As Integer
public:
virtual int Compare(
    MenuButton^ a,
    MenuButton^ b
) sealed
abstract Compare :
        a : MenuButton *
        b : MenuButton -> int
override Compare :
        a : MenuButton *
        b : MenuButton -> int

Parameters

a
Type: SMath.ControlsMenuButton
b
Type: SMath.ControlsMenuButton

Return Value

Type: Int32

Implements

IComparerTCompare(T, T)
See Also

Reference

MenuButtonComparer Class
SMath.Controls Namespace


MenuButtonLocation Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MenuButtonLocation
<FlagsAttribute>
Public Enumeration MenuButtonLocation
[FlagsAttribute]
public enum class MenuButtonLocation
[<FlagsAttribute>]
type MenuButtonLocation
Members
Member name | Value | Description
Auto | 1 |
FileMenu | 2 |
ViewMenu | 4 |
ToolsMenu | 8 |
HelpMenu | 16 |
ContextMenu | 32 |
FormatToolbar | 64 |
See Also

Reference

SMath.Controls Namespace


MenuContext Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMenuContext

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MenuContext
Public Class MenuContext
public ref class MenuContext
type MenuContext =  class end

The MenuContext type exposes the following members.

Constructors
 | Name | Description
Public method | MenuContext | Initializes a new instance of the MenuContext class
Top
Properties
 | Name | Description
Public property | CurrentRegions |
Public property | ExistingMenuItems |
Public property | SessionProfile |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MenuContext Constructor

Initializes a new instance of the MenuContext class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuContext(
    SessionProfile SessionProfile
)
Public Sub New (
    SessionProfile As SessionProfile
)
public:
MenuContext(
    SessionProfile^ SessionProfile
)
new :
        SessionProfile : SessionProfile -> MenuContext

Parameters

SessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuContext Properties

The MenuContext type exposes the following members.

Properties
 | Name | Description
Public property | CurrentRegions |
Public property | ExistingMenuItems |
Public property | SessionProfile |
Top
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuContext.CurrentRegions Property

MenuContextCurrentRegions Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase[] CurrentRegions { get; set; }
Public Property CurrentRegions As RegionBase()
    Get
    Set
public:
property array<RegionBase^>^ CurrentRegions {
    array<RegionBase^>^ get ();
    void set (array<RegionBase^>^ value);
}
member CurrentRegions : RegionBase[] with get, set

Property Value

Type: RegionBase
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuContext.ExistingMenuItems Property

MenuContextExistingMenuItems Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton[] ExistingMenuItems { get; set; }
Public Property ExistingMenuItems As MenuButton()
    Get
    Set
public:
property array<MenuButton^>^ ExistingMenuItems {
    array<MenuButton^>^ get ();
    void set (array<MenuButton^>^ value);
}
member ExistingMenuItems : MenuButton[] with get, set

Property Value

Type: MenuButton
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuContext.SessionProfile Property

MenuContextSessionProfile Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; set; }
Public Property SessionProfile As SessionProfile
    Get
    Set
public:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
    void set (SessionProfile^ value);
}
member SessionProfile : SessionProfile with get, set

Property Value

Type: SessionProfile
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuContext Methods

The MenuContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MenuContext Class
SMath.Controls Namespace


MenuExtenders Class

Inheritance Hierarchy
SystemObject
SMath.ControlsMenuExtenders

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MenuExtenders
Public Class MenuExtenders
public ref class MenuExtenders
type MenuExtenders =  class end

The MenuExtenders type exposes the following members.

Constructors
 | Name | Description
Public method | MenuExtenders | Initializes a new instance of the MenuExtenders class
Top
Properties
Name | Description
MenuExtenderPlugins |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetMenuExtenderPlugins | Reset list of menu extenders plug-ins for future usage.Сбросить список дополнений расширителей меню для последующего использования.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


MenuExtenders Constructor

Initializes a new instance of the MenuExtenders class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuExtenders()
Public Sub New
public:
MenuExtenders()
new : unit -> MenuExtenders
See Also

Reference

MenuExtenders Class
SMath.Controls Namespace


MenuExtenders Properties

The MenuExtenders type exposes the following members.

Properties
Name | Description
MenuExtenderPlugins |
Top
See Also

Reference

MenuExtenders Class
SMath.Controls Namespace


MenuExtenders.MenuExtenderPlugins Property

MenuExtendersMenuExtenderPlugins Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<IPluginMenuExtender> MenuExtenderPlugins { get; }
Public Shared ReadOnly Property MenuExtenderPlugins As IEnumerable(Of IPluginMenuExtender)
    Get
public:
static property IEnumerable<IPluginMenuExtender^>^ MenuExtenderPlugins {
    IEnumerable<IPluginMenuExtender^>^ get ();
}
static member MenuExtenderPlugins : IEnumerable<IPluginMenuExtender> with get

Property Value

Type: IEnumerableIPluginMenuExtender
See Also

Reference

MenuExtenders Class
SMath.Controls Namespace


MenuExtenders Methods

The MenuExtenders type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResetMenuExtenderPlugins | Reset list of menu extenders plug-ins for future usage.Сбросить список дополнений расширителей меню для последующего использования.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MenuExtenders Class
SMath.Controls Namespace


MenuExtenders.ResetMenuExtenderPlugins Method

MenuExtendersResetMenuExtenderPlugins Method

Reset list of menu extenders plug-ins for future usage.Сбросить список дополнений расширителей меню для последующего использования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ResetMenuExtenderPlugins()
Public Shared Sub ResetMenuExtenderPlugins
public:
static void ResetMenuExtenderPlugins()
static member ResetMenuExtenderPlugins : unit -> unit
See Also

Reference

MenuExtenders Class
SMath.Controls Namespace


MenuItems Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum MenuItems
Public Enumeration MenuItems
public enum class MenuItems
type MenuItems
Members
Member name | Value | Description
NewFile | 0 |
OpenFile | 1 |
SaveFile | 2 |
Insert | 3 |
OpenExample | 4 |
AboutDialog | 5 |
Recalculate | 6 |
Delete | 7 |
SelectAll | 8 |
Cut | 9 |
Copy | 10 |
Paste | 11 |
Undo | 12 |
Redo | 13 |
See Also

Reference

SMath.Controls Namespace


MissingRegion Class

Region which is shown instead of incorrectly loaded one to indicate existence of it.Элемент листа, отображаемый вместо элемента, для которого не было найдено подходящего обработчика. Демонстрирует пользователю существование элемента листа и его статус.
Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBase
SMath.ControlsRegionEvaluable
SMath.ControlsMissingRegion

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MissingRegion : RegionEvaluable
Public Class MissingRegion
    Inherits RegionEvaluable
public ref class MissingRegion : public RegionEvaluable
type MissingRegion =
    class
        inherit RegionEvaluable
    end

The MissingRegion type exposes the following members.

Constructors
 | Name | Description
Public method | MissingRegion | Initializes a new instance of the MissingRegion class
Top
Properties
 | Name | Description
Public property | ActiveDebugTermIndex | (Inherited from RegionEvaluable.)
Public property | Attributes |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | (Inherited from RegionEvaluable.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Inherited from RegionEvaluable.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes | (Inherited from RegionEvaluable.)
Public property | DebugTerms | (Inherited from RegionEvaluable.)
Public property | DeletedValues | (Inherited from RegionEvaluable.)
Public property | Dependences | (Overrides RegionBaseDependences.)
Public property | DescriptionBounds | (Inherited from RegionEvaluable.)
Public property | DescriptionLocation | (Inherited from RegionEvaluable.)
Public property | DescriptionText | (Inherited from RegionEvaluable.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента. (Inherited from RegionEvaluable.)
Public property | ErrorTerm | (Inherited from RegionEvaluable.)
Public property | ErrorText | Текст ошибки элемента. (Inherited from RegionEvaluable.)
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении. (Inherited from RegionEvaluable.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Inherited from RegionEvaluable.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой. (Inherited from RegionEvaluable.)
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент. (Inherited from RegionEvaluable.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionEvaluable.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | Message |
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Inherited from RegionEvaluable.)
Public property | Optimization | (Inherited from RegionEvaluable.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes | (Inherited from RegionEvaluable.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription | (Inherited from RegionEvaluable.)
Public property | Size | Размер элемента управления. (Inherited from RegionEvaluable.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | TagName |
Public property | Terms | Массив элементов математического выражения. (Inherited from RegionEvaluable.)
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values | (Inherited from RegionEvaluable.)
Public property | WarningColor | Цвет предупреждений элемента. (Inherited from RegionEvaluable.)
Top
Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | Checks if it is required to recalculate page due to the element.Проверяет, необходимо ли из-за данного элемента пересчитывать весь лист. (Inherited from RegionEvaluable.)
Protected method | ChildRepainting | (Inherited from RegionEvaluable.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Overrides RegionBaseClone.)
Public method | Copy | (Inherited from RegionEvaluable.)
Public method | CreateDescription | (Inherited from RegionEvaluable.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Overrides RegionBaseFromXml(StorageReader, FileParsingContext).)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetcurrentTermsContainer | (Inherited from RegionEvaluable.)
Public method | GetCursorType | (Inherited from RegionEvaluable.)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Inherited from RegionEvaluable.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionEvaluable.)
Public method | InitLayout(Store) | (Inherited from RegionEvaluable.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Public method | MarkOutOfDate | Obsolete. (Inherited from RegionEvaluable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Inherited from RegionEvaluable.)
Public method | OnCommandSend(Term) | (Inherited from RegionEvaluable.)
Public method | OnEvaluation | (Overrides RegionEvaluableOnEvaluation(Store).)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Inherited from RegionEvaluable.)
Public method | OnMouseMove | (Inherited from RegionEvaluable.)
Public method | OnMouseUp | (Inherited from RegionEvaluable.)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Overrides RegionEvaluableOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Inherited from RegionEvaluable.)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath | (Inherited from RegionEvaluable.)
Public method | ReadXmlProperties | (Inherited from RegionEvaluable.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | Requests Worksheet to perform evaluation starting from the current Region.Запрашивает лист расчётов инициировать вычисление, начиная с текущего элемента листа. (Inherited from RegionEvaluable.)
Public method | RequestForEvaluation | Obsolete. (Inherited from RegionEvaluable.)
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState | (Inherited from RegionEvaluable.)
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | (Overrides RegionBaseToXml(StorageWriter, FileParsingContext).)
Public method | WriteMath | (Inherited from RegionEvaluable.)
Public method | WriteXmlProperties | (Inherited from RegionEvaluable.)
Top
Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured | (Inherited from RegionEvaluable.)
Public event | EvaluationRequest | (Inherited from RegionEvaluable.)
Public event | EvaluationStateChanged | (Inherited from RegionEvaluable.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description | (Inherited from RegionEvaluable.)
Public field | DescriptionPosition | Obsolete. (Inherited from RegionEvaluable.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Public field | SaveCount |
Public field | SaveIdx |
Protected field | terms | (Inherited from RegionEvaluable.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

SMath.Controls Namespace


MissingRegion Constructor

Initializes a new instance of the MissingRegion class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MissingRegion(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
MissingRegion(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> MissingRegion

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion Properties

The MissingRegion type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDebugTermIndex | (Inherited from RegionEvaluable.)
Public property | Attributes |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | (Inherited from RegionEvaluable.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Inherited from RegionEvaluable.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes | (Inherited from RegionEvaluable.)
Public property | DebugTerms | (Inherited from RegionEvaluable.)
Public property | DeletedValues | (Inherited from RegionEvaluable.)
Public property | Dependences | (Overrides RegionBaseDependences.)
Public property | DescriptionBounds | (Inherited from RegionEvaluable.)
Public property | DescriptionLocation | (Inherited from RegionEvaluable.)
Public property | DescriptionText | (Inherited from RegionEvaluable.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента. (Inherited from RegionEvaluable.)
Public property | ErrorTerm | (Inherited from RegionEvaluable.)
Public property | ErrorText | Текст ошибки элемента. (Inherited from RegionEvaluable.)
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении. (Inherited from RegionEvaluable.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Inherited from RegionEvaluable.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой. (Inherited from RegionEvaluable.)
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент. (Inherited from RegionEvaluable.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionEvaluable.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | Message |
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Inherited from RegionEvaluable.)
Public property | Optimization | (Inherited from RegionEvaluable.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes | (Inherited from RegionEvaluable.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription | (Inherited from RegionEvaluable.)
Public property | Size | Размер элемента управления. (Inherited from RegionEvaluable.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | TagName |
Public property | Terms | Массив элементов математического выражения. (Inherited from RegionEvaluable.)
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values | (Inherited from RegionEvaluable.)
Public property | WarningColor | Цвет предупреждений элемента. (Inherited from RegionEvaluable.)
Top
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.Attributes Property

MissingRegionAttributes Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> Attributes { get; }
Public ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}
member Attributes : Dictionary<string, string> with get

Property Value

Type: DictionaryString, String
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.Dependences Property

MissingRegionDependences Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override List<AssemblyInfo> Dependences { get; set; }
Public Overrides Property Dependences As List(Of AssemblyInfo)
    Get
    Set
public:
virtual property List<AssemblyInfo>^ Dependences {
    List<AssemblyInfo>^ get () override;
    void set (List<AssemblyInfo>^ value) override;
}
abstract Dependences : List<AssemblyInfo> with get, set
override Dependences : List<AssemblyInfo> with get, set

Property Value

Type: ListAssemblyInfo
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.Message Property

MissingRegionMessage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.TagName Property

MissingRegionTagName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string TagName { get; }
Public ReadOnly Property TagName As String
    Get
public:
property String^ TagName {
    String^ get ();
}
member TagName : string with get

Property Value

Type: String
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion Methods

The MissingRegion type exposes the following members.

Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | Checks if it is required to recalculate page due to the element.Проверяет, необходимо ли из-за данного элемента пересчитывать весь лист. (Inherited from RegionEvaluable.)
Protected method | ChildRepainting | (Inherited from RegionEvaluable.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Overrides RegionBaseClone.)
Public method | Copy | (Inherited from RegionEvaluable.)
Public method | CreateDescription | (Inherited from RegionEvaluable.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Overrides RegionBaseFromXml(StorageReader, FileParsingContext).)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetcurrentTermsContainer | (Inherited from RegionEvaluable.)
Public method | GetCursorType | (Inherited from RegionEvaluable.)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Inherited from RegionEvaluable.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionEvaluable.)
Public method | InitLayout(Store) | (Inherited from RegionEvaluable.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Public method | MarkOutOfDate | Obsolete. (Inherited from RegionEvaluable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Inherited from RegionEvaluable.)
Public method | OnCommandSend(Term) | (Inherited from RegionEvaluable.)
Public method | OnEvaluation | (Overrides RegionEvaluableOnEvaluation(Store).)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Inherited from RegionEvaluable.)
Public method | OnMouseMove | (Inherited from RegionEvaluable.)
Public method | OnMouseUp | (Inherited from RegionEvaluable.)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Overrides RegionEvaluableOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Inherited from RegionEvaluable.)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath | (Inherited from RegionEvaluable.)
Public method | ReadXmlProperties | (Inherited from RegionEvaluable.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | Requests Worksheet to perform evaluation starting from the current Region.Запрашивает лист расчётов инициировать вычисление, начиная с текущего элемента листа. (Inherited from RegionEvaluable.)
Public method | RequestForEvaluation | Obsolete. (Inherited from RegionEvaluable.)
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState | (Inherited from RegionEvaluable.)
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | (Overrides RegionBaseToXml(StorageWriter, FileParsingContext).)
Public method | WriteMath | (Inherited from RegionEvaluable.)
Public method | WriteXmlProperties | (Inherited from RegionEvaluable.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.Clone Method

MissingRegionClone Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override RegionBase Clone()
Public Overrides Function Clone As RegionBase
public:
virtual RegionBase^ Clone() override
abstract Clone : unit -> RegionBase
override Clone : unit -> RegionBase

Return Value

Type: RegionBase
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.FromXml Method

MissingRegionFromXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void FromXml(
    StorageReader storage,
    FileParsingContext parsingContext
)
Public Overrides Sub FromXml (
    storage As StorageReader,
    parsingContext As FileParsingContext
)
public:
virtual void FromXml(
    StorageReader^ storage,
    FileParsingContext^ parsingContext
) override
abstract FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit
override FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageReader
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.OnEvaluation Method

MissingRegionOnEvaluation Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnEvaluation(
    Store store
)
Public Overrides Sub OnEvaluation (
    store As Store
)
public:
virtual void OnEvaluation(
    Store^ store
) override
abstract OnEvaluation :
        store : Store -> unit
override OnEvaluation :
        store : Store -> unit

Parameters

store
Type: SMath.MathStore
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.OnPaint Method

MissingRegionOnPaint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnPaint(
    PaintEventOptions e
)
Public Overrides Sub OnPaint (
    e As PaintEventOptions
)
public:
virtual void OnPaint(
    PaintEventOptions^ e
) override
abstract OnPaint :
        e : PaintEventOptions -> unit
override OnPaint :
        e : PaintEventOptions -> unit

Parameters

e
Type: SMath.ManagerPaintEventOptions
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.ToXml Method

MissingRegionToXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    StorageWriter storage,
    FileParsingContext parsingContext
)
Public Overrides Sub ToXml (
    storage As StorageWriter,
    parsingContext As FileParsingContext
)
public:
virtual void ToXml(
    StorageWriter^ storage,
    FileParsingContext^ parsingContext
) override
abstract ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit
override ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageWriter
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion Events

The MissingRegion type exposes the following members.

Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured | (Inherited from RegionEvaluable.)
Public event | EvaluationRequest | (Inherited from RegionEvaluable.)
Public event | EvaluationStateChanged | (Inherited from RegionEvaluable.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion Fields

The MissingRegion type exposes the following members.

Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description | (Inherited from RegionEvaluable.)
Public field | DescriptionPosition | Obsolete. (Inherited from RegionEvaluable.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Public field | SaveCount |
Public field | SaveIdx |
Protected field | terms | (Inherited from RegionEvaluable.)
Top
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.SaveCount Field

MissingRegionSaveCount Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int SaveCount
Public SaveCount As Integer
public:
int SaveCount
val mutable SaveCount: int

Field Value

Type: Int32
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MissingRegion.SaveIdx Field

MissingRegionSaveIdx Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int SaveIdx
Public SaveIdx As Integer
public:
int SaveIdx
val mutable SaveIdx: int

Field Value

Type: Int32
See Also

Reference

MissingRegion Class
SMath.Controls Namespace


MoveDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate TouchSelectionType MoveDelegate(
    PointF pnt,
    float distanceX,
    float distanceY
)
Public Delegate Function MoveDelegate (
    pnt As PointF,
    distanceX As Single,
    distanceY As Single
) As TouchSelectionType
public delegate TouchSelectionType MoveDelegate(
    PointF pnt,
    float distanceX,
    float distanceY
)
type MoveDelegate =
    delegate of
        pnt : PointF *
        distanceX : float32 *
        distanceY : float32 -> TouchSelectionType

Parameters

pnt
Type: System.DrawingPointF
distanceX
Type: SystemSingle
distanceY
Type: SystemSingle

Return Value

Type: TouchSelectionType
See Also

Reference

SMath.Controls Namespace


NonInteractiveWorksheet Class

Non-interactive implementation of the Worksheet. Simplest possible implementation which does not require any overriden methods or properties.
Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheet
SMath.ControlsNonInteractiveWorksheet

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class NonInteractiveWorksheet : Worksheet
Public Class NonInteractiveWorksheet
    Inherits Worksheet
public ref class NonInteractiveWorksheet : public Worksheet
type NonInteractiveWorksheet =
    class
        inherit Worksheet
    end

The NonInteractiveWorksheet type exposes the following members.

Constructors
 | Name | Description
Public method | NonInteractiveWorksheet | Initializes a new instance of the NonInteractiveWorksheet class
Top
Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов. (Inherited from Worksheet.)
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена. (Inherited from Worksheet.)
Public property | ContentSize | (Inherited from Worksheet.)
Public property | CurrentColumnsCount | (Inherited from Worksheet.)
Public property | CurrentContentPlacement | (Inherited from Worksheet.)
Public property | CurrentPage | (Inherited from Worksheet.)
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта. (Inherited from Worksheet.)
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка. (Inherited from Worksheet.)
Public property | Editor | (Inherited from Worksheet.)
Public property | Focused | (Overrides WorksheetFocused.)
Public property | GridSize | (Inherited from Worksheet.)
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет. (Inherited from Worksheet.)
Public property | History | Worksheet changes history.История изменений листа расчётов. (Inherited from Worksheet.)
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода. (Inherited from Worksheet.)
Public property | InvokeRequired | (Inherited from Worksheet.)
Public property | IsDifferentInPlacement | (Inherited from Worksheet.)
Public property | IsInEvalution | Obsolete. (Inherited from Worksheet.)
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке. (Inherited from Worksheet.)
Public property | MetaContext | (Inherited from Worksheet.)
Public property | MetaData | Worksheet meta-data.Мета-данные листа. (Inherited from Worksheet.)
Public property | Mode | (Inherited from Worksheet.)
Public property | MultiplePages | (Inherited from Worksheet.)
Public property | ObjectsManager | (Inherited from Worksheet.)
Public property | PageIndex | (Inherited from Worksheet.)
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов. (Inherited from Worksheet.)
Public property | PagesCount | (Inherited from Worksheet.)
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта. (Inherited from Worksheet.)
Public property | Params | (Inherited from Worksheet.)
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте. (Inherited from Worksheet.)
Public property | ScrollSize | (Inherited from Worksheet.)
Public property | Search | (Inherited from Worksheet.)
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from Worksheet.)
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа. (Inherited from Worksheet.)
Public property | Status | Status of the worksheet.Статус листа расчётов. (Inherited from Worksheet.)
Top
Methods
 | Name | Description
Public method | AddBreakpoint | (Inherited from Worksheet.)
Public method | ApplyInitialDefinitions | (Inherited from Worksheet.)
Public method | Clear | (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт. (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete. (Inherited from Worksheet.)
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) | (Inherited from Worksheet.)
Public method | CreateStore | (Inherited from Worksheet.)
Public method | Dispose | (Inherited from Worksheet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(Int32) | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(RegionsList, Int32) | (Inherited from Worksheet.)
Public method | GetCurrentStore | (Inherited from Worksheet.)
Public method | GetCurrentTooltip | (Inherited from Worksheet.)
Public method | GetCursorType | Defines a mouse cursor type at the specific position on the worksheet.Определение вида курсора в определённом месте листа. (Inherited from Worksheet.)
Public method | GetEvaluationContext | (Inherited from Worksheet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams | (Inherited from Worksheet.)
Public method | GetPreviouslyDefinedParamsAll | (Inherited from Worksheet.)
Public method | GetRegionIndex | (Inherited from Worksheet.)
Public method | GetRegionsBounds | Calculates bounds of the selected Regions. (Inherited from Worksheet.)
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа. (Inherited from Worksheet.)
Public method | GetStaticContextMenuItems | (Inherited from Worksheet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionsList, Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GotFocus | (Inherited from Worksheet.)
Public method | HideCursorIfRequired | (Inherited from Worksheet.)
Public method | HideError | (Overrides WorksheetHideError.)
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов. (Inherited from Worksheet.)
Public method | Insert(ButtonAction) | (Inherited from Worksheet.)
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region. (Inherited from Worksheet.)
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Public method | Invoke | (Inherited from Worksheet.)
Public method | LockRegion | (Inherited from Worksheet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown | Mouse button down event handler.Реакция на событие нажатия клавиши мыши. (Inherited from Worksheet.)
Protected method | MouseMove | Mouse cursor move event handler.Реакция на событие движения курсора мыши. (Inherited from Worksheet.)
Protected method | MouseUp | Mouse button up event handler.Реакция на событие отпускания клавиши мыши. (Inherited from Worksheet.)
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши. (Inherited from Worksheet.)
Protected method | PageStatusManager | (Inherited from Worksheet.)
Public method | RefreshContent | (Inherited from Worksheet.)
Public method | RefreshUI | (Inherited from Worksheet.)
Public method | RemoveRegions(RegionBase) | (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа. (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) | (Inherited from Worksheet.)
Protected method | Resize | Изменение размеров элемента. (Inherited from Worksheet.)
Public method | ResumeLayout | (Inherited from Worksheet.)
Public method | Scroll | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required. (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region. (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, RectangleF) | (Inherited from Worksheet.)
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента. (Inherited from Worksheet.)
Public method | SetDebuggerMode | (Inherited from Worksheet.)
Public method | SetRegionBorder | (Inherited from Worksheet.)
Public method | SetRegionColor | (Inherited from Worksheet.)
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings. (Inherited from Worksheet.)
Public method | SetRegionFontFamily | (Inherited from Worksheet.)
Public method | SetRegionFontSize | (Inherited from Worksheet.)
Public method | ShowCursorIfRequired | (Inherited from Worksheet.)
Public method | ShowError | (Overrides WorksheetShowError(RegionEvaluable, Boolean).)
Protected method | SnapToGrid | (Inherited from Worksheet.)
Public method | SortRegions | (Inherited from Worksheet.)
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа. (Inherited from Worksheet.)
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время. (Inherited from Worksheet.)
Public method | SuppressLayout | (Inherited from Worksheet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов. (Inherited from Worksheet.)
Public method | UnfocusRegions | (Inherited from Worksheet.)
Public method | UnlockRegion | (Inherited from Worksheet.)
Public method | UpdatePageModel | (Inherited from Worksheet.)
Public method | UpdateScrollBars | (Inherited from Worksheet.)
Public method | VerifyLanguageNotifier | (Inherited from Worksheet.)
Top
Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad | (Inherited from Worksheet.)
Public event | OnCurrentRegionChanged | (Inherited from Worksheet.)
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки. (Inherited from Worksheet.)
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки. (Inherited from Worksheet.)
Public event | OnFileContextLoad | (Inherited from Worksheet.)
Public event | OnMenuButtonEmulated | (Inherited from Worksheet.)
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля. (Inherited from Worksheet.)
Public event | OnProgressChanged | (Inherited from Worksheet.)
Public event | OnRegionCreated | (Inherited from Worksheet.)
Public event | OnStatusChanged | (Inherited from Worksheet.)
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа. (Inherited from Worksheet.)
Top
See Also

Reference

SMath.Controls Namespace


NonInteractiveWorksheet Constructor

Initializes a new instance of the NonInteractiveWorksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public NonInteractiveWorksheet(
    SessionProfile sessionProfile,
    PresentationMode mode
)
Public Sub New (
    sessionProfile As SessionProfile,
    mode As PresentationMode
)
public:
NonInteractiveWorksheet(
    SessionProfile^ sessionProfile,
    PresentationMode mode
)
new :
        sessionProfile : SessionProfile *
        mode : PresentationMode -> NonInteractiveWorksheet

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
mode
Type: SMath.ControlsPresentationMode
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet Properties

The NonInteractiveWorksheet type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов. (Inherited from Worksheet.)
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена. (Inherited from Worksheet.)
Public property | ContentSize | (Inherited from Worksheet.)
Public property | CurrentColumnsCount | (Inherited from Worksheet.)
Public property | CurrentContentPlacement | (Inherited from Worksheet.)
Public property | CurrentPage | (Inherited from Worksheet.)
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта. (Inherited from Worksheet.)
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка. (Inherited from Worksheet.)
Public property | Editor | (Inherited from Worksheet.)
Public property | Focused | (Overrides WorksheetFocused.)
Public property | GridSize | (Inherited from Worksheet.)
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет. (Inherited from Worksheet.)
Public property | History | Worksheet changes history.История изменений листа расчётов. (Inherited from Worksheet.)
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода. (Inherited from Worksheet.)
Public property | InvokeRequired | (Inherited from Worksheet.)
Public property | IsDifferentInPlacement | (Inherited from Worksheet.)
Public property | IsInEvalution | Obsolete. (Inherited from Worksheet.)
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке. (Inherited from Worksheet.)
Public property | MetaContext | (Inherited from Worksheet.)
Public property | MetaData | Worksheet meta-data.Мета-данные листа. (Inherited from Worksheet.)
Public property | Mode | (Inherited from Worksheet.)
Public property | MultiplePages | (Inherited from Worksheet.)
Public property | ObjectsManager | (Inherited from Worksheet.)
Public property | PageIndex | (Inherited from Worksheet.)
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов. (Inherited from Worksheet.)
Public property | PagesCount | (Inherited from Worksheet.)
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта. (Inherited from Worksheet.)
Public property | Params | (Inherited from Worksheet.)
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте. (Inherited from Worksheet.)
Public property | ScrollSize | (Inherited from Worksheet.)
Public property | Search | (Inherited from Worksheet.)
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from Worksheet.)
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа. (Inherited from Worksheet.)
Public property | Status | Status of the worksheet.Статус листа расчётов. (Inherited from Worksheet.)
Top
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet.Focused Property

NonInteractiveWorksheetFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Focused { get; }
Public Overrides ReadOnly Property Focused As Boolean
    Get
public:
virtual property bool Focused {
    bool get () override;
}
abstract Focused : bool with get
override Focused : bool with get

Property Value

Type: Boolean

Implements

IDocumentTFocused
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet Methods

The NonInteractiveWorksheet type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | (Inherited from Worksheet.)
Public method | ApplyInitialDefinitions | (Inherited from Worksheet.)
Public method | Clear | (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт. (Inherited from Worksheet.)
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete. (Inherited from Worksheet.)
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) | (Inherited from Worksheet.)
Public method | CreateStore | (Inherited from Worksheet.)
Public method | Dispose | (Inherited from Worksheet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(Int32) | (Inherited from Worksheet.)
Public method | GetCollapsedHeight(RegionsList, Int32) | (Inherited from Worksheet.)
Public method | GetCurrentStore | (Inherited from Worksheet.)
Public method | GetCurrentTooltip | (Inherited from Worksheet.)
Public method | GetCursorType | Defines a mouse cursor type at the specific position on the worksheet.Определение вида курсора в определённом месте листа. (Inherited from Worksheet.)
Public method | GetEvaluationContext | (Inherited from Worksheet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams | (Inherited from Worksheet.)
Public method | GetPreviouslyDefinedParamsAll | (Inherited from Worksheet.)
Public method | GetRegionIndex | (Inherited from Worksheet.)
Public method | GetRegionsBounds | Calculates bounds of the selected Regions. (Inherited from Worksheet.)
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа. (Inherited from Worksheet.)
Public method | GetStaticContextMenuItems | (Inherited from Worksheet.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GetWorksheetPage(RegionsList, Int32, Int32) | (Inherited from Worksheet.)
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object. (Inherited from Worksheet.)
Public method | GotFocus | (Inherited from Worksheet.)
Public method | HideCursorIfRequired | (Inherited from Worksheet.)
Public method | HideError | (Overrides WorksheetHideError.)
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов. (Inherited from Worksheet.)
Public method | Insert(ButtonAction) | (Inherited from Worksheet.)
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region. (Inherited from Worksheet.)
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Public method | Invoke | (Inherited from Worksheet.)
Public method | LockRegion | (Inherited from Worksheet.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown | Mouse button down event handler.Реакция на событие нажатия клавиши мыши. (Inherited from Worksheet.)
Protected method | MouseMove | Mouse cursor move event handler.Реакция на событие движения курсора мыши. (Inherited from Worksheet.)
Protected method | MouseUp | Mouse button up event handler.Реакция на событие отпускания клавиши мыши. (Inherited from Worksheet.)
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши. (Inherited from Worksheet.)
Protected method | PageStatusManager | (Inherited from Worksheet.)
Public method | RefreshContent | (Inherited from Worksheet.)
Public method | RefreshUI | (Inherited from Worksheet.)
Public method | RemoveRegions(RegionBase) | (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа. (Inherited from Worksheet.)
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) | (Inherited from Worksheet.)
Protected method | Resize | Изменение размеров элемента. (Inherited from Worksheet.)
Public method | ResumeLayout | (Inherited from Worksheet.)
Public method | Scroll | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required. (Inherited from Worksheet.)
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) | (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region. (Inherited from Worksheet.)
Public method | ScrollToRegion(RegionBase, RectangleF) | (Inherited from Worksheet.)
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента. (Inherited from Worksheet.)
Public method | SetDebuggerMode | (Inherited from Worksheet.)
Public method | SetRegionBorder | (Inherited from Worksheet.)
Public method | SetRegionColor | (Inherited from Worksheet.)
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings. (Inherited from Worksheet.)
Public method | SetRegionFontFamily | (Inherited from Worksheet.)
Public method | SetRegionFontSize | (Inherited from Worksheet.)
Public method | ShowCursorIfRequired | (Inherited from Worksheet.)
Public method | ShowError | (Overrides WorksheetShowError(RegionEvaluable, Boolean).)
Protected method | SnapToGrid | (Inherited from Worksheet.)
Public method | SortRegions | (Inherited from Worksheet.)
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа. (Inherited from Worksheet.)
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время. (Inherited from Worksheet.)
Public method | SuppressLayout | (Inherited from Worksheet.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов. (Inherited from Worksheet.)
Public method | UnfocusRegions | (Inherited from Worksheet.)
Public method | UnlockRegion | (Inherited from Worksheet.)
Public method | UpdatePageModel | (Inherited from Worksheet.)
Public method | UpdateScrollBars | (Inherited from Worksheet.)
Public method | VerifyLanguageNotifier | (Inherited from Worksheet.)
Top
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet.HideError Method

NonInteractiveWorksheetHideError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void HideError()
Public Overrides Sub HideError
public:
virtual void HideError() override
abstract HideError : unit -> unit
override HideError : unit -> unit

Implements

IDocumentTHideError
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet.Invalidate Method

NonInteractiveWorksheetInvalidate Method

Overload List
 | Name | Description
Public method | Invalidate | (Overrides WorksheetInvalidate.)
Public method | Invalidate(Rectangle) | (Overrides WorksheetInvalidate(Rectangle).)
Public method | Invalidate(Int32, Int32, Int32, Int32) | (Inherited from Worksheet.)
Top
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet.Invalidate Method

NonInteractiveWorksheetInvalidate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Invalidate()
Public Overrides Sub Invalidate
public:
virtual void Invalidate() override
abstract Invalidate : unit -> unit
override Invalidate : unit -> unit

Implements

IDocumentTInvalidate
See Also

Reference

NonInteractiveWorksheet Class
Invalidate Overload
SMath.Controls Namespace


NonInteractiveWorksheet.Invalidate Method (Rectangle)

NonInteractiveWorksheetInvalidate Method (Rectangle)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Invalidate(
    Rectangle rect
)
Public Overrides Sub Invalidate (
    rect As Rectangle
)
public:
virtual void Invalidate(
    Rectangle rect
) override
abstract Invalidate :
        rect : Rectangle -> unit
override Invalidate :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
See Also

Reference

NonInteractiveWorksheet Class
Invalidate Overload
SMath.Controls Namespace


NonInteractiveWorksheet.ShowError Method

NonInteractiveWorksheetShowError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void ShowError(
    RegionEvaluable region,
    bool v
)
Public Overrides Sub ShowError (
    region As RegionEvaluable,
    v As Boolean
)
public:
virtual void ShowError(
    RegionEvaluable^ region,
    bool v
) override
abstract ShowError :
        region : RegionEvaluable *
        v : bool -> unit
override ShowError :
        region : RegionEvaluable *
        v : bool -> unit

Parameters

region
Type: SMath.ControlsRegionEvaluable
v
Type: SystemBoolean
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


NonInteractiveWorksheet Events

The NonInteractiveWorksheet type exposes the following members.

Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad | (Inherited from Worksheet.)
Public event | OnCurrentRegionChanged | (Inherited from Worksheet.)
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки. (Inherited from Worksheet.)
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки. (Inherited from Worksheet.)
Public event | OnFileContextLoad | (Inherited from Worksheet.)
Public event | OnMenuButtonEmulated | (Inherited from Worksheet.)
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля. (Inherited from Worksheet.)
Public event | OnProgressChanged | (Inherited from Worksheet.)
Public event | OnRegionCreated | (Inherited from Worksheet.)
Public event | OnStatusChanged | (Inherited from Worksheet.)
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа. (Inherited from Worksheet.)
Top
See Also

Reference

NonInteractiveWorksheet Class
SMath.Controls Namespace


ObjectsEnumerator(T) Class

ObjectsEnumeratorT Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsEnumeratorT
SMath.ControlsRegionsEnumerator

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ObjectsEnumerator<T> : IEnumerator<T>,
    IDisposable, IEnumerator
where T : IDocumentObject

Public MustInherit Class ObjectsEnumerator(Of T As IDocumentObject)
    Implements IEnumerator(Of T), IDisposable, IEnumerator
generic<typename T>
where T : IDocumentObject
public ref class ObjectsEnumerator abstract : IEnumerator<T>,
    IDisposable, IEnumerator
[<AbstractClassAttribute>]
type ObjectsEnumerator<'T when 'T : IDocumentObject> =
    class
        interface IEnumerator<'T>
        interface IDisposable
        interface IEnumerator
    end

Type Parameters

T

The ObjectsEnumeratorT type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectsEnumeratorT(ListT, ContentPlacement) | Initializes a new instance of the ObjectsEnumeratorT class
Protected method | ObjectsEnumeratorT(ObjectsEnumeratorT, Int32) | Initializes a new instance of the ObjectsEnumeratorT class
Top
Properties
 | Name | Description
Public property | AbsoluteLocation | Absolute location of the Object on the Document depending on the start Object.Абсолютная позиция элемента на документе на основе первого элемента перечисления.
Public property | CollapsedHeight | Gets an invisible distance hidden by collapsed Area Objects above the current Object.Возвращает расстояние скрытое закрытыми областями перед текущим элементом документа.
Public property | Current | Gets the current Object.Возвращает текущий элемент.
Public property | CurrentIndex | Gets the current Object index.Возвращает индекс текущего элемента.
Public property | Depth | Gets depth of the Object inside nested Areas.Возвращает глубину элемента внутри вложенных Областей.
Public property | Evaluable | Gets evaluation status of the Object.Возвращает статус возможности вычисления элемента.
Public property | FilterAllAfter | Gets or sets an index of the last Object to retrieve.Возвращает или задаёт индекс последнего элемента для получения.
Public property | FilterAllBefore | Gets or sets an index of the first Object to retrieve.Возвращает или задаёт индекс первого элемента для получения.
Public property | FilterDeactivated | Defines if the enumerator should hide all deactivated (not added to the Document) Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться деактивированные (не зарегистрированные на документе) элементы документа.
Public property | FilterInvisible | Gets or sets a value that determines if Enumerator will filter out Invisible Objects or not (invisible means that Object is hidden by collapsed Area Objects).Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться элементы документа, скрытые регионами типа Область.
Public property | FilterNonEvaluable | Gets or sets a value that determines if Enumerator will filter out not evaluable Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не вычисляемые элементы документы.
Public property | FilterNonSelected | Gets or sets a value that determines if Enumerator will filter out not selected Objects or not.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не выделенные элементы документа.
Public property | LastIndex | Gets the last Object index. It doesn't check availability of the Object.Возвращает индекс последнего элемента. Проверки на доступность элемента не производится.
Public property | Placement |
Public property | Protected | Gets protection status of the Object (Object is protected if it is included to the locked Area Object).Возвращает статус защищённости элемента (элемент считается защищённым если он находится внутри заблокированной Области).
Public property | Selected | Gets selection status of the Object.Возвращает статус выделения элемента.
Public property | Visible | Gets visibility of the current Object on the Document (visible means that Object is not hidden by collapsed Area Objects).Возвращает видимость текущего элемента на документе (определяет скрыт ли текущий элемент закрытой Областью или нет).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeCurrent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | Reset |
Public method | RestartState |
Public method | SaveState |
Public method | SetFakeCollapsedArea |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorTCurrent |
Explicit interface implementation | IEnumeratorCurrent |
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

SMath.Controls Namespace


ObjectsEnumerator(T) Constructor

ObjectsEnumeratorT Constructor

Overload List
 | Name | Description
Public method | ObjectsEnumeratorT(ListT, ContentPlacement) | Initializes a new instance of the ObjectsEnumeratorT class
Protected method | ObjectsEnumeratorT(ObjectsEnumeratorT, Int32) | Initializes a new instance of the ObjectsEnumeratorT class
Top
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T) Constructor (List(T), ContentPlacement)

ObjectsEnumeratorT Constructor (ListT, ContentPlacement)

Initializes a new instance of the ObjectsEnumeratorT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ObjectsEnumerator(
    List<T> objects,
    ContentPlacement placement
)
Public Sub New (
    objects As List(Of T),
    placement As ContentPlacement
)
public:
ObjectsEnumerator(
    List<T>^ objects,
    ContentPlacement placement
)
new :
        objects : List<'T> *
        placement : ContentPlacement -> ObjectsEnumerator

Parameters

objects
Type: System.Collections.GenericListT
placement
Type: SMath.ManagerContentPlacement
See Also

Reference

ObjectsEnumeratorT Class
ObjectsEnumeratorT Overload
SMath.Controls Namespace


ObjectsEnumerator(T) Constructor (ObjectsEnumerator(T), Int32)

ObjectsEnumeratorT Constructor (ObjectsEnumeratorT, Int32)

Initializes a new instance of the ObjectsEnumeratorT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ObjectsEnumerator(
    ObjectsEnumerator<T> enumerator,
    int stopIndex
)
Protected Sub New (
    enumerator As ObjectsEnumerator(Of T),
    stopIndex As Integer
)
protected:
ObjectsEnumerator(
    ObjectsEnumerator<T>^ enumerator,
    int stopIndex
)
new :
        enumerator : ObjectsEnumerator<'T> *
        stopIndex : int -> ObjectsEnumerator

Parameters

enumerator
Type: SMath.ControlsObjectsEnumerator T
stopIndex
Type: SystemInt32
See Also

Reference

ObjectsEnumeratorT Class
ObjectsEnumeratorT Overload
SMath.Controls Namespace


ObjectsEnumerator(T) Properties

ObjectsEnumeratorT Properties

The ObjectsEnumeratorT generic type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteLocation | Absolute location of the Object on the Document depending on the start Object.Абсолютная позиция элемента на документе на основе первого элемента перечисления.
Public property | CollapsedHeight | Gets an invisible distance hidden by collapsed Area Objects above the current Object.Возвращает расстояние скрытое закрытыми областями перед текущим элементом документа.
Public property | Current | Gets the current Object.Возвращает текущий элемент.
Public property | CurrentIndex | Gets the current Object index.Возвращает индекс текущего элемента.
Public property | Depth | Gets depth of the Object inside nested Areas.Возвращает глубину элемента внутри вложенных Областей.
Public property | Evaluable | Gets evaluation status of the Object.Возвращает статус возможности вычисления элемента.
Public property | FilterAllAfter | Gets or sets an index of the last Object to retrieve.Возвращает или задаёт индекс последнего элемента для получения.
Public property | FilterAllBefore | Gets or sets an index of the first Object to retrieve.Возвращает или задаёт индекс первого элемента для получения.
Public property | FilterDeactivated | Defines if the enumerator should hide all deactivated (not added to the Document) Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться деактивированные (не зарегистрированные на документе) элементы документа.
Public property | FilterInvisible | Gets or sets a value that determines if Enumerator will filter out Invisible Objects or not (invisible means that Object is hidden by collapsed Area Objects).Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться элементы документа, скрытые регионами типа Область.
Public property | FilterNonEvaluable | Gets or sets a value that determines if Enumerator will filter out not evaluable Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не вычисляемые элементы документы.
Public property | FilterNonSelected | Gets or sets a value that determines if Enumerator will filter out not selected Objects or not.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не выделенные элементы документа.
Public property | LastIndex | Gets the last Object index. It doesn't check availability of the Object.Возвращает индекс последнего элемента. Проверки на доступность элемента не производится.
Public property | Placement |
Public property | Protected | Gets protection status of the Object (Object is protected if it is included to the locked Area Object).Возвращает статус защищённости элемента (элемент считается защищённым если он находится внутри заблокированной Области).
Public property | Selected | Gets selection status of the Object.Возвращает статус выделения элемента.
Public property | Visible | Gets visibility of the current Object on the Document (visible means that Object is not hidden by collapsed Area Objects).Возвращает видимость текущего элемента на документе (определяет скрыт ли текущий элемент закрытой Областью или нет).
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorTCurrent |
Explicit interface implementation | IEnumeratorCurrent |
Top
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).IEnumerator(T).Current Property

ObjectsEnumeratorTIEnumeratorTCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
T IEnumerator<T>.Current { get; }
Private ReadOnly Property Current As T
    Implements IEnumerator(Of T).Current
    Get
private:
virtual property T Current {
    T get () sealed = IEnumerator<T>::Current::get;
}
private abstract Current : 'T with get
private override Current : 'T with get

Property Value

Type: T

Implements

IEnumeratorTCurrent
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).IEnumerator.Current Property

ObjectsEnumeratorTIEnumeratorCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Object

Implements

IEnumeratorCurrent
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).AbsoluteLocation Property

ObjectsEnumeratorTAbsoluteLocation Property

Absolute location of the Object on the Document depending on the start Object.Абсолютная позиция элемента на документе на основе первого элемента перечисления.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Point AbsoluteLocation { get; }
Public ReadOnly Property AbsoluteLocation As Point
    Get
public:
property Point AbsoluteLocation {
    Point get ();
}
member AbsoluteLocation : Point with get

Property Value

Type: Point
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).CollapsedHeight Property

ObjectsEnumeratorTCollapsedHeight Property

Gets an invisible distance hidden by collapsed Area Objects above the current Object.Возвращает расстояние скрытое закрытыми областями перед текущим элементом документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CollapsedHeight { get; }
Public ReadOnly Property CollapsedHeight As Integer
    Get
public:
property int CollapsedHeight {
    int get ();
}
member CollapsedHeight : int with get

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Current Property

ObjectsEnumeratorTCurrent Property

Gets the current Object.Возвращает текущий элемент.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T Current { get; protected set; }
Public Property Current As T
    Get
    Protected Set
public:
property T Current {
    T get ();
    protected: void set (T value);
}
member Current : 'T with get, set

Property Value

Type: T
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).CurrentIndex Property

ObjectsEnumeratorTCurrentIndex Property

Gets the current Object index.Возвращает индекс текущего элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentIndex { get; protected set; }
Public Property CurrentIndex As Integer
    Get
    Protected Set
public:
property int CurrentIndex {
    int get ();
    protected: void set (int value);
}
member CurrentIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Depth Property

ObjectsEnumeratorTDepth Property

Gets depth of the Object inside nested Areas.Возвращает глубину элемента внутри вложенных Областей.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Depth { get; protected set; }
Public Property Depth As Integer
    Get
    Protected Set
public:
property int Depth {
    int get ();
    protected: void set (int value);
}
member Depth : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Evaluable Property

ObjectsEnumeratorTEvaluable Property

Gets evaluation status of the Object.Возвращает статус возможности вычисления элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Evaluable { get; protected set; }
Public Property Evaluable As Boolean
    Get
    Protected Set
public:
property bool Evaluable {
    bool get ();
    protected: void set (bool value);
}
member Evaluable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterAllAfter Property

ObjectsEnumeratorTFilterAllAfter Property

Gets or sets an index of the last Object to retrieve.Возвращает или задаёт индекс последнего элемента для получения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int FilterAllAfter { get; set; }
Public Property FilterAllAfter As Integer
    Get
    Set
public:
property int FilterAllAfter {
    int get ();
    void set (int value);
}
member FilterAllAfter : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterAllBefore Property

ObjectsEnumeratorTFilterAllBefore Property

Gets or sets an index of the first Object to retrieve.Возвращает или задаёт индекс первого элемента для получения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int FilterAllBefore { get; set; }
Public Property FilterAllBefore As Integer
    Get
    Set
public:
property int FilterAllBefore {
    int get ();
    void set (int value);
}
member FilterAllBefore : int with get, set

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterDeactivated Property

ObjectsEnumeratorTFilterDeactivated Property

Defines if the enumerator should hide all deactivated (not added to the Document) Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться деактивированные (не зарегистрированные на документе) элементы документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterDeactivated { get; set; }
Public Property FilterDeactivated As Boolean
    Get
    Set
public:
property bool FilterDeactivated {
    bool get ();
    void set (bool value);
}
member FilterDeactivated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterInvisible Property

ObjectsEnumeratorTFilterInvisible Property

Gets or sets a value that determines if Enumerator will filter out Invisible Objects or not (invisible means that Object is hidden by collapsed Area Objects).Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться элементы документа, скрытые регионами типа Область.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterInvisible { get; set; }
Public Property FilterInvisible As Boolean
    Get
    Set
public:
property bool FilterInvisible {
    bool get ();
    void set (bool value);
}
member FilterInvisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterNonEvaluable Property

ObjectsEnumeratorTFilterNonEvaluable Property

Gets or sets a value that determines if Enumerator will filter out not evaluable Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не вычисляемые элементы документы.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterNonEvaluable { get; set; }
Public Property FilterNonEvaluable As Boolean
    Get
    Set
public:
property bool FilterNonEvaluable {
    bool get ();
    void set (bool value);
}
member FilterNonEvaluable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).FilterNonSelected Property

ObjectsEnumeratorTFilterNonSelected Property

Gets or sets a value that determines if Enumerator will filter out not selected Objects or not.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не выделенные элементы документа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool FilterNonSelected { get; set; }
Public Property FilterNonSelected As Boolean
    Get
    Set
public:
property bool FilterNonSelected {
    bool get ();
    void set (bool value);
}
member FilterNonSelected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).LastIndex Property

ObjectsEnumeratorTLastIndex Property

Gets the last Object index. It doesn't check availability of the Object.Возвращает индекс последнего элемента. Проверки на доступность элемента не производится.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int LastIndex { get; }
Public ReadOnly Property LastIndex As Integer
    Get
public:
property int LastIndex {
    int get ();
}
member LastIndex : int with get

Property Value

Type: Int32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Placement Property

ObjectsEnumeratorTPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContentPlacement Placement { get; set; }
Public Property Placement As ContentPlacement
    Get
    Set
public:
property ContentPlacement Placement {
    ContentPlacement get ();
    void set (ContentPlacement value);
}
member Placement : ContentPlacement with get, set

Property Value

Type: ContentPlacement
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Protected Property

ObjectsEnumeratorTProtected Property

Gets protection status of the Object (Object is protected if it is included to the locked Area Object).Возвращает статус защищённости элемента (элемент считается защищённым если он находится внутри заблокированной Области).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Protected { get; protected set; }
Public Property Protected As Boolean
    Get
    Protected Set
public:
property bool Protected {
    bool get ();
    protected: void set (bool value);
}
member Protected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Selected Property

ObjectsEnumeratorTSelected Property

Gets selection status of the Object.Возвращает статус выделения элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; protected set; }
Public Property Selected As Boolean
    Get
    Protected Set
public:
property bool Selected {
    bool get ();
    protected: void set (bool value);
}
member Selected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Visible Property

ObjectsEnumeratorTVisible Property

Gets visibility of the current Object on the Document (visible means that Object is not hidden by collapsed Area Objects).Возвращает видимость текущего элемента на документе (определяет скрыт ли текущий элемент закрытой Областью или нет).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; protected set; }
Public Property Visible As Boolean
    Get
    Protected Set
public:
property bool Visible {
    bool get ();
    protected: void set (bool value);
}
member Visible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T) Methods

ObjectsEnumeratorT Methods

The ObjectsEnumeratorT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MakeCurrent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | Reset |
Public method | RestartState |
Public method | SaveState |
Public method | SetFakeCollapsedArea |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).IDisposable.Dispose Method

ObjectsEnumeratorTIDisposableDispose Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).GetEnumerator Method

ObjectsEnumeratorTGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
IEnumerator<T>^ GetEnumerator()
member GetEnumerator : unit -> IEnumerator<'T>

Return Value

Type: IEnumeratorT
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).GetSubEnumerator Method

ObjectsEnumeratorTGetSubEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract ObjectsEnumerator<T> GetSubEnumerator(
    int stopIndex
)
Public MustOverride Function GetSubEnumerator (
    stopIndex As Integer
) As ObjectsEnumerator(Of T)
public:
virtual ObjectsEnumerator<T>^ GetSubEnumerator(
    int stopIndex
) abstract
abstract GetSubEnumerator :
        stopIndex : int -> ObjectsEnumerator<'T>

Parameters

stopIndex
Type: SystemInt32

Return Value

Type: ObjectsEnumerator T
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).MakeCurrent Method

ObjectsEnumeratorTMakeCurrent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual bool MakeCurrent(
    T obj
)
Protected Overridable Function MakeCurrent (
    obj As T
) As Boolean
protected:
virtual bool MakeCurrent(
    T obj
)
abstract MakeCurrent :
        obj : 'T -> bool
override MakeCurrent :
        obj : 'T -> bool

Parameters

obj
Type: T

Return Value

Type: Boolean
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).MoveNext Method

ObjectsEnumeratorTMoveNext Method

Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Type: Boolean
Returns true if next Object available, otherwise false.Возвращает истину, если следующий элемент доступен, в противном случае возвращает ложь.

Implements

IEnumeratorMoveNext
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).Reset Method

ObjectsEnumeratorTReset Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).RestartState Method

ObjectsEnumeratorTRestartState Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RestartState()
Public Sub RestartState
public:
void RestartState()
member RestartState : unit -> unit
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).SaveState Method

ObjectsEnumeratorTSaveState Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SaveState()
Public Sub SaveState
public:
void SaveState()
member SaveState : unit -> unit
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsEnumerator(T).SetFakeCollapsedArea Method

ObjectsEnumeratorTSetFakeCollapsedArea Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetFakeCollapsedArea(
    int y
)
Public Sub SetFakeCollapsedArea (
    y As Integer
)
public:
void SetFakeCollapsedArea(
    int y
)
member SetFakeCollapsedArea :
        y : int -> unit

Parameters

y
Type: SystemInt32
See Also

Reference

ObjectsEnumeratorT Class
SMath.Controls Namespace


ObjectsList(T) Class

ObjectsListT Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsListT
SMath.ControlsRegionsList

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ObjectsList<T>
where T : IDocumentObject

Public MustInherit Class ObjectsList(Of T As IDocumentObject)
generic<typename T>
where T : IDocumentObject
public ref class ObjectsList abstract
[<AbstractClassAttribute>]
type ObjectsList<'T when 'T : IDocumentObject> =  class end

Type Parameters

T

The ObjectsListT type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectsListT | Initializes a new instance of the ObjectsListT class
Top
Properties
 | Name | Description
Public property | PagesCount |
Public property | Placement |
Public property | StartingFromPage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) |
Public method | IsApplicable(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


ObjectsList(T) Constructor

ObjectsListT Constructor

Initializes a new instance of the ObjectsListT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ObjectsList(
    List<T> objects,
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
Public Sub New (
    objects As List(Of T),
    placement As ContentPlacement,
    startingFromPage As Integer,
    pagesCount As Integer
)
public:
ObjectsList(
    List<T>^ objects,
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
new :
        objects : List<'T> *
        placement : ContentPlacement *
        startingFromPage : int *
        pagesCount : int -> ObjectsList

Parameters

objects
Type: System.Collections.GenericListT
placement
Type: SMath.ManagerContentPlacement
startingFromPage
Type: SystemInt32
pagesCount
Type: SystemInt32
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T) Properties

ObjectsListT Properties

The ObjectsListT generic type exposes the following members.

Properties
 | Name | Description
Public property | PagesCount |
Public property | Placement |
Public property | StartingFromPage |
Top
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T).PagesCount Property

ObjectsListTPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; }
Public ReadOnly Property PagesCount As Integer
    Get
public:
property int PagesCount {
    int get ();
}
member PagesCount : int with get

Property Value

Type: Int32
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T).Placement Property

ObjectsListTPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContentPlacement Placement { get; }
Public ReadOnly Property Placement As ContentPlacement
    Get
public:
property ContentPlacement Placement {
    ContentPlacement get ();
}
member Placement : ContentPlacement with get

Property Value

Type: ContentPlacement
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T).StartingFromPage Property

ObjectsListTStartingFromPage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int StartingFromPage { get; }
Public ReadOnly Property StartingFromPage As Integer
    Get
public:
property int StartingFromPage {
    int get ();
}
member StartingFromPage : int with get

Property Value

Type: Int32
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T) Methods

ObjectsListT Methods

The ObjectsListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) |
Public method | IsApplicable(Int32, Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T).IsApplicable Method

ObjectsListTIsApplicable Method

Overload List
 | Name | Description
Public method | IsApplicable(Int32) |
Public method | IsApplicable(Int32, Int32) |
Top
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsList(T).IsApplicable Method (Int32)

ObjectsListTIsApplicable Method (Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsApplicable(
    int pageIndex
)
Public Function IsApplicable (
    pageIndex As Integer
) As Boolean
public:
bool IsApplicable(
    int pageIndex
)
member IsApplicable :
        pageIndex : int -> bool

Parameters

pageIndex
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ObjectsListT Class
IsApplicable Overload
SMath.Controls Namespace


ObjectsList(T).IsApplicable Method (Int32, Int32)

ObjectsListTIsApplicable Method (Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsApplicable(
    int startingFromPage,
    int pageIndex
)
Public Function IsApplicable (
    startingFromPage As Integer,
    pageIndex As Integer
) As Boolean
public:
bool IsApplicable(
    int startingFromPage,
    int pageIndex
)
member IsApplicable :
        startingFromPage : int *
        pageIndex : int -> bool

Parameters

startingFromPage
Type: SystemInt32
pageIndex
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ObjectsListT Class
IsApplicable Overload
SMath.Controls Namespace


ObjectsList(T).Push Method

ObjectsListTPush Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Push(
    T obj
)
Public Overridable Sub Push (
    obj As T
)
public:
virtual void Push(
    T obj
)
abstract Push :
        obj : 'T -> unit
override Push :
        obj : 'T -> unit

Parameters

obj
Type: T
See Also

Reference

ObjectsListT Class
SMath.Controls Namespace


ObjectsManager(T) Class

ObjectsManagerT Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsManagerT
SMath.ControlsRegionsManagerInternal

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class ObjectsManager<T> : IObjectsManager<T>
where T : IDocumentObject

Public MustInherit Class ObjectsManager(Of T As IDocumentObject)
    Implements IObjectsManager(Of T)
generic<typename T>
where T : IDocumentObject
public ref class ObjectsManager abstract : IObjectsManager<T>
[<AbstractClassAttribute>]
type ObjectsManager<'T when 'T : IDocumentObject> =
    class
        interface IObjectsManager<'T>
    end

Type Parameters

T

The ObjectsManagerT type exposes the following members.

Constructors
 | Name | Description
Protected method | ObjectsManagerT | Initializes a new instance of the ObjectsManagerT class
Top
Properties
 | Name | Description
Public property | ColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу.
Public property | HasHeaderFooter |
Public property | PagesCount |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetEnumerator |
Top
See Also

Reference

SMath.Controls Namespace


ObjectsManager(T) Constructor

ObjectsManagerT Constructor

Initializes a new instance of the ObjectsManagerT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ObjectsManager()
Protected Sub New
protected:
ObjectsManager()
new : unit -> ObjectsManager
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T) Properties

ObjectsManagerT Properties

The ObjectsManagerT generic type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу.
Public property | HasHeaderFooter |
Public property | PagesCount |
Top
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).ColumnsCount Property

ObjectsManagerTColumnsCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ColumnsCount { get; set; }
Public Property ColumnsCount As Integer
    Get
    Set
public:
virtual property int ColumnsCount {
    int get () sealed;
    void set (int value) sealed;
}
abstract ColumnsCount : int with get, set
override ColumnsCount : int with get, set

Property Value

Type: Int32

Implements

IObjectsManagerTColumnsCount
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).CurrentContentPlacement Property

ObjectsManagerTCurrentContentPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContentPlacement CurrentContentPlacement { get; set; }
Public Property CurrentContentPlacement As ContentPlacement
    Get
    Set
public:
virtual property ContentPlacement CurrentContentPlacement {
    ContentPlacement get () sealed;
    void set (ContentPlacement value) sealed;
}
abstract CurrentContentPlacement : ContentPlacement with get, set
override CurrentContentPlacement : ContentPlacement with get, set

Property Value

Type: ContentPlacement

Implements

IObjectsManagerTCurrentContentPlacement
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).CurrentPage Property

ObjectsManagerTCurrentPage Property

Gets the current page.Возвращает текущую страницу.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage CurrentPage { get; set; }
Public Property CurrentPage As DocumentPage
    Get
    Set
public:
virtual property DocumentPage^ CurrentPage {
    DocumentPage^ get () sealed;
    void set (DocumentPage^ value) sealed;
}
abstract CurrentPage : DocumentPage with get, set
override CurrentPage : DocumentPage with get, set

Property Value

Type: DocumentPage

Implements

IObjectsManagerTCurrentPage
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).HasHeaderFooter Property

ObjectsManagerTHasHeaderFooter Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool HasHeaderFooter { get; }
Public MustOverride ReadOnly Property HasHeaderFooter As Boolean
    Get
public:
virtual property bool HasHeaderFooter {
    bool get () abstract;
}
abstract HasHeaderFooter : bool with get

Property Value

Type: Boolean

Implements

IObjectsManagerTHasHeaderFooter
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).PagesCount Property

ObjectsManagerTPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; set; }
Public Property PagesCount As Integer
    Get
    Set
public:
virtual property int PagesCount {
    int get () sealed;
    void set (int value) sealed;
}
abstract PagesCount : int with get, set
override PagesCount : int with get, set

Property Value

Type: Int32

Implements

IObjectsManagerTPagesCount
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T) Methods

ObjectsManagerT Methods

The ObjectsManagerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetEnumerator |
Top
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).IsChanged Method

ObjectsManagerTIsChanged Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsChanged(
    int pagesCount,
    int fullHeight,
    int hiddenHeight
)
Public Function IsChanged (
    pagesCount As Integer,
    fullHeight As Integer,
    hiddenHeight As Integer
) As Boolean
public:
virtual bool IsChanged(
    int pagesCount,
    int fullHeight,
    int hiddenHeight
) sealed
abstract IsChanged :
        pagesCount : int *
        fullHeight : int *
        hiddenHeight : int -> bool
override IsChanged :
        pagesCount : int *
        fullHeight : int *
        hiddenHeight : int -> bool

Parameters

pagesCount
Type: SystemInt32
fullHeight
Type: SystemInt32
hiddenHeight
Type: SystemInt32

Return Value

Type: Boolean

Implements

IObjectsManagerTIsChanged(Int32, Int32, Int32)
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


ObjectsManager(T).TryGetEnumerator Method

ObjectsManagerTTryGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    out ObjectsEnumerator<T> objects
)
Public MustOverride Function TryGetEnumerator (
    placement As ContentPlacement,
    pageIndex As Integer,
    <OutAttribute> ByRef objects As ObjectsEnumerator(Of T)
) As Boolean
public:
virtual bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    [OutAttribute] ObjectsEnumerator<T>^% objects
) abstract
abstract TryGetEnumerator :
        placement : ContentPlacement *
        pageIndex : int *
        objects : ObjectsEnumerator<'T> byref -> bool

Parameters

placement
Type: SMath.ManagerContentPlacement
pageIndex
Type: SystemInt32
objects
Type: SMath.ControlsObjectsEnumerator T

Return Value

Type: Boolean

Implements

IObjectsManagerTTryGetEnumerator(ContentPlacement, Int32, ObjectsEnumeratorT)
See Also

Reference

ObjectsManagerT Class
SMath.Controls Namespace


OnMouseDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void OnMouseDelegate(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
Public Delegate Sub OnMouseDelegate (
    buttons As MouseInputButtons,
    x As Single,
    y As Single,
    count As Integer
)
public delegate void OnMouseDelegate(
    MouseInputButtons buttons,
    float x,
    float y,
    int count
)
type OnMouseDelegate =
    delegate of
        buttons : MouseInputButtons *
        x : float32 *
        y : float32 *
        count : int -> unit

Parameters

buttons
Type: SMath.ManagerMouseInputButtons
x
Type: SystemSingle
y
Type: SystemSingle
count
Type: SystemInt32
See Also

Reference

SMath.Controls Namespace


OnPaintRequestDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void OnPaintRequestDelegate(
    IGraphics g,
    RectangleF bounds
)
Public Delegate Sub OnPaintRequestDelegate (
    g As IGraphics,
    bounds As RectangleF
)
public delegate void OnPaintRequestDelegate(
    IGraphics^ g,
    RectangleF bounds
)
type OnPaintRequestDelegate =
    delegate of
        g : IGraphics *
        bounds : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
bounds
Type: System.DrawingRectangleF
See Also

Reference

SMath.Controls Namespace


PagesEnumerator(T) Class

PagesEnumeratorT Class

Enumerator to iterate through available Document Pages.Объект для перечисления доступных страниц документа.
Inheritance Hierarchy
SystemObject
SMath.ControlsPagesEnumeratorT

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PagesEnumerator<T> : IEnumerator<DocumentPage>,
    IDisposable, IEnumerator
where T : IDocumentObject

Public NotInheritable Class PagesEnumerator(Of T As IDocumentObject)
    Implements IEnumerator(Of DocumentPage), IDisposable,
    IEnumerator
generic<typename T>
where T : IDocumentObject
public ref class PagesEnumerator sealed : IEnumerator<DocumentPage^>,
    IDisposable, IEnumerator
[<SealedAttribute>]
type PagesEnumerator<'T when 'T : IDocumentObject> =
    class
        interface IEnumerator<DocumentPage>
        interface IDisposable
        interface IEnumerator
    end

Type Parameters

T

The PagesEnumeratorT type exposes the following members.

Constructors
 | Name | Description
Public method | PagesEnumeratorT(IDocumentT) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IDocumentT, IGraphics) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IDocumentT, RectangleF) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IObjectsManagerT, PageModel, PagesOptions, MetaContext) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IObjectsManagerT, PageModel, PagesOptions, MetaContext, IGraphics) | Constructor of the object.Конструктор объекта.
Top
Properties
 | Name | Description
Public property | Current | Gets the current object.Возвращает текущий элемент.
Public property | CurrentIndex | Gets the current page index.Возвращает индекс текущей страницы.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocumentPage(Int32, Int32) | Looks up for the Document Page where cursor Y coordinate can be displayed.
Public method | GetDocumentPage(T, Point) | Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.
Public method | GetDocumentPage(T, Int32) | Looks up for the Document Page where Object is displayed.
Public method | GetDocumentPageStrict | Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | MoveNext(IGraphics) | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | Reset | Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями.
Public method | SetCurrentContext | Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.
Public method | SetCurrentContextRaw | Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetPageObjects | Returns Objects located on current Document Page.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorDocumentPageCurrent |
Explicit interface implementation | IEnumeratorCurrent |
Explicit interface implementation | IDisposableDispose |
Explicit interface implementation | IEnumeratorMoveNext |
Explicit interface implementation | IEnumeratorReset |
Top
See Also

Reference

SMath.Controls Namespace


PagesEnumerator(T) Constructor

PagesEnumeratorT Constructor

Overload List
 | Name | Description
Public method | PagesEnumeratorT(IDocumentT) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IDocumentT, IGraphics) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IDocumentT, RectangleF) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IObjectsManagerT, PageModel, PagesOptions, MetaContext) | Constructor of the object.Конструктор объекта.
Public method | PagesEnumeratorT(IObjectsManagerT, PageModel, PagesOptions, MetaContext, IGraphics) | Constructor of the object.Конструктор объекта.
Top
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T) Constructor (IDocument(T))

PagesEnumeratorT Constructor (IDocumentT)

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator(
    IDocument<T> doc
)
Public Sub New (
    doc As IDocument(Of T)
)
public:
PagesEnumerator(
    IDocument<T>^ doc
)
new :
        doc : IDocument<'T> -> PagesEnumerator

Parameters

doc
Type: SMath.ControlsIDocument T
Document to proceed with.Расчёт для работы.
See Also

Reference

PagesEnumeratorT Class
PagesEnumeratorT Overload
SMath.Controls Namespace


PagesEnumerator(T) Constructor (IDocument(T), IGraphics)

PagesEnumeratorT Constructor (IDocumentT, IGraphics)

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator(
    IDocument<T> doc,
    IGraphics graphics
)
Public Sub New (
    doc As IDocument(Of T),
    graphics As IGraphics
)
public:
PagesEnumerator(
    IDocument<T>^ doc,
    IGraphics^ graphics
)
new :
        doc : IDocument<'T> *
        graphics : IGraphics -> PagesEnumerator

Parameters

doc
Type: SMath.ControlsIDocument T
Document to proceed with.Расчёт для работы.
graphics
Type: SMath.DrawingIGraphics
Graphics context to draw Page into.Контекст отрисовки для визуализации страниц.
See Also

Reference

PagesEnumeratorT Class
PagesEnumeratorT Overload
SMath.Controls Namespace


PagesEnumerator(T) Constructor (IDocument(T), RectangleF)

PagesEnumeratorT Constructor (IDocumentT, RectangleF)

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator(
    IDocument<T> doc,
    RectangleF clip
)
Public Sub New (
    doc As IDocument(Of T),
    clip As RectangleF
)
public:
PagesEnumerator(
    IDocument<T>^ doc,
    RectangleF clip
)
new :
        doc : IDocument<'T> *
        clip : RectangleF -> PagesEnumerator

Parameters

doc
Type: SMath.ControlsIDocument T
Document to proceed with.Расчёт для работы.
clip
Type: System.DrawingRectangleF
Visible bounds of the document.Видимая область документа.
See Also

Reference

PagesEnumeratorT Class
PagesEnumeratorT Overload
SMath.Controls Namespace


PagesEnumerator(T) Constructor (IObjectsManager(T), PageModel, PagesOptions, MetaContext)

PagesEnumeratorT Constructor (IObjectsManagerT, PageModel, PagesOptions, MetaContext)

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator(
    IObjectsManager<T> manager,
    PageModel pageModel,
    PagesOptions pagesOptions,
    MetaContext metaContext
)
Public Sub New (
    manager As IObjectsManager(Of T),
    pageModel As PageModel,
    pagesOptions As PagesOptions,
    metaContext As MetaContext
)
public:
PagesEnumerator(
    IObjectsManager<T>^ manager,
    PageModel^ pageModel,
    PagesOptions^ pagesOptions,
    MetaContext^ metaContext
)
new :
        manager : IObjectsManager<'T> *
        pageModel : PageModel *
        pagesOptions : PagesOptions *
        metaContext : MetaContext -> PagesEnumerator

Parameters

manager
Type: SMath.ControlsIObjectsManager T
Objects manager to proceed with.Менеджер объектов для работы.
pageModel
Type: SMath.ManagerPageModel
Printing model of the document.Модель документа для печати.
pagesOptions
Type: SMath.ManagerPagesOptions
Single document page options.Свойства страницы документа.
metaContext
Type: SMath.ManagerMetaContext
Meta data context of the document.Мета данные из контекста документа.
See Also

Reference

PagesEnumeratorT Class
PagesEnumeratorT Overload
SMath.Controls Namespace


PagesEnumerator(T) Constructor (IObjectsManager(T), PageModel, PagesOptions, MetaContext, IGraphics)

PagesEnumeratorT Constructor (IObjectsManagerT, PageModel, PagesOptions, MetaContext, IGraphics)

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesEnumerator(
    IObjectsManager<T> manager,
    PageModel pageModel,
    PagesOptions pagesOptions,
    MetaContext metaContext,
    IGraphics graphics
)
Public Sub New (
    manager As IObjectsManager(Of T),
    pageModel As PageModel,
    pagesOptions As PagesOptions,
    metaContext As MetaContext,
    graphics As IGraphics
)
public:
PagesEnumerator(
    IObjectsManager<T>^ manager,
    PageModel^ pageModel,
    PagesOptions^ pagesOptions,
    MetaContext^ metaContext,
    IGraphics^ graphics
)
new :
        manager : IObjectsManager<'T> *
        pageModel : PageModel *
        pagesOptions : PagesOptions *
        metaContext : MetaContext *
        graphics : IGraphics -> PagesEnumerator

Parameters

manager
Type: SMath.ControlsIObjectsManager T
Objects manager to proceed with.Менеджер объектов для работы.
pageModel
Type: SMath.ManagerPageModel
Printing model of the document.Модель документа для печати.
pagesOptions
Type: SMath.ManagerPagesOptions
Single document page options.Свойства страницы документа.
metaContext
Type: SMath.ManagerMetaContext
Meta data context of the document.Мета данные из контекста документа.
graphics
Type: SMath.DrawingIGraphics
Graphics context to draw Page into.Контекст отрисовки для визуализации страниц.
See Also

Reference

PagesEnumeratorT Class
PagesEnumeratorT Overload
SMath.Controls Namespace


PagesEnumerator(T) Properties

PagesEnumeratorT Properties

The PagesEnumeratorT generic type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current object.Возвращает текущий элемент.
Public property | CurrentIndex | Gets the current page index.Возвращает индекс текущей страницы.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorDocumentPageCurrent |
Explicit interface implementation | IEnumeratorCurrent |
Top
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).IEnumerator(DocumentPage).Current Property

PagesEnumeratorTIEnumeratorDocumentPageCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DocumentPage IEnumerator<DocumentPage>.Current { get; }
Private ReadOnly Property Current As DocumentPage
    Implements IEnumerator(Of DocumentPage).Current
    Get
private:
virtual property DocumentPage^ Current {
    DocumentPage^ get () sealed = IEnumerator<DocumentPage^>::Current::get;
}
private abstract Current : DocumentPage with get
private override Current : DocumentPage with get

Property Value

Type: DocumentPage

Implements

IEnumeratorTCurrent
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).IEnumerator.Current Property

PagesEnumeratorTIEnumeratorCurrent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Object IEnumerator.Current { get; }
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
private abstract Current : Object with get
private override Current : Object with get

Property Value

Type: Object

Implements

IEnumeratorCurrent
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).Current Property

PagesEnumeratorTCurrent Property

Gets the current object.Возвращает текущий элемент.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage Current { get; }
Public ReadOnly Property Current As DocumentPage
    Get
public:
property DocumentPage^ Current {
    DocumentPage^ get ();
}
member Current : DocumentPage with get

Property Value

Type: DocumentPage
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).CurrentIndex Property

PagesEnumeratorTCurrentIndex Property

Gets the current page index.Возвращает индекс текущей страницы.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentIndex { get; }
Public ReadOnly Property CurrentIndex As Integer
    Get
public:
property int CurrentIndex {
    int get ();
}
member CurrentIndex : int with get

Property Value

Type: Int32
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T) Methods

PagesEnumeratorT Methods

The PagesEnumeratorT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocumentPage(Int32, Int32) | Looks up for the Document Page where cursor Y coordinate can be displayed.
Public method | GetDocumentPage(T, Point) | Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.
Public method | GetDocumentPage(T, Int32) | Looks up for the Document Page where Object is displayed.
Public method | GetDocumentPageStrict | Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | MoveNext(IGraphics) | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | Reset | Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями.
Public method | SetCurrentContext | Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.
Public method | SetCurrentContextRaw | Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetPageObjects | Returns Objects located on current Document Page.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Explicit interface implementation | IEnumeratorMoveNext |
Explicit interface implementation | IEnumeratorReset |
Top
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).IDisposable.Dispose Method

PagesEnumeratorTIDisposableDispose Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).IEnumerator.MoveNext Method

PagesEnumeratorTIEnumeratorMoveNext Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IEnumerator.MoveNext()
Private Function MoveNext As Boolean
    Implements IEnumerator.MoveNext
private:
virtual bool MoveNext() sealed = IEnumerator::MoveNext
private abstract MoveNext : unit -> bool
private override MoveNext : unit -> bool

Return Value

Type: Boolean

Implements

IEnumeratorMoveNext
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).IEnumerator.Reset Method

PagesEnumeratorTIEnumeratorReset Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IEnumerator.Reset()
Private Sub Reset Implements IEnumerator.Reset
private:
virtual void Reset() sealed = IEnumerator::Reset
private abstract Reset : unit -> unit
private override Reset : unit -> unit

Implements

IEnumeratorReset
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).GetDocumentPage Method

PagesEnumeratorTGetDocumentPage Method

Overload List
 | Name | Description
Public method | GetDocumentPage(Int32, Int32) | Looks up for the Document Page where cursor Y coordinate can be displayed.
Public method | GetDocumentPage(T, Point) | Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.
Public method | GetDocumentPage(T, Int32) | Looks up for the Document Page where Object is displayed.
Top
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).GetDocumentPage Method (Int32, Int32)

PagesEnumeratorTGetDocumentPage Method (Int32, Int32)

Looks up for the Document Page where cursor Y coordinate can be displayed.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetDocumentPage(
    int y,
    out int collapsedHeight
)
Public Function GetDocumentPage (
    y As Integer,
    <OutAttribute> ByRef collapsedHeight As Integer
) As DocumentPage
public:
DocumentPage^ GetDocumentPage(
    int y,
    [OutAttribute] int% collapsedHeight
)
member GetDocumentPage :
        y : int *
        collapsedHeight : int byref -> DocumentPage

Parameters

y
Type: SystemInt32
The logical coordinate (must not contain Logical Page Offset), f.e.: real location of the Object.
collapsedHeight
Type: SystemInt32
Returns CollapsedHeight for the given Y coordinate.

Return Value

Type: DocumentPage
Document Page where cursor Y coordinate can be displayed.
See Also

Reference

PagesEnumeratorT Class
GetDocumentPage Overload
SMath.Controls Namespace


PagesEnumerator(T).GetDocumentPage Method (T, Point)

PagesEnumeratorTGetDocumentPage Method (T, Point)

Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetDocumentPage(
    T obj,
    Point cursorPosition
)
Public Function GetDocumentPage (
    obj As T,
    cursorPosition As Point
) As DocumentPage
public:
DocumentPage^ GetDocumentPage(
    T obj,
    Point cursorPosition
)
member GetDocumentPage :
        obj : 'T *
        cursorPosition : Point -> DocumentPage

Parameters

obj
Type: T
Object to find Document Page for.
cursorPosition
Type: System.DrawingPoint
Position of the cursor inside an Object.

Return Value

Type: DocumentPage
Document Page where given Object is found. Returns null if no Page found.
See Also

Reference

PagesEnumeratorT Class
GetDocumentPage Overload
SMath.Controls Namespace


PagesEnumerator(T).GetDocumentPage Method (T, Int32)

PagesEnumeratorTGetDocumentPage Method (T, Int32)

Looks up for the Document Page where Object is displayed.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetDocumentPage(
    T obj,
    int preferedPageIndex
)
Public Function GetDocumentPage (
    obj As T,
    preferedPageIndex As Integer
) As DocumentPage
public:
DocumentPage^ GetDocumentPage(
    T obj,
    int preferedPageIndex
)
member GetDocumentPage :
        obj : 'T *
        preferedPageIndex : int -> DocumentPage

Parameters

obj
Type: T
Object to find Document Page for.
preferedPageIndex
Type: SystemInt32
Index of the prefered page to find Object on. Note: large Objects may be located on several Pages at the same time.

Return Value

Type: DocumentPage
Document Page where given Object is found. Returns null if no Page found.
See Also

Reference

PagesEnumeratorT Class
GetDocumentPage Overload
SMath.Controls Namespace


PagesEnumerator(T).GetDocumentPageStrict Method

PagesEnumeratorTGetDocumentPageStrict Method

Looks up for the Document Page where Object is displayed taking in account cursor location into the Object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetDocumentPageStrict(
    T obj,
    Point physicalPnt
)
Public Function GetDocumentPageStrict (
    obj As T,
    physicalPnt As Point
) As DocumentPage
public:
DocumentPage^ GetDocumentPageStrict(
    T obj,
    Point physicalPnt
)
member GetDocumentPageStrict :
        obj : 'T *
        physicalPnt : Point -> DocumentPage

Parameters

obj
Type: T
Object to find Document Page for.
physicalPnt
Type: System.DrawingPoint
Position of the cursor inside an Object.

Return Value

Type: DocumentPage
Document Page where given Object is found. Returns null if no Page found.
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).GetEnumerator Method

PagesEnumeratorTGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<DocumentPage> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DocumentPage)
public:
IEnumerator<DocumentPage^>^ GetEnumerator()
member GetEnumerator : unit -> IEnumerator<DocumentPage>

Return Value

Type: IEnumeratorDocumentPage
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).MoveNext Method

PagesEnumeratorTMoveNext Method

Overload List
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Public method | MoveNext(IGraphics) | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.
Top
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).MoveNext Method

PagesEnumeratorTMoveNext Method

Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext()
Public Function MoveNext As Boolean
public:
bool MoveNext()
member MoveNext : unit -> bool

Return Value

Type: Boolean
Returns true if next Page available, otherwise false.Возвращает истину, если следующая страница доступна, в противном случае возвращает ложь.
See Also

Reference

PagesEnumeratorT Class
MoveNext Overload
SMath.Controls Namespace


PagesEnumerator(T).MoveNext Method (IGraphics)

PagesEnumeratorTMoveNext Method (IGraphics)

Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool MoveNext(
    IGraphics g
)
Public Function MoveNext (
    g As IGraphics
) As Boolean
public:
bool MoveNext(
    IGraphics^ g
)
member MoveNext :
        g : IGraphics -> bool

Parameters

g
Type: SMath.DrawingIGraphics
Drawing surface.Интерфейс для отрисовки.

Return Value

Type: Boolean
Returns true if next Page available, otherwise false.Возвращает истину, если следующая страница доступна, в противном случае возвращает ложь.
See Also

Reference

PagesEnumeratorT Class
MoveNext Overload
SMath.Controls Namespace


PagesEnumerator(T).Reset Method

PagesEnumeratorTReset Method

Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).SetCurrentContext Method

PagesEnumeratorTSetCurrentContext Method

Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentContext(
    Point location
)
Public Sub SetCurrentContext (
    location As Point
)
public:
void SetCurrentContext(
    Point location
)
member SetCurrentContext :
        location : Point -> unit

Parameters

location
Type: System.DrawingPoint
The logical coordinate (must not contain Logical Offset), f.e.: IDocumentObject.Location.
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).SetCurrentContextRaw Method

PagesEnumeratorTSetCurrentContextRaw Method

Updates context based on current state of the enumertor.Обновляет контекст на основании текущего состояния перечислителя.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentContextRaw(
    Point location
)
Public Sub SetCurrentContextRaw (
    location As Point
)
public:
void SetCurrentContextRaw(
    Point location
)
member SetCurrentContextRaw :
        location : Point -> unit

Parameters

location
Type: System.DrawingPoint
The logical coordinate (must contain Logical Offset), f.e.: original mouse location.
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PagesEnumerator(T).TryGetPageObjects Method

PagesEnumeratorTTryGetPageObjects Method

Returns Objects located on current Document Page.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetPageObjects(
    out ObjectsEnumerator<T> objects
)
Public Function TryGetPageObjects (
    <OutAttribute> ByRef objects As ObjectsEnumerator(Of T)
) As Boolean
public:
bool TryGetPageObjects(
    [OutAttribute] ObjectsEnumerator<T>^% objects
)
member TryGetPageObjects :
        objects : ObjectsEnumerator<'T> byref -> bool

Parameters

objects
Type: SMath.ControlsObjectsEnumerator T
Objects located on current Document Page.

Return Value

Type: Boolean
Returns true if objects exists and false otherwise.
See Also

Reference

PagesEnumeratorT Class
SMath.Controls Namespace


PaintEventHandler Delegate

Делегат необходимости перерисовки элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void PaintEventHandler(
    RegionBase sender,
    Rectangle e
)
Public Delegate Sub PaintEventHandler (
    sender As RegionBase,
    e As Rectangle
)
public delegate void PaintEventHandler(
    RegionBase^ sender,
    Rectangle e
)
type PaintEventHandler =
    delegate of
        sender : RegionBase *
        e : Rectangle -> unit

Parameters

sender
Type: SMath.ControlsRegionBase
e
Type: System.DrawingRectangle
See Also

Reference

SMath.Controls Namespace


PasswordRequestEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void PasswordRequestEventHandler(
    Worksheet sender,
    ref string password
)
Public Delegate Sub PasswordRequestEventHandler (
    sender As Worksheet,
    ByRef password As String
)
public delegate void PasswordRequestEventHandler(
    Worksheet^ sender,
    String^% password
)
type PasswordRequestEventHandler =
    delegate of
        sender : Worksheet *
        password : string byref -> unit

Parameters

sender
Type: SMath.ControlsWorksheet
password
Type: SystemString
See Also

Reference

SMath.Controls Namespace


PresentationMode Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum PresentationMode
Public Enumeration PresentationMode
public enum class PresentationMode
type PresentationMode
Members
Member name | Value | Description
Auto | 0 |
Worksheet | 1 |
Document | 2 |
See Also

Reference

SMath.Controls Namespace


ProgressEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ProgressEventHandler(
    RegionBase region,
    string message,
    int current,
    int count,
    Stopwatch watch
)
Public Delegate Sub ProgressEventHandler (
    region As RegionBase,
    message As String,
    current As Integer,
    count As Integer,
    watch As Stopwatch
)
public delegate void ProgressEventHandler(
    RegionBase^ region,
    String^ message,
    int current,
    int count,
    Stopwatch^ watch
)
type ProgressEventHandler =
    delegate of
        region : RegionBase *
        message : string *
        current : int *
        count : int *
        watch : Stopwatch -> unit

Parameters

region
Type: SMath.ControlsRegionBase
message
Type: SystemString
current
Type: SystemInt32
count
Type: SystemInt32
watch
Type: System.DiagnosticsStopwatch
See Also

Reference

SMath.Controls Namespace


PropertiesReader Class

Provides interface to read Region properties during import.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionaryString, String
SMath.ControlsPropertiesReader

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PropertiesReader : Dictionary<string, string>
Public Class PropertiesReader
    Inherits Dictionary(Of String, String)
public ref class PropertiesReader : public Dictionary<String^, String^>
type PropertiesReader =
    class
        inherit Dictionary<string, string>
    end

The PropertiesReader type exposes the following members.

Constructors
 | Name | Description
Public method | PropertiesReader | Initializes a new instance of the PropertiesReader class
Public method | PropertiesReader(XmlReader) | Initializes a new instance of the PropertiesReader class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from DictionaryString, String.)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from DictionaryString, String.)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from DictionaryString, String.)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from DictionaryString, String.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean(String) | Retrieves a boolean property.
Public method | GetBoolean(String, Boolean) | Retrieves a boolean property.
Public method | GetDouble(String) | Retrieves a double property.
Public method | GetDouble(String, Double) | Retrieves a double property.
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt32(String) | Retrieves an integer property.
Public method | GetInt32(String, Int32) | Retrieves an integer property.
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from DictionaryString, String.)
Public method | GetSingle(String) | Retrieves a float property.
Public method | GetSingle(String, Single) | Retrieves a float property.
Public method | GetString(String) | Retrieves a string property.
Public method | GetString(String, String) | Retrieves a string property.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from DictionaryString, String.)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from DictionaryString, String.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueAdd | Adds the specified value to the ICollectionT with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryAdd | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueContains | Determines whether the ICollectionT contains a specific key and value. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryContains | Determines whether the IDictionary contains an element with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueCopyTo | Copies the elements of the ICollectionT to an array of type KeyValuePairTKey, TValue, starting at the specified array index. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionCopyTo | Copies the elements of the ICollectionT to an array, starting at the specified array index. (Inherited from DictionaryString, String.)
Explicit interface implementation | IEnumerableKeyValuePairTKey, TValueGetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IEnumerableGetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryGetEnumerator | Returns an IDictionaryEnumerator for the IDictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryIsFixedSize | Gets a value indicating whether the IDictionary has a fixed size. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueIsReadOnly | Gets a value indicating whether the dictionary is read-only. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryIsReadOnly | Gets a value indicating whether the IDictionary is read-only. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionIsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryItem | Gets or sets the value with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryTKey, TValueKeys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryKeys | Gets an ICollection containing the keys of the IDictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueRemove | Removes a key and value from the dictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryRemove | Removes the element with the specified key from the IDictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionSyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryTKey, TValueValues | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryValues | Gets an ICollection containing the values in the IDictionary. (Inherited from DictionaryString, String.)
Top
See Also

Reference

SMath.Controls Namespace


PropertiesReader Constructor

Overload List
 | Name | Description
Public method | PropertiesReader | Initializes a new instance of the PropertiesReader class
Public method | PropertiesReader(XmlReader) | Initializes a new instance of the PropertiesReader class
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader Constructor

Initializes a new instance of the PropertiesReader class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesReader()
Public Sub New
public:
PropertiesReader()
new : unit -> PropertiesReader
See Also

Reference

PropertiesReader Class
PropertiesReader Overload
SMath.Controls Namespace


PropertiesReader Constructor (XmlReader)

Initializes a new instance of the PropertiesReader class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesReader(
    XmlReader reader
)
Public Sub New (
    reader As XmlReader
)
public:
PropertiesReader(
    XmlReader^ reader
)
new :
        reader : XmlReader -> PropertiesReader

Parameters

reader
Type: System.XmlXmlReader
See Also

Reference

PropertiesReader Class
PropertiesReader Overload
SMath.Controls Namespace


PropertiesReader Properties

The PropertiesReader type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from DictionaryString, String.)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from DictionaryString, String.)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDictionaryIsFixedSize | Gets a value indicating whether the IDictionary has a fixed size. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueIsReadOnly | Gets a value indicating whether the dictionary is read-only. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryIsReadOnly | Gets a value indicating whether the IDictionary is read-only. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionIsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryItem | Gets or sets the value with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryTKey, TValueKeys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryKeys | Gets an ICollection containing the keys of the IDictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionSyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryTKey, TValueValues | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryValues | Gets an ICollection containing the values in the IDictionary. (Inherited from DictionaryString, String.)
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader Methods

The PropertiesReader type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from DictionaryString, String.)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from DictionaryString, String.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean(String) | Retrieves a boolean property.
Public method | GetBoolean(String, Boolean) | Retrieves a boolean property.
Public method | GetDouble(String) | Retrieves a double property.
Public method | GetDouble(String, Double) | Retrieves a double property.
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt32(String) | Retrieves an integer property.
Public method | GetInt32(String, Int32) | Retrieves an integer property.
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from DictionaryString, String.)
Public method | GetSingle(String) | Retrieves a float property.
Public method | GetSingle(String, Single) | Retrieves a float property.
Public method | GetString(String) | Retrieves a string property.
Public method | GetString(String, String) | Retrieves a string property.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from DictionaryString, String.)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from DictionaryString, String.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from DictionaryString, String.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueAdd | Adds the specified value to the ICollectionT with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryAdd | Adds the specified key and value to the dictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueContains | Determines whether the ICollectionT contains a specific key and value. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryContains | Determines whether the IDictionary contains an element with the specified key. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueCopyTo | Copies the elements of the ICollectionT to an array of type KeyValuePairTKey, TValue, starting at the specified array index. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionCopyTo | Copies the elements of the ICollectionT to an array, starting at the specified array index. (Inherited from DictionaryString, String.)
Explicit interface implementation | IEnumerableKeyValuePairTKey, TValueGetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IEnumerableGetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryGetEnumerator | Returns an IDictionaryEnumerator for the IDictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | ICollectionKeyValuePairTKey, TValueRemove | Removes a key and value from the dictionary. (Inherited from DictionaryString, String.)
Explicit interface implementation | IDictionaryRemove | Removes the element with the specified key from the IDictionary. (Inherited from DictionaryString, String.)
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetBoolean Method

PropertiesReaderGetBoolean Method

Overload List
 | Name | Description
Public method | GetBoolean(String) | Retrieves a boolean property.
Public method | GetBoolean(String, Boolean) | Retrieves a boolean property.
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetBoolean Method (String)

PropertiesReaderGetBoolean Method (String)

Retrieves a boolean property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool GetBoolean(
    string name
)
Public Function GetBoolean (
    name As String
) As Boolean
public:
bool GetBoolean(
    String^ name
)
member GetBoolean :
        name : string -> bool

Parameters

name
Type: SystemString
Name of the property to retrieve.

Return Value

Type: Boolean
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetBoolean Overload
SMath.Controls Namespace


PropertiesReader.GetBoolean Method (String, Boolean)

PropertiesReaderGetBoolean Method (String, Boolean)

Retrieves a boolean property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool GetBoolean(
    string name,
    bool defaultValue
)
Public Function GetBoolean (
    name As String,
    defaultValue As Boolean
) As Boolean
public:
bool GetBoolean(
    String^ name,
    bool defaultValue
)
member GetBoolean :
        name : string *
        defaultValue : bool -> bool

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue
Type: SystemBoolean
Default value.

Return Value

Type: Boolean
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetBoolean Overload
SMath.Controls Namespace


PropertiesReader.GetDouble Method

PropertiesReaderGetDouble Method

Overload List
 | Name | Description
Public method | GetDouble(String) | Retrieves a double property.
Public method | GetDouble(String, Double) | Retrieves a double property.
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetDouble Method (String)

PropertiesReaderGetDouble Method (String)

Retrieves a double property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public double GetDouble(
    string name
)
Public Function GetDouble (
    name As String
) As Double
public:
double GetDouble(
    String^ name
)
member GetDouble :
        name : string -> float

Parameters

name
Type: SystemString
Name of the property to retrieve.

Return Value

Type: Double
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetDouble Overload
SMath.Controls Namespace


PropertiesReader.GetDouble Method (String, Double)

PropertiesReaderGetDouble Method (String, Double)

Retrieves a double property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public double GetDouble(
    string name,
    double defaultValue
)
Public Function GetDouble (
    name As String,
    defaultValue As Double
) As Double
public:
double GetDouble(
    String^ name,
    double defaultValue
)
member GetDouble :
        name : string *
        defaultValue : float -> float

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue
Type: SystemDouble
Default value.

Return Value

Type: Double
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetDouble Overload
SMath.Controls Namespace


PropertiesReader.GetInt32 Method

PropertiesReaderGetInt32 Method

Overload List
 | Name | Description
Public method | GetInt32(String) | Retrieves an integer property.
Public method | GetInt32(String, Int32) | Retrieves an integer property.
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetInt32 Method (String)

PropertiesReaderGetInt32 Method (String)

Retrieves an integer property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetInt32(
    string name
)
Public Function GetInt32 (
    name As String
) As Integer
public:
int GetInt32(
    String^ name
)
member GetInt32 :
        name : string -> int

Parameters

name
Type: SystemString
Name of the property to retrieve.

Return Value

Type: Int32
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetInt32 Overload
SMath.Controls Namespace


PropertiesReader.GetInt32 Method (String, Int32)

PropertiesReaderGetInt32 Method (String, Int32)

Retrieves an integer property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetInt32(
    string name,
    int defaultValue
)
Public Function GetInt32 (
    name As String,
    defaultValue As Integer
) As Integer
public:
int GetInt32(
    String^ name,
    int defaultValue
)
member GetInt32 :
        name : string *
        defaultValue : int -> int

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue
Type: SystemInt32
Default value.

Return Value

Type: Int32
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetInt32 Overload
SMath.Controls Namespace


PropertiesReader.GetSingle Method

PropertiesReaderGetSingle Method

Overload List
 | Name | Description
Public method | GetSingle(String) | Retrieves a float property.
Public method | GetSingle(String, Single) | Retrieves a float property.
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetSingle Method (String)

PropertiesReaderGetSingle Method (String)

Retrieves a float property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float GetSingle(
    string name
)
Public Function GetSingle (
    name As String
) As Single
public:
float GetSingle(
    String^ name
)
member GetSingle :
        name : string -> float32

Parameters

name
Type: SystemString
Name of the property to retrieve.

Return Value

Type: Single
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetSingle Overload
SMath.Controls Namespace


PropertiesReader.GetSingle Method (String, Single)

PropertiesReaderGetSingle Method (String, Single)

Retrieves a float property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float GetSingle(
    string name,
    float defaultValue
)
Public Function GetSingle (
    name As String,
    defaultValue As Single
) As Single
public:
float GetSingle(
    String^ name,
    float defaultValue
)
member GetSingle :
        name : string *
        defaultValue : float32 -> float32

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue
Type: SystemSingle
Default value.

Return Value

Type: Single
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetSingle Overload
SMath.Controls Namespace


PropertiesReader.GetString Method

PropertiesReaderGetString Method

Overload List
 | Name | Description
Public method | GetString(String) | Retrieves a string property.
Public method | GetString(String, String) | Retrieves a string property.
Top
See Also

Reference

PropertiesReader Class
SMath.Controls Namespace


PropertiesReader.GetString Method (String)

PropertiesReaderGetString Method (String)

Retrieves a string property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetString(
    string name
)
Public Function GetString (
    name As String
) As String
public:
String^ GetString(
    String^ name
)
member GetString :
        name : string -> string

Parameters

name
Type: SystemString
Name of the property to retrieve.

Return Value

Type: String
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetString Overload
SMath.Controls Namespace


PropertiesReader.GetString Method (String, String)

PropertiesReaderGetString Method (String, String)

Retrieves a string property.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetString(
    string name,
    string defaultValue
)
Public Function GetString (
    name As String,
    defaultValue As String
) As String
public:
String^ GetString(
    String^ name,
    String^ defaultValue
)
member GetString :
        name : string *
        defaultValue : string -> string

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue
Type: SystemString
Default value.

Return Value

Type: String
Property value if the property exists and is parsed OK.
See Also

Reference

PropertiesReader Class
GetString Overload
SMath.Controls Namespace


PropertiesWriter Class

Provides interface to write Region properties during export.
Inheritance Hierarchy
SystemObject
SMath.ControlsPropertiesWriter

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PropertiesWriter
Public Class PropertiesWriter
public ref class PropertiesWriter
type PropertiesWriter =  class end

The PropertiesWriter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertiesWriter | Initializes a new instance of the PropertiesWriter class
Public method | PropertiesWriter(XmlWriter) | Initializes a new instance of the PropertiesWriter class
Top
Properties
 | Name | Description
Public property | IsWritable |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBoolean |
Public method | SetDouble |
Public method | SetInt32 |
Public method | SetSingle |
Public method | SetString |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


PropertiesWriter Constructor

Overload List
 | Name | Description
Public method | PropertiesWriter | Initializes a new instance of the PropertiesWriter class
Public method | PropertiesWriter(XmlWriter) | Initializes a new instance of the PropertiesWriter class
Top
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter Constructor

Initializes a new instance of the PropertiesWriter class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesWriter()
Public Sub New
public:
PropertiesWriter()
new : unit -> PropertiesWriter
See Also

Reference

PropertiesWriter Class
PropertiesWriter Overload
SMath.Controls Namespace


PropertiesWriter Constructor (XmlWriter)

Initializes a new instance of the PropertiesWriter class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesWriter(
    XmlWriter writer
)
Public Sub New (
    writer As XmlWriter
)
public:
PropertiesWriter(
    XmlWriter^ writer
)
new :
        writer : XmlWriter -> PropertiesWriter

Parameters

writer
Type: System.XmlXmlWriter
See Also

Reference

PropertiesWriter Class
PropertiesWriter Overload
SMath.Controls Namespace


PropertiesWriter Properties

The PropertiesWriter type exposes the following members.

Properties
 | Name | Description
Public property | IsWritable |
Top
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.IsWritable Property

PropertiesWriterIsWritable Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsWritable { get; }
Public ReadOnly Property IsWritable As Boolean
    Get
public:
property bool IsWritable {
    bool get ();
}
member IsWritable : bool with get

Property Value

Type: Boolean
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter Methods

The PropertiesWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBoolean |
Public method | SetDouble |
Public method | SetInt32 |
Public method | SetSingle |
Public method | SetString |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.SetBoolean Method

PropertiesWriterSetBoolean Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetBoolean(
    string name,
    bool value
)
Public Sub SetBoolean (
    name As String,
    value As Boolean
)
public:
void SetBoolean(
    String^ name,
    bool value
)
member SetBoolean :
        name : string *
        value : bool -> unit

Parameters

name
Type: SystemString
value
Type: SystemBoolean
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.SetDouble Method

PropertiesWriterSetDouble Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetDouble(
    string name,
    double value
)
Public Sub SetDouble (
    name As String,
    value As Double
)
public:
void SetDouble(
    String^ name,
    double value
)
member SetDouble :
        name : string *
        value : float -> unit

Parameters

name
Type: SystemString
value
Type: SystemDouble
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.SetInt32 Method

PropertiesWriterSetInt32 Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetInt32(
    string name,
    int value
)
Public Sub SetInt32 (
    name As String,
    value As Integer
)
public:
void SetInt32(
    String^ name,
    int value
)
member SetInt32 :
        name : string *
        value : int -> unit

Parameters

name
Type: SystemString
value
Type: SystemInt32
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.SetSingle Method

PropertiesWriterSetSingle Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetSingle(
    string name,
    float value
)
Public Sub SetSingle (
    name As String,
    value As Single
)
public:
void SetSingle(
    String^ name,
    float value
)
member SetSingle :
        name : string *
        value : float32 -> unit

Parameters

name
Type: SystemString
value
Type: SystemSingle
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


PropertiesWriter.SetString Method

PropertiesWriterSetString Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetString(
    string name,
    string value
)
Public Sub SetString (
    name As String,
    value As String
)
public:
void SetString(
    String^ name,
    String^ value
)
member SetString :
        name : string *
        value : string -> unit

Parameters

name
Type: SystemString
value
Type: SystemString
See Also

Reference

PropertiesWriter Class
SMath.Controls Namespace


RegionBase Class

Base class for every worksheet Region.Базовый класс всех элементов листа расчётов.
Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBase
SMath.ControlsRegionEvaluable
SMath.ControlsRegionTranslatable

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RegionBase : IDocumentObject,
    IComparable<RegionBase>
Public MustInherit Class RegionBase
    Implements IDocumentObject, IComparable(Of RegionBase)
public ref class RegionBase abstract : IDocumentObject,
    IComparable<RegionBase^>
[<AbstractClassAttribute>]
type RegionBase =
    class
        interface IDocumentObject
        interface IComparable<RegionBase>
    end

The RegionBase type exposes the following members.

Constructors
 | Name | Description
Public method | RegionBase(RegionBase) | Constructor to copy Region to a new instance.Конструктор элемента для копирования.
Public method | RegionBase(SessionProfile) | Empty Region constructor.Конструктор элемента.
Top
Properties
 | Name | Description
Public property | BackColor | Фоновый цвет элемента.
Public property | BaseLine | Gets base line for the Region.
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента.
Public property | Border | Отрисовка рамки по границе элемента.
Public property | Bottom | Нижняя граница элемента.
Public property | Children |
Public property | Container |
Protected property | ContainsFields |
Public property | CurrentCollapsedHeight |
Public property | CurrentCursorLocation | Returns cursor location within current Region.Возвращает позицию курсора внутри текущего региона.
Public property | CurrentMetaContext |
Public property | CurrentPageOffsets |
Public property | Dependences |
Public property | DrawBase |
Public property | FixedLayout | Defines if modeling options of the Region could be modified.
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяется актуальностью информации элемента (свойство InDate).
Public property | Font | Шрифт используемый элементом.
Public property | FontHeight | Размер используемого элементом шрифта.
Public property | Id |
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов.
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet.
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not.
Public property | Link |
Public property | Location | Location of the Region.Абсолютные координаты элемента листа.
Public property | MetaData |
Public property | Middle | Obsolete.
Public property | MiddleLine | Gets middle line for the Region.
Public property | PageBreaks |
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент.
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего.
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя.
Public property | Right | Правая граница элемента.
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет.
Public property | SelectedBackColor | Выделенный фоновый цвет элемента.
Public property | SelectedTextColor | Цвет выделенного текста элемента.
Protected property | SessionProfile |
Public property | Size | Size of the Region.Размер элемента листа.
Public property | TabStop |
Public property | TextColor | Цвет текста элемента.
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента.
Top
Methods
 | Name | Description
Public method | BeforeCopy |
Public method | BeforePaste |
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе).
Public method | ChangeStatus(String) |
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) |
Protected method | ChildRepainting |
Public method | ClickMenuButton |
Public method | Clone |
Public method | Copy |
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений.
Public method | Dispose | Releases all resources used by the RegionBase
Public method | Draw |
Public method | DrawToBitmap | Получение изображения элемента.
Public method | DrawToBitmap(IGraphics) |
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом.
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml |
Protected method | GetAllChildren |
Public method | GetCursorType | Defines a cursor type by pointer location.Определение вида курсора.
Public method | GetFocusedPart |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetHistoryStep |
Public method | GetSelectionStatus |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout |
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку.
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend |
Public method | OnCommandSend |
Public method | OnKeyDown |
Public method | OnKeyPress |
Public method | OnKeyUp |
Public method | OnMouseDown |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | OnMouseWheel |
Public method | OnPaint |
Public method | OnSelectionUpdate |
Public method | Paste |
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.
Public method | PrePainter(IGraphics) |
 | ReadyToChangeLocation | Obsolete.
Public method | ReadyToPaint | Obsolete.
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные).
Protected method | Resize | Генерирует событие изменения размера.
Public method | ShowAvailableTermsList |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml |
Top
Events
 | Name | Description
Public event | AvailableTermsListShow |
Public event | BeforeLocationChanged |
Public event | Changed |
Public event | FocusChanged |
Public event | MenuButtonClick |
Public event | PaintRequested |
Public event | ProgressChanged |
Public event | Resized |
Public event | StatusChanged |
Top
Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования.
Protected field | dblclick |
Protected field | pen | Массив "карандашей" для рисования.
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo |
Top
See Also

Reference

SMath.Controls Namespace


RegionBase Constructor

Overload List
 | Name | Description
Public method | RegionBase(RegionBase) | Constructor to copy Region to a new instance.Конструктор элемента для копирования.
Public method | RegionBase(SessionProfile) | Empty Region constructor.Конструктор элемента.
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase Constructor (RegionBase)

Constructor to copy Region to a new instance.Конструктор элемента для копирования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase(
    RegionBase value
)
Public Sub New (
    value As RegionBase
)
public:
RegionBase(
    RegionBase^ value
)
new :
        value : RegionBase -> RegionBase

Parameters

value
Type: SMath.ControlsRegionBase
Source Region.Исходный элемент листа.
See Also

Reference

RegionBase Class
RegionBase Overload
SMath.Controls Namespace


RegionBase Constructor (SessionProfile)

Empty Region constructor.Конструктор элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
RegionBase(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> RegionBase

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

RegionBase Class
RegionBase Overload
SMath.Controls Namespace


RegionBase Properties

The RegionBase type exposes the following members.

Properties
 | Name | Description
Public property | BackColor | Фоновый цвет элемента.
Public property | BaseLine | Gets base line for the Region.
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента.
Public property | Border | Отрисовка рамки по границе элемента.
Public property | Bottom | Нижняя граница элемента.
Public property | Children |
Public property | Container |
Protected property | ContainsFields |
Public property | CurrentCollapsedHeight |
Public property | CurrentCursorLocation | Returns cursor location within current Region.Возвращает позицию курсора внутри текущего региона.
Public property | CurrentMetaContext |
Public property | CurrentPageOffsets |
Public property | Dependences |
Public property | DrawBase |
Public property | FixedLayout | Defines if modeling options of the Region could be modified.
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяется актуальностью информации элемента (свойство InDate).
Public property | Font | Шрифт используемый элементом.
Public property | FontHeight | Размер используемого элементом шрифта.
Public property | Id |
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов.
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet.
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not.
Public property | Link |
Public property | Location | Location of the Region.Абсолютные координаты элемента листа.
Public property | MetaData |
Public property | Middle | Obsolete.
Public property | MiddleLine | Gets middle line for the Region.
Public property | PageBreaks |
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент.
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего.
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя.
Public property | Right | Правая граница элемента.
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет.
Public property | SelectedBackColor | Выделенный фоновый цвет элемента.
Public property | SelectedTextColor | Цвет выделенного текста элемента.
Protected property | SessionProfile |
Public property | Size | Size of the Region.Размер элемента листа.
Public property | TabStop |
Public property | TextColor | Цвет текста элемента.
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента.
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BackColor Property

RegionBaseBackColor Property

Фоновый цвет элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Color BackColor { get; set; }
Public Overridable Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get ();
    void set (Color value);
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BaseLine Property

RegionBaseBaseLine Property

Gets base line for the Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual float BaseLine { get; }
Public Overridable ReadOnly Property BaseLine As Single
    Get
public:
virtual property float BaseLine {
    float get ();
}
abstract BaseLine : float32 with get
override BaseLine : float32 with get

Property Value

Type: Single
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BaseSize Property

RegionBaseBaseSize Property

Size of the base part of the Region.Размер базовой составляющей элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Size BaseSize { get; }
Public Overridable ReadOnly Property BaseSize As Size
    Get
public:
virtual property Size BaseSize {
    Size get ();
}
abstract BaseSize : Size with get
override BaseSize : Size with get

Property Value

Type: Size
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Border Property

RegionBaseBorder Property

Отрисовка рамки по границе элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Border { get; set; }
Public Overridable Property Border As Boolean
    Get
    Set
public:
virtual property bool Border {
    bool get ();
    void set (bool value);
}
abstract Border : bool with get, set
override Border : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Bottom Property

RegionBaseBottom Property

Нижняя граница элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Bottom { get; }
Public ReadOnly Property Bottom As Integer
    Get
public:
property int Bottom {
    int get ();
}
member Bottom : int with get

Property Value

Type: Int32
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Children Property

RegionBaseChildren Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ChildrenRegionsList Children { get; }
Public ReadOnly Property Children As ChildrenRegionsList
    Get
public:
property ChildrenRegionsList^ Children {
    ChildrenRegionsList^ get ();
}
member Children : ChildrenRegionsList with get

Property Value

Type: ChildrenRegionsList
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Container Property

RegionBaseContainer Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase Container { get; set; }
Public Property Container As RegionBase
    Get
    Set
public:
property RegionBase^ Container {
    RegionBase^ get ();
    void set (RegionBase^ value);
}
member Container : RegionBase with get, set

Property Value

Type: RegionBase
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ContainsFields Property

RegionBaseContainsFields Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool ContainsFields { get; set; }
Protected Property ContainsFields As Boolean
    Get
    Set
protected:
property bool ContainsFields {
    bool get ();
    void set (bool value);
}
member ContainsFields : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.CurrentCollapsedHeight Property

RegionBaseCurrentCollapsedHeight Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentCollapsedHeight { get; set; }
Public Property CurrentCollapsedHeight As Integer
    Get
    Set
public:
virtual property int CurrentCollapsedHeight {
    int get () sealed;
    void set (int value) sealed;
}
abstract CurrentCollapsedHeight : int with get, set
override CurrentCollapsedHeight : int with get, set

Property Value

Type: Int32

Implements

IDocumentObjectCurrentCollapsedHeight
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.CurrentCursorLocation Property

RegionBaseCurrentCursorLocation Property

Returns cursor location within current Region.Возвращает позицию курсора внутри текущего региона.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle CurrentCursorLocation { get; }
Public Overridable ReadOnly Property CurrentCursorLocation As Rectangle
    Get
public:
virtual property Rectangle CurrentCursorLocation {
    Rectangle get ();
}
abstract CurrentCursorLocation : Rectangle with get
override CurrentCursorLocation : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.CurrentMetaContext Property

RegionBaseCurrentMetaContext Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContextVariables CurrentMetaContext { get; set; }
Public Property CurrentMetaContext As ContextVariables
    Get
    Set
public:
virtual property ContextVariables^ CurrentMetaContext {
    ContextVariables^ get () sealed;
    void set (ContextVariables^ value) sealed;
}
abstract CurrentMetaContext : ContextVariables with get, set
override CurrentMetaContext : ContextVariables with get, set

Property Value

Type: ContextVariables

Implements

IDocumentObjectCurrentMetaContext
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.CurrentPageOffsets Property

RegionBaseCurrentPageOffsets Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ParallelList<Point> CurrentPageOffsets { get; set; }
Public Property CurrentPageOffsets As ParallelList(Of Point)
    Get
    Set
public:
virtual property ParallelList<Point>^ CurrentPageOffsets {
    ParallelList<Point>^ get () sealed;
    void set (ParallelList<Point>^ value) sealed;
}
abstract CurrentPageOffsets : ParallelList<Point> with get, set
override CurrentPageOffsets : ParallelList<Point> with get, set

Property Value

Type: ParallelList Point

Implements

IDocumentObjectCurrentPageOffsets
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Dependences Property

RegionBaseDependences Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual List<AssemblyInfo> Dependences { get; set; }
Public Overridable Property Dependences As List(Of AssemblyInfo)
    Get
    Set
public:
virtual property List<AssemblyInfo>^ Dependences {
    List<AssemblyInfo>^ get ();
    void set (List<AssemblyInfo>^ value);
}
abstract Dependences : List<AssemblyInfo> with get, set
override Dependences : List<AssemblyInfo> with get, set

Property Value

Type: ListAssemblyInfo
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.DrawBase Property

RegionBaseDrawBase Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool DrawBase { get; set; }
Public Overridable Property DrawBase As Boolean
    Get
    Set
public:
virtual property bool DrawBase {
    bool get ();
    void set (bool value);
}
abstract DrawBase : bool with get, set
override DrawBase : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.FixedLayout Property

RegionBaseFixedLayout Property

Defines if modeling options of the Region could be modified.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool FixedLayout { get; set; }
Public Overridable Property FixedLayout As Boolean
    Get
    Set
public:
virtual property bool FixedLayout {
    bool get ();
    void set (bool value);
}
abstract FixedLayout : bool with get, set
override FixedLayout : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Focused Property

RegionBaseFocused Property

Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяется актуальностью информации элемента (свойство InDate).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Focused { get; set; }
Public Overridable Property Focused As Boolean
    Get
    Set
public:
virtual property bool Focused {
    bool get ();
    void set (bool value);
}
abstract Focused : bool with get, set
override Focused : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentObjectFocused
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Font Property

RegionBaseFont Property

Шрифт используемый элементом.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontInfo Font { get; set; }
Public Property Font As FontInfo
    Get
    Set
public:
property FontInfo^ Font {
    FontInfo^ get ();
    void set (FontInfo^ value);
}
member Font : FontInfo with get, set

Property Value

Type: FontInfo
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.FontHeight Property

RegionBaseFontHeight Property

Размер используемого элементом шрифта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual float FontHeight { get; set; }
Public Overridable Property FontHeight As Single
    Get
    Set
public:
virtual property float FontHeight {
    float get ();
    void set (float value);
}
abstract FontHeight : float32 with get, set
override FontHeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Id Property

RegionBaseId Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.InnerBounds Property

RegionBaseInnerBounds Property

Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Rectangle InnerBounds { get; }
Public Overridable ReadOnly Property InnerBounds As Rectangle
    Get
public:
virtual property Rectangle InnerBounds {
    Rectangle get ();
}
abstract InnerBounds : Rectangle with get
override InnerBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.IsActivated Property

RegionBaseIsActivated Property

Determines whether Region is activated and registered on the worksheet.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsActivated { get; }
Public ReadOnly Property IsActivated As Boolean
    Get
public:
virtual property bool IsActivated {
    bool get () sealed;
}
abstract IsActivated : bool with get
override IsActivated : bool with get

Property Value

Type: Boolean

Implements

IDocumentObjectIsActivated
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.IsIntegratedRegion Property

RegionBaseIsIntegratedRegion Property

Determines whether Region is integarted as an important part of another Rerion or not.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsIntegratedRegion { get; }
Public ReadOnly Property IsIntegratedRegion As Boolean
    Get
public:
property bool IsIntegratedRegion {
    bool get ();
}
member IsIntegratedRegion : bool with get

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Link Property

RegionBaseLink Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual string Link { get; set; }
Public Overridable Property Link As String
    Get
    Set
public:
virtual property String^ Link {
    String^ get ();
    void set (String^ value);
}
abstract Link : string with get, set
override Link : string with get, set

Property Value

Type: String
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Location Property

RegionBaseLocation Property

Location of the Region.Абсолютные координаты элемента листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Point Location { get; set; }
Public Overridable Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get ();
    void set (Point value);
}
abstract Location : Point with get, set
override Location : Point with get, set

Property Value

Type: Point

Implements

IDocumentObjectLocation
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.MetaData Property

RegionBaseMetaData Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionBaseRegionMetaData> MetaData { get; set; }
Public Property MetaData As List(Of RegionBaseRegionMetaData)
    Get
    Set
public:
property List<RegionBaseRegionMetaData^>^ MetaData {
    List<RegionBaseRegionMetaData^>^ get ();
    void set (List<RegionBaseRegionMetaData^>^ value);
}
member MetaData : List<RegionBaseRegionMetaData> with get, set

Property Value

Type: ListRegionBaseRegionMetaData
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Middle Property

RegionBaseMiddle Property

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use MiddleLine instead.")]
public virtual int Middle { get; }
<ObsoleteAttribute("Use MiddleLine instead.")>
Public Overridable ReadOnly Property Middle As Integer
    Get
public:
[ObsoleteAttribute(L"Use MiddleLine instead.")]
virtual property int Middle {
    int get ();
}
[<ObsoleteAttribute("Use MiddleLine instead.")>]
abstract Middle : int with get
[<ObsoleteAttribute("Use MiddleLine instead.")>]
override Middle : int with get

Property Value

Type: Int32
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.MiddleLine Property

RegionBaseMiddleLine Property

Gets middle line for the Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual float MiddleLine { get; }
Public Overridable ReadOnly Property MiddleLine As Single
    Get
public:
virtual property float MiddleLine {
    float get ();
}
abstract MiddleLine : float32 with get
override MiddleLine : float32 with get

Property Value

Type: Single
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.PageBreaks Property

RegionBasePageBreaks Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ParallelList<int> PageBreaks { get; }
Public ReadOnly Property PageBreaks As ParallelList(Of Integer)
    Get
public:
property ParallelList<int>^ PageBreaks {
    ParallelList<int>^ get ();
}
member PageBreaks : ParallelList<int> with get

Property Value

Type: ParallelList Int32
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Parent Property

RegionBaseParent Property

Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Worksheet Parent { get; set; }
Public Property Parent As Worksheet
    Get
    Set
public:
property Worksheet^ Parent {
    Worksheet^ get ();
    void set (Worksheet^ value);
}
member Parent : Worksheet with get, set

Property Value

Type: Worksheet
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Regions Property

RegionBaseRegions Property

Children of the current Region.Дочерние элементы листа текущего.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionBase> Regions { get; protected set; }
Public Property Regions As List(Of RegionBase)
    Get
    Protected Set
public:
property List<RegionBase^>^ Regions {
    List<RegionBase^>^ get ();
    protected: void set (List<RegionBase^>^ value);
}
member Regions : List<RegionBase> with get, set

Property Value

Type: ListRegionBase
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.RemoteOwner Property

RegionBaseRemoteOwner Property

Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string RemoteOwner { get; set; }
Public Property RemoteOwner As String
    Get
    Set
public:
property String^ RemoteOwner {
    String^ get ();
    void set (String^ value);
}
member RemoteOwner : string with get, set

Property Value

Type: String
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Right Property

RegionBaseRight Property

Правая граница элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Right { get; }
Public ReadOnly Property Right As Integer
    Get
public:
property int Right {
    int get ();
}
member Right : int with get

Property Value

Type: Int32
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Selected Property

RegionBaseSelected Property

Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
virtual property bool Selected {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract Selected : bool with get, set
override Selected : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentObjectSelected
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.SelectedBackColor Property

RegionBaseSelectedBackColor Property

Выделенный фоновый цвет элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color SelectedBackColor { get; }
Public ReadOnly Property SelectedBackColor As Color
    Get
public:
property Color SelectedBackColor {
    Color get ();
}
member SelectedBackColor : Color with get

Property Value

Type: Color
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.SelectedTextColor Property

RegionBaseSelectedTextColor Property

Цвет выделенного текста элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color SelectedTextColor { get; }
Public ReadOnly Property SelectedTextColor As Color
    Get
public:
property Color SelectedTextColor {
    Color get ();
}
member SelectedTextColor : Color with get

Property Value

Type: Color
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.SessionProfile Property

RegionBaseSessionProfile Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected SessionProfile SessionProfile { get; }
Protected ReadOnly Property SessionProfile As SessionProfile
    Get
protected:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
}
member SessionProfile : SessionProfile with get

Property Value

Type: SessionProfile
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Size Property

RegionBaseSize Property

Size of the Region.Размер элемента листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get ();
    void set (Size value);
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

IDocumentObjectSize
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.TabStop Property

RegionBaseTabStop Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool TabStop { get; }
Public Overridable ReadOnly Property TabStop As Boolean
    Get
public:
virtual property bool TabStop {
    bool get ();
}
abstract TabStop : bool with get
override TabStop : bool with get

Property Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.TextColor Property

RegionBaseTextColor Property

Цвет текста элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Color TextColor { get; set; }
Public Overridable Property TextColor As Color
    Get
    Set
public:
virtual property Color TextColor {
    Color get ();
    void set (Color value);
}
abstract TextColor : Color with get, set
override TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.UniqueId Property

RegionBaseUniqueId Property

Unique Id of the Region.Уникальный идентификатор элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
member UniqueId : string with get, set

Property Value

Type: String
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase Methods

The RegionBase type exposes the following members.

Methods
 | Name | Description
Public method | BeforeCopy |
Public method | BeforePaste |
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе).
Public method | ChangeStatus(String) |
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) |
Protected method | ChildRepainting |
Public method | ClickMenuButton |
Public method | Clone |
Public method | Copy |
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений.
Public method | Dispose |
Public method | Draw |
Public method | DrawToBitmap | Получение изображения элемента.
Public method | DrawToBitmap(IGraphics) |
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом.
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml |
Protected method | GetAllChildren |
Public method | GetCursorType | Defines a cursor type by pointer location.Определение вида курсора.
Public method | GetFocusedPart |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetHistoryStep |
Public method | GetSelectionStatus |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout |
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку.
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend |
Public method | OnCommandSend |
Public method | OnKeyDown |
Public method | OnKeyPress |
Public method | OnKeyUp |
Public method | OnMouseDown |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | OnMouseWheel |
Public method | OnPaint |
Public method | OnSelectionUpdate |
Public method | Paste |
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.
Public method | PrePainter(IGraphics) |
 | ReadyToChangeLocation | Obsolete.
Public method | ReadyToPaint | Obsolete.
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные).
Protected method | Resize | Генерирует событие изменения размера.
Public method | ShowAvailableTermsList |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo |
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.IComparable(RegionBase).CompareTo Method

RegionBaseIComparableRegionBaseCompareTo Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int IComparable<RegionBase>.CompareTo(
    RegionBase other
)
Private Function CompareTo (
    other As RegionBase
) As Integer Implements IComparable(Of RegionBase).CompareTo
private:
virtual int CompareTo(
    RegionBase^ other
) sealed = IComparable<RegionBase^>::CompareTo
private abstract CompareTo :
        other : RegionBase -> int
private override CompareTo :
        other : RegionBase -> int

Parameters

other
Type: SMath.ControlsRegionBase

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BeforeCopy Method

RegionBaseBeforeCopy Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool BeforeCopy(
    IClipboardManager clipboard
)
Public Function BeforeCopy (
    clipboard As IClipboardManager
) As Boolean
public:
bool BeforeCopy(
    IClipboardManager^ clipboard
)
member BeforeCopy :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BeforePaste Method

RegionBaseBeforePaste Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool BeforePaste(
    IClipboardManager clipboard
)
Public Function BeforePaste (
    clipboard As IClipboardManager
) As Boolean
public:
bool BeforePaste(
    IClipboardManager^ clipboard
)
member BeforePaste :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ChangeLocation Method

RegionBaseChangeLocation Method

Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ChangeLocation(
    Point value,
    bool setCache
)
Public Function ChangeLocation (
    value As Point,
    setCache As Boolean
) As Boolean
public:
bool ChangeLocation(
    Point value,
    bool setCache
)
member ChangeLocation :
        value : Point *
        setCache : bool -> bool

Parameters

value
Type: System.DrawingPoint
Новое положение элемента.
setCache
Type: SystemBoolean

Return Value

Type: Boolean
Результат применения.
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ChangeStatus Method

RegionBaseChangeStatus Method

Overload List
 | Name | Description
Public method | ChangeStatus(String) |
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) |
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ChangeStatus Method (String)

RegionBaseChangeStatus Method (String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeStatus(
    string message
)
Public Sub ChangeStatus (
    message As String
)
public:
void ChangeStatus(
    String^ message
)
member ChangeStatus :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

RegionBase Class
ChangeStatus Overload
SMath.Controls Namespace


RegionBase.ChangeStatus Method (String, Int32, Int32, Stopwatch)

RegionBaseChangeStatus Method (String, Int32, Int32, Stopwatch)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeStatus(
    string message,
    int current,
    int count,
    Stopwatch watch
)
Public Sub ChangeStatus (
    message As String,
    current As Integer,
    count As Integer,
    watch As Stopwatch
)
public:
void ChangeStatus(
    String^ message,
    int current,
    int count,
    Stopwatch^ watch
)
member ChangeStatus :
        message : string *
        current : int *
        count : int *
        watch : Stopwatch -> unit

Parameters

message
Type: SystemString
current
Type: SystemInt32
count
Type: SystemInt32
watch
Type: System.DiagnosticsStopwatch
See Also

Reference

RegionBase Class
ChangeStatus Overload
SMath.Controls Namespace


RegionBase.ChildRepainting Method

RegionBaseChildRepainting Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void ChildRepainting(
    RegionBase sender,
    Rectangle e
)
Protected Overridable Sub ChildRepainting (
    sender As RegionBase,
    e As Rectangle
)
protected:
virtual void ChildRepainting(
    RegionBase^ sender,
    Rectangle e
)
abstract ChildRepainting :
        sender : RegionBase *
        e : Rectangle -> unit
override ChildRepainting :
        sender : RegionBase *
        e : Rectangle -> unit

Parameters

sender
Type: SMath.ControlsRegionBase
e
Type: System.DrawingRectangle
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ClickMenuButton Method

RegionBaseClickMenuButton Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ClickMenuButton(
    string message
)
Public Sub ClickMenuButton (
    message As String
)
public:
void ClickMenuButton(
    String^ message
)
member ClickMenuButton :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Clone Method

RegionBaseClone Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract RegionBase Clone()
Public MustOverride Function Clone As RegionBase
public:
virtual RegionBase^ Clone() abstract
abstract Clone : unit -> RegionBase

Return Value

Type: RegionBase
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Copy Method

RegionBaseCopy Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Copy(
    IClipboardManager clipboard
)
Public Overridable Function Copy (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Copy(
    IClipboardManager^ clipboard
)
abstract Copy :
        clipboard : IClipboardManager -> bool
override Copy :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.CreateHistoryStep Method

RegionBaseCreateHistoryStep Method

Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CreateHistoryStep(
    string referer = ""
)
Public Sub CreateHistoryStep (
    Optional referer As String = ""
)
public:
void CreateHistoryStep(
    String^ referer = L""
)
member CreateHistoryStep :
        ?referer : string
(* Defaults:
        let _referer = defaultArg referer ""
*)
-> unit

Parameters

referer (Optional)
Type: SystemString
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Dispose Method

RegionBaseDispose Method

Releases all resources used by the RegionBase

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Draw Method

RegionBaseDraw Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Draw(
    PaintEventOptions args,
    PageModel pageModel,
    bool exportMode
)
Public Sub Draw (
    args As PaintEventOptions,
    pageModel As PageModel,
    exportMode As Boolean
)
public:
virtual void Draw(
    PaintEventOptions^ args,
    PageModel^ pageModel,
    bool exportMode
) sealed
abstract Draw :
        args : PaintEventOptions *
        pageModel : PageModel *
        exportMode : bool -> unit
override Draw :
        args : PaintEventOptions *
        pageModel : PageModel *
        exportMode : bool -> unit

Parameters

args
Type: SMath.ManagerPaintEventOptions
pageModel
Type: SMath.ManagerPageModel
exportMode
Type: SystemBoolean

Implements

IDocumentObjectDraw(PaintEventOptions, PageModel, Boolean)
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.DrawToBitmap Method

RegionBaseDrawToBitmap Method

Overload List
 | Name | Description
Public method | DrawToBitmap | Получение изображения элемента.
Public method | DrawToBitmap(IGraphics) |
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом.
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна.
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.DrawToBitmap Method

RegionBaseDrawToBitmap Method

Получение изображения элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap DrawToBitmap()
Public Function DrawToBitmap As IBitmap
public:
IBitmap^ DrawToBitmap()
member DrawToBitmap : unit -> IBitmap

Return Value

Type: IBitmap
Изображение элемента.
See Also

Reference

RegionBase Class
DrawToBitmap Overload
SMath.Controls Namespace


RegionBase.DrawToBitmap Method (IGraphics)

RegionBaseDrawToBitmap Method (IGraphics)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawToBitmap(
    IGraphics g
)
Public Overridable Sub DrawToBitmap (
    g As IGraphics
)
public:
virtual void DrawToBitmap(
    IGraphics^ g
)
abstract DrawToBitmap :
        g : IGraphics -> unit
override DrawToBitmap :
        g : IGraphics -> unit

Parameters

g
Type: SMath.DrawingIGraphics
See Also

Reference

RegionBase Class
DrawToBitmap Overload
SMath.Controls Namespace


RegionBase.DrawToBitmap Method (Color, Boolean)

RegionBaseDrawToBitmap Method (Color, Boolean)

Получение изображения элемента с указанным фоновым цветом.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap DrawToBitmap(
    Color bgColor,
    bool ctrlFocused
)
Public Function DrawToBitmap (
    bgColor As Color,
    ctrlFocused As Boolean
) As IBitmap
public:
IBitmap^ DrawToBitmap(
    Color bgColor,
    bool ctrlFocused
)
member DrawToBitmap :
        bgColor : Color *
        ctrlFocused : bool -> IBitmap

Parameters

bgColor
Type: System.DrawingColor
Цвет фона.
ctrlFocused
Type: SystemBoolean
Задаёт должен ли элемент при отрисовки быть в фокусе.

Return Value

Type: IBitmap
Изображение элемента.
See Also

Reference

RegionBase Class
DrawToBitmap Overload
SMath.Controls Namespace


RegionBase.DrawToBitmap Method (IGraphics, Point)

RegionBaseDrawToBitmap Method (IGraphics, Point)

Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void DrawToBitmap(
    IGraphics g,
    Point location
)
Public Overridable Sub DrawToBitmap (
    g As IGraphics,
    location As Point
)
public:
virtual void DrawToBitmap(
    IGraphics^ g,
    Point location
)
abstract DrawToBitmap :
        g : IGraphics *
        location : Point -> unit
override DrawToBitmap :
        g : IGraphics *
        location : Point -> unit

Parameters

g
Type: SMath.DrawingIGraphics
Drawing surface.Контекст рисования.
location
Type: System.DrawingPoint
Location of the Region.Позиция элемента для отрисовки.
See Also

Reference

RegionBase Class
DrawToBitmap Overload
SMath.Controls Namespace


RegionBase.FromXml Method

RegionBaseFromXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void FromXml(
    StorageReader storage,
    FileParsingContext parsingContext
)
Public Overridable Sub FromXml (
    storage As StorageReader,
    parsingContext As FileParsingContext
)
public:
virtual void FromXml(
    StorageReader^ storage,
    FileParsingContext^ parsingContext
)
abstract FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit
override FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageReader
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetAllChildren Method

RegionBaseGetAllChildren Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual ChildrenRegionsList[] GetAllChildren()
Protected Overridable Function GetAllChildren As ChildrenRegionsList()
protected:
virtual array<ChildrenRegionsList^>^ GetAllChildren()
abstract GetAllChildren : unit -> ChildrenRegionsList[]
override GetAllChildren : unit -> ChildrenRegionsList[]

Return Value

Type: ChildrenRegionsList
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetCursorType Method

RegionBaseGetCursorType Method

Defines a cursor type by pointer location.Определение вида курсора.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual CursorType GetCursorType(
    MouseEventOptions point
)
Public Overridable Function GetCursorType (
    point As MouseEventOptions
) As CursorType
public:
virtual CursorType GetCursorType(
    MouseEventOptions^ point
)
abstract GetCursorType :
        point : MouseEventOptions -> CursorType
override GetCursorType :
        point : MouseEventOptions -> CursorType

Parameters

point
Type: SMath.ManagerMouseEventOptions
Context of the pointer.Контекст указателя.

Return Value

Type: CursorType
Cursor type with regards to its context.Вид курсора на основании контекста.
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetFocusedPart Method

RegionBaseGetFocusedPart Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase GetFocusedPart()
Public Function GetFocusedPart As RegionBase
public:
RegionBase^ GetFocusedPart()
member GetFocusedPart : unit -> RegionBase

Return Value

Type: RegionBase
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetHashCode Method

RegionBaseGetHashCode Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetHistoryStep Method

RegionBaseGetHistoryStep Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual HistoryStepBase GetHistoryStep()
Public Overridable Function GetHistoryStep As HistoryStepBase
public:
virtual HistoryStepBase^ GetHistoryStep()
abstract GetHistoryStep : unit -> HistoryStepBase
override GetHistoryStep : unit -> HistoryStepBase

Return Value

Type: HistoryStepBase
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.GetSelectionStatus Method

RegionBaseGetSelectionStatus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual RegionSelectionStatus GetSelectionStatus()
Public Overridable Function GetSelectionStatus As RegionSelectionStatus
public:
virtual RegionSelectionStatus GetSelectionStatus()
abstract GetSelectionStatus : unit -> RegionSelectionStatus
override GetSelectionStatus : unit -> RegionSelectionStatus

Return Value

Type: RegionSelectionStatus
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.InitLayout Method

RegionBaseInitLayout Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void InitLayout()
Public Overridable Sub InitLayout
public:
virtual void InitLayout()
abstract InitLayout : unit -> unit
override InitLayout : unit -> unit
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Invalidate Method

RegionBaseInvalidate Method

Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Invalidate()
Public Sub Invalidate
public:
void Invalidate()
member Invalidate : unit -> unit
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.IsEmpty Method

RegionBaseIsEmpty Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty()
Public Overridable Function IsEmpty As Boolean
public:
virtual bool IsEmpty()
abstract IsEmpty : unit -> bool
override IsEmpty : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnBeforeCommandSend Method

RegionBaseOnBeforeCommandSend Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnBeforeCommandSend(
    string value
)
Public Overridable Function OnBeforeCommandSend (
    value As String
) As Boolean
public:
virtual bool OnBeforeCommandSend(
    String^ value
)
abstract OnBeforeCommandSend :
        value : string -> bool
override OnBeforeCommandSend :
        value : string -> bool

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnCommandSend Method

RegionBaseOnCommandSend Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnCommandSend(
    string value
)
Public Overridable Sub OnCommandSend (
    value As String
)
public:
virtual void OnCommandSend(
    String^ value
)
abstract OnCommandSend :
        value : string -> unit
override OnCommandSend :
        value : string -> unit

Parameters

value
Type: SystemString
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnKeyDown Method

RegionBaseOnKeyDown Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnKeyDown(
    KeyEventOptions e
)
Public Overridable Sub OnKeyDown (
    e As KeyEventOptions
)
public:
virtual void OnKeyDown(
    KeyEventOptions^ e
)
abstract OnKeyDown :
        e : KeyEventOptions -> unit
override OnKeyDown :
        e : KeyEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnKeyPress Method

RegionBaseOnKeyPress Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnKeyPress(
    KeyPressEventOptions e
)
Public Overridable Sub OnKeyPress (
    e As KeyPressEventOptions
)
public:
virtual void OnKeyPress(
    KeyPressEventOptions^ e
)
abstract OnKeyPress :
        e : KeyPressEventOptions -> unit
override OnKeyPress :
        e : KeyPressEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyPressEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnKeyUp Method

RegionBaseOnKeyUp Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnKeyUp(
    KeyEventOptions e
)
Public Overridable Sub OnKeyUp (
    e As KeyEventOptions
)
public:
virtual void OnKeyUp(
    KeyEventOptions^ e
)
abstract OnKeyUp :
        e : KeyEventOptions -> unit
override OnKeyUp :
        e : KeyEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnMouseDown Method

RegionBaseOnMouseDown Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnMouseDown(
    MouseEventOptions e
)
Public Overridable Sub OnMouseDown (
    e As MouseEventOptions
)
public:
virtual void OnMouseDown(
    MouseEventOptions^ e
)
abstract OnMouseDown :
        e : MouseEventOptions -> unit
override OnMouseDown :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnMouseMove Method

RegionBaseOnMouseMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnMouseMove(
    MouseEventOptions e
)
Public Overridable Sub OnMouseMove (
    e As MouseEventOptions
)
public:
virtual void OnMouseMove(
    MouseEventOptions^ e
)
abstract OnMouseMove :
        e : MouseEventOptions -> unit
override OnMouseMove :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnMouseUp Method

RegionBaseOnMouseUp Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnMouseUp(
    MouseEventOptions e
)
Public Overridable Sub OnMouseUp (
    e As MouseEventOptions
)
public:
virtual void OnMouseUp(
    MouseEventOptions^ e
)
abstract OnMouseUp :
        e : MouseEventOptions -> unit
override OnMouseUp :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnMouseWheel Method

RegionBaseOnMouseWheel Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool OnMouseWheel(
    MouseEventOptions e,
    int wheelDelta
)
Public Overridable Function OnMouseWheel (
    e As MouseEventOptions,
    wheelDelta As Integer
) As Boolean
public:
virtual bool OnMouseWheel(
    MouseEventOptions^ e,
    int wheelDelta
)
abstract OnMouseWheel :
        e : MouseEventOptions *
        wheelDelta : int -> bool
override OnMouseWheel :
        e : MouseEventOptions *
        wheelDelta : int -> bool

Parameters

e
Type: SMath.ManagerMouseEventOptions
wheelDelta
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnPaint Method

RegionBaseOnPaint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnPaint(
    PaintEventOptions e
)
Public Overridable Sub OnPaint (
    e As PaintEventOptions
)
public:
virtual void OnPaint(
    PaintEventOptions^ e
)
abstract OnPaint :
        e : PaintEventOptions -> unit
override OnPaint :
        e : PaintEventOptions -> unit

Parameters

e
Type: SMath.ManagerPaintEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.OnSelectionUpdate Method

RegionBaseOnSelectionUpdate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnSelectionUpdate(
    MouseEventOptions e1,
    MouseEventOptions e2
)
Public Overridable Sub OnSelectionUpdate (
    e1 As MouseEventOptions,
    e2 As MouseEventOptions
)
public:
virtual void OnSelectionUpdate(
    MouseEventOptions^ e1,
    MouseEventOptions^ e2
)
abstract OnSelectionUpdate :
        e1 : MouseEventOptions *
        e2 : MouseEventOptions -> unit
override OnSelectionUpdate :
        e1 : MouseEventOptions *
        e2 : MouseEventOptions -> unit

Parameters

e1
Type: SMath.ManagerMouseEventOptions
e2
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Paste Method

RegionBasePaste Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Paste(
    IClipboardManager clipboard
)
Public Overridable Function Paste (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Paste(
    IClipboardManager^ clipboard
)
abstract Paste :
        clipboard : IClipboardManager -> bool
override Paste :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.PrePainter Method

RegionBasePrePainter Method

Overload List
 | Name | Description
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.
Public method | PrePainter(IGraphics) |
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.PrePainter Method

RegionBasePrePainter Method

Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void PrePainter()
Public Overridable Sub PrePainter
public:
virtual void PrePainter()
abstract PrePainter : unit -> unit
override PrePainter : unit -> unit
See Also

Reference

RegionBase Class
PrePainter Overload
SMath.Controls Namespace


RegionBase.PrePainter Method (IGraphics)

RegionBasePrePainter Method (IGraphics)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void PrePainter(
    IGraphics g
)
Public Overridable Sub PrePainter (
    g As IGraphics
)
public:
virtual void PrePainter(
    IGraphics^ g
)
abstract PrePainter :
        g : IGraphics -> unit
override PrePainter :
        g : IGraphics -> unit

Parameters

g
Type: SMath.DrawingIGraphics
See Also

Reference

RegionBase Class
PrePainter Overload
SMath.Controls Namespace


RegionBase.ReadyToChangeLocation Method

RegionBaseReadyToChangeLocation Method

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static bool ReadyToChangeLocation()
<ObsoleteAttribute>
Public Shared Function ReadyToChangeLocation As Boolean
public:
[ObsoleteAttribute]
static bool ReadyToChangeLocation()
[<ObsoleteAttribute>]
static member ReadyToChangeLocation : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ReadyToPaint Method

RegionBaseReadyToPaint Method

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public bool ReadyToPaint()
<ObsoleteAttribute>
Public Function ReadyToPaint As Boolean
public:
[ObsoleteAttribute]
bool ReadyToPaint()
[<ObsoleteAttribute>]
member ReadyToPaint : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ResetColors Method

RegionBaseResetColors Method

Безопасное применение цветов (обновляются все зависимые от цветов переменные).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ResetColors(
    Color textColor,
    Color backColor
)
Public Sub ResetColors (
    textColor As Color,
    backColor As Color
)
public:
void ResetColors(
    Color textColor,
    Color backColor
)
member ResetColors :
        textColor : Color *
        backColor : Color -> unit

Parameters

textColor
Type: System.DrawingColor
Новый цвет текста.
backColor
Type: System.DrawingColor
Новый цвет фона.
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Resize Method

RegionBaseResize Method

Генерирует событие изменения размера.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Resize()
Protected Overridable Sub Resize
protected:
virtual void Resize()
abstract Resize : unit -> unit
override Resize : unit -> unit
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ShowAvailableTermsList Method

RegionBaseShowAvailableTermsList Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowAvailableTermsList()
Public Sub ShowAvailableTermsList
public:
void ShowAvailableTermsList()
member ShowAvailableTermsList : unit -> unit
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ToXml Method

RegionBaseToXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void ToXml(
    StorageWriter storage,
    FileParsingContext parsingContext
)
Public Overridable Sub ToXml (
    storage As StorageWriter,
    parsingContext As FileParsingContext
)
public:
virtual void ToXml(
    StorageWriter^ storage,
    FileParsingContext^ parsingContext
)
abstract ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit
override ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageWriter
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase Events

The RegionBase type exposes the following members.

Events
 | Name | Description
Public event | AvailableTermsListShow |
Public event | BeforeLocationChanged |
Public event | Changed |
Public event | FocusChanged |
Public event | MenuButtonClick |
Public event | PaintRequested |
Public event | ProgressChanged |
Public event | Resized |
Public event | StatusChanged |
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.AvailableTermsListShow Event

RegionBaseAvailableTermsListShow Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler AvailableTermsListShow
Public Event AvailableTermsListShow As RegionEventHandler
public:
 event RegionEventHandler^ AvailableTermsListShow {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member AvailableTermsListShow : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.BeforeLocationChanged Event

RegionBaseBeforeLocationChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler BeforeLocationChanged
Public Event BeforeLocationChanged As RegionEventHandler
public:
 event RegionEventHandler^ BeforeLocationChanged {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member BeforeLocationChanged : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Changed Event

RegionBaseChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler Changed
Public Event Changed As RegionEventHandler
public:
 event RegionEventHandler^ Changed {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member Changed : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.FocusChanged Event

RegionBaseFocusChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler FocusChanged
Public Event FocusChanged As RegionEventHandler
public:
 event RegionEventHandler^ FocusChanged {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member FocusChanged : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.MenuButtonClick Event

RegionBaseMenuButtonClick Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event StatusEventHandler MenuButtonClick
Public Event MenuButtonClick As StatusEventHandler
public:
 event StatusEventHandler^ MenuButtonClick {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}
member MenuButtonClick : IEvent<StatusEventHandler,
    EventArgs>

Value

Type: SMath.ControlsStatusEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.PaintRequested Event

RegionBasePaintRequested Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event PaintEventHandler PaintRequested
Public Event PaintRequested As PaintEventHandler
public:
 event PaintEventHandler^ PaintRequested {
    void add (PaintEventHandler^ value);
    void remove (PaintEventHandler^ value);
}
member PaintRequested : IEvent<PaintEventHandler,
    EventArgs>

Value

Type: SMath.ControlsPaintEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.ProgressChanged Event

RegionBaseProgressChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ProgressEventHandler ProgressChanged
Public Event ProgressChanged As ProgressEventHandler
public:
 event ProgressEventHandler^ ProgressChanged {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}
member ProgressChanged : IEvent<ProgressEventHandler,
    EventArgs>

Value

Type: SMath.ControlsProgressEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.Resized Event

RegionBaseResized Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler Resized
Public Event Resized As RegionEventHandler
public:
 event RegionEventHandler^ Resized {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member Resized : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.StatusChanged Event

RegionBaseStatusChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event StatusEventHandler StatusChanged
Public Event StatusChanged As StatusEventHandler
public:
 event StatusEventHandler^ StatusChanged {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}
member StatusChanged : IEvent<StatusEventHandler,
    EventArgs>

Value

Type: SMath.ControlsStatusEventHandler
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase Fields

The RegionBase type exposes the following members.

Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования.
Protected field | dblclick |
Protected field | pen | Массив "карандашей" для рисования.
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения.
Top
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.brush Field

RegionBasebrush Field

Массив "кистей" для рисования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ColorBrush[] brush
Protected brush As ColorBrush()
protected:
array<ColorBrush^>^ brush
val mutable brush: ColorBrush[]

Field Value

Type: ColorBrush
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.dblclick Field

RegionBasedblclick Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Timer dblclick
Protected dblclick As Timer
protected:
Timer^ dblclick
val mutable dblclick: Timer

Field Value

Type: Timer
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.pen Field

RegionBasepen Field

Массив "карандашей" для рисования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ColorPen[] pen
Protected pen As ColorPen()
protected:
array<ColorPen^>^ pen
val mutable pen: ColorPen[]

Field Value

Type: ColorPen
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.referer Field

RegionBasereferer Field

Note: This API is now obsolete.

Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Functionality will be reworked. Don't use it.",
    false)]
public string referer
<ObsoleteAttribute("Functionality will be reworked. Don't use it.",
    false)>
Public referer As String
public:
[ObsoleteAttribute(L"Functionality will be reworked. Don't use it.",
    false)]
String^ referer
[<ObsoleteAttribute("Functionality will be reworked. Don't use it.",
    false)>]
val mutable referer: string

Field Value

Type: String
See Also

Reference

RegionBase Class
SMath.Controls Namespace


RegionBase.RegionMetaData Class

RegionBaseRegionMetaData Class

Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBaseRegionMetaData

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RegionMetaData
Public Class RegionMetaData
public ref class RegionMetaData
type RegionMetaData =  class end

The RegionBaseRegionMetaData type exposes the following members.

Constructors
 | Name | Description
Public method | RegionBaseRegionMetaData | Initializes a new instance of the RegionBaseRegionMetaData class
Top
Properties
 | Name | Description
Public property | Language |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


RegionBase.RegionMetaData Constructor

RegionBaseRegionMetaData Constructor

Initializes a new instance of the RegionBaseRegionMetaData class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionMetaData()
Public Sub New
public:
RegionMetaData()
new : unit -> RegionMetaData
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionMetaData Properties

The RegionBaseRegionMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Language |
Public property | Name |
Public property | Value |
Top
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionBase.RegionMetaData.Language Property

RegionBaseRegionMetaDataLanguage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Property Value

Type: String
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionBase.RegionMetaData.Name Property

RegionBaseRegionMetaDataName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionBase.RegionMetaData.Value Property

RegionBaseRegionMetaDataValue Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionMetaData Methods

The RegionBaseRegionMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegionBaseRegionMetaData Class
SMath.Controls Namespace


RegionEvaluable Class

Base class for every worksheet Region that supports evaluation.Базовый класс всех элементов листа расчётов, поддерживающих вычисление.
Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBase
SMath.ControlsRegionEvaluable
SMath.ControlsMissingRegion
SMath.ControlsRegionHolderT

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RegionEvaluable : RegionBase,
    IEvaluableObject, IDocumentObject, IEvaluable
Public MustInherit Class RegionEvaluable
    Inherits RegionBase
    Implements IEvaluableObject, IDocumentObject, IEvaluable
public ref class RegionEvaluable abstract : public RegionBase,
    IEvaluableObject, IDocumentObject, IEvaluable
[<AbstractClassAttribute>]
type RegionEvaluable =
    class
        inherit RegionBase
        interface IEvaluableObject
        interface IDocumentObject
        interface IEvaluable
    end

The RegionEvaluable type exposes the following members.

Constructors
 | Name | Description
Public method | RegionEvaluable(RegionEvaluable) | Initializes a new instance of the RegionEvaluable class
Public method | RegionEvaluable(SessionProfile) | Initializes a new instance of the RegionEvaluable class
Top
Properties
 | Name | Description
Public property | ActiveDebugTermIndex |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | (Overrides RegionBaseBaseSize.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Overrides RegionBaseCurrentCursorLocation.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes |
Public property | DebugTerms |
Public property | DeletedValues |
Public property | Dependences | (Inherited from RegionBase.)
Public property | DescriptionBounds |
Public property | DescriptionLocation |
Public property | DescriptionText |
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента.
Public property | ErrorTerm |
Public property | ErrorText | Текст ошибки элемента.
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении.
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Overrides RegionBaseFocused.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой.
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент.
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Overrides RegionBaseInnerBounds.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Overrides RegionBaseMiddleLine.)
Public property | Optimization |
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes |
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription |
Public property | Size | Размер элемента управления. (Overrides RegionBaseSize.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | Terms | Массив элементов математического выражения.
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values |
Public property | WarningColor | Цвет предупреждений элемента.
Top
Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | Checks if it is required to recalculate page due to the element.Проверяет, необходимо ли из-за данного элемента пересчитывать весь лист.
 | CheckForMissingParenthesis |
Protected method | ChildRepainting | (Overrides RegionBaseChildRepainting(RegionBase, Rectangle).)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | Copy | (Overrides RegionBaseCopy(IClipboardManager).)
Public method | CreateDescription |
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Inherited from RegionBase.)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetcurrentTermsContainer |
Public method | GetCursorType | (Overrides RegionBaseGetCursorType(MouseEventOptions).)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Overrides RegionBaseGetHistoryStep.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Overrides RegionBaseInitLayout.)
Public method | InitLayout(Store) |
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Public method | MarkOutOfDate | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Overrides RegionBaseOnCommandSend(String).)
Public method | OnCommandSend(Term) |
Public method | OnEvaluation |
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Overrides RegionBaseOnMouseDown(MouseEventOptions).)
Public method | OnMouseMove | (Overrides RegionBaseOnMouseMove(MouseEventOptions).)
Public method | OnMouseUp | (Overrides RegionBaseOnMouseUp(MouseEventOptions).)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Overrides RegionBaseOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Overrides RegionBasePaste(IClipboardManager).)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath |
Public method | ReadXmlProperties |
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | Requests Worksheet to perform evaluation starting from the current Region.Запрашивает лист расчётов инициировать вычисление, начиная с текущего элемента листа.
Public method | RequestForEvaluation | Obsolete.
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении.
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | (Inherited from RegionBase.)
Public method | WriteMath |
Public method | WriteXmlProperties |
Top
Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured |
Public event | EvaluationRequest |
Public event | EvaluationStateChanged |
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description |
Public field | DescriptionPosition | Obsolete.
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Protected field | terms |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

SMath.Controls Namespace


RegionEvaluable Constructor

Overload List
 | Name | Description
Public method | RegionEvaluable(RegionEvaluable) | Initializes a new instance of the RegionEvaluable class
Public method | RegionEvaluable(SessionProfile) | Initializes a new instance of the RegionEvaluable class
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable Constructor (RegionEvaluable)

Initializes a new instance of the RegionEvaluable class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionEvaluable(
    RegionEvaluable value
)
Public Sub New (
    value As RegionEvaluable
)
public:
RegionEvaluable(
    RegionEvaluable^ value
)
new :
        value : RegionEvaluable -> RegionEvaluable

Parameters

value
Type: SMath.ControlsRegionEvaluable
See Also

Reference

RegionEvaluable Class
RegionEvaluable Overload
SMath.Controls Namespace


RegionEvaluable Constructor (SessionProfile)

Initializes a new instance of the RegionEvaluable class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionEvaluable(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
RegionEvaluable(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> RegionEvaluable

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

RegionEvaluable Class
RegionEvaluable Overload
SMath.Controls Namespace


RegionEvaluable Properties

The RegionEvaluable type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDebugTermIndex |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | (Overrides RegionBaseBaseSize.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Overrides RegionBaseCurrentCursorLocation.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes |
Public property | DebugTerms |
Public property | DeletedValues |
Public property | Dependences | (Inherited from RegionBase.)
Public property | DescriptionBounds |
Public property | DescriptionLocation |
Public property | DescriptionText |
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента.
Public property | ErrorTerm |
Public property | ErrorText | Текст ошибки элемента.
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении.
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Overrides RegionBaseFocused.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой.
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент.
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Overrides RegionBaseInnerBounds.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Overrides RegionBaseMiddleLine.)
Public property | Optimization |
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes |
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription |
Public property | Size | Размер элемента управления. (Overrides RegionBaseSize.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | Terms | Массив элементов математического выражения.
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values |
Public property | WarningColor | Цвет предупреждений элемента.
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ActiveDebugTermIndex Property

RegionEvaluableActiveDebugTermIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ActiveDebugTermIndex { get; set; }
Public Property ActiveDebugTermIndex As Integer
    Get
    Set
public:
property int ActiveDebugTermIndex {
    int get ();
    void set (int value);
}
member ActiveDebugTermIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.BaseSize Property

RegionEvaluableBaseSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Size BaseSize { get; }
Public Overrides ReadOnly Property BaseSize As Size
    Get
public:
virtual property Size BaseSize {
    Size get () override;
}
abstract BaseSize : Size with get
override BaseSize : Size with get

Property Value

Type: Size
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.CurrentCursorLocation Property

RegionEvaluableCurrentCursorLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Rectangle CurrentCursorLocation { get; }
Public Overrides ReadOnly Property CurrentCursorLocation As Rectangle
    Get
public:
virtual property Rectangle CurrentCursorLocation {
    Rectangle get () override;
}
abstract CurrentCursorLocation : Rectangle with get
override CurrentCursorLocation : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.CurrentTermIndexes Property

RegionEvaluableCurrentTermIndexes Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual int[] CurrentTermIndexes { get; set; }
Public Overridable Property CurrentTermIndexes As Integer()
    Get
    Set
public:
virtual property array<int>^ CurrentTermIndexes {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract CurrentTermIndexes : int[] with get, set
override CurrentTermIndexes : int[] with get, set

Property Value

Type: Int32
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DebugTerms Property

RegionEvaluableDebugTerms Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<Term, PointF> DebugTerms { get; set; }
Public Property DebugTerms As Dictionary(Of Term, PointF)
    Get
    Set
public:
property Dictionary<Term^, PointF>^ DebugTerms {
    Dictionary<Term^, PointF>^ get ();
    void set (Dictionary<Term^, PointF>^ value);
}
member DebugTerms : Dictionary<Term, PointF> with get, set

Property Value

Type: DictionaryTerm, PointF
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DeletedValues Property

RegionEvaluableDeletedValues Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual List<IPrimitive> DeletedValues { get; }
Public Overridable ReadOnly Property DeletedValues As List(Of IPrimitive)
    Get
public:
virtual property List<IPrimitive^>^ DeletedValues {
    List<IPrimitive^>^ get ();
}
abstract DeletedValues : List<IPrimitive> with get
override DeletedValues : List<IPrimitive> with get

Property Value

Type: ListIPrimitive
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DescriptionBounds Property

RegionEvaluableDescriptionBounds Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF DescriptionBounds { get; }
Public ReadOnly Property DescriptionBounds As RectangleF
    Get
public:
property RectangleF DescriptionBounds {
    RectangleF get ();
}
member DescriptionBounds : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DescriptionLocation Property

RegionEvaluableDescriptionLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ElementPosition DescriptionLocation { get; set; }
Public Property DescriptionLocation As ElementPosition
    Get
    Set
public:
property ElementPosition DescriptionLocation {
    ElementPosition get ();
    void set (ElementPosition value);
}
member DescriptionLocation : ElementPosition with get, set

Property Value

Type: ElementPosition
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DescriptionText Property

RegionEvaluableDescriptionText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string DescriptionText { get; }
Public ReadOnly Property DescriptionText As String
    Get
public:
property String^ DescriptionText {
    String^ get ();
}
member DescriptionText : string with get

Property Value

Type: String
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ErrorId Property

RegionEvaluableErrorId Property

Идентификатор ошибки, произошедшей внутри элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Errors ErrorId { get; set; }
Public Overridable Property ErrorId As Errors
    Get
    Set
public:
virtual property Errors ErrorId {
    Errors get ();
    void set (Errors value);
}
abstract ErrorId : Errors with get, set
override ErrorId : Errors with get, set

Property Value

Type: Errors
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ErrorTerm Property

RegionEvaluableErrorTerm Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual int ErrorTerm { get; set; }
Public Overridable Property ErrorTerm As Integer
    Get
    Set
public:
virtual property int ErrorTerm {
    int get ();
    void set (int value);
}
abstract ErrorTerm : int with get, set
override ErrorTerm : int with get, set

Property Value

Type: Int32
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ErrorText Property

RegionEvaluableErrorText Property

Текст ошибки элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual string ErrorText { get; set; }
Public Overridable Property ErrorText As String
    Get
    Set
public:
virtual property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
abstract ErrorText : string with get, set
override ErrorText : string with get, set

Property Value

Type: String
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Evaluable Property

RegionEvaluableEvaluable Property

Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool Evaluable { get; set; }
Public Overridable Property Evaluable As Boolean
    Get
    Set
public:
virtual property bool Evaluable {
    bool get ();
    void set (bool value);
}
abstract Evaluable : bool with get, set
override Evaluable : bool with get, set

Property Value

Type: Boolean

Implements

IEvaluableEvaluable
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Focused Property

RegionEvaluableFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Focused { get; set; }
Public Overrides Property Focused As Boolean
    Get
    Set
public:
virtual property bool Focused {
    bool get () override;
    void set (bool value) override;
}
abstract Focused : bool with get, set
override Focused : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentObjectFocused
IDocumentObjectFocused
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.InDate Property

RegionEvaluableInDate Property

Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool InDate { get; set; }
Public Overridable Property InDate As Boolean
    Get
    Set
public:
virtual property bool InDate {
    bool get ();
    void set (bool value);
}
abstract InDate : bool with get, set
override InDate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.InEvaluation Property

RegionEvaluableInEvaluation Property

Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool InEvaluation { get; set; }
Public Overridable Property InEvaluation As Boolean
    Get
    Set
public:
virtual property bool InEvaluation {
    bool get ();
    void set (bool value);
}
abstract InEvaluation : bool with get, set
override InEvaluation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.InnerBounds Property

RegionEvaluableInnerBounds Property

Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Rectangle InnerBounds { get; }
Public Overrides ReadOnly Property InnerBounds As Rectangle
    Get
public:
virtual property Rectangle InnerBounds {
    Rectangle get () override;
}
abstract InnerBounds : Rectangle with get
override InnerBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.MiddleLine Property

RegionEvaluableMiddleLine Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override float MiddleLine { get; }
Public Overrides ReadOnly Property MiddleLine As Single
    Get
public:
virtual property float MiddleLine {
    float get () override;
}
abstract MiddleLine : float32 with get
override MiddleLine : float32 with get

Property Value

Type: Single
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Optimization Property

RegionEvaluableOptimization Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OptimizationType Optimization { get; set; }
Public Property Optimization As OptimizationType
    Get
    Set
public:
property OptimizationType Optimization {
    OptimizationType get ();
    void set (OptimizationType value);
}
member Optimization : OptimizationType with get, set

Property Value

Type: OptimizationType
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.SelectedTermsIndexes Property

RegionEvaluableSelectedTermsIndexes Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual int[] SelectedTermsIndexes { get; set; }
Public Overridable Property SelectedTermsIndexes As Integer()
    Get
    Set
public:
virtual property array<int>^ SelectedTermsIndexes {
    array<int>^ get ();
    void set (array<int>^ value);
}
abstract SelectedTermsIndexes : int[] with get, set
override SelectedTermsIndexes : int[] with get, set

Property Value

Type: Int32
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ShowDescription Property

RegionEvaluableShowDescription Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowDescription { get; set; }
Public Property ShowDescription As Boolean
    Get
    Set
public:
property bool ShowDescription {
    bool get ();
    void set (bool value);
}
member ShowDescription : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Size Property

RegionEvaluableSize Property

Размер элемента управления.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () override;
    void set (Size value) override;
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

IDocumentObjectSize
IDocumentObjectSize
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Terms Property

RegionEvaluableTerms Property

Массив элементов математического выражения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Term[] Terms { get; set; }
Public Overridable Property Terms As Term()
    Get
    Set
public:
virtual property array<Term^>^ Terms {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
abstract Terms : Term[] with get, set
override Terms : Term[] with get, set

Property Value

Type: Term
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Values Property

RegionEvaluableValues Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual List<Definition> Values { get; }
Public Overridable ReadOnly Property Values As List(Of Definition)
    Get
public:
virtual property List<Definition^>^ Values {
    List<Definition^>^ get ();
}
abstract Values : List<Definition> with get
override Values : List<Definition> with get

Property Value

Type: ListDefinition
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.WarningColor Property

RegionEvaluableWarningColor Property

Цвет предупреждений элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual Color WarningColor { get; set; }
Public Overridable Property WarningColor As Color
    Get
    Set
public:
virtual property Color WarningColor {
    Color get ();
    void set (Color value);
}
abstract WarningColor : Color with get, set
override WarningColor : Color with get, set

Property Value

Type: Color
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable Methods

The RegionEvaluable type exposes the following members.

Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | Checks if it is required to recalculate page due to the element.Проверяет, необходимо ли из-за данного элемента пересчитывать весь лист.
 | CheckForMissingParenthesis |
Protected method | ChildRepainting | (Overrides RegionBaseChildRepainting(RegionBase, Rectangle).)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | Copy | (Overrides RegionBaseCopy(IClipboardManager).)
Public method | CreateDescription |
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Inherited from RegionBase.)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetcurrentTermsContainer |
Public method | GetCursorType | (Overrides RegionBaseGetCursorType(MouseEventOptions).)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Overrides RegionBaseGetHistoryStep.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Overrides RegionBaseInitLayout.)
Public method | InitLayout(Store) |
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Public method | MarkOutOfDate | Obsolete.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Overrides RegionBaseOnCommandSend(String).)
Public method | OnCommandSend(Term) |
Public method | OnEvaluation |
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Overrides RegionBaseOnMouseDown(MouseEventOptions).)
Public method | OnMouseMove | (Overrides RegionBaseOnMouseMove(MouseEventOptions).)
Public method | OnMouseUp | (Overrides RegionBaseOnMouseUp(MouseEventOptions).)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Overrides RegionBaseOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Overrides RegionBasePaste(IClipboardManager).)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath |
Public method | ReadXmlProperties |
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | Requests Worksheet to perform evaluation starting from the current Region.Запрашивает лист расчётов инициировать вычисление, начиная с текущего элемента листа.
Public method | RequestForEvaluation | Obsolete.
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении.
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToXml | (Inherited from RegionBase.)
Public method | WriteMath |
Public method | WriteXmlProperties |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.CheckEvaluability Method

RegionEvaluableCheckEvaluability Method

Checks if it is required to recalculate page due to the element.Проверяет, необходимо ли из-за данного элемента пересчитывать весь лист.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool CheckEvaluability()
Public Overridable Function CheckEvaluability As Boolean
public:
virtual bool CheckEvaluability()
abstract CheckEvaluability : unit -> bool
override CheckEvaluability : unit -> bool

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.CheckForMissingParenthesis Method

RegionEvaluableCheckForMissingParenthesis Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool CheckForMissingParenthesis(
    ref Term[] terms
)
Public Shared Function CheckForMissingParenthesis (
    ByRef terms As Term()
) As Boolean
public:
static bool CheckForMissingParenthesis(
    array<Term^>^% terms
)
static member CheckForMissingParenthesis :
        terms : Term[] byref -> bool

Parameters

terms
Type: SMath.ManagerTerm

Return Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ChildRepainting Method

RegionEvaluableChildRepainting Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected override void ChildRepainting(
    RegionBase sender,
    Rectangle e
)
Protected Overrides Sub ChildRepainting (
    sender As RegionBase,
    e As Rectangle
)
protected:
virtual void ChildRepainting(
    RegionBase^ sender,
    Rectangle e
) override
abstract ChildRepainting :
        sender : RegionBase *
        e : Rectangle -> unit
override ChildRepainting :
        sender : RegionBase *
        e : Rectangle -> unit

Parameters

sender
Type: SMath.ControlsRegionBase
e
Type: System.DrawingRectangle
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Copy Method

RegionEvaluableCopy Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Copy(
    IClipboardManager clipboard
)
Public Overrides Function Copy (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Copy(
    IClipboardManager^ clipboard
) override
abstract Copy :
        clipboard : IClipboardManager -> bool
override Copy :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.CreateDescription Method

RegionEvaluableCreateDescription Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CreateDescription()
Public Sub CreateDescription
public:
void CreateDescription()
member CreateDescription : unit -> unit
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.GetcurrentTermsContainer Method

RegionEvaluableGetcurrentTermsContainer Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual RegionEvaluable GetcurrentTermsContainer()
Public Overridable Function GetcurrentTermsContainer As RegionEvaluable
public:
virtual RegionEvaluable^ GetcurrentTermsContainer()
abstract GetcurrentTermsContainer : unit -> RegionEvaluable
override GetcurrentTermsContainer : unit -> RegionEvaluable

Return Value

Type: RegionEvaluable
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.GetCursorType Method

RegionEvaluableGetCursorType Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override CursorType GetCursorType(
    MouseEventOptions e
)
Public Overrides Function GetCursorType (
    e As MouseEventOptions
) As CursorType
public:
virtual CursorType GetCursorType(
    MouseEventOptions^ e
) override
abstract GetCursorType :
        e : MouseEventOptions -> CursorType
override GetCursorType :
        e : MouseEventOptions -> CursorType

Parameters

e
Type: SMath.ManagerMouseEventOptions

Return Value

Type: CursorType
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.GetHistoryStep Method

RegionEvaluableGetHistoryStep Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override HistoryStepBase GetHistoryStep()
Public Overrides Function GetHistoryStep As HistoryStepBase
public:
virtual HistoryStepBase^ GetHistoryStep() override
abstract GetHistoryStep : unit -> HistoryStepBase
override GetHistoryStep : unit -> HistoryStepBase

Return Value

Type: HistoryStepBase
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.InitLayout Method

RegionEvaluableInitLayout Method

Overload List
 | Name | Description
Public method | InitLayout | (Overrides RegionBaseInitLayout.)
Public method | InitLayout(Store) |
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.InitLayout Method

RegionEvaluableInitLayout Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void InitLayout()
Public Overrides Sub InitLayout
public:
virtual void InitLayout() override
abstract InitLayout : unit -> unit
override InitLayout : unit -> unit
See Also

Reference

RegionEvaluable Class
InitLayout Overload
SMath.Controls Namespace


RegionEvaluable.InitLayout Method (Store)

RegionEvaluableInitLayout Method (Store)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void InitLayout(
    Store store
)
Public Overridable Sub InitLayout (
    store As Store
)
public:
virtual void InitLayout(
    Store^ store
)
abstract InitLayout :
        store : Store -> unit
override InitLayout :
        store : Store -> unit

Parameters

store
Type: SMath.MathStore
See Also

Reference

RegionEvaluable Class
InitLayout Overload
SMath.Controls Namespace


RegionEvaluable.MarkOutOfDate Method

RegionEvaluableMarkOutOfDate Method

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use RequestEvaluation instead.", true)]
public void MarkOutOfDate()
<ObsoleteAttribute("Use RequestEvaluation instead.", true)>
Public Sub MarkOutOfDate
public:
[ObsoleteAttribute(L"Use RequestEvaluation instead.", true)]
void MarkOutOfDate()
[<ObsoleteAttribute("Use RequestEvaluation instead.", true)>]
member MarkOutOfDate : unit -> unit
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnCommandSend Method

RegionEvaluableOnCommandSend Method

Overload List
 | Name | Description
Public method | OnCommandSend(String) | (Overrides RegionBaseOnCommandSend(String).)
Public method | OnCommandSend(Term) |
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnCommandSend Method (String)

RegionEvaluableOnCommandSend Method (String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnCommandSend(
    string value
)
Public Overrides Sub OnCommandSend (
    value As String
)
public:
virtual void OnCommandSend(
    String^ value
) override
abstract OnCommandSend :
        value : string -> unit
override OnCommandSend :
        value : string -> unit

Parameters

value
Type: SystemString
See Also

Reference

RegionEvaluable Class
OnCommandSend Overload
SMath.Controls Namespace


RegionEvaluable.OnCommandSend Method (Term[])

RegionEvaluableOnCommandSend Method (Term)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void OnCommandSend(
    Term[] value
)
Public Overridable Sub OnCommandSend (
    value As Term()
)
public:
virtual void OnCommandSend(
    array<Term^>^ value
)
abstract OnCommandSend :
        value : Term[] -> unit
override OnCommandSend :
        value : Term[] -> unit

Parameters

value
Type: SMath.ManagerTerm
See Also

Reference

RegionEvaluable Class
OnCommandSend Overload
SMath.Controls Namespace


RegionEvaluable.OnEvaluation Method

RegionEvaluableOnEvaluation Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void OnEvaluation(
    Store store
)
Public MustOverride Sub OnEvaluation (
    store As Store
)
public:
virtual void OnEvaluation(
    Store^ store
) abstract
abstract OnEvaluation :
        store : Store -> unit

Parameters

store
Type: SMath.MathStore
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnMouseDown Method

RegionEvaluableOnMouseDown Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseDown(
    MouseEventOptions e
)
Public Overrides Sub OnMouseDown (
    e As MouseEventOptions
)
public:
virtual void OnMouseDown(
    MouseEventOptions^ e
) override
abstract OnMouseDown :
        e : MouseEventOptions -> unit
override OnMouseDown :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnMouseMove Method

RegionEvaluableOnMouseMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseMove(
    MouseEventOptions e
)
Public Overrides Sub OnMouseMove (
    e As MouseEventOptions
)
public:
virtual void OnMouseMove(
    MouseEventOptions^ e
) override
abstract OnMouseMove :
        e : MouseEventOptions -> unit
override OnMouseMove :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnMouseUp Method

RegionEvaluableOnMouseUp Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseUp(
    MouseEventOptions e
)
Public Overrides Sub OnMouseUp (
    e As MouseEventOptions
)
public:
virtual void OnMouseUp(
    MouseEventOptions^ e
) override
abstract OnMouseUp :
        e : MouseEventOptions -> unit
override OnMouseUp :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.OnPaint Method

RegionEvaluableOnPaint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnPaint(
    PaintEventOptions e
)
Public Overrides Sub OnPaint (
    e As PaintEventOptions
)
public:
virtual void OnPaint(
    PaintEventOptions^ e
) override
abstract OnPaint :
        e : PaintEventOptions -> unit
override OnPaint :
        e : PaintEventOptions -> unit

Parameters

e
Type: SMath.ManagerPaintEventOptions
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Paste Method

RegionEvaluablePaste Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Paste(
    IClipboardManager clipboard
)
Public Overrides Function Paste (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Paste(
    IClipboardManager^ clipboard
) override
abstract Paste :
        clipboard : IClipboardManager -> bool
override Paste :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ReadMath Method

RegionEvaluableReadMath Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ReadMath(
    XmlReader reader,
    string tagName,
    bool skipEncoding,
    FileRequestType requestType,
    FileParsingContext parsingContext
)
Public Sub ReadMath (
    reader As XmlReader,
    tagName As String,
    skipEncoding As Boolean,
    requestType As FileRequestType,
    parsingContext As FileParsingContext
)
public:
void ReadMath(
    XmlReader^ reader,
    String^ tagName,
    bool skipEncoding,
    FileRequestType requestType,
    FileParsingContext^ parsingContext
)
member ReadMath :
        reader : XmlReader *
        tagName : string *
        skipEncoding : bool *
        requestType : FileRequestType *
        parsingContext : FileParsingContext -> unit

Parameters

reader
Type: System.XmlXmlReader
tagName
Type: SystemString
skipEncoding
Type: SystemBoolean
requestType
Type: SMath.ControlsFileRequestType
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ReadXmlProperties Method

RegionEvaluableReadXmlProperties Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ReadXmlProperties(
    PropertiesReader props
)
Public Sub ReadXmlProperties (
    props As PropertiesReader
)
public:
void ReadXmlProperties(
    PropertiesReader^ props
)
member ReadXmlProperties :
        props : PropertiesReader -> unit

Parameters

props
Type: SMath.ControlsPropertiesReader
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.RequestEvaluation Method

RegionEvaluableRequestEvaluation Method

Requests Worksheet to perform evaluation starting from the current Region.Запрашивает лист расчётов инициировать вычисление, начиная с текущего элемента листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void RequestEvaluation(
    bool immediate = false
)
Public Overridable Sub RequestEvaluation (
    Optional immediate As Boolean = false
)
public:
virtual void RequestEvaluation(
    bool immediate = false
)
abstract RequestEvaluation :
        ?immediate : bool
(* Defaults:
        let _immediate = defaultArg immediate false
*)
-> unit
override RequestEvaluation :
        ?immediate : bool
(* Defaults:
        let _immediate = defaultArg immediate false
*)
-> unit

Parameters

immediate (Optional)
Type: SystemBoolean
Performs immediate evaluation or schedules it to be performed based on application settings.Инициирует немедленное вычисление или назначает его согласно настройкам программы.
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.RequestForEvaluation Method

RegionEvaluableRequestForEvaluation Method

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use RequestEvaluation instead.", true)]
public void RequestForEvaluation()
<ObsoleteAttribute("Use RequestEvaluation instead.", true)>
Public Sub RequestForEvaluation
public:
[ObsoleteAttribute(L"Use RequestEvaluation instead.", true)]
void RequestForEvaluation()
[<ObsoleteAttribute("Use RequestEvaluation instead.", true)>]
member RequestForEvaluation : unit -> unit
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.SetEvaluationState Method

RegionEvaluableSetEvaluationState Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetEvaluationState(
    bool state
)
Public Sub SetEvaluationState (
    state As Boolean
)
public:
void SetEvaluationState(
    bool state
)
member SetEvaluationState :
        state : bool -> unit

Parameters

state
Type: SystemBoolean
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ShowError Method

RegionEvaluableShowError Method

Overload List
 | Name | Description
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении.
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении.
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ShowError Method (Exception, IPrimitive)

RegionEvaluableShowError Method (Exception, IPrimitive)

Сообщает об ошибке в элементе при вычислении.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowError(
    Exception e,
    IPrimitive value
)
Public Overridable Sub ShowError (
    e As Exception,
    value As IPrimitive
)
public:
virtual void ShowError(
    Exception^ e,
    IPrimitive^ value
)
abstract ShowError :
        e : Exception *
        value : IPrimitive -> unit
override ShowError :
        e : Exception *
        value : IPrimitive -> unit

Parameters

e
Type: SystemException
Текущая ошибка.
value
Type: SMath.ManagerIPrimitive
Элемент выражения, вызвавший ошибку.
See Also

Reference

RegionEvaluable Class
ShowError Overload
SMath.Controls Namespace


RegionEvaluable.ShowError Method (Exception, Term)

RegionEvaluableShowError Method (Exception, Term)

Сообщает об ошибке в элементе при вычислении.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowError(
    Exception e,
    Term value
)
Public Overridable Sub ShowError (
    e As Exception,
    value As Term
)
public:
virtual void ShowError(
    Exception^ e,
    Term^ value
)
abstract ShowError :
        e : Exception *
        value : Term -> unit
override ShowError :
        e : Exception *
        value : Term -> unit

Parameters

e
Type: SystemException
Текущая ошибка.
value
Type: SMath.ManagerTerm
Элемент выражения, вызвавший ошибку.
See Also

Reference

RegionEvaluable Class
ShowError Overload
SMath.Controls Namespace


RegionEvaluable.WriteMath Method

RegionEvaluableWriteMath Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteMath(
    XmlWriter writer
)
Public Sub WriteMath (
    writer As XmlWriter
)
public:
void WriteMath(
    XmlWriter^ writer
)
member WriteMath :
        writer : XmlWriter -> unit

Parameters

writer
Type: System.XmlXmlWriter
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.WriteXmlProperties Method

RegionEvaluableWriteXmlProperties Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void WriteXmlProperties(
    PropertiesWriter props
)
Public Sub WriteXmlProperties (
    props As PropertiesWriter
)
public:
void WriteXmlProperties(
    PropertiesWriter^ props
)
member WriteXmlProperties :
        props : PropertiesWriter -> unit

Parameters

props
Type: SMath.ControlsPropertiesWriter
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable Events

The RegionEvaluable type exposes the following members.

Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured |
Public event | EvaluationRequest |
Public event | EvaluationStateChanged |
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.ErrorOccured Event

RegionEvaluableErrorOccured Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ErrorOccuredEventHandler ErrorOccured
Public Event ErrorOccured As ErrorOccuredEventHandler
public:
 event ErrorOccuredEventHandler^ ErrorOccured {
    void add (ErrorOccuredEventHandler^ value);
    void remove (ErrorOccuredEventHandler^ value);
}
member ErrorOccured : IEvent<ErrorOccuredEventHandler,
    EventArgs>

Value

Type: SMath.ControlsErrorOccuredEventHandler
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.EvaluationRequest Event

RegionEvaluableEvaluationRequest Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event EvaluateActionEventHandler EvaluationRequest
Public Event EvaluationRequest As EvaluateActionEventHandler
public:
 event EvaluateActionEventHandler^ EvaluationRequest {
    void add (EvaluateActionEventHandler^ value);
    void remove (EvaluateActionEventHandler^ value);
}
member EvaluationRequest : IEvent<EvaluateActionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsEvaluateActionEventHandler
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.EvaluationStateChanged Event

RegionEvaluableEvaluationStateChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEvaluationStateEventHandler EvaluationStateChanged
Public Event EvaluationStateChanged As RegionEvaluationStateEventHandler
public:
 event RegionEvaluationStateEventHandler^ EvaluationStateChanged {
    void add (RegionEvaluationStateEventHandler^ value);
    void remove (RegionEvaluationStateEventHandler^ value);
}
member EvaluationStateChanged : IEvent<RegionEvaluationStateEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEvaluationStateEventHandler
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable Fields

The RegionEvaluable type exposes the following members.

Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description |
Public field | DescriptionPosition | Obsolete.
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Protected field | terms |
Top
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.Description Field

RegionEvaluableDescription Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionTranslatable Description
Public Description As RegionTranslatable
public:
RegionTranslatable^ Description
val mutable Description: RegionTranslatable

Field Value

Type: RegionTranslatable
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.DescriptionPosition Field

RegionEvaluableDescriptionPosition Field

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use DescriptionLocation instead.")]
public ElementPosition DescriptionPosition
<ObsoleteAttribute("Use DescriptionLocation instead.")>
Public DescriptionPosition As ElementPosition
public:
[ObsoleteAttribute(L"Use DescriptionLocation instead.")]
ElementPosition DescriptionPosition
[<ObsoleteAttribute("Use DescriptionLocation instead.")>]
val mutable DescriptionPosition: ElementPosition

Field Value

Type: ElementPosition
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluable.terms Field

RegionEvaluableterms Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Term[] terms
Protected terms As Term()
protected:
array<Term^>^ terms
val mutable terms: Term[]

Field Value

Type: Term
See Also

Reference

RegionEvaluable Class
SMath.Controls Namespace


RegionEvaluationStateEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void RegionEvaluationStateEventHandler(
    RegionEvaluable sender,
    bool state
)
Public Delegate Sub RegionEvaluationStateEventHandler (
    sender As RegionEvaluable,
    state As Boolean
)
public delegate void RegionEvaluationStateEventHandler(
    RegionEvaluable^ sender,
    bool state
)
type RegionEvaluationStateEventHandler =
    delegate of
        sender : RegionEvaluable *
        state : bool -> unit

Parameters

sender
Type: SMath.ControlsRegionEvaluable
state
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


RegionEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void RegionEventHandler(
    RegionBase sender
)
Public Delegate Sub RegionEventHandler (
    sender As RegionBase
)
public delegate void RegionEventHandler(
    RegionBase^ sender
)
type RegionEventHandler =
    delegate of
        sender : RegionBase -> unit

Parameters

sender
Type: SMath.ControlsRegionBase
See Also

Reference

SMath.Controls Namespace


RegionHolder(T) Class

RegionHolderT Class

Region Holder class that implements support for custom Region canvas to be wrapped by the Evaluable Region which supports all the features of the program. It provides built-in Math Region located next to the custom Region.
Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBase
SMath.ControlsRegionEvaluable
SMath.ControlsRegionHolderT

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RegionHolder<T> : RegionEvaluable,
    IRegionWithEditableText, IRegionWithInputData, IRegionWithTooltip, IRegionWithExtendedSearch
where T : RegionEvaluable

Public MustInherit Class RegionHolder(Of T As RegionEvaluable)
    Inherits RegionEvaluable
    Implements IRegionWithEditableText, IRegionWithInputData, IRegionWithTooltip, IRegionWithExtendedSearch
generic<typename T>
where T : RegionEvaluable
public ref class RegionHolder abstract : public RegionEvaluable,
    IRegionWithEditableText, IRegionWithInputData, IRegionWithTooltip, IRegionWithExtendedSearch
[<AbstractClassAttribute>]
type RegionHolder<'T when 'T : RegionEvaluable> =
    class
        inherit RegionEvaluable
        interface IRegionWithEditableText
        interface IRegionWithInputData
        interface IRegionWithTooltip
        interface IRegionWithExtendedSearch
    end

Type Parameters

T
Type of the Custom Region which is to be used as a main graphical representation of the result Region.

The RegionHolderT type exposes the following members.

Constructors
 | Name | Description
Public method | RegionHolderT(RegionHolderT) | Initializes a new instance of the RegionHolderT class
Public method | RegionHolderT(SessionProfile) | Initializes a new instance of the RegionHolderT class
Top
Properties
 | Name | Description
Public property | ActiveDebugTermIndex | (Inherited from RegionEvaluable.)
Public property | BackColor | (Overrides RegionBaseBackColor.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента. (Overrides RegionEvaluableBaseSize.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Protected property | canv | Custom Region which is to be used as a main graphical representation of the result Region.
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Overrides RegionEvaluableCurrentCursorLocation.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes | (Overrides RegionEvaluableCurrentTermIndexes.)
Public property | CursorPosition |
Public property | DebugTerms | (Inherited from RegionEvaluable.)
Public property | DeletedValues | (Inherited from RegionEvaluable.)
Public property | Dependences | (Overrides RegionBaseDependences.)
Public property | DescriptionBounds | (Inherited from RegionEvaluable.)
Public property | DescriptionLocation | (Inherited from RegionEvaluable.)
Public property | DescriptionText | (Inherited from RegionEvaluable.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента. (Inherited from RegionEvaluable.)
Public property | ErrorTerm | (Overrides RegionEvaluableErrorTerm.)
Public property | ErrorText | (Overrides RegionEvaluableErrorText.)
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении. (Inherited from RegionEvaluable.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Overrides RegionEvaluableFocused.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | (Overrides RegionBaseFontHeight.)
Public property | Id | (Inherited from RegionBase.)
Protected property | ImmediateEvaluationOnCanvasRequest |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой. (Inherited from RegionEvaluable.)
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент. (Inherited from RegionEvaluable.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionEvaluable.)
Public property | InputDataVisibility |
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Protected property | math | Built-in Math Region placed next to the custom Region.
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Overrides RegionEvaluableMiddleLine.)
Public property | MinimumSize |
Public property | Optimization | (Inherited from RegionEvaluable.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Protected property | ResizeBounds |
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes | (Overrides RegionEvaluableSelectedTermsIndexes.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription | (Inherited from RegionEvaluable.)
Public property | Size | (Overrides RegionEvaluableSize.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | Terms | (Overrides RegionEvaluableTerms.)
Public property | TextColor | (Overrides RegionBaseTextColor.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values | (Inherited from RegionEvaluable.)
Public property | WarningColor | Цвет предупреждений элемента. (Inherited from RegionEvaluable.)
Top
Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | (Overrides RegionEvaluableCheckEvaluability.)
Protected method | ChildRepainting | (Inherited from RegionEvaluable.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | Copy | (Overrides RegionEvaluableCopy(IClipboardManager).)
Public method | CreateDescription | (Inherited from RegionEvaluable.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Overrides RegionBaseFromXml(StorageReader, FileParsingContext).)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetCanvas |
Public method | GetcurrentTermsContainer | (Overrides RegionEvaluableGetcurrentTermsContainer.)
Public method | GetCursorType | (Overrides RegionEvaluableGetCursorType(MouseEventOptions).)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Overrides RegionEvaluableGetHistoryStep.)
Public method | GetSelectionStatus | (Overrides RegionBaseGetSelectionStatus.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionEvaluable.)
Public method | InitLayout(Store) | (Inherited from RegionEvaluable.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Overrides RegionBaseIsEmpty.)
Public method | MarkOutOfDate | Obsolete. (Inherited from RegionEvaluable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Overrides RegionEvaluableOnCommandSend(String).)
Public method | OnCommandSend(Term) | (Overrides RegionEvaluableOnCommandSend(Term).)
Public method | OnEvaluation | Processing of the Plot Regions.Обработка элементов-графиков. (Overrides RegionEvaluableOnEvaluation(Store).)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Overrides RegionEvaluableOnMouseDown(MouseEventOptions).)
Public method | OnMouseMove | (Overrides RegionEvaluableOnMouseMove(MouseEventOptions).)
Public method | OnMouseUp | (Overrides RegionEvaluableOnMouseUp(MouseEventOptions).)
Public method | OnMouseWheel | (Overrides RegionBaseOnMouseWheel(MouseEventOptions, Int32).)
Protected method | OnMouseWheelAction |
Public method | OnPaint | (Overrides RegionEvaluableOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Protected method | OnSizeChanged |
Public method | Paste | (Overrides RegionEvaluablePaste(IClipboardManager).)
Public method | PrePainter | (Overrides RegionBasePrePainter.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath | (Inherited from RegionEvaluable.)
Public method | ReadXmlProperties | (Inherited from RegionEvaluable.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | (Overrides RegionEvaluableRequestEvaluation(Boolean).)
Public method | RequestForEvaluation | Obsolete. (Inherited from RegionEvaluable.)
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState | (Inherited from RegionEvaluable.)
Public method | SetSize |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToXml | (Overrides RegionBaseToXml(StorageWriter, FileParsingContext).)
Public method | TrySearch |
Public method | WriteMath | (Inherited from RegionEvaluable.)
Public method | WriteXmlProperties | (Inherited from RegionEvaluable.)
Top
Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured | (Inherited from RegionEvaluable.)
Public event | EvaluationRequest | (Inherited from RegionEvaluable.)
Public event | EvaluationStateChanged | (Inherited from RegionEvaluable.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description | (Inherited from RegionEvaluable.)
Public field | DescriptionPosition | Obsolete. (Inherited from RegionEvaluable.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Protected field | terms | (Inherited from RegionEvaluable.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Explicit interface implementation | IRegionWithEditableTextSerializedValue |
Explicit interface implementation | IRegionWithEditableTextSetPreviousChar |
Explicit interface implementation | IRegionWithEditableTextTryGetPreviousChar |
Explicit interface implementation | IRegionWithTooltipTryGetTooltip |
Top
See Also

Reference

SMath.Controls Namespace


RegionHolder(T) Constructor

RegionHolderT Constructor

Overload List
 | Name | Description
Public method | RegionHolderT(RegionHolderT) | Initializes a new instance of the RegionHolderT class
Public method | RegionHolderT(SessionProfile) | Initializes a new instance of the RegionHolderT class
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T) Constructor (RegionHolder(T))

RegionHolderT Constructor (RegionHolderT)

Initializes a new instance of the RegionHolderT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionHolder(
    RegionHolder<T> value
)
Public Sub New (
    value As RegionHolder(Of T)
)
public:
RegionHolder(
    RegionHolder<T>^ value
)
new :
        value : RegionHolder<'T> -> RegionHolder

Parameters

value
Type: SMath.ControlsRegionHolder T
See Also

Reference

RegionHolderT Class
RegionHolderT Overload
SMath.Controls Namespace


RegionHolder(T) Constructor (SessionProfile)

RegionHolderT Constructor (SessionProfile)

Initializes a new instance of the RegionHolderT class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionHolder(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
RegionHolder(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> RegionHolder

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

RegionHolderT Class
RegionHolderT Overload
SMath.Controls Namespace


RegionHolder(T) Properties

RegionHolderT Properties

The RegionHolderT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDebugTermIndex | (Inherited from RegionEvaluable.)
Public property | BackColor | (Overrides RegionBaseBackColor.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента. (Overrides RegionEvaluableBaseSize.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Protected property | canv | Custom Region which is to be used as a main graphical representation of the result Region.
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | (Overrides RegionEvaluableCurrentCursorLocation.)
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | CurrentTermIndexes | (Overrides RegionEvaluableCurrentTermIndexes.)
Public property | CursorPosition |
Public property | DebugTerms | (Inherited from RegionEvaluable.)
Public property | DeletedValues | (Inherited from RegionEvaluable.)
Public property | Dependences | (Overrides RegionBaseDependences.)
Public property | DescriptionBounds | (Inherited from RegionEvaluable.)
Public property | DescriptionLocation | (Inherited from RegionEvaluable.)
Public property | DescriptionText | (Inherited from RegionEvaluable.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | ErrorId | Идентификатор ошибки, произошедшей внутри элемента. (Inherited from RegionEvaluable.)
Public property | ErrorTerm | (Overrides RegionEvaluableErrorTerm.)
Public property | ErrorText | (Overrides RegionEvaluableErrorText.)
Public property | Evaluable | Gets or sets value defines if the Region is valuable or not.Определяет, учитывается ли элемент при вычислении. (Inherited from RegionEvaluable.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | (Overrides RegionEvaluableFocused.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | (Overrides RegionBaseFontHeight.)
Public property | Id | (Inherited from RegionBase.)
Protected property | ImmediateEvaluationOnCanvasRequest |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и синхронизированы ли все составляющие элемента между собой. (Inherited from RegionEvaluable.)
Public property | InEvaluation | Gets or sets whether Region is under evaluation now.Возвращает или задаёт значение, определяющее является ли элемент листа вычисляемым в данный момент. (Inherited from RegionEvaluable.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionEvaluable.)
Public property | InputDataVisibility |
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Protected property | math | Built-in Math Region placed next to the custom Region.
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | (Overrides RegionEvaluableMiddleLine.)
Public property | MinimumSize |
Public property | Optimization | (Inherited from RegionEvaluable.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Protected property | ResizeBounds |
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTermsIndexes | (Overrides RegionEvaluableSelectedTermsIndexes.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | ShowDescription | (Inherited from RegionEvaluable.)
Public property | Size | (Overrides RegionEvaluableSize.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | Terms | (Overrides RegionEvaluableTerms.)
Public property | TextColor | (Overrides RegionBaseTextColor.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Public property | Values | (Inherited from RegionEvaluable.)
Public property | WarningColor | Цвет предупреждений элемента. (Inherited from RegionEvaluable.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IRegionWithEditableTextSerializedValue |
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).BackColor Property

RegionHolderTBackColor Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Color BackColor { get; set; }
Public Overrides Property BackColor As Color
    Get
    Set
public:
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
abstract BackColor : Color with get, set
override BackColor : Color with get, set

Property Value

Type: Color
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).BaseSize Property

RegionHolderTBaseSize Property

Size of the base part of the Region.Размер базовой составляющей элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Size BaseSize { get; }
Public Overrides ReadOnly Property BaseSize As Size
    Get
public:
virtual property Size BaseSize {
    Size get () override;
}
abstract BaseSize : Size with get
override BaseSize : Size with get

Property Value

Type: Size
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).canv Property

RegionHolderTcanv Property

Custom Region which is to be used as a main graphical representation of the result Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected T canv { get; }
Protected ReadOnly Property canv As T
    Get
protected:
property T canv {
    T get ();
}
member canv : 'T with get

Property Value

Type: T
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).CurrentCursorLocation Property

RegionHolderTCurrentCursorLocation Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Rectangle CurrentCursorLocation { get; }
Public Overrides ReadOnly Property CurrentCursorLocation As Rectangle
    Get
public:
virtual property Rectangle CurrentCursorLocation {
    Rectangle get () override;
}
abstract CurrentCursorLocation : Rectangle with get
override CurrentCursorLocation : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).CurrentTermIndexes Property

RegionHolderTCurrentTermIndexes Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int[] CurrentTermIndexes { get; set; }
Public Overrides Property CurrentTermIndexes As Integer()
    Get
    Set
public:
virtual property array<int>^ CurrentTermIndexes {
    array<int>^ get () override;
    void set (array<int>^ value) override;
}
abstract CurrentTermIndexes : int[] with get, set
override CurrentTermIndexes : int[] with get, set

Property Value

Type: Int32
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).CursorPosition Property

RegionHolderTCursorPosition Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CursorPosition { get; }
Public ReadOnly Property CursorPosition As Integer
    Get
public:
virtual property int CursorPosition {
    int get () sealed;
}
abstract CursorPosition : int with get
override CursorPosition : int with get

Property Value

Type: Int32

Implements

IRegionWithExtendedSearchCursorPosition
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Dependences Property

RegionHolderTDependences Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override List<AssemblyInfo> Dependences { get; set; }
Public Overrides Property Dependences As List(Of AssemblyInfo)
    Get
    Set
public:
virtual property List<AssemblyInfo>^ Dependences {
    List<AssemblyInfo>^ get () override;
    void set (List<AssemblyInfo>^ value) override;
}
abstract Dependences : List<AssemblyInfo> with get, set
override Dependences : List<AssemblyInfo> with get, set

Property Value

Type: ListAssemblyInfo
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ErrorTerm Property

RegionHolderTErrorTerm Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int ErrorTerm { get; set; }
Public Overrides Property ErrorTerm As Integer
    Get
    Set
public:
virtual property int ErrorTerm {
    int get () override;
    void set (int value) override;
}
abstract ErrorTerm : int with get, set
override ErrorTerm : int with get, set

Property Value

Type: Int32
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ErrorText Property

RegionHolderTErrorText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ErrorText { get; set; }
Public Overrides Property ErrorText As String
    Get
    Set
public:
virtual property String^ ErrorText {
    String^ get () override;
    void set (String^ value) override;
}
abstract ErrorText : string with get, set
override ErrorText : string with get, set

Property Value

Type: String
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Focused Property

RegionHolderTFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Focused { get; set; }
Public Overrides Property Focused As Boolean
    Get
    Set
public:
virtual property bool Focused {
    bool get () override;
    void set (bool value) override;
}
abstract Focused : bool with get, set
override Focused : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentObjectFocused
IDocumentObjectFocused
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).FontHeight Property

RegionHolderTFontHeight Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override float FontHeight { get; set; }
Public Overrides Property FontHeight As Single
    Get
    Set
public:
virtual property float FontHeight {
    float get () override;
    void set (float value) override;
}
abstract FontHeight : float32 with get, set
override FontHeight : float32 with get, set

Property Value

Type: Single
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ImmediateEvaluationOnCanvasRequest Property

RegionHolderTImmediateEvaluationOnCanvasRequest Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool ImmediateEvaluationOnCanvasRequest { get; set; }
Protected Property ImmediateEvaluationOnCanvasRequest As Boolean
    Get
    Set
protected:
property bool ImmediateEvaluationOnCanvasRequest {
    bool get ();
    void set (bool value);
}
member ImmediateEvaluationOnCanvasRequest : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).InputDataVisibility Property

RegionHolderTInputDataVisibility Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool InputDataVisibility { get; set; }
Public Property InputDataVisibility As Boolean
    Get
    Set
public:
virtual property bool InputDataVisibility {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract InputDataVisibility : bool with get, set
override InputDataVisibility : bool with get, set

Property Value

Type: Boolean

Implements

IRegionWithInputDataInputDataVisibility
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).IRegionWithEditableText.SerializedValue Property

RegionHolderTIRegionWithEditableTextSerializedValue Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string IRegionWithEditableText.SerializedValue { get; set; }
Private Property SerializedValue As String
    Implements IRegionWithEditableText.SerializedValue
    Get
    Set
private:
virtual property String^ SerializedValue {
    String^ get () sealed = IRegionWithEditableText::SerializedValue::get;
    void set (String^ value) sealed = IRegionWithEditableText::SerializedValue::set;
}
private abstract SerializedValue : string with get, set
private override SerializedValue : string with get, set

Property Value

Type: String

Implements

IRegionWithEditableTextSerializedValue
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).math Property

RegionHolderTmath Property

Built-in Math Region placed next to the custom Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected RegionEvaluable math { get; }
Protected ReadOnly Property math As RegionEvaluable
    Get
protected:
property RegionEvaluable^ math {
    RegionEvaluable^ get ();
}
member math : RegionEvaluable with get

Property Value

Type: RegionEvaluable
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).MiddleLine Property

RegionHolderTMiddleLine Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override float MiddleLine { get; }
Public Overrides ReadOnly Property MiddleLine As Single
    Get
public:
virtual property float MiddleLine {
    float get () override;
}
abstract MiddleLine : float32 with get
override MiddleLine : float32 with get

Property Value

Type: Single
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).MinimumSize Property

RegionHolderTMinimumSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size MinimumSize { get; set; }
Public Property MinimumSize As Size
    Get
    Set
public:
property Size MinimumSize {
    Size get ();
    void set (Size value);
}
member MinimumSize : Size with get, set

Property Value

Type: Size
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ResizeBounds Property

RegionHolderTResizeBounds Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual Rectangle ResizeBounds { get; }
Protected Overridable ReadOnly Property ResizeBounds As Rectangle
    Get
protected:
virtual property Rectangle ResizeBounds {
    Rectangle get ();
}
abstract ResizeBounds : Rectangle with get
override ResizeBounds : Rectangle with get

Property Value

Type: Rectangle
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).SelectedTermsIndexes Property

RegionHolderTSelectedTermsIndexes Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int[] SelectedTermsIndexes { get; set; }
Public Overrides Property SelectedTermsIndexes As Integer()
    Get
    Set
public:
virtual property array<int>^ SelectedTermsIndexes {
    array<int>^ get () override;
    void set (array<int>^ value) override;
}
abstract SelectedTermsIndexes : int[] with get, set
override SelectedTermsIndexes : int[] with get, set

Property Value

Type: Int32
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Size Property

RegionHolderTSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () override;
    void set (Size value) override;
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

IDocumentObjectSize
IDocumentObjectSize
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Terms Property

RegionHolderTTerms Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Term[] Terms { get; set; }
Public Overrides Property Terms As Term()
    Get
    Set
public:
virtual property array<Term^>^ Terms {
    array<Term^>^ get () override;
    void set (array<Term^>^ value) override;
}
abstract Terms : Term[] with get, set
override Terms : Term[] with get, set

Property Value

Type: Term
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).TextColor Property

RegionHolderTTextColor Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override Color TextColor { get; set; }
Public Overrides Property TextColor As Color
    Get
    Set
public:
virtual property Color TextColor {
    Color get () override;
    void set (Color value) override;
}
abstract TextColor : Color with get, set
override TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T) Methods

RegionHolderT Methods

The RegionHolderT generic type exposes the following members.

Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Public method | CheckEvaluability | (Overrides RegionEvaluableCheckEvaluability.)
Protected method | ChildRepainting | (Inherited from RegionEvaluable.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | Copy | (Overrides RegionEvaluableCopy(IClipboardManager).)
Public method | CreateDescription | (Inherited from RegionEvaluable.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Overrides RegionBaseFromXml(StorageReader, FileParsingContext).)
Protected method | GetAllChildren | (Inherited from RegionBase.)
Public method | GetCanvas |
Public method | GetcurrentTermsContainer | (Overrides RegionEvaluableGetcurrentTermsContainer.)
Public method | GetCursorType | (Overrides RegionEvaluableGetCursorType(MouseEventOptions).)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Overrides RegionEvaluableGetHistoryStep.)
Public method | GetSelectionStatus | (Overrides RegionBaseGetSelectionStatus.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionEvaluable.)
Public method | InitLayout(Store) | (Inherited from RegionEvaluable.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Overrides RegionBaseIsEmpty.)
Public method | MarkOutOfDate | Obsolete. (Inherited from RegionEvaluable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend(String) | (Overrides RegionEvaluableOnCommandSend(String).)
Public method | OnCommandSend(Term) | (Overrides RegionEvaluableOnCommandSend(Term).)
Public method | OnEvaluation | Processing of the Plot Regions.Обработка элементов-графиков. (Overrides RegionEvaluableOnEvaluation(Store).)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Overrides RegionEvaluableOnMouseDown(MouseEventOptions).)
Public method | OnMouseMove | (Overrides RegionEvaluableOnMouseMove(MouseEventOptions).)
Public method | OnMouseUp | (Overrides RegionEvaluableOnMouseUp(MouseEventOptions).)
Public method | OnMouseWheel | (Overrides RegionBaseOnMouseWheel(MouseEventOptions, Int32).)
Protected method | OnMouseWheelAction |
Public method | OnPaint | (Overrides RegionEvaluableOnPaint(PaintEventOptions).)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Protected method | OnSizeChanged |
Public method | Paste | (Overrides RegionEvaluablePaste(IClipboardManager).)
Public method | PrePainter | (Overrides RegionBasePrePainter.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadMath | (Inherited from RegionEvaluable.)
Public method | ReadXmlProperties | (Inherited from RegionEvaluable.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RequestEvaluation | (Overrides RegionEvaluableRequestEvaluation(Boolean).)
Public method | RequestForEvaluation | Obsolete. (Inherited from RegionEvaluable.)
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetEvaluationState | (Inherited from RegionEvaluable.)
Public method | SetSize |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowError(Exception, IPrimitive) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ShowError(Exception, Term) | Сообщает об ошибке в элементе при вычислении. (Inherited from RegionEvaluable.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToXml | (Overrides RegionBaseToXml(StorageWriter, FileParsingContext).)
Public method | TrySearch |
Public method | WriteMath | (Inherited from RegionEvaluable.)
Public method | WriteXmlProperties | (Inherited from RegionEvaluable.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Explicit interface implementation | IRegionWithEditableTextSetPreviousChar |
Explicit interface implementation | IRegionWithEditableTextTryGetPreviousChar |
Explicit interface implementation | IRegionWithTooltipTryGetTooltip |
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).CheckEvaluability Method

RegionHolderTCheckEvaluability Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool CheckEvaluability()
Public Overrides Function CheckEvaluability As Boolean
public:
virtual bool CheckEvaluability() override
abstract CheckEvaluability : unit -> bool
override CheckEvaluability : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Copy Method

RegionHolderTCopy Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Copy(
    IClipboardManager clipboard
)
Public Overrides Function Copy (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Copy(
    IClipboardManager^ clipboard
) override
abstract Copy :
        clipboard : IClipboardManager -> bool
override Copy :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).FromXml Method

RegionHolderTFromXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void FromXml(
    StorageReader storage,
    FileParsingContext parsingContext
)
Public Overrides Sub FromXml (
    storage As StorageReader,
    parsingContext As FileParsingContext
)
public:
virtual void FromXml(
    StorageReader^ storage,
    FileParsingContext^ parsingContext
) override
abstract FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit
override FromXml :
        storage : StorageReader *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageReader
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).GetCanvas Method

RegionHolderTGetCanvas Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T GetCanvas()
Public Function GetCanvas As T
public:
T GetCanvas()
member GetCanvas : unit -> 'T

Return Value

Type: T
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).GetcurrentTermsContainer Method

RegionHolderTGetcurrentTermsContainer Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override RegionEvaluable GetcurrentTermsContainer()
Public Overrides Function GetcurrentTermsContainer As RegionEvaluable
public:
virtual RegionEvaluable^ GetcurrentTermsContainer() override
abstract GetcurrentTermsContainer : unit -> RegionEvaluable
override GetcurrentTermsContainer : unit -> RegionEvaluable

Return Value

Type: RegionEvaluable
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).GetCursorType Method

RegionHolderTGetCursorType Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override CursorType GetCursorType(
    MouseEventOptions e
)
Public Overrides Function GetCursorType (
    e As MouseEventOptions
) As CursorType
public:
virtual CursorType GetCursorType(
    MouseEventOptions^ e
) override
abstract GetCursorType :
        e : MouseEventOptions -> CursorType
override GetCursorType :
        e : MouseEventOptions -> CursorType

Parameters

e
Type: SMath.ManagerMouseEventOptions

Return Value

Type: CursorType
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).GetHistoryStep Method

RegionHolderTGetHistoryStep Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override HistoryStepBase GetHistoryStep()
Public Overrides Function GetHistoryStep As HistoryStepBase
public:
virtual HistoryStepBase^ GetHistoryStep() override
abstract GetHistoryStep : unit -> HistoryStepBase
override GetHistoryStep : unit -> HistoryStepBase

Return Value

Type: HistoryStepBase
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).GetSelectionStatus Method

RegionHolderTGetSelectionStatus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override RegionSelectionStatus GetSelectionStatus()
Public Overrides Function GetSelectionStatus As RegionSelectionStatus
public:
virtual RegionSelectionStatus GetSelectionStatus() override
abstract GetSelectionStatus : unit -> RegionSelectionStatus
override GetSelectionStatus : unit -> RegionSelectionStatus

Return Value

Type: RegionSelectionStatus
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).IRegionWithEditableText.SetPreviousChar Method

RegionHolderTIRegionWithEditableTextSetPreviousChar Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IRegionWithEditableText.SetPreviousChar(
    char letter
)
Private Function SetPreviousChar (
    letter As Char
) As Boolean Implements IRegionWithEditableText.SetPreviousChar
private:
virtual bool SetPreviousChar(
    wchar_t letter
) sealed = IRegionWithEditableText::SetPreviousChar
private abstract SetPreviousChar :
        letter : char -> bool
private override SetPreviousChar :
        letter : char -> bool

Parameters

letter
Type: SystemChar

Return Value

Type: Boolean

Implements

IRegionWithEditableTextSetPreviousChar(Char)
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).IRegionWithEditableText.TryGetPreviousChar Method

RegionHolderTIRegionWithEditableTextTryGetPreviousChar Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IRegionWithEditableText.TryGetPreviousChar(
    out char letter
)
Private Function TryGetPreviousChar (
    <OutAttribute> ByRef letter As Char
) As Boolean Implements IRegionWithEditableText.TryGetPreviousChar
private:
virtual bool TryGetPreviousChar(
    [OutAttribute] wchar_t% letter
) sealed = IRegionWithEditableText::TryGetPreviousChar
private abstract TryGetPreviousChar :
        letter : char byref -> bool
private override TryGetPreviousChar :
        letter : char byref -> bool

Parameters

letter
Type: SystemChar

Return Value

Type: Boolean

Implements

IRegionWithEditableTextTryGetPreviousChar(Char)
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).IRegionWithTooltip.TryGetTooltip Method

RegionHolderTIRegionWithTooltipTryGetTooltip Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IRegionWithTooltip.TryGetTooltip(
    out IBitmap bmp
)
Private Function TryGetTooltip (
    <OutAttribute> ByRef bmp As IBitmap
) As Boolean Implements IRegionWithTooltip.TryGetTooltip
private:
virtual bool TryGetTooltip(
    [OutAttribute] IBitmap^% bmp
) sealed = IRegionWithTooltip::TryGetTooltip
private abstract TryGetTooltip :
        bmp : IBitmap byref -> bool
private override TryGetTooltip :
        bmp : IBitmap byref -> bool

Parameters

bmp
Type: SMath.DrawingIBitmap

Return Value

Type: Boolean

Implements

IRegionWithTooltipTryGetTooltip(IBitmap)
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).IsEmpty Method

RegionHolderTIsEmpty Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool IsEmpty()
Public Overrides Function IsEmpty As Boolean
public:
virtual bool IsEmpty() override
abstract IsEmpty : unit -> bool
override IsEmpty : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnCommandSend Method

RegionHolderTOnCommandSend Method

Overload List
 | Name | Description
Public method | OnCommandSend(String) | (Overrides RegionEvaluableOnCommandSend(String).)
Public method | OnCommandSend(Term) | (Overrides RegionEvaluableOnCommandSend(Term).)
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnCommandSend Method (String)

RegionHolderTOnCommandSend Method (String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnCommandSend(
    string value
)
Public Overrides Sub OnCommandSend (
    value As String
)
public:
virtual void OnCommandSend(
    String^ value
) override
abstract OnCommandSend :
        value : string -> unit
override OnCommandSend :
        value : string -> unit

Parameters

value
Type: SystemString
See Also

Reference

RegionHolderT Class
OnCommandSend Overload
SMath.Controls Namespace


RegionHolder(T).OnCommandSend Method (Term[])

RegionHolderTOnCommandSend Method (Term)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnCommandSend(
    Term[] value
)
Public Overrides Sub OnCommandSend (
    value As Term()
)
public:
virtual void OnCommandSend(
    array<Term^>^ value
) override
abstract OnCommandSend :
        value : Term[] -> unit
override OnCommandSend :
        value : Term[] -> unit

Parameters

value
Type: SMath.ManagerTerm
See Also

Reference

RegionHolderT Class
OnCommandSend Overload
SMath.Controls Namespace


RegionHolder(T).OnEvaluation Method

RegionHolderTOnEvaluation Method

Processing of the Plot Regions.Обработка элементов-графиков.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnEvaluation(
    Store store
)
Public Overrides Sub OnEvaluation (
    store As Store
)
public:
virtual void OnEvaluation(
    Store^ store
) override
abstract OnEvaluation :
        store : Store -> unit
override OnEvaluation :
        store : Store -> unit

Parameters

store
Type: SMath.MathStore
Current evaluation context.Контекст текущего выражения.
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnMouseDown Method

RegionHolderTOnMouseDown Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseDown(
    MouseEventOptions e
)
Public Overrides Sub OnMouseDown (
    e As MouseEventOptions
)
public:
virtual void OnMouseDown(
    MouseEventOptions^ e
) override
abstract OnMouseDown :
        e : MouseEventOptions -> unit
override OnMouseDown :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnMouseMove Method

RegionHolderTOnMouseMove Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseMove(
    MouseEventOptions e
)
Public Overrides Sub OnMouseMove (
    e As MouseEventOptions
)
public:
virtual void OnMouseMove(
    MouseEventOptions^ e
) override
abstract OnMouseMove :
        e : MouseEventOptions -> unit
override OnMouseMove :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnMouseUp Method

RegionHolderTOnMouseUp Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnMouseUp(
    MouseEventOptions e
)
Public Overrides Sub OnMouseUp (
    e As MouseEventOptions
)
public:
virtual void OnMouseUp(
    MouseEventOptions^ e
) override
abstract OnMouseUp :
        e : MouseEventOptions -> unit
override OnMouseUp :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnMouseWheel Method

RegionHolderTOnMouseWheel Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool OnMouseWheel(
    MouseEventOptions e,
    int delta
)
Public Overrides Function OnMouseWheel (
    e As MouseEventOptions,
    delta As Integer
) As Boolean
public:
virtual bool OnMouseWheel(
    MouseEventOptions^ e,
    int delta
) override
abstract OnMouseWheel :
        e : MouseEventOptions *
        delta : int -> bool
override OnMouseWheel :
        e : MouseEventOptions *
        delta : int -> bool

Parameters

e
Type: SMath.ManagerMouseEventOptions
delta
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnMouseWheelAction Method

RegionHolderTOnMouseWheelAction Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnMouseWheelAction(
    MouseEventOptions e,
    int delta
)
Protected Overridable Sub OnMouseWheelAction (
    e As MouseEventOptions,
    delta As Integer
)
protected:
virtual void OnMouseWheelAction(
    MouseEventOptions^ e,
    int delta
)
abstract OnMouseWheelAction :
        e : MouseEventOptions *
        delta : int -> unit
override OnMouseWheelAction :
        e : MouseEventOptions *
        delta : int -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
delta
Type: SystemInt32
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnPaint Method

RegionHolderTOnPaint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void OnPaint(
    PaintEventOptions e
)
Public Overrides Sub OnPaint (
    e As PaintEventOptions
)
public:
virtual void OnPaint(
    PaintEventOptions^ e
) override
abstract OnPaint :
        e : PaintEventOptions -> unit
override OnPaint :
        e : PaintEventOptions -> unit

Parameters

e
Type: SMath.ManagerPaintEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).OnSizeChanged Method

RegionHolderTOnSizeChanged Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnSizeChanged(
    MouseEventOptions e
)
Protected Overridable Sub OnSizeChanged (
    e As MouseEventOptions
)
protected:
virtual void OnSizeChanged(
    MouseEventOptions^ e
)
abstract OnSizeChanged :
        e : MouseEventOptions -> unit
override OnSizeChanged :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).Paste Method

RegionHolderTPaste Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Paste(
    IClipboardManager clipboard
)
Public Overrides Function Paste (
    clipboard As IClipboardManager
) As Boolean
public:
virtual bool Paste(
    IClipboardManager^ clipboard
) override
abstract Paste :
        clipboard : IClipboardManager -> bool
override Paste :
        clipboard : IClipboardManager -> bool

Parameters

clipboard
Type: SMath.ControlsIClipboardManager

Return Value

Type: Boolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).PrePainter Method

RegionHolderTPrePainter Method

Overload List
 | Name | Description
Public method | PrePainter | (Overrides RegionBasePrePainter.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).PrePainter Method

RegionHolderTPrePainter Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void PrePainter()
Public Overrides Sub PrePainter
public:
virtual void PrePainter() override
abstract PrePainter : unit -> unit
override PrePainter : unit -> unit
See Also

Reference

RegionHolderT Class
PrePainter Overload
SMath.Controls Namespace


RegionHolder(T).RequestEvaluation Method

RegionHolderTRequestEvaluation Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void RequestEvaluation(
    bool immediate = false
)
Public Overrides Sub RequestEvaluation (
    Optional immediate As Boolean = false
)
public:
virtual void RequestEvaluation(
    bool immediate = false
) override
abstract RequestEvaluation :
        ?immediate : bool
(* Defaults:
        let _immediate = defaultArg immediate false
*)
-> unit
override RequestEvaluation :
        ?immediate : bool
(* Defaults:
        let _immediate = defaultArg immediate false
*)
-> unit

Parameters

immediate (Optional)
Type: SystemBoolean
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).SetSize Method

RegionHolderTSetSize Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetSize(
    Size tempSize,
    MouseEventOptions e = null
)
Public Sub SetSize (
    tempSize As Size,
    Optional e As MouseEventOptions = Nothing
)
public:
void SetSize(
    Size tempSize,
    MouseEventOptions^ e = nullptr
)
member SetSize :
        tempSize : Size *
        ?e : MouseEventOptions
(* Defaults:
        let _e = defaultArg e null
*)
-> unit

Parameters

tempSize
Type: System.DrawingSize
e (Optional)
Type: SMath.ManagerMouseEventOptions
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ToString Method

RegionHolderTToString Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).ToXml Method

RegionHolderTToXml Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void ToXml(
    StorageWriter storage,
    FileParsingContext parsingContext
)
Public Overrides Sub ToXml (
    storage As StorageWriter,
    parsingContext As FileParsingContext
)
public:
virtual void ToXml(
    StorageWriter^ storage,
    FileParsingContext^ parsingContext
) override
abstract ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit
override ToXml :
        storage : StorageWriter *
        parsingContext : FileParsingContext -> unit

Parameters

storage
Type: SMath.ControlsStorageWriter
parsingContext
Type: SMath.ControlsFileParsingContext
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T).TrySearch Method

RegionHolderTTrySearch Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TrySearch(
    string value,
    MatchingOptions options,
    out List<ExtendedSearchEntry> entries
)
Public Function TrySearch (
    value As String,
    options As MatchingOptions,
    <OutAttribute> ByRef entries As List(Of ExtendedSearchEntry)
) As Boolean
public:
virtual bool TrySearch(
    String^ value,
    MatchingOptions^ options,
    [OutAttribute] List<ExtendedSearchEntry>^% entries
) sealed
abstract TrySearch :
        value : string *
        options : MatchingOptions *
        entries : List<ExtendedSearchEntry> byref -> bool
override TrySearch :
        value : string *
        options : MatchingOptions *
        entries : List<ExtendedSearchEntry> byref -> bool

Parameters

value
Type: SystemString
options
Type: SMath.ControlsMatchingOptions
entries
Type: System.Collections.GenericListExtendedSearchEntry

Return Value

Type: Boolean

Implements

IRegionWithExtendedSearchTrySearch(String, MatchingOptions, ListExtendedSearchEntry)
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T) Events

RegionHolderT Events

The RegionHolderT generic type exposes the following members.

Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | ErrorOccured | (Inherited from RegionEvaluable.)
Public event | EvaluationRequest | (Inherited from RegionEvaluable.)
Public event | EvaluationStateChanged | (Inherited from RegionEvaluable.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionHolder(T) Fields

RegionHolderT Fields

The RegionHolderT generic type exposes the following members.

Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Public field | Description | (Inherited from RegionEvaluable.)
Public field | DescriptionPosition | Obsolete. (Inherited from RegionEvaluable.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Protected field | terms | (Inherited from RegionEvaluable.)
Top
See Also

Reference

RegionHolderT Class
SMath.Controls Namespace


RegionSelectDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void RegionSelectDelegate(
    Point pnt1,
    Point pnt2
)
Public Delegate Sub RegionSelectDelegate (
    pnt1 As Point,
    pnt2 As Point
)
public delegate void RegionSelectDelegate(
    Point pnt1,
    Point pnt2
)
type RegionSelectDelegate =
    delegate of
        pnt1 : Point *
        pnt2 : Point -> unit

Parameters

pnt1
Type: System.DrawingPoint
pnt2
Type: System.DrawingPoint
See Also

Reference

SMath.Controls Namespace


RegionSelectionStatus Enumeration

Selection into the current Region.Выделение внутри элемента листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum RegionSelectionStatus
Public Enumeration RegionSelectionStatus
public enum class RegionSelectionStatus
type RegionSelectionStatus
Members
Member name | Value | Description
None | 0 | No selection.Нет выделения.
Text | 1 | Text selected.Выделен текст.
Variable | 2 | Variable selected.Выделена переменная.
Constant | 3 | Constant selected.Выделена константа.
MathExpression | 4 | Math expression selected.Выделено математическое выражение.
See Also

Reference

SMath.Controls Namespace


RegionsEnumerator Class

Enumerator to iterate through available Worksheet Regions.Объект для перечисления доступных элементов листа.
Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsEnumerator RegionBase
SMath.ControlsRegionsEnumerator

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class RegionsEnumerator : ObjectsEnumerator<RegionBase>
Public NotInheritable Class RegionsEnumerator
    Inherits ObjectsEnumerator(Of RegionBase)
public ref class RegionsEnumerator sealed : public ObjectsEnumerator<RegionBase^>
[<SealedAttribute>]
type RegionsEnumerator =
    class
        inherit ObjectsEnumerator<RegionBase>
    end

The RegionsEnumerator type exposes the following members.

Constructors
 | Name | Description
Public method | RegionsEnumerator | Constructor of the object.Конструктор объекта.
Top
Properties
 | Name | Description
Public property | AbsoluteDefinitions |
Public property | AbsoluteLocation | Absolute location of the Object on the Document depending on the start Object.Абсолютная позиция элемента на документе на основе первого элемента перечисления. (Inherited from ObjectsEnumeratorT.)
Public property | CollapsedHeight | Gets an invisible distance hidden by collapsed Area Objects above the current Object.Возвращает расстояние скрытое закрытыми областями перед текущим элементом документа. (Inherited from ObjectsEnumeratorT.)
Public property | Current | Gets the current Object.Возвращает текущий элемент. (Inherited from ObjectsEnumeratorT.)
Public property | CurrentIndex | Gets the current Object index.Возвращает индекс текущего элемента. (Inherited from ObjectsEnumeratorT.)
Public property | Depth | Gets depth of the Object inside nested Areas.Возвращает глубину элемента внутри вложенных Областей. (Inherited from ObjectsEnumeratorT.)
Public property | Evaluable | Gets evaluation status of the Object.Возвращает статус возможности вычисления элемента. (Inherited from ObjectsEnumeratorT.)
Public property | FilterAllAfter | Gets or sets an index of the last Object to retrieve.Возвращает или задаёт индекс последнего элемента для получения. (Inherited from ObjectsEnumeratorT.)
Public property | FilterAllBefore | Gets or sets an index of the first Object to retrieve.Возвращает или задаёт индекс первого элемента для получения. (Inherited from ObjectsEnumeratorT.)
Public property | FilterDeactivated | Defines if the enumerator should hide all deactivated (not added to the Document) Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться деактивированные (не зарегистрированные на документе) элементы документа. (Inherited from ObjectsEnumeratorT.)
Public property | FilterInvisible | Gets or sets a value that determines if Enumerator will filter out Invisible Objects or not (invisible means that Object is hidden by collapsed Area Objects).Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться элементы документа, скрытые регионами типа Область. (Inherited from ObjectsEnumeratorT.)
Public property | FilterNonEvaluable | Gets or sets a value that determines if Enumerator will filter out not evaluable Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не вычисляемые элементы документы. (Inherited from ObjectsEnumeratorT.)
Public property | FilterNonSelected | Gets or sets a value that determines if Enumerator will filter out not selected Objects or not.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не выделенные элементы документа. (Inherited from ObjectsEnumeratorT.)
Public property | LastIndex | Gets the last Object index. It doesn't check availability of the Object.Возвращает индекс последнего элемента. Проверки на доступность элемента не производится. (Inherited from ObjectsEnumeratorT.)
Public property | Placement | (Inherited from ObjectsEnumeratorT.)
Public property | Protected | Gets protection status of the Object (Object is protected if it is included to the locked Area Object).Возвращает статус защищённости элемента (элемент считается защищённым если он находится внутри заблокированной Области). (Inherited from ObjectsEnumeratorT.)
Public property | Selected | Gets selection status of the Object.Возвращает статус выделения элемента. (Inherited from ObjectsEnumeratorT.)
Public property | TopCorrection | Obsolete.
Public property | Visible | Gets visibility of the current Object on the Document (visible means that Object is not hidden by collapsed Area Objects).Возвращает видимость текущего элемента на документе (определяет скрыт ли текущий элемент закрытой Областью или нет). (Inherited from ObjectsEnumeratorT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ObjectsEnumeratorT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubEnumerator | (Overrides ObjectsEnumeratorTGetSubEnumerator(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции. (Inherited from ObjectsEnumeratorT.)
Public method | Reset | Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями. (Overrides ObjectsEnumeratorTReset.)
Public method | RestartState | (Inherited from ObjectsEnumeratorT.)
Public method | SaveState | (Inherited from ObjectsEnumeratorT.)
Public method | SetFakeCollapsedArea | (Inherited from ObjectsEnumeratorT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ProgressChanged |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorTCurrent | (Inherited from ObjectsEnumeratorT.)
Explicit interface implementation | IEnumeratorCurrent | (Inherited from ObjectsEnumeratorT.)
Explicit interface implementation | IDisposableDispose | (Inherited from ObjectsEnumeratorT.)
Top
See Also

Reference

SMath.Controls Namespace


RegionsEnumerator Constructor

Constructor of the object.Конструктор объекта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator(
    List<RegionBase> regions,
    ContentPlacement placement
)
Public Sub New (
    regions As List(Of RegionBase),
    placement As ContentPlacement
)
public:
RegionsEnumerator(
    List<RegionBase^>^ regions,
    ContentPlacement placement
)
new :
        regions : List<RegionBase> *
        placement : ContentPlacement -> RegionsEnumerator

Parameters

regions
Type: System.Collections.GenericListRegionBase
Regions to iterate.Элементы листа для итераций.
placement
Type: SMath.ManagerContentPlacement
Placement of the content elements.Расположение элементов документа.
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator Properties

The RegionsEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteDefinitions |
Public property | AbsoluteLocation | Absolute location of the Object on the Document depending on the start Object.Абсолютная позиция элемента на документе на основе первого элемента перечисления. (Inherited from ObjectsEnumeratorT.)
Public property | CollapsedHeight | Gets an invisible distance hidden by collapsed Area Objects above the current Object.Возвращает расстояние скрытое закрытыми областями перед текущим элементом документа. (Inherited from ObjectsEnumeratorT.)
Public property | Current | Gets the current Object.Возвращает текущий элемент. (Inherited from ObjectsEnumeratorT.)
Public property | CurrentIndex | Gets the current Object index.Возвращает индекс текущего элемента. (Inherited from ObjectsEnumeratorT.)
Public property | Depth | Gets depth of the Object inside nested Areas.Возвращает глубину элемента внутри вложенных Областей. (Inherited from ObjectsEnumeratorT.)
Public property | Evaluable | Gets evaluation status of the Object.Возвращает статус возможности вычисления элемента. (Inherited from ObjectsEnumeratorT.)
Public property | FilterAllAfter | Gets or sets an index of the last Object to retrieve.Возвращает или задаёт индекс последнего элемента для получения. (Inherited from ObjectsEnumeratorT.)
Public property | FilterAllBefore | Gets or sets an index of the first Object to retrieve.Возвращает или задаёт индекс первого элемента для получения. (Inherited from ObjectsEnumeratorT.)
Public property | FilterDeactivated | Defines if the enumerator should hide all deactivated (not added to the Document) Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться деактивированные (не зарегистрированные на документе) элементы документа. (Inherited from ObjectsEnumeratorT.)
Public property | FilterInvisible | Gets or sets a value that determines if Enumerator will filter out Invisible Objects or not (invisible means that Object is hidden by collapsed Area Objects).Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться элементы документа, скрытые регионами типа Область. (Inherited from ObjectsEnumeratorT.)
Public property | FilterNonEvaluable | Gets or sets a value that determines if Enumerator will filter out not evaluable Objects.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не вычисляемые элементы документы. (Inherited from ObjectsEnumeratorT.)
Public property | FilterNonSelected | Gets or sets a value that determines if Enumerator will filter out not selected Objects or not.Возвращает или задаёт значение, определяющее будут ли при выборке отфильтровываться не выделенные элементы документа. (Inherited from ObjectsEnumeratorT.)
Public property | LastIndex | Gets the last Object index. It doesn't check availability of the Object.Возвращает индекс последнего элемента. Проверки на доступность элемента не производится. (Inherited from ObjectsEnumeratorT.)
Public property | Placement | (Inherited from ObjectsEnumeratorT.)
Public property | Protected | Gets protection status of the Object (Object is protected if it is included to the locked Area Object).Возвращает статус защищённости элемента (элемент считается защищённым если он находится внутри заблокированной Области). (Inherited from ObjectsEnumeratorT.)
Public property | Selected | Gets selection status of the Object.Возвращает статус выделения элемента. (Inherited from ObjectsEnumeratorT.)
Public property | TopCorrection | Obsolete.
Public property | Visible | Gets visibility of the current Object on the Document (visible means that Object is not hidden by collapsed Area Objects).Возвращает видимость текущего элемента на документе (определяет скрыт ли текущий элемент закрытой Областью или нет). (Inherited from ObjectsEnumeratorT.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumeratorTCurrent | (Inherited from ObjectsEnumeratorT.)
Explicit interface implementation | IEnumeratorCurrent | (Inherited from ObjectsEnumeratorT.)
Top
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator.AbsoluteDefinitions Property

RegionsEnumeratorAbsoluteDefinitions Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Definition> AbsoluteDefinitions { get; set; }
Public Property AbsoluteDefinitions As List(Of Definition)
    Get
    Set
public:
property List<Definition^>^ AbsoluteDefinitions {
    List<Definition^>^ get ();
    void set (List<Definition^>^ value);
}
member AbsoluteDefinitions : List<Definition> with get, set

Property Value

Type: ListDefinition
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator.TopCorrection Property

RegionsEnumeratorTopCorrection Property

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use CollapsedHeight instead.", false)]
public int TopCorrection { get; }
<ObsoleteAttribute("Use CollapsedHeight instead.", false)>
Public ReadOnly Property TopCorrection As Integer
    Get
public:
[ObsoleteAttribute(L"Use CollapsedHeight instead.", false)]
property int TopCorrection {
    int get ();
}
[<ObsoleteAttribute("Use CollapsedHeight instead.", false)>]
member TopCorrection : int with get

Property Value

Type: Int32
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator Methods

The RegionsEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ObjectsEnumeratorT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubEnumerator | (Overrides ObjectsEnumeratorTGetSubEnumerator(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next available element of the collection.Продвигает итератор на следующий доступный элемент коллекции. (Inherited from ObjectsEnumeratorT.)
Public method | Reset | Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями. (Overrides ObjectsEnumeratorTReset.)
Public method | RestartState | (Inherited from ObjectsEnumeratorT.)
Public method | SaveState | (Inherited from ObjectsEnumeratorT.)
Public method | SetFakeCollapsedArea | (Inherited from ObjectsEnumeratorT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose | (Inherited from ObjectsEnumeratorT.)
Top
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator.GetSubEnumerator Method

RegionsEnumeratorGetSubEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override ObjectsEnumerator<RegionBase> GetSubEnumerator(
    int stopIndex
)
Public Overrides Function GetSubEnumerator (
    stopIndex As Integer
) As ObjectsEnumerator(Of RegionBase)
public:
virtual ObjectsEnumerator<RegionBase^>^ GetSubEnumerator(
    int stopIndex
) override
abstract GetSubEnumerator :
        stopIndex : int -> ObjectsEnumerator<RegionBase>
override GetSubEnumerator :
        stopIndex : int -> ObjectsEnumerator<RegionBase>

Parameters

stopIndex
Type: SystemInt32

Return Value

Type: ObjectsEnumerator RegionBase
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator.Reset Method

RegionsEnumeratorReset Method

Сбрасывает внутренние значения счётчика на исходные. При этом настройки фильтрации остаются с выставленными значениями.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator Events

The RegionsEnumerator type exposes the following members.

Events
 | Name | Description
Public event | ProgressChanged |
Top
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsEnumerator.ProgressChanged Event

RegionsEnumeratorProgressChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ProgressEventHandler ProgressChanged
Public Event ProgressChanged As ProgressEventHandler
public:
 event ProgressEventHandler^ ProgressChanged {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}
member ProgressChanged : IEvent<ProgressEventHandler,
    EventArgs>

Value

Type: SMath.ControlsProgressEventHandler
See Also

Reference

RegionsEnumerator Class
SMath.Controls Namespace


RegionsList Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsList RegionBase
SMath.ControlsRegionsList
SMath.ControlsChildrenRegionsList

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RegionsList : ObjectsList<RegionBase>
Public Class RegionsList
    Inherits ObjectsList(Of RegionBase)
public ref class RegionsList : public ObjectsList<RegionBase^>
type RegionsList =
    class
        inherit ObjectsList<RegionBase>
    end

The RegionsList type exposes the following members.

Constructors
 | Name | Description
Public method | RegionsList(ContentPlacement) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ListRegionBase, ContentPlacement) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ContentPlacement, Int32, Int32) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ListRegionBase, ContentPlacement, Int32, Int32) | Initializes a new instance of the RegionsList class
Top
Properties
 | Name | Description
Public property | PagesCount | (Inherited from ObjectsListT.)
Public property | Placement | (Inherited from ObjectsListT.)
Public property | StartingFromPage | (Inherited from ObjectsListT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetEnumerator(RegionsEnumerator) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) | (Inherited from ObjectsListT.)
Public method | IsApplicable(Int32, Int32) | (Inherited from ObjectsListT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | (Inherited from ObjectsListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


RegionsList Constructor

Overload List
 | Name | Description
Public method | RegionsList(ContentPlacement) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ListRegionBase, ContentPlacement) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ContentPlacement, Int32, Int32) | Initializes a new instance of the RegionsList class
Public method | RegionsList(ListRegionBase, ContentPlacement, Int32, Int32) | Initializes a new instance of the RegionsList class
Top
See Also

Reference

RegionsList Class
SMath.Controls Namespace


RegionsList Constructor (ContentPlacement)

Initializes a new instance of the RegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsList(
    ContentPlacement placement
)
Public Sub New (
    placement As ContentPlacement
)
public:
RegionsList(
    ContentPlacement placement
)
new :
        placement : ContentPlacement -> RegionsList

Parameters

placement
Type: SMath.ManagerContentPlacement
See Also

Reference

RegionsList Class
RegionsList Overload
SMath.Controls Namespace


RegionsList Constructor (List(RegionBase), ContentPlacement)

RegionsList Constructor (ListRegionBase, ContentPlacement)

Initializes a new instance of the RegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsList(
    List<RegionBase> regions,
    ContentPlacement placement
)
Public Sub New (
    regions As List(Of RegionBase),
    placement As ContentPlacement
)
public:
RegionsList(
    List<RegionBase^>^ regions,
    ContentPlacement placement
)
new :
        regions : List<RegionBase> *
        placement : ContentPlacement -> RegionsList

Parameters

regions
Type: System.Collections.GenericListRegionBase
placement
Type: SMath.ManagerContentPlacement
See Also

Reference

RegionsList Class
RegionsList Overload
SMath.Controls Namespace


RegionsList Constructor (ContentPlacement, Int32, Int32)

Initializes a new instance of the RegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsList(
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
Public Sub New (
    placement As ContentPlacement,
    startingFromPage As Integer,
    pagesCount As Integer
)
public:
RegionsList(
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
new :
        placement : ContentPlacement *
        startingFromPage : int *
        pagesCount : int -> RegionsList

Parameters

placement
Type: SMath.ManagerContentPlacement
startingFromPage
Type: SystemInt32
pagesCount
Type: SystemInt32
See Also

Reference

RegionsList Class
RegionsList Overload
SMath.Controls Namespace


RegionsList Constructor (List(RegionBase), ContentPlacement, Int32, Int32)

RegionsList Constructor (ListRegionBase, ContentPlacement, Int32, Int32)

Initializes a new instance of the RegionsList class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsList(
    List<RegionBase> regions,
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
Public Sub New (
    regions As List(Of RegionBase),
    placement As ContentPlacement,
    startingFromPage As Integer,
    pagesCount As Integer
)
public:
RegionsList(
    List<RegionBase^>^ regions,
    ContentPlacement placement,
    int startingFromPage,
    int pagesCount
)
new :
        regions : List<RegionBase> *
        placement : ContentPlacement *
        startingFromPage : int *
        pagesCount : int -> RegionsList

Parameters

regions
Type: System.Collections.GenericListRegionBase
placement
Type: SMath.ManagerContentPlacement
startingFromPage
Type: SystemInt32
pagesCount
Type: SystemInt32
See Also

Reference

RegionsList Class
RegionsList Overload
SMath.Controls Namespace


RegionsList Properties

The RegionsList type exposes the following members.

Properties
 | Name | Description
Public property | PagesCount | (Inherited from ObjectsListT.)
Public property | Placement | (Inherited from ObjectsListT.)
Public property | StartingFromPage | (Inherited from ObjectsListT.)
Top
See Also

Reference

RegionsList Class
SMath.Controls Namespace


RegionsList Methods

The RegionsList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetEnumerator(RegionsEnumerator) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsApplicable(Int32) | (Inherited from ObjectsListT.)
Public method | IsApplicable(Int32, Int32) | (Inherited from ObjectsListT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | (Inherited from ObjectsListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegionsList Class
SMath.Controls Namespace


RegionsList.GetEnumerator Method

RegionsListGetEnumerator Method

Overload List
 | Name | Description
Public method | GetEnumerator |
Public method | GetEnumerator(RegionsEnumerator) |
Top
See Also

Reference

RegionsList Class
SMath.Controls Namespace


RegionsList.GetEnumerator Method

RegionsListGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator GetEnumerator()
Public Function GetEnumerator As RegionsEnumerator
public:
RegionsEnumerator^ GetEnumerator()
member GetEnumerator : unit -> RegionsEnumerator

Return Value

Type: RegionsEnumerator
See Also

Reference

RegionsList Class
GetEnumerator Overload
SMath.Controls Namespace


RegionsList.GetEnumerator Method (RegionsEnumerator)

RegionsListGetEnumerator Method (RegionsEnumerator)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator GetEnumerator(
    RegionsEnumerator enumerator
)
Public Function GetEnumerator (
    enumerator As RegionsEnumerator
) As RegionsEnumerator
public:
RegionsEnumerator^ GetEnumerator(
    RegionsEnumerator^ enumerator
)
member GetEnumerator :
        enumerator : RegionsEnumerator -> RegionsEnumerator

Parameters

enumerator
Type: SMath.ControlsRegionsEnumerator

Return Value

Type: RegionsEnumerator
See Also

Reference

RegionsList Class
GetEnumerator Overload
SMath.Controls Namespace


RegionsManager Class

Inheritance Hierarchy
SystemObject
SMath.ControlsRegionsManager

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RegionsManager
Public Class RegionsManager
public ref class RegionsManager
type RegionsManager =  class end

The RegionsManager type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | IsProtected |
Public property | PagesCount |
Public property | StartingFromPage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllEnumerators |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


RegionsManager Properties

The RegionsManager type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | IsProtected |
Public property | PagesCount |
Public property | StartingFromPage |
Top
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager.Content Property

RegionsManagerContent Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator Content { get; }
Public ReadOnly Property Content As RegionsEnumerator
    Get
public:
property RegionsEnumerator^ Content {
    RegionsEnumerator^ get ();
}
member Content : RegionsEnumerator with get

Property Value

Type: RegionsEnumerator
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager.IsProtected Property

RegionsManagerIsProtected Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsProtected { get; }
Public ReadOnly Property IsProtected As Boolean
    Get
public:
property bool IsProtected {
    bool get ();
}
member IsProtected : bool with get

Property Value

Type: Boolean
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager.PagesCount Property

RegionsManagerPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; }
Public ReadOnly Property PagesCount As Integer
    Get
public:
property int PagesCount {
    int get ();
}
member PagesCount : int with get

Property Value

Type: Int32
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager.StartingFromPage Property

RegionsManagerStartingFromPage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int StartingFromPage { get; }
Public ReadOnly Property StartingFromPage As Integer
    Get
public:
property int StartingFromPage {
    int get ();
}
member StartingFromPage : int with get

Property Value

Type: Int32
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager Methods

The RegionsManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllEnumerators |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManager.GetAllEnumerators Method

RegionsManagerGetAllEnumerators Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<RegionsEnumerator> GetAllEnumerators()
Public Function GetAllEnumerators As IEnumerable(Of RegionsEnumerator)
public:
IEnumerable<RegionsEnumerator^>^ GetAllEnumerators()
member GetAllEnumerators : unit -> IEnumerable<RegionsEnumerator>

Return Value

Type: IEnumerableRegionsEnumerator
See Also

Reference

RegionsManager Class
SMath.Controls Namespace


RegionsManagerInternal Class

Inheritance Hierarchy
SystemObject
SMath.ControlsObjectsManager RegionBase
SMath.ControlsRegionsManagerInternal

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RegionsManagerInternal : ObjectsManager<RegionBase>
Public Class RegionsManagerInternal
    Inherits ObjectsManager(Of RegionBase)
public ref class RegionsManagerInternal : public ObjectsManager<RegionBase^>
type RegionsManagerInternal =
    class
        inherit ObjectsManager<RegionBase>
    end

The RegionsManagerInternal type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsCount | (Inherited from ObjectsManagerT.)
Public property | CurrentContentPlacement | (Inherited from ObjectsManagerT.)
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу. (Inherited from ObjectsManagerT.)
Public property | Footers |
Public property | HasHeaderFooter | (Overrides ObjectsManagerTHasHeaderFooter.)
Public property | Headers |
Public property | Main |
Public property | PagesCount | (Inherited from ObjectsManagerT.)
Public property | RegionsCount |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList |
Public method | GetList(ContentPlacement) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsChanged | (Inherited from ObjectsManagerT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetEnumerator | (Overrides ObjectsManagerTTryGetEnumerator(ContentPlacement, Int32, ObjectsEnumeratorT).)
Public method | TryGetFooter |
Public method | TryGetHeader |
Public method | TryGetList |
Top
See Also

Reference

SMath.Controls Namespace


RegionsManagerInternal Properties

The RegionsManagerInternal type exposes the following members.

Properties
 | Name | Description
Public property | ColumnsCount | (Inherited from ObjectsManagerT.)
Public property | CurrentContentPlacement | (Inherited from ObjectsManagerT.)
Public property | CurrentPage | Gets the current page.Возвращает текущую страницу. (Inherited from ObjectsManagerT.)
Public property | Footers |
Public property | HasHeaderFooter | (Overrides ObjectsManagerTHasHeaderFooter.)
Public property | Headers |
Public property | Main |
Public property | PagesCount | (Inherited from ObjectsManagerT.)
Public property | RegionsCount |
Top
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.Footers Property

RegionsManagerInternalFooters Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionsList> Footers { get; }
Public ReadOnly Property Footers As List(Of RegionsList)
    Get
public:
property List<RegionsList^>^ Footers {
    List<RegionsList^>^ get ();
}
member Footers : List<RegionsList> with get

Property Value

Type: ListRegionsList
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.HasHeaderFooter Property

RegionsManagerInternalHasHeaderFooter Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool HasHeaderFooter { get; }
Public Overrides ReadOnly Property HasHeaderFooter As Boolean
    Get
public:
virtual property bool HasHeaderFooter {
    bool get () override;
}
abstract HasHeaderFooter : bool with get
override HasHeaderFooter : bool with get

Property Value

Type: Boolean

Implements

IObjectsManagerTHasHeaderFooter
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.Headers Property

RegionsManagerInternalHeaders Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionsList> Headers { get; }
Public ReadOnly Property Headers As List(Of RegionsList)
    Get
public:
property List<RegionsList^>^ Headers {
    List<RegionsList^>^ get ();
}
member Headers : List<RegionsList> with get

Property Value

Type: ListRegionsList
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.Main Property

RegionsManagerInternalMain Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsList Main { get; }
Public ReadOnly Property Main As RegionsList
    Get
public:
property RegionsList^ Main {
    RegionsList^ get ();
}
member Main : RegionsList with get

Property Value

Type: RegionsList
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.RegionsCount Property

RegionsManagerInternalRegionsCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int RegionsCount { get; }
Public ReadOnly Property RegionsCount As Integer
    Get
public:
property int RegionsCount {
    int get ();
}
member RegionsCount : int with get

Property Value

Type: Int32
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal Methods

The RegionsManagerInternal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList |
Public method | GetList(ContentPlacement) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsChanged | (Inherited from ObjectsManagerT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetEnumerator | (Overrides ObjectsManagerTTryGetEnumerator(ContentPlacement, Int32, ObjectsEnumeratorT).)
Public method | TryGetFooter |
Public method | TryGetHeader |
Public method | TryGetList |
Top
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.GetEnumerator Method

RegionsManagerInternalGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator GetEnumerator()
Public Function GetEnumerator As RegionsEnumerator
public:
RegionsEnumerator^ GetEnumerator()
member GetEnumerator : unit -> RegionsEnumerator

Return Value

Type: RegionsEnumerator
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.GetList Method

RegionsManagerInternalGetList Method

Overload List
 | Name | Description
Public method | GetList |
Public method | GetList(ContentPlacement) |
Top
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.GetList Method

RegionsManagerInternalGetList Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionBase> GetList()
Public Function GetList As List(Of RegionBase)
public:
List<RegionBase^>^ GetList()
member GetList : unit -> List<RegionBase>

Return Value

Type: ListRegionBase
See Also

Reference

RegionsManagerInternal Class
GetList Overload
SMath.Controls Namespace


RegionsManagerInternal.GetList Method (ContentPlacement)

RegionsManagerInternalGetList Method (ContentPlacement)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<RegionBase> GetList(
    ContentPlacement placement
)
Public Function GetList (
    placement As ContentPlacement
) As List(Of RegionBase)
public:
List<RegionBase^>^ GetList(
    ContentPlacement placement
)
member GetList :
        placement : ContentPlacement -> List<RegionBase>

Parameters

placement
Type: SMath.ManagerContentPlacement

Return Value

Type: ListRegionBase
See Also

Reference

RegionsManagerInternal Class
GetList Overload
SMath.Controls Namespace


RegionsManagerInternal.TryGetEnumerator Method

RegionsManagerInternalTryGetEnumerator Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    out ObjectsEnumerator<RegionBase> enumerator
)
Public Overrides Function TryGetEnumerator (
    placement As ContentPlacement,
    pageIndex As Integer,
    <OutAttribute> ByRef enumerator As ObjectsEnumerator(Of RegionBase)
) As Boolean
public:
virtual bool TryGetEnumerator(
    ContentPlacement placement,
    int pageIndex,
    [OutAttribute] ObjectsEnumerator<RegionBase^>^% enumerator
) override
abstract TryGetEnumerator :
        placement : ContentPlacement *
        pageIndex : int *
        enumerator : ObjectsEnumerator<RegionBase> byref -> bool
override TryGetEnumerator :
        placement : ContentPlacement *
        pageIndex : int *
        enumerator : ObjectsEnumerator<RegionBase> byref -> bool

Parameters

placement
Type: SMath.ManagerContentPlacement
pageIndex
Type: SystemInt32
enumerator
Type: SMath.ControlsObjectsEnumerator RegionBase

Return Value

Type: Boolean

Implements

IObjectsManagerTTryGetEnumerator(ContentPlacement, Int32, ObjectsEnumeratorT)
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.TryGetFooter Method

RegionsManagerInternalTryGetFooter Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetFooter(
    int pageIndex,
    out RegionsList footer
)
Public Function TryGetFooter (
    pageIndex As Integer,
    <OutAttribute> ByRef footer As RegionsList
) As Boolean
public:
bool TryGetFooter(
    int pageIndex,
    [OutAttribute] RegionsList^% footer
)
member TryGetFooter :
        pageIndex : int *
        footer : RegionsList byref -> bool

Parameters

pageIndex
Type: SystemInt32
footer
Type: SMath.ControlsRegionsList

Return Value

Type: Boolean
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.TryGetHeader Method

RegionsManagerInternalTryGetHeader Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetHeader(
    int pageIndex,
    out RegionsList header
)
Public Function TryGetHeader (
    pageIndex As Integer,
    <OutAttribute> ByRef header As RegionsList
) As Boolean
public:
bool TryGetHeader(
    int pageIndex,
    [OutAttribute] RegionsList^% header
)
member TryGetHeader :
        pageIndex : int *
        header : RegionsList byref -> bool

Parameters

pageIndex
Type: SystemInt32
header
Type: SMath.ControlsRegionsList

Return Value

Type: Boolean
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionsManagerInternal.TryGetList Method

RegionsManagerInternalTryGetList Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryGetList(
    ContentPlacement placement,
    int pageIndex,
    out RegionsList list
)
Public Function TryGetList (
    placement As ContentPlacement,
    pageIndex As Integer,
    <OutAttribute> ByRef list As RegionsList
) As Boolean
public:
bool TryGetList(
    ContentPlacement placement,
    int pageIndex,
    [OutAttribute] RegionsList^% list
)
member TryGetList :
        placement : ContentPlacement *
        pageIndex : int *
        list : RegionsList byref -> bool

Parameters

placement
Type: SMath.ManagerContentPlacement
pageIndex
Type: SystemInt32
list
Type: SMath.ControlsRegionsList

Return Value

Type: Boolean
See Also

Reference

RegionsManagerInternal Class
SMath.Controls Namespace


RegionTranslatable Class

Allows a Region to be translatable.Позволяет элементу листа реализовать встроенную поддержку мультиязычности.
Inheritance Hierarchy
SystemObject
SMath.ControlsRegionBase
SMath.ControlsRegionTranslatable

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class RegionTranslatable : RegionBase
Public MustInherit Class RegionTranslatable
    Inherits RegionBase
public ref class RegionTranslatable abstract : public RegionBase
[<AbstractClassAttribute>]
type RegionTranslatable =
    class
        inherit RegionBase
    end

The RegionTranslatable type exposes the following members.

Constructors
 | Name | Description
Public method | RegionTranslatable(RegionTranslatable) | Initializes a new instance of the RegionTranslatable class
Public method | RegionTranslatable(SessionProfile) | Initializes a new instance of the RegionTranslatable class
Top
Properties
 | Name | Description
Public property | AvailableLanguages |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента. (Inherited from RegionBase.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | Returns cursor location within current Region.Возвращает позицию курсора внутри текущего региона. (Inherited from RegionBase.)
Public property | CurrentLanguage |
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | Dependences | (Inherited from RegionBase.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяется актуальностью информации элемента (свойство InDate). (Inherited from RegionBase.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionBase.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | Gets middle line for the Region. (Inherited from RegionBase.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | Size | Size of the Region.Размер элемента листа. (Inherited from RegionBase.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Top
Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Protected method | ChildRepainting | (Inherited from RegionBase.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | ContainsTranslationValue |
Public method | Copy | (Inherited from RegionBase.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Inherited from RegionBase.)
Protected method | GetAllChildren | (Overrides RegionBaseGetAllChildren.)
Public method | GetCursorType | Defines a cursor type by pointer location.Определение вида курсора. (Inherited from RegionBase.)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Inherited from RegionBase.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetTranslation |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionBase.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Protected method | LanguageChange |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend | (Inherited from RegionBase.)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Inherited from RegionBase.)
Public method | OnMouseMove | (Inherited from RegionBase.)
Public method | OnMouseUp | (Inherited from RegionBase.)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Inherited from RegionBase.)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Inherited from RegionBase.)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RemoveCurrentValue |
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetCurrentValue |
Public method | SetTranslationValue(Object) |
Public method | SetTranslationValue(Object, String) |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowTranslationValue | Activates value by the specified language. Creates an empty entry if no translation exists.Активирует значение указанного языка. Создаёт пустое значение, если перевода для указанного языка не существует.
Public method | ToString | (Overrides ObjectToString.)
Public method | ToXml | (Inherited from RegionBase.)
Top
Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | onValueLanguageChanged |
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

SMath.Controls Namespace


RegionTranslatable Constructor

Overload List
 | Name | Description
Public method | RegionTranslatable(RegionTranslatable) | Initializes a new instance of the RegionTranslatable class
Public method | RegionTranslatable(SessionProfile) | Initializes a new instance of the RegionTranslatable class
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable Constructor (RegionTranslatable)

Initializes a new instance of the RegionTranslatable class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionTranslatable(
    RegionTranslatable region
)
Public Sub New (
    region As RegionTranslatable
)
public:
RegionTranslatable(
    RegionTranslatable^ region
)
new :
        region : RegionTranslatable -> RegionTranslatable

Parameters

region
Type: SMath.ControlsRegionTranslatable
See Also

Reference

RegionTranslatable Class
RegionTranslatable Overload
SMath.Controls Namespace


RegionTranslatable Constructor (SessionProfile)

Initializes a new instance of the RegionTranslatable class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionTranslatable(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
RegionTranslatable(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> RegionTranslatable

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

RegionTranslatable Class
RegionTranslatable Overload
SMath.Controls Namespace


RegionTranslatable Properties

The RegionTranslatable type exposes the following members.

Properties
 | Name | Description
Public property | AvailableLanguages |
Public property | BackColor | Фоновый цвет элемента. (Inherited from RegionBase.)
Public property | BaseLine | Gets base line for the Region. (Inherited from RegionBase.)
Public property | BaseSize | Size of the base part of the Region.Размер базовой составляющей элемента. (Inherited from RegionBase.)
Public property | Border | Отрисовка рамки по границе элемента. (Inherited from RegionBase.)
Public property | Bottom | Нижняя граница элемента. (Inherited from RegionBase.)
Public property | Children | (Inherited from RegionBase.)
Public property | Container | (Inherited from RegionBase.)
Protected property | ContainsFields | (Inherited from RegionBase.)
Public property | CurrentCollapsedHeight | (Inherited from RegionBase.)
Public property | CurrentCursorLocation | Returns cursor location within current Region.Возвращает позицию курсора внутри текущего региона. (Inherited from RegionBase.)
Public property | CurrentLanguage |
Public property | CurrentMetaContext | (Inherited from RegionBase.)
Public property | CurrentPageOffsets | (Inherited from RegionBase.)
Public property | Dependences | (Inherited from RegionBase.)
Public property | DrawBase | (Inherited from RegionBase.)
Public property | FixedLayout | Defines if modeling options of the Region could be modified. (Inherited from RegionBase.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяется актуальностью информации элемента (свойство InDate). (Inherited from RegionBase.)
Public property | Font | Шрифт используемый элементом. (Inherited from RegionBase.)
Public property | FontHeight | Размер используемого элементом шрифта. (Inherited from RegionBase.)
Public property | Id | (Inherited from RegionBase.)
Public property | InnerBounds | Bounds of the content Region area relative to the Worksheet.Границы контента элемента относительно листа расчётов. (Inherited from RegionBase.)
Public property | IsActivated | Determines whether Region is activated and registered on the worksheet. (Inherited from RegionBase.)
Public property | IsIntegratedRegion | Determines whether Region is integarted as an important part of another Rerion or not. (Inherited from RegionBase.)
Public property | Link | (Inherited from RegionBase.)
Public property | Location | Location of the Region.Абсолютные координаты элемента листа. (Inherited from RegionBase.)
Public property | MetaData | (Inherited from RegionBase.)
Public property | Middle | Obsolete. (Inherited from RegionBase.)
Public property | MiddleLine | Gets middle line for the Region. (Inherited from RegionBase.)
Public property | PageBreaks | (Inherited from RegionBase.)
Public property | Parent | Gets the Worksheet where Region exists.Определяет лист расчётов, в котором расположен элемент. (Inherited from RegionBase.)
Public property | Regions | Children of the current Region.Дочерние элементы листа текущего. (Inherited from RegionBase.)
Public property | RemoteOwner | Name of the remote owner client. Must be empty if Region belongs to local user.Имя пользователя, контролирующего элемент. Должно содержать пустую строку, если элемент под управлением локального пользователя. (Inherited from RegionBase.)
Public property | Right | Правая граница элемента. (Inherited from RegionBase.)
Public property | Selected | Determines whether Region is selected within the Worksheet.Определяет, является ли элемент выделенным на листе или нет. (Inherited from RegionBase.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента. (Inherited from RegionBase.)
Public property | SelectedTextColor | Цвет выделенного текста элемента. (Inherited from RegionBase.)
Protected property | SessionProfile | (Inherited from RegionBase.)
Public property | Size | Size of the Region.Размер элемента листа. (Inherited from RegionBase.)
Public property | TabStop | (Inherited from RegionBase.)
Public property | TextColor | Цвет текста элемента. (Inherited from RegionBase.)
Public property | UniqueId | Unique Id of the Region.Уникальный идентификатор элемента. (Inherited from RegionBase.)
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.AvailableLanguages Property

RegionTranslatableAvailableLanguages Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] AvailableLanguages { get; }
Public ReadOnly Property AvailableLanguages As String()
    Get
public:
property array<String^>^ AvailableLanguages {
    array<String^>^ get ();
}
member AvailableLanguages : string[] with get

Property Value

Type: String
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.CurrentLanguage Property

RegionTranslatableCurrentLanguage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string CurrentLanguage { get; }
Public ReadOnly Property CurrentLanguage As String
    Get
public:
property String^ CurrentLanguage {
    String^ get ();
}
member CurrentLanguage : string with get

Property Value

Type: String
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable Methods

The RegionTranslatable type exposes the following members.

Methods
 | Name | Description
Public method | BeforeCopy | (Inherited from RegionBase.)
Public method | BeforePaste | (Inherited from RegionBase.)
Public method | ChangeLocation | Безопасное изменение положения элемента (перерисовываются старое и новое положения элемента на листе). (Inherited from RegionBase.)
Public method | ChangeStatus(String) | (Inherited from RegionBase.)
Public method | ChangeStatus(String, Int32, Int32, Stopwatch) | (Inherited from RegionBase.)
Protected method | ChildRepainting | (Inherited from RegionBase.)
Public method | ClickMenuButton | (Inherited from RegionBase.)
Public method | Clone | (Inherited from RegionBase.)
Public method | ContainsTranslationValue |
Public method | Copy | (Inherited from RegionBase.)
Public method | CreateHistoryStep | Registrates Region changes into changes history.Регистрация изменений элемента листа в истории изменений. (Inherited from RegionBase.)
Public method | Dispose | (Inherited from RegionBase.)
Public method | Draw | (Inherited from RegionBase.)
Public method | DrawToBitmap | Получение изображения элемента. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics) | (Inherited from RegionBase.)
Public method | DrawToBitmap(Color, Boolean) | Получение изображения элемента с указанным фоновым цветом. (Inherited from RegionBase.)
Public method | DrawToBitmap(IGraphics, Point) | Drawing of the Region on the specified location.Отрисовка элемента по указанным координатам полотна. (Inherited from RegionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml | (Inherited from RegionBase.)
Protected method | GetAllChildren | (Overrides RegionBaseGetAllChildren.)
Public method | GetCursorType | Defines a cursor type by pointer location.Определение вида курсора. (Inherited from RegionBase.)
Public method | GetFocusedPart | (Inherited from RegionBase.)
Public method | GetHashCode | (Inherited from RegionBase.)
Public method | GetHistoryStep | (Inherited from RegionBase.)
Public method | GetSelectionStatus | (Inherited from RegionBase.)
Public method | GetTranslation |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | InitLayout | (Inherited from RegionBase.)
Public method | Invalidate | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку. (Inherited from RegionBase.)
Public method | IsEmpty | (Inherited from RegionBase.)
Protected method | LanguageChange |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnBeforeCommandSend | (Inherited from RegionBase.)
Public method | OnCommandSend | (Inherited from RegionBase.)
Public method | OnKeyDown | (Inherited from RegionBase.)
Public method | OnKeyPress | (Inherited from RegionBase.)
Public method | OnKeyUp | (Inherited from RegionBase.)
Public method | OnMouseDown | (Inherited from RegionBase.)
Public method | OnMouseMove | (Inherited from RegionBase.)
Public method | OnMouseUp | (Inherited from RegionBase.)
Public method | OnMouseWheel | (Inherited from RegionBase.)
Public method | OnPaint | (Inherited from RegionBase.)
Public method | OnSelectionUpdate | (Inherited from RegionBase.)
Public method | Paste | (Inherited from RegionBase.)
Public method | PrePainter | Prepares a Region for the future drawing. Actualizes internal fields and initializes a region if needed.Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from RegionBase.)
Public method | PrePainter(IGraphics) | (Inherited from RegionBase.)
Public method | ReadyToPaint | Obsolete. (Inherited from RegionBase.)
Public method | RemoveCurrentValue |
Public method | ResetColors | Безопасное применение цветов (обновляются все зависимые от цветов переменные). (Inherited from RegionBase.)
Protected method | Resize | Генерирует событие изменения размера. (Inherited from RegionBase.)
Public method | SetCurrentValue |
Public method | SetTranslationValue(Object) |
Public method | SetTranslationValue(Object, String) |
Public method | ShowAvailableTermsList | (Inherited from RegionBase.)
Public method | ShowTranslationValue | Activates value by the specified language. Creates an empty entry if no translation exists.Активирует значение указанного языка. Создаёт пустое значение, если перевода для указанного языка не существует.
Public method | ToString | (Overrides ObjectToString.)
Public method | ToXml | (Inherited from RegionBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableRegionBaseCompareTo | (Inherited from RegionBase.)
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.ContainsTranslationValue Method

RegionTranslatableContainsTranslationValue Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsTranslationValue(
    string lang
)
Public Function ContainsTranslationValue (
    lang As String
) As Boolean
public:
bool ContainsTranslationValue(
    String^ lang
)
member ContainsTranslationValue :
        lang : string -> bool

Parameters

lang
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.GetAllChildren Method

RegionTranslatableGetAllChildren Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected override ChildrenRegionsList[] GetAllChildren()
Protected Overrides Function GetAllChildren As ChildrenRegionsList()
protected:
virtual array<ChildrenRegionsList^>^ GetAllChildren() override
abstract GetAllChildren : unit -> ChildrenRegionsList[]
override GetAllChildren : unit -> ChildrenRegionsList[]

Return Value

Type: ChildrenRegionsList
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.GetTranslation Method

RegionTranslatableGetTranslation Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool GetTranslation(
    string lang,
    out Object value,
    out ChildrenRegionsList children
)
Public Function GetTranslation (
    lang As String,
    <OutAttribute> ByRef value As Object,
    <OutAttribute> ByRef children As ChildrenRegionsList
) As Boolean
public:
bool GetTranslation(
    String^ lang,
    [OutAttribute] Object^% value,
    [OutAttribute] ChildrenRegionsList^% children
)
member GetTranslation :
        lang : string *
        value : Object byref *
        children : ChildrenRegionsList byref -> bool

Parameters

lang
Type: SystemString
value
Type: SystemObject
children
Type: SMath.ControlsChildrenRegionsList

Return Value

Type: Boolean
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.LanguageChange Method

RegionTranslatableLanguageChange Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract void LanguageChange(
    Object value
)
Protected MustOverride Sub LanguageChange (
    value As Object
)
protected:
virtual void LanguageChange(
    Object^ value
) abstract
abstract LanguageChange :
        value : Object -> unit

Parameters

value
Type: SystemObject
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.RemoveCurrentValue Method

RegionTranslatableRemoveCurrentValue Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool RemoveCurrentValue()
Public Function RemoveCurrentValue As Boolean
public:
bool RemoveCurrentValue()
member RemoveCurrentValue : unit -> bool

Return Value

Type: Boolean
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.SetCurrentValue Method

RegionTranslatableSetCurrentValue Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentValue()
Public Sub SetCurrentValue
public:
void SetCurrentValue()
member SetCurrentValue : unit -> unit
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.SetTranslationValue Method

RegionTranslatableSetTranslationValue Method

Overload List
 | Name | Description
Public method | SetTranslationValue(Object) |
Public method | SetTranslationValue(Object, String) |
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.SetTranslationValue Method (Object)

RegionTranslatableSetTranslationValue Method (Object)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetTranslationValue(
    Object value
)
Public Sub SetTranslationValue (
    value As Object
)
public:
void SetTranslationValue(
    Object^ value
)
member SetTranslationValue :
        value : Object -> unit

Parameters

value
Type: SystemObject
See Also

Reference

RegionTranslatable Class
SetTranslationValue Overload
SMath.Controls Namespace


RegionTranslatable.SetTranslationValue Method (Object, String)

RegionTranslatableSetTranslationValue Method (Object, String)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetTranslationValue(
    Object value,
    string lang
)
Public Sub SetTranslationValue (
    value As Object,
    lang As String
)
public:
void SetTranslationValue(
    Object^ value,
    String^ lang
)
member SetTranslationValue :
        value : Object *
        lang : string -> unit

Parameters

value
Type: SystemObject
lang
Type: SystemString
See Also

Reference

RegionTranslatable Class
SetTranslationValue Overload
SMath.Controls Namespace


RegionTranslatable.ShowTranslationValue Method

RegionTranslatableShowTranslationValue Method

Activates value by the specified language. Creates an empty entry if no translation exists.Активирует значение указанного языка. Создаёт пустое значение, если перевода для указанного языка не существует.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ShowTranslationValue(
    string lang
)
Public Sub ShowTranslationValue (
    lang As String
)
public:
void ShowTranslationValue(
    String^ lang
)
member ShowTranslationValue :
        lang : string -> unit

Parameters

lang
Type: SystemString
Three-letter language representation.Трёхбуквенное обозначение языка перевода.
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.ToString Method

RegionTranslatableToString Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable Events

The RegionTranslatable type exposes the following members.

Events
 | Name | Description
Public event | AvailableTermsListShow | (Inherited from RegionBase.)
Public event | BeforeLocationChanged | (Inherited from RegionBase.)
Public event | Changed | (Inherited from RegionBase.)
Public event | FocusChanged | (Inherited from RegionBase.)
Public event | MenuButtonClick | (Inherited from RegionBase.)
Public event | onValueLanguageChanged |
Public event | PaintRequested | (Inherited from RegionBase.)
Public event | ProgressChanged | (Inherited from RegionBase.)
Public event | Resized | (Inherited from RegionBase.)
Public event | StatusChanged | (Inherited from RegionBase.)
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable.onValueLanguageChanged Event

RegionTranslatableonValueLanguageChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ValueLanguageChanged onValueLanguageChanged
Public Event onValueLanguageChanged As ValueLanguageChanged
public:
 event ValueLanguageChanged^ onValueLanguageChanged {
    void add (ValueLanguageChanged^ value);
    void remove (ValueLanguageChanged^ value);
}
member onValueLanguageChanged : IEvent<ValueLanguageChanged,
    EventArgs>

Value

Type: SMath.ControlsValueLanguageChanged
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


RegionTranslatable Fields

The RegionTranslatable type exposes the following members.

Fields
 | Name | Description
Protected field | brush | Массив "кистей" для рисования. (Inherited from RegionBase.)
Protected field | dblclick | (Inherited from RegionBase.)
Protected field | pen | Массив "карандашей" для рисования. (Inherited from RegionBase.)
Public field | referer | Obsolete. Text action name of the last change in the Region.Текстовое значение выполненного в элементе изменения. (Inherited from RegionBase.)
Top
See Also

Reference

RegionTranslatable Class
SMath.Controls Namespace


ResizeDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ResizeDelegate(
    Size size
)
Public Delegate Sub ResizeDelegate (
    size As Size
)
public delegate void ResizeDelegate(
    Size size
)
type ResizeDelegate =
    delegate of
        size : Size -> unit

Parameters

size
Type: System.DrawingSize
See Also

Reference

SMath.Controls Namespace


ResultPreparedEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ResultPreparedEventHandler(
    RegionEvaluable sender,
    Term[] terms
)
Public Delegate Sub ResultPreparedEventHandler (
    sender As RegionEvaluable,
    terms As Term()
)
public delegate void ResultPreparedEventHandler(
    RegionEvaluable^ sender,
    array<Term^>^ terms
)
type ResultPreparedEventHandler =
    delegate of
        sender : RegionEvaluable *
        terms : Term[] -> unit

Parameters

sender
Type: SMath.ControlsRegionEvaluable
terms
Type: SMath.ManagerTerm
See Also

Reference

SMath.Controls Namespace


ScaleMode Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ScaleMode
Public Enumeration ScaleMode
public enum class ScaleMode
type ScaleMode
Members
Member name | Value | Description
Manual | 0 |
PageWidth | 1 |
ContentWidth | 2 |
FullPage | 3 |
See Also

Reference

SMath.Controls Namespace


ScrollBehavior Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ScrollBehavior
Public Enumeration ScrollBehavior
public enum class ScrollBehavior
type ScrollBehavior
Members
Member name | Value | Description
DocumentCursor | 0 |
RegionCursor | 1 |
PageUp | 2 |
PageDown | 3 |
Home | 4 |
End | 5 |
Reset | 6 |
Left | 7 |
Right | 8 |
Down | 9 |
Up | 10 |
SmallLeft | 11 |
SmallRight | 12 |
SmallDown | 13 |
SmallUp | 14 |
See Also

Reference

SMath.Controls Namespace


SelectDialogInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsSelectDialogInfo
SMath.ControlsSelectFunctionDialogInfo
SMath.ControlsSelectOperatorDialogInfo
SMath.ControlsSelectUnitDialogInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SelectDialogInfo
Public MustInherit Class SelectDialogInfo
public ref class SelectDialogInfo abstract
[<AbstractClassAttribute>]
type SelectDialogInfo =  class end

The SelectDialogInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SelectDialogInfo | Initializes a new instance of the SelectDialogInfo class
Top
Properties
 | Name | Description
Public property | Categories |
Public property | CategoriesTitle |
Public property | ItemsTitle |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | sessionProfile |
Top
See Also

Reference

SMath.Controls Namespace


SelectDialogInfo Constructor

Initializes a new instance of the SelectDialogInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SelectDialogInfo(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
SelectDialogInfo(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> SelectDialogInfo

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo Properties

The SelectDialogInfo type exposes the following members.

Properties
 | Name | Description
Public property | Categories |
Public property | CategoriesTitle |
Public property | ItemsTitle |
Public property | Title |
Top
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.Categories Property

SelectDialogInfoCategories Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IList<string> Categories { get; protected set; }
Public Property Categories As IList(Of String)
    Get
    Protected Set
public:
property IList<String^>^ Categories {
    IList<String^>^ get ();
    protected: void set (IList<String^>^ value);
}
member Categories : IList<string> with get, set

Property Value

Type: IListString
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.CategoriesTitle Property

SelectDialogInfoCategoriesTitle Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string CategoriesTitle { get; protected set; }
Public Property CategoriesTitle As String
    Get
    Protected Set
public:
property String^ CategoriesTitle {
    String^ get ();
    protected: void set (String^ value);
}
member CategoriesTitle : string with get, set

Property Value

Type: String
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.ItemsTitle Property

SelectDialogInfoItemsTitle Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ItemsTitle { get; protected set; }
Public Property ItemsTitle As String
    Get
    Protected Set
public:
property String^ ItemsTitle {
    String^ get ();
    protected: void set (String^ value);
}
member ItemsTitle : string with get, set

Property Value

Type: String
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.Title Property

SelectDialogInfoTitle Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; protected set; }
Public Property Title As String
    Get
    Protected Set
public:
property String^ Title {
    String^ get ();
    protected: void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo Methods

The SelectDialogInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.GetCurrentItems Method

SelectDialogInfoGetCurrentItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<ListBoxItem> GetCurrentItems(
    int selIndex,
    string pattern
)
Public Function GetCurrentItems (
    selIndex As Integer,
    pattern As String
) As List(Of ListBoxItem)
public:
List<ListBoxItem^>^ GetCurrentItems(
    int selIndex,
    String^ pattern
)
member GetCurrentItems :
        selIndex : int *
        pattern : string -> List<ListBoxItem>

Parameters

selIndex
Type: SystemInt32
pattern
Type: SystemString

Return Value

Type: ListListBoxItem
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.GetItems Method

SelectDialogInfoGetItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerable<IDetailedTerm> GetItems(
    int selIndex
)
Public MustOverride Function GetItems (
    selIndex As Integer
) As IEnumerable(Of IDetailedTerm)
public:
virtual IEnumerable<IDetailedTerm^>^ GetItems(
    int selIndex
) abstract
abstract GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>

Parameters

selIndex
Type: SystemInt32

Return Value

Type: IEnumerableIDetailedTerm
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.Perform Method

SelectDialogInfoPerform Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Perform(
    Worksheet worksheet,
    ListBoxItem item
)
Public Sub Perform (
    worksheet As Worksheet,
    item As ListBoxItem
)
public:
void Perform(
    Worksheet^ worksheet,
    ListBoxItem^ item
)
member Perform :
        worksheet : Worksheet *
        item : ListBoxItem -> unit

Parameters

worksheet
Type: SMath.ControlsWorksheet
item
Type: SMath.ControlsListBoxItem
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo Fields

The SelectDialogInfo type exposes the following members.

Fields
 | Name | Description
Protected field | sessionProfile |
Top
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectDialogInfo.sessionProfile Field

SelectDialogInfosessionProfile Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected SessionProfile sessionProfile
Protected sessionProfile As SessionProfile
protected:
SessionProfile^ sessionProfile
val mutable sessionProfile: SessionProfile

Field Value

Type: SessionProfile
See Also

Reference

SelectDialogInfo Class
SMath.Controls Namespace


SelectFunctionDialogInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsSelectDialogInfo
SMath.ControlsSelectFunctionDialogInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SelectFunctionDialogInfo : SelectDialogInfo
Public Class SelectFunctionDialogInfo
    Inherits SelectDialogInfo
public ref class SelectFunctionDialogInfo : public SelectDialogInfo
type SelectFunctionDialogInfo =
    class
        inherit SelectDialogInfo
    end

The SelectFunctionDialogInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SelectFunctionDialogInfo | Initializes a new instance of the SelectFunctionDialogInfo class
Top
Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SMath.Controls Namespace


SelectFunctionDialogInfo Constructor

Initializes a new instance of the SelectFunctionDialogInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SelectFunctionDialogInfo(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
SelectFunctionDialogInfo(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> SelectFunctionDialogInfo

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

SelectFunctionDialogInfo Class
SMath.Controls Namespace


SelectFunctionDialogInfo Properties

The SelectFunctionDialogInfo type exposes the following members.

Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectFunctionDialogInfo Class
SMath.Controls Namespace


SelectFunctionDialogInfo Methods

The SelectFunctionDialogInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectFunctionDialogInfo Class
SMath.Controls Namespace


SelectFunctionDialogInfo.GetItems Method

SelectFunctionDialogInfoGetItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<IDetailedTerm> GetItems(
    int selIndex
)
Public Overrides Function GetItems (
    selIndex As Integer
) As IEnumerable(Of IDetailedTerm)
public:
virtual IEnumerable<IDetailedTerm^>^ GetItems(
    int selIndex
) override
abstract GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>
override GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>

Parameters

selIndex
Type: SystemInt32

Return Value

Type: IEnumerableIDetailedTerm
See Also

Reference

SelectFunctionDialogInfo Class
SMath.Controls Namespace


SelectFunctionDialogInfo Fields

The SelectFunctionDialogInfo type exposes the following members.

Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectFunctionDialogInfo Class
SMath.Controls Namespace


SelectionType Enumeration

Определяет то, какие элементы необходимо выделить при использовании метода SelectRegions(...).

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum SelectionType
Public Enumeration SelectionType
public enum class SelectionType
type SelectionType
Members
Member name | Value | Description
ByRectangle | 0 | Выделяет только те элементы, которые находятся в выделении.
All | 1 | Выделяет все элементы текущего листа.
None | 2 | Снимает выделение со всех элементов (если такие имеются) листа.
See Also

Reference

SMath.Controls Namespace


SelectOperatorDialogInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsSelectDialogInfo
SMath.ControlsSelectOperatorDialogInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SelectOperatorDialogInfo : SelectDialogInfo
Public Class SelectOperatorDialogInfo
    Inherits SelectDialogInfo
public ref class SelectOperatorDialogInfo : public SelectDialogInfo
type SelectOperatorDialogInfo =
    class
        inherit SelectDialogInfo
    end

The SelectOperatorDialogInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SelectOperatorDialogInfo | Initializes a new instance of the SelectOperatorDialogInfo class
Top
Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SMath.Controls Namespace


SelectOperatorDialogInfo Constructor

Initializes a new instance of the SelectOperatorDialogInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SelectOperatorDialogInfo(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
SelectOperatorDialogInfo(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> SelectOperatorDialogInfo

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

SelectOperatorDialogInfo Class
SMath.Controls Namespace


SelectOperatorDialogInfo Properties

The SelectOperatorDialogInfo type exposes the following members.

Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectOperatorDialogInfo Class
SMath.Controls Namespace


SelectOperatorDialogInfo Methods

The SelectOperatorDialogInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectOperatorDialogInfo Class
SMath.Controls Namespace


SelectOperatorDialogInfo.GetItems Method

SelectOperatorDialogInfoGetItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<IDetailedTerm> GetItems(
    int selIndex
)
Public Overrides Function GetItems (
    selIndex As Integer
) As IEnumerable(Of IDetailedTerm)
public:
virtual IEnumerable<IDetailedTerm^>^ GetItems(
    int selIndex
) override
abstract GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>
override GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>

Parameters

selIndex
Type: SystemInt32

Return Value

Type: IEnumerableIDetailedTerm
See Also

Reference

SelectOperatorDialogInfo Class
SMath.Controls Namespace


SelectOperatorDialogInfo Fields

The SelectOperatorDialogInfo type exposes the following members.

Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectOperatorDialogInfo Class
SMath.Controls Namespace


SelectUnitDialogInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsSelectDialogInfo
SMath.ControlsSelectUnitDialogInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SelectUnitDialogInfo : SelectDialogInfo
Public Class SelectUnitDialogInfo
    Inherits SelectDialogInfo
public ref class SelectUnitDialogInfo : public SelectDialogInfo
type SelectUnitDialogInfo =
    class
        inherit SelectDialogInfo
    end

The SelectUnitDialogInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SelectUnitDialogInfo | Initializes a new instance of the SelectUnitDialogInfo class
Top
Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SMath.Controls Namespace


SelectUnitDialogInfo Constructor

Initializes a new instance of the SelectUnitDialogInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SelectUnitDialogInfo(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
SelectUnitDialogInfo(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> SelectUnitDialogInfo

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

SelectUnitDialogInfo Class
SMath.Controls Namespace


SelectUnitDialogInfo Properties

The SelectUnitDialogInfo type exposes the following members.

Properties
 | Name | Description
Public property | Categories | (Inherited from SelectDialogInfo.)
Public property | CategoriesTitle | (Inherited from SelectDialogInfo.)
Public property | ItemsTitle | (Inherited from SelectDialogInfo.)
Public property | Title | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectUnitDialogInfo Class
SMath.Controls Namespace


SelectUnitDialogInfo Methods

The SelectUnitDialogInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCurrentItems | (Inherited from SelectDialogInfo.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | (Overrides SelectDialogInfoGetItems(Int32).)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Perform | (Inherited from SelectDialogInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectUnitDialogInfo Class
SMath.Controls Namespace


SelectUnitDialogInfo.GetItems Method

SelectUnitDialogInfoGetItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override IEnumerable<IDetailedTerm> GetItems(
    int selIndex
)
Public Overrides Function GetItems (
    selIndex As Integer
) As IEnumerable(Of IDetailedTerm)
public:
virtual IEnumerable<IDetailedTerm^>^ GetItems(
    int selIndex
) override
abstract GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>
override GetItems :
        selIndex : int -> IEnumerable<IDetailedTerm>

Parameters

selIndex
Type: SystemInt32

Return Value

Type: IEnumerableIDetailedTerm
See Also

Reference

SelectUnitDialogInfo Class
SMath.Controls Namespace


SelectUnitDialogInfo Fields

The SelectUnitDialogInfo type exposes the following members.

Fields
 | Name | Description
Protected field | sessionProfile | (Inherited from SelectDialogInfo.)
Top
See Also

Reference

SelectUnitDialogInfo Class
SMath.Controls Namespace


SimpleTouchDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void SimpleTouchDelegate(
    PointF pnt
)
Public Delegate Sub SimpleTouchDelegate (
    pnt As PointF
)
public delegate void SimpleTouchDelegate(
    PointF pnt
)
type SimpleTouchDelegate =
    delegate of
        pnt : PointF -> unit

Parameters

pnt
Type: System.DrawingPointF
See Also

Reference

SMath.Controls Namespace


StatusEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void StatusEventHandler(
    RegionBase region,
    string message
)
Public Delegate Sub StatusEventHandler (
    region As RegionBase,
    message As String
)
public delegate void StatusEventHandler(
    RegionBase^ region,
    String^ message
)
type StatusEventHandler =
    delegate of
        region : RegionBase *
        message : string -> unit

Parameters

region
Type: SMath.ControlsRegionBase
message
Type: SystemString
See Also

Reference

SMath.Controls Namespace


StorageReader Class

Region content import manager.
Inheritance Hierarchy
SystemObject
SMath.ControlsStorageReader

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class StorageReader
Public Class StorageReader
public ref class StorageReader
type StorageReader =  class end

The StorageReader type exposes the following members.

Constructors
 | Name | Description
Public method | StorageReader(PropertiesReader, String, String) | Initializes a new instance of the StorageReader class
Public method | StorageReader(PropertiesReader, String, StringBuilder) | Initializes a new instance of the StorageReader class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Properties | Returns reader for properties.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetXmlReader | Generates new XmlReader to get data from.
Public method | GetXmlString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


StorageReader Constructor

Overload List
 | Name | Description
Public method | StorageReader(PropertiesReader, String, String) | Initializes a new instance of the StorageReader class
Public method | StorageReader(PropertiesReader, String, StringBuilder) | Initializes a new instance of the StorageReader class
Top
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader Constructor (PropertiesReader, String, String)

Initializes a new instance of the StorageReader class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StorageReader(
    PropertiesReader properties,
    string name,
    string rawXml
)
Public Sub New (
    properties As PropertiesReader,
    name As String,
    rawXml As String
)
public:
StorageReader(
    PropertiesReader^ properties,
    String^ name,
    String^ rawXml
)
new :
        properties : PropertiesReader *
        name : string *
        rawXml : string -> StorageReader

Parameters

properties
Type: SMath.ControlsPropertiesReader
name
Type: SystemString
rawXml
Type: SystemString
See Also

Reference

StorageReader Class
StorageReader Overload
SMath.Controls Namespace


StorageReader Constructor (PropertiesReader, String, StringBuilder)

Initializes a new instance of the StorageReader class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StorageReader(
    PropertiesReader properties,
    string name,
    StringBuilder rawXml
)
Public Sub New (
    properties As PropertiesReader,
    name As String,
    rawXml As StringBuilder
)
public:
StorageReader(
    PropertiesReader^ properties,
    String^ name,
    StringBuilder^ rawXml
)
new :
        properties : PropertiesReader *
        name : string *
        rawXml : StringBuilder -> StorageReader

Parameters

properties
Type: SMath.ControlsPropertiesReader
name
Type: SystemString
rawXml
Type: System.TextStringBuilder
See Also

Reference

StorageReader Class
StorageReader Overload
SMath.Controls Namespace


StorageReader Properties

The StorageReader type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Properties | Returns reader for properties.
Top
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader.Name Property

StorageReaderName Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader.Properties Property

StorageReaderProperties Property

Returns reader for properties.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesReader Properties { get; }
Public ReadOnly Property Properties As PropertiesReader
    Get
public:
property PropertiesReader^ Properties {
    PropertiesReader^ get ();
}
member Properties : PropertiesReader with get

Property Value

Type: PropertiesReader
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader Methods

The StorageReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetXmlReader | Generates new XmlReader to get data from.
Public method | GetXmlString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader.GetXmlReader Method

StorageReaderGetXmlReader Method

Generates new XmlReader to get data from.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public XmlReader GetXmlReader()
Public Function GetXmlReader As XmlReader
public:
XmlReader^ GetXmlReader()
member GetXmlReader : unit -> XmlReader

Return Value

Type: XmlReader
XmlReader to get data from.
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageReader.GetXmlString Method

StorageReaderGetXmlString Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetXmlString()
Public Function GetXmlString As String
public:
String^ GetXmlString()
member GetXmlString : unit -> string

Return Value

Type: String
See Also

Reference

StorageReader Class
SMath.Controls Namespace


StorageWriter Class

Region content export manager.
Inheritance Hierarchy
SystemObject
SMath.ControlsStorageWriter

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class StorageWriter
Public Class StorageWriter
public ref class StorageWriter
type StorageWriter =  class end

The StorageWriter type exposes the following members.

Constructors
 | Name | Description
Public method | StorageWriter | Initializes a new instance of the StorageWriter class
Top
Properties
 | Name | Description
Public property | Properties | Returns writer for properties.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetXmlWriter | Generates new XmlWriter to be used for data storage. Note: Do not dispose it.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


StorageWriter Constructor

Initializes a new instance of the StorageWriter class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StorageWriter(
    PropertiesWriter properties,
    XmlWriter writer
)
Public Sub New (
    properties As PropertiesWriter,
    writer As XmlWriter
)
public:
StorageWriter(
    PropertiesWriter^ properties,
    XmlWriter^ writer
)
new :
        properties : PropertiesWriter *
        writer : XmlWriter -> StorageWriter

Parameters

properties
Type: SMath.ControlsPropertiesWriter
writer
Type: System.XmlXmlWriter
See Also

Reference

StorageWriter Class
SMath.Controls Namespace


StorageWriter Properties

The StorageWriter type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Returns writer for properties.
Top
See Also

Reference

StorageWriter Class
SMath.Controls Namespace


StorageWriter.Properties Property

StorageWriterProperties Property

Returns writer for properties.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PropertiesWriter Properties { get; }
Public ReadOnly Property Properties As PropertiesWriter
    Get
public:
property PropertiesWriter^ Properties {
    PropertiesWriter^ get ();
}
member Properties : PropertiesWriter with get

Property Value

Type: PropertiesWriter
See Also

Reference

StorageWriter Class
SMath.Controls Namespace


StorageWriter Methods

The StorageWriter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetXmlWriter | Generates new XmlWriter to be used for data storage. Note: Do not dispose it.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StorageWriter Class
SMath.Controls Namespace


StorageWriter.GetXmlWriter Method

StorageWriterGetXmlWriter Method

Generates new XmlWriter to be used for data storage. Note: Do not dispose it.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public XmlWriter GetXmlWriter()
Public Function GetXmlWriter As XmlWriter
public:
XmlWriter^ GetXmlWriter()
member GetXmlWriter : unit -> XmlWriter

Return Value

Type: XmlWriter
XmlWriter to be used for data storage.
See Also

Reference

StorageWriter Class
SMath.Controls Namespace


ToolboxItemInfo Class

Inheritance Hierarchy
SystemObject
SMath.ControlsToolboxItemInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ToolboxItemInfo
Public Class ToolboxItemInfo
public ref class ToolboxItemInfo
type ToolboxItemInfo =  class end

The ToolboxItemInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxItemInfo | Initializes a new instance of the ToolboxItemInfo class
Public method | ToolboxItemInfo(String, ToolboxItemType) | Initializes a new instance of the ToolboxItemInfo class
Public method | ToolboxItemInfo(String, String, ToolboxItemType) | Initializes a new instance of the ToolboxItemInfo class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Text |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


ToolboxItemInfo Constructor

Overload List
 | Name | Description
Public method | ToolboxItemInfo | Initializes a new instance of the ToolboxItemInfo class
Public method | ToolboxItemInfo(String, ToolboxItemType) | Initializes a new instance of the ToolboxItemInfo class
Public method | ToolboxItemInfo(String, String, ToolboxItemType) | Initializes a new instance of the ToolboxItemInfo class
Top
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemInfo Constructor

Initializes a new instance of the ToolboxItemInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemInfo()
Public Sub New
public:
ToolboxItemInfo()
new : unit -> ToolboxItemInfo
See Also

Reference

ToolboxItemInfo Class
ToolboxItemInfo Overload
SMath.Controls Namespace


ToolboxItemInfo Constructor (String, ToolboxItemType)

Initializes a new instance of the ToolboxItemInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemInfo(
    string text,
    ToolboxItemType drawableId
)
Public Sub New (
    text As String,
    drawableId As ToolboxItemType
)
public:
ToolboxItemInfo(
    String^ text,
    ToolboxItemType drawableId
)
new :
        text : string *
        drawableId : ToolboxItemType -> ToolboxItemInfo

Parameters

text
Type: SystemString
drawableId
Type: SMath.ControlsToolboxItemType
See Also

Reference

ToolboxItemInfo Class
ToolboxItemInfo Overload
SMath.Controls Namespace


ToolboxItemInfo Constructor (String, String, ToolboxItemType)

Initializes a new instance of the ToolboxItemInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemInfo(
    string text,
    string action,
    ToolboxItemType drawableId
)
Public Sub New (
    text As String,
    action As String,
    drawableId As ToolboxItemType
)
public:
ToolboxItemInfo(
    String^ text,
    String^ action,
    ToolboxItemType drawableId
)
new :
        text : string *
        action : string *
        drawableId : ToolboxItemType -> ToolboxItemInfo

Parameters

text
Type: SystemString
action
Type: SystemString
drawableId
Type: SMath.ControlsToolboxItemType
See Also

Reference

ToolboxItemInfo Class
ToolboxItemInfo Overload
SMath.Controls Namespace


ToolboxItemInfo Properties

The ToolboxItemInfo type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Text |
Public property | Type |
Top
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemInfo.Action Property

ToolboxItemInfoAction Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Action { get; }
Public ReadOnly Property Action As String
    Get
public:
property String^ Action {
    String^ get ();
}
member Action : string with get

Property Value

Type: String
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemInfo.Text Property

ToolboxItemInfoText Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemInfo.Type Property

ToolboxItemInfoType Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxItemType Type { get; }
Public ReadOnly Property Type As ToolboxItemType
    Get
public:
property ToolboxItemType Type {
    ToolboxItemType get ();
}
member Type : ToolboxItemType with get

Property Value

Type: ToolboxItemType
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemInfo Methods

The ToolboxItemInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxItemInfo Class
SMath.Controls Namespace


ToolboxItemType Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ToolboxItemType
Public Enumeration ToolboxItemType
public enum class ToolboxItemType
type ToolboxItemType
Members
Member name | Value | Description
RightMode | 0 |
RightItem | 1 |
RightFunc | 2 |
RightUnit | 3 |
See Also

Reference

SMath.Controls Namespace


TouchSelectionType Enumeration

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum TouchSelectionType
Public Enumeration TouchSelectionType
public enum class TouchSelectionType
type TouchSelectionType
Members
Member name | Value | Description
None | 0 |
Move | 1 |
LeftSelector | 2 |
RightSelector | 3 |
See Also

Reference

SMath.Controls Namespace


ValueLanguageChanged Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ValueLanguageChanged(
    RegionTranslatable sender,
    bool perform
)
Public Delegate Sub ValueLanguageChanged (
    sender As RegionTranslatable,
    perform As Boolean
)
public delegate void ValueLanguageChanged(
    RegionTranslatable^ sender,
    bool perform
)
type ValueLanguageChanged =
    delegate of
        sender : RegionTranslatable *
        perform : bool -> unit

Parameters

sender
Type: SMath.ControlsRegionTranslatable
perform
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


Worksheet Class

Worksheet Control of the program.Элемент управления рабочего листа программы.
Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheet
SMath.ControlsInteractiveWorksheet
SMath.ControlsNonInteractiveWorksheet

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Worksheet : IDocument<RegionBase>,
    IDisposable
Public MustInherit Class Worksheet
    Implements IDocument(Of RegionBase), IDisposable
public ref class Worksheet abstract : IDocument<RegionBase^>,
    IDisposable
[<AbstractClassAttribute>]
type Worksheet =
    class
        interface IDocument<RegionBase>
        interface IDisposable
    end

The Worksheet type exposes the following members.

Constructors
 | Name | Description
Public method | Worksheet(Worksheet) | Initializes a new instance of the Worksheet class
Public method | Worksheet(SessionProfile, PresentationMode) | Constructor of the Worksheet.Конструктор листа расчётов.
Top
Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена.
Public property | ContentSize |
Public property | CurrentColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage |
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта.
 | CustomRegionPlugins | Returns the list of installed Custom Region plug-ins.Возвращает список установленных Custom Region дополнений.
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка.
Public property | Editor |
Public property | Focused |
Public property | GridSize |
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет.
Public property | History | Worksheet changes history.История изменений листа расчётов.
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода.
Public property | InvokeRequired |
Public property | IsDifferentInPlacement |
Public property | IsInEvalution | Obsolete.
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке.
Public property | MetaContext |
Public property | MetaData | Worksheet meta-data.Мета-данные листа.
Public property | Mode |
Public property | MultiplePages |
Public property | ObjectsManager |
Public property | PageIndex |
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов.
Public property | PagesCount |
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта.
Public property | Params |
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте.
Public property | ScrollSize |
Public property | Search |
Public property | SessionProfile | Session parameters.Параметры сессии.
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа.
Public property | Status | Status of the worksheet.Статус листа расчётов.
Top
Methods
 | Name | Description
Public method | AddBreakpoint |
Public method | ApplyInitialDefinitions |
Public method | Clear |
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт.
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete.
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) |
Public method | CreateStore |
Public method | Dispose | Releases all resources used by the Worksheet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus |
 | GetAssemblyTagName |
Public method | GetCollapsedHeight(Int32) |
Public method | GetCollapsedHeight(RegionsList, Int32) |
Public method | GetCurrentStore |
Public method | GetCurrentTooltip |
Public method | GetCursorType | Defines a mouse cursor type at the specific position on the worksheet.Определение вида курсора в определённом месте листа.
Public method | GetEvaluationContext |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams |
Public method | GetPreviouslyDefinedParamsAll |
Public method | GetRegionIndex |
Public method | GetRegionsBounds | Calculates bounds of the selected Regions.
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа.
Public method | GetStaticContextMenuItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) |
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionsList, Int32, Int32) |
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object.
Public method | GotFocus |
Public method | HideCursorIfRequired |
Public method | HideError |
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов.
Public method | Insert(ButtonAction) |
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region.
Public method | Invalidate |
Public method | Invalidate(Rectangle) |
Public method | Invalidate(Int32, Int32, Int32, Int32) |
Public method | Invoke |
Public method | LockRegion |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown | Mouse button down event handler.Реакция на событие нажатия клавиши мыши.
Protected method | MouseMove | Mouse cursor move event handler.Реакция на событие движения курсора мыши.
Protected method | MouseUp | Mouse button up event handler.Реакция на событие отпускания клавиши мыши.
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши.
Protected method | PageStatusManager |
Public method | RefreshContent |
Public method | RefreshUI |
Public method | RemoveRegions(RegionBase) |
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа.
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) |
 | ResetCustomRegionPlugins | Reset list of Custom Region plug-ins for future usage.Сбросить список Custom Region дополнений для последующего использования.
 | ResetRegionDrawingPlugins | Reset list of Region Drawing plug-ins for future usage.Сбросить список Region Drawing дополнений для последующего использования.
Protected method | Resize | Изменение размеров элемента.
Public method | ResumeLayout |
Public method | Scroll |
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required.
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) |
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) |
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region.
Public method | ScrollToRegion(RegionBase, RectangleF) |
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента.
Public method | SetDebuggerMode |
Public method | SetRegionBorder |
Public method | SetRegionColor |
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings.
Public method | SetRegionFontFamily |
Public method | SetRegionFontSize |
Public method | ShowCursorIfRequired |
Public method | ShowError |
Protected method | SnapToGrid |
Public method | SortRegions |
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа.
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время.
Public method | SuppressLayout |
 | Test |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов.
 | TryGetRegionByTagName | Enumerates all the available custom region plug-ins in order to find one with specified tag name. Creates a new Region after plug-in is found.
Public method | UnfocusRegions |
Public method | UnlockRegion |
Public method | UpdatePageModel |
Public method | UpdateScrollBars |
Public method | VerifyLanguageNotifier |
Top
Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad |
Public event | OnCurrentRegionChanged |
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки.
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки.
Public event | OnFileContextLoad |
Public event | OnMenuButtonEmulated |
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля.
Public event | OnProgressChanged |
Public event | OnRegionCreated |
Public event | OnStatusChanged |
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа.
Top
Fields
Name | Description
regionDrawingPlugins |
Top
See Also

Reference

SMath.Controls Namespace


Worksheet Constructor

Overload List
 | Name | Description
Public method | Worksheet(Worksheet) | Initializes a new instance of the Worksheet class
Public method | Worksheet(SessionProfile, PresentationMode) | Constructor of the Worksheet.Конструктор листа расчётов.
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet Constructor (Worksheet)

Initializes a new instance of the Worksheet class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Worksheet(
    Worksheet worksheet
)
Public Sub New (
    worksheet As Worksheet
)
public:
Worksheet(
    Worksheet^ worksheet
)
new :
        worksheet : Worksheet -> Worksheet

Parameters

worksheet
Type: SMath.ControlsWorksheet
See Also

Reference

Worksheet Class
Worksheet Overload
SMath.Controls Namespace


Worksheet Constructor (SessionProfile, PresentationMode)

Constructor of the Worksheet.Конструктор листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Worksheet(
    SessionProfile sessionProfile,
    PresentationMode mode
)
Public Sub New (
    sessionProfile As SessionProfile,
    mode As PresentationMode
)
public:
Worksheet(
    SessionProfile^ sessionProfile,
    PresentationMode mode
)
new :
        sessionProfile : SessionProfile *
        mode : PresentationMode -> Worksheet

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
mode
Type: SMath.ControlsPresentationMode
See Also

Reference

Worksheet Class
Worksheet Overload
SMath.Controls Namespace


Worksheet Properties

The Worksheet type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteDefinitions | Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.
Public property | Clipboard | Clipboard manager.Менеджер буфера обмена.
Public property | ContentSize |
Public property | CurrentColumnsCount |
Public property | CurrentContentPlacement |
Public property | CurrentPage |
Public property | CurrentRegion | Current Region of the Worksheet.Текущий элемент листа рассчёта.
 | CustomRegionPlugins | Returns the list of installed Custom Region plug-ins.Возвращает список установленных Custom Region дополнений.
Public property | DrawGrid | Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка.
Public property | Editor |
Public property | Focused |
Public property | GridSize |
Public property | HasCurrentRegion | Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет.
Public property | History | Worksheet changes history.История изменений листа расчётов.
Public property | IntelliSense | Dynamic assistance for the Worksheet.Динамическая помощь ввода.
Public property | InvokeRequired |
Public property | IsDifferentInPlacement |
Public property | IsInEvalution | Obsolete.
Public property | LanguageNotifier | On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке.
Public property | MetaContext |
Public property | MetaData | Worksheet meta-data.Мета-данные листа.
Public property | Mode |
Public property | MultiplePages |
Public property | ObjectsManager |
Public property | PageIndex |
Public property | PageModel | Print out worksheet parameters.Параметры печати листа расчётов.
Public property | PagesCount |
Public property | PagesOptions | Worksheet Pages manager.Менеджер страниц листа расчёта.
Public property | Params |
Public property | Pointer | Current Worksheet cursor information.Информация о курсоре в текущем рассчёте.
Public property | ScrollSize |
Public property | Search |
Public property | SessionProfile | Session parameters.Параметры сессии.
Public property | Size | Current size of the visible active Worksheet area.Текущий размер видимой активной части листа.
Public property | Status | Status of the worksheet.Статус листа расчётов.
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.AbsoluteDefinitions Property

WorksheetAbsoluteDefinitions Property

Gets or sets a list of Absolute Definitions (definitions available to read/write anywhere in the Worksheet) for the Worksheet.Определяет список абсолютных определений (определений, разрешённых для чтения/записи где угодно в расчёте), доступных на листе расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Definition> AbsoluteDefinitions { get; set; }
Public Property AbsoluteDefinitions As List(Of Definition)
    Get
    Set
public:
property List<Definition^>^ AbsoluteDefinitions {
    List<Definition^>^ get ();
    void set (List<Definition^>^ value);
}
member AbsoluteDefinitions : List<Definition> with get, set

Property Value

Type: ListDefinition
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Clipboard Property

WorksheetClipboard Property

Clipboard manager.Менеджер буфера обмена.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IClipboardManager Clipboard { get; set; }
Public Property Clipboard As IClipboardManager
    Get
    Set
public:
property IClipboardManager^ Clipboard {
    IClipboardManager^ get ();
    void set (IClipboardManager^ value);
}
member Clipboard : IClipboardManager with get, set

Property Value

Type: IClipboardManager
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ContentSize Property

WorksheetContentSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size ContentSize { get; set; }
Public Property ContentSize As Size
    Get
    Set
public:
virtual property Size ContentSize {
    Size get () sealed;
    void set (Size value) sealed;
}
abstract ContentSize : Size with get, set
override ContentSize : Size with get, set

Property Value

Type: Size

Implements

IDocumentTContentSize
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CurrentColumnsCount Property

WorksheetCurrentColumnsCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentColumnsCount { get; }
Public ReadOnly Property CurrentColumnsCount As Integer
    Get
public:
property int CurrentColumnsCount {
    int get ();
}
member CurrentColumnsCount : int with get

Property Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CurrentContentPlacement Property

WorksheetCurrentContentPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContentPlacement CurrentContentPlacement { get; set; }
Public Property CurrentContentPlacement As ContentPlacement
    Get
    Set
public:
property ContentPlacement CurrentContentPlacement {
    ContentPlacement get ();
    void set (ContentPlacement value);
}
member CurrentContentPlacement : ContentPlacement with get, set

Property Value

Type: ContentPlacement
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CurrentPage Property

WorksheetCurrentPage Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage CurrentPage { get; }
Public ReadOnly Property CurrentPage As DocumentPage
    Get
public:
property DocumentPage^ CurrentPage {
    DocumentPage^ get ();
}
member CurrentPage : DocumentPage with get

Property Value

Type: DocumentPage
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CurrentRegion Property

WorksheetCurrentRegion Property

Current Region of the Worksheet.Текущий элемент листа рассчёта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase CurrentRegion { get; }
Public ReadOnly Property CurrentRegion As RegionBase
    Get
public:
property RegionBase^ CurrentRegion {
    RegionBase^ get ();
}
member CurrentRegion : RegionBase with get

Property Value

Type: RegionBase
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CustomRegionPlugins Property

WorksheetCustomRegionPlugins Property

Returns the list of installed Custom Region plug-ins.Возвращает список установленных Custom Region дополнений.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<PluginInfo> CustomRegionPlugins { get; }
Public Shared ReadOnly Property CustomRegionPlugins As IEnumerable(Of PluginInfo)
    Get
public:
static property IEnumerable<PluginInfo^>^ CustomRegionPlugins {
    IEnumerable<PluginInfo^>^ get ();
}
static member CustomRegionPlugins : IEnumerable<PluginInfo> with get

Property Value

Type: IEnumerablePluginInfo
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.DrawGrid Property

WorksheetDrawGrid Property

Defines if the grid will be drawn on the worksheet.Определяет, будет ли на листе отрисована сетка.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool DrawGrid { get; set; }
Public Property DrawGrid As Boolean
    Get
    Set
public:
virtual property bool DrawGrid {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract DrawGrid : bool with get, set
override DrawGrid : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentTDrawGrid
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Editor Property

WorksheetEditor Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetEditor Editor { get; set; }
Public Property Editor As WorksheetEditor
    Get
    Set
public:
property WorksheetEditor^ Editor {
    WorksheetEditor^ get ();
    void set (WorksheetEditor^ value);
}
member Editor : WorksheetEditor with get, set

Property Value

Type: WorksheetEditor
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Focused Property

WorksheetFocused Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool Focused { get; }
Public MustOverride ReadOnly Property Focused As Boolean
    Get
public:
virtual property bool Focused {
    bool get () abstract;
}
abstract Focused : bool with get

Property Value

Type: Boolean

Implements

IDocumentTFocused
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GridSize Property

WorksheetGridSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GridSize { get; }
Public ReadOnly Property GridSize As Integer
    Get
public:
property int GridSize {
    int get ();
}
member GridSize : int with get

Property Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.HasCurrentRegion Property

WorksheetHasCurrentRegion Property

Defines whether the Worksheet contain Current Region or not.Определяет есть ли текущий регион на листе рассчётов или нет.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasCurrentRegion { get; }
Public ReadOnly Property HasCurrentRegion As Boolean
    Get
public:
property bool HasCurrentRegion {
    bool get ();
}
member HasCurrentRegion : bool with get

Property Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.History Property

WorksheetHistory Property

Worksheet changes history.История изменений листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManager History { get; set; }
Public Property History As HistoryManager
    Get
    Set
public:
property HistoryManager^ History {
    HistoryManager^ get ();
    void set (HistoryManager^ value);
}
member History : HistoryManager with get, set

Property Value

Type: HistoryManager
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.IntelliSense Property

WorksheetIntelliSense Property

Dynamic assistance for the Worksheet.Динамическая помощь ввода.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IAutoComplete IntelliSense { get; set; }
Public Property IntelliSense As IAutoComplete
    Get
    Set
public:
property IAutoComplete^ IntelliSense {
    IAutoComplete^ get ();
    void set (IAutoComplete^ value);
}
member IntelliSense : IAutoComplete with get, set

Property Value

Type: IAutoComplete
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.InvokeRequired Property

WorksheetInvokeRequired Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual bool InvokeRequired { get; }
Public Overridable ReadOnly Property InvokeRequired As Boolean
    Get
public:
virtual property bool InvokeRequired {
    bool get ();
}
abstract InvokeRequired : bool with get
override InvokeRequired : bool with get

Property Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.IsDifferentInPlacement Property

WorksheetIsDifferentInPlacement Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDifferentInPlacement { get; set; }
Public Property IsDifferentInPlacement As Boolean
    Get
    Set
public:
property bool IsDifferentInPlacement {
    bool get ();
    void set (bool value);
}
member IsDifferentInPlacement : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.IsInEvalution Property

WorksheetIsInEvalution Property

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Status Property instead.")]
public bool IsInEvalution { get; }
<ObsoleteAttribute("Use Status Property instead.")>
Public ReadOnly Property IsInEvalution As Boolean
    Get
public:
[ObsoleteAttribute(L"Use Status Property instead.")]
property bool IsInEvalution {
    bool get ();
}
[<ObsoleteAttribute("Use Status Property instead.")>]
member IsInEvalution : bool with get

Property Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.LanguageNotifier Property

WorksheetLanguageNotifier Property

On screen notification of current selected language for multilingual regions.Напоминания для мультиязычных элементов листа о текущем выбранном языке.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ITranslationNotification LanguageNotifier { get; set; }
Public Property LanguageNotifier As ITranslationNotification
    Get
    Set
public:
property ITranslationNotification^ LanguageNotifier {
    ITranslationNotification^ get ();
    void set (ITranslationNotification^ value);
}
member LanguageNotifier : ITranslationNotification with get, set

Property Value

Type: ITranslationNotification
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MetaContext Property

WorksheetMetaContext Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MetaContext MetaContext { get; set; }
Public Property MetaContext As MetaContext
    Get
    Set
public:
virtual property MetaContext^ MetaContext {
    MetaContext^ get () sealed;
    void set (MetaContext^ value) sealed;
}
abstract MetaContext : MetaContext with get, set
override MetaContext : MetaContext with get, set

Property Value

Type: MetaContext

Implements

IDocumentTMetaContext
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MetaData Property

WorksheetMetaData Property

Worksheet meta-data.Мета-данные листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, WorksheetInfo> MetaData { get; set; }
Public Property MetaData As Dictionary(Of String, WorksheetInfo)
    Get
    Set
public:
property Dictionary<String^, WorksheetInfo^>^ MetaData {
    Dictionary<String^, WorksheetInfo^>^ get ();
    void set (Dictionary<String^, WorksheetInfo^>^ value);
}
member MetaData : Dictionary<string, WorksheetInfo> with get, set

Property Value

Type: DictionaryString, WorksheetInfo
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Mode Property

WorksheetMode Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PresentationMode Mode { get; }
Public ReadOnly Property Mode As PresentationMode
    Get
public:
virtual property PresentationMode Mode {
    PresentationMode get () sealed;
}
abstract Mode : PresentationMode with get
override Mode : PresentationMode with get

Property Value

Type: PresentationMode

Implements

IDocumentTMode
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MultiplePages Property

WorksheetMultiplePages Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool MultiplePages { get; set; }
Public Property MultiplePages As Boolean
    Get
    Set
public:
virtual property bool MultiplePages {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract MultiplePages : bool with get, set
override MultiplePages : bool with get, set

Property Value

Type: Boolean

Implements

IDocumentTMultiplePages
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ObjectsManager Property

WorksheetObjectsManager Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IObjectsManager<RegionBase> ObjectsManager { get; set; }
Public Property ObjectsManager As IObjectsManager(Of RegionBase)
    Get
    Set
public:
virtual property IObjectsManager<RegionBase^>^ ObjectsManager {
    IObjectsManager<RegionBase^>^ get () sealed;
    void set (IObjectsManager<RegionBase^>^ value) sealed;
}
abstract ObjectsManager : IObjectsManager<RegionBase> with get, set
override ObjectsManager : IObjectsManager<RegionBase> with get, set

Property Value

Type: IObjectsManager RegionBase

Implements

IDocumentTObjectsManager
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.PageIndex Property

WorksheetPageIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PageIndex { get; }
Public ReadOnly Property PageIndex As Integer
    Get
public:
property int PageIndex {
    int get ();
}
member PageIndex : int with get

Property Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.PageModel Property

WorksheetPageModel Property

Print out worksheet parameters.Параметры печати листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel PageModel { get; set; }
Public Property PageModel As PageModel
    Get
    Set
public:
virtual property PageModel^ PageModel {
    PageModel^ get () sealed;
    void set (PageModel^ value) sealed;
}
abstract PageModel : PageModel with get, set
override PageModel : PageModel with get, set

Property Value

Type: PageModel

Implements

IDocumentTPageModel
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.PagesCount Property

WorksheetPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; }
Public ReadOnly Property PagesCount As Integer
    Get
public:
property int PagesCount {
    int get ();
}
member PagesCount : int with get

Property Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.PagesOptions Property

WorksheetPagesOptions Property

Worksheet Pages manager.Менеджер страниц листа расчёта.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesOptions PagesOptions { get; set; }
Public Property PagesOptions As PagesOptions
    Get
    Set
public:
virtual property PagesOptions^ PagesOptions {
    PagesOptions^ get () sealed;
    void set (PagesOptions^ value) sealed;
}
abstract PagesOptions : PagesOptions with get, set
override PagesOptions : PagesOptions with get, set

Property Value

Type: PagesOptions

Implements

IDocumentTPagesOptions
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Params Property

WorksheetParams Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetParams Params { get; set; }
Public Property Params As WorksheetParams
    Get
    Set
public:
property WorksheetParams^ Params {
    WorksheetParams^ get ();
    void set (WorksheetParams^ value);
}
member Params : WorksheetParams with get, set

Property Value

Type: WorksheetParams
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Pointer Property

WorksheetPointer Property

Current Worksheet cursor information.Информация о курсоре в текущем рассчёте.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPointer Pointer { get; set; }
Public Property Pointer As DocumentPointer
    Get
    Set
public:
virtual property DocumentPointer^ Pointer {
    DocumentPointer^ get () sealed;
    void set (DocumentPointer^ value) sealed;
}
abstract Pointer : DocumentPointer with get, set
override Pointer : DocumentPointer with get, set

Property Value

Type: DocumentPointer

Implements

IDocumentTPointer
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ScrollSize Property

WorksheetScrollSize Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size ScrollSize { get; set; }
Public Property ScrollSize As Size
    Get
    Set
public:
virtual property Size ScrollSize {
    Size get () sealed;
    void set (Size value) sealed;
}
abstract ScrollSize : Size with get, set
override ScrollSize : Size with get, set

Property Value

Type: Size

Implements

IDocumentTScrollSize
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Search Property

WorksheetSearch Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetSearch Search { get; set; }
Public Property Search As WorksheetSearch
    Get
    Set
public:
property WorksheetSearch^ Search {
    WorksheetSearch^ get ();
    void set (WorksheetSearch^ value);
}
member Search : WorksheetSearch with get, set

Property Value

Type: WorksheetSearch
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SessionProfile Property

WorksheetSessionProfile Property

Session parameters.Параметры сессии.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; set; }
Public Property SessionProfile As SessionProfile
    Get
    Set
public:
virtual property SessionProfile^ SessionProfile {
    SessionProfile^ get () sealed;
    void set (SessionProfile^ value) sealed;
}
abstract SessionProfile : SessionProfile with get, set
override SessionProfile : SessionProfile with get, set

Property Value

Type: SessionProfile

Implements

IDocumentTSessionProfile
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Size Property

WorksheetSize Property

Current size of the visible active Worksheet area.Текущий размер видимой активной части листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () sealed;
    void set (Size value) sealed;
}
abstract Size : Size with get, set
override Size : Size with get, set

Property Value

Type: Size

Implements

IDocumentTSize
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Status Property

WorksheetStatus Property

Status of the worksheet.Статус листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentStatus Status { get; set; }
Public Property Status As DocumentStatus
    Get
    Set
public:
virtual property DocumentStatus Status {
    DocumentStatus get () sealed;
    void set (DocumentStatus value) sealed;
}
abstract Status : DocumentStatus with get, set
override Status : DocumentStatus with get, set

Property Value

Type: DocumentStatus

Implements

IDocumentTStatus
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet Methods

The Worksheet type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint |
Public method | ApplyInitialDefinitions |
Public method | Clear |
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт.
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete.
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) |
Public method | CreateStore |
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus |
 | GetAssemblyTagName |
Public method | GetCollapsedHeight(Int32) |
Public method | GetCollapsedHeight(RegionsList, Int32) |
Public method | GetCurrentStore |
Public method | GetCurrentTooltip |
Public method | GetCursorType | Defines a mouse cursor type at the specific position on the worksheet.Определение вида курсора в определённом месте листа.
Public method | GetEvaluationContext |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPreviouslyDefinedParams |
Public method | GetPreviouslyDefinedParamsAll |
Public method | GetRegionIndex |
Public method | GetRegionsBounds | Calculates bounds of the selected Regions.
Public method | GetRegionsEnumerator | Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа.
Public method | GetStaticContextMenuItems |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetWorksheetPage(Int32, Int32) |
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionsList, Int32, Int32) |
Public method | GetWorksheetPageStrict | Returns Document Page which contains given Object.
Public method | GotFocus |
Public method | HideCursorIfRequired |
Public method | HideError |
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов.
Public method | Insert(ButtonAction) |
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region.
Public method | Invalidate |
Public method | Invalidate(Rectangle) |
Public method | Invalidate(Int32, Int32, Int32, Int32) |
Public method | Invoke |
Public method | LockRegion |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MouseDown | Mouse button down event handler.Реакция на событие нажатия клавиши мыши.
Protected method | MouseMove | Mouse cursor move event handler.Реакция на событие движения курсора мыши.
Protected method | MouseUp | Mouse button up event handler.Реакция на событие отпускания клавиши мыши.
Protected method | MouseWheel | Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши.
Protected method | PageStatusManager |
Public method | RefreshContent |
Public method | RefreshUI |
Public method | RemoveRegions(RegionBase) |
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа.
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) |
 | ResetCustomRegionPlugins | Reset list of Custom Region plug-ins for future usage.Сбросить список Custom Region дополнений для последующего использования.
 | ResetRegionDrawingPlugins | Reset list of Region Drawing plug-ins for future usage.Сбросить список Region Drawing дополнений для последующего использования.
Protected method | Resize | Изменение размеров элемента.
Public method | ResumeLayout |
Public method | Scroll |
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required.
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) |
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) |
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region.
Public method | ScrollToRegion(RegionBase, RectangleF) |
Public method | SelectRegions | Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента.
Public method | SetDebuggerMode |
Public method | SetRegionBorder |
Public method | SetRegionColor |
Public method | SetRegionCurrentTextLang | Updates all translatable Regions to set language according to global application settings.
Public method | SetRegionFontFamily |
Public method | SetRegionFontSize |
Public method | ShowCursorIfRequired |
Public method | ShowError |
Protected method | SnapToGrid |
Public method | SortRegions |
Public method | StartEvaluation | Performs evaluation of the worksheet.Начинает пересчёт данных листа.
Public method | StartEvaluationAndWait | Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время.
Public method | SuppressLayout |
 | Test |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryAbortEvaluation | Abort worksheet recalculation.Прерывает пересчёт листа расчётов.
 | TryGetRegionByTagName | Enumerates all the available custom region plug-ins in order to find one with specified tag name. Creates a new Region after plug-in is found.
Public method | UnfocusRegions |
Public method | UnlockRegion |
Public method | UpdatePageModel |
Public method | UpdateScrollBars |
Public method | VerifyLanguageNotifier |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.AddBreakpoint Method

WorksheetAddBreakpoint Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddBreakpoint(
    Term term,
    bool toggle
)
Public Sub AddBreakpoint (
    term As Term,
    toggle As Boolean
)
public:
void AddBreakpoint(
    Term^ term,
    bool toggle
)
member AddBreakpoint :
        term : Term *
        toggle : bool -> unit

Parameters

term
Type: SMath.ManagerTerm
toggle
Type: SystemBoolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ApplyInitialDefinitions Method

WorksheetApplyInitialDefinitions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ApplyInitialDefinitions(
    List<Definition> defs
)
Public Sub ApplyInitialDefinitions (
    defs As List(Of Definition)
)
public:
void ApplyInitialDefinitions(
    List<Definition^>^ defs
)
member ApplyInitialDefinitions :
        defs : List<Definition> -> unit

Parameters

defs
Type: System.Collections.GenericListDefinition
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Clear Method

WorksheetClear Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Clear()
Public Function Clear As Boolean
public:
bool Clear()
member Clear : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CreateRegions Method

WorksheetCreateRegions Method

Overload List
 | Name | Description
Public method | CreateRegions(IEnumerableRegionBase, Boolean, LocationCorrectionMode) | Adds Regions to the worksheet.Добавляет элементы листа в расчёт.
Public method | CreateRegions(IEnumerableRegionBase, Boolean, Boolean) | Obsolete.
Public method | CreateRegions(RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.CreateRegions Method (IEnumerable(RegionBase), Boolean, LocationCorrectionMode)

WorksheetCreateRegions Method (IEnumerableRegionBase, Boolean, LocationCorrectionMode)

Adds Regions to the worksheet.Добавляет элементы листа в расчёт.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CreateRegions(
    IEnumerable<RegionBase> newRegions,
    bool showProgress = false,
    LocationCorrectionMode locationCorrection = LocationCorrectionMode.CorrectWithCursor
)
Public Sub CreateRegions (
    newRegions As IEnumerable(Of RegionBase),
    Optional showProgress As Boolean = false,
    Optional locationCorrection As LocationCorrectionMode = LocationCorrectionMode.CorrectWithCursor
)
public:
void CreateRegions(
    IEnumerable<RegionBase^>^ newRegions,
    bool showProgress = false,
    LocationCorrectionMode locationCorrection = LocationCorrectionMode::CorrectWithCursor
)
member CreateRegions :
        newRegions : IEnumerable<RegionBase> *
        ?showProgress : bool *
        ?locationCorrection : LocationCorrectionMode
(* Defaults:
        let _showProgress = defaultArg showProgress false
        let _locationCorrection = defaultArg locationCorrection LocationCorrectionMode.CorrectWithCursor
*)
-> unit

Parameters

newRegions
Type: System.Collections.GenericIEnumerableRegionBase
Regions to add.Элементы листа для добавления.
showProgress (Optional)
Type: SystemBoolean
locationCorrection (Optional)
Type: SMath.ControlsLocationCorrectionMode
See Also

Reference

Worksheet Class
CreateRegions Overload
SMath.Controls Namespace


Worksheet.CreateRegions Method (IEnumerable(RegionBase), Boolean, Boolean)

WorksheetCreateRegions Method (IEnumerableRegionBase, Boolean, Boolean)

Note: This API is now obsolete.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use overloaded method instead.", false)]
public void CreateRegions(
    IEnumerable<RegionBase> newRegions,
    bool withProgress,
    bool useCursorLocation
)
<ObsoleteAttribute("Use overloaded method instead.", false)>
Public Sub CreateRegions (
    newRegions As IEnumerable(Of RegionBase),
    withProgress As Boolean,
    useCursorLocation As Boolean
)
public:
[ObsoleteAttribute(L"Use overloaded method instead.", false)]
void CreateRegions(
    IEnumerable<RegionBase^>^ newRegions,
    bool withProgress,
    bool useCursorLocation
)
[<ObsoleteAttribute("Use overloaded method instead.", false)>]
member CreateRegions :
        newRegions : IEnumerable<RegionBase> *
        withProgress : bool *
        useCursorLocation : bool -> unit

Parameters

newRegions
Type: System.Collections.GenericIEnumerableRegionBase
withProgress
Type: SystemBoolean
useCursorLocation
Type: SystemBoolean
See Also

Reference

Worksheet Class
CreateRegions Overload
SMath.Controls Namespace


Worksheet.CreateRegions Method (RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode)

WorksheetCreateRegions Method (RegionsEnumerator, Int32, Int32, Boolean, LocationCorrectionMode)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CreateRegions(
    RegionsEnumerator enumerator,
    int startingFromPage,
    int pagesCount,
    bool showProgress = false,
    LocationCorrectionMode locationCorrection = LocationCorrectionMode.CorrectWithCursor
)
Public Sub CreateRegions (
    enumerator As RegionsEnumerator,
    startingFromPage As Integer,
    pagesCount As Integer,
    Optional showProgress As Boolean = false,
    Optional locationCorrection As LocationCorrectionMode = LocationCorrectionMode.CorrectWithCursor
)
public:
void CreateRegions(
    RegionsEnumerator^ enumerator,
    int startingFromPage,
    int pagesCount,
    bool showProgress = false,
    LocationCorrectionMode locationCorrection = LocationCorrectionMode::CorrectWithCursor
)
member CreateRegions :
        enumerator : RegionsEnumerator *
        startingFromPage : int *
        pagesCount : int *
        ?showProgress : bool *
        ?locationCorrection : LocationCorrectionMode
(* Defaults:
        let _showProgress = defaultArg showProgress false
        let _locationCorrection = defaultArg locationCorrection LocationCorrectionMode.CorrectWithCursor
*)
-> unit

Parameters

enumerator
Type: SMath.ControlsRegionsEnumerator
startingFromPage
Type: SystemInt32
pagesCount
Type: SystemInt32
showProgress (Optional)
Type: SystemBoolean
locationCorrection (Optional)
Type: SMath.ControlsLocationCorrectionMode
See Also

Reference

Worksheet Class
CreateRegions Overload
SMath.Controls Namespace


Worksheet.CreateStore Method

WorksheetCreateStore Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store CreateStore()
Public Function CreateStore As Store
public:
Store^ CreateStore()
member CreateStore : unit -> Store

Return Value

Type: Store
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Dispose Method

WorksheetDispose Method

Releases all resources used by the Worksheet

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Focus Method

WorksheetFocus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Focus()
Public Overridable Sub Focus
public:
virtual void Focus()
abstract Focus : unit -> unit
override Focus : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetAssemblyTagName Method

WorksheetGetAssemblyTagName Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetAssemblyTagName(
    RegionBase obj
)
Public Shared Function GetAssemblyTagName (
    obj As RegionBase
) As String
public:
static String^ GetAssemblyTagName(
    RegionBase^ obj
)
static member GetAssemblyTagName :
        obj : RegionBase -> string

Parameters

obj
Type: SMath.ControlsRegionBase

Return Value

Type: String
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetCollapsedHeight Method

WorksheetGetCollapsedHeight Method

Overload List
 | Name | Description
Public method | GetCollapsedHeight(Int32) |
Public method | GetCollapsedHeight(RegionsList, Int32) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetCollapsedHeight Method (Int32)

WorksheetGetCollapsedHeight Method (Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetCollapsedHeight(
    int y
)
Public Function GetCollapsedHeight (
    y As Integer
) As Integer
public:
int GetCollapsedHeight(
    int y
)
member GetCollapsedHeight :
        y : int -> int

Parameters

y
Type: SystemInt32
The logical coordinate (must not contain Logical Page Offset), f.e.: real location of the Region.

Return Value

Type: Int32
See Also

Reference

Worksheet Class
GetCollapsedHeight Overload
SMath.Controls Namespace


Worksheet.GetCollapsedHeight Method (RegionsList, Int32)

WorksheetGetCollapsedHeight Method (RegionsList, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetCollapsedHeight(
    RegionsList list,
    int y
)
Public Function GetCollapsedHeight (
    list As RegionsList,
    y As Integer
) As Integer
public:
int GetCollapsedHeight(
    RegionsList^ list,
    int y
)
member GetCollapsedHeight :
        list : RegionsList *
        y : int -> int

Parameters

list
Type: SMath.ControlsRegionsList
y
Type: SystemInt32
The logical coordinate (must not contain Logical Page Offset), f.e.: real location of the Region.

Return Value

Type: Int32
See Also

Reference

Worksheet Class
GetCollapsedHeight Overload
SMath.Controls Namespace


Worksheet.GetCurrentStore Method

WorksheetGetCurrentStore Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store GetCurrentStore()
Public Function GetCurrentStore As Store
public:
Store^ GetCurrentStore()
member GetCurrentStore : unit -> Store

Return Value

Type: Store
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetCurrentTooltip Method

WorksheetGetCurrentTooltip Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap GetCurrentTooltip(
    int index
)
Public Function GetCurrentTooltip (
    index As Integer
) As IBitmap
public:
IBitmap^ GetCurrentTooltip(
    int index
)
member GetCurrentTooltip :
        index : int -> IBitmap

Parameters

index
Type: SystemInt32

Return Value

Type: IBitmap
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetCursorType Method

WorksheetGetCursorType Method

Defines a mouse cursor type at the specific position on the worksheet.Определение вида курсора в определённом месте листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual CursorStatus GetCursorType(
    MouseEventOptions e
)
Public Overridable Function GetCursorType (
    e As MouseEventOptions
) As CursorStatus
public:
virtual CursorStatus^ GetCursorType(
    MouseEventOptions^ e
)
abstract GetCursorType :
        e : MouseEventOptions -> CursorStatus
override GetCursorType :
        e : MouseEventOptions -> CursorStatus

Parameters

e
Type: SMath.ManagerMouseEventOptions
Place of the mouse cursor.Положение курсора.

Return Value

Type: CursorStatus
Returns type of the mouse cursor according to its position.Возвращает вид курсора на основании его положения.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetEvaluationContext Method

WorksheetGetEvaluationContext Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EvaluationContext GetEvaluationContext()
Public Function GetEvaluationContext As EvaluationContext
public:
EvaluationContext^ GetEvaluationContext()
member GetEvaluationContext : unit -> EvaluationContext

Return Value

Type: EvaluationContext
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetPreviouslyDefinedParams Method

WorksheetGetPreviouslyDefinedParams Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Definition> GetPreviouslyDefinedParams()
Public Function GetPreviouslyDefinedParams As List(Of Definition)
public:
List<Definition^>^ GetPreviouslyDefinedParams()
member GetPreviouslyDefinedParams : unit -> List<Definition>

Return Value

Type: ListDefinition
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetPreviouslyDefinedParamsAll Method

WorksheetGetPreviouslyDefinedParamsAll Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Definition> GetPreviouslyDefinedParamsAll()
Public Function GetPreviouslyDefinedParamsAll As List(Of Definition)
public:
List<Definition^>^ GetPreviouslyDefinedParamsAll()
member GetPreviouslyDefinedParamsAll : unit -> List<Definition>

Return Value

Type: ListDefinition
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetRegionIndex Method

WorksheetGetRegionIndex Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetRegionIndex(
    RegionBase region
)
Public Function GetRegionIndex (
    region As RegionBase
) As Integer
public:
int GetRegionIndex(
    RegionBase^ region
)
member GetRegionIndex :
        region : RegionBase -> int

Parameters

region
Type: SMath.ControlsRegionBase

Return Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetRegionsBounds Method

WorksheetGetRegionsBounds Method

Calculates bounds of the selected Regions.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Rectangle GetRegionsBounds(
    bool selected,
    int sizeLimit = 0
)
Public Function GetRegionsBounds (
    selected As Boolean,
    Optional sizeLimit As Integer = 0
) As Rectangle
public:
Rectangle GetRegionsBounds(
    bool selected,
    int sizeLimit = 0
)
member GetRegionsBounds :
        selected : bool *
        ?sizeLimit : int
(* Defaults:
        let _sizeLimit = defaultArg sizeLimit 0
*)
-> Rectangle

Parameters

selected
Type: SystemBoolean
Whether selected Regions only must be taken in account.
sizeLimit (Optional)
Type: SystemInt32
Maximum limit of the pixels count. Set 0 for no limits.

Return Value

Type: Rectangle
Bounding rectangle for the selected Regions.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetRegionsEnumerator Method

WorksheetGetRegionsEnumerator Method

Creates enumerator to iterate through available Worksheet Regions.Создаёт объект для перечисления доступных элементов листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionsEnumerator GetRegionsEnumerator()
Public Function GetRegionsEnumerator As RegionsEnumerator
public:
RegionsEnumerator^ GetRegionsEnumerator()
member GetRegionsEnumerator : unit -> RegionsEnumerator

Return Value

Type: RegionsEnumerator
Returns enumerator to iterate through available Worksheet Regions.Возвращает объект для перечисления доступных элементов листа.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetStaticContextMenuItems Method

WorksheetGetStaticContextMenuItems Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MenuButton[] GetStaticContextMenuItems(
    RegionBase[] regions
)
Public Function GetStaticContextMenuItems (
    regions As RegionBase()
) As MenuButton()
public:
array<MenuButton^>^ GetStaticContextMenuItems(
    array<RegionBase^>^ regions
)
member GetStaticContextMenuItems :
        regions : RegionBase[] -> MenuButton[]

Parameters

regions
Type: SMath.ControlsRegionBase

Return Value

Type: MenuButton
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetWorksheetPage Method

WorksheetGetWorksheetPage Method

Overload List
 | Name | Description
Public method | GetWorksheetPage(Int32, Int32) |
Public method | GetWorksheetPage(RegionBase, Point) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionBase, Int32) | Returns Document Page which contains given Object.
Public method | GetWorksheetPage(RegionsList, Int32, Int32) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GetWorksheetPage Method (Int32, Int32)

WorksheetGetWorksheetPage Method (Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetWorksheetPage(
    int y,
    out int collapsedHeight
)
Public Function GetWorksheetPage (
    y As Integer,
    <OutAttribute> ByRef collapsedHeight As Integer
) As DocumentPage
public:
DocumentPage^ GetWorksheetPage(
    int y,
    [OutAttribute] int% collapsedHeight
)
member GetWorksheetPage :
        y : int *
        collapsedHeight : int byref -> DocumentPage

Parameters

y
Type: SystemInt32
The logical coordinate (must not contain Logical Page Offset), f.e.: real location of the Region.
collapsedHeight
Type: SystemInt32

Return Value

Type: DocumentPage
See Also

Reference

Worksheet Class
GetWorksheetPage Overload
SMath.Controls Namespace


Worksheet.GetWorksheetPage Method (RegionBase, Point)

WorksheetGetWorksheetPage Method (RegionBase, Point)

Returns Document Page which contains given Object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetWorksheetPage(
    RegionBase region,
    Point logicalPnt
)
Public Function GetWorksheetPage (
    region As RegionBase,
    logicalPnt As Point
) As DocumentPage
public:
DocumentPage^ GetWorksheetPage(
    RegionBase^ region,
    Point logicalPnt
)
member GetWorksheetPage :
        region : RegionBase *
        logicalPnt : Point -> DocumentPage

Parameters

region
Type: SMath.ControlsRegionBase
logicalPnt
Type: System.DrawingPoint

Return Value

Type: DocumentPage
See Also

Reference

Worksheet Class
GetWorksheetPage Overload
SMath.Controls Namespace


Worksheet.GetWorksheetPage Method (RegionBase, Int32)

WorksheetGetWorksheetPage Method (RegionBase, Int32)

Returns Document Page which contains given Object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetWorksheetPage(
    RegionBase region,
    int preferedPageIndex
)
Public Function GetWorksheetPage (
    region As RegionBase,
    preferedPageIndex As Integer
) As DocumentPage
public:
DocumentPage^ GetWorksheetPage(
    RegionBase^ region,
    int preferedPageIndex
)
member GetWorksheetPage :
        region : RegionBase *
        preferedPageIndex : int -> DocumentPage

Parameters

region
Type: SMath.ControlsRegionBase
preferedPageIndex
Type: SystemInt32

Return Value

Type: DocumentPage
See Also

Reference

Worksheet Class
GetWorksheetPage Overload
SMath.Controls Namespace


Worksheet.GetWorksheetPage Method (RegionsList, Int32, Int32)

WorksheetGetWorksheetPage Method (RegionsList, Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetWorksheetPage(
    RegionsList list,
    int y,
    out int collapsedHeight
)
Public Function GetWorksheetPage (
    list As RegionsList,
    y As Integer,
    <OutAttribute> ByRef collapsedHeight As Integer
) As DocumentPage
public:
DocumentPage^ GetWorksheetPage(
    RegionsList^ list,
    int y,
    [OutAttribute] int% collapsedHeight
)
member GetWorksheetPage :
        list : RegionsList *
        y : int *
        collapsedHeight : int byref -> DocumentPage

Parameters

list
Type: SMath.ControlsRegionsList
y
Type: SystemInt32
The logical coordinate (must not contain Logical Page Offset), f.e.: real location of the Region.
collapsedHeight
Type: SystemInt32

Return Value

Type: DocumentPage
See Also

Reference

Worksheet Class
GetWorksheetPage Overload
SMath.Controls Namespace


Worksheet.GetWorksheetPageStrict Method

WorksheetGetWorksheetPageStrict Method

Returns Document Page which contains given Object.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentPage GetWorksheetPageStrict(
    RegionBase region,
    Point physicalPnt
)
Public Function GetWorksheetPageStrict (
    region As RegionBase,
    physicalPnt As Point
) As DocumentPage
public:
DocumentPage^ GetWorksheetPageStrict(
    RegionBase^ region,
    Point physicalPnt
)
member GetWorksheetPageStrict :
        region : RegionBase *
        physicalPnt : Point -> DocumentPage

Parameters

region
Type: SMath.ControlsRegionBase
physicalPnt
Type: System.DrawingPoint

Return Value

Type: DocumentPage
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.GotFocus Method

WorksheetGotFocus Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void GotFocus(
    EventArgs e
)
Public Sub GotFocus (
    e As EventArgs
)
public:
void GotFocus(
    EventArgs^ e
)
member GotFocus :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.HideCursorIfRequired Method

WorksheetHideCursorIfRequired Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void HideCursorIfRequired()
Public Overridable Sub HideCursorIfRequired
public:
virtual void HideCursorIfRequired()
abstract HideCursorIfRequired : unit -> unit
override HideCursorIfRequired : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.HideError Method

WorksheetHideError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void HideError()
Public MustOverride Sub HideError
public:
virtual void HideError() abstract
abstract HideError : unit -> unit

Implements

IDocumentTHideError
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Insert Method

WorksheetInsert Method

Overload List
 | Name | Description
Public method | Insert(String) | Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов.
Public method | Insert(ButtonAction) |
Public method | Insert(RegionBase) | Adds Regions to Worksheet and insert focus in the first added Region.
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Insert Method (String)

WorksheetInsert Method (String)

Parses a text command for the current worksheet.Разбирает текстовою команду текущего листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    string value
)
Public Sub Insert (
    value As String
)
public:
void Insert(
    String^ value
)
member Insert :
        value : string -> unit

Parameters

value
Type: SystemString
Text command.Текстовая команда.
See Also

Reference

Worksheet Class
Insert Overload
SMath.Controls Namespace


Worksheet.Insert Method (ButtonAction)

WorksheetInsert Method (ButtonAction)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Insert(
    ButtonAction action
)
Public Function Insert (
    action As ButtonAction
) As Boolean
public:
bool Insert(
    ButtonAction^ action
)
member Insert :
        action : ButtonAction -> bool

Parameters

action
Type: SMath.ControlsButtonAction

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
Insert Overload
SMath.Controls Namespace


Worksheet.Insert Method (RegionBase[])

WorksheetInsert Method (RegionBase)

Adds Regions to Worksheet and insert focus in the first added Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Insert(
    RegionBase[] regions
)
Public Sub Insert (
    regions As RegionBase()
)
public:
void Insert(
    array<RegionBase^>^ regions
)
member Insert :
        regions : RegionBase[] -> unit

Parameters

regions
Type: SMath.ControlsRegionBase
List of Regions to add into Worksheet.
See Also

Reference

Worksheet Class
Insert Overload
SMath.Controls Namespace


Worksheet.Invalidate Method

WorksheetInvalidate Method

Overload List
 | Name | Description
Public method | Invalidate |
Public method | Invalidate(Rectangle) |
Public method | Invalidate(Int32, Int32, Int32, Int32) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Invalidate Method

WorksheetInvalidate Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void Invalidate()
Public MustOverride Sub Invalidate
public:
virtual void Invalidate() abstract
abstract Invalidate : unit -> unit

Implements

IDocumentTInvalidate
See Also

Reference

Worksheet Class
Invalidate Overload
SMath.Controls Namespace


Worksheet.Invalidate Method (Rectangle)

WorksheetInvalidate Method (Rectangle)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void Invalidate(
    Rectangle rect
)
Public MustOverride Sub Invalidate (
    rect As Rectangle
)
public:
virtual void Invalidate(
    Rectangle rect
) abstract
abstract Invalidate :
        rect : Rectangle -> unit

Parameters

rect
Type: System.DrawingRectangle
See Also

Reference

Worksheet Class
Invalidate Overload
SMath.Controls Namespace


Worksheet.Invalidate Method (Int32, Int32, Int32, Int32)

WorksheetInvalidate Method (Int32, Int32, Int32, Int32)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Invalidate(
    int x,
    int y,
    int width,
    int height
)
Public Sub Invalidate (
    x As Integer,
    y As Integer,
    width As Integer,
    height As Integer
)
public:
void Invalidate(
    int x,
    int y,
    int width,
    int height
)
member Invalidate :
        x : int *
        y : int *
        width : int *
        height : int -> unit

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

Worksheet Class
Invalidate Overload
SMath.Controls Namespace


Worksheet.Invoke Method

WorksheetInvoke Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Invoke(
    Delegate method,
    params Object[] args
)
Public Overridable Sub Invoke (
    method As Delegate,
    ParamArray args As Object()
)
public:
virtual void Invoke(
    Delegate^ method,
    ... array<Object^>^ args
)
abstract Invoke :
        method : Delegate *
        args : Object[] -> unit
override Invoke :
        method : Delegate *
        args : Object[] -> unit

Parameters

method
Type: SystemDelegate
args
Type: SystemObject
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.LockRegion Method

WorksheetLockRegion Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LockRegion(
    string password
)
Public Sub LockRegion (
    password As String
)
public:
void LockRegion(
    String^ password
)
member LockRegion :
        password : string -> unit

Parameters

password
Type: SystemString
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MouseDown Method

WorksheetMouseDown Method

Mouse button down event handler.Реакция на событие нажатия клавиши мыши.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void MouseDown(
    MouseEventOptions e
)
Protected Sub MouseDown (
    e As MouseEventOptions
)
protected:
void MouseDown(
    MouseEventOptions^ e
)
member MouseDown :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
Mouse button down event arguments.Аргументы события нажатия кнопки мыши.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MouseMove Method

WorksheetMouseMove Method

Mouse cursor move event handler.Реакция на событие движения курсора мыши.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void MouseMove(
    MouseEventOptions e
)
Protected Sub MouseMove (
    e As MouseEventOptions
)
protected:
void MouseMove(
    MouseEventOptions^ e
)
member MouseMove :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
Mouse cursor move event arguments.Аргументы события движения курсора мыши.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MouseUp Method

WorksheetMouseUp Method

Mouse button up event handler.Реакция на событие отпускания клавиши мыши.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void MouseUp(
    MouseEventOptions e
)
Protected Sub MouseUp (
    e As MouseEventOptions
)
protected:
void MouseUp(
    MouseEventOptions^ e
)
member MouseUp :
        e : MouseEventOptions -> unit

Parameters

e
Type: SMath.ManagerMouseEventOptions
Mouse button up event arguments.Аргументы события отпускания кнопки мыши.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.MouseWheel Method

WorksheetMouseWheel Method

Changing of the scrollbars values by mouse wheel.Изменение положения кареток прокрутки с помощью колеса мыши.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected bool MouseWheel(
    PointF point,
    int delta
)
Protected Function MouseWheel (
    point As PointF,
    delta As Integer
) As Boolean
protected:
bool MouseWheel(
    PointF point,
    int delta
)
member MouseWheel :
        point : PointF *
        delta : int -> bool

Parameters

point
Type: System.DrawingPointF
Current cursor position.Текущее положение курсора.
delta
Type: SystemInt32
Mouse wheel value.Значение прокрутки колеса мыши.

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.PageStatusManager Method

WorksheetPageStatusManager Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected void PageStatusManager(
    bool forced
)
Protected Sub PageStatusManager (
    forced As Boolean
)
protected:
void PageStatusManager(
    bool forced
)
member PageStatusManager :
        forced : bool -> unit

Parameters

forced
Type: SystemBoolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.RefreshContent Method

WorksheetRefreshContent Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RefreshContent()
Public Sub RefreshContent
public:
void RefreshContent()
member RefreshContent : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.RefreshUI Method

WorksheetRefreshUI Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RefreshUI()
Public Sub RefreshUI
public:
virtual void RefreshUI() sealed
abstract RefreshUI : unit -> unit
override RefreshUI : unit -> unit

Implements

IDocumentTRefreshUI
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.RemoveRegions Method

WorksheetRemoveRegions Method

Overload List
 | Name | Description
Public method | RemoveRegions(RegionBase) |
Public method | RemoveRegions(IEnumerableRegionBase) | Removes Regions from the worksheet.Удаление элементов листа.
Public method | RemoveRegions(IEnumerableRegionBase, Boolean) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.RemoveRegions Method (RegionBase)

WorksheetRemoveRegions Method (RegionBase)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveRegions(
    RegionBase regionToRemove
)
Public Sub RemoveRegions (
    regionToRemove As RegionBase
)
public:
void RemoveRegions(
    RegionBase^ regionToRemove
)
member RemoveRegions :
        regionToRemove : RegionBase -> unit

Parameters

regionToRemove
Type: SMath.ControlsRegionBase
See Also

Reference

Worksheet Class
RemoveRegions Overload
SMath.Controls Namespace


Worksheet.RemoveRegions Method (IEnumerable(RegionBase))

WorksheetRemoveRegions Method (IEnumerableRegionBase)

Removes Regions from the worksheet.Удаление элементов листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveRegions(
    IEnumerable<RegionBase> regionsToRemove
)
Public Sub RemoveRegions (
    regionsToRemove As IEnumerable(Of RegionBase)
)
public:
void RemoveRegions(
    IEnumerable<RegionBase^>^ regionsToRemove
)
member RemoveRegions :
        regionsToRemove : IEnumerable<RegionBase> -> unit

Parameters

regionsToRemove
Type: System.Collections.GenericIEnumerableRegionBase
Array of the worksheet Regions to remove.Массив элементов листа для удаления.
See Also

Reference

Worksheet Class
RemoveRegions Overload
SMath.Controls Namespace


Worksheet.RemoveRegions Method (IEnumerable(RegionBase), Boolean)

WorksheetRemoveRegions Method (IEnumerableRegionBase, Boolean)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveRegions(
    IEnumerable<RegionBase> regionsToRemove,
    bool empty
)
Public Sub RemoveRegions (
    regionsToRemove As IEnumerable(Of RegionBase),
    empty As Boolean
)
public:
void RemoveRegions(
    IEnumerable<RegionBase^>^ regionsToRemove,
    bool empty
)
member RemoveRegions :
        regionsToRemove : IEnumerable<RegionBase> *
        empty : bool -> unit

Parameters

regionsToRemove
Type: System.Collections.GenericIEnumerableRegionBase
empty
Type: SystemBoolean
See Also

Reference

Worksheet Class
RemoveRegions Overload
SMath.Controls Namespace


Worksheet.ResetCustomRegionPlugins Method

WorksheetResetCustomRegionPlugins Method

Reset list of Custom Region plug-ins for future usage.Сбросить список Custom Region дополнений для последующего использования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ResetCustomRegionPlugins()
Public Shared Sub ResetCustomRegionPlugins
public:
static void ResetCustomRegionPlugins()
static member ResetCustomRegionPlugins : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ResetRegionDrawingPlugins Method

WorksheetResetRegionDrawingPlugins Method

Reset list of Region Drawing plug-ins for future usage.Сбросить список Region Drawing дополнений для последующего использования.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ResetRegionDrawingPlugins()
Public Shared Sub ResetRegionDrawingPlugins
public:
static void ResetRegionDrawingPlugins()
static member ResetRegionDrawingPlugins : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Resize Method

WorksheetResize Method

Изменение размеров элемента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Resize(
    EventArgs eventg
)
Protected Overridable Sub Resize (
    eventg As EventArgs
)
protected:
virtual void Resize(
    EventArgs^ eventg
)
abstract Resize :
        eventg : EventArgs -> unit
override Resize :
        eventg : EventArgs -> unit

Parameters

eventg
Type: SystemEventArgs
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ResumeLayout Method

WorksheetResumeLayout Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ResumeLayout()
Public Sub ResumeLayout
public:
void ResumeLayout()
member ResumeLayout : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Scroll Method

WorksheetScroll Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void Scroll(
    ScrollBehavior behavior,
    Rectangle rect
)
Public Overridable Sub Scroll (
    behavior As ScrollBehavior,
    rect As Rectangle
)
public:
virtual void Scroll(
    ScrollBehavior behavior,
    Rectangle rect
)
abstract Scroll :
        behavior : ScrollBehavior *
        rect : Rectangle -> unit
override Scroll :
        behavior : ScrollBehavior *
        rect : Rectangle -> unit

Parameters

behavior
Type: SMath.ControlsScrollBehavior
rect
Type: System.DrawingRectangle
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ScrollToContent Method

WorksheetScrollToContent Method

Overload List
 | Name | Description
Public method | ScrollToContent(RegionBase, Boolean) | Scrolls Worksheet to specified Region. Expands collapsed Areas if required.
Public method | ScrollToContent(RegionBase, RectangleF, Boolean) |
Public method | ScrollToContent(RegionEvaluable, Int32, Boolean) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ScrollToContent Method (RegionBase, Boolean)

WorksheetScrollToContent Method (RegionBase, Boolean)

Scrolls Worksheet to specified Region. Expands collapsed Areas if required.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToContent(
    RegionBase region,
    bool focus
)
Public Sub ScrollToContent (
    region As RegionBase,
    focus As Boolean
)
public:
void ScrollToContent(
    RegionBase^ region,
    bool focus
)
member ScrollToContent :
        region : RegionBase *
        focus : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
Region to display.
focus
Type: SystemBoolean
Determines if a Region should be Focused immediately after it is displayed or not.
See Also

Reference

Worksheet Class
ScrollToContent Overload
SMath.Controls Namespace


Worksheet.ScrollToContent Method (RegionBase, RectangleF, Boolean)

WorksheetScrollToContent Method (RegionBase, RectangleF, Boolean)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToContent(
    RegionBase region,
    RectangleF bounds,
    bool focus
)
Public Sub ScrollToContent (
    region As RegionBase,
    bounds As RectangleF,
    focus As Boolean
)
public:
void ScrollToContent(
    RegionBase^ region,
    RectangleF bounds,
    bool focus
)
member ScrollToContent :
        region : RegionBase *
        bounds : RectangleF *
        focus : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
bounds
Type: System.DrawingRectangleF
focus
Type: SystemBoolean
See Also

Reference

Worksheet Class
ScrollToContent Overload
SMath.Controls Namespace


Worksheet.ScrollToContent Method (RegionEvaluable, Int32, Boolean)

WorksheetScrollToContent Method (RegionEvaluable, Int32, Boolean)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToContent(
    RegionEvaluable region,
    int index,
    bool focus
)
Public Sub ScrollToContent (
    region As RegionEvaluable,
    index As Integer,
    focus As Boolean
)
public:
void ScrollToContent(
    RegionEvaluable^ region,
    int index,
    bool focus
)
member ScrollToContent :
        region : RegionEvaluable *
        index : int *
        focus : bool -> unit

Parameters

region
Type: SMath.ControlsRegionEvaluable
index
Type: SystemInt32
focus
Type: SystemBoolean
See Also

Reference

Worksheet Class
ScrollToContent Overload
SMath.Controls Namespace


Worksheet.ScrollToRegion Method

WorksheetScrollToRegion Method

Overload List
 | Name | Description
Public method | ScrollToRegion(RegionBase, Boolean) | Scrolls Worksheet to show specific Region.
Public method | ScrollToRegion(RegionBase, RectangleF) |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ScrollToRegion Method (RegionBase, Boolean)

WorksheetScrollToRegion Method (RegionBase, Boolean)

Scrolls Worksheet to show specific Region.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToRegion(
    RegionBase region,
    bool full
)
Public Sub ScrollToRegion (
    region As RegionBase,
    full As Boolean
)
public:
void ScrollToRegion(
    RegionBase^ region,
    bool full
)
member ScrollToRegion :
        region : RegionBase *
        full : bool -> unit

Parameters

region
Type: SMath.ControlsRegionBase
Region to scroll to.
full
Type: SystemBoolean
Determines if the whole region to be shown.
See Also

Reference

Worksheet Class
ScrollToRegion Overload
SMath.Controls Namespace


Worksheet.ScrollToRegion Method (RegionBase, RectangleF)

WorksheetScrollToRegion Method (RegionBase, RectangleF)

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ScrollToRegion(
    RegionBase region,
    RectangleF bounds
)
Public Sub ScrollToRegion (
    region As RegionBase,
    bounds As RectangleF
)
public:
void ScrollToRegion(
    RegionBase^ region,
    RectangleF bounds
)
member ScrollToRegion :
        region : RegionBase *
        bounds : RectangleF -> unit

Parameters

region
Type: SMath.ControlsRegionBase
bounds
Type: System.DrawingRectangleF
See Also

Reference

Worksheet Class
ScrollToRegion Overload
SMath.Controls Namespace


Worksheet.SelectRegions Method

WorksheetSelectRegions Method

Работает со свойством выделения элементов. Назначение меняется, в зависимости от полученного аргумента.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SelectRegions(
    SelectionType value
)
Public Sub SelectRegions (
    value As SelectionType
)
public:
void SelectRegions(
    SelectionType value
)
member SelectRegions :
        value : SelectionType -> unit

Parameters

value
Type: SMath.ControlsSelectionType
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetDebuggerMode Method

WorksheetSetDebuggerMode Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetDebuggerMode(
    DebuggerMode mode
)
Public Sub SetDebuggerMode (
    mode As DebuggerMode
)
public:
void SetDebuggerMode(
    DebuggerMode mode
)
member SetDebuggerMode :
        mode : DebuggerMode -> unit

Parameters

mode
Type: SMath.ControlsDebuggerMode
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetRegionBorder Method

WorksheetSetRegionBorder Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SetRegionBorder()
Public Function SetRegionBorder As Boolean
public:
bool SetRegionBorder()
member SetRegionBorder : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetRegionColor Method

WorksheetSetRegionColor Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetRegionColor(
    Color color,
    int inc
)
Public Sub SetRegionColor (
    color As Color,
    inc As Integer
)
public:
void SetRegionColor(
    Color color,
    int inc
)
member SetRegionColor :
        color : Color *
        inc : int -> unit

Parameters

color
Type: System.DrawingColor
inc
Type: SystemInt32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetRegionCurrentTextLang Method

WorksheetSetRegionCurrentTextLang Method

Updates all translatable Regions to set language according to global application settings.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetRegionCurrentTextLang()
Public Sub SetRegionCurrentTextLang
public:
void SetRegionCurrentTextLang()
member SetRegionCurrentTextLang : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetRegionFontFamily Method

WorksheetSetRegionFontFamily Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetRegionFontFamily(
    string family
)
Public Sub SetRegionFontFamily (
    family As String
)
public:
void SetRegionFontFamily(
    String^ family
)
member SetRegionFontFamily :
        family : string -> unit

Parameters

family
Type: SystemString
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SetRegionFontSize Method

WorksheetSetRegionFontSize Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetRegionFontSize(
    int inc
)
Public Sub SetRegionFontSize (
    inc As Integer
)
public:
void SetRegionFontSize(
    int inc
)
member SetRegionFontSize :
        inc : int -> unit

Parameters

inc
Type: SystemInt32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ShowCursorIfRequired Method

WorksheetShowCursorIfRequired Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void ShowCursorIfRequired(
    bool force
)
Public Overridable Sub ShowCursorIfRequired (
    force As Boolean
)
public:
virtual void ShowCursorIfRequired(
    bool force
)
abstract ShowCursorIfRequired :
        force : bool -> unit
override ShowCursorIfRequired :
        force : bool -> unit

Parameters

force
Type: SystemBoolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.ShowError Method

WorksheetShowError Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void ShowError(
    RegionEvaluable region,
    bool v
)
Public MustOverride Sub ShowError (
    region As RegionEvaluable,
    v As Boolean
)
public:
virtual void ShowError(
    RegionEvaluable^ region,
    bool v
) abstract
abstract ShowError :
        region : RegionEvaluable *
        v : bool -> unit

Parameters

region
Type: SMath.ControlsRegionEvaluable
v
Type: SystemBoolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SnapToGrid Method

WorksheetSnapToGrid Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected int SnapToGrid(
    int value
)
Protected Function SnapToGrid (
    value As Integer
) As Integer
protected:
int SnapToGrid(
    int value
)
member SnapToGrid :
        value : int -> int

Parameters

value
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SortRegions Method

WorksheetSortRegions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SortRegions()
Public Sub SortRegions
public:
void SortRegions()
member SortRegions : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.StartEvaluation Method

WorksheetStartEvaluation Method

Performs evaluation of the worksheet.Начинает пересчёт данных листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void StartEvaluation(
    int startIndex = 0,
    int endIndex = 2147483647,
    bool withTests = true,
    bool withDebug = false
)
Public Sub StartEvaluation (
    Optional startIndex As Integer = 0,
    Optional endIndex As Integer = 2147483647,
    Optional withTests As Boolean = true,
    Optional withDebug As Boolean = false
)
public:
void StartEvaluation(
    int startIndex = 0,
    int endIndex = 2147483647,
    bool withTests = true,
    bool withDebug = false
)
member StartEvaluation :
        ?startIndex : int *
        ?endIndex : int *
        ?withTests : bool *
        ?withDebug : bool
(* Defaults:
        let _startIndex = defaultArg startIndex 0
        let _endIndex = defaultArg endIndex 2147483647
        let _withTests = defaultArg withTests true
        let _withDebug = defaultArg withDebug false
*)
-> unit

Parameters

startIndex (Optional)
Type: SystemInt32
Start index of the Region to proceed evaluation for.Стартовый индекс региона, с которого будет начат пересчёт.
endIndex (Optional)
Type: SystemInt32
End index of the Region to proceed evaluation for.Конечный индекс региона, после которого пересчёт будет завершён.
withTests (Optional)
Type: SystemBoolean
Includes evaluation of the depended Regions below (applicable if endIndex doesn't include last Region).Определяет должны ли вычисляться ниже лежащие элементы листа, зависимые от вычисляемых в данный момент (имеет смысл, если последний элемент листа не включён в пересчёт).
withDebug (Optional)
Type: SystemBoolean
Starts evaluation and breaks execution on first possible operation.Начать пересчёт и остановиться на первой же подходящей инструкции.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.StartEvaluationAndWait Method

WorksheetStartEvaluationAndWait Method

Performs evaluation of the worksheet within a limited time.Начинает пересчёт данных листа за ограниченное время.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool StartEvaluationAndWait(
    int startIndex = 0,
    int endIndex = 2147483647,
    bool withTests = true,
    int maxTimeMs = 3000,
    int sleepTimeMs = 10,
    bool withDebug = false
)
Public Function StartEvaluationAndWait (
    Optional startIndex As Integer = 0,
    Optional endIndex As Integer = 2147483647,
    Optional withTests As Boolean = true,
    Optional maxTimeMs As Integer = 3000,
    Optional sleepTimeMs As Integer = 10,
    Optional withDebug As Boolean = false
) As Boolean
public:
bool StartEvaluationAndWait(
    int startIndex = 0,
    int endIndex = 2147483647,
    bool withTests = true,
    int maxTimeMs = 3000,
    int sleepTimeMs = 10,
    bool withDebug = false
)
member StartEvaluationAndWait :
        ?startIndex : int *
        ?endIndex : int *
        ?withTests : bool *
        ?maxTimeMs : int *
        ?sleepTimeMs : int *
        ?withDebug : bool
(* Defaults:
        let _startIndex = defaultArg startIndex 0
        let _endIndex = defaultArg endIndex 2147483647
        let _withTests = defaultArg withTests true
        let _maxTimeMs = defaultArg maxTimeMs 3000
        let _sleepTimeMs = defaultArg sleepTimeMs 10
        let _withDebug = defaultArg withDebug false
*)
-> bool

Parameters

startIndex (Optional)
Type: SystemInt32
Start index of the Region to proceed evaluation for.Стартовый индекс региона, с которого будет начат пересчёт.
endIndex (Optional)
Type: SystemInt32
End index of the Region to proceed evaluation for.Конечный индекс региона, после которого пересчёт будет завершён.
withTests (Optional)
Type: SystemBoolean
Includes evaluation of the depended Regions below (applicable if endIndex doesn't include last Region).Определяет должны ли вычисляться ниже лежащие элементы листа, зависимые от вычисляемых в данный момент (имеет смысл, если последний элемент листа не включён в пересчёт).
maxTimeMs (Optional)
Type: SystemInt32
Maximum time reserved for evaluation in milliseconds.Максимально допустимое время выполнения пересчёта в миллисекундах.
sleepTimeMs (Optional)
Type: SystemInt32
Sleep time for current thread to wait for evaluation finish in milliseconds.Время ожидания окончания вычислений текущим потоком в миллисекундах.
withDebug (Optional)
Type: SystemBoolean
Starts evaluation and breaks execution on first possible operation.Начать пересчёт и остановиться на первой же подходящей инструкции.

Return Value

Type: Boolean
Returns true if evaluation completed successfully.Возвращает истину, если пересчёт успешно завершён.
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.SuppressLayout Method

WorksheetSuppressLayout Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SuppressLayout()
Public Sub SuppressLayout
public:
void SuppressLayout()
member SuppressLayout : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.Test Method

WorksheetTest Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool Test(
    Worksheet target,
    string file,
    int maxEvaluationTime,
    out string msg
)
Public Shared Function Test (
    target As Worksheet,
    file As String,
    maxEvaluationTime As Integer,
    <OutAttribute> ByRef msg As String
) As Boolean
public:
static bool Test(
    Worksheet^ target,
    String^ file,
    int maxEvaluationTime,
    [OutAttribute] String^% msg
)
static member Test :
        target : Worksheet *
        file : string *
        maxEvaluationTime : int *
        msg : string byref -> bool

Parameters

target
Type: SMath.ControlsWorksheet
file
Type: SystemString
maxEvaluationTime
Type: SystemInt32
msg
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.TryAbortEvaluation Method

WorksheetTryAbortEvaluation Method

Abort worksheet recalculation.Прерывает пересчёт листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TryAbortEvaluation()
Public Function TryAbortEvaluation As Boolean
public:
bool TryAbortEvaluation()
member TryAbortEvaluation : unit -> bool

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.TryGetRegionByTagName Method

WorksheetTryGetRegionByTagName Method

Enumerates all the available custom region plug-ins in order to find one with specified tag name. Creates a new Region after plug-in is found.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryGetRegionByTagName(
    SessionProfile sessionProfile,
    string tagName,
    out RegionBase region
)
Public Shared Function TryGetRegionByTagName (
    sessionProfile As SessionProfile,
    tagName As String,
    <OutAttribute> ByRef region As RegionBase
) As Boolean
public:
static bool TryGetRegionByTagName(
    SessionProfile^ sessionProfile,
    String^ tagName,
    [OutAttribute] RegionBase^% region
)
static member TryGetRegionByTagName :
        sessionProfile : SessionProfile *
        tagName : string *
        region : RegionBase byref -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
tagName
Type: SystemString
region
Type: SMath.ControlsRegionBase

Return Value

Type: Boolean
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.UnfocusRegions Method

WorksheetUnfocusRegions Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UnfocusRegions(
    RegionBase except = null
)
Public Sub UnfocusRegions (
    Optional except As RegionBase = Nothing
)
public:
void UnfocusRegions(
    RegionBase^ except = nullptr
)
member UnfocusRegions :
        ?except : RegionBase
(* Defaults:
        let _except = defaultArg except null
*)
-> unit

Parameters

except (Optional)
Type: SMath.ControlsRegionBase
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.UnlockRegion Method

WorksheetUnlockRegion Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UnlockRegion(
    string password
)
Public Sub UnlockRegion (
    password As String
)
public:
void UnlockRegion(
    String^ password
)
member UnlockRegion :
        password : string -> unit

Parameters

password
Type: SystemString
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.UpdatePageModel Method

WorksheetUpdatePageModel Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UpdatePageModel(
    PageModelViewMode mode
)
Public Sub UpdatePageModel (
    mode As PageModelViewMode
)
public:
void UpdatePageModel(
    PageModelViewMode mode
)
member UpdatePageModel :
        mode : PageModelViewMode -> unit

Parameters

mode
Type: SMath.ManagerPageModelViewMode
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.UpdateScrollBars Method

WorksheetUpdateScrollBars Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void UpdateScrollBars()
Public Overridable Sub UpdateScrollBars
public:
virtual void UpdateScrollBars()
abstract UpdateScrollBars : unit -> unit
override UpdateScrollBars : unit -> unit

Implements

IDocumentTUpdateScrollBars
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.VerifyLanguageNotifier Method

WorksheetVerifyLanguageNotifier Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public virtual void VerifyLanguageNotifier()
Public Overridable Sub VerifyLanguageNotifier
public:
virtual void VerifyLanguageNotifier()
abstract VerifyLanguageNotifier : unit -> unit
override VerifyLanguageNotifier : unit -> unit
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet Events

The Worksheet type exposes the following members.

Events
 | Name | Description
Public event | OnBeforeWorksheetUnoad |
Public event | OnCurrentRegionChanged |
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки.
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки.
Public event | OnFileContextLoad |
Public event | OnMenuButtonEmulated |
Public event | OnPasswordRequest | Requests password.Запрос на получение пароля.
Public event | OnProgressChanged |
Public event | OnRegionCreated |
Public event | OnStatusChanged |
Public event | WorksheetStatusChanged | Worksheet status change.Изменение статуса листа.
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnBeforeWorksheetUnoad Event

WorksheetOnBeforeWorksheetUnoad Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event WorksheetCancelEventHandler OnBeforeWorksheetUnoad
Public Event OnBeforeWorksheetUnoad As WorksheetCancelEventHandler
public:
 event WorksheetCancelEventHandler^ OnBeforeWorksheetUnoad {
    void add (WorksheetCancelEventHandler^ value);
    void remove (WorksheetCancelEventHandler^ value);
}
member OnBeforeWorksheetUnoad : IEvent<WorksheetCancelEventHandler,
    EventArgs>

Value

Type: SMath.ControlsWorksheetCancelEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnCurrentRegionChanged Event

WorksheetOnCurrentRegionChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler OnCurrentRegionChanged
Public Event OnCurrentRegionChanged As RegionEventHandler
public:
 event RegionEventHandler^ OnCurrentRegionChanged {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member OnCurrentRegionChanged : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnDataTrace Event

WorksheetOnDataTrace Event

Occurs on data sent to trace.Вызывается при посылке данных трассировки.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event TraceEvaluationData OnDataTrace
Public Event OnDataTrace As TraceEvaluationData
public:
 event TraceEvaluationData^ OnDataTrace {
    void add (TraceEvaluationData^ value);
    void remove (TraceEvaluationData^ value);
}
member OnDataTrace : IEvent<TraceEvaluationData,
    EventArgs>

Value

Type: SMath.MathTraceEvaluationData
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnDebugStart Event

WorksheetOnDebugStart Event

Occurs on debug session started.Вызывается при начале сессии отладки.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event DebugOccuredEventHandler OnDebugStart
Public Event OnDebugStart As DebugOccuredEventHandler
public:
 event DebugOccuredEventHandler^ OnDebugStart {
    void add (DebugOccuredEventHandler^ value);
    void remove (DebugOccuredEventHandler^ value);
}
member OnDebugStart : IEvent<DebugOccuredEventHandler,
    EventArgs>

Value

Type: SMath.MathDebugOccuredEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnFileContextLoad Event

WorksheetOnFileContextLoad Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event WorksheetFileContextLoadDelegate OnFileContextLoad
Public Event OnFileContextLoad As WorksheetFileContextLoadDelegate
public:
 event WorksheetFileContextLoadDelegate^ OnFileContextLoad {
    void add (WorksheetFileContextLoadDelegate^ value);
    void remove (WorksheetFileContextLoadDelegate^ value);
}
member OnFileContextLoad : IEvent<WorksheetFileContextLoadDelegate,
    EventArgs>

Value

Type: SMath.ControlsWorksheetFileContextLoadDelegate
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnMenuButtonEmulated Event

WorksheetOnMenuButtonEmulated Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event StatusEventHandler OnMenuButtonEmulated
Public Event OnMenuButtonEmulated As StatusEventHandler
public:
 event StatusEventHandler^ OnMenuButtonEmulated {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}
member OnMenuButtonEmulated : IEvent<StatusEventHandler,
    EventArgs>

Value

Type: SMath.ControlsStatusEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnPasswordRequest Event

WorksheetOnPasswordRequest Event

Requests password.Запрос на получение пароля.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event PasswordRequestEventHandler OnPasswordRequest
Public Event OnPasswordRequest As PasswordRequestEventHandler
public:
 event PasswordRequestEventHandler^ OnPasswordRequest {
    void add (PasswordRequestEventHandler^ value);
    void remove (PasswordRequestEventHandler^ value);
}
member OnPasswordRequest : IEvent<PasswordRequestEventHandler,
    EventArgs>

Value

Type: SMath.ControlsPasswordRequestEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnProgressChanged Event

WorksheetOnProgressChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ProgressEventHandler OnProgressChanged
Public Event OnProgressChanged As ProgressEventHandler
public:
 event ProgressEventHandler^ OnProgressChanged {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}
member OnProgressChanged : IEvent<ProgressEventHandler,
    EventArgs>

Value

Type: SMath.ControlsProgressEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnRegionCreated Event

WorksheetOnRegionCreated Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEventHandler OnRegionCreated
Public Event OnRegionCreated As RegionEventHandler
public:
 event RegionEventHandler^ OnRegionCreated {
    void add (RegionEventHandler^ value);
    void remove (RegionEventHandler^ value);
}
member OnRegionCreated : IEvent<RegionEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.OnStatusChanged Event

WorksheetOnStatusChanged Event

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event StatusEventHandler OnStatusChanged
Public Event OnStatusChanged As StatusEventHandler
public:
 event StatusEventHandler^ OnStatusChanged {
    void add (StatusEventHandler^ value);
    void remove (StatusEventHandler^ value);
}
member OnStatusChanged : IEvent<StatusEventHandler,
    EventArgs>

Value

Type: SMath.ControlsStatusEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.WorksheetStatusChanged Event

WorksheetWorksheetStatusChanged Event

Worksheet status change.Изменение статуса листа.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event WorksheetStatusChangedEventHandler WorksheetStatusChanged
Public Event WorksheetStatusChanged As WorksheetStatusChangedEventHandler
public:
 event WorksheetStatusChangedEventHandler^ WorksheetStatusChanged {
    void add (WorksheetStatusChangedEventHandler^ value);
    void remove (WorksheetStatusChangedEventHandler^ value);
}
member WorksheetStatusChanged : IEvent<WorksheetStatusChangedEventHandler,
    EventArgs>

Value

Type: SMath.ControlsWorksheetStatusChangedEventHandler
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet Fields

The Worksheet type exposes the following members.

Fields
Name | Description
regionDrawingPlugins |
Top
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.regionDrawingPlugins Field

WorksheetregionDrawingPlugins Field

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<PluginInfo> regionDrawingPlugins
Public Shared regionDrawingPlugins As List(Of PluginInfo)
public:
static List<PluginInfo^>^ regionDrawingPlugins
static val mutable regionDrawingPlugins: List<PluginInfo>

Field Value

Type: ListPluginInfo
See Also

Reference

Worksheet Class
SMath.Controls Namespace


Worksheet.FileContextLoadDelegate Delegate

WorksheetFileContextLoadDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void FileContextLoadDelegate(
    string fileName,
    out FileContext fileContext
)
Public Delegate Sub FileContextLoadDelegate (
    fileName As String,
    <OutAttribute> ByRef fileContext As FileContext
)
public delegate void FileContextLoadDelegate(
    String^ fileName,
    [OutAttribute] FileContext^% fileContext
)
type FileContextLoadDelegate =
    delegate of
        fileName : string *
        fileContext : FileContext byref -> unit

Parameters

fileName
Type: SystemString
fileContext
Type: SMath.ControlsFileContext
See Also

Reference

SMath.Controls Namespace


WorksheetCancelEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void WorksheetCancelEventHandler(
    Worksheet sender,
    out bool cancel
)
Public Delegate Sub WorksheetCancelEventHandler (
    sender As Worksheet,
    <OutAttribute> ByRef cancel As Boolean
)
public delegate void WorksheetCancelEventHandler(
    Worksheet^ sender,
    [OutAttribute] bool% cancel
)
type WorksheetCancelEventHandler =
    delegate of
        sender : Worksheet *
        cancel : bool byref -> unit

Parameters

sender
Type: SMath.ControlsWorksheet
cancel
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


WorksheetEditor Class

Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheetEditor

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class WorksheetEditor
Public Class WorksheetEditor
public ref class WorksheetEditor
type WorksheetEditor =  class end

The WorksheetEditor type exposes the following members.

Constructors
 | Name | Description
Public method | WorksheetEditor | Initializes a new instance of the WorksheetEditor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | HandlePreprocessingAction |
Public method | InsertManager |
Public method | InsertSnippet | Inserts snippet to the worksheet.Вставляет заготовку в лист расчётов.
Public method | IsInputKey |
Public method | KeyDown |
Public method | KeyPress |
Public method | KeyUp |
Public method | LinkOpener |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


WorksheetEditor Constructor

Initializes a new instance of the WorksheetEditor class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetEditor(
    Worksheet worksheet
)
Public Sub New (
    worksheet As Worksheet
)
public:
WorksheetEditor(
    Worksheet^ worksheet
)
new :
        worksheet : Worksheet -> WorksheetEditor

Parameters

worksheet
Type: SMath.ControlsWorksheet
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor Methods

The WorksheetEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | HandlePreprocessingAction |
Public method | InsertManager |
Public method | InsertSnippet | Inserts snippet to the worksheet.Вставляет заготовку в лист расчётов.
Public method | IsInputKey |
Public method | KeyDown |
Public method | KeyPress |
Public method | KeyUp |
Public method | LinkOpener |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.HandlePreprocessingAction Method

WorksheetEditorHandlePreprocessingAction Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void HandlePreprocessingAction(
    RegionBase initRegion,
    string value
)
Public Sub HandlePreprocessingAction (
    initRegion As RegionBase,
    value As String
)
public:
void HandlePreprocessingAction(
    RegionBase^ initRegion,
    String^ value
)
member HandlePreprocessingAction :
        initRegion : RegionBase *
        value : string -> unit

Parameters

initRegion
Type: SMath.ControlsRegionBase
value
Type: SystemString
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.InsertManager Method

WorksheetEditorInsertManager Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void InsertManager(
    string value
)
Public Sub InsertManager (
    value As String
)
public:
void InsertManager(
    String^ value
)
member InsertManager :
        value : string -> unit

Parameters

value
Type: SystemString
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.InsertSnippet Method

WorksheetEditorInsertSnippet Method

Inserts snippet to the worksheet.Вставляет заготовку в лист расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void InsertSnippet(
    string fileName,
    bool insideArea
)
Public Sub InsertSnippet (
    fileName As String,
    insideArea As Boolean
)
public:
void InsertSnippet(
    String^ fileName,
    bool insideArea
)
member InsertSnippet :
        fileName : string *
        insideArea : bool -> unit

Parameters

fileName
Type: SystemString
Full path to the snippet file.Полный путь к файлу заготовки.
insideArea
Type: SystemBoolean
Defines if the snippet will be inserted into the Area Region.Определяет будет ли заготовка вставлена внутри Области.
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.IsInputKey Method

WorksheetEditorIsInputKey Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsInputKey(
    InputKeys keyData
)
Public Function IsInputKey (
    keyData As InputKeys
) As Boolean
public:
bool IsInputKey(
    InputKeys keyData
)
member IsInputKey :
        keyData : InputKeys -> bool

Parameters

keyData
Type: SMath.ManagerInputKeys

Return Value

Type: Boolean
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.KeyDown Method

WorksheetEditorKeyDown Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void KeyDown(
    KeyEventOptions e
)
Public Sub KeyDown (
    e As KeyEventOptions
)
public:
void KeyDown(
    KeyEventOptions^ e
)
member KeyDown :
        e : KeyEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyEventOptions
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.KeyPress Method

WorksheetEditorKeyPress Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void KeyPress(
    KeyPressEventOptions e
)
Public Sub KeyPress (
    e As KeyPressEventOptions
)
public:
void KeyPress(
    KeyPressEventOptions^ e
)
member KeyPress :
        e : KeyPressEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyPressEventOptions
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.KeyUp Method

WorksheetEditorKeyUp Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void KeyUp(
    KeyEventOptions e
)
Public Sub KeyUp (
    e As KeyEventOptions
)
public:
void KeyUp(
    KeyEventOptions^ e
)
member KeyUp :
        e : KeyEventOptions -> unit

Parameters

e
Type: SMath.ManagerKeyEventOptions
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetEditor.LinkOpener Method

WorksheetEditorLinkOpener Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool LinkOpener(
    string fileName
)
Public Function LinkOpener (
    fileName As String
) As Boolean
public:
bool LinkOpener(
    String^ fileName
)
member LinkOpener :
        fileName : string -> bool

Parameters

fileName
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

WorksheetEditor Class
SMath.Controls Namespace


WorksheetGraphicsEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void WorksheetGraphicsEventHandler(
    Worksheet sender,
    out IGraphics g,
    IBitmap bmp
)
Public Delegate Sub WorksheetGraphicsEventHandler (
    sender As Worksheet,
    <OutAttribute> ByRef g As IGraphics,
    bmp As IBitmap
)
public delegate void WorksheetGraphicsEventHandler(
    Worksheet^ sender,
    [OutAttribute] IGraphics^% g,
    IBitmap^ bmp
)
type WorksheetGraphicsEventHandler =
    delegate of
        sender : Worksheet *
        g : IGraphics byref *
        bmp : IBitmap -> unit

Parameters

sender
Type: SMath.ControlsWorksheet
g
Type: SMath.DrawingIGraphics
bmp
Type: SMath.DrawingIBitmap
See Also

Reference

SMath.Controls Namespace


WorksheetInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentMetaData
SMath.ControlsWorksheetInfo

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class WorksheetInfo : DocumentMetaData
Public Class WorksheetInfo
    Inherits DocumentMetaData
public ref class WorksheetInfo : public DocumentMetaData
type WorksheetInfo =
    class
        inherit DocumentMetaData
    end

The WorksheetInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WorksheetInfo(String) | Initializes a new instance of the WorksheetInfo class
Public method | WorksheetInfo(WorksheetInfo) | Initializes a new instance of the WorksheetInfo class
Public method | WorksheetInfo(String, String, String, String, String, String, String) | Initializes a new instance of the WorksheetInfo class
Top
Properties
 | Name | Description
Public property | Author | (Inherited from DocumentMetaData.)
Public property | Company | (Inherited from DocumentMetaData.)
Public property | Description | (Inherited from DocumentMetaData.)
Public property | Keywords | (Inherited from DocumentMetaData.)
Public property | LanguageAbbr |
Public property | Title | (Inherited from DocumentMetaData.)
Public property | Translator | (Inherited from DocumentMetaData.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


WorksheetInfo Constructor

Overload List
 | Name | Description
Public method | WorksheetInfo(String) | Initializes a new instance of the WorksheetInfo class
Public method | WorksheetInfo(WorksheetInfo) | Initializes a new instance of the WorksheetInfo class
Public method | WorksheetInfo(String, String, String, String, String, String, String) | Initializes a new instance of the WorksheetInfo class
Top
See Also

Reference

WorksheetInfo Class
SMath.Controls Namespace


WorksheetInfo Constructor (String)

Initializes a new instance of the WorksheetInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetInfo(
    string languageAbbr
)
Public Sub New (
    languageAbbr As String
)
public:
WorksheetInfo(
    String^ languageAbbr
)
new :
        languageAbbr : string -> WorksheetInfo

Parameters

languageAbbr
Type: SystemString
See Also

Reference

WorksheetInfo Class
WorksheetInfo Overload
SMath.Controls Namespace


WorksheetInfo Constructor (WorksheetInfo)

Initializes a new instance of the WorksheetInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetInfo(
    WorksheetInfo value
)
Public Sub New (
    value As WorksheetInfo
)
public:
WorksheetInfo(
    WorksheetInfo^ value
)
new :
        value : WorksheetInfo -> WorksheetInfo

Parameters

value
Type: SMath.ControlsWorksheetInfo
See Also

Reference

WorksheetInfo Class
WorksheetInfo Overload
SMath.Controls Namespace


WorksheetInfo Constructor (String, String, String, String, String, String, String)

Initializes a new instance of the WorksheetInfo class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetInfo(
    string languageAbbr,
    string title,
    string author,
    string translator,
    string description,
    string company,
    string keywords
)
Public Sub New (
    languageAbbr As String,
    title As String,
    author As String,
    translator As String,
    description As String,
    company As String,
    keywords As String
)
public:
WorksheetInfo(
    String^ languageAbbr,
    String^ title,
    String^ author,
    String^ translator,
    String^ description,
    String^ company,
    String^ keywords
)
new :
        languageAbbr : string *
        title : string *
        author : string *
        translator : string *
        description : string *
        company : string *
        keywords : string -> WorksheetInfo

Parameters

languageAbbr
Type: SystemString
title
Type: SystemString
author
Type: SystemString
translator
Type: SystemString
description
Type: SystemString
company
Type: SystemString
keywords
Type: SystemString
See Also

Reference

WorksheetInfo Class
WorksheetInfo Overload
SMath.Controls Namespace


WorksheetInfo Properties

The WorksheetInfo type exposes the following members.

Properties
 | Name | Description
Public property | Author | (Inherited from DocumentMetaData.)
Public property | Company | (Inherited from DocumentMetaData.)
Public property | Description | (Inherited from DocumentMetaData.)
Public property | Keywords | (Inherited from DocumentMetaData.)
Public property | LanguageAbbr |
Public property | Title | (Inherited from DocumentMetaData.)
Public property | Translator | (Inherited from DocumentMetaData.)
Top
See Also

Reference

WorksheetInfo Class
SMath.Controls Namespace


WorksheetInfo.LanguageAbbr Property

WorksheetInfoLanguageAbbr Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string LanguageAbbr { get; set; }
Public Property LanguageAbbr As String
    Get
    Set
public:
property String^ LanguageAbbr {
    String^ get ();
    void set (String^ value);
}
member LanguageAbbr : string with get, set

Property Value

Type: String
See Also

Reference

WorksheetInfo Class
SMath.Controls Namespace


WorksheetInfo Methods

The WorksheetInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorksheetInfo Class
SMath.Controls Namespace


WorksheetParams Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ControlsWorksheetParams

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class WorksheetParams : DocumentParams
Public Class WorksheetParams
    Inherits DocumentParams
public ref class WorksheetParams : public DocumentParams
type WorksheetParams =
    class
        inherit DocumentParams
    end

The WorksheetParams type exposes the following members.

Constructors
 | Name | Description
Public method | WorksheetParams | Initializes a new instance of the WorksheetParams class
Top
Properties
 | Name | Description
Public property | AutoEvaluation | Defines if automatic evaluation enabled for the Worksheet.Определяет включён ли автоматический пересчёт листа при изменениях.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | GeneratorVersion | Version of the generator application.Версия приложения, создавшего файл.
Public property | Id | (Inherited from DocumentParams.)
Public property | OnError | Defines what automatic action is enabled on calculation error for the Worksheet.Определяет автоматическое действие при обнаружении ошибки в расчёте.
Public property | OutputUnitsSystem | Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.
Public property | Revision | (Inherited from DocumentParams.)
Public property | Shortcut | Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Public property | Title | Title of the worksheet.Заголовок листа расчётов.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


WorksheetParams Constructor

Initializes a new instance of the WorksheetParams class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetParams()
Public Sub New
public:
WorksheetParams()
new : unit -> WorksheetParams
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams Properties

The WorksheetParams type exposes the following members.

Properties
 | Name | Description
Public property | AutoEvaluation | Defines if automatic evaluation enabled for the Worksheet.Определяет включён ли автоматический пересчёт листа при изменениях.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | GeneratorVersion | Version of the generator application.Версия приложения, создавшего файл.
Public property | Id | (Inherited from DocumentParams.)
Public property | OnError | Defines what automatic action is enabled on calculation error for the Worksheet.Определяет автоматическое действие при обнаружении ошибки в расчёте.
Public property | OutputUnitsSystem | Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.
Public property | Revision | (Inherited from DocumentParams.)
Public property | Shortcut | Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Public property | Title | Title of the worksheet.Заголовок листа расчётов.
Top
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.AutoEvaluation Property

WorksheetParamsAutoEvaluation Property

Defines if automatic evaluation enabled for the Worksheet.Определяет включён ли автоматический пересчёт листа при изменениях.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool AutoEvaluation { get; set; }
Public Property AutoEvaluation As Boolean
    Get
    Set
public:
property bool AutoEvaluation {
    bool get ();
    void set (bool value);
}
member AutoEvaluation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.GeneratorVersion Property

WorksheetParamsGeneratorVersion Property

Version of the generator application.Версия приложения, создавшего файл.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Version GeneratorVersion { get; set; }
Public Property GeneratorVersion As Version
    Get
    Set
public:
property Version^ GeneratorVersion {
    Version^ get ();
    void set (Version^ value);
}
member GeneratorVersion : Version with get, set

Property Value

Type: Version
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.OnError Property

WorksheetParamsOnError Property

Defines what automatic action is enabled on calculation error for the Worksheet.Определяет автоматическое действие при обнаружении ошибки в расчёте.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OnErrorAction OnError { get; set; }
Public Property OnError As OnErrorAction
    Get
    Set
public:
property OnErrorAction OnError {
    OnErrorAction get ();
    void set (OnErrorAction value);
}
member OnError : OnErrorAction with get, set

Property Value

Type: OnErrorAction
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.OutputUnitsSystem Property

WorksheetParamsOutputUnitsSystem Property

Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string OutputUnitsSystem { get; set; }
Public Property OutputUnitsSystem As String
    Get
    Set
public:
property String^ OutputUnitsSystem {
    String^ get ();
    void set (String^ value);
}
member OutputUnitsSystem : string with get, set

Property Value

Type: String
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.Shortcut Property

WorksheetParamsShortcut Property

Gets or sets shortcut of the document to use for snippets.Возвращает или задаёт ярлык на документ при использовании заготовок.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Shortcut { get; set; }
Public Property Shortcut As String
    Get
    Set
public:
property String^ Shortcut {
    String^ get ();
    void set (String^ value);
}
member Shortcut : string with get, set

Property Value

Type: String
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.SuppressUI Property

WorksheetParamsSuppressUI Property

Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SuppressUI { get; set; }
Public Property SuppressUI As Boolean
    Get
    Set
public:
property bool SuppressUI {
    bool get ();
    void set (bool value);
}
member SuppressUI : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams.Title Property

WorksheetParamsTitle Property

Title of the worksheet.Заголовок листа расчётов.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetParams Methods

The WorksheetParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorksheetParams Class
SMath.Controls Namespace


WorksheetSearch Class

Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheetSearch

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class WorksheetSearch
Public Class WorksheetSearch
public ref class WorksheetSearch
type WorksheetSearch =  class end

The WorksheetSearch type exposes the following members.

Constructors
 | Name | Description
Public method | WorksheetSearch | Initializes a new instance of the WorksheetSearch class
Top
Properties
 | Name | Description
Public property | Count |
Public property | CurrentIndex |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsRegionFound |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Previous |
Public method | Refresh |
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


WorksheetSearch Constructor

Initializes a new instance of the WorksheetSearch class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetSearch(
    Worksheet worksheet
)
Public Sub New (
    worksheet As Worksheet
)
public:
WorksheetSearch(
    Worksheet^ worksheet
)
new :
        worksheet : Worksheet -> WorksheetSearch

Parameters

worksheet
Type: SMath.ControlsWorksheet
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch Properties

The WorksheetSearch type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | CurrentIndex |
Top
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Count Property

WorksheetSearchCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.CurrentIndex Property

WorksheetSearchCurrentIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentIndex { get; }
Public ReadOnly Property CurrentIndex As Integer
    Get
public:
property int CurrentIndex {
    int get ();
}
member CurrentIndex : int with get

Property Value

Type: Int32
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch Methods

The WorksheetSearch type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsRegionFound |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next |
Public method | Previous |
Public method | Refresh |
Public method | Start |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Clear Method

WorksheetSearchClear Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.IsRegionFound Method

WorksheetSearchIsRegionFound Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsRegionFound(
    RegionBase region,
    out MatchingContext ctx
)
Public Function IsRegionFound (
    region As RegionBase,
    <OutAttribute> ByRef ctx As MatchingContext
) As Boolean
public:
bool IsRegionFound(
    RegionBase^ region,
    [OutAttribute] MatchingContext^% ctx
)
member IsRegionFound :
        region : RegionBase *
        ctx : MatchingContext byref -> bool

Parameters

region
Type: SMath.ControlsRegionBase
ctx
Type: SMath.ControlsMatchingContext

Return Value

Type: Boolean
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Next Method

WorksheetSearchNext Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Next(
    bool doScroll
)
Public Sub Next (
    doScroll As Boolean
)
public:
void Next(
    bool doScroll
)
member Next :
        doScroll : bool -> unit

Parameters

doScroll
Type: SystemBoolean
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Previous Method

WorksheetSearchPrevious Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Previous()
Public Sub Previous
public:
void Previous()
member Previous : unit -> unit
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Refresh Method

WorksheetSearchRefresh Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSearch.Start Method

WorksheetSearchStart Method

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Start(
    string value,
    GlobalMatchingOptions options
)
Public Sub Start (
    value As String,
    options As GlobalMatchingOptions
)
public:
void Start(
    String^ value,
    GlobalMatchingOptions^ options
)
member Start :
        value : string *
        options : GlobalMatchingOptions -> unit

Parameters

value
Type: SystemString
options
Type: SMath.ControlsGlobalMatchingOptions
See Also

Reference

WorksheetSearch Class
SMath.Controls Namespace


WorksheetSelectionStatus Enumeration

On page selection.Выделение на листе.

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum WorksheetSelectionStatus
Public Enumeration WorksheetSelectionStatus
public enum class WorksheetSelectionStatus
type WorksheetSelectionStatus
Members
Member name | Value | Description
InEdit | 0 | On page Region editing.Редактирование элемента листа.
Selected | 1 | One or more Regions selected.Выделен один или несколько элементов.
None | 2 | No Region selected or in focus.Не выделено ни одного элемента.
See Also

Reference

SMath.Controls Namespace


WorksheetStatus Class

Inheritance Hierarchy
SystemObject
SMath.ControlsWorksheetStatus

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class WorksheetStatus
Public Class WorksheetStatus
public ref class WorksheetStatus
type WorksheetStatus =  class end

The WorksheetStatus type exposes the following members.

Constructors
 | Name | Description
Public method | WorksheetStatus | Initializes a new instance of the WorksheetStatus class
Top
Properties
 | Name | Description
Public property | ClipboardStatus |
Public property | CurrentPageIndex |
Public property | InCtrlSelection |
Public property | IsEdited |
Public property | IsLocked |
Public property | PagesCount |
Public property | PageSelection |
Public property | PageStatus |
Public property | Region |
Public property | UnReDoStatus |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Controls Namespace


WorksheetStatus Constructor

Initializes a new instance of the WorksheetStatus class

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetStatus(
    DocumentStatus pageStatus,
    WorksheetSelectionStatus pageSelection,
    RegionSelectionStatus inCtrlSelection,
    ClipboardStatus clipboardStatus,
    HistoryManagerStepType unReDoStatus,
    bool edited,
    RegionBase regionBase,
    bool locked,
    int currentPageIndex,
    int pagesCount
)
Public Sub New (
    pageStatus As DocumentStatus,
    pageSelection As WorksheetSelectionStatus,
    inCtrlSelection As RegionSelectionStatus,
    clipboardStatus As ClipboardStatus,
    unReDoStatus As HistoryManagerStepType,
    edited As Boolean,
    regionBase As RegionBase,
    locked As Boolean,
    currentPageIndex As Integer,
    pagesCount As Integer
)
public:
WorksheetStatus(
    DocumentStatus pageStatus,
    WorksheetSelectionStatus pageSelection,
    RegionSelectionStatus inCtrlSelection,
    ClipboardStatus clipboardStatus,
    HistoryManagerStepType unReDoStatus,
    bool edited,
    RegionBase^ regionBase,
    bool locked,
    int currentPageIndex,
    int pagesCount
)
new :
        pageStatus : DocumentStatus *
        pageSelection : WorksheetSelectionStatus *
        inCtrlSelection : RegionSelectionStatus *
        clipboardStatus : ClipboardStatus *
        unReDoStatus : HistoryManagerStepType *
        edited : bool *
        regionBase : RegionBase *
        locked : bool *
        currentPageIndex : int *
        pagesCount : int -> WorksheetStatus

Parameters

pageStatus
Type: SMath.ControlsDocumentStatus
pageSelection
Type: SMath.ControlsWorksheetSelectionStatus
inCtrlSelection
Type: SMath.ControlsRegionSelectionStatus
clipboardStatus
Type: SMath.ControlsClipboardStatus
unReDoStatus
Type: SMath.ControlsHistoryManagerStepType
edited
Type: SystemBoolean
regionBase
Type: SMath.ControlsRegionBase
locked
Type: SystemBoolean
currentPageIndex
Type: SystemInt32
pagesCount
Type: SystemInt32
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus Properties

The WorksheetStatus type exposes the following members.

Properties
 | Name | Description
Public property | ClipboardStatus |
Public property | CurrentPageIndex |
Public property | InCtrlSelection |
Public property | IsEdited |
Public property | IsLocked |
Public property | PagesCount |
Public property | PageSelection |
Public property | PageStatus |
Public property | Region |
Public property | UnReDoStatus |
Top
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.ClipboardStatus Property

WorksheetStatusClipboardStatus Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ClipboardStatus ClipboardStatus { get; set; }
Public Property ClipboardStatus As ClipboardStatus
    Get
    Set
public:
property ClipboardStatus ClipboardStatus {
    ClipboardStatus get ();
    void set (ClipboardStatus value);
}
member ClipboardStatus : ClipboardStatus with get, set

Property Value

Type: ClipboardStatus
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.CurrentPageIndex Property

WorksheetStatusCurrentPageIndex Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentPageIndex { get; set; }
Public Property CurrentPageIndex As Integer
    Get
    Set
public:
property int CurrentPageIndex {
    int get ();
    void set (int value);
}
member CurrentPageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.InCtrlSelection Property

WorksheetStatusInCtrlSelection Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionSelectionStatus InCtrlSelection { get; set; }
Public Property InCtrlSelection As RegionSelectionStatus
    Get
    Set
public:
property RegionSelectionStatus InCtrlSelection {
    RegionSelectionStatus get ();
    void set (RegionSelectionStatus value);
}
member InCtrlSelection : RegionSelectionStatus with get, set

Property Value

Type: RegionSelectionStatus
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.IsEdited Property

WorksheetStatusIsEdited Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsEdited { get; set; }
Public Property IsEdited As Boolean
    Get
    Set
public:
property bool IsEdited {
    bool get ();
    void set (bool value);
}
member IsEdited : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.IsLocked Property

WorksheetStatusIsLocked Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsLocked { get; set; }
Public Property IsLocked As Boolean
    Get
    Set
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}
member IsLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.PagesCount Property

WorksheetStatusPagesCount Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; set; }
Public Property PagesCount As Integer
    Get
    Set
public:
property int PagesCount {
    int get ();
    void set (int value);
}
member PagesCount : int with get, set

Property Value

Type: Int32
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.PageSelection Property

WorksheetStatusPageSelection Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public WorksheetSelectionStatus PageSelection { get; set; }
Public Property PageSelection As WorksheetSelectionStatus
    Get
    Set
public:
property WorksheetSelectionStatus PageSelection {
    WorksheetSelectionStatus get ();
    void set (WorksheetSelectionStatus value);
}
member PageSelection : WorksheetSelectionStatus with get, set

Property Value

Type: WorksheetSelectionStatus
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.PageStatus Property

WorksheetStatusPageStatus Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentStatus PageStatus { get; set; }
Public Property PageStatus As DocumentStatus
    Get
    Set
public:
property DocumentStatus PageStatus {
    DocumentStatus get ();
    void set (DocumentStatus value);
}
member PageStatus : DocumentStatus with get, set

Property Value

Type: DocumentStatus
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.Region Property

WorksheetStatusRegion Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RegionBase Region { get; set; }
Public Property Region As RegionBase
    Get
    Set
public:
property RegionBase^ Region {
    RegionBase^ get ();
    void set (RegionBase^ value);
}
member Region : RegionBase with get, set

Property Value

Type: RegionBase
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus.UnReDoStatus Property

WorksheetStatusUnReDoStatus Property

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public HistoryManagerStepType UnReDoStatus { get; set; }
Public Property UnReDoStatus As HistoryManagerStepType
    Get
    Set
public:
property HistoryManagerStepType UnReDoStatus {
    HistoryManagerStepType get ();
    void set (HistoryManagerStepType value);
}
member UnReDoStatus : HistoryManagerStepType with get, set

Property Value

Type: HistoryManagerStepType
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatus Methods

The WorksheetStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorksheetStatus Class
SMath.Controls Namespace


WorksheetStatusChangedEventHandler Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void WorksheetStatusChangedEventHandler(
    Worksheet sender,
    WorksheetStatus status
)
Public Delegate Sub WorksheetStatusChangedEventHandler (
    sender As Worksheet,
    status As WorksheetStatus
)
public delegate void WorksheetStatusChangedEventHandler(
    Worksheet^ sender,
    WorksheetStatus^ status
)
type WorksheetStatusChangedEventHandler =
    delegate of
        sender : Worksheet *
        status : WorksheetStatus -> unit

Parameters

sender
Type: SMath.ControlsWorksheet
status
Type: SMath.ControlsWorksheetStatus
See Also

Reference

SMath.Controls Namespace


ZoomDelegate Delegate

Namespace: SMath.Controls
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ZoomDelegate(
    float scaleFactor,
    float focusX,
    float focusY,
    SizeF size,
    bool doubleTap
)
Public Delegate Sub ZoomDelegate (
    scaleFactor As Single,
    focusX As Single,
    focusY As Single,
    size As SizeF,
    doubleTap As Boolean
)
public delegate void ZoomDelegate(
    float scaleFactor,
    float focusX,
    float focusY,
    SizeF size,
    bool doubleTap
)
type ZoomDelegate =
    delegate of
        scaleFactor : float32 *
        focusX : float32 *
        focusY : float32 *
        size : SizeF *
        doubleTap : bool -> unit

Parameters

scaleFactor
Type: SystemSingle
focusX
Type: SystemSingle
focusY
Type: SystemSingle
size
Type: System.DrawingSizeF
doubleTap
Type: SystemBoolean
See Also

Reference

SMath.Controls Namespace


SMath.Drawing Namespace

Classes
 | Class | Description
Public class | BitmapExtensions | Extension methods for IBitmap objects.Методы расширения объектов IBitmap.
Public class | ColorBrush |
Public class | ColorBrushes |
Public class | ColorPen |
Public class | ColorPens |
Public class | DesktopBitmap |
Public class | DesktopFontFamily |
Public class | DesktopGraphics |
Public class | DrawingSpecifics |
Public class | EmptyAccount |
Public class | FontInfo |
Public class | FontMetrics |
Public class | Graphics |
Public class | GraphicsExtensions | Extension methods for IGraphics objects.Методы расширения объектов IGraphics.
Public class | LinearGradientColorBrush |
Public class | PathArcTo |
Public class | PathCubicTo |
Public class | PathLineTo |
Public class | PathMoveTo |
Public class | PathQuadCurveTo |
Public class | PathStep |
Public class | StringOptions |
Public class | SvgGraphics |
Public class | SvgGraphicsSvgNotSupported |
Public class | SystemColorBrushes |
Public class | SystemSpecificColors |
Interfaces
 | Interface | Description
Public interface | IAccountManager |
Public interface | IBitmap |
Public interface | IDrawingSpecifics |
Public interface | IFontFamily |
Public interface | IGraphics |
Public interface | ISystemSpecifics |
Delegates
 | Delegate | Description
Public delegate | AccountStatusChange |
Enumerations
 | Enumeration | Description
Public enumeration | AccountPlan |
Public enumeration | AuthError |
Public enumeration | AuthStatus |
Public enumeration | BitmapFormat |
Public enumeration | FontfaceStyle |
Public enumeration | PlatformType |
Public enumeration | StringOptionsFlags |
Public enumeration | StrokeStyle |


AccountPlan Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum AccountPlan
Public Enumeration AccountPlan
public enum class AccountPlan
type AccountPlan
Members
Member name | Value | Description
Basic | 1 |
Personal | 2 |
Advanced | 3 |
Unlimited | 4 |
See Also

Reference

SMath.Drawing Namespace


AccountStatusChange Delegate

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void AccountStatusChange(
    IAccountManager account,
    string authorizationToken
)
Public Delegate Sub AccountStatusChange (
    account As IAccountManager,
    authorizationToken As String
)
public delegate void AccountStatusChange(
    IAccountManager^ account,
    String^ authorizationToken
)
type AccountStatusChange =
    delegate of
        account : IAccountManager *
        authorizationToken : string -> unit

Parameters

account
Type: SMath.DrawingIAccountManager
authorizationToken
Type: SystemString
See Also

Reference

SMath.Drawing Namespace


AuthError Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum AuthError
Public Enumeration AuthError
public enum class AuthError
type AuthError
Members
Member name | Value | Description
None | 0 |
WrongCredentials | 1 |
NoConnection | 2 |
See Also

Reference

SMath.Drawing Namespace


AuthStatus Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AuthStatus
<FlagsAttribute>
Public Enumeration AuthStatus
[FlagsAttribute]
public enum class AuthStatus
[<FlagsAttribute>]
type AuthStatus
Members
Member name | Value | Description
SignedOut | 1 |
SignedIn | 2 |
Offline | 6 |
SignInRequired | 10 |
DuplicatedSignIn | 22 |
See Also

Reference

SMath.Drawing Namespace


BitmapExtensions Class

Extension methods for IBitmap objects.Методы расширения объектов IBitmap.
Inheritance Hierarchy
SystemObject
SMath.DrawingBitmapExtensions

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class BitmapExtensions
Public NotInheritable Class BitmapExtensions
public ref class BitmapExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BitmapExtensions =  class end

The BitmapExtensions type exposes the following members.

Methods
Name | Description
Clone |
Top
See Also

Reference

SMath.Drawing Namespace


BitmapExtensions Methods

The BitmapExtensions type exposes the following members.

Methods
Name | Description
Clone |
Top
See Also

Reference

BitmapExtensions Class
SMath.Drawing Namespace


BitmapExtensions.Clone Method

BitmapExtensionsClone Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IBitmap Clone(
    IBitmap bmp
)
Public Shared Function Clone (
    bmp As IBitmap
) As IBitmap
public:
static IBitmap^ Clone(
    IBitmap^ bmp
)
static member Clone :
        bmp : IBitmap -> IBitmap

Parameters

bmp
Type: SMath.DrawingIBitmap

Return Value

Type: IBitmap
See Also

Reference

BitmapExtensions Class
SMath.Drawing Namespace


BitmapFormat Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum BitmapFormat
Public Enumeration BitmapFormat
public enum class BitmapFormat
type BitmapFormat
Members
Member name | Value | Description
Bmp | 3 |
Gif | 2 |
Jpeg | 1 |
Png | 0 |
Webp | 4 |
See Also

Reference

SMath.Drawing Namespace


ColorBrush Class

Inheritance Hierarchy
SystemObject
SMath.DrawingColorBrush
SMath.DrawingLinearGradientColorBrush

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ColorBrush
Public Class ColorBrush
public ref class ColorBrush
type ColorBrush =  class end

The ColorBrush type exposes the following members.

Constructors
 | Name | Description
Public method | ColorBrush | Initializes a new instance of the ColorBrush class
Top
Properties
 | Name | Description
Public property | Color |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


ColorBrush Constructor

Initializes a new instance of the ColorBrush class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorBrush(
    Color Color
)
Public Sub New (
    Color As Color
)
public:
ColorBrush(
    Color Color
)
new :
        Color : Color -> ColorBrush

Parameters

Color
Type: System.DrawingColor
See Also

Reference

ColorBrush Class
SMath.Drawing Namespace


ColorBrush Properties

The ColorBrush type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Top
See Also

Reference

ColorBrush Class
SMath.Drawing Namespace


ColorBrush.Color Property

ColorBrushColor Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorBrush Class
SMath.Drawing Namespace


ColorBrush Methods

The ColorBrush type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorBrush Class
SMath.Drawing Namespace


ColorBrushes Class

Inheritance Hierarchy
SystemObject
SMath.DrawingColorBrushes

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ColorBrushes
Public Class ColorBrushes
public ref class ColorBrushes
type ColorBrushes =  class end

The ColorBrushes type exposes the following members.

Constructors
 | Name | Description
Public method | ColorBrushes | Initializes a new instance of the ColorBrushes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AliceBlue |
AntiqueWhite |
Aqua |
Aquamarine |
Azure |
Beige |
Bisque |
Black |
BlanchedAlmond |
Blue |
BlueViolet |
Brown |
BurlyWood |
CadetBlue |
Chartreuse |
Chocolate |
Coral |
CornflowerBlue |
Cornsilk |
Crimson |
Cyan |
DarkBlue |
DarkCyan |
DarkGoldenrod |
DarkGray |
DarkGreen |
DarkKhaki |
DarkMagenta |
DarkOliveGreen |
DarkOrange |
DarkOrchid |
DarkRed |
DarkSalmon |
DarkSeaGreen |
DarkSlateBlue |
DarkSlateGray |
DarkTurquoise |
DarkViolet |
DeepPink |
DeepSkyBlue |
DimGray |
DodgerBlue |
Firebrick |
FloralWhite |
ForestGreen |
Fuchsia |
Gainsboro |
GhostWhite |
Gold |
Goldenrod |
Gray |
Green |
GreenYellow |
Honeydew |
HotPink |
IndianRed |
Indigo |
Ivory |
Khaki |
Lavender |
LavenderBlush |
LawnGreen |
LemonChiffon |
LightBlue |
LightCoral |
LightCyan |
LightGoldenrodYellow |
LightGray |
LightGreen |
LightPink |
LightSalmon |
LightSeaGreen |
LightSkyBlue |
LightSlateGray |
LightSteelBlue |
LightYellow |
Lime |
LimeGreen |
Linen |
Magenta |
Maroon |
MediumAquamarine |
MediumBlue |
MediumOrchid |
MediumPurple |
MediumSeaGreen |
MediumSlateBlue |
MediumSpringGreen |
MediumTurquoise |
MediumVioletRed |
MidnightBlue |
MintCream |
MistyRose |
Moccasin |
NavajoWhite |
Navy |
OldLace |
Olive |
OliveDrab |
Orange |
OrangeRed |
Orchid |
PaleGoldenrod |
PaleGreen |
PaleTurquoise |
PaleVioletRed |
PapayaWhip |
PeachPuff |
Peru |
Pink |
Plum |
PowderBlue |
Purple |
Red |
RosyBrown |
RoyalBlue |
SaddleBrown |
Salmon |
SandyBrown |
SeaGreen |
SeaShell |
Sienna |
Silver |
SkyBlue |
SlateBlue |
SlateGray |
Snow |
SpringGreen |
SteelBlue |
Tan |
Teal |
Thistle |
Tomato |
Transparent |
Turquoise |
Violet |
Wheat |
White |
WhiteSmoke |
Yellow |
YellowGreen |
Top
See Also

Reference

SMath.Drawing Namespace


ColorBrushes Constructor

Initializes a new instance of the ColorBrushes class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorBrushes()
Public Sub New
public:
ColorBrushes()
new : unit -> ColorBrushes
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes Methods

The ColorBrushes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes Fields

The ColorBrushes type exposes the following members.

Fields
Name | Description
AliceBlue |
AntiqueWhite |
Aqua |
Aquamarine |
Azure |
Beige |
Bisque |
Black |
BlanchedAlmond |
Blue |
BlueViolet |
Brown |
BurlyWood |
CadetBlue |
Chartreuse |
Chocolate |
Coral |
CornflowerBlue |
Cornsilk |
Crimson |
Cyan |
DarkBlue |
DarkCyan |
DarkGoldenrod |
DarkGray |
DarkGreen |
DarkKhaki |
DarkMagenta |
DarkOliveGreen |
DarkOrange |
DarkOrchid |
DarkRed |
DarkSalmon |
DarkSeaGreen |
DarkSlateBlue |
DarkSlateGray |
DarkTurquoise |
DarkViolet |
DeepPink |
DeepSkyBlue |
DimGray |
DodgerBlue |
Firebrick |
FloralWhite |
ForestGreen |
Fuchsia |
Gainsboro |
GhostWhite |
Gold |
Goldenrod |
Gray |
Green |
GreenYellow |
Honeydew |
HotPink |
IndianRed |
Indigo |
Ivory |
Khaki |
Lavender |
LavenderBlush |
LawnGreen |
LemonChiffon |
LightBlue |
LightCoral |
LightCyan |
LightGoldenrodYellow |
LightGray |
LightGreen |
LightPink |
LightSalmon |
LightSeaGreen |
LightSkyBlue |
LightSlateGray |
LightSteelBlue |
LightYellow |
Lime |
LimeGreen |
Linen |
Magenta |
Maroon |
MediumAquamarine |
MediumBlue |
MediumOrchid |
MediumPurple |
MediumSeaGreen |
MediumSlateBlue |
MediumSpringGreen |
MediumTurquoise |
MediumVioletRed |
MidnightBlue |
MintCream |
MistyRose |
Moccasin |
NavajoWhite |
Navy |
OldLace |
Olive |
OliveDrab |
Orange |
OrangeRed |
Orchid |
PaleGoldenrod |
PaleGreen |
PaleTurquoise |
PaleVioletRed |
PapayaWhip |
PeachPuff |
Peru |
Pink |
Plum |
PowderBlue |
Purple |
Red |
RosyBrown |
RoyalBlue |
SaddleBrown |
Salmon |
SandyBrown |
SeaGreen |
SeaShell |
Sienna |
Silver |
SkyBlue |
SlateBlue |
SlateGray |
Snow |
SpringGreen |
SteelBlue |
Tan |
Teal |
Thistle |
Tomato |
Transparent |
Turquoise |
Violet |
Wheat |
White |
WhiteSmoke |
Yellow |
YellowGreen |
Top
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.AliceBlue Field

ColorBrushesAliceBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush AliceBlue
Public Shared AliceBlue As ColorBrush
public:
static ColorBrush^ AliceBlue
static val mutable AliceBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.AntiqueWhite Field

ColorBrushesAntiqueWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush AntiqueWhite
Public Shared AntiqueWhite As ColorBrush
public:
static ColorBrush^ AntiqueWhite
static val mutable AntiqueWhite: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Aqua Field

ColorBrushesAqua Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Aqua
Public Shared Aqua As ColorBrush
public:
static ColorBrush^ Aqua
static val mutable Aqua: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Aquamarine Field

ColorBrushesAquamarine Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Aquamarine
Public Shared Aquamarine As ColorBrush
public:
static ColorBrush^ Aquamarine
static val mutable Aquamarine: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Azure Field

ColorBrushesAzure Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Azure
Public Shared Azure As ColorBrush
public:
static ColorBrush^ Azure
static val mutable Azure: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Beige Field

ColorBrushesBeige Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Beige
Public Shared Beige As ColorBrush
public:
static ColorBrush^ Beige
static val mutable Beige: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Bisque Field

ColorBrushesBisque Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Bisque
Public Shared Bisque As ColorBrush
public:
static ColorBrush^ Bisque
static val mutable Bisque: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Black Field

ColorBrushesBlack Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Black
Public Shared Black As ColorBrush
public:
static ColorBrush^ Black
static val mutable Black: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.BlanchedAlmond Field

ColorBrushesBlanchedAlmond Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush BlanchedAlmond
Public Shared BlanchedAlmond As ColorBrush
public:
static ColorBrush^ BlanchedAlmond
static val mutable BlanchedAlmond: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Blue Field

ColorBrushesBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Blue
Public Shared Blue As ColorBrush
public:
static ColorBrush^ Blue
static val mutable Blue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.BlueViolet Field

ColorBrushesBlueViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush BlueViolet
Public Shared BlueViolet As ColorBrush
public:
static ColorBrush^ BlueViolet
static val mutable BlueViolet: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Brown Field

ColorBrushesBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Brown
Public Shared Brown As ColorBrush
public:
static ColorBrush^ Brown
static val mutable Brown: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.BurlyWood Field

ColorBrushesBurlyWood Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush BurlyWood
Public Shared BurlyWood As ColorBrush
public:
static ColorBrush^ BurlyWood
static val mutable BurlyWood: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.CadetBlue Field

ColorBrushesCadetBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush CadetBlue
Public Shared CadetBlue As ColorBrush
public:
static ColorBrush^ CadetBlue
static val mutable CadetBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Chartreuse Field

ColorBrushesChartreuse Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Chartreuse
Public Shared Chartreuse As ColorBrush
public:
static ColorBrush^ Chartreuse
static val mutable Chartreuse: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Chocolate Field

ColorBrushesChocolate Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Chocolate
Public Shared Chocolate As ColorBrush
public:
static ColorBrush^ Chocolate
static val mutable Chocolate: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Coral Field

ColorBrushesCoral Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Coral
Public Shared Coral As ColorBrush
public:
static ColorBrush^ Coral
static val mutable Coral: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.CornflowerBlue Field

ColorBrushesCornflowerBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush CornflowerBlue
Public Shared CornflowerBlue As ColorBrush
public:
static ColorBrush^ CornflowerBlue
static val mutable CornflowerBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Cornsilk Field

ColorBrushesCornsilk Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Cornsilk
Public Shared Cornsilk As ColorBrush
public:
static ColorBrush^ Cornsilk
static val mutable Cornsilk: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Crimson Field

ColorBrushesCrimson Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Crimson
Public Shared Crimson As ColorBrush
public:
static ColorBrush^ Crimson
static val mutable Crimson: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Cyan Field

ColorBrushesCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Cyan
Public Shared Cyan As ColorBrush
public:
static ColorBrush^ Cyan
static val mutable Cyan: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkBlue Field

ColorBrushesDarkBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkBlue
Public Shared DarkBlue As ColorBrush
public:
static ColorBrush^ DarkBlue
static val mutable DarkBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkCyan Field

ColorBrushesDarkCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkCyan
Public Shared DarkCyan As ColorBrush
public:
static ColorBrush^ DarkCyan
static val mutable DarkCyan: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkGoldenrod Field

ColorBrushesDarkGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkGoldenrod
Public Shared DarkGoldenrod As ColorBrush
public:
static ColorBrush^ DarkGoldenrod
static val mutable DarkGoldenrod: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkGray Field

ColorBrushesDarkGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkGray
Public Shared DarkGray As ColorBrush
public:
static ColorBrush^ DarkGray
static val mutable DarkGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkGreen Field

ColorBrushesDarkGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkGreen
Public Shared DarkGreen As ColorBrush
public:
static ColorBrush^ DarkGreen
static val mutable DarkGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkKhaki Field

ColorBrushesDarkKhaki Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkKhaki
Public Shared DarkKhaki As ColorBrush
public:
static ColorBrush^ DarkKhaki
static val mutable DarkKhaki: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkMagenta Field

ColorBrushesDarkMagenta Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkMagenta
Public Shared DarkMagenta As ColorBrush
public:
static ColorBrush^ DarkMagenta
static val mutable DarkMagenta: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkOliveGreen Field

ColorBrushesDarkOliveGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkOliveGreen
Public Shared DarkOliveGreen As ColorBrush
public:
static ColorBrush^ DarkOliveGreen
static val mutable DarkOliveGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkOrange Field

ColorBrushesDarkOrange Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkOrange
Public Shared DarkOrange As ColorBrush
public:
static ColorBrush^ DarkOrange
static val mutable DarkOrange: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkOrchid Field

ColorBrushesDarkOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkOrchid
Public Shared DarkOrchid As ColorBrush
public:
static ColorBrush^ DarkOrchid
static val mutable DarkOrchid: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkRed Field

ColorBrushesDarkRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkRed
Public Shared DarkRed As ColorBrush
public:
static ColorBrush^ DarkRed
static val mutable DarkRed: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkSalmon Field

ColorBrushesDarkSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkSalmon
Public Shared DarkSalmon As ColorBrush
public:
static ColorBrush^ DarkSalmon
static val mutable DarkSalmon: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkSeaGreen Field

ColorBrushesDarkSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkSeaGreen
Public Shared DarkSeaGreen As ColorBrush
public:
static ColorBrush^ DarkSeaGreen
static val mutable DarkSeaGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkSlateBlue Field

ColorBrushesDarkSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkSlateBlue
Public Shared DarkSlateBlue As ColorBrush
public:
static ColorBrush^ DarkSlateBlue
static val mutable DarkSlateBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkSlateGray Field

ColorBrushesDarkSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkSlateGray
Public Shared DarkSlateGray As ColorBrush
public:
static ColorBrush^ DarkSlateGray
static val mutable DarkSlateGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkTurquoise Field

ColorBrushesDarkTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkTurquoise
Public Shared DarkTurquoise As ColorBrush
public:
static ColorBrush^ DarkTurquoise
static val mutable DarkTurquoise: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DarkViolet Field

ColorBrushesDarkViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DarkViolet
Public Shared DarkViolet As ColorBrush
public:
static ColorBrush^ DarkViolet
static val mutable DarkViolet: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DeepPink Field

ColorBrushesDeepPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DeepPink
Public Shared DeepPink As ColorBrush
public:
static ColorBrush^ DeepPink
static val mutable DeepPink: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DeepSkyBlue Field

ColorBrushesDeepSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DeepSkyBlue
Public Shared DeepSkyBlue As ColorBrush
public:
static ColorBrush^ DeepSkyBlue
static val mutable DeepSkyBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DimGray Field

ColorBrushesDimGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DimGray
Public Shared DimGray As ColorBrush
public:
static ColorBrush^ DimGray
static val mutable DimGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.DodgerBlue Field

ColorBrushesDodgerBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush DodgerBlue
Public Shared DodgerBlue As ColorBrush
public:
static ColorBrush^ DodgerBlue
static val mutable DodgerBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Firebrick Field

ColorBrushesFirebrick Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Firebrick
Public Shared Firebrick As ColorBrush
public:
static ColorBrush^ Firebrick
static val mutable Firebrick: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.FloralWhite Field

ColorBrushesFloralWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush FloralWhite
Public Shared FloralWhite As ColorBrush
public:
static ColorBrush^ FloralWhite
static val mutable FloralWhite: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.ForestGreen Field

ColorBrushesForestGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush ForestGreen
Public Shared ForestGreen As ColorBrush
public:
static ColorBrush^ ForestGreen
static val mutable ForestGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Fuchsia Field

ColorBrushesFuchsia Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Fuchsia
Public Shared Fuchsia As ColorBrush
public:
static ColorBrush^ Fuchsia
static val mutable Fuchsia: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Gainsboro Field

ColorBrushesGainsboro Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Gainsboro
Public Shared Gainsboro As ColorBrush
public:
static ColorBrush^ Gainsboro
static val mutable Gainsboro: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.GhostWhite Field

ColorBrushesGhostWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush GhostWhite
Public Shared GhostWhite As ColorBrush
public:
static ColorBrush^ GhostWhite
static val mutable GhostWhite: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Gold Field

ColorBrushesGold Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Gold
Public Shared Gold As ColorBrush
public:
static ColorBrush^ Gold
static val mutable Gold: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Goldenrod Field

ColorBrushesGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Goldenrod
Public Shared Goldenrod As ColorBrush
public:
static ColorBrush^ Goldenrod
static val mutable Goldenrod: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Gray Field

ColorBrushesGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Gray
Public Shared Gray As ColorBrush
public:
static ColorBrush^ Gray
static val mutable Gray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Green Field

ColorBrushesGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Green
Public Shared Green As ColorBrush
public:
static ColorBrush^ Green
static val mutable Green: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.GreenYellow Field

ColorBrushesGreenYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush GreenYellow
Public Shared GreenYellow As ColorBrush
public:
static ColorBrush^ GreenYellow
static val mutable GreenYellow: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Honeydew Field

ColorBrushesHoneydew Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Honeydew
Public Shared Honeydew As ColorBrush
public:
static ColorBrush^ Honeydew
static val mutable Honeydew: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.HotPink Field

ColorBrushesHotPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush HotPink
Public Shared HotPink As ColorBrush
public:
static ColorBrush^ HotPink
static val mutable HotPink: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.IndianRed Field

ColorBrushesIndianRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush IndianRed
Public Shared IndianRed As ColorBrush
public:
static ColorBrush^ IndianRed
static val mutable IndianRed: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Indigo Field

ColorBrushesIndigo Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Indigo
Public Shared Indigo As ColorBrush
public:
static ColorBrush^ Indigo
static val mutable Indigo: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Ivory Field

ColorBrushesIvory Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Ivory
Public Shared Ivory As ColorBrush
public:
static ColorBrush^ Ivory
static val mutable Ivory: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Khaki Field

ColorBrushesKhaki Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Khaki
Public Shared Khaki As ColorBrush
public:
static ColorBrush^ Khaki
static val mutable Khaki: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Lavender Field

ColorBrushesLavender Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Lavender
Public Shared Lavender As ColorBrush
public:
static ColorBrush^ Lavender
static val mutable Lavender: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LavenderBlush Field

ColorBrushesLavenderBlush Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LavenderBlush
Public Shared LavenderBlush As ColorBrush
public:
static ColorBrush^ LavenderBlush
static val mutable LavenderBlush: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LawnGreen Field

ColorBrushesLawnGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LawnGreen
Public Shared LawnGreen As ColorBrush
public:
static ColorBrush^ LawnGreen
static val mutable LawnGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LemonChiffon Field

ColorBrushesLemonChiffon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LemonChiffon
Public Shared LemonChiffon As ColorBrush
public:
static ColorBrush^ LemonChiffon
static val mutable LemonChiffon: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightBlue Field

ColorBrushesLightBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightBlue
Public Shared LightBlue As ColorBrush
public:
static ColorBrush^ LightBlue
static val mutable LightBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightCoral Field

ColorBrushesLightCoral Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightCoral
Public Shared LightCoral As ColorBrush
public:
static ColorBrush^ LightCoral
static val mutable LightCoral: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightCyan Field

ColorBrushesLightCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightCyan
Public Shared LightCyan As ColorBrush
public:
static ColorBrush^ LightCyan
static val mutable LightCyan: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightGoldenrodYellow Field

ColorBrushesLightGoldenrodYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightGoldenrodYellow
Public Shared LightGoldenrodYellow As ColorBrush
public:
static ColorBrush^ LightGoldenrodYellow
static val mutable LightGoldenrodYellow: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightGray Field

ColorBrushesLightGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightGray
Public Shared LightGray As ColorBrush
public:
static ColorBrush^ LightGray
static val mutable LightGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightGreen Field

ColorBrushesLightGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightGreen
Public Shared LightGreen As ColorBrush
public:
static ColorBrush^ LightGreen
static val mutable LightGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightPink Field

ColorBrushesLightPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightPink
Public Shared LightPink As ColorBrush
public:
static ColorBrush^ LightPink
static val mutable LightPink: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightSalmon Field

ColorBrushesLightSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightSalmon
Public Shared LightSalmon As ColorBrush
public:
static ColorBrush^ LightSalmon
static val mutable LightSalmon: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightSeaGreen Field

ColorBrushesLightSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightSeaGreen
Public Shared LightSeaGreen As ColorBrush
public:
static ColorBrush^ LightSeaGreen
static val mutable LightSeaGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightSkyBlue Field

ColorBrushesLightSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightSkyBlue
Public Shared LightSkyBlue As ColorBrush
public:
static ColorBrush^ LightSkyBlue
static val mutable LightSkyBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightSlateGray Field

ColorBrushesLightSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightSlateGray
Public Shared LightSlateGray As ColorBrush
public:
static ColorBrush^ LightSlateGray
static val mutable LightSlateGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightSteelBlue Field

ColorBrushesLightSteelBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightSteelBlue
Public Shared LightSteelBlue As ColorBrush
public:
static ColorBrush^ LightSteelBlue
static val mutable LightSteelBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LightYellow Field

ColorBrushesLightYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LightYellow
Public Shared LightYellow As ColorBrush
public:
static ColorBrush^ LightYellow
static val mutable LightYellow: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Lime Field

ColorBrushesLime Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Lime
Public Shared Lime As ColorBrush
public:
static ColorBrush^ Lime
static val mutable Lime: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.LimeGreen Field

ColorBrushesLimeGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush LimeGreen
Public Shared LimeGreen As ColorBrush
public:
static ColorBrush^ LimeGreen
static val mutable LimeGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Linen Field

ColorBrushesLinen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Linen
Public Shared Linen As ColorBrush
public:
static ColorBrush^ Linen
static val mutable Linen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Magenta Field

ColorBrushesMagenta Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Magenta
Public Shared Magenta As ColorBrush
public:
static ColorBrush^ Magenta
static val mutable Magenta: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Maroon Field

ColorBrushesMaroon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Maroon
Public Shared Maroon As ColorBrush
public:
static ColorBrush^ Maroon
static val mutable Maroon: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumAquamarine Field

ColorBrushesMediumAquamarine Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumAquamarine
Public Shared MediumAquamarine As ColorBrush
public:
static ColorBrush^ MediumAquamarine
static val mutable MediumAquamarine: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumBlue Field

ColorBrushesMediumBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumBlue
Public Shared MediumBlue As ColorBrush
public:
static ColorBrush^ MediumBlue
static val mutable MediumBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumOrchid Field

ColorBrushesMediumOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumOrchid
Public Shared MediumOrchid As ColorBrush
public:
static ColorBrush^ MediumOrchid
static val mutable MediumOrchid: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumPurple Field

ColorBrushesMediumPurple Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumPurple
Public Shared MediumPurple As ColorBrush
public:
static ColorBrush^ MediumPurple
static val mutable MediumPurple: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumSeaGreen Field

ColorBrushesMediumSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumSeaGreen
Public Shared MediumSeaGreen As ColorBrush
public:
static ColorBrush^ MediumSeaGreen
static val mutable MediumSeaGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumSlateBlue Field

ColorBrushesMediumSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumSlateBlue
Public Shared MediumSlateBlue As ColorBrush
public:
static ColorBrush^ MediumSlateBlue
static val mutable MediumSlateBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumSpringGreen Field

ColorBrushesMediumSpringGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumSpringGreen
Public Shared MediumSpringGreen As ColorBrush
public:
static ColorBrush^ MediumSpringGreen
static val mutable MediumSpringGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumTurquoise Field

ColorBrushesMediumTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumTurquoise
Public Shared MediumTurquoise As ColorBrush
public:
static ColorBrush^ MediumTurquoise
static val mutable MediumTurquoise: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MediumVioletRed Field

ColorBrushesMediumVioletRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MediumVioletRed
Public Shared MediumVioletRed As ColorBrush
public:
static ColorBrush^ MediumVioletRed
static val mutable MediumVioletRed: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MidnightBlue Field

ColorBrushesMidnightBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MidnightBlue
Public Shared MidnightBlue As ColorBrush
public:
static ColorBrush^ MidnightBlue
static val mutable MidnightBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MintCream Field

ColorBrushesMintCream Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MintCream
Public Shared MintCream As ColorBrush
public:
static ColorBrush^ MintCream
static val mutable MintCream: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.MistyRose Field

ColorBrushesMistyRose Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush MistyRose
Public Shared MistyRose As ColorBrush
public:
static ColorBrush^ MistyRose
static val mutable MistyRose: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Moccasin Field

ColorBrushesMoccasin Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Moccasin
Public Shared Moccasin As ColorBrush
public:
static ColorBrush^ Moccasin
static val mutable Moccasin: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.NavajoWhite Field

ColorBrushesNavajoWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush NavajoWhite
Public Shared NavajoWhite As ColorBrush
public:
static ColorBrush^ NavajoWhite
static val mutable NavajoWhite: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Navy Field

ColorBrushesNavy Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Navy
Public Shared Navy As ColorBrush
public:
static ColorBrush^ Navy
static val mutable Navy: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.OldLace Field

ColorBrushesOldLace Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush OldLace
Public Shared OldLace As ColorBrush
public:
static ColorBrush^ OldLace
static val mutable OldLace: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Olive Field

ColorBrushesOlive Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Olive
Public Shared Olive As ColorBrush
public:
static ColorBrush^ Olive
static val mutable Olive: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.OliveDrab Field

ColorBrushesOliveDrab Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush OliveDrab
Public Shared OliveDrab As ColorBrush
public:
static ColorBrush^ OliveDrab
static val mutable OliveDrab: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Orange Field

ColorBrushesOrange Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Orange
Public Shared Orange As ColorBrush
public:
static ColorBrush^ Orange
static val mutable Orange: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.OrangeRed Field

ColorBrushesOrangeRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush OrangeRed
Public Shared OrangeRed As ColorBrush
public:
static ColorBrush^ OrangeRed
static val mutable OrangeRed: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Orchid Field

ColorBrushesOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Orchid
Public Shared Orchid As ColorBrush
public:
static ColorBrush^ Orchid
static val mutable Orchid: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PaleGoldenrod Field

ColorBrushesPaleGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PaleGoldenrod
Public Shared PaleGoldenrod As ColorBrush
public:
static ColorBrush^ PaleGoldenrod
static val mutable PaleGoldenrod: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PaleGreen Field

ColorBrushesPaleGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PaleGreen
Public Shared PaleGreen As ColorBrush
public:
static ColorBrush^ PaleGreen
static val mutable PaleGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PaleTurquoise Field

ColorBrushesPaleTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PaleTurquoise
Public Shared PaleTurquoise As ColorBrush
public:
static ColorBrush^ PaleTurquoise
static val mutable PaleTurquoise: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PaleVioletRed Field

ColorBrushesPaleVioletRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PaleVioletRed
Public Shared PaleVioletRed As ColorBrush
public:
static ColorBrush^ PaleVioletRed
static val mutable PaleVioletRed: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PapayaWhip Field

ColorBrushesPapayaWhip Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PapayaWhip
Public Shared PapayaWhip As ColorBrush
public:
static ColorBrush^ PapayaWhip
static val mutable PapayaWhip: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PeachPuff Field

ColorBrushesPeachPuff Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PeachPuff
Public Shared PeachPuff As ColorBrush
public:
static ColorBrush^ PeachPuff
static val mutable PeachPuff: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Peru Field

ColorBrushesPeru Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Peru
Public Shared Peru As ColorBrush
public:
static ColorBrush^ Peru
static val mutable Peru: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Pink Field

ColorBrushesPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Pink
Public Shared Pink As ColorBrush
public:
static ColorBrush^ Pink
static val mutable Pink: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Plum Field

ColorBrushesPlum Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Plum
Public Shared Plum As ColorBrush
public:
static ColorBrush^ Plum
static val mutable Plum: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.PowderBlue Field

ColorBrushesPowderBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush PowderBlue
Public Shared PowderBlue As ColorBrush
public:
static ColorBrush^ PowderBlue
static val mutable PowderBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Purple Field

ColorBrushesPurple Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Purple
Public Shared Purple As ColorBrush
public:
static ColorBrush^ Purple
static val mutable Purple: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Red Field

ColorBrushesRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Red
Public Shared Red As ColorBrush
public:
static ColorBrush^ Red
static val mutable Red: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.RosyBrown Field

ColorBrushesRosyBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush RosyBrown
Public Shared RosyBrown As ColorBrush
public:
static ColorBrush^ RosyBrown
static val mutable RosyBrown: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.RoyalBlue Field

ColorBrushesRoyalBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush RoyalBlue
Public Shared RoyalBlue As ColorBrush
public:
static ColorBrush^ RoyalBlue
static val mutable RoyalBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SaddleBrown Field

ColorBrushesSaddleBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SaddleBrown
Public Shared SaddleBrown As ColorBrush
public:
static ColorBrush^ SaddleBrown
static val mutable SaddleBrown: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Salmon Field

ColorBrushesSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Salmon
Public Shared Salmon As ColorBrush
public:
static ColorBrush^ Salmon
static val mutable Salmon: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SandyBrown Field

ColorBrushesSandyBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SandyBrown
Public Shared SandyBrown As ColorBrush
public:
static ColorBrush^ SandyBrown
static val mutable SandyBrown: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SeaGreen Field

ColorBrushesSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SeaGreen
Public Shared SeaGreen As ColorBrush
public:
static ColorBrush^ SeaGreen
static val mutable SeaGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SeaShell Field

ColorBrushesSeaShell Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SeaShell
Public Shared SeaShell As ColorBrush
public:
static ColorBrush^ SeaShell
static val mutable SeaShell: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Sienna Field

ColorBrushesSienna Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Sienna
Public Shared Sienna As ColorBrush
public:
static ColorBrush^ Sienna
static val mutable Sienna: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Silver Field

ColorBrushesSilver Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Silver
Public Shared Silver As ColorBrush
public:
static ColorBrush^ Silver
static val mutable Silver: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SkyBlue Field

ColorBrushesSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SkyBlue
Public Shared SkyBlue As ColorBrush
public:
static ColorBrush^ SkyBlue
static val mutable SkyBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SlateBlue Field

ColorBrushesSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SlateBlue
Public Shared SlateBlue As ColorBrush
public:
static ColorBrush^ SlateBlue
static val mutable SlateBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SlateGray Field

ColorBrushesSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SlateGray
Public Shared SlateGray As ColorBrush
public:
static ColorBrush^ SlateGray
static val mutable SlateGray: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Snow Field

ColorBrushesSnow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Snow
Public Shared Snow As ColorBrush
public:
static ColorBrush^ Snow
static val mutable Snow: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SpringGreen Field

ColorBrushesSpringGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SpringGreen
Public Shared SpringGreen As ColorBrush
public:
static ColorBrush^ SpringGreen
static val mutable SpringGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.SteelBlue Field

ColorBrushesSteelBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush SteelBlue
Public Shared SteelBlue As ColorBrush
public:
static ColorBrush^ SteelBlue
static val mutable SteelBlue: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Tan Field

ColorBrushesTan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Tan
Public Shared Tan As ColorBrush
public:
static ColorBrush^ Tan
static val mutable Tan: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Teal Field

ColorBrushesTeal Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Teal
Public Shared Teal As ColorBrush
public:
static ColorBrush^ Teal
static val mutable Teal: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Thistle Field

ColorBrushesThistle Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Thistle
Public Shared Thistle As ColorBrush
public:
static ColorBrush^ Thistle
static val mutable Thistle: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Tomato Field

ColorBrushesTomato Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Tomato
Public Shared Tomato As ColorBrush
public:
static ColorBrush^ Tomato
static val mutable Tomato: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Transparent Field

ColorBrushesTransparent Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Transparent
Public Shared Transparent As ColorBrush
public:
static ColorBrush^ Transparent
static val mutable Transparent: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Turquoise Field

ColorBrushesTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Turquoise
Public Shared Turquoise As ColorBrush
public:
static ColorBrush^ Turquoise
static val mutable Turquoise: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Violet Field

ColorBrushesViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Violet
Public Shared Violet As ColorBrush
public:
static ColorBrush^ Violet
static val mutable Violet: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Wheat Field

ColorBrushesWheat Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Wheat
Public Shared Wheat As ColorBrush
public:
static ColorBrush^ Wheat
static val mutable Wheat: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.White Field

ColorBrushesWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush White
Public Shared White As ColorBrush
public:
static ColorBrush^ White
static val mutable White: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.WhiteSmoke Field

ColorBrushesWhiteSmoke Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush WhiteSmoke
Public Shared WhiteSmoke As ColorBrush
public:
static ColorBrush^ WhiteSmoke
static val mutable WhiteSmoke: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.Yellow Field

ColorBrushesYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Yellow
Public Shared Yellow As ColorBrush
public:
static ColorBrush^ Yellow
static val mutable Yellow: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorBrushes.YellowGreen Field

ColorBrushesYellowGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush YellowGreen
Public Shared YellowGreen As ColorBrush
public:
static ColorBrush^ YellowGreen
static val mutable YellowGreen: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

ColorBrushes Class
SMath.Drawing Namespace


ColorPen Class

Inheritance Hierarchy
SystemObject
SMath.DrawingColorPen

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ColorPen : IDisposable
Public Class ColorPen
    Implements IDisposable
public ref class ColorPen : IDisposable
type ColorPen =
    class
        interface IDisposable
    end

The ColorPen type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPen(Color) | Initializes a new instance of the ColorPen class
Public method | ColorPen(Color, Single) | Initializes a new instance of the ColorPen class
Top
Properties
 | Name | Description
Public property | Color |
Public property | DashStyle |
Public property | HairlineMode |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ColorPen
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


ColorPen Constructor

Overload List
 | Name | Description
Public method | ColorPen(Color) | Initializes a new instance of the ColorPen class
Public method | ColorPen(Color, Single) | Initializes a new instance of the ColorPen class
Top
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen Constructor (Color)

Initializes a new instance of the ColorPen class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorPen(
    Color color
)
Public Sub New (
    color As Color
)
public:
ColorPen(
    Color color
)
new :
        color : Color -> ColorPen

Parameters

color
Type: System.DrawingColor
See Also

Reference

ColorPen Class
ColorPen Overload
SMath.Drawing Namespace


ColorPen Constructor (Color, Single)

Initializes a new instance of the ColorPen class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorPen(
    Color color,
    float width
)
Public Sub New (
    color As Color,
    width As Single
)
public:
ColorPen(
    Color color,
    float width
)
new :
        color : Color *
        width : float32 -> ColorPen

Parameters

color
Type: System.DrawingColor
width
Type: SystemSingle
See Also

Reference

ColorPen Class
ColorPen Overload
SMath.Drawing Namespace


ColorPen Properties

The ColorPen type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Public property | DashStyle |
Public property | HairlineMode |
Public property | Width |
Top
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen.Color Property

ColorPenColor Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen.DashStyle Property

ColorPenDashStyle Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StrokeStyle DashStyle { get; set; }
Public Property DashStyle As StrokeStyle
    Get
    Set
public:
property StrokeStyle DashStyle {
    StrokeStyle get ();
    void set (StrokeStyle value);
}
member DashStyle : StrokeStyle with get, set

Property Value

Type: StrokeStyle
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen.HairlineMode Property

ColorPenHairlineMode Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HairlineMode { get; set; }
Public Property HairlineMode As Boolean
    Get
    Set
public:
property bool HairlineMode {
    bool get ();
    void set (bool value);
}
member HairlineMode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen.Width Property

ColorPenWidth Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Width { get; set; }
Public Property Width As Single
    Get
    Set
public:
property float Width {
    float get ();
    void set (float value);
}
member Width : float32 with get, set

Property Value

Type: Single
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen Methods

The ColorPen type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPen.Dispose Method

ColorPenDispose Method

Releases all resources used by the ColorPen

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ColorPen Class
SMath.Drawing Namespace


ColorPens Class

Inheritance Hierarchy
SystemObject
SMath.DrawingColorPens

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ColorPens
Public Class ColorPens
public ref class ColorPens
type ColorPens =  class end

The ColorPens type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPens | Initializes a new instance of the ColorPens class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AliceBlue |
AntiqueWhite |
Aqua |
Aquamarine |
Azure |
Beige |
Bisque |
Black |
BlanchedAlmond |
Blue |
BlueViolet |
Brown |
BurlyWood |
CadetBlue |
Chartreuse |
Chocolate |
Coral |
CornflowerBlue |
Cornsilk |
Crimson |
Cyan |
DarkBlue |
DarkCyan |
DarkGoldenrod |
DarkGray |
DarkGreen |
DarkKhaki |
DarkMagenta |
DarkOliveGreen |
DarkOrange |
DarkOrchid |
DarkRed |
DarkSalmon |
DarkSeaGreen |
DarkSlateBlue |
DarkSlateGray |
DarkTurquoise |
DarkViolet |
DeepPink |
DeepSkyBlue |
DimGray |
DodgerBlue |
Firebrick |
FloralWhite |
ForestGreen |
Fuchsia |
Gainsboro |
GhostWhite |
Gold |
Goldenrod |
Gray |
Green |
GreenYellow |
Honeydew |
HotPink |
IndianRed |
Indigo |
Ivory |
Khaki |
Lavender |
LavenderBlush |
LawnGreen |
LemonChiffon |
LightBlue |
LightCoral |
LightCyan |
LightGoldenrodYellow |
LightGray |
LightGreen |
LightPink |
LightSalmon |
LightSeaGreen |
LightSkyBlue |
LightSlateGray |
LightSteelBlue |
LightYellow |
Lime |
LimeGreen |
Linen |
Magenta |
Maroon |
MediumAquamarine |
MediumBlue |
MediumOrchid |
MediumPurple |
MediumSeaGreen |
MediumSlateBlue |
MediumSpringGreen |
MediumTurquoise |
MediumVioletRed |
MidnightBlue |
MintCream |
MistyRose |
Moccasin |
NavajoWhite |
Navy |
OldLace |
Olive |
OliveDrab |
Orange |
OrangeRed |
Orchid |
PaleGoldenrod |
PaleGreen |
PaleTurquoise |
PaleVioletRed |
PapayaWhip |
PeachPuff |
Peru |
Pink |
Plum |
PowderBlue |
Purple |
Red |
RosyBrown |
RoyalBlue |
SaddleBrown |
Salmon |
SandyBrown |
SeaGreen |
SeaShell |
Sienna |
Silver |
SkyBlue |
SlateBlue |
SlateGray |
Snow |
SpringGreen |
SteelBlue |
Tan |
Teal |
Thistle |
Tomato |
Transparent |
Turquoise |
Violet |
Wheat |
White |
WhiteSmoke |
Yellow |
YellowGreen |
Top
See Also

Reference

SMath.Drawing Namespace


ColorPens Constructor

Initializes a new instance of the ColorPens class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorPens()
Public Sub New
public:
ColorPens()
new : unit -> ColorPens
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens Methods

The ColorPens type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens Fields

The ColorPens type exposes the following members.

Fields
Name | Description
AliceBlue |
AntiqueWhite |
Aqua |
Aquamarine |
Azure |
Beige |
Bisque |
Black |
BlanchedAlmond |
Blue |
BlueViolet |
Brown |
BurlyWood |
CadetBlue |
Chartreuse |
Chocolate |
Coral |
CornflowerBlue |
Cornsilk |
Crimson |
Cyan |
DarkBlue |
DarkCyan |
DarkGoldenrod |
DarkGray |
DarkGreen |
DarkKhaki |
DarkMagenta |
DarkOliveGreen |
DarkOrange |
DarkOrchid |
DarkRed |
DarkSalmon |
DarkSeaGreen |
DarkSlateBlue |
DarkSlateGray |
DarkTurquoise |
DarkViolet |
DeepPink |
DeepSkyBlue |
DimGray |
DodgerBlue |
Firebrick |
FloralWhite |
ForestGreen |
Fuchsia |
Gainsboro |
GhostWhite |
Gold |
Goldenrod |
Gray |
Green |
GreenYellow |
Honeydew |
HotPink |
IndianRed |
Indigo |
Ivory |
Khaki |
Lavender |
LavenderBlush |
LawnGreen |
LemonChiffon |
LightBlue |
LightCoral |
LightCyan |
LightGoldenrodYellow |
LightGray |
LightGreen |
LightPink |
LightSalmon |
LightSeaGreen |
LightSkyBlue |
LightSlateGray |
LightSteelBlue |
LightYellow |
Lime |
LimeGreen |
Linen |
Magenta |
Maroon |
MediumAquamarine |
MediumBlue |
MediumOrchid |
MediumPurple |
MediumSeaGreen |
MediumSlateBlue |
MediumSpringGreen |
MediumTurquoise |
MediumVioletRed |
MidnightBlue |
MintCream |
MistyRose |
Moccasin |
NavajoWhite |
Navy |
OldLace |
Olive |
OliveDrab |
Orange |
OrangeRed |
Orchid |
PaleGoldenrod |
PaleGreen |
PaleTurquoise |
PaleVioletRed |
PapayaWhip |
PeachPuff |
Peru |
Pink |
Plum |
PowderBlue |
Purple |
Red |
RosyBrown |
RoyalBlue |
SaddleBrown |
Salmon |
SandyBrown |
SeaGreen |
SeaShell |
Sienna |
Silver |
SkyBlue |
SlateBlue |
SlateGray |
Snow |
SpringGreen |
SteelBlue |
Tan |
Teal |
Thistle |
Tomato |
Transparent |
Turquoise |
Violet |
Wheat |
White |
WhiteSmoke |
Yellow |
YellowGreen |
Top
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.AliceBlue Field

ColorPensAliceBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen AliceBlue
Public Shared AliceBlue As ColorPen
public:
static ColorPen^ AliceBlue
static val mutable AliceBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.AntiqueWhite Field

ColorPensAntiqueWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen AntiqueWhite
Public Shared AntiqueWhite As ColorPen
public:
static ColorPen^ AntiqueWhite
static val mutable AntiqueWhite: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Aqua Field

ColorPensAqua Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Aqua
Public Shared Aqua As ColorPen
public:
static ColorPen^ Aqua
static val mutable Aqua: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Aquamarine Field

ColorPensAquamarine Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Aquamarine
Public Shared Aquamarine As ColorPen
public:
static ColorPen^ Aquamarine
static val mutable Aquamarine: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Azure Field

ColorPensAzure Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Azure
Public Shared Azure As ColorPen
public:
static ColorPen^ Azure
static val mutable Azure: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Beige Field

ColorPensBeige Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Beige
Public Shared Beige As ColorPen
public:
static ColorPen^ Beige
static val mutable Beige: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Bisque Field

ColorPensBisque Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Bisque
Public Shared Bisque As ColorPen
public:
static ColorPen^ Bisque
static val mutable Bisque: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Black Field

ColorPensBlack Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Black
Public Shared Black As ColorPen
public:
static ColorPen^ Black
static val mutable Black: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.BlanchedAlmond Field

ColorPensBlanchedAlmond Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen BlanchedAlmond
Public Shared BlanchedAlmond As ColorPen
public:
static ColorPen^ BlanchedAlmond
static val mutable BlanchedAlmond: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Blue Field

ColorPensBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Blue
Public Shared Blue As ColorPen
public:
static ColorPen^ Blue
static val mutable Blue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.BlueViolet Field

ColorPensBlueViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen BlueViolet
Public Shared BlueViolet As ColorPen
public:
static ColorPen^ BlueViolet
static val mutable BlueViolet: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Brown Field

ColorPensBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Brown
Public Shared Brown As ColorPen
public:
static ColorPen^ Brown
static val mutable Brown: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.BurlyWood Field

ColorPensBurlyWood Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen BurlyWood
Public Shared BurlyWood As ColorPen
public:
static ColorPen^ BurlyWood
static val mutable BurlyWood: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.CadetBlue Field

ColorPensCadetBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen CadetBlue
Public Shared CadetBlue As ColorPen
public:
static ColorPen^ CadetBlue
static val mutable CadetBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Chartreuse Field

ColorPensChartreuse Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Chartreuse
Public Shared Chartreuse As ColorPen
public:
static ColorPen^ Chartreuse
static val mutable Chartreuse: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Chocolate Field

ColorPensChocolate Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Chocolate
Public Shared Chocolate As ColorPen
public:
static ColorPen^ Chocolate
static val mutable Chocolate: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Coral Field

ColorPensCoral Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Coral
Public Shared Coral As ColorPen
public:
static ColorPen^ Coral
static val mutable Coral: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.CornflowerBlue Field

ColorPensCornflowerBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen CornflowerBlue
Public Shared CornflowerBlue As ColorPen
public:
static ColorPen^ CornflowerBlue
static val mutable CornflowerBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Cornsilk Field

ColorPensCornsilk Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Cornsilk
Public Shared Cornsilk As ColorPen
public:
static ColorPen^ Cornsilk
static val mutable Cornsilk: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Crimson Field

ColorPensCrimson Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Crimson
Public Shared Crimson As ColorPen
public:
static ColorPen^ Crimson
static val mutable Crimson: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Cyan Field

ColorPensCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Cyan
Public Shared Cyan As ColorPen
public:
static ColorPen^ Cyan
static val mutable Cyan: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkBlue Field

ColorPensDarkBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkBlue
Public Shared DarkBlue As ColorPen
public:
static ColorPen^ DarkBlue
static val mutable DarkBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkCyan Field

ColorPensDarkCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkCyan
Public Shared DarkCyan As ColorPen
public:
static ColorPen^ DarkCyan
static val mutable DarkCyan: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkGoldenrod Field

ColorPensDarkGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkGoldenrod
Public Shared DarkGoldenrod As ColorPen
public:
static ColorPen^ DarkGoldenrod
static val mutable DarkGoldenrod: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkGray Field

ColorPensDarkGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkGray
Public Shared DarkGray As ColorPen
public:
static ColorPen^ DarkGray
static val mutable DarkGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkGreen Field

ColorPensDarkGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkGreen
Public Shared DarkGreen As ColorPen
public:
static ColorPen^ DarkGreen
static val mutable DarkGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkKhaki Field

ColorPensDarkKhaki Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkKhaki
Public Shared DarkKhaki As ColorPen
public:
static ColorPen^ DarkKhaki
static val mutable DarkKhaki: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkMagenta Field

ColorPensDarkMagenta Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkMagenta
Public Shared DarkMagenta As ColorPen
public:
static ColorPen^ DarkMagenta
static val mutable DarkMagenta: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkOliveGreen Field

ColorPensDarkOliveGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkOliveGreen
Public Shared DarkOliveGreen As ColorPen
public:
static ColorPen^ DarkOliveGreen
static val mutable DarkOliveGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkOrange Field

ColorPensDarkOrange Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkOrange
Public Shared DarkOrange As ColorPen
public:
static ColorPen^ DarkOrange
static val mutable DarkOrange: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkOrchid Field

ColorPensDarkOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkOrchid
Public Shared DarkOrchid As ColorPen
public:
static ColorPen^ DarkOrchid
static val mutable DarkOrchid: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkRed Field

ColorPensDarkRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkRed
Public Shared DarkRed As ColorPen
public:
static ColorPen^ DarkRed
static val mutable DarkRed: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkSalmon Field

ColorPensDarkSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkSalmon
Public Shared DarkSalmon As ColorPen
public:
static ColorPen^ DarkSalmon
static val mutable DarkSalmon: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkSeaGreen Field

ColorPensDarkSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkSeaGreen
Public Shared DarkSeaGreen As ColorPen
public:
static ColorPen^ DarkSeaGreen
static val mutable DarkSeaGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkSlateBlue Field

ColorPensDarkSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkSlateBlue
Public Shared DarkSlateBlue As ColorPen
public:
static ColorPen^ DarkSlateBlue
static val mutable DarkSlateBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkSlateGray Field

ColorPensDarkSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkSlateGray
Public Shared DarkSlateGray As ColorPen
public:
static ColorPen^ DarkSlateGray
static val mutable DarkSlateGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkTurquoise Field

ColorPensDarkTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkTurquoise
Public Shared DarkTurquoise As ColorPen
public:
static ColorPen^ DarkTurquoise
static val mutable DarkTurquoise: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DarkViolet Field

ColorPensDarkViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DarkViolet
Public Shared DarkViolet As ColorPen
public:
static ColorPen^ DarkViolet
static val mutable DarkViolet: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DeepPink Field

ColorPensDeepPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DeepPink
Public Shared DeepPink As ColorPen
public:
static ColorPen^ DeepPink
static val mutable DeepPink: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DeepSkyBlue Field

ColorPensDeepSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DeepSkyBlue
Public Shared DeepSkyBlue As ColorPen
public:
static ColorPen^ DeepSkyBlue
static val mutable DeepSkyBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DimGray Field

ColorPensDimGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DimGray
Public Shared DimGray As ColorPen
public:
static ColorPen^ DimGray
static val mutable DimGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.DodgerBlue Field

ColorPensDodgerBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen DodgerBlue
Public Shared DodgerBlue As ColorPen
public:
static ColorPen^ DodgerBlue
static val mutable DodgerBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Firebrick Field

ColorPensFirebrick Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Firebrick
Public Shared Firebrick As ColorPen
public:
static ColorPen^ Firebrick
static val mutable Firebrick: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.FloralWhite Field

ColorPensFloralWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen FloralWhite
Public Shared FloralWhite As ColorPen
public:
static ColorPen^ FloralWhite
static val mutable FloralWhite: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.ForestGreen Field

ColorPensForestGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen ForestGreen
Public Shared ForestGreen As ColorPen
public:
static ColorPen^ ForestGreen
static val mutable ForestGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Fuchsia Field

ColorPensFuchsia Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Fuchsia
Public Shared Fuchsia As ColorPen
public:
static ColorPen^ Fuchsia
static val mutable Fuchsia: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Gainsboro Field

ColorPensGainsboro Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Gainsboro
Public Shared Gainsboro As ColorPen
public:
static ColorPen^ Gainsboro
static val mutable Gainsboro: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.GhostWhite Field

ColorPensGhostWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen GhostWhite
Public Shared GhostWhite As ColorPen
public:
static ColorPen^ GhostWhite
static val mutable GhostWhite: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Gold Field

ColorPensGold Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Gold
Public Shared Gold As ColorPen
public:
static ColorPen^ Gold
static val mutable Gold: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Goldenrod Field

ColorPensGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Goldenrod
Public Shared Goldenrod As ColorPen
public:
static ColorPen^ Goldenrod
static val mutable Goldenrod: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Gray Field

ColorPensGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Gray
Public Shared Gray As ColorPen
public:
static ColorPen^ Gray
static val mutable Gray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Green Field

ColorPensGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Green
Public Shared Green As ColorPen
public:
static ColorPen^ Green
static val mutable Green: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.GreenYellow Field

ColorPensGreenYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen GreenYellow
Public Shared GreenYellow As ColorPen
public:
static ColorPen^ GreenYellow
static val mutable GreenYellow: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Honeydew Field

ColorPensHoneydew Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Honeydew
Public Shared Honeydew As ColorPen
public:
static ColorPen^ Honeydew
static val mutable Honeydew: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.HotPink Field

ColorPensHotPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen HotPink
Public Shared HotPink As ColorPen
public:
static ColorPen^ HotPink
static val mutable HotPink: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.IndianRed Field

ColorPensIndianRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen IndianRed
Public Shared IndianRed As ColorPen
public:
static ColorPen^ IndianRed
static val mutable IndianRed: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Indigo Field

ColorPensIndigo Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Indigo
Public Shared Indigo As ColorPen
public:
static ColorPen^ Indigo
static val mutable Indigo: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Ivory Field

ColorPensIvory Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Ivory
Public Shared Ivory As ColorPen
public:
static ColorPen^ Ivory
static val mutable Ivory: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Khaki Field

ColorPensKhaki Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Khaki
Public Shared Khaki As ColorPen
public:
static ColorPen^ Khaki
static val mutable Khaki: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Lavender Field

ColorPensLavender Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Lavender
Public Shared Lavender As ColorPen
public:
static ColorPen^ Lavender
static val mutable Lavender: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LavenderBlush Field

ColorPensLavenderBlush Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LavenderBlush
Public Shared LavenderBlush As ColorPen
public:
static ColorPen^ LavenderBlush
static val mutable LavenderBlush: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LawnGreen Field

ColorPensLawnGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LawnGreen
Public Shared LawnGreen As ColorPen
public:
static ColorPen^ LawnGreen
static val mutable LawnGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LemonChiffon Field

ColorPensLemonChiffon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LemonChiffon
Public Shared LemonChiffon As ColorPen
public:
static ColorPen^ LemonChiffon
static val mutable LemonChiffon: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightBlue Field

ColorPensLightBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightBlue
Public Shared LightBlue As ColorPen
public:
static ColorPen^ LightBlue
static val mutable LightBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightCoral Field

ColorPensLightCoral Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightCoral
Public Shared LightCoral As ColorPen
public:
static ColorPen^ LightCoral
static val mutable LightCoral: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightCyan Field

ColorPensLightCyan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightCyan
Public Shared LightCyan As ColorPen
public:
static ColorPen^ LightCyan
static val mutable LightCyan: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightGoldenrodYellow Field

ColorPensLightGoldenrodYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightGoldenrodYellow
Public Shared LightGoldenrodYellow As ColorPen
public:
static ColorPen^ LightGoldenrodYellow
static val mutable LightGoldenrodYellow: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightGray Field

ColorPensLightGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightGray
Public Shared LightGray As ColorPen
public:
static ColorPen^ LightGray
static val mutable LightGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightGreen Field

ColorPensLightGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightGreen
Public Shared LightGreen As ColorPen
public:
static ColorPen^ LightGreen
static val mutable LightGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightPink Field

ColorPensLightPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightPink
Public Shared LightPink As ColorPen
public:
static ColorPen^ LightPink
static val mutable LightPink: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightSalmon Field

ColorPensLightSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightSalmon
Public Shared LightSalmon As ColorPen
public:
static ColorPen^ LightSalmon
static val mutable LightSalmon: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightSeaGreen Field

ColorPensLightSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightSeaGreen
Public Shared LightSeaGreen As ColorPen
public:
static ColorPen^ LightSeaGreen
static val mutable LightSeaGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightSkyBlue Field

ColorPensLightSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightSkyBlue
Public Shared LightSkyBlue As ColorPen
public:
static ColorPen^ LightSkyBlue
static val mutable LightSkyBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightSlateGray Field

ColorPensLightSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightSlateGray
Public Shared LightSlateGray As ColorPen
public:
static ColorPen^ LightSlateGray
static val mutable LightSlateGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightSteelBlue Field

ColorPensLightSteelBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightSteelBlue
Public Shared LightSteelBlue As ColorPen
public:
static ColorPen^ LightSteelBlue
static val mutable LightSteelBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LightYellow Field

ColorPensLightYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LightYellow
Public Shared LightYellow As ColorPen
public:
static ColorPen^ LightYellow
static val mutable LightYellow: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Lime Field

ColorPensLime Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Lime
Public Shared Lime As ColorPen
public:
static ColorPen^ Lime
static val mutable Lime: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.LimeGreen Field

ColorPensLimeGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen LimeGreen
Public Shared LimeGreen As ColorPen
public:
static ColorPen^ LimeGreen
static val mutable LimeGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Linen Field

ColorPensLinen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Linen
Public Shared Linen As ColorPen
public:
static ColorPen^ Linen
static val mutable Linen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Magenta Field

ColorPensMagenta Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Magenta
Public Shared Magenta As ColorPen
public:
static ColorPen^ Magenta
static val mutable Magenta: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Maroon Field

ColorPensMaroon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Maroon
Public Shared Maroon As ColorPen
public:
static ColorPen^ Maroon
static val mutable Maroon: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumAquamarine Field

ColorPensMediumAquamarine Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumAquamarine
Public Shared MediumAquamarine As ColorPen
public:
static ColorPen^ MediumAquamarine
static val mutable MediumAquamarine: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumBlue Field

ColorPensMediumBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumBlue
Public Shared MediumBlue As ColorPen
public:
static ColorPen^ MediumBlue
static val mutable MediumBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumOrchid Field

ColorPensMediumOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumOrchid
Public Shared MediumOrchid As ColorPen
public:
static ColorPen^ MediumOrchid
static val mutable MediumOrchid: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumPurple Field

ColorPensMediumPurple Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumPurple
Public Shared MediumPurple As ColorPen
public:
static ColorPen^ MediumPurple
static val mutable MediumPurple: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumSeaGreen Field

ColorPensMediumSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumSeaGreen
Public Shared MediumSeaGreen As ColorPen
public:
static ColorPen^ MediumSeaGreen
static val mutable MediumSeaGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumSlateBlue Field

ColorPensMediumSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumSlateBlue
Public Shared MediumSlateBlue As ColorPen
public:
static ColorPen^ MediumSlateBlue
static val mutable MediumSlateBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumSpringGreen Field

ColorPensMediumSpringGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumSpringGreen
Public Shared MediumSpringGreen As ColorPen
public:
static ColorPen^ MediumSpringGreen
static val mutable MediumSpringGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumTurquoise Field

ColorPensMediumTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumTurquoise
Public Shared MediumTurquoise As ColorPen
public:
static ColorPen^ MediumTurquoise
static val mutable MediumTurquoise: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MediumVioletRed Field

ColorPensMediumVioletRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MediumVioletRed
Public Shared MediumVioletRed As ColorPen
public:
static ColorPen^ MediumVioletRed
static val mutable MediumVioletRed: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MidnightBlue Field

ColorPensMidnightBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MidnightBlue
Public Shared MidnightBlue As ColorPen
public:
static ColorPen^ MidnightBlue
static val mutable MidnightBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MintCream Field

ColorPensMintCream Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MintCream
Public Shared MintCream As ColorPen
public:
static ColorPen^ MintCream
static val mutable MintCream: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.MistyRose Field

ColorPensMistyRose Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen MistyRose
Public Shared MistyRose As ColorPen
public:
static ColorPen^ MistyRose
static val mutable MistyRose: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Moccasin Field

ColorPensMoccasin Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Moccasin
Public Shared Moccasin As ColorPen
public:
static ColorPen^ Moccasin
static val mutable Moccasin: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.NavajoWhite Field

ColorPensNavajoWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen NavajoWhite
Public Shared NavajoWhite As ColorPen
public:
static ColorPen^ NavajoWhite
static val mutable NavajoWhite: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Navy Field

ColorPensNavy Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Navy
Public Shared Navy As ColorPen
public:
static ColorPen^ Navy
static val mutable Navy: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.OldLace Field

ColorPensOldLace Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen OldLace
Public Shared OldLace As ColorPen
public:
static ColorPen^ OldLace
static val mutable OldLace: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Olive Field

ColorPensOlive Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Olive
Public Shared Olive As ColorPen
public:
static ColorPen^ Olive
static val mutable Olive: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.OliveDrab Field

ColorPensOliveDrab Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen OliveDrab
Public Shared OliveDrab As ColorPen
public:
static ColorPen^ OliveDrab
static val mutable OliveDrab: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Orange Field

ColorPensOrange Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Orange
Public Shared Orange As ColorPen
public:
static ColorPen^ Orange
static val mutable Orange: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.OrangeRed Field

ColorPensOrangeRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen OrangeRed
Public Shared OrangeRed As ColorPen
public:
static ColorPen^ OrangeRed
static val mutable OrangeRed: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Orchid Field

ColorPensOrchid Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Orchid
Public Shared Orchid As ColorPen
public:
static ColorPen^ Orchid
static val mutable Orchid: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PaleGoldenrod Field

ColorPensPaleGoldenrod Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PaleGoldenrod
Public Shared PaleGoldenrod As ColorPen
public:
static ColorPen^ PaleGoldenrod
static val mutable PaleGoldenrod: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PaleGreen Field

ColorPensPaleGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PaleGreen
Public Shared PaleGreen As ColorPen
public:
static ColorPen^ PaleGreen
static val mutable PaleGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PaleTurquoise Field

ColorPensPaleTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PaleTurquoise
Public Shared PaleTurquoise As ColorPen
public:
static ColorPen^ PaleTurquoise
static val mutable PaleTurquoise: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PaleVioletRed Field

ColorPensPaleVioletRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PaleVioletRed
Public Shared PaleVioletRed As ColorPen
public:
static ColorPen^ PaleVioletRed
static val mutable PaleVioletRed: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PapayaWhip Field

ColorPensPapayaWhip Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PapayaWhip
Public Shared PapayaWhip As ColorPen
public:
static ColorPen^ PapayaWhip
static val mutable PapayaWhip: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PeachPuff Field

ColorPensPeachPuff Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PeachPuff
Public Shared PeachPuff As ColorPen
public:
static ColorPen^ PeachPuff
static val mutable PeachPuff: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Peru Field

ColorPensPeru Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Peru
Public Shared Peru As ColorPen
public:
static ColorPen^ Peru
static val mutable Peru: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Pink Field

ColorPensPink Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Pink
Public Shared Pink As ColorPen
public:
static ColorPen^ Pink
static val mutable Pink: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Plum Field

ColorPensPlum Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Plum
Public Shared Plum As ColorPen
public:
static ColorPen^ Plum
static val mutable Plum: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.PowderBlue Field

ColorPensPowderBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen PowderBlue
Public Shared PowderBlue As ColorPen
public:
static ColorPen^ PowderBlue
static val mutable PowderBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Purple Field

ColorPensPurple Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Purple
Public Shared Purple As ColorPen
public:
static ColorPen^ Purple
static val mutable Purple: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Red Field

ColorPensRed Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Red
Public Shared Red As ColorPen
public:
static ColorPen^ Red
static val mutable Red: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.RosyBrown Field

ColorPensRosyBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen RosyBrown
Public Shared RosyBrown As ColorPen
public:
static ColorPen^ RosyBrown
static val mutable RosyBrown: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.RoyalBlue Field

ColorPensRoyalBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen RoyalBlue
Public Shared RoyalBlue As ColorPen
public:
static ColorPen^ RoyalBlue
static val mutable RoyalBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SaddleBrown Field

ColorPensSaddleBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SaddleBrown
Public Shared SaddleBrown As ColorPen
public:
static ColorPen^ SaddleBrown
static val mutable SaddleBrown: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Salmon Field

ColorPensSalmon Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Salmon
Public Shared Salmon As ColorPen
public:
static ColorPen^ Salmon
static val mutable Salmon: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SandyBrown Field

ColorPensSandyBrown Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SandyBrown
Public Shared SandyBrown As ColorPen
public:
static ColorPen^ SandyBrown
static val mutable SandyBrown: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SeaGreen Field

ColorPensSeaGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SeaGreen
Public Shared SeaGreen As ColorPen
public:
static ColorPen^ SeaGreen
static val mutable SeaGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SeaShell Field

ColorPensSeaShell Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SeaShell
Public Shared SeaShell As ColorPen
public:
static ColorPen^ SeaShell
static val mutable SeaShell: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Sienna Field

ColorPensSienna Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Sienna
Public Shared Sienna As ColorPen
public:
static ColorPen^ Sienna
static val mutable Sienna: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Silver Field

ColorPensSilver Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Silver
Public Shared Silver As ColorPen
public:
static ColorPen^ Silver
static val mutable Silver: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SkyBlue Field

ColorPensSkyBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SkyBlue
Public Shared SkyBlue As ColorPen
public:
static ColorPen^ SkyBlue
static val mutable SkyBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SlateBlue Field

ColorPensSlateBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SlateBlue
Public Shared SlateBlue As ColorPen
public:
static ColorPen^ SlateBlue
static val mutable SlateBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SlateGray Field

ColorPensSlateGray Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SlateGray
Public Shared SlateGray As ColorPen
public:
static ColorPen^ SlateGray
static val mutable SlateGray: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Snow Field

ColorPensSnow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Snow
Public Shared Snow As ColorPen
public:
static ColorPen^ Snow
static val mutable Snow: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SpringGreen Field

ColorPensSpringGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SpringGreen
Public Shared SpringGreen As ColorPen
public:
static ColorPen^ SpringGreen
static val mutable SpringGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.SteelBlue Field

ColorPensSteelBlue Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen SteelBlue
Public Shared SteelBlue As ColorPen
public:
static ColorPen^ SteelBlue
static val mutable SteelBlue: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Tan Field

ColorPensTan Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Tan
Public Shared Tan As ColorPen
public:
static ColorPen^ Tan
static val mutable Tan: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Teal Field

ColorPensTeal Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Teal
Public Shared Teal As ColorPen
public:
static ColorPen^ Teal
static val mutable Teal: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Thistle Field

ColorPensThistle Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Thistle
Public Shared Thistle As ColorPen
public:
static ColorPen^ Thistle
static val mutable Thistle: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Tomato Field

ColorPensTomato Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Tomato
Public Shared Tomato As ColorPen
public:
static ColorPen^ Tomato
static val mutable Tomato: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Transparent Field

ColorPensTransparent Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Transparent
Public Shared Transparent As ColorPen
public:
static ColorPen^ Transparent
static val mutable Transparent: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Turquoise Field

ColorPensTurquoise Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Turquoise
Public Shared Turquoise As ColorPen
public:
static ColorPen^ Turquoise
static val mutable Turquoise: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Violet Field

ColorPensViolet Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Violet
Public Shared Violet As ColorPen
public:
static ColorPen^ Violet
static val mutable Violet: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Wheat Field

ColorPensWheat Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Wheat
Public Shared Wheat As ColorPen
public:
static ColorPen^ Wheat
static val mutable Wheat: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.White Field

ColorPensWhite Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen White
Public Shared White As ColorPen
public:
static ColorPen^ White
static val mutable White: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.WhiteSmoke Field

ColorPensWhiteSmoke Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen WhiteSmoke
Public Shared WhiteSmoke As ColorPen
public:
static ColorPen^ WhiteSmoke
static val mutable WhiteSmoke: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.Yellow Field

ColorPensYellow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen Yellow
Public Shared Yellow As ColorPen
public:
static ColorPen^ Yellow
static val mutable Yellow: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


ColorPens.YellowGreen Field

ColorPensYellowGreen Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorPen YellowGreen
Public Shared YellowGreen As ColorPen
public:
static ColorPen^ YellowGreen
static val mutable YellowGreen: ColorPen

Field Value

Type: ColorPen
See Also

Reference

ColorPens Class
SMath.Drawing Namespace


DesktopBitmap Class

Inheritance Hierarchy
SystemObject
SMath.DrawingDesktopBitmap

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DesktopBitmap : IBitmap,
    IDisposable
Public Class DesktopBitmap
    Implements IBitmap, IDisposable
public ref class DesktopBitmap : IBitmap,
    IDisposable
type DesktopBitmap =
    class
        interface IBitmap
        interface IDisposable
    end

The DesktopBitmap type exposes the following members.

Constructors
 | Name | Description
Public method | DesktopBitmap | Initializes a new instance of the DesktopBitmap class
Top
Properties
 | Name | Description
Public property | Height |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DesktopBitmap
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rotate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapT |
Public method | WrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | Clone | (Defined by BitmapExtensions.)
Top
See Also

Reference

SMath.Drawing Namespace


DesktopBitmap Constructor

Initializes a new instance of the DesktopBitmap class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DesktopBitmap()
Public Sub New
public:
DesktopBitmap()
new : unit -> DesktopBitmap
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap Properties

The DesktopBitmap type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | Width |
Top
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Height Property

DesktopBitmapHeight Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
virtual property int Height {
    int get () sealed;
}
abstract Height : int with get
override Height : int with get

Property Value

Type: Int32

Implements

IBitmapHeight
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Width Property

DesktopBitmapWidth Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
virtual property int Width {
    int get () sealed;
}
abstract Width : int with get
override Width : int with get

Property Value

Type: Int32

Implements

IBitmapWidth
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap Methods

The DesktopBitmap type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rotate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapT |
Public method | WrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | Clone | (Defined by BitmapExtensions.)
Top
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Dispose Method

DesktopBitmapDispose Method

Releases all resources used by the DesktopBitmap

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Rotate Method

DesktopBitmapRotate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Rotate(
    int degrees
)
Public Sub Rotate (
    degrees As Integer
)
public:
virtual void Rotate(
    int degrees
) sealed
abstract Rotate :
        degrees : int -> unit
override Rotate :
        degrees : int -> unit

Parameters

degrees
Type: SystemInt32

Implements

IBitmapRotate(Int32)
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Unwrap(T) Method

DesktopBitmapUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T Unwrap<T>()
where T : class

Public Function Unwrap(Of T As Class) As T
public:
generic<typename T>
where T : ref class
virtual T Unwrap() sealed
abstract Unwrap : unit -> 'T  when 'T : not struct
override Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T

Implements

IBitmapUnwrapT
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopBitmap.Wrap(T) Method

DesktopBitmapWrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Wrap<T>(
    T bmp
)
where T : class

Public Sub Wrap(Of T As Class) (
    bmp As T
)
public:
generic<typename T>
where T : ref class
virtual void Wrap(
    T bmp
) sealed
abstract Wrap :
        bmp : 'T -> unit  when 'T : not struct
override Wrap :
        bmp : 'T -> unit  when 'T : not struct

Parameters

bmp
Type: T

Type Parameters

T

Implements

IBitmapWrapT(T)
See Also

Reference

DesktopBitmap Class
SMath.Drawing Namespace


DesktopFontFamily Class

Inheritance Hierarchy
SystemObject
SMath.DrawingDesktopFontFamily

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DesktopFontFamily : IFontFamily
Public Class DesktopFontFamily
    Implements IFontFamily
public ref class DesktopFontFamily : IFontFamily
type DesktopFontFamily =
    class
        interface IFontFamily
    end

The DesktopFontFamily type exposes the following members.

Constructors
 | Name | Description
Public method | DesktopFontFamily | Initializes a new instance of the DesktopFontFamily class
Top
Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapT |
Public method | WrapT |
Top
See Also

Reference

SMath.Drawing Namespace


DesktopFontFamily Constructor

Initializes a new instance of the DesktopFontFamily class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DesktopFontFamily(
    string family
)
Public Sub New (
    family As String
)
public:
DesktopFontFamily(
    String^ family
)
new :
        family : string -> DesktopFontFamily

Parameters

family
Type: SystemString
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopFontFamily Properties

The DesktopFontFamily type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopFontFamily.Name Property

DesktopFontFamilyName Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IFontFamilyName
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopFontFamily Methods

The DesktopFontFamily type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnwrapT |
Public method | WrapT |
Top
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopFontFamily.Unwrap(T) Method

DesktopFontFamilyUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T Unwrap<T>()
where T : class

Public Function Unwrap(Of T As Class) As T
public:
generic<typename T>
where T : ref class
virtual T Unwrap() sealed
abstract Unwrap : unit -> 'T  when 'T : not struct
override Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T

Implements

IFontFamilyUnwrapT
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopFontFamily.Wrap(T) Method

DesktopFontFamilyWrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Wrap<T>(
    T fontFamily
)
where T : class

Public Sub Wrap(Of T As Class) (
    fontFamily As T
)
public:
generic<typename T>
where T : ref class
virtual void Wrap(
    T fontFamily
) sealed
abstract Wrap :
        fontFamily : 'T -> unit  when 'T : not struct
override Wrap :
        fontFamily : 'T -> unit  when 'T : not struct

Parameters

fontFamily
Type: T

Type Parameters

T

Implements

IFontFamilyWrapT(T)
See Also

Reference

DesktopFontFamily Class
SMath.Drawing Namespace


DesktopGraphics Class

Inheritance Hierarchy
SystemObject
SMath.DrawingDesktopGraphics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DesktopGraphics : IGraphics,
    IDisposable
Public Class DesktopGraphics
    Implements IGraphics, IDisposable
public ref class DesktopGraphics : IGraphics,
    IDisposable
type DesktopGraphics =
    class
        interface IGraphics
        interface IDisposable
    end

The DesktopGraphics type exposes the following members.

Constructors
 | Name | Description
Public method | DesktopGraphics | Initializes a new instance of the DesktopGraphics class
Top
Properties
 | Name | Description
Public property | ClipBounds |
Public property | Dpi |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | DrawBezier |
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath |
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillBezier |
Public method | FillEllipse |
Public method | FillPath |
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MeasureString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore |
Public method | Rotate |
Public method | Save |
Public method | SaveAndClip |
Public method | Scale |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate |
Public method | UnwrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

SMath.Drawing Namespace


DesktopGraphics Constructor

Initializes a new instance of the DesktopGraphics class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DesktopGraphics(
    Graphics graphics
)
Public Sub New (
    graphics As Graphics
)
public:
DesktopGraphics(
    Graphics^ graphics
)
new :
        graphics : Graphics -> DesktopGraphics

Parameters

graphics
Type: System.DrawingGraphics
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics Properties

The DesktopGraphics type exposes the following members.

Properties
 | Name | Description
Public property | ClipBounds |
Public property | Dpi |
Top
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.ClipBounds Property

DesktopGraphicsClipBounds Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF ClipBounds { get; }
Public ReadOnly Property ClipBounds As RectangleF
    Get
public:
virtual property RectangleF ClipBounds {
    RectangleF get () sealed;
}
abstract ClipBounds : RectangleF with get
override ClipBounds : RectangleF with get

Property Value

Type: RectangleF

Implements

IGraphicsClipBounds
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Dpi Property

DesktopGraphicsDpi Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Dpi { get; }
Public ReadOnly Property Dpi As Single
    Get
public:
virtual property float Dpi {
    float get () sealed;
}
abstract Dpi : float32 with get
override Dpi : float32 with get

Property Value

Type: Single

Implements

IGraphicsDpi
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics Methods

The DesktopGraphics type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | DrawBezier |
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath |
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillBezier |
Public method | FillEllipse |
Public method | FillPath |
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | MeasureString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore |
Public method | Rotate |
Public method | Save |
Public method | SaveAndClip |
Public method | Scale |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate |
Public method | UnwrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.IDisposable.Dispose Method

DesktopGraphicsIDisposableDispose Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Clear Method

DesktopGraphicsClear Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    Color color
)
Public Sub Clear (
    color As Color
)
public:
virtual void Clear(
    Color color
) sealed
abstract Clear :
        color : Color -> unit
override Clear :
        color : Color -> unit

Parameters

color
Type: System.DrawingColor

Implements

IGraphicsClear(Color)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawBezier Method

DesktopGraphicsDrawBezier Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawBezier(
    ColorPen pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Public Sub DrawBezier (
    pen As ColorPen,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
public:
virtual void DrawBezier(
    ColorPen^ pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
) sealed
abstract DrawBezier :
        pen : ColorPen *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit
override DrawBezier :
        pen : ColorPen *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

pen
Type: SMath.DrawingColorPen
point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
point3
Type: System.DrawingPointF
point4
Type: System.DrawingPointF

Implements

IGraphicsDrawBezier(ColorPen, PointF, PointF, PointF, PointF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawEllipse Method

DesktopGraphicsDrawEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawEllipse(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Public Sub DrawEllipse (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void DrawEllipse(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
) sealed
abstract DrawEllipse :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override DrawEllipse :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsDrawEllipse(ColorPen, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawImage Method

DesktopGraphicsDrawImage Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawImage(
    IBitmap bmp,
    RectangleF destRect,
    RectangleF srcRect
)
Public Sub DrawImage (
    bmp As IBitmap,
    destRect As RectangleF,
    srcRect As RectangleF
)
public:
virtual void DrawImage(
    IBitmap^ bmp,
    RectangleF destRect,
    RectangleF srcRect
) sealed
abstract DrawImage :
        bmp : IBitmap *
        destRect : RectangleF *
        srcRect : RectangleF -> unit
override DrawImage :
        bmp : IBitmap *
        destRect : RectangleF *
        srcRect : RectangleF -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
destRect
Type: System.DrawingRectangleF
srcRect
Type: System.DrawingRectangleF

Implements

IGraphicsDrawImage(IBitmap, RectangleF, RectangleF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawLine Method

DesktopGraphicsDrawLine Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawLine(
    ColorPen pen,
    float x1,
    float y1,
    float x2,
    float y2
)
Public Sub DrawLine (
    pen As ColorPen,
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
)
public:
virtual void DrawLine(
    ColorPen^ pen,
    float x1,
    float y1,
    float x2,
    float y2
) sealed
abstract DrawLine :
        pen : ColorPen *
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> unit
override DrawLine :
        pen : ColorPen *
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x1
Type: SystemSingle
y1
Type: SystemSingle
x2
Type: SystemSingle
y2
Type: SystemSingle

Implements

IGraphicsDrawLine(ColorPen, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawPath Method

DesktopGraphicsDrawPath Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF DrawPath(
    ColorPen pen,
    PathStep[] steps,
    bool closed
)
Public Function DrawPath (
    pen As ColorPen,
    steps As PathStep(),
    closed As Boolean
) As RectangleF
public:
virtual RectangleF DrawPath(
    ColorPen^ pen,
    array<PathStep^>^ steps,
    bool closed
) sealed
abstract DrawPath :
        pen : ColorPen *
        steps : PathStep[] *
        closed : bool -> RectangleF
override DrawPath :
        pen : ColorPen *
        steps : PathStep[] *
        closed : bool -> RectangleF

Parameters

pen
Type: SMath.DrawingColorPen
steps
Type: SMath.DrawingPathStep
closed
Type: SystemBoolean

Return Value

Type: RectangleF

Implements

IGraphicsDrawPath(ColorPen, PathStep, Boolean)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawPolyline Method

DesktopGraphicsDrawPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawPolyline(
    ColorPen pen,
    PointF[] points
)
Public Sub DrawPolyline (
    pen As ColorPen,
    points As PointF()
)
public:
virtual void DrawPolyline(
    ColorPen^ pen,
    array<PointF>^ points
) sealed
abstract DrawPolyline :
        pen : ColorPen *
        points : PointF[] -> unit
override DrawPolyline :
        pen : ColorPen *
        points : PointF[] -> unit

Parameters

pen
Type: SMath.DrawingColorPen
points
Type: System.DrawingPointF

Implements

IGraphicsDrawPolyline(ColorPen, PointF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawRectangle Method

DesktopGraphicsDrawRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Public Sub DrawRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void DrawRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
) sealed
abstract DrawRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override DrawRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsDrawRectangle(ColorPen, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawRoundedRectangle Method

DesktopGraphicsDrawRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawRoundedRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Public Sub DrawRoundedRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
public:
virtual void DrawRoundedRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
) sealed
abstract DrawRoundedRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit
override DrawRoundedRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle

Implements

IGraphicsDrawRoundedRectangle(ColorPen, Single, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.DrawString Method

DesktopGraphicsDrawString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawString(
    string text,
    FontInfo font,
    ColorBrush brush,
    float x,
    float y,
    float width,
    StringOptions format
)
Public Sub DrawString (
    text As String,
    font As FontInfo,
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    format As StringOptions
)
public:
virtual void DrawString(
    String^ text,
    FontInfo^ font,
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    StringOptions^ format
) sealed
abstract DrawString :
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        format : StringOptions -> unit
override DrawString :
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        format : StringOptions -> unit

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions

Implements

IGraphicsDrawString(String, FontInfo, ColorBrush, Single, Single, Single, StringOptions)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillBezier Method

DesktopGraphicsFillBezier Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillBezier(
    ColorBrush brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Public Sub FillBezier (
    brush As ColorBrush,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
public:
virtual void FillBezier(
    ColorBrush^ brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
) sealed
abstract FillBezier :
        brush : ColorBrush *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit
override FillBezier :
        brush : ColorBrush *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
point3
Type: System.DrawingPointF
point4
Type: System.DrawingPointF

Implements

IGraphicsFillBezier(ColorBrush, PointF, PointF, PointF, PointF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillEllipse Method

DesktopGraphicsFillEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillEllipse(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Public Sub FillEllipse (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void FillEllipse(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
) sealed
abstract FillEllipse :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override FillEllipse :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsFillEllipse(ColorBrush, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillPath Method

DesktopGraphicsFillPath Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF FillPath(
    ColorBrush brush,
    PathStep[] steps
)
Public Function FillPath (
    brush As ColorBrush,
    steps As PathStep()
) As RectangleF
public:
virtual RectangleF FillPath(
    ColorBrush^ brush,
    array<PathStep^>^ steps
) sealed
abstract FillPath :
        brush : ColorBrush *
        steps : PathStep[] -> RectangleF
override FillPath :
        brush : ColorBrush *
        steps : PathStep[] -> RectangleF

Parameters

brush
Type: SMath.DrawingColorBrush
steps
Type: SMath.DrawingPathStep

Return Value

Type: RectangleF

Implements

IGraphicsFillPath(ColorBrush, PathStep)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillPolyline Method

DesktopGraphicsFillPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillPolyline(
    ColorBrush brush,
    PointF[] points
)
Public Sub FillPolyline (
    brush As ColorBrush,
    points As PointF()
)
public:
virtual void FillPolyline(
    ColorBrush^ brush,
    array<PointF>^ points
) sealed
abstract FillPolyline :
        brush : ColorBrush *
        points : PointF[] -> unit
override FillPolyline :
        brush : ColorBrush *
        points : PointF[] -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
points
Type: System.DrawingPointF

Implements

IGraphicsFillPolyline(ColorBrush, PointF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillRectangle Method

DesktopGraphicsFillRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Public Sub FillRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void FillRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
) sealed
abstract FillRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override FillRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsFillRectangle(ColorBrush, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.FillRoundedRectangle Method

DesktopGraphicsFillRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillRoundedRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Public Sub FillRoundedRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
public:
virtual void FillRoundedRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
) sealed
abstract FillRoundedRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit
override FillRoundedRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle

Implements

IGraphicsFillRoundedRectangle(ColorBrush, Single, Single, Single, Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.MeasureString Method

DesktopGraphicsMeasureString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SizeF MeasureString(
    string text,
    FontInfo font,
    float width,
    StringOptions format
)
Public Function MeasureString (
    text As String,
    font As FontInfo,
    width As Single,
    format As StringOptions
) As SizeF
public:
virtual SizeF MeasureString(
    String^ text,
    FontInfo^ font,
    float width,
    StringOptions^ format
) sealed
abstract MeasureString :
        text : string *
        font : FontInfo *
        width : float32 *
        format : StringOptions -> SizeF
override MeasureString :
        text : string *
        font : FontInfo *
        width : float32 *
        format : StringOptions -> SizeF

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions

Return Value

Type: SizeF

Implements

IGraphicsMeasureString(String, FontInfo, Single, StringOptions)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Restore Method

DesktopGraphicsRestore Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Restore()
Public Sub Restore
public:
virtual void Restore() sealed
abstract Restore : unit -> unit
override Restore : unit -> unit

Implements

IGraphicsRestore
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Rotate Method

DesktopGraphicsRotate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Rotate(
    float degrees
)
Public Sub Rotate (
    degrees As Single
)
public:
virtual void Rotate(
    float degrees
) sealed
abstract Rotate :
        degrees : float32 -> unit
override Rotate :
        degrees : float32 -> unit

Parameters

degrees
Type: SystemSingle

Implements

IGraphicsRotate(Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Save Method

DesktopGraphicsSave Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IGraphicsSave
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.SaveAndClip Method

DesktopGraphicsSaveAndClip Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SaveAndClip(
    RectangleF bounds
)
Public Sub SaveAndClip (
    bounds As RectangleF
)
public:
virtual void SaveAndClip(
    RectangleF bounds
) sealed
abstract SaveAndClip :
        bounds : RectangleF -> unit
override SaveAndClip :
        bounds : RectangleF -> unit

Parameters

bounds
Type: System.DrawingRectangleF

Implements

IGraphicsSaveAndClip(RectangleF)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Scale Method

DesktopGraphicsScale Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Scale(
    float scaleX,
    float scaleY
)
Public Sub Scale (
    scaleX As Single,
    scaleY As Single
)
public:
virtual void Scale(
    float scaleX,
    float scaleY
) sealed
abstract Scale :
        scaleX : float32 *
        scaleY : float32 -> unit
override Scale :
        scaleX : float32 *
        scaleY : float32 -> unit

Parameters

scaleX
Type: SystemSingle
scaleY
Type: SystemSingle

Implements

IGraphicsScale(Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Translate Method

DesktopGraphicsTranslate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Translate(
    float x,
    float y
)
Public Sub Translate (
    x As Single,
    y As Single
)
public:
virtual void Translate(
    float x,
    float y
) sealed
abstract Translate :
        x : float32 *
        y : float32 -> unit
override Translate :
        x : float32 *
        y : float32 -> unit

Parameters

x
Type: SystemSingle
y
Type: SystemSingle

Implements

IGraphicsTranslate(Single, Single)
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DesktopGraphics.Unwrap(T) Method

DesktopGraphicsUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T Unwrap<T>()
where T : class

Public Function Unwrap(Of T As Class) As T
public:
generic<typename T>
where T : ref class
virtual T Unwrap() sealed
abstract Unwrap : unit -> 'T  when 'T : not struct
override Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T

Implements

IGraphicsUnwrapT
See Also

Reference

DesktopGraphics Class
SMath.Drawing Namespace


DrawingSpecifics Class

Inheritance Hierarchy
SystemObject
SMath.DrawingDrawingSpecifics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DrawingSpecifics : IDrawingSpecifics
Public Class DrawingSpecifics
    Implements IDrawingSpecifics
public ref class DrawingSpecifics : IDrawingSpecifics
type DrawingSpecifics =
    class
        interface IDrawingSpecifics
    end

The DrawingSpecifics type exposes the following members.

Constructors
 | Name | Description
Public method | DrawingSpecifics | Initializes a new instance of the DrawingSpecifics class
Top
Properties
 | Name | Description
Public property | DpiScreen |
Public property | GenericMonospace |
Public property | GenericSansSerif |
Public property | GenericSerif |
 | IsCompatibilityDrawingMode |
Top
Methods
 | Name | Description
Public method | BitmapFromNativeImageT |
Public method | CloneBitmap |
Public method | CreateBitmap |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPaths |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GraphicsFromBitmap |
Public method | GraphicsFromNativeCanvasT |
 | LoadChars |
Public method | LoadFontFamily |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


DrawingSpecifics Constructor

Initializes a new instance of the DrawingSpecifics class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DrawingSpecifics()
Public Sub New
public:
DrawingSpecifics()
new : unit -> DrawingSpecifics
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics Properties

The DrawingSpecifics type exposes the following members.

Properties
 | Name | Description
Public property | DpiScreen |
Public property | GenericMonospace |
Public property | GenericSansSerif |
Public property | GenericSerif |
 | IsCompatibilityDrawingMode |
Top
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.DpiScreen Property

DrawingSpecificsDpiScreen Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float DpiScreen { get; }
Public ReadOnly Property DpiScreen As Single
    Get
public:
virtual property float DpiScreen {
    float get () sealed;
}
abstract DpiScreen : float32 with get
override DpiScreen : float32 with get

Property Value

Type: Single

Implements

IDrawingSpecificsDpiScreen
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GenericMonospace Property

DrawingSpecificsGenericMonospace Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily GenericMonospace { get; }
Public ReadOnly Property GenericMonospace As IFontFamily
    Get
public:
virtual property IFontFamily^ GenericMonospace {
    IFontFamily^ get () sealed;
}
abstract GenericMonospace : IFontFamily with get
override GenericMonospace : IFontFamily with get

Property Value

Type: IFontFamily

Implements

IDrawingSpecificsGenericMonospace
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GenericSansSerif Property

DrawingSpecificsGenericSansSerif Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily GenericSansSerif { get; }
Public ReadOnly Property GenericSansSerif As IFontFamily
    Get
public:
virtual property IFontFamily^ GenericSansSerif {
    IFontFamily^ get () sealed;
}
abstract GenericSansSerif : IFontFamily with get
override GenericSansSerif : IFontFamily with get

Property Value

Type: IFontFamily

Implements

IDrawingSpecificsGenericSansSerif
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GenericSerif Property

DrawingSpecificsGenericSerif Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily GenericSerif { get; }
Public ReadOnly Property GenericSerif As IFontFamily
    Get
public:
virtual property IFontFamily^ GenericSerif {
    IFontFamily^ get () sealed;
}
abstract GenericSerif : IFontFamily with get
override GenericSerif : IFontFamily with get

Property Value

Type: IFontFamily

Implements

IDrawingSpecificsGenericSerif
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.IsCompatibilityDrawingMode Property

DrawingSpecificsIsCompatibilityDrawingMode Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsCompatibilityDrawingMode { get; }
Public Shared ReadOnly Property IsCompatibilityDrawingMode As Boolean
    Get
public:
static property bool IsCompatibilityDrawingMode {
    bool get ();
}
static member IsCompatibilityDrawingMode : bool with get

Property Value

Type: Boolean
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics Methods

The DrawingSpecifics type exposes the following members.

Methods
 | Name | Description
Public method | BitmapFromNativeImageT |
Public method | CloneBitmap |
Public method | CreateBitmap |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPaths |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GraphicsFromBitmap |
Public method | GraphicsFromNativeCanvasT |
 | LoadChars |
Public method | LoadFontFamily |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.BitmapFromNativeImage(T) Method

DrawingSpecificsBitmapFromNativeImageT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap BitmapFromNativeImage<T>(
    T image
)
where T : class

Public Function BitmapFromNativeImage(Of T As Class) (
    image As T
) As IBitmap
public:
generic<typename T>
where T : ref class
virtual IBitmap^ BitmapFromNativeImage(
    T image
) sealed
abstract BitmapFromNativeImage :
        image : 'T -> IBitmap  when 'T : not struct
override BitmapFromNativeImage :
        image : 'T -> IBitmap  when 'T : not struct

Parameters

image
Type: T

Type Parameters

T

Return Value

Type: IBitmap

Implements

IDrawingSpecificsBitmapFromNativeImageT(T)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.CloneBitmap Method

DrawingSpecificsCloneBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap CloneBitmap(
    IBitmap image
)
Public Function CloneBitmap (
    image As IBitmap
) As IBitmap
public:
virtual IBitmap^ CloneBitmap(
    IBitmap^ image
) sealed
abstract CloneBitmap :
        image : IBitmap -> IBitmap
override CloneBitmap :
        image : IBitmap -> IBitmap

Parameters

image
Type: SMath.DrawingIBitmap

Return Value

Type: IBitmap

Implements

IDrawingSpecificsCloneBitmap(IBitmap)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.CreateBitmap Method

DrawingSpecificsCreateBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap CreateBitmap(
    int width,
    int height
)
Public Function CreateBitmap (
    width As Integer,
    height As Integer
) As IBitmap
public:
virtual IBitmap^ CreateBitmap(
    int width,
    int height
) sealed
abstract CreateBitmap :
        width : int *
        height : int -> IBitmap
override CreateBitmap :
        width : int *
        height : int -> IBitmap

Parameters

width
Type: SystemInt32
height
Type: SystemInt32

Return Value

Type: IBitmap

Implements

IDrawingSpecificsCreateBitmap(Int32, Int32)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GetPaths Method

DrawingSpecificsGetPaths Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<GraphicsPath> GetPaths(
    string text,
    float fontSize,
    float x,
    float y
)
Public Shared Function GetPaths (
    text As String,
    fontSize As Single,
    x As Single,
    y As Single
) As List(Of GraphicsPath)
public:
static List<GraphicsPath^>^ GetPaths(
    String^ text,
    float fontSize,
    float x,
    float y
)
static member GetPaths :
        text : string *
        fontSize : float32 *
        x : float32 *
        y : float32 -> List<GraphicsPath>

Parameters

text
Type: SystemString
fontSize
Type: SystemSingle
x
Type: SystemSingle
y
Type: SystemSingle

Return Value

Type: ListGraphicsPath
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GraphicsFromBitmap Method

DrawingSpecificsGraphicsFromBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IGraphics GraphicsFromBitmap(
    IBitmap bmp
)
Public Function GraphicsFromBitmap (
    bmp As IBitmap
) As IGraphics
public:
virtual IGraphics^ GraphicsFromBitmap(
    IBitmap^ bmp
) sealed
abstract GraphicsFromBitmap :
        bmp : IBitmap -> IGraphics
override GraphicsFromBitmap :
        bmp : IBitmap -> IGraphics

Parameters

bmp
Type: SMath.DrawingIBitmap

Return Value

Type: IGraphics

Implements

IDrawingSpecificsGraphicsFromBitmap(IBitmap)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.GraphicsFromNativeCanvas(T) Method

DrawingSpecificsGraphicsFromNativeCanvasT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IGraphics GraphicsFromNativeCanvas<T>(
    T graphics
)
where T : class

Public Function GraphicsFromNativeCanvas(Of T As Class) (
    graphics As T
) As IGraphics
public:
generic<typename T>
where T : ref class
virtual IGraphics^ GraphicsFromNativeCanvas(
    T graphics
) sealed
abstract GraphicsFromNativeCanvas :
        graphics : 'T -> IGraphics  when 'T : not struct
override GraphicsFromNativeCanvas :
        graphics : 'T -> IGraphics  when 'T : not struct

Parameters

graphics
Type: T

Type Parameters

T

Return Value

Type: IGraphics

Implements

IDrawingSpecificsGraphicsFromNativeCanvasT(T)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.LoadChars Method

DrawingSpecificsLoadChars Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadChars(
    bool isCompat
)
Public Shared Sub LoadChars (
    isCompat As Boolean
)
public:
static void LoadChars(
    bool isCompat
)
static member LoadChars :
        isCompat : bool -> unit

Parameters

isCompat
Type: SystemBoolean
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


DrawingSpecifics.LoadFontFamily Method

DrawingSpecificsLoadFontFamily Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily LoadFontFamily(
    string fileName
)
Public Function LoadFontFamily (
    fileName As String
) As IFontFamily
public:
virtual IFontFamily^ LoadFontFamily(
    String^ fileName
) sealed
abstract LoadFontFamily :
        fileName : string -> IFontFamily
override LoadFontFamily :
        fileName : string -> IFontFamily

Parameters

fileName
Type: SystemString

Return Value

Type: IFontFamily

Implements

IDrawingSpecificsLoadFontFamily(String)
See Also

Reference

DrawingSpecifics Class
SMath.Drawing Namespace


EmptyAccount Class

Inheritance Hierarchy
SystemObject
SMath.DrawingEmptyAccount

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class EmptyAccount : IAccountManager
Public Class EmptyAccount
    Implements IAccountManager
public ref class EmptyAccount : IAccountManager
type EmptyAccount =
    class
        interface IAccountManager
    end

The EmptyAccount type exposes the following members.

Constructors
 | Name | Description
Public method | EmptyAccount | Initializes a new instance of the EmptyAccount class
Top
Properties
 | Name | Description
Public property | DisplayName |
Public property | Error |
Public property | PlanExpirationDate |
Public property | PlanId |
Public property | Status |
Public property | Username |
Top
Methods
 | Name | Description
Public method | CheckSubscribtion |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOfflineCode |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | StatusChanged |
Top
See Also

Reference

SMath.Drawing Namespace


EmptyAccount Constructor

Initializes a new instance of the EmptyAccount class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EmptyAccount()
Public Sub New
public:
EmptyAccount()
new : unit -> EmptyAccount
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount Properties

The EmptyAccount type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Error |
Public property | PlanExpirationDate |
Public property | PlanId |
Public property | Status |
Public property | Username |
Top
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.DisplayName Property

EmptyAccountDisplayName Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get () sealed;
}
abstract DisplayName : string with get
override DisplayName : string with get

Property Value

Type: String

Implements

IAccountManagerDisplayName
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.Error Property

EmptyAccountError Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AuthError Error { get; }
Public ReadOnly Property Error As AuthError
    Get
public:
virtual property AuthError Error {
    AuthError get () sealed;
}
abstract Error : AuthError with get
override Error : AuthError with get

Property Value

Type: AuthError

Implements

IAccountManagerError
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.PlanExpirationDate Property

EmptyAccountPlanExpirationDate Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DateTime PlanExpirationDate { get; }
Public ReadOnly Property PlanExpirationDate As DateTime
    Get
public:
virtual property DateTime PlanExpirationDate {
    DateTime get () sealed;
}
abstract PlanExpirationDate : DateTime with get
override PlanExpirationDate : DateTime with get

Property Value

Type: DateTime

Implements

IAccountManagerPlanExpirationDate
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.PlanId Property

EmptyAccountPlanId Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AccountPlan PlanId { get; }
Public ReadOnly Property PlanId As AccountPlan
    Get
public:
virtual property AccountPlan PlanId {
    AccountPlan get () sealed;
}
abstract PlanId : AccountPlan with get
override PlanId : AccountPlan with get

Property Value

Type: AccountPlan

Implements

IAccountManagerPlanId
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.Status Property

EmptyAccountStatus Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AuthStatus Status { get; }
Public ReadOnly Property Status As AuthStatus
    Get
public:
virtual property AuthStatus Status {
    AuthStatus get () sealed;
}
abstract Status : AuthStatus with get
override Status : AuthStatus with get

Property Value

Type: AuthStatus

Implements

IAccountManagerStatus
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.Username Property

EmptyAccountUsername Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Username { get; }
Public ReadOnly Property Username As String
    Get
public:
virtual property String^ Username {
    String^ get () sealed;
}
abstract Username : string with get
override Username : string with get

Property Value

Type: String

Implements

IAccountManagerUsername
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount Methods

The EmptyAccount type exposes the following members.

Methods
 | Name | Description
Public method | CheckSubscribtion |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOfflineCode |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.CheckSubscribtion Method

EmptyAccountCheckSubscribtion Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool CheckSubscribtion(
    string featureName,
    out string featureOptions
)
Public Function CheckSubscribtion (
    featureName As String,
    <OutAttribute> ByRef featureOptions As String
) As Boolean
public:
virtual bool CheckSubscribtion(
    String^ featureName,
    [OutAttribute] String^% featureOptions
) sealed
abstract CheckSubscribtion :
        featureName : string *
        featureOptions : string byref -> bool
override CheckSubscribtion :
        featureName : string *
        featureOptions : string byref -> bool

Parameters

featureName
Type: SystemString
featureOptions
Type: SystemString

Return Value

Type: Boolean

Implements

IAccountManagerCheckSubscribtion(String, String)
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.GetOfflineCode Method

EmptyAccountGetOfflineCode Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetOfflineCode(
    string username
)
Public Function GetOfflineCode (
    username As String
) As String
public:
virtual String^ GetOfflineCode(
    String^ username
) sealed
abstract GetOfflineCode :
        username : string -> string
override GetOfflineCode :
        username : string -> string

Parameters

username
Type: SystemString

Return Value

Type: String

Implements

IAccountManagerGetOfflineCode(String)
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.LogIn Method

EmptyAccountLogIn Method

Overload List
 | Name | Description
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Top
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.LogIn Method (String, Int64)

EmptyAccountLogIn Method (String, Int64)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LogIn(
    string username,
    long activationCode
)
Public Sub LogIn (
    username As String,
    activationCode As Long
)
public:
virtual void LogIn(
    String^ username,
    long long activationCode
) sealed
abstract LogIn :
        username : string *
        activationCode : int64 -> unit
override LogIn :
        username : string *
        activationCode : int64 -> unit

Parameters

username
Type: SystemString
activationCode
Type: SystemInt64

Implements

IAccountManagerLogIn(String, Int64)
See Also

Reference

EmptyAccount Class
LogIn Overload
SMath.Drawing Namespace


EmptyAccount.LogIn Method (String, String)

EmptyAccountLogIn Method (String, String)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LogIn(
    string username,
    string password
)
Public Sub LogIn (
    username As String,
    password As String
)
public:
virtual void LogIn(
    String^ username,
    String^ password
) sealed
abstract LogIn :
        username : string *
        password : string -> unit
override LogIn :
        username : string *
        password : string -> unit

Parameters

username
Type: SystemString
password
Type: SystemString

Implements

IAccountManagerLogIn(String, String)
See Also

Reference

EmptyAccount Class
LogIn Overload
SMath.Drawing Namespace


EmptyAccount.Refresh Method

EmptyAccountRefresh Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Refresh(
    string authorizationToken,
    string username,
    string displayName
)
Public Sub Refresh (
    authorizationToken As String,
    username As String,
    displayName As String
)
public:
virtual void Refresh(
    String^ authorizationToken,
    String^ username,
    String^ displayName
) sealed
abstract Refresh :
        authorizationToken : string *
        username : string *
        displayName : string -> unit
override Refresh :
        authorizationToken : string *
        username : string *
        displayName : string -> unit

Parameters

authorizationToken
Type: SystemString
username
Type: SystemString
displayName
Type: SystemString

Implements

IAccountManagerRefresh(String, String, String)
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount Events

The EmptyAccount type exposes the following members.

Events
 | Name | Description
Public event | StatusChanged |
Top
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


EmptyAccount.StatusChanged Event

EmptyAccountStatusChanged Event

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event AccountStatusChange StatusChanged
Public Event StatusChanged As AccountStatusChange
public:
virtual  event AccountStatusChange^ StatusChanged {
    void add (AccountStatusChange^ value);
    void remove (AccountStatusChange^ value);
}
abstract StatusChanged : IEvent<AccountStatusChange,
    EventArgs>
override StatusChanged : IEvent<AccountStatusChange,
    EventArgs>

Value

Type: SMath.DrawingAccountStatusChange

Implements

IAccountManagerStatusChanged
See Also

Reference

EmptyAccount Class
SMath.Drawing Namespace


FontfaceStyle Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FontfaceStyle
<FlagsAttribute>
Public Enumeration FontfaceStyle
[FlagsAttribute]
public enum class FontfaceStyle
[<FlagsAttribute>]
type FontfaceStyle
Members
Member name | Value | Description
Regular | 0 |
Bold | 1 |
Italic | 2 |
Underline | 4 |
Strikeout | 8 |
See Also

Reference

SMath.Drawing Namespace


FontInfo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingFontInfo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FontInfo
Public Class FontInfo
public ref class FontInfo
type FontInfo =  class end

The FontInfo type exposes the following members.

Constructors
 | Name | Description
Public method | FontInfo(FontInfo, FontfaceStyle) | Initializes a new instance of the FontInfo class
Public method | FontInfo(String, Single, FontfaceStyle) | Initializes a new instance of the FontInfo class
Public method | FontInfo(IFontFamily, Single, FontfaceStyle) | Initializes a new instance of the FontInfo class
Top
Properties
 | Name | Description
Public property | FontFamily |
Public property | Height |
Public property | Name |
Public property | Size |
Public property | Style |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMetrics |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


FontInfo Constructor

Overload List
 | Name | Description
Public method | FontInfo(FontInfo, FontfaceStyle) | Initializes a new instance of the FontInfo class
Public method | FontInfo(String, Single, FontfaceStyle) | Initializes a new instance of the FontInfo class
Public method | FontInfo(IFontFamily, Single, FontfaceStyle) | Initializes a new instance of the FontInfo class
Top
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo Constructor (FontInfo, FontfaceStyle)

Initializes a new instance of the FontInfo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontInfo(
    FontInfo font,
    FontfaceStyle style
)
Public Sub New (
    font As FontInfo,
    style As FontfaceStyle
)
public:
FontInfo(
    FontInfo^ font,
    FontfaceStyle style
)
new :
        font : FontInfo *
        style : FontfaceStyle -> FontInfo

Parameters

font
Type: SMath.DrawingFontInfo
style
Type: SMath.DrawingFontfaceStyle
See Also

Reference

FontInfo Class
FontInfo Overload
SMath.Drawing Namespace


FontInfo Constructor (String, Single, FontfaceStyle)

Initializes a new instance of the FontInfo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontInfo(
    string name,
    float size,
    FontfaceStyle style
)
Public Sub New (
    name As String,
    size As Single,
    style As FontfaceStyle
)
public:
FontInfo(
    String^ name,
    float size,
    FontfaceStyle style
)
new :
        name : string *
        size : float32 *
        style : FontfaceStyle -> FontInfo

Parameters

name
Type: SystemString
size
Type: SystemSingle
style
Type: SMath.DrawingFontfaceStyle
See Also

Reference

FontInfo Class
FontInfo Overload
SMath.Drawing Namespace


FontInfo Constructor (IFontFamily, Single, FontfaceStyle)

Initializes a new instance of the FontInfo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontInfo(
    IFontFamily family,
    float size,
    FontfaceStyle style
)
Public Sub New (
    family As IFontFamily,
    size As Single,
    style As FontfaceStyle
)
public:
FontInfo(
    IFontFamily^ family,
    float size,
    FontfaceStyle style
)
new :
        family : IFontFamily *
        size : float32 *
        style : FontfaceStyle -> FontInfo

Parameters

family
Type: SMath.DrawingIFontFamily
size
Type: SystemSingle
style
Type: SMath.DrawingFontfaceStyle
See Also

Reference

FontInfo Class
FontInfo Overload
SMath.Drawing Namespace


FontInfo Properties

The FontInfo type exposes the following members.

Properties
 | Name | Description
Public property | FontFamily |
Public property | Height |
Public property | Name |
Public property | Size |
Public property | Style |
Top
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.FontFamily Property

FontInfoFontFamily Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily FontFamily { get; }
Public ReadOnly Property FontFamily As IFontFamily
    Get
public:
property IFontFamily^ FontFamily {
    IFontFamily^ get ();
}
member FontFamily : IFontFamily with get

Property Value

Type: IFontFamily
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.Height Property

FontInfoHeight Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int Height {
    int get ();
    void set (int value);
}
member Height : int with get, set

Property Value

Type: Int32
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.Name Property

FontInfoName Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.Size Property

FontInfoSize Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Size { get; set; }
Public Property Size As Single
    Get
    Set
public:
property float Size {
    float get ();
    void set (float value);
}
member Size : float32 with get, set

Property Value

Type: Single
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.Style Property

FontInfoStyle Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontfaceStyle Style { get; }
Public ReadOnly Property Style As FontfaceStyle
    Get
public:
property FontfaceStyle Style {
    FontfaceStyle get ();
}
member Style : FontfaceStyle with get

Property Value

Type: FontfaceStyle
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo Methods

The FontInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMetrics |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontInfo.GetMetrics Method

FontInfoGetMetrics Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontMetrics GetMetrics()
Public Function GetMetrics As FontMetrics
public:
FontMetrics^ GetMetrics()
member GetMetrics : unit -> FontMetrics

Return Value

Type: FontMetrics
See Also

Reference

FontInfo Class
SMath.Drawing Namespace


FontMetrics Class

Inheritance Hierarchy
SystemObject
SMath.DrawingFontMetrics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class FontMetrics
Public Class FontMetrics
public ref class FontMetrics
type FontMetrics =  class end

The FontMetrics type exposes the following members.

Constructors
 | Name | Description
Public method | FontMetrics | Initializes a new instance of the FontMetrics class
Top
Properties
 | Name | Description
Public property | CellAscent |
Public property | CellDescent |
Public property | Height |
Public property | StrikethroughPosition |
Public property | UnderlinePosition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


FontMetrics Constructor

Initializes a new instance of the FontMetrics class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontMetrics(
    FontInfo font
)
Public Sub New (
    font As FontInfo
)
public:
FontMetrics(
    FontInfo^ font
)
new :
        font : FontInfo -> FontMetrics

Parameters

font
Type: SMath.DrawingFontInfo
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics Properties

The FontMetrics type exposes the following members.

Properties
 | Name | Description
Public property | CellAscent |
Public property | CellDescent |
Public property | Height |
Public property | StrikethroughPosition |
Public property | UnderlinePosition |
Top
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics.CellAscent Property

FontMetricsCellAscent Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float CellAscent { get; }
Public ReadOnly Property CellAscent As Single
    Get
public:
property float CellAscent {
    float get ();
}
member CellAscent : float32 with get

Property Value

Type: Single
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics.CellDescent Property

FontMetricsCellDescent Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float CellDescent { get; }
Public ReadOnly Property CellDescent As Single
    Get
public:
property float CellDescent {
    float get ();
}
member CellDescent : float32 with get

Property Value

Type: Single
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics.Height Property

FontMetricsHeight Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Height { get; }
Public ReadOnly Property Height As Single
    Get
public:
property float Height {
    float get ();
}
member Height : float32 with get

Property Value

Type: Single
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics.StrikethroughPosition Property

FontMetricsStrikethroughPosition Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float StrikethroughPosition { get; }
Public ReadOnly Property StrikethroughPosition As Single
    Get
public:
property float StrikethroughPosition {
    float get ();
}
member StrikethroughPosition : float32 with get

Property Value

Type: Single
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics.UnderlinePosition Property

FontMetricsUnderlinePosition Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float UnderlinePosition { get; }
Public ReadOnly Property UnderlinePosition As Single
    Get
public:
property float UnderlinePosition {
    float get ();
}
member UnderlinePosition : float32 with get

Property Value

Type: Single
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


FontMetrics Methods

The FontMetrics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FontMetrics Class
SMath.Drawing Namespace


Graphics Class

Inheritance Hierarchy
SystemObject
SMath.DrawingGraphics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class Graphics
Public NotInheritable Class Graphics
public ref class Graphics abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Graphics =  class end

The Graphics type exposes the following members.

Properties
Name | Description
Specifics |
Top
Methods
Name | Description
ColorToWebColor | Converts .Net Color to Web Color. Method created, because .Net Compact Framework 2.0 doesn't support System.Drawing.ColorTranslator class.
GetColorByName |
WebColorToColor | Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.
Top
Fields
Name | Description
ContentDpi |
EquationsFontFileName |
EquationsFontName |
Top
See Also

Reference

SMath.Drawing Namespace


Graphics Properties

The Graphics type exposes the following members.

Properties
Name | Description
Specifics |
Top
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.Specifics Property

GraphicsSpecifics Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static DrawingSpecifics Specifics { get; }
Public Shared ReadOnly Property Specifics As DrawingSpecifics
    Get
public:
static property DrawingSpecifics^ Specifics {
    DrawingSpecifics^ get ();
}
static member Specifics : DrawingSpecifics with get

Property Value

Type: DrawingSpecifics
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics Methods

The Graphics type exposes the following members.

Methods
Name | Description
ColorToWebColor | Converts .Net Color to Web Color. Method created, because .Net Compact Framework 2.0 doesn't support System.Drawing.ColorTranslator class.
GetColorByName |
WebColorToColor | Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.
Top
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.ColorToWebColor Method

GraphicsColorToWebColor Method

Converts .Net Color to Web Color. Method created, because .Net Compact Framework 2.0 doesn't support System.Drawing.ColorTranslator class.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string ColorToWebColor(
    Color color
)
Public Shared Function ColorToWebColor (
    color As Color
) As String
public:
static String^ ColorToWebColor(
    Color color
)
static member ColorToWebColor :
        color : Color -> string

Parameters

color
Type: System.DrawingColor
Input Color.

Return Value

Type: String
String represents a Web Color.
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.GetColorByName Method

GraphicsGetColorByName Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color GetColorByName(
    string colorName
)
Public Shared Function GetColorByName (
    colorName As String
) As Color
public:
static Color GetColorByName(
    String^ colorName
)
static member GetColorByName :
        colorName : string -> Color

Parameters

colorName
Type: SystemString

Return Value

Type: Color
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.WebColorToColor Method

GraphicsWebColorToColor Method

Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int WebColorToColor(
    string value
)
Public Shared Function WebColorToColor (
    value As String
) As Integer
public:
static int WebColorToColor(
    String^ value
)
static member WebColorToColor :
        value : string -> int

Parameters

value
Type: SystemString
Input Web Color string.

Return Value

Type: Int32
.Net Color.
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics Fields

The Graphics type exposes the following members.

Fields
Name | Description
ContentDpi |
EquationsFontFileName |
EquationsFontName |
Top
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.ContentDpi Field

GraphicsContentDpi Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const float ContentDpi = 96f
Public Const ContentDpi As Single = 96F
public:
literal float ContentDpi = 96f
static val mutable ContentDpi: float32

Field Value

Type: Single
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.EquationsFontFileName Field

GraphicsEquationsFontFileName Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EquationsFontFileName = "SMathEquations.ttf"
Public Const EquationsFontFileName As String = "SMathEquations.ttf"
public:
literal String^ EquationsFontFileName = "SMathEquations.ttf"
static val mutable EquationsFontFileName: string

Field Value

Type: String
See Also

Reference

Graphics Class
SMath.Drawing Namespace


Graphics.EquationsFontName Field

GraphicsEquationsFontName Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EquationsFontName = "SMath Equations"
Public Const EquationsFontName As String = "SMath Equations"
public:
literal String^ EquationsFontName = "SMath Equations"
static val mutable EquationsFontName: string

Field Value

Type: String
See Also

Reference

Graphics Class
SMath.Drawing Namespace


GraphicsExtensions Class

Extension methods for IGraphics objects.Методы расширения объектов IGraphics.
Inheritance Hierarchy
SystemObject
SMath.DrawingGraphicsExtensions

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class GraphicsExtensions
Public NotInheritable Class GraphicsExtensions
public ref class GraphicsExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GraphicsExtensions =  class end

The GraphicsExtensions type exposes the following members.

Methods
Name | Description
DrawEllipse |
DrawImage(IGraphics, IBitmap, PointF) |
DrawImage(IGraphics, IBitmap, RectangleF) |
DrawImage(IGraphics, IBitmap, Single, Single) |
DrawLine |
DrawPath | Obsolete. Draws a PathStep array.
DrawRectangle |
DrawRoundedRectangle |
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single) |
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single, StringOptions) |
DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV.
FillEllipse |
FillPath | Obsolete. Fills the interior of a PathStep array.
FillRectangle |
FillRoundedRectangle |
FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically.
MeasureString |
Scale |
Test | Testing of cross-platform graphics.
Top
See Also

Reference

SMath.Drawing Namespace


GraphicsExtensions Methods

The GraphicsExtensions type exposes the following members.

Methods
Name | Description
DrawEllipse |
DrawImage(IGraphics, IBitmap, PointF) |
DrawImage(IGraphics, IBitmap, RectangleF) |
DrawImage(IGraphics, IBitmap, Single, Single) |
DrawLine |
DrawPath | Obsolete. Draws a PathStep array.
DrawRectangle |
DrawRoundedRectangle |
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single) |
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single, StringOptions) |
DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV.
FillEllipse |
FillPath | Obsolete. Fills the interior of a PathStep array.
FillRectangle |
FillRoundedRectangle |
FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically.
MeasureString |
Scale |
Test | Testing of cross-platform graphics.
Top
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawEllipse Method

GraphicsExtensionsDrawEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawEllipse(
    IGraphics g,
    ColorPen pen,
    RectangleF rect
)
Public Shared Sub DrawEllipse (
    g As IGraphics,
    pen As ColorPen,
    rect As RectangleF
)
public:
static void DrawEllipse(
    IGraphics^ g,
    ColorPen^ pen,
    RectangleF rect
)
static member DrawEllipse :
        g : IGraphics *
        pen : ColorPen *
        rect : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
rect
Type: System.DrawingRectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawImage Method

GraphicsExtensionsDrawImage Method

Overload List
Name | Description
DrawImage(IGraphics, IBitmap, PointF) |
DrawImage(IGraphics, IBitmap, RectangleF) |
DrawImage(IGraphics, IBitmap, Single, Single) |
Top
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawImage Method (IGraphics, IBitmap, PointF)

GraphicsExtensionsDrawImage Method (IGraphics, IBitmap, PointF)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawImage(
    IGraphics g,
    IBitmap bmp,
    PointF pnt
)
Public Shared Sub DrawImage (
    g As IGraphics,
    bmp As IBitmap,
    pnt As PointF
)
public:
static void DrawImage(
    IGraphics^ g,
    IBitmap^ bmp,
    PointF pnt
)
static member DrawImage :
        g : IGraphics *
        bmp : IBitmap *
        pnt : PointF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
bmp
Type: SMath.DrawingIBitmap
pnt
Type: System.DrawingPointF
See Also

Reference

GraphicsExtensions Class
DrawImage Overload
SMath.Drawing Namespace


GraphicsExtensions.DrawImage Method (IGraphics, IBitmap, RectangleF)

GraphicsExtensionsDrawImage Method (IGraphics, IBitmap, RectangleF)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawImage(
    IGraphics g,
    IBitmap bmp,
    RectangleF destRect
)
Public Shared Sub DrawImage (
    g As IGraphics,
    bmp As IBitmap,
    destRect As RectangleF
)
public:
static void DrawImage(
    IGraphics^ g,
    IBitmap^ bmp,
    RectangleF destRect
)
static member DrawImage :
        g : IGraphics *
        bmp : IBitmap *
        destRect : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
bmp
Type: SMath.DrawingIBitmap
destRect
Type: System.DrawingRectangleF
See Also

Reference

GraphicsExtensions Class
DrawImage Overload
SMath.Drawing Namespace


GraphicsExtensions.DrawImage Method (IGraphics, IBitmap, Single, Single)

GraphicsExtensionsDrawImage Method (IGraphics, IBitmap, Single, Single)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawImage(
    IGraphics g,
    IBitmap bmp,
    float x,
    float y
)
Public Shared Sub DrawImage (
    g As IGraphics,
    bmp As IBitmap,
    x As Single,
    y As Single
)
public:
static void DrawImage(
    IGraphics^ g,
    IBitmap^ bmp,
    float x,
    float y
)
static member DrawImage :
        g : IGraphics *
        bmp : IBitmap *
        x : float32 *
        y : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
bmp
Type: SMath.DrawingIBitmap
x
Type: SystemSingle
y
Type: SystemSingle
See Also

Reference

GraphicsExtensions Class
DrawImage Overload
SMath.Drawing Namespace


GraphicsExtensions.DrawLine Method

GraphicsExtensionsDrawLine Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawLine(
    IGraphics g,
    ColorPen pen,
    PointF pnt1,
    PointF pnt2
)
Public Shared Sub DrawLine (
    g As IGraphics,
    pen As ColorPen,
    pnt1 As PointF,
    pnt2 As PointF
)
public:
static void DrawLine(
    IGraphics^ g,
    ColorPen^ pen,
    PointF pnt1,
    PointF pnt2
)
static member DrawLine :
        g : IGraphics *
        pen : ColorPen *
        pnt1 : PointF *
        pnt2 : PointF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
pnt1
Type: System.DrawingPointF
pnt2
Type: System.DrawingPointF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawPath Method

GraphicsExtensionsDrawPath Method

Note: This API is now obsolete.

Draws a PathStep array.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static RectangleF DrawPath(
    IGraphics g,
    ColorPen pen,
    float startX,
    float startY,
    PathStep[] steps,
    bool closed
)
<ObsoleteAttribute>
Public Shared Function DrawPath (
    g As IGraphics,
    pen As ColorPen,
    startX As Single,
    startY As Single,
    steps As PathStep(),
    closed As Boolean
) As RectangleF
public:
[ObsoleteAttribute]
static RectangleF DrawPath(
    IGraphics^ g,
    ColorPen^ pen,
    float startX,
    float startY,
    array<PathStep^>^ steps,
    bool closed
)
[<ObsoleteAttribute>]
static member DrawPath :
        g : IGraphics *
        pen : ColorPen *
        startX : float32 *
        startY : float32 *
        steps : PathStep[] *
        closed : bool -> RectangleF

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
startX
Type: SystemSingle
startY
Type: SystemSingle
steps
Type: SMath.DrawingPathStep
closed
Type: SystemBoolean

Return Value

Type: RectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawRectangle Method

GraphicsExtensionsDrawRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawRectangle(
    IGraphics g,
    ColorPen pen,
    RectangleF rect
)
Public Shared Sub DrawRectangle (
    g As IGraphics,
    pen As ColorPen,
    rect As RectangleF
)
public:
static void DrawRectangle(
    IGraphics^ g,
    ColorPen^ pen,
    RectangleF rect
)
static member DrawRectangle :
        g : IGraphics *
        pen : ColorPen *
        rect : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
rect
Type: System.DrawingRectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawRoundedRectangle Method

GraphicsExtensionsDrawRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawRoundedRectangle(
    IGraphics g,
    ColorPen pen,
    RectangleF rect,
    float arcSize
)
Public Shared Sub DrawRoundedRectangle (
    g As IGraphics,
    pen As ColorPen,
    rect As RectangleF,
    arcSize As Single
)
public:
static void DrawRoundedRectangle(
    IGraphics^ g,
    ColorPen^ pen,
    RectangleF rect,
    float arcSize
)
static member DrawRoundedRectangle :
        g : IGraphics *
        pen : ColorPen *
        rect : RectangleF *
        arcSize : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
rect
Type: System.DrawingRectangleF
arcSize
Type: SystemSingle
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawString Method

GraphicsExtensionsDrawString Method

Overload List
Name | Description
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single) |
DrawString(IGraphics, String, FontInfo, ColorBrush, Single, Single, StringOptions) |
Top
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.DrawString Method (IGraphics, String, FontInfo, ColorBrush, Single, Single)

GraphicsExtensionsDrawString Method (IGraphics, String, FontInfo, ColorBrush, Single, Single)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawString(
    IGraphics g,
    string text,
    FontInfo font,
    ColorBrush brush,
    float x,
    float y
)
Public Shared Sub DrawString (
    g As IGraphics,
    text As String,
    font As FontInfo,
    brush As ColorBrush,
    x As Single,
    y As Single
)
public:
static void DrawString(
    IGraphics^ g,
    String^ text,
    FontInfo^ font,
    ColorBrush^ brush,
    float x,
    float y
)
static member DrawString :
        g : IGraphics *
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
text
Type: SystemString
font
Type: SMath.DrawingFontInfo
brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
See Also

Reference

GraphicsExtensions Class
DrawString Overload
SMath.Drawing Namespace


GraphicsExtensions.DrawString Method (IGraphics, String, FontInfo, ColorBrush, Single, Single, StringOptions)

GraphicsExtensionsDrawString Method (IGraphics, String, FontInfo, ColorBrush, Single, Single, StringOptions)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DrawString(
    IGraphics g,
    string text,
    FontInfo font,
    ColorBrush brush,
    float x,
    float y,
    StringOptions format
)
Public Shared Sub DrawString (
    g As IGraphics,
    text As String,
    font As FontInfo,
    brush As ColorBrush,
    x As Single,
    y As Single,
    format As StringOptions
)
public:
static void DrawString(
    IGraphics^ g,
    String^ text,
    FontInfo^ font,
    ColorBrush^ brush,
    float x,
    float y,
    StringOptions^ format
)
static member DrawString :
        g : IGraphics *
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        format : StringOptions -> unit

Parameters

g
Type: SMath.DrawingIGraphics
text
Type: SystemString
font
Type: SMath.DrawingFontInfo
brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
format
Type: SMath.DrawingStringOptions
See Also

Reference

GraphicsExtensions Class
DrawString Overload
SMath.Drawing Namespace


GraphicsExtensions.DrawSvgPath Method

GraphicsExtensionsDrawSvgPath Method

Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static RectangleF DrawSvgPath(
    IGraphics g,
    ColorPen pen,
    string path
)
Public Shared Function DrawSvgPath (
    g As IGraphics,
    pen As ColorPen,
    path As String
) As RectangleF
public:
static RectangleF DrawSvgPath(
    IGraphics^ g,
    ColorPen^ pen,
    String^ path
)
static member DrawSvgPath :
        g : IGraphics *
        pen : ColorPen *
        path : string -> RectangleF

Parameters

g
Type: SMath.DrawingIGraphics
pen
Type: SMath.DrawingColorPen
path
Type: SystemString

Return Value

Type: RectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.FillEllipse Method

GraphicsExtensionsFillEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void FillEllipse(
    IGraphics g,
    ColorBrush brush,
    RectangleF rect
)
Public Shared Sub FillEllipse (
    g As IGraphics,
    brush As ColorBrush,
    rect As RectangleF
)
public:
static void FillEllipse(
    IGraphics^ g,
    ColorBrush^ brush,
    RectangleF rect
)
static member FillEllipse :
        g : IGraphics *
        brush : ColorBrush *
        rect : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
brush
Type: SMath.DrawingColorBrush
rect
Type: System.DrawingRectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.FillPath Method

GraphicsExtensionsFillPath Method

Note: This API is now obsolete.

Fills the interior of a PathStep array.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute]
public static RectangleF FillPath(
    IGraphics g,
    ColorBrush brush,
    float startX,
    float startY,
    PathStep[] steps
)
<ObsoleteAttribute>
Public Shared Function FillPath (
    g As IGraphics,
    brush As ColorBrush,
    startX As Single,
    startY As Single,
    steps As PathStep()
) As RectangleF
public:
[ObsoleteAttribute]
static RectangleF FillPath(
    IGraphics^ g,
    ColorBrush^ brush,
    float startX,
    float startY,
    array<PathStep^>^ steps
)
[<ObsoleteAttribute>]
static member FillPath :
        g : IGraphics *
        brush : ColorBrush *
        startX : float32 *
        startY : float32 *
        steps : PathStep[] -> RectangleF

Parameters

g
Type: SMath.DrawingIGraphics
brush
Type: SMath.DrawingColorBrush
startX
Type: SystemSingle
startY
Type: SystemSingle
steps
Type: SMath.DrawingPathStep

Return Value

Type: RectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.FillRectangle Method

GraphicsExtensionsFillRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void FillRectangle(
    IGraphics g,
    ColorBrush brush,
    RectangleF rect
)
Public Shared Sub FillRectangle (
    g As IGraphics,
    brush As ColorBrush,
    rect As RectangleF
)
public:
static void FillRectangle(
    IGraphics^ g,
    ColorBrush^ brush,
    RectangleF rect
)
static member FillRectangle :
        g : IGraphics *
        brush : ColorBrush *
        rect : RectangleF -> unit

Parameters

g
Type: SMath.DrawingIGraphics
brush
Type: SMath.DrawingColorBrush
rect
Type: System.DrawingRectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.FillRoundedRectangle Method

GraphicsExtensionsFillRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void FillRoundedRectangle(
    IGraphics g,
    ColorBrush brush,
    RectangleF rect,
    float arcSize
)
Public Shared Sub FillRoundedRectangle (
    g As IGraphics,
    brush As ColorBrush,
    rect As RectangleF,
    arcSize As Single
)
public:
static void FillRoundedRectangle(
    IGraphics^ g,
    ColorBrush^ brush,
    RectangleF rect,
    float arcSize
)
static member FillRoundedRectangle :
        g : IGraphics *
        brush : ColorBrush *
        rect : RectangleF *
        arcSize : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
brush
Type: SMath.DrawingColorBrush
rect
Type: System.DrawingRectangleF
arcSize
Type: SystemSingle
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.FillSvgPath Method

GraphicsExtensionsFillSvgPath Method

Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static RectangleF FillSvgPath(
    IGraphics g,
    ColorBrush brush,
    string path
)
Public Shared Function FillSvgPath (
    g As IGraphics,
    brush As ColorBrush,
    path As String
) As RectangleF
public:
static RectangleF FillSvgPath(
    IGraphics^ g,
    ColorBrush^ brush,
    String^ path
)
static member FillSvgPath :
        g : IGraphics *
        brush : ColorBrush *
        path : string -> RectangleF

Parameters

g
Type: SMath.DrawingIGraphics
brush
Type: SMath.DrawingColorBrush
path
Type: SystemString

Return Value

Type: RectangleF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.MeasureString Method

GraphicsExtensionsMeasureString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SizeF MeasureString(
    IGraphics g,
    string text,
    FontInfo font
)
Public Shared Function MeasureString (
    g As IGraphics,
    text As String,
    font As FontInfo
) As SizeF
public:
static SizeF MeasureString(
    IGraphics^ g,
    String^ text,
    FontInfo^ font
)
static member MeasureString :
        g : IGraphics *
        text : string *
        font : FontInfo -> SizeF

Parameters

g
Type: SMath.DrawingIGraphics
text
Type: SystemString
font
Type: SMath.DrawingFontInfo

Return Value

Type: SizeF
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.Scale Method

GraphicsExtensionsScale Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Scale(
    IGraphics g,
    float factor
)
Public Shared Sub Scale (
    g As IGraphics,
    factor As Single
)
public:
static void Scale(
    IGraphics^ g,
    float factor
)
static member Scale :
        g : IGraphics *
        factor : float32 -> unit

Parameters

g
Type: SMath.DrawingIGraphics
factor
Type: SystemSingle
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


GraphicsExtensions.Test Method

GraphicsExtensionsTest Method

Testing of cross-platform graphics.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Test(
    IGraphics g
)
Public Shared Sub Test (
    g As IGraphics
)
public:
static void Test(
    IGraphics^ g
)
static member Test :
        g : IGraphics -> unit

Parameters

g
Type: SMath.DrawingIGraphics
See Also

Reference

GraphicsExtensions Class
SMath.Drawing Namespace


IAccountManager Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IAccountManager
Public Interface IAccountManager
public interface class IAccountManager
type IAccountManager =  interface end

The IAccountManager type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Error |
Public property | PlanExpirationDate |
Public property | PlanId |
Public property | Status |
Public property | Username |
Top
Methods
 | Name | Description
Public method | CheckSubscribtion |
Public method | GetOfflineCode |
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Public method | Refresh |
Top
Events
 | Name | Description
Public event | StatusChanged |
Top
See Also

Reference

SMath.Drawing Namespace


IAccountManager Properties

The IAccountManager type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Error |
Public property | PlanExpirationDate |
Public property | PlanId |
Public property | Status |
Public property | Username |
Top
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.DisplayName Property

IAccountManagerDisplayName Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string DisplayName { get; }
ReadOnly Property DisplayName As String
    Get
property String^ DisplayName {
    String^ get ();
}
abstract DisplayName : string with get

Property Value

Type: String
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.Error Property

IAccountManagerError Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
AuthError Error { get; }
ReadOnly Property Error As AuthError
    Get
property AuthError Error {
    AuthError get ();
}
abstract Error : AuthError with get

Property Value

Type: AuthError
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.PlanExpirationDate Property

IAccountManagerPlanExpirationDate Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
DateTime PlanExpirationDate { get; }
ReadOnly Property PlanExpirationDate As DateTime
    Get
property DateTime PlanExpirationDate {
    DateTime get ();
}
abstract PlanExpirationDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.PlanId Property

IAccountManagerPlanId Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
AccountPlan PlanId { get; }
ReadOnly Property PlanId As AccountPlan
    Get
property AccountPlan PlanId {
    AccountPlan get ();
}
abstract PlanId : AccountPlan with get

Property Value

Type: AccountPlan
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.Status Property

IAccountManagerStatus Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
AuthStatus Status { get; }
ReadOnly Property Status As AuthStatus
    Get
property AuthStatus Status {
    AuthStatus get ();
}
abstract Status : AuthStatus with get

Property Value

Type: AuthStatus
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.Username Property

IAccountManagerUsername Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Username { get; }
ReadOnly Property Username As String
    Get
property String^ Username {
    String^ get ();
}
abstract Username : string with get

Property Value

Type: String
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager Methods

The IAccountManager type exposes the following members.

Methods
 | Name | Description
Public method | CheckSubscribtion |
Public method | GetOfflineCode |
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Public method | Refresh |
Top
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.CheckSubscribtion Method

IAccountManagerCheckSubscribtion Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool CheckSubscribtion(
    string featureName,
    out string featureOptions
)
Function CheckSubscribtion (
    featureName As String,
    <OutAttribute> ByRef featureOptions As String
) As Boolean
bool CheckSubscribtion(
    String^ featureName,
    [OutAttribute] String^% featureOptions
)
abstract CheckSubscribtion :
        featureName : string *
        featureOptions : string byref -> bool

Parameters

featureName
Type: SystemString
featureOptions
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.GetOfflineCode Method

IAccountManagerGetOfflineCode Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string GetOfflineCode(
    string username
)
Function GetOfflineCode (
    username As String
) As String
String^ GetOfflineCode(
    String^ username
)
abstract GetOfflineCode :
        username : string -> string

Parameters

username
Type: SystemString

Return Value

Type: String
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.LogIn Method

IAccountManagerLogIn Method

Overload List
 | Name | Description
Public method | LogIn(String, Int64) |
Public method | LogIn(String, String) |
Top
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.LogIn Method (String, Int64)

IAccountManagerLogIn Method (String, Int64)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void LogIn(
    string username,
    long activationCode
)
Sub LogIn (
    username As String,
    activationCode As Long
)
void LogIn(
    String^ username,
    long long activationCode
)
abstract LogIn :
        username : string *
        activationCode : int64 -> unit

Parameters

username
Type: SystemString
activationCode
Type: SystemInt64
See Also

Reference

IAccountManager Interface
LogIn Overload
SMath.Drawing Namespace


IAccountManager.LogIn Method (String, String)

IAccountManagerLogIn Method (String, String)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void LogIn(
    string username,
    string password
)
Sub LogIn (
    username As String,
    password As String
)
void LogIn(
    String^ username,
    String^ password
)
abstract LogIn :
        username : string *
        password : string -> unit

Parameters

username
Type: SystemString
password
Type: SystemString
See Also

Reference

IAccountManager Interface
LogIn Overload
SMath.Drawing Namespace


IAccountManager.Refresh Method

IAccountManagerRefresh Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Refresh(
    string authorizationToken,
    string username,
    string displayName
)
Sub Refresh (
    authorizationToken As String,
    username As String,
    displayName As String
)
void Refresh(
    String^ authorizationToken,
    String^ username,
    String^ displayName
)
abstract Refresh :
        authorizationToken : string *
        username : string *
        displayName : string -> unit

Parameters

authorizationToken
Type: SystemString
username
Type: SystemString
displayName
Type: SystemString
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager Events

The IAccountManager type exposes the following members.

Events
 | Name | Description
Public event | StatusChanged |
Top
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IAccountManager.StatusChanged Event

IAccountManagerStatusChanged Event

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
event AccountStatusChange StatusChanged
Event StatusChanged As AccountStatusChange
 event AccountStatusChange^ StatusChanged {
    void add (AccountStatusChange^ value);
    void remove (AccountStatusChange^ value);
}
abstract StatusChanged : IEvent<AccountStatusChange,
    EventArgs>

Value

Type: SMath.DrawingAccountStatusChange
See Also

Reference

IAccountManager Interface
SMath.Drawing Namespace


IBitmap Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IBitmap : IDisposable
Public Interface IBitmap
    Inherits IDisposable
public interface class IBitmap : IDisposable
type IBitmap =
    interface
        interface IDisposable
    end

The IBitmap type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Rotate |
Public method | UnwrapT |
Public method | WrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | Clone | (Defined by BitmapExtensions.)
Top
See Also

Reference

SMath.Drawing Namespace


IBitmap Properties

The IBitmap type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | Width |
Top
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap.Height Property

IBitmapHeight Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int Height { get; }
ReadOnly Property Height As Integer
    Get
property int Height {
    int get ();
}
abstract Height : int with get

Property Value

Type: Int32
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap.Width Property

IBitmapWidth Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int Width { get; }
ReadOnly Property Width As Integer
    Get
property int Width {
    int get ();
}
abstract Width : int with get

Property Value

Type: Int32
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap Methods

The IBitmap type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Rotate |
Public method | UnwrapT |
Public method | WrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | Clone | (Defined by BitmapExtensions.)
Top
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap.Rotate Method

IBitmapRotate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Rotate(
    int degrees
)
Sub Rotate (
    degrees As Integer
)
void Rotate(
    int degrees
)
abstract Rotate :
        degrees : int -> unit

Parameters

degrees
Type: SystemInt32
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap.Unwrap(T) Method

IBitmapUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
T Unwrap<T>()
where T : class

Function Unwrap(Of T As Class) As T
generic<typename T>
where T : ref class
T Unwrap()
abstract Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IBitmap.Wrap(T) Method

IBitmapWrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Wrap<T>(
    T bmp
)
where T : class

Sub Wrap(Of T As Class) (
    bmp As T
)
generic<typename T>
where T : ref class
void Wrap(
    T bmp
)
abstract Wrap :
        bmp : 'T -> unit  when 'T : not struct

Parameters

bmp
Type: T

Type Parameters

T
See Also

Reference

IBitmap Interface
SMath.Drawing Namespace


IDrawingSpecifics Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IDrawingSpecifics
Public Interface IDrawingSpecifics
public interface class IDrawingSpecifics
type IDrawingSpecifics =  interface end

The IDrawingSpecifics type exposes the following members.

Properties
 | Name | Description
Public property | DpiScreen |
Public property | GenericMonospace |
Public property | GenericSansSerif |
Public property | GenericSerif |
Top
Methods
 | Name | Description
Public method | BitmapFromNativeImageT |
Public method | CloneBitmap |
Public method | CreateBitmap |
Public method | GraphicsFromBitmap |
Public method | GraphicsFromNativeCanvasT |
Public method | LoadFontFamily |
Top
See Also

Reference

SMath.Drawing Namespace


IDrawingSpecifics Properties

The IDrawingSpecifics type exposes the following members.

Properties
 | Name | Description
Public property | DpiScreen |
Public property | GenericMonospace |
Public property | GenericSansSerif |
Public property | GenericSerif |
Top
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.DpiScreen Property

IDrawingSpecificsDpiScreen Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float DpiScreen { get; }
ReadOnly Property DpiScreen As Single
    Get
property float DpiScreen {
    float get ();
}
abstract DpiScreen : float32 with get

Property Value

Type: Single
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.GenericMonospace Property

IDrawingSpecificsGenericMonospace Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IFontFamily GenericMonospace { get; }
ReadOnly Property GenericMonospace As IFontFamily
    Get
property IFontFamily^ GenericMonospace {
    IFontFamily^ get ();
}
abstract GenericMonospace : IFontFamily with get

Property Value

Type: IFontFamily
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.GenericSansSerif Property

IDrawingSpecificsGenericSansSerif Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IFontFamily GenericSansSerif { get; }
ReadOnly Property GenericSansSerif As IFontFamily
    Get
property IFontFamily^ GenericSansSerif {
    IFontFamily^ get ();
}
abstract GenericSansSerif : IFontFamily with get

Property Value

Type: IFontFamily
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.GenericSerif Property

IDrawingSpecificsGenericSerif Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IFontFamily GenericSerif { get; }
ReadOnly Property GenericSerif As IFontFamily
    Get
property IFontFamily^ GenericSerif {
    IFontFamily^ get ();
}
abstract GenericSerif : IFontFamily with get

Property Value

Type: IFontFamily
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics Methods

The IDrawingSpecifics type exposes the following members.

Methods
 | Name | Description
Public method | BitmapFromNativeImageT |
Public method | CloneBitmap |
Public method | CreateBitmap |
Public method | GraphicsFromBitmap |
Public method | GraphicsFromNativeCanvasT |
Public method | LoadFontFamily |
Top
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.BitmapFromNativeImage(T) Method

IDrawingSpecificsBitmapFromNativeImageT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap BitmapFromNativeImage<T>(
    T image
)
where T : class

Function BitmapFromNativeImage(Of T As Class) (
    image As T
) As IBitmap
generic<typename T>
where T : ref class
IBitmap^ BitmapFromNativeImage(
    T image
)
abstract BitmapFromNativeImage :
        image : 'T -> IBitmap  when 'T : not struct

Parameters

image
Type: T

Type Parameters

T

Return Value

Type: IBitmap
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.CloneBitmap Method

IDrawingSpecificsCloneBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap CloneBitmap(
    IBitmap bmp
)
Function CloneBitmap (
    bmp As IBitmap
) As IBitmap
IBitmap^ CloneBitmap(
    IBitmap^ bmp
)
abstract CloneBitmap :
        bmp : IBitmap -> IBitmap

Parameters

bmp
Type: SMath.DrawingIBitmap

Return Value

Type: IBitmap
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.CreateBitmap Method

IDrawingSpecificsCreateBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap CreateBitmap(
    int width,
    int height
)
Function CreateBitmap (
    width As Integer,
    height As Integer
) As IBitmap
IBitmap^ CreateBitmap(
    int width,
    int height
)
abstract CreateBitmap :
        width : int *
        height : int -> IBitmap

Parameters

width
Type: SystemInt32
height
Type: SystemInt32

Return Value

Type: IBitmap
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.GraphicsFromBitmap Method

IDrawingSpecificsGraphicsFromBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IGraphics GraphicsFromBitmap(
    IBitmap bmp
)
Function GraphicsFromBitmap (
    bmp As IBitmap
) As IGraphics
IGraphics^ GraphicsFromBitmap(
    IBitmap^ bmp
)
abstract GraphicsFromBitmap :
        bmp : IBitmap -> IGraphics

Parameters

bmp
Type: SMath.DrawingIBitmap

Return Value

Type: IGraphics
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.GraphicsFromNativeCanvas(T) Method

IDrawingSpecificsGraphicsFromNativeCanvasT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IGraphics GraphicsFromNativeCanvas<T>(
    T graphics
)
where T : class

Function GraphicsFromNativeCanvas(Of T As Class) (
    graphics As T
) As IGraphics
generic<typename T>
where T : ref class
IGraphics^ GraphicsFromNativeCanvas(
    T graphics
)
abstract GraphicsFromNativeCanvas :
        graphics : 'T -> IGraphics  when 'T : not struct

Parameters

graphics
Type: T

Type Parameters

T

Return Value

Type: IGraphics
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IDrawingSpecifics.LoadFontFamily Method

IDrawingSpecificsLoadFontFamily Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IFontFamily LoadFontFamily(
    string fileName
)
Function LoadFontFamily (
    fileName As String
) As IFontFamily
IFontFamily^ LoadFontFamily(
    String^ fileName
)
abstract LoadFontFamily :
        fileName : string -> IFontFamily

Parameters

fileName
Type: SystemString

Return Value

Type: IFontFamily
See Also

Reference

IDrawingSpecifics Interface
SMath.Drawing Namespace


IFontFamily Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IFontFamily
Public Interface IFontFamily
public interface class IFontFamily
type IFontFamily =  interface end

The IFontFamily type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | UnwrapT |
Public method | WrapT |
Top
See Also

Reference

SMath.Drawing Namespace


IFontFamily Properties

The IFontFamily type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IFontFamily Interface
SMath.Drawing Namespace


IFontFamily.Name Property

IFontFamilyName Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IFontFamily Interface
SMath.Drawing Namespace


IFontFamily Methods

The IFontFamily type exposes the following members.

Methods
 | Name | Description
Public method | UnwrapT |
Public method | WrapT |
Top
See Also

Reference

IFontFamily Interface
SMath.Drawing Namespace


IFontFamily.Unwrap(T) Method

IFontFamilyUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
T Unwrap<T>()
where T : class

Function Unwrap(Of T As Class) As T
generic<typename T>
where T : ref class
T Unwrap()
abstract Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T
See Also

Reference

IFontFamily Interface
SMath.Drawing Namespace


IFontFamily.Wrap(T) Method

IFontFamilyWrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Wrap<T>(
    T fontFamily
)
where T : class

Sub Wrap(Of T As Class) (
    fontFamily As T
)
generic<typename T>
where T : ref class
void Wrap(
    T fontFamily
)
abstract Wrap :
        fontFamily : 'T -> unit  when 'T : not struct

Parameters

fontFamily
Type: T

Type Parameters

T
See Also

Reference

IFontFamily Interface
SMath.Drawing Namespace


IGraphics Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IGraphics : IDisposable
Public Interface IGraphics
    Inherits IDisposable
public interface class IGraphics : IDisposable
type IGraphics =
    interface
        interface IDisposable
    end

The IGraphics type exposes the following members.

Properties
 | Name | Description
Public property | ClipBounds | Current clipping rectangle.
Public property | Dpi |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DrawBezier | Draws a Bézier spline defined by four PointF structures.
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath | Draws a PathStep array.
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | FillBezier | Fills a Bézier spline defined by four PointF structures.
Public method | FillEllipse |
Public method | FillPath | Fills the interior of a PathStep array.
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Public method | MeasureString |
Public method | Restore | Sets the state of the current graphics object to what it was when SMath.Manager.IGraphics.Save was last called.
Public method | Rotate |
Public method | Save | Stores state of the current graphics object.
Public method | SaveAndClip | Stores state of the current graphics object and sets the clipping rectanle afterwards.
Public method | Scale |
Public method | Translate |
Public method | UnwrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
See Also

Reference

SMath.Drawing Namespace


IGraphics Properties

The IGraphics type exposes the following members.

Properties
 | Name | Description
Public property | ClipBounds | Current clipping rectangle.
Public property | Dpi |
Top
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.ClipBounds Property

IGraphicsClipBounds Property

Current clipping rectangle.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RectangleF ClipBounds { get; }
ReadOnly Property ClipBounds As RectangleF
    Get
property RectangleF ClipBounds {
    RectangleF get ();
}
abstract ClipBounds : RectangleF with get

Property Value

Type: RectangleF
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Dpi Property

IGraphicsDpi Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
float Dpi { get; }
ReadOnly Property Dpi As Single
    Get
property float Dpi {
    float get ();
}
abstract Dpi : float32 with get

Property Value

Type: Single
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics Methods

The IGraphics type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | DrawBezier | Draws a Bézier spline defined by four PointF structures.
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath | Draws a PathStep array.
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | FillBezier | Fills a Bézier spline defined by four PointF structures.
Public method | FillEllipse |
Public method | FillPath | Fills the interior of a PathStep array.
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Public method | MeasureString |
Public method | Restore | Sets the state of the current graphics object to what it was when SMath.Manager.IGraphics.Save was last called.
Public method | Rotate |
Public method | Save | Stores state of the current graphics object.
Public method | SaveAndClip | Stores state of the current graphics object and sets the clipping rectanle afterwards.
Public method | Scale |
Public method | Translate |
Public method | UnwrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Clear Method

IGraphicsClear Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Clear(
    Color color
)
Sub Clear (
    color As Color
)
void Clear(
    Color color
)
abstract Clear :
        color : Color -> unit

Parameters

color
Type: System.DrawingColor
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawBezier Method

IGraphicsDrawBezier Method

Draws a Bézier spline defined by four PointF structures.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawBezier(
    ColorPen pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Sub DrawBezier (
    pen As ColorPen,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
void DrawBezier(
    ColorPen^ pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
abstract DrawBezier :
        pen : ColorPen *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

pen
Type: SMath.DrawingColorPen
Pen that determines the color and width of the curve.
point1
Type: System.DrawingPointF
PointF structure that represents the starting point of the curve.
point2
Type: System.DrawingPointF
PointF structure that represents the first control point for the curve.
point3
Type: System.DrawingPointF
PointF structure that represents the second control point for the curve.
point4
Type: System.DrawingPointF
PointF structure that represents the ending point of the curve.
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawEllipse Method

IGraphicsDrawEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawEllipse(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Sub DrawEllipse (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
void DrawEllipse(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
)
abstract DrawEllipse :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawImage Method

IGraphicsDrawImage Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawImage(
    IBitmap bmp,
    RectangleF destRect,
    RectangleF srcRect
)
Sub DrawImage (
    bmp As IBitmap,
    destRect As RectangleF,
    srcRect As RectangleF
)
void DrawImage(
    IBitmap^ bmp,
    RectangleF destRect,
    RectangleF srcRect
)
abstract DrawImage :
        bmp : IBitmap *
        destRect : RectangleF *
        srcRect : RectangleF -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
destRect
Type: System.DrawingRectangleF
srcRect
Type: System.DrawingRectangleF
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawLine Method

IGraphicsDrawLine Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawLine(
    ColorPen pen,
    float x1,
    float y1,
    float x2,
    float y2
)
Sub DrawLine (
    pen As ColorPen,
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
)
void DrawLine(
    ColorPen^ pen,
    float x1,
    float y1,
    float x2,
    float y2
)
abstract DrawLine :
        pen : ColorPen *
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x1
Type: SystemSingle
y1
Type: SystemSingle
x2
Type: SystemSingle
y2
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawPath Method

IGraphicsDrawPath Method

Draws a PathStep array.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RectangleF DrawPath(
    ColorPen pen,
    PathStep[] steps,
    bool closed
)
Function DrawPath (
    pen As ColorPen,
    steps As PathStep(),
    closed As Boolean
) As RectangleF
RectangleF DrawPath(
    ColorPen^ pen,
    array<PathStep^>^ steps,
    bool closed
)
abstract DrawPath :
        pen : ColorPen *
        steps : PathStep[] *
        closed : bool -> RectangleF

Parameters

pen
Type: SMath.DrawingColorPen
Pen that determines the color and width of the curve.
steps
Type: SMath.DrawingPathStep
closed
Type: SystemBoolean
Close the current contour. If the current point is not equal to the first point of the contour, a line segment is automatically added.

Return Value

Type: RectangleF
Returns the bounds of the control points of the path.
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawPolyline Method

IGraphicsDrawPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawPolyline(
    ColorPen pen,
    PointF[] points
)
Sub DrawPolyline (
    pen As ColorPen,
    points As PointF()
)
void DrawPolyline(
    ColorPen^ pen,
    array<PointF>^ points
)
abstract DrawPolyline :
        pen : ColorPen *
        points : PointF[] -> unit

Parameters

pen
Type: SMath.DrawingColorPen
points
Type: System.DrawingPointF
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawRectangle Method

IGraphicsDrawRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Sub DrawRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
void DrawRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
)
abstract DrawRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawRoundedRectangle Method

IGraphicsDrawRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawRoundedRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Sub DrawRoundedRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
void DrawRoundedRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
abstract DrawRoundedRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.DrawString Method

IGraphicsDrawString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void DrawString(
    string text,
    FontInfo font,
    ColorBrush brush,
    float x,
    float y,
    float width,
    StringOptions format
)
Sub DrawString (
    text As String,
    font As FontInfo,
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    format As StringOptions
)
void DrawString(
    String^ text,
    FontInfo^ font,
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    StringOptions^ format
)
abstract DrawString :
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        format : StringOptions -> unit

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillBezier Method

IGraphicsFillBezier Method

Fills a Bézier spline defined by four PointF structures.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void FillBezier(
    ColorBrush brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Sub FillBezier (
    brush As ColorBrush,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
void FillBezier(
    ColorBrush^ brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
abstract FillBezier :
        brush : ColorBrush *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
Brush that determines the color of the fill.
point1
Type: System.DrawingPointF
PointF structure that represents the starting point of the curve.
point2
Type: System.DrawingPointF
PointF structure that represents the first control point for the curve.
point3
Type: System.DrawingPointF
PointF structure that represents the second control point for the curve.
point4
Type: System.DrawingPointF
PointF structure that represents the ending point of the curve.
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillEllipse Method

IGraphicsFillEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void FillEllipse(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Sub FillEllipse (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
void FillEllipse(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
)
abstract FillEllipse :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillPath Method

IGraphicsFillPath Method

Fills the interior of a PathStep array.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
RectangleF FillPath(
    ColorBrush brush,
    PathStep[] steps
)
Function FillPath (
    brush As ColorBrush,
    steps As PathStep()
) As RectangleF
RectangleF FillPath(
    ColorBrush^ brush,
    array<PathStep^>^ steps
)
abstract FillPath :
        brush : ColorBrush *
        steps : PathStep[] -> RectangleF

Parameters

brush
Type: SMath.DrawingColorBrush
Brush that determines the color of the fill.
steps
Type: SMath.DrawingPathStep

Return Value

Type: RectangleF
Returns the bounds of the control points of the path.
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillPolyline Method

IGraphicsFillPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void FillPolyline(
    ColorBrush brush,
    PointF[] points
)
Sub FillPolyline (
    brush As ColorBrush,
    points As PointF()
)
void FillPolyline(
    ColorBrush^ brush,
    array<PointF>^ points
)
abstract FillPolyline :
        brush : ColorBrush *
        points : PointF[] -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
points
Type: System.DrawingPointF
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillRectangle Method

IGraphicsFillRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void FillRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Sub FillRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
void FillRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
)
abstract FillRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.FillRoundedRectangle Method

IGraphicsFillRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void FillRoundedRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Sub FillRoundedRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
void FillRoundedRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
abstract FillRoundedRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.MeasureString Method

IGraphicsMeasureString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
SizeF MeasureString(
    string text,
    FontInfo font,
    float width,
    StringOptions format
)
Function MeasureString (
    text As String,
    font As FontInfo,
    width As Single,
    format As StringOptions
) As SizeF
SizeF MeasureString(
    String^ text,
    FontInfo^ font,
    float width,
    StringOptions^ format
)
abstract MeasureString :
        text : string *
        font : FontInfo *
        width : float32 *
        format : StringOptions -> SizeF

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions

Return Value

Type: SizeF
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Restore Method

IGraphicsRestore Method

Sets the state of the current graphics object to what it was when SMath.Manager.IGraphics.Save was last called.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Restore()
Sub Restore
void Restore()
abstract Restore : unit -> unit
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Rotate Method

IGraphicsRotate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Rotate(
    float degrees
)
Sub Rotate (
    degrees As Single
)
void Rotate(
    float degrees
)
abstract Rotate :
        degrees : float32 -> unit

Parameters

degrees
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Save Method

IGraphicsSave Method

Stores state of the current graphics object.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.SaveAndClip Method

IGraphicsSaveAndClip Method

Stores state of the current graphics object and sets the clipping rectanle afterwards.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void SaveAndClip(
    RectangleF bounds
)
Sub SaveAndClip (
    bounds As RectangleF
)
void SaveAndClip(
    RectangleF bounds
)
abstract SaveAndClip :
        bounds : RectangleF -> unit

Parameters

bounds
Type: System.DrawingRectangleF
Modifies the clipping path to be the intersection of the current path and the supplied rectangle.
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Scale Method

IGraphicsScale Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Scale(
    float scaleX,
    float scaleY
)
Sub Scale (
    scaleX As Single,
    scaleY As Single
)
void Scale(
    float scaleX,
    float scaleY
)
abstract Scale :
        scaleX : float32 *
        scaleY : float32 -> unit

Parameters

scaleX
Type: SystemSingle
scaleY
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Translate Method

IGraphicsTranslate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Translate(
    float x,
    float y
)
Sub Translate (
    x As Single,
    y As Single
)
void Translate(
    float x,
    float y
)
abstract Translate :
        x : float32 *
        y : float32 -> unit

Parameters

x
Type: SystemSingle
y
Type: SystemSingle
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


IGraphics.Unwrap(T) Method

IGraphicsUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
T Unwrap<T>()
where T : class

Function Unwrap(Of T As Class) As T
generic<typename T>
where T : ref class
T Unwrap()
abstract Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T
See Also

Reference

IGraphics Interface
SMath.Drawing Namespace


ISystemSpecifics Interface

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface ISystemSpecifics
Public Interface ISystemSpecifics
public interface class ISystemSpecifics
type ISystemSpecifics =  interface end

The ISystemSpecifics type exposes the following members.

Properties
 | Name | Description
Public property | DoubleClickTime |
Public property | PaperId |
Public property | PaperSize |
Public property | Platform |
Public property | ScrollbarWidth |
Top
Methods
 | Name | Description
Public method | BitmapFromResources |
Public method | BitmapToStream |
Public method | FileToBitmap |
Public method | OpenUrl |
Public method | ShowAlert |
Public method | StreamToBitmap(Stream) |
Public method | StreamToBitmap(Stream, Boolean) |
Top
See Also

Reference

SMath.Drawing Namespace


ISystemSpecifics Properties

The ISystemSpecifics type exposes the following members.

Properties
 | Name | Description
Public property | DoubleClickTime |
Public property | PaperId |
Public property | PaperSize |
Public property | Platform |
Public property | ScrollbarWidth |
Top
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.DoubleClickTime Property

ISystemSpecificsDoubleClickTime Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
double DoubleClickTime { get; }
ReadOnly Property DoubleClickTime As Double
    Get
property double DoubleClickTime {
    double get ();
}
abstract DoubleClickTime : float with get

Property Value

Type: Double
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.PaperId Property

ISystemSpecificsPaperId Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int PaperId { get; }
ReadOnly Property PaperId As Integer
    Get
property int PaperId {
    int get ();
}
abstract PaperId : int with get

Property Value

Type: Int32
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.PaperSize Property

ISystemSpecificsPaperSize Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Size PaperSize { get; }
ReadOnly Property PaperSize As Size
    Get
property Size PaperSize {
    Size get ();
}
abstract PaperSize : Size with get

Property Value

Type: Size
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.Platform Property

ISystemSpecificsPlatform Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
PlatformType Platform { get; }
ReadOnly Property Platform As PlatformType
    Get
property PlatformType Platform {
    PlatformType get ();
}
abstract Platform : PlatformType with get

Property Value

Type: PlatformType
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.ScrollbarWidth Property

ISystemSpecificsScrollbarWidth Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int ScrollbarWidth { get; }
ReadOnly Property ScrollbarWidth As Integer
    Get
property int ScrollbarWidth {
    int get ();
}
abstract ScrollbarWidth : int with get

Property Value

Type: Int32
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics Methods

The ISystemSpecifics type exposes the following members.

Methods
 | Name | Description
Public method | BitmapFromResources |
Public method | BitmapToStream |
Public method | FileToBitmap |
Public method | OpenUrl |
Public method | ShowAlert |
Public method | StreamToBitmap(Stream) |
Public method | StreamToBitmap(Stream, Boolean) |
Top
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.BitmapFromResources Method

ISystemSpecificsBitmapFromResources Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap BitmapFromResources(
    Assembly assembly,
    string resourceName
)
Function BitmapFromResources (
    assembly As Assembly,
    resourceName As String
) As IBitmap
IBitmap^ BitmapFromResources(
    Assembly^ assembly,
    String^ resourceName
)
abstract BitmapFromResources :
        assembly : Assembly *
        resourceName : string -> IBitmap

Parameters

assembly
Type: System.ReflectionAssembly
resourceName
Type: SystemString

Return Value

Type: IBitmap
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.BitmapToStream Method

ISystemSpecificsBitmapToStream Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void BitmapToStream(
    IBitmap bmp,
    Stream ms,
    BitmapFormat format
)
Sub BitmapToStream (
    bmp As IBitmap,
    ms As Stream,
    format As BitmapFormat
)
void BitmapToStream(
    IBitmap^ bmp,
    Stream^ ms,
    BitmapFormat format
)
abstract BitmapToStream :
        bmp : IBitmap *
        ms : Stream *
        format : BitmapFormat -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
ms
Type: System.IOStream
format
Type: SMath.DrawingBitmapFormat
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.FileToBitmap Method

ISystemSpecificsFileToBitmap Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap FileToBitmap(
    string fileName
)
Function FileToBitmap (
    fileName As String
) As IBitmap
IBitmap^ FileToBitmap(
    String^ fileName
)
abstract FileToBitmap :
        fileName : string -> IBitmap

Parameters

fileName
Type: SystemString

Return Value

Type: IBitmap
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.OpenUrl Method

ISystemSpecificsOpenUrl Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void OpenUrl(
    string url
)
Sub OpenUrl (
    url As String
)
void OpenUrl(
    String^ url
)
abstract OpenUrl :
        url : string -> unit

Parameters

url
Type: SystemString
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.ShowAlert Method

ISystemSpecificsShowAlert Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ShowAlert(
    string message,
    string title
)
Sub ShowAlert (
    message As String,
    title As String
)
void ShowAlert(
    String^ message,
    String^ title
)
abstract ShowAlert :
        message : string *
        title : string -> unit

Parameters

message
Type: SystemString
title
Type: SystemString
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.StreamToBitmap Method

ISystemSpecificsStreamToBitmap Method

Overload List
 | Name | Description
Public method | StreamToBitmap(Stream) |
Public method | StreamToBitmap(Stream, Boolean) |
Top
See Also

Reference

ISystemSpecifics Interface
SMath.Drawing Namespace


ISystemSpecifics.StreamToBitmap Method (Stream)

ISystemSpecificsStreamToBitmap Method (Stream)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap StreamToBitmap(
    Stream memstream
)
Function StreamToBitmap (
    memstream As Stream
) As IBitmap
IBitmap^ StreamToBitmap(
    Stream^ memstream
)
abstract StreamToBitmap :
        memstream : Stream -> IBitmap

Parameters

memstream
Type: System.IOStream

Return Value

Type: IBitmap
See Also

Reference

ISystemSpecifics Interface
StreamToBitmap Overload
SMath.Drawing Namespace


ISystemSpecifics.StreamToBitmap Method (Stream, Boolean)

ISystemSpecificsStreamToBitmap Method (Stream, Boolean)

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IBitmap StreamToBitmap(
    Stream memstream,
    bool arg
)
Function StreamToBitmap (
    memstream As Stream,
    arg As Boolean
) As IBitmap
IBitmap^ StreamToBitmap(
    Stream^ memstream,
    bool arg
)
abstract StreamToBitmap :
        memstream : Stream *
        arg : bool -> IBitmap

Parameters

memstream
Type: System.IOStream
arg
Type: SystemBoolean

Return Value

Type: IBitmap
See Also

Reference

ISystemSpecifics Interface
StreamToBitmap Overload
SMath.Drawing Namespace


LinearGradientColorBrush Class

Inheritance Hierarchy
SystemObject
SMath.DrawingColorBrush
SMath.DrawingLinearGradientColorBrush

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class LinearGradientColorBrush : ColorBrush
Public Class LinearGradientColorBrush
    Inherits ColorBrush
public ref class LinearGradientColorBrush : public ColorBrush
type LinearGradientColorBrush =
    class
        inherit ColorBrush
    end

The LinearGradientColorBrush type exposes the following members.

Constructors
 | Name | Description
Public method | LinearGradientColorBrush | Initializes a new instance of the LinearGradientColorBrush class
Top
Properties
 | Name | Description
Public property | Color | (Inherited from ColorBrush.)
Public property | Color2 |
Public property | EndPoint |
Public property | StartPoint |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


LinearGradientColorBrush Constructor

Initializes a new instance of the LinearGradientColorBrush class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public LinearGradientColorBrush(
    PointF startPnt,
    PointF endPnt,
    Color startColor,
    Color endColor
)
Public Sub New (
    startPnt As PointF,
    endPnt As PointF,
    startColor As Color,
    endColor As Color
)
public:
LinearGradientColorBrush(
    PointF startPnt,
    PointF endPnt,
    Color startColor,
    Color endColor
)
new :
        startPnt : PointF *
        endPnt : PointF *
        startColor : Color *
        endColor : Color -> LinearGradientColorBrush

Parameters

startPnt
Type: System.DrawingPointF
endPnt
Type: System.DrawingPointF
startColor
Type: System.DrawingColor
endColor
Type: System.DrawingColor
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


LinearGradientColorBrush Properties

The LinearGradientColorBrush type exposes the following members.

Properties
 | Name | Description
Public property | Color | (Inherited from ColorBrush.)
Public property | Color2 |
Public property | EndPoint |
Public property | StartPoint |
Top
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


LinearGradientColorBrush.Color2 Property

LinearGradientColorBrushColor2 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color Color2 { get; set; }
Public Property Color2 As Color
    Get
    Set
public:
property Color Color2 {
    Color get ();
    void set (Color value);
}
member Color2 : Color with get, set

Property Value

Type: Color
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


LinearGradientColorBrush.EndPoint Property

LinearGradientColorBrushEndPoint Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF EndPoint { get; set; }
Public Property EndPoint As PointF
    Get
    Set
public:
property PointF EndPoint {
    PointF get ();
    void set (PointF value);
}
member EndPoint : PointF with get, set

Property Value

Type: PointF
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


LinearGradientColorBrush.StartPoint Property

LinearGradientColorBrushStartPoint Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF StartPoint { get; set; }
Public Property StartPoint As PointF
    Get
    Set
public:
property PointF StartPoint {
    PointF get ();
    void set (PointF value);
}
member StartPoint : PointF with get, set

Property Value

Type: PointF
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


LinearGradientColorBrush Methods

The LinearGradientColorBrush type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinearGradientColorBrush Class
SMath.Drawing Namespace


PathArcTo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathLineTo
SMath.DrawingPathArcTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PathArcTo : PathLineTo
Public Class PathArcTo
    Inherits PathLineTo
public ref class PathArcTo : public PathLineTo
type PathArcTo =
    class
        inherit PathLineTo
    end

The PathArcTo type exposes the following members.

Constructors
 | Name | Description
Public method | PathArcTo | Initializes a new instance of the PathArcTo class
Top
Properties
 | Name | Description
Public property | Height |
Public property | StartAngle |
Public property | SweepAngle |
Public property | Width |
Public property | X | (Inherited from PathLineTo.)
Public property | Y | (Inherited from PathLineTo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathArcTo Constructor

Initializes a new instance of the PathArcTo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PathArcTo(
    float x,
    float y,
    float width,
    float height,
    float startAngle,
    float sweepAngle
)
Public Sub New (
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    startAngle As Single,
    sweepAngle As Single
)
public:
PathArcTo(
    float x,
    float y,
    float width,
    float height,
    float startAngle,
    float sweepAngle
)
new :
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        startAngle : float32 *
        sweepAngle : float32 -> PathArcTo

Parameters

x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
startAngle
Type: SystemSingle
sweepAngle
Type: SystemSingle
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo Properties

The PathArcTo type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | StartAngle |
Public property | SweepAngle |
Public property | Width |
Public property | X | (Inherited from PathLineTo.)
Public property | Y | (Inherited from PathLineTo.)
Top
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo.Height Property

PathArcToHeight Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Height { get; set; }
Public Property Height As Single
    Get
    Set
public:
property float Height {
    float get ();
    void set (float value);
}
member Height : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo.StartAngle Property

PathArcToStartAngle Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float StartAngle { get; set; }
Public Property StartAngle As Single
    Get
    Set
public:
property float StartAngle {
    float get ();
    void set (float value);
}
member StartAngle : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo.SweepAngle Property

PathArcToSweepAngle Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float SweepAngle { get; set; }
Public Property SweepAngle As Single
    Get
    Set
public:
property float SweepAngle {
    float get ();
    void set (float value);
}
member SweepAngle : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo.Width Property

PathArcToWidth Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Width { get; set; }
Public Property Width As Single
    Get
    Set
public:
property float Width {
    float get ();
    void set (float value);
}
member Width : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathArcTo Methods

The PathArcTo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathArcTo Class
SMath.Drawing Namespace


PathCubicTo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathCubicTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PathCubicTo : PathStep
Public Class PathCubicTo
    Inherits PathStep
public ref class PathCubicTo : public PathStep
type PathCubicTo =
    class
        inherit PathStep
    end

The PathCubicTo type exposes the following members.

Constructors
 | Name | Description
Public method | PathCubicTo | Initializes a new instance of the PathCubicTo class
Top
Properties
 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | Point3 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathCubicTo Constructor

Initializes a new instance of the PathCubicTo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PathCubicTo(
    PointF point1,
    PointF point2,
    PointF point3
)
Public Sub New (
    point1 As PointF,
    point2 As PointF,
    point3 As PointF
)
public:
PathCubicTo(
    PointF point1,
    PointF point2,
    PointF point3
)
new :
        point1 : PointF *
        point2 : PointF *
        point3 : PointF -> PathCubicTo

Parameters

point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
point3
Type: System.DrawingPointF
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathCubicTo Properties

The PathCubicTo type exposes the following members.

Properties
 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | Point3 |
Top
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathCubicTo.Point1 Property

PathCubicToPoint1 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point1 { get; set; }
Public Property Point1 As PointF
    Get
    Set
public:
property PointF Point1 {
    PointF get ();
    void set (PointF value);
}
member Point1 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathCubicTo.Point2 Property

PathCubicToPoint2 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point2 { get; set; }
Public Property Point2 As PointF
    Get
    Set
public:
property PointF Point2 {
    PointF get ();
    void set (PointF value);
}
member Point2 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathCubicTo.Point3 Property

PathCubicToPoint3 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point3 { get; set; }
Public Property Point3 As PointF
    Get
    Set
public:
property PointF Point3 {
    PointF get ();
    void set (PointF value);
}
member Point3 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathCubicTo Methods

The PathCubicTo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathCubicTo Class
SMath.Drawing Namespace


PathLineTo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathLineTo
SMath.DrawingPathArcTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PathLineTo : PathStep
Public Class PathLineTo
    Inherits PathStep
public ref class PathLineTo : public PathStep
type PathLineTo =
    class
        inherit PathStep
    end

The PathLineTo type exposes the following members.

Constructors
 | Name | Description
Public method | PathLineTo | Initializes a new instance of the PathLineTo class
Top
Properties
 | Name | Description
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathLineTo Constructor

Initializes a new instance of the PathLineTo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PathLineTo(
    float x,
    float y
)
Public Sub New (
    x As Single,
    y As Single
)
public:
PathLineTo(
    float x,
    float y
)
new :
        x : float32 *
        y : float32 -> PathLineTo

Parameters

x
Type: SystemSingle
y
Type: SystemSingle
See Also

Reference

PathLineTo Class
SMath.Drawing Namespace


PathLineTo Properties

The PathLineTo type exposes the following members.

Properties
 | Name | Description
Public property | X |
Public property | Y |
Top
See Also

Reference

PathLineTo Class
SMath.Drawing Namespace


PathLineTo.X Property

PathLineToX Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float X { get; set; }
Public Property X As Single
    Get
    Set
public:
property float X {
    float get ();
    void set (float value);
}
member X : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathLineTo Class
SMath.Drawing Namespace


PathLineTo.Y Property

PathLineToY Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
public:
property float Y {
    float get ();
    void set (float value);
}
member Y : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathLineTo Class
SMath.Drawing Namespace


PathLineTo Methods

The PathLineTo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathLineTo Class
SMath.Drawing Namespace


PathMoveTo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathMoveTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PathMoveTo : PathStep
Public Class PathMoveTo
    Inherits PathStep
public ref class PathMoveTo : public PathStep
type PathMoveTo =
    class
        inherit PathStep
    end

The PathMoveTo type exposes the following members.

Constructors
 | Name | Description
Public method | PathMoveTo | Initializes a new instance of the PathMoveTo class
Top
Properties
 | Name | Description
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathMoveTo Constructor

Initializes a new instance of the PathMoveTo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PathMoveTo(
    float x,
    float y
)
Public Sub New (
    x As Single,
    y As Single
)
public:
PathMoveTo(
    float x,
    float y
)
new :
        x : float32 *
        y : float32 -> PathMoveTo

Parameters

x
Type: SystemSingle
y
Type: SystemSingle
See Also

Reference

PathMoveTo Class
SMath.Drawing Namespace


PathMoveTo Properties

The PathMoveTo type exposes the following members.

Properties
 | Name | Description
Public property | X |
Public property | Y |
Top
See Also

Reference

PathMoveTo Class
SMath.Drawing Namespace


PathMoveTo.X Property

PathMoveToX Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float X { get; set; }
Public Property X As Single
    Get
    Set
public:
property float X {
    float get ();
    void set (float value);
}
member X : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathMoveTo Class
SMath.Drawing Namespace


PathMoveTo.Y Property

PathMoveToY Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
public:
property float Y {
    float get ();
    void set (float value);
}
member Y : float32 with get, set

Property Value

Type: Single
See Also

Reference

PathMoveTo Class
SMath.Drawing Namespace


PathMoveTo Methods

The PathMoveTo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathMoveTo Class
SMath.Drawing Namespace


PathQuadCurveTo Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathQuadCurveTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PathQuadCurveTo : PathStep
Public Class PathQuadCurveTo
    Inherits PathStep
public ref class PathQuadCurveTo : public PathStep
type PathQuadCurveTo =
    class
        inherit PathStep
    end

The PathQuadCurveTo type exposes the following members.

Constructors
 | Name | Description
Public method | PathQuadCurveTo | Initializes a new instance of the PathQuadCurveTo class
Top
Properties
 | Name | Description
Public property | Point1 |
Public property | Point2 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathQuadCurveTo Constructor

Initializes a new instance of the PathQuadCurveTo class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PathQuadCurveTo(
    PointF point1,
    PointF point2
)
Public Sub New (
    point1 As PointF,
    point2 As PointF
)
public:
PathQuadCurveTo(
    PointF point1,
    PointF point2
)
new :
        point1 : PointF *
        point2 : PointF -> PathQuadCurveTo

Parameters

point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
See Also

Reference

PathQuadCurveTo Class
SMath.Drawing Namespace


PathQuadCurveTo Properties

The PathQuadCurveTo type exposes the following members.

Properties
 | Name | Description
Public property | Point1 |
Public property | Point2 |
Top
See Also

Reference

PathQuadCurveTo Class
SMath.Drawing Namespace


PathQuadCurveTo.Point1 Property

PathQuadCurveToPoint1 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point1 { get; set; }
Public Property Point1 As PointF
    Get
    Set
public:
property PointF Point1 {
    PointF get ();
    void set (PointF value);
}
member Point1 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

PathQuadCurveTo Class
SMath.Drawing Namespace


PathQuadCurveTo.Point2 Property

PathQuadCurveToPoint2 Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Point2 { get; set; }
Public Property Point2 As PointF
    Get
    Set
public:
property PointF Point2 {
    PointF get ();
    void set (PointF value);
}
member Point2 : PointF with get, set

Property Value

Type: PointF
See Also

Reference

PathQuadCurveTo Class
SMath.Drawing Namespace


PathQuadCurveTo Methods

The PathQuadCurveTo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathQuadCurveTo Class
SMath.Drawing Namespace


PathStep Class

Inheritance Hierarchy
SystemObject
SMath.DrawingPathStep
SMath.DrawingPathCubicTo
SMath.DrawingPathLineTo
SMath.DrawingPathMoveTo
SMath.DrawingPathQuadCurveTo

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PathStep
Public MustInherit Class PathStep
public ref class PathStep abstract
[<AbstractClassAttribute>]
type PathStep =  class end

The PathStep type exposes the following members.

Constructors
 | Name | Description
Protected method | PathStep | Initializes a new instance of the PathStep class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing Namespace


PathStep Constructor

Initializes a new instance of the PathStep class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected PathStep()
Protected Sub New
protected:
PathStep()
new : unit -> PathStep
See Also

Reference

PathStep Class
SMath.Drawing Namespace


PathStep Methods

The PathStep type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathStep Class
SMath.Drawing Namespace


PlatformType Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum PlatformType
Public Enumeration PlatformType
public enum class PlatformType
type PlatformType
Members
Member name | Value | Description
NotDefined | 0 |
PC | 1 |
PPC | 2 |
Smartphone | 3 |
Android | 4 |
IOS | 5 |
UniversalWindows | 6 |
See Also

Reference

SMath.Drawing Namespace


StringOptions Class

Inheritance Hierarchy
SystemObject
SMath.DrawingStringOptions

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class StringOptions
Public Class StringOptions
public ref class StringOptions
type StringOptions =  class end

The StringOptions type exposes the following members.

Constructors
 | Name | Description
Public method | StringOptions | Initializes a new instance of the StringOptions class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FormatFlags |
 | GenericDefault |
 | GenericTypographic |
Top
See Also

Reference

SMath.Drawing Namespace


StringOptions Constructor

Initializes a new instance of the StringOptions class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StringOptions()
Public Sub New
public:
StringOptions()
new : unit -> StringOptions
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptions Methods

The StringOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptions Fields

The StringOptions type exposes the following members.

Fields
 | Name | Description
Public field | FormatFlags |
 | GenericDefault |
 | GenericTypographic |
Top
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptions.FormatFlags Field

StringOptionsFormatFlags Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public StringOptionsFlags FormatFlags
Public FormatFlags As StringOptionsFlags
public:
StringOptionsFlags FormatFlags
val mutable FormatFlags: StringOptionsFlags

Field Value

Type: StringOptionsFlags
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptions.GenericDefault Field

StringOptionsGenericDefault Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static StringOptions GenericDefault
Public Shared GenericDefault As StringOptions
public:
static StringOptions^ GenericDefault
static val mutable GenericDefault: StringOptions

Field Value

Type: StringOptions
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptions.GenericTypographic Field

StringOptionsGenericTypographic Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static StringOptions GenericTypographic
Public Shared GenericTypographic As StringOptions
public:
static StringOptions^ GenericTypographic
static val mutable GenericTypographic: StringOptions

Field Value

Type: StringOptions
See Also

Reference

StringOptions Class
SMath.Drawing Namespace


StringOptionsFlags Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum StringOptionsFlags
<FlagsAttribute>
Public Enumeration StringOptionsFlags
[FlagsAttribute]
public enum class StringOptionsFlags
[<FlagsAttribute>]
type StringOptionsFlags
Members
Member name | Value | Description
DirectionRightToLeft | 1 |
DirectionVertical | 2 |
FitBlackBox | 4 |
DisplayFormatControl | 32 |
NoFontFallback | 1024 |
MeasureTrailingSpaces | 2048 |
NoWrap | 4096 |
LineLimit | 8192 |
NoClip | 16384 |
See Also

Reference

SMath.Drawing Namespace


StrokeStyle Enumeration

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum StrokeStyle
Public Enumeration StrokeStyle
public enum class StrokeStyle
type StrokeStyle
Members
Member name | Value | Description
Solid | 0 |
Dash | 1 |
Dot | 2 |
DashDot | 3 |
DashDotDot | 4 |
Custom | 5 |
See Also

Reference

SMath.Drawing Namespace


SvgGraphics Class

Inheritance Hierarchy
SystemObject
SMath.DrawingSvgGraphics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SvgGraphics : IGraphics,
    IDisposable
Public Class SvgGraphics
    Implements IGraphics, IDisposable
public ref class SvgGraphics : IGraphics,
    IDisposable
type SvgGraphics =
    class
        interface IGraphics
        interface IDisposable
    end

The SvgGraphics type exposes the following members.

Constructors
 | Name | Description
Public method | SvgGraphics | Initializes a new instance of the SvgGraphics class
Top
Properties
 | Name | Description
Public property | ClipBounds |
Public property | Dpi |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Dispose | Releases all resources used by the SvgGraphics
Public method | DrawBezier |
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath |
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillBezier |
Public method | FillEllipse |
Public method | FillPath |
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCustomFontCSSRule |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueClientId | Returns 22 length unique Id consists with letters, digits and underscore char. Created based on GUID structure.
Public method | MeasureString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore |
Public method | Rotate |
Public method | Save |
Public method | SaveAndClip |
Public method | Scale |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate |
Public method | UnwrapT |
Top
Fields
Name | Description
XMLNS |
XMLNS_XLINK |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
See Also

Reference

SMath.Drawing Namespace


SvgGraphics Constructor

Initializes a new instance of the SvgGraphics class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SvgGraphics(
    Stream stream,
    Size size,
    bool includeDeclaration,
    bool includeCustomFont,
    ISystemSpecifics tools
)
Public Sub New (
    stream As Stream,
    size As Size,
    includeDeclaration As Boolean,
    includeCustomFont As Boolean,
    tools As ISystemSpecifics
)
public:
SvgGraphics(
    Stream^ stream,
    Size size,
    bool includeDeclaration,
    bool includeCustomFont,
    ISystemSpecifics^ tools
)
new :
        stream : Stream *
        size : Size *
        includeDeclaration : bool *
        includeCustomFont : bool *
        tools : ISystemSpecifics -> SvgGraphics

Parameters

stream
Type: System.IOStream
size
Type: System.DrawingSize
includeDeclaration
Type: SystemBoolean
includeCustomFont
Type: SystemBoolean
tools
Type: SMath.DrawingISystemSpecifics
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics Properties

The SvgGraphics type exposes the following members.

Properties
 | Name | Description
Public property | ClipBounds |
Public property | Dpi |
Top
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.ClipBounds Property

SvgGraphicsClipBounds Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF ClipBounds { get; }
Public ReadOnly Property ClipBounds As RectangleF
    Get
public:
virtual property RectangleF ClipBounds {
    RectangleF get () sealed;
}
abstract ClipBounds : RectangleF with get
override ClipBounds : RectangleF with get

Property Value

Type: RectangleF

Implements

IGraphicsClipBounds
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Dpi Property

SvgGraphicsDpi Property

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Dpi { get; }
Public ReadOnly Property Dpi As Single
    Get
public:
virtual property float Dpi {
    float get () sealed;
}
abstract Dpi : float32 with get
override Dpi : float32 with get

Property Value

Type: Single

Implements

IGraphicsDpi
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics Methods

The SvgGraphics type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Dispose |
Public method | DrawBezier |
Public method | DrawEllipse |
Public method | DrawImage |
Public method | DrawLine |
Public method | DrawPath |
Public method | DrawPolyline |
Public method | DrawRectangle |
Public method | DrawRoundedRectangle |
Public method | DrawString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillBezier |
Public method | FillEllipse |
Public method | FillPath |
Public method | FillPolyline |
Public method | FillRectangle |
Public method | FillRoundedRectangle |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCustomFontCSSRule |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueClientId | Returns 22 length unique Id consists with letters, digits and underscore char. Created based on GUID structure.
Public method | MeasureString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Restore |
Public method | Rotate |
Public method | Save |
Public method | SaveAndClip |
Public method | Scale |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate |
Public method | UnwrapT |
Top
Extension Methods
 | Name | Description
Public Extension Method | DrawEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, PointF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, RectangleF) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawImage(IBitmap, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawLine | (Defined by GraphicsExtensions.)
Public Extension Method | DrawPath | Draws a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | DrawRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawString(String, FontInfo, ColorBrush, Single, Single, StringOptions) | Overloaded. (Defined by GraphicsExtensions.)
Public Extension Method | DrawSvgPath | Draws an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. (Defined by GraphicsExtensions.)
Public Extension Method | FillEllipse | (Defined by GraphicsExtensions.)
Public Extension Method | FillPath | Fills the interior of a PathStep array. (Defined by GraphicsExtensions.)
Public Extension Method | FillRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillRoundedRectangle | (Defined by GraphicsExtensions.)
Public Extension Method | FillSvgPath | Fills an SVG path. The following instructions supported: hHmMlLaAqQcCtTsSvVzZ. Limitation: - Only one argument can be used for hHvV. Note: - Using of zZ have no sence as path will be rendered closed for filling automatically. (Defined by GraphicsExtensions.)
Public Extension Method | MeasureString | (Defined by GraphicsExtensions.)
Public Extension Method | Scale | (Defined by GraphicsExtensions.)
Public Extension Method | Test | Testing of cross-platform graphics. (Defined by GraphicsExtensions.)
Top
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Clear Method

SvgGraphicsClear Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    Color color
)
Public Sub Clear (
    color As Color
)
public:
virtual void Clear(
    Color color
) sealed
abstract Clear :
        color : Color -> unit
override Clear :
        color : Color -> unit

Parameters

color
Type: System.DrawingColor

Implements

IGraphicsClear(Color)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Dispose Method

SvgGraphicsDispose Method

Releases all resources used by the SvgGraphics

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawBezier Method

SvgGraphicsDrawBezier Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawBezier(
    ColorPen pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Public Sub DrawBezier (
    pen As ColorPen,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
public:
virtual void DrawBezier(
    ColorPen^ pen,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
) sealed
abstract DrawBezier :
        pen : ColorPen *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit
override DrawBezier :
        pen : ColorPen *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

pen
Type: SMath.DrawingColorPen
point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
point3
Type: System.DrawingPointF
point4
Type: System.DrawingPointF

Implements

IGraphicsDrawBezier(ColorPen, PointF, PointF, PointF, PointF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawEllipse Method

SvgGraphicsDrawEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawEllipse(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Public Sub DrawEllipse (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void DrawEllipse(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
) sealed
abstract DrawEllipse :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override DrawEllipse :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsDrawEllipse(ColorPen, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawImage Method

SvgGraphicsDrawImage Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawImage(
    IBitmap bmp,
    RectangleF destRect,
    RectangleF srcRect
)
Public Sub DrawImage (
    bmp As IBitmap,
    destRect As RectangleF,
    srcRect As RectangleF
)
public:
virtual void DrawImage(
    IBitmap^ bmp,
    RectangleF destRect,
    RectangleF srcRect
) sealed
abstract DrawImage :
        bmp : IBitmap *
        destRect : RectangleF *
        srcRect : RectangleF -> unit
override DrawImage :
        bmp : IBitmap *
        destRect : RectangleF *
        srcRect : RectangleF -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
destRect
Type: System.DrawingRectangleF
srcRect
Type: System.DrawingRectangleF

Implements

IGraphicsDrawImage(IBitmap, RectangleF, RectangleF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawLine Method

SvgGraphicsDrawLine Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawLine(
    ColorPen pen,
    float x1,
    float y1,
    float x2,
    float y2
)
Public Sub DrawLine (
    pen As ColorPen,
    x1 As Single,
    y1 As Single,
    x2 As Single,
    y2 As Single
)
public:
virtual void DrawLine(
    ColorPen^ pen,
    float x1,
    float y1,
    float x2,
    float y2
) sealed
abstract DrawLine :
        pen : ColorPen *
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> unit
override DrawLine :
        pen : ColorPen *
        x1 : float32 *
        y1 : float32 *
        x2 : float32 *
        y2 : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x1
Type: SystemSingle
y1
Type: SystemSingle
x2
Type: SystemSingle
y2
Type: SystemSingle

Implements

IGraphicsDrawLine(ColorPen, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawPath Method

SvgGraphicsDrawPath Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF DrawPath(
    ColorPen pen,
    PathStep[] steps,
    bool closed
)
Public Function DrawPath (
    pen As ColorPen,
    steps As PathStep(),
    closed As Boolean
) As RectangleF
public:
virtual RectangleF DrawPath(
    ColorPen^ pen,
    array<PathStep^>^ steps,
    bool closed
) sealed
abstract DrawPath :
        pen : ColorPen *
        steps : PathStep[] *
        closed : bool -> RectangleF
override DrawPath :
        pen : ColorPen *
        steps : PathStep[] *
        closed : bool -> RectangleF

Parameters

pen
Type: SMath.DrawingColorPen
steps
Type: SMath.DrawingPathStep
closed
Type: SystemBoolean

Return Value

Type: RectangleF

Implements

IGraphicsDrawPath(ColorPen, PathStep, Boolean)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawPolyline Method

SvgGraphicsDrawPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawPolyline(
    ColorPen pen,
    PointF[] points
)
Public Sub DrawPolyline (
    pen As ColorPen,
    points As PointF()
)
public:
virtual void DrawPolyline(
    ColorPen^ pen,
    array<PointF>^ points
) sealed
abstract DrawPolyline :
        pen : ColorPen *
        points : PointF[] -> unit
override DrawPolyline :
        pen : ColorPen *
        points : PointF[] -> unit

Parameters

pen
Type: SMath.DrawingColorPen
points
Type: System.DrawingPointF

Implements

IGraphicsDrawPolyline(ColorPen, PointF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawRectangle Method

SvgGraphicsDrawRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height
)
Public Sub DrawRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void DrawRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height
) sealed
abstract DrawRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override DrawRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsDrawRectangle(ColorPen, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawRoundedRectangle Method

SvgGraphicsDrawRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawRoundedRectangle(
    ColorPen pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Public Sub DrawRoundedRectangle (
    pen As ColorPen,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
public:
virtual void DrawRoundedRectangle(
    ColorPen^ pen,
    float x,
    float y,
    float width,
    float height,
    float arcSize
) sealed
abstract DrawRoundedRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit
override DrawRoundedRectangle :
        pen : ColorPen *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

pen
Type: SMath.DrawingColorPen
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle

Implements

IGraphicsDrawRoundedRectangle(ColorPen, Single, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.DrawString Method

SvgGraphicsDrawString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawString(
    string text,
    FontInfo font,
    ColorBrush brush,
    float x,
    float y,
    float width,
    StringOptions format
)
Public Sub DrawString (
    text As String,
    font As FontInfo,
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    format As StringOptions
)
public:
virtual void DrawString(
    String^ text,
    FontInfo^ font,
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    StringOptions^ format
) sealed
abstract DrawString :
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        format : StringOptions -> unit
override DrawString :
        text : string *
        font : FontInfo *
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        format : StringOptions -> unit

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions

Implements

IGraphicsDrawString(String, FontInfo, ColorBrush, Single, Single, Single, StringOptions)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillBezier Method

SvgGraphicsFillBezier Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillBezier(
    ColorBrush brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
)
Public Sub FillBezier (
    brush As ColorBrush,
    point1 As PointF,
    point2 As PointF,
    point3 As PointF,
    point4 As PointF
)
public:
virtual void FillBezier(
    ColorBrush^ brush,
    PointF point1,
    PointF point2,
    PointF point3,
    PointF point4
) sealed
abstract FillBezier :
        brush : ColorBrush *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit
override FillBezier :
        brush : ColorBrush *
        point1 : PointF *
        point2 : PointF *
        point3 : PointF *
        point4 : PointF -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
point1
Type: System.DrawingPointF
point2
Type: System.DrawingPointF
point3
Type: System.DrawingPointF
point4
Type: System.DrawingPointF

Implements

IGraphicsFillBezier(ColorBrush, PointF, PointF, PointF, PointF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillEllipse Method

SvgGraphicsFillEllipse Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillEllipse(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Public Sub FillEllipse (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void FillEllipse(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
) sealed
abstract FillEllipse :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override FillEllipse :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsFillEllipse(ColorBrush, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillPath Method

SvgGraphicsFillPath Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF FillPath(
    ColorBrush brush,
    PathStep[] steps
)
Public Function FillPath (
    brush As ColorBrush,
    steps As PathStep()
) As RectangleF
public:
virtual RectangleF FillPath(
    ColorBrush^ brush,
    array<PathStep^>^ steps
) sealed
abstract FillPath :
        brush : ColorBrush *
        steps : PathStep[] -> RectangleF
override FillPath :
        brush : ColorBrush *
        steps : PathStep[] -> RectangleF

Parameters

brush
Type: SMath.DrawingColorBrush
steps
Type: SMath.DrawingPathStep

Return Value

Type: RectangleF

Implements

IGraphicsFillPath(ColorBrush, PathStep)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillPolyline Method

SvgGraphicsFillPolyline Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillPolyline(
    ColorBrush brush,
    PointF[] points
)
Public Sub FillPolyline (
    brush As ColorBrush,
    points As PointF()
)
public:
virtual void FillPolyline(
    ColorBrush^ brush,
    array<PointF>^ points
) sealed
abstract FillPolyline :
        brush : ColorBrush *
        points : PointF[] -> unit
override FillPolyline :
        brush : ColorBrush *
        points : PointF[] -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
points
Type: System.DrawingPointF

Implements

IGraphicsFillPolyline(ColorBrush, PointF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillRectangle Method

SvgGraphicsFillRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height
)
Public Sub FillRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single
)
public:
virtual void FillRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height
) sealed
abstract FillRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit
override FillRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle

Implements

IGraphicsFillRectangle(ColorBrush, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.FillRoundedRectangle Method

SvgGraphicsFillRoundedRectangle Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void FillRoundedRectangle(
    ColorBrush brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
)
Public Sub FillRoundedRectangle (
    brush As ColorBrush,
    x As Single,
    y As Single,
    width As Single,
    height As Single,
    arcSize As Single
)
public:
virtual void FillRoundedRectangle(
    ColorBrush^ brush,
    float x,
    float y,
    float width,
    float height,
    float arcSize
) sealed
abstract FillRoundedRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit
override FillRoundedRectangle :
        brush : ColorBrush *
        x : float32 *
        y : float32 *
        width : float32 *
        height : float32 *
        arcSize : float32 -> unit

Parameters

brush
Type: SMath.DrawingColorBrush
x
Type: SystemSingle
y
Type: SystemSingle
width
Type: SystemSingle
height
Type: SystemSingle
arcSize
Type: SystemSingle

Implements

IGraphicsFillRoundedRectangle(ColorBrush, Single, Single, Single, Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.GetCustomFontCSSRule Method

SvgGraphicsGetCustomFontCSSRule Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetCustomFontCSSRule()
Public Shared Function GetCustomFontCSSRule As String
public:
static String^ GetCustomFontCSSRule()
static member GetCustomFontCSSRule : unit -> string

Return Value

Type: String
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.GetUniqueClientId Method

SvgGraphicsGetUniqueClientId Method

Returns 22 length unique Id consists with letters, digits and underscore char. Created based on GUID structure.

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetUniqueClientId()
Public Shared Function GetUniqueClientId As String
public:
static String^ GetUniqueClientId()
static member GetUniqueClientId : unit -> string

Return Value

Type: String
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.MeasureString Method

SvgGraphicsMeasureString Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SizeF MeasureString(
    string text,
    FontInfo font,
    float width,
    StringOptions format
)
Public Function MeasureString (
    text As String,
    font As FontInfo,
    width As Single,
    format As StringOptions
) As SizeF
public:
virtual SizeF MeasureString(
    String^ text,
    FontInfo^ font,
    float width,
    StringOptions^ format
) sealed
abstract MeasureString :
        text : string *
        font : FontInfo *
        width : float32 *
        format : StringOptions -> SizeF
override MeasureString :
        text : string *
        font : FontInfo *
        width : float32 *
        format : StringOptions -> SizeF

Parameters

text
Type: SystemString
font
Type: SMath.DrawingFontInfo
width
Type: SystemSingle
format
Type: SMath.DrawingStringOptions

Return Value

Type: SizeF

Implements

IGraphicsMeasureString(String, FontInfo, Single, StringOptions)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Restore Method

SvgGraphicsRestore Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Restore()
Public Sub Restore
public:
virtual void Restore() sealed
abstract Restore : unit -> unit
override Restore : unit -> unit

Implements

IGraphicsRestore
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Rotate Method

SvgGraphicsRotate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Rotate(
    float degrees
)
Public Sub Rotate (
    degrees As Single
)
public:
virtual void Rotate(
    float degrees
) sealed
abstract Rotate :
        degrees : float32 -> unit
override Rotate :
        degrees : float32 -> unit

Parameters

degrees
Type: SystemSingle

Implements

IGraphicsRotate(Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Save Method

SvgGraphicsSave Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implements

IGraphicsSave
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.SaveAndClip Method

SvgGraphicsSaveAndClip Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SaveAndClip(
    RectangleF bounds
)
Public Sub SaveAndClip (
    bounds As RectangleF
)
public:
virtual void SaveAndClip(
    RectangleF bounds
) sealed
abstract SaveAndClip :
        bounds : RectangleF -> unit
override SaveAndClip :
        bounds : RectangleF -> unit

Parameters

bounds
Type: System.DrawingRectangleF

Implements

IGraphicsSaveAndClip(RectangleF)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Scale Method

SvgGraphicsScale Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Scale(
    float scaleX,
    float scaleY
)
Public Sub Scale (
    scaleX As Single,
    scaleY As Single
)
public:
virtual void Scale(
    float scaleX,
    float scaleY
) sealed
abstract Scale :
        scaleX : float32 *
        scaleY : float32 -> unit
override Scale :
        scaleX : float32 *
        scaleY : float32 -> unit

Parameters

scaleX
Type: SystemSingle
scaleY
Type: SystemSingle

Implements

IGraphicsScale(Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Translate Method

SvgGraphicsTranslate Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Translate(
    float x,
    float y
)
Public Sub Translate (
    x As Single,
    y As Single
)
public:
virtual void Translate(
    float x,
    float y
) sealed
abstract Translate :
        x : float32 *
        y : float32 -> unit
override Translate :
        x : float32 *
        y : float32 -> unit

Parameters

x
Type: SystemSingle
y
Type: SystemSingle

Implements

IGraphicsTranslate(Single, Single)
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.Unwrap(T) Method

SvgGraphicsUnwrapT Method

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T Unwrap<T>()
where T : class

Public Function Unwrap(Of T As Class) As T
public:
generic<typename T>
where T : ref class
virtual T Unwrap() sealed
abstract Unwrap : unit -> 'T  when 'T : not struct
override Unwrap : unit -> 'T  when 'T : not struct

Type Parameters

T

Return Value

Type: T

Implements

IGraphicsUnwrapT
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics Fields

The SvgGraphics type exposes the following members.

Fields
Name | Description
XMLNS |
XMLNS_XLINK |
Top
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.XMLNS Field

SvgGraphicsXMLNS Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string XMLNS = "http://www.w3.org/2000/svg"
Public Const XMLNS As String = "http://www.w3.org/2000/svg"
public:
literal String^ XMLNS = "http://www.w3.org/2000/svg"
static val mutable XMLNS: string

Field Value

Type: String
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.XMLNS_XLINK Field

SvgGraphicsXMLNS_XLINK Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string XMLNS_XLINK = "http://www.w3.org/1999/xlink"
Public Const XMLNS_XLINK As String = "http://www.w3.org/1999/xlink"
public:
literal String^ XMLNS_XLINK = "http://www.w3.org/1999/xlink"
static val mutable XMLNS_XLINK: string

Field Value

Type: String
See Also

Reference

SvgGraphics Class
SMath.Drawing Namespace


SvgGraphics.SvgNotSupported Class

SvgGraphicsSvgNotSupported Class

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
SystemNotSupportedException
SMath.DrawingSvgGraphicsSvgNotSupported

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SvgNotSupported : NotSupportedException
Public Class SvgNotSupported
    Inherits NotSupportedException
public ref class SvgNotSupported : public NotSupportedException
type SvgNotSupported =
    class
        inherit NotSupportedException
    end

The SvgGraphicsSvgNotSupported type exposes the following members.

Constructors
 | Name | Description
Public method | SvgGraphicsSvgNotSupported | Initializes a new instance of the SvgGraphicsSvgNotSupported class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SMath.Drawing Namespace


SvgGraphics.SvgNotSupported Constructor

SvgGraphicsSvgNotSupported Constructor

Initializes a new instance of the SvgGraphicsSvgNotSupported class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SvgNotSupported()
Public Sub New
public:
SvgNotSupported()
new : unit -> SvgNotSupported
See Also

Reference

SvgGraphicsSvgNotSupported Class
SMath.Drawing Namespace


SvgNotSupported Properties

The SvgGraphicsSvgNotSupported type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SvgGraphicsSvgNotSupported Class
SMath.Drawing Namespace


SvgNotSupported Methods

The SvgGraphicsSvgNotSupported type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SvgGraphicsSvgNotSupported Class
SMath.Drawing Namespace


SystemColorBrushes Class

Inheritance Hierarchy
SystemObject
SMath.DrawingSystemColorBrushes

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SystemColorBrushes
Public Class SystemColorBrushes
public ref class SystemColorBrushes
type SystemColorBrushes =  class end

The SystemColorBrushes type exposes the following members.

Constructors
 | Name | Description
Public method | SystemColorBrushes | Initializes a new instance of the SystemColorBrushes class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ControlText |
Info |
Top
See Also

Reference

SMath.Drawing Namespace


SystemColorBrushes Constructor

Initializes a new instance of the SystemColorBrushes class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SystemColorBrushes()
Public Sub New
public:
SystemColorBrushes()
new : unit -> SystemColorBrushes
See Also

Reference

SystemColorBrushes Class
SMath.Drawing Namespace


SystemColorBrushes Methods

The SystemColorBrushes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemColorBrushes Class
SMath.Drawing Namespace


SystemColorBrushes Fields

The SystemColorBrushes type exposes the following members.

Fields
Name | Description
ControlText |
Info |
Top
See Also

Reference

SystemColorBrushes Class
SMath.Drawing Namespace


SystemColorBrushes.ControlText Field

SystemColorBrushesControlText Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush ControlText
Public Shared ControlText As ColorBrush
public:
static ColorBrush^ ControlText
static val mutable ControlText: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

SystemColorBrushes Class
SMath.Drawing Namespace


SystemColorBrushes.Info Field

SystemColorBrushesInfo Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ColorBrush Info
Public Shared Info As ColorBrush
public:
static ColorBrush^ Info
static val mutable Info: ColorBrush

Field Value

Type: ColorBrush
See Also

Reference

SystemColorBrushes Class
SMath.Drawing Namespace


SystemSpecificColors Class

Inheritance Hierarchy
SystemObject
SMath.DrawingSystemSpecificColors

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SystemSpecificColors
Public Class SystemSpecificColors
public ref class SystemSpecificColors
type SystemSpecificColors =  class end

The SystemSpecificColors type exposes the following members.

Constructors
 | Name | Description
Public method | SystemSpecificColors | Initializes a new instance of the SystemSpecificColors class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ButtonShadow |
Control |
ControlLight |
ControlLightLight |
ControlText |
Highlight |
HighlightText |
InactiveCaption |
Info |
InfoText |
Window |
WindowText |
Top
See Also

Reference

SMath.Drawing Namespace


SystemSpecificColors Constructor

Initializes a new instance of the SystemSpecificColors class

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SystemSpecificColors()
Public Sub New
public:
SystemSpecificColors()
new : unit -> SystemSpecificColors
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors Methods

The SystemSpecificColors type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors Fields

The SystemSpecificColors type exposes the following members.

Fields
Name | Description
ButtonShadow |
Control |
ControlLight |
ControlLightLight |
ControlText |
Highlight |
HighlightText |
InactiveCaption |
Info |
InfoText |
Window |
WindowText |
Top
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.ButtonShadow Field

SystemSpecificColorsButtonShadow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ButtonShadow
Public Shared ButtonShadow As Color
public:
static Color ButtonShadow
static val mutable ButtonShadow: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.Control Field

SystemSpecificColorsControl Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Control
Public Shared Control As Color
public:
static Color Control
static val mutable Control: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.ControlLight Field

SystemSpecificColorsControlLight Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ControlLight
Public Shared ControlLight As Color
public:
static Color ControlLight
static val mutable ControlLight: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.ControlLightLight Field

SystemSpecificColorsControlLightLight Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ControlLightLight
Public Shared ControlLightLight As Color
public:
static Color ControlLightLight
static val mutable ControlLightLight: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.ControlText Field

SystemSpecificColorsControlText Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ControlText
Public Shared ControlText As Color
public:
static Color ControlText
static val mutable ControlText: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.Highlight Field

SystemSpecificColorsHighlight Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Highlight
Public Shared Highlight As Color
public:
static Color Highlight
static val mutable Highlight: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.HighlightText Field

SystemSpecificColorsHighlightText Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color HighlightText
Public Shared HighlightText As Color
public:
static Color HighlightText
static val mutable HighlightText: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.InactiveCaption Field

SystemSpecificColorsInactiveCaption Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color InactiveCaption
Public Shared InactiveCaption As Color
public:
static Color InactiveCaption
static val mutable InactiveCaption: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.Info Field

SystemSpecificColorsInfo Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Info
Public Shared Info As Color
public:
static Color Info
static val mutable Info: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.InfoText Field

SystemSpecificColorsInfoText Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color InfoText
Public Shared InfoText As Color
public:
static Color InfoText
static val mutable InfoText: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.Window Field

SystemSpecificColorsWindow Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Window
Public Shared Window As Color
public:
static Color Window
static val mutable Window: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SystemSpecificColors.WindowText Field

SystemSpecificColorsWindowText Field

Namespace: SMath.Drawing
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color WindowText
Public Shared WindowText As Color
public:
static Color WindowText
static val mutable WindowText: Color

Field Value

Type: Color
See Also

Reference

SystemSpecificColors Class
SMath.Drawing Namespace


SMath.Drawing.Svg Namespace

Classes
 | Class | Description
Public class | GraphicsFormatter |
Public class | SvgPathParser |
Interfaces
 | Interface | Description
Public interface | ISourceFormatter |


GraphicsFormatter Class

Inheritance Hierarchy
SystemObject
SMath.Drawing.SvgGraphicsFormatter

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class GraphicsFormatter : ISourceFormatter
Public Class GraphicsFormatter
    Implements ISourceFormatter
public ref class GraphicsFormatter : ISourceFormatter
type GraphicsFormatter =
    class
        interface ISourceFormatter
    end

The GraphicsFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | GraphicsFormatter | Initializes a new instance of the GraphicsFormatter class
Top
Properties
 | Name | Description
Public property | IsClosed |
Public property | Steps |
Top
Methods
 | Name | Description
Public method | ArcTo |
Public method | ClosePath |
Public method | CurveTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LineTo |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo |
Public method | QuadCurveTo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing.Svg Namespace


GraphicsFormatter Constructor

Initializes a new instance of the GraphicsFormatter class

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public GraphicsFormatter()
Public Sub New
public:
GraphicsFormatter()
new : unit -> GraphicsFormatter
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter Properties

The GraphicsFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsClosed |
Public property | Steps |
Top
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.IsClosed Property

GraphicsFormatterIsClosed Property

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
public:
property bool IsClosed {
    bool get ();
}
member IsClosed : bool with get

Property Value

Type: Boolean
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.Steps Property

GraphicsFormatterSteps Property

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<PathStep> Steps { get; }
Public ReadOnly Property Steps As List(Of PathStep)
    Get
public:
property List<PathStep^>^ Steps {
    List<PathStep^>^ get ();
}
member Steps : List<PathStep> with get

Property Value

Type: ListPathStep
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter Methods

The GraphicsFormatter type exposes the following members.

Methods
 | Name | Description
Public method | ArcTo |
Public method | ClosePath |
Public method | CurveTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | LineTo |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveTo |
Public method | QuadCurveTo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.ArcTo Method

GraphicsFormatterArcTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ArcTo(
    PointF size,
    float angle,
    bool isLarge,
    bool sweep,
    PointF endPoint,
    PointF startPoint
)
Public Sub ArcTo (
    size As PointF,
    angle As Single,
    isLarge As Boolean,
    sweep As Boolean,
    endPoint As PointF,
    startPoint As PointF
)
public:
virtual void ArcTo(
    PointF size,
    float angle,
    bool isLarge,
    bool sweep,
    PointF endPoint,
    PointF startPoint
) sealed
abstract ArcTo :
        size : PointF *
        angle : float32 *
        isLarge : bool *
        sweep : bool *
        endPoint : PointF *
        startPoint : PointF -> unit
override ArcTo :
        size : PointF *
        angle : float32 *
        isLarge : bool *
        sweep : bool *
        endPoint : PointF *
        startPoint : PointF -> unit

Parameters

size
Type: System.DrawingPointF
angle
Type: SystemSingle
isLarge
Type: SystemBoolean
sweep
Type: SystemBoolean
endPoint
Type: System.DrawingPointF
startPoint
Type: System.DrawingPointF

Implements

ISourceFormatterArcTo(PointF, Single, Boolean, Boolean, PointF, PointF)
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.ClosePath Method

GraphicsFormatterClosePath Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ClosePath()
Public Sub ClosePath
public:
virtual void ClosePath() sealed
abstract ClosePath : unit -> unit
override ClosePath : unit -> unit

Implements

ISourceFormatterClosePath
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.CurveTo Method

GraphicsFormatterCurveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CurveTo(
    PointF pt1,
    PointF pt2,
    PointF pt3
)
Public Sub CurveTo (
    pt1 As PointF,
    pt2 As PointF,
    pt3 As PointF
)
public:
virtual void CurveTo(
    PointF pt1,
    PointF pt2,
    PointF pt3
) sealed
abstract CurveTo :
        pt1 : PointF *
        pt2 : PointF *
        pt3 : PointF -> unit
override CurveTo :
        pt1 : PointF *
        pt2 : PointF *
        pt3 : PointF -> unit

Parameters

pt1
Type: System.DrawingPointF
pt2
Type: System.DrawingPointF
pt3
Type: System.DrawingPointF

Implements

ISourceFormatterCurveTo(PointF, PointF, PointF)
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.LineTo Method

GraphicsFormatterLineTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void LineTo(
    PointF pt
)
Public Sub LineTo (
    pt As PointF
)
public:
virtual void LineTo(
    PointF pt
) sealed
abstract LineTo :
        pt : PointF -> unit
override LineTo :
        pt : PointF -> unit

Parameters

pt
Type: System.DrawingPointF

Implements

ISourceFormatterLineTo(PointF)
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.MoveTo Method

GraphicsFormatterMoveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MoveTo(
    PointF pt
)
Public Sub MoveTo (
    pt As PointF
)
public:
virtual void MoveTo(
    PointF pt
) sealed
abstract MoveTo :
        pt : PointF -> unit
override MoveTo :
        pt : PointF -> unit

Parameters

pt
Type: System.DrawingPointF

Implements

ISourceFormatterMoveTo(PointF)
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


GraphicsFormatter.QuadCurveTo Method

GraphicsFormatterQuadCurveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void QuadCurveTo(
    PointF pt1,
    PointF pt2
)
Public Sub QuadCurveTo (
    pt1 As PointF,
    pt2 As PointF
)
public:
virtual void QuadCurveTo(
    PointF pt1,
    PointF pt2
) sealed
abstract QuadCurveTo :
        pt1 : PointF *
        pt2 : PointF -> unit
override QuadCurveTo :
        pt1 : PointF *
        pt2 : PointF -> unit

Parameters

pt1
Type: System.DrawingPointF
pt2
Type: System.DrawingPointF

Implements

ISourceFormatterQuadCurveTo(PointF, PointF)
See Also

Reference

GraphicsFormatter Class
SMath.Drawing.Svg Namespace


ISourceFormatter Interface

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface ISourceFormatter
Public Interface ISourceFormatter
public interface class ISourceFormatter
type ISourceFormatter =  interface end

The ISourceFormatter type exposes the following members.

Methods
 | Name | Description
Public method | ArcTo |
Public method | ClosePath |
Public method | CurveTo |
Public method | LineTo |
Public method | MoveTo |
Public method | QuadCurveTo |
Top
See Also

Reference

SMath.Drawing.Svg Namespace


ISourceFormatter Methods

The ISourceFormatter type exposes the following members.

Methods
 | Name | Description
Public method | ArcTo |
Public method | ClosePath |
Public method | CurveTo |
Public method | LineTo |
Public method | MoveTo |
Public method | QuadCurveTo |
Top
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.ArcTo Method

ISourceFormatterArcTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ArcTo(
    PointF size,
    float angle,
    bool isLarge,
    bool sweep,
    PointF ep,
    PointF sp
)
Sub ArcTo (
    size As PointF,
    angle As Single,
    isLarge As Boolean,
    sweep As Boolean,
    ep As PointF,
    sp As PointF
)
void ArcTo(
    PointF size,
    float angle,
    bool isLarge,
    bool sweep,
    PointF ep,
    PointF sp
)
abstract ArcTo :
        size : PointF *
        angle : float32 *
        isLarge : bool *
        sweep : bool *
        ep : PointF *
        sp : PointF -> unit

Parameters

size
Type: System.DrawingPointF
angle
Type: SystemSingle
isLarge
Type: SystemBoolean
sweep
Type: SystemBoolean
ep
Type: System.DrawingPointF
sp
Type: System.DrawingPointF
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.ClosePath Method

ISourceFormatterClosePath Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void ClosePath()
Sub ClosePath
void ClosePath()
abstract ClosePath : unit -> unit
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.CurveTo Method

ISourceFormatterCurveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void CurveTo(
    PointF pt1,
    PointF pt2,
    PointF pt3
)
Sub CurveTo (
    pt1 As PointF,
    pt2 As PointF,
    pt3 As PointF
)
void CurveTo(
    PointF pt1,
    PointF pt2,
    PointF pt3
)
abstract CurveTo :
        pt1 : PointF *
        pt2 : PointF *
        pt3 : PointF -> unit

Parameters

pt1
Type: System.DrawingPointF
pt2
Type: System.DrawingPointF
pt3
Type: System.DrawingPointF
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.LineTo Method

ISourceFormatterLineTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void LineTo(
    PointF pt
)
Sub LineTo (
    pt As PointF
)
void LineTo(
    PointF pt
)
abstract LineTo :
        pt : PointF -> unit

Parameters

pt
Type: System.DrawingPointF
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.MoveTo Method

ISourceFormatterMoveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void MoveTo(
    PointF pt
)
Sub MoveTo (
    pt As PointF
)
void MoveTo(
    PointF pt
)
abstract MoveTo :
        pt : PointF -> unit

Parameters

pt
Type: System.DrawingPointF
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


ISourceFormatter.QuadCurveTo Method

ISourceFormatterQuadCurveTo Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void QuadCurveTo(
    PointF pt1,
    PointF pt2
)
Sub QuadCurveTo (
    pt1 As PointF,
    pt2 As PointF
)
void QuadCurveTo(
    PointF pt1,
    PointF pt2
)
abstract QuadCurveTo :
        pt1 : PointF *
        pt2 : PointF -> unit

Parameters

pt1
Type: System.DrawingPointF
pt2
Type: System.DrawingPointF
See Also

Reference

ISourceFormatter Interface
SMath.Drawing.Svg Namespace


SvgPathParser Class

Inheritance Hierarchy
SystemObject
SMath.Drawing.SvgSvgPathParser

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SvgPathParser
Public Class SvgPathParser
public ref class SvgPathParser
type SvgPathParser =  class end

The SvgPathParser type exposes the following members.

Constructors
 | Name | Description
Public method | SvgPathParser | Initializes a new instance of the SvgPathParser class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Drawing.Svg Namespace


SvgPathParser Constructor

Initializes a new instance of the SvgPathParser class

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SvgPathParser()
Public Sub New
public:
SvgPathParser()
new : unit -> SvgPathParser
See Also

Reference

SvgPathParser Class
SMath.Drawing.Svg Namespace


SvgPathParser Methods

The SvgPathParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SvgPathParser Class
SMath.Drawing.Svg Namespace


SvgPathParser.Parse Method

SvgPathParserParse Method

Namespace: SMath.Drawing.Svg
Assembly: SMath.Drawing (in SMath.Drawing.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Parse(
    string svg,
    ISourceFormatter formatter
)
Public Shared Sub Parse (
    svg As String,
    formatter As ISourceFormatter
)
public:
static void Parse(
    String^ svg,
    ISourceFormatter^ formatter
)
static member Parse :
        svg : string *
        formatter : ISourceFormatter -> unit

Parameters

svg
Type: SystemString
formatter
Type: SMath.Drawing.SvgISourceFormatter
See Also

Reference

SvgPathParser Class
SMath.Drawing.Svg Namespace


SMath.Manager Namespace

Classes
 | Class | Description
Public class | ActionContext | Base context class.Базовый класс контекста.
Public class | AlertBox |
Public class | AppSettings |
Public class | Archiver | Methods to create a stored archive of files.
Public class | ArgumentInfo | Information about the Argument.Информация об аргументе.
Public class | ButtonsMetaData |
Public class | ContentFormats |
Public class | ContextVariables |
Public class | ConversionT | Parent class contains logic to convert string of math expression to the reverse polish notation (RPN).Класс-родитель для перевода текстового выражения в постфиксную форму (ОПЗ).
Public class | Converter | Class with conversion methods represented.Класс, представляющий специфичные методы конвертации данных.
Public class | DataCompression | LZW compression manager.
Public class | Definition | Stores information about single definition.Хранит информацию о конкретном определении.
Public class | DimensionInfo |
Public class | DocumentMetaData | Document meta-data which describes its origin.
Public class | DocumentParams |
Public class | DrawingManager |
Public class | EmptyPlaceholderException |
Public class | EmptyPlugin |
Public class | Entry | Data format used for calculations. Allows to manage expressions as a tree.
Public class | Expression | Helpers methods to work with math expression represented in reverse polish notation.Вспомогательные методы для работы с выражениями, записанными в виде постфиксной нотации.
Public class | FractionsSolver |
Public class | FractionsSolverFraction |
Public class | Functions | Перечисление доступных встроенных функций.
Public class | GeneralException |
Public class | GlobalParams | Obsolete.
Public class | GlobalProfile |
Public class | InterruptCalculationException |
Public class | KeyEventOptions |
Public class | KeyPressEventOptions |
Public class | LanguageInfo |
Public class | MathException |
Public class | MathMethods | Auxiliary mathematical methods.Вспомогательные математические методы.
Public class | MetaContext |
Public class | MouseEventOptions |
Public class | NotDefinedException |
Public class | OperatorInfo | Класс характеристик оператора
Public class | OptionsCollection |
Public class | PageMargins |
Public class | PageModel | Printing model of the document.Модель документа для печати.
Public class | PageOptions |
Public class | PagesOptions | Single document page options.Свойства страницы документа.
Public class | PaintEventOptions |
Public class | ParallelListT |
Public class | Parallels |
Public class | PluginDependencyAttribute |
Public class | PluginInfo | Plug-in information.
Public class | PluginInitialMeta |
Public class | PluginsManager | Methods to manage Plug-ins.
Public class | PrimitiveInfo |
Public class | PrimitivesCollection |
Public class | PrimitivesManager |
Public class | Protection |
Public class | RecentPage |
Public class | RunningTitle |
Public class | SessionOptions | Application context options.
Public class | SessionProfile | Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.
Public class | SessionProfileBuiltInVarInfo |
Public class | SessionsManager | Application context manager.
Public class | SMathColors |
Public class | Term | Expression component.Компонента выражения.
Public class | TermFormat |
Public class | TermInfo | Information about the Term.Информация об элементе выражения.
Public class | TermsConverter |
Public class | TermsConverterTextEntryManager |
Public class | TermsConverterTextEntryManagerTextEntryState |
Public class | TermsFuzzyComparer | Compares Terms according to their children count. It works according to the following rule: if one of the instances allows to handle any amount of children, then Terms will be defined as equal.
Public class | TermsReferencesComparer | Compares Terms according to their object references.
Public class | ThreadSafeImageContainer |
Public class | ToolboxGroup |
Public class | UnitInfo |
Public class | UnitsManager |
Public class | UnitsSet |
Public class | WorkingThread | Managing of working threads in order to optimize performance and handle work termination.Обрабатывает рабочие процессы для оптимизации производительности и обработки их прерываний.
Structures
 | Structure | Description
Public structure | ArchiverFileEntry | Archive file entry.
Public structure | AssemblyInfo | Assembly Information structure.
Public structure | Brackets | Доступные встроенные скобки программы.
Public structure | Operators | Доступные встроенные операторы программы.
Public structure | Symbols | Доступные встроенные символы программы.
Interfaces
 | Interface | Description
Public interface | IDetailedTerm |
Public interface | IEvaluationActionContext |
Public interface | IPlugin | Base Interface for SMath Studio Plug-ins.
Public interface | IPluginHandleEvaluation | Base Evaluation Interface for SMath Studio Plug-ins.
Public interface | IPluginToolboxGroups | Base Toolbox Groups handler Interface for SMath Studio Plug-ins.Базовый интерфейс поддержки групп тулбоксов в виде дополнений для SMath Studio.
Public interface | IPrimitive |
Public interface | IPrimitiveT |
Delegates
 | Delegate | Description
Public delegate | ErrorOccuredEventHandler |
Public delegate | PluginsRequestEventHandler |
Public delegate | PluginsStatusEventHandler |
Public delegate | UndefinedVariablesHandler |
Enumerations
 | Enumeration | Description
Public enumeration | AnswerType | Тип ответа (используется при вычислении корня по формуле Муавра).
Public enumeration | ArgumentSections | Section argument belongs to.Раздел, к которому принадлежит аргумент.
Public enumeration | BackgroundImageSize |
Public enumeration | ContentPlacement | Placement of the content elements.Расположение элементов документа.
Public enumeration | Errors | Перечисление доступных ошибок программы.
Public enumeration | FileOrigins |
Public enumeration | FileTypes |
Public enumeration | FractionsType | Тип дроби.
Public enumeration | FunctionSections | Function's section.
Public enumeration | InputKeys |
Public enumeration | MouseInputButtons |
Public enumeration | OnErrorAction |
Public enumeration | OperatorType | Допустимое количество операндов оператора
Public enumeration | OptimizationType | Evaluation optimization type.Тип оптимизации вычисления.
Public enumeration | OSType |
Public enumeration | PageModelViewMode |
Public enumeration | PageOrientation |
Public enumeration | PluginState |
Public enumeration | ProductUrlType |
Public enumeration | SysSettings | Тип отображения системы.
Public enumeration | TermOrigin | The origin of the expression component (order based on the priorities).Происхождение компоненты выражения (порядок согласно приоритетам).
Public enumeration | TermType | Type of the expression component.Определение типа компоненты выражения.
Public enumeration | TextAlignment |
Public enumeration | WorkingThreadState | State of the working thread.


ActionContext Class

Base context class.Базовый класс контекста.
Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ManagerActionContext
SMath.ControlsFileContext
SMath.ControlsFileParsingContext
SMath.MathStore

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ActionContext : DocumentParams,
    IDisposable
Public Class ActionContext
    Inherits DocumentParams
    Implements IDisposable
public ref class ActionContext : public DocumentParams,
    IDisposable
type ActionContext =
    class
        inherit DocumentParams
        interface IDisposable
    end

The ActionContext type exposes the following members.

Constructors
 | Name | Description
Public method | ActionContext(ActionContext) | Constructor of the Context class.Конструктор класса-контекста.
Public method | ActionContext(SessionProfile) | Constructor of the Context class.Конструктор класса-контекста.
Top
Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет.
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста.
Public property | GeneratorVersion | Version of the application.Версия приложения.
Public property | Id | (Inherited from DocumentParams.)
Public property | Revision | (Inherited from DocumentParams.)
Public property | SessionProfile | Session parameters.Параметры сессии.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Top
Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина).
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError |
Public method | RequestPlugins |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции.
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

SMath.Manager Namespace


ActionContext Constructor

Overload List
 | Name | Description
Public method | ActionContext(ActionContext) | Constructor of the Context class.Конструктор класса-контекста.
Public method | ActionContext(SessionProfile) | Constructor of the Context class.Конструктор класса-контекста.
Top
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext Constructor (ActionContext)

Constructor of the Context class.Конструктор класса-контекста.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ActionContext(
    ActionContext context
)
Public Sub New (
    context As ActionContext
)
public:
ActionContext(
    ActionContext^ context
)
new :
        context : ActionContext -> ActionContext

Parameters

context
Type: SMath.ManagerActionContext
See Also

Reference

ActionContext Class
ActionContext Overload
SMath.Manager Namespace


ActionContext Constructor (SessionProfile)

Constructor of the Context class.Конструктор класса-контекста.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ActionContext(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
ActionContext(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> ActionContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

ActionContext Class
ActionContext Overload
SMath.Manager Namespace


ActionContext Properties

The ActionContext type exposes the following members.

Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет.
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста.
Public property | GeneratorVersion | Version of the application.Версия приложения.
Public property | Id | (Inherited from DocumentParams.)
Public property | Revision | (Inherited from DocumentParams.)
Public property | SessionProfile | Session parameters.Параметры сессии.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Top
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.Action Property

ActionContextAction Property

Text value of the current context usage.Текстовое значение текущего использования контекста.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Action { get; set; }
Public Property Action As String
    Get
    Set
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}
member Action : string with get, set

Property Value

Type: String
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.Cancel Property

ActionContextCancel Property

Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.Dependencies Property

ActionContextDependencies Property

All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<AssemblyInfo> Dependencies { get; }
Public ReadOnly Property Dependencies As List(Of AssemblyInfo)
    Get
public:
property List<AssemblyInfo>^ Dependencies {
    List<AssemblyInfo>^ get ();
}
member Dependencies : List<AssemblyInfo> with get

Property Value

Type: ListAssemblyInfo
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.FractionsTypeNumeric Property

ActionContextFractionsTypeNumeric Property

Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FractionsType FractionsTypeNumeric { get; set; }
Public Property FractionsTypeNumeric As FractionsType
    Get
    Set
public:
property FractionsType FractionsTypeNumeric {
    FractionsType get ();
    void set (FractionsType value);
}
member FractionsTypeNumeric : FractionsType with get, set

Property Value

Type: FractionsType
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.GeneratorVersion Property

ActionContextGeneratorVersion Property

Version of the application.Версия приложения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Version GeneratorVersion { get; set; }
Public Property GeneratorVersion As Version
    Get
    Set
public:
property Version^ GeneratorVersion {
    Version^ get ();
    void set (Version^ value);
}
member GeneratorVersion : Version with get, set

Property Value

Type: Version
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.SessionProfile Property

ActionContextSessionProfile Property

Session parameters.Параметры сессии.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; set; }
Public Property SessionProfile As SessionProfile
    Get
    Set
public:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
    void set (SessionProfile^ value);
}
member SessionProfile : SessionProfile with get, set

Property Value

Type: SessionProfile
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.SuppressUI Property

ActionContextSuppressUI Property

Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SuppressUI { get; set; }
Public Property SuppressUI As Boolean
    Get
    Set
public:
property bool SuppressUI {
    bool get ();
    void set (bool value);
}
member SuppressUI : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext Methods

The ActionContext type exposes the following members.

Methods
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина).
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError |
Public method | RequestPlugins |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.IDisposable.Dispose Method

ActionContextIDisposableDispose Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.AddDependency Method

ActionContextAddDependency Method

Overload List
 | Name | Description
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина).
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов).
Top
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.AddDependency Method (AssemblyInfo)

ActionContextAddDependency Method (AssemblyInfo)

Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddDependency(
    AssemblyInfo info
)
Public Sub AddDependency (
    info As AssemblyInfo
)
public:
void AddDependency(
    AssemblyInfo info
)
member AddDependency :
        info : AssemblyInfo -> unit

Parameters

info
Type: SMath.ManagerAssemblyInfo
Plug-in information.Информация о дополнении (плагине).
See Also

Reference

ActionContext Class
AddDependency Overload
SMath.Manager Namespace


ActionContext.AddDependency Method (IEnumerable(AssemblyInfo))

ActionContextAddDependency Method (IEnumerableAssemblyInfo)

Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddDependency(
    IEnumerable<AssemblyInfo> infos
)
Public Sub AddDependency (
    infos As IEnumerable(Of AssemblyInfo)
)
public:
void AddDependency(
    IEnumerable<AssemblyInfo>^ infos
)
member AddDependency :
        infos : IEnumerable<AssemblyInfo> -> unit

Parameters

infos
Type: System.Collections.GenericIEnumerableAssemblyInfo
Plug-in information.Информация о дополнении (плагине).
See Also

Reference

ActionContext Class
AddDependency Overload
SMath.Manager Namespace


ActionContext.RaiseError Method

ActionContextRaiseError Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool RaiseError(
    string message
)
Public Function RaiseError (
    message As String
) As Boolean
public:
bool RaiseError(
    String^ message
)
member RaiseError :
        message : string -> bool

Parameters

message
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.RequestPlugins Method

ActionContextRequestPlugins Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool RequestPlugins()
Public Function RequestPlugins As Boolean
public:
bool RequestPlugins()
member RequestPlugins : unit -> bool

Return Value

Type: Boolean
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext Events

The ActionContext type exposes the following members.

Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции.
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям.
Top
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.ErrorOccured Event

ActionContextErrorOccured Event

Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ErrorOccuredEventHandler ErrorOccured
Public Event ErrorOccured As ErrorOccuredEventHandler
public:
 event ErrorOccuredEventHandler^ ErrorOccured {
    void add (ErrorOccuredEventHandler^ value);
    void remove (ErrorOccuredEventHandler^ value);
}
member ErrorOccured : IEvent<ErrorOccuredEventHandler,
    EventArgs>

Value

Type: SMath.ManagerErrorOccuredEventHandler
See Also

Reference

ActionContext Class
SMath.Manager Namespace


ActionContext.PluginsRequested Event

ActionContextPluginsRequested Event

Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event PluginsRequestEventHandler PluginsRequested
Public Event PluginsRequested As PluginsRequestEventHandler
public:
 event PluginsRequestEventHandler^ PluginsRequested {
    void add (PluginsRequestEventHandler^ value);
    void remove (PluginsRequestEventHandler^ value);
}
member PluginsRequested : IEvent<PluginsRequestEventHandler,
    EventArgs>

Value

Type: SMath.ManagerPluginsRequestEventHandler
See Also

Reference

ActionContext Class
SMath.Manager Namespace


AlertBox Class

Inheritance Hierarchy
SystemObject
SMath.ManagerAlertBox

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class AlertBox
Public Class AlertBox
public ref class AlertBox
type AlertBox =  class end

The AlertBox type exposes the following members.

Constructors
 | Name | Description
Public method | AlertBox | Initializes a new instance of the AlertBox class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Show(String) |
 | Show(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


AlertBox Constructor

Initializes a new instance of the AlertBox class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AlertBox()
Public Sub New
public:
AlertBox()
new : unit -> AlertBox
See Also

Reference

AlertBox Class
SMath.Manager Namespace


AlertBox Methods

The AlertBox type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Show(String) |
 | Show(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AlertBox Class
SMath.Manager Namespace


AlertBox.Show Method

AlertBoxShow Method

Overload List
Name | Description
Show(String) |
Show(String, String) |
Top
See Also

Reference

AlertBox Class
SMath.Manager Namespace


AlertBox.Show Method (String)

AlertBoxShow Method (String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Show(
    string message
)
Public Shared Sub Show (
    message As String
)
public:
static void Show(
    String^ message
)
static member Show :
        message : string -> unit

Parameters

message
Type: SystemString
See Also

Reference

AlertBox Class
Show Overload
SMath.Manager Namespace


AlertBox.Show Method (String, String)

AlertBoxShow Method (String, String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Show(
    string message,
    string title
)
Public Shared Sub Show (
    message As String,
    title As String
)
public:
static void Show(
    String^ message,
    String^ title
)
static member Show :
        message : string *
        title : string -> unit

Parameters

message
Type: SystemString
title
Type: SystemString
See Also

Reference

AlertBox Class
Show Overload
SMath.Manager Namespace


AnswerType Enumeration

Тип ответа (используется при вычислении корня по формуле Муавра).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum AnswerType
Public Enumeration AnswerType
public enum class AnswerType
type AnswerType
Members
Member name | Value | Description
All | 0 | Показывать все ответы.
Real | 1 | Показывать только действительный ответы.
Imaginary | 2 | Показывать только мнимые ответы.
Single | 3 | Показать единственный ответ (первый действительный или, если действительного нет, первый по счёту).
Standart | 4 | Стандартно (показать первый ответ из списка).
See Also

Reference

SMath.Manager Namespace


AppSettings Class

Inheritance Hierarchy
SystemObject
SMath.ManagerAppSettings

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class AppSettings
Public Class AppSettings
public ref class AppSettings
type AppSettings =  class end

The AppSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AppSettings | Initializes a new instance of the AppSettings class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


AppSettings Constructor

Initializes a new instance of the AppSettings class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AppSettings()
Public Sub New
public:
AppSettings()
new : unit -> AppSettings
See Also

Reference

AppSettings Class
SMath.Manager Namespace


AppSettings Methods

The AppSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AppSettings Class
SMath.Manager Namespace


AppSettings.Load Method

AppSettingsLoad Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    out SessionOptions options
)
Public Shared Sub Load (
    <OutAttribute> ByRef options As SessionOptions
)
public:
static void Load(
    [OutAttribute] SessionOptions^% options
)
static member Load :
        options : SessionOptions byref -> unit

Parameters

options
Type: SMath.ManagerSessionOptions
See Also

Reference

AppSettings Class
SMath.Manager Namespace


Archiver Class

Methods to create a stored archive of files.
Inheritance Hierarchy
SystemObject
SMath.ManagerArchiver

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Archiver : IDisposable
Public Class Archiver
    Implements IDisposable
public ref class Archiver : IDisposable
type Archiver =
    class
        interface IDisposable
    end

The Archiver type exposes the following members.

Methods
 | Name | Description
Public method | AddFile | Add file stream facility method.
Public method | AddStream | Main method for adding a stream to storage file.
Public method | Close | Closes a stream.
 | Create(Stream, String) | Method to create a new storage.
 | Create(String, String) | Method to create a new storage.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractFile | Copy the contents of a stored file into a physical file.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Updates central directory (if pertinent).
Public method | GetFileOffset | Calculate the file offset by reading the corresponding local header.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open(Stream, FileAccess) | Method to open an existing storage.
 | Open(String, FileAccess) | Method to open an existing storage.
Public method | ReadCentralDir | Read all the file records in the central directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

SMath.Manager Namespace


Archiver Methods

The Archiver type exposes the following members.

Methods
 | Name | Description
Public method | AddFile | Add file stream facility method.
Public method | AddStream | Main method for adding a stream to storage file.
Public method | Close | Closes a stream.
 | Create(Stream, String) | Method to create a new storage.
 | Create(String, String) | Method to create a new storage.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractFile | Copy the contents of a stored file into a physical file.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Updates central directory (if pertinent).
Public method | GetFileOffset | Calculate the file offset by reading the corresponding local header.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open(Stream, FileAccess) | Method to open an existing storage.
 | Open(String, FileAccess) | Method to open an existing storage.
Public method | ReadCentralDir | Read all the file records in the central directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Top
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.IDisposable.Dispose Method

ArchiverIDisposableDispose Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.AddFile Method

ArchiverAddFile Method

Add file stream facility method.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddFile(
    string pathName,
    string fileName,
    string comment
)
Public Sub AddFile (
    pathName As String,
    fileName As String,
    comment As String
)
public:
void AddFile(
    String^ pathName,
    String^ fileName,
    String^ comment
)
member AddFile :
        pathName : string *
        fileName : string *
        comment : string -> unit

Parameters

pathName
Type: SystemString
fileName
Type: SystemString
comment
Type: SystemString
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.AddStream Method

ArchiverAddStream Method

Main method for adding a stream to storage file.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddStream(
    string fileName,
    Stream source,
    DateTime modTime,
    string comment
)
Public Sub AddStream (
    fileName As String,
    source As Stream,
    modTime As DateTime,
    comment As String
)
public:
void AddStream(
    String^ fileName,
    Stream^ source,
    DateTime modTime,
    String^ comment
)
member AddStream :
        fileName : string *
        source : Stream *
        modTime : DateTime *
        comment : string -> unit

Parameters

fileName
Type: SystemString
source
Type: System.IOStream
modTime
Type: SystemDateTime
comment
Type: SystemString
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Close Method

ArchiverClose Method

Closes a stream.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Create Method

ArchiverCreate Method

Overload List
Name | Description
Create(Stream, String) | Method to create a new storage.
Create(String, String) | Method to create a new storage.
Top
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Create Method (Stream, String)

ArchiverCreate Method (Stream, String)

Method to create a new storage.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Archiver Create(
    Stream stream,
    string comment
)
Public Shared Function Create (
    stream As Stream,
    comment As String
) As Archiver
public:
static Archiver^ Create(
    Stream^ stream,
    String^ comment
)
static member Create :
        stream : Stream *
        comment : string -> Archiver

Parameters

stream
Type: System.IOStream
comment
Type: SystemString

Return Value

Type: Archiver
See Also

Reference

Archiver Class
Create Overload
SMath.Manager Namespace


Archiver.Create Method (String, String)

ArchiverCreate Method (String, String)

Method to create a new storage.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Archiver Create(
    string fileName,
    string comment
)
Public Shared Function Create (
    fileName As String,
    comment As String
) As Archiver
public:
static Archiver^ Create(
    String^ fileName,
    String^ comment
)
static member Create :
        fileName : string *
        comment : string -> Archiver

Parameters

fileName
Type: SystemString
comment
Type: SystemString

Return Value

Type: Archiver
See Also

Reference

Archiver Class
Create Overload
SMath.Manager Namespace


Archiver.ExtractFile Method

ArchiverExtractFile Method

Copy the contents of a stored file into a physical file.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MemoryStream ExtractFile(
    ArchiverFileEntry fileEntry
)
Public Function ExtractFile (
    fileEntry As ArchiverFileEntry
) As MemoryStream
public:
MemoryStream^ ExtractFile(
    ArchiverFileEntry fileEntry
)
member ExtractFile :
        fileEntry : ArchiverFileEntry -> MemoryStream

Parameters

fileEntry
Type: SMath.ManagerArchiverFileEntry

Return Value

Type: MemoryStream
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Flush Method

ArchiverFlush Method

Updates central directory (if pertinent).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.GetFileOffset Method

ArchiverGetFileOffset Method

Calculate the file offset by reading the corresponding local header.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint GetFileOffset(
    uint headerOffset
)
Public Function GetFileOffset (
    headerOffset As UInteger
) As UInteger
public:
unsigned int GetFileOffset(
    unsigned int headerOffset
)
member GetFileOffset :
        headerOffset : uint32 -> uint32

Parameters

headerOffset
Type: SystemUInt32

Return Value

Type: UInt32
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Open Method

ArchiverOpen Method

Overload List
Name | Description
Open(Stream, FileAccess) | Method to open an existing storage.
Open(String, FileAccess) | Method to open an existing storage.
Top
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.Open Method (Stream, FileAccess)

ArchiverOpen Method (Stream, FileAccess)

Method to open an existing storage.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Archiver Open(
    Stream stream,
    FileAccess access
)
Public Shared Function Open (
    stream As Stream,
    access As FileAccess
) As Archiver
public:
static Archiver^ Open(
    Stream^ stream,
    FileAccess access
)
static member Open :
        stream : Stream *
        access : FileAccess -> Archiver

Parameters

stream
Type: System.IOStream
access
Type: System.IOFileAccess

Return Value

Type: Archiver
See Also

Reference

Archiver Class
Open Overload
SMath.Manager Namespace


Archiver.Open Method (String, FileAccess)

ArchiverOpen Method (String, FileAccess)

Method to open an existing storage.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Archiver Open(
    string fileName,
    FileAccess access
)
Public Shared Function Open (
    fileName As String,
    access As FileAccess
) As Archiver
public:
static Archiver^ Open(
    String^ fileName,
    FileAccess access
)
static member Open :
        fileName : string *
        access : FileAccess -> Archiver

Parameters

fileName
Type: SystemString
access
Type: System.IOFileAccess

Return Value

Type: Archiver
See Also

Reference

Archiver Class
Open Overload
SMath.Manager Namespace


Archiver.ReadCentralDir Method

ArchiverReadCentralDir Method

Read all the file records in the central directory.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<ArchiverFileEntry> ReadCentralDir()
Public Function ReadCentralDir As List(Of ArchiverFileEntry)
public:
List<ArchiverFileEntry>^ ReadCentralDir()
member ReadCentralDir : unit -> List<ArchiverFileEntry>

Return Value

Type: ListArchiverFileEntry
See Also

Reference

Archiver Class
SMath.Manager Namespace


Archiver.FileEntry Structure

ArchiverFileEntry Structure

Archive file entry.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct FileEntry
Public Structure FileEntry
public value class FileEntry
[<SealedAttribute>]
type FileEntry =  struct end

The ArchiverFileEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Comment |
Public field | Crc32 |
Public field | FileName |
Public field | FileOffset |
Public field | FileSize |
Public field | HeaderOffset |
Public field | HeaderSize |
Public field | ModifyTime |
Top
See Also

Reference

SMath.Manager Namespace


FileEntry Methods

The ArchiverFileEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


FileEntry Fields

The ArchiverFileEntry type exposes the following members.

Fields
 | Name | Description
Public field | Comment |
Public field | Crc32 |
Public field | FileName |
Public field | FileOffset |
Public field | FileSize |
Public field | HeaderOffset |
Public field | HeaderSize |
Public field | ModifyTime |
Top
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.Comment Field

ArchiverFileEntryComment Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Comment
Public Comment As String
public:
String^ Comment
val mutable Comment: string

Field Value

Type: String
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.Crc32 Field

ArchiverFileEntryCrc32 Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint Crc32
Public Crc32 As UInteger
public:
unsigned int Crc32
val mutable Crc32: uint32

Field Value

Type: UInt32
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.FileName Field

ArchiverFileEntryFileName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName
Public FileName As String
public:
String^ FileName
val mutable FileName: string

Field Value

Type: String
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.FileOffset Field

ArchiverFileEntryFileOffset Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint FileOffset
Public FileOffset As UInteger
public:
unsigned int FileOffset
val mutable FileOffset: uint32

Field Value

Type: UInt32
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.FileSize Field

ArchiverFileEntryFileSize Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint FileSize
Public FileSize As UInteger
public:
unsigned int FileSize
val mutable FileSize: uint32

Field Value

Type: UInt32
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.HeaderOffset Field

ArchiverFileEntryHeaderOffset Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint HeaderOffset
Public HeaderOffset As UInteger
public:
unsigned int HeaderOffset
val mutable HeaderOffset: uint32

Field Value

Type: UInt32
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.HeaderSize Field

ArchiverFileEntryHeaderSize Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public uint HeaderSize
Public HeaderSize As UInteger
public:
unsigned int HeaderSize
val mutable HeaderSize: uint32

Field Value

Type: UInt32
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


Archiver.FileEntry.ModifyTime Field

ArchiverFileEntryModifyTime Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DateTime ModifyTime
Public ModifyTime As DateTime
public:
DateTime ModifyTime
val mutable ModifyTime: DateTime

Field Value

Type: DateTime
See Also

Reference

ArchiverFileEntry Structure
SMath.Manager Namespace


ArgumentInfo Class

Information about the Argument.Информация об аргументе.
Inheritance Hierarchy
SystemObject
SMath.ManagerArgumentInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ArgumentInfo
Public Class ArgumentInfo
public ref class ArgumentInfo
type ArgumentInfo =  class end

The ArgumentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ArgumentInfo(String) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(ArgumentSections) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(String, Boolean) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(ArgumentSections, Boolean) | Initializes a new instance of the ArgumentInfo class
Top
Properties
 | Name | Description
Public property | IsUndefinedArgumentSupported |
Public property | Section |
Public property | Text |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(SessionProfile) |
Top
See Also

Reference

SMath.Manager Namespace


ArgumentInfo Constructor

Overload List
 | Name | Description
Public method | ArgumentInfo(String) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(ArgumentSections) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(String, Boolean) | Initializes a new instance of the ArgumentInfo class
Public method | ArgumentInfo(ArgumentSections, Boolean) | Initializes a new instance of the ArgumentInfo class
Top
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo Constructor (String)

Initializes a new instance of the ArgumentInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentInfo(
    string text
)
Public Sub New (
    text As String
)
public:
ArgumentInfo(
    String^ text
)
new :
        text : string -> ArgumentInfo

Parameters

text
Type: SystemString
See Also

Reference

ArgumentInfo Class
ArgumentInfo Overload
SMath.Manager Namespace


ArgumentInfo Constructor (ArgumentSections)

Initializes a new instance of the ArgumentInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentInfo(
    ArgumentSections section
)
Public Sub New (
    section As ArgumentSections
)
public:
ArgumentInfo(
    ArgumentSections section
)
new :
        section : ArgumentSections -> ArgumentInfo

Parameters

section
Type: SMath.ManagerArgumentSections
See Also

Reference

ArgumentInfo Class
ArgumentInfo Overload
SMath.Manager Namespace


ArgumentInfo Constructor (String, Boolean)

Initializes a new instance of the ArgumentInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentInfo(
    string text,
    bool isUndefinedArgumentSupported
)
Public Sub New (
    text As String,
    isUndefinedArgumentSupported As Boolean
)
public:
ArgumentInfo(
    String^ text,
    bool isUndefinedArgumentSupported
)
new :
        text : string *
        isUndefinedArgumentSupported : bool -> ArgumentInfo

Parameters

text
Type: SystemString
isUndefinedArgumentSupported
Type: SystemBoolean
See Also

Reference

ArgumentInfo Class
ArgumentInfo Overload
SMath.Manager Namespace


ArgumentInfo Constructor (ArgumentSections, Boolean)

Initializes a new instance of the ArgumentInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentInfo(
    ArgumentSections section,
    bool isUndefinedArgumentSupported
)
Public Sub New (
    section As ArgumentSections,
    isUndefinedArgumentSupported As Boolean
)
public:
ArgumentInfo(
    ArgumentSections section,
    bool isUndefinedArgumentSupported
)
new :
        section : ArgumentSections *
        isUndefinedArgumentSupported : bool -> ArgumentInfo

Parameters

section
Type: SMath.ManagerArgumentSections
isUndefinedArgumentSupported
Type: SystemBoolean
See Also

Reference

ArgumentInfo Class
ArgumentInfo Overload
SMath.Manager Namespace


ArgumentInfo Properties

The ArgumentInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsUndefinedArgumentSupported |
Public property | Section |
Public property | Text |
Top
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo.IsUndefinedArgumentSupported Property

ArgumentInfoIsUndefinedArgumentSupported Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsUndefinedArgumentSupported { get; set; }
Public Property IsUndefinedArgumentSupported As Boolean
    Get
    Set
public:
property bool IsUndefinedArgumentSupported {
    bool get ();
    void set (bool value);
}
member IsUndefinedArgumentSupported : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo.Section Property

ArgumentInfoSection Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentSections Section { get; set; }
Public Property Section As ArgumentSections
    Get
    Set
public:
property ArgumentSections Section {
    ArgumentSections get ();
    void set (ArgumentSections value);
}
member Section : ArgumentSections with get, set

Property Value

Type: ArgumentSections
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo.Text Property

ArgumentInfoText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo Methods

The ArgumentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(SessionProfile) |
Top
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo.ToString Method

ArgumentInfoToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(SessionProfile) |
Top
See Also

Reference

ArgumentInfo Class
SMath.Manager Namespace


ArgumentInfo.ToString Method (SessionProfile)

ArgumentInfoToString Method (SessionProfile)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    SessionProfile sessionProfile
)
Public Function ToString (
    sessionProfile As SessionProfile
) As String
public:
String^ ToString(
    SessionProfile^ sessionProfile
)
member ToString :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
See Also

Reference

ArgumentInfo Class
ToString Overload
SMath.Manager Namespace


ArgumentSections Enumeration

Section argument belongs to.Раздел, к которому принадлежит аргумент.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ArgumentSections
<FlagsAttribute>
Public Enumeration ArgumentSections
[FlagsAttribute]
public enum class ArgumentSections
[<FlagsAttribute>]
type ArgumentSections
Members
Member name | Value | Description
None | 0 | Any.Любой.
ComplexNumber | 1 | Complex number.Комплексное число.
RealNumber | 2 | Number.Число.
ImaginaryNumber | 4 | Imaginary number.Мнимое число.
String | 8 | String.Строка.
Variable | 16 | Variable.Переменная.
Unit | 32 | Unit.Единица измерения.
Function | 64 | Function.Функция.
Expression | 128 | Expression.Выражение.
SymbolicExpression | 256 | Symbolic expression.Символьное выражение.
NumericExpression | 512 | Numeric expression.Численное выражение.
Matrix | 1024 | Matrix.Матрица.
RowVector | 2048 | Vector-row.Вектор-строка.
ColumnVector | 4096 | Vector.Вектор.
FileName | 8192 | File name.Имя файла.
Condition | 16384 | Condition.Условие.
Increment | 32768 | Increment.Инкремент.
Action | 65536 | Action.Действие.
Delimiter | 131072 | Delimiter.Разделитель.
Default | 262144 | Argument.Аргумент.
Name | 524288 | Name.Имя.
Date | 1048576 | Date.Дата.
Currency | 2097152 | Currency.Валюта.
See Also

Reference

SMath.Manager Namespace


AssemblyInfo Structure

Assembly Information structure.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct AssemblyInfo : IComparable<AssemblyInfo>
Public Structure AssemblyInfo
    Implements IComparable(Of AssemblyInfo)
public value class AssemblyInfo : IComparable<AssemblyInfo>
[<SealedAttribute>]
type AssemblyInfo =
    struct
        interface IComparable<AssemblyInfo>
    end

The AssemblyInfo type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyInfo(Assembly) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, Version, Guid) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String, String, String) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String, String, Version, Guid) | Plug-in Info Constructor.
Top
Properties
 | Name | Description
Public property | Author | Assembly author.
Public property | Description | Assembly description.
Public property | FileName | File name for the external plug-in.
Public property | PrettyTitle | Pretty assembly title.
Public property | PublicGuid | Assembly static GUID.
Public property | Title | Assembly title.
Public property | Version | Assembly Version.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares two assemblies by public GUID.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsSupportedVersion |
Public method | ToString | Shows a string representation of assembly information.Показывает строковое представление информации о сборке. (Overrides ValueTypeToString.)
Top
Fields
Name | Description
Empty |
Top
See Also

Reference

SMath.Manager Namespace


AssemblyInfo Constructor

Overload List
 | Name | Description
Public method | AssemblyInfo(Assembly) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, Version, Guid) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String, String, String) | Plug-in Info Constructor.
Public method | AssemblyInfo(String, String, String, Version, Guid) | Plug-in Info Constructor.
Top
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo Constructor (Assembly)

Plug-in Info Constructor.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo(
    Assembly a
)
Public Sub New (
    a As Assembly
)
public:
AssemblyInfo(
    Assembly^ a
)
new :
        a : Assembly -> AssemblyInfo

Parameters

a
Type: System.ReflectionAssembly
Assembly to retrieve info from.
See Also

Reference

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Constructor (String, String)

Plug-in Info Constructor.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo(
    string title,
    string fileName
)
Public Sub New (
    title As String,
    fileName As String
)
public:
AssemblyInfo(
    String^ title,
    String^ fileName
)
new :
        title : string *
        fileName : string -> AssemblyInfo

Parameters

title
Type: SystemString
Plug-in title.
fileName
Type: SystemString
File name for the external plug-in. SMath Studio will not try to load plug-in on initialization.
See Also

Reference

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Constructor (String, Version, Guid)

Plug-in Info Constructor.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo(
    string title,
    Version version,
    Guid publicGuid
)
Public Sub New (
    title As String,
    version As Version,
    publicGuid As Guid
)
public:
AssemblyInfo(
    String^ title,
    Version^ version,
    Guid publicGuid
)
new :
        title : string *
        version : Version *
        publicGuid : Guid -> AssemblyInfo

Parameters

title
Type: SystemString
Plug-in title.
version
Type: SystemVersion
Plug-in Version.
publicGuid
Type: SystemGuid
Plug-in static GUID.
See Also

Reference

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Constructor (String, String, String, String)

Plug-in Info Constructor.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo(
    string title,
    string description,
    string author,
    string fileName
)
Public Sub New (
    title As String,
    description As String,
    author As String,
    fileName As String
)
public:
AssemblyInfo(
    String^ title,
    String^ description,
    String^ author,
    String^ fileName
)
new :
        title : string *
        description : string *
        author : string *
        fileName : string -> AssemblyInfo

Parameters

title
Type: SystemString
Plug-in title.
description
Type: SystemString
Plug-in description.
author
Type: SystemString
Plug-in author.
fileName
Type: SystemString
File name for the external plug-in. SMath Studio will not try to load plug-in on initialization.
See Also

Reference

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Constructor (String, String, String, Version, Guid)

Plug-in Info Constructor.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo(
    string title,
    string description,
    string author,
    Version version,
    Guid publicGuid
)
Public Sub New (
    title As String,
    description As String,
    author As String,
    version As Version,
    publicGuid As Guid
)
public:
AssemblyInfo(
    String^ title,
    String^ description,
    String^ author,
    Version^ version,
    Guid publicGuid
)
new :
        title : string *
        description : string *
        author : string *
        version : Version *
        publicGuid : Guid -> AssemblyInfo

Parameters

title
Type: SystemString
Plug-in title.
description
Type: SystemString
Plug-in description.
author
Type: SystemString
Plug-in author.
version
Type: SystemVersion
Plug-in Version.
publicGuid
Type: SystemGuid
Plug-in static GUID.
See Also

Reference

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Properties

The AssemblyInfo type exposes the following members.

Properties
 | Name | Description
Public property | Author | Assembly author.
Public property | Description | Assembly description.
Public property | FileName | File name for the external plug-in.
Public property | PrettyTitle | Pretty assembly title.
Public property | PublicGuid | Assembly static GUID.
Public property | Title | Assembly title.
Public property | Version | Assembly Version.
Top
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.Author Property

AssemblyInfoAuthor Property

Assembly author.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Author { get; }
Public ReadOnly Property Author As String
    Get
public:
property String^ Author {
    String^ get ();
}
member Author : string with get

Property Value

Type: String
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.Description Property

AssemblyInfoDescription Property

Assembly description.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.FileName Property

AssemblyInfoFileName Property

File name for the external plug-in.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.PrettyTitle Property

AssemblyInfoPrettyTitle Property

Pretty assembly title.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string PrettyTitle { get; set; }
Public Property PrettyTitle As String
    Get
    Set
public:
property String^ PrettyTitle {
    String^ get ();
    void set (String^ value);
}
member PrettyTitle : string with get, set

Property Value

Type: String
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.PublicGuid Property

AssemblyInfoPublicGuid Property

Assembly static GUID.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid PublicGuid { get; }
Public ReadOnly Property PublicGuid As Guid
    Get
public:
property Guid PublicGuid {
    Guid get ();
}
member PublicGuid : Guid with get

Property Value

Type: Guid
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.Title Property

AssemblyInfoTitle Property

Assembly title.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.Version Property

AssemblyInfoVersion Property

Assembly Version.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get
public:
property Version^ Version {
    Version^ get ();
}
member Version : Version with get

Property Value

Type: Version
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo Methods

The AssemblyInfo type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares two assemblies by public GUID.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsSupportedVersion |
Public method | ToString | Shows a string representation of assembly information.Показывает строковое представление информации о сборке. (Overrides ValueTypeToString.)
Top
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.CompareTo Method

AssemblyInfoCompareTo Method

Compares two assemblies by public GUID.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CompareTo(
    AssemblyInfo other
)
Public Function CompareTo (
    other As AssemblyInfo
) As Integer
public:
virtual int CompareTo(
    AssemblyInfo other
) sealed
abstract CompareTo :
        other : AssemblyInfo -> int
override CompareTo :
        other : AssemblyInfo -> int

Parameters

other
Type: SMath.ManagerAssemblyInfo
Assembly to compare with.

Return Value

Type: Int32
Result of assemblies comparison.

Implements

IComparableTCompareTo(T)
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.IsSupportedVersion Method

AssemblyInfoIsSupportedVersion Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSupportedVersion(
    Version checking
)
Public Function IsSupportedVersion (
    checking As Version
) As Boolean
public:
bool IsSupportedVersion(
    Version^ checking
)
member IsSupportedVersion :
        checking : Version -> bool

Parameters

checking
Type: SystemVersion

Return Value

Type: Boolean
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.ToString Method

AssemblyInfoToString Method

Shows a string representation of assembly information.Показывает строковое представление информации о сборке.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Return a string representation of assembly information.Возвращает строковое представление информации о сборке.
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo Fields

The AssemblyInfo type exposes the following members.

Fields
Name | Description
Empty |
Top
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo.Empty Field

AssemblyInfoEmpty Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static AssemblyInfo Empty
Public Shared Empty As AssemblyInfo
public:
static AssemblyInfo Empty
static val mutable Empty: AssemblyInfo

Field Value

Type: AssemblyInfo
See Also

Reference

AssemblyInfo Structure
SMath.Manager Namespace


BackgroundImageSize Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum BackgroundImageSize
Public Enumeration BackgroundImageSize
public enum class BackgroundImageSize
type BackgroundImageSize
Members
Member name | Value | Description
Fit | 0 |
Stretch | 1 |
Fill | 2 |
See Also

Reference

SMath.Manager Namespace


Brackets Structure

Доступные встроенные скобки программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct Brackets
Public Structure Brackets
public value class Brackets
[<SealedAttribute>]
type Brackets =  struct end

The Brackets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
Name | Description
LeftInvisible | Невидимая открывающая скобка.
LeftVisible | Видимая открывающая скобка.
RightInvisible | Невидимая закрывающая скобка.
RightVisible | Видимая закрывающая скобка.
Top
See Also

Reference

SMath.Manager Namespace


Brackets Methods

The Brackets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Brackets Structure
SMath.Manager Namespace


Brackets Fields

The Brackets type exposes the following members.

Fields
Name | Description
LeftInvisible | Невидимая открывающая скобка.
LeftVisible | Видимая открывающая скобка.
RightInvisible | Невидимая закрывающая скобка.
RightVisible | Видимая закрывающая скобка.
Top
See Also

Reference

Brackets Structure
SMath.Manager Namespace


Brackets.LeftInvisible Field

BracketsLeftInvisible Field

Невидимая открывающая скобка.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string LeftInvisible = "{"
Public Const LeftInvisible As String = "{"
public:
literal String^ LeftInvisible = "{"
static val mutable LeftInvisible: string

Field Value

Type: String
See Also

Reference

Brackets Structure
SMath.Manager Namespace


Brackets.LeftVisible Field

BracketsLeftVisible Field

Видимая открывающая скобка.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string LeftVisible = "("
Public Const LeftVisible As String = "("
public:
literal String^ LeftVisible = "("
static val mutable LeftVisible: string

Field Value

Type: String
See Also

Reference

Brackets Structure
SMath.Manager Namespace


Brackets.RightInvisible Field

BracketsRightInvisible Field

Невидимая закрывающая скобка.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string RightInvisible = "}"
Public Const RightInvisible As String = "}"
public:
literal String^ RightInvisible = "}"
static val mutable RightInvisible: string

Field Value

Type: String
See Also

Reference

Brackets Structure
SMath.Manager Namespace


Brackets.RightVisible Field

BracketsRightVisible Field

Видимая закрывающая скобка.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string RightVisible = ")"
Public Const RightVisible As String = ")"
public:
literal String^ RightVisible = ")"
static val mutable RightVisible: string

Field Value

Type: String
See Also

Reference

Brackets Structure
SMath.Manager Namespace


ButtonsMetaData Class

Inheritance Hierarchy
SystemObject
SMath.ManagerButtonsMetaData

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ButtonsMetaData
Public Class ButtonsMetaData
public ref class ButtonsMetaData
type ButtonsMetaData =  class end

The ButtonsMetaData type exposes the following members.

Constructors
 | Name | Description
Protected method | ButtonsMetaData | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(String) | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(IBitmap) | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(String, Size) | Initializes a new instance of the ButtonsMetaData class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Description |
Public property | Image |
Public property | IsVectorImage |
Public property | ShortCut |
Public property | Size |
Public property | SvgImage |
Public property | Text |
Public property | ToolTip |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


ButtonsMetaData Constructor

Overload List
 | Name | Description
Protected method | ButtonsMetaData | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(String) | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(IBitmap) | Initializes a new instance of the ButtonsMetaData class
Public method | ButtonsMetaData(String, Size) | Initializes a new instance of the ButtonsMetaData class
Top
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData Constructor

Initializes a new instance of the ButtonsMetaData class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected ButtonsMetaData()
Protected Sub New
protected:
ButtonsMetaData()
new : unit -> ButtonsMetaData
See Also

Reference

ButtonsMetaData Class
ButtonsMetaData Overload
SMath.Manager Namespace


ButtonsMetaData Constructor (String)

Initializes a new instance of the ButtonsMetaData class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ButtonsMetaData(
    string text
)
Public Sub New (
    text As String
)
public:
ButtonsMetaData(
    String^ text
)
new :
        text : string -> ButtonsMetaData

Parameters

text
Type: SystemString
See Also

Reference

ButtonsMetaData Class
ButtonsMetaData Overload
SMath.Manager Namespace


ButtonsMetaData Constructor (IBitmap)

Initializes a new instance of the ButtonsMetaData class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ButtonsMetaData(
    IBitmap image
)
Public Sub New (
    image As IBitmap
)
public:
ButtonsMetaData(
    IBitmap^ image
)
new :
        image : IBitmap -> ButtonsMetaData

Parameters

image
Type: SMath.DrawingIBitmap
See Also

Reference

ButtonsMetaData Class
ButtonsMetaData Overload
SMath.Manager Namespace


ButtonsMetaData Constructor (String[], Size)

ButtonsMetaData Constructor (String, Size)

Initializes a new instance of the ButtonsMetaData class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ButtonsMetaData(
    string[] svgPaths,
    Size svgSize
)
Public Sub New (
    svgPaths As String(),
    svgSize As Size
)
public:
ButtonsMetaData(
    array<String^>^ svgPaths,
    Size svgSize
)
new :
        svgPaths : string[] *
        svgSize : Size -> ButtonsMetaData

Parameters

svgPaths
Type: SystemString
svgSize
Type: System.DrawingSize
See Also

Reference

ButtonsMetaData Class
ButtonsMetaData Overload
SMath.Manager Namespace


ButtonsMetaData Properties

The ButtonsMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Description |
Public property | Image |
Public property | IsVectorImage |
Public property | ShortCut |
Public property | Size |
Public property | SvgImage |
Public property | Text |
Public property | ToolTip |
Top
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.Action Property

ButtonsMetaDataAction Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Action { get; set; }
Public Property Action As String
    Get
    Set
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}
member Action : string with get, set

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.Description Property

ButtonsMetaDataDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.Image Property

ButtonsMetaDataImage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap Image { get; protected set; }
Public Property Image As IBitmap
    Get
    Protected Set
public:
property IBitmap^ Image {
    IBitmap^ get ();
    protected: void set (IBitmap^ value);
}
member Image : IBitmap with get, set

Property Value

Type: IBitmap
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.IsVectorImage Property

ButtonsMetaDataIsVectorImage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsVectorImage { get; }
Public ReadOnly Property IsVectorImage As Boolean
    Get
public:
property bool IsVectorImage {
    bool get ();
}
member IsVectorImage : bool with get

Property Value

Type: Boolean
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.ShortCut Property

ButtonsMetaDataShortCut Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ShortCut { get; set; }
Public Property ShortCut As String
    Get
    Set
public:
property String^ ShortCut {
    String^ get ();
    void set (String^ value);
}
member ShortCut : string with get, set

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.Size Property

ButtonsMetaDataSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
property Size Size {
    Size get ();
    void set (Size value);
}
member Size : Size with get, set

Property Value

Type: Size
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.SvgImage Property

ButtonsMetaDataSvgImage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string SvgImage { get; }
Public ReadOnly Property SvgImage As String
    Get
public:
property String^ SvgImage {
    String^ get ();
}
member SvgImage : string with get

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.Text Property

ButtonsMetaDataText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData.ToolTip Property

ButtonsMetaDataToolTip Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ToolTip { get; }
Public ReadOnly Property ToolTip As String
    Get
public:
property String^ ToolTip {
    String^ get ();
}
member ToolTip : string with get

Property Value

Type: String
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ButtonsMetaData Methods

The ButtonsMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ButtonsMetaData Class
SMath.Manager Namespace


ContentFormats Class

Inheritance Hierarchy
SystemObject
SMath.ManagerContentFormats

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ContentFormats
Public Class ContentFormats
public ref class ContentFormats
type ContentFormats =  class end

The ContentFormats type exposes the following members.

Constructors
 | Name | Description
Public method | ContentFormats | Initializes a new instance of the ContentFormats class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Bitmap |
Html |
UnicodeText |
Top
See Also

Reference

SMath.Manager Namespace


ContentFormats Constructor

Initializes a new instance of the ContentFormats class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContentFormats()
Public Sub New
public:
ContentFormats()
new : unit -> ContentFormats
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentFormats Methods

The ContentFormats type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentFormats Fields

The ContentFormats type exposes the following members.

Fields
Name | Description
Bitmap |
Html |
UnicodeText |
Top
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentFormats.Bitmap Field

ContentFormatsBitmap Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static readonly string Bitmap
Public Shared ReadOnly Bitmap As String
public:
static initonly String^ Bitmap
static val Bitmap: string

Field Value

Type: String
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentFormats.Html Field

ContentFormatsHtml Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static readonly string Html
Public Shared ReadOnly Html As String
public:
static initonly String^ Html
static val Html: string

Field Value

Type: String
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentFormats.UnicodeText Field

ContentFormatsUnicodeText Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static readonly string UnicodeText
Public Shared ReadOnly UnicodeText As String
public:
static initonly String^ UnicodeText
static val UnicodeText: string

Field Value

Type: String
See Also

Reference

ContentFormats Class
SMath.Manager Namespace


ContentPlacement Enumeration

Placement of the content elements.Расположение элементов документа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ContentPlacement
Public Enumeration ContentPlacement
public enum class ContentPlacement
type ContentPlacement
Members
Member name | Value | Description
Main | 0 | Main worksheet content.
Header | 1 | Worksheet Header.
Footer | 2 | Worksheet Footer.
See Also

Reference

SMath.Manager Namespace


ContextVariables Class

Inheritance Hierarchy
SystemObject
SMath.ManagerContextVariables

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ContextVariables
Public Class ContextVariables
public ref class ContextVariables
type ContextVariables =  class end

The ContextVariables type exposes the following members.

Constructors
 | Name | Description
Public method | ContextVariables | Initializes a new instance of the ContextVariables class
Top
Properties
 | Name | Description
Public property | Author |
Public property | Company |
Public property | CurrentPage |
Public property | Description |
Public property | FileName |
Public property | Id |
Public property | Keywords |
Public property | PagesCount |
Public property | Revision |
Public property | Title |
Public property | Translator |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Empty |
Top
See Also

Reference

SMath.Manager Namespace


ContextVariables Constructor

Initializes a new instance of the ContextVariables class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ContextVariables(
    int currentPage,
    int pagesCount,
    MetaContext metaContext
)
Public Sub New (
    currentPage As Integer,
    pagesCount As Integer,
    metaContext As MetaContext
)
public:
ContextVariables(
    int currentPage,
    int pagesCount,
    MetaContext^ metaContext
)
new :
        currentPage : int *
        pagesCount : int *
        metaContext : MetaContext -> ContextVariables

Parameters

currentPage
Type: SystemInt32
pagesCount
Type: SystemInt32
metaContext
Type: SMath.ManagerMetaContext
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables Properties

The ContextVariables type exposes the following members.

Properties
 | Name | Description
Public property | Author |
Public property | Company |
Public property | CurrentPage |
Public property | Description |
Public property | FileName |
Public property | Id |
Public property | Keywords |
Public property | PagesCount |
Public property | Revision |
Public property | Title |
Public property | Translator |
Top
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Author Property

ContextVariablesAuthor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Author { get; }
Public ReadOnly Property Author As String
    Get
public:
property String^ Author {
    String^ get ();
}
member Author : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Company Property

ContextVariablesCompany Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Company { get; }
Public ReadOnly Property Company As String
    Get
public:
property String^ Company {
    String^ get ();
}
member Company : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.CurrentPage Property

ContextVariablesCurrentPage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int CurrentPage { get; }
Public ReadOnly Property CurrentPage As Integer
    Get
public:
property int CurrentPage {
    int get ();
}
member CurrentPage : int with get

Property Value

Type: Int32
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Description Property

ContextVariablesDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.FileName Property

ContextVariablesFileName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Id Property

ContextVariablesId Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}
member Id : Guid with get

Property Value

Type: Guid
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Keywords Property

ContextVariablesKeywords Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Keywords { get; }
Public ReadOnly Property Keywords As String
    Get
public:
property String^ Keywords {
    String^ get ();
}
member Keywords : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.PagesCount Property

ContextVariablesPagesCount Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PagesCount { get; }
Public ReadOnly Property PagesCount As Integer
    Get
public:
property int PagesCount {
    int get ();
}
member PagesCount : int with get

Property Value

Type: Int32
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Revision Property

ContextVariablesRevision Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Revision { get; }
Public ReadOnly Property Revision As Integer
    Get
public:
property int Revision {
    int get ();
}
member Revision : int with get

Property Value

Type: Int32
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Title Property

ContextVariablesTitle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Translator Property

ContextVariablesTranslator Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Translator { get; }
Public ReadOnly Property Translator As String
    Get
public:
property String^ Translator {
    String^ get ();
}
member Translator : string with get

Property Value

Type: String
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables Methods

The ContextVariables type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables Fields

The ContextVariables type exposes the following members.

Fields
Name | Description
Empty |
Top
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


ContextVariables.Empty Field

ContextVariablesEmpty Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static ContextVariables Empty
Public Shared Empty As ContextVariables
public:
static ContextVariables^ Empty
static val mutable Empty: ContextVariables

Field Value

Type: ContextVariables
See Also

Reference

ContextVariables Class
SMath.Manager Namespace


Conversion(T) Class

ConversionT Class

Parent class contains logic to convert string of math expression to the reverse polish notation (RPN).Класс-родитель для перевода текстового выражения в постфиксную форму (ОПЗ).
Inheritance Hierarchy
SystemObject
SMath.ManagerConversionT

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class Conversion<T>
where T : IPrimitive

Public MustInherit Class Conversion(Of T As IPrimitive)
generic<typename T>
where T : IPrimitive
public ref class Conversion abstract
[<AbstractClassAttribute>]
type Conversion<'T when 'T : IPrimitive> =  class end

Type Parameters

T
Expression component type to store the primitives in.Тип компоненты выражения для хранения результата конвертации.

The ConversionT type exposes the following members.

Constructors
 | Name | Description
Protected method | ConversionT | Initializes a new instance of the ConversionT class
Top
Methods
 | Name | Description
Protected method | CreateBracket | Creates Bracket.Создание скобки.
Protected method | CreateFunction(String) | Creates a Function.Создание функции.
Protected method | CreateFunction(T, Int32) | Preparing of the next stack element.Подготовка следующего элемента стэка.
Protected method | CreateOperand | Creates Operand.Создание операнда.
Protected method | CreateOperator | Creates Operator.Создание оператора.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PushFromStack | Moving an expression component from the stack to result.Размещение элементов из стэка в результат.
Public method | ToPostfix | Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN).Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | result | Result stack.Результирующий стэк.
Top
See Also

Reference

SMath.Manager Namespace


Conversion(T) Constructor

ConversionT Constructor

Initializes a new instance of the ConversionT class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Conversion()
Protected Sub New
protected:
Conversion()
new : unit -> Conversion
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T) Methods

ConversionT Methods

The ConversionT generic type exposes the following members.

Methods
 | Name | Description
Protected method | CreateBracket | Creates Bracket.Создание скобки.
Protected method | CreateFunction(String) | Creates a Function.Создание функции.
Protected method | CreateFunction(T, Int32) | Preparing of the next stack element.Подготовка следующего элемента стэка.
Protected method | CreateOperand | Creates Operand.Создание операнда.
Protected method | CreateOperator | Creates Operator.Создание оператора.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PushFromStack | Moving an expression component from the stack to result.Размещение элементов из стэка в результат.
Public method | ToPostfix | Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN).Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).CreateBracket Method

ConversionTCreateBracket Method

Creates Bracket.Создание скобки.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract T CreateBracket(
    string value
)
Protected MustOverride Function CreateBracket (
    value As String
) As T
protected:
virtual T CreateBracket(
    String^ value
) abstract
abstract CreateBracket :
        value : string -> 'T

Parameters

value
Type: SystemString
Type of the Bracket.Вид скобки.

Return Value

Type: T
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).CreateFunction Method

ConversionTCreateFunction Method

Overload List
 | Name | Description
Protected method | CreateFunction(String) | Creates a Function.Создание функции.
Protected method | CreateFunction(T, Int32) | Preparing of the next stack element.Подготовка следующего элемента стэка.
Top
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).CreateFunction Method (String)

ConversionTCreateFunction Method (String)

Creates a Function.Создание функции.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract T CreateFunction(
    string value
)
Protected MustOverride Function CreateFunction (
    value As String
) As T
protected:
virtual T CreateFunction(
    String^ value
) abstract
abstract CreateFunction :
        value : string -> 'T

Parameters

value
Type: SystemString
Name of a Function.Название функции.

Return Value

Type: T
See Also

Reference

ConversionT Class
CreateFunction Overload
SMath.Manager Namespace


Conversion(T).CreateFunction Method (T, Int32)

ConversionTCreateFunction Method (T, Int32)

Preparing of the next stack element.Подготовка следующего элемента стэка.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract T CreateFunction(
    T prev,
    int argsCount
)
Protected MustOverride Function CreateFunction (
    prev As T,
    argsCount As Integer
) As T
protected:
virtual T CreateFunction(
    T prev,
    int argsCount
) abstract
abstract CreateFunction :
        prev : 'T *
        argsCount : int -> 'T

Parameters

prev
Type: T
argsCount
Type: SystemInt32

Return Value

Type: T
See Also

Reference

ConversionT Class
CreateFunction Overload
SMath.Manager Namespace


Conversion(T).CreateOperand Method

ConversionTCreateOperand Method

Creates Operand.Создание операнда.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract T CreateOperand(
    string value
)
Protected MustOverride Function CreateOperand (
    value As String
) As T
protected:
virtual T CreateOperand(
    String^ value
) abstract
abstract CreateOperand :
        value : string -> 'T

Parameters

value
Type: SystemString
Text value of the Operand.Текстовое значение операнда.

Return Value

Type: T
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).CreateOperator Method

ConversionTCreateOperator Method

Creates Operator.Создание оператора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract T CreateOperator(
    string value,
    int child
)
Protected MustOverride Function CreateOperator (
    value As String,
    child As Integer
) As T
protected:
virtual T CreateOperator(
    String^ value,
    int child
) abstract
abstract CreateOperator :
        value : string *
        child : int -> 'T

Parameters

value
Type: SystemString
Text value of the Operator.Текстовое значение оператора.
child
Type: SystemInt32
Number of children.Количество зависимы элементов.

Return Value

Type: T
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).PushFromStack Method

ConversionTPushFromStack Method

Moving an expression component from the stack to result.Размещение элементов из стэка в результат.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract void PushFromStack(
    T last
)
Protected MustOverride Sub PushFromStack (
    last As T
)
protected:
virtual void PushFromStack(
    T last
) abstract
abstract PushFromStack :
        last : 'T -> unit

Parameters

last
Type: T
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).ToPostfix Method

ConversionTToPostfix Method

Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN).Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Stack<T> ToPostfix(
    ref string value
)
Public Function ToPostfix (
    ByRef value As String
) As Stack(Of T)
public:
Stack<T>^ ToPostfix(
    String^% value
)
member ToPostfix :
        value : string byref -> Stack<'T>

Parameters

value
Type: SystemString
String of the mathematical expression.Строка математического выражения.

Return Value

Type: StackT
Return an array of the expression components in RPN order.Возвращает массив компонент выражения в порядке ОПЗ.
Remarks
Important to be sure that both delimiters - Decimal Symbol and Argument Separator - are correctly specified in the global parameters.Важно убедиться, что оба разделителя - целой и дробной частей числа и аргументов функций - верно выставлены в глобальных параметрах программы.
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T) Fields

ConversionT Fields

The ConversionT generic type exposes the following members.

Fields
 | Name | Description
Protected field | result | Result stack.Результирующий стэк.
Top
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Conversion(T).result Field

ConversionTresult Field

Result stack.Результирующий стэк.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Stack<T> result
Protected result As Stack(Of T)
protected:
Stack<T>^ result
val mutable result: Stack<'T>

Field Value

Type: StackT
See Also

Reference

ConversionT Class
SMath.Manager Namespace


Converter Class

Class with conversion methods represented.Класс, представляющий специфичные методы конвертации данных.
Inheritance Hierarchy
SystemObject
SMath.ManagerConverter

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Converter
Public Class Converter
public ref class Converter
type Converter =  class end

The Converter type exposes the following members.

Constructors
 | Name | Description
Public method | Converter | Initializes a new instance of the Converter class
Top
Methods
 | Name | Description
 | CorrectExpressionString | Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters.Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(Term) | Obsolete. Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.
 | ToTerms | Obsolete. Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.
Top
See Also

Reference

SMath.Manager Namespace


Converter Constructor

Initializes a new instance of the Converter class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Converter()
Public Sub New
public:
Converter()
new : unit -> Converter
See Also

Reference

Converter Class
SMath.Manager Namespace


Converter Methods

The Converter type exposes the following members.

Methods
 | Name | Description
 | CorrectExpressionString | Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters.Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(Term) | Obsolete. Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.
 | ToTerms | Obsolete. Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.
Top
See Also

Reference

Converter Class
SMath.Manager Namespace


Converter.CorrectExpressionString Method

ConverterCorrectExpressionString Method

Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters.Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string CorrectExpressionString(
    string value,
    char decimalSymbolFrom,
    char decimalSymbolTo,
    char argumentsSeparatorFrom,
    char argumentsSeparatorTo
)
Public Shared Function CorrectExpressionString (
    value As String,
    decimalSymbolFrom As Char,
    decimalSymbolTo As Char,
    argumentsSeparatorFrom As Char,
    argumentsSeparatorTo As Char
) As String
public:
static String^ CorrectExpressionString(
    String^ value,
    wchar_t decimalSymbolFrom,
    wchar_t decimalSymbolTo,
    wchar_t argumentsSeparatorFrom,
    wchar_t argumentsSeparatorTo
)
static member CorrectExpressionString :
        value : string *
        decimalSymbolFrom : char *
        decimalSymbolTo : char *
        argumentsSeparatorFrom : char *
        argumentsSeparatorTo : char -> string

Parameters

value
Type: SystemString
Initial math expression to modify.Исходное математическое выражение для модификации.
decimalSymbolFrom
Type: SystemChar
Decimal Symbol to remove.Исходный разделитель целой и дробной частей числа (будет заменён).
decimalSymbolTo
Type: SystemChar
Decimal Symbol to insert.Искомый разделитель целой и дробной частей числа (будет вставлен).
argumentsSeparatorFrom
Type: SystemChar
Arguments separator to remove.Исходный разделитель аргументов функций (будет заменён).
argumentsSeparatorTo
Type: SystemChar
Arguments separator to insert.Искомый разделитель аргументов функций (будет вставлен).

Return Value

Type: String
Returns string of mathematical expression with modified separators.Возвращает строку математического выражения с модифицированными разделителями.
See Also

Reference

Converter Class
SMath.Manager Namespace


Converter.ToString Method

ConverterToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(Term) | Obsolete. Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.
Top
See Also

Reference

Converter Class
SMath.Manager Namespace


Converter.ToString Method (Term[])

ConverterToString Method (Term)

Note: This API is now obsolete.

Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use TermsConverter.ToString(Term[]) instead.", false)]
public static string ToString(
    Term[] value
)
<ObsoleteAttribute("Use TermsConverter.ToString(Term[]) instead.", false)>
Public Shared Function ToString (
    value As Term()
) As String
public:
[ObsoleteAttribute(L"Use TermsConverter.ToString(Term[]) instead.",
    false)]
static String^ ToString(
    array<Term^>^ value
)
[<ObsoleteAttribute("Use TermsConverter.ToString(Term[]) instead.",
    false)>]
static member ToString :
        value : Term[] -> string

Parameters

value
Type: SMath.ManagerTerm
Term array to perform conversion.Массив Term для преобразования.

Return Value

Type: String
Math expression represented as a string.Математическое выражение, записанное в строку.
See Also

Reference

Converter Class
ToString Overload
SMath.Manager Namespace


Converter.ToTerms Method

ConverterToTerms Method

Note: This API is now obsolete.

Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use TermsConverter.ToTerms(string) instead.", false)]
public static Term[] ToTerms(
    string value
)
<ObsoleteAttribute("Use TermsConverter.ToTerms(string) instead.", false)>
Public Shared Function ToTerms (
    value As String
) As Term()
public:
[ObsoleteAttribute(L"Use TermsConverter.ToTerms(string) instead.", false)]
static array<Term^>^ ToTerms(
    String^ value
)
[<ObsoleteAttribute("Use TermsConverter.ToTerms(string) instead.", false)>]
static member ToTerms :
        value : string -> Term[]

Parameters

value
Type: SystemString
String to convert.Строка для преобразования.

Return Value

Type: Term
Math expression in RPN represented by the array of Term.Математическое выражение в виде ОПЗ, представленная массивом Term.
See Also

Reference

Converter Class
SMath.Manager Namespace


DataCompression Class

LZW compression manager.
Inheritance Hierarchy
SystemObject
SMath.ManagerDataCompression

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DataCompression
Public Class DataCompression
public ref class DataCompression
type DataCompression =  class end

The DataCompression type exposes the following members.

Constructors
 | Name | Description
Public method | DataCompression | Initializes a new instance of the DataCompression class
Top
Methods
 | Name | Description
 | Compress |
 | Decompress |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


DataCompression Constructor

Initializes a new instance of the DataCompression class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DataCompression()
Public Sub New
public:
DataCompression()
new : unit -> DataCompression
See Also

Reference

DataCompression Class
SMath.Manager Namespace


DataCompression Methods

The DataCompression type exposes the following members.

Methods
 | Name | Description
 | Compress |
 | Decompress |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataCompression Class
SMath.Manager Namespace


DataCompression.Compress Method

DataCompressionCompress Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static MemoryStream Compress(
    Stream input
)
Public Shared Function Compress (
    input As Stream
) As MemoryStream
public:
static MemoryStream^ Compress(
    Stream^ input
)
static member Compress :
        input : Stream -> MemoryStream

Parameters

input
Type: System.IOStream

Return Value

Type: MemoryStream
See Also

Reference

DataCompression Class
SMath.Manager Namespace


DataCompression.Decompress Method

DataCompressionDecompress Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static MemoryStream Decompress(
    Stream input
)
Public Shared Function Decompress (
    input As Stream
) As MemoryStream
public:
static MemoryStream^ Decompress(
    Stream^ input
)
static member Decompress :
        input : Stream -> MemoryStream

Parameters

input
Type: System.IOStream

Return Value

Type: MemoryStream
See Also

Reference

DataCompression Class
SMath.Manager Namespace


Definition Class

Stores information about single definition.Хранит информацию о конкретном определении.
Inheritance Hierarchy
SystemObject
SMath.ManagerDefinition

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Definition
Public Class Definition
public ref class Definition
type Definition =  class end

The Definition type exposes the following members.

Constructors
 | Name | Description
Public method | Definition(Definition) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Term) | Obsolete. Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry, String) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry, String, Boolean) | Definition of the function/variable.Конструктор определения переменной или функции.
Top
Properties
 | Name | Description
Public property | Answer | Obsolete.
Public property | Depth | Defines context depth current definition is applicable to.
Public property | Description | Contains description of the definition.Содержит описание определения.
Public property | IsArgument |
Public property | IsCalculated | Defines if current definition was already calculated and doesn't require any additional evaluation to proceed or not.
Public property | IsDeleted | Returns true if this definition is not actual anymore.Определяет, должно ли текущее определение игнорироваться или оно является актуальным.
Public property | IsFunction | Returns a type of the definition: Function (true) or Variable (false).Возвращает статус определения: функция (истина) или переменная (ложь).
Public property | IsInUse | Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions).Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).
Public property | IsLocal | Defines if definition was created within current Region or outside of it (i.e. inside another Region of the Worksheet).
Public property | IsProgram | Detects procedure at right part of the definition.
Public property | IsSpecial | Defines if definition is a special kind of built-in variable/function.
Public property | IsTerminator | Returns true if this definition is Terminator.Возвращает истину, если определение является заглушкой.
Public property | Name | Name of the Function or Variable.Имя функции или переменной.
Public property | Result | Value of the Function or Variable.Значение функции или переменной.
Public property | Variables | If function, then a list of variables should be defined.Список аргументов, если определяется функция.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToEntry |
Public method | ToString | Shows a string representation of current definition.Показывает строковое представление текущего определения. (Overrides ObjectToString.)
Public method | ToTerm |
Public method | ToTerm(SessionProfile) |
Top
See Also

Reference

SMath.Manager Namespace


Definition Constructor

Overload List
 | Name | Description
Public method | Definition(Definition) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Term) | Obsolete. Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry, String) | Initializes a new instance of the Definition class
Public method | Definition(String, Term, Entry, String, Boolean) | Definition of the function/variable.Конструктор определения переменной или функции.
Top
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition Constructor (Definition)

Initializes a new instance of the Definition class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Definition(
    Definition value
)
Public Sub New (
    value As Definition
)
public:
Definition(
    Definition^ value
)
new :
        value : Definition -> Definition

Parameters

value
Type: SMath.ManagerDefinition
See Also

Reference

Definition Class
Definition Overload
SMath.Manager Namespace


Definition Constructor (String, Term[], Entry)

Definition Constructor (String, Term, Entry)

Initializes a new instance of the Definition class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Definition(
    string name,
    Term[] variables,
    Entry answer
)
Public Sub New (
    name As String,
    variables As Term(),
    answer As Entry
)
public:
Definition(
    String^ name,
    array<Term^>^ variables,
    Entry^ answer
)
new :
        name : string *
        variables : Term[] *
        answer : Entry -> Definition

Parameters

name
Type: SystemString
variables
Type: SMath.ManagerTerm
answer
Type: SMath.ManagerEntry
See Also

Reference

Definition Class
Definition Overload
SMath.Manager Namespace


Definition Constructor (String, Term[], Term[])

Definition Constructor (String, Term, Term)

Note: This API is now obsolete.

Initializes a new instance of the Definition class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public Definition(
    string name,
    Term[] answer,
    Term[] variables
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Sub New (
    name As String,
    answer As Term(),
    variables As Term()
)
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
Definition(
    String^ name,
    array<Term^>^ answer,
    array<Term^>^ variables
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
new :
        name : string *
        answer : Term[] *
        variables : Term[] -> Definition

Parameters

name
Type: SystemString
answer
Type: SMath.ManagerTerm
variables
Type: SMath.ManagerTerm
See Also

Reference

Definition Class
Definition Overload
SMath.Manager Namespace


Definition Constructor (String, Term[], Entry, String)

Definition Constructor (String, Term, Entry, String)

Initializes a new instance of the Definition class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Definition(
    string name,
    Term[] variables,
    Entry answer,
    string description
)
Public Sub New (
    name As String,
    variables As Term(),
    answer As Entry,
    description As String
)
public:
Definition(
    String^ name,
    array<Term^>^ variables,
    Entry^ answer,
    String^ description
)
new :
        name : string *
        variables : Term[] *
        answer : Entry *
        description : string -> Definition

Parameters

name
Type: SystemString
variables
Type: SMath.ManagerTerm
answer
Type: SMath.ManagerEntry
description
Type: SystemString
See Also

Reference

Definition Class
Definition Overload
SMath.Manager Namespace


Definition Constructor (String, Term[], Entry, String, Boolean)

Definition Constructor (String, Term, Entry, String, Boolean)

Definition of the function/variable.Конструктор определения переменной или функции.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Definition(
    string name,
    Term[] variables,
    Entry result,
    string description,
    bool isSpecial
)
Public Sub New (
    name As String,
    variables As Term(),
    result As Entry,
    description As String,
    isSpecial As Boolean
)
public:
Definition(
    String^ name,
    array<Term^>^ variables,
    Entry^ result,
    String^ description,
    bool isSpecial
)
new :
        name : string *
        variables : Term[] *
        result : Entry *
        description : string *
        isSpecial : bool -> Definition

Parameters

name
Type: SystemString
Name of the function/variable.Имя переменной или функции.
variables
Type: SMath.ManagerTerm
If function, then a list of variables should be defined.Список аргументов, если определяется функция.
result
Type: SMath.ManagerEntry
Value of the function/variable.Значение переменной или функции.
description
Type: SystemString
Description of the function/variable.Описание переменной или функции.
isSpecial
Type: SystemBoolean
Indicates whether value of the global variable/function defined in run-time (used in very special cases).Определяет, задаётся ли значение для этой глобальной переменной/функции в процессе вычисления или нет (используется в очень специальных случаях).
See Also

Reference

Definition Class
Definition Overload
SMath.Manager Namespace


Definition Properties

The Definition type exposes the following members.

Properties
 | Name | Description
Public property | Answer | Obsolete.
Public property | Depth | Defines context depth current definition is applicable to.
Public property | Description | Contains description of the definition.Содержит описание определения.
Public property | IsArgument |
Public property | IsCalculated | Defines if current definition was already calculated and doesn't require any additional evaluation to proceed or not.
Public property | IsDeleted | Returns true if this definition is not actual anymore.Определяет, должно ли текущее определение игнорироваться или оно является актуальным.
Public property | IsFunction | Returns a type of the definition: Function (true) or Variable (false).Возвращает статус определения: функция (истина) или переменная (ложь).
Public property | IsInUse | Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions).Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).
Public property | IsLocal | Defines if definition was created within current Region or outside of it (i.e. inside another Region of the Worksheet).
Public property | IsProgram | Detects procedure at right part of the definition.
Public property | IsSpecial | Defines if definition is a special kind of built-in variable/function.
Public property | IsTerminator | Returns true if this definition is Terminator.Возвращает истину, если определение является заглушкой.
Public property | Name | Name of the Function or Variable.Имя функции или переменной.
Public property | Result | Value of the Function or Variable.Значение функции или переменной.
Public property | Variables | If function, then a list of variables should be defined.Список аргументов, если определяется функция.
Top
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Answer Property

DefinitionAnswer Property

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Result property instead.", false)]
public Term[] Answer { get; set; }
<ObsoleteAttribute("Use Result property instead.", false)>
Public Property Answer As Term()
    Get
    Set
public:
[ObsoleteAttribute(L"Use Result property instead.", false)]
property array<Term^>^ Answer {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
[<ObsoleteAttribute("Use Result property instead.", false)>]
member Answer : Term[] with get, set

Property Value

Type: Term
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Depth Property

DefinitionDepth Property

Defines context depth current definition is applicable to.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set
public:
property int Depth {
    int get ();
    void set (int value);
}
member Depth : int with get, set

Property Value

Type: Int32
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Description Property

DefinitionDescription Property

Contains description of the definition.Содержит описание определения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsArgument Property

DefinitionIsArgument Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsArgument { get; set; }
Public Property IsArgument As Boolean
    Get
    Set
public:
property bool IsArgument {
    bool get ();
    void set (bool value);
}
member IsArgument : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsCalculated Property

DefinitionIsCalculated Property

Defines if current definition was already calculated and doesn't require any additional evaluation to proceed or not.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsCalculated { get; set; }
Public Property IsCalculated As Boolean
    Get
    Set
public:
property bool IsCalculated {
    bool get ();
    void set (bool value);
}
member IsCalculated : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsDeleted Property

DefinitionIsDeleted Property

Returns true if this definition is not actual anymore.Определяет, должно ли текущее определение игнорироваться или оно является актуальным.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get
public:
property bool IsDeleted {
    bool get ();
}
member IsDeleted : bool with get

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsFunction Property

DefinitionIsFunction Property

Returns a type of the definition: Function (true) or Variable (false).Возвращает статус определения: функция (истина) или переменная (ложь).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsFunction { get; }
Public ReadOnly Property IsFunction As Boolean
    Get
public:
property bool IsFunction {
    bool get ();
}
member IsFunction : bool with get

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsInUse Property

DefinitionIsInUse Property

Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions).Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsInUse { get; set; }
Public Property IsInUse As Boolean
    Get
    Set
public:
property bool IsInUse {
    bool get ();
    void set (bool value);
}
member IsInUse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsLocal Property

DefinitionIsLocal Property

Defines if definition was created within current Region or outside of it (i.e. inside another Region of the Worksheet).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; set; }
Public Property IsLocal As Boolean
    Get
    Set
public:
property bool IsLocal {
    bool get ();
    void set (bool value);
}
member IsLocal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsProgram Property

DefinitionIsProgram Property

Detects procedure at right part of the definition.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsProgram { get; }
Public ReadOnly Property IsProgram As Boolean
    Get
public:
property bool IsProgram {
    bool get ();
}
member IsProgram : bool with get

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsSpecial Property

DefinitionIsSpecial Property

Defines if definition is a special kind of built-in variable/function.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsSpecial { get; set; }
Public Property IsSpecial As Boolean
    Get
    Set
public:
property bool IsSpecial {
    bool get ();
    void set (bool value);
}
member IsSpecial : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.IsTerminator Property

DefinitionIsTerminator Property

Returns true if this definition is Terminator.Возвращает истину, если определение является заглушкой.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsTerminator { get; }
Public ReadOnly Property IsTerminator As Boolean
    Get
public:
property bool IsTerminator {
    bool get ();
}
member IsTerminator : bool with get

Property Value

Type: Boolean
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Name Property

DefinitionName Property

Name of the Function or Variable.Имя функции или переменной.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Result Property

DefinitionResult Property

Value of the Function or Variable.Значение функции или переменной.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry Result { get; set; }
Public Property Result As Entry
    Get
    Set
public:
property Entry^ Result {
    Entry^ get ();
    void set (Entry^ value);
}
member Result : Entry with get, set

Property Value

Type: Entry
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.Variables Property

DefinitionVariables Property

If function, then a list of variables should be defined.Список аргументов, если определяется функция.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] Variables { get; set; }
Public Property Variables As Term()
    Get
    Set
public:
property array<Term^>^ Variables {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
member Variables : Term[] with get, set

Property Value

Type: Term
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition Methods

The Definition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToEntry |
Public method | ToString | Shows a string representation of current definition.Показывает строковое представление текущего определения. (Overrides ObjectToString.)
Public method | ToTerm |
Public method | ToTerm(SessionProfile) |
Top
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.ToEntry Method

DefinitionToEntry Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry ToEntry()
Public Function ToEntry As Entry
public:
Entry^ ToEntry()
member ToEntry : unit -> Entry

Return Value

Type: Entry
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.ToString Method

DefinitionToString Method

Shows a string representation of current definition.Показывает строковое представление текущего определения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Return a string representation of current definition.Возвращает строковое представление текущего определения.
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.ToTerm Method

DefinitionToTerm Method

Overload List
 | Name | Description
Public method | ToTerm |
Public method | ToTerm(SessionProfile) |
Top
See Also

Reference

Definition Class
SMath.Manager Namespace


Definition.ToTerm Method

DefinitionToTerm Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm()
Public Function ToTerm As Term
public:
Term^ ToTerm()
member ToTerm : unit -> Term

Return Value

Type: Term
See Also

Reference

Definition Class
ToTerm Overload
SMath.Manager Namespace


Definition.ToTerm Method (SessionProfile)

DefinitionToTerm Method (SessionProfile)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm(
    SessionProfile sessionProfile
)
Public Function ToTerm (
    sessionProfile As SessionProfile
) As Term
public:
Term^ ToTerm(
    SessionProfile^ sessionProfile
)
member ToTerm :
        sessionProfile : SessionProfile -> Term

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: Term
See Also

Reference

Definition Class
ToTerm Overload
SMath.Manager Namespace


DimensionInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDimensionInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DimensionInfo
Public Class DimensionInfo
public ref class DimensionInfo
type DimensionInfo =  class end

The DimensionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionInfo | Initializes a new instance of the DimensionInfo class
Top
Properties
 | Name | Description
Public property | ContainsBaseUnit |
Public property | Description |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindBestUnitBySystem |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetUnitsBySystem |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | TryInsertBaseUnit |
Top
See Also

Reference

SMath.Manager Namespace


DimensionInfo Constructor

Initializes a new instance of the DimensionInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DimensionInfo(
    string description
)
Public Sub New (
    description As String
)
public:
DimensionInfo(
    String^ description
)
new :
        description : string -> DimensionInfo

Parameters

description
Type: SystemString
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo Properties

The DimensionInfo type exposes the following members.

Properties
 | Name | Description
Public property | ContainsBaseUnit |
Public property | Description |
Top
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.ContainsBaseUnit Property

DimensionInfoContainsBaseUnit Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ContainsBaseUnit { get; }
Public ReadOnly Property ContainsBaseUnit As Boolean
    Get
public:
property bool ContainsBaseUnit {
    bool get ();
}
member ContainsBaseUnit : bool with get

Property Value

Type: Boolean
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.Description Property

DimensionInfoDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo Methods

The DimensionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindBestUnitBySystem |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetUnitsBySystem |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | TryInsertBaseUnit |
Top
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.FindBestUnitBySystem Method

DimensionInfoFindBestUnitBySystem Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public UnitInfo FindBestUnitBySystem(
    string system
)
Public Function FindBestUnitBySystem (
    system As String
) As UnitInfo
public:
UnitInfo^ FindBestUnitBySystem(
    String^ system
)
member FindBestUnitBySystem :
        system : string -> UnitInfo

Parameters

system
Type: SystemString

Return Value

Type: UnitInfo
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.GetUnitsBySystem Method

DimensionInfoGetUnitsBySystem Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<UnitInfo> GetUnitsBySystem(
    string system
)
Public Function GetUnitsBySystem (
    system As String
) As List(Of UnitInfo)
public:
List<UnitInfo^>^ GetUnitsBySystem(
    String^ system
)
member GetUnitsBySystem :
        system : string -> List<UnitInfo>

Parameters

system
Type: SystemString

Return Value

Type: ListUnitInfo
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.ToString Method

DimensionInfoToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DimensionInfo.TryInsertBaseUnit Method

DimensionInfoTryInsertBaseUnit Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void TryInsertBaseUnit(
    UnitInfo ui
)
Public Sub TryInsertBaseUnit (
    ui As UnitInfo
)
public:
void TryInsertBaseUnit(
    UnitInfo^ ui
)
member TryInsertBaseUnit :
        ui : UnitInfo -> unit

Parameters

ui
Type: SMath.ManagerUnitInfo
See Also

Reference

DimensionInfo Class
SMath.Manager Namespace


DocumentMetaData Class

Document meta-data which describes its origin.
Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentMetaData
SMath.ControlsWorksheetInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DocumentMetaData
Public Class DocumentMetaData
public ref class DocumentMetaData
type DocumentMetaData =  class end

The DocumentMetaData type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentMetaData | Initializes a new instance of the DocumentMetaData class
Top
Properties
 | Name | Description
Public property | Author |
Public property | Company |
Public property | Description |
Public property | Keywords |
Public property | Title |
Public property | Translator |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


DocumentMetaData Constructor

Initializes a new instance of the DocumentMetaData class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentMetaData()
Public Sub New
public:
DocumentMetaData()
new : unit -> DocumentMetaData
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData Properties

The DocumentMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Author |
Public property | Company |
Public property | Description |
Public property | Keywords |
Public property | Title |
Public property | Translator |
Top
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Author Property

DocumentMetaDataAuthor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
member Author : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Company Property

DocumentMetaDataCompany Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Company { get; set; }
Public Property Company As String
    Get
    Set
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}
member Company : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Description Property

DocumentMetaDataDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Keywords Property

DocumentMetaDataKeywords Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}
member Keywords : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Title Property

DocumentMetaDataTitle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData.Translator Property

DocumentMetaDataTranslator Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Translator { get; set; }
Public Property Translator As String
    Get
    Set
public:
property String^ Translator {
    String^ get ();
    void set (String^ value);
}
member Translator : string with get, set

Property Value

Type: String
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentMetaData Methods

The DocumentMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentMetaData Class
SMath.Manager Namespace


DocumentParams Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ControlsWorksheetParams
SMath.ManagerActionContext

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DocumentParams
Public Class DocumentParams
public ref class DocumentParams
type DocumentParams =  class end

The DocumentParams type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentParams | Initializes a new instance of the DocumentParams class
Top
Properties
 | Name | Description
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов.
Public property | Id |
Public property | Revision |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


DocumentParams Constructor

Initializes a new instance of the DocumentParams class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentParams()
Public Sub New
public:
DocumentParams()
new : unit -> DocumentParams
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DocumentParams Properties

The DocumentParams type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов.
Public property | Id |
Public property | Revision |
Top
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DocumentParams.FileName Property

DocumentParamsFileName Property

Current worksheet full file name.Полное имя файла текущего листа расчётов.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DocumentParams.Id Property

DocumentParamsId Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DocumentParams.Revision Property

DocumentParamsRevision Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
member Revision : int with get, set

Property Value

Type: Int32
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DocumentParams Methods

The DocumentParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DocumentParams Class
SMath.Manager Namespace


DrawingManager Class

Inheritance Hierarchy
SystemObject
SMath.ManagerDrawingManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class DrawingManager
Public Class DrawingManager
public ref class DrawingManager
type DrawingManager =  class end

The DrawingManager type exposes the following members.

Constructors
 | Name | Description
Public method | DrawingManager | Initializes a new instance of the DrawingManager class
Top
Properties
 | Name | Description
Public property | Absolute |
Public property | BackgroundColor |
Public property | BuiltInFunction |
Public property | BuiltInFunctionIndex |
Public property | BuiltInVariable |
Public property | BuiltInVariableIndex |
Public property | DefaultTerm |
Public property | DefaultTermIndex |
Public property | FontFamily |
Public property | FontSize |
Public property | Name |
Public property | Number |
Public property | Operator |
Public property | String |
Public property | TextColor |
Public property | Unit |
Public property | UnitIndex |
Public property | UserDefinedFunction |
Public property | UserDefinedFunctionIndex |
Public property | UserDefinedVariable |
Public property | UserDefinedVariableIndex |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColor |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
SettingsFileName |
Top
See Also

Reference

SMath.Manager Namespace


DrawingManager Constructor

Initializes a new instance of the DrawingManager class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DrawingManager(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
DrawingManager(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> DrawingManager

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager Properties

The DrawingManager type exposes the following members.

Properties
 | Name | Description
Public property | Absolute |
Public property | BackgroundColor |
Public property | BuiltInFunction |
Public property | BuiltInFunctionIndex |
Public property | BuiltInVariable |
Public property | BuiltInVariableIndex |
Public property | DefaultTerm |
Public property | DefaultTermIndex |
Public property | FontFamily |
Public property | FontSize |
Public property | Name |
Public property | Number |
Public property | Operator |
Public property | String |
Public property | TextColor |
Public property | Unit |
Public property | UnitIndex |
Public property | UserDefinedFunction |
Public property | UserDefinedFunctionIndex |
Public property | UserDefinedVariable |
Public property | UserDefinedVariableIndex |
Top
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Absolute Property

DrawingManagerAbsolute Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat Absolute { get; set; }
Public Property Absolute As TermFormat
    Get
    Set
public:
property TermFormat^ Absolute {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member Absolute : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.BackgroundColor Property

DrawingManagerBackgroundColor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
member BackgroundColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.BuiltInFunction Property

DrawingManagerBuiltInFunction Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat BuiltInFunction { get; set; }
Public Property BuiltInFunction As TermFormat
    Get
    Set
public:
property TermFormat^ BuiltInFunction {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member BuiltInFunction : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.BuiltInFunctionIndex Property

DrawingManagerBuiltInFunctionIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat BuiltInFunctionIndex { get; set; }
Public Property BuiltInFunctionIndex As TermFormat
    Get
    Set
public:
property TermFormat^ BuiltInFunctionIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member BuiltInFunctionIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.BuiltInVariable Property

DrawingManagerBuiltInVariable Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat BuiltInVariable { get; set; }
Public Property BuiltInVariable As TermFormat
    Get
    Set
public:
property TermFormat^ BuiltInVariable {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member BuiltInVariable : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.BuiltInVariableIndex Property

DrawingManagerBuiltInVariableIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat BuiltInVariableIndex { get; set; }
Public Property BuiltInVariableIndex As TermFormat
    Get
    Set
public:
property TermFormat^ BuiltInVariableIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member BuiltInVariableIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.DefaultTerm Property

DrawingManagerDefaultTerm Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat DefaultTerm { get; set; }
Public Property DefaultTerm As TermFormat
    Get
    Set
public:
property TermFormat^ DefaultTerm {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member DefaultTerm : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.DefaultTermIndex Property

DrawingManagerDefaultTermIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat DefaultTermIndex { get; set; }
Public Property DefaultTermIndex As TermFormat
    Get
    Set
public:
property TermFormat^ DefaultTermIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member DefaultTermIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.FontFamily Property

DrawingManagerFontFamily Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IFontFamily FontFamily { get; set; }
Public Property FontFamily As IFontFamily
    Get
    Set
public:
property IFontFamily^ FontFamily {
    IFontFamily^ get ();
    void set (IFontFamily^ value);
}
member FontFamily : IFontFamily with get, set

Property Value

Type: IFontFamily
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.FontSize Property

DrawingManagerFontSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int FontSize { get; }
Public ReadOnly Property FontSize As Integer
    Get
public:
property int FontSize {
    int get ();
}
member FontSize : int with get

Property Value

Type: Int32
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Name Property

DrawingManagerName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Number Property

DrawingManagerNumber Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat Number { get; set; }
Public Property Number As TermFormat
    Get
    Set
public:
property TermFormat^ Number {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member Number : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Operator Property

DrawingManagerOperator Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat Operator { get; set; }
Public Property Operator As TermFormat
    Get
    Set
public:
property TermFormat^ Operator {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member Operator : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.String Property

DrawingManagerString Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat String { get; set; }
Public Property String As TermFormat
    Get
    Set
public:
property TermFormat^ String {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member String : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.TextColor Property

DrawingManagerTextColor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
member TextColor : Color with get, set

Property Value

Type: Color
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Unit Property

DrawingManagerUnit Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat Unit { get; set; }
Public Property Unit As TermFormat
    Get
    Set
public:
property TermFormat^ Unit {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member Unit : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.UnitIndex Property

DrawingManagerUnitIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat UnitIndex { get; set; }
Public Property UnitIndex As TermFormat
    Get
    Set
public:
property TermFormat^ UnitIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member UnitIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.UserDefinedFunction Property

DrawingManagerUserDefinedFunction Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat UserDefinedFunction { get; set; }
Public Property UserDefinedFunction As TermFormat
    Get
    Set
public:
property TermFormat^ UserDefinedFunction {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member UserDefinedFunction : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.UserDefinedFunctionIndex Property

DrawingManagerUserDefinedFunctionIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat UserDefinedFunctionIndex { get; set; }
Public Property UserDefinedFunctionIndex As TermFormat
    Get
    Set
public:
property TermFormat^ UserDefinedFunctionIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member UserDefinedFunctionIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.UserDefinedVariable Property

DrawingManagerUserDefinedVariable Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat UserDefinedVariable { get; set; }
Public Property UserDefinedVariable As TermFormat
    Get
    Set
public:
property TermFormat^ UserDefinedVariable {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member UserDefinedVariable : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.UserDefinedVariableIndex Property

DrawingManagerUserDefinedVariableIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat UserDefinedVariableIndex { get; set; }
Public Property UserDefinedVariableIndex As TermFormat
    Get
    Set
public:
property TermFormat^ UserDefinedVariableIndex {
    TermFormat^ get ();
    void set (TermFormat^ value);
}
member UserDefinedVariableIndex : TermFormat with get, set

Property Value

Type: TermFormat
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager Methods

The DrawingManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColor |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Load |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.GetColor Method

DrawingManagerGetColor Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color GetColor(
    int inc
)
Public Function GetColor (
    inc As Integer
) As Color
public:
Color GetColor(
    int inc
)
member GetColor :
        inc : int -> Color

Parameters

inc
Type: SystemInt32

Return Value

Type: Color
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.Load Method

DrawingManagerLoad Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Load(
    Stream stream,
    string name,
    Nullable<int> size
)
Public Sub Load (
    stream As Stream,
    name As String,
    size As Nullable(Of Integer)
)
public:
void Load(
    Stream^ stream,
    String^ name,
    Nullable<int> size
)
member Load :
        stream : Stream *
        name : string *
        size : Nullable<int> -> unit

Parameters

stream
Type: System.IOStream
name
Type: SystemString
size
Type: SystemNullableInt32
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.SetColor Method

DrawingManagerSetColor Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetColor(
    int inc,
    Color color
)
Public Sub SetColor (
    inc As Integer,
    color As Color
)
public:
void SetColor(
    int inc,
    Color color
)
member SetColor :
        inc : int *
        color : Color -> unit

Parameters

inc
Type: SystemInt32
color
Type: System.DrawingColor
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager Fields

The DrawingManager type exposes the following members.

Fields
Name | Description
SettingsFileName |
Top
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


DrawingManager.SettingsFileName Field

DrawingManagerSettingsFileName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SettingsFileName
Public Shared SettingsFileName As String
public:
static String^ SettingsFileName
static val mutable SettingsFileName: string

Field Value

Type: String
See Also

Reference

DrawingManager Class
SMath.Manager Namespace


EmptyPlaceholderException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.ManagerGeneralException
SMath.ManagerMathException
SMath.ManagerEmptyPlaceholderException

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class EmptyPlaceholderException : MathException
Public Class EmptyPlaceholderException
    Inherits MathException
public ref class EmptyPlaceholderException : public MathException
type EmptyPlaceholderException =
    class
        inherit MathException
    end

The EmptyPlaceholderException type exposes the following members.

Constructors
 | Name | Description
Public method | EmptyPlaceholderException(IPrimitive) | Initializes a new instance of the EmptyPlaceholderException class
Public method | EmptyPlaceholderException(TermType) | Initializes a new instance of the EmptyPlaceholderException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение. (Inherited from MathException.)
Public property | EvaluationStack | (Inherited from MathException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

SMath.Manager Namespace


EmptyPlaceholderException Constructor

Overload List
 | Name | Description
Public method | EmptyPlaceholderException(IPrimitive) | Initializes a new instance of the EmptyPlaceholderException class
Public method | EmptyPlaceholderException(TermType) | Initializes a new instance of the EmptyPlaceholderException class
Top
See Also

Reference

EmptyPlaceholderException Class
SMath.Manager Namespace


EmptyPlaceholderException Constructor (IPrimitive)

Initializes a new instance of the EmptyPlaceholderException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EmptyPlaceholderException(
    IPrimitive element
)
Public Sub New (
    element As IPrimitive
)
public:
EmptyPlaceholderException(
    IPrimitive^ element
)
new :
        element : IPrimitive -> EmptyPlaceholderException

Parameters

element
Type: SMath.ManagerIPrimitive
See Also

Reference

EmptyPlaceholderException Class
EmptyPlaceholderException Overload
SMath.Manager Namespace


EmptyPlaceholderException Constructor (TermType)

Initializes a new instance of the EmptyPlaceholderException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EmptyPlaceholderException(
    TermType type
)
Public Sub New (
    type As TermType
)
public:
EmptyPlaceholderException(
    TermType type
)
new :
        type : TermType -> EmptyPlaceholderException

Parameters

type
Type: SMath.ManagerTermType
See Also

Reference

EmptyPlaceholderException Class
EmptyPlaceholderException Overload
SMath.Manager Namespace


EmptyPlaceholderException Properties

The EmptyPlaceholderException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение. (Inherited from MathException.)
Public property | EvaluationStack | (Inherited from MathException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EmptyPlaceholderException Class
SMath.Manager Namespace


EmptyPlaceholderException Methods

The EmptyPlaceholderException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EmptyPlaceholderException Class
SMath.Manager Namespace


EmptyPlaceholderException Fields

The EmptyPlaceholderException type exposes the following members.

Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

EmptyPlaceholderException Class
SMath.Manager Namespace


EmptyPlugin Class

Inheritance Hierarchy
SystemObject
SMath.ManagerEmptyPlugin

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class EmptyPlugin : IPlugin,
    IDisposable
Public Class EmptyPlugin
    Implements IPlugin, IDisposable
public ref class EmptyPlugin : IPlugin,
    IDisposable
type EmptyPlugin =
    class
        interface IPlugin
        interface IDisposable
    end

The EmptyPlugin type exposes the following members.

Constructors
 | Name | Description
Public method | EmptyPlugin | Initializes a new instance of the EmptyPlugin class
Top
Properties
 | Name | Description
Public property | Dependences |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the EmptyPlugin
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


EmptyPlugin Constructor

Initializes a new instance of the EmptyPlugin class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EmptyPlugin()
Public Sub New
public:
EmptyPlugin()
new : unit -> EmptyPlugin
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


EmptyPlugin Properties

The EmptyPlugin type exposes the following members.

Properties
 | Name | Description
Public property | Dependences |
Top
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


EmptyPlugin.Dependences Property

EmptyPluginDependences Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo[] Dependences { get; }
Public ReadOnly Property Dependences As AssemblyInfo()
    Get
public:
property array<AssemblyInfo>^ Dependences {
    array<AssemblyInfo>^ get ();
}
member Dependences : AssemblyInfo[] with get

Property Value

Type: AssemblyInfo
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


EmptyPlugin Methods

The EmptyPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


EmptyPlugin.Dispose Method

EmptyPluginDispose Method

Releases all resources used by the EmptyPlugin

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


EmptyPlugin.Initialize Method

EmptyPluginInitialize Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implements

IPluginInitialize
See Also

Reference

EmptyPlugin Class
SMath.Manager Namespace


Entry Class

Data format used for calculations. Allows to manage expressions as a tree.
Inheritance Hierarchy
SystemObject
SMath.ManagerEntry

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Entry : IPrimitive<Entry>,
    IPrimitive
Public Class Entry
    Implements IPrimitive(Of Entry), IPrimitive
public ref class Entry : IPrimitive<Entry^>,
    IPrimitive
type Entry =
    class
        interface IPrimitive<Entry>
        interface IPrimitive
    end

The Entry type exposes the following members.

Constructors
 | Name | Description
Public method | Entry(String) | Constructor to create an expression operand.
Public method | Entry(Entry) | Constructor to create a full copy of the given Entry.
Public method | Entry(IPrimitive) | Initializes a new instance of the Entry class
Public method | Entry(String, TermType, Entry) | Initializes a new instance of the Entry class
Top
Properties
 | Name | Description
Public property | ArgsCount |
Public property | Items | Children of current entry.
Public property | RecurseItemsCount | Returns overall length of the Entry items (recursively).
Public property | Tag |
Public property | TagSubst |
Public property | Text |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Contains | Determines whether a primitive is in the expression.
 | CopyWithVeryFirstLeast |
 | Create | Creates a new instance of Entry from list of Terms.
 | CreateMeta | Creates a new instance of Entry from list of Terms.
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetRevertedEnumerator | Returns reverted enumerator to iterate through equation terms. NOTE: The result terms has reverted order but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVeryFirstLeast | Gets the very first operand of the expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRevertedList | Non recursive retrieving of the list of primitives in reverted order. NOTE: It is a bit slower then ToTermsList and result array has reverted order of items but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.
Public method | ToString | String representation of math expression.Строковое представление математического выражения. (Overrides ObjectToString.)
Public method | ToTagsList |
Public method | ToTerm | Terms array representation of math expression.Представление математического выражения в виде массива Term.
Public method | ToTermsList | Terms list representation of math expression.Представление математического выражения в виде списка Term.
 | TryFixStructure | Converts list of Terms to new Entry instance with checks for missing parenthesis and errors in math expression structure.
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

SMath.Manager Namespace


Entry Constructor

Overload List
 | Name | Description
Public method | Entry(String) | Constructor to create an expression operand.
Public method | Entry(Entry) | Constructor to create a full copy of the given Entry.
Public method | Entry(IPrimitive) | Initializes a new instance of the Entry class
Public method | Entry(String, TermType, Entry) | Initializes a new instance of the Entry class
Top
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry Constructor (String)

Constructor to create an expression operand.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry(
    string text
)
Public Sub New (
    text As String
)
public:
Entry(
    String^ text
)
new :
        text : string -> Entry

Parameters

text
Type: SystemString
Text value of the operand.
See Also

Reference

Entry Class
Entry Overload
SMath.Manager Namespace


Entry Constructor (Entry)

Constructor to create a full copy of the given Entry.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry(
    Entry value
)
Public Sub New (
    value As Entry
)
public:
Entry(
    Entry^ value
)
new :
        value : Entry -> Entry

Parameters

value
Type: SMath.ManagerEntry
Entry to copy expression from.
See Also

Reference

Entry Class
Entry Overload
SMath.Manager Namespace


Entry Constructor (IPrimitive)

Initializes a new instance of the Entry class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry(
    IPrimitive value
)
Public Sub New (
    value As IPrimitive
)
public:
Entry(
    IPrimitive^ value
)
new :
        value : IPrimitive -> Entry

Parameters

value
Type: SMath.ManagerIPrimitive
See Also

Reference

Entry Class
Entry Overload
SMath.Manager Namespace


Entry Constructor (String, TermType, Entry[])

Entry Constructor (String, TermType, Entry)

Initializes a new instance of the Entry class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry(
    string text,
    TermType type,
    Entry[] items
)
Public Sub New (
    text As String,
    type As TermType,
    items As Entry()
)
public:
Entry(
    String^ text,
    TermType type,
    array<Entry^>^ items
)
new :
        text : string *
        type : TermType *
        items : Entry[] -> Entry

Parameters

text
Type: SystemString
type
Type: SMath.ManagerTermType
items
Type: SMath.ManagerEntry
See Also

Reference

Entry Class
Entry Overload
SMath.Manager Namespace


Entry Properties

The Entry type exposes the following members.

Properties
 | Name | Description
Public property | ArgsCount |
Public property | Items | Children of current entry.
Public property | RecurseItemsCount | Returns overall length of the Entry items (recursively).
Public property | Tag |
Public property | TagSubst |
Public property | Text |
Public property | Type |
Top
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ArgsCount Property

EntryArgsCount Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ArgsCount { get; }
Public ReadOnly Property ArgsCount As Integer
    Get
public:
virtual property int ArgsCount {
    int get () sealed;
}
abstract ArgsCount : int with get
override ArgsCount : int with get

Property Value

Type: Int32

Implements

IPrimitiveArgsCount
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Items Property

EntryItems Property

Children of current entry.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry[] Items { get; }
Public ReadOnly Property Items As Entry()
    Get
public:
virtual property array<Entry^>^ Items {
    array<Entry^>^ get () sealed;
}
abstract Items : Entry[] with get
override Items : Entry[] with get

Property Value

Type: Entry

Implements

IPrimitiveTItems
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.RecurseItemsCount Property

EntryRecurseItemsCount Property

Returns overall length of the Entry items (recursively).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int RecurseItemsCount { get; }
Public ReadOnly Property RecurseItemsCount As Integer
    Get
public:
property int RecurseItemsCount {
    int get ();
}
member RecurseItemsCount : int with get

Property Value

Type: Int32
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Tag Property

EntryTag Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term Tag { get; set; }
Public Property Tag As Term
    Get
    Set
public:
property Term^ Tag {
    Term^ get ();
    void set (Term^ value);
}
member Tag : Term with get, set

Property Value

Type: Term
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.TagSubst Property

EntryTagSubst Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term TagSubst { get; set; }
Public Property TagSubst As Term
    Get
    Set
public:
property Term^ TagSubst {
    Term^ get ();
    void set (Term^ value);
}
member TagSubst : Term with get, set

Property Value

Type: Term
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Text Property

EntryText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IPrimitiveText
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Type Property

EntryType Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermType Type { get; }
Public ReadOnly Property Type As TermType
    Get
public:
virtual property TermType Type {
    TermType get () sealed;
}
abstract Type : TermType with get
override Type : TermType with get

Property Value

Type: TermType

Implements

IPrimitiveType
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry Methods

The Entry type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether a primitive is in the expression.
 | CopyWithVeryFirstLeast |
 | Create | Creates a new instance of Entry from list of Terms.
 | CreateMeta | Creates a new instance of Entry from list of Terms.
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetRevertedEnumerator | Returns reverted enumerator to iterate through equation terms. NOTE: The result terms has reverted order but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVeryFirstLeast | Gets the very first operand of the expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToRevertedList | Non recursive retrieving of the list of primitives in reverted order. NOTE: It is a bit slower then ToTermsList and result array has reverted order of items but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.
Public method | ToString | String representation of math expression.Строковое представление математического выражения. (Overrides ObjectToString.)
Public method | ToTagsList |
Public method | ToTerm | Terms array representation of math expression.Представление математического выражения в виде массива Term.
Public method | ToTermsList | Terms list representation of math expression.Представление математического выражения в виде списка Term.
 | TryFixStructure | Converts list of Terms to new Entry instance with checks for missing parenthesis and errors in math expression structure.
Top
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Contains Method

EntryContains Method

Determines whether a primitive is in the expression.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    IPrimitive value
)
Public Function Contains (
    value As IPrimitive
) As Boolean
public:
bool Contains(
    IPrimitive^ value
)
member Contains :
        value : IPrimitive -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
Primitive to locate in math expression.

Return Value

Type: Boolean
Returns true if primitive is found in the expression; otherwise, false.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.CopyWithVeryFirstLeast Method

EntryCopyWithVeryFirstLeast Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Entry CopyWithVeryFirstLeast(
    Entry value,
    Entry least
)
Public Shared Function CopyWithVeryFirstLeast (
    value As Entry,
    least As Entry
) As Entry
public:
static Entry^ CopyWithVeryFirstLeast(
    Entry^ value,
    Entry^ least
)
static member CopyWithVeryFirstLeast :
        value : Entry *
        least : Entry -> Entry

Parameters

value
Type: SMath.ManagerEntry
least
Type: SMath.ManagerEntry

Return Value

Type: Entry
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Create Method

EntryCreate Method

Creates a new instance of Entry from list of Terms.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Entry Create(
    IEnumerable<Term> value
)
Public Shared Function Create (
    value As IEnumerable(Of Term)
) As Entry
public:
static Entry^ Create(
    IEnumerable<Term^>^ value
)
static member Create :
        value : IEnumerable<Term> -> Entry

Parameters

value
Type: System.Collections.GenericIEnumerableTerm
List of Terms to use as a source.

Return Value

Type: Entry
Math expression as an instance of Entry.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.CreateMeta Method

EntryCreateMeta Method

Creates a new instance of Entry from list of Terms.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Entry CreateMeta(
    IEnumerable<Term> value
)
Public Shared Function CreateMeta (
    value As IEnumerable(Of Term)
) As Entry
public:
static Entry^ CreateMeta(
    IEnumerable<Term^>^ value
)
static member CreateMeta :
        value : IEnumerable<Term> -> Entry

Parameters

value
Type: System.Collections.GenericIEnumerableTerm
List of Terms to use as a source.

Return Value

Type: Entry
Math expression as an instance of Entry.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Equals Method

EntryEquals Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.GetHashCode Method

EntryGetHashCode Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.GetRevertedEnumerator Method

EntryGetRevertedEnumerator Method

Returns reverted enumerator to iterate through equation terms. NOTE: The result terms has reverted order but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Entry> GetRevertedEnumerator()
Public Function GetRevertedEnumerator As IEnumerable(Of Entry)
public:
IEnumerable<Entry^>^ GetRevertedEnumerator()
member GetRevertedEnumerator : unit -> IEnumerable<Entry>

Return Value

Type: IEnumerableEntry
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.GetVeryFirstLeast Method

EntryGetVeryFirstLeast Method

Gets the very first operand of the expression.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry GetVeryFirstLeast()
Public Function GetVeryFirstLeast As Entry
public:
Entry^ GetVeryFirstLeast()
member GetVeryFirstLeast : unit -> Entry

Return Value

Type: Entry
Very first operand of the expression.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ToRevertedList Method

EntryToRevertedList Method

Non recursive retrieving of the list of primitives in reverted order. NOTE: It is a bit slower then ToTermsList and result array has reverted order of items but it do not use recursion, which allows to avoid usage of call stack to prevent StackOverflow exception. This method is strongly recommended for complex expressions.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Entry> ToRevertedList()
Public Function ToRevertedList As List(Of Entry)
public:
virtual List<Entry^>^ ToRevertedList() sealed
abstract ToRevertedList : unit -> List<Entry>
override ToRevertedList : unit -> List<Entry>

Return Value

Type: ListEntry
List of primitives in reverted order.

Implements

IPrimitiveTToRevertedList
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ToString Method

EntryToString Method

String representation of math expression.Строковое представление математического выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Math expression as a string.Выражение, записанное в строку.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ToTagsList Method

EntryToTagsList Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Term> ToTagsList()
Public Function ToTagsList As List(Of Term)
public:
List<Term^>^ ToTagsList()
member ToTagsList : unit -> List<Term>

Return Value

Type: ListTerm
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ToTerm Method

EntryToTerm Method

Terms array representation of math expression.Представление математического выражения в виде массива Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm()
Public Function ToTerm As Term
public:
Term^ ToTerm()
member ToTerm : unit -> Term

Return Value

Type: Term
Math expression as a Terms array.Выражение, записанное в виде массива Term.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.ToTermsList Method

EntryToTermsList Method

Terms list representation of math expression.Представление математического выражения в виде списка Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<Term> ToTermsList()
Public Function ToTermsList As List(Of Term)
public:
virtual List<Term^>^ ToTermsList() sealed
abstract ToTermsList : unit -> List<Term>
override ToTermsList : unit -> List<Term>

Return Value

Type: ListTerm
Math expression as a Terms list.Выражение, записанное в виде списка Term.

Implements

IPrimitiveTToTermsList
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.TryFixStructure Method

EntryTryFixStructure Method

Converts list of Terms to new Entry instance with checks for missing parenthesis and errors in math expression structure.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryFixStructure(
    IEnumerable<Term> terms,
    out Entry entry
)
Public Shared Function TryFixStructure (
    terms As IEnumerable(Of Term),
    <OutAttribute> ByRef entry As Entry
) As Boolean
public:
static bool TryFixStructure(
    IEnumerable<Term^>^ terms,
    [OutAttribute] Entry^% entry
)
static member TryFixStructure :
        terms : IEnumerable<Term> *
        entry : Entry byref -> bool

Parameters

terms
Type: System.Collections.GenericIEnumerableTerm
List of Terms to use as a source.
entry
Type: SMath.ManagerEntry
Result math expression as an instance of Entry.

Return Value

Type: Boolean
Result of the structure test.
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry Operators

The Entry type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Equality Operator

EntryEquality Operator

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Entry c1,
    Entry c2
)
Public Shared Operator = (
    c1 As Entry,
    c2 As Entry
) As Boolean
public:
static bool operator ==(
    Entry^ c1,
    Entry^ c2
)
static let inline (=)
        c1 : Entry *
        c2 : Entry  : bool

Parameters

c1
Type: SMath.ManagerEntry
c2
Type: SMath.ManagerEntry

Return Value

Type: Boolean
See Also

Reference

Entry Class
SMath.Manager Namespace


Entry.Inequality Operator

EntryInequality Operator

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Entry c1,
    Entry c2
)
Public Shared Operator <> (
    c1 As Entry,
    c2 As Entry
) As Boolean
public:
static bool operator !=(
    Entry^ c1,
    Entry^ c2
)
static let inline (<>)
        c1 : Entry *
        c2 : Entry  : bool

Parameters

c1
Type: SMath.ManagerEntry
c2
Type: SMath.ManagerEntry

Return Value

Type: Boolean
See Also

Reference

Entry Class
SMath.Manager Namespace


ErrorOccuredEventHandler Delegate

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void ErrorOccuredEventHandler(
    ActionContext context,
    string message
)
Public Delegate Sub ErrorOccuredEventHandler (
    context As ActionContext,
    message As String
)
public delegate void ErrorOccuredEventHandler(
    ActionContext^ context,
    String^ message
)
type ErrorOccuredEventHandler =
    delegate of
        context : ActionContext *
        message : string -> unit

Parameters

context
Type: SMath.ManagerActionContext
message
Type: SystemString
See Also

Reference

SMath.Manager Namespace


Errors Enumeration

Перечисление доступных ошибок программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum Errors
Public Enumeration Errors
public enum class Errors
type Errors
Members
Member name | Value | Description
NoError | -1 | Нет ошибки.
EmptyElements | 0 | Не все пустые элементы заполнены.
EmptyOperators | 1 | Не все пустые операторы заполнены.
NotDefined | 2 | - не определено.
SystemsNotSupported | 3 | Системы не поддерживаются.
ArgumentMustBeScalar | 4 | Аргумент должен быть скаляром.
LimitsMustBeInteger | 5 | Пределы функции должны быть целыми действительными числами.
TypeConversionError | 6 | Ошибка приведения типов. Пожалуйста, свяжитесь с разработчиком программы с указанием вызвавшего данную ошибку примера.
ArgumentCanNotBeZero | 7 | Аргумент нуля не существует.
NoResult | 8 | Нет решения.
CriticalError | 9 | Обнаружена критическая ошибка.
RestorationStarted | 10 | Если восстановление пройдёт безуспешно, экстренное сохранение информации Вы найдёте в папке программы по адресу: .
Uncertainty | 11 | Неопределённость.
ArgumentMustBePositiveInteger | 12 | Аргумент должен быть целым положительным числом.
RoundingCoefficientError | 13 | Коэффициент округления должен лежать в диапазоне от 0 до 15 включительно.
VariableOfIntegrationNotSpecified | 14 | Переменная интегрирования не указана, либо указана не верно.
LimitsMustBeReal | 15 | Пределы интегрирования должны быть действительными числами.
NoRealRoots | 16 | Действительных корней нет.
InequalitiesNotSupported | 17 | Неравенства не поддерживаются.
CanNotFindFile | 18 | Невозможно найти файл:.
CanNotStartsWithNumber | 19 | Названия параметров и функций не могут начинаться с числа. Пожалуйста, задайте другое имя.
ControlCanNotBeDisplayed | 20 | Один или несколько элементов листа не удаётся отобразить.
XMCDFileCanNotBeFullyParsed | 21 | {0} ошибок обнаружено при разборе .xmcd файла. Данная версия программы не может полностью отобразить документ. Пожалуйста, проверьте доступные обновления программы, в противном случае отправьте файл разработчикам для будущей реализации.
RealPartMustBeMoreThanZero | 22 | Действительная часть аргумента должна быть больше нуля.
XMCDFileCanNotBeFullySaved | 23 | {0} ошибок обнаружено при сохранении .xmcd файла. Установленная версия программы не может полностью сохранить документ в выбранном формате. Используйте формат файлов SMath Studio (*.sm) для сохранения всех данных листа.
DimensionsDifferent | 24 | Размерность элементов различна.
ProcessingInterruptedByUser | 25 | Вычисление прервано пользователем.
ArgumentMustBeVector | 26 | Аргумент должен быть вектором.
FileRequiresNewerProgram | 27 | Файл {0} был создан с помощью более поздней версии {1}: {2}.
FileRequiresNewerPlugin | 28 | Файл {0} требует более позднюю версию дополнения {1}: {2} или старшую.
FileRequiresForPlugin | 29 | Файл {0} требует, чтобы было установлено дополнение: {1} (версия: {2}; GUID: {3}).
AlertsOccuredOnFileOpen | 30 | Ошибки произошли во время открытия файла {0}.
FileCanBeOpenedWithErrors | 31 | Результат открытия файла может содержать ошибки. Вы всё равно хотите открыть файл {0}?
PluginCannotBeEnabled | 32 | Ошибка возникла при открытии стороннего дополнения. Дополнение отключено.
PluginRequiresNewerProgram | 33 | Дополнение {0} требует более новой версии программы {1}: {2} или старшую.
PluginRequiresNewerPlugin | 34 | Дополнение {0} требует наличия новой версии дополнительного установленного дополнения {1}: {2} или старшую.
PluginRequiresForPlugin | 35 | Дополнение {0} требует наличия дополнительного установленного дополнения: {1} (версия: {2}; GUID: {3}).
AlertsOccuredOnPluginOpen | 36 | Ошибки возникли при подключении дополнения {0}.
PluginCanBeOpenedWithErrors | 37 | Используя данный плагин на листе могут возникнуть неожиданные ошибки визуализации и/или вычисления. Вы всё равно хотите активировать дополнение {0}?
WrongDomainOrIpSpecified | 38 | Wrong Domain name or IP address specified.
WrongLoginNameSpecified | 39 | Wrong Login name specified.
WrongPasswordSpecified | 40 | Wrong password specified.
WrongSessionIdSpecified | 41 | Wrong Session ID specified.
FunctionNotDefined | 42 | - функция не определена.
ResultIsAboveMaxAllowedPositiveNumber | 43 | Значение вышло за пределы максимально-допустимого положительного числа.
ResultIsBelowMinAllowedNegativeNumber | 44 | Значение вышло за пределы минимально-допустимого отрицательного числа.
ArgumentMustBeString | 45 | Argument must be a string.
CanNotParseString | 46 | Невозможно разобрать строку:.
WrongArguments | 47 | Function has some invalid arguments.
ActionCouldNotBePerformedWithText | 48 | Action could not be performed with text.
ResultIsAboveMaxAllowedForByte | 49 | Значение вышло за пределы максимально-допустимого для байта.
FileHasWrongFormat | 50 | File has wrong format. Data import cannot be performed.
FileIsEmpty | 51 | File is empty. No data imported.
ResultIsAboveMaxAllowedWhenIncreasing | 52 | Значение вышло за пределы максимально-допустимого при увеличении.
ResultIsBelowMinAllowedWhenDecreasing | 53 | Значение вышло за пределы минимально-допустимого при уменьшении.
IncreaseMaximumNumberLength | 54 | Необходимо увеличить количество значащих цифр ('Меню' >> 'Опции' >> 'Вычисления' >> 'Макс. длина чисел').
VariablesShouldBeDefinedForArgumentFunctions | 55 | Нельзя передавать значения переменных функции-аргумента. / Variables should be defined for argument-functions.
NumeralSystemBaseError | 56 | Основание системы счисления должно принимать значение от 1 до 37.
DivisionByZero | 57 | Деление на ноль.
LogarithmOfZeroIsNotDefined | 58 | Логарифм нуля не существует.
ArgumentMustBeRealNumber | 59 | Аргумент должен быть действительным.
NumberOfRowsOrColumnsDoNotMatch | 60 | Количество строк или столбцов первой матрицы не соответствует количеству строк или столбцов второй матрицы.
MatricesDoNotMatch | 61 | Матрицы не соответственные.
DivisorMatrixMustBeSquare | 62 | Матрица-делитель не квадратная.
CrossProductCanNotBeCalculated | 63 | Векторное произведение доступно только для векторов, заданных тремя компонентами.
CanNotCalculate | 64 | Не могу вычислить.
MatrixMustBeSquare | 65 | Матрица не квадратная.
FactorialNotDefined | 66 | Факториал существует только от натуральных чисел и нуля.
MatrixNoninvertible | 67 | Не существует, матрица вырожденная (определитель матрицы равен нулю).
ExampleIncorrect | 68 | Выражение задано не верно.
ArgumentMustBeMatrixOrVector | 69 | Аргумент не может быть скаляром.
CanNotSolve | 70 | По заданным критериям ответ найти невозможно. Проверьте настройки программы ('Меню' >> 'Опции' >> 'Вычисления' >> 'Ответ (множества)').
LogarithmCanNotBeZeroBase | 71 | Ноль не может быть основанием логарифма.
LogarithmCanNotBeOneBase | 72 | Единица не может быть основанием логарифма.
CanNotParseMatrix | 73 | Клеточные матрицы не поддерживаются (нельзя вычислить матрицу, один или несколько элементов которой - матрицы).
UnitsDontMatch | 74 | Units don't match.
CanNotInsert | 75 | Невозможно вставить.
CanNotParse | 76 | формат не поддерживается.
SelectExpression | 77 | Выделите разбираемое выражение или его часть.
ExportError | 78 | Произошла ошибка при экспорте документа.
OperationCanNotBePerformedWithUnits | 79 | Operation cannot be performed with units.
ArgumentDoesNotMatchToExpectedKind | 80 | Argument doesn't match to expected kind.Аргумент не соответствует требуемому виду.
EquationTooLongForVisualisation | 81 | Длина выражения слишком велика для корректного его отображения.
ResultPlacedToClipboard | 82 | Ответ помещён в буфер обмена операционной системы.
HighlightVariable | 83 | Выделите переменную.
AssignVariable | 84 | Задайте переменную.
FileNotExists | 85 | Такой файл не существует.
FillInFileName | 86 | Введите имя файла.
FileAlreadyExistsContinue | 87 | Данный файл уже существует. Продолжить?
NoElementByIndex | 88 | Нельзя задать значение элемента, т.к. элемента с указанным индексом не существует.
PasswordCannotBeEmpty | 89 | Password cannot be empty.Нельзя указывать пустой пароль.
PasswordEntriesDoNotMatch | 90 | Password entries do not match.Указанные пароли не совпадают.
PasswordDoesNotMatch | 91 | Password does not match.Пароль не подходит.
ProcedureOutputValueIsUndefined | 92 | Output value must be defined for the called procedure.Выходное значение вызываемой процедуры должно быть определено.
ResolveDependencies | 93 | {0} requires the following plug-in(s) to be installed and enabled. Please ensure dependencies are resolved before continuing.Следующие дополнения должны быть установлены и включены для {0}. Пожалуйста, перед продолжением убедитесь, что все зависимости разрешены.
NotAllDependenciesResolved | 94 | Not all dependencies resolved. Do you want to continue anyway? Press "No" to abort {0} loading.Не все зависимости разрешены. Хотите продолжить в любом случае? Нажмите "Нет", что бы прекратить загрузку {0}.
PluginsInstallationFailed | 95 | Plug-in(s) installation failed.Установка дополнений завершилась ошибкой.
VariableDefinedAndTypeDiffers | 99 | Variable already defined by value of another type.Переменная уже определена и имеет значение другого типа.
See Also

Reference

SMath.Manager Namespace


Expression Class

Helpers methods to work with math expression represented in reverse polish notation.Вспомогательные методы для работы с выражениями, записанными в виде постфиксной нотации.
Inheritance Hierarchy
SystemObject
SMath.ManagerExpression

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Expression
Public Class Expression
public ref class Expression
type Expression =  class end

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Methods
 | Name | Description
 | CheckDefinition | Checks if left part of the definition expression is specified correctly.Проверяет правильно ли составлена левая часть выражения определения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneratesDefinitionExpression | Recreates definition of the expression using specified name, variables and the answer.Воссоздаёт определение выражения по заданным имени, массиву переменных и ответу.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IndexOf(Term, Term) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
 | IndexOf(Term, Term, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
 | IndexOf(Term, Term, Int32, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Term, Term, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
 | Merge(Term, Term, Int32, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
 | Split(Term, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | Split(Term, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | Split(Term, Int32, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | SplitSingle(Term, Int32, Int32) | Returns the specified argument of expression based on the parent element specified by index.Возвращает указанный аргумент выражения основываясь на индексе родительского элемента.
 | SplitSingle(Term, Int32, Int32, Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


Expression Constructor

Initializes a new instance of the Expression class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Expression()
Public Sub New
public:
Expression()
new : unit -> Expression
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
 | CheckDefinition | Checks if left part of the definition expression is specified correctly.Проверяет правильно ли составлена левая часть выражения определения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneratesDefinitionExpression | Recreates definition of the expression using specified name, variables and the answer.Воссоздаёт определение выражения по заданным имени, массиву переменных и ответу.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IndexOf(Term, Term) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
 | IndexOf(Term, Term, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
 | IndexOf(Term, Term, Int32, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Term, Term, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
 | Merge(Term, Term, Int32, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
 | Split(Term, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | Split(Term, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | Split(Term, Int32, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
 | SplitSingle(Term, Int32, Int32) | Returns the specified argument of expression based on the parent element specified by index.Возвращает указанный аргумент выражения основываясь на индексе родительского элемента.
 | SplitSingle(Term, Int32, Int32, Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.CheckDefinition Method

ExpressionCheckDefinition Method

Checks if left part of the definition expression is specified correctly.Проверяет правильно ли составлена левая часть выражения определения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int CheckDefinition(
    Entry leftPart,
    out Entry[] arguments,
    out Term[] variables
)
Public Shared Function CheckDefinition (
    leftPart As Entry,
    <OutAttribute> ByRef arguments As Entry(),
    <OutAttribute> ByRef variables As Term()
) As Integer
public:
static int CheckDefinition(
    Entry^ leftPart,
    [OutAttribute] array<Entry^>^% arguments,
    [OutAttribute] array<Term^>^% variables
)
static member CheckDefinition :
        leftPart : Entry *
        arguments : Entry[] byref *
        variables : Term[] byref -> int

Parameters

leftPart
Type: SMath.ManagerEntry
Left part of the definition expression.Левая часть выражения определения.
arguments
Type: SMath.ManagerEntry
Creates an array of functions (if left part is function) arguments.Создаёт массив аргументов функции (если в левой части выражения функция).
variables
Type: SMath.ManagerTerm
Creates an array of function's (if left part is function) variables.Создаёт массив переменных функции (если в левой части выражения функция).

Return Value

Type: Int32
Returns a check status. If returns "-1" - this expression is correct but cannot be used as the left part of the definition expression. If returns number of variables - expression is correct. Any other number means index of variable that causes an error.Возвращает статус проверки. Если возвращает "-1" - выражение составлено верно, но не может использоваться в качестве левой части выражения определения. Если возвращает число переменных - выражение задано верно. Любое другое возвращаемое число указывает индекс переменной, вызвавшей ошибку.
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.GeneratesDefinitionExpression Method

ExpressionGeneratesDefinitionExpression Method

Recreates definition of the expression using specified name, variables and the answer.Воссоздаёт определение выражения по заданным имени, массиву переменных и ответу.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<Term> GeneratesDefinitionExpression(
    string name,
    Term[] variables,
    Entry answer
)
Public Shared Function GeneratesDefinitionExpression (
    name As String,
    variables As Term(),
    answer As Entry
) As List(Of Term)
public:
static List<Term^>^ GeneratesDefinitionExpression(
    String^ name,
    array<Term^>^ variables,
    Entry^ answer
)
static member GeneratesDefinitionExpression :
        name : string *
        variables : Term[] *
        answer : Entry -> List<Term>

Parameters

name
Type: SystemString
Term name.Имя вхождения.
variables
Type: SMath.ManagerTerm
Term's variables.Массив переменных вхождения.
answer
Type: SMath.ManagerEntry
Right part of the expression.Правая часть выражения вхождения.

Return Value

Type: ListTerm
Definition expression.Выражение определения.
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.IndexOf Method

ExpressionIndexOf Method

Overload List
Name | Description
IndexOf(Term, Term) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
IndexOf(Term, Term, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
IndexOf(Term, Term, Int32, Int32) | Search of the elements in the math expression.Поиск элементов в математическом выражении.
Top
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.IndexOf Method (Term[], Term[])

ExpressionIndexOf Method (Term, Term)

Search of the elements in the math expression.Поиск элементов в математическом выражении.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int IndexOf(
    Term[] source,
    Term[] values
)
Public Shared Function IndexOf (
    source As Term(),
    values As Term()
) As Integer
public:
static int IndexOf(
    array<Term^>^ source,
    array<Term^>^ values
)
static member IndexOf :
        source : Term[] *
        values : Term[] -> int

Parameters

source
Type: SMath.ManagerTerm
Source expression to search entries in.Массив элементов, в котором будет осуществляться поиск.
values
Type: SMath.ManagerTerm
Array of the expression components to search.Массив искомых элементов.

Return Value

Type: Int32
Returns index of the first found entry in the expression.Возвращает индекс первого встретившегося искомого элемента в выражении.
See Also

Reference

Expression Class
IndexOf Overload
SMath.Manager Namespace


Expression.IndexOf Method (Term[], Term[], Int32)

ExpressionIndexOf Method (Term, Term, Int32)

Search of the elements in the math expression.Поиск элементов в математическом выражении.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int IndexOf(
    Term[] source,
    Term[] values,
    int startIndex
)
Public Shared Function IndexOf (
    source As Term(),
    values As Term(),
    startIndex As Integer
) As Integer
public:
static int IndexOf(
    array<Term^>^ source,
    array<Term^>^ values,
    int startIndex
)
static member IndexOf :
        source : Term[] *
        values : Term[] *
        startIndex : int -> int

Parameters

source
Type: SMath.ManagerTerm
Source expression to search entries in.Массив элементов, в котором будет осуществляться поиск.
values
Type: SMath.ManagerTerm
Array of the expression components to search.Массив искомых элементов.
startIndex
Type: SystemInt32
Start index to search.Начальный индекс для поиска.

Return Value

Type: Int32
Returns index of the first found entry in the expression.Возвращает индекс первого встретившегося искомого элемента в выражении.
See Also

Reference

Expression Class
IndexOf Overload
SMath.Manager Namespace


Expression.IndexOf Method (Term[], Term[], Int32, Int32)

ExpressionIndexOf Method (Term, Term, Int32, Int32)

Search of the elements in the math expression.Поиск элементов в математическом выражении.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int IndexOf(
    Term[] source,
    Term[] values,
    int startIndex,
    out int searchIndex
)
Public Shared Function IndexOf (
    source As Term(),
    values As Term(),
    startIndex As Integer,
    <OutAttribute> ByRef searchIndex As Integer
) As Integer
public:
static int IndexOf(
    array<Term^>^ source,
    array<Term^>^ values,
    int startIndex,
    [OutAttribute] int% searchIndex
)
static member IndexOf :
        source : Term[] *
        values : Term[] *
        startIndex : int *
        searchIndex : int byref -> int

Parameters

source
Type: SMath.ManagerTerm
Source expression to search entries in.Массив элементов, в котором будет осуществляться поиск.
values
Type: SMath.ManagerTerm
Array of the expression components to search.Массив искомых элементов.
startIndex
Type: SystemInt32
Start index to search.Начальный индекс для поиска.
searchIndex
Type: SystemInt32
Returns an values-index of the found element.Возвращает индекс найденного элемента.

Return Value

Type: Int32
Returns index of the first found entry in the expression.Возвращает индекс первого встретившегося искомого элемента в выражении.
See Also

Reference

Expression Class
IndexOf Overload
SMath.Manager Namespace


Expression.Merge Method

ExpressionMerge Method

Overload List
Name | Description
Merge(Term, Term, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
Merge(Term, Term, Int32, Int32) | Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.
Top
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.Merge Method (Term[], Term[], Int32)

ExpressionMerge Method (Term, Term, Int32)

Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] Merge(
    Term[] source,
    Term[] insert,
    int position
)
Public Shared Function Merge (
    source As Term(),
    insert As Term(),
    position As Integer
) As Term()
public:
static array<Term^>^ Merge(
    array<Term^>^ source,
    array<Term^>^ insert,
    int position
)
static member Merge :
        source : Term[] *
        insert : Term[] *
        position : int -> Term[]

Parameters

source
Type: SMath.ManagerTerm
Target expression array to insert the second one in.Массив, в который будет произведена вставка.
insert
Type: SMath.ManagerTerm
Expression array to merge.Массив, который будет вставлен в source.
position
Type: SystemInt32
Index of the element where second expression will be merged to the target.Индекс элемента выражения в который будет произведена вставка.

Return Value

Type: Term
Result of merging expressions.Результат объединения массивов элементов математического выражения.
See Also

Reference

Expression Class
Merge Overload
SMath.Manager Namespace


Expression.Merge Method (Term[], Term[], Int32, Int32)

ExpressionMerge Method (Term, Term, Int32, Int32)

Merging second expression into the first one in the specified position.Подстановка второго выражения в первое в указанном индексом элементе.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] Merge(
    Term[] source,
    Term[] insert,
    int position,
    int globalrev
)
Public Shared Function Merge (
    source As Term(),
    insert As Term(),
    position As Integer,
    globalrev As Integer
) As Term()
public:
static array<Term^>^ Merge(
    array<Term^>^ source,
    array<Term^>^ insert,
    int position,
    int globalrev
)
static member Merge :
        source : Term[] *
        insert : Term[] *
        position : int *
        globalrev : int -> Term[]

Parameters

source
Type: SMath.ManagerTerm
Target expression array to insert the second one in.Массив, в который будет произведена вставка.
insert
Type: SMath.ManagerTerm
Expression array to merge.Массив, который будет вставлен в source.
position
Type: SystemInt32
Index of the element where second expression will be merged to the target.Индекс элемента выражения в который будет произведена вставка.
globalrev
Type: SystemInt32
Number of elements to remove in place of the subexpression.Количество элементов для удаления вместе вставки подвыражения.

Return Value

Type: Term
Result of merging expressions.Результат объединения массивов элементов математического выражения.
See Also

Reference

Expression Class
Merge Overload
SMath.Manager Namespace


Expression.Split Method

ExpressionSplit Method

Overload List
Name | Description
Split(Term, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Split(Term, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Split(Term, Int32, Int32, Int32) | Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Top
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.Split Method (Term[], Int32)

ExpressionSplit Method (Term, Int32)

Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[][] Split(
    Term[] values,
    int index
)
Public Shared Function Split (
    values As Term(),
    index As Integer
) As Term()()
public:
static array<array<Term^>^>^ Split(
    array<Term^>^ values,
    int index
)
static member Split :
        values : Term[] *
        index : int -> Term[][]

Parameters

values
Type: SMath.ManagerTerm
Source expression to split.Выражение для разбора.
index
Type: SystemInt32
Root (parent) element index.Индекс элемента-родителя.

Return Value

Type: Term
Array of the children elements.Массив зависимых выражений.
See Also

Reference

Expression Class
Split Overload
SMath.Manager Namespace


Expression.Split Method (Term[], Int32, Int32)

ExpressionSplit Method (Term, Int32, Int32)

Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[][] Split(
    Term[] values,
    int index,
    out int globalrev
)
Public Shared Function Split (
    values As Term(),
    index As Integer,
    <OutAttribute> ByRef globalrev As Integer
) As Term()()
public:
static array<array<Term^>^>^ Split(
    array<Term^>^ values,
    int index,
    [OutAttribute] int% globalrev
)
static member Split :
        values : Term[] *
        index : int *
        globalrev : int byref -> Term[][]

Parameters

values
Type: SMath.ManagerTerm
Source expression to split.Выражение для разбора.
index
Type: SystemInt32
Root (parent) element index.Индекс элемента-родителя.
globalrev
Type: SystemInt32
Sum of the children elements.Суммарное количество элементов компонент, зависимых от родителя.

Return Value

Type: Term
Array of the children elements.Массив зависимых выражений.
See Also

Reference

Expression Class
Split Overload
SMath.Manager Namespace


Expression.Split Method (Term[], Int32, Int32, Int32)

ExpressionSplit Method (Term, Int32, Int32, Int32)

Splits expression on the array of arguments based on the parent element specified by index.Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[][] Split(
    Term[] values,
    int index,
    out int globalrev,
    int argsToReturn
)
Public Shared Function Split (
    values As Term(),
    index As Integer,
    <OutAttribute> ByRef globalrev As Integer,
    argsToReturn As Integer
) As Term()()
public:
static array<array<Term^>^>^ Split(
    array<Term^>^ values,
    int index,
    [OutAttribute] int% globalrev,
    int argsToReturn
)
static member Split :
        values : Term[] *
        index : int *
        globalrev : int byref *
        argsToReturn : int -> Term[][]

Parameters

values
Type: SMath.ManagerTerm
Source expression to split.Выражение для разбора.
index
Type: SystemInt32
Root (parent) element index.Индекс элемента-родителя.
globalrev
Type: SystemInt32
Sum of the children elements.Суммарное количество элементов компонент, зависимых от родителя.
argsToReturn
Type: SystemInt32
Number of arguments to return (by default method will return all children of the specified parent).Количество аргументов, которые будут возвращены (по-умолчанию равно количеству зависимых элементов указанного родителя).

Return Value

Type: Term
Array of the children elements.Массив зависимых выражений.
See Also

Reference

Expression Class
Split Overload
SMath.Manager Namespace


Expression.SplitSingle Method

ExpressionSplitSingle Method

Overload List
Name | Description
SplitSingle(Term, Int32, Int32) | Returns the specified argument of expression based on the parent element specified by index.Возвращает указанный аргумент выражения основываясь на индексе родительского элемента.
SplitSingle(Term, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

Expression Class
SMath.Manager Namespace


Expression.SplitSingle Method (Term[], Int32, Int32)

ExpressionSplitSingle Method (Term, Int32, Int32)

Returns the specified argument of expression based on the parent element specified by index.Возвращает указанный аргумент выражения основываясь на индексе родительского элемента.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] SplitSingle(
    Term[] values,
    int index,
    int argToReturn
)
Public Shared Function SplitSingle (
    values As Term(),
    index As Integer,
    argToReturn As Integer
) As Term()
public:
static array<Term^>^ SplitSingle(
    array<Term^>^ values,
    int index,
    int argToReturn
)
static member SplitSingle :
        values : Term[] *
        index : int *
        argToReturn : int -> Term[]

Parameters

values
Type: SMath.ManagerTerm
Source expression to split.Выражение для разбора.
index
Type: SystemInt32
Root (parent) element index.Индекс элемента-родителя.
argToReturn
Type: SystemInt32
Index of the argument to return.Индекс искомого аргумента выражения.

Return Value

Type: Term
Argument of the expression by index.Аргумент выражения по индексу.
See Also

Reference

Expression Class
SplitSingle Overload
SMath.Manager Namespace


Expression.SplitSingle Method (Term[], Int32, Int32, Int32, Int32)

ExpressionSplitSingle Method (Term, Int32, Int32, Int32, Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void SplitSingle(
    Term[] values,
    int rootIndex,
    int argToReturn,
    out int startPosition,
    out int endPosition
)
Public Shared Sub SplitSingle (
    values As Term(),
    rootIndex As Integer,
    argToReturn As Integer,
    <OutAttribute> ByRef startPosition As Integer,
    <OutAttribute> ByRef endPosition As Integer
)
public:
static void SplitSingle(
    array<Term^>^ values,
    int rootIndex,
    int argToReturn,
    [OutAttribute] int% startPosition,
    [OutAttribute] int% endPosition
)
static member SplitSingle :
        values : Term[] *
        rootIndex : int *
        argToReturn : int *
        startPosition : int byref *
        endPosition : int byref -> unit

Parameters

values
Type: SMath.ManagerTerm
rootIndex
Type: SystemInt32
argToReturn
Type: SystemInt32
startPosition
Type: SystemInt32
endPosition
Type: SystemInt32
See Also

Reference

Expression Class
SplitSingle Overload
SMath.Manager Namespace


FileOrigins Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FileOrigins
<FlagsAttribute>
Public Enumeration FileOrigins
[FlagsAttribute]
public enum class FileOrigins
[<FlagsAttribute>]
type FileOrigins
Members
Member name | Value | Description
BuiltIn | 1 |
Custom | 2 |
See Also

Reference

SMath.Manager Namespace


FileTypes Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum FileTypes
Public Enumeration FileTypes
public enum class FileTypes
type FileTypes
Members
Member name | Value | Description
Examples | 0 |
Snippets | 1 |
Entries | 2 |
Languages | 3 |
Presentations | 4 |
Other | 5 |
See Also

Reference

SMath.Manager Namespace


FractionsSolver Class

Inheritance Hierarchy
SystemObject
SMath.ManagerFractionsSolver

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static class FractionsSolver
Public NotInheritable Class FractionsSolver
public ref class FractionsSolver abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FractionsSolver =  class end

The FractionsSolver type exposes the following members.

Methods
Name | Description
Calculate |
ToTerms(Double, Boolean) |
ToTerms(Double, Double) |
Top
See Also

Reference

SMath.Manager Namespace


FractionsSolver Methods

The FractionsSolver type exposes the following members.

Methods
Name | Description
Calculate |
ToTerms(Double, Boolean) |
ToTerms(Double, Double) |
Top
See Also

Reference

FractionsSolver Class
SMath.Manager Namespace


FractionsSolver.Calculate Method

FractionsSolverCalculate Method

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static FractionsSolverFraction Calculate(
    params Term[][] value
)
Public Shared Function Calculate (
    ParamArray value As Term()()
) As FractionsSolverFraction
public:
static FractionsSolverFraction^ Calculate(
    ... array<array<Term^>^>^ value
)
static member Calculate :
        value : Term[][] -> FractionsSolverFraction

Parameters

value
Type: SMath.ManagerTerm

Return Value

Type: FractionsSolverFraction
See Also

Reference

FractionsSolver Class
SMath.Manager Namespace


FractionsSolver.ToTerms Method

FractionsSolverToTerms Method

Overload List
Name | Description
ToTerms(Double, Boolean) |
ToTerms(Double, Double) |
Top
See Also

Reference

FractionsSolver Class
SMath.Manager Namespace


FractionsSolver.ToTerms Method (Double, Boolean)

FractionsSolverToTerms Method (Double, Boolean)

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToTerms(
    double value,
    bool integerOnly
)
Public Shared Function ToTerms (
    value As Double,
    integerOnly As Boolean
) As Term()
public:
static array<Term^>^ ToTerms(
    double value,
    bool integerOnly
)
static member ToTerms :
        value : float *
        integerOnly : bool -> Term[]

Parameters

value
Type: SystemDouble
integerOnly
Type: SystemBoolean

Return Value

Type: Term
See Also

Reference

FractionsSolver Class
ToTerms Overload
SMath.Manager Namespace


FractionsSolver.ToTerms Method (Double, Double)

FractionsSolverToTerms Method (Double, Double)

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToTerms(
    double num,
    double den
)
Public Shared Function ToTerms (
    num As Double,
    den As Double
) As Term()
public:
static array<Term^>^ ToTerms(
    double num,
    double den
)
static member ToTerms :
        num : float *
        den : float -> Term[]

Parameters

num
Type: SystemDouble
den
Type: SystemDouble

Return Value

Type: Term
See Also

Reference

FractionsSolver Class
ToTerms Overload
SMath.Manager Namespace


FractionsSolver.Fraction Class

FractionsSolverFraction Class

Inheritance Hierarchy
SystemObject
SMath.ManagerFractionsSolverFraction

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class Fraction
Public Class Fraction
public ref class Fraction
type Fraction =  class end

The FractionsSolverFraction type exposes the following members.

Constructors
 | Name | Description
Public method | FractionsSolverFraction | Initializes a new instance of the FractionsSolverFraction class
Top
Properties
 | Name | Description
Public property | Den |
Public property | Num |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToTerms |
Top
See Also

Reference

SMath.Manager Namespace


FractionsSolver.Fraction Constructor

FractionsSolverFraction Constructor

Initializes a new instance of the FractionsSolverFraction class

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Fraction()
Public Sub New
public:
Fraction()
new : unit -> Fraction
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


Fraction Properties

The FractionsSolverFraction type exposes the following members.

Properties
 | Name | Description
Public property | Den |
Public property | Num |
Top
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


FractionsSolver.Fraction.Den Property

FractionsSolverFractionDen Property

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public double Den { get; set; }
Public Property Den As Double
    Get
    Set
public:
property double Den {
    double get ();
    void set (double value);
}
member Den : float with get, set

Property Value

Type: Double
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


FractionsSolver.Fraction.Num Property

FractionsSolverFractionNum Property

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public double Num { get; set; }
Public Property Num As Double
    Get
    Set
public:
property double Num {
    double get ();
    void set (double value);
}
member Num : float with get, set

Property Value

Type: Double
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


Fraction Methods

The FractionsSolverFraction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToTerms |
Top
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


FractionsSolver.Fraction.ToTerms Method

FractionsSolverFractionToTerms Method

Namespace: SMath.Manager
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Term[] ToTerms()
Public Function ToTerms As Term()
public:
array<Term^>^ ToTerms()
member ToTerms : unit -> Term[]

Return Value

Type: Term
See Also

Reference

FractionsSolverFraction Class
SMath.Manager Namespace


FractionsType Enumeration

Тип дроби.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum FractionsType
Public Enumeration FractionsType
public enum class FractionsType
type FractionsType
Members
Member name | Value | Description
Decimal | 0 | Десятичная дробь.
Fraction | 1 | Обыкновенная дробь.
Auto | 2 | Определяется программой.
Undefined | 3 | Не определено.
See Also

Reference

SMath.Manager Namespace


Functions Class

Перечисление доступных встроенных функций.
Inheritance Hierarchy
SystemObject
SMath.ManagerFunctions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class Functions
Public NotInheritable Class Functions
public ref class Functions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Functions =  class end

The Functions type exposes the following members.

Properties
Name | Description
A2t | Перевод числа из алгебраического в тригонометрический.
Abs | Модуль (абсолютное значение).
Ainterp | Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Alg | Алгебраическое дополнение.
Arccos | Арккосинус.
Arccosec | Арккосеканс.
Arcctg | Арккотангенс.
Arch | Гиперболический арккосинус.
Arcsec | Арксеканс.
Arcsin | Арксинус.
Arctg | Арктангенс.
Arcth | Гиперболический арккотангенс.
Arg | Аргумент комплексного числа.
Arsh | Гиперболический арксинус.
Arth | Гиперболический арктангенс.
Augment | Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.
Ch | Гиперболический косинус.
Cinterp | Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Col | Столбец матрицы/вектора.
Cols | Количество столбцов матрицы/вектора.
Cos | Косинус.
Cosec | Косеканс.
CosecH | Гиперболический косеканс.
CSort | Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания.
Ctg | Котангенс.
Cth | Гиперболический котангенс.
Det | Детерминант (Определитель).
DFile | Безвозвратно удалить файл с математическим выражением, если такой существует.
Diag | Возвращает матрицу на главной диагонали которой элементы вектора аргумента.
Diff | Дифференцирование.
Eigenvals | Собственные числа квадратной матрицы.
El | Элемент матрицы/вектора.
Eval | Переводит выражение представленное аналитически в численный вид.
Exp | Экспонента.
Expand | Упрощение.
For | Цикл.
Gamma | Функция вычисления функции Гамма.
Identity | Единичная матрица указанных размеров.
If | Оператор ветвления.
Im | Мнимая часть числа.
Int | Интеграл.
Invert | Обратное значение.
Length | Количество элементов матрицы/вектора.
Lg | Десятичный логарифм.
Lim | Передел (программа умеет только отображать).
Line | Функция программирования - линия.
Linterp | Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Ln | Натуральный логарифм.
Log | Логарифм по основанию.
Mat | Матрица.
Matrix | Создание матрицы указанных аргументами размеров.
Max | Максимальный элемент матрицы/вектора.
Min | Минимальный элемент матрицы/вектора.
Minor | Минор матрицы.
Mod | Остаток от деления.
Norm1 | Возвращает норму матрицы в пространстве L1.
NormE | Возвращает евклидову норму матрицы.
NormI | Возвращает равномерную норму матрицы.
Nthroot | Корень произвольной степени.
Numden | Получение числителя и знаменателя в виде вектор-столбца.
Perc | Проценты.
Pol2xy | Перевод координат из полярных в прямоугольные.
Polyroots | Вычисление корней полинома.
Product | Функция произведения.
Random | Случайное число.
Range | Функция создания массива по заданным параметрам.
Rank | Ранг матрицы.
Re | Действительная часть числа.
Reverse | Изменяет порядок строк матрицы или элементов вектора на противоположный.
RFile | Прочитать математическое выражение из файла, если такой существует.
Round | Округление числа.
Row | Строка матрицы/вектора.
Rows | Количество строк матрицы/вектора.
RSort | Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания.
Sec | Секанс.
Sech | Гиперболический секанс.
Sh | Гиперболический синус.
Sign | Сигнатура.
Sin | Синус.
Solve | Получение корней уравнения.
Sort | Возвращает вектор с элементами, отсортированными в порядке возрастания.
Sqrt | Квадратный корень.
Stack | Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.
Submatrix | Получение матрицы указанных размеров из существующей.
Sum | Функция суммирования.
Switch | Функция выбора.
Sys | Алгебраическая система.
Tg | Тангенс.
Th | Гиперболический тангенс.
Tr | След матрицы.
Transpose | Транспонирование матрицы/вектора.
Trunc | Получение целой части числа.
Vminor | Визуальное представление минора - без вычисления конечного определителя.
WFile | Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением.
While | Цикл типа while.
Xy2pol | Перевод координат из прямоугольных к полярным.
Top
Methods
Name | Description
PrepareBuiltInFunctions |
Top
See Also

Reference

SMath.Manager Namespace


Functions Properties

The Functions type exposes the following members.

Properties
Name | Description
A2t | Перевод числа из алгебраического в тригонометрический.
Abs | Модуль (абсолютное значение).
Ainterp | Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Alg | Алгебраическое дополнение.
Arccos | Арккосинус.
Arccosec | Арккосеканс.
Arcctg | Арккотангенс.
Arch | Гиперболический арккосинус.
Arcsec | Арксеканс.
Arcsin | Арксинус.
Arctg | Арктангенс.
Arcth | Гиперболический арккотангенс.
Arg | Аргумент комплексного числа.
Arsh | Гиперболический арксинус.
Arth | Гиперболический арктангенс.
Augment | Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.
Ch | Гиперболический косинус.
Cinterp | Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Col | Столбец матрицы/вектора.
Cols | Количество столбцов матрицы/вектора.
Cos | Косинус.
Cosec | Косеканс.
CosecH | Гиперболический косеканс.
CSort | Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания.
Ctg | Котангенс.
Cth | Гиперболический котангенс.
Det | Детерминант (Определитель).
DFile | Безвозвратно удалить файл с математическим выражением, если такой существует.
Diag | Возвращает матрицу на главной диагонали которой элементы вектора аргумента.
Diff | Дифференцирование.
Eigenvals | Собственные числа квадратной матрицы.
El | Элемент матрицы/вектора.
Eval | Переводит выражение представленное аналитически в численный вид.
Exp | Экспонента.
Expand | Упрощение.
For | Цикл.
Gamma | Функция вычисления функции Гамма.
Identity | Единичная матрица указанных размеров.
If | Оператор ветвления.
Im | Мнимая часть числа.
Int | Интеграл.
Invert | Обратное значение.
Length | Количество элементов матрицы/вектора.
Lg | Десятичный логарифм.
Lim | Передел (программа умеет только отображать).
Line | Функция программирования - линия.
Linterp | Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.
Ln | Натуральный логарифм.
Log | Логарифм по основанию.
Mat | Матрица.
Matrix | Создание матрицы указанных аргументами размеров.
Max | Максимальный элемент матрицы/вектора.
Min | Минимальный элемент матрицы/вектора.
Minor | Минор матрицы.
Mod | Остаток от деления.
Norm1 | Возвращает норму матрицы в пространстве L1.
NormE | Возвращает евклидову норму матрицы.
NormI | Возвращает равномерную норму матрицы.
Nthroot | Корень произвольной степени.
Numden | Получение числителя и знаменателя в виде вектор-столбца.
Perc | Проценты.
Pol2xy | Перевод координат из полярных в прямоугольные.
Polyroots | Вычисление корней полинома.
Product | Функция произведения.
Random | Случайное число.
Range | Функция создания массива по заданным параметрам.
Rank | Ранг матрицы.
Re | Действительная часть числа.
Reverse | Изменяет порядок строк матрицы или элементов вектора на противоположный.
RFile | Прочитать математическое выражение из файла, если такой существует.
Round | Округление числа.
Row | Строка матрицы/вектора.
Rows | Количество строк матрицы/вектора.
RSort | Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания.
Sec | Секанс.
Sech | Гиперболический секанс.
Sh | Гиперболический синус.
Sign | Сигнатура.
Sin | Синус.
Solve | Получение корней уравнения.
Sort | Возвращает вектор с элементами, отсортированными в порядке возрастания.
Sqrt | Квадратный корень.
Stack | Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.
Submatrix | Получение матрицы указанных размеров из существующей.
Sum | Функция суммирования.
Switch | Функция выбора.
Sys | Алгебраическая система.
Tg | Тангенс.
Th | Гиперболический тангенс.
Tr | След матрицы.
Transpose | Транспонирование матрицы/вектора.
Trunc | Получение целой части числа.
Vminor | Визуальное представление минора - без вычисления конечного определителя.
WFile | Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением.
While | Цикл типа while.
Xy2pol | Перевод координат из прямоугольных к полярным.
Top
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.A2t Property

FunctionsA2t Property

Перевод числа из алгебраического в тригонометрический.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string A2t { get; }
Public Shared ReadOnly Property A2t As String
    Get
public:
static property String^ A2t {
    String^ get ();
}
static member A2t : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Abs Property

FunctionsAbs Property

Модуль (абсолютное значение).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Abs { get; }
Public Shared ReadOnly Property Abs As String
    Get
public:
static property String^ Abs {
    String^ get ();
}
static member Abs : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Ainterp Property

FunctionsAinterp Property

Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Ainterp { get; }
Public Shared ReadOnly Property Ainterp As String
    Get
public:
static property String^ Ainterp {
    String^ get ();
}
static member Ainterp : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Alg Property

FunctionsAlg Property

Алгебраическое дополнение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Alg { get; }
Public Shared ReadOnly Property Alg As String
    Get
public:
static property String^ Alg {
    String^ get ();
}
static member Alg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arccos Property

FunctionsArccos Property

Арккосинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arccos { get; }
Public Shared ReadOnly Property Arccos As String
    Get
public:
static property String^ Arccos {
    String^ get ();
}
static member Arccos : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arccosec Property

FunctionsArccosec Property

Арккосеканс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arccosec { get; }
Public Shared ReadOnly Property Arccosec As String
    Get
public:
static property String^ Arccosec {
    String^ get ();
}
static member Arccosec : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arcctg Property

FunctionsArcctg Property

Арккотангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arcctg { get; }
Public Shared ReadOnly Property Arcctg As String
    Get
public:
static property String^ Arcctg {
    String^ get ();
}
static member Arcctg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arch Property

FunctionsArch Property

Гиперболический арккосинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arch { get; }
Public Shared ReadOnly Property Arch As String
    Get
public:
static property String^ Arch {
    String^ get ();
}
static member Arch : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arcsec Property

FunctionsArcsec Property

Арксеканс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arcsec { get; }
Public Shared ReadOnly Property Arcsec As String
    Get
public:
static property String^ Arcsec {
    String^ get ();
}
static member Arcsec : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arcsin Property

FunctionsArcsin Property

Арксинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arcsin { get; }
Public Shared ReadOnly Property Arcsin As String
    Get
public:
static property String^ Arcsin {
    String^ get ();
}
static member Arcsin : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arctg Property

FunctionsArctg Property

Арктангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arctg { get; }
Public Shared ReadOnly Property Arctg As String
    Get
public:
static property String^ Arctg {
    String^ get ();
}
static member Arctg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arcth Property

FunctionsArcth Property

Гиперболический арккотангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arcth { get; }
Public Shared ReadOnly Property Arcth As String
    Get
public:
static property String^ Arcth {
    String^ get ();
}
static member Arcth : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arg Property

FunctionsArg Property

Аргумент комплексного числа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arg { get; }
Public Shared ReadOnly Property Arg As String
    Get
public:
static property String^ Arg {
    String^ get ();
}
static member Arg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arsh Property

FunctionsArsh Property

Гиперболический арксинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arsh { get; }
Public Shared ReadOnly Property Arsh As String
    Get
public:
static property String^ Arsh {
    String^ get ();
}
static member Arsh : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Arth Property

FunctionsArth Property

Гиперболический арктангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Arth { get; }
Public Shared ReadOnly Property Arth As String
    Get
public:
static property String^ Arth {
    String^ get ();
}
static member Arth : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Augment Property

FunctionsAugment Property

Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Augment { get; }
Public Shared ReadOnly Property Augment As String
    Get
public:
static property String^ Augment {
    String^ get ();
}
static member Augment : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Ch Property

FunctionsCh Property

Гиперболический косинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Ch { get; }
Public Shared ReadOnly Property Ch As String
    Get
public:
static property String^ Ch {
    String^ get ();
}
static member Ch : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Cinterp Property

FunctionsCinterp Property

Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Cinterp { get; }
Public Shared ReadOnly Property Cinterp As String
    Get
public:
static property String^ Cinterp {
    String^ get ();
}
static member Cinterp : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Col Property

FunctionsCol Property

Столбец матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Col { get; }
Public Shared ReadOnly Property Col As String
    Get
public:
static property String^ Col {
    String^ get ();
}
static member Col : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Cols Property

FunctionsCols Property

Количество столбцов матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Cols { get; }
Public Shared ReadOnly Property Cols As String
    Get
public:
static property String^ Cols {
    String^ get ();
}
static member Cols : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Cos Property

FunctionsCos Property

Косинус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Cos { get; }
Public Shared ReadOnly Property Cos As String
    Get
public:
static property String^ Cos {
    String^ get ();
}
static member Cos : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Cosec Property

FunctionsCosec Property

Косеканс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Cosec { get; }
Public Shared ReadOnly Property Cosec As String
    Get
public:
static property String^ Cosec {
    String^ get ();
}
static member Cosec : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.CosecH Property

FunctionsCosecH Property

Гиперболический косеканс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string CosecH { get; }
Public Shared ReadOnly Property CosecH As String
    Get
public:
static property String^ CosecH {
    String^ get ();
}
static member CosecH : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.CSort Property

FunctionsCSort Property

Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string CSort { get; }
Public Shared ReadOnly Property CSort As String
    Get
public:
static property String^ CSort {
    String^ get ();
}
static member CSort : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Ctg Property

FunctionsCtg Property

Котангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Ctg { get; }
Public Shared ReadOnly Property Ctg As String
    Get
public:
static property String^ Ctg {
    String^ get ();
}
static member Ctg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Cth Property

FunctionsCth Property

Гиперболический котангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Cth { get; }
Public Shared ReadOnly Property Cth As String
    Get
public:
static property String^ Cth {
    String^ get ();
}
static member Cth : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Det Property

FunctionsDet Property

Детерминант (Определитель).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Det { get; }
Public Shared ReadOnly Property Det As String
    Get
public:
static property String^ Det {
    String^ get ();
}
static member Det : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.DFile Property

FunctionsDFile Property

Безвозвратно удалить файл с математическим выражением, если такой существует.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DFile { get; }
Public Shared ReadOnly Property DFile As String
    Get
public:
static property String^ DFile {
    String^ get ();
}
static member DFile : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Diag Property

FunctionsDiag Property

Возвращает матрицу на главной диагонали которой элементы вектора аргумента.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Diag { get; }
Public Shared ReadOnly Property Diag As String
    Get
public:
static property String^ Diag {
    String^ get ();
}
static member Diag : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Diff Property

FunctionsDiff Property

Дифференцирование.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Diff { get; }
Public Shared ReadOnly Property Diff As String
    Get
public:
static property String^ Diff {
    String^ get ();
}
static member Diff : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Eigenvals Property

FunctionsEigenvals Property

Собственные числа квадратной матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Eigenvals { get; }
Public Shared ReadOnly Property Eigenvals As String
    Get
public:
static property String^ Eigenvals {
    String^ get ();
}
static member Eigenvals : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.El Property

FunctionsEl Property

Элемент матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string El { get; }
Public Shared ReadOnly Property El As String
    Get
public:
static property String^ El {
    String^ get ();
}
static member El : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Eval Property

FunctionsEval Property

Переводит выражение представленное аналитически в численный вид.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Eval { get; }
Public Shared ReadOnly Property Eval As String
    Get
public:
static property String^ Eval {
    String^ get ();
}
static member Eval : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Exp Property

FunctionsExp Property

Экспонента.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Exp { get; }
Public Shared ReadOnly Property Exp As String
    Get
public:
static property String^ Exp {
    String^ get ();
}
static member Exp : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Expand Property

FunctionsExpand Property

Упрощение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Expand { get; }
Public Shared ReadOnly Property Expand As String
    Get
public:
static property String^ Expand {
    String^ get ();
}
static member Expand : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.For Property

FunctionsFor Property

Цикл.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string For { get; }
Public Shared ReadOnly Property For As String
    Get
public:
static property String^ For {
    String^ get ();
}
static member For : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Gamma Property

FunctionsGamma Property

Функция вычисления функции Гамма.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Gamma { get; }
Public Shared ReadOnly Property Gamma As String
    Get
public:
static property String^ Gamma {
    String^ get ();
}
static member Gamma : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Identity Property

FunctionsIdentity Property

Единичная матрица указанных размеров.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Identity { get; }
Public Shared ReadOnly Property Identity As String
    Get
public:
static property String^ Identity {
    String^ get ();
}
static member Identity : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.If Property

FunctionsIf Property

Оператор ветвления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string If { get; }
Public Shared ReadOnly Property If As String
    Get
public:
static property String^ If {
    String^ get ();
}
static member If : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Im Property

FunctionsIm Property

Мнимая часть числа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Im { get; }
Public Shared ReadOnly Property Im As String
    Get
public:
static property String^ Im {
    String^ get ();
}
static member Im : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Int Property

FunctionsInt Property

Интеграл.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Int { get; }
Public Shared ReadOnly Property Int As String
    Get
public:
static property String^ Int {
    String^ get ();
}
static member Int : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Invert Property

FunctionsInvert Property

Обратное значение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Invert { get; }
Public Shared ReadOnly Property Invert As String
    Get
public:
static property String^ Invert {
    String^ get ();
}
static member Invert : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Length Property

FunctionsLength Property

Количество элементов матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Length { get; }
Public Shared ReadOnly Property Length As String
    Get
public:
static property String^ Length {
    String^ get ();
}
static member Length : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Lg Property

FunctionsLg Property

Десятичный логарифм.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Lg { get; }
Public Shared ReadOnly Property Lg As String
    Get
public:
static property String^ Lg {
    String^ get ();
}
static member Lg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Lim Property

FunctionsLim Property

Передел (программа умеет только отображать).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Lim { get; }
Public Shared ReadOnly Property Lim As String
    Get
public:
static property String^ Lim {
    String^ get ();
}
static member Lim : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Line Property

FunctionsLine Property

Функция программирования - линия.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Line { get; }
Public Shared ReadOnly Property Line As String
    Get
public:
static property String^ Line {
    String^ get ();
}
static member Line : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Linterp Property

FunctionsLinterp Property

Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Linterp { get; }
Public Shared ReadOnly Property Linterp As String
    Get
public:
static property String^ Linterp {
    String^ get ();
}
static member Linterp : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Ln Property

FunctionsLn Property

Натуральный логарифм.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Ln { get; }
Public Shared ReadOnly Property Ln As String
    Get
public:
static property String^ Ln {
    String^ get ();
}
static member Ln : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Log Property

FunctionsLog Property

Логарифм по основанию.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Log { get; }
Public Shared ReadOnly Property Log As String
    Get
public:
static property String^ Log {
    String^ get ();
}
static member Log : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Mat Property

FunctionsMat Property

Матрица.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Mat { get; }
Public Shared ReadOnly Property Mat As String
    Get
public:
static property String^ Mat {
    String^ get ();
}
static member Mat : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Matrix Property

FunctionsMatrix Property

Создание матрицы указанных аргументами размеров.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Matrix { get; }
Public Shared ReadOnly Property Matrix As String
    Get
public:
static property String^ Matrix {
    String^ get ();
}
static member Matrix : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Max Property

FunctionsMax Property

Максимальный элемент матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Max { get; }
Public Shared ReadOnly Property Max As String
    Get
public:
static property String^ Max {
    String^ get ();
}
static member Max : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Min Property

FunctionsMin Property

Минимальный элемент матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Min { get; }
Public Shared ReadOnly Property Min As String
    Get
public:
static property String^ Min {
    String^ get ();
}
static member Min : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Minor Property

FunctionsMinor Property

Минор матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Minor { get; }
Public Shared ReadOnly Property Minor As String
    Get
public:
static property String^ Minor {
    String^ get ();
}
static member Minor : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Mod Property

FunctionsMod Property

Остаток от деления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Mod { get; }
Public Shared ReadOnly Property Mod As String
    Get
public:
static property String^ Mod {
    String^ get ();
}
static member Mod : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Norm1 Property

FunctionsNorm1 Property

Возвращает норму матрицы в пространстве L1.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Norm1 { get; }
Public Shared ReadOnly Property Norm1 As String
    Get
public:
static property String^ Norm1 {
    String^ get ();
}
static member Norm1 : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.NormE Property

FunctionsNormE Property

Возвращает евклидову норму матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string NormE { get; }
Public Shared ReadOnly Property NormE As String
    Get
public:
static property String^ NormE {
    String^ get ();
}
static member NormE : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.NormI Property

FunctionsNormI Property

Возвращает равномерную норму матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string NormI { get; }
Public Shared ReadOnly Property NormI As String
    Get
public:
static property String^ NormI {
    String^ get ();
}
static member NormI : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Nthroot Property

FunctionsNthroot Property

Корень произвольной степени.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Nthroot { get; }
Public Shared ReadOnly Property Nthroot As String
    Get
public:
static property String^ Nthroot {
    String^ get ();
}
static member Nthroot : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Numden Property

FunctionsNumden Property

Получение числителя и знаменателя в виде вектор-столбца.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Numden { get; }
Public Shared ReadOnly Property Numden As String
    Get
public:
static property String^ Numden {
    String^ get ();
}
static member Numden : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Perc Property

FunctionsPerc Property

Проценты.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Perc { get; }
Public Shared ReadOnly Property Perc As String
    Get
public:
static property String^ Perc {
    String^ get ();
}
static member Perc : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Pol2xy Property

FunctionsPol2xy Property

Перевод координат из полярных в прямоугольные.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Pol2xy { get; }
Public Shared ReadOnly Property Pol2xy As String
    Get
public:
static property String^ Pol2xy {
    String^ get ();
}
static member Pol2xy : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Polyroots Property

FunctionsPolyroots Property

Вычисление корней полинома.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Polyroots { get; }
Public Shared ReadOnly Property Polyroots As String
    Get
public:
static property String^ Polyroots {
    String^ get ();
}
static member Polyroots : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Product Property

FunctionsProduct Property

Функция произведения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Product { get; }
Public Shared ReadOnly Property Product As String
    Get
public:
static property String^ Product {
    String^ get ();
}
static member Product : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Random Property

FunctionsRandom Property

Случайное число.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Random { get; }
Public Shared ReadOnly Property Random As String
    Get
public:
static property String^ Random {
    String^ get ();
}
static member Random : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Range Property

FunctionsRange Property

Функция создания массива по заданным параметрам.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Range { get; }
Public Shared ReadOnly Property Range As String
    Get
public:
static property String^ Range {
    String^ get ();
}
static member Range : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Rank Property

FunctionsRank Property

Ранг матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Rank { get; }
Public Shared ReadOnly Property Rank As String
    Get
public:
static property String^ Rank {
    String^ get ();
}
static member Rank : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Re Property

FunctionsRe Property

Действительная часть числа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Re { get; }
Public Shared ReadOnly Property Re As String
    Get
public:
static property String^ Re {
    String^ get ();
}
static member Re : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Reverse Property

FunctionsReverse Property

Изменяет порядок строк матрицы или элементов вектора на противоположный.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Reverse { get; }
Public Shared ReadOnly Property Reverse As String
    Get
public:
static property String^ Reverse {
    String^ get ();
}
static member Reverse : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.RFile Property

FunctionsRFile Property

Прочитать математическое выражение из файла, если такой существует.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string RFile { get; }
Public Shared ReadOnly Property RFile As String
    Get
public:
static property String^ RFile {
    String^ get ();
}
static member RFile : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Round Property

FunctionsRound Property

Округление числа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Round { get; }
Public Shared ReadOnly Property Round As String
    Get
public:
static property String^ Round {
    String^ get ();
}
static member Round : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Row Property

FunctionsRow Property

Строка матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Row { get; }
Public Shared ReadOnly Property Row As String
    Get
public:
static property String^ Row {
    String^ get ();
}
static member Row : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Rows Property

FunctionsRows Property

Количество строк матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Rows { get; }
Public Shared ReadOnly Property Rows As String
    Get
public:
static property String^ Rows {
    String^ get ();
}
static member Rows : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.RSort Property

FunctionsRSort Property

Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string RSort { get; }
Public Shared ReadOnly Property RSort As String
    Get
public:
static property String^ RSort {
    String^ get ();
}
static member RSort : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sec Property

FunctionsSec Property

Секанс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sec { get; }
Public Shared ReadOnly Property Sec As String
    Get
public:
static property String^ Sec {
    String^ get ();
}
static member Sec : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sech Property

FunctionsSech Property

Гиперболический секанс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sech { get; }
Public Shared ReadOnly Property Sech As String
    Get
public:
static property String^ Sech {
    String^ get ();
}
static member Sech : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sh Property

FunctionsSh Property

Гиперболический синус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sh { get; }
Public Shared ReadOnly Property Sh As String
    Get
public:
static property String^ Sh {
    String^ get ();
}
static member Sh : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sign Property

FunctionsSign Property

Сигнатура.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sign { get; }
Public Shared ReadOnly Property Sign As String
    Get
public:
static property String^ Sign {
    String^ get ();
}
static member Sign : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sin Property

FunctionsSin Property

Синус.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sin { get; }
Public Shared ReadOnly Property Sin As String
    Get
public:
static property String^ Sin {
    String^ get ();
}
static member Sin : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Solve Property

FunctionsSolve Property

Получение корней уравнения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Solve { get; }
Public Shared ReadOnly Property Solve As String
    Get
public:
static property String^ Solve {
    String^ get ();
}
static member Solve : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sort Property

FunctionsSort Property

Возвращает вектор с элементами, отсортированными в порядке возрастания.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sort { get; }
Public Shared ReadOnly Property Sort As String
    Get
public:
static property String^ Sort {
    String^ get ();
}
static member Sort : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sqrt Property

FunctionsSqrt Property

Квадратный корень.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sqrt { get; }
Public Shared ReadOnly Property Sqrt As String
    Get
public:
static property String^ Sqrt {
    String^ get ();
}
static member Sqrt : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Stack Property

FunctionsStack Property

Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Stack { get; }
Public Shared ReadOnly Property Stack As String
    Get
public:
static property String^ Stack {
    String^ get ();
}
static member Stack : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Submatrix Property

FunctionsSubmatrix Property

Получение матрицы указанных размеров из существующей.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Submatrix { get; }
Public Shared ReadOnly Property Submatrix As String
    Get
public:
static property String^ Submatrix {
    String^ get ();
}
static member Submatrix : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sum Property

FunctionsSum Property

Функция суммирования.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sum { get; }
Public Shared ReadOnly Property Sum As String
    Get
public:
static property String^ Sum {
    String^ get ();
}
static member Sum : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Switch Property

FunctionsSwitch Property

Функция выбора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Switch { get; }
Public Shared ReadOnly Property Switch As String
    Get
public:
static property String^ Switch {
    String^ get ();
}
static member Switch : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Sys Property

FunctionsSys Property

Алгебраическая система.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Sys { get; }
Public Shared ReadOnly Property Sys As String
    Get
public:
static property String^ Sys {
    String^ get ();
}
static member Sys : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Tg Property

FunctionsTg Property

Тангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Tg { get; }
Public Shared ReadOnly Property Tg As String
    Get
public:
static property String^ Tg {
    String^ get ();
}
static member Tg : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Th Property

FunctionsTh Property

Гиперболический тангенс.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Th { get; }
Public Shared ReadOnly Property Th As String
    Get
public:
static property String^ Th {
    String^ get ();
}
static member Th : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Tr Property

FunctionsTr Property

След матрицы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Tr { get; }
Public Shared ReadOnly Property Tr As String
    Get
public:
static property String^ Tr {
    String^ get ();
}
static member Tr : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Transpose Property

FunctionsTranspose Property

Транспонирование матрицы/вектора.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Transpose { get; }
Public Shared ReadOnly Property Transpose As String
    Get
public:
static property String^ Transpose {
    String^ get ();
}
static member Transpose : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Trunc Property

FunctionsTrunc Property

Получение целой части числа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Trunc { get; }
Public Shared ReadOnly Property Trunc As String
    Get
public:
static property String^ Trunc {
    String^ get ();
}
static member Trunc : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Vminor Property

FunctionsVminor Property

Визуальное представление минора - без вычисления конечного определителя.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Vminor { get; }
Public Shared ReadOnly Property Vminor As String
    Get
public:
static property String^ Vminor {
    String^ get ();
}
static member Vminor : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.WFile Property

FunctionsWFile Property

Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string WFile { get; }
Public Shared ReadOnly Property WFile As String
    Get
public:
static property String^ WFile {
    String^ get ();
}
static member WFile : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.While Property

FunctionsWhile Property

Цикл типа while.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string While { get; }
Public Shared ReadOnly Property While As String
    Get
public:
static property String^ While {
    String^ get ();
}
static member While : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.Xy2pol Property

FunctionsXy2pol Property

Перевод координат из прямоугольных к полярным.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Xy2pol { get; }
Public Shared ReadOnly Property Xy2pol As String
    Get
public:
static property String^ Xy2pol {
    String^ get ();
}
static member Xy2pol : string with get

Property Value

Type: String
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions Methods

The Functions type exposes the following members.

Methods
Name | Description
PrepareBuiltInFunctions |
Top
See Also

Reference

Functions Class
SMath.Manager Namespace


Functions.PrepareBuiltInFunctions Method

FunctionsPrepareBuiltInFunctions Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<TermInfo> PrepareBuiltInFunctions(
    SessionProfile sessionProfile
)
Public Shared Function PrepareBuiltInFunctions (
    sessionProfile As SessionProfile
) As List(Of TermInfo)
public:
static List<TermInfo^>^ PrepareBuiltInFunctions(
    SessionProfile^ sessionProfile
)
static member PrepareBuiltInFunctions :
        sessionProfile : SessionProfile -> List<TermInfo>

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: ListTermInfo
See Also

Reference

Functions Class
SMath.Manager Namespace


FunctionSections Enumeration

Function's section.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FunctionSections
<FlagsAttribute>
Public Enumeration FunctionSections
[FlagsAttribute]
public enum class FunctionSections
[<FlagsAttribute>]
type FunctionSections
Members
Member name | Value | Description
Unknown | 0 | No section matches the function.
MatricesAndVectors | 1 | Matrices and Vectors Section.
ComplexNumbers | 2 | Complex Numbers Section.
Trigonometric | 4 | Trigonometric Section.
Hyperbolic | 8 | Hyperbolic Section.
Programming | 16 | Programming Section.
Strings | 32 | Strings Section.
Files | 64 | Files Section.
See Also

Reference

SMath.Manager Namespace


GeneralException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.ManagerGeneralException
SMath.ManagerInterruptCalculationException
SMath.ManagerMathException

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class GeneralException : Exception
Public Class GeneralException
    Inherits Exception
public ref class GeneralException : public Exception
type GeneralException =
    class
        inherit Exception
    end

The GeneralException type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralException | Initializes a new instance of the GeneralException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorId |
Public method | GetErrorText(SessionProfile) |
 | GetErrorText(SessionProfile, Errors) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ErrorId |
Top
See Also

Reference

SMath.Manager Namespace


GeneralException Constructor

Initializes a new instance of the GeneralException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public GeneralException(
    Errors errorId
)
Public Sub New (
    errorId As Errors
)
public:
GeneralException(
    Errors errorId
)
new :
        errorId : Errors -> GeneralException

Parameters

errorId
Type: SMath.ManagerErrors
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException Properties

The GeneralException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException.Message Property

GeneralExceptionMessage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}
abstract Message : string with get
override Message : string with get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException Methods

The GeneralException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorId |
Public method | GetErrorText(SessionProfile) |
 | GetErrorText(SessionProfile, Errors) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException.GetErrorId Method

GeneralExceptionGetErrorId Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Errors GetErrorId(
    Exception e
)
Public Shared Function GetErrorId (
    e As Exception
) As Errors
public:
static Errors GetErrorId(
    Exception^ e
)
static member GetErrorId :
        e : Exception -> Errors

Parameters

e
Type: SystemException

Return Value

Type: Errors
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException.GetErrorText Method

GeneralExceptionGetErrorText Method

Overload List
 | Name | Description
Public method | GetErrorText(SessionProfile) |
 | GetErrorText(SessionProfile, Errors) |
Top
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException.GetErrorText Method (SessionProfile)

GeneralExceptionGetErrorText Method (SessionProfile)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetErrorText(
    SessionProfile sessionProfile
)
Public Function GetErrorText (
    sessionProfile As SessionProfile
) As String
public:
String^ GetErrorText(
    SessionProfile^ sessionProfile
)
member GetErrorText :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
See Also

Reference

GeneralException Class
GetErrorText Overload
SMath.Manager Namespace


GeneralException.GetErrorText Method (SessionProfile, Errors)

GeneralExceptionGetErrorText Method (SessionProfile, Errors)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetErrorText(
    SessionProfile sessionProfile,
    Errors inc
)
Public Shared Function GetErrorText (
    sessionProfile As SessionProfile,
    inc As Errors
) As String
public:
static String^ GetErrorText(
    SessionProfile^ sessionProfile,
    Errors inc
)
static member GetErrorText :
        sessionProfile : SessionProfile *
        inc : Errors -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
inc
Type: SMath.ManagerErrors

Return Value

Type: String
See Also

Reference

GeneralException Class
GetErrorText Overload
SMath.Manager Namespace


GeneralException Fields

The GeneralException type exposes the following members.

Fields
 | Name | Description
Public field | ErrorId |
Top
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GeneralException.ErrorId Field

GeneralExceptionErrorId Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Errors ErrorId
Public ErrorId As Errors
public:
Errors ErrorId
val mutable ErrorId: Errors

Field Value

Type: Errors
See Also

Reference

GeneralException Class
SMath.Manager Namespace


GlobalParams Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
SMath.ManagerGlobalProfile
SMath.ManagerGlobalParams

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SessionProfile enabled interfaces instead. SessionProfile contains all session specific options moved there from obsolete GlobalParams.")]
public class GlobalParams : GlobalProfile
<ObsoleteAttribute("Use SessionProfile enabled interfaces instead. SessionProfile contains all session specific options moved there from obsolete GlobalParams.")>
Public Class GlobalParams
    Inherits GlobalProfile
[ObsoleteAttribute(L"Use SessionProfile enabled interfaces instead. SessionProfile contains all session specific options moved there from obsolete GlobalParams.")]
public ref class GlobalParams : public GlobalProfile
[<ObsoleteAttribute("Use SessionProfile enabled interfaces instead. SessionProfile contains all session specific options moved there from obsolete GlobalParams.")>]
type GlobalParams =
    class
        inherit GlobalProfile
    end

The GlobalParams type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalParams | Initializes a new instance of the GlobalParams class
Top
Properties
Name | Description
ArgumentsSeparator |
CurLang3Letter |
CurrentArgumentsSeparator |
CurrentDecimalSymbol |
CurrentUnitsLanguage |
DecimalPlaces |
DecimalSymbol |
ExponentialThreshold |
IntegralAccuracy |
NamingType |
SolveFromPoint |
SolveToPoint |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


GlobalParams Constructor

Initializes a new instance of the GlobalParams class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public GlobalParams()
Public Sub New
public:
GlobalParams()
new : unit -> GlobalParams
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams Properties

The GlobalParams type exposes the following members.

Properties
Name | Description
ArgumentsSeparator |
CurLang3Letter |
CurrentArgumentsSeparator |
CurrentDecimalSymbol |
CurrentUnitsLanguage |
DecimalPlaces |
DecimalSymbol |
ExponentialThreshold |
IntegralAccuracy |
NamingType |
SolveFromPoint |
SolveToPoint |
Top
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.ArgumentsSeparator Property

GlobalParamsArgumentsSeparator Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char ArgumentsSeparator { get; }
Public Shared ReadOnly Property ArgumentsSeparator As Char
    Get
public:
static property wchar_t ArgumentsSeparator {
    wchar_t get ();
}
static member ArgumentsSeparator : char with get

Property Value

Type: Char
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.CurLang3Letter Property

GlobalParamsCurLang3Letter Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string CurLang3Letter { get; }
Public Shared ReadOnly Property CurLang3Letter As String
    Get
public:
static property String^ CurLang3Letter {
    String^ get ();
}
static member CurLang3Letter : string with get

Property Value

Type: String
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.CurrentArgumentsSeparator Property

GlobalParamsCurrentArgumentsSeparator Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char CurrentArgumentsSeparator { get; }
Public Shared ReadOnly Property CurrentArgumentsSeparator As Char
    Get
public:
static property wchar_t CurrentArgumentsSeparator {
    wchar_t get ();
}
static member CurrentArgumentsSeparator : char with get

Property Value

Type: Char
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.CurrentDecimalSymbol Property

GlobalParamsCurrentDecimalSymbol Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char CurrentDecimalSymbol { get; }
Public Shared ReadOnly Property CurrentDecimalSymbol As Char
    Get
public:
static property wchar_t CurrentDecimalSymbol {
    wchar_t get ();
}
static member CurrentDecimalSymbol : char with get

Property Value

Type: Char
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.CurrentUnitsLanguage Property

GlobalParamsCurrentUnitsLanguage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string CurrentUnitsLanguage { get; }
Public Shared ReadOnly Property CurrentUnitsLanguage As String
    Get
public:
static property String^ CurrentUnitsLanguage {
    String^ get ();
}
static member CurrentUnitsLanguage : string with get

Property Value

Type: String
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.DecimalPlaces Property

GlobalParamsDecimalPlaces Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int DecimalPlaces { get; }
Public Shared ReadOnly Property DecimalPlaces As Integer
    Get
public:
static property int DecimalPlaces {
    int get ();
}
static member DecimalPlaces : int with get

Property Value

Type: Int32
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.DecimalSymbol Property

GlobalParamsDecimalSymbol Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char DecimalSymbol { get; }
Public Shared ReadOnly Property DecimalSymbol As Char
    Get
public:
static property wchar_t DecimalSymbol {
    wchar_t get ();
}
static member DecimalSymbol : char with get

Property Value

Type: Char
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.ExponentialThreshold Property

GlobalParamsExponentialThreshold Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int ExponentialThreshold { get; }
Public Shared ReadOnly Property ExponentialThreshold As Integer
    Get
public:
static property int ExponentialThreshold {
    int get ();
}
static member ExponentialThreshold : int with get

Property Value

Type: Int32
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.IntegralAccuracy Property

GlobalParamsIntegralAccuracy Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int IntegralAccuracy { get; }
Public Shared ReadOnly Property IntegralAccuracy As Integer
    Get
public:
static property int IntegralAccuracy {
    int get ();
}
static member IntegralAccuracy : int with get

Property Value

Type: Int32
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.NamingType Property

GlobalParamsNamingType Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Guid NamingType { get; }
Public Shared ReadOnly Property NamingType As Guid
    Get
public:
static property Guid NamingType {
    Guid get ();
}
static member NamingType : Guid with get

Property Value

Type: Guid
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.SolveFromPoint Property

GlobalParamsSolveFromPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int SolveFromPoint { get; }
Public Shared ReadOnly Property SolveFromPoint As Integer
    Get
public:
static property int SolveFromPoint {
    int get ();
}
static member SolveFromPoint : int with get

Property Value

Type: Int32
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams.SolveToPoint Property

GlobalParamsSolveToPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int SolveToPoint { get; }
Public Shared ReadOnly Property SolveToPoint As Integer
    Get
public:
static property int SolveToPoint {
    int get ();
}
static member SolveToPoint : int with get

Property Value

Type: Int32
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalParams Methods

The GlobalParams type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GlobalParams Class
SMath.Manager Namespace


GlobalProfile Class

Inheritance Hierarchy
SystemObject
SMath.ManagerGlobalProfile
SMath.ManagerGlobalParams

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class GlobalProfile
Public Class GlobalProfile
public ref class GlobalProfile
type GlobalProfile =  class end

The GlobalProfile type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalProfile | Initializes a new instance of the GlobalProfile class
Top
Properties
Name | Description
ApplicationPath | Current application directory.Возвращает папку из которой происходит запуск программы.
Info |
IsPortableVersion | Defines if current program instance is a Portable version.Определяет является текущая копия программы портативной версией или нет.
OS | Returns type of the current client Operating System.Тип текущей клиентской операционной системы на которой выполняется программа.
Platform | Returns type of the current client platform.Тип текущей клиентской платформы на которой происходит выполнение программы.
ReleaseDate |
SettingsDirectory | Get the directory where all user specific parameters will be stored.Возвращает папку, куда записываются настройки программы.
SystemUniqueIdentifier |
Top
Methods
 | Name | Description
 | AppendToLog | Appends a record to log. Activates a Debug session if it is not activated yet.Добавляет запись в лог. Активирует режим отладки, если тот ещё не активен.
 | ColorToWebColor | Obsolete.
 | DisposePlugins | Завершение работы дополнений.
 | ElapsedToString | Returns time span as a short string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAssemblyT |
 | GetColorByName | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProductUrl(ProductUrlType) |
 | GetProductUrl(SessionProfile, ProductUrlType) |
 | GetProductUrl(SessionProfile, ProductUrlType, DictionaryString, String) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsBuiltInVariable | Detects if variable is built-in for SMath Studio.Определяет является ли переменная встроенной в SMath Studio.
 | IsResizableFunction |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreloadAssemblies |
 | PreloadAssemblies(Assembly) |
 | ReplaceUnicodeChars | Obsolete.
 | Scale(Int32) |
 | Scale(Single) |
 | SnapToGrid |
 | ToScreenDpi |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WebColorToColor | Obsolete.
Top
Fields
Name | Description
ArgumentsSeparatorStandard |
ArgumentsSeparatorSystem |
AvailableLanguages |
BuiltInFunctions |
CanvasCursorSize |
CanvasGridSize |
CanvasGridSizeSmall |
ContentDpi |
DebugPath |
DecimalSymbolStandard |
DecimalSymbolSystem |
DefaultInteractiveTutorial |
DefinitionOptimization |
EntriesFolderName |
ExtensionsFolderName |
FatalErrors |
FractionsTypeNumeric |
InteractiveTutorial |
IsAltKeyPressed |
IsAutoReCalc |
IsCtrlKeyPressed |
IsDynamicAssistance |
IsPreloadEnabled |
IsProgressFrequencyLimited |
IsShiftKeyPressed |
IsWebApplication |
MaxEvaluationTime |
MaxTestingTime |
namingEuro |
namingWorld |
PaperId |
PaperSize |
Plugins |
ProgressFrequency |
ProgressSleepPeriod |
Representations |
SessionHost |
SessionLogin |
SupportEMail |
SystemItemsType |
WebHost |
Top
See Also

Reference

SMath.Manager Namespace


GlobalProfile Constructor

Initializes a new instance of the GlobalProfile class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public GlobalProfile()
Public Sub New
public:
GlobalProfile()
new : unit -> GlobalProfile
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile Properties

The GlobalProfile type exposes the following members.

Properties
Name | Description
ApplicationPath | Current application directory.Возвращает папку из которой происходит запуск программы.
Info |
IsPortableVersion | Defines if current program instance is a Portable version.Определяет является текущая копия программы портативной версией или нет.
OS | Returns type of the current client Operating System.Тип текущей клиентской операционной системы на которой выполняется программа.
Platform | Returns type of the current client platform.Тип текущей клиентской платформы на которой происходит выполнение программы.
ReleaseDate |
SettingsDirectory | Get the directory where all user specific parameters will be stored.Возвращает папку, куда записываются настройки программы.
SystemUniqueIdentifier |
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ApplicationPath Property

GlobalProfileApplicationPath Property

Current application directory.Возвращает папку из которой происходит запуск программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string ApplicationPath { get; set; }
Public Shared Property ApplicationPath As String
    Get
    Set
public:
static property String^ ApplicationPath {
    String^ get ();
    void set (String^ value);
}
static member ApplicationPath : string with get, set

Property Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Info Property

GlobalProfileInfo Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static AssemblyInfo Info { get; }
Public Shared ReadOnly Property Info As AssemblyInfo
    Get
public:
static property AssemblyInfo Info {
    AssemblyInfo get ();
}
static member Info : AssemblyInfo with get

Property Value

Type: AssemblyInfo
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsPortableVersion Property

GlobalProfileIsPortableVersion Property

Defines if current program instance is a Portable version.Определяет является текущая копия программы портативной версией или нет.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPortableVersion { get; }
Public Shared ReadOnly Property IsPortableVersion As Boolean
    Get
public:
static property bool IsPortableVersion {
    bool get ();
}
static member IsPortableVersion : bool with get

Property Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.OS Property

GlobalProfileOS Property

Returns type of the current client Operating System.Тип текущей клиентской операционной системы на которой выполняется программа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static OSType OS { get; }
Public Shared ReadOnly Property OS As OSType
    Get
public:
static property OSType OS {
    OSType get ();
}
static member OS : OSType with get

Property Value

Type: OSType
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Platform Property

GlobalProfilePlatform Property

Returns type of the current client platform.Тип текущей клиентской платформы на которой происходит выполнение программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static PlatformType Platform { get; }
Public Shared ReadOnly Property Platform As PlatformType
    Get
public:
static property PlatformType Platform {
    PlatformType get ();
}
static member Platform : PlatformType with get

Property Value

Type: PlatformType
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ReleaseDate Property

GlobalProfileReleaseDate Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static DateTime ReleaseDate { get; }
Public Shared ReadOnly Property ReleaseDate As DateTime
    Get
public:
static property DateTime ReleaseDate {
    DateTime get ();
}
static member ReleaseDate : DateTime with get

Property Value

Type: DateTime
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SettingsDirectory Property

GlobalProfileSettingsDirectory Property

Get the directory where all user specific parameters will be stored.Возвращает папку, куда записываются настройки программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SettingsDirectory { get; }
Public Shared ReadOnly Property SettingsDirectory As String
    Get
public:
static property String^ SettingsDirectory {
    String^ get ();
}
static member SettingsDirectory : string with get

Property Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SystemUniqueIdentifier Property

GlobalProfileSystemUniqueIdentifier Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SystemUniqueIdentifier { get; }
Public Shared ReadOnly Property SystemUniqueIdentifier As String
    Get
public:
static property String^ SystemUniqueIdentifier {
    String^ get ();
}
static member SystemUniqueIdentifier : string with get

Property Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile Methods

The GlobalProfile type exposes the following members.

Methods
 | Name | Description
 | AppendToLog | Appends a record to log. Activates a Debug session if it is not activated yet.Добавляет запись в лог. Активирует режим отладки, если тот ещё не активен.
 | ColorToWebColor | Obsolete.
 | DisposePlugins | Завершение работы дополнений.
 | ElapsedToString | Returns time span as a short string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAssemblyT |
 | GetColorByName | Obsolete.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProductUrl(ProductUrlType) |
 | GetProductUrl(SessionProfile, ProductUrlType) |
 | GetProductUrl(SessionProfile, ProductUrlType, DictionaryString, String) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsBuiltInVariable | Detects if variable is built-in for SMath Studio.Определяет является ли переменная встроенной в SMath Studio.
 | IsResizableFunction |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PreloadAssemblies |
 | PreloadAssemblies(Assembly) |
 | ReplaceUnicodeChars | Obsolete.
 | Scale(Int32) |
 | Scale(Single) |
 | SnapToGrid |
 | ToScreenDpi |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WebColorToColor | Obsolete.
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.AppendToLog Method

GlobalProfileAppendToLog Method

Appends a record to log. Activates a Debug session if it is not activated yet.Добавляет запись в лог. Активирует режим отладки, если тот ещё не активен.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void AppendToLog(
    string text,
    string signature
)
Public Shared Sub AppendToLog (
    text As String,
    signature As String
)
public:
static void AppendToLog(
    String^ text,
    String^ signature
)
static member AppendToLog :
        text : string *
        signature : string -> unit

Parameters

text
Type: SystemString
Text to append.Текст для добавления.
signature
Type: SystemString
Record signature.Подпись события.
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ColorToWebColor Method

GlobalProfileColorToWebColor Method

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SMath.Drawing.Graphics.ColorToWebColor instead.")]
public static string ColorToWebColor(
    Color color
)
<ObsoleteAttribute("Use SMath.Drawing.Graphics.ColorToWebColor instead.")>
Public Shared Function ColorToWebColor (
    color As Color
) As String
public:
[ObsoleteAttribute(L"Use SMath.Drawing.Graphics.ColorToWebColor instead.")]
static String^ ColorToWebColor(
    Color color
)
[<ObsoleteAttribute("Use SMath.Drawing.Graphics.ColorToWebColor instead.")>]
static member ColorToWebColor :
        color : Color -> string

Parameters

color
Type: System.DrawingColor

Return Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DisposePlugins Method

GlobalProfileDisposePlugins Method

Завершение работы дополнений.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DisposePlugins()
Public Shared Sub DisposePlugins
public:
static void DisposePlugins()
static member DisposePlugins : unit -> unit
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ElapsedToString Method

GlobalProfileElapsedToString Method

Returns time span as a short string.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string ElapsedToString(
    TimeSpan ts
)
Public Shared Function ElapsedToString (
    ts As TimeSpan
) As String
public:
static String^ ElapsedToString(
    TimeSpan ts
)
static member ElapsedToString :
        ts : TimeSpan -> string

Parameters

ts
Type: SystemTimeSpan

Return Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.GetAssembly(T) Method

GlobalProfileGetAssemblyT Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Assembly GetAssembly<T>()
where T : class

Public Shared Function GetAssembly(Of T As Class) As Assembly
public:
generic<typename T>
where T : ref class
static Assembly^ GetAssembly()
static member GetAssembly : unit -> Assembly  when 'T : not struct

Type Parameters

T

Return Value

Type: Assembly
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.GetColorByName Method

GlobalProfileGetColorByName Method

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")]
public static Color GetColorByName(
    string colorName
)
<ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")>
Public Shared Function GetColorByName (
    colorName As String
) As Color
public:
[ObsoleteAttribute(L"Use SMath.Drawing.Graphics.GetColorByName instead.")]
static Color GetColorByName(
    String^ colorName
)
[<ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")>]
static member GetColorByName :
        colorName : string -> Color

Parameters

colorName
Type: SystemString

Return Value

Type: Color
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.GetProductUrl Method

GlobalProfileGetProductUrl Method

Overload List
Name | Description
GetProductUrl(ProductUrlType) |
GetProductUrl(SessionProfile, ProductUrlType) |
GetProductUrl(SessionProfile, ProductUrlType, DictionaryString, String) |
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.GetProductUrl Method (ProductUrlType)

GlobalProfileGetProductUrl Method (ProductUrlType)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetProductUrl(
    ProductUrlType urlType
)
Public Shared Function GetProductUrl (
    urlType As ProductUrlType
) As String
public:
static String^ GetProductUrl(
    ProductUrlType urlType
)
static member GetProductUrl :
        urlType : ProductUrlType -> string

Parameters

urlType
Type: SMath.ManagerProductUrlType

Return Value

Type: String
See Also

Reference

GlobalProfile Class
GetProductUrl Overload
SMath.Manager Namespace


GlobalProfile.GetProductUrl Method (SessionProfile, ProductUrlType)

GlobalProfileGetProductUrl Method (SessionProfile, ProductUrlType)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetProductUrl(
    SessionProfile sessionProfile,
    ProductUrlType urlType
)
Public Shared Function GetProductUrl (
    sessionProfile As SessionProfile,
    urlType As ProductUrlType
) As String
public:
static String^ GetProductUrl(
    SessionProfile^ sessionProfile,
    ProductUrlType urlType
)
static member GetProductUrl :
        sessionProfile : SessionProfile *
        urlType : ProductUrlType -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
urlType
Type: SMath.ManagerProductUrlType

Return Value

Type: String
See Also

Reference

GlobalProfile Class
GetProductUrl Overload
SMath.Manager Namespace


GlobalProfile.GetProductUrl Method (SessionProfile, ProductUrlType, Dictionary(String, String))

GlobalProfileGetProductUrl Method (SessionProfile, ProductUrlType, DictionaryString, String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetProductUrl(
    SessionProfile sessionProfile,
    ProductUrlType urlType,
    Dictionary<string, string> args
)
Public Shared Function GetProductUrl (
    sessionProfile As SessionProfile,
    urlType As ProductUrlType,
    args As Dictionary(Of String, String)
) As String
public:
static String^ GetProductUrl(
    SessionProfile^ sessionProfile,
    ProductUrlType urlType,
    Dictionary<String^, String^>^ args
)
static member GetProductUrl :
        sessionProfile : SessionProfile *
        urlType : ProductUrlType *
        args : Dictionary<string, string> -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
urlType
Type: SMath.ManagerProductUrlType
args
Type: System.Collections.GenericDictionaryString, String

Return Value

Type: String
See Also

Reference

GlobalProfile Class
GetProductUrl Overload
SMath.Manager Namespace


GlobalProfile.IsBuiltInVariable Method

GlobalProfileIsBuiltInVariable Method

Detects if variable is built-in for SMath Studio.Определяет является ли переменная встроенной в SMath Studio.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInVariable(
    IPrimitive value
)
Public Shared Function IsBuiltInVariable (
    value As IPrimitive
) As Boolean
public:
static bool IsBuiltInVariable(
    IPrimitive^ value
)
static member IsBuiltInVariable :
        value : IPrimitive -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
Primitive to test.Примитив для тестирования.

Return Value

Type: Boolean
Returns true if variable is built-in.Возвращает истинно, если переменная встроена.
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsResizableFunction Method

GlobalProfileIsResizableFunction Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsResizableFunction(
    string name
)
Public Shared Function IsResizableFunction (
    name As String
) As Boolean
public:
static bool IsResizableFunction(
    String^ name
)
static member IsResizableFunction :
        name : string -> bool

Parameters

name
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.PreloadAssemblies Method

GlobalProfilePreloadAssemblies Method

Overload List
Name | Description
PreloadAssemblies |
PreloadAssemblies(Assembly) |
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.PreloadAssemblies Method

GlobalProfilePreloadAssemblies Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void PreloadAssemblies()
Public Shared Sub PreloadAssemblies
public:
static void PreloadAssemblies()
static member PreloadAssemblies : unit -> unit
See Also

Reference

GlobalProfile Class
PreloadAssemblies Overload
SMath.Manager Namespace


GlobalProfile.PreloadAssemblies Method (Assembly)

GlobalProfilePreloadAssemblies Method (Assembly)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void PreloadAssemblies(
    Assembly asm
)
Public Shared Sub PreloadAssemblies (
    asm As Assembly
)
public:
static void PreloadAssemblies(
    Assembly^ asm
)
static member PreloadAssemblies :
        asm : Assembly -> unit

Parameters

asm
Type: System.ReflectionAssembly
See Also

Reference

GlobalProfile Class
PreloadAssemblies Overload
SMath.Manager Namespace


GlobalProfile.ReplaceUnicodeChars Method

GlobalProfileReplaceUnicodeChars Method

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use TermsConverter.Decode instead.")]
public static string ReplaceUnicodeChars(
    string text
)
<ObsoleteAttribute("Use TermsConverter.Decode instead.")>
Public Shared Function ReplaceUnicodeChars (
    text As String
) As String
public:
[ObsoleteAttribute(L"Use TermsConverter.Decode instead.")]
static String^ ReplaceUnicodeChars(
    String^ text
)
[<ObsoleteAttribute("Use TermsConverter.Decode instead.")>]
static member ReplaceUnicodeChars :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Scale Method

GlobalProfileScale Method

Overload List
Name | Description
Scale(Int32) |
Scale(Single) |
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Scale Method (Int32)

GlobalProfileScale Method (Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int Scale(
    int value
)
Public Shared Function Scale (
    value As Integer
) As Integer
public:
static int Scale(
    int value
)
static member Scale :
        value : int -> int

Parameters

value
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

GlobalProfile Class
Scale Overload
SMath.Manager Namespace


GlobalProfile.Scale Method (Single)

GlobalProfileScale Method (Single)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static float Scale(
    float value
)
Public Shared Function Scale (
    value As Single
) As Single
public:
static float Scale(
    float value
)
static member Scale :
        value : float32 -> float32

Parameters

value
Type: SystemSingle

Return Value

Type: Single
See Also

Reference

GlobalProfile Class
Scale Overload
SMath.Manager Namespace


GlobalProfile.SnapToGrid Method

GlobalProfileSnapToGrid Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int SnapToGrid(
    double value,
    ContentPlacement placement
)
Public Shared Function SnapToGrid (
    value As Double,
    placement As ContentPlacement
) As Integer
public:
static int SnapToGrid(
    double value,
    ContentPlacement placement
)
static member SnapToGrid :
        value : float *
        placement : ContentPlacement -> int

Parameters

value
Type: SystemDouble
placement
Type: SMath.ManagerContentPlacement

Return Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ToScreenDpi Method

GlobalProfileToScreenDpi Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static float ToScreenDpi(
    float value
)
Public Shared Function ToScreenDpi (
    value As Single
) As Single
public:
static float ToScreenDpi(
    float value
)
static member ToScreenDpi :
        value : float32 -> float32

Parameters

value
Type: SystemSingle

Return Value

Type: Single
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.WebColorToColor Method

GlobalProfileWebColorToColor Method

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")]
public static int WebColorToColor(
    string value
)
<ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")>
Public Shared Function WebColorToColor (
    value As String
) As Integer
public:
[ObsoleteAttribute(L"Use SMath.Drawing.Graphics.GetColorByName instead.")]
static int WebColorToColor(
    String^ value
)
[<ObsoleteAttribute("Use SMath.Drawing.Graphics.GetColorByName instead.")>]
static member WebColorToColor :
        value : string -> int

Parameters

value
Type: SystemString

Return Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile Fields

The GlobalProfile type exposes the following members.

Fields
Name | Description
ArgumentsSeparatorStandard |
ArgumentsSeparatorSystem |
AvailableLanguages |
BuiltInFunctions |
CanvasCursorSize |
CanvasGridSize |
CanvasGridSizeSmall |
ContentDpi |
DebugPath |
DecimalSymbolStandard |
DecimalSymbolSystem |
DefaultInteractiveTutorial |
DefinitionOptimization |
EntriesFolderName |
ExtensionsFolderName |
FatalErrors |
FractionsTypeNumeric |
InteractiveTutorial |
IsAltKeyPressed |
IsAutoReCalc |
IsCtrlKeyPressed |
IsDynamicAssistance |
IsPreloadEnabled |
IsProgressFrequencyLimited |
IsShiftKeyPressed |
IsWebApplication |
MaxEvaluationTime |
MaxTestingTime |
namingEuro |
namingWorld |
PaperId |
PaperSize |
Plugins |
ProgressFrequency |
ProgressSleepPeriod |
Representations |
SessionHost |
SessionLogin |
SupportEMail |
SystemItemsType |
WebHost |
Top
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ArgumentsSeparatorStandard Field

GlobalProfileArgumentsSeparatorStandard Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char ArgumentsSeparatorStandard
Public Shared ArgumentsSeparatorStandard As Char
public:
static wchar_t ArgumentsSeparatorStandard
static val mutable ArgumentsSeparatorStandard: char

Field Value

Type: Char
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ArgumentsSeparatorSystem Field

GlobalProfileArgumentsSeparatorSystem Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char ArgumentsSeparatorSystem
Public Shared ArgumentsSeparatorSystem As Char
public:
static wchar_t ArgumentsSeparatorSystem
static val mutable ArgumentsSeparatorSystem: char

Field Value

Type: Char
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.AvailableLanguages Field

GlobalProfileAvailableLanguages Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static LanguageInfo[] AvailableLanguages
Public Shared AvailableLanguages As LanguageInfo()
public:
static array<LanguageInfo^>^ AvailableLanguages
static val mutable AvailableLanguages: LanguageInfo[]

Field Value

Type: LanguageInfo
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.BuiltInFunctions Field

GlobalProfileBuiltInFunctions Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TermInfo[] BuiltInFunctions
Public Shared BuiltInFunctions As TermInfo()
public:
static array<TermInfo^>^ BuiltInFunctions
static val mutable BuiltInFunctions: TermInfo[]

Field Value

Type: TermInfo
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.CanvasCursorSize Field

GlobalProfileCanvasCursorSize Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int CanvasCursorSize = 9
Public Const CanvasCursorSize As Integer = 9
public:
literal int CanvasCursorSize = 9
static val mutable CanvasCursorSize: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.CanvasGridSize Field

GlobalProfileCanvasGridSize Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int CanvasGridSize = 9
Public Const CanvasGridSize As Integer = 9
public:
literal int CanvasGridSize = 9
static val mutable CanvasGridSize: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.CanvasGridSizeSmall Field

GlobalProfileCanvasGridSizeSmall Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int CanvasGridSizeSmall = 3
Public Const CanvasGridSizeSmall As Integer = 3
public:
literal int CanvasGridSizeSmall = 3
static val mutable CanvasGridSizeSmall: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ContentDpi Field

GlobalProfileContentDpi Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const float ContentDpi = 96f
Public Const ContentDpi As Single = 96F
public:
literal float ContentDpi = 96f
static val mutable ContentDpi: float32

Field Value

Type: Single
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DebugPath Field

GlobalProfileDebugPath Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DebugPath
Public Shared DebugPath As String
public:
static String^ DebugPath
static val mutable DebugPath: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DecimalSymbolStandard Field

GlobalProfileDecimalSymbolStandard Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char DecimalSymbolStandard
Public Shared DecimalSymbolStandard As Char
public:
static wchar_t DecimalSymbolStandard
static val mutable DecimalSymbolStandard: char

Field Value

Type: Char
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DecimalSymbolSystem Field

GlobalProfileDecimalSymbolSystem Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static char DecimalSymbolSystem
Public Shared DecimalSymbolSystem As Char
public:
static wchar_t DecimalSymbolSystem
static val mutable DecimalSymbolSystem: char

Field Value

Type: Char
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DefaultInteractiveTutorial Field

GlobalProfileDefaultInteractiveTutorial Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DefaultInteractiveTutorial
Public Shared DefaultInteractiveTutorial As String
public:
static String^ DefaultInteractiveTutorial
static val mutable DefaultInteractiveTutorial: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.DefinitionOptimization Field

GlobalProfileDefinitionOptimization Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static OptimizationType DefinitionOptimization
Public Shared DefinitionOptimization As OptimizationType
public:
static OptimizationType DefinitionOptimization
static val mutable DefinitionOptimization: OptimizationType

Field Value

Type: OptimizationType
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.EntriesFolderName Field

GlobalProfileEntriesFolderName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EntriesFolderName = "entries"
Public Const EntriesFolderName As String = "entries"
public:
literal String^ EntriesFolderName = "entries"
static val mutable EntriesFolderName: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ExtensionsFolderName Field

GlobalProfileExtensionsFolderName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ExtensionsFolderName = "extensions"
Public Const ExtensionsFolderName As String = "extensions"
public:
literal String^ ExtensionsFolderName = "extensions"
static val mutable ExtensionsFolderName: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.FatalErrors Field

GlobalProfileFatalErrors Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string[] FatalErrors
Public Shared FatalErrors As String()
public:
static array<String^>^ FatalErrors
static val mutable FatalErrors: string[]

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.FractionsTypeNumeric Field

GlobalProfileFractionsTypeNumeric Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static FractionsType FractionsTypeNumeric
Public Shared FractionsTypeNumeric As FractionsType
public:
static FractionsType FractionsTypeNumeric
static val mutable FractionsTypeNumeric: FractionsType

Field Value

Type: FractionsType
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.InteractiveTutorial Field

GlobalProfileInteractiveTutorial Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string InteractiveTutorial
Public Shared InteractiveTutorial As String
public:
static String^ InteractiveTutorial
static val mutable InteractiveTutorial: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsAltKeyPressed Field

GlobalProfileIsAltKeyPressed Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsAltKeyPressed
Public Shared IsAltKeyPressed As Boolean
public:
static bool IsAltKeyPressed
static val mutable IsAltKeyPressed: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsAutoReCalc Field

GlobalProfileIsAutoReCalc Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsAutoReCalc
Public Shared IsAutoReCalc As Boolean
public:
static bool IsAutoReCalc
static val mutable IsAutoReCalc: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsCtrlKeyPressed Field

GlobalProfileIsCtrlKeyPressed Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsCtrlKeyPressed
Public Shared IsCtrlKeyPressed As Boolean
public:
static bool IsCtrlKeyPressed
static val mutable IsCtrlKeyPressed: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsDynamicAssistance Field

GlobalProfileIsDynamicAssistance Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsDynamicAssistance
Public Shared IsDynamicAssistance As Boolean
public:
static bool IsDynamicAssistance
static val mutable IsDynamicAssistance: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsPreloadEnabled Field

GlobalProfileIsPreloadEnabled Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPreloadEnabled
Public Shared IsPreloadEnabled As Boolean
public:
static bool IsPreloadEnabled
static val mutable IsPreloadEnabled: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsProgressFrequencyLimited Field

GlobalProfileIsProgressFrequencyLimited Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsProgressFrequencyLimited
Public Shared IsProgressFrequencyLimited As Boolean
public:
static bool IsProgressFrequencyLimited
static val mutable IsProgressFrequencyLimited: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsShiftKeyPressed Field

GlobalProfileIsShiftKeyPressed Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsShiftKeyPressed
Public Shared IsShiftKeyPressed As Boolean
public:
static bool IsShiftKeyPressed
static val mutable IsShiftKeyPressed: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.IsWebApplication Field

GlobalProfileIsWebApplication Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsWebApplication
Public Shared IsWebApplication As Boolean
public:
static bool IsWebApplication
static val mutable IsWebApplication: bool

Field Value

Type: Boolean
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.MaxEvaluationTime Field

GlobalProfileMaxEvaluationTime Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int MaxEvaluationTime = 3000
Public Const MaxEvaluationTime As Integer = 3000
public:
literal int MaxEvaluationTime = 3000
static val mutable MaxEvaluationTime: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.MaxTestingTime Field

GlobalProfileMaxTestingTime Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int MaxTestingTime = 3600000
Public Const MaxTestingTime As Integer = 3600000
public:
literal int MaxTestingTime = 3600000
static val mutable MaxTestingTime: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.namingEuro Field

GlobalProfilenamingEuro Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Guid namingEuro
Public Shared namingEuro As Guid
public:
static Guid namingEuro
static val mutable namingEuro: Guid

Field Value

Type: Guid
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.namingWorld Field

GlobalProfilenamingWorld Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Guid namingWorld
Public Shared namingWorld As Guid
public:
static Guid namingWorld
static val mutable namingWorld: Guid

Field Value

Type: Guid
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.PaperId Field

GlobalProfilePaperId Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int PaperId
Public Shared PaperId As Integer
public:
static int PaperId
static val mutable PaperId: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.PaperSize Field

GlobalProfilePaperSize Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Size PaperSize
Public Shared PaperSize As Size
public:
static Size PaperSize
static val mutable PaperSize: Size

Field Value

Type: Size
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Plugins Field

GlobalProfilePlugins Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<PluginInfo> Plugins
Public Shared Plugins As List(Of PluginInfo)
public:
static List<PluginInfo^>^ Plugins
static val mutable Plugins: List<PluginInfo>

Field Value

Type: ListPluginInfo
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ProgressFrequency Field

GlobalProfileProgressFrequency Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int ProgressFrequency = 100
Public Const ProgressFrequency As Integer = 100
public:
literal int ProgressFrequency = 100
static val mutable ProgressFrequency: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.ProgressSleepPeriod Field

GlobalProfileProgressSleepPeriod Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const int ProgressSleepPeriod = 10
Public Const ProgressSleepPeriod As Integer = 10
public:
literal int ProgressSleepPeriod = 10
static val mutable ProgressSleepPeriod: int

Field Value

Type: Int32
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.Representations Field

GlobalProfileRepresentations Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> Representations
Public Shared Representations As List(Of String)
public:
static List<String^>^ Representations
static val mutable Representations: List<string>

Field Value

Type: ListString
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SessionHost Field

GlobalProfileSessionHost Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SessionHost
Public Shared SessionHost As String
public:
static String^ SessionHost
static val mutable SessionHost: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SessionLogin Field

GlobalProfileSessionLogin Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SessionLogin
Public Shared SessionLogin As String
public:
static String^ SessionLogin
static val mutable SessionLogin: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SupportEMail Field

GlobalProfileSupportEMail Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string SupportEMail = "support@smath.com"
Public Const SupportEMail As String = "support@smath.com"
public:
literal String^ SupportEMail = "support@smath.com"
static val mutable SupportEMail: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.SystemItemsType Field

GlobalProfileSystemItemsType Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SysSettings SystemItemsType
Public Shared SystemItemsType As SysSettings
public:
static SysSettings SystemItemsType
static val mutable SystemItemsType: SysSettings

Field Value

Type: SysSettings
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


GlobalProfile.WebHost Field

GlobalProfileWebHost Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string WebHost = "smath.com"
Public Const WebHost As String = "smath.com"
public:
literal String^ WebHost = "smath.com"
static val mutable WebHost: string

Field Value

Type: String
See Also

Reference

GlobalProfile Class
SMath.Manager Namespace


IDetailedTerm Interface

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IDetailedTerm
Public Interface IDetailedTerm
public interface class IDetailedTerm
type IDetailedTerm =  interface end

The IDetailedTerm type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | Title |
Top
Methods
 | Name | Description
Public method | GetDetails |
Public method | ToTerm |
Top
See Also

Reference

SMath.Manager Namespace


IDetailedTerm Properties

The IDetailedTerm type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | Title |
Top
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IDetailedTerm.Description Property

IDetailedTermDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Description { get; }
ReadOnly Property Description As String
    Get
property String^ Description {
    String^ get ();
}
abstract Description : string with get

Property Value

Type: String
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IDetailedTerm.Title Property

IDetailedTermTitle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Title { get; }
ReadOnly Property Title As String
    Get
property String^ Title {
    String^ get ();
}
abstract Title : string with get

Property Value

Type: String
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IDetailedTerm Methods

The IDetailedTerm type exposes the following members.

Methods
 | Name | Description
Public method | GetDetails |
Public method | ToTerm |
Top
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IDetailedTerm.GetDetails Method

IDetailedTermGetDetails Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string GetDetails(
    SessionProfile sessionProfile
)
Function GetDetails (
    sessionProfile As SessionProfile
) As String
String^ GetDetails(
    SessionProfile^ sessionProfile
)
abstract GetDetails :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IDetailedTerm.ToTerm Method

IDetailedTermToTerm Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
Term ToTerm(
    SessionProfile sessionProfile
)
Function ToTerm (
    sessionProfile As SessionProfile
) As Term
Term^ ToTerm(
    SessionProfile^ sessionProfile
)
abstract ToTerm :
        sessionProfile : SessionProfile -> Term

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: Term
See Also

Reference

IDetailedTerm Interface
SMath.Manager Namespace


IEvaluationActionContext Interface

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IEvaluationActionContext
Public Interface IEvaluationActionContext
public interface class IEvaluationActionContext
type IEvaluationActionContext =  interface end

The IEvaluationActionContext type exposes the following members.

Properties
 | Name | Description
Public property | IsDefProcessing |
Public property | IsUnderVectorization |
Top
Methods
 | Name | Description
Public method | Contains(IPrimitive) |
Public method | Contains(IPrimitive, Definition) |
Top
See Also

Reference

SMath.Manager Namespace


IEvaluationActionContext Properties

The IEvaluationActionContext type exposes the following members.

Properties
 | Name | Description
Public property | IsDefProcessing |
Public property | IsUnderVectorization |
Top
See Also

Reference

IEvaluationActionContext Interface
SMath.Manager Namespace


IEvaluationActionContext.IsDefProcessing Property

IEvaluationActionContextIsDefProcessing Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsDefProcessing { get; set; }
Property IsDefProcessing As Boolean
    Get
    Set
property bool IsDefProcessing {
    bool get ();
    void set (bool value);
}
abstract IsDefProcessing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IEvaluationActionContext Interface
SMath.Manager Namespace


IEvaluationActionContext.IsUnderVectorization Property

IEvaluationActionContextIsUnderVectorization Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IsUnderVectorization { get; }
ReadOnly Property IsUnderVectorization As Boolean
    Get
property bool IsUnderVectorization {
    bool get ();
}
abstract IsUnderVectorization : bool with get

Property Value

Type: Boolean
See Also

Reference

IEvaluationActionContext Interface
SMath.Manager Namespace


IEvaluationActionContext Methods

Methods
 | Name | Description
Public method | Contains(IPrimitive) |
Public method | Contains(IPrimitive, Definition) |
Top
See Also

Reference

IEvaluationActionContext Interface
SMath.Manager Namespace


IEvaluationActionContext.Contains Method

IEvaluationActionContextContains Method

Overload List
 | Name | Description
Public method | Contains(IPrimitive) |
Public method | Contains(IPrimitive, Definition) |
Top
See Also

Reference

IEvaluationActionContext Interface
SMath.Manager Namespace


IEvaluationActionContext.Contains Method (IPrimitive[])

IEvaluationActionContextContains Method (IPrimitive)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    params IPrimitive[] value
)
Function Contains (
    ParamArray value As IPrimitive()
) As Boolean
bool Contains(
    ... array<IPrimitive^>^ value
)
abstract Contains :
        value : IPrimitive[] -> bool

Parameters

value
Type: SMath.ManagerIPrimitive

Return Value

Type: Boolean
See Also

Reference

IEvaluationActionContext Interface
Contains Overload
SMath.Manager Namespace


IEvaluationActionContext.Contains Method (IPrimitive, Definition)

IEvaluationActionContextContains Method (IPrimitive, Definition)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool Contains(
    IPrimitive value,
    out Definition def
)
Function Contains (
    value As IPrimitive,
    <OutAttribute> ByRef def As Definition
) As Boolean
bool Contains(
    IPrimitive^ value,
    [OutAttribute] Definition^% def
)
abstract Contains :
        value : IPrimitive *
        def : Definition byref -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
def
Type: SMath.ManagerDefinition

Return Value

Type: Boolean
See Also

Reference

IEvaluationActionContext Interface
Contains Overload
SMath.Manager Namespace


InputKeys Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum InputKeys
<FlagsAttribute>
Public Enumeration InputKeys
[FlagsAttribute]
public enum class InputKeys
[<FlagsAttribute>]
type InputKeys
Members
Member name | Value | Description
Modifiers | -65536 |
None | 0 |
LButton | 1 |
RButton | 2 |
Cancel | 3 |
MButton | 4 |
XButton1 | 5 |
XButton2 | 6 |
Back | 8 |
Tab | 9 |
LineFeed | 10 |
Clear | 12 |
Enter | 13 |
Return | 13 |
ShiftKey | 16 |
ControlKey | 17 |
Menu | 18 |
Pause | 19 |
CapsLock | 20 |
Capital | 20 |
KanaMode | 21 |
HanguelMode | 21 |
HangulMode | 21 |
JunjaMode | 23 |
FinalMode | 24 |
KanjiMode | 25 |
HanjaMode | 25 |
Escape | 27 |
IMEConvert | 28 |
IMENonconvert | 29 |
IMEAceept | 30 |
IMEAccept | 30 |
IMEModeChange | 31 |
Space | 32 |
Prior | 33 |
PageUp | 33 |
Next | 34 |
PageDown | 34 |
End | 35 |
Home | 36 |
Left | 37 |
Up | 38 |
Right | 39 |
Down | 40 |
Select | 41 |
Print | 42 |
Execute | 43 |
PrintScreen | 44 |
Snapshot | 44 |
Insert | 45 |
Delete | 46 |
Help | 47 |
D0 | 48 |
D1 | 49 |
D2 | 50 |
D3 | 51 |
D4 | 52 |
D5 | 53 |
D6 | 54 |
D7 | 55 |
D8 | 56 |
D9 | 57 |
A | 65 |
B | 66 |
C | 67 |
D | 68 |
E | 69 |
F | 70 |
G | 71 |
H | 72 |
I | 73 |
J | 74 |
K | 75 |
L | 76 |
M | 77 |
N | 78 |
O | 79 |
P | 80 |
Q | 81 |
R | 82 |
S | 83 |
T | 84 |
U | 85 |
V | 86 |
W | 87 |
X | 88 |
Y | 89 |
Z | 90 |
LWin | 91 |
RWin | 92 |
Apps | 93 |
Sleep | 95 |
NumPad0 | 96 |
NumPad1 | 97 |
NumPad2 | 98 |
NumPad3 | 99 |
NumPad4 | 100 |
NumPad5 | 101 |
NumPad6 | 102 |
NumPad7 | 103 |
NumPad8 | 104 |
NumPad9 | 105 |
Multiply | 106 |
Add | 107 |
Separator | 108 |
Subtract | 109 |
Decimal | 110 |
Divide | 111 |
F1 | 112 |
F2 | 113 |
F3 | 114 |
F4 | 115 |
F5 | 116 |
F6 | 117 |
F7 | 118 |
F8 | 119 |
F9 | 120 |
F10 | 121 |
F11 | 122 |
F12 | 123 |
F13 | 124 |
F14 | 125 |
F15 | 126 |
F16 | 127 |
F17 | 128 |
F18 | 129 |
F19 | 130 |
F20 | 131 |
F21 | 132 |
F22 | 133 |
F23 | 134 |
F24 | 135 |
NumLock | 144 |
Scroll | 145 |
LShiftKey | 160 |
RShiftKey | 161 |
LControlKey | 162 |
RControlKey | 163 |
LMenu | 164 |
RMenu | 165 |
BrowserBack | 166 |
BrowserForward | 167 |
BrowserRefresh | 168 |
BrowserStop | 169 |
BrowserSearch | 170 |
BrowserFavorites | 171 |
BrowserHome | 172 |
VolumeMute | 173 |
VolumeDown | 174 |
VolumeUp | 175 |
MediaNextTrack | 176 |
MediaPreviousTrack | 177 |
MediaStop | 178 |
MediaPlayPause | 179 |
LaunchMail | 180 |
SelectMedia | 181 |
LaunchApplication1 | 182 |
LaunchApplication2 | 183 |
Oem1 | 186 |
OemSemicolon | 186 |
Oemplus | 187 |
Oemcomma | 188 |
OemMinus | 189 |
OemPeriod | 190 |
OemQuestion | 191 |
Oem2 | 191 |
Oemtilde | 192 |
Oem3 | 192 |
Oem4 | 219 |
OemOpenBrackets | 219 |
OemPipe | 220 |
Oem5 | 220 |
Oem6 | 221 |
OemCloseBrackets | 221 |
Oem7 | 222 |
OemQuotes | 222 |
Oem8 | 223 |
Oem102 | 226 |
OemBackslash | 226 |
ProcessKey | 229 |
Packet | 231 |
Attn | 246 |
Crsel | 247 |
Exsel | 248 |
EraseEof | 249 |
Play | 250 |
Zoom | 251 |
NoName | 252 |
Pa1 | 253 |
OemClear | 254 |
KeyCode | 65535 |
Shift | 65536 |
Control | 131072 |
Alt | 262144 |
See Also

Reference

SMath.Manager Namespace


InterruptCalculationException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.ManagerGeneralException
SMath.ManagerInterruptCalculationException

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class InterruptCalculationException : GeneralException
Public Class InterruptCalculationException
    Inherits GeneralException
public ref class InterruptCalculationException : public GeneralException
type InterruptCalculationException =
    class
        inherit GeneralException
    end

The InterruptCalculationException type exposes the following members.

Constructors
 | Name | Description
Public method | InterruptCalculationException | Initializes a new instance of the InterruptCalculationException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

SMath.Manager Namespace


InterruptCalculationException Constructor

Initializes a new instance of the InterruptCalculationException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InterruptCalculationException()
Public Sub New
public:
InterruptCalculationException()
new : unit -> InterruptCalculationException
See Also

Reference

InterruptCalculationException Class
SMath.Manager Namespace


InterruptCalculationException Properties

The InterruptCalculationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InterruptCalculationException Class
SMath.Manager Namespace


InterruptCalculationException Methods

The InterruptCalculationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InterruptCalculationException Class
SMath.Manager Namespace


InterruptCalculationException Fields

The InterruptCalculationException type exposes the following members.

Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

InterruptCalculationException Class
SMath.Manager Namespace


IPlugin Interface

Base Interface for SMath Studio Plug-ins.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPlugin : IDisposable
Public Interface IPlugin
    Inherits IDisposable
public interface class IPlugin : IDisposable
type IPlugin =
    interface
        interface IDisposable
    end

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize.
Top
See Also

Reference

SMath.Manager Namespace


IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Fires on plug-in initialize.
Top
See Also

Reference

IPlugin Interface
SMath.Manager Namespace


IPlugin.Initialize Method

IPluginInitialize Method

Fires on plug-in initialize.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void Initialize()
Sub Initialize
void Initialize()
abstract Initialize : unit -> unit
See Also

Reference

IPlugin Interface
SMath.Manager Namespace


IPluginHandleEvaluation Interface

Base Evaluation Interface for SMath Studio Plug-ins.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginHandleEvaluation : IPlugin,
    IDisposable
Public Interface IPluginHandleEvaluation
    Inherits IPlugin, IDisposable
public interface class IPluginHandleEvaluation : IPlugin,
    IDisposable
type IPluginHandleEvaluation =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginHandleEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Manager Namespace


IPluginHandleEvaluation Methods

The IPluginHandleEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginHandleEvaluation Interface
SMath.Manager Namespace


IPluginHandleEvaluation.GetTermsHandled Method

IPluginHandleEvaluationGetTermsHandled Method

List of available terms, that plug-in can evaluate.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
TermInfo[] GetTermsHandled(
    SessionProfile sessionProfile
)
Function GetTermsHandled (
    sessionProfile As SessionProfile
) As TermInfo()
array<TermInfo^>^ GetTermsHandled(
    SessionProfile^ sessionProfile
)
abstract GetTermsHandled :
        sessionProfile : SessionProfile -> TermInfo[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: TermInfo
See Also

Reference

IPluginHandleEvaluation Interface
SMath.Manager Namespace


IPluginToolboxGroups Interface

Base Toolbox Groups handler Interface for SMath Studio Plug-ins.Базовый интерфейс поддержки групп тулбоксов в виде дополнений для SMath Studio.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginToolboxGroups : IPlugin,
    IDisposable
Public Interface IPluginToolboxGroups
    Inherits IPlugin, IDisposable
public interface class IPluginToolboxGroups : IPlugin,
    IDisposable
type IPluginToolboxGroups =
    interface
        interface IPlugin
        interface IDisposable
    end

The IPluginToolboxGroups type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetToolboxGroups | Array of Toolbox Groups, handled by Plug-in.Массив групп тулбоксов, поддерживаемых дополнением.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Manager Namespace


IPluginToolboxGroups Methods

The IPluginToolboxGroups type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetToolboxGroups | Array of Toolbox Groups, handled by Plug-in.Массив групп тулбоксов, поддерживаемых дополнением.
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginToolboxGroups Interface
SMath.Manager Namespace


IPluginToolboxGroups.GetToolboxGroups Method

IPluginToolboxGroupsGetToolboxGroups Method

Array of Toolbox Groups, handled by Plug-in.Массив групп тулбоксов, поддерживаемых дополнением.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
ToolboxGroup[] GetToolboxGroups(
    SessionProfile sessionProfile
)
Function GetToolboxGroups (
    sessionProfile As SessionProfile
) As ToolboxGroup()
array<ToolboxGroup^>^ GetToolboxGroups(
    SessionProfile^ sessionProfile
)
abstract GetToolboxGroups :
        sessionProfile : SessionProfile -> ToolboxGroup[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: ToolboxGroup
See Also

Reference

IPluginToolboxGroups Interface
SMath.Manager Namespace


IPrimitive Interface

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPrimitive
Public Interface IPrimitive
public interface class IPrimitive
type IPrimitive =  interface end

The IPrimitive type exposes the following members.

Properties
Name Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property Text
Text value of the expression component.Текстовое значение компоненты выражения.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
Top
See Also

Reference

SMath.Manager Namespace


IPrimitive Properties

The IPrimitive type exposes the following members.

Properties
Name Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property Text
Text value of the expression component.Текстовое значение компоненты выражения.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
Top
See Also

Reference

IPrimitive Interface
SMath.Manager Namespace


IPrimitive.ArgsCount Property

IPrimitiveArgsCount Property

Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int ArgsCount { get; }
ReadOnly Property ArgsCount As Integer
    Get
property int ArgsCount {
    int get ();
}
abstract ArgsCount : int with get

Property Value

Type: Int32
See Also

Reference

IPrimitive Interface
SMath.Manager Namespace


IPrimitive.Text Property

IPrimitiveText Property

Text value of the expression component.Текстовое значение компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
string Text { get; }
ReadOnly Property Text As String
    Get
property String^ Text {
    String^ get ();
}
abstract Text : string with get

Property Value

Type: String
See Also

Reference

IPrimitive Interface
SMath.Manager Namespace


IPrimitive.Type Property

IPrimitiveType Property

Type of the expression component.Определение типа компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
TermType Type { get; }
ReadOnly Property Type As TermType
    Get
property TermType Type {
    TermType get ();
}
abstract Type : TermType with get

Property Value

Type: TermType
See Also

Reference

IPrimitive Interface
SMath.Manager Namespace


IPrimitive(T) Interface

IPrimitiveT Interface

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPrimitive<T> : IPrimitive
where T : IPrimitive

Public Interface IPrimitive(Of T As IPrimitive)
    Inherits IPrimitive
generic<typename T>
where T : IPrimitive
public interface class IPrimitive : IPrimitive
type IPrimitive<'T when 'T : IPrimitive> =
    interface
        interface IPrimitive
    end

Type Parameters

T

The IPrimitiveT type exposes the following members.

Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
(Inherited from IPrimitive.)
Public property | Items
Public property Text
Text value of the expression component.Текстовое значение компоненты выражения.
(Inherited from IPrimitive.)
Public property Type
Type of the expression component.Определение типа компоненты выражения.
(Inherited from IPrimitive.)
Top
Methods
 | Name | Description
Public method | ToRevertedList |
Public method | ToTermsList |
Top
See Also

Reference

SMath.Manager Namespace


IPrimitive(T) Properties

IPrimitiveT Properties

The IPrimitiveT generic type exposes the following members.

Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
(Inherited from IPrimitive.)
Public property | Items
Public property Text
Text value of the expression component.Текстовое значение компоненты выражения.
(Inherited from IPrimitive.)
Public property Type
Type of the expression component.Определение типа компоненты выражения.
(Inherited from IPrimitive.)
Top
See Also

Reference

IPrimitiveT Interface
SMath.Manager Namespace


IPrimitive(T).Items Property

IPrimitiveTItems Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
T[] Items { get; }
ReadOnly Property Items As T()
    Get
property array<T>^ Items {
    array<T>^ get ();
}
abstract Items : 'T[] with get

Property Value

Type: T
See Also

Reference

IPrimitiveT Interface
SMath.Manager Namespace


IPrimitive(T) Methods

IPrimitiveT Methods

The IPrimitiveT generic type exposes the following members.

Methods
 | Name | Description
Public method | ToRevertedList |
Public method | ToTermsList |
Top
See Also

Reference

IPrimitiveT Interface
SMath.Manager Namespace


IPrimitive(T).ToRevertedList Method

IPrimitiveTToRevertedList Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
List<T> ToRevertedList()
Function ToRevertedList As List(Of T)
List<T>^ ToRevertedList()
abstract ToRevertedList : unit -> List<'T>

Return Value

Type: ListT
See Also

Reference

IPrimitiveT Interface
SMath.Manager Namespace


IPrimitive(T).ToTermsList Method

IPrimitiveTToTermsList Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
List<Term> ToTermsList()
Function ToTermsList As List(Of Term)
List<Term^>^ ToTermsList()
abstract ToTermsList : unit -> List<Term>

Return Value

Type: ListTerm
See Also

Reference

IPrimitiveT Interface
SMath.Manager Namespace


KeyEventOptions Class

Inheritance Hierarchy
SystemObject
SMath.ManagerKeyEventOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class KeyEventOptions
Public Class KeyEventOptions
public ref class KeyEventOptions
type KeyEventOptions =  class end

The KeyEventOptions type exposes the following members.

Constructors
 | Name | Description
Public method | KeyEventOptions | Initializes a new instance of the KeyEventOptions class
Top
Properties
 | Name | Description
Public property | Alt |
Public property | Control |
Public property | Handled |
Public property | KeyCode |
Public property | KeyData |
Public property | KeyValue |
Public property | Shift |
Public property | SuppressKeyPress |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


KeyEventOptions Constructor

Initializes a new instance of the KeyEventOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public KeyEventOptions()
Public Sub New
public:
KeyEventOptions()
new : unit -> KeyEventOptions
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions Properties

The KeyEventOptions type exposes the following members.

Properties
 | Name | Description
Public property | Alt |
Public property | Control |
Public property | Handled |
Public property | KeyCode |
Public property | KeyData |
Public property | KeyValue |
Public property | Shift |
Public property | SuppressKeyPress |
Top
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.Alt Property

KeyEventOptionsAlt Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Alt { get; set; }
Public Property Alt As Boolean
    Get
    Set
public:
property bool Alt {
    bool get ();
    void set (bool value);
}
member Alt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.Control Property

KeyEventOptionsControl Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Control { get; set; }
Public Property Control As Boolean
    Get
    Set
public:
property bool Control {
    bool get ();
    void set (bool value);
}
member Control : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.Handled Property

KeyEventOptionsHandled Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.KeyCode Property

KeyEventOptionsKeyCode Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int KeyCode { get; set; }
Public Property KeyCode As Integer
    Get
    Set
public:
property int KeyCode {
    int get ();
    void set (int value);
}
member KeyCode : int with get, set

Property Value

Type: Int32
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.KeyData Property

KeyEventOptionsKeyData Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public InputKeys KeyData { get; set; }
Public Property KeyData As InputKeys
    Get
    Set
public:
property InputKeys KeyData {
    InputKeys get ();
    void set (InputKeys value);
}
member KeyData : InputKeys with get, set

Property Value

Type: InputKeys
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.KeyValue Property

KeyEventOptionsKeyValue Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int KeyValue { get; set; }
Public Property KeyValue As Integer
    Get
    Set
public:
property int KeyValue {
    int get ();
    void set (int value);
}
member KeyValue : int with get, set

Property Value

Type: Int32
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.Shift Property

KeyEventOptionsShift Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Shift { get; set; }
Public Property Shift As Boolean
    Get
    Set
public:
property bool Shift {
    bool get ();
    void set (bool value);
}
member Shift : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions.SuppressKeyPress Property

KeyEventOptionsSuppressKeyPress Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SuppressKeyPress { get; set; }
Public Property SuppressKeyPress As Boolean
    Get
    Set
public:
property bool SuppressKeyPress {
    bool get ();
    void set (bool value);
}
member SuppressKeyPress : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyEventOptions Methods

The KeyEventOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeyEventOptions Class
SMath.Manager Namespace


KeyPressEventOptions Class

Inheritance Hierarchy
SystemObject
SMath.ManagerKeyPressEventOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class KeyPressEventOptions
Public Class KeyPressEventOptions
public ref class KeyPressEventOptions
type KeyPressEventOptions =  class end

The KeyPressEventOptions type exposes the following members.

Constructors
 | Name | Description
Public method | KeyPressEventOptions | Initializes a new instance of the KeyPressEventOptions class
Top
Properties
 | Name | Description
Public property | Handled |
Public property | KeyChar |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


KeyPressEventOptions Constructor

Initializes a new instance of the KeyPressEventOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public KeyPressEventOptions()
Public Sub New
public:
KeyPressEventOptions()
new : unit -> KeyPressEventOptions
See Also

Reference

KeyPressEventOptions Class
SMath.Manager Namespace


KeyPressEventOptions Properties

The KeyPressEventOptions type exposes the following members.

Properties
 | Name | Description
Public property | Handled |
Public property | KeyChar |
Top
See Also

Reference

KeyPressEventOptions Class
SMath.Manager Namespace


KeyPressEventOptions.Handled Property

KeyPressEventOptionsHandled Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

KeyPressEventOptions Class
SMath.Manager Namespace


KeyPressEventOptions.KeyChar Property

KeyPressEventOptionsKeyChar Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public char KeyChar { get; set; }
Public Property KeyChar As Char
    Get
    Set
public:
property wchar_t KeyChar {
    wchar_t get ();
    void set (wchar_t value);
}
member KeyChar : char with get, set

Property Value

Type: Char
See Also

Reference

KeyPressEventOptions Class
SMath.Manager Namespace


KeyPressEventOptions Methods

The KeyPressEventOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KeyPressEventOptions Class
SMath.Manager Namespace


LanguageInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerLanguageInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class LanguageInfo : IComparable
Public Class LanguageInfo
    Implements IComparable
public ref class LanguageInfo : IComparable
type LanguageInfo =
    class
        interface IComparable
    end

The LanguageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageInfo | Initializes a new instance of the LanguageInfo class
Top
Properties
 | Name | Description
Public property | Abbr |
Public property | FileName |
Public property | Flag |
Public property | Guid |
Public property | IsLoaded |
Public property | Name |
Public property | NamingType |
Public property | StringsCustom |
Public property | StringsErrors |
Public property | StringsFunctionsDescription |
Public property | StringsGUI |
Public property | StringsMathBookContent |
Public property | StringsToolTip |
Public property | Translators |
Public property | Version |
Top
Methods
 | Name | Description
Public method | ActivateLanguage |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFullName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage | Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но если английские недоступен, то будет выбран первый же доступный язык.
 | GetShortName |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | LoadLanguage | Load language from stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Fields
Name | Description
DefaultDirectoryName |
DefaultLanguage |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

SMath.Manager Namespace


LanguageInfo Constructor

Initializes a new instance of the LanguageInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public LanguageInfo(
    string abbr,
    string name,
    IBitmap flag,
    string translators,
    string version,
    string fileName,
    Guid guid
)
Public Sub New (
    abbr As String,
    name As String,
    flag As IBitmap,
    translators As String,
    version As String,
    fileName As String,
    guid As Guid
)
public:
LanguageInfo(
    String^ abbr,
    String^ name,
    IBitmap^ flag,
    String^ translators,
    String^ version,
    String^ fileName,
    Guid guid
)
new :
        abbr : string *
        name : string *
        flag : IBitmap *
        translators : string *
        version : string *
        fileName : string *
        guid : Guid -> LanguageInfo

Parameters

abbr
Type: SystemString
name
Type: SystemString
flag
Type: SMath.DrawingIBitmap
translators
Type: SystemString
version
Type: SystemString
fileName
Type: SystemString
guid
Type: SystemGuid
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo Properties

The LanguageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Abbr |
Public property | FileName |
Public property | Flag |
Public property | Guid |
Public property | IsLoaded |
Public property | Name |
Public property | NamingType |
Public property | StringsCustom |
Public property | StringsErrors |
Public property | StringsFunctionsDescription |
Public property | StringsGUI |
Public property | StringsMathBookContent |
Public property | StringsToolTip |
Public property | Translators |
Public property | Version |
Top
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Abbr Property

LanguageInfoAbbr Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Abbr { get; set; }
Public Property Abbr As String
    Get
    Set
public:
property String^ Abbr {
    String^ get ();
    void set (String^ value);
}
member Abbr : string with get, set

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.FileName Property

LanguageInfoFileName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Flag Property

LanguageInfoFlag Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap Flag { get; set; }
Public Property Flag As IBitmap
    Get
    Set
public:
property IBitmap^ Flag {
    IBitmap^ get ();
    void set (IBitmap^ value);
}
member Flag : IBitmap with get, set

Property Value

Type: IBitmap
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Guid Property

LanguageInfoGuid Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.IsLoaded Property

LanguageInfoIsLoaded Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsLoaded { get; }
Public ReadOnly Property IsLoaded As Boolean
    Get
public:
property bool IsLoaded {
    bool get ();
}
member IsLoaded : bool with get

Property Value

Type: Boolean
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Name Property

LanguageInfoName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.NamingType Property

LanguageInfoNamingType Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid NamingType { get; set; }
Public Property NamingType As Guid
    Get
    Set
public:
property Guid NamingType {
    Guid get ();
    void set (Guid value);
}
member NamingType : Guid with get, set

Property Value

Type: Guid
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsCustom Property

LanguageInfoStringsCustom Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> StringsCustom { get; }
Public ReadOnly Property StringsCustom As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ StringsCustom {
    Dictionary<String^, String^>^ get ();
}
member StringsCustom : Dictionary<string, string> with get

Property Value

Type: DictionaryString, String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsErrors Property

LanguageInfoStringsErrors Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] StringsErrors { get; }
Public ReadOnly Property StringsErrors As String()
    Get
public:
property array<String^>^ StringsErrors {
    array<String^>^ get ();
}
member StringsErrors : string[] with get

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsFunctionsDescription Property

LanguageInfoStringsFunctionsDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] StringsFunctionsDescription { get; }
Public ReadOnly Property StringsFunctionsDescription As String()
    Get
public:
property array<String^>^ StringsFunctionsDescription {
    array<String^>^ get ();
}
member StringsFunctionsDescription : string[] with get

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsGUI Property

LanguageInfoStringsGUI Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] StringsGUI { get; }
Public ReadOnly Property StringsGUI As String()
    Get
public:
property array<String^>^ StringsGUI {
    array<String^>^ get ();
}
member StringsGUI : string[] with get

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsMathBookContent Property

LanguageInfoStringsMathBookContent Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] StringsMathBookContent { get; }
Public ReadOnly Property StringsMathBookContent As String()
    Get
public:
property array<String^>^ StringsMathBookContent {
    array<String^>^ get ();
}
member StringsMathBookContent : string[] with get

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.StringsToolTip Property

LanguageInfoStringsToolTip Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] StringsToolTip { get; }
Public ReadOnly Property StringsToolTip As String()
    Get
public:
property array<String^>^ StringsToolTip {
    array<String^>^ get ();
}
member StringsToolTip : string[] with get

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Translators Property

LanguageInfoTranslators Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Translators { get; set; }
Public Property Translators As String
    Get
    Set
public:
property String^ Translators {
    String^ get ();
    void set (String^ value);
}
member Translators : string with get, set

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.Version Property

LanguageInfoVersion Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo Methods

The LanguageInfo type exposes the following members.

Methods
 | Name | Description
Public method | ActivateLanguage |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFullName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLanguage | Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но если английские недоступен, то будет выбран первый же доступный язык.
 | GetShortName |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | LoadLanguage | Load language from stream.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.IComparable.CompareTo Method

LanguageInfoIComparableCompareTo Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int IComparable.CompareTo(
    Object obj
)
Private Function CompareTo (
    obj As Object
) As Integer Implements IComparable.CompareTo
private:
virtual int CompareTo(
    Object^ obj
) sealed = IComparable::CompareTo
private abstract CompareTo :
        obj : Object -> int
private override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.ActivateLanguage Method

LanguageInfoActivateLanguage Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ActivateLanguage(
    SessionsManager manager
)
Public Sub ActivateLanguage (
    manager As SessionsManager
)
public:
void ActivateLanguage(
    SessionsManager^ manager
)
member ActivateLanguage :
        manager : SessionsManager -> unit

Parameters

manager
Type: SMath.ManagerSessionsManager
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.GetFullName Method

LanguageInfoGetFullName Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetFullName(
    string shortName
)
Public Shared Function GetFullName (
    shortName As String
) As String
public:
static String^ GetFullName(
    String^ shortName
)
static member GetFullName :
        shortName : string -> string

Parameters

shortName
Type: SystemString

Return Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.GetLanguage Method

LanguageInfoGetLanguage Method

Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но если английские недоступен, то будет выбран первый же доступный язык.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static LanguageInfo GetLanguage(
    string value
)
Public Shared Function GetLanguage (
    value As String
) As LanguageInfo
public:
static LanguageInfo^ GetLanguage(
    String^ value
)
static member GetLanguage :
        value : string -> LanguageInfo

Parameters

value
Type: SystemString
Трёхбуквенное обозначение языка по стандарту ISO 639-2.

Return Value

Type: LanguageInfo
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.GetShortName Method

LanguageInfoGetShortName Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetShortName(
    string fullName
)
Public Shared Function GetShortName (
    fullName As String
) As String
public:
static String^ GetShortName(
    String^ fullName
)
static member GetShortName :
        fullName : string -> string

Parameters

fullName
Type: SystemString

Return Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.LoadLanguage Method

LanguageInfoLoadLanguage Method

Load language from stream.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static LanguageInfo LoadLanguage(
    Stream stream,
    string fileName,
    bool fullLoad,
    out Guid NamingType
)
Public Shared Function LoadLanguage (
    stream As Stream,
    fileName As String,
    fullLoad As Boolean,
    <OutAttribute> ByRef NamingType As Guid
) As LanguageInfo
public:
static LanguageInfo^ LoadLanguage(
    Stream^ stream,
    String^ fileName,
    bool fullLoad,
    [OutAttribute] Guid% NamingType
)
static member LoadLanguage :
        stream : Stream *
        fileName : string *
        fullLoad : bool *
        NamingType : Guid byref -> LanguageInfo

Parameters

stream
Type: System.IOStream
Stream of the file containing language settings.
fileName
Type: SystemString
Path to the file on local drive (if available).
fullLoad
Type: SystemBoolean
Determines whether language should be loaded as a current language or not.
NamingType
Type: SystemGuid

Return Value

Type: LanguageInfo
Full description of loaded language.
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.ToString Method

LanguageInfoToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo Fields

The LanguageInfo type exposes the following members.

Fields
Name | Description
DefaultDirectoryName |
DefaultLanguage |
Top
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.DefaultDirectoryName Field

LanguageInfoDefaultDirectoryName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DefaultDirectoryName = "lang"
Public Const DefaultDirectoryName As String = "lang"
public:
literal String^ DefaultDirectoryName = "lang"
static val mutable DefaultDirectoryName: string

Field Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


LanguageInfo.DefaultLanguage Field

LanguageInfoDefaultLanguage Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DefaultLanguage = "ENG"
Public Const DefaultLanguage As String = "ENG"
public:
literal String^ DefaultLanguage = "ENG"
static val mutable DefaultLanguage: string

Field Value

Type: String
See Also

Reference

LanguageInfo Class
SMath.Manager Namespace


MathException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.ManagerGeneralException
SMath.ManagerMathException
SMath.ManagerEmptyPlaceholderException
SMath.ManagerNotDefinedException

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MathException : GeneralException
Public Class MathException
    Inherits GeneralException
public ref class MathException : public GeneralException
type MathException =
    class
        inherit GeneralException
    end

The MathException type exposes the following members.

Constructors
 | Name | Description
Public method | MathException(Errors) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, IPrimitive) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, Term) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, IPrimitive, ListIPrimitive) | Constructor of the Class.Конструктор класса.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.
Public property | EvaluationStack |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

SMath.Manager Namespace


MathException Constructor

Overload List
 | Name | Description
Public method | MathException(Errors) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, IPrimitive) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, Term) | Constructor of the Class.Конструктор класса.
Public method | MathException(Errors, IPrimitive, ListIPrimitive) | Constructor of the Class.Конструктор класса.
Top
See Also

Reference

MathException Class
SMath.Manager Namespace


MathException Constructor (Errors)

Constructor of the Class.Конструктор класса.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MathException(
    Errors errorId
)
Public Sub New (
    errorId As Errors
)
public:
MathException(
    Errors errorId
)
new :
        errorId : Errors -> MathException

Parameters

errorId
Type: SMath.ManagerErrors
Id of the error occurred.Идентификатор произошедшей ошибки.
See Also

Reference

MathException Class
MathException Overload
SMath.Manager Namespace


MathException Constructor (Errors, IPrimitive)

Constructor of the Class.Конструктор класса.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MathException(
    Errors errorId,
    IPrimitive element
)
Public Sub New (
    errorId As Errors,
    element As IPrimitive
)
public:
MathException(
    Errors errorId,
    IPrimitive^ element
)
new :
        errorId : Errors *
        element : IPrimitive -> MathException

Parameters

errorId
Type: SMath.ManagerErrors
Id of the error occurred.Идентификатор произошедшей ошибки.
element
Type: SMath.ManagerIPrimitive
Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.
See Also

Reference

MathException Class
MathException Overload
SMath.Manager Namespace


MathException Constructor (Errors, Term)

Constructor of the Class.Конструктор класса.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MathException(
    Errors errorId,
    Term element
)
Public Sub New (
    errorId As Errors,
    element As Term
)
public:
MathException(
    Errors errorId,
    Term^ element
)
new :
        errorId : Errors *
        element : Term -> MathException

Parameters

errorId
Type: SMath.ManagerErrors
Id of the error occurred.Идентификатор произошедшей ошибки.
element
Type: SMath.ManagerTerm
Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.
See Also

Reference

MathException Class
MathException Overload
SMath.Manager Namespace


MathException Constructor (Errors, IPrimitive, List(IPrimitive))

MathException Constructor (Errors, IPrimitive, ListIPrimitive)

Constructor of the Class.Конструктор класса.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MathException(
    Errors errorId,
    IPrimitive element,
    List<IPrimitive> evaluationStack
)
Public Sub New (
    errorId As Errors,
    element As IPrimitive,
    evaluationStack As List(Of IPrimitive)
)
public:
MathException(
    Errors errorId,
    IPrimitive^ element,
    List<IPrimitive^>^ evaluationStack
)
new :
        errorId : Errors *
        element : IPrimitive *
        evaluationStack : List<IPrimitive> -> MathException

Parameters

errorId
Type: SMath.ManagerErrors
Id of the error occurred.Идентификатор произошедшей ошибки.
element
Type: SMath.ManagerIPrimitive
Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.
evaluationStack
Type: System.Collections.GenericListIPrimitive
See Also

Reference

MathException Class
MathException Overload
SMath.Manager Namespace


MathException Properties

The MathException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.
Public property | EvaluationStack |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

MathException Class
SMath.Manager Namespace


MathException.Element Property

MathExceptionElement Property

Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IPrimitive Element { get; }
Public ReadOnly Property Element As IPrimitive
    Get
public:
property IPrimitive^ Element {
    IPrimitive^ get ();
}
member Element : IPrimitive with get

Property Value

Type: IPrimitive
See Also

Reference

MathException Class
SMath.Manager Namespace


MathException.EvaluationStack Property

MathExceptionEvaluationStack Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<IPrimitive> EvaluationStack { get; }
Public ReadOnly Property EvaluationStack As List(Of IPrimitive)
    Get
public:
property List<IPrimitive^>^ EvaluationStack {
    List<IPrimitive^>^ get ();
}
member EvaluationStack : List<IPrimitive> with get

Property Value

Type: ListIPrimitive
See Also

Reference

MathException Class
SMath.Manager Namespace


MathException Methods

The MathException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

MathException Class
SMath.Manager Namespace


MathException Fields

The MathException type exposes the following members.

Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

MathException Class
SMath.Manager Namespace


MathMethods Class

Auxiliary mathematical methods.Вспомогательные математические методы.
Inheritance Hierarchy
SystemObject
SMath.ManagerMathMethods

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MathMethods
Public Class MathMethods
public ref class MathMethods
type MathMethods =  class end

The MathMethods type exposes the following members.

Constructors
 | Name | Description
Public method | MathMethods | Initializes a new instance of the MathMethods class
Top
Methods
 | Name | Description
 | DoubleToFraction(Double, Double, Double) |
 | DoubleToFraction(Double, Int32, Double, Double) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FractionReduction | Сокращение дроби.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IntToFileSize | Converts a file size to a string.Конвертация размера файла в строку.
 | IsNumber(String) | Check if a string can be converted into a number.Проверка строки на возможность конвертирования в число.
 | IsNumber(SessionProfile, String) |
 | IsParam | Check if a symbol is part of a parameter name.Проверка символа, является ли он элементом имени параметра или нет.
 | IsTextOrNumber(String) |
 | IsTextOrNumber(IPrimitive) |
 | LongNumber(Double) | Converts double to a long string.
 | LongNumber(Single) | Converts float to a long string.
 | LongNumber(String) | Converts a string representation of a number to a double.
 | LongNumber15 | Converts double to a long string.
 | LongNumberSystem(Double) | Converts double to a long string. Throws exception when infinity detected.
 | LongNumberSystem(Single) | Converts float to a long string. Throws exception when infinity detected.
 | LongNumberSystem15 | Converts double to a long string. Throws exception when infinity detected.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseString | Converts a LongNumber to a double.
 | Priority(String) | Determines the priority of mathematical primitives.Определение приоритета математического примитива.
 | Priority(String, Char) |
 | SetSystemSeparator |
 | SetUserSeparator |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DoubleFixedPoint |
DoubleFixedPoint15 |
Top
See Also

Reference

SMath.Manager Namespace


MathMethods Constructor

Initializes a new instance of the MathMethods class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MathMethods()
Public Sub New
public:
MathMethods()
new : unit -> MathMethods
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods Methods

The MathMethods type exposes the following members.

Methods
 | Name | Description
 | DoubleToFraction(Double, Double, Double) |
 | DoubleToFraction(Double, Int32, Double, Double) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FractionReduction | Сокращение дроби.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IntToFileSize | Converts a file size to a string.Конвертация размера файла в строку.
 | IsNumber(String) | Check if a string can be converted into a number.Проверка строки на возможность конвертирования в число.
 | IsNumber(SessionProfile, String) |
 | IsParam | Check if a symbol is part of a parameter name.Проверка символа, является ли он элементом имени параметра или нет.
 | IsTextOrNumber(String) |
 | IsTextOrNumber(IPrimitive) |
 | LongNumber(Double) | Converts double to a long string.
 | LongNumber(Single) | Converts float to a long string.
 | LongNumber(String) | Converts a string representation of a number to a double.
 | LongNumber15 | Converts double to a long string.
 | LongNumberSystem(Double) | Converts double to a long string. Throws exception when infinity detected.
 | LongNumberSystem(Single) | Converts float to a long string. Throws exception when infinity detected.
 | LongNumberSystem15 | Converts double to a long string. Throws exception when infinity detected.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseString | Converts a LongNumber to a double.
 | Priority(String) | Determines the priority of mathematical primitives.Определение приоритета математического примитива.
 | Priority(String, Char) |
 | SetSystemSeparator |
 | SetUserSeparator |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.DoubleToFraction Method

MathMethodsDoubleToFraction Method

Overload List
Name | Description
DoubleToFraction(Double, Double, Double) |
DoubleToFraction(Double, Int32, Double, Double) |
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.DoubleToFraction Method (Double, Double, Double)

MathMethodsDoubleToFraction Method (Double, Double, Double)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DoubleToFraction(
    double value,
    out double num,
    out double den
)
Public Shared Sub DoubleToFraction (
    value As Double,
    <OutAttribute> ByRef num As Double,
    <OutAttribute> ByRef den As Double
)
public:
static void DoubleToFraction(
    double value,
    [OutAttribute] double% num,
    [OutAttribute] double% den
)
static member DoubleToFraction :
        value : float *
        num : float byref *
        den : float byref -> unit

Parameters

value
Type: SystemDouble
num
Type: SystemDouble
den
Type: SystemDouble
See Also

Reference

MathMethods Class
DoubleToFraction Overload
SMath.Manager Namespace


MathMethods.DoubleToFraction Method (Double, Int32, Double, Double)

MathMethodsDoubleToFraction Method (Double, Int32, Double, Double)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DoubleToFraction(
    double value,
    int round,
    out double num,
    out double den
)
Public Shared Sub DoubleToFraction (
    value As Double,
    round As Integer,
    <OutAttribute> ByRef num As Double,
    <OutAttribute> ByRef den As Double
)
public:
static void DoubleToFraction(
    double value,
    int round,
    [OutAttribute] double% num,
    [OutAttribute] double% den
)
static member DoubleToFraction :
        value : float *
        round : int *
        num : float byref *
        den : float byref -> unit

Parameters

value
Type: SystemDouble
round
Type: SystemInt32
num
Type: SystemDouble
den
Type: SystemDouble
See Also

Reference

MathMethods Class
DoubleToFraction Overload
SMath.Manager Namespace


MathMethods.FractionReduction Method

MathMethodsFractionReduction Method

Сокращение дроби.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void FractionReduction(
    ref double num,
    ref double den
)
Public Shared Sub FractionReduction (
    ByRef num As Double,
    ByRef den As Double
)
public:
static void FractionReduction(
    double% num,
    double% den
)
static member FractionReduction :
        num : float byref *
        den : float byref -> unit

Parameters

num
Type: SystemDouble
Числитель.
den
Type: SystemDouble
Знаменатель.
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.IntToFileSize Method

MathMethodsIntToFileSize Method

Converts a file size to a string.Конвертация размера файла в строку.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string IntToFileSize(
    double s
)
Public Shared Function IntToFileSize (
    s As Double
) As String
public:
static String^ IntToFileSize(
    double s
)
static member IntToFileSize :
        s : float -> string

Parameters

s
Type: SystemDouble
File size.Размер файла.

Return Value

Type: String
Human readable file size.Строковый вид записи размера файла.
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.IsNumber Method

MathMethodsIsNumber Method

Overload List
Name | Description
IsNumber(String) | Check if a string can be converted into a number.Проверка строки на возможность конвертирования в число.
IsNumber(SessionProfile, String) |
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.IsNumber Method (String)

MathMethodsIsNumber Method (String)

Check if a string can be converted into a number.Проверка строки на возможность конвертирования в число.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumber(
    string value
)
Public Shared Function IsNumber (
    value As String
) As Boolean
public:
static bool IsNumber(
    String^ value
)
static member IsNumber :
        value : string -> bool

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

MathMethods Class
IsNumber Overload
SMath.Manager Namespace


MathMethods.IsNumber Method (SessionProfile, String)

MathMethodsIsNumber Method (SessionProfile, String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumber(
    SessionProfile sessionProfile,
    string value
)
Public Shared Function IsNumber (
    sessionProfile As SessionProfile,
    value As String
) As Boolean
public:
static bool IsNumber(
    SessionProfile^ sessionProfile,
    String^ value
)
static member IsNumber :
        sessionProfile : SessionProfile *
        value : string -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

MathMethods Class
IsNumber Overload
SMath.Manager Namespace


MathMethods.IsParam Method

MathMethodsIsParam Method

Check if a symbol is part of a parameter name.Проверка символа, является ли он элементом имени параметра или нет.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsParam(
    ref char value
)
Public Shared Function IsParam (
    ByRef value As Char
) As Boolean
public:
static bool IsParam(
    wchar_t% value
)
static member IsParam :
        value : char byref -> bool

Parameters

value
Type: SystemChar
Symbol to verify.Символ для проверки.

Return Value

Type: Boolean
The result of the test.Результат проверки символа.
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.IsTextOrNumber Method

MathMethodsIsTextOrNumber Method

Overload List
Name | Description
IsTextOrNumber(String) |
IsTextOrNumber(IPrimitive) |
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.IsTextOrNumber Method (String)

MathMethodsIsTextOrNumber Method (String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsTextOrNumber(
    string value
)
Public Shared Function IsTextOrNumber (
    value As String
) As Boolean
public:
static bool IsTextOrNumber(
    String^ value
)
static member IsTextOrNumber :
        value : string -> bool

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

MathMethods Class
IsTextOrNumber Overload
SMath.Manager Namespace


MathMethods.IsTextOrNumber Method (IPrimitive)

MathMethodsIsTextOrNumber Method (IPrimitive)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsTextOrNumber(
    IPrimitive value
)
Public Shared Function IsTextOrNumber (
    value As IPrimitive
) As Boolean
public:
static bool IsTextOrNumber(
    IPrimitive^ value
)
static member IsTextOrNumber :
        value : IPrimitive -> bool

Parameters

value
Type: SMath.ManagerIPrimitive

Return Value

Type: Boolean
See Also

Reference

MathMethods Class
IsTextOrNumber Overload
SMath.Manager Namespace


MathMethods.LongNumber Method

MathMethodsLongNumber Method

Overload List
Name | Description
LongNumber(Double) | Converts double to a long string.
LongNumber(Single) | Converts float to a long string.
LongNumber(String) | Converts a string representation of a number to a double.
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.LongNumber Method (Double)

MathMethodsLongNumber Method (Double)

Converts double to a long string.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumber(
    double value
)
Public Shared Function LongNumber (
    value As Double
) As String
public:
static String^ LongNumber(
    double value
)
static member LongNumber :
        value : float -> string

Parameters

value
Type: SystemDouble
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
LongNumber Overload
SMath.Manager Namespace


MathMethods.LongNumber Method (Single)

MathMethodsLongNumber Method (Single)

Converts float to a long string.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumber(
    float value
)
Public Shared Function LongNumber (
    value As Single
) As String
public:
static String^ LongNumber(
    float value
)
static member LongNumber :
        value : float32 -> string

Parameters

value
Type: SystemSingle
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
LongNumber Overload
SMath.Manager Namespace


MathMethods.LongNumber Method (String)

MathMethodsLongNumber Method (String)

Converts a string representation of a number to a double.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumber(
    string D
)
Public Shared Function LongNumber (
    D As String
) As String
public:
static String^ LongNumber(
    String^ D
)
static member LongNumber :
        D : string -> string

Parameters

D
Type: SystemString

Return Value

Type: String
See Also

Reference

MathMethods Class
LongNumber Overload
SMath.Manager Namespace


MathMethods.LongNumber15 Method

MathMethodsLongNumber15 Method

Converts double to a long string.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumber15(
    double value
)
Public Shared Function LongNumber15 (
    value As Double
) As String
public:
static String^ LongNumber15(
    double value
)
static member LongNumber15 :
        value : float -> string

Parameters

value
Type: SystemDouble
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.LongNumberSystem Method

MathMethodsLongNumberSystem Method

Overload List
Name | Description
LongNumberSystem(Double) | Converts double to a long string. Throws exception when infinity detected.
LongNumberSystem(Single) | Converts float to a long string. Throws exception when infinity detected.
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.LongNumberSystem Method (Double)

MathMethodsLongNumberSystem Method (Double)

Converts double to a long string. Throws exception when infinity detected.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumberSystem(
    double value
)
Public Shared Function LongNumberSystem (
    value As Double
) As String
public:
static String^ LongNumberSystem(
    double value
)
static member LongNumberSystem :
        value : float -> string

Parameters

value
Type: SystemDouble
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
LongNumberSystem Overload
SMath.Manager Namespace


MathMethods.LongNumberSystem Method (Single)

MathMethodsLongNumberSystem Method (Single)

Converts float to a long string. Throws exception when infinity detected.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumberSystem(
    float value
)
Public Shared Function LongNumberSystem (
    value As Single
) As String
public:
static String^ LongNumberSystem(
    float value
)
static member LongNumberSystem :
        value : float32 -> string

Parameters

value
Type: SystemSingle
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
LongNumberSystem Overload
SMath.Manager Namespace


MathMethods.LongNumberSystem15 Method

MathMethodsLongNumberSystem15 Method

Converts double to a long string. Throws exception when infinity detected.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string LongNumberSystem15(
    double value
)
Public Shared Function LongNumberSystem15 (
    value As Double
) As String
public:
static String^ LongNumberSystem15(
    double value
)
static member LongNumberSystem15 :
        value : float -> string

Parameters

value
Type: SystemDouble
Value to convert.

Return Value

Type: String
String representation of the given number.
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.ParseString Method

MathMethodsParseString Method

Converts a LongNumber to a double.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static double ParseString(
    string text
)
Public Shared Function ParseString (
    text As String
) As Double
public:
static double ParseString(
    String^ text
)
static member ParseString :
        text : string -> float

Parameters

text
Type: SystemString

Return Value

Type: Double
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.Priority Method

MathMethodsPriority Method

Overload List
Name | Description
Priority(String) | Determines the priority of mathematical primitives.Определение приоритета математического примитива.
Priority(String, Char) |
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.Priority Method (String)

MathMethodsPriority Method (String)

Determines the priority of mathematical primitives.Определение приоритета математического примитива.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int Priority(
    string value
)
Public Shared Function Priority (
    value As String
) As Integer
public:
static int Priority(
    String^ value
)
static member Priority :
        value : string -> int

Parameters

value
Type: SystemString
Text representation of the primitive.Текстовое представление примитива.

Return Value

Type: Int32
Primitive's mathematical priority.Приоритет математического примитива.
See Also

Reference

MathMethods Class
Priority Overload
SMath.Manager Namespace


MathMethods.Priority Method (String, Char)

MathMethodsPriority Method (String, Char)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static int Priority(
    string value,
    char argSeparator
)
Public Shared Function Priority (
    value As String,
    argSeparator As Char
) As Integer
public:
static int Priority(
    String^ value,
    wchar_t argSeparator
)
static member Priority :
        value : string *
        argSeparator : char -> int

Parameters

value
Type: SystemString
argSeparator
Type: SystemChar

Return Value

Type: Int32
See Also

Reference

MathMethods Class
Priority Overload
SMath.Manager Namespace


MathMethods.SetSystemSeparator Method

MathMethodsSetSystemSeparator Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SetSystemSeparator(
    string value
)
Public Shared Function SetSystemSeparator (
    value As String
) As String
public:
static String^ SetSystemSeparator(
    String^ value
)
static member SetSystemSeparator :
        value : string -> string

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.SetUserSeparator Method

MathMethodsSetUserSeparator Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SetUserSeparator(
    string value
)
Public Shared Function SetUserSeparator (
    value As String
) As String
public:
static String^ SetUserSeparator(
    String^ value
)
static member SetUserSeparator :
        value : string -> string

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods Fields

The MathMethods type exposes the following members.

Fields
Name | Description
DoubleFixedPoint |
DoubleFixedPoint15 |
Top
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.DoubleFixedPoint Field

MathMethodsDoubleFixedPoint Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DoubleFixedPoint = "0.###################################################################################################################################################################################################################################################################################################################################################"
Public Const DoubleFixedPoint As String = "0.###################################################################################################################################################################################################################################################################################################################################################"
public:
literal String^ DoubleFixedPoint = "0.###################################################################################################################################################################################################################################################################################################################################################"
static val mutable DoubleFixedPoint: string

Field Value

Type: String
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MathMethods.DoubleFixedPoint15 Field

MathMethodsDoubleFixedPoint15 Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DoubleFixedPoint15 = "0.###############"
Public Const DoubleFixedPoint15 As String = "0.###############"
public:
literal String^ DoubleFixedPoint15 = "0.###############"
static val mutable DoubleFixedPoint15: string

Field Value

Type: String
See Also

Reference

MathMethods Class
SMath.Manager Namespace


MetaContext Class

Inheritance Hierarchy
SystemObject
SMath.ManagerMetaContext

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MetaContext
Public Class MetaContext
public ref class MetaContext
type MetaContext =  class end

The MetaContext type exposes the following members.

Constructors
 | Name | Description
Public method | MetaContext | Initializes a new instance of the MetaContext class
Top
Properties
 | Name | Description
Public property | DocParams |
Public property | MetaData |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


MetaContext Constructor

Initializes a new instance of the MetaContext class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MetaContext(
    DocumentParams docParams,
    DocumentMetaData metaData
)
Public Sub New (
    docParams As DocumentParams,
    metaData As DocumentMetaData
)
public:
MetaContext(
    DocumentParams^ docParams,
    DocumentMetaData^ metaData
)
new :
        docParams : DocumentParams *
        metaData : DocumentMetaData -> MetaContext

Parameters

docParams
Type: SMath.ManagerDocumentParams
metaData
Type: SMath.ManagerDocumentMetaData
See Also

Reference

MetaContext Class
SMath.Manager Namespace


MetaContext Properties

The MetaContext type exposes the following members.

Properties
 | Name | Description
Public property | DocParams |
Public property | MetaData |
Top
See Also

Reference

MetaContext Class
SMath.Manager Namespace


MetaContext.DocParams Property

MetaContextDocParams Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentParams DocParams { get; }
Public ReadOnly Property DocParams As DocumentParams
    Get
public:
property DocumentParams^ DocParams {
    DocumentParams^ get ();
}
member DocParams : DocumentParams with get

Property Value

Type: DocumentParams
See Also

Reference

MetaContext Class
SMath.Manager Namespace


MetaContext.MetaData Property

MetaContextMetaData Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DocumentMetaData MetaData { get; }
Public ReadOnly Property MetaData As DocumentMetaData
    Get
public:
property DocumentMetaData^ MetaData {
    DocumentMetaData^ get ();
}
member MetaData : DocumentMetaData with get

Property Value

Type: DocumentMetaData
See Also

Reference

MetaContext Class
SMath.Manager Namespace


MetaContext Methods

The MetaContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MetaContext Class
SMath.Manager Namespace


MouseEventOptions Class

Inheritance Hierarchy
SystemObject
SMath.ManagerMouseEventOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class MouseEventOptions
Public Class MouseEventOptions
public ref class MouseEventOptions
type MouseEventOptions =  class end

The MouseEventOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MouseEventOptions | Initializes a new instance of the MouseEventOptions class
Top
Properties
 | Name | Description
Public property | Button |
Public property | Clicks |
Public property | Delta |
Public property | Location |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


MouseEventOptions Constructor

Initializes a new instance of the MouseEventOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MouseEventOptions(
    MouseInputButtons Button,
    int Clicks,
    float X,
    float Y,
    int Delta
)
Public Sub New (
    Button As MouseInputButtons,
    Clicks As Integer,
    X As Single,
    Y As Single,
    Delta As Integer
)
public:
MouseEventOptions(
    MouseInputButtons Button,
    int Clicks,
    float X,
    float Y,
    int Delta
)
new :
        Button : MouseInputButtons *
        Clicks : int *
        X : float32 *
        Y : float32 *
        Delta : int -> MouseEventOptions

Parameters

Button
Type: SMath.ManagerMouseInputButtons
Clicks
Type: SystemInt32
X
Type: SystemSingle
Y
Type: SystemSingle
Delta
Type: SystemInt32
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions Properties

The MouseEventOptions type exposes the following members.

Properties
 | Name | Description
Public property | Button |
Public property | Clicks |
Public property | Delta |
Public property | Location |
Public property | X |
Public property | Y |
Top
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.Button Property

MouseEventOptionsButton Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MouseInputButtons Button { get; set; }
Public Property Button As MouseInputButtons
    Get
    Set
public:
property MouseInputButtons Button {
    MouseInputButtons get ();
    void set (MouseInputButtons value);
}
member Button : MouseInputButtons with get, set

Property Value

Type: MouseInputButtons
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.Clicks Property

MouseEventOptionsClicks Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Clicks { get; set; }
Public Property Clicks As Integer
    Get
    Set
public:
property int Clicks {
    int get ();
    void set (int value);
}
member Clicks : int with get, set

Property Value

Type: Int32
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.Delta Property

MouseEventOptionsDelta Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Delta { get; set; }
Public Property Delta As Integer
    Get
    Set
public:
property int Delta {
    int get ();
    void set (int value);
}
member Delta : int with get, set

Property Value

Type: Int32
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.Location Property

MouseEventOptionsLocation Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PointF Location { get; }
Public ReadOnly Property Location As PointF
    Get
public:
property PointF Location {
    PointF get ();
}
member Location : PointF with get

Property Value

Type: PointF
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.X Property

MouseEventOptionsX Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float X { get; set; }
Public Property X As Single
    Get
    Set
public:
property float X {
    float get ();
    void set (float value);
}
member X : float32 with get, set

Property Value

Type: Single
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions.Y Property

MouseEventOptionsY Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
public:
property float Y {
    float get ();
    void set (float value);
}
member Y : float32 with get, set

Property Value

Type: Single
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseEventOptions Methods

The MouseEventOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MouseEventOptions Class
SMath.Manager Namespace


MouseInputButtons Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum MouseInputButtons
Public Enumeration MouseInputButtons
public enum class MouseInputButtons
type MouseInputButtons
Members
Member name | Value | Description
None | 0 |
Left | 1048576 |
Right | 2097152 |
Middle | 4194304 |
XButton1 | 8388608 |
XButton2 | 16777216 |
See Also

Reference

SMath.Manager Namespace


NotDefinedException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.ManagerGeneralException
SMath.ManagerMathException
SMath.ManagerNotDefinedException

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class NotDefinedException : MathException
Public Class NotDefinedException
    Inherits MathException
public ref class NotDefinedException : public MathException
type NotDefinedException =
    class
        inherit MathException
    end

The NotDefinedException type exposes the following members.

Constructors
 | Name | Description
Public method | NotDefinedException(IPrimitive) | Initializes a new instance of the NotDefinedException class
Public method | NotDefinedException(IPrimitive, ListIPrimitive) | Initializes a new instance of the NotDefinedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение. (Inherited from MathException.)
Public property | EvaluationStack | (Inherited from MathException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

SMath.Manager Namespace


NotDefinedException Constructor

Overload List
 | Name | Description
Public method | NotDefinedException(IPrimitive) | Initializes a new instance of the NotDefinedException class
Public method | NotDefinedException(IPrimitive, ListIPrimitive) | Initializes a new instance of the NotDefinedException class
Top
See Also

Reference

NotDefinedException Class
SMath.Manager Namespace


NotDefinedException Constructor (IPrimitive)

Initializes a new instance of the NotDefinedException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public NotDefinedException(
    IPrimitive element
)
Public Sub New (
    element As IPrimitive
)
public:
NotDefinedException(
    IPrimitive^ element
)
new :
        element : IPrimitive -> NotDefinedException

Parameters

element
Type: SMath.ManagerIPrimitive
See Also

Reference

NotDefinedException Class
NotDefinedException Overload
SMath.Manager Namespace


NotDefinedException Constructor (IPrimitive, List(IPrimitive))

NotDefinedException Constructor (IPrimitive, ListIPrimitive)

Initializes a new instance of the NotDefinedException class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public NotDefinedException(
    IPrimitive element,
    List<IPrimitive> evaluationStack
)
Public Sub New (
    element As IPrimitive,
    evaluationStack As List(Of IPrimitive)
)
public:
NotDefinedException(
    IPrimitive^ element,
    List<IPrimitive^>^ evaluationStack
)
new :
        element : IPrimitive *
        evaluationStack : List<IPrimitive> -> NotDefinedException

Parameters

element
Type: SMath.ManagerIPrimitive
evaluationStack
Type: System.Collections.GenericListIPrimitive
See Also

Reference

NotDefinedException Class
NotDefinedException Overload
SMath.Manager Namespace


NotDefinedException Properties

The NotDefinedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Element | Mathematical primitive, that causes an error.Математический примитив, вызвавший исключение. (Inherited from MathException.)
Public property | EvaluationStack | (Inherited from MathException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Inherited from GeneralException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

NotDefinedException Class
SMath.Manager Namespace


NotDefinedException Methods

The NotDefinedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetErrorText(SessionProfile) | (Inherited from GeneralException.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

NotDefinedException Class
SMath.Manager Namespace


NotDefinedException Fields

The NotDefinedException type exposes the following members.

Fields
 | Name | Description
Public field | ErrorId | (Inherited from GeneralException.)
Top
See Also

Reference

NotDefinedException Class
SMath.Manager Namespace


OnErrorAction Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum OnErrorAction
Public Enumeration OnErrorAction
public enum class OnErrorAction
type OnErrorAction
Members
Member name | Value | Description
Continue | 0 |
Pause | 1 |
Break | 2 |
See Also

Reference

SMath.Manager Namespace


OperatorInfo Class

Класс характеристик оператора
Inheritance Hierarchy
SystemObject
SMath.ManagerOperatorInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class OperatorInfo : IDetailedTerm
Public Class OperatorInfo
    Implements IDetailedTerm
public ref class OperatorInfo : IDetailedTerm
type OperatorInfo =
    class
        interface IDetailedTerm
    end

The OperatorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OperatorInfo | Initializes a new instance of the OperatorInfo class
Top
Properties
 | Name | Description
Public property | Description | Описание оператора
Public property | Symbol | Символ для вставки
Public property | Title | Название оператора
Public property | Type | Тип оператора
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetails |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTerm |
Top
See Also

Reference

SMath.Manager Namespace


OperatorInfo Constructor

Initializes a new instance of the OperatorInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OperatorInfo(
    string title,
    string symbol,
    string descrption,
    OperatorType type
)
Public Sub New (
    title As String,
    symbol As String,
    descrption As String,
    type As OperatorType
)
public:
OperatorInfo(
    String^ title,
    String^ symbol,
    String^ descrption,
    OperatorType type
)
new :
        title : string *
        symbol : string *
        descrption : string *
        type : OperatorType -> OperatorInfo

Parameters

title
Type: SystemString
symbol
Type: SystemString
descrption
Type: SystemString
type
Type: SMath.ManagerOperatorType
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo Properties

The OperatorInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | Описание оператора
Public property | Symbol | Символ для вставки
Public property | Title | Название оператора
Public property | Type | Тип оператора
Top
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.Description Property

OperatorInfoDescription Property

Описание оператора

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IDetailedTermDescription
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.Symbol Property

OperatorInfoSymbol Property

Символ для вставки

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Symbol { get; }
Public ReadOnly Property Symbol As String
    Get
public:
property String^ Symbol {
    String^ get ();
}
member Symbol : string with get

Property Value

Type: String
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.Title Property

OperatorInfoTitle Property

Название оператора

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get

Property Value

Type: String

Implements

IDetailedTermTitle
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.Type Property

OperatorInfoType Property

Тип оператора

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OperatorType Type { get; }
Public ReadOnly Property Type As OperatorType
    Get
public:
property OperatorType Type {
    OperatorType get ();
}
member Type : OperatorType with get

Property Value

Type: OperatorType
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo Methods

The OperatorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetails |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTerm |
Top
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.GetDetails Method

OperatorInfoGetDetails Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetDetails(
    SessionProfile sessionProfile
)
Public Function GetDetails (
    sessionProfile As SessionProfile
) As String
public:
virtual String^ GetDetails(
    SessionProfile^ sessionProfile
) sealed
abstract GetDetails :
        sessionProfile : SessionProfile -> string
override GetDetails :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String

Implements

IDetailedTermGetDetails(SessionProfile)
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.ToString Method

OperatorInfoToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


OperatorInfo.ToTerm Method

OperatorInfoToTerm Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm(
    SessionProfile sessionProfile
)
Public Function ToTerm (
    sessionProfile As SessionProfile
) As Term
public:
virtual Term^ ToTerm(
    SessionProfile^ sessionProfile
) sealed
abstract ToTerm :
        sessionProfile : SessionProfile -> Term
override ToTerm :
        sessionProfile : SessionProfile -> Term

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: Term

Implements

IDetailedTermToTerm(SessionProfile)
See Also

Reference

OperatorInfo Class
SMath.Manager Namespace


Operators Structure

Доступные встроенные операторы программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct Operators
Public Structure Operators
public value class Operators
[<SealedAttribute>]
type Operators =  struct end

The Operators type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
Name | Description
BooleanAnd | Булево "и".
BooleanEqual | Булево "равно".
BooleanLess | Булево "строго меньше".
BooleanLessOrEqual | Булево "меньше либо равно".
BooleanMore | Булево "строго больше".
BooleanMoreOrEqual | Булево "больше либо равно".
BooleanNot | Булево "не".
BooleanNotEqual | Булево "неравно".
BooleanOr | Булево "или".
BooleanXor | Булево "исключающее или".
Break |
Composition | Оператор сложения.
Continue |
Definition | Присвоение.
Division | Оператор деления.
EmptyOperator | Пустой оператор.
Exponentiation | Возведение в степень.
Factorial | Факториал.
MinusPlus | Оператор "минус/плюс".
Multiplication | Оператор скалярного умножения.
NumericEqual | Оператор численного вычисления.
PlusMinus | Оператор "плюс/минус".
Substraction | Obsolete. Оператор вычитания.
Subtraction | Оператор вычитания.
UnitOperator | Оператор единиц измерения.
VectorMultiplication | Оператор векторного умножения.
Top
See Also

Reference

SMath.Manager Namespace


Operators Methods

The Operators type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators Fields

The Operators type exposes the following members.

Fields
Name | Description
BooleanAnd | Булево "и".
BooleanEqual | Булево "равно".
BooleanLess | Булево "строго меньше".
BooleanLessOrEqual | Булево "меньше либо равно".
BooleanMore | Булево "строго больше".
BooleanMoreOrEqual | Булево "больше либо равно".
BooleanNot | Булево "не".
BooleanNotEqual | Булево "неравно".
BooleanOr | Булево "или".
BooleanXor | Булево "исключающее или".
Break |
Composition | Оператор сложения.
Continue |
Definition | Присвоение.
Division | Оператор деления.
EmptyOperator | Пустой оператор.
Exponentiation | Возведение в степень.
Factorial | Факториал.
MinusPlus | Оператор "минус/плюс".
Multiplication | Оператор скалярного умножения.
NumericEqual | Оператор численного вычисления.
PlusMinus | Оператор "плюс/минус".
Substraction | Obsolete. Оператор вычитания.
Subtraction | Оператор вычитания.
UnitOperator | Оператор единиц измерения.
VectorMultiplication | Оператор векторного умножения.
Top
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanAnd Field

OperatorsBooleanAnd Field

Булево "и".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanAnd = "&"
Public Const BooleanAnd As String = "&"
public:
literal String^ BooleanAnd = "&"
static val mutable BooleanAnd: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanEqual Field

OperatorsBooleanEqual Field

Булево "равно".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanEqual = "≡"
Public Const BooleanEqual As String = "≡"
public:
literal String^ BooleanEqual = "≡"
static val mutable BooleanEqual: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanLess Field

OperatorsBooleanLess Field

Булево "строго меньше".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanLess = "<"
Public Const BooleanLess As String = "<"
public:
literal String^ BooleanLess = "<"
static val mutable BooleanLess: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanLessOrEqual Field

OperatorsBooleanLessOrEqual Field

Булево "меньше либо равно".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanLessOrEqual = "≤"
Public Const BooleanLessOrEqual As String = "≤"
public:
literal String^ BooleanLessOrEqual = "≤"
static val mutable BooleanLessOrEqual: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanMore Field

OperatorsBooleanMore Field

Булево "строго больше".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanMore = ">"
Public Const BooleanMore As String = ">"
public:
literal String^ BooleanMore = ">"
static val mutable BooleanMore: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanMoreOrEqual Field

OperatorsBooleanMoreOrEqual Field

Булево "больше либо равно".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanMoreOrEqual = "≥"
Public Const BooleanMoreOrEqual As String = "≥"
public:
literal String^ BooleanMoreOrEqual = "≥"
static val mutable BooleanMoreOrEqual: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanNot Field

OperatorsBooleanNot Field

Булево "не".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanNot = "¬"
Public Const BooleanNot As String = "¬"
public:
literal String^ BooleanNot = "¬"
static val mutable BooleanNot: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanNotEqual Field

OperatorsBooleanNotEqual Field

Булево "неравно".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanNotEqual = "≠"
Public Const BooleanNotEqual As String = "≠"
public:
literal String^ BooleanNotEqual = "≠"
static val mutable BooleanNotEqual: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanOr Field

OperatorsBooleanOr Field

Булево "или".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanOr = "|"
Public Const BooleanOr As String = "|"
public:
literal String^ BooleanOr = "|"
static val mutable BooleanOr: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.BooleanXor Field

OperatorsBooleanXor Field

Булево "исключающее или".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string BooleanXor = "¤"
Public Const BooleanXor As String = "¤"
public:
literal String^ BooleanXor = "¤"
static val mutable BooleanXor: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Break Field

OperatorsBreak Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Break = "break"
Public Const Break As String = "break"
public:
literal String^ Break = "break"
static val mutable Break: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Composition Field

OperatorsComposition Field

Оператор сложения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Composition = "+"
Public Const Composition As String = "+"
public:
literal String^ Composition = "+"
static val mutable Composition: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Continue Field

OperatorsContinue Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Continue = "continue"
Public Const Continue As String = "continue"
public:
literal String^ Continue = "continue"
static val mutable Continue: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Definition Field

OperatorsDefinition Field

Присвоение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Definition = ":"
Public Const Definition As String = ":"
public:
literal String^ Definition = ":"
static val mutable Definition: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Division Field

OperatorsDivision Field

Оператор деления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Division = "/"
Public Const Division As String = "/"
public:
literal String^ Division = "/"
static val mutable Division: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.EmptyOperator Field

OperatorsEmptyOperator Field

Пустой оператор.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EmptyOperator = "$"
Public Const EmptyOperator As String = "$"
public:
literal String^ EmptyOperator = "$"
static val mutable EmptyOperator: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Exponentiation Field

OperatorsExponentiation Field

Возведение в степень.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Exponentiation = "^"
Public Const Exponentiation As String = "^"
public:
literal String^ Exponentiation = "^"
static val mutable Exponentiation: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Factorial Field

OperatorsFactorial Field

Факториал.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Factorial = "!"
Public Const Factorial As String = "!"
public:
literal String^ Factorial = "!"
static val mutable Factorial: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.MinusPlus Field

OperatorsMinusPlus Field

Оператор "минус/плюс".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string MinusPlus = "∓"
Public Const MinusPlus As String = "∓"
public:
literal String^ MinusPlus = "∓"
static val mutable MinusPlus: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Multiplication Field

OperatorsMultiplication Field

Оператор скалярного умножения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Multiplication = "*"
Public Const Multiplication As String = "*"
public:
literal String^ Multiplication = "*"
static val mutable Multiplication: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.NumericEqual Field

OperatorsNumericEqual Field

Оператор численного вычисления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string NumericEqual = "="
Public Const NumericEqual As String = "="
public:
literal String^ NumericEqual = "="
static val mutable NumericEqual: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.PlusMinus Field

OperatorsPlusMinus Field

Оператор "плюс/минус".

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PlusMinus = "±"
Public Const PlusMinus As String = "±"
public:
literal String^ PlusMinus = "±"
static val mutable PlusMinus: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Substraction Field

OperatorsSubstraction Field

Note: This API is now obsolete.

Оператор вычитания.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Operators.Subtraction instead.")]
public const string Substraction = "-"
<ObsoleteAttribute("Use Operators.Subtraction instead.")>
Public Const Substraction As String = "-"
public:
[ObsoleteAttribute(L"Use Operators.Subtraction instead.")]
literal String^ Substraction = "-"
[<ObsoleteAttribute("Use Operators.Subtraction instead.")>]
static val mutable Substraction: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.Subtraction Field

OperatorsSubtraction Field

Оператор вычитания.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Subtraction = "-"
Public Const Subtraction As String = "-"
public:
literal String^ Subtraction = "-"
static val mutable Subtraction: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.UnitOperator Field

OperatorsUnitOperator Field

Оператор единиц измерения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string UnitOperator = "@"
Public Const UnitOperator As String = "@"
public:
literal String^ UnitOperator = "@"
static val mutable UnitOperator: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


Operators.VectorMultiplication Field

OperatorsVectorMultiplication Field

Оператор векторного умножения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string VectorMultiplication = "†"
Public Const VectorMultiplication As String = "†"
public:
literal String^ VectorMultiplication = "†"
static val mutable VectorMultiplication: string

Field Value

Type: String
See Also

Reference

Operators Structure
SMath.Manager Namespace


OperatorType Enumeration

Допустимое количество операндов оператора

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum OperatorType
Public Enumeration OperatorType
public enum class OperatorType
type OperatorType
Members
Member name | Value | Description
Both | 0 | Оператор может иметь любое допустимое количество операндов: один или два
Unary | 1 | Оператор унарный - допустим лишь один операнд
Binary | 2 | Оператор бинарный - допустимо лишь два операнда
See Also

Reference

SMath.Manager Namespace


OptimizationType Enumeration

Evaluation optimization type.Тип оптимизации вычисления.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum OptimizationType
Public Enumeration OptimizationType
public enum class OptimizationType
type OptimizationType
Members
Member name | Value | Description
None | 0 | Without optimization.Без оптимизации.
Symbolic | 1 | Symbolic optimization.Символьная оптимизация.
Numeric | 2 | Numeric optimization.Численная оптимизация.
See Also

Reference

SMath.Manager Namespace


OptionsCollection Class

Inheritance Hierarchy
SystemObject
SMath.ManagerOptionsCollection
SMath.ManagerSessionOptions
SMath.ManagerSessionProfile

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class OptionsCollection : IEnumerable<KeyValuePair<string, string>>,
    IEnumerable
Public Class OptionsCollection
    Implements IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable
public ref class OptionsCollection : IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable
type OptionsCollection =
    class
        interface IEnumerable<KeyValuePair<string, string>>
        interface IEnumerable
    end

The OptionsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OptionsCollection | Initializes a new instance of the OptionsCollection class
Top
Properties
 | Name | Description
Public property | Item |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean |
Public method | GetCollection |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt |
Public method | GetSingle | Retrieves a float property.
Public method | GetString |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParseBoolean |
 | TryParseInt |
Top
Fields
 | Name | Description
Protected field | data |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator |
Top
See Also

Reference

SMath.Manager Namespace


OptionsCollection Constructor

Initializes a new instance of the OptionsCollection class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OptionsCollection()
Public Sub New
public:
OptionsCollection()
new : unit -> OptionsCollection
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection Properties

The OptionsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Top
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.Item Property

OptionsCollectionItem Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As String
    Get
    Set
public:
property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}
member Item : string with get, set

Parameters

name
Type: SystemString

Property Value

Type: String
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection Methods

The OptionsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean |
Public method | GetCollection |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt |
Public method | GetSingle | Retrieves a float property.
Public method | GetString |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParseBoolean |
 | TryParseInt |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator |
Top
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.IEnumerable.GetEnumerator Method

OptionsCollectionIEnumerableGetEnumerator Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetBoolean Method

OptionsCollectionGetBoolean Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool GetBoolean(
    string name,
    bool defaultValue = false
)
Public Function GetBoolean (
    name As String,
    Optional defaultValue As Boolean = false
) As Boolean
public:
bool GetBoolean(
    String^ name,
    bool defaultValue = false
)
member GetBoolean :
        name : string *
        ?defaultValue : bool
(* Defaults:
        let _defaultValue = defaultArg defaultValue false
*)
-> bool

Parameters

name
Type: SystemString
defaultValue (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetCollection Method

OptionsCollectionGetCollection Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetCollection(
    string name
)
Public Function GetCollection (
    name As String
) As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetCollection(
    String^ name
)
member GetCollection :
        name : string -> Dictionary<string, string>

Parameters

name
Type: SystemString

Return Value

Type: DictionaryString, String
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetEnumerator Method

OptionsCollectionGetEnumerator Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>

Return Value

Type: IEnumeratorKeyValuePairString, String

Implements

IEnumerableTGetEnumerator
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetInt Method

OptionsCollectionGetInt Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetInt(
    string name,
    int defaultValue = -1
)
Public Function GetInt (
    name As String,
    Optional defaultValue As Integer = -1
) As Integer
public:
int GetInt(
    String^ name,
    int defaultValue = -1
)
member GetInt :
        name : string *
        ?defaultValue : int
(* Defaults:
        let _defaultValue = defaultArg defaultValue -1
*)
-> int

Parameters

name
Type: SystemString
defaultValue (Optional)
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetSingle Method

OptionsCollectionGetSingle Method

Retrieves a float property.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float GetSingle(
    string name,
    float defaultValue = -1f
)
Public Function GetSingle (
    name As String,
    Optional defaultValue As Single = -1F
) As Single
public:
float GetSingle(
    String^ name,
    float defaultValue = -1f
)
member GetSingle :
        name : string *
        ?defaultValue : float32
(* Defaults:
        let _defaultValue = defaultArg defaultValue -1f
*)
-> float32

Parameters

name
Type: SystemString
Name of the property to retrieve.
defaultValue (Optional)
Type: SystemSingle
Default value.

Return Value

Type: Single
Property value if the property exists and is parsed OK.
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.GetString Method

OptionsCollectionGetString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetString(
    string name,
    string defaultValue = null
)
Public Function GetString (
    name As String,
    Optional defaultValue As String = Nothing
) As String
public:
String^ GetString(
    String^ name,
    String^ defaultValue = nullptr
)
member GetString :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue null
*)
-> string

Parameters

name
Type: SystemString
defaultValue (Optional)
Type: SystemString

Return Value

Type: String
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.TryParseBoolean Method

OptionsCollectionTryParseBoolean Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected static bool TryParseBoolean(
    string name,
    bool defaultValue = false
)
Protected Shared Function TryParseBoolean (
    name As String,
    Optional defaultValue As Boolean = false
) As Boolean
protected:
static bool TryParseBoolean(
    String^ name,
    bool defaultValue = false
)
static member TryParseBoolean :
        name : string *
        ?defaultValue : bool
(* Defaults:
        let _defaultValue = defaultArg defaultValue false
*)
-> bool

Parameters

name
Type: SystemString
defaultValue (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.TryParseInt Method

OptionsCollectionTryParseInt Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected static int TryParseInt(
    string name,
    int defaultValue = -1
)
Protected Shared Function TryParseInt (
    name As String,
    Optional defaultValue As Integer = -1
) As Integer
protected:
static int TryParseInt(
    String^ name,
    int defaultValue = -1
)
static member TryParseInt :
        name : string *
        ?defaultValue : int
(* Defaults:
        let _defaultValue = defaultArg defaultValue -1
*)
-> int

Parameters

name
Type: SystemString
defaultValue (Optional)
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection Fields

The OptionsCollection type exposes the following members.

Fields
 | Name | Description
Protected field | data |
Top
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OptionsCollection.data Field

OptionsCollectiondata Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Dictionary<string, string> data
Protected data As Dictionary(Of String, String)
protected:
Dictionary<String^, String^>^ data
val mutable data: Dictionary<string, string>

Field Value

Type: DictionaryString, String
See Also

Reference

OptionsCollection Class
SMath.Manager Namespace


OSType Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum OSType
Public Enumeration OSType
public enum class OSType
type OSType
Members
Member name | Value | Description
NotDefined | 0 |
Windows | 1 |
Linux | 2 |
See Also

Reference

SMath.Manager Namespace


PageMargins Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPageMargins

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PageMargins
Public Class PageMargins
public ref class PageMargins
type PageMargins =  class end

The PageMargins type exposes the following members.

Constructors
 | Name | Description
Public method | PageMargins(PageMargins) | Initializes a new instance of the PageMargins class
Public method | PageMargins(Int32, Int32, Int32, Int32) | Initializes a new instance of the PageMargins class
Top
Properties
 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Right |
Public property | Top |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PageMargins Constructor

Overload List
 | Name | Description
Public method | PageMargins(PageMargins) | Initializes a new instance of the PageMargins class
Public method | PageMargins(Int32, Int32, Int32, Int32) | Initializes a new instance of the PageMargins class
Top
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins Constructor (PageMargins)

Initializes a new instance of the PageMargins class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageMargins(
    PageMargins margins
)
Public Sub New (
    margins As PageMargins
)
public:
PageMargins(
    PageMargins^ margins
)
new :
        margins : PageMargins -> PageMargins

Parameters

margins
Type: SMath.ManagerPageMargins
See Also

Reference

PageMargins Class
PageMargins Overload
SMath.Manager Namespace


PageMargins Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the PageMargins class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageMargins(
    int Left,
    int Right,
    int Top,
    int Bottom
)
Public Sub New (
    Left As Integer,
    Right As Integer,
    Top As Integer,
    Bottom As Integer
)
public:
PageMargins(
    int Left,
    int Right,
    int Top,
    int Bottom
)
new :
        Left : int *
        Right : int *
        Top : int *
        Bottom : int -> PageMargins

Parameters

Left
Type: SystemInt32
Right
Type: SystemInt32
Top
Type: SystemInt32
Bottom
Type: SystemInt32
See Also

Reference

PageMargins Class
PageMargins Overload
SMath.Manager Namespace


PageMargins Properties

The PageMargins type exposes the following members.

Properties
 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Right |
Public property | Top |
Top
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.Bottom Property

PageMarginsBottom Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Bottom { get; set; }
Public Property Bottom As Integer
    Get
    Set
public:
property int Bottom {
    int get ();
    void set (int value);
}
member Bottom : int with get, set

Property Value

Type: Int32
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.Left Property

PageMarginsLeft Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Left { get; set; }
Public Property Left As Integer
    Get
    Set
public:
property int Left {
    int get ();
    void set (int value);
}
member Left : int with get, set

Property Value

Type: Int32
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.Right Property

PageMarginsRight Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Right { get; set; }
Public Property Right As Integer
    Get
    Set
public:
property int Right {
    int get ();
    void set (int value);
}
member Right : int with get, set

Property Value

Type: Int32
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.Top Property

PageMarginsTop Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Type: Int32
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins Methods

The PageMargins type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.Equals Method

PageMarginsEquals Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageMargins.GetHashCode Method

PageMarginsGetHashCode Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

PageMargins Class
SMath.Manager Namespace


PageModel Class

Printing model of the document.Модель документа для печати.
Inheritance Hierarchy
SystemObject
SMath.ManagerPageModel

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PageModel
Public Class PageModel
public ref class PageModel
type PageModel =  class end

The PageModel type exposes the following members.

Constructors
 | Name | Description
Public method | PageModel | Initializes a new instance of the PageModel class
Public method | PageModel(PageModel) | Initializes a new instance of the PageModel class
Top
Properties
 | Name | Description
Public property | Active | Obsolete.
Public property | CanvasSize |
Public property | Footer |
Public property | Header |
Public property | Margins |
Public property | Mode |
Public property | Orientation |
Public property | PaperId |
Public property | PrintAreas |
Public property | PrintBackgroundImages |
Public property | PrintEmptyPages |
Public property | PrintGrid |
Public property | PrintHeaderFooter |
Public property | SimpleEqualsOnly |
Public property | Size |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PageModel Constructor

Overload List
 | Name | Description
Public method | PageModel | Initializes a new instance of the PageModel class
Public method | PageModel(PageModel) | Initializes a new instance of the PageModel class
Top
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel Constructor

Initializes a new instance of the PageModel class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel()
Public Sub New
public:
PageModel()
new : unit -> PageModel
See Also

Reference

PageModel Class
PageModel Overload
SMath.Manager Namespace


PageModel Constructor (PageModel)

Initializes a new instance of the PageModel class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel(
    PageModel pageModel
)
Public Sub New (
    pageModel As PageModel
)
public:
PageModel(
    PageModel^ pageModel
)
new :
        pageModel : PageModel -> PageModel

Parameters

pageModel
Type: SMath.ManagerPageModel
See Also

Reference

PageModel Class
PageModel Overload
SMath.Manager Namespace


PageModel Properties

The PageModel type exposes the following members.

Properties
 | Name | Description
Public property | Active | Obsolete.
Public property | CanvasSize |
Public property | Footer |
Public property | Header |
Public property | Margins |
Public property | Mode |
Public property | Orientation |
Public property | PaperId |
Public property | PrintAreas |
Public property | PrintBackgroundImages |
Public property | PrintEmptyPages |
Public property | PrintGrid |
Public property | PrintHeaderFooter |
Public property | SimpleEqualsOnly |
Public property | Size |
Top
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Active Property

PageModelActive Property

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Mode instead.")]
public bool Active { get; set; }
<ObsoleteAttribute("Use Mode instead.")>
Public Property Active As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Use Mode instead.")]
property bool Active {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("Use Mode instead.")>]
member Active : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.CanvasSize Property

PageModelCanvasSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size CanvasSize { get; }
Public ReadOnly Property CanvasSize As Size
    Get
public:
property Size CanvasSize {
    Size get ();
}
member CanvasSize : Size with get

Property Value

Type: Size
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Footer Property

PageModelFooter Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RunningTitle Footer { get; set; }
Public Property Footer As RunningTitle
    Get
    Set
public:
property RunningTitle^ Footer {
    RunningTitle^ get ();
    void set (RunningTitle^ value);
}
member Footer : RunningTitle with get, set

Property Value

Type: RunningTitle
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Header Property

PageModelHeader Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RunningTitle Header { get; set; }
Public Property Header As RunningTitle
    Get
    Set
public:
property RunningTitle^ Header {
    RunningTitle^ get ();
    void set (RunningTitle^ value);
}
member Header : RunningTitle with get, set

Property Value

Type: RunningTitle
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Margins Property

PageModelMargins Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageMargins Margins { get; set; }
Public Property Margins As PageMargins
    Get
    Set
public:
property PageMargins^ Margins {
    PageMargins^ get ();
    void set (PageMargins^ value);
}
member Margins : PageMargins with get, set

Property Value

Type: PageMargins
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Mode Property

PageModelMode Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModelViewMode Mode { get; set; }
Public Property Mode As PageModelViewMode
    Get
    Set
public:
property PageModelViewMode Mode {
    PageModelViewMode get ();
    void set (PageModelViewMode value);
}
member Mode : PageModelViewMode with get, set

Property Value

Type: PageModelViewMode
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Orientation Property

PageModelOrientation Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageOrientation Orientation { get; set; }
Public Property Orientation As PageOrientation
    Get
    Set
public:
property PageOrientation Orientation {
    PageOrientation get ();
    void set (PageOrientation value);
}
member Orientation : PageOrientation with get, set

Property Value

Type: PageOrientation
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PaperId Property

PageModelPaperId Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int PaperId { get; set; }
Public Property PaperId As Integer
    Get
    Set
public:
property int PaperId {
    int get ();
    void set (int value);
}
member PaperId : int with get, set

Property Value

Type: Int32
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PrintAreas Property

PageModelPrintAreas Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool PrintAreas { get; set; }
Public Property PrintAreas As Boolean
    Get
    Set
public:
property bool PrintAreas {
    bool get ();
    void set (bool value);
}
member PrintAreas : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PrintBackgroundImages Property

PageModelPrintBackgroundImages Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool PrintBackgroundImages { get; set; }
Public Property PrintBackgroundImages As Boolean
    Get
    Set
public:
property bool PrintBackgroundImages {
    bool get ();
    void set (bool value);
}
member PrintBackgroundImages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PrintEmptyPages Property

PageModelPrintEmptyPages Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool PrintEmptyPages { get; set; }
Public Property PrintEmptyPages As Boolean
    Get
    Set
public:
property bool PrintEmptyPages {
    bool get ();
    void set (bool value);
}
member PrintEmptyPages : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PrintGrid Property

PageModelPrintGrid Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool PrintGrid { get; set; }
Public Property PrintGrid As Boolean
    Get
    Set
public:
property bool PrintGrid {
    bool get ();
    void set (bool value);
}
member PrintGrid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.PrintHeaderFooter Property

PageModelPrintHeaderFooter Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool PrintHeaderFooter { get; set; }
Public Property PrintHeaderFooter As Boolean
    Get
    Set
public:
property bool PrintHeaderFooter {
    bool get ();
    void set (bool value);
}
member PrintHeaderFooter : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.SimpleEqualsOnly Property

PageModelSimpleEqualsOnly Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SimpleEqualsOnly { get; set; }
Public Property SimpleEqualsOnly As Boolean
    Get
    Set
public:
property bool SimpleEqualsOnly {
    bool get ();
    void set (bool value);
}
member SimpleEqualsOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Size Property

PageModelSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set
public:
property Size Size {
    Size get ();
    void set (Size value);
}
member Size : Size with get, set

Property Value

Type: Size
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel Methods

The PageModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.Equals Method

PageModelEquals Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModel.GetHashCode Method

PageModelGetHashCode Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

PageModel Class
SMath.Manager Namespace


PageModelViewMode Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum PageModelViewMode
Public Enumeration PageModelViewMode
public enum class PageModelViewMode
type PageModelViewMode
Members
Member name | Value | Description
PrintingBounds | 0 |
None | 1 |
Pages | 2 |
See Also

Reference

SMath.Manager Namespace


PageOptions Class

Inheritance Hierarchy
SystemObject
SMath.ManagerThreadSafeImageContainer
SMath.ManagerPageOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PageOptions : ThreadSafeImageContainer
Public Class PageOptions
    Inherits ThreadSafeImageContainer
public ref class PageOptions : public ThreadSafeImageContainer
type PageOptions =
    class
        inherit ThreadSafeImageContainer
    end

The PageOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PageOptions | Initializes a new instance of the PageOptions class
Public method | PageOptions(PageOptions) | Initializes a new instance of the PageOptions class
Public method | PageOptions(BackgroundImageSize, Boolean, IBitmap) | Initializes a new instance of the PageOptions class
Top
Properties
 | Name | Description
Public property | Exists | (Inherited from ThreadSafeImageContainer.)
Public property | FullPage |
Public property | ImageSize |
Public property | Size | (Inherited from ThreadSafeImageContainer.)
Top
Methods
 | Name | Description
Public method | DrawImage | (Inherited from ThreadSafeImageContainer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageCopy | (Inherited from ThreadSafeImageContainer.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage | (Inherited from ThreadSafeImageContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | imageLock | (Inherited from ThreadSafeImageContainer.)
Protected field | optimizedImage | (Inherited from ThreadSafeImageContainer.)
Protected field | originalImage | (Inherited from ThreadSafeImageContainer.)
Top
See Also

Reference

SMath.Manager Namespace


PageOptions Constructor

Overload List
 | Name | Description
Public method | PageOptions | Initializes a new instance of the PageOptions class
Public method | PageOptions(PageOptions) | Initializes a new instance of the PageOptions class
Public method | PageOptions(BackgroundImageSize, Boolean, IBitmap) | Initializes a new instance of the PageOptions class
Top
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOptions Constructor

Initializes a new instance of the PageOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageOptions()
Public Sub New
public:
PageOptions()
new : unit -> PageOptions
See Also

Reference

PageOptions Class
PageOptions Overload
SMath.Manager Namespace


PageOptions Constructor (PageOptions)

Initializes a new instance of the PageOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageOptions(
    PageOptions options
)
Public Sub New (
    options As PageOptions
)
public:
PageOptions(
    PageOptions^ options
)
new :
        options : PageOptions -> PageOptions

Parameters

options
Type: SMath.ManagerPageOptions
See Also

Reference

PageOptions Class
PageOptions Overload
SMath.Manager Namespace


PageOptions Constructor (BackgroundImageSize, Boolean, IBitmap)

Initializes a new instance of the PageOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageOptions(
    BackgroundImageSize imageSize,
    bool fullPage,
    IBitmap backgroundImage
)
Public Sub New (
    imageSize As BackgroundImageSize,
    fullPage As Boolean,
    backgroundImage As IBitmap
)
public:
PageOptions(
    BackgroundImageSize imageSize,
    bool fullPage,
    IBitmap^ backgroundImage
)
new :
        imageSize : BackgroundImageSize *
        fullPage : bool *
        backgroundImage : IBitmap -> PageOptions

Parameters

imageSize
Type: SMath.ManagerBackgroundImageSize
fullPage
Type: SystemBoolean
backgroundImage
Type: SMath.DrawingIBitmap
See Also

Reference

PageOptions Class
PageOptions Overload
SMath.Manager Namespace


PageOptions Properties

The PageOptions type exposes the following members.

Properties
 | Name | Description
Public property | Exists | (Inherited from ThreadSafeImageContainer.)
Public property | FullPage |
Public property | ImageSize |
Public property | Size | (Inherited from ThreadSafeImageContainer.)
Top
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOptions.FullPage Property

PageOptionsFullPage Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool FullPage { get; set; }
Public Property FullPage As Boolean
    Get
    Set
public:
property bool FullPage {
    bool get ();
    void set (bool value);
}
member FullPage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOptions.ImageSize Property

PageOptionsImageSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public BackgroundImageSize ImageSize { get; set; }
Public Property ImageSize As BackgroundImageSize
    Get
    Set
public:
property BackgroundImageSize ImageSize {
    BackgroundImageSize get ();
    void set (BackgroundImageSize value);
}
member ImageSize : BackgroundImageSize with get, set

Property Value

Type: BackgroundImageSize
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOptions Methods

The PageOptions type exposes the following members.

Methods
 | Name | Description
Public method | DrawImage | (Inherited from ThreadSafeImageContainer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageCopy | (Inherited from ThreadSafeImageContainer.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage | (Inherited from ThreadSafeImageContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOptions Fields

The PageOptions type exposes the following members.

Fields
 | Name | Description
Protected field | imageLock | (Inherited from ThreadSafeImageContainer.)
Protected field | optimizedImage | (Inherited from ThreadSafeImageContainer.)
Protected field | originalImage | (Inherited from ThreadSafeImageContainer.)
Top
See Also

Reference

PageOptions Class
SMath.Manager Namespace


PageOrientation Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum PageOrientation
Public Enumeration PageOrientation
public enum class PageOrientation
type PageOrientation
Members
Member name | Value | Description
Portrait | 0 |
Landscape | 1 |
See Also

Reference

SMath.Manager Namespace


PagesOptions Class

Single document page options.Свойства страницы документа.
Inheritance Hierarchy
SystemObject
SMath.ManagerPagesOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PagesOptions
Public Class PagesOptions
public ref class PagesOptions
type PagesOptions =  class end

The PagesOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PagesOptions | Initializes a new instance of the PagesOptions class
Public method | PagesOptions(PagesOptions) | Initializes a new instance of the PagesOptions class
Top
Properties
 | Name | Description
Public property | General |
Public property | Pages |
Top
Methods
 | Name | Description
Public method | DrawBackground |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | HasBackground |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBackground |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PagesOptions Constructor

Overload List
 | Name | Description
Public method | PagesOptions | Initializes a new instance of the PagesOptions class
Public method | PagesOptions(PagesOptions) | Initializes a new instance of the PagesOptions class
Top
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions Constructor

Initializes a new instance of the PagesOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesOptions()
Public Sub New
public:
PagesOptions()
new : unit -> PagesOptions
See Also

Reference

PagesOptions Class
PagesOptions Overload
SMath.Manager Namespace


PagesOptions Constructor (PagesOptions)

Initializes a new instance of the PagesOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PagesOptions(
    PagesOptions options
)
Public Sub New (
    options As PagesOptions
)
public:
PagesOptions(
    PagesOptions^ options
)
new :
        options : PagesOptions -> PagesOptions

Parameters

options
Type: SMath.ManagerPagesOptions
See Also

Reference

PagesOptions Class
PagesOptions Overload
SMath.Manager Namespace


PagesOptions Properties

The PagesOptions type exposes the following members.

Properties
 | Name | Description
Public property | General |
Public property | Pages |
Top
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions.General Property

PagesOptionsGeneral Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageOptions General { get; set; }
Public Property General As PageOptions
    Get
    Set
public:
property PageOptions^ General {
    PageOptions^ get ();
    void set (PageOptions^ value);
}
member General : PageOptions with get, set

Property Value

Type: PageOptions
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions.Pages Property

PagesOptionsPages Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SortedDictionary<int, PageOptions> Pages { get; set; }
Public Property Pages As SortedDictionary(Of Integer, PageOptions)
    Get
    Set
public:
property SortedDictionary<int, PageOptions^>^ Pages {
    SortedDictionary<int, PageOptions^>^ get ();
    void set (SortedDictionary<int, PageOptions^>^ value);
}
member Pages : SortedDictionary<int, PageOptions> with get, set

Property Value

Type: SortedDictionaryInt32, PageOptions
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions Methods

The PagesOptions type exposes the following members.

Methods
 | Name | Description
Public method | DrawBackground |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | HasBackground |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBackground |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions.DrawBackground Method

PagesOptionsDrawBackground Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawBackground(
    int pageNum,
    IGraphics g,
    RectangleF printingRect,
    RectangleF fullRect,
    bool export
)
Public Sub DrawBackground (
    pageNum As Integer,
    g As IGraphics,
    printingRect As RectangleF,
    fullRect As RectangleF,
    export As Boolean
)
public:
void DrawBackground(
    int pageNum,
    IGraphics^ g,
    RectangleF printingRect,
    RectangleF fullRect,
    bool export
)
member DrawBackground :
        pageNum : int *
        g : IGraphics *
        printingRect : RectangleF *
        fullRect : RectangleF *
        export : bool -> unit

Parameters

pageNum
Type: SystemInt32
g
Type: SMath.DrawingIGraphics
printingRect
Type: System.DrawingRectangleF
fullRect
Type: System.DrawingRectangleF
export
Type: SystemBoolean
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions.HasBackground Method

PagesOptionsHasBackground Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool HasBackground(
    int pageNum
)
Public Function HasBackground (
    pageNum As Integer
) As Boolean
public:
bool HasBackground(
    int pageNum
)
member HasBackground :
        pageNum : int -> bool

Parameters

pageNum
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PagesOptions.SetBackground Method

PagesOptionsSetBackground Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetBackground(
    IBitmap bmp,
    int pageNum,
    BackgroundImageSize size,
    bool fullPage
)
Public Sub SetBackground (
    bmp As IBitmap,
    pageNum As Integer,
    size As BackgroundImageSize,
    fullPage As Boolean
)
public:
void SetBackground(
    IBitmap^ bmp,
    int pageNum,
    BackgroundImageSize size,
    bool fullPage
)
member SetBackground :
        bmp : IBitmap *
        pageNum : int *
        size : BackgroundImageSize *
        fullPage : bool -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
pageNum
Type: SystemInt32
size
Type: SMath.ManagerBackgroundImageSize
fullPage
Type: SystemBoolean
See Also

Reference

PagesOptions Class
SMath.Manager Namespace


PaintEventOptions Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPaintEventOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PaintEventOptions
Public Class PaintEventOptions
public ref class PaintEventOptions
type PaintEventOptions =  class end

The PaintEventOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PaintEventOptions | Initializes a new instance of the PaintEventOptions class
Top
Properties
 | Name | Description
Public property | ClipRectangle |
Public property | Graphics |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PaintEventOptions Constructor

Initializes a new instance of the PaintEventOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PaintEventOptions(
    IGraphics Graphics,
    RectangleF ClipRectangle
)
Public Sub New (
    Graphics As IGraphics,
    ClipRectangle As RectangleF
)
public:
PaintEventOptions(
    IGraphics^ Graphics,
    RectangleF ClipRectangle
)
new :
        Graphics : IGraphics *
        ClipRectangle : RectangleF -> PaintEventOptions

Parameters

Graphics
Type: SMath.DrawingIGraphics
ClipRectangle
Type: System.DrawingRectangleF
See Also

Reference

PaintEventOptions Class
SMath.Manager Namespace


PaintEventOptions Properties

The PaintEventOptions type exposes the following members.

Properties
 | Name | Description
Public property | ClipRectangle |
Public property | Graphics |
Top
See Also

Reference

PaintEventOptions Class
SMath.Manager Namespace


PaintEventOptions.ClipRectangle Property

PaintEventOptionsClipRectangle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RectangleF ClipRectangle { get; set; }
Public Property ClipRectangle As RectangleF
    Get
    Set
public:
property RectangleF ClipRectangle {
    RectangleF get ();
    void set (RectangleF value);
}
member ClipRectangle : RectangleF with get, set

Property Value

Type: RectangleF
See Also

Reference

PaintEventOptions Class
SMath.Manager Namespace


PaintEventOptions.Graphics Property

PaintEventOptionsGraphics Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IGraphics Graphics { get; set; }
Public Property Graphics As IGraphics
    Get
    Set
public:
property IGraphics^ Graphics {
    IGraphics^ get ();
    void set (IGraphics^ value);
}
member Graphics : IGraphics with get, set

Property Value

Type: IGraphics
See Also

Reference

PaintEventOptions Class
SMath.Manager Namespace


PaintEventOptions Methods

The PaintEventOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PaintEventOptions Class
SMath.Manager Namespace


ParallelList(T) Class

ParallelListT Class

Inheritance Hierarchy
SystemObject
SMath.ManagerParallelListT

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ParallelList<T>

Public Class ParallelList(Of T)
generic<typename T>
public ref class ParallelList
type ParallelList<'T> =  class end

Type Parameters

T

The ParallelListT type exposes the following members.

Constructors
 | Name | Description
Public method | ParallelListT | Initializes a new instance of the ParallelListT class
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


ParallelList(T) Constructor

ParallelListT Constructor

Initializes a new instance of the ParallelListT class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ParallelList()
Public Sub New
public:
ParallelList()
new : unit -> ParallelList
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


ParallelList(T) Methods

ParallelListT Methods

The ParallelListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | AddRange |
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


ParallelList(T).Add Method

ParallelListTAdd Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Add(
    T value
)
Public Sub Add (
    value As T
)
public:
void Add(
    T value
)
member Add :
        value : 'T -> unit

Parameters

value
Type: T
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


ParallelList(T).AddRange Method

ParallelListTAddRange Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddRange(
    IEnumerable<T> value
)
Public Sub AddRange (
    value As IEnumerable(Of T)
)
public:
void AddRange(
    IEnumerable<T>^ value
)
member AddRange :
        value : IEnumerable<'T> -> unit

Parameters

value
Type: System.Collections.GenericIEnumerableT
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


ParallelList(T).Clear Method

ParallelListTClear Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


ParallelList(T).ToArray Method

ParallelListTToArray Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public T[] ToArray()
Public Function ToArray As T()
public:
array<T>^ ToArray()
member ToArray : unit -> 'T[]

Return Value

Type: T
See Also

Reference

ParallelListT Class
SMath.Manager Namespace


Parallels Class

Inheritance Hierarchy
SystemObject
SMath.ManagerParallels

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Parallels
Public Class Parallels
public ref class Parallels
type Parallels =  class end

The Parallels type exposes the following members.

Constructors
 | Name | Description
Public method | Parallels | Initializes a new instance of the Parallels class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | ForEachT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


Parallels Constructor

Initializes a new instance of the Parallels class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Parallels()
Public Sub New
public:
Parallels()
new : unit -> Parallels
See Also

Reference

Parallels Class
SMath.Manager Namespace


Parallels Methods

The Parallels type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | ForEachT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Parallels Class
SMath.Manager Namespace


Parallels.ForEach(T) Method

ParallelsForEachT Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ForEach<T>(
    IEnumerable<T> items,
    Action<T> action
)

Public Shared Sub ForEach(Of T) (
    items As IEnumerable(Of T),
    action As Action(Of T)
)
public:
generic<typename T>
static void ForEach(
    IEnumerable<T>^ items,
    Action<T>^ action
)
static member ForEach :
        items : IEnumerable<'T> *
        action : Action<'T> -> unit

Parameters

items
Type: System.Collections.GenericIEnumerableT
action
Type: SystemActionT

Type Parameters

T
See Also

Reference

Parallels Class
SMath.Manager Namespace


PluginDependencyAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
SMath.ManagerPluginDependencyAttribute

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PluginDependencyAttribute : Attribute
Public Class PluginDependencyAttribute
    Inherits Attribute
public ref class PluginDependencyAttribute : public Attribute
type PluginDependencyAttribute =
    class
        inherit Attribute
    end

The PluginDependencyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PluginDependencyAttribute | Initializes a new instance of the PluginDependencyAttribute class
Top
Properties
 | Name | Description
Public property | ContentType |
Public property | Name |
Public property | Path |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | Maps a set of names to a corresponding set of dispatch identifiers. (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | Retrieves the type information for an object, which can be used to get the type information for an interface. (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | Retrieves the number of type information interfaces that an object provides (either 0 or 1). (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | Provides access to properties and methods exposed by an object. (Inherited from Attribute.)
Top
See Also

Reference

SMath.Manager Namespace


PluginDependencyAttribute Constructor

Initializes a new instance of the PluginDependencyAttribute class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginDependencyAttribute(
    string name,
    string path
)
Public Sub New (
    name As String,
    path As String
)
public:
PluginDependencyAttribute(
    String^ name,
    String^ path
)
new :
        name : string *
        path : string -> PluginDependencyAttribute

Parameters

name
Type: SystemString
path
Type: SystemString
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginDependencyAttribute Properties

The PluginDependencyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ContentType |
Public property | Name |
Public property | Path |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginDependencyAttribute.ContentType Property

PluginDependencyAttributeContentType Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string ContentType { get; }
Public ReadOnly Property ContentType As String
    Get
public:
property String^ ContentType {
    String^ get ();
}
member ContentType : string with get

Property Value

Type: String
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginDependencyAttribute.Name Property

PluginDependencyAttributeName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginDependencyAttribute.Path Property

PluginDependencyAttributePath Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginDependencyAttribute Methods

The PluginDependencyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | Maps a set of names to a corresponding set of dispatch identifiers. (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | Retrieves the type information for an object, which can be used to get the type information for an interface. (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | Retrieves the number of type information interfaces that an object provides (either 0 or 1). (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | Provides access to properties and methods exposed by an object. (Inherited from Attribute.)
Top
See Also

Reference

PluginDependencyAttribute Class
SMath.Manager Namespace


PluginInfo Class

Plug-in information.
Inheritance Hierarchy
SystemObject
SMath.ManagerPluginInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PluginInfo : IComparable
Public NotInheritable Class PluginInfo
    Implements IComparable
public ref class PluginInfo sealed : IComparable
[<SealedAttribute>]
type PluginInfo =
    class
        interface IComparable
    end

The PluginInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PluginInfo | Constructor of the Plug-in Information class.
Top
Properties
 | Name | Description
Public property | Config | Full path to the configuration file for the plug-in (optional).
Public property | Enabled | Defines if the Plug-in is used by SMath Studio.
Public property | Info | Plug-in detailed information from assembly.
Public property | Location | Full name of the Plug-in main assembly file.
Public property | Plugin | Plug-in implementation.
Public property | References | List of referenced assemblies existing in the same folder.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

SMath.Manager Namespace


PluginInfo Constructor

Constructor of the Plug-in Information class.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginInfo(
    IPlugin plugin,
    AssemblyInfo info,
    string location,
    List<string> references
)
Public Sub New (
    plugin As IPlugin,
    info As AssemblyInfo,
    location As String,
    references As List(Of String)
)
public:
PluginInfo(
    IPlugin^ plugin,
    AssemblyInfo info,
    String^ location,
    List<String^>^ references
)
new :
        plugin : IPlugin *
        info : AssemblyInfo *
        location : string *
        references : List<string> -> PluginInfo

Parameters

plugin
Type: SMath.ManagerIPlugin
Plug-in implementation.
info
Type: SMath.ManagerAssemblyInfo
Plug-in detailed information from assembly.
location
Type: SystemString
Full name of the Plug-in main assembly file.
references
Type: System.Collections.GenericListString
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo Properties

The PluginInfo type exposes the following members.

Properties
 | Name | Description
Public property | Config | Full path to the configuration file for the plug-in (optional).
Public property | Enabled | Defines if the Plug-in is used by SMath Studio.
Public property | Info | Plug-in detailed information from assembly.
Public property | Location | Full name of the Plug-in main assembly file.
Public property | Plugin | Plug-in implementation.
Public property | References | List of referenced assemblies existing in the same folder.
Top
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.Config Property

PluginInfoConfig Property

Full path to the configuration file for the plug-in (optional).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Property Value

Type: String
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.Enabled Property

PluginInfoEnabled Property

Defines if the Plug-in is used by SMath Studio.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.Info Property

PluginInfoInfo Property

Plug-in detailed information from assembly.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public AssemblyInfo Info { get; }
Public ReadOnly Property Info As AssemblyInfo
    Get
public:
property AssemblyInfo Info {
    AssemblyInfo get ();
}
member Info : AssemblyInfo with get

Property Value

Type: AssemblyInfo
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.Location Property

PluginInfoLocation Property

Full name of the Plug-in main assembly file.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get
public:
property String^ Location {
    String^ get ();
}
member Location : string with get

Property Value

Type: String
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.Plugin Property

PluginInfoPlugin Property

Plug-in implementation.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IPlugin Plugin { get; }
Public ReadOnly Property Plugin As IPlugin
    Get
public:
property IPlugin^ Plugin {
    IPlugin^ get ();
}
member Plugin : IPlugin with get

Property Value

Type: IPlugin
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.References Property

PluginInfoReferences Property

List of referenced assemblies existing in the same folder.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> References { get; }
Public ReadOnly Property References As List(Of String)
    Get
public:
property List<String^>^ References {
    List<String^>^ get ();
}
member References : List<string> with get

Property Value

Type: ListString
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo Methods

The PluginInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IComparableCompareTo |
Top
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.IComparable.CompareTo Method

PluginInfoIComparableCompareTo Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
int IComparable.CompareTo(
    Object obj
)
Private Function CompareTo (
    obj As Object
) As Integer Implements IComparable.CompareTo
private:
virtual int CompareTo(
    Object^ obj
) sealed = IComparable::CompareTo
private abstract CompareTo :
        obj : Object -> int
private override CompareTo :
        obj : Object -> int

Parameters

obj
Type: SystemObject

Return Value

Type: Int32

Implements

IComparableCompareTo(Object)
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInfo.ToString Method

PluginInfoToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

PluginInfo Class
SMath.Manager Namespace


PluginInitialMeta Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPluginInitialMeta

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PluginInitialMeta
Public Class PluginInitialMeta
public ref class PluginInitialMeta
type PluginInitialMeta =  class end

The PluginInitialMeta type exposes the following members.

Constructors
 | Name | Description
Public method | PluginInitialMeta(String, String) | Initializes a new instance of the PluginInitialMeta class
Public method | PluginInitialMeta(String, String, Int32, String, String, Boolean) | Initializes a new instance of the PluginInitialMeta class
Top
Properties
 | Name | Description
Public property | Config |
Public property | Disabled |
Public property | Guid |
Public property | Path |
Public property | SortOrder |
Public property | Version |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

SMath.Manager Namespace


PluginInitialMeta Constructor

Overload List
 | Name | Description
Public method | PluginInitialMeta(String, String) | Initializes a new instance of the PluginInitialMeta class
Public method | PluginInitialMeta(String, String, Int32, String, String, Boolean) | Initializes a new instance of the PluginInitialMeta class
Top
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta Constructor (String, String)

Initializes a new instance of the PluginInitialMeta class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginInitialMeta(
    string path,
    string config
)
Public Sub New (
    path As String,
    config As String
)
public:
PluginInitialMeta(
    String^ path,
    String^ config
)
new :
        path : string *
        config : string -> PluginInitialMeta

Parameters

path
Type: SystemString
config
Type: SystemString
See Also

Reference

PluginInitialMeta Class
PluginInitialMeta Overload
SMath.Manager Namespace


PluginInitialMeta Constructor (String, String, Int32, String, String, Boolean)

Initializes a new instance of the PluginInitialMeta class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginInitialMeta(
    string path,
    string config,
    int sortOrder,
    string version,
    string guid,
    bool disabled
)
Public Sub New (
    path As String,
    config As String,
    sortOrder As Integer,
    version As String,
    guid As String,
    disabled As Boolean
)
public:
PluginInitialMeta(
    String^ path,
    String^ config,
    int sortOrder,
    String^ version,
    String^ guid,
    bool disabled
)
new :
        path : string *
        config : string *
        sortOrder : int *
        version : string *
        guid : string *
        disabled : bool -> PluginInitialMeta

Parameters

path
Type: SystemString
config
Type: SystemString
sortOrder
Type: SystemInt32
version
Type: SystemString
guid
Type: SystemString
disabled
Type: SystemBoolean
See Also

Reference

PluginInitialMeta Class
PluginInitialMeta Overload
SMath.Manager Namespace


PluginInitialMeta Properties

The PluginInitialMeta type exposes the following members.

Properties
 | Name | Description
Public property | Config |
Public property | Disabled |
Public property | Guid |
Public property | Path |
Public property | SortOrder |
Public property | Version |
Top
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.Config Property

PluginInitialMetaConfig Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Config { get; }
Public ReadOnly Property Config As String
    Get
public:
property String^ Config {
    String^ get ();
}
member Config : string with get

Property Value

Type: String
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.Disabled Property

PluginInitialMetaDisabled Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Disabled { get; }
Public ReadOnly Property Disabled As Boolean
    Get
public:
property bool Disabled {
    bool get ();
}
member Disabled : bool with get

Property Value

Type: Boolean
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.Guid Property

PluginInitialMetaGuid Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; }
Public ReadOnly Property Guid As String
    Get
public:
property String^ Guid {
    String^ get ();
}
member Guid : string with get

Property Value

Type: String
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.Path Property

PluginInitialMetaPath Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.SortOrder Property

PluginInitialMetaSortOrder Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int SortOrder { get; }
Public ReadOnly Property SortOrder As Integer
    Get
public:
property int SortOrder {
    int get ();
}
member SortOrder : int with get

Property Value

Type: Int32
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.Version Property

PluginInitialMetaVersion Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

Type: String
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta Methods

The PluginInitialMeta type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginInitialMeta.ToString Method

PluginInitialMetaToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

PluginInitialMeta Class
SMath.Manager Namespace


PluginsManager Class

Methods to manage Plug-ins.
Inheritance Hierarchy
SystemObject
SMath.ManagerPluginsManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public sealed class PluginsManager
Public NotInheritable Class PluginsManager
public ref class PluginsManager sealed
[<SealedAttribute>]
type PluginsManager =  class end

The PluginsManager type exposes the following members.

Constructors
 | Name | Description
Public method | PluginsManager | Initializes a new instance of the PluginsManager class
Top
Properties
Name | Description
SpecificActiveVersionConfig |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPluginsHash | Gets a hash for currently loaded Plug-ins.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsPlugInAssembly |
 | IsPluginInstalled(Guid) |
 | IsPluginInstalled(Guid, PluginInfo) |
 | Load | Loads all available Plug-ins from the specific directory.
 | LoadBanch |
 | LoadOne(String) | Loads Plug-in from the specific location.
 | LoadOne(PluginInitialMeta) | Loads Plug-in from the specific location.
 | LoadPlugIn |
 | LoadReferencedT |
 | LoadThirdParty |
 | ParsePlugInFile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParsePlugInFile |
 | UpdateConfigFile |
Top
Fields
Name | Description
ActiveVersionConfig |
DefaultDirectoryName |
Top
See Also

Reference

SMath.Manager Namespace


PluginsManager Constructor

Initializes a new instance of the PluginsManager class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginsManager()
Public Sub New
public:
PluginsManager()
new : unit -> PluginsManager
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager Properties

The PluginsManager type exposes the following members.

Properties
Name | Description
SpecificActiveVersionConfig |
Top
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.SpecificActiveVersionConfig Property

PluginsManagerSpecificActiveVersionConfig Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string SpecificActiveVersionConfig { get; }
Public Shared ReadOnly Property SpecificActiveVersionConfig As String
    Get
public:
static property String^ SpecificActiveVersionConfig {
    String^ get ();
}
static member SpecificActiveVersionConfig : string with get

Property Value

Type: String
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager Methods

The PluginsManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPluginsHash | Gets a hash for currently loaded Plug-ins.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsPlugInAssembly |
 | IsPluginInstalled(Guid) |
 | IsPluginInstalled(Guid, PluginInfo) |
 | Load | Loads all available Plug-ins from the specific directory.
 | LoadBanch |
 | LoadOne(String) | Loads Plug-in from the specific location.
 | LoadOne(PluginInitialMeta) | Loads Plug-in from the specific location.
 | LoadPlugIn |
 | LoadReferencedT |
 | LoadThirdParty |
 | ParsePlugInFile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParsePlugInFile |
 | UpdateConfigFile |
Top
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.GetPluginsHash Method

PluginsManagerGetPluginsHash Method

Gets a hash for currently loaded Plug-ins.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetPluginsHash()
Public Shared Function GetPluginsHash As String
public:
static String^ GetPluginsHash()
static member GetPluginsHash : unit -> string

Return Value

Type: String
Returns a hash for currently loaded Plug-ins.
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.IsPlugInAssembly Method

PluginsManagerIsPlugInAssembly Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPlugInAssembly(
    string fileName,
    string expectedGuid,
    out string resultGuid
)
Public Shared Function IsPlugInAssembly (
    fileName As String,
    expectedGuid As String,
    <OutAttribute> ByRef resultGuid As String
) As Boolean
public:
static bool IsPlugInAssembly(
    String^ fileName,
    String^ expectedGuid,
    [OutAttribute] String^% resultGuid
)
static member IsPlugInAssembly :
        fileName : string *
        expectedGuid : string *
        resultGuid : string byref -> bool

Parameters

fileName
Type: SystemString
expectedGuid
Type: SystemString
resultGuid
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.IsPluginInstalled Method

PluginsManagerIsPluginInstalled Method

Overload List
Name | Description
IsPluginInstalled(Guid) |
IsPluginInstalled(Guid, PluginInfo) |
Top
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.IsPluginInstalled Method (Guid)

PluginsManagerIsPluginInstalled Method (Guid)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPluginInstalled(
    Guid guid
)
Public Shared Function IsPluginInstalled (
    guid As Guid
) As Boolean
public:
static bool IsPluginInstalled(
    Guid guid
)
static member IsPluginInstalled :
        guid : Guid -> bool

Parameters

guid
Type: SystemGuid

Return Value

Type: Boolean
See Also

Reference

PluginsManager Class
IsPluginInstalled Overload
SMath.Manager Namespace


PluginsManager.IsPluginInstalled Method (Guid, PluginInfo)

PluginsManagerIsPluginInstalled Method (Guid, PluginInfo)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPluginInstalled(
    Guid guid,
    out PluginInfo info
)
Public Shared Function IsPluginInstalled (
    guid As Guid,
    <OutAttribute> ByRef info As PluginInfo
) As Boolean
public:
static bool IsPluginInstalled(
    Guid guid,
    [OutAttribute] PluginInfo^% info
)
static member IsPluginInstalled :
        guid : Guid *
        info : PluginInfo byref -> bool

Parameters

guid
Type: SystemGuid
info
Type: SMath.ManagerPluginInfo

Return Value

Type: Boolean
See Also

Reference

PluginsManager Class
IsPluginInstalled Overload
SMath.Manager Namespace


PluginsManager.Load Method

PluginsManagerLoad Method

Loads all available Plug-ins from the specific directory.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Load(
    string path,
    bool thirdParty,
    ref Dictionary<string, PluginInitialMeta> paths
)
Public Shared Sub Load (
    path As String,
    thirdParty As Boolean,
    ByRef paths As Dictionary(Of String, PluginInitialMeta)
)
public:
static void Load(
    String^ path,
    bool thirdParty,
    Dictionary<String^, PluginInitialMeta^>^% paths
)
static member Load :
        path : string *
        thirdParty : bool *
        paths : Dictionary<string, PluginInitialMeta> byref -> unit

Parameters

path
Type: SystemString
Path to the plug-ins.
thirdParty
Type: SystemBoolean
paths
Type: System.Collections.GenericDictionaryString, PluginInitialMeta

Return Value

Type:
A list of plug-ins found.
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.LoadBanch Method

PluginsManagerLoadBanch Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadBanch(
    SessionProfile sessionProfile,
    PluginsStatusEventHandler progress,
    Dictionary<string, PluginInitialMeta> initPaths,
    ref List<PluginInfo> lPlugins
)
Public Shared Sub LoadBanch (
    sessionProfile As SessionProfile,
    progress As PluginsStatusEventHandler,
    initPaths As Dictionary(Of String, PluginInitialMeta),
    ByRef lPlugins As List(Of PluginInfo)
)
public:
static void LoadBanch(
    SessionProfile^ sessionProfile,
    PluginsStatusEventHandler^ progress,
    Dictionary<String^, PluginInitialMeta^>^ initPaths,
    List<PluginInfo^>^% lPlugins
)
static member LoadBanch :
        sessionProfile : SessionProfile *
        progress : PluginsStatusEventHandler *
        initPaths : Dictionary<string, PluginInitialMeta> *
        lPlugins : List<PluginInfo> byref -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
progress
Type: SMath.ManagerPluginsStatusEventHandler
initPaths
Type: System.Collections.GenericDictionaryString, PluginInitialMeta
lPlugins
Type: System.Collections.GenericListPluginInfo
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.LoadOne Method

PluginsManagerLoadOne Method

Overload List
Name | Description
LoadOne(String) | Loads Plug-in from the specific location.
LoadOne(PluginInitialMeta) | Loads Plug-in from the specific location.
Top
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.LoadOne Method (String)

PluginsManagerLoadOne Method (String)

Loads Plug-in from the specific location.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<PluginInfo> LoadOne(
    string fileName
)
Public Shared Function LoadOne (
    fileName As String
) As IEnumerable(Of PluginInfo)
public:
static IEnumerable<PluginInfo^>^ LoadOne(
    String^ fileName
)
static member LoadOne :
        fileName : string -> IEnumerable<PluginInfo>

Parameters

fileName
Type: SystemString
Full file name.

Return Value

Type: IEnumerablePluginInfo
A list of plug-ins found.
See Also

Reference

PluginsManager Class
LoadOne Overload
SMath.Manager Namespace


PluginsManager.LoadOne Method (PluginInitialMeta)

PluginsManagerLoadOne Method (PluginInitialMeta)

Loads Plug-in from the specific location.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<PluginInfo> LoadOne(
    PluginInitialMeta meta
)
Public Shared Function LoadOne (
    meta As PluginInitialMeta
) As IEnumerable(Of PluginInfo)
public:
static IEnumerable<PluginInfo^>^ LoadOne(
    PluginInitialMeta^ meta
)
static member LoadOne :
        meta : PluginInitialMeta -> IEnumerable<PluginInfo>

Parameters

meta
Type: SMath.ManagerPluginInitialMeta
Meta data for plug-in to load.

Return Value

Type: IEnumerablePluginInfo
A list of plug-ins found.
See Also

Reference

PluginsManager Class
LoadOne Overload
SMath.Manager Namespace


PluginsManager.LoadPlugIn Method

PluginsManagerLoadPlugIn Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<PluginInfo> LoadPlugIn(
    Assembly asm,
    string fileName,
    List<string> references,
    bool doPreload
)
Public Shared Function LoadPlugIn (
    asm As Assembly,
    fileName As String,
    references As List(Of String),
    doPreload As Boolean
) As List(Of PluginInfo)
public:
static List<PluginInfo^>^ LoadPlugIn(
    Assembly^ asm,
    String^ fileName,
    List<String^>^ references,
    bool doPreload
)
static member LoadPlugIn :
        asm : Assembly *
        fileName : string *
        references : List<string> *
        doPreload : bool -> List<PluginInfo>

Parameters

asm
Type: System.ReflectionAssembly
fileName
Type: SystemString
references
Type: System.Collections.GenericListString
doPreload
Type: SystemBoolean

Return Value

Type: ListPluginInfo
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.LoadReferenced(T) Method

PluginsManagerLoadReferencedT Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadReferenced<T>()
where T : new(), IPlugin

Public Shared Sub LoadReferenced(Of T As {New, IPlugin})
public:
generic<typename T>
where T : gcnew(), IPlugin
static void LoadReferenced()
static member LoadReferenced : unit -> unit  when 'T : new() and IPlugin

Type Parameters

T
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.LoadThirdParty Method

PluginsManagerLoadThirdParty Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void LoadThirdParty(
    string path,
    ref Dictionary<string, PluginInitialMeta> paths
)
Public Shared Sub LoadThirdParty (
    path As String,
    ByRef paths As Dictionary(Of String, PluginInitialMeta)
)
public:
static void LoadThirdParty(
    String^ path,
    Dictionary<String^, PluginInitialMeta^>^% paths
)
static member LoadThirdParty :
        path : string *
        paths : Dictionary<string, PluginInitialMeta> byref -> unit

Parameters

path
Type: SystemString
paths
Type: System.Collections.GenericDictionaryString, PluginInitialMeta
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.ParsePlugInFile Method

PluginsManagerParsePlugInFile Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool ParsePlugInFile(
    string fileName,
    string guid,
    string currentVersion,
    string config,
    int state,
    Dictionary<string, PluginInitialMeta> paths
)
Public Shared Function ParsePlugInFile (
    fileName As String,
    guid As String,
    currentVersion As String,
    config As String,
    state As Integer,
    paths As Dictionary(Of String, PluginInitialMeta)
) As Boolean
public:
static bool ParsePlugInFile(
    String^ fileName,
    String^ guid,
    String^ currentVersion,
    String^ config,
    int state,
    Dictionary<String^, PluginInitialMeta^>^ paths
)
static member ParsePlugInFile :
        fileName : string *
        guid : string *
        currentVersion : string *
        config : string *
        state : int *
        paths : Dictionary<string, PluginInitialMeta> -> bool

Parameters

fileName
Type: SystemString
guid
Type: SystemString
currentVersion
Type: SystemString
config
Type: SystemString
state
Type: SystemInt32
paths
Type: System.Collections.GenericDictionaryString, PluginInitialMeta

Return Value

Type: Boolean
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.TryParsePlugInFile Method

PluginsManagerTryParsePlugInFile Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryParsePlugInFile(
    string fileName,
    string guid,
    string currentVersion,
    string config,
    int state,
    Dictionary<string, PluginInitialMeta> paths
)
Public Shared Function TryParsePlugInFile (
    fileName As String,
    guid As String,
    currentVersion As String,
    config As String,
    state As Integer,
    paths As Dictionary(Of String, PluginInitialMeta)
) As Boolean
public:
static bool TryParsePlugInFile(
    String^ fileName,
    String^ guid,
    String^ currentVersion,
    String^ config,
    int state,
    Dictionary<String^, PluginInitialMeta^>^ paths
)
static member TryParsePlugInFile :
        fileName : string *
        guid : string *
        currentVersion : string *
        config : string *
        state : int *
        paths : Dictionary<string, PluginInitialMeta> -> bool

Parameters

fileName
Type: SystemString
guid
Type: SystemString
currentVersion
Type: SystemString
config
Type: SystemString
state
Type: SystemInt32
paths
Type: System.Collections.GenericDictionaryString, PluginInitialMeta

Return Value

Type: Boolean
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.UpdateConfigFile Method

PluginsManagerUpdateConfigFile Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string UpdateConfigFile(
    string dir,
    string version,
    string fileName,
    PluginState state
)
Public Shared Function UpdateConfigFile (
    dir As String,
    version As String,
    fileName As String,
    state As PluginState
) As String
public:
static String^ UpdateConfigFile(
    String^ dir,
    String^ version,
    String^ fileName,
    PluginState state
)
static member UpdateConfigFile :
        dir : string *
        version : string *
        fileName : string *
        state : PluginState -> string

Parameters

dir
Type: SystemString
version
Type: SystemString
fileName
Type: SystemString
state
Type: SMath.ManagerPluginState

Return Value

Type: String
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager Fields

The PluginsManager type exposes the following members.

Fields
Name | Description
ActiveVersionConfig |
DefaultDirectoryName |
Top
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.ActiveVersionConfig Field

PluginsManagerActiveVersionConfig Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ActiveVersionConfig = "config.ini"
Public Const ActiveVersionConfig As String = "config.ini"
public:
literal String^ ActiveVersionConfig = "config.ini"
static val mutable ActiveVersionConfig: string

Field Value

Type: String
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsManager.DefaultDirectoryName Field

PluginsManagerDefaultDirectoryName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DefaultDirectoryName = "plugins"
Public Const DefaultDirectoryName As String = "plugins"
public:
literal String^ DefaultDirectoryName = "plugins"
static val mutable DefaultDirectoryName: string

Field Value

Type: String
See Also

Reference

PluginsManager Class
SMath.Manager Namespace


PluginsRequestEventHandler Delegate

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void PluginsRequestEventHandler(
    ActionContext context
)
Public Delegate Sub PluginsRequestEventHandler (
    context As ActionContext
)
public delegate void PluginsRequestEventHandler(
    ActionContext^ context
)
type PluginsRequestEventHandler =
    delegate of
        context : ActionContext -> unit

Parameters

context
Type: SMath.ManagerActionContext
See Also

Reference

SMath.Manager Namespace


PluginsStatusEventHandler Delegate

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void PluginsStatusEventHandler(
    SessionProfile sessionProfile,
    int value,
    int count,
    string message
)
Public Delegate Sub PluginsStatusEventHandler (
    sessionProfile As SessionProfile,
    value As Integer,
    count As Integer,
    message As String
)
public delegate void PluginsStatusEventHandler(
    SessionProfile^ sessionProfile,
    int value,
    int count,
    String^ message
)
type PluginsStatusEventHandler =
    delegate of
        sessionProfile : SessionProfile *
        value : int *
        count : int *
        message : string -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SystemInt32
count
Type: SystemInt32
message
Type: SystemString
See Also

Reference

SMath.Manager Namespace


PluginState Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum PluginState
Public Enumeration PluginState
public enum class PluginState
type PluginState
Members
Member name | Value | Description
Installed | 0 |
Removed | 1 |
Disabled | 2 |
See Also

Reference

SMath.Manager Namespace


PrimitiveInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPrimitiveInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class PrimitiveInfo
Public Class PrimitiveInfo
public ref class PrimitiveInfo
type PrimitiveInfo =  class end

The PrimitiveInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PrimitiveInfo | Initializes a new instance of the PrimitiveInfo class
Top
Properties
 | Name | Description
Public property | pInfo |
Public property | tInfo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PrimitiveInfo Constructor

Initializes a new instance of the PrimitiveInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PrimitiveInfo(
    PluginInfo pInfo,
    TermInfo tInfo
)
Public Sub New (
    pInfo As PluginInfo,
    tInfo As TermInfo
)
public:
PrimitiveInfo(
    PluginInfo^ pInfo,
    TermInfo^ tInfo
)
new :
        pInfo : PluginInfo *
        tInfo : TermInfo -> PrimitiveInfo

Parameters

pInfo
Type: SMath.ManagerPluginInfo
tInfo
Type: SMath.ManagerTermInfo
See Also

Reference

PrimitiveInfo Class
SMath.Manager Namespace


PrimitiveInfo Properties

The PrimitiveInfo type exposes the following members.

Properties
 | Name | Description
Public property | pInfo |
Public property | tInfo |
Top
See Also

Reference

PrimitiveInfo Class
SMath.Manager Namespace


PrimitiveInfo.pInfo Property

PrimitiveInfopInfo Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PluginInfo pInfo { get; set; }
Public Property pInfo As PluginInfo
    Get
    Set
public:
property PluginInfo^ pInfo {
    PluginInfo^ get ();
    void set (PluginInfo^ value);
}
member pInfo : PluginInfo with get, set

Property Value

Type: PluginInfo
See Also

Reference

PrimitiveInfo Class
SMath.Manager Namespace


PrimitiveInfo.tInfo Property

PrimitiveInfotInfo Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo tInfo { get; set; }
Public Property tInfo As TermInfo
    Get
    Set
public:
property TermInfo^ tInfo {
    TermInfo^ get ();
    void set (TermInfo^ value);
}
member tInfo : TermInfo with get, set

Property Value

Type: TermInfo
See Also

Reference

PrimitiveInfo Class
SMath.Manager Namespace


PrimitiveInfo Methods

The PrimitiveInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PrimitiveInfo Class
SMath.Manager Namespace


PrimitivesCollection Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPrimitivesCollection

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class PrimitivesCollection
Public MustInherit Class PrimitivesCollection
public ref class PrimitivesCollection abstract
[<AbstractClassAttribute>]
type PrimitivesCollection =  class end

The PrimitivesCollection type exposes the following members.

Constructors
 | Name | Description
Protected method | PrimitivesCollection | Initializes a new instance of the PrimitivesCollection class
Top
Methods
 | Name | Description
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, Boolean) | Tries to find plug-in by specified primitive.
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, IEvaluationActionContext, Boolean) | Tries to find plug-in by specified primitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsHandled |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets state of the object instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


PrimitivesCollection Constructor

Initializes a new instance of the PrimitivesCollection class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected PrimitivesCollection()
Protected Sub New
protected:
PrimitivesCollection()
new : unit -> PrimitivesCollection
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesCollection Methods

The PrimitivesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, Boolean) | Tries to find plug-in by specified primitive.
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, IEvaluationActionContext, Boolean) | Tries to find plug-in by specified primitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsHandled |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets state of the object instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesCollection.Contains Method

PrimitivesCollectionContains Method

Overload List
 | Name | Description
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, Boolean) | Tries to find plug-in by specified primitive.
Public method | Contains(SessionProfile, IPrimitive, PluginInfo, TermInfo, IEvaluationActionContext, Boolean) | Tries to find plug-in by specified primitive.
Top
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesCollection.Contains Method (SessionProfile, IPrimitive, PluginInfo, TermInfo, Boolean)

PrimitivesCollectionContains Method (SessionProfile, IPrimitive, PluginInfo, TermInfo, Boolean)

Tries to find plug-in by specified primitive.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    SessionProfile sessionProfile,
    IPrimitive value,
    out PluginInfo pluginInfo,
    out TermInfo termInfo,
    bool standard = true
)
Public Function Contains (
    sessionProfile As SessionProfile,
    value As IPrimitive,
    <OutAttribute> ByRef pluginInfo As PluginInfo,
    <OutAttribute> ByRef termInfo As TermInfo,
    Optional standard As Boolean = true
) As Boolean
public:
bool Contains(
    SessionProfile^ sessionProfile,
    IPrimitive^ value,
    [OutAttribute] PluginInfo^% pluginInfo,
    [OutAttribute] TermInfo^% termInfo,
    bool standard = true
)
member Contains :
        sessionProfile : SessionProfile *
        value : IPrimitive *
        pluginInfo : PluginInfo byref *
        termInfo : TermInfo byref *
        ?standard : bool
(* Defaults:
        let _standard = defaultArg standard true
*)
-> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SMath.ManagerIPrimitive
Primitive to search plug-in for.
pluginInfo
Type: SMath.ManagerPluginInfo
Plug-in which allows to handle specified Term calculation.
termInfo
Type: SMath.ManagerTermInfo
Term related information.
standard (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
Return plug-in to use for handling calculation of the Term.
See Also

Reference

PrimitivesCollection Class
Contains Overload
SMath.Manager Namespace


PrimitivesCollection.Contains Method (SessionProfile, IPrimitive, PluginInfo, TermInfo, IEvaluationActionContext, Boolean)

PrimitivesCollectionContains Method (SessionProfile, IPrimitive, PluginInfo, TermInfo, IEvaluationActionContext, Boolean)

Tries to find plug-in by specified primitive.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract bool Contains(
    SessionProfile sessionProfile,
    IPrimitive value,
    out PluginInfo pluginInfo,
    out TermInfo termInfo,
    IEvaluationActionContext ctx,
    bool standard = true
)
Public MustOverride Function Contains (
    sessionProfile As SessionProfile,
    value As IPrimitive,
    <OutAttribute> ByRef pluginInfo As PluginInfo,
    <OutAttribute> ByRef termInfo As TermInfo,
    ctx As IEvaluationActionContext,
    Optional standard As Boolean = true
) As Boolean
public:
virtual bool Contains(
    SessionProfile^ sessionProfile,
    IPrimitive^ value,
    [OutAttribute] PluginInfo^% pluginInfo,
    [OutAttribute] TermInfo^% termInfo,
    IEvaluationActionContext^ ctx,
    bool standard = true
) abstract
abstract Contains :
        sessionProfile : SessionProfile *
        value : IPrimitive *
        pluginInfo : PluginInfo byref *
        termInfo : TermInfo byref *
        ctx : IEvaluationActionContext *
        ?standard : bool
(* Defaults:
        let _standard = defaultArg standard true
*)
-> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SMath.ManagerIPrimitive
Primitive to search plug-in for.
pluginInfo
Type: SMath.ManagerPluginInfo
Plug-in which allows to handle specified Term calculation.
termInfo
Type: SMath.ManagerTermInfo
Term related information.
ctx
Type: SMath.ManagerIEvaluationActionContext
Context of the evaluation action.
standard (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
Return plug-in to use for handling calculation of the Term.
See Also

Reference

PrimitivesCollection Class
Contains Overload
SMath.Manager Namespace


PrimitivesCollection.GetEnumerator Method

PrimitivesCollectionGetEnumerator Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract IEnumerator<KeyValuePair<TermInfo, PluginInfo>> GetEnumerator(
    bool standard,
    TermType type,
    SessionProfile sessionProfile
)
Public MustOverride Function GetEnumerator (
    standard As Boolean,
    type As TermType,
    sessionProfile As SessionProfile
) As IEnumerator(Of KeyValuePair(Of TermInfo, PluginInfo))
public:
virtual IEnumerator<KeyValuePair<TermInfo^, PluginInfo^>>^ GetEnumerator(
    bool standard,
    TermType type,
    SessionProfile^ sessionProfile
) abstract
abstract GetEnumerator :
        standard : bool *
        type : TermType *
        sessionProfile : SessionProfile -> IEnumerator<KeyValuePair<TermInfo, PluginInfo>>

Parameters

standard
Type: SystemBoolean
type
Type: SMath.ManagerTermType
sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: IEnumeratorKeyValuePairTermInfo, PluginInfo
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesCollection.IsHandled Method

PrimitivesCollectionIsHandled Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsHandled(
    SessionProfile sessionProfile,
    Entry value,
    out PluginInfo pluginInfo,
    IEvaluationActionContext ctx,
    bool legacyCheck,
    bool standard = true
)
Public Function IsHandled (
    sessionProfile As SessionProfile,
    value As Entry,
    <OutAttribute> ByRef pluginInfo As PluginInfo,
    ctx As IEvaluationActionContext,
    legacyCheck As Boolean,
    Optional standard As Boolean = true
) As Boolean
public:
bool IsHandled(
    SessionProfile^ sessionProfile,
    Entry^ value,
    [OutAttribute] PluginInfo^% pluginInfo,
    IEvaluationActionContext^ ctx,
    bool legacyCheck,
    bool standard = true
)
member IsHandled :
        sessionProfile : SessionProfile *
        value : Entry *
        pluginInfo : PluginInfo byref *
        ctx : IEvaluationActionContext *
        legacyCheck : bool *
        ?standard : bool
(* Defaults:
        let _standard = defaultArg standard true
*)
-> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SMath.ManagerEntry
pluginInfo
Type: SMath.ManagerPluginInfo
ctx
Type: SMath.ManagerIEvaluationActionContext
legacyCheck
Type: SystemBoolean
standard (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesCollection.Reset Method

PrimitivesCollectionReset Method

Resets state of the object instance.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract void Reset()
Public MustOverride Sub Reset
public:
virtual void Reset() abstract
abstract Reset : unit -> unit
See Also

Reference

PrimitivesCollection Class
SMath.Manager Namespace


PrimitivesManager Class

Inheritance Hierarchy
SystemObject
SMath.ManagerPrimitivesManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class PrimitivesManager
Public NotInheritable Class PrimitivesManager
public ref class PrimitivesManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PrimitivesManager =  class end

The PrimitivesManager type exposes the following members.

Methods
Name | Description
Dispose |
GetPlugInPrimitives |
LoadT | Retrieved all Evaluation plug-ins implements specified interface.
LoadBuiltIn |
Reset | Reset all loaded Evaluation plug-ins for future usage.Сбросить все загруженные Evaluation дополнения для последующего использования.
Top
See Also

Reference

SMath.Manager Namespace


PrimitivesManager Methods

The PrimitivesManager type exposes the following members.

Methods
Name | Description
Dispose |
GetPlugInPrimitives |
LoadT | Retrieved all Evaluation plug-ins implements specified interface.
LoadBuiltIn |
Reset | Reset all loaded Evaluation plug-ins for future usage.Сбросить все загруженные Evaluation дополнения для последующего использования.
Top
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


PrimitivesManager.Dispose Method

PrimitivesManagerDispose Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Dispose(
    SessionProfile sessionProfile
)
Public Shared Sub Dispose (
    sessionProfile As SessionProfile
)
public:
static void Dispose(
    SessionProfile^ sessionProfile
)
static member Dispose :
        sessionProfile : SessionProfile -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


PrimitivesManager.GetPlugInPrimitives Method

PrimitivesManagerGetPlugInPrimitives Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<PrimitiveInfo> GetPlugInPrimitives(
    SessionProfile sessionProfile
)
Public Shared Function GetPlugInPrimitives (
    sessionProfile As SessionProfile
) As List(Of PrimitiveInfo)
public:
static List<PrimitiveInfo^>^ GetPlugInPrimitives(
    SessionProfile^ sessionProfile
)
static member GetPlugInPrimitives :
        sessionProfile : SessionProfile -> List<PrimitiveInfo>

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: ListPrimitiveInfo
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


PrimitivesManager.Load(T) Method

PrimitivesManagerLoadT Method

Retrieved all Evaluation plug-ins implements specified interface.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static PrimitivesCollection Load<T>()
where T : class, IPluginHandleEvaluation

Public Shared Function Load(Of T As {Class, IPluginHandleEvaluation}) As PrimitivesCollection
public:
generic<typename T>
where T : ref class, IPluginHandleEvaluation
static PrimitivesCollection^ Load()
static member Load : unit -> PrimitivesCollection  when 'T : not struct and IPluginHandleEvaluation

Type Parameters

T
Interface of Evaluation plug-ins.

Return Value

Type: PrimitivesCollection
Loaded plug-in data.
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


PrimitivesManager.LoadBuiltIn Method

PrimitivesManagerLoadBuiltIn Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static PrimitivesCollection LoadBuiltIn()
Public Shared Function LoadBuiltIn As PrimitivesCollection
public:
static PrimitivesCollection^ LoadBuiltIn()
static member LoadBuiltIn : unit -> PrimitivesCollection

Return Value

Type: PrimitivesCollection
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


PrimitivesManager.Reset Method

PrimitivesManagerReset Method

Reset all loaded Evaluation plug-ins for future usage.Сбросить все загруженные Evaluation дополнения для последующего использования.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Reset()
Public Shared Sub Reset
public:
static void Reset()
static member Reset : unit -> unit
See Also

Reference

PrimitivesManager Class
SMath.Manager Namespace


ProductUrlType Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum ProductUrlType
Public Enumeration ProductUrlType
public enum class ProductUrlType
type ProductUrlType
Members
Member name | Value | Description
HomePage | 0 |
Cloud | 1 |
Pricing | 2 |
License | 3 |
Support | 4 |
Api | 5 |
Activate | 6 |
See Also

Reference

SMath.Manager Namespace


Protection Class

Inheritance Hierarchy
SystemObject
SMath.ManagerProtection

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Protection
Public Class Protection
public ref class Protection
type Protection =  class end

The Protection type exposes the following members.

Constructors
 | Name | Description
Public method | Protection | Initializes a new instance of the Protection class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMachineId |
 | GetMd5 | Get MD5 hash of current executed application.
 | GetMd5(String) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


Protection Constructor

Initializes a new instance of the Protection class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Protection()
Public Sub New
public:
Protection()
new : unit -> Protection
See Also

Reference

Protection Class
SMath.Manager Namespace


Protection Methods

The Protection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMachineId |
 | GetMd5 | Get MD5 hash of current executed application.
 | GetMd5(String) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Protection Class
SMath.Manager Namespace


Protection.GetMachineId Method

ProtectionGetMachineId Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Guid GetMachineId()
Public Shared Function GetMachineId As Guid
public:
static Guid GetMachineId()
static member GetMachineId : unit -> Guid

Return Value

Type: Guid
See Also

Reference

Protection Class
SMath.Manager Namespace


Protection.GetMd5 Method

ProtectionGetMd5 Method

Overload List
Name | Description
GetMd5 | Get MD5 hash of current executed application.
GetMd5(String) |
Top
See Also

Reference

Protection Class
SMath.Manager Namespace


Protection.GetMd5 Method

ProtectionGetMd5 Method

Get MD5 hash of current executed application.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetMd5()
Public Shared Function GetMd5 As String
public:
static String^ GetMd5()
static member GetMd5 : unit -> string

Return Value

Type: String
See Also

Reference

Protection Class
GetMd5 Overload
SMath.Manager Namespace


Protection.GetMd5 Method (String)

ProtectionGetMd5 Method (String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetMd5(
    string input
)
Public Shared Function GetMd5 (
    input As String
) As String
public:
static String^ GetMd5(
    String^ input
)
static member GetMd5 :
        input : string -> string

Parameters

input
Type: SystemString

Return Value

Type: String
See Also

Reference

Protection Class
GetMd5 Overload
SMath.Manager Namespace


RecentPage Class

Inheritance Hierarchy
SystemObject
SMath.ManagerRecentPage

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RecentPage
Public Class RecentPage
public ref class RecentPage
type RecentPage =  class end

The RecentPage type exposes the following members.

Constructors
 | Name | Description
Public method | RecentPage | Initializes a new instance of the RecentPage class
Top
Properties
 | Name | Description
Public property | FullName |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


RecentPage Constructor

Initializes a new instance of the RecentPage class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RecentPage(
    string fullName
)
Public Sub New (
    fullName As String
)
public:
RecentPage(
    String^ fullName
)
new :
        fullName : string -> RecentPage

Parameters

fullName
Type: SystemString
See Also

Reference

RecentPage Class
SMath.Manager Namespace


RecentPage Properties

The RecentPage type exposes the following members.

Properties
 | Name | Description
Public property | FullName |
Public property | Name |
Top
See Also

Reference

RecentPage Class
SMath.Manager Namespace


RecentPage.FullName Property

RecentPageFullName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Property Value

Type: String
See Also

Reference

RecentPage Class
SMath.Manager Namespace


RecentPage.Name Property

RecentPageName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

RecentPage Class
SMath.Manager Namespace


RecentPage Methods

The RecentPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecentPage Class
SMath.Manager Namespace


RunningTitle Class

Inheritance Hierarchy
SystemObject
SMath.ManagerRunningTitle

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RunningTitle
Public Class RunningTitle
public ref class RunningTitle
type RunningTitle =  class end

The RunningTitle type exposes the following members.

Constructors
 | Name | Description
Public method | RunningTitle(RunningTitle) | Initializes a new instance of the RunningTitle class
Public method | RunningTitle(String, Color, TextAlignment) | Initializes a new instance of the RunningTitle class
Top
Properties
 | Name | Description
Public property | Alignment |
Public property | Color |
Public property | Text |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


RunningTitle Constructor

Overload List
 | Name | Description
Public method | RunningTitle(RunningTitle) | Initializes a new instance of the RunningTitle class
Public method | RunningTitle(String, Color, TextAlignment) | Initializes a new instance of the RunningTitle class
Top
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle Constructor (RunningTitle)

Initializes a new instance of the RunningTitle class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RunningTitle(
    RunningTitle runningTitle
)
Public Sub New (
    runningTitle As RunningTitle
)
public:
RunningTitle(
    RunningTitle^ runningTitle
)
new :
        runningTitle : RunningTitle -> RunningTitle

Parameters

runningTitle
Type: SMath.ManagerRunningTitle
See Also

Reference

RunningTitle Class
RunningTitle Overload
SMath.Manager Namespace


RunningTitle Constructor (String, Color, TextAlignment)

Initializes a new instance of the RunningTitle class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RunningTitle(
    string Text,
    Color Color,
    TextAlignment Alignment
)
Public Sub New (
    Text As String,
    Color As Color,
    Alignment As TextAlignment
)
public:
RunningTitle(
    String^ Text,
    Color Color,
    TextAlignment Alignment
)
new :
        Text : string *
        Color : Color *
        Alignment : TextAlignment -> RunningTitle

Parameters

Text
Type: SystemString
Color
Type: System.DrawingColor
Alignment
Type: SMath.ManagerTextAlignment
See Also

Reference

RunningTitle Class
RunningTitle Overload
SMath.Manager Namespace


RunningTitle Properties

The RunningTitle type exposes the following members.

Properties
 | Name | Description
Public property | Alignment |
Public property | Color |
Public property | Text |
Top
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle.Alignment Property

RunningTitleAlignment Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TextAlignment Alignment { get; set; }
Public Property Alignment As TextAlignment
    Get
    Set
public:
property TextAlignment Alignment {
    TextAlignment get ();
    void set (TextAlignment value);
}
member Alignment : TextAlignment with get, set

Property Value

Type: TextAlignment
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle.Color Property

RunningTitleColor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color Color {
    Color get ();
    void set (Color value);
}
member Color : Color with get, set

Property Value

Type: Color
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle.Text Property

RunningTitleText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle Methods

The RunningTitle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle.Equals Method

RunningTitleEquals Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


RunningTitle.GetHashCode Method

RunningTitleGetHashCode Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

RunningTitle Class
SMath.Manager Namespace


SessionOptions Class

Application context options.
Inheritance Hierarchy
SystemObject
SMath.ManagerOptionsCollection
SMath.ManagerSessionOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SessionOptions : OptionsCollection
Public Class SessionOptions
    Inherits OptionsCollection
public ref class SessionOptions : public OptionsCollection
type SessionOptions =
    class
        inherit OptionsCollection
    end

The SessionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SessionOptions | Initializes a new instance of the SessionOptions class
Public method | SessionOptions(CultureInfo) | Initializes a new instance of the SessionOptions class
Top
Properties
 | Name | Description
Public property | ArgumentsSeparator | Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.
Public property | AuthLogin |
 | AUTHLOGIN |
Public property | AuthName |
 | AUTHNAME |
Public property | AuthToken |
 | AUTHTOKEN |
Public property | DecimalPlaces |
Public property | DecimalSymbol | Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.
Public property | ExponentialThreshold |
Public property | FontHeight |
Public property | FontName |
Public property | FooterText |
Public property | HeaderText |
Public property | IntegralAccuracy |
Public property | Item | (Inherited from OptionsCollection.)
Public property | Lang3Letter |
Public property | NamingType |
Public property | OnError |
Public property | PageMargins |
Public property | PaperId |
Public property | PaperOrientation |
Public property | PaperSize |
Public property | PrintAreas |
Public property | PrintGrid |
Public property | PrintSimpleEqualsOnly |
Public property | RedrawRequired |
Public property | RepresentationStyle |
Public property | RoundingMode |
Public property | SignificantDigits |
Public property | SolveFromPoint |
Public property | SolveToPoint |
Public property | TrailingZeros |
Public property | UnitsLang3Letter |
Public property | ViewMode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean | (Inherited from OptionsCollection.)
Public method | GetCollection | (Inherited from OptionsCollection.)
Public method | GetEnumerator | (Inherited from OptionsCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | (Inherited from OptionsCollection.)
Public method | GetSingle | Retrieves a float property. (Inherited from OptionsCollection.)
Public method | GetString | (Inherited from OptionsCollection.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
 | ARGUMENTSSEPARATOR |
 | AUTORECALC |
Protected field | data | (Inherited from OptionsCollection.)
 | DECIMALSYMBOL |
 | DEFAULTINTERACTIVETUTORIAL |
 | DYNAMICASSISTANCE |
 | ENHANCEDGRAPHICS |
 | EXPONENTIALTHRESHOLD |
 | FONTNAME |
 | FONTSIZE |
 | INTEGRAL |
 | LANGUAGE |
 | NUM |
 | ONERRORACTION |
 | OUTPUTUNITSSYSTEM |
 | PAGEFOOTER |
 | PAGEHEADER |
 | PAGEMARGINBOTTOM |
 | PAGEMARGINLEFT |
 | PAGEMARGINRIGHT |
 | PAGEMARGINTOP |
 | PAGEORIENTATION |
 | PAGESIZE |
 | PRINTAREAREGIONS |
 | PRINTEQUALITYSIGN |
 | PRINTGRID |
 | PRINTINGBOUNDS |
 | REPRESENTATION |
 | ROOTSA |
 | ROOTSB |
 | ROUNDING |
 | SESSIONHOST |
 | SESSIONLOGIN |
 | SIGNIFICANTDIGITS |
 | STYLE |
 | TRAILINGZEROS |
 | UNITS |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator | (Inherited from OptionsCollection.)
Top
See Also

Reference

SMath.Manager Namespace


SessionOptions Constructor

Overload List
 | Name | Description
Public method | SessionOptions | Initializes a new instance of the SessionOptions class
Public method | SessionOptions(CultureInfo) | Initializes a new instance of the SessionOptions class
Top
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions Constructor

Initializes a new instance of the SessionOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionOptions()
Public Sub New
public:
SessionOptions()
new : unit -> SessionOptions
See Also

Reference

SessionOptions Class
SessionOptions Overload
SMath.Manager Namespace


SessionOptions Constructor (CultureInfo)

Initializes a new instance of the SessionOptions class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionOptions(
    CultureInfo cultureInfo
)
Public Sub New (
    cultureInfo As CultureInfo
)
public:
SessionOptions(
    CultureInfo^ cultureInfo
)
new :
        cultureInfo : CultureInfo -> SessionOptions

Parameters

cultureInfo
Type: System.GlobalizationCultureInfo
See Also

Reference

SessionOptions Class
SessionOptions Overload
SMath.Manager Namespace


SessionOptions Properties

The SessionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentsSeparator | Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.
Public property | AuthLogin |
 | AUTHLOGIN |
Public property | AuthName |
 | AUTHNAME |
Public property | AuthToken |
 | AUTHTOKEN |
Public property | DecimalPlaces |
Public property | DecimalSymbol | Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.
Public property | ExponentialThreshold |
Public property | FontHeight |
Public property | FontName |
Public property | FooterText |
Public property | HeaderText |
Public property | IntegralAccuracy |
Public property | Item | (Inherited from OptionsCollection.)
Public property | Lang3Letter |
Public property | NamingType |
Public property | OnError |
Public property | PageMargins |
Public property | PaperId |
Public property | PaperOrientation |
Public property | PaperSize |
Public property | PrintAreas |
Public property | PrintGrid |
Public property | PrintSimpleEqualsOnly |
Public property | RedrawRequired |
Public property | RepresentationStyle |
Public property | RoundingMode |
Public property | SignificantDigits |
Public property | SolveFromPoint |
Public property | SolveToPoint |
Public property | TrailingZeros |
Public property | UnitsLang3Letter |
Public property | ViewMode |
Top
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ArgumentsSeparator Property

SessionOptionsArgumentsSeparator Property

Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<char> ArgumentsSeparator { get; set; }
Public Property ArgumentsSeparator As Nullable(Of Char)
    Get
    Set
public:
property Nullable<wchar_t> ArgumentsSeparator {
    Nullable<wchar_t> get ();
    void set (Nullable<wchar_t> value);
}
member ArgumentsSeparator : Nullable<char> with get, set

Property Value

Type: NullableChar
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AuthLogin Property

SessionOptionsAuthLogin Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthLogin { get; set; }
Public Property AuthLogin As String
    Get
    Set
public:
property String^ AuthLogin {
    String^ get ();
    void set (String^ value);
}
member AuthLogin : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AUTHLOGIN Property

SessionOptionsAUTHLOGIN Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string AUTHLOGIN { get; }
Public Shared ReadOnly Property AUTHLOGIN As String
    Get
public:
static property String^ AUTHLOGIN {
    String^ get ();
}
static member AUTHLOGIN : string with get

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AuthName Property

SessionOptionsAuthName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthName { get; set; }
Public Property AuthName As String
    Get
    Set
public:
property String^ AuthName {
    String^ get ();
    void set (String^ value);
}
member AuthName : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AUTHNAME Property

SessionOptionsAUTHNAME Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string AUTHNAME { get; }
Public Shared ReadOnly Property AUTHNAME As String
    Get
public:
static property String^ AUTHNAME {
    String^ get ();
}
static member AUTHNAME : string with get

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AuthToken Property

SessionOptionsAuthToken Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthToken { get; set; }
Public Property AuthToken As String
    Get
    Set
public:
property String^ AuthToken {
    String^ get ();
    void set (String^ value);
}
member AuthToken : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AUTHTOKEN Property

SessionOptionsAUTHTOKEN Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string AUTHTOKEN { get; }
Public Shared ReadOnly Property AUTHTOKEN As String
    Get
public:
static property String^ AUTHTOKEN {
    String^ get ();
}
static member AUTHTOKEN : string with get

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.DecimalPlaces Property

SessionOptionsDecimalPlaces Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> DecimalPlaces { get; set; }
Public Property DecimalPlaces As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> DecimalPlaces {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member DecimalPlaces : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.DecimalSymbol Property

SessionOptionsDecimalSymbol Property

Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<char> DecimalSymbol { get; set; }
Public Property DecimalSymbol As Nullable(Of Char)
    Get
    Set
public:
property Nullable<wchar_t> DecimalSymbol {
    Nullable<wchar_t> get ();
    void set (Nullable<wchar_t> value);
}
member DecimalSymbol : Nullable<char> with get, set

Property Value

Type: NullableChar
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ExponentialThreshold Property

SessionOptionsExponentialThreshold Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExponentialThreshold { get; set; }
Public Property ExponentialThreshold As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExponentialThreshold {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExponentialThreshold : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.FontHeight Property

SessionOptionsFontHeight Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> FontHeight { get; set; }
Public Property FontHeight As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> FontHeight {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member FontHeight : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.FontName Property

SessionOptionsFontName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
member FontName : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.FooterText Property

SessionOptionsFooterText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FooterText { get; set; }
Public Property FooterText As String
    Get
    Set
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}
member FooterText : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.HeaderText Property

SessionOptionsHeaderText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string HeaderText { get; set; }
Public Property HeaderText As String
    Get
    Set
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}
member HeaderText : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.IntegralAccuracy Property

SessionOptionsIntegralAccuracy Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> IntegralAccuracy { get; set; }
Public Property IntegralAccuracy As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> IntegralAccuracy {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member IntegralAccuracy : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.Lang3Letter Property

SessionOptionsLang3Letter Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Lang3Letter { get; set; }
Public Property Lang3Letter As String
    Get
    Set
public:
property String^ Lang3Letter {
    String^ get ();
    void set (String^ value);
}
member Lang3Letter : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.NamingType Property

SessionOptionsNamingType Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<Guid> NamingType { get; set; }
Public Property NamingType As Nullable(Of Guid)
    Get
    Set
public:
property Nullable<Guid> NamingType {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}
member NamingType : Nullable<Guid> with get, set

Property Value

Type: NullableGuid
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.OnError Property

SessionOptionsOnError Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<OnErrorAction> OnError { get; set; }
Public Property OnError As Nullable(Of OnErrorAction)
    Get
    Set
public:
property Nullable<OnErrorAction> OnError {
    Nullable<OnErrorAction> get ();
    void set (Nullable<OnErrorAction> value);
}
member OnError : Nullable<OnErrorAction> with get, set

Property Value

Type: NullableOnErrorAction
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PageMargins Property

SessionOptionsPageMargins Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageMargins PageMargins { get; set; }
Public Property PageMargins As PageMargins
    Get
    Set
public:
property PageMargins^ PageMargins {
    PageMargins^ get ();
    void set (PageMargins^ value);
}
member PageMargins : PageMargins with get, set

Property Value

Type: PageMargins
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PaperId Property

SessionOptionsPaperId Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> PaperId { get; set; }
Public Property PaperId As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> PaperId {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member PaperId : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PaperOrientation Property

SessionOptionsPaperOrientation Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<PageOrientation> PaperOrientation { get; set; }
Public Property PaperOrientation As Nullable(Of PageOrientation)
    Get
    Set
public:
property Nullable<PageOrientation> PaperOrientation {
    Nullable<PageOrientation> get ();
    void set (Nullable<PageOrientation> value);
}
member PaperOrientation : Nullable<PageOrientation> with get, set

Property Value

Type: NullablePageOrientation
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PaperSize Property

SessionOptionsPaperSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<Size> PaperSize { get; set; }
Public Property PaperSize As Nullable(Of Size)
    Get
    Set
public:
property Nullable<Size> PaperSize {
    Nullable<Size> get ();
    void set (Nullable<Size> value);
}
member PaperSize : Nullable<Size> with get, set

Property Value

Type: NullableSize
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PrintAreas Property

SessionOptionsPrintAreas Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> PrintAreas { get; set; }
Public Property PrintAreas As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> PrintAreas {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member PrintAreas : Nullable<bool> with get, set

Property Value

Type: NullableBoolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PrintGrid Property

SessionOptionsPrintGrid Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> PrintGrid { get; set; }
Public Property PrintGrid As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> PrintGrid {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member PrintGrid : Nullable<bool> with get, set

Property Value

Type: NullableBoolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PrintSimpleEqualsOnly Property

SessionOptionsPrintSimpleEqualsOnly Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> PrintSimpleEqualsOnly { get; set; }
Public Property PrintSimpleEqualsOnly As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> PrintSimpleEqualsOnly {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member PrintSimpleEqualsOnly : Nullable<bool> with get, set

Property Value

Type: NullableBoolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.RedrawRequired Property

SessionOptionsRedrawRequired Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool RedrawRequired { get; }
Public ReadOnly Property RedrawRequired As Boolean
    Get
public:
property bool RedrawRequired {
    bool get ();
}
member RedrawRequired : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.RepresentationStyle Property

SessionOptionsRepresentationStyle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string RepresentationStyle { get; set; }
Public Property RepresentationStyle As String
    Get
    Set
public:
property String^ RepresentationStyle {
    String^ get ();
    void set (String^ value);
}
member RepresentationStyle : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.RoundingMode Property

SessionOptionsRoundingMode Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<MidpointRounding> RoundingMode { get; set; }
Public Property RoundingMode As Nullable(Of MidpointRounding)
    Get
    Set
public:
property Nullable<MidpointRounding> RoundingMode {
    Nullable<MidpointRounding> get ();
    void set (Nullable<MidpointRounding> value);
}
member RoundingMode : Nullable<MidpointRounding> with get, set

Property Value

Type: NullableMidpointRounding
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SignificantDigits Property

SessionOptionsSignificantDigits Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> SignificantDigits { get; set; }
Public Property SignificantDigits As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> SignificantDigits {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member SignificantDigits : Nullable<bool> with get, set

Property Value

Type: NullableBoolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SolveFromPoint Property

SessionOptionsSolveFromPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SolveFromPoint { get; set; }
Public Property SolveFromPoint As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SolveFromPoint {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SolveFromPoint : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SolveToPoint Property

SessionOptionsSolveToPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SolveToPoint { get; set; }
Public Property SolveToPoint As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SolveToPoint {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SolveToPoint : Nullable<int> with get, set

Property Value

Type: NullableInt32
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.TrailingZeros Property

SessionOptionsTrailingZeros Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> TrailingZeros { get; set; }
Public Property TrailingZeros As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> TrailingZeros {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member TrailingZeros : Nullable<bool> with get, set

Property Value

Type: NullableBoolean
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.UnitsLang3Letter Property

SessionOptionsUnitsLang3Letter Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string UnitsLang3Letter { get; set; }
Public Property UnitsLang3Letter As String
    Get
    Set
public:
property String^ UnitsLang3Letter {
    String^ get ();
    void set (String^ value);
}
member UnitsLang3Letter : string with get, set

Property Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ViewMode Property

SessionOptionsViewMode Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Nullable<PageModelViewMode> ViewMode { get; set; }
Public Property ViewMode As Nullable(Of PageModelViewMode)
    Get
    Set
public:
property Nullable<PageModelViewMode> ViewMode {
    Nullable<PageModelViewMode> get ();
    void set (Nullable<PageModelViewMode> value);
}
member ViewMode : Nullable<PageModelViewMode> with get, set

Property Value

Type: NullablePageModelViewMode
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions Methods

The SessionOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean | (Inherited from OptionsCollection.)
Public method | GetCollection | (Inherited from OptionsCollection.)
Public method | GetEnumerator | (Inherited from OptionsCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | (Inherited from OptionsCollection.)
Public method | GetSingle | Retrieves a float property. (Inherited from OptionsCollection.)
Public method | GetString | (Inherited from OptionsCollection.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator | (Inherited from OptionsCollection.)
Top
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions Fields

The SessionOptions type exposes the following members.

Fields
 | Name | Description
 | ARGUMENTSSEPARATOR |
 | AUTORECALC |
Protected field | data | (Inherited from OptionsCollection.)
 | DECIMALSYMBOL |
 | DEFAULTINTERACTIVETUTORIAL |
 | DYNAMICASSISTANCE |
 | ENHANCEDGRAPHICS |
 | EXPONENTIALTHRESHOLD |
 | FONTNAME |
 | FONTSIZE |
 | INTEGRAL |
 | LANGUAGE |
 | NUM |
 | ONERRORACTION |
 | OUTPUTUNITSSYSTEM |
 | PAGEFOOTER |
 | PAGEHEADER |
 | PAGEMARGINBOTTOM |
 | PAGEMARGINLEFT |
 | PAGEMARGINRIGHT |
 | PAGEMARGINTOP |
 | PAGEORIENTATION |
 | PAGESIZE |
 | PRINTAREAREGIONS |
 | PRINTEQUALITYSIGN |
 | PRINTGRID |
 | PRINTINGBOUNDS |
 | REPRESENTATION |
 | ROOTSA |
 | ROOTSB |
 | ROUNDING |
 | SESSIONHOST |
 | SESSIONLOGIN |
 | SIGNIFICANTDIGITS |
 | STYLE |
 | TRAILINGZEROS |
 | UNITS |
Top
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ARGUMENTSSEPARATOR Field

SessionOptionsARGUMENTSSEPARATOR Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ARGUMENTSSEPARATOR = "ArgumentsSeparator"
Public Const ARGUMENTSSEPARATOR As String = "ArgumentsSeparator"
public:
literal String^ ARGUMENTSSEPARATOR = "ArgumentsSeparator"
static val mutable ARGUMENTSSEPARATOR: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.AUTORECALC Field

SessionOptionsAUTORECALC Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string AUTORECALC = "AutoReCalc"
Public Const AUTORECALC As String = "AutoReCalc"
public:
literal String^ AUTORECALC = "AutoReCalc"
static val mutable AUTORECALC: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.DECIMALSYMBOL Field

SessionOptionsDECIMALSYMBOL Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DECIMALSYMBOL = "DecimalSymbol"
Public Const DECIMALSYMBOL As String = "DecimalSymbol"
public:
literal String^ DECIMALSYMBOL = "DecimalSymbol"
static val mutable DECIMALSYMBOL: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.DEFAULTINTERACTIVETUTORIAL Field

SessionOptionsDEFAULTINTERACTIVETUTORIAL Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DEFAULTINTERACTIVETUTORIAL = "DefaultInteractiveTutorial"
Public Const DEFAULTINTERACTIVETUTORIAL As String = "DefaultInteractiveTutorial"
public:
literal String^ DEFAULTINTERACTIVETUTORIAL = "DefaultInteractiveTutorial"
static val mutable DEFAULTINTERACTIVETUTORIAL: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.DYNAMICASSISTANCE Field

SessionOptionsDYNAMICASSISTANCE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DYNAMICASSISTANCE = "DynamicAssistance"
Public Const DYNAMICASSISTANCE As String = "DynamicAssistance"
public:
literal String^ DYNAMICASSISTANCE = "DynamicAssistance"
static val mutable DYNAMICASSISTANCE: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ENHANCEDGRAPHICS Field

SessionOptionsENHANCEDGRAPHICS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ENHANCEDGRAPHICS = "EnhancedGraphics"
Public Const ENHANCEDGRAPHICS As String = "EnhancedGraphics"
public:
literal String^ ENHANCEDGRAPHICS = "EnhancedGraphics"
static val mutable ENHANCEDGRAPHICS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.EXPONENTIALTHRESHOLD Field

SessionOptionsEXPONENTIALTHRESHOLD Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EXPONENTIALTHRESHOLD = "ExponentialThreshold"
Public Const EXPONENTIALTHRESHOLD As String = "ExponentialThreshold"
public:
literal String^ EXPONENTIALTHRESHOLD = "ExponentialThreshold"
static val mutable EXPONENTIALTHRESHOLD: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.FONTNAME Field

SessionOptionsFONTNAME Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FONTNAME = "FontName"
Public Const FONTNAME As String = "FontName"
public:
literal String^ FONTNAME = "FontName"
static val mutable FONTNAME: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.FONTSIZE Field

SessionOptionsFONTSIZE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FONTSIZE = "FontSize"
Public Const FONTSIZE As String = "FontSize"
public:
literal String^ FONTSIZE = "FontSize"
static val mutable FONTSIZE: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.INTEGRAL Field

SessionOptionsINTEGRAL Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string INTEGRAL = "Integral"
Public Const INTEGRAL As String = "Integral"
public:
literal String^ INTEGRAL = "Integral"
static val mutable INTEGRAL: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.LANGUAGE Field

SessionOptionsLANGUAGE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string LANGUAGE = "Language"
Public Const LANGUAGE As String = "Language"
public:
literal String^ LANGUAGE = "Language"
static val mutable LANGUAGE: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.NUM Field

SessionOptionsNUM Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string NUM = "Num"
Public Const NUM As String = "Num"
public:
literal String^ NUM = "Num"
static val mutable NUM: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ONERRORACTION Field

SessionOptionsONERRORACTION Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ONERRORACTION = "OnErrorAction"
Public Const ONERRORACTION As String = "OnErrorAction"
public:
literal String^ ONERRORACTION = "OnErrorAction"
static val mutable ONERRORACTION: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.OUTPUTUNITSSYSTEM Field

SessionOptionsOUTPUTUNITSSYSTEM Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string OUTPUTUNITSSYSTEM = "OutputUnitsSystem"
Public Const OUTPUTUNITSSYSTEM As String = "OutputUnitsSystem"
public:
literal String^ OUTPUTUNITSSYSTEM = "OutputUnitsSystem"
static val mutable OUTPUTUNITSSYSTEM: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEFOOTER Field

SessionOptionsPAGEFOOTER Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEFOOTER = "PageFooter"
Public Const PAGEFOOTER As String = "PageFooter"
public:
literal String^ PAGEFOOTER = "PageFooter"
static val mutable PAGEFOOTER: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEHEADER Field

SessionOptionsPAGEHEADER Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEHEADER = "PageHeader"
Public Const PAGEHEADER As String = "PageHeader"
public:
literal String^ PAGEHEADER = "PageHeader"
static val mutable PAGEHEADER: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEMARGINBOTTOM Field

SessionOptionsPAGEMARGINBOTTOM Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEMARGINBOTTOM = "PageMarginBottom"
Public Const PAGEMARGINBOTTOM As String = "PageMarginBottom"
public:
literal String^ PAGEMARGINBOTTOM = "PageMarginBottom"
static val mutable PAGEMARGINBOTTOM: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEMARGINLEFT Field

SessionOptionsPAGEMARGINLEFT Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEMARGINLEFT = "PageMarginLeft"
Public Const PAGEMARGINLEFT As String = "PageMarginLeft"
public:
literal String^ PAGEMARGINLEFT = "PageMarginLeft"
static val mutable PAGEMARGINLEFT: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEMARGINRIGHT Field

SessionOptionsPAGEMARGINRIGHT Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEMARGINRIGHT = "PageMarginRight"
Public Const PAGEMARGINRIGHT As String = "PageMarginRight"
public:
literal String^ PAGEMARGINRIGHT = "PageMarginRight"
static val mutable PAGEMARGINRIGHT: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEMARGINTOP Field

SessionOptionsPAGEMARGINTOP Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEMARGINTOP = "PageMarginTop"
Public Const PAGEMARGINTOP As String = "PageMarginTop"
public:
literal String^ PAGEMARGINTOP = "PageMarginTop"
static val mutable PAGEMARGINTOP: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGEORIENTATION Field

SessionOptionsPAGEORIENTATION Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGEORIENTATION = "PageOrientation"
Public Const PAGEORIENTATION As String = "PageOrientation"
public:
literal String^ PAGEORIENTATION = "PageOrientation"
static val mutable PAGEORIENTATION: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PAGESIZE Field

SessionOptionsPAGESIZE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PAGESIZE = "PageSize"
Public Const PAGESIZE As String = "PageSize"
public:
literal String^ PAGESIZE = "PageSize"
static val mutable PAGESIZE: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PRINTAREAREGIONS Field

SessionOptionsPRINTAREAREGIONS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PRINTAREAREGIONS = "PrintAreaRegions"
Public Const PRINTAREAREGIONS As String = "PrintAreaRegions"
public:
literal String^ PRINTAREAREGIONS = "PrintAreaRegions"
static val mutable PRINTAREAREGIONS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PRINTEQUALITYSIGN Field

SessionOptionsPRINTEQUALITYSIGN Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PRINTEQUALITYSIGN = "PrintEqualitySign"
Public Const PRINTEQUALITYSIGN As String = "PrintEqualitySign"
public:
literal String^ PRINTEQUALITYSIGN = "PrintEqualitySign"
static val mutable PRINTEQUALITYSIGN: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PRINTGRID Field

SessionOptionsPRINTGRID Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PRINTGRID = "PrintGrid"
Public Const PRINTGRID As String = "PrintGrid"
public:
literal String^ PRINTGRID = "PrintGrid"
static val mutable PRINTGRID: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.PRINTINGBOUNDS Field

SessionOptionsPRINTINGBOUNDS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PRINTINGBOUNDS = "PrintingBounds"
Public Const PRINTINGBOUNDS As String = "PrintingBounds"
public:
literal String^ PRINTINGBOUNDS = "PrintingBounds"
static val mutable PRINTINGBOUNDS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.REPRESENTATION Field

SessionOptionsREPRESENTATION Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string REPRESENTATION = "Representation"
Public Const REPRESENTATION As String = "Representation"
public:
literal String^ REPRESENTATION = "Representation"
static val mutable REPRESENTATION: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ROOTSA Field

SessionOptionsROOTSA Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ROOTSA = "RootsA"
Public Const ROOTSA As String = "RootsA"
public:
literal String^ ROOTSA = "RootsA"
static val mutable ROOTSA: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ROOTSB Field

SessionOptionsROOTSB Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ROOTSB = "RootsB"
Public Const ROOTSB As String = "RootsB"
public:
literal String^ ROOTSB = "RootsB"
static val mutable ROOTSB: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.ROUNDING Field

SessionOptionsROUNDING Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ROUNDING = "Rounding"
Public Const ROUNDING As String = "Rounding"
public:
literal String^ ROUNDING = "Rounding"
static val mutable ROUNDING: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SESSIONHOST Field

SessionOptionsSESSIONHOST Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string SESSIONHOST = "SessionHost"
Public Const SESSIONHOST As String = "SessionHost"
public:
literal String^ SESSIONHOST = "SessionHost"
static val mutable SESSIONHOST: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SESSIONLOGIN Field

SessionOptionsSESSIONLOGIN Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string SESSIONLOGIN = "SessionLogin"
Public Const SESSIONLOGIN As String = "SessionLogin"
public:
literal String^ SESSIONLOGIN = "SessionLogin"
static val mutable SESSIONLOGIN: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.SIGNIFICANTDIGITS Field

SessionOptionsSIGNIFICANTDIGITS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string SIGNIFICANTDIGITS = "SignificantDigits"
Public Const SIGNIFICANTDIGITS As String = "SignificantDigits"
public:
literal String^ SIGNIFICANTDIGITS = "SignificantDigits"
static val mutable SIGNIFICANTDIGITS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.STYLE Field

SessionOptionsSTYLE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string STYLE = "Style"
Public Const STYLE As String = "Style"
public:
literal String^ STYLE = "Style"
static val mutable STYLE: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.TRAILINGZEROS Field

SessionOptionsTRAILINGZEROS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string TRAILINGZEROS = "TrailingZeros"
Public Const TRAILINGZEROS As String = "TrailingZeros"
public:
literal String^ TRAILINGZEROS = "TrailingZeros"
static val mutable TRAILINGZEROS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionOptions.UNITS Field

SessionOptionsUNITS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string UNITS = "Units"
Public Const UNITS As String = "Units"
public:
literal String^ UNITS = "Units"
static val mutable UNITS: string

Field Value

Type: String
See Also

Reference

SessionOptions Class
SMath.Manager Namespace


SessionProfile Class

Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.
Inheritance Hierarchy
SystemObject
SMath.ManagerOptionsCollection
SMath.ManagerSessionProfile

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class SessionProfile : OptionsCollection,
    IDisposable
Public Class SessionProfile
    Inherits OptionsCollection
    Implements IDisposable
public ref class SessionProfile : public OptionsCollection,
    IDisposable
type SessionProfile =
    class
        inherit OptionsCollection
        interface IDisposable
    end

The SessionProfile type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentsSeparator | Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.
Public property | AuthLogin |
Public property | AuthName |
Public property | AuthToken |
Public property | BuiltInFunctions |
Public property | BuiltInOperators |
Public property | BuiltInSpecialVariables |
Public property | BuiltInVariables | Built-in program's constants.Встроенные константы программы.
Public property | CurrentLanguage | Interface language to be used within current application session.
Public property | CurrentUnits | Set of Units to be used within current application session.
Public property | CurrentUnitsLanguage | Selected language of the built-in units.Выбранный язык встроенных единиц измерения.
Public property | DecimalPlaces |
Public property | DecimalSymbol | Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.
Public property | Drawing |
Public property | ExponentialThreshold |
Public property | FontName |
Public property | IntegralAccuracy |
Public property | Item | (Inherited from OptionsCollection.)
Public property | NamingType | Gets or sets a type of the functions to be displayed.Возвращает или задаёт тип используемых функций.
Public property | OnError |
Public property | PageModel |
Public property | PrimitivesBuiltIn |
Public property | PrimitivesExternal |
Public property | RoundingMode |
Public property | SignificantDigits |
Public property | SolveFromPoint |
Public property | SolveToPoint |
Public property | TrailingZeros | Whether trailing zeros must be displayed or not.Определяет необходимость отображения завершающих нулей десятичной дроби.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SessionProfile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean | (Inherited from OptionsCollection.)
Public method | GetCollection | (Inherited from OptionsCollection.)
Public method | GetEnumerator | (Inherited from OptionsCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | (Inherited from OptionsCollection.)
Public method | GetSingle | Retrieves a float property. (Inherited from OptionsCollection.)
Public method | GetString | (Inherited from OptionsCollection.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsStandardEquationsSettings | Detects if standard settings of visualization used by context (takes into account: Decimal symbol, Arguments separator, naming type and units language).
 | Load | Load session options from file.Загрузка параметров сессии из файла.
 | Load(Stream) | Load session options from stream.Загрузка параметров сессии из потока.
Public method | MakeGlobal | Uses current Session Profile as a Global Context for old-style plug-ins.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save session options to file.Сохранение параметров сессии в файл.
Public method | Save(Stream) | Save session options to stream.Сохранение параметров сессии в поток.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
Fields
 | Name | Description
Protected field | data | (Inherited from OptionsCollection.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator | (Inherited from OptionsCollection.)
Top
See Also

Reference

SMath.Manager Namespace


SessionProfile Properties

The SessionProfile type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentsSeparator | Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.
Public property | AuthLogin |
Public property | AuthName |
Public property | AuthToken |
Public property | BuiltInFunctions |
Public property | BuiltInOperators |
Public property | BuiltInSpecialVariables |
Public property | BuiltInVariables | Built-in program's constants.Встроенные константы программы.
Public property | CurrentLanguage | Interface language to be used within current application session.
Public property | CurrentUnits | Set of Units to be used within current application session.
Public property | CurrentUnitsLanguage | Selected language of the built-in units.Выбранный язык встроенных единиц измерения.
Public property | DecimalPlaces |
Public property | DecimalSymbol | Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.
Public property | Drawing |
Public property | ExponentialThreshold |
Public property | FontName |
Public property | IntegralAccuracy |
Public property | Item | (Inherited from OptionsCollection.)
Public property | NamingType | Gets or sets a type of the functions to be displayed.Возвращает или задаёт тип используемых функций.
Public property | OnError |
Public property | PageModel |
Public property | PrimitivesBuiltIn |
Public property | PrimitivesExternal |
Public property | RoundingMode |
Public property | SignificantDigits |
Public property | SolveFromPoint |
Public property | SolveToPoint |
Public property | TrailingZeros | Whether trailing zeros must be displayed or not.Определяет необходимость отображения завершающих нулей десятичной дроби.
Top
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.ArgumentsSeparator Property

SessionProfileArgumentsSeparator Property

Function's arguments separator to use within a program.Разделитель аргументов функций, используемый для ввода и вывода данных программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public char ArgumentsSeparator { get; }
Public ReadOnly Property ArgumentsSeparator As Char
    Get
public:
property wchar_t ArgumentsSeparator {
    wchar_t get ();
}
member ArgumentsSeparator : char with get

Property Value

Type: Char
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.AuthLogin Property

SessionProfileAuthLogin Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthLogin { get; set; }
Public Property AuthLogin As String
    Get
    Set
public:
property String^ AuthLogin {
    String^ get ();
    void set (String^ value);
}
member AuthLogin : string with get, set

Property Value

Type: String
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.AuthName Property

SessionProfileAuthName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthName { get; set; }
Public Property AuthName As String
    Get
    Set
public:
property String^ AuthName {
    String^ get ();
    void set (String^ value);
}
member AuthName : string with get, set

Property Value

Type: String
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.AuthToken Property

SessionProfileAuthToken Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string AuthToken { get; set; }
Public Property AuthToken As String
    Get
    Set
public:
property String^ AuthToken {
    String^ get ();
    void set (String^ value);
}
member AuthToken : string with get, set

Property Value

Type: String
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.BuiltInFunctions Property

SessionProfileBuiltInFunctions Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo[] BuiltInFunctions { get; }
Public ReadOnly Property BuiltInFunctions As TermInfo()
    Get
public:
property array<TermInfo^>^ BuiltInFunctions {
    array<TermInfo^>^ get ();
}
member BuiltInFunctions : TermInfo[] with get

Property Value

Type: TermInfo
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.BuiltInOperators Property

SessionProfileBuiltInOperators Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<OperatorInfo> BuiltInOperators { get; }
Public ReadOnly Property BuiltInOperators As List(Of OperatorInfo)
    Get
public:
property List<OperatorInfo^>^ BuiltInOperators {
    List<OperatorInfo^>^ get ();
}
member BuiltInOperators : List<OperatorInfo> with get

Property Value

Type: ListOperatorInfo
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.BuiltInSpecialVariables Property

SessionProfileBuiltInSpecialVariables Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<SessionProfileBuiltInVarInfo> BuiltInSpecialVariables { get; }
Public ReadOnly Property BuiltInSpecialVariables As List(Of SessionProfileBuiltInVarInfo)
    Get
public:
property List<SessionProfileBuiltInVarInfo^>^ BuiltInSpecialVariables {
    List<SessionProfileBuiltInVarInfo^>^ get ();
}
member BuiltInSpecialVariables : List<SessionProfileBuiltInVarInfo> with get

Property Value

Type: ListSessionProfileBuiltInVarInfo
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.BuiltInVariables Property

SessionProfileBuiltInVariables Property

Built-in program's constants.Встроенные константы программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<SessionProfileBuiltInVarInfo> BuiltInVariables { get; }
Public ReadOnly Property BuiltInVariables As List(Of SessionProfileBuiltInVarInfo)
    Get
public:
property List<SessionProfileBuiltInVarInfo^>^ BuiltInVariables {
    List<SessionProfileBuiltInVarInfo^>^ get ();
}
member BuiltInVariables : List<SessionProfileBuiltInVarInfo> with get

Property Value

Type: ListSessionProfileBuiltInVarInfo
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.CurrentLanguage Property

SessionProfileCurrentLanguage Property

Interface language to be used within current application session.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public LanguageInfo CurrentLanguage { get; }
Public ReadOnly Property CurrentLanguage As LanguageInfo
    Get
public:
property LanguageInfo^ CurrentLanguage {
    LanguageInfo^ get ();
}
member CurrentLanguage : LanguageInfo with get

Property Value

Type: LanguageInfo
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.CurrentUnits Property

SessionProfileCurrentUnits Property

Set of Units to be used within current application session.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public UnitsSet CurrentUnits { get; }
Public ReadOnly Property CurrentUnits As UnitsSet
    Get
public:
property UnitsSet^ CurrentUnits {
    UnitsSet^ get ();
}
member CurrentUnits : UnitsSet with get

Property Value

Type: UnitsSet
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.CurrentUnitsLanguage Property

SessionProfileCurrentUnitsLanguage Property

Selected language of the built-in units.Выбранный язык встроенных единиц измерения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string CurrentUnitsLanguage { get; }
Public ReadOnly Property CurrentUnitsLanguage As String
    Get
public:
property String^ CurrentUnitsLanguage {
    String^ get ();
}
member CurrentUnitsLanguage : string with get

Property Value

Type: String
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.DecimalPlaces Property

SessionProfileDecimalPlaces Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int DecimalPlaces { get; }
Public ReadOnly Property DecimalPlaces As Integer
    Get
public:
property int DecimalPlaces {
    int get ();
}
member DecimalPlaces : int with get

Property Value

Type: Int32
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.DecimalSymbol Property

SessionProfileDecimalSymbol Property

Decimal Symbol. Also used as a char to start subscript in the variables names.Разделитель целой и дробной частей числа. Также используется для подстрочного индекса в имени переменных.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public char DecimalSymbol { get; }
Public ReadOnly Property DecimalSymbol As Char
    Get
public:
property wchar_t DecimalSymbol {
    wchar_t get ();
}
member DecimalSymbol : char with get

Property Value

Type: Char
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Drawing Property

SessionProfileDrawing Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public DrawingManager Drawing { get; }
Public ReadOnly Property Drawing As DrawingManager
    Get
public:
property DrawingManager^ Drawing {
    DrawingManager^ get ();
}
member Drawing : DrawingManager with get

Property Value

Type: DrawingManager
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.ExponentialThreshold Property

SessionProfileExponentialThreshold Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ExponentialThreshold { get; }
Public ReadOnly Property ExponentialThreshold As Integer
    Get
public:
property int ExponentialThreshold {
    int get ();
}
member ExponentialThreshold : int with get

Property Value

Type: Int32
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.FontName Property

SessionProfileFontName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
public:
property String^ FontName {
    String^ get ();
}
member FontName : string with get

Property Value

Type: String
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.IntegralAccuracy Property

SessionProfileIntegralAccuracy Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int IntegralAccuracy { get; }
Public ReadOnly Property IntegralAccuracy As Integer
    Get
public:
property int IntegralAccuracy {
    int get ();
}
member IntegralAccuracy : int with get

Property Value

Type: Int32
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.NamingType Property

SessionProfileNamingType Property

Gets or sets a type of the functions to be displayed.Возвращает или задаёт тип используемых функций.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid NamingType { get; }
Public ReadOnly Property NamingType As Guid
    Get
public:
property Guid NamingType {
    Guid get ();
}
member NamingType : Guid with get

Property Value

Type: Guid
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.OnError Property

SessionProfileOnError Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OnErrorAction OnError { get; set; }
Public Property OnError As OnErrorAction
    Get
    Set
public:
property OnErrorAction OnError {
    OnErrorAction get ();
    void set (OnErrorAction value);
}
member OnError : OnErrorAction with get, set

Property Value

Type: OnErrorAction
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.PageModel Property

SessionProfilePageModel Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PageModel PageModel { get; }
Public ReadOnly Property PageModel As PageModel
    Get
public:
property PageModel^ PageModel {
    PageModel^ get ();
}
member PageModel : PageModel with get

Property Value

Type: PageModel
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.PrimitivesBuiltIn Property

SessionProfilePrimitivesBuiltIn Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PrimitivesCollection PrimitivesBuiltIn { get; }
Public ReadOnly Property PrimitivesBuiltIn As PrimitivesCollection
    Get
public:
property PrimitivesCollection^ PrimitivesBuiltIn {
    PrimitivesCollection^ get ();
}
member PrimitivesBuiltIn : PrimitivesCollection with get

Property Value

Type: PrimitivesCollection
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.PrimitivesExternal Property

SessionProfilePrimitivesExternal Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public PrimitivesCollection PrimitivesExternal { get; }
Public ReadOnly Property PrimitivesExternal As PrimitivesCollection
    Get
public:
property PrimitivesCollection^ PrimitivesExternal {
    PrimitivesCollection^ get ();
}
member PrimitivesExternal : PrimitivesCollection with get

Property Value

Type: PrimitivesCollection
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.RoundingMode Property

SessionProfileRoundingMode Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public MidpointRounding RoundingMode { get; set; }
Public Property RoundingMode As MidpointRounding
    Get
    Set
public:
property MidpointRounding RoundingMode {
    MidpointRounding get ();
    void set (MidpointRounding value);
}
member RoundingMode : MidpointRounding with get, set

Property Value

Type: MidpointRounding
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.SignificantDigits Property

SessionProfileSignificantDigits Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SignificantDigits { get; set; }
Public Property SignificantDigits As Boolean
    Get
    Set
public:
property bool SignificantDigits {
    bool get ();
    void set (bool value);
}
member SignificantDigits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.SolveFromPoint Property

SessionProfileSolveFromPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int SolveFromPoint { get; }
Public ReadOnly Property SolveFromPoint As Integer
    Get
public:
property int SolveFromPoint {
    int get ();
}
member SolveFromPoint : int with get

Property Value

Type: Int32
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.SolveToPoint Property

SessionProfileSolveToPoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int SolveToPoint { get; }
Public ReadOnly Property SolveToPoint As Integer
    Get
public:
property int SolveToPoint {
    int get ();
}
member SolveToPoint : int with get

Property Value

Type: Int32
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.TrailingZeros Property

SessionProfileTrailingZeros Property

Whether trailing zeros must be displayed or not.Определяет необходимость отображения завершающих нулей десятичной дроби.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool TrailingZeros { get; }
Public ReadOnly Property TrailingZeros As Boolean
    Get
public:
property bool TrailingZeros {
    bool get ();
}
member TrailingZeros : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile Methods

The SessionProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBoolean | (Inherited from OptionsCollection.)
Public method | GetCollection | (Inherited from OptionsCollection.)
Public method | GetEnumerator | (Inherited from OptionsCollection.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt | (Inherited from OptionsCollection.)
Public method | GetSingle | Retrieves a float property. (Inherited from OptionsCollection.)
Public method | GetString | (Inherited from OptionsCollection.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsStandardEquationsSettings | Detects if standard settings of visualization used by context (takes into account: Decimal symbol, Arguments separator, naming type and units language).
 | Load | Load session options from file.Загрузка параметров сессии из файла.
 | Load(Stream) | Load session options from stream.Загрузка параметров сессии из потока.
Public method | MakeGlobal | Uses current Session Profile as a Global Context for old-style plug-ins.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Save session options to file.Сохранение параметров сессии в файл.
Public method | Save(Stream) | Save session options to stream.Сохранение параметров сессии в поток.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEnumerableGetEnumerator | (Inherited from OptionsCollection.)
Top
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Dispose Method

SessionProfileDispose Method

Releases all resources used by the SessionProfile

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.IsStandardEquationsSettings Method

SessionProfileIsStandardEquationsSettings Method

Detects if standard settings of visualization used by context (takes into account: Decimal symbol, Arguments separator, naming type and units language).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsStandardEquationsSettings()
Public Function IsStandardEquationsSettings As Boolean
public:
bool IsStandardEquationsSettings()
member IsStandardEquationsSettings : unit -> bool

Return Value

Type: Boolean
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Load Method

SessionProfileLoad Method

Overload List
Name | Description
Load | Load session options from file.Загрузка параметров сессии из файла.
Load(Stream) | Load session options from stream.Загрузка параметров сессии из потока.
Top
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Load Method

SessionProfileLoad Method

Load session options from file.Загрузка параметров сессии из файла.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionOptions Load()
Public Shared Function Load As SessionOptions
public:
static SessionOptions^ Load()
static member Load : unit -> SessionOptions

Return Value

Type: SessionOptions
See Also

Reference

SessionProfile Class
Load Overload
SMath.Manager Namespace


SessionProfile.Load Method (Stream)

SessionProfileLoad Method (Stream)

Load session options from stream.Загрузка параметров сессии из потока.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionOptions Load(
    Stream stream
)
Public Shared Function Load (
    stream As Stream
) As SessionOptions
public:
static SessionOptions^ Load(
    Stream^ stream
)
static member Load :
        stream : Stream -> SessionOptions

Parameters

stream
Type: System.IOStream

Return Value

Type: SessionOptions
See Also

Reference

SessionProfile Class
Load Overload
SMath.Manager Namespace


SessionProfile.MakeGlobal Method

SessionProfileMakeGlobal Method

Uses current Session Profile as a Global Context for old-style plug-ins.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void MakeGlobal()
Public Sub MakeGlobal
public:
void MakeGlobal()
member MakeGlobal : unit -> unit
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Save Method

SessionProfileSave Method

Overload List
 | Name | Description
Public method | Save | Save session options to file.Сохранение параметров сессии в файл.
Public method | Save(Stream) | Save session options to stream.Сохранение параметров сессии в поток.
Top
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.Save Method

SessionProfileSave Method

Save session options to file.Сохранение параметров сессии в файл.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

SessionProfile Class
Save Overload
SMath.Manager Namespace


SessionProfile.Save Method (Stream)

SessionProfileSave Method (Stream)

Save session options to stream.Сохранение параметров сессии в поток.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Save(
    Stream stream
)
Public Sub Save (
    stream As Stream
)
public:
void Save(
    Stream^ stream
)
member Save :
        stream : Stream -> unit

Parameters

stream
Type: System.IOStream
See Also

Reference

SessionProfile Class
Save Overload
SMath.Manager Namespace


SessionProfile.Update Method

SessionProfileUpdate Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Update(
    SessionOptions options
)
Public Sub Update (
    options As SessionOptions
)
public:
void Update(
    SessionOptions^ options
)
member Update :
        options : SessionOptions -> unit

Parameters

options
Type: SMath.ManagerSessionOptions
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile Fields

The SessionProfile type exposes the following members.

Fields
 | Name | Description
Protected field | data | (Inherited from OptionsCollection.)
Top
See Also

Reference

SessionProfile Class
SMath.Manager Namespace


SessionProfile.BuiltInVarInfo Class

SessionProfileBuiltInVarInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerSessionProfileBuiltInVarInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class BuiltInVarInfo
Public Class BuiltInVarInfo
public ref class BuiltInVarInfo
type BuiltInVarInfo =  class end

The SessionProfileBuiltInVarInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SessionProfileBuiltInVarInfo | Initializes a new instance of the SessionProfileBuiltInVarInfo class
Top
Properties
 | Name | Description
Public property | Description |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


SessionProfile.BuiltInVarInfo Constructor

SessionProfileBuiltInVarInfo Constructor

Initializes a new instance of the SessionProfileBuiltInVarInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public BuiltInVarInfo()
Public Sub New
public:
BuiltInVarInfo()
new : unit -> BuiltInVarInfo
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


BuiltInVarInfo Properties

The SessionProfileBuiltInVarInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | Name |
Public property | Value |
Top
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


SessionProfile.BuiltInVarInfo.Description Property

SessionProfileBuiltInVarInfoDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


SessionProfile.BuiltInVarInfo.Name Property

SessionProfileBuiltInVarInfoName Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


SessionProfile.BuiltInVarInfo.Value Property

SessionProfileBuiltInVarInfoValue Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry Value { get; set; }
Public Property Value As Entry
    Get
    Set
public:
property Entry^ Value {
    Entry^ get ();
    void set (Entry^ value);
}
member Value : Entry with get, set

Property Value

Type: Entry
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


BuiltInVarInfo Methods

The SessionProfileBuiltInVarInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SessionProfileBuiltInVarInfo Class
SMath.Manager Namespace


SessionsManager Class

Application context manager.
Inheritance Hierarchy
SystemObject
SMath.ManagerSessionsManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract class SessionsManager
Public MustInherit Class SessionsManager
public ref class SessionsManager abstract
[<AbstractClassAttribute>]
type SessionsManager =  class end

The SessionsManager type exposes the following members.

Constructors
 | Name | Description
Protected method | SessionsManager(ISystemSpecifics) | Initializes a new instance of the SessionsManager class
Protected method | SessionsManager(ISystemSpecifics, IAccountManager) | Initializes a new instance of the SessionsManager class
Top
Properties
 | Name | Description
Public property | Account |
 | Current |
 | IsCreated | Determines if Session Manager instance is already created or not.
Public property | Specifics |
Top
Methods
 | Name | Description
 | DisposeProfile |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FetchProfile | Returns default session context created on application start.
 | FetchProfile(String) | Returns session context by its Id.
 | FetchProfile(SessionOptions) | Updates and returns default session context created on application start.
 | FetchProfile(String, SessionOptions) | Updates and returns session context by its Id.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileByName |
Public method | GetFiles |
Protected method | GetFilesByType |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadLanguages | Preload all available languages form the specified directory.Загрузка списка доступных языковых файлов из указанной директории.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


SessionsManager Constructor

Overload List
 | Name | Description
Protected method | SessionsManager(ISystemSpecifics) | Initializes a new instance of the SessionsManager class
Protected method | SessionsManager(ISystemSpecifics, IAccountManager) | Initializes a new instance of the SessionsManager class
Top
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager Constructor (ISystemSpecifics)

Initializes a new instance of the SessionsManager class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected SessionsManager(
    ISystemSpecifics specifics
)
Protected Sub New (
    specifics As ISystemSpecifics
)
protected:
SessionsManager(
    ISystemSpecifics^ specifics
)
new :
        specifics : ISystemSpecifics -> SessionsManager

Parameters

specifics
Type: SMath.DrawingISystemSpecifics
See Also

Reference

SessionsManager Class
SessionsManager Overload
SMath.Manager Namespace


SessionsManager Constructor (ISystemSpecifics, IAccountManager)

Initializes a new instance of the SessionsManager class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected SessionsManager(
    ISystemSpecifics specifics,
    IAccountManager account
)
Protected Sub New (
    specifics As ISystemSpecifics,
    account As IAccountManager
)
protected:
SessionsManager(
    ISystemSpecifics^ specifics,
    IAccountManager^ account
)
new :
        specifics : ISystemSpecifics *
        account : IAccountManager -> SessionsManager

Parameters

specifics
Type: SMath.DrawingISystemSpecifics
account
Type: SMath.DrawingIAccountManager
See Also

Reference

SessionsManager Class
SessionsManager Overload
SMath.Manager Namespace


SessionsManager Properties

The SessionsManager type exposes the following members.

Properties
 | Name | Description
Public property | Account |
 | Current |
 | IsCreated | Determines if Session Manager instance is already created or not.
Public property | Specifics |
Top
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.Account Property

SessionsManagerAccount Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IAccountManager Account { get; }
Public ReadOnly Property Account As IAccountManager
    Get
public:
property IAccountManager^ Account {
    IAccountManager^ get ();
}
member Account : IAccountManager with get

Property Value

Type: IAccountManager
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.Current Property

SessionsManagerCurrent Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionsManager Current { get; protected set; }
Public Shared Property Current As SessionsManager
    Get
    Protected Set
public:
static property SessionsManager^ Current {
    SessionsManager^ get ();
    protected: void set (SessionsManager^ value);
}
static member Current : SessionsManager with get, set

Property Value

Type: SessionsManager
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.IsCreated Property

SessionsManagerIsCreated Property

Determines if Session Manager instance is already created or not.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsCreated { get; }
Public Shared ReadOnly Property IsCreated As Boolean
    Get
public:
static property bool IsCreated {
    bool get ();
}
static member IsCreated : bool with get

Property Value

Type: Boolean
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.Specifics Property

SessionsManagerSpecifics Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ISystemSpecifics Specifics { get; }
Public ReadOnly Property Specifics As ISystemSpecifics
    Get
public:
property ISystemSpecifics^ Specifics {
    ISystemSpecifics^ get ();
}
member Specifics : ISystemSpecifics with get

Property Value

Type: ISystemSpecifics
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager Methods

The SessionsManager type exposes the following members.

Methods
 | Name | Description
 | DisposeProfile |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FetchProfile | Returns default session context created on application start.
 | FetchProfile(String) | Returns session context by its Id.
 | FetchProfile(SessionOptions) | Updates and returns default session context created on application start.
 | FetchProfile(String, SessionOptions) | Updates and returns session context by its Id.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileByName |
Public method | GetFiles |
Protected method | GetFilesByType |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReloadLanguages | Preload all available languages form the specified directory.Загрузка списка доступных языковых файлов из указанной директории.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.DisposeProfile Method

SessionsManagerDisposeProfile Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void DisposeProfile(
    string sessionId
)
Public Shared Sub DisposeProfile (
    sessionId As String
)
public:
static void DisposeProfile(
    String^ sessionId
)
static member DisposeProfile :
        sessionId : string -> unit

Parameters

sessionId
Type: SystemString
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.FetchProfile Method

SessionsManagerFetchProfile Method

Overload List
Name | Description
FetchProfile | Returns default session context created on application start.
FetchProfile(String) | Returns session context by its Id.
FetchProfile(SessionOptions) | Updates and returns default session context created on application start.
FetchProfile(String, SessionOptions) | Updates and returns session context by its Id.
Top
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.FetchProfile Method

SessionsManagerFetchProfile Method

Returns default session context created on application start.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionProfile FetchProfile()
Public Shared Function FetchProfile As SessionProfile
public:
static SessionProfile^ FetchProfile()
static member FetchProfile : unit -> SessionProfile

Return Value

Type: SessionProfile
See Also

Reference

SessionsManager Class
FetchProfile Overload
SMath.Manager Namespace


SessionsManager.FetchProfile Method (String)

SessionsManagerFetchProfile Method (String)

Returns session context by its Id.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionProfile FetchProfile(
    string sessionId
)
Public Shared Function FetchProfile (
    sessionId As String
) As SessionProfile
public:
static SessionProfile^ FetchProfile(
    String^ sessionId
)
static member FetchProfile :
        sessionId : string -> SessionProfile

Parameters

sessionId
Type: SystemString
Id of a session to fetch.

Return Value

Type: SessionProfile
See Also

Reference

SessionsManager Class
FetchProfile Overload
SMath.Manager Namespace


SessionsManager.FetchProfile Method (SessionOptions)

SessionsManagerFetchProfile Method (SessionOptions)

Updates and returns default session context created on application start.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionProfile FetchProfile(
    SessionOptions options
)
Public Shared Function FetchProfile (
    options As SessionOptions
) As SessionProfile
public:
static SessionProfile^ FetchProfile(
    SessionOptions^ options
)
static member FetchProfile :
        options : SessionOptions -> SessionProfile

Parameters

options
Type: SMath.ManagerSessionOptions
Context options to set.

Return Value

Type: SessionProfile
See Also

Reference

SessionsManager Class
FetchProfile Overload
SMath.Manager Namespace


SessionsManager.FetchProfile Method (String, SessionOptions)

SessionsManagerFetchProfile Method (String, SessionOptions)

Updates and returns session context by its Id.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static SessionProfile FetchProfile(
    string sessionId,
    SessionOptions options
)
Public Shared Function FetchProfile (
    sessionId As String,
    options As SessionOptions
) As SessionProfile
public:
static SessionProfile^ FetchProfile(
    String^ sessionId,
    SessionOptions^ options
)
static member FetchProfile :
        sessionId : string *
        options : SessionOptions -> SessionProfile

Parameters

sessionId
Type: SystemString
Id of a session to fetch.
options
Type: SMath.ManagerSessionOptions
Context options to set.

Return Value

Type: SessionProfile
See Also

Reference

SessionsManager Class
FetchProfile Overload
SMath.Manager Namespace


SessionsManager.GetFileByName Method

SessionsManagerGetFileByName Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public abstract Stream GetFileByName(
    string fileName
)
Public MustOverride Function GetFileByName (
    fileName As String
) As Stream
public:
virtual Stream^ GetFileByName(
    String^ fileName
) abstract
abstract GetFileByName :
        fileName : string -> Stream

Parameters

fileName
Type: SystemString

Return Value

Type: Stream
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.GetFiles Method

SessionsManagerGetFiles Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> GetFiles(
    FileTypes fileType,
    FileOrigins fileOrigins
)
Public Function GetFiles (
    fileType As FileTypes,
    fileOrigins As FileOrigins
) As List(Of String)
public:
List<String^>^ GetFiles(
    FileTypes fileType,
    FileOrigins fileOrigins
)
member GetFiles :
        fileType : FileTypes *
        fileOrigins : FileOrigins -> List<string>

Parameters

fileType
Type: SMath.ManagerFileTypes
fileOrigins
Type: SMath.ManagerFileOrigins

Return Value

Type: ListString
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.GetFilesByType Method

SessionsManagerGetFilesByType Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected abstract List<string> GetFilesByType(
    string type,
    string extension,
    FileOrigins fileOrigins
)
Protected MustOverride Function GetFilesByType (
    type As String,
    extension As String,
    fileOrigins As FileOrigins
) As List(Of String)
protected:
virtual List<String^>^ GetFilesByType(
    String^ type,
    String^ extension,
    FileOrigins fileOrigins
) abstract
abstract GetFilesByType :
        type : string *
        extension : string *
        fileOrigins : FileOrigins -> List<string>

Parameters

type
Type: SystemString
extension
Type: SystemString
fileOrigins
Type: SMath.ManagerFileOrigins

Return Value

Type: ListString
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SessionsManager.ReloadLanguages Method

SessionsManagerReloadLanguages Method

Preload all available languages form the specified directory.Загрузка списка доступных языковых файлов из указанной директории.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void ReloadLanguages()
Public Shared Sub ReloadLanguages
public:
static void ReloadLanguages()
static member ReloadLanguages : unit -> unit
See Also

Reference

SessionsManager Class
SMath.Manager Namespace


SMathColors Class

Inheritance Hierarchy
SystemObject
SMath.ManagerSMathColors

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class SMathColors
Public NotInheritable Class SMathColors
public ref class SMathColors abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SMathColors =  class end

The SMathColors type exposes the following members.

Properties
Name | Description
ActiveBreakpoint |
Background |
Breakpoint |
ErrorEntry |
HighlightedText |
RegularText |
Selection |
StringEntry |
UnitEntry |
Top
See Also

Reference

SMath.Manager Namespace


SMathColors Properties

The SMathColors type exposes the following members.

Properties
Name | Description
ActiveBreakpoint |
Background |
Breakpoint |
ErrorEntry |
HighlightedText |
RegularText |
Selection |
StringEntry |
UnitEntry |
Top
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.ActiveBreakpoint Property

SMathColorsActiveBreakpoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ActiveBreakpoint { get; }
Public Shared ReadOnly Property ActiveBreakpoint As Color
    Get
public:
static property Color ActiveBreakpoint {
    Color get ();
}
static member ActiveBreakpoint : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.Background Property

SMathColorsBackground Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Background { get; }
Public Shared ReadOnly Property Background As Color
    Get
public:
static property Color Background {
    Color get ();
}
static member Background : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.Breakpoint Property

SMathColorsBreakpoint Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Breakpoint { get; }
Public Shared ReadOnly Property Breakpoint As Color
    Get
public:
static property Color Breakpoint {
    Color get ();
}
static member Breakpoint : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.ErrorEntry Property

SMathColorsErrorEntry Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color ErrorEntry { get; }
Public Shared ReadOnly Property ErrorEntry As Color
    Get
public:
static property Color ErrorEntry {
    Color get ();
}
static member ErrorEntry : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.HighlightedText Property

SMathColorsHighlightedText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color HighlightedText { get; }
Public Shared ReadOnly Property HighlightedText As Color
    Get
public:
static property Color HighlightedText {
    Color get ();
}
static member HighlightedText : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.RegularText Property

SMathColorsRegularText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color RegularText { get; }
Public Shared ReadOnly Property RegularText As Color
    Get
public:
static property Color RegularText {
    Color get ();
}
static member RegularText : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.Selection Property

SMathColorsSelection Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color Selection { get; }
Public Shared ReadOnly Property Selection As Color
    Get
public:
static property Color Selection {
    Color get ();
}
static member Selection : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.StringEntry Property

SMathColorsStringEntry Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color StringEntry { get; }
Public Shared ReadOnly Property StringEntry As Color
    Get
public:
static property Color StringEntry {
    Color get ();
}
static member StringEntry : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


SMathColors.UnitEntry Property

SMathColorsUnitEntry Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Color UnitEntry { get; }
Public Shared ReadOnly Property UnitEntry As Color
    Get
public:
static property Color UnitEntry {
    Color get ();
}
static member UnitEntry : Color with get

Property Value

Type: Color
See Also

Reference

SMathColors Class
SMath.Manager Namespace


Symbols Structure

Доступные встроенные символы программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public struct Symbols
Public Structure Symbols
public value class Symbols
[<SealedAttribute>]
type Symbols =  struct end

The Symbols type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
Name | Description
AbsoluteChar | Symbol shown at start of each absolute definition of math expression.Символ, идентифицирующий абсолютное определение.
EilerConstant | Eiler constant.Константа e.
EmptyOperand | Empty operand (placeholder).Пустой (незаполненный) операнд.
ImaginaryUnit | Imaginary unit.Мнимая единица.
Infinity | Infinity.Бесконечность.
PiConstant | Pi constant.Константа пи.
StringChar | Symbol shown at start and at the end of each String of math expression.Символ, идентифицирующий строку.
UnitChar | Symbol shown at start of each Unit of math expression.Символ, идентифицирующий единицу измерения.
Top
See Also

Reference

SMath.Manager Namespace


Symbols Methods

The Symbols type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols Fields

The Symbols type exposes the following members.

Fields
Name | Description
AbsoluteChar | Symbol shown at start of each absolute definition of math expression.Символ, идентифицирующий абсолютное определение.
EilerConstant | Eiler constant.Константа e.
EmptyOperand | Empty operand (placeholder).Пустой (незаполненный) операнд.
ImaginaryUnit | Imaginary unit.Мнимая единица.
Infinity | Infinity.Бесконечность.
PiConstant | Pi constant.Константа пи.
StringChar | Symbol shown at start and at the end of each String of math expression.Символ, идентифицирующий строку.
UnitChar | Symbol shown at start of each Unit of math expression.Символ, идентифицирующий единицу измерения.
Top
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.AbsoluteChar Field

SymbolsAbsoluteChar Field

Symbol shown at start of each absolute definition of math expression.Символ, идентифицирующий абсолютное определение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string AbsoluteChar = "~"
Public Const AbsoluteChar As String = "~"
public:
literal String^ AbsoluteChar = "~"
static val mutable AbsoluteChar: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.EilerConstant Field

SymbolsEilerConstant Field

Eiler constant.Константа e.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EilerConstant = "e"
Public Const EilerConstant As String = "e"
public:
literal String^ EilerConstant = "e"
static val mutable EilerConstant: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.EmptyOperand Field

SymbolsEmptyOperand Field

Empty operand (placeholder).Пустой (незаполненный) операнд.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string EmptyOperand = "#"
Public Const EmptyOperand As String = "#"
public:
literal String^ EmptyOperand = "#"
static val mutable EmptyOperand: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.ImaginaryUnit Field

SymbolsImaginaryUnit Field

Imaginary unit.Мнимая единица.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string ImaginaryUnit = "i"
Public Const ImaginaryUnit As String = "i"
public:
literal String^ ImaginaryUnit = "i"
static val mutable ImaginaryUnit: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.Infinity Field

SymbolsInfinity Field

Infinity.Бесконечность.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string Infinity = "∞"
Public Const Infinity As String = "∞"
public:
literal String^ Infinity = "∞"
static val mutable Infinity: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.PiConstant Field

SymbolsPiConstant Field

Pi constant.Константа пи.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string PiConstant = "π"
Public Const PiConstant As String = "π"
public:
literal String^ PiConstant = "π"
static val mutable PiConstant: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.StringChar Field

SymbolsStringChar Field

Symbol shown at start and at the end of each String of math expression.Символ, идентифицирующий строку.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string StringChar = """
Public Const StringChar As String = """
public:
literal String^ StringChar = """
static val mutable StringChar: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


Symbols.UnitChar Field

SymbolsUnitChar Field

Symbol shown at start of each Unit of math expression.Символ, идентифицирующий единицу измерения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string UnitChar = "'"
Public Const UnitChar As String = "'"
public:
literal String^ UnitChar = "'"
static val mutable UnitChar: string

Field Value

Type: String
See Also

Reference

Symbols Structure
SMath.Manager Namespace


SysSettings Enumeration

Тип отображения системы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum SysSettings
Public Enumeration SysSettings
public enum class SysSettings
type SysSettings
Members
Member name | Value | Description
None | 0 | Показывать все строки системы.
UnRepeatable | 1 | Показывать только уникальные строки системы.
See Also

Reference

SMath.Manager Namespace


Term Class

Expression component.Компонента выражения.
Inheritance Hierarchy
SystemObject
SMath.ManagerTerm
SMath.ManagerTermInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Term : IPrimitive, IEquatable<Term>
Public Class Term
    Implements IPrimitive, IEquatable(Of Term)
public ref class Term : IPrimitive, IEquatable<Term^>
type Term =
    class
        interface IPrimitive
        interface IEquatable<Term>
    end

The Term type exposes the following members.

Constructors
 | Name | Description
Public method | Term(IPrimitive) | Copying of the expression component.Копирование компоненты выражения.
Public method | Term(Term) | Initializes a new instance of the Term class
Public method | Term(String, TermType, Int32) | Constructor of the instance of an expression component.Создание компоненты выражения.
Top
Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property | ChildCount | Obsolete.
Public property Text
Text value of the expression component.Текстовая ценность компоненты выражения.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Shows a string representation of current expression component.Показывает строковое представление текущего компонента выражения. (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Compares data of two Term instances.Сравнивает данные двух экземпляров Term.
Inequality | Compares data of two Term instances.Сравнивает данные двух экземпляров Term.
Top
Fields
Name | Description
Empty | Empty instance of the expression component.Пустой экземпляр компоненты выражения.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEquatableTermEquals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом.
Top
See Also

Reference

SMath.Manager Namespace


Term Constructor

Overload List
 | Name | Description
Public method | Term(IPrimitive) | Copying of the expression component.Копирование компоненты выражения.
Public method | Term(Term) | Initializes a new instance of the Term class
Public method | Term(String, TermType, Int32) | Constructor of the instance of an expression component.Создание компоненты выражения.
Top
See Also

Reference

Term Class
SMath.Manager Namespace


Term Constructor (IPrimitive)

Copying of the expression component.Копирование компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term(
    IPrimitive value
)
Public Sub New (
    value As IPrimitive
)
public:
Term(
    IPrimitive^ value
)
new :
        value : IPrimitive -> Term

Parameters

value
Type: SMath.ManagerIPrimitive
Expression component.Компоненты выражения.
See Also

Reference

Term Class
Term Overload
SMath.Manager Namespace


Term Constructor (Term)

Initializes a new instance of the Term class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term(
    Term value
)
Public Sub New (
    value As Term
)
public:
Term(
    Term^ value
)
new :
        value : Term -> Term

Parameters

value
Type: SMath.ManagerTerm
See Also

Reference

Term Class
Term Overload
SMath.Manager Namespace


Term Constructor (String, TermType, Int32)

Constructor of the instance of an expression component.Создание компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term(
    string text,
    TermType type,
    int childCount
)
Public Sub New (
    text As String,
    type As TermType,
    childCount As Integer
)
public:
Term(
    String^ text,
    TermType type,
    int childCount
)
new :
        text : string *
        type : TermType *
        childCount : int -> Term

Parameters

text
Type: SystemString
Text value of the expression component.Текстовая ценность компоненты выражения.
type
Type: SMath.ManagerTermType
Type of the expression component.Определение типа компоненты выражения.
childCount
Type: SystemInt32
Number of children of the expression component.Количество аргументов компоненты выражения.
See Also

Reference

Term Class
Term Overload
SMath.Manager Namespace


Term Properties

The Term type exposes the following members.

Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property | ChildCount | Obsolete.
Public property Text
Text value of the expression component.Текстовая ценность компоненты выражения.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
Top
See Also

Reference

Term Class
SMath.Manager Namespace


Term.ArgsCount Property

TermArgsCount Property

Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int ArgsCount { get; }
Public ReadOnly Property ArgsCount As Integer
    Get
public:
virtual property int ArgsCount {
    int get () sealed;
}
abstract ArgsCount : int with get
override ArgsCount : int with get

Property Value

Type: Int32

Implements

IPrimitiveArgsCount
See Also

Reference

Term Class
SMath.Manager Namespace


Term.ChildCount Property

TermChildCount Property

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ArgsCount instead", false)]
public int ChildCount { get; set; }
<ObsoleteAttribute("Use ArgsCount instead", false)>
Public Property ChildCount As Integer
    Get
    Set
public:
[ObsoleteAttribute(L"Use ArgsCount instead", false)]
property int ChildCount {
    int get ();
    void set (int value);
}
[<ObsoleteAttribute("Use ArgsCount instead", false)>]
member ChildCount : int with get, set

Property Value

Type: Int32
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Text Property

TermText Property

Text value of the expression component.Текстовая ценность компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Text : string with get, set
override Text : string with get, set

Property Value

Type: String

Implements

IPrimitiveText
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Type Property

TermType Property

Type of the expression component.Определение типа компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermType Type { get; set; }
Public Property Type As TermType
    Get
    Set
public:
virtual property TermType Type {
    TermType get () sealed;
    void set (TermType value) sealed;
}
abstract Type : TermType with get, set
override Type : TermType with get, set

Property Value

Type: TermType

Implements

IPrimitiveType
See Also

Reference

Term Class
SMath.Manager Namespace


Term Methods

The Term type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Shows a string representation of current expression component.Показывает строковое представление текущего компонента выражения. (Overrides ObjectToString.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEquatableTermEquals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом.
Top
See Also

Reference

Term Class
SMath.Manager Namespace


Term.IEquatable(Term).Equals Method

TermIEquatableTermEquals Method

Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool IEquatable<Term>.Equals(
    Term other
)
Private Function Equals (
    other As Term
) As Boolean Implements IEquatable(Of Term).Equals
private:
virtual bool Equals(
    Term^ other
) sealed = IEquatable<Term^>::Equals
private abstract Equals :
        other : Term -> bool
private override Equals :
        other : Term -> bool

Parameters

other
Type: SMath.ManagerTerm
Term to compare with the current expression component.Элемент для сравнения с текущим компонентом выражения.

Return Value

Type: Boolean
Returns true if data is equal and false otherwise.Возвращает истину, если данные идентичны, и ложь в обратном случае.

Implements

IEquatableTEquals(T)
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Clone Method

TermClone Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term Clone()
Public Function Clone As Term
public:
Term^ Clone()
member Clone : unit -> Term

Return Value

Type: Term
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Equals Method

TermEquals Method

Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Object to compare with the current expression component.Объект для сравнения с текущим компонентом выражения.

Return Value

Type: Boolean
Returns true if data is equal and false otherwise.Возвращает истину, если данные идентичны, и ложь в обратном случае.
See Also

Reference

Term Class
SMath.Manager Namespace


Term.GetHashCode Method

TermGetHashCode Method

Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Term.Хэш-код текущего типа.
See Also

Reference

Term Class
SMath.Manager Namespace


Term.ToString Method

TermToString Method

Shows a string representation of current expression component.Показывает строковое представление текущего компонента выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Return a string representation of current expression component.Возвращает строковое представление текущего компонента выражения.
See Also

Reference

Term Class
SMath.Manager Namespace


Term Operators

The Term type exposes the following members.

Operators
Name | Description
Equality | Compares data of two Term instances.Сравнивает данные двух экземпляров Term.
Inequality | Compares data of two Term instances.Сравнивает данные двух экземпляров Term.
Top
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Equality Operator

TermEquality Operator

Compares data of two Term instances.Сравнивает данные двух экземпляров Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    Term c1,
    Term c2
)
Public Shared Operator = (
    c1 As Term,
    c2 As Term
) As Boolean
public:
static bool operator ==(
    Term^ c1,
    Term^ c2
)
static let inline (=)
        c1 : Term *
        c2 : Term  : bool

Parameters

c1
Type: SMath.ManagerTerm
First instance to compare.Первый экземпляр для сравнения.
c2
Type: SMath.ManagerTerm
Second instance to compare.Второй экземпляр для сравнения.

Return Value

Type: Boolean
Returns true if data is equal and false otherwise.Возвращает истину, если данные идентичны, и ложь в обратном случае.
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Inequality Operator

TermInequality Operator

Compares data of two Term instances.Сравнивает данные двух экземпляров Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    Term c1,
    Term c2
)
Public Shared Operator <> (
    c1 As Term,
    c2 As Term
) As Boolean
public:
static bool operator !=(
    Term^ c1,
    Term^ c2
)
static let inline (<>)
        c1 : Term *
        c2 : Term  : bool

Parameters

c1
Type: SMath.ManagerTerm
First instance to compare.Первый экземпляр для сравнения.
c2
Type: SMath.ManagerTerm
Second instance to compare.Второй экземпляр для сравнения.

Return Value

Type: Boolean
Returns false if data is equal and true otherwise.Возвращает ложь, если данные идентичны, и истину в обратном случае.
See Also

Reference

Term Class
SMath.Manager Namespace


Term Fields

The Term type exposes the following members.

Fields
Name | Description
Empty | Empty instance of the expression component.Пустой экземпляр компоненты выражения.
Top
See Also

Reference

Term Class
SMath.Manager Namespace


Term.Empty Field

TermEmpty Field

Empty instance of the expression component.Пустой экземпляр компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static readonly Term Empty
Public Shared ReadOnly Empty As Term
public:
static initonly Term^ Empty
static val Empty: Term

Field Value

Type: Term
See Also

Reference

Term Class
SMath.Manager Namespace


TermFormat Class

Inheritance Hierarchy
SystemObject
SMath.ManagerTermFormat

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TermFormat
Public Class TermFormat
public ref class TermFormat
type TermFormat =  class end

The TermFormat type exposes the following members.

Constructors
 | Name | Description
Public method | TermFormat | Initializes a new instance of the TermFormat class
Top
Properties
 | Name | Description
Public property | Brush |
Public property | FontStyle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareFont |
Public method | PrepareSize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


TermFormat Constructor

Initializes a new instance of the TermFormat class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermFormat(
    float fontSize,
    IFontFamily family,
    FontfaceStyle style,
    Color textColor,
    Color backgroundColor
)
Public Sub New (
    fontSize As Single,
    family As IFontFamily,
    style As FontfaceStyle,
    textColor As Color,
    backgroundColor As Color
)
public:
TermFormat(
    float fontSize,
    IFontFamily^ family,
    FontfaceStyle style,
    Color textColor,
    Color backgroundColor
)
new :
        fontSize : float32 *
        family : IFontFamily *
        style : FontfaceStyle *
        textColor : Color *
        backgroundColor : Color -> TermFormat

Parameters

fontSize
Type: SystemSingle
family
Type: SMath.DrawingIFontFamily
style
Type: SMath.DrawingFontfaceStyle
textColor
Type: System.DrawingColor
backgroundColor
Type: System.DrawingColor
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat Properties

The TermFormat type exposes the following members.

Properties
 | Name | Description
Public property | Brush |
Public property | FontStyle |
Top
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat.Brush Property

TermFormatBrush Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ColorBrush Brush { get; }
Public ReadOnly Property Brush As ColorBrush
    Get
public:
property ColorBrush^ Brush {
    ColorBrush^ get ();
}
member Brush : ColorBrush with get

Property Value

Type: ColorBrush
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat.FontStyle Property

TermFormatFontStyle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontfaceStyle FontStyle { get; }
Public ReadOnly Property FontStyle As FontfaceStyle
    Get
public:
property FontfaceStyle FontStyle {
    FontfaceStyle get ();
}
member FontStyle : FontfaceStyle with get

Property Value

Type: FontfaceStyle
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat Methods

The TermFormat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareFont |
Public method | PrepareSize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat.PrepareFont Method

TermFormatPrepareFont Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FontInfo PrepareFont(
    SessionProfile sessionProfile,
    float fontSize
)
Public Function PrepareFont (
    sessionProfile As SessionProfile,
    fontSize As Single
) As FontInfo
public:
FontInfo^ PrepareFont(
    SessionProfile^ sessionProfile,
    float fontSize
)
member PrepareFont :
        sessionProfile : SessionProfile *
        fontSize : float32 -> FontInfo

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
fontSize
Type: SystemSingle

Return Value

Type: FontInfo
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermFormat.PrepareSize Method

TermFormatPrepareSize Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public float PrepareSize(
    SessionProfile sessionProfile,
    float fontSize
)
Public Function PrepareSize (
    sessionProfile As SessionProfile,
    fontSize As Single
) As Single
public:
float PrepareSize(
    SessionProfile^ sessionProfile,
    float fontSize
)
member PrepareSize :
        sessionProfile : SessionProfile *
        fontSize : float32 -> float32

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
fontSize
Type: SystemSingle

Return Value

Type: Single
See Also

Reference

TermFormat Class
SMath.Manager Namespace


TermInfo Class

Information about the Term.Информация об элементе выражения.
Inheritance Hierarchy
SystemObject
SMath.ManagerTerm
SMath.ManagerTermInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TermInfo : Term, IDetailedTerm
Public Class TermInfo
    Inherits Term
    Implements IDetailedTerm
public ref class TermInfo : public Term,
    IDetailedTerm
type TermInfo =
    class
        inherit Term
        interface IDetailedTerm
    end

The TermInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, ArgumentInfo) | Constructor of new Term information.Конструктор типа информации об элементе выражения.
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Term, ArgumentInfo) | Constructor of new Term information.Конструктор типа информации об элементе выражения.
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Boolean, ArgumentInfo) | Initializes a new instance of the TermInfo class
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Boolean, Term, ArgumentInfo) | Initializes a new instance of the TermInfo class
Top
Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
(Inherited from Term.)
Public property Arguments
Array of Term's arguments.Массив аргументов элемента.
Public property | ChildCount | Obsolete. (Inherited from Term.)
Public property DefaultArguments
List of default arguments to be used for a function.Список аргументов по-умолчанию для функции.
Public property Description
Description of the Term.Описание элемента выражения.
Public property | IsUndefinedArgumentsSupported
Public property NameGuid
Gets or sets a GUID for Term text name.Возвращает или задаёт GUID для имени элемента.
Remarks
Used if the Term has different text names for every Function's Types specified by program.Используется если элемент выражения имеет различные имена в зависимости от заданного типа функций программы.
Public property Section
Term's section.Раздел элемента выражения.
Public property | SupportedUnderVectorization
Public property | Text
Public property Title
Always empty as it is not used for Functions.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
(Inherited from Term.)
Public property Visible
If Term is visible for user.Определяет виден ли элемент пользователю.
Top
Methods
 | Name | Description
Public method | AddNameGuidPair | Adds a pair of Name and GUID in order to support additional Function's Type.Добавляет пару имени с GUID для поддержки дополнительного типа функций программы.
 | ChangeTermByNamingType | Changes naming type of the specified Term.Меняет тип имени указанного примитива.
Public method | Clone | (Inherited from Term.)
Public method | Equals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Inherited from Term.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetails | Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.
Public method | GetDetailsHtml | Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Inherited from Term.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsPreserved | Checks if Term is defined in one of the loaded plug-ins or is it built-in primitive.Проверяет существует ли определение элементу выражения в одном из загруженных дополнений (плагинов) или он является встроенным.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Shows a string representation of current expression component.Показывает строковое представление текущего компонента выражения. (Inherited from Term.)
Public method | ToTerm |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEquatableTermEquals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Inherited from Term.)
Top
See Also

Reference

SMath.Manager Namespace


TermInfo Constructor

Overload List
 | Name | Description
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, ArgumentInfo) | Constructor of new Term information.Конструктор типа информации об элементе выражения.
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Term, ArgumentInfo) | Constructor of new Term information.Конструктор типа информации об элементе выражения.
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Boolean, ArgumentInfo) | Initializes a new instance of the TermInfo class
Public method | TermInfo(String, TermType, String, FunctionSections, Boolean, Boolean, Term, ArgumentInfo) | Initializes a new instance of the TermInfo class
Top
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, ArgumentInfo[])

TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, ArgumentInfo)

Constructor of new Term information.Конструктор типа информации об элементе выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo(
    string name,
    TermType type,
    string description,
    FunctionSections section,
    bool visible,
    params ArgumentInfo[] args
)
Public Sub New (
    name As String,
    type As TermType,
    description As String,
    section As FunctionSections,
    visible As Boolean,
    ParamArray args As ArgumentInfo()
)
public:
TermInfo(
    String^ name,
    TermType type,
    String^ description,
    FunctionSections section,
    bool visible,
    ... array<ArgumentInfo^>^ args
)
new :
        name : string *
        type : TermType *
        description : string *
        section : FunctionSections *
        visible : bool *
        args : ArgumentInfo[] -> TermInfo

Parameters

name
Type: SystemString
Term's default name.Имя элемента выражения по-умолчанию.
type
Type: SMath.ManagerTermType
Type of the Term.Тип элемента выражения.
description
Type: SystemString
Description of the Term.Описание элемента выражения.
section
Type: SMath.ManagerFunctionSections
Term's section.Раздел элемента выражения.
visible
Type: SystemBoolean
If Term is visible for user.Определяет виден ли элемент пользователю.
args
Type: SMath.ManagerArgumentInfo
Array of Term's arguments.Массив аргументов элемента.
See Also

Reference

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Term[], ArgumentInfo[])

TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Term, ArgumentInfo)

Constructor of new Term information.Конструктор типа информации об элементе выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo(
    string name,
    TermType type,
    string description,
    FunctionSections section,
    bool visible,
    Term[] defArgs,
    params ArgumentInfo[] args
)
Public Sub New (
    name As String,
    type As TermType,
    description As String,
    section As FunctionSections,
    visible As Boolean,
    defArgs As Term(),
    ParamArray args As ArgumentInfo()
)
public:
TermInfo(
    String^ name,
    TermType type,
    String^ description,
    FunctionSections section,
    bool visible,
    array<Term^>^ defArgs,
    ... array<ArgumentInfo^>^ args
)
new :
        name : string *
        type : TermType *
        description : string *
        section : FunctionSections *
        visible : bool *
        defArgs : Term[] *
        args : ArgumentInfo[] -> TermInfo

Parameters

name
Type: SystemString
Term's default name.Имя элемента выражения по-умолчанию.
type
Type: SMath.ManagerTermType
Type of the Term.Тип элемента выражения.
description
Type: SystemString
Description of the Term.Описание элемента выражения.
section
Type: SMath.ManagerFunctionSections
Term's section.Раздел элемента выражения.
visible
Type: SystemBoolean
If Term is visible for user.Определяет виден ли элемент пользователю.
defArgs
Type: SMath.ManagerTerm
List of default arguments to be used for a function.Список аргументов по-умолчанию для функции.
args
Type: SMath.ManagerArgumentInfo
Array of Term's arguments.Массив аргументов элемента.
See Also

Reference

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Boolean, ArgumentInfo[])

TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Boolean, ArgumentInfo)

Initializes a new instance of the TermInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo(
    string name,
    TermType type,
    string description,
    FunctionSections section,
    bool visible,
    bool supportedUnderVectorization,
    params ArgumentInfo[] args
)
Public Sub New (
    name As String,
    type As TermType,
    description As String,
    section As FunctionSections,
    visible As Boolean,
    supportedUnderVectorization As Boolean,
    ParamArray args As ArgumentInfo()
)
public:
TermInfo(
    String^ name,
    TermType type,
    String^ description,
    FunctionSections section,
    bool visible,
    bool supportedUnderVectorization,
    ... array<ArgumentInfo^>^ args
)
new :
        name : string *
        type : TermType *
        description : string *
        section : FunctionSections *
        visible : bool *
        supportedUnderVectorization : bool *
        args : ArgumentInfo[] -> TermInfo

Parameters

name
Type: SystemString
type
Type: SMath.ManagerTermType
description
Type: SystemString
section
Type: SMath.ManagerFunctionSections
visible
Type: SystemBoolean
supportedUnderVectorization
Type: SystemBoolean
args
Type: SMath.ManagerArgumentInfo
See Also

Reference

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Boolean, Term[], ArgumentInfo[])

TermInfo Constructor (String, TermType, String, FunctionSections, Boolean, Boolean, Term, ArgumentInfo)

Initializes a new instance of the TermInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermInfo(
    string name,
    TermType type,
    string description,
    FunctionSections section,
    bool visible,
    bool supportedUnderVectorization,
    Term[] defArgs,
    params ArgumentInfo[] args
)
Public Sub New (
    name As String,
    type As TermType,
    description As String,
    section As FunctionSections,
    visible As Boolean,
    supportedUnderVectorization As Boolean,
    defArgs As Term(),
    ParamArray args As ArgumentInfo()
)
public:
TermInfo(
    String^ name,
    TermType type,
    String^ description,
    FunctionSections section,
    bool visible,
    bool supportedUnderVectorization,
    array<Term^>^ defArgs,
    ... array<ArgumentInfo^>^ args
)
new :
        name : string *
        type : TermType *
        description : string *
        section : FunctionSections *
        visible : bool *
        supportedUnderVectorization : bool *
        defArgs : Term[] *
        args : ArgumentInfo[] -> TermInfo

Parameters

name
Type: SystemString
type
Type: SMath.ManagerTermType
description
Type: SystemString
section
Type: SMath.ManagerFunctionSections
visible
Type: SystemBoolean
supportedUnderVectorization
Type: SystemBoolean
defArgs
Type: SMath.ManagerTerm
args
Type: SMath.ManagerArgumentInfo
See Also

Reference

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Properties

The TermInfo type exposes the following members.

Properties
Name | Description
Public property ArgsCount
Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Количество аргументов компоненты выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
(Inherited from Term.)
Public property Arguments
Array of Term's arguments.Массив аргументов элемента.
Public property | ChildCount | Obsolete. (Inherited from Term.)
Public property DefaultArguments
List of default arguments to be used for a function.Список аргументов по-умолчанию для функции.
Public property Description
Description of the Term.Описание элемента выражения.
Public property | IsUndefinedArgumentsSupported
Public property NameGuid
Gets or sets a GUID for Term text name.Возвращает или задаёт GUID для имени элемента.
Remarks
Used if the Term has different text names for every Function's Types specified by program.Используется если элемент выражения имеет различные имена в зависимости от заданного типа функций программы.
Public property Section
Term's section.Раздел элемента выражения.
Public property | SupportedUnderVectorization
Public property | Text
Public property Title
Always empty as it is not used for Functions.
Public property Type
Type of the expression component.Определение типа компоненты выражения.
(Inherited from Term.)
Public property Visible
If Term is visible for user.Определяет виден ли элемент пользователю.
Top
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Arguments Property

TermInfoArguments Property

Array of Term's arguments.Массив аргументов элемента.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ArgumentInfo[] Arguments { get; }
Public ReadOnly Property Arguments As ArgumentInfo()
    Get
public:
property array<ArgumentInfo^>^ Arguments {
    array<ArgumentInfo^>^ get ();
}
member Arguments : ArgumentInfo[] with get

Property Value

Type: ArgumentInfo
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.DefaultArguments Property

TermInfoDefaultArguments Property

List of default arguments to be used for a function.Список аргументов по-умолчанию для функции.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] DefaultArguments { get; }
Public ReadOnly Property DefaultArguments As Term()
    Get
public:
property array<Term^>^ DefaultArguments {
    array<Term^>^ get ();
}
member DefaultArguments : Term[] with get

Property Value

Type: Term
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Description Property

TermInfoDescription Property

Description of the Term.Описание элемента выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IDetailedTermDescription
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.IsUndefinedArgumentsSupported Property

TermInfoIsUndefinedArgumentsSupported Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsUndefinedArgumentsSupported { set; }
Public WriteOnly Property IsUndefinedArgumentsSupported As Boolean
    Set
public:
property bool IsUndefinedArgumentsSupported {
    void set (bool value);
}
member IsUndefinedArgumentsSupported : bool with set

Property Value

Type: Boolean
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.NameGuid Property

TermInfoNameGuid Property

Gets or sets a GUID for Term text name.Возвращает или задаёт GUID для имени элемента.
Remarks
Used if the Term has different text names for every Function's Types specified by program.Используется если элемент выражения имеет различные имена в зависимости от заданного типа функций программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Guid NameGuid { get; set; }
Public Property NameGuid As Guid
    Get
    Set
public:
property Guid NameGuid {
    Guid get ();
    void set (Guid value);
}
member NameGuid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Section Property

TermInfoSection Property

Term's section.Раздел элемента выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FunctionSections Section { get; }
Public ReadOnly Property Section As FunctionSections
    Get
public:
property FunctionSections Section {
    FunctionSections get ();
}
member Section : FunctionSections with get

Property Value

Type: FunctionSections
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.SupportedUnderVectorization Property

TermInfoSupportedUnderVectorization Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SupportedUnderVectorization { get; }
Public ReadOnly Property SupportedUnderVectorization As Boolean
    Get
public:
property bool SupportedUnderVectorization {
    bool get ();
}
member SupportedUnderVectorization : bool with get

Property Value

Type: Boolean
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Text Property

TermInfoText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Title Property

TermInfoTitle Property

Always empty as it is not used for Functions.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get

Property Value

Type: String

Implements

IDetailedTermTitle
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.Visible Property

TermInfoVisible Property

If Term is visible for user.Определяет виден ли элемент пользователю.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Property Value

Type: Boolean
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo Methods

The TermInfo type exposes the following members.

Methods
 | Name | Description
Public method | AddNameGuidPair | Adds a pair of Name and GUID in order to support additional Function's Type.Добавляет пару имени с GUID для поддержки дополнительного типа функций программы.
 | ChangeTermByNamingType | Changes naming type of the specified Term.Меняет тип имени указанного примитива.
Public method | Clone | (Inherited from Term.)
Public method | Equals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Inherited from Term.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetails | Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.
Public method | GetDetailsHtml | Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Inherited from Term.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | IsPreserved | Checks if Term is defined in one of the loaded plug-ins or is it built-in primitive.Проверяет существует ли определение элементу выражения в одном из загруженных дополнений (плагинов) или он является встроенным.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Shows a string representation of current expression component.Показывает строковое представление текущего компонента выражения. (Inherited from Term.)
Public method | ToTerm |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IEquatableTermEquals | Compares an object with a second one.Сравнивает текущий экземпляр компонента выражения со вторым объектом. (Inherited from Term.)
Top
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.AddNameGuidPair Method

TermInfoAddNameGuidPair Method

Adds a pair of Name and GUID in order to support additional Function's Type.Добавляет пару имени с GUID для поддержки дополнительного типа функций программы.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddNameGuidPair(
    string name,
    Guid guid
)
Public Sub AddNameGuidPair (
    name As String,
    guid As Guid
)
public:
void AddNameGuidPair(
    String^ name,
    Guid guid
)
member AddNameGuidPair :
        name : string *
        guid : Guid -> unit

Parameters

name
Type: SystemString
Term's name.Имя элемента выражения.
guid
Type: SystemGuid
GUID of the Function's Type.GUID типа функций программы.
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.ChangeTermByNamingType Method

TermInfoChangeTermByNamingType Method

Changes naming type of the specified Term.Меняет тип имени указанного примитива.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool ChangeTermByNamingType(
    SessionProfile sessionProfile,
    Term value,
    Guid toType,
    bool standard
)
Public Shared Function ChangeTermByNamingType (
    sessionProfile As SessionProfile,
    value As Term,
    toType As Guid,
    standard As Boolean
) As Boolean
public:
static bool ChangeTermByNamingType(
    SessionProfile^ sessionProfile,
    Term^ value,
    Guid toType,
    bool standard
)
static member ChangeTermByNamingType :
        sessionProfile : SessionProfile *
        value : Term *
        toType : Guid *
        standard : bool -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SMath.ManagerTerm
Term to process changes.Примитив для проведения изменений.
toType
Type: SystemGuid
Target naming type of the Term.Искомый тип имени примитива.
standard
Type: SystemBoolean

Return Value

Type: Boolean
Returns true if change was performed successfully. False otherwise.Возвращает истину, если изменение прошло успешно. В противном случае возвращает ложь.
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.GetDetails Method

TermInfoGetDetails Method

Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetDetails(
    SessionProfile sessionProfile
)
Public Function GetDetails (
    sessionProfile As SessionProfile
) As String
public:
virtual String^ GetDetails(
    SessionProfile^ sessionProfile
) sealed
abstract GetDetails :
        sessionProfile : SessionProfile -> string
override GetDetails :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
Return a string representation of current expression component information.Возвращает строковое представление текущей информации о компоненте выражения.

Implements

IDetailedTermGetDetails(SessionProfile)
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.GetDetailsHtml Method

TermInfoGetDetailsHtml Method

Shows a string representation of current expression component information.Показывает строковое представление текущей информации о компоненте выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetDetailsHtml(
    SessionProfile sessionProfile
)
Public Function GetDetailsHtml (
    sessionProfile As SessionProfile
) As String
public:
String^ GetDetailsHtml(
    SessionProfile^ sessionProfile
)
member GetDetailsHtml :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String
Return a string representation of current expression component information.Возвращает строковое представление текущей информации о компоненте выражения.
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.IsPreserved Method

TermInfoIsPreserved Method

Checks if Term is defined in one of the loaded plug-ins or is it built-in primitive.Проверяет существует ли определение элементу выражения в одном из загруженных дополнений (плагинов) или он является встроенным.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool IsPreserved(
    SessionProfile sessionProfile,
    Term value,
    out TermInfo termInfo,
    bool standard
)
Public Shared Function IsPreserved (
    sessionProfile As SessionProfile,
    value As Term,
    <OutAttribute> ByRef termInfo As TermInfo,
    standard As Boolean
) As Boolean
public:
static bool IsPreserved(
    SessionProfile^ sessionProfile,
    Term^ value,
    [OutAttribute] TermInfo^% termInfo,
    bool standard
)
static member IsPreserved :
        sessionProfile : SessionProfile *
        value : Term *
        termInfo : TermInfo byref *
        standard : bool -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
value
Type: SMath.ManagerTerm
Expression component to find definition for.Компонент выражения, для которого производится проверка наличия определения.
termInfo
Type: SMath.ManagerTermInfo
standard
Type: SystemBoolean

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermInfo.ToTerm Method

TermInfoToTerm Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm(
    SessionProfile sessionProfile
)
Public Function ToTerm (
    sessionProfile As SessionProfile
) As Term
public:
virtual Term^ ToTerm(
    SessionProfile^ sessionProfile
) sealed
abstract ToTerm :
        sessionProfile : SessionProfile -> Term
override ToTerm :
        sessionProfile : SessionProfile -> Term

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: Term

Implements

IDetailedTermToTerm(SessionProfile)
See Also

Reference

TermInfo Class
SMath.Manager Namespace


TermOrigin Enumeration

The origin of the expression component (order based on the priorities).Происхождение компоненты выражения (порядок согласно приоритетам).

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum TermOrigin
Public Enumeration TermOrigin
public enum class TermOrigin
type TermOrigin
Members
Member name | Value | Description
Undefined | 0 | Origin is undefined.Происхождение не определено.
BuiltIn | 1 | Built-in expression component.Встроенная компонента.
Plugin | 2 | Plug-in-defined expression component.Компонента определённая в дополнении (плагине).
UserDefined | 3 | User-defined expression component.Компонента определённая пользователем.
See Also

Reference

SMath.Manager Namespace


TermsConverter Class

Inheritance Hierarchy
SystemObject
SMath.ManagerTermsConverter

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class TermsConverter
Public NotInheritable Class TermsConverter
public ref class TermsConverter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TermsConverter =  class end

The TermsConverter type exposes the following members.

Methods
Name | Description
DecodeText(String) |
DecodeText(String, ContextVariables) | Replaces special chars in string.
DecodeText(String, ContextVariables, Boolean) |
EncodeText |
GetManager |
ToStandard(SessionProfile, IListTerm) |
ToStandard(SessionProfile, IListTerm, Int32) |
ToString | Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.
ToTerms | Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.
ToUser(SessionProfile, IListTerm) |
ToUser(SessionProfile, IListTerm, Int32) |
TryGetIndexOfPreviousChar |
Top
Fields
Name | Description
FieldAUTHOR |
FieldCOMPANY |
FieldCOUNT |
FieldDATE |
FieldDESCRIPTION |
FieldFILENAME |
FieldID |
FieldKEYWORDS |
FieldPAGENUM |
FieldREVISION |
FieldTIME |
FieldTITLE |
FieldTRANSLATOR |
Top
See Also

Reference

SMath.Manager Namespace


TermsConverter Methods

The TermsConverter type exposes the following members.

Methods
Name | Description
DecodeText(String) |
DecodeText(String, ContextVariables) | Replaces special chars in string.
DecodeText(String, ContextVariables, Boolean) |
EncodeText |
GetManager |
ToStandard(SessionProfile, IListTerm) |
ToStandard(SessionProfile, IListTerm, Int32) |
ToString | Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.
ToTerms | Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.
ToUser(SessionProfile, IListTerm) |
ToUser(SessionProfile, IListTerm, Int32) |
TryGetIndexOfPreviousChar |
Top
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.DecodeText Method

TermsConverterDecodeText Method

Overload List
Name | Description
DecodeText(String) |
DecodeText(String, ContextVariables) | Replaces special chars in string.
DecodeText(String, ContextVariables, Boolean) |
Top
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.DecodeText Method (String)

TermsConverterDecodeText Method (String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DecodeText(
    string text
)
Public Shared Function DecodeText (
    text As String
) As String
public:
static String^ DecodeText(
    String^ text
)
static member DecodeText :
        text : string -> string

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

TermsConverter Class
DecodeText Overload
SMath.Manager Namespace


TermsConverter.DecodeText Method (String, ContextVariables)

TermsConverterDecodeText Method (String, ContextVariables)

Replaces special chars in string.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DecodeText(
    string text,
    ContextVariables vars
)
Public Shared Function DecodeText (
    text As String,
    vars As ContextVariables
) As String
public:
static String^ DecodeText(
    String^ text,
    ContextVariables^ vars
)
static member DecodeText :
        text : string *
        vars : ContextVariables -> string

Parameters

text
Type: SystemString
String to decode.
vars
Type: SMath.ManagerContextVariables

Return Value

Type: String
Decoded string.
See Also

Reference

TermsConverter Class
DecodeText Overload
SMath.Manager Namespace


TermsConverter.DecodeText Method (String, ContextVariables, Boolean)

TermsConverterDecodeText Method (String, ContextVariables, Boolean)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DecodeText(
    string text,
    ContextVariables vars,
    ref bool containsFields
)
Public Shared Function DecodeText (
    text As String,
    vars As ContextVariables,
    ByRef containsFields As Boolean
) As String
public:
static String^ DecodeText(
    String^ text,
    ContextVariables^ vars,
    bool% containsFields
)
static member DecodeText :
        text : string *
        vars : ContextVariables *
        containsFields : bool byref -> string

Parameters

text
Type: SystemString
vars
Type: SMath.ManagerContextVariables
containsFields
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

TermsConverter Class
DecodeText Overload
SMath.Manager Namespace


TermsConverter.EncodeText Method

TermsConverterEncodeText Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string EncodeText(
    string input
)
Public Shared Function EncodeText (
    input As String
) As String
public:
static String^ EncodeText(
    String^ input
)
static member EncodeText :
        input : string -> string

Parameters

input
Type: SystemString

Return Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.GetManager Method

TermsConverterGetManager Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TermsConverterTextEntryManager GetManager(
    SessionProfile sessionProfile,
    bool isTerms
)
Public Shared Function GetManager (
    sessionProfile As SessionProfile,
    isTerms As Boolean
) As TermsConverterTextEntryManager
public:
static TermsConverterTextEntryManager^ GetManager(
    SessionProfile^ sessionProfile,
    bool isTerms
)
static member GetManager :
        sessionProfile : SessionProfile *
        isTerms : bool -> TermsConverterTextEntryManager

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
isTerms
Type: SystemBoolean

Return Value

Type: TermsConverterTextEntryManager
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.ToStandard Method

TermsConverterToStandard Method

Overload List
Name | Description
ToStandard(SessionProfile, IListTerm) |
ToStandard(SessionProfile, IListTerm, Int32) |
Top
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.ToStandard Method (SessionProfile, IList(Term))

TermsConverterToStandard Method (SessionProfile, IListTerm)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToStandard(
    SessionProfile sessionProfile,
    IList<Term> input
)
Public Shared Function ToStandard (
    sessionProfile As SessionProfile,
    input As IList(Of Term)
) As Term()
public:
static array<Term^>^ ToStandard(
    SessionProfile^ sessionProfile,
    IList<Term^>^ input
)
static member ToStandard :
        sessionProfile : SessionProfile *
        input : IList<Term> -> Term[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
input
Type: System.Collections.GenericIListTerm

Return Value

Type: Term
See Also

Reference

TermsConverter Class
ToStandard Overload
SMath.Manager Namespace


TermsConverter.ToStandard Method (SessionProfile, IList(Term), Int32)

TermsConverterToStandard Method (SessionProfile, IListTerm, Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToStandard(
    SessionProfile sessionProfile,
    IList<Term> input,
    int currentTermIdx
)
Public Shared Function ToStandard (
    sessionProfile As SessionProfile,
    input As IList(Of Term),
    currentTermIdx As Integer
) As Term()
public:
static array<Term^>^ ToStandard(
    SessionProfile^ sessionProfile,
    IList<Term^>^ input,
    int currentTermIdx
)
static member ToStandard :
        sessionProfile : SessionProfile *
        input : IList<Term> *
        currentTermIdx : int -> Term[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
input
Type: System.Collections.GenericIListTerm
currentTermIdx
Type: SystemInt32

Return Value

Type: Term
See Also

Reference

TermsConverter Class
ToStandard Overload
SMath.Manager Namespace


TermsConverter.ToString Method

TermsConverterToString Method

Converts math expression from the array of Term to string.Переводит математическое выражение из массива Term в строку.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string ToString(
    IList<Term> value
)
Public Shared Function ToString (
    value As IList(Of Term)
) As String
public:
static String^ ToString(
    IList<Term^>^ value
)
static member ToString :
        value : IList<Term> -> string

Parameters

value
Type: System.Collections.GenericIListTerm
Term array to perform conversion.Массив Term для преобразования.

Return Value

Type: String
Math expression represented as a string.Математическое выражение, записанное в строку.
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.ToTerms Method

TermsConverterToTerms Method

Converts math expression from the string to array of Term.Перевести математическое выражение из строки в массив Term.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToTerms(
    string value
)
Public Shared Function ToTerms (
    value As String
) As Term()
public:
static array<Term^>^ ToTerms(
    String^ value
)
static member ToTerms :
        value : string -> Term[]

Parameters

value
Type: SystemString
String to convert.Строка для преобразования.

Return Value

Type: Term
Math expression in RPN represented by the array of Term.Математическое выражение в виде ОПЗ, представленная массивом Term.
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.ToUser Method

TermsConverterToUser Method

Overload List
Name | Description
ToUser(SessionProfile, IListTerm) |
ToUser(SessionProfile, IListTerm, Int32) |
Top
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.ToUser Method (SessionProfile, IList(Term))

TermsConverterToUser Method (SessionProfile, IListTerm)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToUser(
    SessionProfile sessionProfile,
    IList<Term> input
)
Public Shared Function ToUser (
    sessionProfile As SessionProfile,
    input As IList(Of Term)
) As Term()
public:
static array<Term^>^ ToUser(
    SessionProfile^ sessionProfile,
    IList<Term^>^ input
)
static member ToUser :
        sessionProfile : SessionProfile *
        input : IList<Term> -> Term[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
input
Type: System.Collections.GenericIListTerm

Return Value

Type: Term
See Also

Reference

TermsConverter Class
ToUser Overload
SMath.Manager Namespace


TermsConverter.ToUser Method (SessionProfile, IList(Term), Int32)

TermsConverterToUser Method (SessionProfile, IListTerm, Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] ToUser(
    SessionProfile sessionProfile,
    IList<Term> input,
    int currentTermIdx
)
Public Shared Function ToUser (
    sessionProfile As SessionProfile,
    input As IList(Of Term),
    currentTermIdx As Integer
) As Term()
public:
static array<Term^>^ ToUser(
    SessionProfile^ sessionProfile,
    IList<Term^>^ input,
    int currentTermIdx
)
static member ToUser :
        sessionProfile : SessionProfile *
        input : IList<Term> *
        currentTermIdx : int -> Term[]

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
input
Type: System.Collections.GenericIListTerm
currentTermIdx
Type: SystemInt32

Return Value

Type: Term
See Also

Reference

TermsConverter Class
ToUser Overload
SMath.Manager Namespace


TermsConverter.TryGetIndexOfPreviousChar Method

TermsConverterTryGetIndexOfPreviousChar Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryGetIndexOfPreviousChar(
    SessionProfile sessionProfile,
    string text,
    int position,
    out int index
)
Public Shared Function TryGetIndexOfPreviousChar (
    sessionProfile As SessionProfile,
    text As String,
    position As Integer,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
static bool TryGetIndexOfPreviousChar(
    SessionProfile^ sessionProfile,
    String^ text,
    int position,
    [OutAttribute] int% index
)
static member TryGetIndexOfPreviousChar :
        sessionProfile : SessionProfile *
        text : string *
        position : int *
        index : int byref -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
text
Type: SystemString
position
Type: SystemInt32
index
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter Fields

The TermsConverter type exposes the following members.

Fields
Name | Description
FieldAUTHOR |
FieldCOMPANY |
FieldCOUNT |
FieldDATE |
FieldDESCRIPTION |
FieldFILENAME |
FieldID |
FieldKEYWORDS |
FieldPAGENUM |
FieldREVISION |
FieldTIME |
FieldTITLE |
FieldTRANSLATOR |
Top
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldAUTHOR Field

TermsConverterFieldAUTHOR Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldAUTHOR = "AUTHOR"
Public Const FieldAUTHOR As String = "AUTHOR"
public:
literal String^ FieldAUTHOR = "AUTHOR"
static val mutable FieldAUTHOR: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldCOMPANY Field

TermsConverterFieldCOMPANY Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldCOMPANY = "COMPANY"
Public Const FieldCOMPANY As String = "COMPANY"
public:
literal String^ FieldCOMPANY = "COMPANY"
static val mutable FieldCOMPANY: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldCOUNT Field

TermsConverterFieldCOUNT Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldCOUNT = "COUNT"
Public Const FieldCOUNT As String = "COUNT"
public:
literal String^ FieldCOUNT = "COUNT"
static val mutable FieldCOUNT: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldDATE Field

TermsConverterFieldDATE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldDATE = "DATE"
Public Const FieldDATE As String = "DATE"
public:
literal String^ FieldDATE = "DATE"
static val mutable FieldDATE: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldDESCRIPTION Field

TermsConverterFieldDESCRIPTION Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldDESCRIPTION = "DESCRIPTION"
Public Const FieldDESCRIPTION As String = "DESCRIPTION"
public:
literal String^ FieldDESCRIPTION = "DESCRIPTION"
static val mutable FieldDESCRIPTION: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldFILENAME Field

TermsConverterFieldFILENAME Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldFILENAME = "FILENAME"
Public Const FieldFILENAME As String = "FILENAME"
public:
literal String^ FieldFILENAME = "FILENAME"
static val mutable FieldFILENAME: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldID Field

TermsConverterFieldID Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldID = "ID"
Public Const FieldID As String = "ID"
public:
literal String^ FieldID = "ID"
static val mutable FieldID: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldKEYWORDS Field

TermsConverterFieldKEYWORDS Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldKEYWORDS = "KEYWORDS"
Public Const FieldKEYWORDS As String = "KEYWORDS"
public:
literal String^ FieldKEYWORDS = "KEYWORDS"
static val mutable FieldKEYWORDS: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldPAGENUM Field

TermsConverterFieldPAGENUM Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldPAGENUM = "PAGENUM"
Public Const FieldPAGENUM As String = "PAGENUM"
public:
literal String^ FieldPAGENUM = "PAGENUM"
static val mutable FieldPAGENUM: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldREVISION Field

TermsConverterFieldREVISION Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldREVISION = "REVISION"
Public Const FieldREVISION As String = "REVISION"
public:
literal String^ FieldREVISION = "REVISION"
static val mutable FieldREVISION: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldTIME Field

TermsConverterFieldTIME Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldTIME = "TIME"
Public Const FieldTIME As String = "TIME"
public:
literal String^ FieldTIME = "TIME"
static val mutable FieldTIME: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldTITLE Field

TermsConverterFieldTITLE Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldTITLE = "TITLE"
Public Const FieldTITLE As String = "TITLE"
public:
literal String^ FieldTITLE = "TITLE"
static val mutable FieldTITLE: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.FieldTRANSLATOR Field

TermsConverterFieldTRANSLATOR Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string FieldTRANSLATOR = "TRANSLATOR"
Public Const FieldTRANSLATOR As String = "TRANSLATOR"
public:
literal String^ FieldTRANSLATOR = "TRANSLATOR"
static val mutable FieldTRANSLATOR: string

Field Value

Type: String
See Also

Reference

TermsConverter Class
SMath.Manager Namespace


TermsConverter.TextEntryManager Class

TermsConverterTextEntryManager Class

Inheritance Hierarchy
SystemObject
SMath.ManagerTermsConverterTextEntryManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TextEntryManager
Public Class TextEntryManager
public ref class TextEntryManager
type TextEntryManager =  class end

The TermsConverterTextEntryManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFor(String) |
Public method | GetFor(String, Int32) |
Public method | GetFor(IPrimitive, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Substring |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


TextEntryManager Methods

The TermsConverterTextEntryManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFor(String) |
Public method | GetFor(String, Int32) |
Public method | GetFor(IPrimitive, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetList |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Substring |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TermsConverterTextEntryManager Class
SMath.Manager Namespace


TextEntryManager.GetFor Method

TextEntryManagerGetFor Method

Overload List
 | Name | Description
Public method | GetFor(String) |
Public method | GetFor(String, Int32) |
Public method | GetFor(IPrimitive, Int32) |
Top
See Also

Reference

TermsConverterTextEntryManager Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.GetFor Method (String)

TermsConverterTextEntryManagerGetFor Method (String)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermsConverterTextEntryManagerTextEntryState GetFor(
    string text
)
Public Function GetFor (
    text As String
) As TermsConverterTextEntryManagerTextEntryState
public:
TermsConverterTextEntryManagerTextEntryState^ GetFor(
    String^ text
)
member GetFor :
        text : string -> TermsConverterTextEntryManagerTextEntryState

Parameters

text
Type: SystemString

Return Value

Type: TermsConverterTextEntryManagerTextEntryState
See Also

Reference

TermsConverterTextEntryManager Class
GetFor Overload
SMath.Manager Namespace


TermsConverter.TextEntryManager.GetFor Method (String, Int32)

TermsConverterTextEntryManagerGetFor Method (String, Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermsConverterTextEntryManagerTextEntryState GetFor(
    string text,
    int cursorPos = -1
)
Public Function GetFor (
    text As String,
    Optional cursorPos As Integer = -1
) As TermsConverterTextEntryManagerTextEntryState
public:
TermsConverterTextEntryManagerTextEntryState^ GetFor(
    String^ text,
    int cursorPos = -1
)
member GetFor :
        text : string *
        ?cursorPos : int
(* Defaults:
        let _cursorPos = defaultArg cursorPos -1
*)
-> TermsConverterTextEntryManagerTextEntryState

Parameters

text
Type: SystemString
cursorPos (Optional)
Type: SystemInt32

Return Value

Type: TermsConverterTextEntryManagerTextEntryState
See Also

Reference

TermsConverterTextEntryManager Class
GetFor Overload
SMath.Manager Namespace


TermsConverter.TextEntryManager.GetFor Method (IPrimitive, Int32)

TermsConverterTextEntryManagerGetFor Method (IPrimitive, Int32)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermsConverterTextEntryManagerTextEntryState GetFor(
    IPrimitive term,
    int cursorPos = -1
)
Public Function GetFor (
    term As IPrimitive,
    Optional cursorPos As Integer = -1
) As TermsConverterTextEntryManagerTextEntryState
public:
TermsConverterTextEntryManagerTextEntryState^ GetFor(
    IPrimitive^ term,
    int cursorPos = -1
)
member GetFor :
        term : IPrimitive *
        ?cursorPos : int
(* Defaults:
        let _cursorPos = defaultArg cursorPos -1
*)
-> TermsConverterTextEntryManagerTextEntryState

Parameters

term
Type: SMath.ManagerIPrimitive
cursorPos (Optional)
Type: SystemInt32

Return Value

Type: TermsConverterTextEntryManagerTextEntryState
See Also

Reference

TermsConverterTextEntryManager Class
GetFor Overload
SMath.Manager Namespace


TermsConverter.TextEntryManager.GetList Method

TermsConverterTextEntryManagerGetList Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> GetList(
    string text,
    out int indexPos
)
Public Function GetList (
    text As String,
    <OutAttribute> ByRef indexPos As Integer
) As List(Of String)
public:
List<String^>^ GetList(
    String^ text,
    [OutAttribute] int% indexPos
)
member GetList :
        text : string *
        indexPos : int byref -> List<string>

Parameters

text
Type: SystemString
indexPos
Type: SystemInt32

Return Value

Type: ListString
See Also

Reference

TermsConverterTextEntryManager Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.Substring Method

TermsConverterTextEntryManagerSubstring Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Substring(
    string text,
    int pos,
    int length
)
Public Function Substring (
    text As String,
    pos As Integer,
    length As Integer
) As String
public:
String^ Substring(
    String^ text,
    int pos,
    int length
)
member Substring :
        text : string *
        pos : int *
        length : int -> string

Parameters

text
Type: SystemString
pos
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: String
See Also

Reference

TermsConverterTextEntryManager Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState Class

TermsConverterTextEntryManagerTextEntryState Class

Inheritance Hierarchy
SystemObject
SMath.ManagerTermsConverterTextEntryManagerTextEntryState

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TextEntryState
Public Class TextEntryState
public ref class TextEntryState
type TextEntryState =  class end

The TermsConverterTextEntryManagerTextEntryState type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsText |
Public property | Parts |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | InsertOnly |
Public method | IsLetterOrDigit |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveOnly |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


TextEntryState Properties

The TermsConverterTextEntryManagerTextEntryState type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsText |
Public property | Parts |
Top
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.Count Property

TermsConverterTextEntryManagerTextEntryStateCount Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.IsText Property

TermsConverterTextEntryManagerTextEntryStateIsText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsText { get; set; }
Public Property IsText As Boolean
    Get
    Set
public:
property bool IsText {
    bool get ();
    void set (bool value);
}
member IsText : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.Parts Property

TermsConverterTextEntryManagerTextEntryStateParts Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> Parts { get; }
Public ReadOnly Property Parts As List(Of String)
    Get
public:
property List<String^>^ Parts {
    List<String^>^ get ();
}
member Parts : List<string> with get

Property Value

Type: ListString
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TextEntryState Methods

The TermsConverterTextEntryManagerTextEntryState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | InsertOnly |
Public method | IsLetterOrDigit |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveOnly |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.Insert Method

TermsConverterTextEntryManagerTextEntryStateInsert Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Insert(
    int pos,
    string text
)
Public Function Insert (
    pos As Integer,
    text As String
) As String
public:
String^ Insert(
    int pos,
    String^ text
)
member Insert :
        pos : int *
        text : string -> string

Parameters

pos
Type: SystemInt32
text
Type: SystemString

Return Value

Type: String
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.InsertOnly Method

TermsConverterTextEntryManagerTextEntryStateInsertOnly Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void InsertOnly(
    int pos,
    string text
)
Public Sub InsertOnly (
    pos As Integer,
    text As String
)
public:
void InsertOnly(
    int pos,
    String^ text
)
member InsertOnly :
        pos : int *
        text : string -> unit

Parameters

pos
Type: SystemInt32
text
Type: SystemString
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.IsLetterOrDigit Method

TermsConverterTextEntryManagerTextEntryStateIsLetterOrDigit Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsLetterOrDigit(
    int pos
)
Public Function IsLetterOrDigit (
    pos As Integer
) As Boolean
public:
bool IsLetterOrDigit(
    int pos
)
member IsLetterOrDigit :
        pos : int -> bool

Parameters

pos
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.Remove Method

TermsConverterTextEntryManagerTextEntryStateRemove Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Remove(
    int pos,
    int length
)
Public Function Remove (
    pos As Integer,
    length As Integer
) As String
public:
String^ Remove(
    int pos,
    int length
)
member Remove :
        pos : int *
        length : int -> string

Parameters

pos
Type: SystemInt32
length
Type: SystemInt32

Return Value

Type: String
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsConverter.TextEntryManager.TextEntryState.RemoveOnly Method

TermsConverterTextEntryManagerTextEntryStateRemoveOnly Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveOnly(
    int pos,
    int length
)
Public Sub RemoveOnly (
    pos As Integer,
    length As Integer
)
public:
void RemoveOnly(
    int pos,
    int length
)
member RemoveOnly :
        pos : int *
        length : int -> unit

Parameters

pos
Type: SystemInt32
length
Type: SystemInt32
See Also

Reference

TermsConverterTextEntryManagerTextEntryState Class
SMath.Manager Namespace


TermsFuzzyComparer Class

Compares Terms according to their children count. It works according to the following rule: if one of the instances allows to handle any amount of children, then Terms will be defined as equal.
Inheritance Hierarchy
SystemObject
SMath.ManagerTermsFuzzyComparer

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TermsFuzzyComparer : IEqualityComparer<IPrimitive>
Public Class TermsFuzzyComparer
    Implements IEqualityComparer(Of IPrimitive)
public ref class TermsFuzzyComparer : IEqualityComparer<IPrimitive^>
type TermsFuzzyComparer =
    class
        interface IEqualityComparer<IPrimitive>
    end

The TermsFuzzyComparer type exposes the following members.

Constructors
 | Name | Description
Public method | TermsFuzzyComparer | Initializes a new instance of the TermsFuzzyComparer class
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(IPrimitive, IPrimitive) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(IPrimitive) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


TermsFuzzyComparer Constructor

Initializes a new instance of the TermsFuzzyComparer class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermsFuzzyComparer()
Public Sub New
public:
TermsFuzzyComparer()
new : unit -> TermsFuzzyComparer
See Also

Reference

TermsFuzzyComparer Class
SMath.Manager Namespace


TermsFuzzyComparer Methods

The TermsFuzzyComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(IPrimitive, IPrimitive) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(IPrimitive) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TermsFuzzyComparer Class
SMath.Manager Namespace


TermsFuzzyComparer.Equals Method

TermsFuzzyComparerEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(IPrimitive, IPrimitive) |
Top
See Also

Reference

TermsFuzzyComparer Class
SMath.Manager Namespace


TermsFuzzyComparer.Equals Method (IPrimitive, IPrimitive)

TermsFuzzyComparerEquals Method (IPrimitive, IPrimitive)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    IPrimitive x,
    IPrimitive y
)
Public Function Equals (
    x As IPrimitive,
    y As IPrimitive
) As Boolean
public:
virtual bool Equals(
    IPrimitive^ x,
    IPrimitive^ y
) sealed
abstract Equals :
        x : IPrimitive *
        y : IPrimitive -> bool
override Equals :
        x : IPrimitive *
        y : IPrimitive -> bool

Parameters

x
Type: SMath.ManagerIPrimitive
y
Type: SMath.ManagerIPrimitive

Return Value

Type: Boolean

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

TermsFuzzyComparer Class
Equals Overload
SMath.Manager Namespace


TermsFuzzyComparer.GetHashCode Method

TermsFuzzyComparerGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(IPrimitive) |
Top
See Also

Reference

TermsFuzzyComparer Class
SMath.Manager Namespace


TermsFuzzyComparer.GetHashCode Method (IPrimitive)

TermsFuzzyComparerGetHashCode Method (IPrimitive)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    IPrimitive obj
)
Public Function GetHashCode (
    obj As IPrimitive
) As Integer
public:
virtual int GetHashCode(
    IPrimitive^ obj
) sealed
abstract GetHashCode :
        obj : IPrimitive -> int
override GetHashCode :
        obj : IPrimitive -> int

Parameters

obj
Type: SMath.ManagerIPrimitive

Return Value

Type: Int32

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

TermsFuzzyComparer Class
GetHashCode Overload
SMath.Manager Namespace


TermsReferencesComparer Class

Compares Terms according to their object references.
Inheritance Hierarchy
SystemObject
SMath.ManagerTermsReferencesComparer

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class TermsReferencesComparer : IEqualityComparer<Term>
Public Class TermsReferencesComparer
    Implements IEqualityComparer(Of Term)
public ref class TermsReferencesComparer : IEqualityComparer<Term^>
type TermsReferencesComparer =
    class
        interface IEqualityComparer<Term>
    end

The TermsReferencesComparer type exposes the following members.

Constructors
 | Name | Description
Public method | TermsReferencesComparer | Initializes a new instance of the TermsReferencesComparer class
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Term, Term) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(Term) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


TermsReferencesComparer Constructor

Initializes a new instance of the TermsReferencesComparer class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public TermsReferencesComparer()
Public Sub New
public:
TermsReferencesComparer()
new : unit -> TermsReferencesComparer
See Also

Reference

TermsReferencesComparer Class
SMath.Manager Namespace


TermsReferencesComparer Methods

The TermsReferencesComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Term, Term) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(Term) |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TermsReferencesComparer Class
SMath.Manager Namespace


TermsReferencesComparer.Equals Method

TermsReferencesComparerEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Term, Term) |
Top
See Also

Reference

TermsReferencesComparer Class
SMath.Manager Namespace


TermsReferencesComparer.Equals Method (Term, Term)

TermsReferencesComparerEquals Method (Term, Term)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    Term x,
    Term y
)
Public Function Equals (
    x As Term,
    y As Term
) As Boolean
public:
virtual bool Equals(
    Term^ x,
    Term^ y
) sealed
abstract Equals :
        x : Term *
        y : Term -> bool
override Equals :
        x : Term *
        y : Term -> bool

Parameters

x
Type: SMath.ManagerTerm
y
Type: SMath.ManagerTerm

Return Value

Type: Boolean

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

TermsReferencesComparer Class
Equals Overload
SMath.Manager Namespace


TermsReferencesComparer.GetHashCode Method

TermsReferencesComparerGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(Term) |
Top
See Also

Reference

TermsReferencesComparer Class
SMath.Manager Namespace


TermsReferencesComparer.GetHashCode Method (Term)

TermsReferencesComparerGetHashCode Method (Term)

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int GetHashCode(
    Term obj
)
Public Function GetHashCode (
    obj As Term
) As Integer
public:
virtual int GetHashCode(
    Term^ obj
) sealed
abstract GetHashCode :
        obj : Term -> int
override GetHashCode :
        obj : Term -> int

Parameters

obj
Type: SMath.ManagerTerm

Return Value

Type: Int32

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

TermsReferencesComparer Class
GetHashCode Overload
SMath.Manager Namespace


TermType Enumeration

Type of the expression component.Определение типа компоненты выражения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum TermType
Public Enumeration TermType
public enum class TermType
type TermType
Members
Member name | Value | Description
Operand | 1 | The operand can be represented by the number, parameter or variable.Операнд может быть как числом, так и параметром или переменной.
Operator | 2 | The operator may be unary or binary.Оператор может быть унарным или бинарным.
Function | 3 | The function.Функция.
Bracket | 4 | Brackets.Пользовательские скобки.
See Also

Reference

SMath.Manager Namespace


TextAlignment Enumeration

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum TextAlignment
Public Enumeration TextAlignment
public enum class TextAlignment
type TextAlignment
Members
Member name | Value | Description
Left | 1 |
Center | 2 |
Right | 3 |
See Also

Reference

SMath.Manager Namespace


ThreadSafeImageContainer Class

Inheritance Hierarchy
SystemObject
SMath.ManagerThreadSafeImageContainer
SMath.ManagerPageOptions

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ThreadSafeImageContainer
Public Class ThreadSafeImageContainer
public ref class ThreadSafeImageContainer
type ThreadSafeImageContainer =  class end

The ThreadSafeImageContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ThreadSafeImageContainer | Initializes a new instance of the ThreadSafeImageContainer class
Public method | ThreadSafeImageContainer(ThreadSafeImageContainer) | Initializes a new instance of the ThreadSafeImageContainer class
Top
Properties
 | Name | Description
Public property | Exists |
Public property | Size |
Top
Methods
 | Name | Description
Public method | DrawImage |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageCopy |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | imageLock |
Protected field | optimizedImage |
Protected field | originalImage |
Top
See Also

Reference

SMath.Manager Namespace


ThreadSafeImageContainer Constructor

Overload List
 | Name | Description
Public method | ThreadSafeImageContainer | Initializes a new instance of the ThreadSafeImageContainer class
Public method | ThreadSafeImageContainer(ThreadSafeImageContainer) | Initializes a new instance of the ThreadSafeImageContainer class
Top
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer Constructor

Initializes a new instance of the ThreadSafeImageContainer class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ThreadSafeImageContainer()
Public Sub New
public:
ThreadSafeImageContainer()
new : unit -> ThreadSafeImageContainer
See Also

Reference

ThreadSafeImageContainer Class
ThreadSafeImageContainer Overload
SMath.Manager Namespace


ThreadSafeImageContainer Constructor (ThreadSafeImageContainer)

Initializes a new instance of the ThreadSafeImageContainer class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ThreadSafeImageContainer(
    ThreadSafeImageContainer options
)
Public Sub New (
    options As ThreadSafeImageContainer
)
public:
ThreadSafeImageContainer(
    ThreadSafeImageContainer^ options
)
new :
        options : ThreadSafeImageContainer -> ThreadSafeImageContainer

Parameters

options
Type: SMath.ManagerThreadSafeImageContainer
See Also

Reference

ThreadSafeImageContainer Class
ThreadSafeImageContainer Overload
SMath.Manager Namespace


ThreadSafeImageContainer Properties

The ThreadSafeImageContainer type exposes the following members.

Properties
 | Name | Description
Public property | Exists |
Public property | Size |
Top
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.Exists Property

ThreadSafeImageContainerExists Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
public:
property bool Exists {
    bool get ();
}
member Exists : bool with get

Property Value

Type: Boolean
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.Size Property

ThreadSafeImageContainerSize Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size Size {
    Size get ();
}
member Size : Size with get

Property Value

Type: Size
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer Methods

The ThreadSafeImageContainer type exposes the following members.

Methods
 | Name | Description
Public method | DrawImage |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageCopy |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetImage |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.DrawImage Method

ThreadSafeImageContainerDrawImage Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void DrawImage(
    IGraphics g,
    RectangleF rect,
    bool export
)
Public Sub DrawImage (
    g As IGraphics,
    rect As RectangleF,
    export As Boolean
)
public:
void DrawImage(
    IGraphics^ g,
    RectangleF rect,
    bool export
)
member DrawImage :
        g : IGraphics *
        rect : RectangleF *
        export : bool -> unit

Parameters

g
Type: SMath.DrawingIGraphics
rect
Type: System.DrawingRectangleF
export
Type: SystemBoolean
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.GetImageCopy Method

ThreadSafeImageContainerGetImageCopy Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IBitmap GetImageCopy(
    bool export
)
Public Function GetImageCopy (
    export As Boolean
) As IBitmap
public:
IBitmap^ GetImageCopy(
    bool export
)
member GetImageCopy :
        export : bool -> IBitmap

Parameters

export
Type: SystemBoolean

Return Value

Type: IBitmap
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.SetImage Method

ThreadSafeImageContainerSetImage Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void SetImage(
    IBitmap bmp
)
Public Sub SetImage (
    bmp As IBitmap
)
public:
void SetImage(
    IBitmap^ bmp
)
member SetImage :
        bmp : IBitmap -> unit

Parameters

bmp
Type: SMath.DrawingIBitmap
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer Fields

The ThreadSafeImageContainer type exposes the following members.

Fields
 | Name | Description
Protected field | imageLock |
Protected field | optimizedImage |
Protected field | originalImage |
Top
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.imageLock Field

ThreadSafeImageContainerimageLock Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected Object imageLock
Protected imageLock As Object
protected:
Object^ imageLock
val mutable imageLock: Object

Field Value

Type: Object
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.optimizedImage Field

ThreadSafeImageContaineroptimizedImage Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected IBitmap optimizedImage
Protected optimizedImage As IBitmap
protected:
IBitmap^ optimizedImage
val mutable optimizedImage: IBitmap

Field Value

Type: IBitmap
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ThreadSafeImageContainer.originalImage Field

ThreadSafeImageContaineroriginalImage Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
protected IBitmap originalImage
Protected originalImage As IBitmap
protected:
IBitmap^ originalImage
val mutable originalImage: IBitmap

Field Value

Type: IBitmap
See Also

Reference

ThreadSafeImageContainer Class
SMath.Manager Namespace


ToolboxGroup Class

Inheritance Hierarchy
SystemObject
SMath.ManagerToolboxGroup

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class ToolboxGroup
Public Class ToolboxGroup
public ref class ToolboxGroup
type ToolboxGroup =  class end

The ToolboxGroup type exposes the following members.

Constructors
 | Name | Description
Public method | ToolboxGroup | Initializes a new instance of the ToolboxGroup class
Top
Properties
 | Name | Description
Public property | Buttons |
Public property | Index |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


ToolboxGroup Constructor

Initializes a new instance of the ToolboxGroup class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ToolboxGroup()
Public Sub New
public:
ToolboxGroup()
new : unit -> ToolboxGroup
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


ToolboxGroup Properties

The ToolboxGroup type exposes the following members.

Properties
 | Name | Description
Public property | Buttons |
Public property | Index |
Public property | Title |
Top
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


ToolboxGroup.Buttons Property

ToolboxGroupButtons Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public ButtonsMetaData[] Buttons { get; set; }
Public Property Buttons As ButtonsMetaData()
    Get
    Set
public:
property array<ButtonsMetaData^>^ Buttons {
    array<ButtonsMetaData^>^ get ();
    void set (array<ButtonsMetaData^>^ value);
}
member Buttons : ButtonsMetaData[] with get, set

Property Value

Type: ButtonsMetaData
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


ToolboxGroup.Index Property

ToolboxGroupIndex Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


ToolboxGroup.Title Property

ToolboxGroupTitle Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

Type: String
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


ToolboxGroup Methods

The ToolboxGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToolboxGroup Class
SMath.Manager Namespace


UndefinedVariablesHandler Delegate

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate List<IPrimitive> UndefinedVariablesHandler(
    Entry entry
)
Public Delegate Function UndefinedVariablesHandler (
    entry As Entry
) As List(Of IPrimitive)
public delegate List<IPrimitive^>^ UndefinedVariablesHandler(
    Entry^ entry
)
type UndefinedVariablesHandler =
    delegate of
        entry : Entry -> List<IPrimitive>

Parameters

entry
Type: SMath.ManagerEntry

Return Value

Type: ListIPrimitive
See Also

Reference

SMath.Manager Namespace


UnitInfo Class

Inheritance Hierarchy
SystemObject
SMath.ManagerUnitInfo

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class UnitInfo : IDetailedTerm
Public Class UnitInfo
    Implements IDetailedTerm
public ref class UnitInfo : IDetailedTerm
type UnitInfo =
    class
        interface IDetailedTerm
    end

The UnitInfo type exposes the following members.

Constructors
 | Name | Description
Public method | UnitInfo | Initializes a new instance of the UnitInfo class
Top
Properties
 | Name | Description
Public property | BackwardRelation | Used by non-linear units only.
Public property | DefaultNames |
Public property | Description |
Public property | DimensionDescription |
Public property | DimensionId |
Public property | Factor |
Public property | IsBaseUnit |
Public property | Offset |
Public property | Properties |
Public property | Relations |
Public property | SynonymFor |
Public property | System |
Public property | Text |
Public property | Title | Always empty as it is not used for Units.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultName |
Public method | GetDetails |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRelationBySystem | Obsolete.
Public method | GetRelationByUnitSystem | Returns relation for the specified system. If not specified, then returns relation for any available system, prioritized by specified one.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTerm |
Top
See Also

Reference

SMath.Manager Namespace


UnitInfo Constructor

Initializes a new instance of the UnitInfo class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public UnitInfo(
    string name,
    Term[] factor,
    Term[] offset,
    Term[] connection,
    string description,
    string dimensionDescription,
    int dimensionId,
    bool isBaseUnit,
    string system,
    string[] properties,
    string synonymFor
)
Public Sub New (
    name As String,
    factor As Term(),
    offset As Term(),
    connection As Term(),
    description As String,
    dimensionDescription As String,
    dimensionId As Integer,
    isBaseUnit As Boolean,
    system As String,
    properties As String(),
    synonymFor As String
)
public:
UnitInfo(
    String^ name,
    array<Term^>^ factor,
    array<Term^>^ offset,
    array<Term^>^ connection,
    String^ description,
    String^ dimensionDescription,
    int dimensionId,
    bool isBaseUnit,
    String^ system,
    array<String^>^ properties,
    String^ synonymFor
)
new :
        name : string *
        factor : Term[] *
        offset : Term[] *
        connection : Term[] *
        description : string *
        dimensionDescription : string *
        dimensionId : int *
        isBaseUnit : bool *
        system : string *
        properties : string[] *
        synonymFor : string -> UnitInfo

Parameters

name
Type: SystemString
factor
Type: SMath.ManagerTerm
offset
Type: SMath.ManagerTerm
connection
Type: SMath.ManagerTerm
description
Type: SystemString
dimensionDescription
Type: SystemString
dimensionId
Type: SystemInt32
isBaseUnit
Type: SystemBoolean
system
Type: SystemString
properties
Type: SystemString
synonymFor
Type: SystemString
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo Properties

The UnitInfo type exposes the following members.

Properties
 | Name | Description
Public property | BackwardRelation | Used by non-linear units only.
Public property | DefaultNames |
Public property | Description |
Public property | DimensionDescription |
Public property | DimensionId |
Public property | Factor |
Public property | IsBaseUnit |
Public property | Offset |
Public property | Properties |
Public property | Relations |
Public property | SynonymFor |
Public property | System |
Public property | Text |
Public property | Title | Always empty as it is not used for Units.
Top
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.BackwardRelation Property

UnitInfoBackwardRelation Property

Used by non-linear units only.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] BackwardRelation { get; }
Public ReadOnly Property BackwardRelation As Term()
    Get
public:
property array<Term^>^ BackwardRelation {
    array<Term^>^ get ();
}
member BackwardRelation : Term[] with get

Property Value

Type: Term
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.DefaultNames Property

UnitInfoDefaultNames Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] DefaultNames { get; set; }
Public Property DefaultNames As String()
    Get
    Set
public:
property array<String^>^ DefaultNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DefaultNames : string[] with get, set

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Description Property

UnitInfoDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () sealed;
}
abstract Description : string with get
override Description : string with get

Property Value

Type: String

Implements

IDetailedTermDescription
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.DimensionDescription Property

UnitInfoDimensionDescription Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string DimensionDescription { get; }
Public ReadOnly Property DimensionDescription As String
    Get
public:
property String^ DimensionDescription {
    String^ get ();
}
member DimensionDescription : string with get

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.DimensionId Property

UnitInfoDimensionId Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int DimensionId { get; }
Public ReadOnly Property DimensionId As Integer
    Get
public:
property int DimensionId {
    int get ();
}
member DimensionId : int with get

Property Value

Type: Int32
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Factor Property

UnitInfoFactor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] Factor { get; }
Public ReadOnly Property Factor As Term()
    Get
public:
property array<Term^>^ Factor {
    array<Term^>^ get ();
}
member Factor : Term[] with get

Property Value

Type: Term
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.IsBaseUnit Property

UnitInfoIsBaseUnit Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsBaseUnit { get; }
Public ReadOnly Property IsBaseUnit As Boolean
    Get
public:
property bool IsBaseUnit {
    bool get ();
}
member IsBaseUnit : bool with get

Property Value

Type: Boolean
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Offset Property

UnitInfoOffset Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term[] Offset { get; }
Public ReadOnly Property Offset As Term()
    Get
public:
property array<Term^>^ Offset {
    array<Term^>^ get ();
}
member Offset : Term[] with get

Property Value

Type: Term
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Properties Property

UnitInfoProperties Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string[] Properties { get; set; }
Public Property Properties As String()
    Get
    Set
public:
property array<String^>^ Properties {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Properties : string[] with get, set

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Relations Property

UnitInfoRelations Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, Entry> Relations { get; set; }
Public Property Relations As Dictionary(Of String, Entry)
    Get
    Set
public:
property Dictionary<String^, Entry^>^ Relations {
    Dictionary<String^, Entry^>^ get ();
    void set (Dictionary<String^, Entry^>^ value);
}
member Relations : Dictionary<string, Entry> with get, set

Property Value

Type: DictionaryString, Entry
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.SynonymFor Property

UnitInfoSynonymFor Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string SynonymFor { get; }
Public ReadOnly Property SynonymFor As String
    Get
public:
property String^ SynonymFor {
    String^ get ();
}
member SynonymFor : string with get

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.System Property

UnitInfoSystem Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string System { get; }
Public ReadOnly Property System As String
    Get
public:
property String^ System {
    String^ get ();
}
member System : string with get

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Text Property

UnitInfoText Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.Title Property

UnitInfoTitle Property

Always empty as it is not used for Units.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
virtual property String^ Title {
    String^ get () sealed;
}
abstract Title : string with get
override Title : string with get

Property Value

Type: String

Implements

IDetailedTermTitle
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo Methods

The UnitInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaultName |
Public method | GetDetails |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRelationBySystem | Obsolete.
Public method | GetRelationByUnitSystem | Returns relation for the specified system. If not specified, then returns relation for any available system, prioritized by specified one.
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Public method | ToTerm |
Top
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.GetDefaultName Method

UnitInfoGetDefaultName Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetDefaultName()
Public Function GetDefaultName As String
public:
String^ GetDefaultName()
member GetDefaultName : unit -> string

Return Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.GetDetails Method

UnitInfoGetDetails Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string GetDetails(
    SessionProfile sessionProfile
)
Public Function GetDetails (
    sessionProfile As SessionProfile
) As String
public:
virtual String^ GetDetails(
    SessionProfile^ sessionProfile
) sealed
abstract GetDetails :
        sessionProfile : SessionProfile -> string
override GetDetails :
        sessionProfile : SessionProfile -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: String

Implements

IDetailedTermGetDetails(SessionProfile)
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.GetRelationBySystem Method

UnitInfoGetRelationBySystem Method

Note: This API is now obsolete.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public Term[] GetRelationBySystem(
    string system,
    bool strict
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Function GetRelationBySystem (
    system As String,
    strict As Boolean
) As Term()
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
array<Term^>^ GetRelationBySystem(
    String^ system,
    bool strict
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
member GetRelationBySystem :
        system : string *
        strict : bool -> Term[]

Parameters

system
Type: SystemString
strict
Type: SystemBoolean

Return Value

Type: Term
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.GetRelationByUnitSystem Method

UnitInfoGetRelationByUnitSystem Method

Returns relation for the specified system. If not specified, then returns relation for any available system, prioritized by specified one.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry GetRelationByUnitSystem(
    string system,
    bool strict
)
Public Function GetRelationByUnitSystem (
    system As String,
    strict As Boolean
) As Entry
public:
Entry^ GetRelationByUnitSystem(
    String^ system,
    bool strict
)
member GetRelationByUnitSystem :
        system : string *
        strict : bool -> Entry

Parameters

system
Type: SystemString
System of units.
strict
Type: SystemBoolean
Determines if only specified system of units applicable.

Return Value

Type: Entry
Units relation prior to units system.
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.ToString Method

UnitInfoToString Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitInfo.ToTerm Method

UnitInfoToTerm Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Term ToTerm(
    SessionProfile sessionProfile
)
Public Function ToTerm (
    sessionProfile As SessionProfile
) As Term
public:
virtual Term^ ToTerm(
    SessionProfile^ sessionProfile
) sealed
abstract ToTerm :
        sessionProfile : SessionProfile -> Term
override ToTerm :
        sessionProfile : SessionProfile -> Term

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile

Return Value

Type: Term

Implements

IDetailedTermToTerm(SessionProfile)
See Also

Reference

UnitInfo Class
SMath.Manager Namespace


UnitsManager Class

Inheritance Hierarchy
SystemObject
SMath.ManagerUnitsManager

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class UnitsManager
Public Class UnitsManager
public ref class UnitsManager
type UnitsManager =  class end

The UnitsManager type exposes the following members.

Properties
Name | Description
BuiltInDimensions |
BuiltInUnitsLinear |
BuiltInUnitsNonLinear |
BuiltInUnitsSystems |
CurrentUnitsFileNames |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentUnitName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetUnits |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryGetUnit |
Top
Fields
Name | Description
AvailableUnitsLanguages | List of the available units languages.Список доступных языков единиц измерения.
DefaultUnitsLanguage |
DefaultUnitsSystemName |
MasterFileName |
NeutralUnitsSystemName |
UseSpecialSymbols |
Top
See Also

Reference

SMath.Manager Namespace


UnitsManager Properties

The UnitsManager type exposes the following members.

Properties
Name | Description
BuiltInDimensions |
BuiltInUnitsLinear |
BuiltInUnitsNonLinear |
BuiltInUnitsSystems |
CurrentUnitsFileNames |
Top
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.BuiltInDimensions Property

UnitsManagerBuiltInDimensions Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<int, DimensionInfo> BuiltInDimensions { get; set; }
Public Shared Property BuiltInDimensions As Dictionary(Of Integer, DimensionInfo)
    Get
    Set
public:
static property Dictionary<int, DimensionInfo^>^ BuiltInDimensions {
    Dictionary<int, DimensionInfo^>^ get ();
    void set (Dictionary<int, DimensionInfo^>^ value);
}
static member BuiltInDimensions : Dictionary<int, DimensionInfo> with get, set

Property Value

Type: DictionaryInt32, DimensionInfo
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.BuiltInUnitsLinear Property

UnitsManagerBuiltInUnitsLinear Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, UnitInfo> BuiltInUnitsLinear { get; set; }
Public Shared Property BuiltInUnitsLinear As Dictionary(Of String, UnitInfo)
    Get
    Set
public:
static property Dictionary<String^, UnitInfo^>^ BuiltInUnitsLinear {
    Dictionary<String^, UnitInfo^>^ get ();
    void set (Dictionary<String^, UnitInfo^>^ value);
}
static member BuiltInUnitsLinear : Dictionary<string, UnitInfo> with get, set

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.BuiltInUnitsNonLinear Property

UnitsManagerBuiltInUnitsNonLinear Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, UnitInfo> BuiltInUnitsNonLinear { get; set; }
Public Shared Property BuiltInUnitsNonLinear As Dictionary(Of String, UnitInfo)
    Get
    Set
public:
static property Dictionary<String^, UnitInfo^>^ BuiltInUnitsNonLinear {
    Dictionary<String^, UnitInfo^>^ get ();
    void set (Dictionary<String^, UnitInfo^>^ value);
}
static member BuiltInUnitsNonLinear : Dictionary<string, UnitInfo> with get, set

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.BuiltInUnitsSystems Property

UnitsManagerBuiltInUnitsSystems Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> BuiltInUnitsSystems { get; set; }
Public Shared Property BuiltInUnitsSystems As List(Of String)
    Get
    Set
public:
static property List<String^>^ BuiltInUnitsSystems {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
static member BuiltInUnitsSystems : List<string> with get, set

Property Value

Type: ListString
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.CurrentUnitsFileNames Property

UnitsManagerCurrentUnitsFileNames Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> CurrentUnitsFileNames { get; set; }
Public Shared Property CurrentUnitsFileNames As List(Of String)
    Get
    Set
public:
static property List<String^>^ CurrentUnitsFileNames {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
static member CurrentUnitsFileNames : List<string> with get, set

Property Value

Type: ListString
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager Methods

The UnitsManager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentUnitName |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetUnits |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryGetUnit |
Top
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.GetCurrentUnitName Method

UnitsManagerGetCurrentUnitName Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string GetCurrentUnitName(
    SessionProfile sessionProfile,
    string name,
    bool standard
)
Public Shared Function GetCurrentUnitName (
    sessionProfile As SessionProfile,
    name As String,
    standard As Boolean
) As String
public:
static String^ GetCurrentUnitName(
    SessionProfile^ sessionProfile,
    String^ name,
    bool standard
)
static member GetCurrentUnitName :
        sessionProfile : SessionProfile *
        name : string *
        standard : bool -> string

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
name
Type: SystemString
standard
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.GetUnits Method

UnitsManagerGetUnits Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void GetUnits(
    SessionProfile sessionProfile
)
Public Sub GetUnits (
    sessionProfile As SessionProfile
)
public:
void GetUnits(
    SessionProfile^ sessionProfile
)
member GetUnits :
        sessionProfile : SessionProfile -> unit

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.TryGetUnit Method

UnitsManagerTryGetUnit Method

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryGetUnit(
    SessionProfile sessionProfile,
    string name,
    out UnitInfo unitDef,
    bool standard
)
Public Shared Function TryGetUnit (
    sessionProfile As SessionProfile,
    name As String,
    <OutAttribute> ByRef unitDef As UnitInfo,
    standard As Boolean
) As Boolean
public:
static bool TryGetUnit(
    SessionProfile^ sessionProfile,
    String^ name,
    [OutAttribute] UnitInfo^% unitDef,
    bool standard
)
static member TryGetUnit :
        sessionProfile : SessionProfile *
        name : string *
        unitDef : UnitInfo byref *
        standard : bool -> bool

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
name
Type: SystemString
unitDef
Type: SMath.ManagerUnitInfo
standard
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager Fields

The UnitsManager type exposes the following members.

Fields
Name | Description
AvailableUnitsLanguages | List of the available units languages.Список доступных языков единиц измерения.
DefaultUnitsLanguage |
DefaultUnitsSystemName |
MasterFileName |
NeutralUnitsSystemName |
UseSpecialSymbols |
Top
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.AvailableUnitsLanguages Field

UnitsManagerAvailableUnitsLanguages Field

List of the available units languages.Список доступных языков единиц измерения.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static List<string> AvailableUnitsLanguages
Public Shared AvailableUnitsLanguages As List(Of String)
public:
static List<String^>^ AvailableUnitsLanguages
static val mutable AvailableUnitsLanguages: List<string>

Field Value

Type: ListString
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.DefaultUnitsLanguage Field

UnitsManagerDefaultUnitsLanguage Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string DefaultUnitsLanguage = "ENG"
Public Const DefaultUnitsLanguage As String = "ENG"
public:
literal String^ DefaultUnitsLanguage = "ENG"
static val mutable DefaultUnitsLanguage: string

Field Value

Type: String
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.DefaultUnitsSystemName Field

UnitsManagerDefaultUnitsSystemName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string DefaultUnitsSystemName
Public Shared DefaultUnitsSystemName As String
public:
static String^ DefaultUnitsSystemName
static val mutable DefaultUnitsSystemName: string

Field Value

Type: String
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.MasterFileName Field

UnitsManagerMasterFileName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string MasterFileName = "Units.xml"
Public Const MasterFileName As String = "Units.xml"
public:
literal String^ MasterFileName = "Units.xml"
static val mutable MasterFileName: string

Field Value

Type: String
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.NeutralUnitsSystemName Field

UnitsManagerNeutralUnitsSystemName Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public const string NeutralUnitsSystemName = "All"
Public Const NeutralUnitsSystemName As String = "All"
public:
literal String^ NeutralUnitsSystemName = "All"
static val mutable NeutralUnitsSystemName: string

Field Value

Type: String
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsManager.UseSpecialSymbols Field

UnitsManagerUseSpecialSymbols Field

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool UseSpecialSymbols
Public Shared UseSpecialSymbols As Boolean
public:
static bool UseSpecialSymbols
static val mutable UseSpecialSymbols: bool

Field Value

Type: Boolean
See Also

Reference

UnitsManager Class
SMath.Manager Namespace


UnitsSet Class

Inheritance Hierarchy
SystemObject
SMath.ManagerUnitsSet

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class UnitsSet
Public Class UnitsSet
public ref class UnitsSet
type UnitsSet =  class end

The UnitsSet type exposes the following members.

Constructors
 | Name | Description
Public method | UnitsSet | Initializes a new instance of the UnitsSet class
Top
Properties
 | Name | Description
Public property | LinearUnitsCurrent |
Public property | LinearUnitsStandard |
Public property | NonLinearUnitsCurrent |
Public property | NonLinearUnitsStandard |
Public property | UnitsDimensions |
Public property | UnitsSystems |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Manager Namespace


UnitsSet Constructor

Initializes a new instance of the UnitsSet class

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public UnitsSet()
Public Sub New
public:
UnitsSet()
new : unit -> UnitsSet
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet Properties

The UnitsSet type exposes the following members.

Properties
 | Name | Description
Public property | LinearUnitsCurrent |
Public property | LinearUnitsStandard |
Public property | NonLinearUnitsCurrent |
Public property | NonLinearUnitsStandard |
Public property | UnitsDimensions |
Public property | UnitsSystems |
Top
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.LinearUnitsCurrent Property

UnitsSetLinearUnitsCurrent Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, UnitInfo> LinearUnitsCurrent { get; }
Public ReadOnly Property LinearUnitsCurrent As Dictionary(Of String, UnitInfo)
    Get
public:
property Dictionary<String^, UnitInfo^>^ LinearUnitsCurrent {
    Dictionary<String^, UnitInfo^>^ get ();
}
member LinearUnitsCurrent : Dictionary<string, UnitInfo> with get

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.LinearUnitsStandard Property

UnitsSetLinearUnitsStandard Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, UnitInfo> LinearUnitsStandard { get; }
Public ReadOnly Property LinearUnitsStandard As Dictionary(Of String, UnitInfo)
    Get
public:
property Dictionary<String^, UnitInfo^>^ LinearUnitsStandard {
    Dictionary<String^, UnitInfo^>^ get ();
}
member LinearUnitsStandard : Dictionary<string, UnitInfo> with get

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.NonLinearUnitsCurrent Property

UnitsSetNonLinearUnitsCurrent Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, UnitInfo> NonLinearUnitsCurrent { get; }
Public ReadOnly Property NonLinearUnitsCurrent As Dictionary(Of String, UnitInfo)
    Get
public:
property Dictionary<String^, UnitInfo^>^ NonLinearUnitsCurrent {
    Dictionary<String^, UnitInfo^>^ get ();
}
member NonLinearUnitsCurrent : Dictionary<string, UnitInfo> with get

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.NonLinearUnitsStandard Property

UnitsSetNonLinearUnitsStandard Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, UnitInfo> NonLinearUnitsStandard { get; }
Public ReadOnly Property NonLinearUnitsStandard As Dictionary(Of String, UnitInfo)
    Get
public:
property Dictionary<String^, UnitInfo^>^ NonLinearUnitsStandard {
    Dictionary<String^, UnitInfo^>^ get ();
}
member NonLinearUnitsStandard : Dictionary<string, UnitInfo> with get

Property Value

Type: DictionaryString, UnitInfo
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.UnitsDimensions Property

UnitsSetUnitsDimensions Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Dictionary<int, DimensionInfo> UnitsDimensions { get; }
Public ReadOnly Property UnitsDimensions As Dictionary(Of Integer, DimensionInfo)
    Get
public:
property Dictionary<int, DimensionInfo^>^ UnitsDimensions {
    Dictionary<int, DimensionInfo^>^ get ();
}
member UnitsDimensions : Dictionary<int, DimensionInfo> with get

Property Value

Type: DictionaryInt32, DimensionInfo
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet.UnitsSystems Property

UnitsSetUnitsSystems Property

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public List<string> UnitsSystems { get; }
Public ReadOnly Property UnitsSystems As List(Of String)
    Get
public:
property List<String^>^ UnitsSystems {
    List<String^>^ get ();
}
member UnitsSystems : List<string> with get

Property Value

Type: ListString
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


UnitsSet Methods

The UnitsSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnitsSet Class
SMath.Manager Namespace


WorkingThread Class

Managing of working threads in order to optimize performance and handle work termination.Обрабатывает рабочие процессы для оптимизации производительности и обработки их прерываний.
Inheritance Hierarchy
SystemObject
SMath.ManagerWorkingThread

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class WorkingThread
Public NotInheritable Class WorkingThread
public ref class WorkingThread abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WorkingThread =  class end

The WorkingThread type exposes the following members.

Methods
Name | Description
Register | Handle new working thread.Зарегистрировать рабочий поток.
Unregister | Remove handled working thread.Удалить зарегистрированный рабочий поток.
Verify | Check if current working thread must be terminated. Raises an exception if required.Проверка текущего рабочего процесса на отсутствие запроса по прекращению. При необходимости инициирует исключение.
Top
See Also

Reference

SMath.Manager Namespace


WorkingThread Methods

The WorkingThread type exposes the following members.

Methods
Name | Description
Register | Handle new working thread.Зарегистрировать рабочий поток.
Unregister | Remove handled working thread.Удалить зарегистрированный рабочий поток.
Verify | Check if current working thread must be terminated. Raises an exception if required.Проверка текущего рабочего процесса на отсутствие запроса по прекращению. При необходимости инициирует исключение.
Top
See Also

Reference

WorkingThread Class
SMath.Manager Namespace


WorkingThread.Register Method

WorkingThreadRegister Method

Handle new working thread.Зарегистрировать рабочий поток.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static string Register()
Public Shared Function Register As String
public:
static String^ Register()
static member Register : unit -> string

Return Value

Type: String
Returns name of the handled working thread.Возвращает имя добавленного рабочего потока.
See Also

Reference

WorkingThread Class
SMath.Manager Namespace


WorkingThread.Unregister Method

WorkingThreadUnregister Method

Remove handled working thread.Удалить зарегистрированный рабочий поток.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static void Unregister()
Public Shared Sub Unregister
public:
static void Unregister()
static member Unregister : unit -> unit
See Also

Reference

WorkingThread Class
SMath.Manager Namespace


WorkingThread.Verify Method

WorkingThreadVerify Method

Check if current working thread must be terminated. Raises an exception if required.Проверка текущего рабочего процесса на отсутствие запроса по прекращению. При необходимости инициирует исключение.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static WorkingThreadState Verify(
    bool allowException = true
)
Public Shared Function Verify (
    Optional allowException As Boolean = true
) As WorkingThreadState
public:
static WorkingThreadState Verify(
    bool allowException = true
)
static member Verify :
        ?allowException : bool
(* Defaults:
        let _allowException = defaultArg allowException true
*)
-> WorkingThreadState

Parameters

allowException (Optional)
Type: SystemBoolean
Determines whether exception can be raised in order to terminate evaluation.

Return Value

Type: WorkingThreadState
Defines if thread must be terminated or not.
See Also

Reference

WorkingThread Class
SMath.Manager Namespace


WorkingThreadState Enumeration

State of the working thread.

Namespace: SMath.Manager
Assembly: SMath.Manager (in SMath.Manager.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public enum WorkingThreadState
Public Enumeration WorkingThreadState
public enum class WorkingThreadState
type WorkingThreadState
Members
Member name | Value | Description
Regular | 0 | Work in progress.
LimitedResources | 1 | Limited resources detected on work start.
AbortRequested | 2 | Work is ready to be terminated.
See Also

Reference

SMath.Manager Namespace


SMath.Math Namespace

Classes
 | Class | Description
Public class | Computation | Contains main evaluation and substitution methods to work with math expressions.Содержит основные методы для обработки и вычисления математических выражений.
Public class | ComputationRuleException |
Public class | Decision | Obsolete.
Public class | Elements | Allows to handle most often used operations with el() function.
Public class | EvaluationContext | Context of the worksheet evaluation process.Контекст процесса вычислений на листе расчётов.
Public class | Store | Evaluation context. Data type that stores all information about variables, arguments and functions definitions. Definitions represented in a stack.Контекст вычисления. Тип данных, хранящий в себе информацию об объявленных функциях и переменных. В Store все объявления записываются в стэк.
Interfaces
 | Interface | Description
Public interface | IPluginLowLevelEvaluation | Interface to handle low-level evaluation.
Public interface | IPluginLowLevelEvaluationFast | Interface to handle low-level evaluation.
Delegates
 | Delegate | Description
Public delegate | DebugOccuredEventHandler |
Public delegate | TraceEvaluationData |


Computation Class

Contains main evaluation and substitution methods to work with math expressions.Содержит основные методы для обработки и вычисления математических выражений.
Inheritance Hierarchy
SystemObject
SMath.MathComputation

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class Computation
Public NotInheritable Class Computation
public ref class Computation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Computation =  class end

The Computation type exposes the following members.

Methods
Name | Description
NumericCalculation(Entry, Store) | Numeric evaluation of math expression with all possible substitutions based on the evaluation context.Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
NumericCalculation(Term, Store) |
Preprocessing(Entry, Store) | Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plug-ins, where current term can be handled.Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.
Preprocessing(Term, Store) |
SymbolicCalculation(Entry, Store) | Symbolic evaluation of math expression with all possible substitutions based on the evaluation context.Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
SymbolicCalculation(Term, Store) |
Top
Fields
Name | Description
dataFast |
dataLegacy |
Top
See Also

Reference

SMath.Math Namespace


Computation Methods

Methods
Name | Description
NumericCalculation(Entry, Store) | Numeric evaluation of math expression with all possible substitutions based on the evaluation context.Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
NumericCalculation(Term, Store) |
Preprocessing(Entry, Store) | Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plug-ins, where current term can be handled.Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.
Preprocessing(Term, Store) |
SymbolicCalculation(Entry, Store) | Symbolic evaluation of math expression with all possible substitutions based on the evaluation context.Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
SymbolicCalculation(Term, Store) |
Top
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.NumericCalculation Method

ComputationNumericCalculation Method

Overload List
Name | Description
NumericCalculation(Entry, Store) | Numeric evaluation of math expression with all possible substitutions based on the evaluation context.Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
NumericCalculation(Term, Store) |
Top
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.NumericCalculation Method (Entry, Store)

ComputationNumericCalculation Method (Entry, Store)

Numeric evaluation of math expression with all possible substitutions based on the evaluation context.Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TNumber NumericCalculation(
    Entry value,
    Store store
)
Public Shared Function NumericCalculation (
    value As Entry,
    store As Store
) As TNumber
public:
static TNumber^ NumericCalculation(
    Entry^ value,
    Store^ store
)
static member NumericCalculation :
        value : Entry *
        store : Store -> TNumber

Parameters

value
Type: SMath.ManagerEntry
Math expression to evaluate.Математическое выражение для вычисления.
store
Type: SMath.MathStore
Current evaluation context.Текущий контекст вычисления.

Return Value

Type: TNumber
Result of the numeric evaluation.Результат численного вычисления выражения.
See Also

Reference

Computation Class
NumericCalculation Overload
SMath.Math Namespace


Computation.NumericCalculation Method (Term[], Store)

ComputationNumericCalculation Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TNumber NumericCalculation(
    Term[] root,
    ref Store store
)
Public Shared Function NumericCalculation (
    root As Term(),
    ByRef store As Store
) As TNumber
public:
static TNumber^ NumericCalculation(
    array<Term^>^ root,
    Store^% store
)
static member NumericCalculation :
        root : Term[] *
        store : Store byref -> TNumber

Parameters

root
Type: SMath.ManagerTerm
store
Type: SMath.MathStore

Return Value

Type: TNumber
See Also

Reference

Computation Class
NumericCalculation Overload
SMath.Math Namespace


Computation.Preprocessing Method

ComputationPreprocessing Method

Overload List
Name | Description
Preprocessing(Entry, Store) | Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plug-ins, where current term can be handled.Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.
Preprocessing(Term, Store) |
Top
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.Preprocessing Method (Entry, Store)

ComputationPreprocessing Method (Entry, Store)

Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plug-ins, where current term can be handled.Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Entry Preprocessing(
    Entry value,
    Store context
)
Public Shared Function Preprocessing (
    value As Entry,
    context As Store
) As Entry
public:
static Entry^ Preprocessing(
    Entry^ value,
    Store^ context
)
static member Preprocessing :
        value : Entry *
        context : Store -> Entry

Parameters

value
Type: SMath.ManagerEntry
Math expression to perform all kind of substitutions.Математическое выражение для проведения всех возможных подстановок.
context
Type: SMath.MathStore
Current evaluation context.Текущий контекст вычисления.

Return Value

Type: Entry
Substitutions result.Результат подстановок.
See Also

Reference

Computation Class
Preprocessing Overload
SMath.Math Namespace


Computation.Preprocessing Method (Term[], Store)

ComputationPreprocessing Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] Preprocessing(
    Term[] root,
    ref Store store
)
Public Shared Function Preprocessing (
    root As Term(),
    ByRef store As Store
) As Term()
public:
static array<Term^>^ Preprocessing(
    array<Term^>^ root,
    Store^% store
)
static member Preprocessing :
        root : Term[] *
        store : Store byref -> Term[]

Parameters

root
Type: SMath.ManagerTerm
store
Type: SMath.MathStore

Return Value

Type: Term
See Also

Reference

Computation Class
Preprocessing Overload
SMath.Math Namespace


Computation.SymbolicCalculation Method

ComputationSymbolicCalculation Method

Overload List
Name | Description
SymbolicCalculation(Entry, Store) | Symbolic evaluation of math expression with all possible substitutions based on the evaluation context.Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
SymbolicCalculation(Term, Store) |
Top
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.SymbolicCalculation Method (Entry, Store)

ComputationSymbolicCalculation Method (Entry, Store)

Symbolic evaluation of math expression with all possible substitutions based on the evaluation context.Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static MItem SymbolicCalculation(
    Entry value,
    Store store
)
Public Shared Function SymbolicCalculation (
    value As Entry,
    store As Store
) As MItem
public:
static MItem^ SymbolicCalculation(
    Entry^ value,
    Store^ store
)
static member SymbolicCalculation :
        value : Entry *
        store : Store -> MItem

Parameters

value
Type: SMath.ManagerEntry
Math expression to evaluate.Математическое выражение для вычисления.
store
Type: SMath.MathStore
Current evaluation context.Текущий контекст вычисления.

Return Value

Type: MItem
Result of the symbolic evaluation.Результат символьного вычисления выражения.
See Also

Reference

Computation Class
SymbolicCalculation Overload
SMath.Math Namespace


Computation.SymbolicCalculation Method (Term[], Store)

ComputationSymbolicCalculation Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] SymbolicCalculation(
    Term[] root,
    ref Store store
)
Public Shared Function SymbolicCalculation (
    root As Term(),
    ByRef store As Store
) As Term()
public:
static array<Term^>^ SymbolicCalculation(
    array<Term^>^ root,
    Store^% store
)
static member SymbolicCalculation :
        root : Term[] *
        store : Store byref -> Term[]

Parameters

root
Type: SMath.ManagerTerm
store
Type: SMath.MathStore

Return Value

Type: Term
See Also

Reference

Computation Class
SymbolicCalculation Overload
SMath.Math Namespace


Computation Fields

The Computation type exposes the following members.

Fields
Name | Description
dataFast |
dataLegacy |
Top
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.dataFast Field

ComputationdataFast Field

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static PrimitivesCollection dataFast
Public Shared dataFast As PrimitivesCollection
public:
static PrimitivesCollection^ dataFast
static val mutable dataFast: PrimitivesCollection

Field Value

Type: PrimitivesCollection
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.dataLegacy Field

ComputationdataLegacy Field

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static PrimitivesCollection dataLegacy
Public Shared dataLegacy As PrimitivesCollection
public:
static PrimitivesCollection^ dataLegacy
static val mutable dataLegacy: PrimitivesCollection

Field Value

Type: PrimitivesCollection
See Also

Reference

Computation Class
SMath.Math Namespace


Computation.RuleException Class

ComputationRuleException Class

Inheritance Hierarchy
SystemObject
SystemException
SMath.MathComputationRuleException

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class RuleException : Exception
Public Class RuleException
    Inherits Exception
public ref class RuleException : public Exception
type RuleException =
    class
        inherit Exception
    end

The ComputationRuleException type exposes the following members.

Constructors
 | Name | Description
Public method | ComputationRuleException | Initializes a new instance of the ComputationRuleException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | Message |
Top
See Also

Reference

SMath.Math Namespace


Computation.RuleException Constructor

ComputationRuleException Constructor

Initializes a new instance of the ComputationRuleException class

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public RuleException(
    string message
)
Public Sub New (
    message As String
)
public:
RuleException(
    String^ message
)
new :
        message : string -> RuleException

Parameters

message
Type: SystemString
See Also

Reference

ComputationRuleException Class
SMath.Math Namespace


RuleException Properties

The ComputationRuleException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ComputationRuleException Class
SMath.Math Namespace


RuleException Methods

The ComputationRuleException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ComputationRuleException Class
SMath.Math Namespace


RuleException Fields

The ComputationRuleException type exposes the following members.

Fields
 | Name | Description
Public field | Message |
Top
See Also

Reference

ComputationRuleException Class
SMath.Math Namespace


Computation.RuleException.Message Field

ComputationRuleExceptionMessage Field

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string Message
Public Message As String
public:
String^ Message
val mutable Message: string

Field Value

Type: String
See Also

Reference

ComputationRuleException Class
SMath.Math Namespace


DebugOccuredEventHandler Delegate

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void DebugOccuredEventHandler(
    Store context,
    Entry entry
)
Public Delegate Sub DebugOccuredEventHandler (
    context As Store,
    entry As Entry
)
public delegate void DebugOccuredEventHandler(
    Store^ context,
    Entry^ entry
)
type DebugOccuredEventHandler =
    delegate of
        context : Store *
        entry : Entry -> unit

Parameters

context
Type: SMath.MathStore
entry
Type: SMath.ManagerEntry
See Also

Reference

SMath.Math Namespace


Decision Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
SMath.MathDecision

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Computation class instead.")]
public static class Decision
<ObsoleteAttribute("Use Computation class instead.")>
Public NotInheritable Class Decision
[ObsoleteAttribute(L"Use Computation class instead.")]
public ref class Decision abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("Use Computation class instead.")>]
type Decision =  class end
Methods
Name | Description
NumericCalculation(Entry, Store) |
NumericCalculation(Term, Store) |
Preprocessing(Entry, Store) |
Preprocessing(Term, Store) |
SymbolicCalculation(Entry, Store) |
SymbolicCalculation(Term, Store) |
Top
See Also

Reference

SMath.Math Namespace


Decision Methods

Methods
Name | Description
NumericCalculation(Entry, Store) |
NumericCalculation(Term, Store) |
Preprocessing(Entry, Store) |
Preprocessing(Term, Store) |
SymbolicCalculation(Entry, Store) |
SymbolicCalculation(Term, Store) |
Top
See Also

Reference

Decision Class
SMath.Math Namespace


Decision.NumericCalculation Method

DecisionNumericCalculation Method

Overload List
Name | Description
NumericCalculation(Entry, Store) |
NumericCalculation(Term, Store) |
Top
See Also

Reference

Decision Class
SMath.Math Namespace


Decision.NumericCalculation Method (Entry, Store)

DecisionNumericCalculation Method (Entry, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TNumber NumericCalculation(
    Entry value,
    Store context
)
Public Shared Function NumericCalculation (
    value As Entry,
    context As Store
) As TNumber
public:
static TNumber^ NumericCalculation(
    Entry^ value,
    Store^ context
)
static member NumericCalculation :
        value : Entry *
        context : Store -> TNumber

Parameters

value
Type: SMath.ManagerEntry
context
Type: SMath.MathStore

Return Value

Type: TNumber
See Also

Reference

Decision Class
NumericCalculation Overload
SMath.Math Namespace


Decision.NumericCalculation Method (Term[], Store)

DecisionNumericCalculation Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static TNumber NumericCalculation(
    Term[] root,
    ref Store context
)
Public Shared Function NumericCalculation (
    root As Term(),
    ByRef context As Store
) As TNumber
public:
static TNumber^ NumericCalculation(
    array<Term^>^ root,
    Store^% context
)
static member NumericCalculation :
        root : Term[] *
        context : Store byref -> TNumber

Parameters

root
Type: SMath.ManagerTerm
context
Type: SMath.MathStore

Return Value

Type: TNumber
See Also

Reference

Decision Class
NumericCalculation Overload
SMath.Math Namespace


Decision.Preprocessing Method

DecisionPreprocessing Method

Overload List
Name | Description
Preprocessing(Entry, Store) |
Preprocessing(Term, Store) |
Top
See Also

Reference

Decision Class
SMath.Math Namespace


Decision.Preprocessing Method (Entry, Store)

DecisionPreprocessing Method (Entry, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Entry Preprocessing(
    Entry value,
    Store context
)
Public Shared Function Preprocessing (
    value As Entry,
    context As Store
) As Entry
public:
static Entry^ Preprocessing(
    Entry^ value,
    Store^ context
)
static member Preprocessing :
        value : Entry *
        context : Store -> Entry

Parameters

value
Type: SMath.ManagerEntry
context
Type: SMath.MathStore

Return Value

Type: Entry
See Also

Reference

Decision Class
Preprocessing Overload
SMath.Math Namespace


Decision.Preprocessing Method (Term[], Store)

DecisionPreprocessing Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] Preprocessing(
    Term[] root,
    ref Store context
)
Public Shared Function Preprocessing (
    root As Term(),
    ByRef context As Store
) As Term()
public:
static array<Term^>^ Preprocessing(
    array<Term^>^ root,
    Store^% context
)
static member Preprocessing :
        root : Term[] *
        context : Store byref -> Term[]

Parameters

root
Type: SMath.ManagerTerm
context
Type: SMath.MathStore

Return Value

Type: Term
See Also

Reference

Decision Class
Preprocessing Overload
SMath.Math Namespace


Decision.SymbolicCalculation Method

DecisionSymbolicCalculation Method

Overload List
Name | Description
SymbolicCalculation(Entry, Store) |
SymbolicCalculation(Term, Store) |
Top
See Also

Reference

Decision Class
SMath.Math Namespace


Decision.SymbolicCalculation Method (Entry, Store)

DecisionSymbolicCalculation Method (Entry, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static MItem SymbolicCalculation(
    Entry value,
    Store context
)
Public Shared Function SymbolicCalculation (
    value As Entry,
    context As Store
) As MItem
public:
static MItem^ SymbolicCalculation(
    Entry^ value,
    Store^ context
)
static member SymbolicCalculation :
        value : Entry *
        context : Store -> MItem

Parameters

value
Type: SMath.ManagerEntry
context
Type: SMath.MathStore

Return Value

Type: MItem
See Also

Reference

Decision Class
SymbolicCalculation Overload
SMath.Math Namespace


Decision.SymbolicCalculation Method (Term[], Store)

DecisionSymbolicCalculation Method (Term, Store)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Term[] SymbolicCalculation(
    Term[] root,
    ref Store context
)
Public Shared Function SymbolicCalculation (
    root As Term(),
    ByRef context As Store
) As Term()
public:
static array<Term^>^ SymbolicCalculation(
    array<Term^>^ root,
    Store^% context
)
static member SymbolicCalculation :
        root : Term[] *
        context : Store byref -> Term[]

Parameters

root
Type: SMath.ManagerTerm
context
Type: SMath.MathStore

Return Value

Type: Term
See Also

Reference

Decision Class
SymbolicCalculation Overload
SMath.Math Namespace


Elements Class

Allows to handle most often used operations with el() function.
Inheritance Hierarchy
SystemObject
SMath.MathElements

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static class Elements
Public NotInheritable Class Elements
public ref class Elements abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Elements =  class end

The Elements type exposes the following members.

Methods
Name | Description
TryArraysHandling | Defining matrix/vector element in array-like approach.
TryGetElementByIndex | Retreives matrix/vector element by index.
TryMultiHandling |
TrySetElementsByIndex | Присваивание значения элементу матрицы, системы или линии с помощью функции el(;;)
Top
See Also

Reference

SMath.Math Namespace


Elements Methods

The Elements type exposes the following members.

Methods
Name | Description
TryArraysHandling | Defining matrix/vector element in array-like approach.
TryGetElementByIndex | Retreives matrix/vector element by index.
TryMultiHandling |
TrySetElementsByIndex | Присваивание значения элементу матрицы, системы или линии с помощью функции el(;;)
Top
See Also

Reference

Elements Class
SMath.Math Namespace


Elements.TryArraysHandling Method

ElementsTryArraysHandling Method

Defining matrix/vector element in array-like approach.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryArraysHandling(
    Store store,
    Entry leftPart,
    Entry rightPart,
    out Entry result
)
Public Shared Function TryArraysHandling (
    store As Store,
    leftPart As Entry,
    rightPart As Entry,
    <OutAttribute> ByRef result As Entry
) As Boolean
public:
static bool TryArraysHandling(
    Store^ store,
    Entry^ leftPart,
    Entry^ rightPart,
    [OutAttribute] Entry^% result
)
static member TryArraysHandling :
        store : Store *
        leftPart : Entry *
        rightPart : Entry *
        result : Entry byref -> bool

Parameters

store
Type: SMath.MathStore
leftPart
Type: SMath.ManagerEntry
rightPart
Type: SMath.ManagerEntry
result
Type: SMath.ManagerEntry

Return Value

Type: Boolean
See Also

Reference

Elements Class
SMath.Math Namespace


Elements.TryGetElementByIndex Method

ElementsTryGetElementByIndex Method

Retreives matrix/vector element by index.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryGetElementByIndex(
    Entry value,
    Store context,
    out Entry result
)
Public Shared Function TryGetElementByIndex (
    value As Entry,
    context As Store,
    <OutAttribute> ByRef result As Entry
) As Boolean
public:
static bool TryGetElementByIndex(
    Entry^ value,
    Store^ context,
    [OutAttribute] Entry^% result
)
static member TryGetElementByIndex :
        value : Entry *
        context : Store *
        result : Entry byref -> bool

Parameters

value
Type: SMath.ManagerEntry
context
Type: SMath.MathStore
result
Type: SMath.ManagerEntry

Return Value

Type: Boolean
See Also

Reference

Elements Class
SMath.Math Namespace


Elements.TryMultiHandling Method

ElementsTryMultiHandling Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TryMultiHandling(
    Store store,
    Entry leftPart,
    Entry rightPart,
    out Entry result
)
Public Shared Function TryMultiHandling (
    store As Store,
    leftPart As Entry,
    rightPart As Entry,
    <OutAttribute> ByRef result As Entry
) As Boolean
public:
static bool TryMultiHandling(
    Store^ store,
    Entry^ leftPart,
    Entry^ rightPart,
    [OutAttribute] Entry^% result
)
static member TryMultiHandling :
        store : Store *
        leftPart : Entry *
        rightPart : Entry *
        result : Entry byref -> bool

Parameters

store
Type: SMath.MathStore
leftPart
Type: SMath.ManagerEntry
rightPart
Type: SMath.ManagerEntry
result
Type: SMath.ManagerEntry

Return Value

Type: Boolean
See Also

Reference

Elements Class
SMath.Math Namespace


Elements.TrySetElementsByIndex Method

ElementsTrySetElementsByIndex Method

Присваивание значения элементу матрицы, системы или линии с помощью функции el(;;)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static bool TrySetElementsByIndex(
    Store store,
    Entry leftPart,
    Entry rightPart,
    Entry[] arguments,
    List<string> subst,
    ref bool resultCalculated,
    out Definition result
)
Public Shared Function TrySetElementsByIndex (
    store As Store,
    leftPart As Entry,
    rightPart As Entry,
    arguments As Entry(),
    subst As List(Of String),
    ByRef resultCalculated As Boolean,
    <OutAttribute> ByRef result As Definition
) As Boolean
public:
static bool TrySetElementsByIndex(
    Store^ store,
    Entry^ leftPart,
    Entry^ rightPart,
    array<Entry^>^ arguments,
    List<String^>^ subst,
    bool% resultCalculated,
    [OutAttribute] Definition^% result
)
static member TrySetElementsByIndex :
        store : Store *
        leftPart : Entry *
        rightPart : Entry *
        arguments : Entry[] *
        subst : List<string> *
        resultCalculated : bool byref *
        result : Definition byref -> bool

Parameters

store
Type: SMath.MathStore
leftPart
Type: SMath.ManagerEntry
rightPart
Type: SMath.ManagerEntry
arguments
Type: SMath.ManagerEntry
subst
Type: System.Collections.GenericListString
resultCalculated
Type: SystemBoolean
result
Type: SMath.ManagerDefinition

Return Value

Type: Boolean
See Also

Reference

Elements Class
SMath.Math Namespace


EvaluationContext Class

Context of the worksheet evaluation process.Контекст процесса вычислений на листе расчётов.
Inheritance Hierarchy
SystemObject
SMath.MathEvaluationContext

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class EvaluationContext
Public Class EvaluationContext
public ref class EvaluationContext
type EvaluationContext =  class end

The EvaluationContext type exposes the following members.

Constructors
 | Name | Description
Public method | EvaluationContext(SessionProfile) | Initializes a new instance of the EvaluationContext class
Public method | EvaluationContext(SessionProfile, WorksheetParams) | Initializes a new instance of the EvaluationContext class
Top
Properties
 | Name | Description
Public property | Depth | Determines depth of the context.Определяет глубину контекста.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов.
Public property | FractionsTypeNumeric | Output type of the fractions for numeric calculations.Тип отображения дробей в результатах после численных вычислений.
Public property | GeneratorVersion | Version of the application.Версия приложения.
Public property | OnError | Defines if automatic pause on calculation error enabled for the Worksheet.Определяет включена ли автоматическая приостановка вычислений при обнаружении ошибки.
Public property | OutputUnitsSystem | Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.
Public property | SessionProfile | Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.
Public property | StackDepth | Determines stack depth of evaluation.Определяет глубину стека вычислений.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Top
Methods
 | Name | Description
Public method | AddBreakpoint |
Public method | ChangeErrorState |
Public method | ChangeEvaluationState |
Public method | CheckBreakpoint |
Public method | CreateStore |
Public method | CreateStore(IEnumerableDefinition) | Create a Store object with specified definitions included.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause |
Public method | ProgressChange |
Public method | Resume |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки.
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки.
Public event | OnErrorState |
Public event | OnEvaluation | Raises on evaluation process status changed.Вызывается при изменении статуса процесса вычисления.
Public event | OnProgressChanged |
Top
See Also

Reference

SMath.Math Namespace


EvaluationContext Constructor

Overload List
 | Name | Description
Public method | EvaluationContext(SessionProfile) | Initializes a new instance of the EvaluationContext class
Public method | EvaluationContext(SessionProfile, WorksheetParams) | Initializes a new instance of the EvaluationContext class
Top
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext Constructor (SessionProfile)

Initializes a new instance of the EvaluationContext class

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EvaluationContext(
    SessionProfile sessionProfile
)
Public Sub New (
    sessionProfile As SessionProfile
)
public:
EvaluationContext(
    SessionProfile^ sessionProfile
)
new :
        sessionProfile : SessionProfile -> EvaluationContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
See Also

Reference

EvaluationContext Class
EvaluationContext Overload
SMath.Math Namespace


EvaluationContext Constructor (SessionProfile, WorksheetParams)

Initializes a new instance of the EvaluationContext class

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EvaluationContext(
    SessionProfile sessionProfile,
    WorksheetParams parameters
)
Public Sub New (
    sessionProfile As SessionProfile,
    parameters As WorksheetParams
)
public:
EvaluationContext(
    SessionProfile^ sessionProfile,
    WorksheetParams^ parameters
)
new :
        sessionProfile : SessionProfile *
        parameters : WorksheetParams -> EvaluationContext

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
parameters
Type: SMath.ControlsWorksheetParams
See Also

Reference

EvaluationContext Class
EvaluationContext Overload
SMath.Math Namespace


EvaluationContext Properties

The EvaluationContext type exposes the following members.

Properties
 | Name | Description
Public property | Depth | Determines depth of the context.Определяет глубину контекста.
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов.
Public property | FractionsTypeNumeric | Output type of the fractions for numeric calculations.Тип отображения дробей в результатах после численных вычислений.
Public property | GeneratorVersion | Version of the application.Версия приложения.
Public property | OnError | Defines if automatic pause on calculation error enabled for the Worksheet.Определяет включена ли автоматическая приостановка вычислений при обнаружении ошибки.
Public property | OutputUnitsSystem | Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.
Public property | SessionProfile | Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.
Public property | StackDepth | Determines stack depth of evaluation.Определяет глубину стека вычислений.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.
Top
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.Depth Property

EvaluationContextDepth Property

Determines depth of the context.Определяет глубину контекста.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set
public:
property int Depth {
    int get ();
    void set (int value);
}
member Depth : int with get, set

Property Value

Type: Int32
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.FileName Property

EvaluationContextFileName Property

Current worksheet full file name.Полное имя файла текущего листа расчётов.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.FractionsTypeNumeric Property

EvaluationContextFractionsTypeNumeric Property

Output type of the fractions for numeric calculations.Тип отображения дробей в результатах после численных вычислений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public FractionsType FractionsTypeNumeric { get; set; }
Public Property FractionsTypeNumeric As FractionsType
    Get
    Set
public:
property FractionsType FractionsTypeNumeric {
    FractionsType get ();
    void set (FractionsType value);
}
member FractionsTypeNumeric : FractionsType with get, set

Property Value

Type: FractionsType
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.GeneratorVersion Property

EvaluationContextGeneratorVersion Property

Version of the application.Версия приложения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Version GeneratorVersion { get; set; }
Public Property GeneratorVersion As Version
    Get
    Set
public:
property Version^ GeneratorVersion {
    Version^ get ();
    void set (Version^ value);
}
member GeneratorVersion : Version with get, set

Property Value

Type: Version
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnError Property

EvaluationContextOnError Property

Defines if automatic pause on calculation error enabled for the Worksheet.Определяет включена ли автоматическая приостановка вычислений при обнаружении ошибки.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OnErrorAction OnError { get; set; }
Public Property OnError As OnErrorAction
    Get
    Set
public:
property OnErrorAction OnError {
    OnErrorAction get ();
    void set (OnErrorAction value);
}
member OnError : OnErrorAction with get, set

Property Value

Type: OnErrorAction
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OutputUnitsSystem Property

EvaluationContextOutputUnitsSystem Property

Gets or sets default output units system for calculations with units of measurements.Возвращает или задаёт выходную систему единиц измерения по-умолчанию для вычислений с единицами измерения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public string OutputUnitsSystem { get; set; }
Public Property OutputUnitsSystem As String
    Get
    Set
public:
property String^ OutputUnitsSystem {
    String^ get ();
    void set (String^ value);
}
member OutputUnitsSystem : string with get, set

Property Value

Type: String
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.SessionProfile Property

EvaluationContextSessionProfile Property

Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public SessionProfile SessionProfile { get; set; }
Public Property SessionProfile As SessionProfile
    Get
    Set
public:
property SessionProfile^ SessionProfile {
    SessionProfile^ get ();
    void set (SessionProfile^ value);
}
member SessionProfile : SessionProfile with get, set

Property Value

Type: SessionProfile
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.StackDepth Property

EvaluationContextStackDepth Property

Determines stack depth of evaluation.Определяет глубину стека вычислений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int StackDepth { get; set; }
Public Property StackDepth As Integer
    Get
    Set
public:
property int StackDepth {
    int get ();
    void set (int value);
}
member StackDepth : int with get, set

Property Value

Type: Int32
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.SuppressUI Property

EvaluationContextSuppressUI Property

Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SuppressUI { get; set; }
Public Property SuppressUI As Boolean
    Get
    Set
public:
property bool SuppressUI {
    bool get ();
    void set (bool value);
}
member SuppressUI : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext Methods

The EvaluationContext type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint |
Public method | ChangeErrorState |
Public method | ChangeEvaluationState |
Public method | CheckBreakpoint |
Public method | CreateStore |
Public method | CreateStore(IEnumerableDefinition) | Create a Store object with specified definitions included.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause |
Public method | ProgressChange |
Public method | Resume |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.AddBreakpoint Method

EvaluationContextAddBreakpoint Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddBreakpoint(
    Term term,
    bool toggle
)
Public Sub AddBreakpoint (
    term As Term,
    toggle As Boolean
)
public:
void AddBreakpoint(
    Term^ term,
    bool toggle
)
member AddBreakpoint :
        term : Term *
        toggle : bool -> unit

Parameters

term
Type: SMath.ManagerTerm
toggle
Type: SystemBoolean
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.ChangeErrorState Method

EvaluationContextChangeErrorState Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeErrorState(
    RegionEvaluable region,
    bool hasError
)
Public Sub ChangeErrorState (
    region As RegionEvaluable,
    hasError As Boolean
)
public:
void ChangeErrorState(
    RegionEvaluable^ region,
    bool hasError
)
member ChangeErrorState :
        region : RegionEvaluable *
        hasError : bool -> unit

Parameters

region
Type: SMath.ControlsRegionEvaluable
hasError
Type: SystemBoolean
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.ChangeEvaluationState Method

EvaluationContextChangeEvaluationState Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ChangeEvaluationState(
    string action
)
Public Sub ChangeEvaluationState (
    action As String
)
public:
void ChangeEvaluationState(
    String^ action
)
member ChangeEvaluationState :
        action : string -> unit

Parameters

action
Type: SystemString
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.CheckBreakpoint Method

EvaluationContextCheckBreakpoint Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void CheckBreakpoint(
    Store context,
    Entry value,
    int iter
)
Public Sub CheckBreakpoint (
    context As Store,
    value As Entry,
    iter As Integer
)
public:
void CheckBreakpoint(
    Store^ context,
    Entry^ value,
    int iter
)
member CheckBreakpoint :
        context : Store *
        value : Entry *
        iter : int -> unit

Parameters

context
Type: SMath.MathStore
value
Type: SMath.ManagerEntry
iter
Type: SystemInt32
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.CreateStore Method

EvaluationContextCreateStore Method

Overload List
 | Name | Description
Public method | CreateStore |
Public method | CreateStore(IEnumerableDefinition) | Create a Store object with specified definitions included.
Top
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.CreateStore Method

EvaluationContextCreateStore Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store CreateStore()
Public Function CreateStore As Store
public:
Store^ CreateStore()
member CreateStore : unit -> Store

Return Value

Type: Store
See Also

Reference

EvaluationContext Class
CreateStore Overload
SMath.Math Namespace


EvaluationContext.CreateStore Method (IEnumerable(Definition))

EvaluationContextCreateStore Method (IEnumerableDefinition)

Create a Store object with specified definitions included.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store CreateStore(
    IEnumerable<Definition> array
)
Public Function CreateStore (
    array As IEnumerable(Of Definition)
) As Store
public:
Store^ CreateStore(
    IEnumerable<Definition^>^ array
)
member CreateStore :
        array : IEnumerable<Definition> -> Store

Parameters

array
Type: System.Collections.GenericIEnumerableDefinition
Array of the definitions to be copied to the Shared definitions list on context creation.Массив определений для его копирования в список публичных определений создаваемого контекста.

Return Value

Type: Store
See Also

Reference

EvaluationContext Class
CreateStore Overload
SMath.Math Namespace


EvaluationContext.Pause Method

EvaluationContextPause Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Pause()
Public Sub Pause
public:
void Pause()
member Pause : unit -> unit
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.ProgressChange Method

EvaluationContextProgressChange Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ProgressChange(
    RegionBase region,
    string message,
    int current,
    int count,
    Stopwatch watch
)
Public Sub ProgressChange (
    region As RegionBase,
    message As String,
    current As Integer,
    count As Integer,
    watch As Stopwatch
)
public:
void ProgressChange(
    RegionBase^ region,
    String^ message,
    int current,
    int count,
    Stopwatch^ watch
)
member ProgressChange :
        region : RegionBase *
        message : string *
        current : int *
        count : int *
        watch : Stopwatch -> unit

Parameters

region
Type: SMath.ControlsRegionBase
message
Type: SystemString
current
Type: SystemInt32
count
Type: SystemInt32
watch
Type: System.DiagnosticsStopwatch
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.Resume Method

EvaluationContextResume Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Resume()
Public Sub Resume
public:
void Resume()
member Resume : unit -> unit
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext Events

The EvaluationContext type exposes the following members.

Events
 | Name | Description
Public event | OnDataTrace | Occurs on data sent to trace.Вызывается при посылке данных трассировки.
Public event | OnDebugStart | Occurs on debug session started.Вызывается при начале сессии отладки.
Public event | OnErrorState |
Public event | OnEvaluation | Raises on evaluation process status changed.Вызывается при изменении статуса процесса вычисления.
Public event | OnProgressChanged |
Top
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnDataTrace Event

EvaluationContextOnDataTrace Event

Occurs on data sent to trace.Вызывается при посылке данных трассировки.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event TraceEvaluationData OnDataTrace
Public Event OnDataTrace As TraceEvaluationData
public:
 event TraceEvaluationData^ OnDataTrace {
    void add (TraceEvaluationData^ value);
    void remove (TraceEvaluationData^ value);
}
member OnDataTrace : IEvent<TraceEvaluationData,
    EventArgs>

Value

Type: SMath.MathTraceEvaluationData
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnDebugStart Event

EvaluationContextOnDebugStart Event

Occurs on debug session started.Вызывается при начале сессии отладки.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event DebugOccuredEventHandler OnDebugStart
Public Event OnDebugStart As DebugOccuredEventHandler
public:
 event DebugOccuredEventHandler^ OnDebugStart {
    void add (DebugOccuredEventHandler^ value);
    void remove (DebugOccuredEventHandler^ value);
}
member OnDebugStart : IEvent<DebugOccuredEventHandler,
    EventArgs>

Value

Type: SMath.MathDebugOccuredEventHandler
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnErrorState Event

EvaluationContextOnErrorState Event

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event RegionEvaluationStateEventHandler OnErrorState
Public Event OnErrorState As RegionEvaluationStateEventHandler
public:
 event RegionEvaluationStateEventHandler^ OnErrorState {
    void add (RegionEvaluationStateEventHandler^ value);
    void remove (RegionEvaluationStateEventHandler^ value);
}
member OnErrorState : IEvent<RegionEvaluationStateEventHandler,
    EventArgs>

Value

Type: SMath.ControlsRegionEvaluationStateEventHandler
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnEvaluation Event

EvaluationContextOnEvaluation Event

Raises on evaluation process status changed.Вызывается при изменении статуса процесса вычисления.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event EvaluationEventHandler OnEvaluation
Public Event OnEvaluation As EvaluationEventHandler
public:
 event EvaluationEventHandler^ OnEvaluation {
    void add (EvaluationEventHandler^ value);
    void remove (EvaluationEventHandler^ value);
}
member OnEvaluation : IEvent<EvaluationEventHandler,
    EventArgs>

Value

Type: SMath.ControlsEvaluationEventHandler
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


EvaluationContext.OnProgressChanged Event

EvaluationContextOnProgressChanged Event

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public event ProgressEventHandler OnProgressChanged
Public Event OnProgressChanged As ProgressEventHandler
public:
 event ProgressEventHandler^ OnProgressChanged {
    void add (ProgressEventHandler^ value);
    void remove (ProgressEventHandler^ value);
}
member OnProgressChanged : IEvent<ProgressEventHandler,
    EventArgs>

Value

Type: SMath.ControlsProgressEventHandler
See Also

Reference

EvaluationContext Class
SMath.Math Namespace


IPluginLowLevelEvaluation Interface

Interface to handle low-level evaluation.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginLowLevelEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
Public Interface IPluginLowLevelEvaluation
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
public interface class IPluginLowLevelEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
type IPluginLowLevelEvaluation =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

The IPluginLowLevelEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExpressionEvaluation | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

SMath.Math Namespace


IPluginLowLevelEvaluation Methods

The IPluginLowLevelEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExpressionEvaluation | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Top
See Also

Reference

IPluginLowLevelEvaluation Interface
SMath.Math Namespace


IPluginLowLevelEvaluation.ExpressionEvaluation Method

IPluginLowLevelEvaluationExpressionEvaluation Method

Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool ExpressionEvaluation(
    Term root,
    Term[][] args,
    ref Store context,
    ref Term[] result
)
Function ExpressionEvaluation (
    root As Term,
    args As Term()(),
    ByRef context As Store,
    ByRef result As Term()
) As Boolean
bool ExpressionEvaluation(
    Term^ root,
    array<array<Term^>^>^ args,
    Store^% context,
    array<Term^>^% result
)
abstract ExpressionEvaluation :
        root : Term *
        args : Term[][] *
        context : Store byref *
        result : Term[] byref -> bool

Parameters

root
Type: SMath.ManagerTerm
Root Term of the expression.
args
Type: SMath.ManagerTerm
Arguments of the root element.
context
Type: SMath.MathStore
On page definitions (variables, functions and terminators).
result
Type: SMath.ManagerTerm
Evaluation result.

Return Value

Type: Boolean
Indicates success of evaluation.
See Also

Reference

IPluginLowLevelEvaluation Interface
SMath.Math Namespace


IPluginLowLevelEvaluationFast Interface

Interface to handle low-level evaluation.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public interface IPluginLowLevelEvaluationFast : IPluginHandleEvaluation,
    IPlugin, IDisposable
Public Interface IPluginLowLevelEvaluationFast
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
public interface class IPluginLowLevelEvaluationFast : IPluginHandleEvaluation,
    IPlugin, IDisposable
type IPluginLowLevelEvaluationFast =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

The IPluginLowLevelEvaluationFast type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | TryEvaluateExpression | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Top
See Also

Reference

SMath.Math Namespace


IPluginLowLevelEvaluationFast Methods

The IPluginLowLevelEvaluationFast type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | TryEvaluateExpression | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Top
See Also

Reference

IPluginLowLevelEvaluationFast Interface
SMath.Math Namespace


IPluginLowLevelEvaluationFast.TryEvaluateExpression Method

IPluginLowLevelEvaluationFastTryEvaluateExpression Method

Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
bool TryEvaluateExpression(
    Entry value,
    Store context,
    out Entry result
)
Function TryEvaluateExpression (
    value As Entry,
    context As Store,
    <OutAttribute> ByRef result As Entry
) As Boolean
bool TryEvaluateExpression(
    Entry^ value,
    Store^ context,
    [OutAttribute] Entry^% result
)
abstract TryEvaluateExpression :
        value : Entry *
        context : Store *
        result : Entry byref -> bool

Parameters

value
Type: SMath.ManagerEntry
Expression Entry.
context
Type: SMath.MathStore
Calculation context. Allows to manage worksheet definitions (variables, functions and terminators).
result
Type: SMath.ManagerEntry
Evaluation result.

Return Value

Type: Boolean
Indicates success of evaluation.
See Also

Reference

IPluginLowLevelEvaluationFast Interface
SMath.Math Namespace


Store Class

Evaluation context. Data type that stores all information about variables, arguments and functions definitions. Definitions represented in a stack.Контекст вычисления. Тип данных, хранящий в себе информацию об объявленных функциях и переменных. В Store все объявления записываются в стэк.
Inheritance Hierarchy
SystemObject
SMath.ManagerDocumentParams
SMath.ManagerActionContext
SMath.MathStore

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public class Store : ActionContext, IEvaluationActionContext,
    IEnumerable<Definition>, IEnumerable, IDisposable
Public Class Store
    Inherits ActionContext
    Implements IEvaluationActionContext, IEnumerable(Of Definition),
    IEnumerable, IDisposable
public ref class Store : public ActionContext,
    IEvaluationActionContext, IEnumerable<Definition^>, IEnumerable, IDisposable
type Store =
    class
        inherit ActionContext
        interface IEvaluationActionContext
        interface IEnumerable<Definition>
        interface IEnumerable
        interface IDisposable
    end

The Store type exposes the following members.

Constructors
 | Name | Description
Public method | Store(EvaluationContext) | Constructor of context-class Store.Конструктор класса-контекста Store.
Public method | Store(Store) | Constructor of context-class Store. Creates full copy of the specified Store object. Handy for multi-threading calculations.Конструктор класса-контекста Store.
Top
Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | ActionAborted | Determines if action in the scope of current context was flagged as aborted or not.Определяет помечено ли текущее действие вычисления как отменённое.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | Count | Number of Shared definitions.Количество публичных определений.
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | IgnoreUnits | Determines if units of measurement should be taken into account or not while evaluation.Определяет необходимо ли учитывать единицы измерения при вычислениях.
Public property | IsDefProcessing | Determines if action in the scope of current context was initiated for calculation of definition.Определяет инициировано ли текущее действие вычисления вычислениями определения.
Public property | IsUnderVectorization | Determines whether current action performed in the scope of vectorization process or not.Определяет находится ли текущий процесс вычислений в контексте векторизации или нет.
Public property | Item | Returns a definition by the index from the shared definition collection.Возвращает определение по индексу из публичной коллекции присваиваний.
Public property | Optimization | Defines if right part of the definition should be optimized using Symbolic Library.Определяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.
Public property | OutputUnitsSystem | Obsolete.
Public property | Revision | (Inherited from DocumentParams.)
Public property | Scope | Context of the current worksheet evaluation process.Контекст текущего процесса вычислений листа расчётов.
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SkipClearOnError | Determines whether variable/function must leave its previous value on error or not.Определяет должна ли переменная/функции иметь своё предыдущее значение после ошибки.
Public property | StartDepth | Start scope depth for current calculation context.Стартовое значение глубины контекста в рамках текущей операции вычислений.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Top
Methods
 | Name | Description
Public method | AddDefinition(Definition) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Definition, Boolean) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Entry, Entry) | Adds a definition to current evaluation context.Добавляет определение к текущему контексту вычисления.
Public method | AddDefinition(Term, Term) | Obsolete.
Public method | AddDefinition(String, Term, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Term, Term) | Obsolete.
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | AddTerminator | Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition.Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.
Public method | AppendDefinition(String, Term, Entry) | Add new variable or function to the end of definitions list.Добавляет новую переменную или функцию в конец списка определений.
Public method | AppendDefinition(String, Term, Term) | Obsolete.
Public method | Clear | Clears a definition from the global store.
Public method | CloneShare | Creates a copy of current context with Shared definitions only.Создаёт копию текущего контекста только с публичными определениями.
Public method | Contains(IPrimitive) | Determines if current context contains definition of specified primitives.Проверяет список публичных определений на наличие указанных определений.
Public method | Contains(IPrimitive, Definition) |
Public method | Contains(IPrimitive, Int32) | Determines if current context contains definition of the Term.Проверяет список публичных определений на наличие конкретного определения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromFile | Load evaluation context from file.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsDefined(IPrimitive) | Obsolete. Checks if every element of mathematical expression is defined. Not recursive.Проверяет существует ли определение каждому элементу математического выражения. Проверка не рекурсивная.
Public method | IsDefined(IPrimitive, Boolean) | Checks if element of mathematical expression is defined.Проверяет существует ли определение элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean) | Checks if every element of mathematical expression is defined.Проверяет существует ли определение каждому элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean, Boolean, Boolean) |
Public method | IsGraphChanged | Detects structural changes between calculation contexts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RemoveAt | Removes Definition at the specific position of the shared list.Удаляет определение из публичного списка по указанному индексу.
Public method | RemoveRange | Removes Definitions of the specific range of the shared list.Удаление определений из публичного списка в указанном диапазоне.
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToFile | Creates a file contains exported evaluation context.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TraceData | Sends trace data to the subscribers.Посылает данные трассировки подписчикам.
Public method | UpdateAt(Int32, Entry) | Updates answer for the specific definition.Обновляет ответ указанного определения.
Public method | UpdateAt(Int32, Term) | Obsolete.
Top
Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Explicit interface implementation | IEnumerableGetEnumerator |
Top
See Also

Reference

SMath.Math Namespace


Store Constructor

Overload List
 | Name | Description
Public method | Store(EvaluationContext) | Constructor of context-class Store.Конструктор класса-контекста Store.
Public method | Store(Store) | Constructor of context-class Store. Creates full copy of the specified Store object. Handy for multi-threading calculations.Конструктор класса-контекста Store.
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store Constructor (EvaluationContext)

Constructor of context-class Store.Конструктор класса-контекста Store.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store(
    EvaluationContext scope
)
Public Sub New (
    scope As EvaluationContext
)
public:
Store(
    EvaluationContext^ scope
)
new :
        scope : EvaluationContext -> Store

Parameters

scope
Type: SMath.MathEvaluationContext
See Also

Reference

Store Class
Store Overload
SMath.Math Namespace


Store Constructor (Store)

Constructor of context-class Store. Creates full copy of the specified Store object. Handy for multi-threading calculations.Конструктор класса-контекста Store.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store(
    Store store
)
Public Sub New (
    store As Store
)
public:
Store(
    Store^ store
)
new :
        store : Store -> Store

Parameters

store
Type: SMath.MathStore
See Also

Reference

Store Class
Store Overload
SMath.Math Namespace


Store Properties

The Store type exposes the following members.

Properties
 | Name | Description
Public property | Action | Text value of the current context usage.Текстовое значение текущего использования контекста. (Inherited from ActionContext.)
Public property | ActionAborted | Determines if action in the scope of current context was flagged as aborted or not.Определяет помечено ли текущее действие вычисления как отменённое.
Public property | Cancel | Determines if operation requests for canceling.Определяет запрашивается ли завершение операции или нет. (Inherited from ActionContext.)
Public property | Count | Number of Shared definitions.Количество публичных определений.
Public property | Dependencies | All plug-in dependences for the current expression evaluation.Содержит список дополнений (плагинов), участвовавших в процессе текущего вычисления. (Inherited from ActionContext.)
Public property | FileName | Current worksheet full file name.Полное имя файла текущего листа расчётов. (Inherited from DocumentParams.)
Public property | FractionsTypeNumeric | Numeric fractions type required for current context.Тип дробей требуемый для численных вычислений текущего контекста. (Inherited from ActionContext.)
Public property | GeneratorVersion | Version of the application.Версия приложения. (Inherited from ActionContext.)
Public property | Id | (Inherited from DocumentParams.)
Public property | IgnoreUnits | Determines if units of measurement should be taken into account or not while evaluation.Определяет необходимо ли учитывать единицы измерения при вычислениях.
Public property | IsDefProcessing | Determines if action in the scope of current context was initiated for calculation of definition.Определяет инициировано ли текущее действие вычисления вычислениями определения.
Public property | IsUnderVectorization | Determines whether current action performed in the scope of vectorization process or not.Определяет находится ли текущий процесс вычислений в контексте векторизации или нет.
Public property | Item | Returns a definition by the index from the shared definition collection.Возвращает определение по индексу из публичной коллекции присваиваний.
Public property | Optimization | Defines if right part of the definition should be optimized using Symbolic Library.Определяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.
Public property | OutputUnitsSystem | Obsolete.
Public property | Revision | (Inherited from DocumentParams.)
Public property | Scope | Context of the current worksheet evaluation process.Контекст текущего процесса вычислений листа расчётов.
Public property | SessionProfile | Session parameters.Параметры сессии. (Inherited from ActionContext.)
Public property | SkipClearOnError | Determines whether variable/function must leave its previous value on error or not.Определяет должна ли переменная/функции иметь своё предыдущее значение после ошибки.
Public property | StartDepth | Start scope depth for current calculation context.Стартовое значение глубины контекста в рамках текущей операции вычислений.
Public property | SuppressUI | Determines whether any interactions with user is not supported.Определяет отсутствие поддержки интерфейса пользователя. (Inherited from ActionContext.)
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.ActionAborted Property

StoreActionAborted Property

Determines if action in the scope of current context was flagged as aborted or not.Определяет помечено ли текущее действие вычисления как отменённое.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool ActionAborted { get; set; }
Public Property ActionAborted As Boolean
    Get
    Set
public:
property bool ActionAborted {
    bool get ();
    void set (bool value);
}
member ActionAborted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Store Class
SMath.Math Namespace


Store.Count Property

StoreCount Property

Number of Shared definitions.Количество публичных определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

Store Class
SMath.Math Namespace


Store.IgnoreUnits Property

StoreIgnoreUnits Property

Determines if units of measurement should be taken into account or not while evaluation.Определяет необходимо ли учитывать единицы измерения при вычислениях.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreUnits { get; set; }
Public Property IgnoreUnits As Boolean
    Get
    Set
public:
property bool IgnoreUnits {
    bool get ();
    void set (bool value);
}
member IgnoreUnits : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Store Class
SMath.Math Namespace


Store.IsDefProcessing Property

StoreIsDefProcessing Property

Determines if action in the scope of current context was initiated for calculation of definition.Определяет инициировано ли текущее действие вычисления вычислениями определения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDefProcessing { get; set; }
Public Property IsDefProcessing As Boolean
    Get
    Set
public:
virtual property bool IsDefProcessing {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsDefProcessing : bool with get, set
override IsDefProcessing : bool with get, set

Property Value

Type: Boolean

Implements

IEvaluationActionContextIsDefProcessing
See Also

Reference

Store Class
SMath.Math Namespace


Store.IsUnderVectorization Property

StoreIsUnderVectorization Property

Determines whether current action performed in the scope of vectorization process or not.Определяет находится ли текущий процесс вычислений в контексте векторизации или нет.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsUnderVectorization { get; set; }
Public Property IsUnderVectorization As Boolean
    Get
    Set
public:
virtual property bool IsUnderVectorization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsUnderVectorization : bool with get, set
override IsUnderVectorization : bool with get, set

Property Value

Type: Boolean

Implements

IEvaluationActionContextIsUnderVectorization
See Also

Reference

Store Class
SMath.Math Namespace


Store.Item Property

StoreItem Property

Returns a definition by the index from the shared definition collection.Возвращает определение по индексу из публичной коллекции присваиваний.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Definition this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Definition
    Get
public:
property Definition^ default[int index] {
    Definition^ get (int index);
}
member Item : Definition with get

Parameters

index
Type: SystemInt32
Index of the definition.Индекс определения.

Return Value

Type: Definition
Definition by index.Определение по индексу.
See Also

Reference

Store Class
SMath.Math Namespace


Store.Optimization Property

StoreOptimization Property

Defines if right part of the definition should be optimized using Symbolic Library.Определяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public OptimizationType Optimization { get; set; }
Public Property Optimization As OptimizationType
    Get
    Set
public:
property OptimizationType Optimization {
    OptimizationType get ();
    void set (OptimizationType value);
}
member Optimization : OptimizationType with get, set

Property Value

Type: OptimizationType
See Also

Reference

Store Class
SMath.Math Namespace


Store.OutputUnitsSystem Property

StoreOutputUnitsSystem Property

Note: This API is now obsolete.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Scope.OutputUnitsSystem instead.")]
public string OutputUnitsSystem { get; }
<ObsoleteAttribute("Use Scope.OutputUnitsSystem instead.")>
Public ReadOnly Property OutputUnitsSystem As String
    Get
public:
[ObsoleteAttribute(L"Use Scope.OutputUnitsSystem instead.")]
property String^ OutputUnitsSystem {
    String^ get ();
}
[<ObsoleteAttribute("Use Scope.OutputUnitsSystem instead.")>]
member OutputUnitsSystem : string with get

Property Value

Type: String
See Also

Reference

Store Class
SMath.Math Namespace


Store.Scope Property

StoreScope Property

Context of the current worksheet evaluation process.Контекст текущего процесса вычислений листа расчётов.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public EvaluationContext Scope { get; }
Public ReadOnly Property Scope As EvaluationContext
    Get
public:
property EvaluationContext^ Scope {
    EvaluationContext^ get ();
}
member Scope : EvaluationContext with get

Property Value

Type: EvaluationContext
See Also

Reference

Store Class
SMath.Math Namespace


Store.SkipClearOnError Property

StoreSkipClearOnError Property

Determines whether variable/function must leave its previous value on error or not.Определяет должна ли переменная/функции иметь своё предыдущее значение после ошибки.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool SkipClearOnError { get; set; }
Public Property SkipClearOnError As Boolean
    Get
    Set
public:
property bool SkipClearOnError {
    bool get ();
    void set (bool value);
}
member SkipClearOnError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Store Class
SMath.Math Namespace


Store.StartDepth Property

StoreStartDepth Property

Start scope depth for current calculation context.Стартовое значение глубины контекста в рамках текущей операции вычислений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int StartDepth { get; }
Public ReadOnly Property StartDepth As Integer
    Get
public:
property int StartDepth {
    int get ();
}
member StartDepth : int with get

Property Value

Type: Int32
See Also

Reference

Store Class
SMath.Math Namespace


Store Methods

The Store type exposes the following members.

Methods
 | Name | Description
Public method | AddDefinition(Definition) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Definition, Boolean) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Entry, Entry) | Adds a definition to current evaluation context.Добавляет определение к текущему контексту вычисления.
Public method | AddDefinition(Term, Term) | Obsolete.
Public method | AddDefinition(String, Term, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Term, Term) | Obsolete.
Public method | AddDependency(AssemblyInfo) | Add dependence from specific plug-in.Добавление зависимости текущего вычисления от дополнения (плагина). (Inherited from ActionContext.)
Public method | AddDependency(IEnumerableAssemblyInfo) | Add dependences from specific plug-ins.Добавление зависимостей текущего вычисления от дополнений (плагинов). (Inherited from ActionContext.)
Public method | AddTerminator | Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition.Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.
Public method | AppendDefinition(String, Term, Entry) | Add new variable or function to the end of definitions list.Добавляет новую переменную или функцию в конец списка определений.
Public method | AppendDefinition(String, Term, Term) | Obsolete.
Public method | Clear | Clears a definition from the global store.
Public method | CloneShare | Creates a copy of current context with Shared definitions only.Создаёт копию текущего контекста только с публичными определениями.
Public method | Contains(IPrimitive) | Determines if current context contains definition of specified primitives.Проверяет список публичных определений на наличие указанных определений.
Public method | Contains(IPrimitive, Definition) |
Public method | Contains(IPrimitive, Int32) | Determines if current context contains definition of the Term.Проверяет список публичных определений на наличие конкретного определения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromFile | Load evaluation context from file.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | IsDefined(IPrimitive) | Obsolete. Checks if every element of mathematical expression is defined. Not recursive.Проверяет существует ли определение каждому элементу математического выражения. Проверка не рекурсивная.
Public method | IsDefined(IPrimitive, Boolean) | Checks if element of mathematical expression is defined.Проверяет существует ли определение элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean) | Checks if every element of mathematical expression is defined.Проверяет существует ли определение каждому элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean, Boolean, Boolean) |
Public method | IsGraphChanged | Detects structural changes between calculation contexts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseError | (Inherited from ActionContext.)
Public method | RemoveAt | Removes Definition at the specific position of the shared list.Удаляет определение из публичного списка по указанному индексу.
Public method | RemoveRange | Removes Definitions of the specific range of the shared list.Удаление определений из публичного списка в указанном диапазоне.
Public method | RequestPlugins | (Inherited from ActionContext.)
Public method | ToFile | Creates a file contains exported evaluation context.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TraceData | Sends trace data to the subscribers.Посылает данные трассировки подписчикам.
Public method | UpdateAt(Int32, Entry) | Updates answer for the specific definition.Обновляет ответ указанного определения.
Public method | UpdateAt(Int32, Term) | Obsolete.
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IDisposableDispose |
Explicit interface implementation | IEnumerableGetEnumerator |
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.IDisposable.Dispose Method

StoreIDisposableDispose Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose
private abstract Dispose : unit -> unit
private override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Store Class
SMath.Math Namespace


Store.IEnumerable.GetEnumerator Method

StoreIEnumerableGetEnumerator Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

Store Class
SMath.Math Namespace


Store.AddDefinition Method

StoreAddDefinition Method

Overload List
 | Name | Description
Public method | AddDefinition(Definition) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Definition, Boolean) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(Entry, Entry) | Adds a definition to current evaluation context.Добавляет определение к текущему контексту вычисления.
Public method | AddDefinition(Term, Term) | Obsolete.
Public method | AddDefinition(String, Term, Entry) | Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.
Public method | AddDefinition(String, Term, Term) | Obsolete.
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.AddDefinition Method (Definition)

StoreAddDefinition Method (Definition)

Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int AddDefinition(
    Definition definition
)
Public Function AddDefinition (
    definition As Definition
) As Integer
public:
int AddDefinition(
    Definition^ definition
)
member AddDefinition :
        definition : Definition -> int

Parameters

definition
Type: SMath.ManagerDefinition
Definition to add.Определение для добавления.

Return Value

Type: Int32
Returns index of the definition inside list of definition.Возвращает индекс определения в списке определений.
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (String, Entry)

StoreAddDefinition Method (String, Entry)

Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int AddDefinition(
    string name,
    Entry answer
)
Public Function AddDefinition (
    name As String,
    answer As Entry
) As Integer
public:
int AddDefinition(
    String^ name,
    Entry^ answer
)
member AddDefinition :
        name : string *
        answer : Entry -> int

Parameters

name
Type: SystemString
Name of the definition.Имя компоненты для определения.
answer
Type: SMath.ManagerEntry
Answer, i.e. value of definition.Результат, ассоциированный с определением.

Return Value

Type: Int32
Returns index of the definition inside list of definition.Возвращает индекс определения в списке определений.
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (Definition, Boolean)

StoreAddDefinition Method (Definition, Boolean)

Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int AddDefinition(
    Definition definition,
    bool isCalculated
)
Public Function AddDefinition (
    definition As Definition,
    isCalculated As Boolean
) As Integer
public:
int AddDefinition(
    Definition^ definition,
    bool isCalculated
)
member AddDefinition :
        definition : Definition *
        isCalculated : bool -> int

Parameters

definition
Type: SMath.ManagerDefinition
Definition to add.Определение для добавления.
isCalculated
Type: SystemBoolean
Whether definition is already calculated or not.Определяет было ли определение уже посчитано или нет.

Return Value

Type: Int32
Returns index of the definition inside list of definition.Возвращает индекс определения в списке определений.
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (Entry, Entry)

StoreAddDefinition Method (Entry, Entry)

Adds a definition to current evaluation context.Добавляет определение к текущему контексту вычисления.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Entry AddDefinition(
    Entry leftPart,
    Entry rightPart
)
Public Function AddDefinition (
    leftPart As Entry,
    rightPart As Entry
) As Entry
public:
Entry^ AddDefinition(
    Entry^ leftPart,
    Entry^ rightPart
)
member AddDefinition :
        leftPart : Entry *
        rightPart : Entry -> Entry

Parameters

leftPart
Type: SMath.ManagerEntry
Left part of the expression.
rightPart
Type: SMath.ManagerEntry
Right part of the equation.

Return Value

Type: Entry
Exceptions
Exception | Condition
MathException | Will thrown if definition cannot be accepted by current context of evaluation.Произойдёт если определение не может быть принято текущим контекстом вычисления.
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (Term[], Term[])

StoreAddDefinition Method (Term, Term)

Note: This API is now obsolete.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public Term[] AddDefinition(
    Term[] leftPart,
    Term[] rightPart
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Function AddDefinition (
    leftPart As Term(),
    rightPart As Term()
) As Term()
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
array<Term^>^ AddDefinition(
    array<Term^>^ leftPart,
    array<Term^>^ rightPart
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
member AddDefinition :
        leftPart : Term[] *
        rightPart : Term[] -> Term[]

Parameters

leftPart
Type: SMath.ManagerTerm
rightPart
Type: SMath.ManagerTerm

Return Value

Type: Term
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (String, Term[], Entry)

StoreAddDefinition Method (String, Term, Entry)

Updates existing or adds a new variable or function to the definitions list.Обновляет существующую или добавляет новую переменную или функцию к списку определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int AddDefinition(
    string name,
    Term[] variables,
    Entry answer
)
Public Function AddDefinition (
    name As String,
    variables As Term(),
    answer As Entry
) As Integer
public:
int AddDefinition(
    String^ name,
    array<Term^>^ variables,
    Entry^ answer
)
member AddDefinition :
        name : string *
        variables : Term[] *
        answer : Entry -> int

Parameters

name
Type: SystemString
Name of the definition.Имя компоненты для определения.
variables
Type: SMath.ManagerTerm
If function, then a list of variables should be defined.Если определяется функция, то должен быть указан список её аргументов.
answer
Type: SMath.ManagerEntry
Answer, i.e. value of definition.Результат, ассоциированный с определением.

Return Value

Type: Int32
Returns index of the definition inside list of definition.Возвращает индекс определения в списке определений.
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddDefinition Method (String, Term[], Term[])

StoreAddDefinition Method (String, Term, Term)

Note: This API is now obsolete.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public int AddDefinition(
    string name,
    Term[] answer,
    Term[] variables
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Function AddDefinition (
    name As String,
    answer As Term(),
    variables As Term()
) As Integer
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
int AddDefinition(
    String^ name,
    array<Term^>^ answer,
    array<Term^>^ variables
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
member AddDefinition :
        name : string *
        answer : Term[] *
        variables : Term[] -> int

Parameters

name
Type: SystemString
answer
Type: SMath.ManagerTerm
variables
Type: SMath.ManagerTerm

Return Value

Type: Int32
See Also

Reference

Store Class
AddDefinition Overload
SMath.Math Namespace


Store.AddTerminator Method

StoreAddTerminator Method

Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition.Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void AddTerminator(
    Term term
)
Public Sub AddTerminator (
    term As Term
)
public:
void AddTerminator(
    Term^ term
)
member AddTerminator :
        term : Term -> unit

Parameters

term
Type: SMath.ManagerTerm
Terminator options.Свойства заглушки.
See Also

Reference

Store Class
SMath.Math Namespace


Store.AppendDefinition Method

StoreAppendDefinition Method

Overload List
 | Name | Description
Public method | AppendDefinition(String, Term, Entry) | Add new variable or function to the end of definitions list.Добавляет новую переменную или функцию в конец списка определений.
Public method | AppendDefinition(String, Term, Term) | Obsolete.
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.AppendDefinition Method (String, Term[], Entry)

StoreAppendDefinition Method (String, Term, Entry)

Add new variable or function to the end of definitions list.Добавляет новую переменную или функцию в конец списка определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public int AppendDefinition(
    string name,
    Term[] variables,
    Entry result
)
Public Function AppendDefinition (
    name As String,
    variables As Term(),
    result As Entry
) As Integer
public:
int AppendDefinition(
    String^ name,
    array<Term^>^ variables,
    Entry^ result
)
member AppendDefinition :
        name : string *
        variables : Term[] *
        result : Entry -> int

Parameters

name
Type: SystemString
Name of the new definition.Имя компоненты для определения.
variables
Type: SMath.ManagerTerm
If function, then a list of variables should be defined.Если определяется функция, то должен быть указан список её аргументов.
result
Type: SMath.ManagerEntry
Answer, i.e. value of definition.Результат, ассоциированный с определением.

Return Value

Type: Int32
Returns index of the definition inside list of definition.Возвращает индекс определения в списке определений.
See Also

Reference

Store Class
AppendDefinition Overload
SMath.Math Namespace


Store.AppendDefinition Method (String, Term[], Term[])

StoreAppendDefinition Method (String, Term, Term)

Note: This API is now obsolete.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public int AppendDefinition(
    string name,
    Term[] answer,
    Term[] variables
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Function AppendDefinition (
    name As String,
    answer As Term(),
    variables As Term()
) As Integer
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
int AppendDefinition(
    String^ name,
    array<Term^>^ answer,
    array<Term^>^ variables
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
member AppendDefinition :
        name : string *
        answer : Term[] *
        variables : Term[] -> int

Parameters

name
Type: SystemString
answer
Type: SMath.ManagerTerm
variables
Type: SMath.ManagerTerm

Return Value

Type: Int32
See Also

Reference

Store Class
AppendDefinition Overload
SMath.Math Namespace


Store.Clear Method

StoreClear Method

Clears a definition from the global store.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void Clear(
    IPrimitive definition
)
Public Sub Clear (
    definition As IPrimitive
)
public:
void Clear(
    IPrimitive^ definition
)
member Clear :
        definition : IPrimitive -> unit

Parameters

definition
Type: SMath.ManagerIPrimitive
Definition to clear.
See Also

Reference

Store Class
SMath.Math Namespace


Store.CloneShare Method

StoreCloneShare Method

Creates a copy of current context with Shared definitions only.Создаёт копию текущего контекста только с публичными определениями.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public Store CloneShare()
Public Function CloneShare As Store
public:
Store^ CloneShare()
member CloneShare : unit -> Store

Return Value

Type: Store
Copy of current context with Shared definitions only.Копия текущего контекста с публичными определениями.
See Also

Reference

Store Class
SMath.Math Namespace


Store.Contains Method

StoreContains Method

Overload List
 | Name | Description
Public method | Contains(IPrimitive) | Determines if current context contains definition of specified primitives.Проверяет список публичных определений на наличие указанных определений.
Public method | Contains(IPrimitive, Definition) |
Public method | Contains(IPrimitive, Int32) | Determines if current context contains definition of the Term.Проверяет список публичных определений на наличие конкретного определения.
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.Contains Method (IPrimitive[])

StoreContains Method (IPrimitive)

Determines if current context contains definition of specified primitives.Проверяет список публичных определений на наличие указанных определений.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    params IPrimitive[] values
)
Public Function Contains (
    ParamArray values As IPrimitive()
) As Boolean
public:
virtual bool Contains(
    ... array<IPrimitive^>^ values
) sealed
abstract Contains :
        values : IPrimitive[] -> bool
override Contains :
        values : IPrimitive[] -> bool

Parameters

values
Type: SMath.ManagerIPrimitive
Expression components to find definition for.Компоненты выражения, для которых производится проверка наличия определений.

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.

Implements

IEvaluationActionContextContains(IPrimitive)
Remarks
Only checks current context definitions. If it is required to determine definition for the Term within a list of built-in functions and variables and entries handled by loaded plug-ins as well use SMath.Manager.Store.IsDefined.Проверяет только наличие определения внутри публичного списка определений текущего контекста. Для проверки наличия определения так же и в списке встроенных функций и переменных программы, в том числе и среди примитивов поддерживаемых подключёнными плагинами, необходимо использовать SMath.Manager.Store.IsDefined.
See Also

Reference

Store Class
Contains Overload
SMath.Math Namespace


Store.Contains Method (IPrimitive, Definition)

StoreContains Method (IPrimitive, Definition)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    IPrimitive value,
    out Definition def
)
Public Function Contains (
    value As IPrimitive,
    <OutAttribute> ByRef def As Definition
) As Boolean
public:
virtual bool Contains(
    IPrimitive^ value,
    [OutAttribute] Definition^% def
) sealed
abstract Contains :
        value : IPrimitive *
        def : Definition byref -> bool
override Contains :
        value : IPrimitive *
        def : Definition byref -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
def
Type: SMath.ManagerDefinition

Return Value

Type: Boolean

Implements

IEvaluationActionContextContains(IPrimitive, Definition)
See Also

Reference

Store Class
Contains Overload
SMath.Math Namespace


Store.Contains Method (IPrimitive, Int32)

StoreContains Method (IPrimitive, Int32)

Determines if current context contains definition of the Term.Проверяет список публичных определений на наличие конкретного определения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    IPrimitive value,
    out int index
)
Public Function Contains (
    value As IPrimitive,
    <OutAttribute> ByRef index As Integer
) As Boolean
public:
bool Contains(
    IPrimitive^ value,
    [OutAttribute] int% index
)
member Contains :
        value : IPrimitive *
        index : int byref -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
Expression component to find definition for.Компонент выражения, для которого производится проверка наличия определения.
index
Type: SystemInt32
Defines an index of the definition to use from current context.Возвращает индекс определения из контекста, которое может быть использовано для подстановки.

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
Remarks
Only checks current context definitions. If it is required to determine definition for the Term within a list of built-in functions and variables and entries handled by loaded plug-ins as well use SMath.Manager.Store.IsDefined.Проверяет только наличие определения внутри публичного списка определений текущего контекста. Для проверки наличия определения так же и в списке встроенных функций и переменных программы, в том числе и среди примитивов поддерживаемых подключёнными плагинами, необходимо использовать SMath.Manager.Store.IsDefined.
See Also

Reference

Store Class
Contains Overload
SMath.Math Namespace


Store.FromFile Method

StoreFromFile Method

Load evaluation context from file.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public static Store FromFile(
    SessionProfile sessionProfile,
    string fileName,
    out DocumentMetaData metaData
)
Public Shared Function FromFile (
    sessionProfile As SessionProfile,
    fileName As String,
    <OutAttribute> ByRef metaData As DocumentMetaData
) As Store
public:
static Store^ FromFile(
    SessionProfile^ sessionProfile,
    String^ fileName,
    [OutAttribute] DocumentMetaData^% metaData
)
static member FromFile :
        sessionProfile : SessionProfile *
        fileName : string *
        metaData : DocumentMetaData byref -> Store

Parameters

sessionProfile
Type: SMath.ManagerSessionProfile
Current Session Profile describes all session specific parameters. Used as a main context for all IO/visualization/calculation operations.
fileName
Type: SystemString
FileName to load context from.
metaData
Type: SMath.ManagerDocumentMetaData
Document meta-data loaded from file.

Return Value

Type: Store
Returns evaluation context.
See Also

Reference

Store Class
SMath.Math Namespace


Store.GetEnumerator Method

StoreGetEnumerator Method

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public IEnumerator<Definition> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Definition)
public:
virtual IEnumerator<Definition^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<Definition>
override GetEnumerator : unit -> IEnumerator<Definition>

Return Value

Type: IEnumeratorDefinition

Implements

IEnumerableTGetEnumerator
See Also

Reference

Store Class
SMath.Math Namespace


Store.IsDefined Method

StoreIsDefined Method

Overload List
 | Name | Description
Public method | IsDefined(IPrimitive) | Obsolete. Checks if every element of mathematical expression is defined. Not recursive.Проверяет существует ли определение каждому элементу математического выражения. Проверка не рекурсивная.
Public method | IsDefined(IPrimitive, Boolean) | Checks if element of mathematical expression is defined.Проверяет существует ли определение элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean) | Checks if every element of mathematical expression is defined.Проверяет существует ли определение каждому элементу математического выражения.
Public method | IsDefined(IPrimitive, Boolean, Boolean, Boolean) |
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.IsDefined Method (IPrimitive[])

StoreIsDefined Method (IPrimitive)

Note: This API is now obsolete.

Checks if every element of mathematical expression is defined. Not recursive.Проверяет существует ли определение каждому элементу математического выражения. Проверка не рекурсивная.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use IsDefined(IPrimitive[], bool) with false set for recursiveCheck attribute instead.")]
public bool IsDefined(
    params IPrimitive[] values
)
<ObsoleteAttribute("Use IsDefined(IPrimitive[], bool) with false set for recursiveCheck attribute instead.")>
Public Function IsDefined (
    ParamArray values As IPrimitive()
) As Boolean
public:
[ObsoleteAttribute(L"Use IsDefined(IPrimitive[], bool) with false set for recursiveCheck attribute instead.")]
bool IsDefined(
    ... array<IPrimitive^>^ values
)
[<ObsoleteAttribute("Use IsDefined(IPrimitive[], bool) with false set for recursiveCheck attribute instead.")>]
member IsDefined :
        values : IPrimitive[] -> bool

Parameters

values
Type: SMath.ManagerIPrimitive
Mathematical expression to check for definitions.Математическое выражение для проверки.

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
Remarks
Determines definition for every element into expression within public collection of definitions of current context, within a list of built-in functions and variables and entries handled by loaded plug-ins.Проверяет наличие определения каждого элемента выражения в коллекции публичных определений контекста вычисления, в списке встроенных функций и переменных программы, в том числе и среди примитивов поддерживаемых подключёнными плагинами.
See Also

Reference

Store Class
IsDefined Overload
SMath.Math Namespace


Store.IsDefined Method (IPrimitive, Boolean)

StoreIsDefined Method (IPrimitive, Boolean)

Checks if element of mathematical expression is defined.Проверяет существует ли определение элементу математического выражения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDefined(
    IPrimitive value,
    bool recursiveCheck
)
Public Function IsDefined (
    value As IPrimitive,
    recursiveCheck As Boolean
) As Boolean
public:
bool IsDefined(
    IPrimitive^ value,
    bool recursiveCheck
)
member IsDefined :
        value : IPrimitive *
        recursiveCheck : bool -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
Mathematical expression to check for definitions.Математическое выражение для проверки.
recursiveCheck
Type: SystemBoolean
Determines whether check for definitions must be recursive or not.Определяет необходимость рекурсивной проверки определений.

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
Remarks
Determines definition for element into expression within public collection of definitions of current context, within a list of built-in functions and variables and entries handled by loaded plug-ins.Проверяет наличие определения элемента выражения в коллекции публичных определений контекста вычисления, в списке встроенных функций и переменных программы, в том числе и среди примитивов поддерживаемых подключёнными плагинами.
See Also

Reference

Store Class
IsDefined Overload
SMath.Math Namespace


Store.IsDefined Method (IPrimitive[], Boolean)

StoreIsDefined Method (IPrimitive, Boolean)

Checks if every element of mathematical expression is defined.Проверяет существует ли определение каждому элементу математического выражения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDefined(
    IPrimitive[] values,
    bool recursiveCheck
)
Public Function IsDefined (
    values As IPrimitive(),
    recursiveCheck As Boolean
) As Boolean
public:
bool IsDefined(
    array<IPrimitive^>^ values,
    bool recursiveCheck
)
member IsDefined :
        values : IPrimitive[] *
        recursiveCheck : bool -> bool

Parameters

values
Type: SMath.ManagerIPrimitive
Mathematical expression to check for definitions.Математическое выражение для проверки.
recursiveCheck
Type: SystemBoolean
Determines whether check for definitions must be recursive or not.Определяет необходимость рекурсивной проверки определений.

Return Value

Type: Boolean
Returns a result of check.Возвращает результат проверки.
Remarks
Determines definition for every element into expression within public collection of definitions of current context, within a list of built-in functions and variables and entries handled by loaded plug-ins.Проверяет наличие определения каждого элемента выражения в коллекции публичных определений контекста вычисления, в списке встроенных функций и переменных программы, в том числе и среди примитивов поддерживаемых подключёнными плагинами.
See Also

Reference

Store Class
IsDefined Overload
SMath.Math Namespace


Store.IsDefined Method (IPrimitive, Boolean, Boolean, Boolean)

StoreIsDefined Method (IPrimitive, Boolean, Boolean, Boolean)

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsDefined(
    IPrimitive value,
    bool recursiveCheck,
    bool builtInOnly,
    bool isStandard
)
Public Function IsDefined (
    value As IPrimitive,
    recursiveCheck As Boolean,
    builtInOnly As Boolean,
    isStandard As Boolean
) As Boolean
public:
bool IsDefined(
    IPrimitive^ value,
    bool recursiveCheck,
    bool builtInOnly,
    bool isStandard
)
member IsDefined :
        value : IPrimitive *
        recursiveCheck : bool *
        builtInOnly : bool *
        isStandard : bool -> bool

Parameters

value
Type: SMath.ManagerIPrimitive
recursiveCheck
Type: SystemBoolean
builtInOnly
Type: SystemBoolean
isStandard
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

Store Class
IsDefined Overload
SMath.Math Namespace


Store.IsGraphChanged Method

StoreIsGraphChanged Method

Detects structural changes between calculation contexts.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public bool IsGraphChanged(
    Store lastStore
)
Public Function IsGraphChanged (
    lastStore As Store
) As Boolean
public:
bool IsGraphChanged(
    Store^ lastStore
)
member IsGraphChanged :
        lastStore : Store -> bool

Parameters

lastStore
Type: SMath.MathStore

Return Value

Type: Boolean
See Also

Reference

Store Class
SMath.Math Namespace


Store.RemoveAt Method

StoreRemoveAt Method

Removes Definition at the specific position of the shared list.Удаляет определение из публичного списка по указанному индексу.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
void RemoveAt(
    int index
)
member RemoveAt :
        index : int -> unit

Parameters

index
Type: SystemInt32
Position of the Definition to remove.Позиция определения в списке.
See Also

Reference

Store Class
SMath.Math Namespace


Store.RemoveRange Method

StoreRemoveRange Method

Removes Definitions of the specific range of the shared list.Удаление определений из публичного списка в указанном диапазоне.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void RemoveRange(
    int index,
    int count
)
Public Sub RemoveRange (
    index As Integer,
    count As Integer
)
public:
void RemoveRange(
    int index,
    int count
)
member RemoveRange :
        index : int *
        count : int -> unit

Parameters

index
Type: SystemInt32
Start index of the Definitions to remove.Стартовая позиция в диапазоне определений.
count
Type: SystemInt32
Count of the Definitions to remove.Количество определений для удаления.
See Also

Reference

Store Class
SMath.Math Namespace


Store.ToFile Method

StoreToFile Method

Creates a file contains exported evaluation context.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void ToFile(
    string fileName,
    DocumentMetaData metaData
)
Public Sub ToFile (
    fileName As String,
    metaData As DocumentMetaData
)
public:
void ToFile(
    String^ fileName,
    DocumentMetaData^ metaData
)
member ToFile :
        fileName : string *
        metaData : DocumentMetaData -> unit

Parameters

fileName
Type: SystemString
File to export evaluation context to.
metaData
Type: SMath.ManagerDocumentMetaData
Document meta-data which describes its origin.
See Also

Reference

Store Class
SMath.Math Namespace


Store.TraceData Method

StoreTraceData Method

Sends trace data to the subscribers.Посылает данные трассировки подписчикам.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void TraceData(
    string message
)
Public Sub TraceData (
    message As String
)
public:
void TraceData(
    String^ message
)
member TraceData :
        message : string -> unit

Parameters

message
Type: SystemString
Data to trace.Данные трассировки.
See Also

Reference

Store Class
SMath.Math Namespace


Store.UpdateAt Method

StoreUpdateAt Method

Overload List
 | Name | Description
Public method | UpdateAt(Int32, Entry) | Updates answer for the specific definition.Обновляет ответ указанного определения.
Public method | UpdateAt(Int32, Term) | Obsolete.
Top
See Also

Reference

Store Class
SMath.Math Namespace


Store.UpdateAt Method (Int32, Entry)

StoreUpdateAt Method (Int32, Entry)

Updates answer for the specific definition.Обновляет ответ указанного определения.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public void UpdateAt(
    int index,
    Entry result
)
Public Sub UpdateAt (
    index As Integer,
    result As Entry
)
public:
void UpdateAt(
    int index,
    Entry^ result
)
member UpdateAt :
        index : int *
        result : Entry -> unit

Parameters

index
Type: SystemInt32
Index of the definition inside list of definitions.Индекс определения в списке определений.
result
Type: SMath.ManagerEntry
Answer, i.e. value of definition.Результат, ассоциированный с определением.
See Also

Reference

Store Class
UpdateAt Overload
SMath.Math Namespace


Store.UpdateAt Method (Int32, Term[])

StoreUpdateAt Method (Int32, Term)

Note: This API is now obsolete.

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use Entry instead of Term[]", false)]
public void UpdateAt(
    int index,
    Term[] answer
)
<ObsoleteAttribute("Use Entry instead of Term[]", false)>
Public Sub UpdateAt (
    index As Integer,
    answer As Term()
)
public:
[ObsoleteAttribute(L"Use Entry instead of Term[]", false)]
void UpdateAt(
    int index,
    array<Term^>^ answer
)
[<ObsoleteAttribute("Use Entry instead of Term[]", false)>]
member UpdateAt :
        index : int *
        answer : Term[] -> unit

Parameters

index
Type: SystemInt32
answer
Type: SMath.ManagerTerm
See Also

Reference

Store Class
UpdateAt Overload
SMath.Math Namespace


Store Events

The Store type exposes the following members.

Events
 | Name | Description
Public event | ErrorOccured | Raises if error occurred while operation in progress.Вызывается при появлении ошибки во время выполнении операции. (Inherited from ActionContext.)
Public event | PluginsRequested | Raises if plug-ins requested.Вызывается при запросе к неустановленным дополнениям. (Inherited from ActionContext.)
Top
See Also

Reference

Store Class
SMath.Math Namespace


TraceEvaluationData Delegate

Namespace: SMath.Math
Assembly: SMath.Controls (in SMath.Controls.dll) Version: 1.0
Syntax
C#
VB
C++
F#
Copy
public delegate void TraceEvaluationData(
    string message,
    Store store
)
Public Delegate Sub TraceEvaluationData (
    message As String,
    store As Store
)
public delegate void TraceEvaluationData(
    String^ message,
    Store^ store
)
type TraceEvaluationData =
    delegate of
        message : string *
        store : Store -> unit

Parameters

message
Type: SystemString
store
Type: SMath.MathStore
See Also

Reference

SMath.Math Namespace


SMath.Math.Numeric Namespace

Classes
 | Class | Description
Public class | BaseEntry | Base class for the numeric components of math expression.Базовый класс для численных математических примитивов.
Public class | CalculationOptions |
Public class | Constants |
Public class | Expression | Numeric evaluation methods.Численные методы вычислений.
Public class | TComplex |
Public class | TDouble |
Public class | TFraction |
Public class | TInfinity |
Public class | TMatrix |
Public class | TNumber | Менеджер численных математических примитивов.
Public class | TSystem |
Interfaces
 | Interface | Description
Public interface | IPluginMathNumericEvaluation | Interface for the numeric evaluation plug-ins.Интерфейс для дополнений (плагинов), организующих численное вычисление.
Enumerations
 | Enumeration | Description
Public enumeration | BaseEntryType |
Public enumeration | InfType |


BaseEntry Class

Base class for the numeric components of math expression.Базовый класс для численных математических примитивов.
Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
More...

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseEntry
Public MustInherit Class BaseEntry
public ref class BaseEntry abstract
[<AbstractClassAttribute>]
type BaseEntry =  class end

The BaseEntry type exposes the following members.

Constructors
 | Name | Description
Public method | BaseEntry | Initializes a new instance of the BaseEntry class
Top
Properties
 | Name | Description
Public property | HasUnits |
Public property | IzZero |
Public property | Type |
Public property | Units | Unit of the expression component.Размерность математического примитива.
Top
Methods
 | Name | Description
Public method | Clone | Copying of the expression component.Копирование математического примитива.
Public method | Com | Addition (composition) operation.Операция сложения.
 | ComUnits |
Public method | Cos |
Public method | Cot |
Public method | Div | Division operation.Операция деления.
 | DivUnits |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FireExceptionIfUnits | Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units.Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | GetUnitsAppender |
Public method | Gt |
Public method | Lt |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mul | Multiplication operation.Операция умножения.
 | MulUnits |
Public method | Pow | Exponentiation operation.Операция возведения в степень.
Public method | Round(BaseEntry) |
Public method | Round(BaseEntry, TDouble) |
Public method | Sin |
Public method | Sub | Subtraction operation.Операция вычитания.
Public method | Tan |
Public method | ToDouble | Converts current expression component to Double value.Преобразование математического примитива к числу с плавающей запятой.
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Overrides ObjectToString.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Public method | Trunc |
Top
Operators
Name | Description
GreaterThan |
LessThan |
Top
See Also

Reference

SMath.Math.Numeric Namespace
Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTComplex
SMath.Math.NumericTDouble
SMath.Math.NumericTFraction
SMath.Math.NumericTInfinity
SMath.Math.NumericTMatrix
SMath.Math.NumericTSystem


BaseEntry Constructor

Initializes a new instance of the BaseEntry class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry(
    BaseEntryType type
)
Public Sub New (
    type As BaseEntryType
)
public:
BaseEntry(
    BaseEntryType type
)
new :
        type : BaseEntryType -> BaseEntry

Parameters

type
Type: SMath.Math.NumericBaseEntryType
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry Properties

The BaseEntry type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits |
Public property | IzZero |
Public property | Type |
Public property | Units | Unit of the expression component.Размерность математического примитива.
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.HasUnits Property

BaseEntryHasUnits Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public bool HasUnits { get; }
Public ReadOnly Property HasUnits As Boolean
    Get
public:
property bool HasUnits {
    bool get ();
}
member HasUnits : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.IzZero Property

BaseEntryIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public abstract bool IzZero { get; }
Public MustOverride ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () abstract;
}
abstract IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Type Property

BaseEntryType Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntryType Type { get; }
Public ReadOnly Property Type As BaseEntryType
    Get
public:
property BaseEntryType Type {
    BaseEntryType get ();
}
member Type : BaseEntryType with get

Property Value

Type: BaseEntryType
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Units Property

BaseEntryUnits Property

Unit of the expression component.Размерность математического примитива.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public MItem Units { get; set; }
Public Property Units As MItem
    Get
    Set
public:
property MItem^ Units {
    MItem^ get ();
    void set (MItem^ value);
}
member Units : MItem with get, set

Property Value

Type: MItem
Remarks
Every instance of the class has a Unit defined inside and this Unit is equal to 1. This is a requirement for every numeric expression component.Каждый экземпляр класса содержит в себе единицу измерения равную единице. Единица измерения является обязательным условием для каждого численного примитива.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry Methods

The BaseEntry type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Copying of the expression component.Копирование математического примитива.
Public method | Com | Addition (composition) operation.Операция сложения.
 | ComUnits |
Public method | Cos |
Public method | Cot |
Public method | Div | Division operation.Операция деления.
 | DivUnits |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FireExceptionIfUnits | Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units.Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | GetUnitsAppender |
Public method | Gt |
Public method | Lt |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mul | Multiplication operation.Операция умножения.
 | MulUnits |
Public method | Pow | Exponentiation operation.Операция возведения в степень.
Public method | Round(BaseEntry) |
Public method | Round(BaseEntry, TDouble) |
Public method | Sin |
Public method | Sub | Subtraction operation.Операция вычитания.
Public method | Tan |
Public method | ToDouble | Converts current expression component to Double value.Преобразование математического примитива к числу с плавающей запятой.
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Overrides ObjectToString.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Public method | Trunc |
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Clone Method

BaseEntryClone Method

Copying of the expression component.Копирование математического примитива.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public abstract BaseEntry Clone()
Public MustOverride Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() abstract
abstract Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
Returns a copy of current expression component.Копия исходного математического примитива.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Com Method

BaseEntryCom Method

Addition (composition) operation.Операция сложения.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Com(
    BaseEntry value
)
Public Overridable Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
)
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
Second operand.Второй операнд.

Return Value

Type: BaseEntry
Addition (composition) result.Результат сложения.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.ComUnits Method

BaseEntryComUnits Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
protected static void ComUnits(
    BaseEntry c1,
    BaseEntry c2,
    BaseEntry result
)
Protected Shared Sub ComUnits (
    c1 As BaseEntry,
    c2 As BaseEntry,
    result As BaseEntry
)
protected:
static void ComUnits(
    BaseEntry^ c1,
    BaseEntry^ c2,
    BaseEntry^ result
)
static member ComUnits :
        c1 : BaseEntry *
        c2 : BaseEntry *
        result : BaseEntry -> unit

Parameters

c1
Type: SMath.Math.NumericBaseEntry
c2
Type: SMath.Math.NumericBaseEntry
result
Type: SMath.Math.NumericBaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Cos Method

BaseEntryCos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Cos()
Public Overridable Function Cos As BaseEntry
public:
virtual BaseEntry^ Cos()
abstract Cos : unit -> BaseEntry
override Cos : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Cot Method

BaseEntryCot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Cot()
Public Overridable Function Cot As BaseEntry
public:
virtual BaseEntry^ Cot()
abstract Cot : unit -> BaseEntry
override Cot : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Div Method

BaseEntryDiv Method

Division operation.Операция деления.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Div(
    BaseEntry value
)
Public Overridable Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
)
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
Second operand (divisor).Делитель.

Return Value

Type: BaseEntry
Division result.Результат деления.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.DivUnits Method

BaseEntryDivUnits Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
protected static void DivUnits(
    BaseEntry c1,
    BaseEntry c2,
    BaseEntry result
)
Protected Shared Sub DivUnits (
    c1 As BaseEntry,
    c2 As BaseEntry,
    result As BaseEntry
)
protected:
static void DivUnits(
    BaseEntry^ c1,
    BaseEntry^ c2,
    BaseEntry^ result
)
static member DivUnits :
        c1 : BaseEntry *
        c2 : BaseEntry *
        result : BaseEntry -> unit

Parameters

c1
Type: SMath.Math.NumericBaseEntry
c2
Type: SMath.Math.NumericBaseEntry
result
Type: SMath.Math.NumericBaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.FireExceptionIfUnits Method

BaseEntryFireExceptionIfUnits Method

Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units.Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static void FireExceptionIfUnits(
    params BaseEntry[] args
)
Public Shared Sub FireExceptionIfUnits (
    ParamArray args As BaseEntry()
)
public:
static void FireExceptionIfUnits(
    ... array<BaseEntry^>^ args
)
static member FireExceptionIfUnits :
        args : BaseEntry[] -> unit

Parameters

args
Type: SMath.Math.NumericBaseEntry
List of the expression components to check.Список математических примитивов для проверки.
Exceptions
Exception | Condition
GeneralException | Thrown if one of the expression components contains Units.Возникает, если хотя бы один из переданных математических примитивов содержит единицы измерения.
Remarks
Expression components that contains Unit equal to 1 will not cause and exception.Компоненты выражения, которые содержат единицу (1) в качестве единицы измерения, не будут вызывать ошибку.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.GetUnitsAppender Method

BaseEntryGetUnitsAppender Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
protected string GetUnitsAppender()
Protected Function GetUnitsAppender As String
protected:
String^ GetUnitsAppender()
member GetUnitsAppender : unit -> string

Return Value

Type: String
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Gt Method

BaseEntryGt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual bool Gt(
    BaseEntry value
)
Public Overridable Function Gt (
    value As BaseEntry
) As Boolean
public:
virtual bool Gt(
    BaseEntry^ value
)
abstract Gt :
        value : BaseEntry -> bool
override Gt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Lt Method

BaseEntryLt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual bool Lt(
    BaseEntry value
)
Public Overridable Function Lt (
    value As BaseEntry
) As Boolean
public:
virtual bool Lt(
    BaseEntry^ value
)
abstract Lt :
        value : BaseEntry -> bool
override Lt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Mul Method

BaseEntryMul Method

Multiplication operation.Операция умножения.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Mul(
    BaseEntry value
)
Public Overridable Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
)
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
Second operand.Второй операнд.

Return Value

Type: BaseEntry
Multiplication result.Результат умножения.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.MulUnits Method

BaseEntryMulUnits Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
protected static void MulUnits(
    BaseEntry c1,
    BaseEntry c2,
    BaseEntry result
)
Protected Shared Sub MulUnits (
    c1 As BaseEntry,
    c2 As BaseEntry,
    result As BaseEntry
)
protected:
static void MulUnits(
    BaseEntry^ c1,
    BaseEntry^ c2,
    BaseEntry^ result
)
static member MulUnits :
        c1 : BaseEntry *
        c2 : BaseEntry *
        result : BaseEntry -> unit

Parameters

c1
Type: SMath.Math.NumericBaseEntry
c2
Type: SMath.Math.NumericBaseEntry
result
Type: SMath.Math.NumericBaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Pow Method

BaseEntryPow Method

Exponentiation operation.Операция возведения в степень.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Pow(
    BaseEntry value
)
Public Overridable Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
)
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
Second operand (index).Показатель степени.

Return Value

Type: BaseEntry
Exponentiation result.Результат возведения в степень.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Round Method

BaseEntryRound Method

Overload List
 | Name | Description
Public method | Round(BaseEntry) |
Public method | Round(BaseEntry, TDouble) |
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Round Method (BaseEntry)

BaseEntryRound Method (BaseEntry)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Round(
    BaseEntry value
)
Public Function Round (
    value As BaseEntry
) As BaseEntry
public:
BaseEntry^ Round(
    BaseEntry^ value
)
member Round :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
Round Overload
SMath.Math.Numeric Namespace


BaseEntry.Round Method (BaseEntry, TDouble)

BaseEntryRound Method (BaseEntry, TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Round(
    BaseEntry value,
    TDouble type
)
Public Function Round (
    value As BaseEntry,
    type As TDouble
) As BaseEntry
public:
BaseEntry^ Round(
    BaseEntry^ value,
    TDouble^ type
)
member Round :
        value : BaseEntry *
        type : TDouble -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
type
Type: SMath.Math.NumericTDouble

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
Round Overload
SMath.Math.Numeric Namespace


BaseEntry.Sin Method

BaseEntrySin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Sin()
Public Overridable Function Sin As BaseEntry
public:
virtual BaseEntry^ Sin()
abstract Sin : unit -> BaseEntry
override Sin : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Sub Method

BaseEntrySub Method

Subtraction operation.Операция вычитания.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Sub(
    BaseEntry value
)
Public Overridable Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
)
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry
Second operand.Второй операнд.

Return Value

Type: BaseEntry
Subtraction result.Результат вычитания.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.Tan Method

BaseEntryTan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual BaseEntry Tan()
Public Overridable Function Tan As BaseEntry
public:
virtual BaseEntry^ Tan()
abstract Tan : unit -> BaseEntry
override Tan : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.ToDouble Method

BaseEntryToDouble Method

Converts current expression component to Double value.Преобразование математического примитива к числу с плавающей запятой.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public abstract double ToDouble()
Public MustOverride Function ToDouble As Double
public:
virtual double ToDouble() abstract
abstract ToDouble : unit -> float

Return Value

Type: Double
Returns Double.Число с плавающей запятой.
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.ToString Method

BaseEntryToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Overrides ObjectToString.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.ToString Method

BaseEntryToString Method

Converts math expression component to string.Преобразование математического примитива в строку.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
Expression component represented as a string.Математический примитив в виде строки.
See Also

Reference

BaseEntry Class
ToString Overload
SMath.Math.Numeric Namespace


BaseEntry.ToString Method (Int32, Int32, FractionsType, Boolean)

BaseEntryToString Method (Int32, Int32, FractionsType, Boolean)

Note: This API is now obsolete.

Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use method with 6 arguments.")]
public virtual string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros
)
<ObsoleteAttribute("Use method with 6 arguments.")>
Public Overridable Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean
) As String
public:
[ObsoleteAttribute(L"Use method with 6 arguments.")]
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros
)
[<ObsoleteAttribute("Use method with 6 arguments.")>]
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool -> string
[<ObsoleteAttribute("Use method with 6 arguments.")>]
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool -> string

Parameters

decimalPlaces
Type: SystemInt32
Decimal places of the result value.Число значащих цифр после запятой.
exponentialThreshold
Type: SystemInt32
Exponential threshold of the result value.Экспоненциальный порог значения.
fractionType
Type: SMath.ManagerFractionsType
Fraction type of the result value.Тип дробей.
trailingZeros
Type: SystemBoolean
Sets if the answer should be displayed with trailing zeros or not.Указывает необходимость отображения конечных нолей в выражении.

Return Value

Type: String
Expression component represented as a string.Строка с учётом заданного количества цифр после запятой.
See Also

Reference

BaseEntry Class
ToString Overload
SMath.Math.Numeric Namespace


BaseEntry.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

BaseEntryToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public abstract string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public MustOverride Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) abstract
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
Decimal places of the result value.Число значащих цифр после запятой.
exponentialThreshold
Type: SystemInt32
Exponential threshold of the result value.Экспоненциальный порог значения.
fractionType
Type: SMath.ManagerFractionsType
Fraction type of the result value.Тип дробей.
trailingZeros
Type: SystemBoolean
Sets if the answer should be displayed with trailing zeros or not.Указывает необходимость отображения конечных нолей в выражении.
significantDigits
Type: SystemBoolean
Whether answer should be displayed in significant digits mode.Указывает необходимость отображения конечных нолей в выражении.
rounding
Type: SystemMidpointRounding
Mathematical rounding method to process a number that is midway.Метод математического округления.

Return Value

Type: String
Expression component represented as a string.Строка с учётом заданного количества цифр после запятой.
See Also

Reference

BaseEntry Class
ToString Overload
SMath.Math.Numeric Namespace


BaseEntry.ToTerms Method

BaseEntryToTerms Method

Overload List
 | Name | Description
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.ToTerms Method

BaseEntryToTerms Method

Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual Term[] ToTerms()
Public Overridable Function ToTerms As Term()
public:
virtual array<Term^>^ ToTerms()
abstract ToTerms : unit -> Term[]
override ToTerms : unit -> Term[]

Return Value

Type: Term
Array of Term in RPN.Массив базовых примитивов.
See Also

Reference

BaseEntry Class
ToTerms Overload
SMath.Math.Numeric Namespace


BaseEntry.ToTerms Method (Int32, Int32, FractionsType, Boolean)

BaseEntryToTerms Method (Int32, Int32, FractionsType, Boolean)

Note: This API is now obsolete.

Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use method with 6 arguments.")]
public virtual Term[] ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros
)
<ObsoleteAttribute("Use method with 6 arguments.")>
Public Overridable Function ToTerms (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean
) As Term()
public:
[ObsoleteAttribute(L"Use method with 6 arguments.")]
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros
)
[<ObsoleteAttribute("Use method with 6 arguments.")>]
abstract ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool -> Term[]
[<ObsoleteAttribute("Use method with 6 arguments.")>]
override ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool -> Term[]

Parameters

decimalPlaces
Type: SystemInt32
Decimal places of the result value.Число значащих цифр после запятой.
exponentialThreshold
Type: SystemInt32
Exponential threshold of the result value.Экспоненциальный порог значения.
fractionType
Type: SMath.ManagerFractionsType
Fraction type of the result value.Тип дробей.
trailingZeros
Type: SystemBoolean
Sets if the answer should be displayed with trailing zeros or not.Указывает необходимость отображения конечных нолей в выражении.

Return Value

Type: Term
Array of Term in RPN.Массив базовых примитивов с учётом заданного количества цифр после запятой.
See Also

Reference

BaseEntry Class
ToTerms Overload
SMath.Math.Numeric Namespace


BaseEntry.ToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

BaseEntryToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public virtual Term[] ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overridable Function ToTerms (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As Term()
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
abstract ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]
override ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]

Parameters

decimalPlaces
Type: SystemInt32
Decimal places of the result value.Число значащих цифр после запятой.
exponentialThreshold
Type: SystemInt32
Exponential threshold of the result value.Экспоненциальный порог значения.
fractionType
Type: SMath.ManagerFractionsType
Fraction type of the result value.Тип дробей.
trailingZeros
Type: SystemBoolean
Sets if the answer should be displayed with trailing zeros or not.Указывает необходимость отображения конечных нолей в выражении.
significantDigits
Type: SystemBoolean
Whether answer should be displayed in significant digits mode.Указывает необходимость отображения конечных нолей в выражении.
rounding
Type: SystemMidpointRounding
Mathematical rounding method to process a number that is midway.Метод математического округления.

Return Value

Type: Term
Array of Term in RPN.Массив базовых примитивов с учётом заданного количества цифр после запятой.
See Also

Reference

BaseEntry Class
ToTerms Overload
SMath.Math.Numeric Namespace


BaseEntry.Trunc Method

BaseEntryTrunc Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Trunc()
Public Function Trunc As BaseEntry
public:
BaseEntry^ Trunc()
member Trunc : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry Operators

The BaseEntry type exposes the following members.

Operators
Name | Description
GreaterThan |
LessThan |
Top
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.GreaterThan Operator

BaseEntryGreaterThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    BaseEntry c1,
    BaseEntry c2
)
Public Shared Operator > (
    c1 As BaseEntry,
    c2 As BaseEntry
) As Boolean
public:
static bool operator >(
    BaseEntry^ c1,
    BaseEntry^ c2
)
static let inline (>)
        c1 : BaseEntry *
        c2 : BaseEntry  : bool

Parameters

c1
Type: SMath.Math.NumericBaseEntry
c2
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry.LessThan Operator

BaseEntryLessThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    BaseEntry c1,
    BaseEntry c2
)
Public Shared Operator < (
    c1 As BaseEntry,
    c2 As BaseEntry
) As Boolean
public:
static bool operator <(
    BaseEntry^ c1,
    BaseEntry^ c2
)
static let inline (<)
        c1 : BaseEntry *
        c2 : BaseEntry  : bool

Parameters

c1
Type: SMath.Math.NumericBaseEntry
c2
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntryType Enumeration

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public enum BaseEntryType
Public Enumeration BaseEntryType
public enum class BaseEntryType
type BaseEntryType
Members
Member name | Value | Description
Undefined | 0 |
Double | 1 |
Fraction | 2 |
Complex | 3 |
Infinity | 4 |
Matrix | 5 |
System | 6 |
See Also

Reference

SMath.Math.Numeric Namespace


CalculationOptions Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericCalculationOptions

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public class CalculationOptions
Public Class CalculationOptions
public ref class CalculationOptions
type CalculationOptions =  class end

The CalculationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CalculationOptions | Initializes a new instance of the CalculationOptions class
Top
Properties
 | Name | Description
Public property | IgnoreZeroPowerZeroException |
Public property | Substitutions |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Empty |
Top
See Also

Reference

SMath.Math.Numeric Namespace


CalculationOptions Constructor

Initializes a new instance of the CalculationOptions class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public CalculationOptions()
Public Sub New
public:
CalculationOptions()
new : unit -> CalculationOptions
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions Properties

The CalculationOptions type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreZeroPowerZeroException |
Public property | Substitutions |
Top
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions.IgnoreZeroPowerZeroException Property

CalculationOptionsIgnoreZeroPowerZeroException Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreZeroPowerZeroException { get; set; }
Public Property IgnoreZeroPowerZeroException As Boolean
    Get
    Set
public:
property bool IgnoreZeroPowerZeroException {
    bool get ();
    void set (bool value);
}
member IgnoreZeroPowerZeroException : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions.Substitutions Property

CalculationOptionsSubstitutions Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public List<string> Substitutions { get; set; }
Public Property Substitutions As List(Of String)
    Get
    Set
public:
property List<String^>^ Substitutions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Substitutions : List<string> with get, set

Property Value

Type: ListString
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions Methods

The CalculationOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions Fields

The CalculationOptions type exposes the following members.

Fields
Name | Description
Empty |
Top
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


CalculationOptions.Empty Field

CalculationOptionsEmpty Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static readonly CalculationOptions Empty
Public Shared ReadOnly Empty As CalculationOptions
public:
static initonly CalculationOptions^ Empty
static val Empty: CalculationOptions

Field Value

Type: CalculationOptions
See Also

Reference

CalculationOptions Class
SMath.Math.Numeric Namespace


Constants Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericConstants

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public class Constants
Public Class Constants
public ref class Constants
type Constants =  class end

The Constants type exposes the following members.

Constructors
 | Name | Description
Public method | Constants | Initializes a new instance of the Constants class
Top
Properties
Name | Description
EI | e^i
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
random |
Top
See Also

Reference

SMath.Math.Numeric Namespace


Constants Constructor

Initializes a new instance of the Constants class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public Constants()
Public Sub New
public:
Constants()
new : unit -> Constants
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Constants Properties

The Constants type exposes the following members.

Properties
Name | Description
EI | e^i
Top
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Constants.EI Property

ConstantsEI Property

e^i

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TComplex EI { get; }
Public Shared ReadOnly Property EI As TComplex
    Get
public:
static property TComplex^ EI {
    TComplex^ get ();
}
static member EI : TComplex with get

Property Value

Type: TComplex
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Constants Methods

The Constants type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Constants Fields

The Constants type exposes the following members.

Fields
Name | Description
random |
Top
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Constants.random Field

Constantsrandom Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static Random random
Public Shared random As Random
public:
static Random^ random
static val mutable random: Random

Field Value

Type: Random
See Also

Reference

Constants Class
SMath.Math.Numeric Namespace


Expression Class

Numeric evaluation methods.Численные методы вычислений.
Inheritance Hierarchy
SystemObject
SMath.Math.NumericExpression

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public class Expression
Public Class Expression
public ref class Expression
type Expression =  class end

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Methods
 | Name | Description
 | Calculate(Entry, ActionContext) | Numeric expression evaluation.Численное вычисление выражения.
 | Calculate(Term, ActionContext) |
 | Calculate(Entry, ActionContext, CalculationOptions) | Numeric expression evaluation.Численное вычисление выражения.
 | Calculate(Term, ActionContext, CalculationOptions) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Math.Numeric Namespace


Expression Constructor

Initializes a new instance of the Expression class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public Expression()
Public Sub New
public:
Expression()
new : unit -> Expression
See Also

Reference

Expression Class
SMath.Math.Numeric Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
 | Calculate(Entry, ActionContext) | Numeric expression evaluation.Численное вычисление выражения.
 | Calculate(Term, ActionContext) |
 | Calculate(Entry, ActionContext, CalculationOptions) | Numeric expression evaluation.Численное вычисление выражения.
 | Calculate(Term, ActionContext, CalculationOptions) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Expression Class
SMath.Math.Numeric Namespace


Expression.Calculate Method

ExpressionCalculate Method

Overload List
Name | Description
Calculate(Entry, ActionContext) | Numeric expression evaluation.Численное вычисление выражения.
Calculate(Term, ActionContext) |
Calculate(Entry, ActionContext, CalculationOptions) | Numeric expression evaluation.Численное вычисление выражения.
Calculate(Term, ActionContext, CalculationOptions) |
Top
See Also

Reference

Expression Class
SMath.Math.Numeric Namespace


Expression.Calculate Method (Entry, ActionContext)

ExpressionCalculate Method (Entry, ActionContext)

Numeric expression evaluation.Численное вычисление выражения.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber Calculate(
    Entry value,
    ActionContext store
)
Public Shared Function Calculate (
    value As Entry,
    store As ActionContext
) As TNumber
public:
static TNumber^ Calculate(
    Entry^ value,
    ActionContext^ store
)
static member Calculate :
        value : Entry *
        store : ActionContext -> TNumber

Parameters

value
Type: SMath.ManagerEntry
Expression to evaluate numerically.Выражение для вычисления.
store
Type: SMath.ManagerActionContext
Current evaluation context.Контекст выполнения вычисления.

Return Value

Type: TNumber
Result of the numeric evaluation.Результат численного вычисления.
See Also

Reference

Expression Class
Calculate Overload
SMath.Math.Numeric Namespace


Expression.Calculate Method (Term[], ActionContext)

ExpressionCalculate Method (Term, ActionContext)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber Calculate(
    Term[] value,
    ActionContext store
)
Public Shared Function Calculate (
    value As Term(),
    store As ActionContext
) As TNumber
public:
static TNumber^ Calculate(
    array<Term^>^ value,
    ActionContext^ store
)
static member Calculate :
        value : Term[] *
        store : ActionContext -> TNumber

Parameters

value
Type: SMath.ManagerTerm
store
Type: SMath.ManagerActionContext

Return Value

Type: TNumber
See Also

Reference

Expression Class
Calculate Overload
SMath.Math.Numeric Namespace


Expression.Calculate Method (Entry, ActionContext, CalculationOptions)

ExpressionCalculate Method (Entry, ActionContext, CalculationOptions)

Numeric expression evaluation.Численное вычисление выражения.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber Calculate(
    Entry value,
    ActionContext store,
    CalculationOptions options
)
Public Shared Function Calculate (
    value As Entry,
    store As ActionContext,
    options As CalculationOptions
) As TNumber
public:
static TNumber^ Calculate(
    Entry^ value,
    ActionContext^ store,
    CalculationOptions^ options
)
static member Calculate :
        value : Entry *
        store : ActionContext *
        options : CalculationOptions -> TNumber

Parameters

value
Type: SMath.ManagerEntry
Expression to evaluate numerically.Выражение для вычисления.
store
Type: SMath.ManagerActionContext
Current evaluation context.Контекст выполнения вычисления.
options
Type: SMath.Math.NumericCalculationOptions
Specific options of current calculation.Специализированный настройки текущего вычисления.

Return Value

Type: TNumber
Result of the numeric evaluation.Результат численного вычисления.
See Also

Reference

Expression Class
Calculate Overload
SMath.Math.Numeric Namespace


Expression.Calculate Method (Term[], ActionContext, CalculationOptions)

ExpressionCalculate Method (Term, ActionContext, CalculationOptions)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber Calculate(
    Term[] value,
    ActionContext store,
    CalculationOptions options
)
Public Shared Function Calculate (
    value As Term(),
    store As ActionContext,
    options As CalculationOptions
) As TNumber
public:
static TNumber^ Calculate(
    array<Term^>^ value,
    ActionContext^ store,
    CalculationOptions^ options
)
static member Calculate :
        value : Term[] *
        store : ActionContext *
        options : CalculationOptions -> TNumber

Parameters

value
Type: SMath.ManagerTerm
store
Type: SMath.ManagerActionContext
options
Type: SMath.Math.NumericCalculationOptions

Return Value

Type: TNumber
See Also

Reference

Expression Class
Calculate Overload
SMath.Math.Numeric Namespace


InfType Enumeration

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public enum InfType
Public Enumeration InfType
public enum class InfType
type InfType
Members
Member name | Value | Description
infNeg | 0 |
val | 1 |
infPos | 2 |
See Also

Reference

SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Interface

Interface for the numeric evaluation plug-ins.Интерфейс для дополнений (плагинов), организующих численное вычисление.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public interface IPluginMathNumericEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
Public Interface IPluginMathNumericEvaluation
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
public interface class IPluginMathNumericEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
type IPluginMathNumericEvaluation =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

The IPluginMathNumericEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | NumericEvaluation | Numerical calculation of the element.Численное вычисление компонента выражения.
Top
See Also

Reference

SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Methods

The IPluginMathNumericEvaluation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetTermsHandled | List of available terms, that plug-in can evaluate. (Inherited from IPluginHandleEvaluation.)
Public method | Initialize | Fires on plug-in initialize. (Inherited from IPlugin.)
Public method | NumericEvaluation | Numerical calculation of the element.Численное вычисление компонента выражения.
Top
See Also

Reference

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation.NumericEvaluation Method

IPluginMathNumericEvaluationNumericEvaluation Method

Numerical calculation of the element.Численное вычисление компонента выражения.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
bool NumericEvaluation(
    Term value,
    TNumber[] args,
    ref TNumber result
)
Function NumericEvaluation (
    value As Term,
    args As TNumber(),
    ByRef result As TNumber
) As Boolean
bool NumericEvaluation(
    Term^ value,
    array<TNumber^>^ args,
    TNumber^% result
)
abstract NumericEvaluation :
        value : Term *
        args : TNumber[] *
        result : TNumber byref -> bool

Parameters

value
Type: SMath.ManagerTerm
Term to evaluate.Компонент выражения для вычисления.
args
Type: SMath.Math.NumericTNumber
Arguments of the element.Аргументы компонента выражения.
result
Type: SMath.Math.NumericTNumber
Numeric evaluation result.Результат численных вычислений.

Return Value

Type: Boolean
Indicates success of evaluation.Возвращает статус результата вычисления.
See Also

Reference

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


TComplex Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTComplex

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TComplex : BaseEntry
Public NotInheritable Class TComplex
    Inherits BaseEntry
public ref class TComplex sealed : public BaseEntry
[<SealedAttribute>]
type TComplex =
    class
        inherit BaseEntry
    end

The TComplex type exposes the following members.

Constructors
 | Name | Description
Public method | TComplex(TComplex) | Initializes a new instance of the TComplex class
Public method | TComplex(Double, Double) | Initializes a new instance of the TComplex class
Public method | TComplex(TDouble, TDouble) | Initializes a new instance of the TComplex class
Public method | TComplex(TInfinity, TInfinity) | Initializes a new instance of the TComplex class
Top
Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
 | Arg(Double, Double, Double, Double) |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Ln |
Public method | Log |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | pol2xy |
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TComplex) |
Public method | Power(TDouble) |
Public method | Power(TFraction) |
 | Power(MItem, Double, Double, Double, Double, Double, Double, Double, Double, BaseEntry, Double, Double, Double, Double) |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Public method | xy2pol |
Public method | xy2pol(TComplex) |
Top
Operators
Name | Description
Addition |
Division |
Equality |
(Double to TComplex) |
(TDouble to TComplex) |
(TFraction to TComplex) |
(TInfinity to TComplex) |
(TNumber to TComplex) |
Inequality |
Multiply |
Subtraction |
Top
Fields
 | Name | Description
Public field | Im |
Public field | Re |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TComplex Constructor

Overload List
 | Name | Description
Public method | TComplex(TComplex) | Initializes a new instance of the TComplex class
Public method | TComplex(Double, Double) | Initializes a new instance of the TComplex class
Public method | TComplex(TDouble, TDouble) | Initializes a new instance of the TComplex class
Public method | TComplex(TInfinity, TInfinity) | Initializes a new instance of the TComplex class
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex Constructor (TComplex)

Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex(
    TComplex value
)
Public Sub New (
    value As TComplex
)
public:
TComplex(
    TComplex^ value
)
new :
        value : TComplex -> TComplex

Parameters

value
Type: SMath.Math.NumericTComplex
See Also

Reference

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (Double, Double)

Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex(
    double re,
    double im
)
Public Sub New (
    re As Double,
    im As Double
)
public:
TComplex(
    double re,
    double im
)
new :
        re : float *
        im : float -> TComplex

Parameters

re
Type: SystemDouble
im
Type: SystemDouble
See Also

Reference

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (TDouble, TDouble)

Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex(
    TDouble re,
    TDouble im
)
Public Sub New (
    re As TDouble,
    im As TDouble
)
public:
TComplex(
    TDouble^ re,
    TDouble^ im
)
new :
        re : TDouble *
        im : TDouble -> TComplex

Parameters

re
Type: SMath.Math.NumericTDouble
im
Type: SMath.Math.NumericTDouble
See Also

Reference

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (TInfinity, TInfinity)

Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex(
    TInfinity re,
    TInfinity im
)
Public Sub New (
    re As TInfinity,
    im As TInfinity
)
public:
TComplex(
    TInfinity^ re,
    TInfinity^ im
)
new :
        re : TInfinity *
        im : TInfinity -> TComplex

Parameters

re
Type: SMath.Math.NumericTInfinity
im
Type: SMath.Math.NumericTInfinity
See Also

Reference

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Properties

The TComplex type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.IzZero Property

TComplexIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex Methods

The TComplex type exposes the following members.

Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
 | Arg(Double, Double, Double, Double) |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Ln |
Public method | Log |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | pol2xy |
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TComplex) |
Public method | Power(TDouble) |
Public method | Power(TFraction) |
 | Power(MItem, Double, Double, Double, Double, Double, Double, Double, Double, BaseEntry, Double, Double, Double, Double) |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Public method | xy2pol |
Public method | xy2pol(TComplex) |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Abs Method

TComplexAbs Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Abs()
Public Function Abs As TNumber
public:
TNumber^ Abs()
member Abs : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ACos Method

TComplexACos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACos()
Public Function ACos As TNumber
public:
TNumber^ ACos()
member ACos : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ACosH Method

TComplexACosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACosH()
Public Function ACosH As TNumber
public:
TNumber^ ACosH()
member ACosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ACot Method

TComplexACot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACot()
Public Function ACot As TNumber
public:
TNumber^ ACot()
member ACot : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ACotH Method

TComplexACotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACotH()
Public Function ACotH As TNumber
public:
TNumber^ ACotH()
member ACotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Arg Method

TComplexArg Method

Overload List
 | Name | Description
Public method | Arg |
 | Arg(Double, Double, Double, Double) |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Arg Method

TComplexArg Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double Arg()
Public Function Arg As Double
public:
double Arg()
member Arg : unit -> float

Return Value

Type: Double
See Also

Reference

TComplex Class
Arg Overload
SMath.Math.Numeric Namespace


TComplex.Arg Method (Double, Double, Double, Double)

TComplexArg Method (Double, Double, Double, Double)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static double Arg(
    double thisRenum,
    double thisReden,
    double thisImnum,
    double thisImden
)
Public Shared Function Arg (
    thisRenum As Double,
    thisReden As Double,
    thisImnum As Double,
    thisImden As Double
) As Double
public:
static double Arg(
    double thisRenum,
    double thisReden,
    double thisImnum,
    double thisImden
)
static member Arg :
        thisRenum : float *
        thisReden : float *
        thisImnum : float *
        thisImden : float -> float

Parameters

thisRenum
Type: SystemDouble
thisReden
Type: SystemDouble
thisImnum
Type: SystemDouble
thisImden
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

TComplex Class
Arg Overload
SMath.Math.Numeric Namespace


TComplex.ASin Method

TComplexASin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASin()
Public Function ASin As TNumber
public:
TNumber^ ASin()
member ASin : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ASinH Method

TComplexASinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASinH()
Public Function ASinH As TNumber
public:
TNumber^ ASinH()
member ASinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ATan Method

TComplexATan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan()
Public Function ATan As TNumber
public:
TNumber^ ATan()
member ATan : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ATan2 Method

TComplexATan2 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan2(
    TComplex y
)
Public Function ATan2 (
    y As TComplex
) As TNumber
public:
TNumber^ ATan2(
    TComplex^ y
)
member ATan2 :
        y : TComplex -> TNumber

Parameters

y
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ATanH Method

TComplexATanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATanH()
Public Function ATanH As TNumber
public:
TNumber^ ATanH()
member ATanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Clone Method

TComplexClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Com Method

TComplexCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Cos Method

TComplexCos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cos()
Public Overrides Function Cos As BaseEntry
public:
virtual BaseEntry^ Cos() override
abstract Cos : unit -> BaseEntry
override Cos : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.CosH Method

TComplexCosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CosH()
Public Function CosH As TNumber
public:
TNumber^ CosH()
member CosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Cot Method

TComplexCot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cot()
Public Overrides Function Cot As BaseEntry
public:
virtual BaseEntry^ Cot() override
abstract Cot : unit -> BaseEntry
override Cot : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.CotH Method

TComplexCotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CotH()
Public Function CotH As TNumber
public:
TNumber^ CotH()
member CotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Div Method

TComplexDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Equals Method

TComplexEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.GetHashCode Method

TComplexGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Ln Method

TComplexLn Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex Ln()
Public Function Ln As TComplex
public:
TComplex^ Ln()
member Ln : unit -> TComplex

Return Value

Type: TComplex
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Log Method

TComplexLog Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex Log(
    TComplex Base
)
Public Function Log (
    Base As TComplex
) As TComplex
public:
TComplex^ Log(
    TComplex^ Base
)
member Log :
        Base : TComplex -> TComplex

Parameters

Base
Type: SMath.Math.NumericTComplex

Return Value

Type: TComplex
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Mul Method

TComplexMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.pol2xy Method

TComplexpol2xy Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber pol2xy(
    TComplex value
)
Public Function pol2xy (
    value As TComplex
) As TNumber
public:
TNumber^ pol2xy(
    TComplex^ value
)
member pol2xy :
        value : TComplex -> TNumber

Parameters

value
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Pow Method

TComplexPow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Power Method

TComplexPower Method

Overload List
 | Name | Description
Public method | Power(TComplex) |
Public method | Power(TDouble) |
Public method | Power(TFraction) |
 | Power(MItem, Double, Double, Double, Double, Double, Double, Double, Double, BaseEntry, Double, Double, Double, Double) |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Power Method (TComplex)

TComplexPower Method (TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TComplex value
)
Public Function Power (
    value As TComplex
) As TNumber
public:
TNumber^ Power(
    TComplex^ value
)
member Power :
        value : TComplex -> TNumber

Parameters

value
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
Power Overload
SMath.Math.Numeric Namespace


TComplex.Power Method (TDouble)

TComplexPower Method (TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TDouble value
)
Public Function Power (
    value As TDouble
) As TNumber
public:
TNumber^ Power(
    TDouble^ value
)
member Power :
        value : TDouble -> TNumber

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TComplex Class
Power Overload
SMath.Math.Numeric Namespace


TComplex.Power Method (TFraction)

TComplexPower Method (TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TFraction value
)
Public Function Power (
    value As TFraction
) As TNumber
public:
TNumber^ Power(
    TFraction^ value
)
member Power :
        value : TFraction -> TNumber

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TComplex Class
Power Overload
SMath.Math.Numeric Namespace


TComplex.Power Method (MItem, Double, Double, Double, Double, Double, Double, Double, Double, BaseEntry, Double, Double, Double, Double)

TComplexPower Method (MItem, Double, Double, Double, Double, Double, Double, Double, Double, BaseEntry, Double, Double, Double, Double)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber Power(
    MItem units,
    double valueAbs,
    double thisRenum,
    double thisReden,
    double thisImnum,
    double thisImden,
    double powerRenum,
    double powerReden,
    double powerImnum,
    BaseEntry valueobj,
    double thisRe,
    double thisIm,
    double powerRe,
    double powerIm
)
Public Shared Function Power (
    units As MItem,
    valueAbs As Double,
    thisRenum As Double,
    thisReden As Double,
    thisImnum As Double,
    thisImden As Double,
    powerRenum As Double,
    powerReden As Double,
    powerImnum As Double,
    valueobj As BaseEntry,
    thisRe As Double,
    thisIm As Double,
    powerRe As Double,
    powerIm As Double
) As TNumber
public:
static TNumber^ Power(
    MItem^ units,
    double valueAbs,
    double thisRenum,
    double thisReden,
    double thisImnum,
    double thisImden,
    double powerRenum,
    double powerReden,
    double powerImnum,
    BaseEntry^ valueobj,
    double thisRe,
    double thisIm,
    double powerRe,
    double powerIm
)
static member Power :
        units : MItem *
        valueAbs : float *
        thisRenum : float *
        thisReden : float *
        thisImnum : float *
        thisImden : float *
        powerRenum : float *
        powerReden : float *
        powerImnum : float *
        valueobj : BaseEntry *
        thisRe : float *
        thisIm : float *
        powerRe : float *
        powerIm : float -> TNumber

Parameters

units
Type: SMath.Math.SymbolicMItem
valueAbs
Type: SystemDouble
thisRenum
Type: SystemDouble
thisReden
Type: SystemDouble
thisImnum
Type: SystemDouble
thisImden
Type: SystemDouble
powerRenum
Type: SystemDouble
powerReden
Type: SystemDouble
powerImnum
Type: SystemDouble
valueobj
Type: SMath.Math.NumericBaseEntry
thisRe
Type: SystemDouble
thisIm
Type: SystemDouble
powerRe
Type: SystemDouble
powerIm
Type: SystemDouble

Return Value

Type: TNumber
See Also

Reference

TComplex Class
Power Overload
SMath.Math.Numeric Namespace


TComplex.Sin Method

TComplexSin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sin()
Public Overrides Function Sin As BaseEntry
public:
virtual BaseEntry^ Sin() override
abstract Sin : unit -> BaseEntry
override Sin : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.SinH Method

TComplexSinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber SinH()
Public Function SinH As TNumber
public:
TNumber^ SinH()
member SinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Sub Method

TComplexSub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Tan Method

TComplexTan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Tan()
Public Overrides Function Tan As BaseEntry
public:
virtual BaseEntry^ Tan() override
abstract Tan : unit -> BaseEntry
override Tan : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.TanH Method

TComplexTanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber TanH()
Public Function TanH As TNumber
public:
TNumber^ TanH()
member TanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ToDouble Method

TComplexToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ToString Method

TComplexToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TComplexToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TComplex Class
ToString Overload
SMath.Math.Numeric Namespace


TComplex.xy2pol Method

TComplexxy2pol Method

Overload List
 | Name | Description
Public method | xy2pol |
Public method | xy2pol(TComplex) |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.xy2pol Method

TComplexxy2pol Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber xy2pol()
Public Function xy2pol As TNumber
public:
TNumber^ xy2pol()
member xy2pol : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TComplex Class
xy2pol Overload
SMath.Math.Numeric Namespace


TComplex.xy2pol Method (TComplex)

TComplexxy2pol Method (TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber xy2pol(
    TComplex value
)
Public Function xy2pol (
    value As TComplex
) As TNumber
public:
TNumber^ xy2pol(
    TComplex^ value
)
member xy2pol :
        value : TComplex -> TNumber

Parameters

value
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
xy2pol Overload
SMath.Math.Numeric Namespace


TComplex Operators and Type Conversions

The TComplex type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
(Double to TComplex) |
(TDouble to TComplex) |
(TFraction to TComplex) |
(TInfinity to TComplex) |
(TNumber to TComplex) |
Inequality |
Multiply |
Subtraction |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Addition Operator

TComplexAddition Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TComplex c1,
    TComplex c2
)
Public Shared Operator + (
    c1 As TComplex,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator +(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (+)
        c1 : TComplex *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Division Operator

TComplexDivision Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TComplex c1,
    TComplex c2
)
Public Shared Operator / (
    c1 As TComplex,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator /(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (/)
        c1 : TComplex *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Equality Operator

TComplexEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TComplex c1,
    TComplex c2
)
Public Shared Operator = (
    c1 As TComplex,
    c2 As TComplex
) As Boolean
public:
static bool operator ==(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (=)
        c1 : TComplex *
        c2 : TComplex  : bool

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: Boolean
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex Implicit Conversion Operators

TComplex Conversion Operators

Overload List
Name | Description
(Double to TComplex) |
(TDouble to TComplex) |
(TFraction to TComplex) |
(TInfinity to TComplex) |
(TNumber to TComplex) |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex Implicit Conversion (Double to TComplex)

TComplex Conversion (Double to TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TComplex (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TComplex
static implicit operator TComplex^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TComplex
See Also

Reference

TComplex Class
Overload
SMath.Math.Numeric Namespace


TComplex Implicit Conversion (TDouble to TComplex)

TComplex Conversion (TDouble to TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TComplex (
    TDouble value
)
Public Shared Widening Operator CType (
    value As TDouble
) As TComplex
static implicit operator TComplex^ (
    TDouble^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TComplex
See Also

Reference

TComplex Class
Overload
SMath.Math.Numeric Namespace


TComplex Implicit Conversion (TFraction to TComplex)

TComplex Conversion (TFraction to TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TComplex (
    TFraction value
)
Public Shared Widening Operator CType (
    value As TFraction
) As TComplex
static implicit operator TComplex^ (
    TFraction^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TComplex
See Also

Reference

TComplex Class
Overload
SMath.Math.Numeric Namespace


TComplex Implicit Conversion (TInfinity to TComplex)

TComplex Conversion (TInfinity to TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TComplex (
    TInfinity value
)
Public Shared Widening Operator CType (
    value As TInfinity
) As TComplex
static implicit operator TComplex^ (
    TInfinity^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTInfinity

Return Value

Type: TComplex
See Also

Reference

TComplex Class
Overload
SMath.Math.Numeric Namespace


TComplex Implicit Conversion (TNumber to TComplex)

TComplex Conversion (TNumber to TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TComplex (
    TNumber value
)
Public Shared Widening Operator CType (
    value As TNumber
) As TComplex
static implicit operator TComplex^ (
    TNumber^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TComplex
See Also

Reference

TComplex Class
Overload
SMath.Math.Numeric Namespace


TComplex.Inequality Operator

TComplexInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TComplex c1,
    TComplex c2
)
Public Shared Operator <> (
    c1 As TComplex,
    c2 As TComplex
) As Boolean
public:
static bool operator !=(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (<>)
        c1 : TComplex *
        c2 : TComplex  : bool

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: Boolean
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Multiply Operator

TComplexMultiply Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TComplex c1,
    TComplex c2
)
Public Shared Operator * (
    c1 As TComplex,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator *(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (*)
        c1 : TComplex *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Subtraction Operator

TComplexSubtraction Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TComplex c1,
    TComplex c2
)
Public Shared Operator - (
    c1 As TComplex,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator -(
    TComplex^ c1,
    TComplex^ c2
)
static let inline (-)
        c1 : TComplex *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex Fields

The TComplex type exposes the following members.

Fields
 | Name | Description
Public field | Im |
Public field | Re |
Top
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Im Field

TComplexIm Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TInfinity Im
Public ReadOnly Im As TInfinity
public:
initonly TInfinity^ Im
val Im: TInfinity

Field Value

Type: TInfinity
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TComplex.Re Field

TComplexRe Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TInfinity Re
Public ReadOnly Re As TInfinity
public:
initonly TInfinity^ Re
val Re: TInfinity

Field Value

Type: TInfinity
See Also

Reference

TComplex Class
SMath.Math.Numeric Namespace


TDouble Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTDouble

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TDouble : BaseEntry
Public NotInheritable Class TDouble
    Inherits BaseEntry
public ref class TDouble sealed : public BaseEntry
[<SealedAttribute>]
type TDouble =
    class
        inherit BaseEntry
    end

The TDouble type exposes the following members.

Constructors
 | Name | Description
Public method | TDouble(Double) | Initializes a new instance of the TDouble class
Public method | TDouble(String) | Initializes a new instance of the TDouble class
Public method | TDouble(TDouble) | Initializes a new instance of the TDouble class
Top
Properties
 | Name | Description
Public property | D |
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Identity |
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Matrix |
Public method | Mod |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Public method | Random |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
 | ToSignificantDigits | Format the value with the indicated number of significant digits.
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trunc | (Inherited from BaseEntry.)
Top
Operators
Name | Description
Addition |
Division |
Equality |
(Double to TDouble) |
Inequality |
Multiply |
Subtraction |
Top
Fields
 | Name | Description
Public field | isText |
Public field | Text |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TDouble Constructor

Overload List
 | Name | Description
Public method | TDouble(Double) | Initializes a new instance of the TDouble class
Public method | TDouble(String) | Initializes a new instance of the TDouble class
Public method | TDouble(TDouble) | Initializes a new instance of the TDouble class
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble Constructor (Double)

Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble(
    double D
)
Public Sub New (
    D As Double
)
public:
TDouble(
    double D
)
new :
        D : float -> TDouble

Parameters

D
Type: SystemDouble
See Also

Reference

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Constructor (String)

Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble(
    string text
)
Public Sub New (
    text As String
)
public:
TDouble(
    String^ text
)
new :
        text : string -> TDouble

Parameters

text
Type: SystemString
See Also

Reference

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Constructor (TDouble)

Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble(
    TDouble D
)
Public Sub New (
    D As TDouble
)
public:
TDouble(
    TDouble^ D
)
new :
        D : TDouble -> TDouble

Parameters

D
Type: SMath.Math.NumericTDouble
See Also

Reference

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Properties

The TDouble type exposes the following members.

Properties
 | Name | Description
Public property | D |
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.D Property

TDoubleD Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double D { get; }
Public ReadOnly Property D As Double
    Get
public:
property double D {
    double get ();
}
member D : float with get

Property Value

Type: Double
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.IzZero Property

TDoubleIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble Methods

The TDouble type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Identity |
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Matrix |
Public method | Mod |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Public method | Random |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
 | ToSignificantDigits | Format the value with the indicated number of significant digits.
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trunc | (Inherited from BaseEntry.)
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Clone Method

TDoubleClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Com Method

TDoubleCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Div Method

TDoubleDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Equals Method

TDoubleEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Factorial Method

TDoubleFactorial Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble Factorial()
Public Function Factorial As TDouble
public:
TDouble^ Factorial()
member Factorial : unit -> TDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.GetHashCode Method

TDoubleGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Gt Method

TDoubleGt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Gt(
    BaseEntry value
)
Public Overrides Function Gt (
    value As BaseEntry
) As Boolean
public:
virtual bool Gt(
    BaseEntry^ value
) override
abstract Gt :
        value : BaseEntry -> bool
override Gt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Identity Method

TDoubleIdentity Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Identity()
Public Function Identity As TMatrix
public:
TMatrix^ Identity()
member Identity : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Lt Method

TDoubleLt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Lt(
    BaseEntry value
)
Public Overrides Function Lt (
    value As BaseEntry
) As Boolean
public:
virtual bool Lt(
    BaseEntry^ value
) override
abstract Lt :
        value : BaseEntry -> bool
override Lt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Matrix Method

TDoubleMatrix Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Matrix(
    TDouble value
)
Public Function Matrix (
    value As TDouble
) As TMatrix
public:
TMatrix^ Matrix(
    TDouble^ value
)
member Matrix :
        value : TDouble -> TMatrix

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TMatrix
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Mod Method

TDoubleMod Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Mod(
    TDouble value
)
Public Function Mod (
    value As TDouble
) As BaseEntry
public:
BaseEntry^ Mod(
    TDouble^ value
)
member Mod :
        value : TDouble -> BaseEntry

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Mul Method

TDoubleMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Pow Method

TDoublePow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Power Method

TDoublePower Method

Overload List
 | Name | Description
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Power Method (TDouble)

TDoublePower Method (TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Power(
    TDouble value
)
Public Function Power (
    value As TDouble
) As BaseEntry
public:
BaseEntry^ Power(
    TDouble^ value
)
member Power :
        value : TDouble -> BaseEntry

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
Power Overload
SMath.Math.Numeric Namespace


TDouble.Power Method (TFraction)

TDoublePower Method (TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry Power(
    TFraction value
)
Public Function Power (
    value As TFraction
) As BaseEntry
public:
BaseEntry^ Power(
    TFraction^ value
)
member Power :
        value : TFraction -> BaseEntry

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
Power Overload
SMath.Math.Numeric Namespace


TDouble.Random Method

TDoubleRandom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble Random()
Public Function Random As TDouble
public:
TDouble^ Random()
member Random : unit -> TDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Sign Method

TDoubleSign Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble Sign()
Public Function Sign As TDouble
public:
TDouble^ Sign()
member Sign : unit -> TDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Sub Method

TDoubleSub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.ToDouble Method

TDoubleToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.ToSignificantDigits Method

TDoubleToSignificantDigits Method

Format the value with the indicated number of significant digits.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static string ToSignificantDigits(
    double value,
    int significantDigits,
    bool trailingZeros,
    MidpointRounding rounding
)
Public Shared Function ToSignificantDigits (
    value As Double,
    significantDigits As Integer,
    trailingZeros As Boolean,
    rounding As MidpointRounding
) As String
public:
static String^ ToSignificantDigits(
    double value,
    int significantDigits,
    bool trailingZeros,
    MidpointRounding rounding
)
static member ToSignificantDigits :
        value : float *
        significantDigits : int *
        trailingZeros : bool *
        rounding : MidpointRounding -> string

Parameters

value
Type: SystemDouble
significantDigits
Type: SystemInt32
trailingZeros
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.ToString Method

TDoubleToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TDoubleToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TDouble Class
ToString Overload
SMath.Math.Numeric Namespace


TDouble.ToTerms Method

TDoubleToTerms Method

Overload List
 | Name | Description
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.ToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TDoubleToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override Term[] ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToTerms (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As Term()
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]
override ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: Term
See Also

Reference

TDouble Class
ToTerms Overload
SMath.Math.Numeric Namespace


TDouble Operators and Type Conversions

The TDouble type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
(Double to TDouble) |
Inequality |
Multiply |
Subtraction |
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Addition Operator

TDoubleAddition Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TDouble operator +(
    TDouble c1,
    TDouble c2
)
Public Shared Operator + (
    c1 As TDouble,
    c2 As TDouble
) As TDouble
public:
static TDouble^ operator +(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (+)
        c1 : TDouble *
        c2 : TDouble  : TDouble

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Division Operator

TDoubleDivision Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TFraction operator /(
    TDouble c1,
    TDouble c2
)
Public Shared Operator / (
    c1 As TDouble,
    c2 As TDouble
) As TFraction
public:
static TFraction^ operator /(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (/)
        c1 : TDouble *
        c2 : TDouble  : TFraction

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TFraction
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Equality Operator

TDoubleEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TDouble c1,
    TDouble c2
)
Public Shared Operator = (
    c1 As TDouble,
    c2 As TDouble
) As Boolean
public:
static bool operator ==(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (=)
        c1 : TDouble *
        c2 : TDouble  : bool

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble Implicit Conversion (Double to TDouble)

TDouble Conversion (Double to TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TDouble (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TDouble
static implicit operator TDouble^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Inequality Operator

TDoubleInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TDouble c1,
    TDouble c2
)
Public Shared Operator <> (
    c1 As TDouble,
    c2 As TDouble
) As Boolean
public:
static bool operator !=(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (<>)
        c1 : TDouble *
        c2 : TDouble  : bool

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Multiply Operator

TDoubleMultiply Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TDouble operator *(
    TDouble c1,
    TDouble c2
)
Public Shared Operator * (
    c1 As TDouble,
    c2 As TDouble
) As TDouble
public:
static TDouble^ operator *(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (*)
        c1 : TDouble *
        c2 : TDouble  : TDouble

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Subtraction Operator

TDoubleSubtraction Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TDouble operator -(
    TDouble c1,
    TDouble c2
)
Public Shared Operator - (
    c1 As TDouble,
    c2 As TDouble
) As TDouble
public:
static TDouble^ operator -(
    TDouble^ c1,
    TDouble^ c2
)
static let inline (-)
        c1 : TDouble *
        c2 : TDouble  : TDouble

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TDouble
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble Fields

The TDouble type exposes the following members.

Fields
 | Name | Description
Public field | isText |
Public field | Text |
Top
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.isText Field

TDoubleisText Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly bool isText
Public ReadOnly isText As Boolean
public:
initonly bool isText
val isText: bool

Field Value

Type: Boolean
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TDouble.Text Field

TDoubleText Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly string Text
Public ReadOnly Text As String
public:
initonly String^ Text
val Text: string

Field Value

Type: String
See Also

Reference

TDouble Class
SMath.Math.Numeric Namespace


TFraction Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTFraction

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TFraction : BaseEntry
Public NotInheritable Class TFraction
    Inherits BaseEntry
public ref class TFraction sealed : public BaseEntry
[<SealedAttribute>]
type TFraction =
    class
        inherit BaseEntry
    end

The TFraction type exposes the following members.

Constructors
 | Name | Description
Public method | TFraction(Double) | Initializes a new instance of the TFraction class
Public method | TFraction(Double, Double) | Initializes a new instance of the TFraction class
Public method | TFraction(TDouble, TDouble) | Initializes a new instance of the TFraction class
Public method | TFraction(Double, Double, Boolean) | Initializes a new instance of the TFraction class
Top
Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Top
Operators
Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |
Equality |
GreaterThan |
Inequality |
LessThan |
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |
Top
Fields
 | Name | Description
Public field | den |
Public field | num |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TFraction Constructor

Overload List
 | Name | Description
Public method | TFraction(Double) | Initializes a new instance of the TFraction class
Public method | TFraction(Double, Double) | Initializes a new instance of the TFraction class
Public method | TFraction(TDouble, TDouble) | Initializes a new instance of the TFraction class
Public method | TFraction(Double, Double, Boolean) | Initializes a new instance of the TFraction class
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction Constructor (Double)

Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TFraction(
    double D
)
Public Sub New (
    D As Double
)
public:
TFraction(
    double D
)
new :
        D : float -> TFraction

Parameters

D
Type: SystemDouble
See Also

Reference

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Constructor (Double, Double)

Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TFraction(
    double num,
    double den
)
Public Sub New (
    num As Double,
    den As Double
)
public:
TFraction(
    double num,
    double den
)
new :
        num : float *
        den : float -> TFraction

Parameters

num
Type: SystemDouble
den
Type: SystemDouble
See Also

Reference

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Constructor (TDouble, TDouble)

Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TFraction(
    TDouble num,
    TDouble den
)
Public Sub New (
    num As TDouble,
    den As TDouble
)
public:
TFraction(
    TDouble^ num,
    TDouble^ den
)
new :
        num : TDouble *
        den : TDouble -> TFraction

Parameters

num
Type: SMath.Math.NumericTDouble
den
Type: SMath.Math.NumericTDouble
See Also

Reference

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Constructor (Double, Double, Boolean)

Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TFraction(
    double num,
    double den,
    bool fast
)
Public Sub New (
    num As Double,
    den As Double,
    fast As Boolean
)
public:
TFraction(
    double num,
    double den,
    bool fast
)
new :
        num : float *
        den : float *
        fast : bool -> TFraction

Parameters

num
Type: SystemDouble
den
Type: SystemDouble
fast
Type: SystemBoolean
See Also

Reference

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Properties

The TFraction type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.IzZero Property

TFractionIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction Methods

The TFraction type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Clone Method

TFractionClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Com Method

TFractionCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Div Method

TFractionDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Equals Method

TFractionEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.GetHashCode Method

TFractionGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Gt Method

TFractionGt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Gt(
    BaseEntry value
)
Public Overrides Function Gt (
    value As BaseEntry
) As Boolean
public:
virtual bool Gt(
    BaseEntry^ value
) override
abstract Gt :
        value : BaseEntry -> bool
override Gt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Lt Method

TFractionLt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Lt(
    BaseEntry value
)
Public Overrides Function Lt (
    value As BaseEntry
) As Boolean
public:
virtual bool Lt(
    BaseEntry^ value
) override
abstract Lt :
        value : BaseEntry -> bool
override Lt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Mul Method

TFractionMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Pow Method

TFractionPow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Power Method

TFractionPower Method

Overload List
 | Name | Description
Public method | Power(TDouble) |
Public method | Power(TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Power Method (TDouble)

TFractionPower Method (TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TDouble value
)
Public Function Power (
    value As TDouble
) As TNumber
public:
TNumber^ Power(
    TDouble^ value
)
member Power :
        value : TDouble -> TNumber

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Power Overload
SMath.Math.Numeric Namespace


TFraction.Power Method (TFraction)

TFractionPower Method (TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TFraction value
)
Public Function Power (
    value As TFraction
) As TNumber
public:
TNumber^ Power(
    TFraction^ value
)
member Power :
        value : TFraction -> TNumber

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Power Overload
SMath.Math.Numeric Namespace


TFraction.Sub Method

TFractionSub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.ToDouble Method

TFractionToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.ToString Method

TFractionToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TFractionToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TFraction Class
ToString Overload
SMath.Math.Numeric Namespace


TFraction Operators

The TFraction type exposes the following members.

Operators
Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |
Equality |
GreaterThan |
Inequality |
LessThan |
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Addition Operator

TFractionAddition Operator

Overload List
Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Addition Operator (TDouble, TFraction)

TFractionAddition Operator (TDouble, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TDouble c1,
    TFraction c2
)
Public Shared Operator + (
    c1 As TDouble,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator +(
    TDouble^ c1,
    TFraction^ c2
)
static let inline (+)
        c1 : TDouble *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


TFraction.Addition Operator (TFraction, TDouble)

TFractionAddition Operator (TFraction, TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TFraction c1,
    TDouble c2
)
Public Shared Operator + (
    c1 As TFraction,
    c2 As TDouble
) As TNumber
public:
static TNumber^ operator +(
    TFraction^ c1,
    TDouble^ c2
)
static let inline (+)
        c1 : TFraction *
        c2 : TDouble  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


TFraction.Addition Operator (TFraction, TFraction)

TFractionAddition Operator (TFraction, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TFraction c1,
    TFraction c2
)
Public Shared Operator + (
    c1 As TFraction,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator +(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (+)
        c1 : TFraction *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


TFraction.Division Operator

TFractionDivision Operator

Overload List
Name | Description
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Division Operator (TDouble, TFraction)

TFractionDivision Operator (TDouble, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TDouble c1,
    TFraction c2
)
Public Shared Operator / (
    c1 As TDouble,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator /(
    TDouble^ c1,
    TFraction^ c2
)
static let inline (/)
        c1 : TDouble *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


TFraction.Division Operator (TFraction, TDouble)

TFractionDivision Operator (TFraction, TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TFraction c1,
    TDouble c2
)
Public Shared Operator / (
    c1 As TFraction,
    c2 As TDouble
) As TNumber
public:
static TNumber^ operator /(
    TFraction^ c1,
    TDouble^ c2
)
static let inline (/)
        c1 : TFraction *
        c2 : TDouble  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


TFraction.Division Operator (TFraction, TFraction)

TFractionDivision Operator (TFraction, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TFraction c1,
    TFraction c2
)
Public Shared Operator / (
    c1 As TFraction,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator /(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (/)
        c1 : TFraction *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


TFraction.Equality Operator

TFractionEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TFraction c1,
    TFraction c2
)
Public Shared Operator = (
    c1 As TFraction,
    c2 As TFraction
) As Boolean
public:
static bool operator ==(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (=)
        c1 : TFraction *
        c2 : TFraction  : bool

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.GreaterThan Operator

TFractionGreaterThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    TFraction c1,
    TFraction c2
)
Public Shared Operator > (
    c1 As TFraction,
    c2 As TFraction
) As Boolean
public:
static bool operator >(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (>)
        c1 : TFraction *
        c2 : TFraction  : bool

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Inequality Operator

TFractionInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TFraction c1,
    TFraction c2
)
Public Shared Operator <> (
    c1 As TFraction,
    c2 As TFraction
) As Boolean
public:
static bool operator !=(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (<>)
        c1 : TFraction *
        c2 : TFraction  : bool

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.LessThan Operator

TFractionLessThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    TFraction c1,
    TFraction c2
)
Public Shared Operator < (
    c1 As TFraction,
    c2 As TFraction
) As Boolean
public:
static bool operator <(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (<)
        c1 : TFraction *
        c2 : TFraction  : bool

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: Boolean
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Multiply Operator

TFractionMultiply Operator

Overload List
Name | Description
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Multiply Operator (TDouble, TFraction)

TFractionMultiply Operator (TDouble, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TDouble c1,
    TFraction c2
)
Public Shared Operator * (
    c1 As TDouble,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator *(
    TDouble^ c1,
    TFraction^ c2
)
static let inline (*)
        c1 : TDouble *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


TFraction.Multiply Operator (TFraction, TDouble)

TFractionMultiply Operator (TFraction, TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TFraction c1,
    TDouble c2
)
Public Shared Operator * (
    c1 As TFraction,
    c2 As TDouble
) As TNumber
public:
static TNumber^ operator *(
    TFraction^ c1,
    TDouble^ c2
)
static let inline (*)
        c1 : TFraction *
        c2 : TDouble  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


TFraction.Multiply Operator (TFraction, TFraction)

TFractionMultiply Operator (TFraction, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TFraction c1,
    TFraction c2
)
Public Shared Operator * (
    c1 As TFraction,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator *(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (*)
        c1 : TFraction *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


TFraction.Subtraction Operator

TFractionSubtraction Operator

Overload List
Name | Description
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.Subtraction Operator (TDouble, TFraction)

TFractionSubtraction Operator (TDouble, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TDouble c1,
    TFraction c2
)
Public Shared Operator - (
    c1 As TDouble,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator -(
    TDouble^ c1,
    TFraction^ c2
)
static let inline (-)
        c1 : TDouble *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTDouble
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


TFraction.Subtraction Operator (TFraction, TDouble)

TFractionSubtraction Operator (TFraction, TDouble)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TFraction c1,
    TDouble c2
)
Public Shared Operator - (
    c1 As TFraction,
    c2 As TDouble
) As TNumber
public:
static TNumber^ operator -(
    TFraction^ c1,
    TDouble^ c2
)
static let inline (-)
        c1 : TFraction *
        c2 : TDouble  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTDouble

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


TFraction.Subtraction Operator (TFraction, TFraction)

TFractionSubtraction Operator (TFraction, TFraction)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TFraction c1,
    TFraction c2
)
Public Shared Operator - (
    c1 As TFraction,
    c2 As TFraction
) As TNumber
public:
static TNumber^ operator -(
    TFraction^ c1,
    TFraction^ c2
)
static let inline (-)
        c1 : TFraction *
        c2 : TFraction  : TNumber

Parameters

c1
Type: SMath.Math.NumericTFraction
c2
Type: SMath.Math.NumericTFraction

Return Value

Type: TNumber
See Also

Reference

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


TFraction Fields

The TFraction type exposes the following members.

Fields
 | Name | Description
Public field | den |
Public field | num |
Top
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.den Field

TFractionden Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TDouble den
Public ReadOnly den As TDouble
public:
initonly TDouble^ den
val den: TDouble

Field Value

Type: TDouble
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TFraction.num Field

TFractionnum Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TDouble num
Public ReadOnly num As TDouble
public:
initonly TDouble^ num
val num: TDouble

Field Value

Type: TDouble
See Also

Reference

TFraction Class
SMath.Math.Numeric Namespace


TInfinity Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTInfinity

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TInfinity : BaseEntry
Public NotInheritable Class TInfinity
    Inherits BaseEntry
public ref class TInfinity sealed : public BaseEntry
[<SealedAttribute>]
type TInfinity =
    class
        inherit BaseEntry
    end

The TInfinity type exposes the following members.

Constructors
 | Name | Description
Public method | TInfinity(InfType) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TFraction) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TInfinity) | Initializes a new instance of the TInfinity class
Top
Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | ACot |
Public method | ATan |
Public method | ATan2 |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Ln |
Public method | Log |
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Top
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
(Double to TInfinity) |
(TDouble to TInfinity) |
(TFraction to TInfinity) |
(TNumber to TInfinity) |
Inequality |
LessThan |
Multiply |
Subtraction |
Top
Fields
 | Name | Description
Public field | den |
Public field | inf |
 | multiZero |
Public field | num |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TInfinity Constructor

Overload List
 | Name | Description
Public method | TInfinity(InfType) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TFraction) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TInfinity) | Initializes a new instance of the TInfinity class
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Constructor (InfType)

Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TInfinity(
    InfType inf
)
Public Sub New (
    inf As InfType
)
public:
TInfinity(
    InfType inf
)
new :
        inf : InfType -> TInfinity

Parameters

inf
Type: SMath.Math.NumericInfType
See Also

Reference

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Constructor (TFraction)

Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TInfinity(
    TFraction d
)
Public Sub New (
    d As TFraction
)
public:
TInfinity(
    TFraction^ d
)
new :
        d : TFraction -> TInfinity

Parameters

d
Type: SMath.Math.NumericTFraction
See Also

Reference

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Constructor (TInfinity)

Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TInfinity(
    TInfinity d
)
Public Sub New (
    d As TInfinity
)
public:
TInfinity(
    TInfinity^ d
)
new :
        d : TInfinity -> TInfinity

Parameters

d
Type: SMath.Math.NumericTInfinity
See Also

Reference

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Properties

The TInfinity type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.IzZero Property

TInfinityIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Methods

The TInfinity type exposes the following members.

Methods
 | Name | Description
Public method | ACot |
Public method | ATan |
Public method | ATan2 |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Overrides BaseEntryGt(BaseEntry).)
Public method | Ln |
Public method | Log |
Public method | Lt | (Overrides BaseEntryLt(BaseEntry).)
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc | (Inherited from BaseEntry.)
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ACot Method

TInfinityACot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACot()
Public Function ACot As TNumber
public:
TNumber^ ACot()
member ACot : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ATan Method

TInfinityATan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan()
Public Function ATan As TNumber
public:
TNumber^ ATan()
member ATan : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ATan2 Method

TInfinityATan2 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan2(
    TInfinity y
)
Public Function ATan2 (
    y As TInfinity
) As TNumber
public:
TNumber^ ATan2(
    TInfinity^ y
)
member ATan2 :
        y : TInfinity -> TNumber

Parameters

y
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Clone Method

TInfinityClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Com Method

TInfinityCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Cos Method

TInfinityCos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cos()
Public Overrides Function Cos As BaseEntry
public:
virtual BaseEntry^ Cos() override
abstract Cos : unit -> BaseEntry
override Cos : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.CosH Method

TInfinityCosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CosH()
Public Function CosH As TNumber
public:
TNumber^ CosH()
member CosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Cot Method

TInfinityCot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cot()
Public Overrides Function Cot As BaseEntry
public:
virtual BaseEntry^ Cot() override
abstract Cot : unit -> BaseEntry
override Cot : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.CotH Method

TInfinityCotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CotH()
Public Function CotH As TNumber
public:
TNumber^ CotH()
member CotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Div Method

TInfinityDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Equals Method

TInfinityEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Factorial Method

TInfinityFactorial Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Factorial()
Public Function Factorial As TNumber
public:
TNumber^ Factorial()
member Factorial : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.GetHashCode Method

TInfinityGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Gt Method

TInfinityGt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Gt(
    BaseEntry value
)
Public Overrides Function Gt (
    value As BaseEntry
) As Boolean
public:
virtual bool Gt(
    BaseEntry^ value
) override
abstract Gt :
        value : BaseEntry -> bool
override Gt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Ln Method

TInfinityLn Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Ln()
Public Function Ln As TNumber
public:
TNumber^ Ln()
member Ln : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Log Method

TInfinityLog Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Log(
    TInfinity Base
)
Public Function Log (
    Base As TInfinity
) As TNumber
public:
TNumber^ Log(
    TInfinity^ Base
)
member Log :
        Base : TInfinity -> TNumber

Parameters

Base
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Lt Method

TInfinityLt Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Lt(
    BaseEntry value
)
Public Overrides Function Lt (
    value As BaseEntry
) As Boolean
public:
virtual bool Lt(
    BaseEntry^ value
) override
abstract Lt :
        value : BaseEntry -> bool
override Lt :
        value : BaseEntry -> bool

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Mul Method

TInfinityMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Pow Method

TInfinityPow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Power Method

TInfinityPower Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TNumber value
)
Public Function Power (
    value As TNumber
) As TNumber
public:
TNumber^ Power(
    TNumber^ value
)
member Power :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Sign Method

TInfinitySign Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Sign()
Public Function Sign As TNumber
public:
TNumber^ Sign()
member Sign : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Sin Method

TInfinitySin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sin()
Public Overrides Function Sin As BaseEntry
public:
virtual BaseEntry^ Sin() override
abstract Sin : unit -> BaseEntry
override Sin : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.SinH Method

TInfinitySinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber SinH()
Public Function SinH As TNumber
public:
TNumber^ SinH()
member SinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Sub Method

TInfinitySub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Tan Method

TInfinityTan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Tan()
Public Overrides Function Tan As BaseEntry
public:
virtual BaseEntry^ Tan() override
abstract Tan : unit -> BaseEntry
override Tan : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.TanH Method

TInfinityTanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber TanH()
Public Function TanH As TNumber
public:
TNumber^ TanH()
member TanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ToDouble Method

TInfinityToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ToString Method

TInfinityToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TInfinityToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TInfinity Class
ToString Overload
SMath.Math.Numeric Namespace


TInfinity Operators and Type Conversions

The TInfinity type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
(Double to TInfinity) |
(TDouble to TInfinity) |
(TFraction to TInfinity) |
(TNumber to TInfinity) |
Inequality |
LessThan |
Multiply |
Subtraction |
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Addition Operator

TInfinityAddition Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator + (
    c1 As TInfinity,
    c2 As TInfinity
) As TNumber
public:
static TNumber^ operator +(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (+)
        c1 : TInfinity *
        c2 : TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Division Operator

TInfinityDivision Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator / (
    c1 As TInfinity,
    c2 As TInfinity
) As TNumber
public:
static TNumber^ operator /(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (/)
        c1 : TInfinity *
        c2 : TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Equality Operator

TInfinityEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator = (
    c1 As TInfinity,
    c2 As TInfinity
) As Boolean
public:
static bool operator ==(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (=)
        c1 : TInfinity *
        c2 : TInfinity  : bool

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.GreaterThan Operator

TInfinityGreaterThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator > (
    c1 As TInfinity,
    c2 As TInfinity
) As Boolean
public:
static bool operator >(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (>)
        c1 : TInfinity *
        c2 : TInfinity  : bool

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Implicit Conversion Operators

TInfinity Conversion Operators

Overload List
Name | Description
(Double to TInfinity) |
(TDouble to TInfinity) |
(TFraction to TInfinity) |
(TNumber to TInfinity) |
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Implicit Conversion (Double to TInfinity)

TInfinity Conversion (Double to TInfinity)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TInfinity (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TInfinity
static implicit operator TInfinity^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TInfinity
See Also

Reference

TInfinity Class
Overload
SMath.Math.Numeric Namespace


TInfinity Implicit Conversion (TDouble to TInfinity)

TInfinity Conversion (TDouble to TInfinity)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TInfinity (
    TDouble value
)
Public Shared Widening Operator CType (
    value As TDouble
) As TInfinity
static implicit operator TInfinity^ (
    TDouble^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TInfinity
See Also

Reference

TInfinity Class
Overload
SMath.Math.Numeric Namespace


TInfinity Implicit Conversion (TFraction to TInfinity)

TInfinity Conversion (TFraction to TInfinity)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TInfinity (
    TFraction value
)
Public Shared Widening Operator CType (
    value As TFraction
) As TInfinity
static implicit operator TInfinity^ (
    TFraction^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TInfinity
See Also

Reference

TInfinity Class
Overload
SMath.Math.Numeric Namespace


TInfinity Implicit Conversion (TNumber to TInfinity)

TInfinity Conversion (TNumber to TInfinity)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TInfinity (
    TNumber value
)
Public Shared Widening Operator CType (
    value As TNumber
) As TInfinity
static implicit operator TInfinity^ (
    TNumber^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TInfinity
See Also

Reference

TInfinity Class
Overload
SMath.Math.Numeric Namespace


TInfinity.Inequality Operator

TInfinityInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator <> (
    c1 As TInfinity,
    c2 As TInfinity
) As Boolean
public:
static bool operator !=(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (<>)
        c1 : TInfinity *
        c2 : TInfinity  : bool

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.LessThan Operator

TInfinityLessThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator < (
    c1 As TInfinity,
    c2 As TInfinity
) As Boolean
public:
static bool operator <(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (<)
        c1 : TInfinity *
        c2 : TInfinity  : bool

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Multiply Operator

TInfinityMultiply Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator * (
    c1 As TInfinity,
    c2 As TInfinity
) As TNumber
public:
static TNumber^ operator *(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (*)
        c1 : TInfinity *
        c2 : TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.Subtraction Operator

TInfinitySubtraction Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TInfinity c1,
    TInfinity c2
)
Public Shared Operator - (
    c1 As TInfinity,
    c2 As TInfinity
) As TNumber
public:
static TNumber^ operator -(
    TInfinity^ c1,
    TInfinity^ c2
)
static let inline (-)
        c1 : TInfinity *
        c2 : TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.NumericTInfinity
c2
Type: SMath.Math.NumericTInfinity

Return Value

Type: TNumber
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Fields

The TInfinity type exposes the following members.

Fields
 | Name | Description
Public field | den |
Public field | inf |
 | multiZero |
Public field | num |
Top
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.den Field

TInfinityden Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TDouble den
Public ReadOnly den As TDouble
public:
initonly TDouble^ den
val den: TDouble

Field Value

Type: TDouble
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.inf Field

TInfinityinf Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly InfType inf
Public ReadOnly inf As InfType
public:
initonly InfType inf
val inf: InfType

Field Value

Type: InfType
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.multiZero Field

TInfinitymultiZero Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool multiZero
Public Shared multiZero As Boolean
public:
static bool multiZero
static val mutable multiZero: bool

Field Value

Type: Boolean
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity.num Field

TInfinitynum Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TDouble num
Public ReadOnly num As TDouble
public:
initonly TDouble^ num
val num: TDouble

Field Value

Type: TDouble
See Also

Reference

TInfinity Class
SMath.Math.Numeric Namespace


TMatrix Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTMatrix

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TMatrix : BaseEntry
Public NotInheritable Class TMatrix
    Inherits BaseEntry
public ref class TMatrix sealed : public BaseEntry
[<SealedAttribute>]
type TMatrix =
    class
        inherit BaseEntry
    end

The TMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | TMatrix | Initializes a new instance of the TMatrix class
Top
Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | Item |
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | Ainterp |
Public method | Alg |
Public method | buildakimaspline | Построение таблицы коэффициентов сплайна Акимы.
Public method | buildcubicspline | Построение таблицы коэффициентов кубического сплайна.
Public method | buildhermitespline | Построение таблицы коэффициентов сплайна Эрмита.
Public method | buildlinearspline | Построение таблицы коэффициентов кусочно-линейного сплайна.
Public method | Cinterp |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Col |
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
 | eigenpolyroots | Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.
Public method | El |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | FFT |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | GetLength |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Norm1 | Вычисление l-нормы матрицы.
Public method | NormE | Вычисление нормы Фробениуса матрицы.
Public method | NormI | Вычисление m-нормы матрицы.
Public method | PolyRoots |
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | rmatrixlu |
Public method | rmatrixluinverse | Возвращает матрицу, обратную к исходной.
Public method | rmatrixtrinverse |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Row |
Public method | RSort |
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sort |
Public method | splineinterpolation | Вычисление интерполирующего сплайна.
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Submatrix |
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trace |
Public method | Transpose |
Public method | Trunc | (Inherited from BaseEntry.)
Public method | VMinor |
Public method | VMultiplication |
Top
Operators
Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |
Equality |
(Double to TMatrix) |
(TComplex to TMatrix) |
(TDouble to TMatrix) |
(TFraction to TMatrix) |
(TInfinity to TMatrix) |
(TNumber to TMatrix) |
Inequality |
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |
Top
Fields
 | Name | Description
 | lunb |
 | MachineEpsilon |
Public field | unit |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TMatrix Constructor

Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix(
    TNumber[,] unit
)
Public Sub New (
    unit As TNumber(,)
)
public:
TMatrix(
    array<TNumber^,2>^ unit
)
new :
        unit : TNumber[,] -> TMatrix

Parameters

unit
Type: SMath.Math.NumericTNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Properties

The TMatrix type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | Item |
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Item Property

TMatrixItem Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber this[
    int row,
    int col
] { get; set; }
Public Default Property Item (
    row As Integer,
    col As Integer
) As TNumber
    Get
    Set
public:
property TNumber^ default[int row, int col] {
    TNumber^ get (int row, int col);
    void set (int row, int col, TNumber^ value);
}
member Item : TNumber with get, set

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Property Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.IzZero Property

TMatrixIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Methods

The TMatrix type exposes the following members.

Methods
 | Name | Description
Public method | Ainterp |
Public method | Alg |
Public method | buildakimaspline | Построение таблицы коэффициентов сплайна Акимы.
Public method | buildcubicspline | Построение таблицы коэффициентов кубического сплайна.
Public method | buildhermitespline | Построение таблицы коэффициентов сплайна Эрмита.
Public method | buildlinearspline | Построение таблицы коэффициентов кусочно-линейного сплайна.
Public method | Cinterp |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Col |
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Inherited from BaseEntry.)
Public method | Cot | (Inherited from BaseEntry.)
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
 | eigenpolyroots | Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.
Public method | El |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | FFT |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | GetLength |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Norm1 | Вычисление l-нормы матрицы.
Public method | NormE | Вычисление нормы Фробениуса матрицы.
Public method | NormI | Вычисление m-нормы матрицы.
Public method | PolyRoots |
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | rmatrixlu |
Public method | rmatrixluinverse | Возвращает матрицу, обратную к исходной.
Public method | rmatrixtrinverse |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Row |
Public method | RSort |
Public method | Sin | (Inherited from BaseEntry.)
Public method | Sort |
Public method | splineinterpolation | Вычисление интерполирующего сплайна.
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Submatrix |
Public method | Tan | (Inherited from BaseEntry.)
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trace |
Public method | Transpose |
Public method | Trunc | (Inherited from BaseEntry.)
Public method | VMinor |
Public method | VMultiplication |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Ainterp Method

TMatrixAinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double Ainterp(
    double[] x,
    double[] y,
    double pnt
)
Public Function Ainterp (
    x As Double(),
    y As Double(),
    pnt As Double
) As Double
public:
double Ainterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
member Ainterp :
        x : float[] *
        y : float[] *
        pnt : float -> float

Parameters

x
Type: SystemDouble
y
Type: SystemDouble
pnt
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Alg Method

TMatrixAlg Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Alg(
    int row,
    int col
)
Public Function Alg (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ Alg(
    int row,
    int col
)
member Alg :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.buildakimaspline Method

TMatrixbuildakimaspline Method

Построение таблицы коэффициентов сплайна Акимы.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public void buildakimaspline(
    double[] x,
    double[] y,
    int n,
    out double[] c
)
Public Sub buildakimaspline (
    x As Double(),
    y As Double(),
    n As Integer,
    <OutAttribute> ByRef c As Double()
)
public:
void buildakimaspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    [OutAttribute] array<double>^% c
)
member buildakimaspline :
        x : float[] *
        y : float[] *
        n : int *
        c : float[] byref -> unit

Parameters

x
Type: SystemDouble
Абсциссы, массив с нумерацией элементов [0..N-1].
y
Type: SystemDouble
Значения функции, массив с нумерацией элементов [0..N-1].
n
Type: SystemInt32
Число точек, N>=5.
c
Type: SystemDouble
Таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.buildcubicspline Method

TMatrixbuildcubicspline Method

Построение таблицы коэффициентов кубического сплайна.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public void buildcubicspline(
    double[] x,
    double[] y,
    int n,
    int boundltype,
    double boundl,
    int boundrtype,
    double boundr,
    out double[] c
)
Public Sub buildcubicspline (
    x As Double(),
    y As Double(),
    n As Integer,
    boundltype As Integer,
    boundl As Double,
    boundrtype As Integer,
    boundr As Double,
    <OutAttribute> ByRef c As Double()
)
public:
void buildcubicspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    int boundltype,
    double boundl,
    int boundrtype,
    double boundr,
    [OutAttribute] array<double>^% c
)
member buildcubicspline :
        x : float[] *
        y : float[] *
        n : int *
        boundltype : int *
        boundl : float *
        boundrtype : int *
        boundr : float *
        c : float[] byref -> unit

Parameters

x
Type: SystemDouble
Абсциссы, массив с нумерацией элементов [0..N-1].
y
Type: SystemDouble
Значения функции, массив с нумерацией элементов [0..N-1].
n
Type: SystemInt32
Число точек, N>=2.
boundltype
Type: SystemInt32
Тип граничного условия (левая граница).
boundl
Type: SystemDouble
Значение первой (или второй, в зависимости от BoundType) производной сплайна на левой границе.
boundrtype
Type: SystemInt32
Тип граничного условия (правая граница).
boundr
Type: SystemDouble
Значение первой (или второй, в зависимости от BoundType) производной сплайна на правой границе.
c
Type: SystemDouble
Таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.buildhermitespline Method

TMatrixbuildhermitespline Method

Построение таблицы коэффициентов сплайна Эрмита.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public void buildhermitespline(
    double[] x,
    double[] y,
    double[] d,
    int n,
    out double[] c
)
Public Sub buildhermitespline (
    x As Double(),
    y As Double(),
    d As Double(),
    n As Integer,
    <OutAttribute> ByRef c As Double()
)
public:
void buildhermitespline(
    array<double>^ x,
    array<double>^ y,
    array<double>^ d,
    int n,
    [OutAttribute] array<double>^% c
)
member buildhermitespline :
        x : float[] *
        y : float[] *
        d : float[] *
        n : int *
        c : float[] byref -> unit

Parameters

x
Type: SystemDouble
Абсциссы, массив с нумерацией элементов [0..N-1].
y
Type: SystemDouble
Значения функции, массив с нумерацией элементов [0..N-1].
d
Type: SystemDouble
Значения производной, массив с нумерацией элементов [0..N-1].
n
Type: SystemInt32
Число точек, N>=2.
c
Type: SystemDouble
Таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.buildlinearspline Method

TMatrixbuildlinearspline Method

Построение таблицы коэффициентов кусочно-линейного сплайна.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public void buildlinearspline(
    double[] x,
    double[] y,
    int n,
    out double[] c
)
Public Sub buildlinearspline (
    x As Double(),
    y As Double(),
    n As Integer,
    <OutAttribute> ByRef c As Double()
)
public:
void buildlinearspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    [OutAttribute] array<double>^% c
)
member buildlinearspline :
        x : float[] *
        y : float[] *
        n : int *
        c : float[] byref -> unit

Parameters

x
Type: SystemDouble
Абсциссы, массив с нумерацией элементов [0..N-1].
y
Type: SystemDouble
Значения функции, массив с нумерацией элементов [0..N-1].
n
Type: SystemInt32
Число точек, N>=2.
c
Type: SystemDouble
Таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Cinterp Method

TMatrixCinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double Cinterp(
    double[] x,
    double[] y,
    double pnt
)
Public Function Cinterp (
    x As Double(),
    y As Double(),
    pnt As Double
) As Double
public:
double Cinterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
member Cinterp :
        x : float[] *
        y : float[] *
        pnt : float -> float

Parameters

x
Type: SystemDouble
y
Type: SystemDouble
pnt
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Clone Method

TMatrixClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Col Method

TMatrixCol Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Col(
    int value
)
Public Function Col (
    value As Integer
) As TMatrix
public:
TMatrix^ Col(
    int value
)
member Col :
        value : int -> TMatrix

Parameters

value
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Com Method

TMatrixCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.CSort Method

TMatrixCSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix CSort(
    int index
)
Public Function CSort (
    index As Integer
) As TMatrix
public:
TMatrix^ CSort(
    int index
)
member CSort :
        index : int -> TMatrix

Parameters

index
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Determinant Method

TMatrixDeterminant Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex Determinant()
Public Function Determinant As TComplex
public:
TComplex^ Determinant()
member Determinant : unit -> TComplex

Return Value

Type: TComplex
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Diag Method

TMatrixDiag Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Diag()
Public Function Diag As TMatrix
public:
TMatrix^ Diag()
member Diag : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Div Method

TMatrixDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.eigenpolyroots Method

TMatrixeigenpolyroots Method

Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool eigenpolyroots(
    double[] c,
    int n,
    out double[] wr,
    out double[] wi
)
Public Shared Function eigenpolyroots (
    c As Double(),
    n As Integer,
    <OutAttribute> ByRef wr As Double(),
    <OutAttribute> ByRef wi As Double()
) As Boolean
public:
static bool eigenpolyroots(
    array<double>^ c,
    int n,
    [OutAttribute] array<double>^% wr,
    [OutAttribute] array<double>^% wi
)
static member eigenpolyroots :
        c : float[] *
        n : int *
        wr : float[] byref *
        wi : float[] byref -> bool

Parameters

c
Type: SystemDouble
Массив коэффициентов полинома. Нумерация элементов от 0 до N. C[I] - коэффициент при X^I.
n
Type: SystemInt32
Степень полинома. N>=1.
wr
Type: SystemDouble
Массив вещественных частей корней полинома. Нумерация элементов от 1 до N.
wi
Type: SystemDouble
Массив мнимых частей корней полинома. Нумерация элементов от 1 до N. При этом комплексно-сопряженные корни идут один за другим.

Return Value

Type: Boolean
True, если алгоритм поиска собственных значений сошелся. False, если алгоритм поиска собственных значений не сошелся.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.El Method

TMatrixEl Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber El(
    int row,
    int col
)
Public Function El (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ El(
    int row,
    int col
)
member El :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Equals Method

TMatrixEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.FFT Method

TMatrixFFT Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix FFT(
    double[] dIn,
    int nn,
    int beginData
)
Public Function FFT (
    dIn As Double(),
    nn As Integer,
    beginData As Integer
) As TMatrix
public:
TMatrix^ FFT(
    array<double>^ dIn,
    int nn,
    int beginData
)
member FFT :
        dIn : float[] *
        nn : int *
        beginData : int -> TMatrix

Parameters

dIn
Type: SystemDouble
nn
Type: SystemInt32
beginData
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.GetHashCode Method

TMatrixGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.GetInverse Method

TMatrixGetInverse Method

Обращение матрицы общего вида.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix GetInverse()
Public Function GetInverse As TMatrix
public:
TMatrix^ GetInverse()
member GetInverse : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.GetLength Method

TMatrixGetLength Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public int GetLength(
    int dimension
)
Public Function GetLength (
    dimension As Integer
) As Integer
public:
int GetLength(
    int dimension
)
member GetLength :
        dimension : int -> int

Parameters

dimension
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Im Method

TMatrixIm Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Im()
Public Function Im As TMatrix
public:
TMatrix^ Im()
member Im : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Length Method

TMatrixLength Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public int Length()
Public Function Length As Integer
public:
int Length()
member Length : unit -> int

Return Value

Type: Int32
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Linterp Method

TMatrixLinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double Linterp(
    double[] x,
    double[] y,
    double pnt
)
Public Function Linterp (
    x As Double(),
    y As Double(),
    pnt As Double
) As Double
public:
double Linterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
member Linterp :
        x : float[] *
        y : float[] *
        pnt : float -> float

Parameters

x
Type: SystemDouble
y
Type: SystemDouble
pnt
Type: SystemDouble

Return Value

Type: Double
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Max Method

TMatrixMax Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Max()
Public Function Max As TNumber
public:
TNumber^ Max()
member Max : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Min Method

TMatrixMin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Min()
Public Function Min As TNumber
public:
TNumber^ Min()
member Min : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Minor Method

TMatrixMinor Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Minor(
    int row,
    int col
)
Public Function Minor (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ Minor(
    int row,
    int col
)
member Minor :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Mul Method

TMatrixMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Norm1 Method

TMatrixNorm1 Method

Вычисление l-нормы матрицы.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Norm1()
Public Function Norm1 As TNumber
public:
TNumber^ Norm1()
member Norm1 : unit -> TNumber

Return Value

Type: TNumber
Значение нормы.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.NormE Method

TMatrixNormE Method

Вычисление нормы Фробениуса матрицы.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber NormE()
Public Function NormE As TNumber
public:
TNumber^ NormE()
member NormE : unit -> TNumber

Return Value

Type: TNumber
Значение нормы.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.NormI Method

TMatrixNormI Method

Вычисление m-нормы матрицы.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber NormI()
Public Function NormI As TNumber
public:
TNumber^ NormI()
member NormI : unit -> TNumber

Return Value

Type: TNumber
Значение нормы.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.PolyRoots Method

TMatrixPolyRoots Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix PolyRoots()
Public Function PolyRoots As TMatrix
public:
TMatrix^ PolyRoots()
member PolyRoots : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Pow Method

TMatrixPow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Power Method

TMatrixPower Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TNumber value
)
Public Function Power (
    value As TNumber
) As TNumber
public:
TNumber^ Power(
    TNumber^ value
)
member Power :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Rank Method

TMatrixRank Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TDouble Rank()
Public Function Rank As TDouble
public:
TDouble^ Rank()
member Rank : unit -> TDouble

Return Value

Type: TDouble
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Re Method

TMatrixRe Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Re()
Public Function Re As TMatrix
public:
TMatrix^ Re()
member Re : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Reverse Method

TMatrixReverse Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Reverse()
Public Function Reverse As TMatrix
public:
TMatrix^ Reverse()
member Reverse : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.rmatrixlu Method

TMatrixrmatrixlu Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public void rmatrixlu(
    ref TComplex[,] a,
    int m,
    int n,
    ref int[] pivots
)
Public Sub rmatrixlu (
    ByRef a As TComplex(,),
    m As Integer,
    n As Integer,
    ByRef pivots As Integer()
)
public:
void rmatrixlu(
    array<TComplex^,2>^% a,
    int m,
    int n,
    array<int>^% pivots
)
member rmatrixlu :
        a : TComplex[,] byref *
        m : int *
        n : int *
        pivots : int[] byref -> unit

Parameters

a
Type: SMath.Math.NumericTComplex
m
Type: SystemInt32
n
Type: SystemInt32
pivots
Type: SystemInt32
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.rmatrixluinverse Method

TMatrixrmatrixluinverse Method

Возвращает матрицу, обратную к исходной.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public bool rmatrixluinverse(
    ref TComplex[,] a,
    ref int[] pivots,
    int n
)
Public Function rmatrixluinverse (
    ByRef a As TComplex(,),
    ByRef pivots As Integer(),
    n As Integer
) As Boolean
public:
bool rmatrixluinverse(
    array<TComplex^,2>^% a,
    array<int>^% pivots,
    int n
)
member rmatrixluinverse :
        a : TComplex[,] byref *
        pivots : int[] byref *
        n : int -> bool

Parameters

a
Type: SMath.Math.NumericTComplex
LU-разложение матрицы.
pivots
Type: SystemInt32
Таблица перестановок, произведенных в ходе LU-разложения.
n
Type: SystemInt32
Размерность матрицы.

Return Value

Type: Boolean
Определяет является ли исходная матрица вырожденной.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.rmatrixtrinverse Method

TMatrixrmatrixtrinverse Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public bool rmatrixtrinverse(
    ref TComplex[,] a,
    int n,
    bool isupper,
    bool isunittriangular
)
Public Function rmatrixtrinverse (
    ByRef a As TComplex(,),
    n As Integer,
    isupper As Boolean,
    isunittriangular As Boolean
) As Boolean
public:
bool rmatrixtrinverse(
    array<TComplex^,2>^% a,
    int n,
    bool isupper,
    bool isunittriangular
)
member rmatrixtrinverse :
        a : TComplex[,] byref *
        n : int *
        isupper : bool *
        isunittriangular : bool -> bool

Parameters

a
Type: SMath.Math.NumericTComplex
n
Type: SystemInt32
isupper
Type: SystemBoolean
isunittriangular
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Row Method

TMatrixRow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Row(
    int value
)
Public Function Row (
    value As Integer
) As TMatrix
public:
TMatrix^ Row(
    int value
)
member Row :
        value : int -> TMatrix

Parameters

value
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.RSort Method

TMatrixRSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix RSort(
    int index
)
Public Function RSort (
    index As Integer
) As TMatrix
public:
TMatrix^ RSort(
    int index
)
member RSort :
        index : int -> TMatrix

Parameters

index
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Sort Method

TMatrixSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Sort()
Public Function Sort As TMatrix
public:
TMatrix^ Sort()
member Sort : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.splineinterpolation Method

TMatrixsplineinterpolation Method

Вычисление интерполирующего сплайна.

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public double splineinterpolation(
    ref double[] c,
    double x
)
Public Function splineinterpolation (
    ByRef c As Double(),
    x As Double
) As Double
public:
double splineinterpolation(
    array<double>^% c,
    double x
)
member splineinterpolation :
        c : float[] byref *
        x : float -> float

Parameters

c
Type: SystemDouble
Массив коэффициентов, вычисленный подпрограммой для построения сплайна.
x
Type: SystemDouble
Точка, в которой вычисляется значение сплайна.

Return Value

Type: Double
Значение сплайна в точке X.
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Sub Method

TMatrixSub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Submatrix Method

TMatrixSubmatrix Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
Public Function Submatrix (
    startRow As Integer,
    endRow As Integer,
    startCol As Integer,
    endCol As Integer
) As TMatrix
public:
TMatrix^ Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
member Submatrix :
        startRow : int *
        endRow : int *
        startCol : int *
        endCol : int -> TMatrix

Parameters

startRow
Type: SystemInt32
endRow
Type: SystemInt32
startCol
Type: SystemInt32
endCol
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.ToDouble Method

TMatrixToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.ToString Method

TMatrixToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TMatrixToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TMatrix Class
ToString Overload
SMath.Math.Numeric Namespace


TMatrix.ToTerms Method

TMatrixToTerms Method

Overload List
 | Name | Description
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.ToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TMatrixToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override Term[] ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToTerms (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As Term()
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]
override ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: Term
See Also

Reference

TMatrix Class
ToTerms Overload
SMath.Math.Numeric Namespace


TMatrix.Trace Method

TMatrixTrace Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TComplex Trace()
Public Function Trace As TComplex
public:
TComplex^ Trace()
member Trace : unit -> TComplex

Return Value

Type: TComplex
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Transpose Method

TMatrixTranspose Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Transpose()
Public Function Transpose As TMatrix
public:
TMatrix^ Transpose()
member Transpose : unit -> TMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.VMinor Method

TMatrixVMinor Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix VMinor(
    int row,
    int col
)
Public Function VMinor (
    row As Integer,
    col As Integer
) As TMatrix
public:
TMatrix^ VMinor(
    int row,
    int col
)
member VMinor :
        row : int *
        col : int -> TMatrix

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.VMultiplication Method

TMatrixVMultiplication Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix VMultiplication(
    TMatrix value
)
Public Function VMultiplication (
    value As TMatrix
) As TMatrix
public:
TMatrix^ VMultiplication(
    TMatrix^ value
)
member VMultiplication :
        value : TMatrix -> TMatrix

Parameters

value
Type: SMath.Math.NumericTMatrix

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Operators and Type Conversions

The TMatrix type exposes the following members.

Operators
Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |
Equality |
(Double to TMatrix) |
(TComplex to TMatrix) |
(TDouble to TMatrix) |
(TFraction to TMatrix) |
(TInfinity to TMatrix) |
(TNumber to TMatrix) |
Inequality |
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Addition Operator

TMatrixAddition Operator

Overload List
Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Addition Operator (TComplex, TMatrix)

TMatrixAddition Operator (TComplex, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TComplex c1,
    TMatrix c2
)
Public Shared Operator + (
    c1 As TComplex,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator +(
    TComplex^ c1,
    TMatrix^ c2
)
static let inline (+)
        c1 : TComplex *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


TMatrix.Addition Operator (TMatrix, TComplex)

TMatrixAddition Operator (TMatrix, TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TMatrix c1,
    TComplex c2
)
Public Shared Operator + (
    c1 As TMatrix,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator +(
    TMatrix^ c1,
    TComplex^ c2
)
static let inline (+)
        c1 : TMatrix *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


TMatrix.Addition Operator (TMatrix, TMatrix)

TMatrixAddition Operator (TMatrix, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator + (
    c1 As TMatrix,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator +(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (+)
        c1 : TMatrix *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


TMatrix.Division Operator

TMatrixDivision Operator

Overload List
Name | Description
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Division Operator (TComplex, TMatrix)

TMatrixDivision Operator (TComplex, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TComplex c1,
    TMatrix c2
)
Public Shared Operator / (
    c1 As TComplex,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator /(
    TComplex^ c1,
    TMatrix^ c2
)
static let inline (/)
        c1 : TComplex *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


TMatrix.Division Operator (TMatrix, TComplex)

TMatrixDivision Operator (TMatrix, TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TMatrix c1,
    TComplex c2
)
Public Shared Operator / (
    c1 As TMatrix,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator /(
    TMatrix^ c1,
    TComplex^ c2
)
static let inline (/)
        c1 : TMatrix *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


TMatrix.Division Operator (TMatrix, TMatrix)

TMatrixDivision Operator (TMatrix, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator / (
    c1 As TMatrix,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator /(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (/)
        c1 : TMatrix *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


TMatrix.Equality Operator

TMatrixEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator = (
    c1 As TMatrix,
    c2 As TMatrix
) As Boolean
public:
static bool operator ==(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (=)
        c1 : TMatrix *
        c2 : TMatrix  : bool

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: Boolean
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion Operators

TMatrix Conversion Operators

Overload List
Name | Description
(Double to TMatrix) |
(TComplex to TMatrix) |
(TDouble to TMatrix) |
(TFraction to TMatrix) |
(TInfinity to TMatrix) |
(TNumber to TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (Double to TMatrix)

TMatrix Conversion (Double to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TMatrix
static implicit operator TMatrix^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (TComplex to TMatrix)

TMatrix Conversion (TComplex to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    TComplex value
)
Public Shared Widening Operator CType (
    value As TComplex
) As TMatrix
static implicit operator TMatrix^ (
    TComplex^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTComplex

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (TDouble to TMatrix)

TMatrix Conversion (TDouble to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    TDouble value
)
Public Shared Widening Operator CType (
    value As TDouble
) As TMatrix
static implicit operator TMatrix^ (
    TDouble^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (TFraction to TMatrix)

TMatrix Conversion (TFraction to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    TFraction value
)
Public Shared Widening Operator CType (
    value As TFraction
) As TMatrix
static implicit operator TMatrix^ (
    TFraction^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (TInfinity to TMatrix)

TMatrix Conversion (TInfinity to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    TInfinity value
)
Public Shared Widening Operator CType (
    value As TInfinity
) As TMatrix
static implicit operator TMatrix^ (
    TInfinity^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTInfinity

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix Implicit Conversion (TNumber to TMatrix)

TMatrix Conversion (TNumber to TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TMatrix (
    TNumber value
)
Public Shared Widening Operator CType (
    value As TNumber
) As TMatrix
static implicit operator TMatrix^ (
    TNumber^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TMatrix
See Also

Reference

TMatrix Class
Overload
SMath.Math.Numeric Namespace


TMatrix.Inequality Operator

TMatrixInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator <> (
    c1 As TMatrix,
    c2 As TMatrix
) As Boolean
public:
static bool operator !=(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (<>)
        c1 : TMatrix *
        c2 : TMatrix  : bool

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: Boolean
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Multiply Operator

TMatrixMultiply Operator

Overload List
Name | Description
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Multiply Operator (TComplex, TMatrix)

TMatrixMultiply Operator (TComplex, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TComplex c1,
    TMatrix c2
)
Public Shared Operator * (
    c1 As TComplex,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator *(
    TComplex^ c1,
    TMatrix^ c2
)
static let inline (*)
        c1 : TComplex *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


TMatrix.Multiply Operator (TMatrix, TComplex)

TMatrixMultiply Operator (TMatrix, TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TMatrix c1,
    TComplex c2
)
Public Shared Operator * (
    c1 As TMatrix,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator *(
    TMatrix^ c1,
    TComplex^ c2
)
static let inline (*)
        c1 : TMatrix *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


TMatrix.Multiply Operator (TMatrix, TMatrix)

TMatrixMultiply Operator (TMatrix, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator * (
    c1 As TMatrix,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator *(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (*)
        c1 : TMatrix *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


TMatrix.Subtraction Operator

TMatrixSubtraction Operator

Overload List
Name | Description
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.Subtraction Operator (TComplex, TMatrix)

TMatrixSubtraction Operator (TComplex, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TComplex c1,
    TMatrix c2
)
Public Shared Operator - (
    c1 As TComplex,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator -(
    TComplex^ c1,
    TMatrix^ c2
)
static let inline (-)
        c1 : TComplex *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTComplex
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


TMatrix.Subtraction Operator (TMatrix, TComplex)

TMatrixSubtraction Operator (TMatrix, TComplex)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TMatrix c1,
    TComplex c2
)
Public Shared Operator - (
    c1 As TMatrix,
    c2 As TComplex
) As TNumber
public:
static TNumber^ operator -(
    TMatrix^ c1,
    TComplex^ c2
)
static let inline (-)
        c1 : TMatrix *
        c2 : TComplex  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTComplex

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


TMatrix.Subtraction Operator (TMatrix, TMatrix)

TMatrixSubtraction Operator (TMatrix, TMatrix)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TMatrix c1,
    TMatrix c2
)
Public Shared Operator - (
    c1 As TMatrix,
    c2 As TMatrix
) As TNumber
public:
static TNumber^ operator -(
    TMatrix^ c1,
    TMatrix^ c2
)
static let inline (-)
        c1 : TMatrix *
        c2 : TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.NumericTMatrix
c2
Type: SMath.Math.NumericTMatrix

Return Value

Type: TNumber
See Also

Reference

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


TMatrix Fields

The TMatrix type exposes the following members.

Fields
 | Name | Description
 | lunb |
 | MachineEpsilon |
Public field | unit |
Top
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.lunb Field

TMatrixlunb Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public const int lunb = 8
Public Const lunb As Integer = 8
public:
literal int lunb = 8
static val mutable lunb: int

Field Value

Type: Int32
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.MachineEpsilon Field

TMatrixMachineEpsilon Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public const double MachineEpsilon = 5E-16
Public Const MachineEpsilon As Double = 5E-16
public:
literal double MachineEpsilon = 5E-16
static val mutable MachineEpsilon: float

Field Value

Type: Double
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix.unit Field

TMatrixunit Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TNumber[,] unit
Public ReadOnly unit As TNumber(,)
public:
initonly array<TNumber^,2>^ unit
val unit: TNumber[,]

Field Value

Type: TNumber
See Also

Reference

TMatrix Class
SMath.Math.Numeric Namespace


TNumber Class

Менеджер численных математических примитивов.
Inheritance Hierarchy
SystemObject
SMath.Math.NumericTNumber

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TNumber
Public NotInheritable Class TNumber
public ref class TNumber sealed
[<SealedAttribute>]
type TNumber =  class end

The TNumber type exposes the following members.

Constructors
 | Name | Description
Public method | TNumber | Initializes a new instance of the TNumber class
Public method | TNumber(Double) | Initializes a new instance of the TNumber class
Public method | TNumber(InfType) | Initializes a new instance of the TNumber class
Public method | TNumber(TComplex) | Initializes a new instance of the TNumber class
Public method | TNumber(TFraction) | Initializes a new instance of the TNumber class
Public method | TNumber(TInfinity) | Initializes a new instance of the TNumber class
Public method | TNumber(Double, Double) | Initializes a new instance of the TNumber class
Public method | TNumber(TDouble, TDouble) | Initializes a new instance of the TNumber class
Top
Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosec |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Ainterp |
Public method | Alg |
Public method | Arg |
Public method | ASec |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Augment |
Public method | Cinterp |
Public method | Col |
Public method | Cols |
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | CSort |
Public method | Determinant |
Public method | Diag |
 | DoubleOrFraction |
Public method | El(Int32) |
Public method | El(Int32, Int32) |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | FFT |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Identity |
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Ln |
Public method | Log |
Public method | Matrix |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mod |
Public method | Norm1 |
Public method | NormE |
Public method | NormI |
Public method | Numden |
Public method | pol2xy |
Public method | PolyRoots |
Public method | Polyroots2 |
Public method | Power(TNumber) |
Public method | Power(TNumber, Boolean) |
Public method | Random |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | Round(TNumber) |
Public method | Round(TNumber, TNumber) |
Public method | Row |
Public method | Rows |
Public method | RSort |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sort |
Public method | Stack |
Public method | Submatrix |
Public method | Tan |
Public method | TanH |
Public method | ToInt32 |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Trace |
Public method | Transpose |
Public method | Trunc |
Public method | VMinor |
Public method | VMultiplication |
Public method | xy2pol |
Public method | xy2pol(TNumber) |
Top
Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
(Double to TNumber) |
(BaseEntry to TNumber) |
Inequality |
LessThan |
Multiply |
Subtraction |
Top
Fields
 | Name | Description
Public field | obj |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TNumber Constructor

Overload List
 | Name | Description
Public method | TNumber | Initializes a new instance of the TNumber class
Public method | TNumber(Double) | Initializes a new instance of the TNumber class
Public method | TNumber(InfType) | Initializes a new instance of the TNumber class
Public method | TNumber(TComplex) | Initializes a new instance of the TNumber class
Public method | TNumber(TFraction) | Initializes a new instance of the TNumber class
Public method | TNumber(TInfinity) | Initializes a new instance of the TNumber class
Public method | TNumber(Double, Double) | Initializes a new instance of the TNumber class
Public method | TNumber(TDouble, TDouble) | Initializes a new instance of the TNumber class
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber Constructor

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber()
Public Sub New
public:
TNumber()
new : unit -> TNumber
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (Double)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    double value
)
Public Sub New (
    value As Double
)
public:
TNumber(
    double value
)
new :
        value : float -> TNumber

Parameters

value
Type: SystemDouble
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (InfType)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    InfType D
)
Public Sub New (
    D As InfType
)
public:
TNumber(
    InfType D
)
new :
        D : InfType -> TNumber

Parameters

D
Type: SMath.Math.NumericInfType
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TComplex)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    TComplex value
)
Public Sub New (
    value As TComplex
)
public:
TNumber(
    TComplex^ value
)
new :
        value : TComplex -> TNumber

Parameters

value
Type: SMath.Math.NumericTComplex
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TFraction)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    TFraction D
)
Public Sub New (
    D As TFraction
)
public:
TNumber(
    TFraction^ D
)
new :
        D : TFraction -> TNumber

Parameters

D
Type: SMath.Math.NumericTFraction
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TInfinity)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    TInfinity value
)
Public Sub New (
    value As TInfinity
)
public:
TNumber(
    TInfinity^ value
)
new :
        value : TInfinity -> TNumber

Parameters

value
Type: SMath.Math.NumericTInfinity
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (Double, Double)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    double num,
    double den
)
Public Sub New (
    num As Double,
    den As Double
)
public:
TNumber(
    double num,
    double den
)
new :
        num : float *
        den : float -> TNumber

Parameters

num
Type: SystemDouble
den
Type: SystemDouble
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TDouble, TDouble)

Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber(
    TDouble num,
    TDouble den
)
Public Sub New (
    num As TDouble,
    den As TDouble
)
public:
TNumber(
    TDouble^ num,
    TDouble^ den
)
new :
        num : TDouble *
        den : TDouble -> TNumber

Parameters

num
Type: SMath.Math.NumericTDouble
den
Type: SMath.Math.NumericTDouble
See Also

Reference

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Methods

The TNumber type exposes the following members.

Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosec |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Ainterp |
Public method | Alg |
Public method | Arg |
Public method | ASec |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Augment |
Public method | Cinterp |
Public method | Col |
Public method | Cols |
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | CSort |
Public method | Determinant |
Public method | Diag |
 | DoubleOrFraction |
Public method | El(Int32) |
Public method | El(Int32, Int32) |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | FFT |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Identity |
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Ln |
Public method | Log |
Public method | Matrix |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mod |
Public method | Norm1 |
Public method | NormE |
Public method | NormI |
Public method | Numden |
Public method | pol2xy |
Public method | PolyRoots |
Public method | Polyroots2 |
Public method | Power(TNumber) |
Public method | Power(TNumber, Boolean) |
Public method | Random |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | Round(TNumber) |
Public method | Round(TNumber, TNumber) |
Public method | Row |
Public method | Rows |
Public method | RSort |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sort |
Public method | Stack |
Public method | Submatrix |
Public method | Tan |
Public method | TanH |
Public method | ToInt32 |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Trace |
Public method | Transpose |
Public method | Trunc |
Public method | VMinor |
Public method | VMultiplication |
Public method | xy2pol |
Public method | xy2pol(TNumber) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Abs Method

TNumberAbs Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Abs()
Public Function Abs As TNumber
public:
TNumber^ Abs()
member Abs : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ACos Method

TNumberACos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACos()
Public Function ACos As TNumber
public:
TNumber^ ACos()
member ACos : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ACosec Method

TNumberACosec Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACosec()
Public Function ACosec As TNumber
public:
TNumber^ ACosec()
member ACosec : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ACosH Method

TNumberACosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACosH()
Public Function ACosH As TNumber
public:
TNumber^ ACosH()
member ACosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ACot Method

TNumberACot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACot()
Public Function ACot As TNumber
public:
TNumber^ ACot()
member ACot : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ACotH Method

TNumberACotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACotH()
Public Function ACotH As TNumber
public:
TNumber^ ACotH()
member ACotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Ainterp Method

TNumberAinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Ainterp(
    BaseEntry c2,
    BaseEntry pnt
)
Public Function Ainterp (
    c2 As BaseEntry,
    pnt As BaseEntry
) As TNumber
public:
TNumber^ Ainterp(
    BaseEntry^ c2,
    BaseEntry^ pnt
)
member Ainterp :
        c2 : BaseEntry *
        pnt : BaseEntry -> TNumber

Parameters

c2
Type: SMath.Math.NumericBaseEntry
pnt
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Alg Method

TNumberAlg Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Alg(
    int row,
    int col
)
Public Function Alg (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ Alg(
    int row,
    int col
)
member Alg :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Arg Method

TNumberArg Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Arg()
Public Function Arg As TNumber
public:
TNumber^ Arg()
member Arg : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ASec Method

TNumberASec Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASec()
Public Function ASec As TNumber
public:
TNumber^ ASec()
member ASec : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ASin Method

TNumberASin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASin()
Public Function ASin As TNumber
public:
TNumber^ ASin()
member ASin : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ASinH Method

TNumberASinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASinH()
Public Function ASinH As TNumber
public:
TNumber^ ASinH()
member ASinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ATan Method

TNumberATan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan()
Public Function ATan As TNumber
public:
TNumber^ ATan()
member ATan : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ATan2 Method

TNumberATan2 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan2(
    BaseEntry Base
)
Public Function ATan2 (
    Base As BaseEntry
) As TNumber
public:
TNumber^ ATan2(
    BaseEntry^ Base
)
member ATan2 :
        Base : BaseEntry -> TNumber

Parameters

Base
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ATanH Method

TNumberATanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATanH()
Public Function ATanH As TNumber
public:
TNumber^ ATanH()
member ATanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Augment Method

TNumberAugment Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Augment(
    TNumber[] value
)
Public Function Augment (
    value As TNumber()
) As TMatrix
public:
TMatrix^ Augment(
    array<TNumber^>^ value
)
member Augment :
        value : TNumber[] -> TMatrix

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TMatrix
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Cinterp Method

TNumberCinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Cinterp(
    BaseEntry c2,
    BaseEntry pnt
)
Public Function Cinterp (
    c2 As BaseEntry,
    pnt As BaseEntry
) As TNumber
public:
TNumber^ Cinterp(
    BaseEntry^ c2,
    BaseEntry^ pnt
)
member Cinterp :
        c2 : BaseEntry *
        pnt : BaseEntry -> TNumber

Parameters

c2
Type: SMath.Math.NumericBaseEntry
pnt
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Col Method

TNumberCol Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Col(
    int value
)
Public Function Col (
    value As Integer
) As TNumber
public:
TNumber^ Col(
    int value
)
member Col :
        value : int -> TNumber

Parameters

value
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Cols Method

TNumberCols Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Cols()
Public Function Cols As TNumber
public:
TNumber^ Cols()
member Cols : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Cos Method

TNumberCos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Cos()
Public Function Cos As TNumber
public:
TNumber^ Cos()
member Cos : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.CosH Method

TNumberCosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CosH()
Public Function CosH As TNumber
public:
TNumber^ CosH()
member CosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Cot Method

TNumberCot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Cot()
Public Function Cot As TNumber
public:
TNumber^ Cot()
member Cot : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.CotH Method

TNumberCotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CotH()
Public Function CotH As TNumber
public:
TNumber^ CotH()
member CotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.CSort Method

TNumberCSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CSort(
    TNumber ind
)
Public Function CSort (
    ind As TNumber
) As TNumber
public:
TNumber^ CSort(
    TNumber^ ind
)
member CSort :
        ind : TNumber -> TNumber

Parameters

ind
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Determinant Method

TNumberDeterminant Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Determinant()
Public Function Determinant As TNumber
public:
TNumber^ Determinant()
member Determinant : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Diag Method

TNumberDiag Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Diag()
Public Function Diag As TNumber
public:
TNumber^ Diag()
member Diag : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.DoubleOrFraction Method

TNumberDoubleOrFraction Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber DoubleOrFraction(
    double d
)
Public Shared Function DoubleOrFraction (
    d As Double
) As TNumber
public:
static TNumber^ DoubleOrFraction(
    double d
)
static member DoubleOrFraction :
        d : float -> TNumber

Parameters

d
Type: SystemDouble

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.El Method

TNumberEl Method

Overload List
 | Name | Description
Public method | El(Int32) |
Public method | El(Int32, Int32) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.El Method (Int32)

TNumberEl Method (Int32)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber El(
    int row
)
Public Function El (
    row As Integer
) As TNumber
public:
TNumber^ El(
    int row
)
member El :
        row : int -> TNumber

Parameters

row
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
El Overload
SMath.Math.Numeric Namespace


TNumber.El Method (Int32, Int32)

TNumberEl Method (Int32, Int32)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber El(
    int row,
    int col
)
Public Function El (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ El(
    int row,
    int col
)
member El :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
El Overload
SMath.Math.Numeric Namespace


TNumber.Equals Method

TNumberEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Factorial Method

TNumberFactorial Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Factorial()
Public Function Factorial As TNumber
public:
TNumber^ Factorial()
member Factorial : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.FFT Method

TNumberFFT Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber FFT(
    TNumber c1
)
Public Function FFT (
    c1 As TNumber
) As TNumber
public:
TNumber^ FFT(
    TNumber^ c1
)
member FFT :
        c1 : TNumber -> TNumber

Parameters

c1
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.GetHashCode Method

TNumberGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Identity Method

TNumberIdentity Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Identity()
Public Function Identity As TNumber
public:
TNumber^ Identity()
member Identity : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Im Method

TNumberIm Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Im()
Public Function Im As TNumber
public:
TNumber^ Im()
member Im : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Length Method

TNumberLength Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Length()
Public Function Length As TNumber
public:
TNumber^ Length()
member Length : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Linterp Method

TNumberLinterp Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Linterp(
    BaseEntry c2,
    BaseEntry pnt
)
Public Function Linterp (
    c2 As BaseEntry,
    pnt As BaseEntry
) As TNumber
public:
TNumber^ Linterp(
    BaseEntry^ c2,
    BaseEntry^ pnt
)
member Linterp :
        c2 : BaseEntry *
        pnt : BaseEntry -> TNumber

Parameters

c2
Type: SMath.Math.NumericBaseEntry
pnt
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Ln Method

TNumberLn Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Ln()
Public Function Ln As TNumber
public:
TNumber^ Ln()
member Ln : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Log Method

TNumberLog Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Log(
    BaseEntry Base
)
Public Function Log (
    Base As BaseEntry
) As TNumber
public:
TNumber^ Log(
    BaseEntry^ Base
)
member Log :
        Base : BaseEntry -> TNumber

Parameters

Base
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Matrix Method

TNumberMatrix Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Matrix(
    TNumber value
)
Public Function Matrix (
    value As TNumber
) As TNumber
public:
TNumber^ Matrix(
    TNumber^ value
)
member Matrix :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Max Method

TNumberMax Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Max()
Public Function Max As TNumber
public:
TNumber^ Max()
member Max : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Min Method

TNumberMin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Min()
Public Function Min As TNumber
public:
TNumber^ Min()
member Min : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Minor Method

TNumberMinor Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Minor(
    int row,
    int col
)
Public Function Minor (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ Minor(
    int row,
    int col
)
member Minor :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Mod Method

TNumberMod Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Mod(
    TNumber value
)
Public Function Mod (
    value As TNumber
) As TNumber
public:
TNumber^ Mod(
    TNumber^ value
)
member Mod :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Norm1 Method

TNumberNorm1 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Norm1()
Public Function Norm1 As TNumber
public:
TNumber^ Norm1()
member Norm1 : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.NormE Method

TNumberNormE Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber NormE()
Public Function NormE As TNumber
public:
TNumber^ NormE()
member NormE : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.NormI Method

TNumberNormI Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber NormI()
Public Function NormI As TNumber
public:
TNumber^ NormI()
member NormI : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Numden Method

TNumberNumden Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Numden()
Public Function Numden As TNumber
public:
TNumber^ Numden()
member Numden : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.pol2xy Method

TNumberpol2xy Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber pol2xy(
    TNumber value
)
Public Function pol2xy (
    value As TNumber
) As TNumber
public:
TNumber^ pol2xy(
    TNumber^ value
)
member pol2xy :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.PolyRoots Method

TNumberPolyRoots Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber PolyRoots()
Public Function PolyRoots As TNumber
public:
TNumber^ PolyRoots()
member PolyRoots : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Polyroots2 Method

TNumberPolyroots2 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Polyroots2()
Public Function Polyroots2 As TNumber
public:
TNumber^ Polyroots2()
member Polyroots2 : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Power Method

TNumberPower Method

Overload List
 | Name | Description
Public method | Power(TNumber) |
Public method | Power(TNumber, Boolean) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Power Method (TNumber)

TNumberPower Method (TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TNumber value
)
Public Function Power (
    value As TNumber
) As TNumber
public:
TNumber^ Power(
    TNumber^ value
)
member Power :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Power Overload
SMath.Math.Numeric Namespace


TNumber.Power Method (TNumber, Boolean)

TNumberPower Method (TNumber, Boolean)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TNumber value,
    bool check0p0
)
Public Function Power (
    value As TNumber,
    check0p0 As Boolean
) As TNumber
public:
TNumber^ Power(
    TNumber^ value,
    bool check0p0
)
member Power :
        value : TNumber *
        check0p0 : bool -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber
check0p0
Type: SystemBoolean

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Power Overload
SMath.Math.Numeric Namespace


TNumber.Random Method

TNumberRandom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Random()
Public Function Random As TNumber
public:
TNumber^ Random()
member Random : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Rank Method

TNumberRank Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Rank()
Public Function Rank As TNumber
public:
TNumber^ Rank()
member Rank : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Re Method

TNumberRe Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Re()
Public Function Re As TNumber
public:
TNumber^ Re()
member Re : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Reverse Method

TNumberReverse Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Reverse()
Public Function Reverse As TNumber
public:
TNumber^ Reverse()
member Reverse : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Round Method

TNumberRound Method

Overload List
 | Name | Description
Public method | Round(TNumber) |
Public method | Round(TNumber, TNumber) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Round Method (TNumber)

TNumberRound Method (TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Round(
    TNumber value
)
Public Function Round (
    value As TNumber
) As TNumber
public:
TNumber^ Round(
    TNumber^ value
)
member Round :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Round Overload
SMath.Math.Numeric Namespace


TNumber.Round Method (TNumber, TNumber)

TNumberRound Method (TNumber, TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Round(
    TNumber value,
    TNumber type
)
Public Function Round (
    value As TNumber,
    type As TNumber
) As TNumber
public:
TNumber^ Round(
    TNumber^ value,
    TNumber^ type
)
member Round :
        value : TNumber *
        type : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber
type
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Round Overload
SMath.Math.Numeric Namespace


TNumber.Row Method

TNumberRow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Row(
    int value
)
Public Function Row (
    value As Integer
) As TNumber
public:
TNumber^ Row(
    int value
)
member Row :
        value : int -> TNumber

Parameters

value
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Rows Method

TNumberRows Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Rows()
Public Function Rows As TNumber
public:
TNumber^ Rows()
member Rows : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.RSort Method

TNumberRSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber RSort(
    TNumber ind
)
Public Function RSort (
    ind As TNumber
) As TNumber
public:
TNumber^ RSort(
    TNumber^ ind
)
member RSort :
        ind : TNumber -> TNumber

Parameters

ind
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Sign Method

TNumberSign Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Sign()
Public Function Sign As TNumber
public:
TNumber^ Sign()
member Sign : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Sin Method

TNumberSin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Sin()
Public Function Sin As TNumber
public:
TNumber^ Sin()
member Sin : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.SinH Method

TNumberSinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber SinH()
Public Function SinH As TNumber
public:
TNumber^ SinH()
member SinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Sort Method

TNumberSort Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Sort()
Public Function Sort As TNumber
public:
TNumber^ Sort()
member Sort : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Stack Method

TNumberStack Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TMatrix Stack(
    TNumber[] value
)
Public Function Stack (
    value As TNumber()
) As TMatrix
public:
TMatrix^ Stack(
    array<TNumber^>^ value
)
member Stack :
        value : TNumber[] -> TMatrix

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TMatrix
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Submatrix Method

TNumberSubmatrix Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
Public Function Submatrix (
    startRow As Integer,
    endRow As Integer,
    startCol As Integer,
    endCol As Integer
) As TNumber
public:
TNumber^ Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
member Submatrix :
        startRow : int *
        endRow : int *
        startCol : int *
        endCol : int -> TNumber

Parameters

startRow
Type: SystemInt32
endRow
Type: SystemInt32
startCol
Type: SystemInt32
endCol
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Tan Method

TNumberTan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Tan()
Public Function Tan As TNumber
public:
TNumber^ Tan()
member Tan : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.TanH Method

TNumberTanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber TanH()
Public Function TanH As TNumber
public:
TNumber^ TanH()
member TanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.ToInt32 Method

TNumberToInt32 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public int ToInt32()
Public Function ToInt32 As Integer
public:
int ToInt32()
member ToInt32 : unit -> int

Return Value

Type: Int32
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Trace Method

TNumberTrace Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Trace()
Public Function Trace As TNumber
public:
TNumber^ Trace()
member Trace : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Transpose Method

TNumberTranspose Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Transpose()
Public Function Transpose As TNumber
public:
TNumber^ Transpose()
member Transpose : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Trunc Method

TNumberTrunc Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Trunc()
Public Function Trunc As TNumber
public:
TNumber^ Trunc()
member Trunc : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.VMinor Method

TNumberVMinor Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber VMinor(
    int row,
    int col
)
Public Function VMinor (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ VMinor(
    int row,
    int col
)
member VMinor :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.VMultiplication Method

TNumberVMultiplication Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber VMultiplication(
    TNumber value
)
Public Function VMultiplication (
    value As TNumber
) As TNumber
public:
TNumber^ VMultiplication(
    TNumber^ value
)
member VMultiplication :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.xy2pol Method

TNumberxy2pol Method

Overload List
 | Name | Description
Public method | xy2pol |
Public method | xy2pol(TNumber) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.xy2pol Method

TNumberxy2pol Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber xy2pol()
Public Function xy2pol As TNumber
public:
TNumber^ xy2pol()
member xy2pol : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
xy2pol Overload
SMath.Math.Numeric Namespace


TNumber.xy2pol Method (TNumber)

TNumberxy2pol Method (TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber xy2pol(
    TNumber value
)
Public Function xy2pol (
    value As TNumber
) As TNumber
public:
TNumber^ xy2pol(
    TNumber^ value
)
member xy2pol :
        value : TNumber -> TNumber

Parameters

value
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
xy2pol Overload
SMath.Math.Numeric Namespace


TNumber Operators and Type Conversions

The TNumber type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
GreaterThan |
(Double to TNumber) |
(BaseEntry to TNumber) |
Inequality |
LessThan |
Multiply |
Subtraction |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Addition Operator

TNumberAddition Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TNumber c1,
    TNumber c2
)
Public Shared Operator + (
    c1 As TNumber,
    c2 As TNumber
) As TNumber
public:
static TNumber^ operator +(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (+)
        c1 : TNumber *
        c2 : TNumber  : TNumber

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Division Operator

TNumberDivision Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TNumber c1,
    TNumber c2
)
Public Shared Operator / (
    c1 As TNumber,
    c2 As TNumber
) As TNumber
public:
static TNumber^ operator /(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (/)
        c1 : TNumber *
        c2 : TNumber  : TNumber

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Equality Operator

TNumberEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TNumber c1,
    TNumber c2
)
Public Shared Operator = (
    c1 As TNumber,
    c2 As TNumber
) As Boolean
public:
static bool operator ==(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (=)
        c1 : TNumber *
        c2 : TNumber  : bool

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: Boolean
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.GreaterThan Operator

TNumberGreaterThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    TNumber c1,
    TNumber c2
)
Public Shared Operator > (
    c1 As TNumber,
    c2 As TNumber
) As Boolean
public:
static bool operator >(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (>)
        c1 : TNumber *
        c2 : TNumber  : bool

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: Boolean
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber Implicit Conversion Operators

TNumber Conversion Operators

Overload List
Name | Description
(Double to TNumber) |
(BaseEntry to TNumber) |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber Implicit Conversion (Double to TNumber)

TNumber Conversion (Double to TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TNumber (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TNumber
static implicit operator TNumber^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Overload
SMath.Math.Numeric Namespace


TNumber Implicit Conversion (BaseEntry to TNumber)

TNumber Conversion (BaseEntry to TNumber)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TNumber (
    BaseEntry value
)
Public Shared Widening Operator CType (
    value As BaseEntry
) As TNumber
static implicit operator TNumber^ (
    BaseEntry^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: TNumber
See Also

Reference

TNumber Class
Overload
SMath.Math.Numeric Namespace


TNumber.Inequality Operator

TNumberInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TNumber c1,
    TNumber c2
)
Public Shared Operator <> (
    c1 As TNumber,
    c2 As TNumber
) As Boolean
public:
static bool operator !=(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (<>)
        c1 : TNumber *
        c2 : TNumber  : bool

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: Boolean
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.LessThan Operator

TNumberLessThan Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    TNumber c1,
    TNumber c2
)
Public Shared Operator < (
    c1 As TNumber,
    c2 As TNumber
) As Boolean
public:
static bool operator <(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (<)
        c1 : TNumber *
        c2 : TNumber  : bool

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: Boolean
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Multiply Operator

TNumberMultiply Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TNumber c1,
    TNumber c2
)
Public Shared Operator * (
    c1 As TNumber,
    c2 As TNumber
) As TNumber
public:
static TNumber^ operator *(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (*)
        c1 : TNumber *
        c2 : TNumber  : TNumber

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.Subtraction Operator

TNumberSubtraction Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TNumber c1,
    TNumber c2
)
Public Shared Operator - (
    c1 As TNumber,
    c2 As TNumber
) As TNumber
public:
static TNumber^ operator -(
    TNumber^ c1,
    TNumber^ c2
)
static let inline (-)
        c1 : TNumber *
        c2 : TNumber  : TNumber

Parameters

c1
Type: SMath.Math.NumericTNumber
c2
Type: SMath.Math.NumericTNumber

Return Value

Type: TNumber
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber Fields

The TNumber type exposes the following members.

Fields
 | Name | Description
Public field | obj |
Top
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TNumber.obj Field

TNumberobj Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public BaseEntry obj
Public obj As BaseEntry
public:
BaseEntry^ obj
val mutable obj: BaseEntry

Field Value

Type: BaseEntry
See Also

Reference

TNumber Class
SMath.Math.Numeric Namespace


TSystem Class

Inheritance Hierarchy
SystemObject
SMath.Math.NumericBaseEntry
SMath.Math.NumericTSystem

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public sealed class TSystem : BaseEntry
Public NotInheritable Class TSystem
    Inherits BaseEntry
public ref class TSystem sealed : public BaseEntry
[<SealedAttribute>]
type TSystem =
    class
        inherit BaseEntry
    end

The TSystem type exposes the following members.

Constructors
 | Name | Description
Public method | TSystem(TComplex) | Initializes a new instance of the TSystem class
Public method | TSystem(TFraction) | Initializes a new instance of the TSystem class
Public method | TSystem(TInfinity) | Initializes a new instance of the TSystem class
Public method | TSystem(TMatrix) | Initializes a new instance of the TSystem class
Public method | TSystem(TNumber) | Initializes a new instance of the TSystem class
Top
Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Determinant |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | El |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Im |
Public method | Ln |
Public method | Log |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Max |
Public method | Min |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trace |
Public method | Transpose |
Public method | Trunc | (Inherited from BaseEntry.)
Top
Operators
Name | Description
Addition |
Division |
Equality |
(Double to TSystem) |
(TComplex to TSystem) |
(TDouble to TSystem) |
(TFraction to TSystem) |
(TInfinity to TSystem) |
Inequality |
Multiply |
Subtraction |
Top
Fields
 | Name | Description
Public field | matrix |
Top
See Also

Reference

SMath.Math.Numeric Namespace


TSystem Constructor

Overload List
 | Name | Description
Public method | TSystem(TComplex) | Initializes a new instance of the TSystem class
Public method | TSystem(TFraction) | Initializes a new instance of the TSystem class
Public method | TSystem(TInfinity) | Initializes a new instance of the TSystem class
Public method | TSystem(TMatrix) | Initializes a new instance of the TSystem class
Public method | TSystem(TNumber) | Initializes a new instance of the TSystem class
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Constructor (TComplex)

Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TSystem(
    TComplex value
)
Public Sub New (
    value As TComplex
)
public:
TSystem(
    TComplex^ value
)
new :
        value : TComplex -> TSystem

Parameters

value
Type: SMath.Math.NumericTComplex
See Also

Reference

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TFraction)

Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TSystem(
    TFraction value
)
Public Sub New (
    value As TFraction
)
public:
TSystem(
    TFraction^ value
)
new :
        value : TFraction -> TSystem

Parameters

value
Type: SMath.Math.NumericTFraction
See Also

Reference

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TInfinity)

Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TSystem(
    TInfinity value
)
Public Sub New (
    value As TInfinity
)
public:
TSystem(
    TInfinity^ value
)
new :
        value : TInfinity -> TSystem

Parameters

value
Type: SMath.Math.NumericTInfinity
See Also

Reference

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TMatrix)

Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TSystem(
    TMatrix value
)
Public Sub New (
    value As TMatrix
)
public:
TSystem(
    TMatrix^ value
)
new :
        value : TMatrix -> TSystem

Parameters

value
Type: SMath.Math.NumericTMatrix
See Also

Reference

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TNumber[])

TSystem Constructor (TNumber)

Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TSystem(
    TNumber[] matrix
)
Public Sub New (
    matrix As TNumber()
)
public:
TSystem(
    array<TNumber^>^ matrix
)
new :
        matrix : TNumber[] -> TSystem

Parameters

matrix
Type: SMath.Math.NumericTNumber
See Also

Reference

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Properties

The TSystem type exposes the following members.

Properties
 | Name | Description
Public property | HasUnits | (Inherited from BaseEntry.)
Public property | IzZero | (Overrides BaseEntryIzZero.)
Public property | Type | (Inherited from BaseEntry.)
Public property | Units | Unit of the expression component.Размерность математического примитива. (Inherited from BaseEntry.)
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.IzZero Property

TSystemIzZero Property

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool IzZero { get; }
Public Overrides ReadOnly Property IzZero As Boolean
    Get
public:
virtual property bool IzZero {
    bool get () override;
}
abstract IzZero : bool with get
override IzZero : bool with get

Property Value

Type: Boolean
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Methods

The TSystem type exposes the following members.

Methods
 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATan2 |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntryClone.)
Public method | Com | (Overrides BaseEntryCom(BaseEntry).)
Public method | Cos | (Overrides BaseEntryCos.)
Public method | CosH |
Public method | Cot | (Overrides BaseEntryCot.)
Public method | CotH |
Public method | Determinant |
Public method | Div | (Overrides BaseEntryDiv(BaseEntry).)
Public method | El |
Public method | Equals | (Overrides ObjectEquals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | Gt | (Inherited from BaseEntry.)
Public method | Im |
Public method | Ln |
Public method | Log |
Public method | Lt | (Inherited from BaseEntry.)
Public method | Max |
Public method | Min |
Public method | Mul | (Overrides BaseEntryMul(BaseEntry).)
Public method | Pow | (Overrides BaseEntryPow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Round(BaseEntry) | (Inherited from BaseEntry.)
Public method | Round(BaseEntry, TDouble) | (Inherited from BaseEntry.)
Public method | Sign |
Public method | Sin | (Overrides BaseEntrySin.)
Public method | SinH |
Public method | Sub | (Overrides BaseEntrySub(BaseEntry).)
Public method | Tan | (Overrides BaseEntryTan.)
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntryToDouble.)
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Public method | Trace |
Public method | Transpose |
Public method | Trunc | (Inherited from BaseEntry.)
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Abs Method

TSystemAbs Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Abs()
Public Function Abs As TNumber
public:
TNumber^ Abs()
member Abs : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ACos Method

TSystemACos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACos()
Public Function ACos As TNumber
public:
TNumber^ ACos()
member ACos : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ACosH Method

TSystemACosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACosH()
Public Function ACosH As TNumber
public:
TNumber^ ACosH()
member ACosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ACot Method

TSystemACot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACot()
Public Function ACot As TNumber
public:
TNumber^ ACot()
member ACot : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ACotH Method

TSystemACotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ACotH()
Public Function ACotH As TNumber
public:
TNumber^ ACotH()
member ACotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Arg Method

TSystemArg Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Arg()
Public Function Arg As TNumber
public:
TNumber^ Arg()
member Arg : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ASin Method

TSystemASin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASin()
Public Function ASin As TNumber
public:
TNumber^ ASin()
member ASin : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ASinH Method

TSystemASinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ASinH()
Public Function ASinH As TNumber
public:
TNumber^ ASinH()
member ASinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ATan Method

TSystemATan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan()
Public Function ATan As TNumber
public:
TNumber^ ATan()
member ATan : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ATan2 Method

TSystemATan2 Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATan2(
    TSystem Base
)
Public Function ATan2 (
    Base As TSystem
) As TNumber
public:
TNumber^ ATan2(
    TSystem^ Base
)
member ATan2 :
        Base : TSystem -> TNumber

Parameters

Base
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ATanH Method

TSystemATanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber ATanH()
Public Function ATanH As TNumber
public:
TNumber^ ATanH()
member ATanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Clone Method

TSystemClone Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Clone()
Public Overrides Function Clone As BaseEntry
public:
virtual BaseEntry^ Clone() override
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Com Method

TSystemCom Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Com(
    BaseEntry value
)
Public Overrides Function Com (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
abstract Com :
        value : BaseEntry -> BaseEntry
override Com :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Cos Method

TSystemCos Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cos()
Public Overrides Function Cos As BaseEntry
public:
virtual BaseEntry^ Cos() override
abstract Cos : unit -> BaseEntry
override Cos : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.CosH Method

TSystemCosH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CosH()
Public Function CosH As TNumber
public:
TNumber^ CosH()
member CosH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Cot Method

TSystemCot Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Cot()
Public Overrides Function Cot As BaseEntry
public:
virtual BaseEntry^ Cot() override
abstract Cot : unit -> BaseEntry
override Cot : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.CotH Method

TSystemCotH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber CotH()
Public Function CotH As TNumber
public:
TNumber^ CotH()
member CotH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Determinant Method

TSystemDeterminant Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Determinant()
Public Function Determinant As TNumber
public:
TNumber^ Determinant()
member Determinant : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Div Method

TSystemDiv Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Div(
    BaseEntry value
)
Public Overrides Function Div (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
abstract Div :
        value : BaseEntry -> BaseEntry
override Div :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.El Method

TSystemEl Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber El(
    int row,
    int col
)
Public Function El (
    row As Integer,
    col As Integer
) As TNumber
public:
TNumber^ El(
    int row,
    int col
)
member El :
        row : int *
        col : int -> TNumber

Parameters

row
Type: SystemInt32
col
Type: SystemInt32

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Equals Method

TSystemEquals Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Factorial Method

TSystemFactorial Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Factorial()
Public Function Factorial As TNumber
public:
TNumber^ Factorial()
member Factorial : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.GetHashCode Method

TSystemGetHashCode Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Im Method

TSystemIm Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Im()
Public Function Im As TNumber
public:
TNumber^ Im()
member Im : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Ln Method

TSystemLn Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Ln()
Public Function Ln As TNumber
public:
TNumber^ Ln()
member Ln : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Log Method

TSystemLog Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Log(
    TSystem Base
)
Public Function Log (
    Base As TSystem
) As TNumber
public:
TNumber^ Log(
    TSystem^ Base
)
member Log :
        Base : TSystem -> TNumber

Parameters

Base
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Max Method

TSystemMax Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Max()
Public Function Max As TNumber
public:
TNumber^ Max()
member Max : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Min Method

TSystemMin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Min()
Public Function Min As TNumber
public:
TNumber^ Min()
member Min : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Mul Method

TSystemMul Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Mul(
    BaseEntry value
)
Public Overrides Function Mul (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
abstract Mul :
        value : BaseEntry -> BaseEntry
override Mul :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Pow Method

TSystemPow Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Pow(
    BaseEntry value
)
Public Overrides Function Pow (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
abstract Pow :
        value : BaseEntry -> BaseEntry
override Pow :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Power Method

TSystemPower Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Power(
    TSystem value
)
Public Function Power (
    value As TSystem
) As TNumber
public:
TNumber^ Power(
    TSystem^ value
)
member Power :
        value : TSystem -> TNumber

Parameters

value
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Rank Method

TSystemRank Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Rank()
Public Function Rank As TNumber
public:
TNumber^ Rank()
member Rank : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Re Method

TSystemRe Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Re()
Public Function Re As TNumber
public:
TNumber^ Re()
member Re : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Sign Method

TSystemSign Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Sign()
Public Function Sign As TNumber
public:
TNumber^ Sign()
member Sign : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Sin Method

TSystemSin Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sin()
Public Overrides Function Sin As BaseEntry
public:
virtual BaseEntry^ Sin() override
abstract Sin : unit -> BaseEntry
override Sin : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.SinH Method

TSystemSinH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber SinH()
Public Function SinH As TNumber
public:
TNumber^ SinH()
member SinH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Sub Method

TSystemSub Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Sub(
    BaseEntry value
)
Public Overrides Function Sub (
    value As BaseEntry
) As BaseEntry
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
abstract Sub :
        value : BaseEntry -> BaseEntry
override Sub :
        value : BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.NumericBaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Tan Method

TSystemTan Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override BaseEntry Tan()
Public Overrides Function Tan As BaseEntry
public:
virtual BaseEntry^ Tan() override
abstract Tan : unit -> BaseEntry
override Tan : unit -> BaseEntry

Return Value

Type: BaseEntry
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.TanH Method

TSystemTanH Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber TanH()
Public Function TanH As TNumber
public:
TNumber^ TanH()
member TanH : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ToDouble Method

TSystemToDouble Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override double ToDouble()
Public Overrides Function ToDouble As Double
public:
virtual double ToDouble() override
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ToString Method

TSystemToString Method

Overload List
 | Name | Description
Public method | ToString | Converts math expression component to string.Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts math expression component to string with options.Преобразование математического примитива в строку с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToString(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TSystemToString Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override string ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToString (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As String
public:
virtual String^ ToString(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string
override ToString :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> string

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: String
See Also

Reference

TSystem Class
ToString Overload
SMath.Math.Numeric Namespace


TSystem.ToTerms Method

TSystemToTerms Method

Overload List
 | Name | Description
Public method | ToTerms | Converts current expression component to the array of Term in reverse polish notation (RPN).Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean) | Obsolete. Converts current expression component to the array of Term in reverse polish notation (RPN) with options.Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding) | (Overrides BaseEntryToTerms(Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding).)
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.ToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

TSystemToTerms Method (Int32, Int32, FractionsType, Boolean, Boolean, MidpointRounding)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public override Term[] ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
)
Public Overrides Function ToTerms (
    decimalPlaces As Integer,
    exponentialThreshold As Integer,
    fractionType As FractionsType,
    trailingZeros As Boolean,
    significantDigits As Boolean,
    rounding As MidpointRounding
) As Term()
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    int exponentialThreshold,
    FractionsType fractionType,
    bool trailingZeros,
    bool significantDigits,
    MidpointRounding rounding
) override
abstract ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]
override ToTerms :
        decimalPlaces : int *
        exponentialThreshold : int *
        fractionType : FractionsType *
        trailingZeros : bool *
        significantDigits : bool *
        rounding : MidpointRounding -> Term[]

Parameters

decimalPlaces
Type: SystemInt32
exponentialThreshold
Type: SystemInt32
fractionType
Type: SMath.ManagerFractionsType
trailingZeros
Type: SystemBoolean
significantDigits
Type: SystemBoolean
rounding
Type: SystemMidpointRounding

Return Value

Type: Term
See Also

Reference

TSystem Class
ToTerms Overload
SMath.Math.Numeric Namespace


TSystem.Trace Method

TSystemTrace Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Trace()
Public Function Trace As TNumber
public:
TNumber^ Trace()
member Trace : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Transpose Method

TSystemTranspose Method

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public TNumber Transpose()
Public Function Transpose As TNumber
public:
TNumber^ Transpose()
member Transpose : unit -> TNumber

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Operators and Type Conversions

The TSystem type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
(Double to TSystem) |
(TComplex to TSystem) |
(TDouble to TSystem) |
(TFraction to TSystem) |
(TInfinity to TSystem) |
Inequality |
Multiply |
Subtraction |
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Addition Operator

TSystemAddition Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator +(
    TSystem c1,
    TSystem c2
)
Public Shared Operator + (
    c1 As TSystem,
    c2 As TSystem
) As TNumber
public:
static TNumber^ operator +(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (+)
        c1 : TSystem *
        c2 : TSystem  : TNumber

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Division Operator

TSystemDivision Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator /(
    TSystem c1,
    TSystem c2
)
Public Shared Operator / (
    c1 As TSystem,
    c2 As TSystem
) As TNumber
public:
static TNumber^ operator /(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (/)
        c1 : TSystem *
        c2 : TSystem  : TNumber

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Equality Operator

TSystemEquality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    TSystem c1,
    TSystem c2
)
Public Shared Operator = (
    c1 As TSystem,
    c2 As TSystem
) As Boolean
public:
static bool operator ==(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (=)
        c1 : TSystem *
        c2 : TSystem  : bool

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: Boolean
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Implicit Conversion Operators

TSystem Conversion Operators

Overload List
Name | Description
(Double to TSystem) |
(TComplex to TSystem) |
(TDouble to TSystem) |
(TFraction to TSystem) |
(TInfinity to TSystem) |
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Implicit Conversion (Double to TSystem)

TSystem Conversion (Double to TSystem)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TSystem (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As TSystem
static implicit operator TSystem^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: TSystem
See Also

Reference

TSystem Class
Overload
SMath.Math.Numeric Namespace


TSystem Implicit Conversion (TComplex to TSystem)

TSystem Conversion (TComplex to TSystem)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TSystem (
    TComplex value
)
Public Shared Widening Operator CType (
    value As TComplex
) As TSystem
static implicit operator TSystem^ (
    TComplex^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTComplex

Return Value

Type: TSystem
See Also

Reference

TSystem Class
Overload
SMath.Math.Numeric Namespace


TSystem Implicit Conversion (TDouble to TSystem)

TSystem Conversion (TDouble to TSystem)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TSystem (
    TDouble value
)
Public Shared Widening Operator CType (
    value As TDouble
) As TSystem
static implicit operator TSystem^ (
    TDouble^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTDouble

Return Value

Type: TSystem
See Also

Reference

TSystem Class
Overload
SMath.Math.Numeric Namespace


TSystem Implicit Conversion (TFraction to TSystem)

TSystem Conversion (TFraction to TSystem)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TSystem (
    TFraction value
)
Public Shared Widening Operator CType (
    value As TFraction
) As TSystem
static implicit operator TSystem^ (
    TFraction^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTFraction

Return Value

Type: TSystem
See Also

Reference

TSystem Class
Overload
SMath.Math.Numeric Namespace


TSystem Implicit Conversion (TInfinity to TSystem)

TSystem Conversion (TInfinity to TSystem)

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static implicit operator TSystem (
    TInfinity value
)
Public Shared Widening Operator CType (
    value As TInfinity
) As TSystem
static implicit operator TSystem^ (
    TInfinity^ value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.NumericTInfinity

Return Value

Type: TSystem
See Also

Reference

TSystem Class
Overload
SMath.Math.Numeric Namespace


TSystem.Inequality Operator

TSystemInequality Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    TSystem c1,
    TSystem c2
)
Public Shared Operator <> (
    c1 As TSystem,
    c2 As TSystem
) As Boolean
public:
static bool operator !=(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (<>)
        c1 : TSystem *
        c2 : TSystem  : bool

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: Boolean
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Multiply Operator

TSystemMultiply Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator *(
    TSystem c1,
    TSystem c2
)
Public Shared Operator * (
    c1 As TSystem,
    c2 As TSystem
) As TNumber
public:
static TNumber^ operator *(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (*)
        c1 : TSystem *
        c2 : TSystem  : TNumber

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.Subtraction Operator

TSystemSubtraction Operator

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public static TNumber operator -(
    TSystem c1,
    TSystem c2
)
Public Shared Operator - (
    c1 As TSystem,
    c2 As TSystem
) As TNumber
public:
static TNumber^ operator -(
    TSystem^ c1,
    TSystem^ c2
)
static let inline (-)
        c1 : TSystem *
        c2 : TSystem  : TNumber

Parameters

c1
Type: SMath.Math.NumericTSystem
c2
Type: SMath.Math.NumericTSystem

Return Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem Fields

The TSystem type exposes the following members.

Fields
 | Name | Description
Public field | matrix |
Top
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


TSystem.matrix Field

TSystemmatrix Field

Namespace: SMath.Math.Numeric
Assembly: SMath.Math.Numeric (in SMath.Math.Numeric.dll) Version: 1.67
Syntax
C#
VB
C++
F#
Copy
public readonly TNumber[] matrix
Public ReadOnly matrix As TNumber()
public:
initonly array<TNumber^>^ matrix
val matrix: TNumber[]

Field Value

Type: TNumber
See Also

Reference

TSystem Class
SMath.Math.Numeric Namespace


SMath.Math.Symbolic Namespace

Classes
 | Class | Description
Public class | BasicRules | Represents methods to perform basic pre- and post- simplification transformation.Предоставляет методы для совершения простейших преобразований до и после упрощения.
Public class | Constants | Symbolic constants.Символьные константы.
Public class | Converter |
Public class | Expansion | Symbolic expression preprocessing methods to use before the simplification.Предварительная подготовка выражения к последующим упрощениям.
Public class | Expression |
Public class | MItem | Symbolic representation of the mathematical expression.Математическое выражение в символьном виде.
Public class | MMatrix | Symbolic representation of the Matrix.Матрица в символьном виде.


BasicRules Class

Represents methods to perform basic pre- and post- simplification transformation.Предоставляет методы для совершения простейших преобразований до и после упрощения.
Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicBasicRules

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class BasicRules
Public Class BasicRules
public ref class BasicRules
type BasicRules =  class end

The BasicRules type exposes the following members.

Constructors
 | Name | Description
Public method | BasicRules | Initializes a new instance of the BasicRules class
Top
Methods
 | Name | Description
 | Compose | Actions required to compose expression after the simplification is finished.Применение правил преобразования математического выражения после основного упрощения.
 | Decompose | Actions required to decompose expression before the simplification will be started.Применение правил преобразования математического выражения до основного упрощения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryApplyRule | Применения правила преобразования.
Top
See Also

Reference

SMath.Math.Symbolic Namespace


BasicRules Constructor

Initializes a new instance of the BasicRules class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public BasicRules()
Public Sub New
public:
BasicRules()
new : unit -> BasicRules
See Also

Reference

BasicRules Class
SMath.Math.Symbolic Namespace


BasicRules Methods

The BasicRules type exposes the following members.

Methods
 | Name | Description
 | Compose | Actions required to compose expression after the simplification is finished.Применение правил преобразования математического выражения после основного упрощения.
 | Decompose | Actions required to decompose expression before the simplification will be started.Применение правил преобразования математического выражения до основного упрощения.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryApplyRule | Применения правила преобразования.
Top
See Also

Reference

BasicRules Class
SMath.Math.Symbolic Namespace


BasicRules.Compose Method

BasicRulesCompose Method

Actions required to compose expression after the simplification is finished.Применение правил преобразования математического выражения после основного упрощения.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Compose(
    MItem item
)
Public Shared Function Compose (
    item As MItem
) As MItem
public:
static MItem^ Compose(
    MItem^ item
)
static member Compose :
        item : MItem -> MItem

Parameters

item
Type: SMath.Math.SymbolicMItem
Expression to process.Выражение для преобразований.

Return Value

Type: MItem
Processed expression.Преобразованное выражение.
See Also

Reference

BasicRules Class
SMath.Math.Symbolic Namespace


BasicRules.Decompose Method

BasicRulesDecompose Method

Actions required to decompose expression before the simplification will be started.Применение правил преобразования математического выражения до основного упрощения.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Decompose(
    MItem item
)
Public Shared Function Decompose (
    item As MItem
) As MItem
public:
static MItem^ Decompose(
    MItem^ item
)
static member Decompose :
        item : MItem -> MItem

Parameters

item
Type: SMath.Math.SymbolicMItem
Expression to process.Выражение для преобразований.

Return Value

Type: MItem
Processed expression.Преобразованное выражение.
See Also

Reference

BasicRules Class
SMath.Math.Symbolic Namespace


BasicRules.TryApplyRule Method

BasicRulesTryApplyRule Method

Применения правила преобразования.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static bool TryApplyRule(
    MItem value,
    MItem ruleIn,
    MItem ruleOut,
    bool recursive,
    out MItem result
)
Public Shared Function TryApplyRule (
    value As MItem,
    ruleIn As MItem,
    ruleOut As MItem,
    recursive As Boolean,
    <OutAttribute> ByRef result As MItem
) As Boolean
public:
static bool TryApplyRule(
    MItem^ value,
    MItem^ ruleIn,
    MItem^ ruleOut,
    bool recursive,
    [OutAttribute] MItem^% result
)
static member TryApplyRule :
        value : MItem *
        ruleIn : MItem *
        ruleOut : MItem *
        recursive : bool *
        result : MItem byref -> bool

Parameters

value
Type: SMath.Math.SymbolicMItem
Математическое выражение для преобразований.
ruleIn
Type: SMath.Math.SymbolicMItem
Левая часть равенства для проверки на соответствие.
ruleOut
Type: SMath.Math.SymbolicMItem
Правая часть равенства для составления итогового выражения.
recursive
Type: SystemBoolean
result
Type: SMath.Math.SymbolicMItem

Return Value

Type: Boolean
Результат применения правила к математическому выражению.
See Also

Reference

BasicRules Class
SMath.Math.Symbolic Namespace


Constants Class

Symbolic constants.Символьные константы.
Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicConstants

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class Constants
Public Class Constants
public ref class Constants
type Constants =  class end

The Constants type exposes the following members.

Constructors
 | Name | Description
Public method | Constants | Initializes a new instance of the Constants class
Top
Properties
Name | Description
OneCopy | New instance of One represented by the symbolic term.Новый экземпляр значения Единица, представленная символьно.
TwoCopy | New instance of Number two represented by the symbolic term.Новый экземпляр значения Двойка, представленная символьно.
ZeroCopy | New instance of Zero represented by the symbolic term.Новый экземпляр значения Ноль, представленный символьно.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
One | One represented by the symbolic term.Единица, представленная символьно.
Two | Number two represented by the symbolic term.Двойка, представленная символьно.
Zero | Zero represented by the symbolic term.Ноль, представленный символьно.
Top
See Also

Reference

SMath.Math.Symbolic Namespace


Constants Constructor

Initializes a new instance of the Constants class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Constants()
Public Sub New
public:
Constants()
new : unit -> Constants
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants Properties

The Constants type exposes the following members.

Properties
Name | Description
OneCopy | New instance of One represented by the symbolic term.Новый экземпляр значения Единица, представленная символьно.
TwoCopy | New instance of Number two represented by the symbolic term.Новый экземпляр значения Двойка, представленная символьно.
ZeroCopy | New instance of Zero represented by the symbolic term.Новый экземпляр значения Ноль, представленный символьно.
Top
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.OneCopy Property

ConstantsOneCopy Property

New instance of One represented by the symbolic term.Новый экземпляр значения Единица, представленная символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem OneCopy { get; }
Public Shared ReadOnly Property OneCopy As MItem
    Get
public:
static property MItem^ OneCopy {
    MItem^ get ();
}
static member OneCopy : MItem with get

Property Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.TwoCopy Property

ConstantsTwoCopy Property

New instance of Number two represented by the symbolic term.Новый экземпляр значения Двойка, представленная символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem TwoCopy { get; }
Public Shared ReadOnly Property TwoCopy As MItem
    Get
public:
static property MItem^ TwoCopy {
    MItem^ get ();
}
static member TwoCopy : MItem with get

Property Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.ZeroCopy Property

ConstantsZeroCopy Property

New instance of Zero represented by the symbolic term.Новый экземпляр значения Ноль, представленный символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem ZeroCopy { get; }
Public Shared ReadOnly Property ZeroCopy As MItem
    Get
public:
static property MItem^ ZeroCopy {
    MItem^ get ();
}
static member ZeroCopy : MItem with get

Property Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants Methods

The Constants type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants Fields

The Constants type exposes the following members.

Fields
Name | Description
One | One represented by the symbolic term.Единица, представленная символьно.
Two | Number two represented by the symbolic term.Двойка, представленная символьно.
Zero | Zero represented by the symbolic term.Ноль, представленный символьно.
Top
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.One Field

ConstantsOne Field

One represented by the symbolic term.Единица, представленная символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static readonly MItem One
Public Shared ReadOnly One As MItem
public:
static initonly MItem^ One
static val One: MItem

Field Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.Two Field

ConstantsTwo Field

Number two represented by the symbolic term.Двойка, представленная символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static readonly MItem Two
Public Shared ReadOnly Two As MItem
public:
static initonly MItem^ Two
static val Two: MItem

Field Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Constants.Zero Field

ConstantsZero Field

Zero represented by the symbolic term.Ноль, представленный символьно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static readonly MItem Zero
Public Shared ReadOnly Zero As MItem
public:
static initonly MItem^ Zero
static val Zero: MItem

Field Value

Type: MItem
See Also

Reference

Constants Class
SMath.Math.Symbolic Namespace


Converter Class

Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicConverter

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class Converter
Public Class Converter
public ref class Converter
type Converter =  class end

The Converter type exposes the following members.

Constructors
 | Name | Description
Public method | Converter | Initializes a new instance of the Converter class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToMItem(String) | Конвертация из строки в MItem
 | ToMItem(Entry) | Конвертация из Entry в MItem
 | ToMItem(Term) | Конвертация из Term[] в MItem
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(MItem) | Obsolete. Конвертация из MItem в строку
Top
See Also

Reference

SMath.Math.Symbolic Namespace


Converter Constructor

Initializes a new instance of the Converter class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Converter()
Public Sub New
public:
Converter()
new : unit -> Converter
See Also

Reference

Converter Class
SMath.Math.Symbolic Namespace


Converter Methods

The Converter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToMItem(String) | Конвертация из строки в MItem
 | ToMItem(Entry) | Конвертация из Entry в MItem
 | ToMItem(Term) | Конвертация из Term[] в MItem
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(MItem) | Obsolete. Конвертация из MItem в строку
Top
See Also

Reference

Converter Class
SMath.Math.Symbolic Namespace


Converter.ToMItem Method

ConverterToMItem Method

Overload List
Name | Description
ToMItem(String) | Конвертация из строки в MItem
ToMItem(Entry) | Конвертация из Entry в MItem
ToMItem(Term) | Конвертация из Term[] в MItem
Top
See Also

Reference

Converter Class
SMath.Math.Symbolic Namespace


Converter.ToMItem Method (String)

ConverterToMItem Method (String)

Конвертация из строки в MItem

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem ToMItem(
    string value
)
Public Shared Function ToMItem (
    value As String
) As MItem
public:
static MItem^ ToMItem(
    String^ value
)
static member ToMItem :
        value : string -> MItem

Parameters

value
Type: SystemString
Строка математического выражения

Return Value

Type: MItem
Результат перевода выражения
See Also

Reference

Converter Class
ToMItem Overload
SMath.Math.Symbolic Namespace


Converter.ToMItem Method (Entry)

ConverterToMItem Method (Entry)

Конвертация из Entry в MItem

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem ToMItem(
    Entry value
)
Public Shared Function ToMItem (
    value As Entry
) As MItem
public:
static MItem^ ToMItem(
    Entry^ value
)
static member ToMItem :
        value : Entry -> MItem

Parameters

value
Type: SMath.ManagerEntry
Элементов Entry

Return Value

Type: MItem
Результат перевода выражения.
See Also

Reference

Converter Class
ToMItem Overload
SMath.Math.Symbolic Namespace


Converter.ToMItem Method (Term[])

ConverterToMItem Method (Term)

Конвертация из Term[] в MItem

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem ToMItem(
    Term[] value
)
Public Shared Function ToMItem (
    value As Term()
) As MItem
public:
static MItem^ ToMItem(
    array<Term^>^ value
)
static member ToMItem :
        value : Term[] -> MItem

Parameters

value
Type: SMath.ManagerTerm
Массив элементов Term

Return Value

Type: MItem
Результат перевода выражения.
See Also

Reference

Converter Class
ToMItem Overload
SMath.Math.Symbolic Namespace


Converter.ToString Method

ConverterToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToString(MItem) | Obsolete. Конвертация из MItem в строку
Top
See Also

Reference

Converter Class
SMath.Math.Symbolic Namespace


Converter.ToString Method (MItem)

ConverterToString Method (MItem)

Note: This API is now obsolete.

Конвертация из MItem в строку

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Use ToString() method of MItem instance instead.",
    false)]
public static string ToString(
    MItem value
)
<ObsoleteAttribute("Use ToString() method of MItem instance instead.",
    false)>
Public Shared Function ToString (
    value As MItem
) As String
public:
[ObsoleteAttribute(L"Use ToString() method of MItem instance instead.",
    false)]
static String^ ToString(
    MItem^ value
)
[<ObsoleteAttribute("Use ToString() method of MItem instance instead.",
    false)>]
static member ToString :
        value : MItem -> string

Parameters

value
Type: SMath.Math.SymbolicMItem
Математического выражения

Return Value

Type: String
Результат перевода выражения
See Also

Reference

Converter Class
ToString Overload
SMath.Math.Symbolic Namespace


Expansion Class

Symbolic expression preprocessing methods to use before the simplification.Предварительная подготовка выражения к последующим упрощениям.
Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicExpansion

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public sealed class Expansion
Public NotInheritable Class Expansion
public ref class Expansion sealed
[<SealedAttribute>]
type Expansion =  class end

The Expansion type exposes the following members.

Constructors
 | Name | Description
Public method | Expansion | Initializes a new instance of the Expansion class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expand | Expanding of the symbolic expression.Разложение выражения на простейшие слагаемые.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | Prepare | First preparing of the expression before simplification.Первичное преобразование выражения перед упрощением.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Math.Symbolic Namespace


Expansion Constructor

Initializes a new instance of the Expansion class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Expansion()
Public Sub New
public:
Expansion()
new : unit -> Expansion
See Also

Reference

Expansion Class
SMath.Math.Symbolic Namespace


Expansion Methods

The Expansion type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Expand | Expanding of the symbolic expression.Разложение выражения на простейшие слагаемые.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
 | Prepare | First preparing of the expression before simplification.Первичное преобразование выражения перед упрощением.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Expansion Class
SMath.Math.Symbolic Namespace


Expansion.Expand Method

ExpansionExpand Method

Expanding of the symbolic expression.Разложение выражения на простейшие слагаемые.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Expand(
    ref MItem value
)
Public Shared Function Expand (
    ByRef value As MItem
) As MItem
public:
static MItem^ Expand(
    MItem^% value
)
static member Expand :
        value : MItem byref -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
Expression to proceed.Выражение для преобразований.

Return Value

Type: MItem
Expanded expression.Разложенное на простейшие слагаемые выражение.
See Also

Reference

Expansion Class
SMath.Math.Symbolic Namespace


Expansion.Prepare Method

ExpansionPrepare Method

First preparing of the expression before simplification.Первичное преобразование выражения перед упрощением.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Prepare(
    MItem value
)
Public Shared Function Prepare (
    value As MItem
) As MItem
public:
static MItem^ Prepare(
    MItem^ value
)
static member Prepare :
        value : MItem -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
Expression to proceed.Выражение для преобразований.

Return Value

Type: MItem
Prepared expression.Преобразованное выражение.
See Also

Reference

Expansion Class
SMath.Math.Symbolic Namespace


Expression Class

Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicExpression

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class Expression
Public Class Expression
public ref class Expression
type Expression =  class end

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Methods
 | Name | Description
 | DifferentiateEx | Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SimplifyEx(Entry, ActionContext) |
 | SimplifyEx(MItem, ActionContext) | Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и последующими обратными преобразованиями для максимально удобного вывода ответа.
 | SimplifyEx(Term, ActionContext) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SMath.Math.Symbolic Namespace


Expression Constructor

Initializes a new instance of the Expression class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Expression()
Public Sub New
public:
Expression()
new : unit -> Expression
See Also

Reference

Expression Class
SMath.Math.Symbolic Namespace


Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
 | DifferentiateEx | Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SimplifyEx(Entry, ActionContext) |
 | SimplifyEx(MItem, ActionContext) | Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и последующими обратными преобразованиями для максимально удобного вывода ответа.
 | SimplifyEx(Term, ActionContext) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Expression Class
SMath.Math.Symbolic Namespace


Expression.DifferentiateEx Method

ExpressionDifferentiateEx Method

Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem DifferentiateEx(
    MItem value,
    MItem variable,
    ActionContext store
)
Public Shared Function DifferentiateEx (
    value As MItem,
    variable As MItem,
    store As ActionContext
) As MItem
public:
static MItem^ DifferentiateEx(
    MItem^ value,
    MItem^ variable,
    ActionContext^ store
)
static member DifferentiateEx :
        value : MItem *
        variable : MItem *
        store : ActionContext -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
variable
Type: SMath.Math.SymbolicMItem
store
Type: SMath.ManagerActionContext

Return Value

Type: MItem
See Also

Reference

Expression Class
SMath.Math.Symbolic Namespace


Expression.SimplifyEx Method

ExpressionSimplifyEx Method

Overload List
Name | Description
SimplifyEx(Entry, ActionContext) |
SimplifyEx(MItem, ActionContext) | Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и последующими обратными преобразованиями для максимально удобного вывода ответа.
SimplifyEx(Term, ActionContext) |
Top
See Also

Reference

Expression Class
SMath.Math.Symbolic Namespace


Expression.SimplifyEx Method (Entry, ActionContext)

ExpressionSimplifyEx Method (Entry, ActionContext)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem SimplifyEx(
    Entry value,
    ActionContext store
)
Public Shared Function SimplifyEx (
    value As Entry,
    store As ActionContext
) As MItem
public:
static MItem^ SimplifyEx(
    Entry^ value,
    ActionContext^ store
)
static member SimplifyEx :
        value : Entry *
        store : ActionContext -> MItem

Parameters

value
Type: SMath.ManagerEntry
store
Type: SMath.ManagerActionContext

Return Value

Type: MItem
See Also

Reference

Expression Class
SimplifyEx Overload
SMath.Math.Symbolic Namespace


Expression.SimplifyEx Method (MItem, ActionContext)

ExpressionSimplifyEx Method (MItem, ActionContext)

Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и последующими обратными преобразованиями для максимально удобного вывода ответа.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem SimplifyEx(
    MItem value,
    ActionContext store
)
Public Shared Function SimplifyEx (
    value As MItem,
    store As ActionContext
) As MItem
public:
static MItem^ SimplifyEx(
    MItem^ value,
    ActionContext^ store
)
static member SimplifyEx :
        value : MItem *
        store : ActionContext -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
Выражение для упрощений.
store
Type: SMath.ManagerActionContext
Хранилище информации о выполняемом действии.

Return Value

Type: MItem
Результат преобразования выражения.
See Also

Reference

Expression Class
SimplifyEx Overload
SMath.Math.Symbolic Namespace


Expression.SimplifyEx Method (Term[], ActionContext)

ExpressionSimplifyEx Method (Term, ActionContext)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem SimplifyEx(
    Term[] value,
    ActionContext store
)
Public Shared Function SimplifyEx (
    value As Term(),
    store As ActionContext
) As MItem
public:
static MItem^ SimplifyEx(
    array<Term^>^ value,
    ActionContext^ store
)
static member SimplifyEx :
        value : Term[] *
        store : ActionContext -> MItem

Parameters

value
Type: SMath.ManagerTerm
store
Type: SMath.ManagerActionContext

Return Value

Type: MItem
See Also

Reference

Expression Class
SimplifyEx Overload
SMath.Math.Symbolic Namespace


MItem Class

Symbolic representation of the mathematical expression.Математическое выражение в символьном виде.
Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicMItem
SMath.Math.SymbolicMMatrix

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public class MItem : IPrimitive<MItem>,
    IPrimitive
Public Class MItem
    Implements IPrimitive(Of MItem), IPrimitive
public ref class MItem : IPrimitive<MItem^>,
    IPrimitive
type MItem =
    class
        interface IPrimitive<MItem>
        interface IPrimitive
    end

The MItem type exposes the following members.

Constructors
 | Name | Description
Public method | MItem(Double) | Automatically supports positive and negative values.
Public method | MItem(MItem) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(Double, Boolean, Boolean) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(MItem, Boolean, Boolean) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(MItem, String, NullableDouble, TermType, Boolean, Boolean) | Math element constructor.Конструктор математического элемента.
Top
Properties
 | Name | Description
Public property | ArgsCount |
Public property | Inverse | Флаг-индикатор обратного элемента.
Public property | Item | Элемент по его порядковому номеру.
Public property | Items | Зависимые элементы текущего математического элемента.
Public property | Negative | Знак математического элемента.
Public property | Text |
Public property | Type |
Public property | Value |
Top
Methods
 | Name | Description
Public method | ContainsSymbolicEntries |
Public method | ContainsUnits | Проверка символьного математического выражения на предмет наличия в нём единиц измерения.
Public method | ContainsVariable | Определяет, содержит ли выражение любую переменную.
Public method | ContainsVariable(ListMItem) | Проверка символьного математического выражения на предмет наличия в нём переменных.
 | Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
 | Create(MItem, String, NullableDouble, TermType, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
Public method | Equals | Проверка выражений на идентичность. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDenominatorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе).
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Overrides ObjectGetHashCode.)
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности.
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе).
Public method | GetRevertedEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVariablesList | Получение списка переменных, представленных в математическом выражении.
Public method | IsDouble | Метод определяющий является ли математический элемент числом или нет.
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится не поэлементно - проверяются значения выражений, а не их идентичность в записи.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDouble | Конвертирование элемента в число.
Public method | ToEntry | Converts current symbolic equation to Entry object.
Public method | ToRevertedList |
Public method | ToString | Converts current symbolic equation to string representation.Строковое представление математического выражения. (Overrides ObjectToString.)
Public method | ToTerms | Converts current symbolic equation to the array of Terms.Представление символьного математического выражения в виде массива Term.
Public method | ToTermsList | Converts current symbolic equation to the list of Terms.
Top
Operators
Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
(Double to MItem) |
Inequality |
Multiply |
Subtraction |
UnaryNegation |
Top
See Also

Reference

SMath.Math.Symbolic Namespace


MItem Constructor

Overload List
 | Name | Description
Public method | MItem(Double) | Automatically supports positive and negative values.
Public method | MItem(MItem) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(Double, Boolean, Boolean) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(MItem, Boolean, Boolean) | Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.
Public method | MItem(MItem, String, NullableDouble, TermType, Boolean, Boolean) | Math element constructor.Конструктор математического элемента.
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem Constructor (Double)

Automatically supports positive and negative values.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem(
    double value
)
Public Sub New (
    value As Double
)
public:
MItem(
    double value
)
new :
        value : float -> MItem

Parameters

value
Type: SystemDouble
Value to store.
See Also

Reference

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (MItem)

Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem(
    MItem value
)
Public Sub New (
    value As MItem
)
public:
MItem(
    MItem^ value
)
new :
        value : MItem -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
Math element to copy.Математический элемент для копирования.
See Also

Reference

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (Double, Boolean, Boolean)

Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem(
    double value,
    bool changeNegative,
    bool changeInverse
)
Public Sub New (
    value As Double,
    changeNegative As Boolean,
    changeInverse As Boolean
)
public:
MItem(
    double value,
    bool changeNegative,
    bool changeInverse
)
new :
        value : float *
        changeNegative : bool *
        changeInverse : bool -> MItem

Parameters

value
Type: SystemDouble
Math element to copy.Математический элемент для копирования.
changeNegative
Type: SystemBoolean
changeInverse
Type: SystemBoolean
See Also

Reference

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (MItem, Boolean, Boolean)

Math element constructor. Copies existing element content.Конструктор математического элемента. Копирует содержимое существующего элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem(
    MItem value,
    bool changeNegative,
    bool changeInverse
)
Public Sub New (
    value As MItem,
    changeNegative As Boolean,
    changeInverse As Boolean
)
public:
MItem(
    MItem^ value,
    bool changeNegative,
    bool changeInverse
)
new :
        value : MItem *
        changeNegative : bool *
        changeInverse : bool -> MItem

Parameters

value
Type: SMath.Math.SymbolicMItem
Math element to copy.Математический элемент для копирования.
changeNegative
Type: SystemBoolean
changeInverse
Type: SystemBoolean
See Also

Reference

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (MItem[], String, Nullable(Double), TermType, Boolean, Boolean)

MItem Constructor (MItem, String, NullableDouble, TermType, Boolean, Boolean)

Math element constructor.Конструктор математического элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem(
    MItem[] items,
    string text,
    Nullable<double> value,
    TermType type,
    bool negative,
    bool inverse
)
Public Sub New (
    items As MItem(),
    text As String,
    value As Nullable(Of Double),
    type As TermType,
    negative As Boolean,
    inverse As Boolean
)
public:
MItem(
    array<MItem^>^ items,
    String^ text,
    Nullable<double> value,
    TermType type,
    bool negative,
    bool inverse
)
new :
        items : MItem[] *
        text : string *
        value : Nullable<float> *
        type : TermType *
        negative : bool *
        inverse : bool -> MItem

Parameters

items
Type: SMath.Math.SymbolicMItem
Зависимые элементы.
text
Type: SystemString
Текстовое представление математического элемента.
value
Type: SystemNullableDouble
Числовое представление математического элемента.
type
Type: SMath.ManagerTermType
Тип математического элемента.
negative
Type: SystemBoolean
Знак математического элемента.
inverse
Type: SystemBoolean
Флаг-индикатор обратного элемента.
See Also

Reference

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Properties

The MItem type exposes the following members.

Properties
 | Name | Description
Public property | ArgsCount |
Public property | Inverse | Флаг-индикатор обратного элемента.
Public property | Item | Элемент по его порядковому номеру.
Public property | Items | Зависимые элементы текущего математического элемента.
Public property | Negative | Знак математического элемента.
Public property | Text |
Public property | Type |
Public property | Value |
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ArgsCount Property

MItemArgsCount Property

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public int ArgsCount { get; }
Public ReadOnly Property ArgsCount As Integer
    Get
public:
virtual property int ArgsCount {
    int get () sealed;
}
abstract ArgsCount : int with get
override ArgsCount : int with get

Property Value

Type: Int32

Implements

IPrimitiveArgsCount
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Inverse Property

MItemInverse Property

Флаг-индикатор обратного элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool Inverse { get; set; }
Public Property Inverse As Boolean
    Get
    Set
public:
property bool Inverse {
    bool get ();
    void set (bool value);
}
member Inverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Item Property

MItemItem Property

Элемент по его порядковому номеру.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem this[
    int Index
] { get; }
Public ReadOnly Default Property Item (
    Index As Integer
) As MItem
    Get
public:
property MItem^ default[int Index] {
    MItem^ get (int Index);
}
member Item : MItem with get

Parameters

Index
Type: SystemInt32
Порядковый номер элемента.

Return Value

Type: MItem
Элемент символьного выражения.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Items Property

MItemItems Property

Зависимые элементы текущего математического элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem[] Items { get; }
Public ReadOnly Property Items As MItem()
    Get
public:
virtual property array<MItem^>^ Items {
    array<MItem^>^ get () sealed;
}
abstract Items : MItem[] with get
override Items : MItem[] with get

Property Value

Type: MItem

Implements

IPrimitiveTItems
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Negative Property

MItemNegative Property

Знак математического элемента.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool Negative { get; set; }
Public Property Negative As Boolean
    Get
    Set
public:
property bool Negative {
    bool get ();
    void set (bool value);
}
member Negative : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Text Property

MItemText Property

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
virtual property String^ Text {
    String^ get () sealed;
}
abstract Text : string with get
override Text : string with get

Property Value

Type: String

Implements

IPrimitiveText
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Type Property

MItemType Property

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public TermType Type { get; }
Public ReadOnly Property Type As TermType
    Get
public:
virtual property TermType Type {
    TermType get () sealed;
}
abstract Type : TermType with get
override Type : TermType with get

Property Value

Type: TermType

Implements

IPrimitiveType
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Value Property

MItemValue Property

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> Value { get; }
Public ReadOnly Property Value As Nullable(Of Double)
    Get
public:
property Nullable<double> Value {
    Nullable<double> get ();
}
member Value : Nullable<float> with get

Property Value

Type: NullableDouble
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem Methods

The MItem type exposes the following members.

Methods
 | Name | Description
Public method | ContainsSymbolicEntries |
Public method | ContainsUnits | Проверка символьного математического выражения на предмет наличия в нём единиц измерения.
Public method | ContainsVariable | Определяет, содержит ли выражение любую переменную.
Public method | ContainsVariable(ListMItem) | Проверка символьного математического выражения на предмет наличия в нём переменных.
 | Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
 | Create(MItem, String, NullableDouble, TermType, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
Public method | Equals | Проверка выражений на идентичность. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDenominatorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе).
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Overrides ObjectGetHashCode.)
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности.
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе).
Public method | GetRevertedEnumerator |
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVariablesList | Получение списка переменных, представленных в математическом выражении.
Public method | IsDouble | Метод определяющий является ли математический элемент числом или нет.
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится не поэлементно - проверяются значения выражений, а не их идентичность в записи.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDouble | Конвертирование элемента в число.
Public method | ToEntry | Converts current symbolic equation to Entry object.
Public method | ToRevertedList |
Public method | ToString | Converts current symbolic equation to string representation.Строковое представление математического выражения. (Overrides ObjectToString.)
Public method | ToTerms | Converts current symbolic equation to the array of Terms.Представление символьного математического выражения в виде массива Term.
Public method | ToTermsList | Converts current symbolic equation to the list of Terms.
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ContainsSymbolicEntries Method

MItemContainsSymbolicEntries Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool ContainsSymbolicEntries()
Public Function ContainsSymbolicEntries As Boolean
public:
bool ContainsSymbolicEntries()
member ContainsSymbolicEntries : unit -> bool

Return Value

Type: Boolean
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ContainsUnits Method

MItemContainsUnits Method

Проверка символьного математического выражения на предмет наличия в нём единиц измерения.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool ContainsUnits()
Public Function ContainsUnits As Boolean
public:
bool ContainsUnits()
member ContainsUnits : unit -> bool

Return Value

Type: Boolean
Возвращает результат проверки математического выражения на предмет наличия в нём хотя бы одной единицы измерения.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ContainsVariable Method

MItemContainsVariable Method

Overload List
 | Name | Description
Public method | ContainsVariable | Определяет, содержит ли выражение любую переменную.
Public method | ContainsVariable(ListMItem) | Проверка символьного математического выражения на предмет наличия в нём переменных.
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ContainsVariable Method

MItemContainsVariable Method

Определяет, содержит ли выражение любую переменную.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool ContainsVariable()
Public Function ContainsVariable As Boolean
public:
bool ContainsVariable()
member ContainsVariable : unit -> bool

Return Value

Type: Boolean
Результат определения.
See Also

Reference

MItem Class
ContainsVariable Overload
SMath.Math.Symbolic Namespace


MItem.ContainsVariable Method (List(MItem))

MItemContainsVariable Method (ListMItem)

Проверка символьного математического выражения на предмет наличия в нём переменных.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool ContainsVariable(
    List<MItem> variables
)
Public Function ContainsVariable (
    variables As List(Of MItem)
) As Boolean
public:
bool ContainsVariable(
    List<MItem^>^ variables
)
member ContainsVariable :
        variables : List<MItem> -> bool

Parameters

variables
Type: System.Collections.GenericListMItem
Список переменных для проверки.

Return Value

Type: Boolean
Возвращает результат проверки математического выражения на предмет наличия в нём хотя бы одной переменной из переданного списка.
See Also

Reference

MItem Class
ContainsVariable Overload
SMath.Math.Symbolic Namespace


MItem.Create Method

MItemCreate Method

Overload List
Name | Description
Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
Create(MItem, String, NullableDouble, TermType, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Create Method (MItem)

MItemCreate Method (MItem)

Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Create(
    MItem item
)
Public Shared Function Create (
    item As MItem
) As MItem
public:
static MItem^ Create(
    MItem^ item
)
static member Create :
        item : MItem -> MItem

Parameters

item
Type: SMath.Math.SymbolicMItem
Прототип создаваемого элемента.

Return Value

Type: MItem
Возвращает созданный математический элемент.
See Also

Reference

MItem Class
Create Overload
SMath.Math.Symbolic Namespace


MItem.Create Method (MItem[], String, Nullable(Double), TermType, Boolean, Boolean)

MItemCreate Method (MItem, String, NullableDouble, TermType, Boolean, Boolean)

Создание математического элемента в зависимости от его наполнения. Создаётся элемент класса-наследника от MItem если это возможно.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem Create(
    MItem[] items,
    string text,
    Nullable<double> value,
    TermType type,
    bool negative,
    bool inverse
)
Public Shared Function Create (
    items As MItem(),
    text As String,
    value As Nullable(Of Double),
    type As TermType,
    negative As Boolean,
    inverse As Boolean
) As MItem
public:
static MItem^ Create(
    array<MItem^>^ items,
    String^ text,
    Nullable<double> value,
    TermType type,
    bool negative,
    bool inverse
)
static member Create :
        items : MItem[] *
        text : string *
        value : Nullable<float> *
        type : TermType *
        negative : bool *
        inverse : bool -> MItem

Parameters

items
Type: SMath.Math.SymbolicMItem
Коллекция зависимых элементов.
text
Type: SystemString
Текстовое представление математического элемента.
value
Type: SystemNullableDouble
Числовое представление математического элемента.
type
Type: SMath.ManagerTermType
Тип математического элемента.
negative
Type: SystemBoolean
Знак математического элемента.
inverse
Type: SystemBoolean
Флаг-индикатор обратного элемента.

Return Value

Type: MItem
Экземпляр математического элемента.
See Also

Reference

MItem Class
Create Overload
SMath.Math.Symbolic Namespace


MItem.Equals Method

MItemEquals Method

Проверка выражений на идентичность.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
Выражение для проверки.

Return Value

Type: Boolean
Результат проверки.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetDenominatorList Method

MItemGetDenominatorList Method

Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе).

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public List<MItem> GetDenominatorList()
Public Function GetDenominatorList As List(Of MItem)
public:
List<MItem^>^ GetDenominatorList()
member GetDenominatorList : unit -> List<MItem>

Return Value

Type: ListMItem
Возвращает все элементы находящиеся в знаменателе.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetHashCode Method

MItemGetHashCode Method

Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for the current Term.Хэш-код текущего типа.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetItemWithOptions Method

MItemGetItemWithOptions Method

Получение математического элемента без учёта его знака и/или обратности.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem GetItemWithOptions(
    bool unSigned,
    bool unInversed
)
Public Function GetItemWithOptions (
    unSigned As Boolean,
    unInversed As Boolean
) As MItem
public:
MItem^ GetItemWithOptions(
    bool unSigned,
    bool unInversed
)
member GetItemWithOptions :
        unSigned : bool *
        unInversed : bool -> MItem

Parameters

unSigned
Type: SystemBoolean
Не учитывать знак.
unInversed
Type: SystemBoolean
Не учитывать обратность.

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetNumeratorList Method

MItemGetNumeratorList Method

Получить все элементы положительной степени (элементы, находящиеся в числителе).

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public List<MItem> GetNumeratorList()
Public Function GetNumeratorList As List(Of MItem)
public:
List<MItem^>^ GetNumeratorList()
member GetNumeratorList : unit -> List<MItem>

Return Value

Type: ListMItem
Возвращает все элементы находящиеся в числителе.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetRevertedEnumerator Method

MItemGetRevertedEnumerator Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<MItem> GetRevertedEnumerator()
Public Function GetRevertedEnumerator As IEnumerable(Of MItem)
public:
IEnumerable<MItem^>^ GetRevertedEnumerator()
member GetRevertedEnumerator : unit -> IEnumerable<MItem>

Return Value

Type: IEnumerableMItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.GetVariablesList Method

MItemGetVariablesList Method

Получение списка переменных, представленных в математическом выражении.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public void GetVariablesList(
    ref List<MItem> variables
)
Public Sub GetVariablesList (
    ByRef variables As List(Of MItem)
)
public:
void GetVariablesList(
    List<MItem^>^% variables
)
member GetVariablesList :
        variables : List<MItem> byref -> unit

Parameters

variables
Type: System.Collections.GenericListMItem
Возвращает список переменных, представленных в математическом выражении.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.IsDouble Method

MItemIsDouble Method

Метод определяющий является ли математический элемент числом или нет.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDouble()
Public Overridable Function IsDouble As Boolean
public:
virtual bool IsDouble()
abstract IsDouble : unit -> bool
override IsDouble : unit -> bool

Return Value

Type: Boolean
Результат определения.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.MathEqual Method

MItemMathEqual Method

Проверка математических выражений на равенство. Проверка производится не поэлементно - проверяются значения выражений, а не их идентичность в записи.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public bool MathEqual(
    MItem value
)
Public Function MathEqual (
    value As MItem
) As Boolean
public:
bool MathEqual(
    MItem^ value
)
member MathEqual :
        value : MItem -> bool

Parameters

value
Type: SMath.Math.SymbolicMItem
Выражение для проверки.

Return Value

Type: Boolean
Результат проверки.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToDouble Method

MItemToDouble Method

Конвертирование элемента в число.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public virtual double ToDouble()
Public Overridable Function ToDouble As Double
public:
virtual double ToDouble()
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

Type: Double
Число - результат конвертирования.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToEntry Method

MItemToEntry Method

Converts current symbolic equation to Entry object.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Entry ToEntry()
Public Function ToEntry As Entry
public:
Entry^ ToEntry()
member ToEntry : unit -> Entry

Return Value

Type: Entry
Entry object with current symbolic equation.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToRevertedList Method

MItemToRevertedList Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public List<MItem> ToRevertedList()
Public Function ToRevertedList As List(Of MItem)
public:
virtual List<MItem^>^ ToRevertedList() sealed
abstract ToRevertedList : unit -> List<MItem>
override ToRevertedList : unit -> List<MItem>

Return Value

Type: ListMItem

Implements

IPrimitiveTToRevertedList
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToString Method

MItemToString Method

Converts current symbolic equation to string representation.Строковое представление математического выражения.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
String representation of current symbolic equation.Выражение, записанное в строку.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToTerms Method

MItemToTerms Method

Converts current symbolic equation to the array of Terms.Представление символьного математического выражения в виде массива Term.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public Term[] ToTerms()
Public Function ToTerms As Term()
public:
array<Term^>^ ToTerms()
member ToTerms : unit -> Term[]

Return Value

Type: Term
Array of Terms with current symbolic equation.Возвращает символьное математическое выражение в виде массива Term.
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ToTermsList Method

MItemToTermsList Method

Converts current symbolic equation to the list of Terms.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public List<Term> ToTermsList()
Public Function ToTermsList As List(Of Term)
public:
virtual List<Term^>^ ToTermsList() sealed
abstract ToTermsList : unit -> List<Term>
override ToTermsList : unit -> List<Term>

Return Value

Type: ListTerm
List of Terms with current symbolic equation.

Implements

IPrimitiveTToTermsList
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem Operators and Type Conversions

The MItem type exposes the following members.

Operators
Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
(Double to MItem) |
Inequality |
Multiply |
Subtraction |
UnaryNegation |
Top
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Addition Operator

MItemAddition Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator +(
    MItem c1,
    MItem c2
)
Public Shared Operator + (
    c1 As MItem,
    c2 As MItem
) As MItem
public:
static MItem^ operator +(
    MItem^ c1,
    MItem^ c2
)
static let inline (+)
        c1 : MItem *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Division Operator

MItemDivision Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator /(
    MItem c1,
    MItem c2
)
Public Shared Operator / (
    c1 As MItem,
    c2 As MItem
) As MItem
public:
static MItem^ operator /(
    MItem^ c1,
    MItem^ c2
)
static let inline (/)
        c1 : MItem *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Equality Operator

MItemEquality Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    MItem c1,
    MItem c2
)
Public Shared Operator = (
    c1 As MItem,
    c2 As MItem
) As Boolean
public:
static bool operator ==(
    MItem^ c1,
    MItem^ c2
)
static let inline (=)
        c1 : MItem *
        c2 : MItem  : bool

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: Boolean
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.ExclusiveOr Operator

MItemExclusiveOr Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator ^(
    MItem c1,
    MItem c2
)
Public Shared Operator Xor (
    c1 As MItem,
    c2 As MItem
) As MItem
public:
static MItem^ operator ^(
    MItem^ c1,
    MItem^ c2
)
static let inline (^^^)
        c1 : MItem *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem Implicit Conversion (Double to MItem)

MItem Conversion (Double to MItem)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static implicit operator MItem (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As MItem
static implicit operator MItem^ (
    double value
)
F# does not support the declaration of new casting operators.

Parameters

value
Type: SystemDouble

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Inequality Operator

MItemInequality Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    MItem c1,
    MItem c2
)
Public Shared Operator <> (
    c1 As MItem,
    c2 As MItem
) As Boolean
public:
static bool operator !=(
    MItem^ c1,
    MItem^ c2
)
static let inline (<>)
        c1 : MItem *
        c2 : MItem  : bool

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: Boolean
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Multiply Operator

MItemMultiply Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator *(
    MItem c1,
    MItem c2
)
Public Shared Operator * (
    c1 As MItem,
    c2 As MItem
) As MItem
public:
static MItem^ operator *(
    MItem^ c1,
    MItem^ c2
)
static let inline (*)
        c1 : MItem *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.Subtraction Operator

MItemSubtraction Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator -(
    MItem c1,
    MItem c2
)
Public Shared Operator - (
    c1 As MItem,
    c2 As MItem
) As MItem
public:
static MItem^ operator -(
    MItem^ c1,
    MItem^ c2
)
static let inline (-)
        c1 : MItem *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MItem.UnaryNegation Operator

MItemUnaryNegation Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator -(
    MItem c1
)
Public Shared Operator - (
    c1 As MItem
) As MItem
public:
static MItem^ operator -(
    MItem^ c1
)
static let inline (-)
        c1 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MItem Class
SMath.Math.Symbolic Namespace


MMatrix Class

Symbolic representation of the Matrix.Матрица в символьном виде.
Inheritance Hierarchy
SystemObject
SMath.Math.SymbolicMItem
SMath.Math.SymbolicMMatrix

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public sealed class MMatrix : MItem
Public NotInheritable Class MMatrix
    Inherits MItem
public ref class MMatrix sealed : public MItem
[<SealedAttribute>]
type MMatrix =
    class
        inherit MItem
    end

The MMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | MMatrix(MItem) | Initializes a new instance of the MMatrix class
Public method | MMatrix(MItem, Boolean, Boolean) | Initializes a new instance of the MMatrix class
Public method | MMatrix(Boolean, Boolean, Int32, Int32) | Initializes a new instance of the MMatrix class
Top
Properties
 | Name | Description
Public property | ArgsCount | (Inherited from MItem.)
Public property | Cols | Количество столбцов в матрице.
Public property | Inverse | Флаг-индикатор обратного элемента. (Inherited from MItem.)
Public property | ItemInt32 | Элемент по его порядковому номеру. (Inherited from MItem.)
Public property | ItemInt32, Int32 | Элемент матрицы, заданный по строке и столбцу.
Public property | Items | Зависимые элементы текущего математического элемента. (Inherited from MItem.)
Public property | Negative | Знак математического элемента. (Inherited from MItem.)
Public property | Rows | Количество строк в матрице.
Public property | Text | (Inherited from MItem.)
Public property | Type | (Inherited from MItem.)
Public property | Value | (Inherited from MItem.)
Top
Methods
 | Name | Description
Public method | Alg | Алгебраическое дополнение матрицы.
 | CheckForVar |
Public method | ContainsSymbolicEntries | (Inherited from MItem.)
Public method | ContainsUnits | Проверка символьного математического выражения на предмет наличия в нём единиц измерения. (Inherited from MItem.)
Public method | ContainsVariable | Определяет, содержит ли выражение любую переменную. (Inherited from MItem.)
Public method | ContainsVariable(ListMItem) | Проверка символьного математического выражения на предмет наличия в нём переменных. (Inherited from MItem.)
Public method | Determinant | Детерминант (определитель) матрицы.
Public method | Equals | Проверка выражений на идентичность. (Inherited from MItem.)
Public method | GetDenominatorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе). (Inherited from MItem.)
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Inherited from MItem.)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности. (Inherited from MItem.)
Public method | GetLength |
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе). (Inherited from MItem.)
Public method | GetRevertedEnumerator | (Inherited from MItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVariablesList | Получение списка переменных, представленных в математическом выражении. (Inherited from MItem.)
Public method | IsDouble | Метод определяющий является ли математический элемент числом или нет. (Inherited from MItem.)
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится не поэлементно - проверяются значения выражений, а не их идентичность в записи. (Inherited from MItem.)
Public method | Minor | Минор матрицы.
Public method | Rank | Ранг матрицы.
Public method | ToDouble | Конвертирование элемента в число. (Inherited from MItem.)
Public method | ToEntry | Converts current symbolic equation to Entry object. (Inherited from MItem.)
Public method | ToRevertedList | (Inherited from MItem.)
Public method | ToString | Converts current symbolic equation to string representation.Строковое представление математического выражения. (Inherited from MItem.)
Public method | ToTerms | Converts current symbolic equation to the array of Terms.Представление символьного математического выражения в виде массива Term. (Inherited from MItem.)
Public method | ToTermsList | Converts current symbolic equation to the list of Terms. (Inherited from MItem.)
Public method | Trace | След матрицы.
Public method | Transpose | Транспонирование матрицы.
Public method | VMinor | Не вычисленный минор матрицы (определитель).
Public method | VMultiplication |
Top
Operators
Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |
ExclusiveOr |
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |
Top
See Also

Reference

SMath.Math.Symbolic Namespace


MMatrix Constructor

Overload List
 | Name | Description
Public method | MMatrix(MItem) | Initializes a new instance of the MMatrix class
Public method | MMatrix(MItem, Boolean, Boolean) | Initializes a new instance of the MMatrix class
Public method | MMatrix(Boolean, Boolean, Int32, Int32) | Initializes a new instance of the MMatrix class
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Constructor (MItem)

Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix(
    MItem value
)
Public Sub New (
    value As MItem
)
public:
MMatrix(
    MItem^ value
)
new :
        value : MItem -> MMatrix

Parameters

value
Type: SMath.Math.SymbolicMItem
See Also

Reference

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Constructor (MItem[], Boolean, Boolean)

MMatrix Constructor (MItem, Boolean, Boolean)

Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix(
    MItem[] items,
    bool negative,
    bool inverse
)
Public Sub New (
    items As MItem(),
    negative As Boolean,
    inverse As Boolean
)
public:
MMatrix(
    array<MItem^>^ items,
    bool negative,
    bool inverse
)
new :
        items : MItem[] *
        negative : bool *
        inverse : bool -> MMatrix

Parameters

items
Type: SMath.Math.SymbolicMItem
negative
Type: SystemBoolean
inverse
Type: SystemBoolean
See Also

Reference

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Constructor (Boolean, Boolean, Int32, Int32)

Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix(
    bool negative,
    bool inverse,
    int rows,
    int cols
)
Public Sub New (
    negative As Boolean,
    inverse As Boolean,
    rows As Integer,
    cols As Integer
)
public:
MMatrix(
    bool negative,
    bool inverse,
    int rows,
    int cols
)
new :
        negative : bool *
        inverse : bool *
        rows : int *
        cols : int -> MMatrix

Parameters

negative
Type: SystemBoolean
inverse
Type: SystemBoolean
rows
Type: SystemInt32
cols
Type: SystemInt32
See Also

Reference

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Properties

The MMatrix type exposes the following members.

Properties
 | Name | Description
Public property | ArgsCount | (Inherited from MItem.)
Public property | Cols | Количество столбцов в матрице.
Public property | Inverse | Флаг-индикатор обратного элемента. (Inherited from MItem.)
Public property | ItemInt32 | Элемент по его порядковому номеру. (Inherited from MItem.)
Public property | ItemInt32, Int32 | Элемент матрицы, заданный по строке и столбцу.
Public property | Items | Зависимые элементы текущего математического элемента. (Inherited from MItem.)
Public property | Negative | Знак математического элемента. (Inherited from MItem.)
Public property | Rows | Количество строк в матрице.
Public property | Text | (Inherited from MItem.)
Public property | Type | (Inherited from MItem.)
Public property | Value | (Inherited from MItem.)
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Cols Property

MMatrixCols Property

Количество столбцов в матрице.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public int Cols { get; }
Public ReadOnly Property Cols As Integer
    Get
public:
property int Cols {
    int get ();
}
member Cols : int with get

Property Value

Type: Int32
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Item Property

MMatrixItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Элемент по его порядковому номеру. (Inherited from MItem.)
Public property | ItemInt32, Int32 | Элемент матрицы, заданный по строке и столбцу.
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Item Property (Int32, Int32)

MMatrixItem Property (Int32, Int32)

Элемент матрицы, заданный по строке и столбцу.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem this[
    int row,
    int col
] { get; set; }
Public Default Property Item (
    row As Integer,
    col As Integer
) As MItem
    Get
    Set
public:
property MItem^ default[int row, int col] {
    MItem^ get (int row, int col);
    void set (int row, int col, MItem^ value);
}
member Item : MItem with get, set

Parameters

row
Type: SystemInt32
Строка матрицы.
col
Type: SystemInt32
Столбец матрицы.

Return Value

Type: MItem
Элемент матрицы.
See Also

Reference

MMatrix Class
Item Overload
SMath.Math.Symbolic Namespace


MMatrix.Rows Property

MMatrixRows Property

Количество строк в матрице.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get
public:
property int Rows {
    int get ();
}
member Rows : int with get

Property Value

Type: Int32
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Methods

The MMatrix type exposes the following members.

Methods
 | Name | Description
Public method | Alg | Алгебраическое дополнение матрицы.
 | CheckForVar |
Public method | ContainsSymbolicEntries | (Inherited from MItem.)
Public method | ContainsUnits | Проверка символьного математического выражения на предмет наличия в нём единиц измерения. (Inherited from MItem.)
Public method | ContainsVariable | Определяет, содержит ли выражение любую переменную. (Inherited from MItem.)
Public method | ContainsVariable(ListMItem) | Проверка символьного математического выражения на предмет наличия в нём переменных. (Inherited from MItem.)
Public method | Determinant | Детерминант (определитель) матрицы.
Public method | Equals | Проверка выражений на идентичность. (Inherited from MItem.)
Public method | GetDenominatorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе). (Inherited from MItem.)
Public method | GetHashCode | Serves as a hash function for a particular type.Служит хэш-функцией для текущего типа. (Inherited from MItem.)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности. (Inherited from MItem.)
Public method | GetLength |
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе). (Inherited from MItem.)
Public method | GetRevertedEnumerator | (Inherited from MItem.)
Public method | GetType | Gets the type of the current instance. (Inherited from Object.)
Public method | GetVariablesList | Получение списка переменных, представленных в математическом выражении. (Inherited from MItem.)
Public method | IsDouble | Метод определяющий является ли математический элемент числом или нет. (Inherited from MItem.)
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится не поэлементно - проверяются значения выражений, а не их идентичность в записи. (Inherited from MItem.)
Public method | Minor | Минор матрицы.
Public method | Rank | Ранг матрицы.
Public method | ToDouble | Конвертирование элемента в число. (Inherited from MItem.)
Public method | ToEntry | Converts current symbolic equation to Entry object. (Inherited from MItem.)
Public method | ToRevertedList | (Inherited from MItem.)
Public method | ToString | Converts current symbolic equation to string representation.Строковое представление математического выражения. (Inherited from MItem.)
Public method | ToTerms | Converts current symbolic equation to the array of Terms.Представление символьного математического выражения в виде массива Term. (Inherited from MItem.)
Public method | ToTermsList | Converts current symbolic equation to the list of Terms. (Inherited from MItem.)
Public method | Trace | След матрицы.
Public method | Transpose | Транспонирование матрицы.
Public method | VMinor | Не вычисленный минор матрицы (определитель).
Public method | VMultiplication |
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Alg Method

MMatrixAlg Method

Алгебраическое дополнение матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem Alg(
    int row,
    int col
)
Public Function Alg (
    row As Integer,
    col As Integer
) As MItem
public:
MItem^ Alg(
    int row,
    int col
)
member Alg :
        row : int *
        col : int -> MItem

Parameters

row
Type: SystemInt32
Номер строки.
col
Type: SystemInt32
Номер столбца.

Return Value

Type: MItem
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.CheckForVar Method

MMatrixCheckForVar Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static bool CheckForVar(
    MItem item
)
Public Shared Function CheckForVar (
    item As MItem
) As Boolean
public:
static bool CheckForVar(
    MItem^ item
)
static member CheckForVar :
        item : MItem -> bool

Parameters

item
Type: SMath.Math.SymbolicMItem

Return Value

Type: Boolean
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Determinant Method

MMatrixDeterminant Method

Детерминант (определитель) матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem Determinant()
Public Function Determinant As MItem
public:
MItem^ Determinant()
member Determinant : unit -> MItem

Return Value

Type: MItem
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.GetInverse Method

MMatrixGetInverse Method

Обращение матрицы общего вида.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix GetInverse()
Public Function GetInverse As MMatrix
public:
MMatrix^ GetInverse()
member GetInverse : unit -> MMatrix

Return Value

Type: MMatrix
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.GetLength Method

MMatrixGetLength Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public int GetLength(
    int num
)
Public Function GetLength (
    num As Integer
) As Integer
public:
int GetLength(
    int num
)
member GetLength :
        num : int -> int

Parameters

num
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Minor Method

MMatrixMinor Method

Минор матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem Minor(
    int row,
    int col
)
Public Function Minor (
    row As Integer,
    col As Integer
) As MItem
public:
MItem^ Minor(
    int row,
    int col
)
member Minor :
        row : int *
        col : int -> MItem

Parameters

row
Type: SystemInt32
Номер строки.
col
Type: SystemInt32
Номер столбца.

Return Value

Type: MItem
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Rank Method

MMatrixRank Method

Ранг матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem Rank()
Public Function Rank As MItem
public:
MItem^ Rank()
member Rank : unit -> MItem

Return Value

Type: MItem
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Trace Method

MMatrixTrace Method

След матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MItem Trace()
Public Function Trace As MItem
public:
MItem^ Trace()
member Trace : unit -> MItem

Return Value

Type: MItem
След матрицы.
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Transpose Method

MMatrixTranspose Method

Транспонирование матрицы.

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix Transpose()
Public Function Transpose As MMatrix
public:
MMatrix^ Transpose()
member Transpose : unit -> MMatrix

Return Value

Type: MMatrix
Транспонированная матрица.
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.VMinor Method

MMatrixVMinor Method

Не вычисленный минор матрицы (определитель).

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix VMinor(
    int row,
    int col
)
Public Function VMinor (
    row As Integer,
    col As Integer
) As MMatrix
public:
MMatrix^ VMinor(
    int row,
    int col
)
member VMinor :
        row : int *
        col : int -> MMatrix

Parameters

row
Type: SystemInt32
Номер строки.
col
Type: SystemInt32
Номер столбца.

Return Value

Type: MMatrix
Определитель.
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.VMultiplication Method

MMatrixVMultiplication Method

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public MMatrix VMultiplication(
    MMatrix value
)
Public Function VMultiplication (
    value As MMatrix
) As MMatrix
public:
MMatrix^ VMultiplication(
    MMatrix^ value
)
member VMultiplication :
        value : MMatrix -> MMatrix

Parameters

value
Type: SMath.Math.SymbolicMMatrix

Return Value

Type: MMatrix
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Operators

The MMatrix type exposes the following members.

Operators
Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |
ExclusiveOr |
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Addition Operator

MMatrixAddition Operator

Overload List
Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Addition Operator (MItem, MMatrix)

MMatrixAddition Operator (MItem, MMatrix)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator +(
    MItem c1,
    MMatrix c2
)
Public Shared Operator + (
    c1 As MItem,
    c2 As MMatrix
) As MItem
public:
static MItem^ operator +(
    MItem^ c1,
    MMatrix^ c2
)
static let inline (+)
        c1 : MItem *
        c2 : MMatrix  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c2
Type: SMath.Math.SymbolicMMatrix

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


MMatrix.Addition Operator (MMatrix, MItem)

MMatrixAddition Operator (MMatrix, MItem)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator +(
    MMatrix c1,
    MItem c2
)
Public Shared Operator + (
    c1 As MMatrix,
    c2 As MItem
) As MItem
public:
static MItem^ operator +(
    MMatrix^ c1,
    MItem^ c2
)
static let inline (+)
        c1 : MMatrix *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMMatrix
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


MMatrix.Addition Operator (MMatrix, MMatrix)

MMatrixAddition Operator (MMatrix, MMatrix)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator +(
    MMatrix c1,
    MMatrix c2
)
Public Shared Operator + (
    c1 As MMatrix,
    c2 As MMatrix
) As MItem
public:
static MItem^ operator +(
    MMatrix^ c1,
    MMatrix^ c2
)
static let inline (+)
        c1 : MMatrix *
        c2 : MMatrix  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMMatrix
c2
Type: SMath.Math.SymbolicMMatrix

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


MMatrix.ExclusiveOr Operator

MMatrixExclusiveOr Operator

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator ^(
    MMatrix c1,
    MItem c2
)
Public Shared Operator Xor (
    c1 As MMatrix,
    c2 As MItem
) As MItem
public:
static MItem^ operator ^(
    MMatrix^ c1,
    MItem^ c2
)
static let inline (^^^)
        c1 : MMatrix *
        c2 : MItem  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMMatrix
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Multiply Operator

MMatrixMultiply Operator

Overload List
Name | Description
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |
Top
See Also

Reference

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix.Multiply Operator (MItem, MMatrix)

MMatrixMultiply Operator (MItem, MMatrix)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator *(
    MItem c1,
    MMatrix c22
)
Public Shared Operator * (
    c1 As MItem,
    c22 As MMatrix
) As MItem
public:
static MItem^ operator *(
    MItem^ c1,
    MMatrix^ c22
)
static let inline (*)
        c1 : MItem *
        c22 : MMatrix  : MItem

Parameters

c1
Type: SMath.Math.SymbolicMItem
c22
Type: SMath.Math.SymbolicMMatrix

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


MMatrix.Multiply Operator (MMatrix, MItem)

MMatrixMultiply Operator (MMatrix, MItem)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator *(
    MMatrix c11,
    MItem c2
)
Public Shared Operator * (
    c11 As MMatrix,
    c2 As MItem
) As MItem
public:
static MItem^ operator *(
    MMatrix^ c11,
    MItem^ c2
)
static let inline (*)
        c11 : MMatrix *
        c2 : MItem  : MItem

Parameters

c11
Type: SMath.Math.SymbolicMMatrix
c2
Type: SMath.Math.SymbolicMItem

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


MMatrix.Multiply Operator (MMatrix, MMatrix)

MMatrixMultiply Operator (MMatrix, MMatrix)

Namespace: SMath.Math.Symbolic
Assembly: SMath.Math.Symbolic (in SMath.Math.Symbolic.dll) Version: 1.35
Syntax
C#
VB
C++
F#
Copy
public static MItem operator *(
    MMatrix c11,
    MMatrix c22
)
Public Shared Operator * (
    c11 As MMatrix,
    c22 As MMatrix
) As MItem
public:
static MItem^ operator *(
    MMatrix^ c11,
    MMatrix^ c22
)
static let inline (*)
        c11 : MMatrix *
        c22 : MMatrix  : MItem

Parameters

c11
Type: SMath.Math.SymbolicMMatrix
c22
Type: SMath.Math.SymbolicMMatrix

Return Value

Type: MItem
See Also

Reference

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


Welcome to the SMath Studio project

This is a sample conceptual topic. You can use this as a starting point for adding more conceptual content to your help project.

Getting Started

To get started, add a documentation source to the project (a Visual Studio solution, project, or assembly and XML comments file). See the Getting Started topics in the Sandcastle Help File Builder's help file for more information. The following default items are included in this project:

  • ContentLayout.content - Use the content layout file to manage the conceptual content in the project and define its layout in the table of contents.

  • The .\Media folder - Place images in this folder that you will reference from conceptual content using medialLink or mediaLinkInline elements. If you will not have any images in the file, you may remove this folder.

  • The .\icons folder - This contains a default logo for the help file. You may replace it or remove it and the folder if not wanted. If removed or if you change the file name, update the Transform Args project properties page by removing or changing the filename in the logoFile transform argument. Note that unlike images referenced from conceptual topics, the logo file should have its BuildAction property set to Content.

  • The .\Content folder - Use this to store your conceptual topics. You may name the files and organize them however you like. One suggestion is to lay the files out on disk as you have them in the content layout file as shown in this project but the choice is yours. Files can be added via the Solution Explorer or from within the content layout file editor. Files must appear in the content layout file in order to be compiled into the help file.

See the Conceptual Content topics in the Sandcastle Help File Builder's help file for more information. See the Sandcastle MAML Guide for details on Microsoft Assistance Markup Language (MAML) which is used to create these topics.

See Also

Other Resources

Version History


Version History

The topics in this section describe the various changes made to the [TODO: Project Title] over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 0.97

  • [TODO: Add links to each specific version page]

See Also

Other Resources

Welcome to the SMath Studio project


Version 0.97

Version [TODO: Version] was released on [TODO: Date].

Changes in This Release

  • [TODO: Add change items here]

See Also

Other Resources

Version History