SMath.Control Namespace

[image]

SMath Studio Class Libraries Documantation
SMath.Control Namespace
Send Feedback

[Missing <summary> documentation for "N:SMath.Control"]

Classes

 | Class | Description
Public class | AreaControl |
Public class | CanvasControl | Элемент управления рабочего листа программы
Public class | CanvasInfo |
Public class | CanvasStatus |
Public class | CommonControl | Родитель всех элементов управления программы
Public class | CursorStatus |
Public class | DataFiles | English: Data file types manager.
Public class | ErrorControl |
Public class | FileType | English: Class to store metadata of the file type.
Public class | MathControl | Элемент интерфейса для создания и редактирования математического выражения
Public class | MathControl..::..DrawInfo | Вспомогательный класс. Предназначен для сохранения первых результатов обработки элементов формулы перед отрисовкой
Public class | MathControl..::..DrawMemory | Вспомогательный класс. Содержит исчерпывающую информацию для отрисовки математического выражения
Public class | PictureControl |
Public class | PlotControl |
Public class | Renderer | Элемент управления для отображения результатов вычисления класса Vertex
Public class | TextControl |
Public class | UnReDO_Common |

Interfaces

 | Interface | Description
Public interface | IPluginControlDrawing |
Public interface | IPluginHandleFileTypes | English: Base File Types handler Interface for SMath Studio Plugins.
Public interface | IPluginOpenFileTypes | English: Open File Types handler interface.
Public interface | IPluginSaveFileTypes | English: Save File Types handler interface.

Delegates

 | Delegate | Description
Public delegate | CanvasControl..::..ELHISTORYGUI |
Public delegate | ControlEvaluationStateEventHandler |
Public delegate | PageControlMajorChangeEventHandler |
Public delegate | PageStatusChangedEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | CalculateType | Определяет тип производимых вычислений
Public enumeration | CanvasEditStatus | Состояние страницы
Public enumeration | CanvasSelectionStatus | Выделение на листе
Public enumeration | ClipboardStatus | Статус буфера обмена
Public enumeration | ControlType |
Public enumeration | CtrlInSelection | Выделение внутри элемента листа
Public enumeration | CtrlsEvalutionState | Признак того, что выделенные выражения могут быть вычислены
Public enumeration | CtrlsOptimizationState | Признак того, что выделенные выражения оптимизированы
Public enumeration | CursorType | Вид курсора
Public enumeration | FileBehavior | English: Behaviors that can be applied to the file type.
Public enumeration | MouseEventType | Выбор типа реакции на движения мыши.
Public enumeration | PlotType | Выбор типа графика.
Public enumeration | RenderType | Выбор типа рисования графика.
Public enumeration | UnReDoStatus | Статус истории изменений
Public enumeration | UnReDoType | Тип шага истории изменений


AreaControl Class

[image]

SMath Studio Class Libraries Documantation
AreaControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.AreaControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class AreaControl : CommonControl
Visual Basic
Public Class AreaControl _
    Inherits CommonControl
Visual C++
public ref class AreaControl : public CommonControl
F#
type AreaControl =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..AreaControl

See Also

AreaControl Members
SMath.Control Namespace


AreaControl Members

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Members
AreaControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The AreaControl type exposes the following members.

Constructors

 | Name | Description
Public method | AreaControl()()()() |
Public method | AreaControl(AreaControl) |

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | Определение вида курсора (Inherited from CommonControl.)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Inherited from CommonControl.)
Public method | OnMouseUp | (Inherited from CommonControl.)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | collapsed |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | evaluate |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | top |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Evaluate |
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

AreaControl Class
SMath.Control Namespace


AreaControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Constructor
AreaControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AreaControl()()()() | Initializes a new instance of the AreaControl class
Public method | AreaControl(AreaControl) | Initializes a new instance of the AreaControl class

See Also

AreaControl Class
AreaControl Members
SMath.Control Namespace


AreaControl Constructor

[image]

SMath Studio Class Libraries Documantation
AreaControl Constructor
AreaControl Class See Also Send Feedback
Initializes a new instance of the AreaControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public AreaControl()
Visual Basic
Public Sub New
Visual C++
public:
AreaControl()
F#
new : unit -> AreaControl

See Also

AreaControl Class
AreaControl Overload
SMath.Control Namespace


AreaControl Constructor (AreaControl)

[image]

SMath Studio Class Libraries Documantation
AreaControl Constructor (AreaControl)
AreaControl Class See Also Send Feedback
Initializes a new instance of the AreaControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public AreaControl(
    AreaControl value
)
Visual Basic
Public Sub New ( _
    value As AreaControl _
)
Visual C++
public:
AreaControl(
    AreaControl^ value
)
F#
new :
        value:AreaControl -> AreaControl

Parameters

value
Type: SMath.Control..::..AreaControl

[Missing <param name="value"/> documentation for "M:SMath.Control.AreaControl.#ctor(SMath.Control.AreaControl)"]

See Also

AreaControl Class
AreaControl Overload
SMath.Control Namespace


AreaControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Fields
AreaControl Class See Also Send Feedback

The AreaControl type exposes the following members.

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | collapsed |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | evaluate |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | top |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

See Also

AreaControl Class
SMath.Control Namespace


collapsed Field

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..collapsed Field
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.AreaControl.collapsed"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool collapsed
Visual Basic
Public collapsed As Boolean
Visual C++
public:
bool collapsed
F#
val mutable collapsed: bool

See Also

AreaControl Class
SMath.Control Namespace


evaluate Field

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..evaluate Field
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.AreaControl.evaluate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool evaluate
Visual Basic
Public evaluate As Boolean
Visual C++
public:
bool evaluate
F#
val mutable evaluate: bool

See Also

AreaControl Class
SMath.Control Namespace


top Field

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..top Field
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.AreaControl.top"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool top
Visual Basic
Public top As Boolean
Visual C++
public:
bool top
F#
val mutable top: bool

See Also

AreaControl Class
SMath.Control Namespace


AreaControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Methods
AreaControl Class See Also Send Feedback

The AreaControl type exposes the following members.

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | Определение вида курсора (Inherited from CommonControl.)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Inherited from CommonControl.)
Public method | OnMouseUp | (Inherited from CommonControl.)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

See Also

AreaControl Class
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..Clone Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CommonControl Clone()
Visual Basic
Public Overrides Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone() override
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.AreaControl.Clone"]

See Also

AreaControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl..::..GetImage Method
AreaControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

AreaControl Class
AreaControl Members
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..OnMouseDown Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.AreaControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

AreaControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..OnPaint Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.AreaControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

AreaControl Class
SMath.Control Namespace


UndoRedoManager Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..UndoRedoManager Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.UndoRedoManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UndoRedoManager(
    string referer
)
Visual Basic
Public Overrides Sub UndoRedoManager ( _
    referer As String _
)
Visual C++
public:
virtual void UndoRedoManager(
    String^ referer
) override
F#
abstract UndoRedoManager :
        referer:string -> unit
override UndoRedoManager :
        referer:string -> unit

Parameters

referer
Type: System..::..String

[Missing <param name="referer"/> documentation for "M:SMath.Control.AreaControl.UndoRedoManager(System.String)"]

See Also

AreaControl Class
SMath.Control Namespace


UnReDoAccept Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..UnReDoAccept Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void UnReDoAccept(
    UnReDO_Common unReDo_Common
)
Visual Basic
Protected Overrides Sub UnReDoAccept ( _
    unReDo_Common As UnReDO_Common _
)
Visual C++
protected:
virtual void UnReDoAccept(
    UnReDO_Common^ unReDo_Common
) override
F#
abstract UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit
override UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit

Parameters

unReDo_Common
Type: SMath.Control..::..UnReDO_Common

[Missing <param name="unReDo_Common"/> documentation for "M:SMath.Control.AreaControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

See Also

AreaControl Class
SMath.Control Namespace


UnReInit Method

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..UnReInit Method
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.AreaControl.UnReInit"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UnReInit()
Visual Basic
Public Overrides Sub UnReInit
Visual C++
public:
virtual void UnReInit() override
F#
abstract UnReInit : unit -> unit
override UnReInit : unit -> unit

See Also

AreaControl Class
SMath.Control Namespace


AreaControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Properties
AreaControl Class See Also Send Feedback

The AreaControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Evaluate |
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

AreaControl Class
SMath.Control Namespace


Evaluate Property

[image]

SMath Studio Class Libraries Documantation
AreaControl..::..Evaluate Property
AreaControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.AreaControl.Evaluate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Evaluate { get; set; }
Visual Basic
Public Property Evaluate As Boolean
    Get
    Set
Visual C++
public:
property bool Evaluate {
    bool get ();
    void set (bool value);
}
F#
member Evaluate : bool with get, set

See Also

AreaControl Class
SMath.Control Namespace


AreaControl Events

[image] [image]

SMath Studio Class Libraries Documantation
AreaControl Events
AreaControl Class See Also Send Feedback

The AreaControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

AreaControl Class
SMath.Control Namespace


CalculateType Enumeration

[image]

SMath Studio Class Libraries Documantation
CalculateType Enumeration
See Also Send Feedback
Определяет тип производимых вычислений

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CalculateType
Visual Basic
Public Enumeration CalculateType
Visual C++
public enum class CalculateType
F#
type CalculateType

Members

Member name | Value | Description
Numeric | 0 | Численное вычисление
Symbolic | 1 | Символьное вычисление
Ending | 2 | Вычисление выпонено успешно - можно выходить из контрола

See Also

SMath.Control Namespace


CanvasControl Class

[image]

SMath Studio Class Libraries Documantation
CanvasControl Class
Members See Also Send Feedback
Элемент управления рабочего листа программы

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public sealed class CanvasControl : Control
Visual Basic
Public NotInheritable Class CanvasControl _
    Inherits Control
Visual C++
public ref class CanvasControl sealed : public Control
F#
[<SealedAttribute>]
type CanvasControl =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
SMath.Control..::..CanvasControl

See Also

CanvasControl Members
SMath.Control Namespace


CanvasControl Members

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl Members
CanvasControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The CanvasControl type exposes the following members.

Constructors

 | Name | Description
Public method | CanvasControl | Конструктор контрола

Methods

 | Name | Description
Public method | AbortReCalc |
Public method | CreateControl |
Protected method | Dispose | Деструктор контрола (Overrides Control..::..Dispose(Boolean).)
Public method | ElementCreater | Подписаться на все события элемента
Public method | GetCursorType | Определение вида курсора
Public method | GetEvalutionState |
Public method | GetOptimizationState |
Public method | Insert |
Public method | MoveControl |
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnMouseDown | Реакция на событие нажатия клавиши мыши (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | Реакция на событие движения курсора мыши над контролом (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Реакция на событие отпускания клавиши мыши (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Public method | OnMouseWheel |
Protected method | OnPaint | Реакция на событие отрисовки содержимого элемента управления (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Переопределён для избежания эффекта мерцания (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | Изменение размеров контрола (Overrides Control..::..OnResize(EventArgs).)
Public method | OpenXML(Stream, Boolean, Boolean) |
Public method | OpenXML(String, Boolean, Boolean) | Открытие XML структурированного файла SMath Studio
Public method | ReCalcInThread |
Public method | ReDo | Отмена последнего в стэке возврата на шаг назад в истории
Public method | RemoveControls | Удаление элементов с листа с пересчётом размеров листа и результатов вычислений, если необходимо. Так же состояния добавляются в историю изменений. Никаких дополнительных действий для завершения операции не требуется.
Public method | SaveToXML |
Public method | SetBorder |
Public method | SetColor |
Public method | SetCurrentTextLang |
Public method | SetEvalution |
Public method | SetLang |
Public method | SetOptimization |
Public method | SetSize |
Public method | UnDo | Возврат состояния листа в истории на один шаг назад

Fields

 | Name | Description
Public field | backFile |
Public field | canvasInfo |
Public field | ctrlSize |
Public field | drawGrid |
Public field | evalEnd |
Public field | evalStart |
Public field | evalThread |
Public field | gridSize |
Public field | homeFile |
Public field | localpath |
Public field | pageState |
Public field | selfFile |
Public field | title |

Properties

 | Name | Description
Public property | CanvasControls |
Public property | CanvasSize | Текущий размер видимой активной части листа без учёта места, занимаемого каретками прокрутки
Public property | Edited |
Public property | IsEvalutionInProgress |
Public property | IsSelected |

Events

 | Name | Description
Public event | onPageControlMajorChange |
Public event | onPageStatusChanged |

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl Constructor

[image]

SMath Studio Class Libraries Documantation
CanvasControl Constructor
CanvasControl Class See Also Send Feedback
Конструктор контрола

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasControl()
Visual Basic
Public Sub New
Visual C++
public:
CanvasControl()
F#
new : unit -> CanvasControl

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl Fields
CanvasControl Class See Also Send Feedback

The CanvasControl type exposes the following members.

Fields

 | Name | Description
Public field | backFile |
Public field | canvasInfo |
Public field | ctrlSize |
Public field | drawGrid |
Public field | evalEnd |
Public field | evalStart |
Public field | evalThread |
Public field | gridSize |
Public field | homeFile |
Public field | localpath |
Public field | pageState |
Public field | selfFile |
Public field | title |

See Also

CanvasControl Class
SMath.Control Namespace


backFile Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..backFile Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.backFile"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string backFile
Visual Basic
Public backFile As String
Visual C++
public:
String^ backFile
F#
val mutable backFile: string

See Also

CanvasControl Class
SMath.Control Namespace


canvasInfo Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..canvasInfo Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.canvasInfo"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Hashtable canvasInfo
Visual Basic
Public canvasInfo As Hashtable
Visual C++
public:
Hashtable^ canvasInfo
F#
val mutable canvasInfo: Hashtable

See Also

CanvasControl Class
SMath.Control Namespace


ctrlSize Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..ctrlSize Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.ctrlSize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int ctrlSize
Visual Basic
Public ctrlSize As Integer
Visual C++
public:
int ctrlSize
F#
val mutable ctrlSize: int

See Also

CanvasControl Class
SMath.Control Namespace


drawGrid Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..drawGrid Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.drawGrid"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool drawGrid
Visual Basic
Public drawGrid As Boolean
Visual C++
public:
bool drawGrid
F#
val mutable drawGrid: bool

See Also

CanvasControl Class
SMath.Control Namespace


evalEnd Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..evalEnd Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.evalEnd"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public DateTime evalEnd
Visual Basic
Public evalEnd As DateTime
Visual C++
public:
DateTime evalEnd
F#
val mutable evalEnd: DateTime

See Also

CanvasControl Class
SMath.Control Namespace


evalStart Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..evalStart Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.evalStart"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public DateTime evalStart
Visual Basic
Public evalStart As DateTime
Visual C++
public:
DateTime evalStart
F#
val mutable evalStart: DateTime

See Also

CanvasControl Class
SMath.Control Namespace


evalThread Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..evalThread Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.evalThread"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Thread evalThread
Visual Basic
Public evalThread As Thread
Visual C++
public:
Thread^ evalThread
F#
val mutable evalThread: Thread

See Also

CanvasControl Class
SMath.Control Namespace


gridSize Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..gridSize Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.gridSize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int gridSize
Visual Basic
Public gridSize As Integer
Visual C++
public:
int gridSize
F#
val mutable gridSize: int

See Also

CanvasControl Class
SMath.Control Namespace


homeFile Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..homeFile Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.homeFile"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string homeFile
Visual Basic
Public homeFile As String
Visual C++
public:
String^ homeFile
F#
val mutable homeFile: string

See Also

CanvasControl Class
SMath.Control Namespace


localpath Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..localpath Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.localpath"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string localpath
Visual Basic
Public localpath As String
Visual C++
public:
String^ localpath
F#
val mutable localpath: string

See Also

CanvasControl Class
SMath.Control Namespace


pageState Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..pageState Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.pageState"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasEditStatus pageState
Visual Basic
Public pageState As CanvasEditStatus
Visual C++
public:
CanvasEditStatus pageState
F#
val mutable pageState: CanvasEditStatus

See Also

CanvasControl Class
SMath.Control Namespace


selfFile Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..selfFile Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.selfFile"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string selfFile
Visual Basic
Public selfFile As String
Visual C++
public:
String^ selfFile
F#
val mutable selfFile: string

See Also

CanvasControl Class
SMath.Control Namespace


title Field

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..title Field
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasControl.title"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string[] title
Visual Basic
Public title As String()
Visual C++
public:
array<String^>^ title
F#
val mutable title: string[]

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl Methods
CanvasControl Class See Also Send Feedback

The CanvasControl type exposes the following members.

Methods

 | Name | Description
Public method | AbortReCalc |
Public method | CreateControl |
Protected method | Dispose | Деструктор контрола (Overrides Control..::..Dispose(Boolean).)
Public method | ElementCreater | Подписаться на все события элемента
Public method | GetCursorType | Определение вида курсора
Public method | GetEvalutionState |
Public method | GetOptimizationState |
Public method | Insert |
Public method | MoveControl |
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | (Overrides Control..::..OnKeyPress(KeyPressEventArgs).)
Protected method | OnKeyUp | (Overrides Control..::..OnKeyUp(KeyEventArgs).)
Protected method | OnMouseDown | Реакция на событие нажатия клавиши мыши (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | Реакция на событие движения курсора мыши над контролом (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | Реакция на событие отпускания клавиши мыши (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Public method | OnMouseWheel |
Protected method | OnPaint | Реакция на событие отрисовки содержимого элемента управления (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Переопределён для избежания эффекта мерцания (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | Изменение размеров контрола (Overrides Control..::..OnResize(EventArgs).)
Public method | OpenXML(Stream, Boolean, Boolean) |
Public method | OpenXML(String, Boolean, Boolean) | Открытие XML структурированного файла SMath Studio
Public method | ReCalcInThread |
Public method | ReDo | Отмена последнего в стэке возврата на шаг назад в истории
Public method | RemoveControls | Удаление элементов с листа с пересчётом размеров листа и результатов вычислений, если необходимо. Так же состояния добавляются в историю изменений. Никаких дополнительных действий для завершения операции не требуется.
Public method | SaveToXML |
Public method | SetBorder |
Public method | SetColor |
Public method | SetCurrentTextLang |
Public method | SetEvalution |
Public method | SetLang |
Public method | SetOptimization |
Public method | SetSize |
Public method | UnDo | Возврат состояния листа в истории на один шаг назад

See Also

CanvasControl Class
SMath.Control Namespace


AbortReCalc Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..AbortReCalc Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.AbortReCalc"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void AbortReCalc()
Visual Basic
Public Sub AbortReCalc
Visual C++
public:
void AbortReCalc()
F#
member AbortReCalc : unit -> unit

See Also

CanvasControl Class
SMath.Control Namespace


CreateControl Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..CreateControl Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.CreateControl(SMath.Control.CommonControl,System.Drawing.Point,System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CreateControl(
    CommonControl v,
    Point location,
    string uid
)
Visual Basic
Public Sub CreateControl ( _
    v As CommonControl, _
    location As Point, _
    uid As String _
)
Visual C++
public:
void CreateControl(
    CommonControl^ v,
    Point location,
    String^ uid
)
F#
member CreateControl :
        v:CommonControl *
        location:Point *
        uid:string -> unit

Parameters

v
Type: SMath.Control..::..CommonControl

[Missing <param name="v"/> documentation for "M:SMath.Control.CanvasControl.CreateControl(SMath.Control.CommonControl,System.Drawing.Point,System.String)"]

location
Type: System.Drawing..::..Point

[Missing <param name="location"/> documentation for "M:SMath.Control.CanvasControl.CreateControl(SMath.Control.CommonControl,System.Drawing.Point,System.String)"]

uid
Type: System..::..String

[Missing <param name="uid"/> documentation for "M:SMath.Control.CanvasControl.CreateControl(SMath.Control.CommonControl,System.Drawing.Point,System.String)"]

See Also

CanvasControl Class
SMath.Control Namespace


Dispose Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..Dispose Method
CanvasControl Class See Also Send Feedback
Деструктор контрола

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

CanvasControl Class
SMath.Control Namespace


ElementCreater Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..ElementCreater Method
CanvasControl Class See Also Send Feedback
Подписаться на все события элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int ElementCreater(
    CommonControl control,
    Point location,
    bool addToPage,
    bool postProcessing,
    bool makeCurrent,
    bool addToHistory
)
Visual Basic
Public Function ElementCreater ( _
    control As CommonControl, _
    location As Point, _
    addToPage As Boolean, _
    postProcessing As Boolean, _
    makeCurrent As Boolean, _
    addToHistory As Boolean _
) As Integer
Visual C++
public:
int ElementCreater(
    CommonControl^ control,
    Point location,
    bool addToPage,
    bool postProcessing,
    bool makeCurrent,
    bool addToHistory
)
F#
member ElementCreater :
        control:CommonControl *
        location:Point *
        addToPage:bool *
        postProcessing:bool *
        makeCurrent:bool *
        addToHistory:bool -> int

Parameters

control
Type: SMath.Control..::..CommonControl
Будущий элемент листа
location
Type: System.Drawing..::..Point
Будущее положение элемента на листе
addToPage
Type: System..::..Boolean
Определяет, будет ли элемент добавлен на лист (с пересчётом размера листа)
postProcessing
Type: System..::..Boolean
Включает сортировку элементов
makeCurrent
Type: System..::..Boolean
Определяет создаваемый элемент в качестве текущего, ставит в него фокус и удаляет красный крестик с листа
addToHistory
Type: System..::..Boolean
Определяет, будет ли произошедшее записано в историю изменений

Return Value

[Missing <returns> documentation for "M:SMath.Control.CanvasControl.ElementCreater(SMath.Control.CommonControl,System.Drawing.Point,System.Boolean,System.Boolean,System.Boolean,System.Boolean)"]

See Also

CanvasControl Class
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..GetCursorType Method
CanvasControl Class See Also Send Feedback
Определение вида курсора

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CursorStatus GetCursorType(
    MouseEventArgs e
)
Visual Basic
Public Function GetCursorType ( _
    e As MouseEventArgs _
) As CursorStatus
Visual C++
public:
CursorStatus^ GetCursorType(
    MouseEventArgs^ e
)
F#
member GetCursorType :
        e:MouseEventArgs -> CursorStatus

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Return Value

Вид курсора на основании его положения

See Also

CanvasControl Class
SMath.Control Namespace


GetEvalutionState Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..GetEvalutionState Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.GetEvalutionState"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CtrlsEvalutionState GetEvalutionState()
Visual Basic
Public Function GetEvalutionState As CtrlsEvalutionState
Visual C++
public:
CtrlsEvalutionState GetEvalutionState()
F#
member GetEvalutionState : unit -> CtrlsEvalutionState

Return Value

[Missing <returns> documentation for "M:SMath.Control.CanvasControl.GetEvalutionState"]

See Also

CanvasControl Class
SMath.Control Namespace


GetOptimizationState Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..GetOptimizationState Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.GetOptimizationState"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CtrlsOptimizationState GetOptimizationState()
Visual Basic
Public Function GetOptimizationState As CtrlsOptimizationState
Visual C++
public:
CtrlsOptimizationState GetOptimizationState()
F#
member GetOptimizationState : unit -> CtrlsOptimizationState

Return Value

[Missing <returns> documentation for "M:SMath.Control.CanvasControl.GetOptimizationState"]

See Also

CanvasControl Class
SMath.Control Namespace


Insert Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..Insert Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.Insert(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Insert(
    string value
)
Visual Basic
Public Sub Insert ( _
    value As String _
)
Visual C++
public:
void Insert(
    String^ value
)
F#
member Insert :
        value:string -> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Control.CanvasControl.Insert(System.String)"]

See Also

CanvasControl Class
SMath.Control Namespace


MoveControl Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..MoveControl Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.MoveControl(SMath.Control.CommonControl,System.Drawing.Point)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void MoveControl(
    CommonControl v,
    Point location
)
Visual Basic
Public Sub MoveControl ( _
    v As CommonControl, _
    location As Point _
)
Visual C++
public:
void MoveControl(
    CommonControl^ v,
    Point location
)
F#
member MoveControl :
        v:CommonControl *
        location:Point -> unit

Parameters

v
Type: SMath.Control..::..CommonControl

[Missing <param name="v"/> documentation for "M:SMath.Control.CanvasControl.MoveControl(SMath.Control.CommonControl,System.Drawing.Point)"]

location
Type: System.Drawing..::..Point

[Missing <param name="location"/> documentation for "M:SMath.Control.CanvasControl.MoveControl(SMath.Control.CommonControl,System.Drawing.Point)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnGotFocus Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnGotFocus Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OnGotFocus(System.EventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override
F#
abstract OnGotFocus :
        e:EventArgs -> unit
override OnGotFocus :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnGotFocus(System.EventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnKeyDown Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnKeyDown Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OnKeyDown(System.Windows.Forms.KeyEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override
F#
abstract OnKeyDown :
        e:KeyEventArgs -> unit
override OnKeyDown :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnKeyDown(System.Windows.Forms.KeyEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnKeyPress Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnKeyPress Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OnKeyPress(System.Windows.Forms.KeyPressEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnKeyPress(
    KeyPressEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyPress ( _
    e As KeyPressEventArgs _
)
Visual C++
protected:
virtual void OnKeyPress(
    KeyPressEventArgs^ e
) override
F#
abstract OnKeyPress :
        e:KeyPressEventArgs -> unit
override OnKeyPress :
        e:KeyPressEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyPressEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnKeyPress(System.Windows.Forms.KeyPressEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnKeyUp Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnKeyUp Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OnKeyUp(System.Windows.Forms.KeyEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override
F#
abstract OnKeyUp :
        e:KeyEventArgs -> unit
override OnKeyUp :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnKeyUp(System.Windows.Forms.KeyEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnMouseDown Method
CanvasControl Class See Also Send Feedback
Реакция на событие нажатия клавиши мыши

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnMouseMove Method
CanvasControl Class See Also Send Feedback
Реакция на событие движения курсора мыши над контролом

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnMouseUp Method
CanvasControl Class See Also Send Feedback
Реакция на событие отпускания клавиши мыши

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnMouseWheel Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnMouseWheel Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OnMouseWheel(System.Drawing.Point,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void OnMouseWheel(
    Point pnt,
    int wheel
)
Visual Basic
Public Sub OnMouseWheel ( _
    pnt As Point, _
    wheel As Integer _
)
Visual C++
public:
void OnMouseWheel(
    Point pnt,
    int wheel
)
F#
member OnMouseWheel :
        pnt:Point *
        wheel:int -> unit

Parameters

pnt
Type: System.Drawing..::..Point

[Missing <param name="pnt"/> documentation for "M:SMath.Control.CanvasControl.OnMouseWheel(System.Drawing.Point,System.Int32)"]

wheel
Type: System..::..Int32

[Missing <param name="wheel"/> documentation for "M:SMath.Control.CanvasControl.OnMouseWheel(System.Drawing.Point,System.Int32)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnPaint Method
CanvasControl Class See Also Send Feedback
Реакция на событие отрисовки содержимого элемента управления

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnPaintBackground Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnPaintBackground Method
CanvasControl Class See Also Send Feedback
Переопределён для избежания эффекта мерцания

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaintBackground(
    PaintEventArgs^ e
) override
F#
abstract OnPaintBackground :
        e:PaintEventArgs -> unit
override OnPaintBackground :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CanvasControl.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OnResize Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OnResize Method
CanvasControl Class See Also Send Feedback
Изменение размеров контрола

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnResize(
    EventArgs eventg
)
Visual Basic
Protected Overrides Sub OnResize ( _
    eventg As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ eventg
) override
F#
abstract OnResize :
        eventg:EventArgs -> unit
override OnResize :
        eventg:EventArgs -> unit

Parameters

eventg
Type: System..::..EventArgs

[Missing <param name="eventg"/> documentation for "M:SMath.Control.CanvasControl.OnResize(System.EventArgs)"]

See Also

CanvasControl Class
SMath.Control Namespace


OpenXML Method

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OpenXML Method
CanvasControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenXML(Stream, Boolean, Boolean) |
Public method | OpenXML(String, Boolean, Boolean) | Открытие XML структурированного файла SMath Studio

See Also

CanvasControl Class
CanvasControl Members
SMath.Control Namespace


OpenXML Method (Stream, Boolean, Boolean)

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OpenXML Method (Stream, Boolean, Boolean)
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.IO.Stream,System.Boolean,System.Boolean)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool OpenXML(
    Stream stream,
    bool outside,
    bool infoOnly
)
Visual Basic
Public Function OpenXML ( _
    stream As Stream, _
    outside As Boolean, _
    infoOnly As Boolean _
) As Boolean
Visual C++
public:
bool OpenXML(
    Stream^ stream,
    bool outside,
    bool infoOnly
)
F#
member OpenXML :
        stream:Stream *
        outside:bool *
        infoOnly:bool -> bool

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.IO.Stream,System.Boolean,System.Boolean)"]

outside
Type: System..::..Boolean

[Missing <param name="outside"/> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.IO.Stream,System.Boolean,System.Boolean)"]

infoOnly
Type: System..::..Boolean

[Missing <param name="infoOnly"/> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.IO.Stream,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.IO.Stream,System.Boolean,System.Boolean)"]

See Also

CanvasControl Class
OpenXML Overload
SMath.Control Namespace


OpenXML Method (String, Boolean, Boolean)

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..OpenXML Method (String, Boolean, Boolean)
CanvasControl Class See Also Send Feedback
Открытие XML структурированного файла SMath Studio

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool OpenXML(
    string fileName,
    bool outside,
    bool infoOnly
)
Visual Basic
Public Function OpenXML ( _
    fileName As String, _
    outside As Boolean, _
    infoOnly As Boolean _
) As Boolean
Visual C++
public:
bool OpenXML(
    String^ fileName,
    bool outside,
    bool infoOnly
)
F#
member OpenXML :
        fileName:string *
        outside:bool *
        infoOnly:bool -> bool

Parameters

fileName
Type: System..::..String
Полный путь к файлу
outside
Type: System..::..Boolean
Открытие файла извне (т.е. из интерфейса программы, в противном случае, считается, что функция вызывается для вставки выражений из буфера обмена)
infoOnly
Type: System..::..Boolean

[Missing <param name="infoOnly"/> documentation for "M:SMath.Control.CanvasControl.OpenXML(System.String,System.Boolean,System.Boolean)"]

Return Value

Результат проведения операции

See Also

CanvasControl Class
OpenXML Overload
SMath.Control Namespace


ReCalcInThread Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..ReCalcInThread Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.ReCalcInThread(System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ReCalcInThread(
    int startIndex,
    int endIndex
)
Visual Basic
Public Sub ReCalcInThread ( _
    startIndex As Integer, _
    endIndex As Integer _
)
Visual C++
public:
void ReCalcInThread(
    int startIndex,
    int endIndex
)
F#
member ReCalcInThread :
        startIndex:int *
        endIndex:int -> unit

Parameters

startIndex
Type: System..::..Int32

[Missing <param name="startIndex"/> documentation for "M:SMath.Control.CanvasControl.ReCalcInThread(System.Int32,System.Int32)"]

endIndex
Type: System..::..Int32

[Missing <param name="endIndex"/> documentation for "M:SMath.Control.CanvasControl.ReCalcInThread(System.Int32,System.Int32)"]

See Also

CanvasControl Class
SMath.Control Namespace


ReDo Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..ReDo Method
CanvasControl Class See Also Send Feedback
Отмена последнего в стэке возврата на шаг назад в истории

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ReDo()
Visual Basic
Public Sub ReDo
Visual C++
public:
void ReDo()
F#
member ReDo : unit -> unit

See Also

CanvasControl Class
SMath.Control Namespace


RemoveControls Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..RemoveControls Method
CanvasControl Class See Also Send Feedback
Удаление элементов с листа с пересчётом размеров листа и результатов вычислений, если необходимо. Так же состояния добавляются в историю изменений. Никаких дополнительных действий для завершения операции не требуется.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void RemoveControls(
    CommonControl[] controlsIndeces
)
Visual Basic
Public Sub RemoveControls ( _
    controlsIndeces As CommonControl() _
)
Visual C++
public:
void RemoveControls(
    array<CommonControl^>^ controlsIndeces
)
F#
member RemoveControls :
        controlsIndeces:CommonControl[] -> unit

Parameters

controlsIndeces
Type: array< SMath.Control..::..CommonControl >[]()[][]
Индексы элементов листа для удаления

See Also

CanvasControl Class
SMath.Control Namespace


SaveToXML Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SaveToXML Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SaveToXML(System.IO.Stream,System.Boolean)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SaveToXML(
    Stream stream,
    bool outside
)
Visual Basic
Public Sub SaveToXML ( _
    stream As Stream, _
    outside As Boolean _
)
Visual C++
public:
void SaveToXML(
    Stream^ stream,
    bool outside
)
F#
member SaveToXML :
        stream:Stream *
        outside:bool -> unit

Parameters

stream
Type: System.IO..::..Stream

[Missing <param name="stream"/> documentation for "M:SMath.Control.CanvasControl.SaveToXML(System.IO.Stream,System.Boolean)"]

outside
Type: System..::..Boolean

[Missing <param name="outside"/> documentation for "M:SMath.Control.CanvasControl.SaveToXML(System.IO.Stream,System.Boolean)"]

See Also

CanvasControl Class
SMath.Control Namespace


SetBorder Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetBorder Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetBorder"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetBorder()
Visual Basic
Public Sub SetBorder
Visual C++
public:
void SetBorder()
F#
member SetBorder : unit -> unit

See Also

CanvasControl Class
SMath.Control Namespace


SetColor Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetColor Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetColor(System.Drawing.Color,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetColor(
    Color color,
    int inc
)
Visual Basic
Public Sub SetColor ( _
    color As Color, _
    inc As Integer _
)
Visual C++
public:
void SetColor(
    Color color,
    int inc
)
F#
member SetColor :
        color:Color *
        inc:int -> unit

Parameters

color
Type: System.Drawing..::..Color

[Missing <param name="color"/> documentation for "M:SMath.Control.CanvasControl.SetColor(System.Drawing.Color,System.Int32)"]

inc
Type: System..::..Int32

[Missing <param name="inc"/> documentation for "M:SMath.Control.CanvasControl.SetColor(System.Drawing.Color,System.Int32)"]

See Also

CanvasControl Class
SMath.Control Namespace


SetCurrentTextLang Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetCurrentTextLang Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetCurrentTextLang"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetCurrentTextLang()
Visual Basic
Public Sub SetCurrentTextLang
Visual C++
public:
void SetCurrentTextLang()
F#
member SetCurrentTextLang : unit -> unit

See Also

CanvasControl Class
SMath.Control Namespace


SetEvalution Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetEvalution Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetEvalution(System.Boolean)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetEvalution(
    bool evalute
)
Visual Basic
Public Sub SetEvalution ( _
    evalute As Boolean _
)
Visual C++
public:
void SetEvalution(
    bool evalute
)
F#
member SetEvalution :
        evalute:bool -> unit

Parameters

evalute
Type: System..::..Boolean

[Missing <param name="evalute"/> documentation for "M:SMath.Control.CanvasControl.SetEvalution(System.Boolean)"]

See Also

CanvasControl Class
SMath.Control Namespace


SetLang Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetLang Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetLang(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetLang(
    string lang
)
Visual Basic
Public Sub SetLang ( _
    lang As String _
)
Visual C++
public:
void SetLang(
    String^ lang
)
F#
member SetLang :
        lang:string -> unit

Parameters

lang
Type: System..::..String

[Missing <param name="lang"/> documentation for "M:SMath.Control.CanvasControl.SetLang(System.String)"]

See Also

CanvasControl Class
SMath.Control Namespace


SetOptimization Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetOptimization Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetOptimization(SMath.Manager.OptimizationType)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetOptimization(
    OptimizationType optimize
)
Visual Basic
Public Sub SetOptimization ( _
    optimize As OptimizationType _
)
Visual C++
public:
void SetOptimization(
    OptimizationType optimize
)
F#
member SetOptimization :
        optimize:OptimizationType -> unit

Parameters

optimize
Type: SMath.Manager..::..OptimizationType

[Missing <param name="optimize"/> documentation for "M:SMath.Control.CanvasControl.SetOptimization(SMath.Manager.OptimizationType)"]

See Also

CanvasControl Class
SMath.Control Namespace


SetSize Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..SetSize Method
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CanvasControl.SetSize(System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetSize(
    int inc
)
Visual Basic
Public Sub SetSize ( _
    inc As Integer _
)
Visual C++
public:
void SetSize(
    int inc
)
F#
member SetSize :
        inc:int -> unit

Parameters

inc
Type: System..::..Int32

[Missing <param name="inc"/> documentation for "M:SMath.Control.CanvasControl.SetSize(System.Int32)"]

See Also

CanvasControl Class
SMath.Control Namespace


UnDo Method

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..UnDo Method
CanvasControl Class See Also Send Feedback
Возврат состояния листа в истории на один шаг назад

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void UnDo()
Visual Basic
Public Sub UnDo
Visual C++
public:
void UnDo()
F#
member UnDo : unit -> unit

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl Properties
CanvasControl Class See Also Send Feedback

The CanvasControl type exposes the following members.

Properties

 | Name | Description
Public property | CanvasControls |
Public property | CanvasSize | Текущий размер видимой активной части листа без учёта места, занимаемого каретками прокрутки
Public property | Edited |
Public property | IsEvalutionInProgress |
Public property | IsSelected |

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControls Property

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..CanvasControls Property
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CanvasControl.CanvasControls"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public List<CommonControl> CanvasControls { get; }
Visual Basic
Public ReadOnly Property CanvasControls As List(Of CommonControl)
    Get
Visual C++
public:
property List<CommonControl^>^ CanvasControls {
    List<CommonControl^>^ get ();
}
F#
member CanvasControls : List<CommonControl>

See Also

CanvasControl Class
SMath.Control Namespace


CanvasSize Property

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..CanvasSize Property
CanvasControl Class See Also Send Feedback
Текущий размер видимой активной части листа без учёта места, занимаемого каретками прокрутки

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Size CanvasSize { get; }
Visual Basic
Public ReadOnly Property CanvasSize As Size
    Get
Visual C++
public:
property Size CanvasSize {
    Size get ();
}
F#
member CanvasSize : Size

See Also

CanvasControl Class
SMath.Control Namespace


Edited Property

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..Edited Property
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CanvasControl.Edited"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Edited { get; }
Visual Basic
Public ReadOnly Property Edited As Boolean
    Get
Visual C++
public:
property bool Edited {
    bool get ();
}
F#
member Edited : bool

See Also

CanvasControl Class
SMath.Control Namespace


IsEvalutionInProgress Property

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..IsEvalutionInProgress Property
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CanvasControl.IsEvalutionInProgress"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool IsEvalutionInProgress { get; }
Visual Basic
Public ReadOnly Property IsEvalutionInProgress As Boolean
    Get
Visual C++
public:
property bool IsEvalutionInProgress {
    bool get ();
}
F#
member IsEvalutionInProgress : bool

See Also

CanvasControl Class
SMath.Control Namespace


IsSelected Property

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..IsSelected Property
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CanvasControl.IsSelected"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool IsSelected { get; }
Visual Basic
Public ReadOnly Property IsSelected As Boolean
    Get
Visual C++
public:
property bool IsSelected {
    bool get ();
}
F#
member IsSelected : bool

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl Events

[image] [image]

SMath Studio Class Libraries Documantation
CanvasControl Events
CanvasControl Class See Also Send Feedback

The CanvasControl type exposes the following members.

Events

 | Name | Description
Public event | onPageControlMajorChange |
Public event | onPageStatusChanged |

See Also

CanvasControl Class
SMath.Control Namespace


onPageControlMajorChange Event

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..onPageControlMajorChange Event
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "E:SMath.Control.CanvasControl.onPageControlMajorChange"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public event PageControlMajorChangeEventHandler onPageControlMajorChange
Visual Basic
Public Event onPageControlMajorChange As PageControlMajorChangeEventHandler
Visual C++
public:
 event PageControlMajorChangeEventHandler^ onPageControlMajorChange {
    void add (PageControlMajorChangeEventHandler^ value);
    void remove (PageControlMajorChangeEventHandler^ value);
}
F#
member onPageControlMajorChange : IEvent<PageControlMajorChangeEventHandler,
    EventArgs>

See Also

CanvasControl Class
SMath.Control Namespace


onPageStatusChanged Event

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..onPageStatusChanged Event
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "E:SMath.Control.CanvasControl.onPageStatusChanged"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public event PageStatusChangedEventHandler onPageStatusChanged
Visual Basic
Public Event onPageStatusChanged As PageStatusChangedEventHandler
Visual C++
public:
 event PageStatusChangedEventHandler^ onPageStatusChanged {
    void add (PageStatusChangedEventHandler^ value);
    void remove (PageStatusChangedEventHandler^ value);
}
F#
member onPageStatusChanged : IEvent<PageStatusChangedEventHandler,
    EventArgs>

See Also

CanvasControl Class
SMath.Control Namespace


CanvasControl.ELHISTORYGUI Delegate

[image]

SMath Studio Class Libraries Documantation
CanvasControl..::..ELHISTORYGUI Delegate
CanvasControl Class See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.CanvasControl.ELHISTORYGUI"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public delegate void ELHISTORYGUI(
    CommonControl sender
)
Visual Basic
Public Delegate Sub ELHISTORYGUI ( _
    sender As CommonControl _
)
Visual C++
public delegate void ELHISTORYGUI(
    CommonControl^ sender
)
F#
type ELHISTORYGUI =
    delegate of
        sender:CommonControl -> unit

Parameters

sender
Type: SMath.Control..::..CommonControl

See Also

SMath.Control Namespace


CanvasEditStatus Enumeration

[image]

SMath Studio Class Libraries Documantation
CanvasEditStatus Enumeration
See Also Send Feedback
Состояние страницы

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CanvasEditStatus
Visual Basic
Public Enumeration CanvasEditStatus
Visual C++
public enum class CanvasEditStatus
F#
type CanvasEditStatus

Members

Member name | Value | Description
Editable | 0 | Стандартно. Редактируемая
ReadOnly | 1 | Только для чтения
Calculation | 2 | В процессе вычисления: можно просматривать, как в стандартном состоянии, но при этом нельзя редактировать

See Also

SMath.Control Namespace


CanvasInfo Class

[image]

SMath Studio Class Libraries Documantation
CanvasInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.CanvasInfo"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class CanvasInfo
Visual Basic
Public Class CanvasInfo
Visual C++
public ref class CanvasInfo
F#
type CanvasInfo =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CanvasInfo

See Also

CanvasInfo Members
SMath.Control Namespace


CanvasInfo Members

[image] [image]

SMath Studio Class Libraries Documantation
CanvasInfo Members
CanvasInfo Class Constructors Fields See Also Send Feedback

The CanvasInfo type exposes the following members.

Constructors

 | Name | Description
Public method | CanvasInfo()()()() |
Public method | CanvasInfo(CanvasInfo) |
Public method | CanvasInfo(String, String, String, String, String, String) |

Fields

 | Name | Description
Public field | Author |
Public field | Company |
Public field | Description |
Public field | Keywords |
Public field | Title |
Public field | Translator |

See Also

CanvasInfo Class
SMath.Control Namespace


CanvasInfo Constructor

[image] [image]

SMath Studio Class Libraries Documantation
CanvasInfo Constructor
CanvasInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanvasInfo()()()() | Initializes a new instance of the CanvasInfo class
Public method | CanvasInfo(CanvasInfo) | Initializes a new instance of the CanvasInfo class
Public method | CanvasInfo(String, String, String, String, String, String) | Initializes a new instance of the CanvasInfo class

See Also

CanvasInfo Class
CanvasInfo Members
SMath.Control Namespace


CanvasInfo Constructor

[image]

SMath Studio Class Libraries Documantation
CanvasInfo Constructor
CanvasInfo Class See Also Send Feedback
Initializes a new instance of the CanvasInfo class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasInfo()
Visual Basic
Public Sub New
Visual C++
public:
CanvasInfo()
F#
new : unit -> CanvasInfo

See Also

CanvasInfo Class
CanvasInfo Overload
SMath.Control Namespace


CanvasInfo Constructor (CanvasInfo)

[image]

SMath Studio Class Libraries Documantation
CanvasInfo Constructor (CanvasInfo)
CanvasInfo Class See Also Send Feedback
Initializes a new instance of the CanvasInfo class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasInfo(
    CanvasInfo value
)
Visual Basic
Public Sub New ( _
    value As CanvasInfo _
)
Visual C++
public:
CanvasInfo(
    CanvasInfo^ value
)
F#
new :
        value:CanvasInfo -> CanvasInfo

Parameters

value
Type: SMath.Control..::..CanvasInfo

[Missing <param name="value"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(SMath.Control.CanvasInfo)"]

See Also

CanvasInfo Class
CanvasInfo Overload
SMath.Control Namespace


CanvasInfo Constructor (String, String, String, String, String, String)

[image]

SMath Studio Class Libraries Documantation
CanvasInfo Constructor (String, String, String, String, String, String)
CanvasInfo Class See Also Send Feedback
Initializes a new instance of the CanvasInfo class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasInfo(
    string Title,
    string Author,
    string Translator,
    string Description,
    string Company,
    string Keywords
)
Visual Basic
Public Sub New ( _
    Title As String, _
    Author As String, _
    Translator As String, _
    Description As String, _
    Company As String, _
    Keywords As String _
)
Visual C++
public:
CanvasInfo(
    String^ Title,
    String^ Author,
    String^ Translator,
    String^ Description,
    String^ Company,
    String^ Keywords
)
F#
new :
        Title:string *
        Author:string *
        Translator:string *
        Description:string *
        Company:string *
        Keywords:string -> CanvasInfo

Parameters

Title
Type: System..::..String

[Missing <param name="Title"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

Author
Type: System..::..String

[Missing <param name="Author"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

Translator
Type: System..::..String

[Missing <param name="Translator"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

Description
Type: System..::..String

[Missing <param name="Description"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

Company
Type: System..::..String

[Missing <param name="Company"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

Keywords
Type: System..::..String

[Missing <param name="Keywords"/> documentation for "M:SMath.Control.CanvasInfo.#ctor(System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

CanvasInfo Class
CanvasInfo Overload
SMath.Control Namespace


CanvasInfo Fields

[image] [image]

SMath Studio Class Libraries Documantation
CanvasInfo Fields
CanvasInfo Class See Also Send Feedback

The CanvasInfo type exposes the following members.

Fields

 | Name | Description
Public field | Author |
Public field | Company |
Public field | Description |
Public field | Keywords |
Public field | Title |
Public field | Translator |

See Also

CanvasInfo Class
SMath.Control Namespace


Author Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Author Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Author"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Author
Visual Basic
Public Author As String
Visual C++
public:
String^ Author
F#
val mutable Author: string

See Also

CanvasInfo Class
SMath.Control Namespace


Company Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Company Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Company"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Company
Visual Basic
Public Company As String
Visual C++
public:
String^ Company
F#
val mutable Company: string

See Also

CanvasInfo Class
SMath.Control Namespace


Description Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Description Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Description"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Description
Visual Basic
Public Description As String
Visual C++
public:
String^ Description
F#
val mutable Description: string

See Also

CanvasInfo Class
SMath.Control Namespace


Keywords Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Keywords Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Keywords"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Keywords
Visual Basic
Public Keywords As String
Visual C++
public:
String^ Keywords
F#
val mutable Keywords: string

See Also

CanvasInfo Class
SMath.Control Namespace


Title Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Title Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Title"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Title
Visual Basic
Public Title As String
Visual C++
public:
String^ Title
F#
val mutable Title: string

See Also

CanvasInfo Class
SMath.Control Namespace


Translator Field

[image]

SMath Studio Class Libraries Documantation
CanvasInfo..::..Translator Field
CanvasInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasInfo.Translator"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Translator
Visual Basic
Public Translator As String
Visual C++
public:
String^ Translator
F#
val mutable Translator: string

See Also

CanvasInfo Class
SMath.Control Namespace


CanvasSelectionStatus Enumeration

[image]

SMath Studio Class Libraries Documantation
CanvasSelectionStatus Enumeration
See Also Send Feedback
Выделение на листе

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CanvasSelectionStatus
Visual Basic
Public Enumeration CanvasSelectionStatus
Visual C++
public enum class CanvasSelectionStatus
F#
type CanvasSelectionStatus

Members

Member name | Value | Description
InEdit | 0 | Редактирование элемента листа
Selected | 1 | Выделен один или несколько элементов
None | 2 | Не выделено ни одного элемента

See Also

SMath.Control Namespace


CanvasStatus Class

[image]

SMath Studio Class Libraries Documantation
CanvasStatus Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.CanvasStatus"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class CanvasStatus
Visual Basic
Public Class CanvasStatus
Visual C++
public ref class CanvasStatus
F#
type CanvasStatus =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CanvasStatus

See Also

CanvasStatus Members
SMath.Control Namespace


CanvasStatus Members

[image] [image]

SMath Studio Class Libraries Documantation
CanvasStatus Members
CanvasStatus Class Constructors Fields See Also Send Feedback

The CanvasStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CanvasStatus | Initializes a new instance of the CanvasStatus class

Fields

 | Name | Description
Public field | clipboardStatus |
Public field | controlType |
Public field | ctrlsEvaluationState |
Public field | ctrlsOptimization |
Public field | edited |
Public field | inCtrlSelection |
Public field | pageSelection |
Public field | pageStatus |
Public field | unReDoStatus |

See Also

CanvasStatus Class
SMath.Control Namespace


CanvasStatus Constructor

[image]

SMath Studio Class Libraries Documantation
CanvasStatus Constructor
CanvasStatus Class See Also Send Feedback
Initializes a new instance of the CanvasStatus class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasStatus(
    CanvasEditStatus pageStatus,
    CanvasSelectionStatus pageSelection,
    CtrlInSelection inCtrlSelection,
    ClipboardStatus clipboardStatus,
    UnReDoStatus unReDoStatus,
    CtrlsEvalutionState ctrlsEvaluationState,
    bool edited,
    ControlType controlType,
    CtrlsOptimizationState ctrlsOptimization
)
Visual Basic
Public Sub New ( _
    pageStatus As CanvasEditStatus, _
    pageSelection As CanvasSelectionStatus, _
    inCtrlSelection As CtrlInSelection, _
    clipboardStatus As ClipboardStatus, _
    unReDoStatus As UnReDoStatus, _
    ctrlsEvaluationState As CtrlsEvalutionState, _
    edited As Boolean, _
    controlType As ControlType, _
    ctrlsOptimization As CtrlsOptimizationState _
)
Visual C++
public:
CanvasStatus(
    CanvasEditStatus pageStatus,
    CanvasSelectionStatus pageSelection,
    CtrlInSelection inCtrlSelection,
    ClipboardStatus clipboardStatus,
    UnReDoStatus unReDoStatus,
    CtrlsEvalutionState ctrlsEvaluationState,
    bool edited,
    ControlType controlType,
    CtrlsOptimizationState ctrlsOptimization
)
F#
new :
        pageStatus:CanvasEditStatus *
        pageSelection:CanvasSelectionStatus *
        inCtrlSelection:CtrlInSelection *
        clipboardStatus:ClipboardStatus *
        unReDoStatus:UnReDoStatus *
        ctrlsEvaluationState:CtrlsEvalutionState *
        edited:bool *
        controlType:ControlType *
        ctrlsOptimization:CtrlsOptimizationState -> CanvasStatus

Parameters

pageStatus
Type: SMath.Control..::..CanvasEditStatus

[Missing <param name="pageStatus"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

pageSelection
Type: SMath.Control..::..CanvasSelectionStatus

[Missing <param name="pageSelection"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

inCtrlSelection
Type: SMath.Control..::..CtrlInSelection

[Missing <param name="inCtrlSelection"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

clipboardStatus
Type: SMath.Control..::..ClipboardStatus

[Missing <param name="clipboardStatus"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

unReDoStatus
Type: SMath.Control..::..UnReDoStatus

[Missing <param name="unReDoStatus"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

ctrlsEvaluationState
Type: SMath.Control..::..CtrlsEvalutionState

[Missing <param name="ctrlsEvaluationState"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

edited
Type: System..::..Boolean

[Missing <param name="edited"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

controlType
Type: SMath.Control..::..ControlType

[Missing <param name="controlType"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

ctrlsOptimization
Type: SMath.Control..::..CtrlsOptimizationState

[Missing <param name="ctrlsOptimization"/> documentation for "M:SMath.Control.CanvasStatus.#ctor(SMath.Control.CanvasEditStatus,SMath.Control.CanvasSelectionStatus,SMath.Control.CtrlInSelection,SMath.Control.ClipboardStatus,SMath.Control.UnReDoStatus,SMath.Control.CtrlsEvalutionState,System.Boolean,SMath.Control.ControlType,SMath.Control.CtrlsOptimizationState)"]

See Also

CanvasStatus Class
SMath.Control Namespace


CanvasStatus Fields

[image] [image]

SMath Studio Class Libraries Documantation
CanvasStatus Fields
CanvasStatus Class See Also Send Feedback

The CanvasStatus type exposes the following members.

Fields

 | Name | Description
Public field | clipboardStatus |
Public field | controlType |
Public field | ctrlsEvaluationState |
Public field | ctrlsOptimization |
Public field | edited |
Public field | inCtrlSelection |
Public field | pageSelection |
Public field | pageStatus |
Public field | unReDoStatus |

See Also

CanvasStatus Class
SMath.Control Namespace


clipboardStatus Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..clipboardStatus Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.clipboardStatus"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public ClipboardStatus clipboardStatus
Visual Basic
Public clipboardStatus As ClipboardStatus
Visual C++
public:
ClipboardStatus clipboardStatus
F#
val mutable clipboardStatus: ClipboardStatus

See Also

CanvasStatus Class
SMath.Control Namespace


controlType Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..controlType Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.controlType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public ControlType controlType
Visual Basic
Public controlType As ControlType
Visual C++
public:
ControlType controlType
F#
val mutable controlType: ControlType

See Also

CanvasStatus Class
SMath.Control Namespace


ctrlsEvaluationState Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..ctrlsEvaluationState Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.ctrlsEvaluationState"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CtrlsEvalutionState ctrlsEvaluationState
Visual Basic
Public ctrlsEvaluationState As CtrlsEvalutionState
Visual C++
public:
CtrlsEvalutionState ctrlsEvaluationState
F#
val mutable ctrlsEvaluationState: CtrlsEvalutionState

See Also

CanvasStatus Class
SMath.Control Namespace


ctrlsOptimization Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..ctrlsOptimization Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.ctrlsOptimization"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CtrlsOptimizationState ctrlsOptimization
Visual Basic
Public ctrlsOptimization As CtrlsOptimizationState
Visual C++
public:
CtrlsOptimizationState ctrlsOptimization
F#
val mutable ctrlsOptimization: CtrlsOptimizationState

See Also

CanvasStatus Class
SMath.Control Namespace


edited Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..edited Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.edited"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool edited
Visual Basic
Public edited As Boolean
Visual C++
public:
bool edited
F#
val mutable edited: bool

See Also

CanvasStatus Class
SMath.Control Namespace


inCtrlSelection Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..inCtrlSelection Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.inCtrlSelection"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CtrlInSelection inCtrlSelection
Visual Basic
Public inCtrlSelection As CtrlInSelection
Visual C++
public:
CtrlInSelection inCtrlSelection
F#
val mutable inCtrlSelection: CtrlInSelection

See Also

CanvasStatus Class
SMath.Control Namespace


pageSelection Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..pageSelection Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.pageSelection"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasSelectionStatus pageSelection
Visual Basic
Public pageSelection As CanvasSelectionStatus
Visual C++
public:
CanvasSelectionStatus pageSelection
F#
val mutable pageSelection: CanvasSelectionStatus

See Also

CanvasStatus Class
SMath.Control Namespace


pageStatus Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..pageStatus Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.pageStatus"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CanvasEditStatus pageStatus
Visual Basic
Public pageStatus As CanvasEditStatus
Visual C++
public:
CanvasEditStatus pageStatus
F#
val mutable pageStatus: CanvasEditStatus

See Also

CanvasStatus Class
SMath.Control Namespace


unReDoStatus Field

[image]

SMath Studio Class Libraries Documantation
CanvasStatus..::..unReDoStatus Field
CanvasStatus Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CanvasStatus.unReDoStatus"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public UnReDoStatus unReDoStatus
Visual Basic
Public unReDoStatus As UnReDoStatus
Visual C++
public:
UnReDoStatus unReDoStatus
F#
val mutable unReDoStatus: UnReDoStatus

See Also

CanvasStatus Class
SMath.Control Namespace


ClipboardStatus Enumeration

[image]

SMath Studio Class Libraries Documantation
ClipboardStatus Enumeration
See Also Send Feedback
Статус буфера обмена

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum ClipboardStatus
Visual Basic
Public Enumeration ClipboardStatus
Visual C++
public enum class ClipboardStatus
F#
type ClipboardStatus

Members

Member name | Value | Description
Empty | 0 | Пусто или данные из буфера обмена не могут быть интерпретированы
HasData | 1 | Буфер обмена заполнен поддерживаемыми данными

See Also

SMath.Control Namespace


CommonControl Class

[image]

SMath Studio Class Libraries Documantation
CommonControl Class
Members See Also Send Feedback
Родитель всех элементов управления программы

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class CommonControl : IComparable<CommonControl>
Visual Basic
Public Class CommonControl _
    Implements IComparable(Of CommonControl)
Visual C++
public ref class CommonControl : IComparable<CommonControl^>
F#
type CommonControl =
    class
        interface IComparable<CommonControl>
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..AreaControl
SMath.Control..::..MathControl
SMath.Control..::..PictureControl
SMath.Control..::..PlotControl
SMath.Control..::..Renderer
SMath.Control..::..TextControl

See Also

CommonControl Members
SMath.Control Namespace


CommonControl Members

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Members
CommonControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The CommonControl type exposes the following members.

Constructors

 | Name | Description
Public method | CommonControl()()()() | Конструктор контрола
Public method | CommonControl(CommonControl) | Конструктор контрола для копирования

Methods

 | Name | Description
Public method | Action |
Public method | Clone |
Protected method | CustomLineDrawing |
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении
Public method | GetCursorType | Определение вида курсора
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetImage()()()() | Получение изображения элемента
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом
Public method | LinkClick | Сообщает о нажатии на ссылку
Public method | NeedToCalculate | Генерирует событие пересчёта
Public method | OnMouseDown |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | OnPaint |
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.
 | ReadyToChangeLocation |
Public method | ReadyToPaint |
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку
Protected method | Resize | Генерирует событие изменения размера
Public method | SetEvaluationState |
Public method | ShowAvailableTermsList |
Public method | ShowError |
Public method | ShowResult |
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.
Public method | UndoRedoManager |
Protected method | UnReDoAccept | Применение параметров шага истории к элементу
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке
Public method | UnReInit | Удаление наполнения элемента

Fields

 | Name | Description
Protected field | blackBrush |
Public field | brush | Массив "кистей" для рисования
Protected field | dblclick |
Public field | errorId |
Public field | Font | Шрифт используемы элементом
Public field | IsChildControl |
 | lctchange |
Protected field | pen | Массив "карандашей" для рисования
Public field | referer |
Public field | remoteControl |
Public field | uid | Уникальный идентификатор элемента
Protected field | UnReDO |
Protected field | UnReDoMaximum |
Protected field | UnReDoPoint |

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента
Public property | Border | Отрисовка рамки по границе элемента
Public property | Bottom | Нижняя граница элемента
Public property | ErrorText | Текст ошибки элемента
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate)
Public property | FontHeight | Размер используемого элементом шрифта
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой
Public property | Location | Абсолютные координаты элемента управления
Public property | Right | Правая граница элемента
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет
Public property | SelectedBackColor | Выделенный фоновый цвет элемента
Public property | SelectedTextColor | Цвет выделенного текста элемента
Public property | Size | Размер элемента управления
Public property | TextColor | Цвет текста элемента
Public property | WarningColor | Цвет предупреждений элемента

Events

 | Name | Description
Public event | setControlEvaluationState |

See Also

CommonControl Class
SMath.Control Namespace


CommonControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Constructor
CommonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CommonControl()()()() | Конструктор контрола
Public method | CommonControl(CommonControl) | Конструктор контрола для копирования

See Also

CommonControl Class
CommonControl Members
SMath.Control Namespace


CommonControl Constructor

[image]

SMath Studio Class Libraries Documantation
CommonControl Constructor
CommonControl Class See Also Send Feedback
Конструктор контрола

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CommonControl()
Visual Basic
Public Sub New
Visual C++
public:
CommonControl()
F#
new : unit -> CommonControl

See Also

CommonControl Class
CommonControl Overload
SMath.Control Namespace


CommonControl Constructor (CommonControl)

[image]

SMath Studio Class Libraries Documantation
CommonControl Constructor (CommonControl)
CommonControl Class See Also Send Feedback
Конструктор контрола для копирования

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CommonControl(
    CommonControl value
)
Visual Basic
Public Sub New ( _
    value As CommonControl _
)
Visual C++
public:
CommonControl(
    CommonControl^ value
)
F#
new :
        value:CommonControl -> CommonControl

Parameters

value
Type: SMath.Control..::..CommonControl

[Missing <param name="value"/> documentation for "M:SMath.Control.CommonControl.#ctor(SMath.Control.CommonControl)"]

See Also

CommonControl Class
CommonControl Overload
SMath.Control Namespace


CommonControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Fields
CommonControl Class See Also Send Feedback

The CommonControl type exposes the following members.

Fields

 | Name | Description
Protected field | blackBrush |
Public field | brush | Массив "кистей" для рисования
Protected field | dblclick |
Public field | errorId |
Public field | Font | Шрифт используемы элементом
Public field | IsChildControl |
 | lctchange |
Protected field | pen | Массив "карандашей" для рисования
Public field | referer |
Public field | remoteControl |
Public field | uid | Уникальный идентификатор элемента
Protected field | UnReDO |
Protected field | UnReDoMaximum |
Protected field | UnReDoPoint |

See Also

CommonControl Class
SMath.Control Namespace


blackBrush Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..blackBrush Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.blackBrush"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected Brush blackBrush
Visual Basic
Protected blackBrush As Brush
Visual C++
protected:
Brush^ blackBrush
F#
val mutable blackBrush: Brush

See Also

CommonControl Class
SMath.Control Namespace


brush Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..brush Field
CommonControl Class See Also Send Feedback
Массив "кистей" для рисования

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Brush[] brush
Visual Basic
Public brush As Brush()
Visual C++
public:
array<Brush^>^ brush
F#
val mutable brush: Brush[]

See Also

CommonControl Class
SMath.Control Namespace


dblclick Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..dblclick Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.dblclick"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected Timer dblclick
Visual Basic
Protected dblclick As Timer
Visual C++
protected:
Timer^ dblclick
F#
val mutable dblclick: Timer

See Also

CommonControl Class
SMath.Control Namespace


errorId Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..errorId Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.errorId"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Error errorId
Visual Basic
Public errorId As Error
Visual C++
public:
Error errorId
F#
val mutable errorId: Error

See Also

CommonControl Class
SMath.Control Namespace


Font Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Font Field
CommonControl Class See Also Send Feedback
Шрифт используемы элементом

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Font Font
Visual Basic
Public Font As Font
Visual C++
public:
Font^ Font
F#
val mutable Font: Font

See Also

CommonControl Class
SMath.Control Namespace


IsChildControl Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..IsChildControl Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.IsChildControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool IsChildControl
Visual Basic
Public IsChildControl As Boolean
Visual C++
public:
bool IsChildControl
F#
val mutable IsChildControl: bool

See Also

CommonControl Class
SMath.Control Namespace


lctchange Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..lctchange Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.lctchange"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected static Timer lctchange
Visual Basic
Protected Shared lctchange As Timer
Visual C++
protected:
static Timer^ lctchange
F#
static val mutable lctchange: Timer

See Also

CommonControl Class
SMath.Control Namespace


pen Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..pen Field
CommonControl Class See Also Send Feedback
Массив "карандашей" для рисования

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected Pen[] pen
Visual Basic
Protected pen As Pen()
Visual C++
protected:
array<Pen^>^ pen
F#
val mutable pen: Pen[]

See Also

CommonControl Class
SMath.Control Namespace


referer Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..referer Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.referer"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string referer
Visual Basic
Public referer As String
Visual C++
public:
String^ referer
F#
val mutable referer: string

See Also

CommonControl Class
SMath.Control Namespace


remoteControl Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..remoteControl Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.remoteControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string remoteControl
Visual Basic
Public remoteControl As String
Visual C++
public:
String^ remoteControl
F#
val mutable remoteControl: string

See Also

CommonControl Class
SMath.Control Namespace


uid Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..uid Field
CommonControl Class See Also Send Feedback
Уникальный идентификатор элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string uid
Visual Basic
Public uid As String
Visual C++
public:
String^ uid
F#
val mutable uid: string

See Also

CommonControl Class
SMath.Control Namespace


UnReDO Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReDO Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.UnReDO"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected List<UnReDO_Common> UnReDO
Visual Basic
Protected UnReDO As List(Of UnReDO_Common)
Visual C++
protected:
List<UnReDO_Common^>^ UnReDO
F#
val mutable UnReDO: List<UnReDO_Common>

See Also

CommonControl Class
SMath.Control Namespace


UnReDoMaximum Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReDoMaximum Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.UnReDoMaximum"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected int UnReDoMaximum
Visual Basic
Protected UnReDoMaximum As Integer
Visual C++
protected:
int UnReDoMaximum
F#
val mutable UnReDoMaximum: int

See Also

CommonControl Class
SMath.Control Namespace


UnReDoPoint Field

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReDoPoint Field
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.CommonControl.UnReDoPoint"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected int UnReDoPoint
Visual Basic
Protected UnReDoPoint As Integer
Visual C++
protected:
int UnReDoPoint
F#
val mutable UnReDoPoint: int

See Also

CommonControl Class
SMath.Control Namespace


CommonControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Methods
CommonControl Class See Also Send Feedback

The CommonControl type exposes the following members.

Methods

 | Name | Description
Public method | Action |
Public method | Clone |
Protected method | CustomLineDrawing |
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении
Public method | GetCursorType | Определение вида курсора
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetImage()()()() | Получение изображения элемента
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом
Public method | LinkClick | Сообщает о нажатии на ссылку
Public method | NeedToCalculate | Генерирует событие пересчёта
Public method | OnMouseDown |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | OnPaint |
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.
 | ReadyToChangeLocation |
Public method | ReadyToPaint |
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку
Protected method | Resize | Генерирует событие изменения размера
Public method | SetEvaluationState |
Public method | ShowAvailableTermsList |
Public method | ShowError |
Public method | ShowResult |
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.
Public method | UndoRedoManager |
Protected method | UnReDoAccept | Применение параметров шага истории к элементу
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке
Public method | UnReInit | Удаление наполнения элемента

See Also

CommonControl Class
SMath.Control Namespace


Action Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Action Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.Action(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void Action(
    string e
)
Visual Basic
Public Overridable Sub Action ( _
    e As String _
)
Visual C++
public:
virtual void Action(
    String^ e
)
F#
abstract Action :
        e:string -> unit
override Action :
        e:string -> unit

Parameters

e
Type: System..::..String

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.Action(System.String)"]

See Also

CommonControl Class
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Clone Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual CommonControl Clone()
Visual Basic
Public Overridable Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone()
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.Clone"]

See Also

CommonControl Class
SMath.Control Namespace


CustomLineDrawing Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..CustomLineDrawing Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected void CustomLineDrawing(
    PaintEventArgs e,
    Pen pen,
    int x1,
    int y1,
    int x2,
    int y2
)
Visual Basic
Protected Sub CustomLineDrawing ( _
    e As PaintEventArgs, _
    pen As Pen, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer _
)
Visual C++
protected:
void CustomLineDrawing(
    PaintEventArgs^ e,
    Pen^ pen,
    int x1,
    int y1,
    int x2,
    int y2
)
F#
member CustomLineDrawing :
        e:PaintEventArgs *
        pen:Pen *
        x1:int *
        y1:int *
        x2:int *
        y2:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

pen
Type: System.Drawing..::..Pen

[Missing <param name="pen"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.CommonControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Drawing.Pen,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

CommonControl Class
SMath.Control Namespace


dec_errorprovider_nu Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..dec_errorprovider_nu Method
CommonControl Class See Also Send Feedback
Сообщает об ошибке в элементе при вычислении

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void dec_errorprovider_nu(
    Exception e,
    int Position,
    Term value
)
Visual Basic
Public Sub dec_errorprovider_nu ( _
    e As Exception, _
    Position As Integer, _
    value As Term _
)
Visual C++
public:
void dec_errorprovider_nu(
    Exception^ e,
    int Position,
    Term^ value
)
F#
member dec_errorprovider_nu :
        e:Exception *
        Position:int *
        value:Term -> unit

Parameters

e
Type: System..::..Exception

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.dec_errorprovider_nu(System.Exception,System.Int32,SMath.Manager.Term)"]

Position
Type: System..::..Int32
Порядковый номер неверного элемента в ОПЗ
value
Type: SMath.Manager..::..Term

[Missing <param name="value"/> documentation for "M:SMath.Control.CommonControl.dec_errorprovider_nu(System.Exception,System.Int32,SMath.Manager.Term)"]

See Also

CommonControl Class
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..GetCursorType Method
CommonControl Class See Also Send Feedback
Определение вида курсора

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual CursorType GetCursorType(
    MouseEventArgs point
)
Visual Basic
Public Overridable Function GetCursorType ( _
    point As MouseEventArgs _
) As CursorType
Visual C++
public:
virtual CursorType GetCursorType(
    MouseEventArgs^ point
)
F#
abstract GetCursorType :
        point:MouseEventArgs -> CursorType
override GetCursorType :
        point:MouseEventArgs -> CursorType

Parameters

point
Type: System.Windows.Forms..::..MouseEventArgs
Положение курсора

Return Value

Вид курсора на основании его положения

See Also

CommonControl Class
SMath.Control Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..GetHashCode Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.GetHashCode"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.GetHashCode"]

See Also

CommonControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl..::..GetImage Method
CommonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом

See Also

CommonControl Class
CommonControl Members
SMath.Control Namespace


GetImage Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..GetImage Method
CommonControl Class See Also Send Feedback
Получение изображения элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Bitmap GetImage()
Visual Basic
Public Function GetImage As Bitmap
Visual C++
public:
Bitmap^ GetImage()
F#
member GetImage : unit -> Bitmap

Return Value

Изображение элемента

See Also

CommonControl Class
GetImage Overload
SMath.Control Namespace


GetImage Method (Color)

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..GetImage Method (Color)
CommonControl Class See Also Send Feedback
Получение изображения элемента с указанным фоновым цветом

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Bitmap GetImage(
    Color bgColor
)
Visual Basic
Public Function GetImage ( _
    bgColor As Color _
) As Bitmap
Visual C++
public:
Bitmap^ GetImage(
    Color bgColor
)
F#
member GetImage :
        bgColor:Color -> Bitmap

Parameters

bgColor
Type: System.Drawing..::..Color
Цвет фона

Return Value

Изображение элемента

See Also

CommonControl Class
GetImage Overload
SMath.Control Namespace


LinkClick Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..LinkClick Method
CommonControl Class See Also Send Feedback
Сообщает о нажатии на ссылку

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void LinkClick()
Visual Basic
Public Sub LinkClick
Visual C++
public:
void LinkClick()
F#
member LinkClick : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


NeedToCalculate Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..NeedToCalculate Method
CommonControl Class See Also Send Feedback
Генерирует событие пересчёта

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void NeedToCalculate(
    CalculateType e,
    CommonControl sender
)
Visual Basic
Public Sub NeedToCalculate ( _
    e As CalculateType, _
    sender As CommonControl _
)
Visual C++
public:
void NeedToCalculate(
    CalculateType e,
    CommonControl^ sender
)
F#
member NeedToCalculate :
        e:CalculateType *
        sender:CommonControl -> unit

Parameters

e
Type: SMath.Control..::..CalculateType
Тип пересчёта
sender
Type: SMath.Control..::..CommonControl

[Missing <param name="sender"/> documentation for "M:SMath.Control.CommonControl.NeedToCalculate(SMath.Control.CalculateType,SMath.Control.CommonControl)"]

See Also

CommonControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..OnMouseDown Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overridable Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
)
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

CommonControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..OnMouseMove Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overridable Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
)
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

CommonControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..OnMouseUp Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overridable Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
)
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

CommonControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..OnPaint Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overridable Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
)
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

CommonControl Class
SMath.Control Namespace


PrePainter Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..PrePainter Method
CommonControl Class See Also Send Feedback
Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void PrePainter()
Visual Basic
Public Overridable Sub PrePainter
Visual C++
public:
virtual void PrePainter()
F#
abstract PrePainter : unit -> unit
override PrePainter : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


ReadyToChangeLocation Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ReadyToChangeLocation Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.ReadyToChangeLocation"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static bool ReadyToChangeLocation()
Visual Basic
Public Shared Function ReadyToChangeLocation As Boolean
Visual C++
public:
static bool ReadyToChangeLocation()
F#
static member ReadyToChangeLocation : unit -> bool

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.ReadyToChangeLocation"]

See Also

CommonControl Class
SMath.Control Namespace


ReadyToPaint Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ReadyToPaint Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.ReadyToPaint"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool ReadyToPaint()
Visual Basic
Public Function ReadyToPaint As Boolean
Visual C++
public:
bool ReadyToPaint()
F#
member ReadyToPaint : unit -> bool

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.ReadyToPaint"]

See Also

CommonControl Class
SMath.Control Namespace


ReDo Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ReDo Method
CommonControl Class See Also Send Feedback
Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public UnReDO_Common ReDo()
Visual Basic
Public Function ReDo As UnReDO_Common
Visual C++
public:
UnReDO_Common^ ReDo()
F#
member ReDo : unit -> UnReDO_Common

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.ReDo"]

See Also

CommonControl Class
SMath.Control Namespace


RePainter Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..RePainter Method
CommonControl Class See Also Send Feedback
Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void RePainter()
Visual Basic
Public Sub RePainter
Visual C++
public:
void RePainter()
F#
member RePainter : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


Resize Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Resize Method
CommonControl Class See Also Send Feedback
Генерирует событие изменения размера

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected virtual void Resize()
Visual Basic
Protected Overridable Sub Resize
Visual C++
protected:
virtual void Resize()
F#
abstract Resize : unit -> unit
override Resize : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


SetEvaluationState Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..SetEvaluationState Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.SetEvaluationState(System.Boolean)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetEvaluationState(
    bool state
)
Visual Basic
Public Sub SetEvaluationState ( _
    state As Boolean _
)
Visual C++
public:
void SetEvaluationState(
    bool state
)
F#
member SetEvaluationState :
        state:bool -> unit

Parameters

state
Type: System..::..Boolean

[Missing <param name="state"/> documentation for "M:SMath.Control.CommonControl.SetEvaluationState(System.Boolean)"]

See Also

CommonControl Class
SMath.Control Namespace


ShowAvailableTermsList Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ShowAvailableTermsList Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.ShowAvailableTermsList"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ShowAvailableTermsList()
Visual Basic
Public Sub ShowAvailableTermsList
Visual C++
public:
void ShowAvailableTermsList()
F#
member ShowAvailableTermsList : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


ShowError Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ShowError Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.ShowError(System.Exception,SMath.Manager.Term[],SMath.Manager.Definition[],SMath.Control.CalculateType)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ShowError(
    Exception e,
    Term[] ei,
    Definition[] param,
    CalculateType value
)
Visual Basic
Public Sub ShowError ( _
    e As Exception, _
    ei As Term(), _
    param As Definition(), _
    value As CalculateType _
)
Visual C++
public:
void ShowError(
    Exception^ e,
    array<Term^>^ ei,
    array<Definition^>^ param,
    CalculateType value
)
F#
member ShowError :
        e:Exception *
        ei:Term[] *
        param:Definition[] *
        value:CalculateType -> unit

Parameters

e
Type: System..::..Exception

[Missing <param name="e"/> documentation for "M:SMath.Control.CommonControl.ShowError(System.Exception,SMath.Manager.Term[],SMath.Manager.Definition[],SMath.Control.CalculateType)"]

ei
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="ei"/> documentation for "M:SMath.Control.CommonControl.ShowError(System.Exception,SMath.Manager.Term[],SMath.Manager.Definition[],SMath.Control.CalculateType)"]

param
Type: array< SMath.Manager..::..Definition >[]()[][]

[Missing <param name="param"/> documentation for "M:SMath.Control.CommonControl.ShowError(System.Exception,SMath.Manager.Term[],SMath.Manager.Definition[],SMath.Control.CalculateType)"]

value
Type: SMath.Control..::..CalculateType

[Missing <param name="value"/> documentation for "M:SMath.Control.CommonControl.ShowError(System.Exception,SMath.Manager.Term[],SMath.Manager.Definition[],SMath.Control.CalculateType)"]

See Also

CommonControl Class
SMath.Control Namespace


ShowResult Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ShowResult Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.ShowResult(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ShowResult(
    Term[] ei,
    Term[] tstr2,
    CalculateType value
)
Visual Basic
Public Sub ShowResult ( _
    ei As Term(), _
    tstr2 As Term(), _
    value As CalculateType _
)
Visual C++
public:
void ShowResult(
    array<Term^>^ ei,
    array<Term^>^ tstr2,
    CalculateType value
)
F#
member ShowResult :
        ei:Term[] *
        tstr2:Term[] *
        value:CalculateType -> unit

Parameters

ei
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="ei"/> documentation for "M:SMath.Control.CommonControl.ShowResult(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

tstr2
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="tstr2"/> documentation for "M:SMath.Control.CommonControl.ShowResult(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

value
Type: SMath.Control..::..CalculateType

[Missing <param name="value"/> documentation for "M:SMath.Control.CommonControl.ShowResult(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

See Also

CommonControl Class
SMath.Control Namespace


UnDo Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnDo Method
CommonControl Class See Also Send Feedback
Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public UnReDO_Common UnDo()
Visual Basic
Public Function UnDo As UnReDO_Common
Visual C++
public:
UnReDO_Common^ UnDo()
F#
member UnDo : unit -> UnReDO_Common

Return Value

[Missing <returns> documentation for "M:SMath.Control.CommonControl.UnDo"]

See Also

CommonControl Class
SMath.Control Namespace


UndoRedoManager Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UndoRedoManager Method
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.CommonControl.UndoRedoManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void UndoRedoManager(
    string referer
)
Visual Basic
Public Overridable Sub UndoRedoManager ( _
    referer As String _
)
Visual C++
public:
virtual void UndoRedoManager(
    String^ referer
)
F#
abstract UndoRedoManager :
        referer:string -> unit
override UndoRedoManager :
        referer:string -> unit

Parameters

referer
Type: System..::..String

[Missing <param name="referer"/> documentation for "M:SMath.Control.CommonControl.UndoRedoManager(System.String)"]

See Also

CommonControl Class
SMath.Control Namespace


UnReDoAccept Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReDoAccept Method
CommonControl Class See Also Send Feedback
Применение параметров шага истории к элементу

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected virtual void UnReDoAccept(
    UnReDO_Common unReDO_Common
)
Visual Basic
Protected Overridable Sub UnReDoAccept ( _
    unReDO_Common As UnReDO_Common _
)
Visual C++
protected:
virtual void UnReDoAccept(
    UnReDO_Common^ unReDO_Common
)
F#
abstract UnReDoAccept :
        unReDO_Common:UnReDO_Common -> unit
override UnReDoAccept :
        unReDO_Common:UnReDO_Common -> unit

Parameters

unReDO_Common
Type: SMath.Control..::..UnReDO_Common
Шаг истории изменений элемента

See Also

CommonControl Class
SMath.Control Namespace


UnReDoPush Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReDoPush Method
CommonControl Class See Also Send Feedback
Сохранение шага истории в последовательном их списке

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected void UnReDoPush(
    UnReDO_Common action
)
Visual Basic
Protected Sub UnReDoPush ( _
    action As UnReDO_Common _
)
Visual C++
protected:
void UnReDoPush(
    UnReDO_Common^ action
)
F#
member UnReDoPush :
        action:UnReDO_Common -> unit

Parameters

action
Type: SMath.Control..::..UnReDO_Common
Шаг истории изменений элемента

See Also

CommonControl Class
SMath.Control Namespace


UnReInit Method

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..UnReInit Method
CommonControl Class See Also Send Feedback
Удаление наполнения элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual void UnReInit()
Visual Basic
Public Overridable Sub UnReInit
Visual C++
public:
virtual void UnReInit()
F#
abstract UnReInit : unit -> unit
override UnReInit : unit -> unit

See Also

CommonControl Class
SMath.Control Namespace


CommonControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Properties
CommonControl Class See Also Send Feedback

The CommonControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента
Public property | Border | Отрисовка рамки по границе элемента
Public property | Bottom | Нижняя граница элемента
Public property | ErrorText | Текст ошибки элемента
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate)
Public property | FontHeight | Размер используемого элементом шрифта
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой
Public property | Location | Абсолютные координаты элемента управления
Public property | Right | Правая граница элемента
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет
Public property | SelectedBackColor | Выделенный фоновый цвет элемента
Public property | SelectedTextColor | Цвет выделенного текста элемента
Public property | Size | Размер элемента управления
Public property | TextColor | Цвет текста элемента
Public property | WarningColor | Цвет предупреждений элемента

See Also

CommonControl Class
SMath.Control Namespace


BackColor Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..BackColor Property
CommonControl Class See Also Send Feedback
Фоновый цвет элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
F#
member BackColor : Color with get, set

See Also

CommonControl Class
SMath.Control Namespace


Border Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Border Property
CommonControl Class See Also Send Feedback
Отрисовка рамки по границе элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual bool Border { get; set; }
Visual Basic
Public Overridable Property Border As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Border {
    bool get ();
    void set (bool value);
}
F#
abstract Border : bool with get, set
override Border : bool with get, set

See Also

CommonControl Class
SMath.Control Namespace


Bottom Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Bottom Property
CommonControl Class See Also Send Feedback
Нижняя граница элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Bottom { get; }
Visual Basic
Public ReadOnly Property Bottom As Integer
    Get
Visual C++
public:
property int Bottom {
    int get ();
}
F#
member Bottom : int

See Also

CommonControl Class
SMath.Control Namespace


ErrorText Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..ErrorText Property
CommonControl Class See Also Send Feedback
Текст ошибки элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual string ErrorText { get; set; }
Visual Basic
Public Overridable Property ErrorText As String
    Get
    Set
Visual C++
public:
virtual property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
F#
abstract ErrorText : string with get, set
override ErrorText : string with get, set

See Also

CommonControl Class
SMath.Control Namespace


Focused Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Focused Property
CommonControl Class See Also Send Feedback
Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate)

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual bool Focused { get; set; }
Visual Basic
Public Overridable Property Focused As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Focused {
    bool get ();
    void set (bool value);
}
F#
abstract Focused : bool with get, set
override Focused : bool with get, set

See Also

CommonControl Class
SMath.Control Namespace


FontHeight Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..FontHeight Property
CommonControl Class See Also Send Feedback
Размер используемого элементом шрифта

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int FontHeight { get; set; }
Visual Basic
Public Property FontHeight As Integer
    Get
    Set
Visual C++
public:
property int FontHeight {
    int get ();
    void set (int value);
}
F#
member FontHeight : int with get, set

See Also

CommonControl Class
SMath.Control Namespace


InDate Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..InDate Property
CommonControl Class See Also Send Feedback
Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public virtual bool InDate { get; set; }
Visual Basic
Public Overridable Property InDate As Boolean
    Get
    Set
Visual C++
public:
virtual property bool InDate {
    bool get ();
    void set (bool value);
}
F#
abstract InDate : bool with get, set
override InDate : bool with get, set

See Also

CommonControl Class
SMath.Control Namespace


Location Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Location Property
CommonControl Class See Also Send Feedback
Абсолютные координаты элемента управления

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point Location { get; set; }
Visual Basic
Public Property Location As Point
    Get
    Set
Visual C++
public:
property Point Location {
    Point get ();
    void set (Point value);
}
F#
member Location : Point with get, set

See Also

CommonControl Class
SMath.Control Namespace


Right Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Right Property
CommonControl Class See Also Send Feedback
Правая граница элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Right { get; }
Visual Basic
Public ReadOnly Property Right As Integer
    Get
Visual C++
public:
property int Right {
    int get ();
}
F#
member Right : int

See Also

CommonControl Class
SMath.Control Namespace


Selected Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Selected Property
CommonControl Class See Also Send Feedback
Определяет, является ли элемент выделенным на листе или нет

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
F#
member Selected : bool with get, set

See Also

CommonControl Class
SMath.Control Namespace


SelectedBackColor Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..SelectedBackColor Property
CommonControl Class See Also Send Feedback
Выделенный фоновый цвет элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color SelectedBackColor { get; set; }
Visual Basic
Public Property SelectedBackColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedBackColor {
    Color get ();
    void set (Color value);
}
F#
member SelectedBackColor : Color with get, set

See Also

CommonControl Class
SMath.Control Namespace


SelectedTextColor Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..SelectedTextColor Property
CommonControl Class See Also Send Feedback
Цвет выделенного текста элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color SelectedTextColor { get; set; }
Visual Basic
Public Property SelectedTextColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedTextColor {
    Color get ();
    void set (Color value);
}
F#
member SelectedTextColor : Color with get, set

See Also

CommonControl Class
SMath.Control Namespace


Size Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..Size Property
CommonControl Class See Also Send Feedback
Размер элемента управления

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set
Visual C++
public:
property Size Size {
    Size get ();
    void set (Size value);
}
F#
member Size : Size with get, set

See Also

CommonControl Class
SMath.Control Namespace


TextColor Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..TextColor Property
CommonControl Class See Also Send Feedback
Цвет текста элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}
F#
member TextColor : Color with get, set

See Also

CommonControl Class
SMath.Control Namespace


WarningColor Property

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..WarningColor Property
CommonControl Class See Also Send Feedback
Цвет предупреждений элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color WarningColor { get; set; }
Visual Basic
Public Property WarningColor As Color
    Get
    Set
Visual C++
public:
property Color WarningColor {
    Color get ();
    void set (Color value);
}
F#
member WarningColor : Color with get, set

See Also

CommonControl Class
SMath.Control Namespace


CommonControl Events

[image] [image]

SMath Studio Class Libraries Documantation
CommonControl Events
CommonControl Class See Also Send Feedback

The CommonControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState |

See Also

CommonControl Class
SMath.Control Namespace


setControlEvaluationState Event

[image]

SMath Studio Class Libraries Documantation
CommonControl..::..setControlEvaluationState Event
CommonControl Class See Also Send Feedback

[Missing <summary> documentation for "E:SMath.Control.CommonControl.setControlEvaluationState"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public event ControlEvaluationStateEventHandler setControlEvaluationState
Visual Basic
Public Event setControlEvaluationState As ControlEvaluationStateEventHandler
Visual C++
public:
 event ControlEvaluationStateEventHandler^ setControlEvaluationState {
    void add (ControlEvaluationStateEventHandler^ value);
    void remove (ControlEvaluationStateEventHandler^ value);
}
F#
member setControlEvaluationState : IEvent<ControlEvaluationStateEventHandler,
    EventArgs>

See Also

CommonControl Class
SMath.Control Namespace


ControlEvaluationStateEventHandler Delegate

[image]

SMath Studio Class Libraries Documantation
ControlEvaluationStateEventHandler Delegate
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.ControlEvaluationStateEventHandler"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public delegate void ControlEvaluationStateEventHandler(
    CommonControl sender,
    bool state
)
Visual Basic
Public Delegate Sub ControlEvaluationStateEventHandler ( _
    sender As CommonControl, _
    state As Boolean _
)
Visual C++
public delegate void ControlEvaluationStateEventHandler(
    CommonControl^ sender,
    bool state
)
F#
type ControlEvaluationStateEventHandler =
    delegate of
        sender:CommonControl *
        state:bool -> unit

Parameters

sender
Type: SMath.Control..::..CommonControl
state
Type: System..::..Boolean

See Also

SMath.Control Namespace


ControlType Enumeration

[image]

SMath Studio Class Libraries Documantation
ControlType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.ControlType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum ControlType
Visual Basic
Public Enumeration ControlType
Visual C++
public enum class ControlType
F#
type ControlType

Members

Member name | Value | Description
None | 0 |
Math | 1 |
Text | 2 |
Plot | 3 |
Area | 4 |
Picture | 5 |

See Also

SMath.Control Namespace


CtrlInSelection Enumeration

[image]

SMath Studio Class Libraries Documantation
CtrlInSelection Enumeration
See Also Send Feedback
Выделение внутри элемента листа

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CtrlInSelection
Visual Basic
Public Enumeration CtrlInSelection
Visual C++
public enum class CtrlInSelection
F#
type CtrlInSelection

Members

Member name | Value | Description
None | 0 | Нет выделения
Text | 1 | Выделен текст
Variable | 2 | Выделена переменная
Constant | 3 | Выделена константа
MathExpression | 4 | Выделено математическое выражение

See Also

SMath.Control Namespace


CtrlsEvalutionState Enumeration

[image]

SMath Studio Class Libraries Documantation
CtrlsEvalutionState Enumeration
See Also Send Feedback
Признак того, что выделенные выражения могут быть вычислены

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CtrlsEvalutionState
Visual Basic
Public Enumeration CtrlsEvalutionState
Visual C++
public enum class CtrlsEvalutionState
F#
type CtrlsEvalutionState

Members

Member name | Value | Description
NotSupported | 0 | Вычисление не поддерживается
Evaluate | 1 | Вычисление поддерживается
Disabled | 2 | Вычисление поддерживается, но отключено

See Also

SMath.Control Namespace


CtrlsOptimizationState Enumeration

[image]

SMath Studio Class Libraries Documantation
CtrlsOptimizationState Enumeration
See Also Send Feedback
Признак того, что выделенные выражения оптимизированы

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CtrlsOptimizationState
Visual Basic
Public Enumeration CtrlsOptimizationState
Visual C++
public enum class CtrlsOptimizationState
F#
type CtrlsOptimizationState

Members

Member name | Value | Description
NotSupported | -1 | Оптимизирование не поддерживается
NotOptimized | 0 | Контролы не оптимизированы
OptimizedSymbolic | 1 | Контролы оптимизированы символьно
OptimizedNumeric | 2 | Контролы оптимизированы численно

See Also

SMath.Control Namespace


CursorStatus Class

[image]

SMath Studio Class Libraries Documantation
CursorStatus Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.CursorStatus"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class CursorStatus
Visual Basic
Public Class CursorStatus
Visual C++
public ref class CursorStatus
F#
type CursorStatus =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CursorStatus

See Also

CursorStatus Members
SMath.Control Namespace


CursorStatus Members

[image] [image]

SMath Studio Class Libraries Documantation
CursorStatus Members
CursorStatus Class Constructors Properties See Also Send Feedback

The CursorStatus type exposes the following members.

Constructors

 | Name | Description
Public method | CursorStatus | Initializes a new instance of the CursorStatus class

Properties

 | Name | Description
Public property | Control |
Public property | CursorType |

See Also

CursorStatus Class
SMath.Control Namespace


CursorStatus Constructor

[image]

SMath Studio Class Libraries Documantation
CursorStatus Constructor
CursorStatus Class See Also Send Feedback
Initializes a new instance of the CursorStatus class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CursorStatus(
    int control,
    CursorType cursorType
)
Visual Basic
Public Sub New ( _
    control As Integer, _
    cursorType As CursorType _
)
Visual C++
public:
CursorStatus(
    int control,
    CursorType cursorType
)
F#
new :
        control:int *
        cursorType:CursorType -> CursorStatus

Parameters

control
Type: System..::..Int32

[Missing <param name="control"/> documentation for "M:SMath.Control.CursorStatus.#ctor(System.Int32,SMath.Control.CursorType)"]

cursorType
Type: SMath.Control..::..CursorType

[Missing <param name="cursorType"/> documentation for "M:SMath.Control.CursorStatus.#ctor(System.Int32,SMath.Control.CursorType)"]

See Also

CursorStatus Class
SMath.Control Namespace


CursorStatus Properties

[image] [image]

SMath Studio Class Libraries Documantation
CursorStatus Properties
CursorStatus Class See Also Send Feedback

The CursorStatus type exposes the following members.

Properties

 | Name | Description
Public property | Control |
Public property | CursorType |

See Also

CursorStatus Class
SMath.Control Namespace


Control Property

[image]

SMath Studio Class Libraries Documantation
CursorStatus..::..Control Property
CursorStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CursorStatus.Control"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Control { get; set; }
Visual Basic
Public Property Control As Integer
    Get
    Set
Visual C++
public:
property int Control {
    int get ();
    void set (int value);
}
F#
member Control : int with get, set

See Also

CursorStatus Class
SMath.Control Namespace


CursorType Property

[image]

SMath Studio Class Libraries Documantation
CursorStatus..::..CursorType Property
CursorStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.CursorStatus.CursorType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CursorType CursorType { get; set; }
Visual Basic
Public Property CursorType As CursorType
    Get
    Set
Visual C++
public:
property CursorType CursorType {
    CursorType get ();
    void set (CursorType value);
}
F#
member CursorType : CursorType with get, set

See Also

CursorStatus Class
SMath.Control Namespace


CursorType Enumeration

[image]

SMath Studio Class Libraries Documantation
CursorType Enumeration
See Also Send Feedback
Вид курсора

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum CursorType
Visual Basic
Public Enumeration CursorType
Visual C++
public enum class CursorType
F#
type CursorType

Members

Member name | Value | Description
Default | 0 | Не задано
Arrow | 1 | Стрелка - стандартный вид
Text | 2 | Текстовый курсор
Move | 3 | Курсор изменения положения
Moving | 4 | Курсор при перетаскивании
MovingAdd | 5 | Курсор добавления при перетаскивании
SizeH | 6 | Изменение размера по горизонтали
SizeV | 7 | Изменение размера по вертикали
SizeNWSE | 8 | Изменение размера по диагонали

See Also

SMath.Control Namespace


DataFiles Class

[image]

SMath Studio Class Libraries Documantation
DataFiles Class
Members See Also Send Feedback
English: Data file types manager.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class DataFiles
Visual Basic
Public Class DataFiles
Visual C++
public ref class DataFiles
F#
type DataFiles =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..DataFiles

See Also

DataFiles Members
SMath.Control Namespace


DataFiles Members

[image] [image]

SMath Studio Class Libraries Documantation
DataFiles Members
DataFiles Class Constructors Methods See Also Send Feedback

The DataFiles type exposes the following members.

Constructors

 | Name | Description
Public method | DataFiles | Initializes a new instance of the DataFiles class

Methods

Name | Description
GetFileTypeDescriptionByExtension | English: Returns description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.
GetOpenFileTypeFilter | English: Returns open file types filter formatted to use into Open File Dialogs.
GetSaveFileTypeFilter | English: Returns save file types filter formatted to use into Save File Dialogs.
OpenFileType | English: Open file from the specific file type.
SaveFileType | English: Save file to the specific file type.

See Also

DataFiles Class
SMath.Control Namespace


DataFiles Constructor

[image]

SMath Studio Class Libraries Documantation
DataFiles Constructor
DataFiles Class See Also Send Feedback
Initializes a new instance of the DataFiles class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public DataFiles()
Visual Basic
Public Sub New
Visual C++
public:
DataFiles()
F#
new : unit -> DataFiles

See Also

DataFiles Class
SMath.Control Namespace


DataFiles Methods

[image] [image]

SMath Studio Class Libraries Documantation
DataFiles Methods
DataFiles Class See Also Send Feedback

The DataFiles type exposes the following members.

Methods

Name | Description
GetFileTypeDescriptionByExtension | English: Returns description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.
GetOpenFileTypeFilter | English: Returns open file types filter formatted to use into Open File Dialogs.
GetSaveFileTypeFilter | English: Returns save file types filter formatted to use into Save File Dialogs.
OpenFileType | English: Open file from the specific file type.
SaveFileType | English: Save file to the specific file type.

See Also

DataFiles Class
SMath.Control Namespace


GetFileTypeDescriptionByExtension Method

[image]

SMath Studio Class Libraries Documantation
DataFiles..::..GetFileTypeDescriptionByExtension Method
DataFiles Class See Also Send Feedback
English: Returns description of the file type by extension (only types that can be opened). Otherwise returns string.Empty.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static string GetFileTypeDescriptionByExtension(
    string extension
)
Visual Basic
Public Shared Function GetFileTypeDescriptionByExtension ( _
    extension As String _
) As String
Visual C++
public:
static String^ GetFileTypeDescriptionByExtension(
    String^ extension
)
F#
static member GetFileTypeDescriptionByExtension :
        extension:string -> string

Parameters

extension
Type: System..::..String
English: File extension to search.

Return Value

English: Description of the file type.

See Also

DataFiles Class
SMath.Control Namespace


GetOpenFileTypeFilter Method

[image]

SMath Studio Class Libraries Documantation
DataFiles..::..GetOpenFileTypeFilter Method
DataFiles Class See Also Send Feedback
English: Returns open file types filter formatted to use into Open File Dialogs.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static string GetOpenFileTypeFilter()
Visual Basic
Public Shared Function GetOpenFileTypeFilter As String
Visual C++
public:
static String^ GetOpenFileTypeFilter()
F#
static member GetOpenFileTypeFilter : unit -> string

Return Value

English: Open file types filter.

See Also

DataFiles Class
SMath.Control Namespace


GetSaveFileTypeFilter Method

[image]

SMath Studio Class Libraries Documantation
DataFiles..::..GetSaveFileTypeFilter Method
DataFiles Class See Also Send Feedback
English: Returns save file types filter formatted to use into Save File Dialogs.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static string GetSaveFileTypeFilter()
Visual Basic
Public Shared Function GetSaveFileTypeFilter As String
Visual C++
public:
static String^ GetSaveFileTypeFilter()
F#
static member GetSaveFileTypeFilter : unit -> string

Return Value

English: Save file types filter.

See Also

DataFiles Class
SMath.Control Namespace


OpenFileType Method

[image]

SMath Studio Class Libraries Documantation
DataFiles..::..OpenFileType Method
DataFiles Class See Also Send Feedback
English: Open file from the specific file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static bool OpenFileType(
    string fileName,
    CanvasControl canvas
)
Visual Basic
Public Shared Function OpenFileType ( _
    fileName As String, _
    canvas As CanvasControl _
) As Boolean
Visual C++
public:
static bool OpenFileType(
    String^ fileName,
    CanvasControl^ canvas
)
F#
static member OpenFileType :
        fileName:string *
        canvas:CanvasControl -> bool

Parameters

fileName
Type: System..::..String
English: Path to the file.
canvas
Type: SMath.Control..::..CanvasControl
English: Canvas to open data in.

Return Value

English: Defines if file opened correctly.

See Also

DataFiles Class
SMath.Control Namespace


SaveFileType Method

[image]

SMath Studio Class Libraries Documantation
DataFiles..::..SaveFileType Method
DataFiles Class See Also Send Feedback
English: Save file to the specific file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static bool SaveFileType(
    string fileName,
    CanvasControl canvas
)
Visual Basic
Public Shared Function SaveFileType ( _
    fileName As String, _
    canvas As CanvasControl _
) As Boolean
Visual C++
public:
static bool SaveFileType(
    String^ fileName,
    CanvasControl^ canvas
)
F#
static member SaveFileType :
        fileName:string *
        canvas:CanvasControl -> bool

Parameters

fileName
Type: System..::..String
English: Path to the file.
canvas
Type: SMath.Control..::..CanvasControl
English: Canvas to save data to.

Return Value

English: Defines if file saved with restoring ability (i.e. file can be opened as well).

See Also

DataFiles Class
SMath.Control Namespace


ErrorControl Class

[image]

SMath Studio Class Libraries Documantation
ErrorControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.ErrorControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class ErrorControl : Control
Visual Basic
Public Class ErrorControl _
    Inherits Control
Visual C++
public ref class ErrorControl : public Control
F#
type ErrorControl =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
SMath.Control..::..ErrorControl

See Also

ErrorControl Members
SMath.Control Namespace


ErrorControl Members

[image] [image]

SMath Studio Class Libraries Documantation
ErrorControl Members
ErrorControl Class Constructors Methods Properties See Also Send Feedback

The ErrorControl type exposes the following members.

Constructors

 | Name | Description
Public method | ErrorControl | Initializes a new instance of the ErrorControl class

Methods

 | Name | Description
Public method | MakeImage |
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Public method | PrePainter |
Public method | RealSize |

Properties

 | Name | Description
Public property | Image |
Public property | Text | Определяющий текст надписи. (Overrides Control..::..Text.)

See Also

ErrorControl Class
SMath.Control Namespace


ErrorControl Constructor

[image]

SMath Studio Class Libraries Documantation
ErrorControl Constructor
ErrorControl Class See Also Send Feedback
Initializes a new instance of the ErrorControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public ErrorControl()
Visual Basic
Public Sub New
Visual C++
public:
ErrorControl()
F#
new : unit -> ErrorControl

See Also

ErrorControl Class
SMath.Control Namespace


ErrorControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
ErrorControl Methods
ErrorControl Class See Also Send Feedback

The ErrorControl type exposes the following members.

Methods

 | Name | Description
Public method | MakeImage |
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Public method | PrePainter |
Public method | RealSize |

See Also

ErrorControl Class
SMath.Control Namespace


MakeImage Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..MakeImage Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.MakeImage"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Bitmap MakeImage()
Visual Basic
Public Function MakeImage As Bitmap
Visual C++
public:
Bitmap^ MakeImage()
F#
member MakeImage : unit -> Bitmap

Return Value

[Missing <returns> documentation for "M:SMath.Control.ErrorControl.MakeImage"]

See Also

ErrorControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..OnMouseDown Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.ErrorControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

ErrorControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..OnPaint Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.ErrorControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

ErrorControl Class
SMath.Control Namespace


OnPaintBackground Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..OnPaintBackground Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaintBackground(
    PaintEventArgs^ e
) override
F#
abstract OnPaintBackground :
        e:PaintEventArgs -> unit
override OnPaintBackground :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.ErrorControl.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

See Also

ErrorControl Class
SMath.Control Namespace


PrePainter Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..PrePainter Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.PrePainter"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void PrePainter()
Visual Basic
Public Sub PrePainter
Visual C++
public:
void PrePainter()
F#
member PrePainter : unit -> unit

See Also

ErrorControl Class
SMath.Control Namespace


RealSize Method

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..RealSize Method
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.ErrorControl.RealSize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Size RealSize()
Visual Basic
Public Function RealSize As Size
Visual C++
public:
Size RealSize()
F#
member RealSize : unit -> Size

Return Value

[Missing <returns> documentation for "M:SMath.Control.ErrorControl.RealSize"]

See Also

ErrorControl Class
SMath.Control Namespace


ErrorControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
ErrorControl Properties
ErrorControl Class See Also Send Feedback

The ErrorControl type exposes the following members.

Properties

 | Name | Description
Public property | Image |
Public property | Text | Определяющий текст надписи. (Overrides Control..::..Text.)

See Also

ErrorControl Class
SMath.Control Namespace


Image Property

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..Image Property
ErrorControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.ErrorControl.Image"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Bitmap Image { get; set; }
Visual Basic
Public Property Image As Bitmap
    Get
    Set
Visual C++
public:
property Bitmap^ Image {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
F#
member Image : Bitmap with get, set

See Also

ErrorControl Class
SMath.Control Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
ErrorControl..::..Text Property
ErrorControl Class See Also Send Feedback
Определяющий текст надписи.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
F#
abstract Text : string with get, set
override Text : string with get, set

See Also

ErrorControl Class
SMath.Control Namespace


FileBehavior Enumeration

[image]

SMath Studio Class Libraries Documantation
FileBehavior Enumeration
See Also Send Feedback
English: Behaviors that can be applied to the file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum FileBehavior
Visual Basic
Public Enumeration FileBehavior
Visual C++
public enum class FileBehavior
F#
type FileBehavior

Members

Member name | Value | Description
None | 0 | English: Undefined behavior.
Open | 1 | English: File type can be opened only.
Save | 2 | English: File type can be saved only.
OpenSave | 3 | English: File type can be opened and saved.

See Also

SMath.Control Namespace


FileType Class

[image]

SMath Studio Class Libraries Documantation
FileType Class
Members See Also Send Feedback
English: Class to store metadata of the file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class FileType
Visual Basic
Public Class FileType
Visual C++
public ref class FileType
F#
type FileType =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..FileType

See Also

FileType Members
SMath.Control Namespace


FileType Members

[image] [image]

SMath Studio Class Libraries Documantation
FileType Members
FileType Class Constructors Methods Properties See Also Send Feedback

The FileType type exposes the following members.

Constructors

 | Name | Description
Public method | FileType | English: File type constructor.

Methods

 | Name | Description
Public method | JoinExtensions | English: Merging all the extensions in one string with ";" delimiter.

Properties

 | Name | Description
Public property | Behavior | English: Applied to the file type behaviors.
Public property | Description | English: Description of the file type.
Public property | Extensions | English: Array of the extensions associated with current file type.

See Also

FileType Class
SMath.Control Namespace


FileType Constructor

[image]

SMath Studio Class Libraries Documantation
FileType Constructor
FileType Class See Also Send Feedback
English: File type constructor.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public FileType(
    string description,
    string[] extensions,
    FileBehavior behavior
)
Visual Basic
Public Sub New ( _
    description As String, _
    extensions As String(), _
    behavior As FileBehavior _
)
Visual C++
public:
FileType(
    String^ description,
    array<String^>^ extensions,
    FileBehavior behavior
)
F#
new :
        description:string *
        extensions:string[] *
        behavior:FileBehavior -> FileType

Parameters

description
Type: System..::..String
English: Description of the file type.
extensions
Type: array< System..::..String >[]()[][]
English: Array of the extensions associated with current file type.
behavior
Type: SMath.Control..::..FileBehavior
English: Applied to the file type behaviors.

See Also

FileType Class
SMath.Control Namespace


FileType Methods

[image] [image]

SMath Studio Class Libraries Documantation
FileType Methods
FileType Class See Also Send Feedback

The FileType type exposes the following members.

Methods

 | Name | Description
Public method | JoinExtensions | English: Merging all the extensions in one string with ";" delimiter.

See Also

FileType Class
SMath.Control Namespace


JoinExtensions Method

[image]

SMath Studio Class Libraries Documantation
FileType..::..JoinExtensions Method
FileType Class See Also Send Feedback
English: Merging all the extensions in one string with ";" delimiter.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string JoinExtensions()
Visual Basic
Public Function JoinExtensions As String
Visual C++
public:
String^ JoinExtensions()
F#
member JoinExtensions : unit -> string

Return Value

English: Return string contains all the file type extensions.

See Also

FileType Class
SMath.Control Namespace


FileType Properties

[image] [image]

SMath Studio Class Libraries Documantation
FileType Properties
FileType Class See Also Send Feedback

The FileType type exposes the following members.

Properties

 | Name | Description
Public property | Behavior | English: Applied to the file type behaviors.
Public property | Description | English: Description of the file type.
Public property | Extensions | English: Array of the extensions associated with current file type.

See Also

FileType Class
SMath.Control Namespace


Behavior Property

[image]

SMath Studio Class Libraries Documantation
FileType..::..Behavior Property
FileType Class See Also Send Feedback
English: Applied to the file type behaviors.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public FileBehavior Behavior { get; }
Visual Basic
Public ReadOnly Property Behavior As FileBehavior
    Get
Visual C++
public:
property FileBehavior Behavior {
    FileBehavior get ();
}
F#
member Behavior : FileBehavior

See Also

FileType Class
SMath.Control Namespace


Description Property

[image]

SMath Studio Class Libraries Documantation
FileType..::..Description Property
FileType Class See Also Send Feedback
English: Description of the file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}
F#
member Description : string

See Also

FileType Class
SMath.Control Namespace


Extensions Property

[image]

SMath Studio Class Libraries Documantation
FileType..::..Extensions Property
FileType Class See Also Send Feedback
English: Array of the extensions associated with current file type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string[] Extensions { get; }
Visual Basic
Public ReadOnly Property Extensions As String()
    Get
Visual C++
public:
property array<String^>^ Extensions {
    array<String^>^ get ();
}
F#
member Extensions : string[]

See Also

FileType Class
SMath.Control Namespace


IPluginControlDrawing Interface

[image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.IPluginControlDrawing"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public interface IPluginControlDrawing : IPlugin,
    IDisposable
Visual Basic
Public Interface IPluginControlDrawing _
    Inherits IPlugin, IDisposable
Visual C++
public interface class IPluginControlDrawing : IPlugin,
    IDisposable
F#
type IPluginControlDrawing =
    interface
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginControlDrawing Members
SMath.Control Namespace


IPluginControlDrawing Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing Members
IPluginControlDrawing Interface Methods Properties See Also Send Feedback

The IPluginControlDrawing type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | PrepareDrawing | Preparing control for drawing on the canvas.
Public method | ProceedDrawing | Drawing of the Control on the canvas.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)

See Also

IPluginControlDrawing Interface
SMath.Control Namespace


IPluginControlDrawing Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing Methods
IPluginControlDrawing Interface See Also Send Feedback

The IPluginControlDrawing type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | PrepareDrawing | Preparing control for drawing on the canvas.
Public method | ProceedDrawing | Drawing of the Control on the canvas.

See Also

IPluginControlDrawing Interface
SMath.Control Namespace


PrepareDrawing Method

[image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing..::..PrepareDrawing Method
IPluginControlDrawing Interface See Also Send Feedback
Preparing control for drawing on the canvas.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
bool PrepareDrawing(
    CommonControl sender
)
Visual Basic
Function PrepareDrawing ( _
    sender As CommonControl _
) As Boolean
Visual C++
bool PrepareDrawing(
    CommonControl^ sender
)
F#
abstract PrepareDrawing :
        sender:CommonControl -> bool

Parameters

sender
Type: SMath.Control..::..CommonControl

[Missing <param name="sender"/> documentation for "M:SMath.Control.IPluginControlDrawing.PrepareDrawing(SMath.Control.CommonControl)"]

Return Value

Indicates success of preparing

See Also

IPluginControlDrawing Interface
SMath.Control Namespace


ProceedDrawing Method

[image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing..::..ProceedDrawing Method
IPluginControlDrawing Interface See Also Send Feedback
Drawing of the Control on the canvas.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
bool ProceedDrawing(
    CommonControl sender,
    PaintEventArgs e
)
Visual Basic
Function ProceedDrawing ( _
    sender As CommonControl, _
    e As PaintEventArgs _
) As Boolean
Visual C++
bool ProceedDrawing(
    CommonControl^ sender,
    PaintEventArgs^ e
)
F#
abstract ProceedDrawing :
        sender:CommonControl *
        e:PaintEventArgs -> bool

Parameters

sender
Type: SMath.Control..::..CommonControl

[Missing <param name="sender"/> documentation for "M:SMath.Control.IPluginControlDrawing.ProceedDrawing(SMath.Control.CommonControl,System.Windows.Forms.PaintEventArgs)"]

e
Type: System.Windows.Forms..::..PaintEventArgs
Paint arguments

Return Value

Indicates success of drawing

See Also

IPluginControlDrawing Interface
SMath.Control Namespace


IPluginControlDrawing Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginControlDrawing Properties
IPluginControlDrawing Interface See Also Send Feedback

The IPluginControlDrawing type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)

See Also

IPluginControlDrawing Interface
SMath.Control Namespace


IPluginHandleFileTypes Interface

[image]

SMath Studio Class Libraries Documantation
IPluginHandleFileTypes Interface
Members See Also Send Feedback
English: Base File Types handler Interface for SMath Studio Plugins.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public interface IPluginHandleFileTypes : IPlugin,
    IDisposable
Visual Basic
Public Interface IPluginHandleFileTypes _
    Inherits IPlugin, IDisposable
Visual C++
public interface class IPluginHandleFileTypes : IPlugin,
    IDisposable
F#
type IPluginHandleFileTypes =
    interface
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginHandleFileTypes Members
SMath.Control Namespace


IPluginHandleFileTypes Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleFileTypes Members
IPluginHandleFileTypes Interface Methods Properties See Also Send Feedback

The IPluginHandleFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin.

See Also

IPluginHandleFileTypes Interface
SMath.Control Namespace


IPluginHandleFileTypes Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleFileTypes Methods
IPluginHandleFileTypes Interface See Also Send Feedback

The IPluginHandleFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

See Also

IPluginHandleFileTypes Interface
SMath.Control Namespace


IPluginHandleFileTypes Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleFileTypes Properties
IPluginHandleFileTypes Interface See Also Send Feedback

The IPluginHandleFileTypes type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin.

See Also

IPluginHandleFileTypes Interface
SMath.Control Namespace


FileTypesHandled Property

[image]

SMath Studio Class Libraries Documantation
IPluginHandleFileTypes..::..FileTypesHandled Property
IPluginHandleFileTypes Interface See Also Send Feedback
English: Array of the file types, handled by Plugin.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
FileType[] FileTypesHandled { get; }
Visual Basic
ReadOnly Property FileTypesHandled As FileType()
    Get
Visual C++
property array<FileType^>^ FileTypesHandled {
    array<FileType^>^ get ();
}
F#
abstract FileTypesHandled : FileType[]

See Also

IPluginHandleFileTypes Interface
SMath.Control Namespace


IPluginOpenFileTypes Interface

[image]

SMath Studio Class Libraries Documantation
IPluginOpenFileTypes Interface
Members See Also Send Feedback
English: Open File Types handler interface.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public interface IPluginOpenFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
Visual Basic
Public Interface IPluginOpenFileTypes _
    Inherits IPluginHandleFileTypes, IPlugin, IDisposable
Visual C++
public interface class IPluginOpenFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
F#
type IPluginOpenFileTypes =
    interface
        interface IPluginHandleFileTypes
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginOpenFileTypes Members
SMath.Control Namespace


IPluginOpenFileTypes Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginOpenFileTypes Members
IPluginOpenFileTypes Interface Methods Properties See Also Send Feedback

The IPluginOpenFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | OpenFileType | English: Requests to open file of specified type.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin. (Inherited from IPluginHandleFileTypes.)

See Also

IPluginOpenFileTypes Interface
SMath.Control Namespace


IPluginOpenFileTypes Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginOpenFileTypes Methods
IPluginOpenFileTypes Interface See Also Send Feedback

The IPluginOpenFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | OpenFileType | English: Requests to open file of specified type.

See Also

IPluginOpenFileTypes Interface
SMath.Control Namespace


OpenFileType Method

[image]

SMath Studio Class Libraries Documantation
IPluginOpenFileTypes..::..OpenFileType Method
IPluginOpenFileTypes Interface See Also Send Feedback
English: Requests to open file of specified type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
bool OpenFileType(
    string fileName,
    Stream stream,
    List<CommonControl> controls
)
Visual Basic
Function OpenFileType ( _
    fileName As String, _
    stream As Stream, _
    controls As List(Of CommonControl) _
) As Boolean
Visual C++
bool OpenFileType(
    String^ fileName,
    Stream^ stream,
    List<CommonControl^>^ controls
)
F#
abstract OpenFileType :
        fileName:string *
        stream:Stream *
        controls:List<CommonControl> -> bool

Parameters

fileName
Type: System..::..String
English: Full name of the file.
stream
Type: System.IO..::..Stream
English: File stream to read data from.
controls
Type: System.Collections.Generic..::..List <(Of <(<' CommonControl >)>)>
English: List of the Controls currently exist on the worksheet.

Return Value

English: Returns condition of the file open operation.

See Also

IPluginOpenFileTypes Interface
SMath.Control Namespace


IPluginOpenFileTypes Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginOpenFileTypes Properties
IPluginOpenFileTypes Interface See Also Send Feedback

The IPluginOpenFileTypes type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin. (Inherited from IPluginHandleFileTypes.)

See Also

IPluginOpenFileTypes Interface
SMath.Control Namespace


IPluginSaveFileTypes Interface

[image]

SMath Studio Class Libraries Documantation
IPluginSaveFileTypes Interface
Members See Also Send Feedback
English: Save File Types handler interface.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public interface IPluginSaveFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
Visual Basic
Public Interface IPluginSaveFileTypes _
    Inherits IPluginHandleFileTypes, IPlugin, IDisposable
Visual C++
public interface class IPluginSaveFileTypes : IPluginHandleFileTypes,
    IPlugin, IDisposable
F#
type IPluginSaveFileTypes =
    interface
        interface IPluginHandleFileTypes
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginSaveFileTypes Members
SMath.Control Namespace


IPluginSaveFileTypes Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginSaveFileTypes Members
IPluginSaveFileTypes Interface Methods Properties See Also Send Feedback

The IPluginSaveFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | SaveFileType | English: Requests to save file of specified type.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin. (Inherited from IPluginHandleFileTypes.)

See Also

IPluginSaveFileTypes Interface
SMath.Control Namespace


IPluginSaveFileTypes Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginSaveFileTypes Methods
IPluginSaveFileTypes Interface See Also Send Feedback

The IPluginSaveFileTypes type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | SaveFileType | English: Requests to save file of specified type.

See Also

IPluginSaveFileTypes Interface
SMath.Control Namespace


SaveFileType Method

[image]

SMath Studio Class Libraries Documantation
IPluginSaveFileTypes..::..SaveFileType Method
IPluginSaveFileTypes Interface See Also Send Feedback
English: Requests to save file of specified type.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
bool SaveFileType(
    string fileName,
    Stream stream,
    List<CommonControl> controls
)
Visual Basic
Function SaveFileType ( _
    fileName As String, _
    stream As Stream, _
    controls As List(Of CommonControl) _
) As Boolean
Visual C++
bool SaveFileType(
    String^ fileName,
    Stream^ stream,
    List<CommonControl^>^ controls
)
F#
abstract SaveFileType :
        fileName:string *
        stream:Stream *
        controls:List<CommonControl> -> bool

Parameters

fileName
Type: System..::..String
English: Full name of the file.
stream
Type: System.IO..::..Stream
English: File stream to write data to.
controls
Type: System.Collections.Generic..::..List <(Of <(<' CommonControl >)>)>
English: List of the Controls currently exist on the worksheet.

Return Value

English: Returns condition of the file save operation.

See Also

IPluginSaveFileTypes Interface
SMath.Control Namespace


IPluginSaveFileTypes Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginSaveFileTypes Properties
IPluginSaveFileTypes Interface See Also Send Feedback

The IPluginSaveFileTypes type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | FileTypesHandled | English: Array of the file types, handled by Plugin. (Inherited from IPluginHandleFileTypes.)

See Also

IPluginSaveFileTypes Interface
SMath.Control Namespace


MathControl Class

[image]

SMath Studio Class Libraries Documantation
MathControl Class
Members See Also Send Feedback
Элемент интерфейса для создания и редактирования математического выражения

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class MathControl : CommonControl
Visual Basic
Public Class MathControl _
    Inherits CommonControl
Visual C++
public ref class MathControl : public CommonControl
F#
type MathControl =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..MathControl

See Also

MathControl Members
SMath.Control Namespace


MathControl Members

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Members
MathControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The MathControl type exposes the following members.

Constructors

 | Name | Description
Public method | MathControl()()()() | Конструктор элемента управления
Public method | MathControl(MathControl) |

Methods

 | Name | Description
Public method | Action(String) | Редактирование текущей формулы, при помощи вставки управляющей строки либо произвольной строки/символа формулы. (Overrides CommonControl..::..Action(String).)
Public method | Action(array<Term>[]()[][]) |
Public method | Action(array<Term>[]()[][], array<Term>[]()[][], CalculateType) | Составляет итоговое выражение из задания, знака решения и ответа
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Public method | CustomDrawEllipse |
Public method | CustomDrawRectangle |
Public method | CustomFillEllipse |
Public method | CustomFillRectangle |
Protected method | CustomLineDrawing(PaintEventArgs, Pen, Int32, Int32, Int32, Int32) | (Inherited from CommonControl.)
Public method | CustomLineDrawing(PaintEventArgs, Int32, Int32, Int32, Int32, Int32, Int32) |
Public method | CustomStringDrawing |
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32) |
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32, array<Point>[]()[][]) |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | Обработчик реакции контрола на нажатие клавишь мыши (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | Обработчик реакции контрола на движение мышью (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | Отрисовка выражения (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно. (Overrides CommonControl..::..PrePainter()()()().)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

Fields

 | Name | Description
Public field | ActiveTerm |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | bracket |
Public field | bracketPnt1 |
Public field | bracketPnt2 |
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | curFontClr |
Public field | curLineClr |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | dependences |
Public field | error |
Public field | errorId | (Inherited from CommonControl.)
Public field | finish |
Public field | finishNum |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | fraction_type |
Public field | Inc |
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | mem |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | rename |
Public field | sel |
Public field | termsToRename |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)
Public field | values |
Public field | watch |

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | (Overrides CommonControl..::..ErrorText.)
Public property | Evaluate |
Public property | Focused | (Overrides CommonControl..::..Focused.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | InEvaluation |
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Optimize |
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | Terms | Массив элементов математического выражения
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | Units |
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

MathControl Class
SMath.Control Namespace


MathControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Constructor
MathControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MathControl()()()() | Конструктор элемента управления
Public method | MathControl(MathControl) | Initializes a new instance of the MathControl class

See Also

MathControl Class
MathControl Members
SMath.Control Namespace


MathControl Constructor

[image]

SMath Studio Class Libraries Documantation
MathControl Constructor
MathControl Class See Also Send Feedback
Конструктор элемента управления

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MathControl()
Visual Basic
Public Sub New
Visual C++
public:
MathControl()
F#
new : unit -> MathControl

See Also

MathControl Class
MathControl Overload
SMath.Control Namespace


MathControl Constructor (MathControl)

[image]

SMath Studio Class Libraries Documantation
MathControl Constructor (MathControl)
MathControl Class See Also Send Feedback
Initializes a new instance of the MathControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MathControl(
    MathControl value
)
Visual Basic
Public Sub New ( _
    value As MathControl _
)
Visual C++
public:
MathControl(
    MathControl^ value
)
F#
new :
        value:MathControl -> MathControl

Parameters

value
Type: SMath.Control..::..MathControl

[Missing <param name="value"/> documentation for "M:SMath.Control.MathControl.#ctor(SMath.Control.MathControl)"]

See Also

MathControl Class
MathControl Overload
SMath.Control Namespace


MathControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Fields
MathControl Class See Also Send Feedback

The MathControl type exposes the following members.

Fields

 | Name | Description
Public field | ActiveTerm |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | bracket |
Public field | bracketPnt1 |
Public field | bracketPnt2 |
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | curFontClr |
Public field | curLineClr |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | dependences |
Public field | error |
Public field | errorId | (Inherited from CommonControl.)
Public field | finish |
Public field | finishNum |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | fraction_type |
Public field | Inc |
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | mem |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | rename |
Public field | sel |
Public field | termsToRename |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)
Public field | values |
Public field | watch |

See Also

MathControl Class
SMath.Control Namespace


ActiveTerm Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..ActiveTerm Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.ActiveTerm"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Term ActiveTerm
Visual Basic
Public ActiveTerm As Term
Visual C++
public:
Term^ ActiveTerm
F#
val mutable ActiveTerm: Term

See Also

MathControl Class
SMath.Control Namespace


bracket Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..bracket Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.bracket"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool bracket
Visual Basic
Public bracket As Boolean
Visual C++
public:
bool bracket
F#
val mutable bracket: bool

See Also

MathControl Class
SMath.Control Namespace


bracketPnt1 Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..bracketPnt1 Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.bracketPnt1"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point bracketPnt1
Visual Basic
Public bracketPnt1 As Point
Visual C++
public:
Point bracketPnt1
F#
val mutable bracketPnt1: Point

See Also

MathControl Class
SMath.Control Namespace


bracketPnt2 Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..bracketPnt2 Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.bracketPnt2"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point bracketPnt2
Visual Basic
Public bracketPnt2 As Point
Visual C++
public:
Point bracketPnt2
F#
val mutable bracketPnt2: Point

See Also

MathControl Class
SMath.Control Namespace


curFontClr Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..curFontClr Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.curFontClr"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int curFontClr
Visual Basic
Public curFontClr As Integer
Visual C++
public:
int curFontClr
F#
val mutable curFontClr: int

See Also

MathControl Class
SMath.Control Namespace


curLineClr Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..curLineClr Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.curLineClr"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int curLineClr
Visual Basic
Public curLineClr As Integer
Visual C++
public:
int curLineClr
F#
val mutable curLineClr: int

See Also

MathControl Class
SMath.Control Namespace


dependences Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..dependences Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.dependences"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public List<AssemblyInfo> dependences
Visual Basic
Public dependences As List(Of AssemblyInfo)
Visual C++
public:
List<AssemblyInfo>^ dependences
F#
val mutable dependences: List<AssemblyInfo>

See Also

MathControl Class
SMath.Control Namespace


error Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..error Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.error"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int error
Visual Basic
Public error As Integer
Visual C++
public:
int error
F#
val mutable error: int

See Also

MathControl Class
SMath.Control Namespace


finish Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..finish Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.finish"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MathControl..::..DrawInfo[] finish
Visual Basic
Public finish As MathControl..::..DrawInfo()
Visual C++
public:
array<MathControl..::..DrawInfo^>^ finish
F#
val mutable finish: MathControl..::..DrawInfo[]

See Also

MathControl Class
SMath.Control Namespace


finishNum Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..finishNum Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.finishNum"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int finishNum
Visual Basic
Public finishNum As Integer
Visual C++
public:
int finishNum
F#
val mutable finishNum: int

See Also

MathControl Class
SMath.Control Namespace


fraction_type Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..fraction_type Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.fraction_type"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public FractionsType fraction_type
Visual Basic
Public fraction_type As FractionsType
Visual C++
public:
FractionsType fraction_type
F#
val mutable fraction_type: FractionsType

See Also

MathControl Class
SMath.Control Namespace


Inc Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Inc Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.Inc"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Inc
Visual Basic
Public Inc As Integer
Visual C++
public:
int Inc
F#
val mutable Inc: int

See Also

MathControl Class
SMath.Control Namespace


mem Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..mem Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.mem"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MathControl..::..DrawMemory[] mem
Visual Basic
Public mem As MathControl..::..DrawMemory()
Visual C++
public:
array<MathControl..::..DrawMemory^>^ mem
F#
val mutable mem: MathControl..::..DrawMemory[]

See Also

MathControl Class
SMath.Control Namespace


rename Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..rename Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.rename"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool rename
Visual Basic
Public rename As Boolean
Visual C++
public:
bool rename
F#
val mutable rename: bool

See Also

MathControl Class
SMath.Control Namespace


sel Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..sel Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.sel"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int[] sel
Visual Basic
Public sel As Integer()
Visual C++
public:
array<int>^ sel
F#
val mutable sel: int[]

See Also

MathControl Class
SMath.Control Namespace


termsToRename Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..termsToRename Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.termsToRename"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public List<int> termsToRename
Visual Basic
Public termsToRename As List(Of Integer)
Visual C++
public:
List<int>^ termsToRename
F#
val mutable termsToRename: List<int>

See Also

MathControl Class
SMath.Control Namespace


values Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..values Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.values"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Definition[] values
Visual Basic
Public values As Definition()
Visual C++
public:
array<Definition^>^ values
F#
val mutable values: Definition[]

See Also

MathControl Class
SMath.Control Namespace


watch Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..watch Field
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.watch"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int[] watch
Visual Basic
Public watch As Integer()
Visual C++
public:
array<int>^ watch
F#
val mutable watch: int[]

See Also

MathControl Class
SMath.Control Namespace


MathControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Methods
MathControl Class See Also Send Feedback

The MathControl type exposes the following members.

Methods

 | Name | Description
Public method | Action(String) | Редактирование текущей формулы, при помощи вставки управляющей строки либо произвольной строки/символа формулы. (Overrides CommonControl..::..Action(String).)
Public method | Action(array<Term>[]()[][]) |
Public method | Action(array<Term>[]()[][], array<Term>[]()[][], CalculateType) | Составляет итоговое выражение из задания, знака решения и ответа
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Public method | CustomDrawEllipse |
Public method | CustomDrawRectangle |
Public method | CustomFillEllipse |
Public method | CustomFillRectangle |
Protected method | CustomLineDrawing(PaintEventArgs, Pen, Int32, Int32, Int32, Int32) | (Inherited from CommonControl.)
Public method | CustomLineDrawing(PaintEventArgs, Int32, Int32, Int32, Int32, Int32, Int32) |
Public method | CustomStringDrawing |
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32) |
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32, array<Point>[]()[][]) |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | Обработчик реакции контрола на нажатие клавишь мыши (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | Обработчик реакции контрола на движение мышью (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | Отрисовка выражения (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно. (Overrides CommonControl..::..PrePainter()()()().)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

See Also

MathControl Class
SMath.Control Namespace


Action Method

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..Action Method
MathControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Action(String) | Редактирование текущей формулы, при помощи вставки управляющей строки либо произвольной строки/символа формулы. (Overrides CommonControl..::..Action(String).)
Public method | Action(array<Term>[]()[][]) |
Public method | Action(array<Term>[]()[][], array<Term>[]()[][], CalculateType) | Составляет итоговое выражение из задания, знака решения и ответа

See Also

MathControl Class
MathControl Members
SMath.Control Namespace


Action Method (String)

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Action Method (String)
MathControl Class See Also Send Feedback
Редактирование текущей формулы, при помощи вставки управляющей строки либо произвольной строки/символа формулы.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void Action(
    string value
)
Visual Basic
Public Overrides Sub Action ( _
    value As String _
)
Visual C++
public:
virtual void Action(
    String^ value
) override
F#
abstract Action :
        value:string -> unit
override Action :
        value:string -> unit

Parameters

value
Type: System..::..String
Строка для вставки или управляющее выражение

See Also

MathControl Class
Action Overload
SMath.Control Namespace


Action Method (Term[])

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Action Method (array<Term>[]()[][])
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.Action(SMath.Manager.Term[])"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Action(
    Term[] value
)
Visual Basic
Public Sub Action ( _
    value As Term() _
)
Visual C++
public:
void Action(
    array<Term^>^ value
)
F#
member Action :
        value:Term[] -> unit

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="value"/> documentation for "M:SMath.Control.MathControl.Action(SMath.Manager.Term[])"]

See Also

MathControl Class
Action Overload
SMath.Control Namespace


Action Method (Term[], Term[], CalculateType)

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Action Method (array<Term>[]()[][], array<Term>[]()[][], CalculateType)
MathControl Class See Also Send Feedback
Составляет итоговое выражение из задания, знака решения и ответа

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Action(
    Term[] left,
    Term[] right,
    CalculateType type
)
Visual Basic
Public Sub Action ( _
    left As Term(), _
    right As Term(), _
    type As CalculateType _
)
Visual C++
public:
void Action(
    array<Term^>^ left,
    array<Term^>^ right,
    CalculateType type
)
F#
member Action :
        left:Term[] *
        right:Term[] *
        type:CalculateType -> unit

Parameters

left
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="left"/> documentation for "M:SMath.Control.MathControl.Action(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

right
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="right"/> documentation for "M:SMath.Control.MathControl.Action(SMath.Manager.Term[],SMath.Manager.Term[],SMath.Control.CalculateType)"]

type
Type: SMath.Control..::..CalculateType
Оператор решения

See Also

MathControl Class
Action Overload
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Clone Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CommonControl Clone()
Visual Basic
Public Overrides Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone() override
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.MathControl.Clone"]

See Also

MathControl Class
SMath.Control Namespace


CustomDrawEllipse Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomDrawEllipse Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomDrawEllipse(
    PaintEventArgs e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
Visual Basic
Public Sub CustomDrawEllipse ( _
    e As PaintEventArgs, _
    penNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomDrawEllipse(
    PaintEventArgs^ e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
F#
member CustomDrawEllipse :
        e:PaintEventArgs *
        penNo:int *
        x1:int *
        y1:int *
        x2:int *
        y2:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

penNo
Type: System..::..Int32

[Missing <param name="penNo"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomDrawEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
SMath.Control Namespace


CustomDrawRectangle Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomDrawRectangle Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomDrawRectangle(
    PaintEventArgs e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
Visual Basic
Public Sub CustomDrawRectangle ( _
    e As PaintEventArgs, _
    penNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomDrawRectangle(
    PaintEventArgs^ e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
F#
member CustomDrawRectangle :
        e:PaintEventArgs *
        penNo:int *
        x1:int *
        y1:int *
        x2:int *
        y2:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

penNo
Type: System..::..Int32

[Missing <param name="penNo"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomDrawRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
SMath.Control Namespace


CustomFillEllipse Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomFillEllipse Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomFillEllipse(
    PaintEventArgs e,
    int brushNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
Visual Basic
Public Sub CustomFillEllipse ( _
    e As PaintEventArgs, _
    brushNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomFillEllipse(
    PaintEventArgs^ e,
    int brushNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
F#
member CustomFillEllipse :
        e:PaintEventArgs *
        brushNo:int *
        x1:int *
        y1:int *
        x2:int *
        y2:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

brushNo
Type: System..::..Int32

[Missing <param name="brushNo"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomFillEllipse(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
SMath.Control Namespace


CustomFillRectangle Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomFillRectangle Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomFillRectangle(
    PaintEventArgs e,
    int brushNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
Visual Basic
Public Sub CustomFillRectangle ( _
    e As PaintEventArgs, _
    brushNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomFillRectangle(
    PaintEventArgs^ e,
    int brushNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
F#
member CustomFillRectangle :
        e:PaintEventArgs *
        brushNo:int *
        x1:int *
        y1:int *
        x2:int *
        y2:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

brushNo
Type: System..::..Int32

[Missing <param name="brushNo"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomFillRectangle(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
SMath.Control Namespace


CustomLineDrawing Method

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomLineDrawing Method
MathControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | CustomLineDrawing(PaintEventArgs, Pen, Int32, Int32, Int32, Int32) | (Inherited from CommonControl.)
Public method | CustomLineDrawing(PaintEventArgs, Int32, Int32, Int32, Int32, Int32, Int32) |

See Also

MathControl Class
MathControl Members
SMath.Control Namespace


CustomLineDrawing Method (PaintEventArgs, Int32, Int32, Int32, Int32, Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomLineDrawing Method (PaintEventArgs, Int32, Int32, Int32, Int32, Int32, Int32)
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomLineDrawing(
    PaintEventArgs e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
Visual Basic
Public Sub CustomLineDrawing ( _
    e As PaintEventArgs, _
    penNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomLineDrawing(
    PaintEventArgs^ e,
    int penNo,
    int x1,
    int y1,
    int x2,
    int y2,
    int memNo
)
F#
member CustomLineDrawing :
        e:PaintEventArgs *
        penNo:int *
        x1:int *
        y1:int *
        x2:int *
        y2:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

penNo
Type: System..::..Int32

[Missing <param name="penNo"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x2
Type: System..::..Int32

[Missing <param name="x2"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y2
Type: System..::..Int32

[Missing <param name="y2"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomLineDrawing(System.Windows.Forms.PaintEventArgs,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
CustomLineDrawing Overload
SMath.Control Namespace


CustomStringDrawing Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..CustomStringDrawing Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void CustomStringDrawing(
    PaintEventArgs e,
    string text,
    int brushNo,
    int x1,
    int y1,
    int memNo
)
Visual Basic
Public Sub CustomStringDrawing ( _
    e As PaintEventArgs, _
    text As String, _
    brushNo As Integer, _
    x1 As Integer, _
    y1 As Integer, _
    memNo As Integer _
)
Visual C++
public:
void CustomStringDrawing(
    PaintEventArgs^ e,
    String^ text,
    int brushNo,
    int x1,
    int y1,
    int memNo
)
F#
member CustomStringDrawing :
        e:PaintEventArgs *
        text:string *
        brushNo:int *
        x1:int *
        y1:int *
        memNo:int -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

brushNo
Type: System..::..Int32

[Missing <param name="brushNo"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

x1
Type: System..::..Int32

[Missing <param name="x1"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

y1
Type: System..::..Int32

[Missing <param name="y1"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

memNo
Type: System..::..Int32

[Missing <param name="memNo"/> documentation for "M:SMath.Control.MathControl.CustomStringDrawing(System.Windows.Forms.PaintEventArgs,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

MathControl Class
SMath.Control Namespace


DrawWizard Method

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawWizard Method
MathControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32) |
Public method | DrawWizard(Int32, Int32, array<Point>[]()[][], Int32, Int32, array<Point>[]()[][]) |

See Also

MathControl Class
MathControl Members
SMath.Control Namespace


DrawWizard Method (Int32, Int32, Point[], Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawWizard Method (Int32, Int32, array<Point>[]()[][], Int32, Int32)
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void DrawWizard(
    int pageWidth,
    int pageHeight,
    Point[] pnts,
    int i,
    int center
)
Visual Basic
Public Sub DrawWizard ( _
    pageWidth As Integer, _
    pageHeight As Integer, _
    pnts As Point(), _
    i As Integer, _
    center As Integer _
)
Visual C++
public:
void DrawWizard(
    int pageWidth,
    int pageHeight,
    array<Point>^ pnts,
    int i,
    int center
)
F#
member DrawWizard :
        pageWidth:int *
        pageHeight:int *
        pnts:Point[] *
        i:int *
        center:int -> unit

Parameters

pageWidth
Type: System..::..Int32

[Missing <param name="pageWidth"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

pageHeight
Type: System..::..Int32

[Missing <param name="pageHeight"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

pnts
Type: array< System.Drawing..::..Point >[]()[][]

[Missing <param name="pnts"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

center
Type: System..::..Int32

[Missing <param name="center"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32)"]

See Also

MathControl Class
DrawWizard Overload
SMath.Control Namespace


DrawWizard Method (Int32, Int32, Point[], Int32, Int32, Point[])

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawWizard Method (Int32, Int32, array<Point>[]()[][], Int32, Int32, array<Point>[]()[][])
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void DrawWizard(
    int pageWidth,
    int pageHeight,
    Point[] pnts,
    int i,
    int center,
    Point[] pntsAlter
)
Visual Basic
Public Sub DrawWizard ( _
    pageWidth As Integer, _
    pageHeight As Integer, _
    pnts As Point(), _
    i As Integer, _
    center As Integer, _
    pntsAlter As Point() _
)
Visual C++
public:
void DrawWizard(
    int pageWidth,
    int pageHeight,
    array<Point>^ pnts,
    int i,
    int center,
    array<Point>^ pntsAlter
)
F#
member DrawWizard :
        pageWidth:int *
        pageHeight:int *
        pnts:Point[] *
        i:int *
        center:int *
        pntsAlter:Point[] -> unit

Parameters

pageWidth
Type: System..::..Int32

[Missing <param name="pageWidth"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

pageHeight
Type: System..::..Int32

[Missing <param name="pageHeight"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

pnts
Type: array< System.Drawing..::..Point >[]()[][]

[Missing <param name="pnts"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

center
Type: System..::..Int32

[Missing <param name="center"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

pntsAlter
Type: array< System.Drawing..::..Point >[]()[][]

[Missing <param name="pntsAlter"/> documentation for "M:SMath.Control.MathControl.DrawWizard(System.Int32,System.Int32,System.Drawing.Point[],System.Int32,System.Int32,System.Drawing.Point[])"]

See Also

MathControl Class
DrawWizard Overload
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..GetCursorType Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CursorType GetCursorType(
    MouseEventArgs e
)
Visual Basic
Public Overrides Function GetCursorType ( _
    e As MouseEventArgs _
) As CursorType
Visual C++
public:
virtual CursorType GetCursorType(
    MouseEventArgs^ e
) override
F#
abstract GetCursorType :
        e:MouseEventArgs -> CursorType
override GetCursorType :
        e:MouseEventArgs -> CursorType

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.MathControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

See Also

MathControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..GetImage Method
MathControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

MathControl Class
MathControl Members
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..OnMouseDown Method
MathControl Class See Also Send Feedback
Обработчик реакции контрола на нажатие клавишь мыши

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
Абсолютные координаты места курсора мыши

See Also

MathControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..OnMouseMove Method
MathControl Class See Also Send Feedback
Обработчик реакции контрола на движение мышью

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
Абсолютные координаты места курсора мыши

See Also

MathControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..OnMouseUp Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

MathControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..OnPaint Method
MathControl Class See Also Send Feedback
Отрисовка выражения

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.MathControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

MathControl Class
SMath.Control Namespace


PrePainter Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..PrePainter Method
MathControl Class See Also Send Feedback
Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void PrePainter()
Visual Basic
Public Overrides Sub PrePainter
Visual C++
public:
virtual void PrePainter() override
F#
abstract PrePainter : unit -> unit
override PrePainter : unit -> unit

See Also

MathControl Class
SMath.Control Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..ToString Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.ToString"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Control.MathControl.ToString"]

See Also

MathControl Class
SMath.Control Namespace


UndoRedoManager Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..UndoRedoManager Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.UndoRedoManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UndoRedoManager(
    string referer
)
Visual Basic
Public Overrides Sub UndoRedoManager ( _
    referer As String _
)
Visual C++
public:
virtual void UndoRedoManager(
    String^ referer
) override
F#
abstract UndoRedoManager :
        referer:string -> unit
override UndoRedoManager :
        referer:string -> unit

Parameters

referer
Type: System..::..String

[Missing <param name="referer"/> documentation for "M:SMath.Control.MathControl.UndoRedoManager(System.String)"]

See Also

MathControl Class
SMath.Control Namespace


UnReDoAccept Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..UnReDoAccept Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void UnReDoAccept(
    UnReDO_Common unReDo_Common
)
Visual Basic
Protected Overrides Sub UnReDoAccept ( _
    unReDo_Common As UnReDO_Common _
)
Visual C++
protected:
virtual void UnReDoAccept(
    UnReDO_Common^ unReDo_Common
) override
F#
abstract UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit
override UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit

Parameters

unReDo_Common
Type: SMath.Control..::..UnReDO_Common

[Missing <param name="unReDo_Common"/> documentation for "M:SMath.Control.MathControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

See Also

MathControl Class
SMath.Control Namespace


UnReInit Method

[image]

SMath Studio Class Libraries Documantation
MathControl..::..UnReInit Method
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.MathControl.UnReInit"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UnReInit()
Visual Basic
Public Overrides Sub UnReInit
Visual C++
public:
virtual void UnReInit() override
F#
abstract UnReInit : unit -> unit
override UnReInit : unit -> unit

See Also

MathControl Class
SMath.Control Namespace


MathControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Properties
MathControl Class See Also Send Feedback

The MathControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | (Overrides CommonControl..::..ErrorText.)
Public property | Evaluate |
Public property | Focused | (Overrides CommonControl..::..Focused.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | InEvaluation |
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Optimize |
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | Terms | Массив элементов математического выражения
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | Units |
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

MathControl Class
SMath.Control Namespace


ErrorText Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..ErrorText Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.ErrorText"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string ErrorText { get; set; }
Visual Basic
Public Overrides Property ErrorText As String
    Get
    Set
Visual C++
public:
virtual property String^ ErrorText {
    String^ get () override;
    void set (String^ value) override;
}
F#
abstract ErrorText : string with get, set
override ErrorText : string with get, set

See Also

MathControl Class
SMath.Control Namespace


Evaluate Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Evaluate Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.Evaluate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Evaluate { get; set; }
Visual Basic
Public Property Evaluate As Boolean
    Get
    Set
Visual C++
public:
property bool Evaluate {
    bool get ();
    void set (bool value);
}
F#
member Evaluate : bool with get, set

See Also

MathControl Class
SMath.Control Namespace


Focused Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Focused Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.Focused"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override bool Focused { get; set; }
Visual Basic
Public Overrides Property Focused As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Focused {
    bool get () override;
    void set (bool value) override;
}
F#
abstract Focused : bool with get, set
override Focused : bool with get, set

See Also

MathControl Class
SMath.Control Namespace


InEvaluation Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..InEvaluation Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.InEvaluation"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool InEvaluation { get; set; }
Visual Basic
Public Property InEvaluation As Boolean
    Get
    Set
Visual C++
public:
property bool InEvaluation {
    bool get ();
    void set (bool value);
}
F#
member InEvaluation : bool with get, set

See Also

MathControl Class
SMath.Control Namespace


Optimize Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Optimize Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.Optimize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public OptimizationType Optimize { get; set; }
Visual Basic
Public Property Optimize As OptimizationType
    Get
    Set
Visual C++
public:
property OptimizationType Optimize {
    OptimizationType get ();
    void set (OptimizationType value);
}
F#
member Optimize : OptimizationType with get, set

See Also

MathControl Class
SMath.Control Namespace


Terms Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Terms Property
MathControl Class See Also Send Feedback
Массив элементов математического выражения

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Term[] Terms { get; set; }
Visual Basic
Public Property Terms As Term()
    Get
    Set
Visual C++
public:
property array<Term^>^ Terms {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
F#
member Terms : Term[] with get, set

See Also

MathControl Class
SMath.Control Namespace


Units Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..Units Property
MathControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.MathControl.Units"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Term[] Units { get; set; }
Visual Basic
Public Property Units As Term()
    Get
    Set
Visual C++
public:
property array<Term^>^ Units {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
F#
member Units : Term[] with get, set

See Also

MathControl Class
SMath.Control Namespace


MathControl Events

[image] [image]

SMath Studio Class Libraries Documantation
MathControl Events
MathControl Class See Also Send Feedback

The MathControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

MathControl Class
SMath.Control Namespace


MathControl.DrawInfo Class

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo Class
MathControl Class Members See Also Send Feedback
Вспомогательный класс. Предназначен для сохранения первых результатов обработки элементов формулы перед отрисовкой

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class DrawInfo
Visual Basic
Public Class DrawInfo
Visual C++
public ref class DrawInfo
F#
type DrawInfo =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..MathControl..::..DrawInfo

See Also

MathControl..::..DrawInfo Members
SMath.Control Namespace


MathControl.DrawInfo Members

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo Members
MathControl..::..DrawInfo Class Constructors Properties See Also Send Feedback

Элемент интерфейса для создания и редактирования математического выражения

The MathControl..::..DrawInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MathControl..::..DrawInfo | Конструктор класса.

Properties

 | Name | Description
Public property | Center | Центральная (вертикально) точка элемента
Public property | Priority | Приоритет элемента. Необходим для проверки глубины элемента при определении положения кукрсора
Public property | Size | Размер отрисованного элемента

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


MathControl.DrawInfo Constructor

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo Constructor
MathControl..::..DrawInfo Class See Also Send Feedback
Конструктор класса.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public DrawInfo(
    Size size,
    int center,
    int priority
)
Visual Basic
Public Sub New ( _
    size As Size, _
    center As Integer, _
    priority As Integer _
)
Visual C++
public:
DrawInfo(
    Size size,
    int center,
    int priority
)
F#
new :
        size:Size *
        center:int *
        priority:int -> DrawInfo

Parameters

size
Type: System.Drawing..::..Size
Размер отрисованного элемента
center
Type: System..::..Int32
Центральная (вертикально) точка элемента
priority
Type: System..::..Int32
Приоритет элемента. Необходим для проверки глубины элемента при определении положения кукрсора

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


MathControl.DrawInfo Properties

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo Properties
MathControl..::..DrawInfo Class See Also Send Feedback

The MathControl..::..DrawInfo type exposes the following members.

Properties

 | Name | Description
Public property | Center | Центральная (вертикально) точка элемента
Public property | Priority | Приоритет элемента. Необходим для проверки глубины элемента при определении положения кукрсора
Public property | Size | Размер отрисованного элемента

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


Center Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo..::..Center Property
MathControl..::..DrawInfo Class See Also Send Feedback
Центральная (вертикально) точка элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Center { get; set; }
Visual Basic
Public Property Center As Integer
    Get
    Set
Visual C++
public:
property int Center {
    int get ();
    void set (int value);
}
F#
member Center : int with get, set

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


Priority Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo..::..Priority Property
MathControl..::..DrawInfo Class See Also Send Feedback
Приоритет элемента. Необходим для проверки глубины элемента при определении положения кукрсора

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Priority { get; set; }
Visual Basic
Public Property Priority As Integer
    Get
    Set
Visual C++
public:
property int Priority {
    int get ();
    void set (int value);
}
F#
member Priority : int with get, set

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


Size Property

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawInfo..::..Size Property
MathControl..::..DrawInfo Class See Also Send Feedback
Размер отрисованного элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set
Visual C++
public:
property Size Size {
    Size get ();
    void set (Size value);
}
F#
member Size : Size with get, set

See Also

MathControl..::..DrawInfo Class
SMath.Control Namespace


MathControl.DrawMemory Class

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory Class
MathControl Class Members See Also Send Feedback
Вспомогательный класс. Содержит исчерпывающую информацию для отрисовки математического выражения

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class DrawMemory
Visual Basic
Public Class DrawMemory
Visual C++
public ref class DrawMemory
F#
type DrawMemory =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..MathControl..::..DrawMemory

See Also

MathControl..::..DrawMemory Members
SMath.Control Namespace


MathControl.DrawMemory Members

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory Members
MathControl..::..DrawMemory Class Constructors Fields See Also Send Feedback

Элемент интерфейса для создания и редактирования математического выражения

The MathControl..::..DrawMemory type exposes the following members.

Constructors

 | Name | Description
Public method | MathControl..::..DrawMemory | Конструктор класса.

Fields

 | Name | Description
Public field | AltLoc | Дополнительные абсолютные координаты для отрисовки Используются, например, в функции дифференцирования с тремя аргументами
Public field | Center | Относительная центральная точка (по вертикали) элемента
Public field | Duplicate |
Public field | FunctionTextBounds |
Public field | IsCommonFunction |
Public field | IsUnit |
Public field | Location | Абсолютные координаты элемента в формуле при отрисовке
Public field | pm | Зависимые элементы. Массив позиций начальных составляющих элементов, "поглащённых" текущим
Public field | Size | Размер отрисованного элемента
Public field | Text | Имя элемента
Public field | Type | Тип элемента

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


MathControl.DrawMemory Constructor

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory Constructor
MathControl..::..DrawMemory Class See Also Send Feedback
Конструктор класса.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public DrawMemory(
    string text,
    TermType type,
    Point location,
    Size size,
    int[] pm,
    int center
)
Visual Basic
Public Sub New ( _
    text As String, _
    type As TermType, _
    location As Point, _
    size As Size, _
    pm As Integer(), _
    center As Integer _
)
Visual C++
public:
DrawMemory(
    String^ text,
    TermType type,
    Point location,
    Size size,
    array<int>^ pm,
    int center
)
F#
new :
        text:string *
        type:TermType *
        location:Point *
        size:Size *
        pm:int[] *
        center:int -> DrawMemory

Parameters

text
Type: System..::..String
Имя элемента
type
Type: SMath.Manager..::..TermType
Тип элемента
location
Type: System.Drawing..::..Point
Абсолютные координаты элемента в формуле при отрисовке
size
Type: System.Drawing..::..Size
Размер отрисованного элемента
pm
Type: array< System..::..Int32 >[]()[][]
Зависимые элементы. Массив позиций начальных составляющих элементов, "поглащённых" текущим
center
Type: System..::..Int32
Относительная центральная точка (по вертикали) элемента

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


MathControl.DrawMemory Fields

[image] [image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory Fields
MathControl..::..DrawMemory Class See Also Send Feedback

The MathControl..::..DrawMemory type exposes the following members.

Fields

 | Name | Description
Public field | AltLoc | Дополнительные абсолютные координаты для отрисовки Используются, например, в функции дифференцирования с тремя аргументами
Public field | Center | Относительная центральная точка (по вертикали) элемента
Public field | Duplicate |
Public field | FunctionTextBounds |
Public field | IsCommonFunction |
Public field | IsUnit |
Public field | Location | Абсолютные координаты элемента в формуле при отрисовке
Public field | pm | Зависимые элементы. Массив позиций начальных составляющих элементов, "поглащённых" текущим
Public field | Size | Размер отрисованного элемента
Public field | Text | Имя элемента
Public field | Type | Тип элемента

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


AltLoc Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..AltLoc Field
MathControl..::..DrawMemory Class See Also Send Feedback
Дополнительные абсолютные координаты для отрисовки Используются, например, в функции дифференцирования с тремя аргументами

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point AltLoc
Visual Basic
Public AltLoc As Point
Visual C++
public:
Point AltLoc
F#
val mutable AltLoc: Point

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Center Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Center Field
MathControl..::..DrawMemory Class See Also Send Feedback
Относительная центральная точка (по вертикали) элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Center
Visual Basic
Public Center As Integer
Visual C++
public:
int Center
F#
val mutable Center: int

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Duplicate Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Duplicate Field
MathControl..::..DrawMemory Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.DrawMemory.Duplicate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Duplicate
Visual Basic
Public Duplicate As Boolean
Visual C++
public:
bool Duplicate
F#
val mutable Duplicate: bool

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


FunctionTextBounds Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..FunctionTextBounds Field
MathControl..::..DrawMemory Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.DrawMemory.FunctionTextBounds"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Rectangle FunctionTextBounds
Visual Basic
Public FunctionTextBounds As Rectangle
Visual C++
public:
Rectangle FunctionTextBounds
F#
val mutable FunctionTextBounds: Rectangle

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


IsCommonFunction Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..IsCommonFunction Field
MathControl..::..DrawMemory Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.DrawMemory.IsCommonFunction"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool IsCommonFunction
Visual Basic
Public IsCommonFunction As Boolean
Visual C++
public:
bool IsCommonFunction
F#
val mutable IsCommonFunction: bool

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


IsUnit Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..IsUnit Field
MathControl..::..DrawMemory Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.MathControl.DrawMemory.IsUnit"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool IsUnit
Visual Basic
Public IsUnit As Boolean
Visual C++
public:
bool IsUnit
F#
val mutable IsUnit: bool

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Location Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Location Field
MathControl..::..DrawMemory Class See Also Send Feedback
Абсолютные координаты элемента в формуле при отрисовке

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point Location
Visual Basic
Public Location As Point
Visual C++
public:
Point Location
F#
val mutable Location: Point

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


pm Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..pm Field
MathControl..::..DrawMemory Class See Also Send Feedback
Зависимые элементы. Массив позиций начальных составляющих элементов, "поглащённых" текущим

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int[] pm
Visual Basic
Public pm As Integer()
Visual C++
public:
array<int>^ pm
F#
val mutable pm: int[]

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Size Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Size Field
MathControl..::..DrawMemory Class See Also Send Feedback
Размер отрисованного элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Size Size
Visual Basic
Public Size As Size
Visual C++
public:
Size Size
F#
val mutable Size: Size

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Text Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Text Field
MathControl..::..DrawMemory Class See Also Send Feedback
Имя элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Text
Visual Basic
Public Text As String
Visual C++
public:
String^ Text
F#
val mutable Text: string

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


Type Field

[image]

SMath Studio Class Libraries Documantation
MathControl..::..DrawMemory..::..Type Field
MathControl..::..DrawMemory Class See Also Send Feedback
Тип элемента

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public TermType Type
Visual Basic
Public Type As TermType
Visual C++
public:
TermType Type
F#
val mutable Type: TermType

See Also

MathControl..::..DrawMemory Class
SMath.Control Namespace


MouseEventType Enumeration

[image]

SMath Studio Class Libraries Documantation
MouseEventType Enumeration
See Also Send Feedback
Выбор типа реакции на движения мыши.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum MouseEventType
Visual Basic
Public Enumeration MouseEventType
Visual C++
public enum class MouseEventType
F#
type MouseEventType

Members

Member name | Value | Description
Rotate | 0 | Вращение точек относительно центра координат (вращение изображения).
Scroll | 1 | Перемещение точек в плоскости дисплея (перемещение изображения).
Scale | 2 | Изменение расстояния между точками (изменение размера изображения).

See Also

SMath.Control Namespace


PageControlMajorChangeEventHandler Delegate

[image]

SMath Studio Class Libraries Documantation
PageControlMajorChangeEventHandler Delegate
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.PageControlMajorChangeEventHandler"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public delegate void PageControlMajorChangeEventHandler(
    CommonControl sender,
    UnReDoType type,
    string value
)
Visual Basic
Public Delegate Sub PageControlMajorChangeEventHandler ( _
    sender As CommonControl, _
    type As UnReDoType, _
    value As String _
)
Visual C++
public delegate void PageControlMajorChangeEventHandler(
    CommonControl^ sender,
    UnReDoType type,
    String^ value
)
F#
type PageControlMajorChangeEventHandler =
    delegate of
        sender:CommonControl *
        type:UnReDoType *
        value:string -> unit

Parameters

sender
Type: SMath.Control..::..CommonControl
type
Type: SMath.Control..::..UnReDoType
value
Type: System..::..String

See Also

SMath.Control Namespace


PageStatusChangedEventHandler Delegate

[image]

SMath Studio Class Libraries Documantation
PageStatusChangedEventHandler Delegate
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.PageStatusChangedEventHandler"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public delegate void PageStatusChangedEventHandler(
    CanvasControl sender,
    CanvasStatus status
)
Visual Basic
Public Delegate Sub PageStatusChangedEventHandler ( _
    sender As CanvasControl, _
    status As CanvasStatus _
)
Visual C++
public delegate void PageStatusChangedEventHandler(
    CanvasControl^ sender,
    CanvasStatus^ status
)
F#
type PageStatusChangedEventHandler =
    delegate of
        sender:CanvasControl *
        status:CanvasStatus -> unit

Parameters

sender
Type: SMath.Control..::..CanvasControl
status
Type: SMath.Control..::..CanvasStatus

See Also

SMath.Control Namespace


PictureControl Class

[image]

SMath Studio Class Libraries Documantation
PictureControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.PictureControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class PictureControl : CommonControl
Visual Basic
Public Class PictureControl _
    Inherits CommonControl
Visual C++
public ref class PictureControl : public CommonControl
F#
type PictureControl =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..PictureControl

See Also

PictureControl Members
SMath.Control Namespace


PictureControl Members

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Members
PictureControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The PictureControl type exposes the following members.

Constructors

 | Name | Description
Public method | PictureControl()()()() |
Public method | PictureControl(PictureControl) |

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Clear |
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | ExportImage |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | LoadImage |
Public method | LoadImageBitmap |
Public method | LoadImageFromStream |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | SetPenColor |
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Inherited from CommonControl.)
Protected method | UnReDoAccept | Применение параметров шага истории к элементу (Inherited from CommonControl.)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

PictureControl Class
SMath.Control Namespace


PictureControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Constructor
PictureControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PictureControl()()()() | Initializes a new instance of the PictureControl class
Public method | PictureControl(PictureControl) | Initializes a new instance of the PictureControl class

See Also

PictureControl Class
PictureControl Members
SMath.Control Namespace


PictureControl Constructor

[image]

SMath Studio Class Libraries Documantation
PictureControl Constructor
PictureControl Class See Also Send Feedback
Initializes a new instance of the PictureControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PictureControl()
Visual Basic
Public Sub New
Visual C++
public:
PictureControl()
F#
new : unit -> PictureControl

See Also

PictureControl Class
PictureControl Overload
SMath.Control Namespace


PictureControl Constructor (PictureControl)

[image]

SMath Studio Class Libraries Documantation
PictureControl Constructor (PictureControl)
PictureControl Class See Also Send Feedback
Initializes a new instance of the PictureControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PictureControl(
    PictureControl value
)
Visual Basic
Public Sub New ( _
    value As PictureControl _
)
Visual C++
public:
PictureControl(
    PictureControl^ value
)
F#
new :
        value:PictureControl -> PictureControl

Parameters

value
Type: SMath.Control..::..PictureControl

[Missing <param name="value"/> documentation for "M:SMath.Control.PictureControl.#ctor(SMath.Control.PictureControl)"]

See Also

PictureControl Class
PictureControl Overload
SMath.Control Namespace


PictureControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Fields
PictureControl Class See Also Send Feedback

The PictureControl type exposes the following members.

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

See Also

PictureControl Class
SMath.Control Namespace


PictureControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Methods
PictureControl Class See Also Send Feedback

The PictureControl type exposes the following members.

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Clear |
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | ExportImage |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | LoadImage |
Public method | LoadImageBitmap |
Public method | LoadImageFromStream |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | SetPenColor |
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Inherited from CommonControl.)
Protected method | UnReDoAccept | Применение параметров шага истории к элементу (Inherited from CommonControl.)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

See Also

PictureControl Class
SMath.Control Namespace


Clear Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..Clear Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.Clear(System.Boolean)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Clear(
    bool ClearCapturedLines
)
Visual Basic
Public Sub Clear ( _
    ClearCapturedLines As Boolean _
)
Visual C++
public:
void Clear(
    bool ClearCapturedLines
)
F#
member Clear :
        ClearCapturedLines:bool -> unit

Parameters

ClearCapturedLines
Type: System..::..Boolean

[Missing <param name="ClearCapturedLines"/> documentation for "M:SMath.Control.PictureControl.Clear(System.Boolean)"]

See Also

PictureControl Class
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..Clone Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CommonControl Clone()
Visual Basic
Public Overrides Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone() override
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.PictureControl.Clone"]

See Also

PictureControl Class
SMath.Control Namespace


ExportImage Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..ExportImage Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.ExportImage"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Bitmap ExportImage()
Visual Basic
Public Function ExportImage As Bitmap
Visual C++
public:
Bitmap^ ExportImage()
F#
member ExportImage : unit -> Bitmap

Return Value

[Missing <returns> documentation for "M:SMath.Control.PictureControl.ExportImage"]

See Also

PictureControl Class
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..GetCursorType Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CursorType GetCursorType(
    MouseEventArgs e
)
Visual Basic
Public Overrides Function GetCursorType ( _
    e As MouseEventArgs _
) As CursorType
Visual C++
public:
virtual CursorType GetCursorType(
    MouseEventArgs^ e
) override
F#
abstract GetCursorType :
        e:MouseEventArgs -> CursorType
override GetCursorType :
        e:MouseEventArgs -> CursorType

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PictureControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.PictureControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

See Also

PictureControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl..::..GetImage Method
PictureControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

PictureControl Class
PictureControl Members
SMath.Control Namespace


LoadImage Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..LoadImage Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.LoadImage(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void LoadImage(
    string ImageFileName
)
Visual Basic
Public Sub LoadImage ( _
    ImageFileName As String _
)
Visual C++
public:
void LoadImage(
    String^ ImageFileName
)
F#
member LoadImage :
        ImageFileName:string -> unit

Parameters

ImageFileName
Type: System..::..String

[Missing <param name="ImageFileName"/> documentation for "M:SMath.Control.PictureControl.LoadImage(System.String)"]

See Also

PictureControl Class
SMath.Control Namespace


LoadImageBitmap Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..LoadImageBitmap Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.LoadImageBitmap(System.Drawing.Bitmap)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void LoadImageBitmap(
    Bitmap ImageFileStream
)
Visual Basic
Public Sub LoadImageBitmap ( _
    ImageFileStream As Bitmap _
)
Visual C++
public:
void LoadImageBitmap(
    Bitmap^ ImageFileStream
)
F#
member LoadImageBitmap :
        ImageFileStream:Bitmap -> unit

Parameters

ImageFileStream
Type: System.Drawing..::..Bitmap

[Missing <param name="ImageFileStream"/> documentation for "M:SMath.Control.PictureControl.LoadImageBitmap(System.Drawing.Bitmap)"]

See Also

PictureControl Class
SMath.Control Namespace


LoadImageFromStream Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..LoadImageFromStream Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.LoadImageFromStream(System.IO.Stream)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void LoadImageFromStream(
    Stream ImageFileStream
)
Visual Basic
Public Sub LoadImageFromStream ( _
    ImageFileStream As Stream _
)
Visual C++
public:
void LoadImageFromStream(
    Stream^ ImageFileStream
)
F#
member LoadImageFromStream :
        ImageFileStream:Stream -> unit

Parameters

ImageFileStream
Type: System.IO..::..Stream

[Missing <param name="ImageFileStream"/> documentation for "M:SMath.Control.PictureControl.LoadImageFromStream(System.IO.Stream)"]

See Also

PictureControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..OnMouseDown Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PictureControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

PictureControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..OnMouseMove Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PictureControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

PictureControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..OnMouseUp Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PictureControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

PictureControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..OnPaint Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PictureControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

PictureControl Class
SMath.Control Namespace


SetPenColor Method

[image]

SMath Studio Class Libraries Documantation
PictureControl..::..SetPenColor Method
PictureControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PictureControl.SetPenColor(System.Drawing.Color)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetPenColor(
    Color penColour
)
Visual Basic
Public Sub SetPenColor ( _
    penColour As Color _
)
Visual C++
public:
void SetPenColor(
    Color penColour
)
F#
member SetPenColor :
        penColour:Color -> unit

Parameters

penColour
Type: System.Drawing..::..Color

[Missing <param name="penColour"/> documentation for "M:SMath.Control.PictureControl.SetPenColor(System.Drawing.Color)"]

See Also

PictureControl Class
SMath.Control Namespace


PictureControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Properties
PictureControl Class See Also Send Feedback

The PictureControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

PictureControl Class
SMath.Control Namespace


PictureControl Events

[image] [image]

SMath Studio Class Libraries Documantation
PictureControl Events
PictureControl Class See Also Send Feedback

The PictureControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

PictureControl Class
SMath.Control Namespace


PlotControl Class

[image]

SMath Studio Class Libraries Documantation
PlotControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.PlotControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class PlotControl : CommonControl
Visual Basic
Public Class PlotControl _
    Inherits CommonControl
Visual C++
public ref class PlotControl : public CommonControl
F#
type PlotControl =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..PlotControl

See Also

PlotControl Members
SMath.Control Namespace


PlotControl Members

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Members
PlotControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The PlotControl type exposes the following members.

Constructors

 | Name | Description
Public method | PlotControl()()()() |
Public method | PlotControl(PlotControl) |

Methods

 | Name | Description
Public method | Action | (Overrides CommonControl..::..Action(String).)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetControlType |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | math_CalculateMe |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Public method | Reset |
Protected method | Resize | (Overrides CommonControl..::..Resize()()()().)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

Fields

 | Name | Description
Public field | Accuracy |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | Large |
Public field | math |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | prefs |
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | ren |
Public field | rotate_x |
Public field | rotate_y |
Public field | rotate_z |
Public field | scale_x |
Public field | scale_y |
Public field | scale_z |
Protected field | selecter |
Public field | transpose_x |
Public field | transpose_y |
Public field | transpose_z |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | (Overrides CommonControl..::..ErrorText.)
Public property | Evaluate |
Public property | Focused | (Overrides CommonControl..::..Focused.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | (Overrides CommonControl..::..InDate.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | METype |
Public property | PType |
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | RType |
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

PlotControl Class
SMath.Control Namespace


PlotControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Constructor
PlotControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PlotControl()()()() | Initializes a new instance of the PlotControl class
Public method | PlotControl(PlotControl) | Initializes a new instance of the PlotControl class

See Also

PlotControl Class
PlotControl Members
SMath.Control Namespace


PlotControl Constructor

[image]

SMath Studio Class Libraries Documantation
PlotControl Constructor
PlotControl Class See Also Send Feedback
Initializes a new instance of the PlotControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PlotControl()
Visual Basic
Public Sub New
Visual C++
public:
PlotControl()
F#
new : unit -> PlotControl

See Also

PlotControl Class
PlotControl Overload
SMath.Control Namespace


PlotControl Constructor (PlotControl)

[image]

SMath Studio Class Libraries Documantation
PlotControl Constructor (PlotControl)
PlotControl Class See Also Send Feedback
Initializes a new instance of the PlotControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PlotControl(
    PlotControl value
)
Visual Basic
Public Sub New ( _
    value As PlotControl _
)
Visual C++
public:
PlotControl(
    PlotControl^ value
)
F#
new :
        value:PlotControl -> PlotControl

Parameters

value
Type: SMath.Control..::..PlotControl

[Missing <param name="value"/> documentation for "M:SMath.Control.PlotControl.#ctor(SMath.Control.PlotControl)"]

See Also

PlotControl Class
PlotControl Overload
SMath.Control Namespace


PlotControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Fields
PlotControl Class See Also Send Feedback

The PlotControl type exposes the following members.

Fields

 | Name | Description
Public field | Accuracy |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | Large |
Public field | math |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | prefs |
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | ren |
Public field | rotate_x |
Public field | rotate_y |
Public field | rotate_z |
Public field | scale_x |
Public field | scale_y |
Public field | scale_z |
Protected field | selecter |
Public field | transpose_x |
Public field | transpose_y |
Public field | transpose_z |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

See Also

PlotControl Class
SMath.Control Namespace


Accuracy Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Accuracy Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.Accuracy"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point Accuracy
Visual Basic
Public Accuracy As Point
Visual C++
public:
Point Accuracy
F#
val mutable Accuracy: Point

See Also

PlotControl Class
SMath.Control Namespace


Large Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Large Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.Large"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Large
Visual Basic
Public Large As Integer
Visual C++
public:
int Large
F#
val mutable Large: int

See Also

PlotControl Class
SMath.Control Namespace


math Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..math Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.math"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MathControl math
Visual Basic
Public math As MathControl
Visual C++
public:
MathControl^ math
F#
val mutable math: MathControl

See Also

PlotControl Class
SMath.Control Namespace


prefs Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..prefs Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.prefs"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool prefs
Visual Basic
Public prefs As Boolean
Visual C++
public:
bool prefs
F#
val mutable prefs: bool

See Also

PlotControl Class
SMath.Control Namespace


ren Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..ren Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.ren"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Renderer ren
Visual Basic
Public ren As Renderer
Visual C++
public:
Renderer^ ren
F#
val mutable ren: Renderer

See Also

PlotControl Class
SMath.Control Namespace


rotate_x Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..rotate_x Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.rotate_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_x
Visual Basic
Public rotate_x As Integer
Visual C++
public:
int rotate_x
F#
val mutable rotate_x: int

See Also

PlotControl Class
SMath.Control Namespace


rotate_y Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..rotate_y Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.rotate_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_y
Visual Basic
Public rotate_y As Integer
Visual C++
public:
int rotate_y
F#
val mutable rotate_y: int

See Also

PlotControl Class
SMath.Control Namespace


rotate_z Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..rotate_z Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.rotate_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_z
Visual Basic
Public rotate_z As Integer
Visual C++
public:
int rotate_z
F#
val mutable rotate_z: int

See Also

PlotControl Class
SMath.Control Namespace


scale_x Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..scale_x Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.scale_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_x
Visual Basic
Public scale_x As Double
Visual C++
public:
double scale_x
F#
val mutable scale_x: float

See Also

PlotControl Class
SMath.Control Namespace


scale_y Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..scale_y Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.scale_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_y
Visual Basic
Public scale_y As Double
Visual C++
public:
double scale_y
F#
val mutable scale_y: float

See Also

PlotControl Class
SMath.Control Namespace


scale_z Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..scale_z Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.scale_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_z
Visual Basic
Public scale_z As Double
Visual C++
public:
double scale_z
F#
val mutable scale_z: float

See Also

PlotControl Class
SMath.Control Namespace


selecter Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..selecter Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.selecter"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected int selecter
Visual Basic
Protected selecter As Integer
Visual C++
protected:
int selecter
F#
val mutable selecter: int

See Also

PlotControl Class
SMath.Control Namespace


transpose_x Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..transpose_x Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.transpose_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_x
Visual Basic
Public transpose_x As Integer
Visual C++
public:
int transpose_x
F#
val mutable transpose_x: int

See Also

PlotControl Class
SMath.Control Namespace


transpose_y Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..transpose_y Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.transpose_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_y
Visual Basic
Public transpose_y As Integer
Visual C++
public:
int transpose_y
F#
val mutable transpose_y: int

See Also

PlotControl Class
SMath.Control Namespace


transpose_z Field

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..transpose_z Field
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.PlotControl.transpose_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_z
Visual Basic
Public transpose_z As Integer
Visual C++
public:
int transpose_z
F#
val mutable transpose_z: int

See Also

PlotControl Class
SMath.Control Namespace


PlotControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Methods
PlotControl Class See Also Send Feedback

The PlotControl type exposes the following members.

Methods

 | Name | Description
Public method | Action | (Overrides CommonControl..::..Action(String).)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetControlType |
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | math_CalculateMe |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Public method | Reset |
Protected method | Resize | (Overrides CommonControl..::..Resize()()()().)
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

See Also

PlotControl Class
SMath.Control Namespace


Action Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Action Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.Action(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void Action(
    string value
)
Visual Basic
Public Overrides Sub Action ( _
    value As String _
)
Visual C++
public:
virtual void Action(
    String^ value
) override
F#
abstract Action :
        value:string -> unit
override Action :
        value:string -> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Control.PlotControl.Action(System.String)"]

See Also

PlotControl Class
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Clone Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CommonControl Clone()
Visual Basic
Public Overrides Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone() override
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.PlotControl.Clone"]

See Also

PlotControl Class
SMath.Control Namespace


GetControlType Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..GetControlType Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.GetControlType(System.Drawing.Point)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string GetControlType(
    Point e
)
Visual Basic
Public Function GetControlType ( _
    e As Point _
) As String
Visual C++
public:
String^ GetControlType(
    Point e
)
F#
member GetControlType :
        e:Point -> string

Parameters

e
Type: System.Drawing..::..Point

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.GetControlType(System.Drawing.Point)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.PlotControl.GetControlType(System.Drawing.Point)"]

See Also

PlotControl Class
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..GetCursorType Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CursorType GetCursorType(
    MouseEventArgs e
)
Visual Basic
Public Overrides Function GetCursorType ( _
    e As MouseEventArgs _
) As CursorType
Visual C++
public:
virtual CursorType GetCursorType(
    MouseEventArgs^ e
) override
F#
abstract GetCursorType :
        e:MouseEventArgs -> CursorType
override GetCursorType :
        e:MouseEventArgs -> CursorType

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.PlotControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

See Also

PlotControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl..::..GetImage Method
PlotControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

PlotControl Class
PlotControl Members
SMath.Control Namespace


math_CalculateMe Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..math_CalculateMe Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.math_CalculateMe(SMath.Control.CalculateType,SMath.Control.CommonControl)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void math_CalculateMe(
    CalculateType e,
    CommonControl sender
)
Visual Basic
Public Sub math_CalculateMe ( _
    e As CalculateType, _
    sender As CommonControl _
)
Visual C++
public:
void math_CalculateMe(
    CalculateType e,
    CommonControl^ sender
)
F#
member math_CalculateMe :
        e:CalculateType *
        sender:CommonControl -> unit

Parameters

e
Type: SMath.Control..::..CalculateType

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.math_CalculateMe(SMath.Control.CalculateType,SMath.Control.CommonControl)"]

sender
Type: SMath.Control..::..CommonControl

[Missing <param name="sender"/> documentation for "M:SMath.Control.PlotControl.math_CalculateMe(SMath.Control.CalculateType,SMath.Control.CommonControl)"]

See Also

PlotControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..OnMouseDown Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

PlotControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..OnMouseMove Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

PlotControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..OnMouseUp Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

PlotControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..OnPaint Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.PlotControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

PlotControl Class
SMath.Control Namespace


Reset Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Reset Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.Reset"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()
F#
member Reset : unit -> unit

See Also

PlotControl Class
SMath.Control Namespace


Resize Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Resize Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.Resize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void Resize()
Visual Basic
Protected Overrides Sub Resize
Visual C++
protected:
virtual void Resize() override
F#
abstract Resize : unit -> unit
override Resize : unit -> unit

See Also

PlotControl Class
SMath.Control Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..ToString Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.ToString"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Control.PlotControl.ToString"]

See Also

PlotControl Class
SMath.Control Namespace


UndoRedoManager Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..UndoRedoManager Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.UndoRedoManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UndoRedoManager(
    string referer
)
Visual Basic
Public Overrides Sub UndoRedoManager ( _
    referer As String _
)
Visual C++
public:
virtual void UndoRedoManager(
    String^ referer
) override
F#
abstract UndoRedoManager :
        referer:string -> unit
override UndoRedoManager :
        referer:string -> unit

Parameters

referer
Type: System..::..String

[Missing <param name="referer"/> documentation for "M:SMath.Control.PlotControl.UndoRedoManager(System.String)"]

See Also

PlotControl Class
SMath.Control Namespace


UnReDoAccept Method

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..UnReDoAccept Method
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.PlotControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void UnReDoAccept(
    UnReDO_Common unReDo_Common
)
Visual Basic
Protected Overrides Sub UnReDoAccept ( _
    unReDo_Common As UnReDO_Common _
)
Visual C++
protected:
virtual void UnReDoAccept(
    UnReDO_Common^ unReDo_Common
) override
F#
abstract UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit
override UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit

Parameters

unReDo_Common
Type: SMath.Control..::..UnReDO_Common

[Missing <param name="unReDo_Common"/> documentation for "M:SMath.Control.PlotControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

See Also

PlotControl Class
SMath.Control Namespace


PlotControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Properties
PlotControl Class See Also Send Feedback

The PlotControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | (Overrides CommonControl..::..ErrorText.)
Public property | Evaluate |
Public property | Focused | (Overrides CommonControl..::..Focused.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | InDate | (Overrides CommonControl..::..InDate.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | METype |
Public property | PType |
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | RType |
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

PlotControl Class
SMath.Control Namespace


ErrorText Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..ErrorText Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.ErrorText"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string ErrorText { get; set; }
Visual Basic
Public Overrides Property ErrorText As String
    Get
    Set
Visual C++
public:
virtual property String^ ErrorText {
    String^ get () override;
    void set (String^ value) override;
}
F#
abstract ErrorText : string with get, set
override ErrorText : string with get, set

See Also

PlotControl Class
SMath.Control Namespace


Evaluate Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Evaluate Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.Evaluate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Evaluate { get; set; }
Visual Basic
Public Property Evaluate As Boolean
    Get
    Set
Visual C++
public:
property bool Evaluate {
    bool get ();
    void set (bool value);
}
F#
member Evaluate : bool with get, set

See Also

PlotControl Class
SMath.Control Namespace


Focused Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..Focused Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.Focused"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override bool Focused { get; set; }
Visual Basic
Public Overrides Property Focused As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Focused {
    bool get () override;
    void set (bool value) override;
}
F#
abstract Focused : bool with get, set
override Focused : bool with get, set

See Also

PlotControl Class
SMath.Control Namespace


InDate Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..InDate Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.InDate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override bool InDate { get; set; }
Visual Basic
Public Overrides Property InDate As Boolean
    Get
    Set
Visual C++
public:
virtual property bool InDate {
    bool get () override;
    void set (bool value) override;
}
F#
abstract InDate : bool with get, set
override InDate : bool with get, set

See Also

PlotControl Class
SMath.Control Namespace


METype Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..METype Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.METype"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MouseEventType METype { get; set; }
Visual Basic
Public Property METype As MouseEventType
    Get
    Set
Visual C++
public:
property MouseEventType METype {
    MouseEventType get ();
    void set (MouseEventType value);
}
F#
member METype : MouseEventType with get, set

See Also

PlotControl Class
SMath.Control Namespace


PType Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..PType Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.PType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PlotType PType { get; set; }
Visual Basic
Public Property PType As PlotType
    Get
    Set
Visual C++
public:
property PlotType PType {
    PlotType get ();
    void set (PlotType value);
}
F#
member PType : PlotType with get, set

See Also

PlotControl Class
SMath.Control Namespace


RType Property

[image]

SMath Studio Class Libraries Documantation
PlotControl..::..RType Property
PlotControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.PlotControl.RType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public RenderType RType { get; set; }
Visual Basic
Public Property RType As RenderType
    Get
    Set
Visual C++
public:
property RenderType RType {
    RenderType get ();
    void set (RenderType value);
}
F#
member RType : RenderType with get, set

See Also

PlotControl Class
SMath.Control Namespace


PlotControl Events

[image] [image]

SMath Studio Class Libraries Documantation
PlotControl Events
PlotControl Class See Also Send Feedback

The PlotControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

PlotControl Class
SMath.Control Namespace


PlotType Enumeration

[image]

SMath Studio Class Libraries Documantation
PlotType Enumeration
See Also Send Feedback
Выбор типа графика.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum PlotType
Visual Basic
Public Enumeration PlotType
Visual C++
public enum class PlotType
F#
type PlotType

Members

Member name | Value | Description
Plot2D | 0 | Двумерный график.
Plot3D | 1 | трёхмерный график.

See Also

SMath.Control Namespace


Renderer Class

[image]

SMath Studio Class Libraries Documantation
Renderer Class
Members See Also Send Feedback
Элемент управления для отображения результатов вычисления класса Vertex

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class Renderer : CommonControl
Visual Basic
Public Class Renderer _
    Inherits CommonControl
Visual C++
public ref class Renderer : public CommonControl
F#
type Renderer =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..Renderer

See Also

Renderer Members
SMath.Control Namespace


Renderer Members

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Members
Renderer Class Constructors Methods Fields Properties Events See Also Send Feedback

The Renderer type exposes the following members.

Constructors

 | Name | Description
Public method | Renderer()()()() | Конструктор класса
Public method | Renderer(Renderer) |

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Actualize |
Public method | Clone | (Inherited from CommonControl.)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | Определение вида курсора (Inherited from CommonControl.)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | Refresh | Преобразование перспективы для всех вершин
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | Rotate | Преобразование вращения вокруг осей XYZ
Public method | Scale | Преобразование масштабирования относительно центра координат по всем осям
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | Transpose | Преобразование сдвига по всем осям
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Inherited from CommonControl.)
Protected method | UnReDoAccept | Применение параметров шага истории к элементу (Inherited from CommonControl.)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

Fields

 | Name | Description
Public field | _cnx |
Public field | _cny |
Public field | _dist |
Public field | _limits_x |
Public field | _limits_y |
Public field | _limits_z |
Public field | _rotate_x |
Public field | _rotate_y |
Public field | _rotate_z |
Public field | _scale_x |
Public field | _scale_y |
Public field | _scale_z |
Public field | _transpose_x |
Public field | _transpose_y |
Public field | _transpose_z |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | cnx |
Public field | cny |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | dist |
Public field | errorId | (Inherited from CommonControl.)
Public field | font |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | limits_x |
Public field | limits_y |
Public field | limits_z |
Public field | METype |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | PType |
Public field | rad |
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | rotate_x |
Public field | rotate_y |
Public field | rotate_z |
Public field | RType |
Public field | scale_x |
Public field | scale_y |
Public field | scale_z |
Public field | transpose_x |
Public field | transpose_y |
Public field | transpose_z |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | Color_Axis | Цвет осей системы координат
Public property | Color_Canvas | Цвет полотна рисования
Public property | Color_Plot | Цвет элементов графика (точки, линии)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | GridSize |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

Renderer Class
SMath.Control Namespace


Renderer Constructor

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Constructor
Renderer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Renderer()()()() | Конструктор класса
Public method | Renderer(Renderer) | Initializes a new instance of the Renderer class

See Also

Renderer Class
Renderer Members
SMath.Control Namespace


Renderer Constructor

[image]

SMath Studio Class Libraries Documantation
Renderer Constructor
Renderer Class See Also Send Feedback
Конструктор класса

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Renderer()
Visual Basic
Public Sub New
Visual C++
public:
Renderer()
F#
new : unit -> Renderer

See Also

Renderer Class
Renderer Overload
SMath.Control Namespace


Renderer Constructor (Renderer)

[image]

SMath Studio Class Libraries Documantation
Renderer Constructor (Renderer)
Renderer Class See Also Send Feedback
Initializes a new instance of the Renderer class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Renderer(
    Renderer value
)
Visual Basic
Public Sub New ( _
    value As Renderer _
)
Visual C++
public:
Renderer(
    Renderer^ value
)
F#
new :
        value:Renderer -> Renderer

Parameters

value
Type: SMath.Control..::..Renderer

[Missing <param name="value"/> documentation for "M:SMath.Control.Renderer.#ctor(SMath.Control.Renderer)"]

See Also

Renderer Class
Renderer Overload
SMath.Control Namespace


Renderer Fields

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Fields
Renderer Class See Also Send Feedback

The Renderer type exposes the following members.

Fields

 | Name | Description
Public field | _cnx |
Public field | _cny |
Public field | _dist |
Public field | _limits_x |
Public field | _limits_y |
Public field | _limits_z |
Public field | _rotate_x |
Public field | _rotate_y |
Public field | _rotate_z |
Public field | _scale_x |
Public field | _scale_y |
Public field | _scale_z |
Public field | _transpose_x |
Public field | _transpose_y |
Public field | _transpose_z |
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | cnx |
Public field | cny |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | dist |
Public field | errorId | (Inherited from CommonControl.)
Public field | font |
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | limits_x |
Public field | limits_y |
Public field | limits_z |
Public field | METype |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | PType |
Public field | rad |
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | rotate_x |
Public field | rotate_y |
Public field | rotate_z |
Public field | RType |
Public field | scale_x |
Public field | scale_y |
Public field | scale_z |
Public field | transpose_x |
Public field | transpose_y |
Public field | transpose_z |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)

See Also

Renderer Class
SMath.Control Namespace


_cnx Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._cnx Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._cnx"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _cnx
Visual Basic
Public _cnx As Integer
Visual C++
public:
int _cnx
F#
val mutable _cnx: int

See Also

Renderer Class
SMath.Control Namespace


_cny Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._cny Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._cny"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _cny
Visual Basic
Public _cny As Integer
Visual C++
public:
int _cny
F#
val mutable _cny: int

See Also

Renderer Class
SMath.Control Namespace


_dist Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._dist Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._dist"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _dist
Visual Basic
Public _dist As Integer
Visual C++
public:
int _dist
F#
val mutable _dist: int

See Also

Renderer Class
SMath.Control Namespace


_limits_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._limits_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._limits_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _limits_x
Visual Basic
Public _limits_x As Double
Visual C++
public:
double _limits_x
F#
val mutable _limits_x: float

See Also

Renderer Class
SMath.Control Namespace


_limits_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._limits_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._limits_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _limits_y
Visual Basic
Public _limits_y As Double
Visual C++
public:
double _limits_y
F#
val mutable _limits_y: float

See Also

Renderer Class
SMath.Control Namespace


_limits_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._limits_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._limits_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _limits_z
Visual Basic
Public _limits_z As Double
Visual C++
public:
double _limits_z
F#
val mutable _limits_z: float

See Also

Renderer Class
SMath.Control Namespace


_rotate_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._rotate_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._rotate_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _rotate_x
Visual Basic
Public _rotate_x As Integer
Visual C++
public:
int _rotate_x
F#
val mutable _rotate_x: int

See Also

Renderer Class
SMath.Control Namespace


_rotate_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._rotate_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._rotate_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _rotate_y
Visual Basic
Public _rotate_y As Integer
Visual C++
public:
int _rotate_y
F#
val mutable _rotate_y: int

See Also

Renderer Class
SMath.Control Namespace


_rotate_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._rotate_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._rotate_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _rotate_z
Visual Basic
Public _rotate_z As Integer
Visual C++
public:
int _rotate_z
F#
val mutable _rotate_z: int

See Also

Renderer Class
SMath.Control Namespace


_scale_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._scale_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._scale_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _scale_x
Visual Basic
Public _scale_x As Double
Visual C++
public:
double _scale_x
F#
val mutable _scale_x: float

See Also

Renderer Class
SMath.Control Namespace


_scale_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._scale_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._scale_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _scale_y
Visual Basic
Public _scale_y As Double
Visual C++
public:
double _scale_y
F#
val mutable _scale_y: float

See Also

Renderer Class
SMath.Control Namespace


_scale_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._scale_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._scale_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double _scale_z
Visual Basic
Public _scale_z As Double
Visual C++
public:
double _scale_z
F#
val mutable _scale_z: float

See Also

Renderer Class
SMath.Control Namespace


_transpose_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._transpose_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._transpose_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _transpose_x
Visual Basic
Public _transpose_x As Integer
Visual C++
public:
int _transpose_x
F#
val mutable _transpose_x: int

See Also

Renderer Class
SMath.Control Namespace


_transpose_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._transpose_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._transpose_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _transpose_y
Visual Basic
Public _transpose_y As Integer
Visual C++
public:
int _transpose_y
F#
val mutable _transpose_y: int

See Also

Renderer Class
SMath.Control Namespace


_transpose_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::.._transpose_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer._transpose_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int _transpose_z
Visual Basic
Public _transpose_z As Integer
Visual C++
public:
int _transpose_z
F#
val mutable _transpose_z: int

See Also

Renderer Class
SMath.Control Namespace


cnx Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..cnx Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.cnx"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int cnx
Visual Basic
Public cnx As Integer
Visual C++
public:
int cnx
F#
val mutable cnx: int

See Also

Renderer Class
SMath.Control Namespace


cny Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..cny Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.cny"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int cny
Visual Basic
Public cny As Integer
Visual C++
public:
int cny
F#
val mutable cny: int

See Also

Renderer Class
SMath.Control Namespace


dist Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..dist Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.dist"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int dist
Visual Basic
Public dist As Integer
Visual C++
public:
int dist
F#
val mutable dist: int

See Also

Renderer Class
SMath.Control Namespace


font Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..font Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.font"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Font font
Visual Basic
Public font As Font
Visual C++
public:
Font^ font
F#
val mutable font: Font

See Also

Renderer Class
SMath.Control Namespace


limits_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..limits_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.limits_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double limits_x
Visual Basic
Public limits_x As Double
Visual C++
public:
double limits_x
F#
val mutable limits_x: float

See Also

Renderer Class
SMath.Control Namespace


limits_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..limits_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.limits_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double limits_y
Visual Basic
Public limits_y As Double
Visual C++
public:
double limits_y
F#
val mutable limits_y: float

See Also

Renderer Class
SMath.Control Namespace


limits_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..limits_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.limits_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double limits_z
Visual Basic
Public limits_z As Double
Visual C++
public:
double limits_z
F#
val mutable limits_z: float

See Also

Renderer Class
SMath.Control Namespace


METype Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..METype Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.METype"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public MouseEventType METype
Visual Basic
Public METype As MouseEventType
Visual C++
public:
MouseEventType METype
F#
val mutable METype: MouseEventType

See Also

Renderer Class
SMath.Control Namespace


PType Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..PType Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.PType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public PlotType PType
Visual Basic
Public PType As PlotType
Visual C++
public:
PlotType PType
F#
val mutable PType: PlotType

See Also

Renderer Class
SMath.Control Namespace


rad Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..rad Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.rad"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double rad
Visual Basic
Public rad As Double
Visual C++
public:
double rad
F#
val mutable rad: float

See Also

Renderer Class
SMath.Control Namespace


rotate_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..rotate_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.rotate_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_x
Visual Basic
Public rotate_x As Integer
Visual C++
public:
int rotate_x
F#
val mutable rotate_x: int

See Also

Renderer Class
SMath.Control Namespace


rotate_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..rotate_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.rotate_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_y
Visual Basic
Public rotate_y As Integer
Visual C++
public:
int rotate_y
F#
val mutable rotate_y: int

See Also

Renderer Class
SMath.Control Namespace


rotate_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..rotate_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.rotate_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int rotate_z
Visual Basic
Public rotate_z As Integer
Visual C++
public:
int rotate_z
F#
val mutable rotate_z: int

See Also

Renderer Class
SMath.Control Namespace


RType Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..RType Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.RType"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public RenderType RType
Visual Basic
Public RType As RenderType
Visual C++
public:
RenderType RType
F#
val mutable RType: RenderType

See Also

Renderer Class
SMath.Control Namespace


scale_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..scale_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.scale_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_x
Visual Basic
Public scale_x As Double
Visual C++
public:
double scale_x
F#
val mutable scale_x: float

See Also

Renderer Class
SMath.Control Namespace


scale_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..scale_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.scale_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_y
Visual Basic
Public scale_y As Double
Visual C++
public:
double scale_y
F#
val mutable scale_y: float

See Also

Renderer Class
SMath.Control Namespace


scale_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..scale_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.scale_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public double scale_z
Visual Basic
Public scale_z As Double
Visual C++
public:
double scale_z
F#
val mutable scale_z: float

See Also

Renderer Class
SMath.Control Namespace


transpose_x Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..transpose_x Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.transpose_x"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_x
Visual Basic
Public transpose_x As Integer
Visual C++
public:
int transpose_x
F#
val mutable transpose_x: int

See Also

Renderer Class
SMath.Control Namespace


transpose_y Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..transpose_y Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.transpose_y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_y
Visual Basic
Public transpose_y As Integer
Visual C++
public:
int transpose_y
F#
val mutable transpose_y: int

See Also

Renderer Class
SMath.Control Namespace


transpose_z Field

[image]

SMath Studio Class Libraries Documantation
Renderer..::..transpose_z Field
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.Renderer.transpose_z"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int transpose_z
Visual Basic
Public transpose_z As Integer
Visual C++
public:
int transpose_z
F#
val mutable transpose_z: int

See Also

Renderer Class
SMath.Control Namespace


Renderer Methods

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Methods
Renderer Class See Also Send Feedback

The Renderer type exposes the following members.

Methods

 | Name | Description
Public method | Action | (Inherited from CommonControl.)
Public method | Actualize |
Public method | Clone | (Inherited from CommonControl.)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | Определение вида курсора (Inherited from CommonControl.)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Предварительная обработка элемента перед его отрисовкой. Инициализирует и определяет все внутренние параметры. (Inherited from CommonControl.)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | Refresh | Преобразование перспективы для всех вершин
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | Rotate | Преобразование вращения вокруг осей XYZ
Public method | Scale | Преобразование масштабирования относительно центра координат по всем осям
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | Transpose | Преобразование сдвига по всем осям
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Inherited from CommonControl.)
Protected method | UnReDoAccept | Применение параметров шага истории к элементу (Inherited from CommonControl.)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | Удаление наполнения элемента (Inherited from CommonControl.)

See Also

Renderer Class
SMath.Control Namespace


Actualize Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Actualize Method
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.Renderer.Actualize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Actualize()
Visual Basic
Public Sub Actualize
Visual C++
public:
void Actualize()
F#
member Actualize : unit -> unit

See Also

Renderer Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
Renderer..::..GetImage Method
Renderer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

Renderer Class
Renderer Members
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..OnMouseDown Method
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.Renderer.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.Renderer.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

Renderer Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..OnMouseMove Method
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.Renderer.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.Renderer.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

Renderer Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..OnMouseUp Method
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.Renderer.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.Renderer.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

Renderer Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..OnPaint Method
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.Renderer.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.Renderer.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

Renderer Class
SMath.Control Namespace


Refresh Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Refresh Method
Renderer Class See Also Send Feedback
Преобразование перспективы для всех вершин

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh
Visual C++
public:
void Refresh()
F#
member Refresh : unit -> unit

See Also

Renderer Class
SMath.Control Namespace


Rotate Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Rotate Method
Renderer Class See Also Send Feedback
Преобразование вращения вокруг осей XYZ

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Rotate(
    int _a,
    int _b,
    int _c
)
Visual Basic
Public Sub Rotate ( _
    _a As Integer, _
    _b As Integer, _
    _c As Integer _
)
Visual C++
public:
void Rotate(
    int _a,
    int _b,
    int _c
)
F#
member Rotate :
        _a:int *
        _b:int *
        _c:int -> unit

Parameters

_a
Type: System..::..Int32
Угол по оси X
_b
Type: System..::..Int32
Угол по оси Y
_c
Type: System..::..Int32
Угол по оси Z

See Also

Renderer Class
SMath.Control Namespace


Scale Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Scale Method
Renderer Class See Also Send Feedback
Преобразование масштабирования относительно центра координат по всем осям

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Scale(
    double _a,
    double _b,
    double _c
)
Visual Basic
Public Sub Scale ( _
    _a As Double, _
    _b As Double, _
    _c As Double _
)
Visual C++
public:
void Scale(
    double _a,
    double _b,
    double _c
)
F#
member Scale :
        _a:float *
        _b:float *
        _c:float -> unit

Parameters

_a
Type: System..::..Double
Размер по оси X
_b
Type: System..::..Double
Размер по оси Y
_c
Type: System..::..Double
Размер по оси Z

See Also

Renderer Class
SMath.Control Namespace


Transpose Method

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Transpose Method
Renderer Class See Also Send Feedback
Преобразование сдвига по всем осям

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void Transpose(
    int _a,
    int _b,
    int _c
)
Visual Basic
Public Sub Transpose ( _
    _a As Integer, _
    _b As Integer, _
    _c As Integer _
)
Visual C++
public:
void Transpose(
    int _a,
    int _b,
    int _c
)
F#
member Transpose :
        _a:int *
        _b:int *
        _c:int -> unit

Parameters

_a
Type: System..::..Int32
Перемещение по оси X
_b
Type: System..::..Int32
Перемещение по оси Y
_c
Type: System..::..Int32
Перемещение по оси Z

See Also

Renderer Class
SMath.Control Namespace


Renderer Properties

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Properties
Renderer Class See Also Send Feedback

The Renderer type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | Color_Axis | Цвет осей системы координат
Public property | Color_Canvas | Цвет полотна рисования
Public property | Color_Plot | Цвет элементов графика (точки, линии)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | GridSize |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

Renderer Class
SMath.Control Namespace


Color_Axis Property

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Color_Axis Property
Renderer Class See Also Send Feedback
Цвет осей системы координат

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color Color_Axis { get; set; }
Visual Basic
Public Property Color_Axis As Color
    Get
    Set
Visual C++
public:
property Color Color_Axis {
    Color get ();
    void set (Color value);
}
F#
member Color_Axis : Color with get, set

See Also

Renderer Class
SMath.Control Namespace


Color_Canvas Property

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Color_Canvas Property
Renderer Class See Also Send Feedback
Цвет полотна рисования

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color Color_Canvas { get; set; }
Visual Basic
Public Property Color_Canvas As Color
    Get
    Set
Visual C++
public:
property Color Color_Canvas {
    Color get ();
    void set (Color value);
}
F#
member Color_Canvas : Color with get, set

See Also

Renderer Class
SMath.Control Namespace


Color_Plot Property

[image]

SMath Studio Class Libraries Documantation
Renderer..::..Color_Plot Property
Renderer Class See Also Send Feedback
Цвет элементов графика (точки, линии)

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color Color_Plot { get; set; }
Visual Basic
Public Property Color_Plot As Color
    Get
    Set
Visual C++
public:
property Color Color_Plot {
    Color get ();
    void set (Color value);
}
F#
member Color_Plot : Color with get, set

See Also

Renderer Class
SMath.Control Namespace


GridSize Property

[image]

SMath Studio Class Libraries Documantation
Renderer..::..GridSize Property
Renderer Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.Renderer.GridSize"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int GridSize { get; set; }
Visual Basic
Public Property GridSize As Integer
    Get
    Set
Visual C++
public:
property int GridSize {
    int get ();
    void set (int value);
}
F#
member GridSize : int with get, set

See Also

Renderer Class
SMath.Control Namespace


Renderer Events

[image] [image]

SMath Studio Class Libraries Documantation
Renderer Events
Renderer Class See Also Send Feedback

The Renderer type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

Renderer Class
SMath.Control Namespace


RenderType Enumeration

[image]

SMath Studio Class Libraries Documantation
RenderType Enumeration
See Also Send Feedback
Выбор типа рисования графика.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum RenderType
Visual Basic
Public Enumeration RenderType
Visual C++
public enum class RenderType
F#
type RenderType

Members

Member name | Value | Description
Points | 0 | Каждая точка графика представлена единой точкой на дисплее.
Lines | 1 | Каждая точка соеденена с ближайшими прямыми линиями.

See Also

SMath.Control Namespace


TextControl Class

[image]

SMath Studio Class Libraries Documantation
TextControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.TextControl"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class TextControl : CommonControl
Visual Basic
Public Class TextControl _
    Inherits CommonControl
Visual C++
public ref class TextControl : public CommonControl
F#
type TextControl =
    class
        inherit CommonControl
    end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..CommonControl
SMath.Control..::..TextControl

See Also

TextControl Members
SMath.Control Namespace


TextControl Members

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Members
TextControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextControl type exposes the following members.

Constructors

 | Name | Description
Public method | TextControl()()()() | Конструктор элемента управления
Public method | TextControl(TextControl) |

Methods

 | Name | Description
Public method | Action | (Overrides CommonControl..::..Action(String).)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | GetSelectedItems |
Public method | GetText |
Public method | InsertManager |
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | MousePlace |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно. (Overrides CommonControl..::..PrePainter()()()().)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RemoveText |
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetCurrentText |
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | SetText |
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ShowText |
Public method | StringModifier |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | bmpcreate |
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | currentLang |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | isclicked |
Public field | link |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | sel |
Public field | tw |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)
Public field | visi |
Public field | watch |
Public field | X |
Public field | Y |

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Bold |
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | FontName |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Italic |
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | Text |
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | Underline |
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

TextControl Class
SMath.Control Namespace


TextControl Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Constructor
TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextControl()()()() | Конструктор элемента управления
Public method | TextControl(TextControl) | Initializes a new instance of the TextControl class

See Also

TextControl Class
TextControl Members
SMath.Control Namespace


TextControl Constructor

[image]

SMath Studio Class Libraries Documantation
TextControl Constructor
TextControl Class See Also Send Feedback
Конструктор элемента управления

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public TextControl()
Visual Basic
Public Sub New
Visual C++
public:
TextControl()
F#
new : unit -> TextControl

See Also

TextControl Class
TextControl Overload
SMath.Control Namespace


TextControl Constructor (TextControl)

[image]

SMath Studio Class Libraries Documantation
TextControl Constructor (TextControl)
TextControl Class See Also Send Feedback
Initializes a new instance of the TextControl class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public TextControl(
    TextControl value
)
Visual Basic
Public Sub New ( _
    value As TextControl _
)
Visual C++
public:
TextControl(
    TextControl^ value
)
F#
new :
        value:TextControl -> TextControl

Parameters

value
Type: SMath.Control..::..TextControl

[Missing <param name="value"/> documentation for "M:SMath.Control.TextControl.#ctor(SMath.Control.TextControl)"]

See Also

TextControl Class
TextControl Overload
SMath.Control Namespace


TextControl Fields

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Fields
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Fields

 | Name | Description
Protected field | blackBrush | (Inherited from CommonControl.)
Public field | bmpcreate |
Public field | brush | Массив "кистей" для рисования (Inherited from CommonControl.)
Public field | currentLang |
Protected field | dblclick | (Inherited from CommonControl.)
Public field | errorId | (Inherited from CommonControl.)
Public field | Font | Шрифт используемы элементом (Inherited from CommonControl.)
Public field | IsChildControl | (Inherited from CommonControl.)
Public field | isclicked |
Public field | link |
Protected field | pen | Массив "карандашей" для рисования (Inherited from CommonControl.)
Public field | referer | (Inherited from CommonControl.)
Public field | remoteControl | (Inherited from CommonControl.)
Public field | sel |
Public field | tw |
Public field | uid | Уникальный идентификатор элемента (Inherited from CommonControl.)
Protected field | UnReDO | (Inherited from CommonControl.)
Protected field | UnReDoMaximum | (Inherited from CommonControl.)
Protected field | UnReDoPoint | (Inherited from CommonControl.)
Public field | visi |
Public field | watch |
Public field | X |
Public field | Y |

See Also

TextControl Class
SMath.Control Namespace


bmpcreate Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..bmpcreate Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.bmpcreate"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool bmpcreate
Visual Basic
Public bmpcreate As Boolean
Visual C++
public:
bool bmpcreate
F#
val mutable bmpcreate: bool

See Also

TextControl Class
SMath.Control Namespace


currentLang Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..currentLang Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.currentLang"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string currentLang
Visual Basic
Public currentLang As String
Visual C++
public:
String^ currentLang
F#
val mutable currentLang: string

See Also

TextControl Class
SMath.Control Namespace


isclicked Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..isclicked Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.isclicked"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool isclicked
Visual Basic
Public isclicked As Boolean
Visual C++
public:
bool isclicked
F#
val mutable isclicked: bool

See Also

TextControl Class
SMath.Control Namespace


link Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..link Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.link"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string link
Visual Basic
Public link As String
Visual C++
public:
String^ link
F#
val mutable link: string

See Also

TextControl Class
SMath.Control Namespace


sel Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..sel Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.sel"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int[] sel
Visual Basic
Public sel As Integer()
Visual C++
public:
array<int>^ sel
F#
val mutable sel: int[]

See Also

TextControl Class
SMath.Control Namespace


tw Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..tw Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.tw"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int tw
Visual Basic
Public tw As Integer
Visual C++
public:
int tw
F#
val mutable tw: int

See Also

TextControl Class
SMath.Control Namespace


visi Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..visi Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.visi"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool visi
Visual Basic
Public visi As Boolean
Visual C++
public:
bool visi
F#
val mutable visi: bool

See Also

TextControl Class
SMath.Control Namespace


watch Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..watch Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.watch"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int watch
Visual Basic
Public watch As Integer
Visual C++
public:
int watch
F#
val mutable watch: int

See Also

TextControl Class
SMath.Control Namespace


X Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..X Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.X"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int X
Visual Basic
Public X As Integer
Visual C++
public:
int X
F#
val mutable X: int

See Also

TextControl Class
SMath.Control Namespace


Y Field

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Y Field
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.TextControl.Y"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Y
Visual Basic
Public Y As Integer
Visual C++
public:
int Y
F#
val mutable Y: int

See Also

TextControl Class
SMath.Control Namespace


TextControl Methods

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Methods
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Methods

 | Name | Description
Public method | Action | (Overrides CommonControl..::..Action(String).)
Public method | Clone | (Overrides CommonControl..::..Clone()()()().)
Protected method | CustomLineDrawing | (Inherited from CommonControl.)
Public method | dec_errorprovider_nu | Сообщает об ошибке в элементе при вычислении (Inherited from CommonControl.)
Public method | GetCursorType | (Overrides CommonControl..::..GetCursorType(MouseEventArgs).)
Public method | GetHashCode | (Inherited from CommonControl.)
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)
Public method | GetSelectedItems |
Public method | GetText |
Public method | InsertManager |
Public method | LinkClick | Сообщает о нажатии на ссылку (Inherited from CommonControl.)
Public method | MousePlace |
Public method | NeedToCalculate | Генерирует событие пересчёта (Inherited from CommonControl.)
Public method | OnMouseDown | (Overrides CommonControl..::..OnMouseDown(MouseEventArgs).)
Public method | OnMouseMove | (Overrides CommonControl..::..OnMouseMove(MouseEventArgs).)
Public method | OnMouseUp | (Overrides CommonControl..::..OnMouseUp(MouseEventArgs).)
Public method | OnPaint | (Overrides CommonControl..::..OnPaint(PaintEventArgs).)
Public method | PrePainter | Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно. (Overrides CommonControl..::..PrePainter()()()().)
Public method | ReadyToPaint | (Inherited from CommonControl.)
Public method | ReDo | Отменяет возврат контрола на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | RemoveText |
Public method | RePainter | Определяет абсолютные координаты положения элемента управления и посылает обращение на его перерисовку (Inherited from CommonControl.)
Protected method | Resize | Генерирует событие изменения размера (Inherited from CommonControl.)
Public method | SetCurrentText |
Public method | SetEvaluationState | (Inherited from CommonControl.)
Public method | SetText |
Public method | ShowAvailableTermsList | (Inherited from CommonControl.)
Public method | ShowError | (Inherited from CommonControl.)
Public method | ShowResult | (Inherited from CommonControl.)
Public method | ShowText |
Public method | StringModifier |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | UnDo | Возвращает контрол на предыдущее сохранённое состояние. Если будет выполнен, перерисует контрол. (Inherited from CommonControl.)
Public method | UndoRedoManager | (Overrides CommonControl..::..UndoRedoManager(String).)
Protected method | UnReDoAccept | (Overrides CommonControl..::..UnReDoAccept(UnReDO_Common).)
Protected method | UnReDoPush | Сохранение шага истории в последовательном их списке (Inherited from CommonControl.)
Public method | UnReInit | (Overrides CommonControl..::..UnReInit()()()().)

See Also

TextControl Class
SMath.Control Namespace


Action Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Action Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.Action(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void Action(
    string value
)
Visual Basic
Public Overrides Sub Action ( _
    value As String _
)
Visual C++
public:
virtual void Action(
    String^ value
) override
F#
abstract Action :
        value:string -> unit
override Action :
        value:string -> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Control.TextControl.Action(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Clone Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.Clone"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CommonControl Clone()
Visual Basic
Public Overrides Function Clone As CommonControl
Visual C++
public:
virtual CommonControl^ Clone() override
F#
abstract Clone : unit -> CommonControl
override Clone : unit -> CommonControl

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.Clone"]

See Also

TextControl Class
SMath.Control Namespace


GetCursorType Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..GetCursorType Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override CursorType GetCursorType(
    MouseEventArgs e
)
Visual Basic
Public Overrides Function GetCursorType ( _
    e As MouseEventArgs _
) As CursorType
Visual C++
public:
virtual CursorType GetCursorType(
    MouseEventArgs^ e
) override
F#
abstract GetCursorType :
        e:MouseEventArgs -> CursorType
override GetCursorType :
        e:MouseEventArgs -> CursorType

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.TextControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.GetCursorType(System.Windows.Forms.MouseEventArgs)"]

See Also

TextControl Class
SMath.Control Namespace


GetImage Method

[image] [image]

SMath Studio Class Libraries Documantation
TextControl..::..GetImage Method
TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetImage()()()() | Получение изображения элемента (Inherited from CommonControl.)
Public method | GetImage(Color) | Получение изображения элемента с указанным фоновым цветом (Inherited from CommonControl.)

See Also

TextControl Class
TextControl Members
SMath.Control Namespace


GetSelectedItems Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..GetSelectedItems Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.GetSelectedItems"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string GetSelectedItems()
Visual Basic
Public Function GetSelectedItems As String
Visual C++
public:
String^ GetSelectedItems()
F#
member GetSelectedItems : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.GetSelectedItems"]

See Also

TextControl Class
SMath.Control Namespace


GetText Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..GetText Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.GetText(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string GetText(
    string lang
)
Visual Basic
Public Function GetText ( _
    lang As String _
) As String
Visual C++
public:
String^ GetText(
    String^ lang
)
F#
member GetText :
        lang:string -> string

Parameters

lang
Type: System..::..String

[Missing <param name="lang"/> documentation for "M:SMath.Control.TextControl.GetText(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.GetText(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


InsertManager Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..InsertManager Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.InsertManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void InsertManager(
    string value
)
Visual Basic
Public Sub InsertManager ( _
    value As String _
)
Visual C++
public:
void InsertManager(
    String^ value
)
F#
member InsertManager :
        value:string -> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Control.TextControl.InsertManager(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


MousePlace Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..MousePlace Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.MousePlace(System.Int32,System.Int32)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int MousePlace(
    int x,
    int y
)
Visual Basic
Public Function MousePlace ( _
    x As Integer, _
    y As Integer _
) As Integer
Visual C++
public:
int MousePlace(
    int x,
    int y
)
F#
member MousePlace :
        x:int *
        y:int -> int

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:SMath.Control.TextControl.MousePlace(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:SMath.Control.TextControl.MousePlace(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.MousePlace(System.Int32,System.Int32)"]

See Also

TextControl Class
SMath.Control Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..OnMouseDown Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.TextControl.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

TextControl Class
SMath.Control Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..OnMouseMove Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.TextControl.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

TextControl Class
SMath.Control Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..OnMouseUp Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Public Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
public:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.TextControl.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

TextControl Class
SMath.Control Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..OnPaint Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Control.TextControl.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

TextControl Class
SMath.Control Namespace


PrePainter Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..PrePainter Method
TextControl Class See Also Send Feedback
Подготовка выражения к отрисовке в компаненте. Определяет размер холста. Следующая отрисовка учитывает выполнение данной функции и будет выполнена ускоренно.

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void PrePainter()
Visual Basic
Public Overrides Sub PrePainter
Visual C++
public:
virtual void PrePainter() override
F#
abstract PrePainter : unit -> unit
override PrePainter : unit -> unit

See Also

TextControl Class
SMath.Control Namespace


RemoveText Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..RemoveText Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.RemoveText"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool RemoveText()
Visual Basic
Public Function RemoveText As Boolean
Visual C++
public:
bool RemoveText()
F#
member RemoveText : unit -> bool

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.RemoveText"]

See Also

TextControl Class
SMath.Control Namespace


SetCurrentText Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..SetCurrentText Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.SetCurrentText"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetCurrentText()
Visual Basic
Public Sub SetCurrentText
Visual C++
public:
void SetCurrentText()
F#
member SetCurrentText : unit -> unit

See Also

TextControl Class
SMath.Control Namespace


SetText Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..SetText Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.SetText(System.String,System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void SetText(
    string text,
    string lang
)
Visual Basic
Public Sub SetText ( _
    text As String, _
    lang As String _
)
Visual C++
public:
void SetText(
    String^ text,
    String^ lang
)
F#
member SetText :
        text:string *
        lang:string -> unit

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Control.TextControl.SetText(System.String,System.String)"]

lang
Type: System..::..String

[Missing <param name="lang"/> documentation for "M:SMath.Control.TextControl.SetText(System.String,System.String)"]

See Also

TextControl Class
SMath.Control Namespace


ShowText Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..ShowText Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.ShowText(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public void ShowText(
    string lang
)
Visual Basic
Public Sub ShowText ( _
    lang As String _
)
Visual C++
public:
void ShowText(
    String^ lang
)
F#
member ShowText :
        lang:string -> unit

Parameters

lang
Type: System..::..String

[Missing <param name="lang"/> documentation for "M:SMath.Control.TextControl.ShowText(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


StringModifier Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..StringModifier Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.StringModifier(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string StringModifier(
    string value
)
Visual Basic
Public Function StringModifier ( _
    value As String _
) As String
Visual C++
public:
String^ StringModifier(
    String^ value
)
F#
member StringModifier :
        value:string -> string

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Control.TextControl.StringModifier(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.StringModifier(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..ToString Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.ToString"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Control.TextControl.ToString"]

See Also

TextControl Class
SMath.Control Namespace


UndoRedoManager Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..UndoRedoManager Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.UndoRedoManager(System.String)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UndoRedoManager(
    string referer
)
Visual Basic
Public Overrides Sub UndoRedoManager ( _
    referer As String _
)
Visual C++
public:
virtual void UndoRedoManager(
    String^ referer
) override
F#
abstract UndoRedoManager :
        referer:string -> unit
override UndoRedoManager :
        referer:string -> unit

Parameters

referer
Type: System..::..String

[Missing <param name="referer"/> documentation for "M:SMath.Control.TextControl.UndoRedoManager(System.String)"]

See Also

TextControl Class
SMath.Control Namespace


UnReDoAccept Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..UnReDoAccept Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
protected override void UnReDoAccept(
    UnReDO_Common unReDo_Common
)
Visual Basic
Protected Overrides Sub UnReDoAccept ( _
    unReDo_Common As UnReDO_Common _
)
Visual C++
protected:
virtual void UnReDoAccept(
    UnReDO_Common^ unReDo_Common
) override
F#
abstract UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit
override UnReDoAccept :
        unReDo_Common:UnReDO_Common -> unit

Parameters

unReDo_Common
Type: SMath.Control..::..UnReDO_Common

[Missing <param name="unReDo_Common"/> documentation for "M:SMath.Control.TextControl.UnReDoAccept(SMath.Control.UnReDO_Common)"]

See Also

TextControl Class
SMath.Control Namespace


UnReInit Method

[image]

SMath Studio Class Libraries Documantation
TextControl..::..UnReInit Method
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Control.TextControl.UnReInit"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public override void UnReInit()
Visual Basic
Public Overrides Sub UnReInit
Visual C++
public:
virtual void UnReInit() override
F#
abstract UnReInit : unit -> unit
override UnReInit : unit -> unit

See Also

TextControl Class
SMath.Control Namespace


TextControl Properties

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Properties
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Фоновый цвет элемента (Inherited from CommonControl.)
Public property | Bold |
Public property | Border | Отрисовка рамки по границе элемента (Inherited from CommonControl.)
Public property | Bottom | Нижняя граница элемента (Inherited from CommonControl.)
Public property | ErrorText | Текст ошибки элемента (Inherited from CommonControl.)
Public property | Focused | Определяет, находиться ли элемент в стадии редактирования или нет. В случае истины элемент выделяется рамкой и получает право на размещения в себе курсора. Цвет рамки определяетя актуальностью информации элемента (свойство InDate) (Inherited from CommonControl.)
Public property | FontHeight | Размер используемого элементом шрифта (Inherited from CommonControl.)
Public property | FontName |
Public property | InDate | Определяет, является ли содержимое элемента актуальным и соответствуют ли все составляющие элемента синхронизированными между собой (Inherited from CommonControl.)
Public property | Italic |
Public property | Location | Абсолютные координаты элемента управления (Inherited from CommonControl.)
Public property | Right | Правая граница элемента (Inherited from CommonControl.)
Public property | Selected | Определяет, является ли элемент выделенным на листе или нет (Inherited from CommonControl.)
Public property | SelectedBackColor | Выделенный фоновый цвет элемента (Inherited from CommonControl.)
Public property | SelectedTextColor | Цвет выделенного текста элемента (Inherited from CommonControl.)
Public property | Size | Размер элемента управления (Inherited from CommonControl.)
Public property | Text |
Public property | TextColor | Цвет текста элемента (Inherited from CommonControl.)
Public property | Underline |
Public property | WarningColor | Цвет предупреждений элемента (Inherited from CommonControl.)

See Also

TextControl Class
SMath.Control Namespace


Bold Property

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Bold Property
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.TextControl.Bold"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Bold { get; set; }
Visual Basic
Public Property Bold As Boolean
    Get
    Set
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}
F#
member Bold : bool with get, set

See Also

TextControl Class
SMath.Control Namespace


FontName Property

[image]

SMath Studio Class Libraries Documantation
TextControl..::..FontName Property
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.TextControl.FontName"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string FontName { get; set; }
Visual Basic
Public Property FontName As String
    Get
    Set
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
F#
member FontName : string with get, set

See Also

TextControl Class
SMath.Control Namespace


Italic Property

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Italic Property
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.TextControl.Italic"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Italic { get; set; }
Visual Basic
Public Property Italic As Boolean
    Get
    Set
Visual C++
public:
property bool Italic {
    bool get ();
    void set (bool value);
}
F#
member Italic : bool with get, set

See Also

TextControl Class
SMath.Control Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Text Property
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.TextControl.Text"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
F#
member Text : string with get, set

See Also

TextControl Class
SMath.Control Namespace


Underline Property

[image]

SMath Studio Class Libraries Documantation
TextControl..::..Underline Property
TextControl Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Control.TextControl.Underline"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Underline { get; set; }
Visual Basic
Public Property Underline As Boolean
    Get
    Set
Visual C++
public:
property bool Underline {
    bool get ();
    void set (bool value);
}
F#
member Underline : bool with get, set

See Also

TextControl Class
SMath.Control Namespace


TextControl Events

[image] [image]

SMath Studio Class Libraries Documantation
TextControl Events
TextControl Class See Also Send Feedback

The TextControl type exposes the following members.

Events

 | Name | Description
Public event | setControlEvaluationState | (Inherited from CommonControl.)

See Also

TextControl Class
SMath.Control Namespace


UnReDO_Common Class

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Control.UnReDO_Common"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class UnReDO_Common
Visual Basic
Public Class UnReDO_Common
Visual C++
public ref class UnReDO_Common
F#
type UnReDO_Common =  class end

Inheritance Hierarchy

System..::..Object
SMath.Control..::..UnReDO_Common

See Also

UnReDO_Common Members
SMath.Control Namespace


UnReDO_Common Members

[image] [image]

SMath Studio Class Libraries Documantation
UnReDO_Common Members
UnReDO_Common Class Constructors Fields See Also Send Feedback

The UnReDO_Common type exposes the following members.

Constructors

 | Name | Description
Public method | UnReDO_Common | Initializes a new instance of the UnReDO_Common class

Fields

 | Name | Description
Public field | BackColor |
Public field | Border |
Public field | FontHeight |
Public field | Location |
Public field | TextColor |

See Also

UnReDO_Common Class
SMath.Control Namespace


UnReDO_Common Constructor

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common Constructor
UnReDO_Common Class See Also Send Feedback
Initializes a new instance of the UnReDO_Common class

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public UnReDO_Common()
Visual Basic
Public Sub New
Visual C++
public:
UnReDO_Common()
F#
new : unit -> UnReDO_Common

See Also

UnReDO_Common Class
SMath.Control Namespace


UnReDO_Common Fields

[image] [image]

SMath Studio Class Libraries Documantation
UnReDO_Common Fields
UnReDO_Common Class See Also Send Feedback

The UnReDO_Common type exposes the following members.

Fields

 | Name | Description
Public field | BackColor |
Public field | Border |
Public field | FontHeight |
Public field | Location |
Public field | TextColor |

See Also

UnReDO_Common Class
SMath.Control Namespace


BackColor Field

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common..::..BackColor Field
UnReDO_Common Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.UnReDO_Common.BackColor"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color BackColor
Visual Basic
Public BackColor As Color
Visual C++
public:
Color BackColor
F#
val mutable BackColor: Color

See Also

UnReDO_Common Class
SMath.Control Namespace


Border Field

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common..::..Border Field
UnReDO_Common Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.UnReDO_Common.Border"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public bool Border
Visual Basic
Public Border As Boolean
Visual C++
public:
bool Border
F#
val mutable Border: bool

See Also

UnReDO_Common Class
SMath.Control Namespace


FontHeight Field

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common..::..FontHeight Field
UnReDO_Common Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.UnReDO_Common.FontHeight"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int FontHeight
Visual Basic
Public FontHeight As Integer
Visual C++
public:
int FontHeight
F#
val mutable FontHeight: int

See Also

UnReDO_Common Class
SMath.Control Namespace


Location Field

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common..::..Location Field
UnReDO_Common Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.UnReDO_Common.Location"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Point Location
Visual Basic
Public Location As Point
Visual C++
public:
Point Location
F#
val mutable Location: Point

See Also

UnReDO_Common Class
SMath.Control Namespace


TextColor Field

[image]

SMath Studio Class Libraries Documantation
UnReDO_Common..::..TextColor Field
UnReDO_Common Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Control.UnReDO_Common.TextColor"]

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Color TextColor
Visual Basic
Public TextColor As Color
Visual C++
public:
Color TextColor
F#
val mutable TextColor: Color

See Also

UnReDO_Common Class
SMath.Control Namespace


UnReDoStatus Enumeration

[image]

SMath Studio Class Libraries Documantation
UnReDoStatus Enumeration
See Also Send Feedback
Статус истории изменений

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum UnReDoStatus
Visual Basic
Public Enumeration UnReDoStatus
Visual C++
public enum class UnReDoStatus
F#
type UnReDoStatus

Members

Member name | Value | Description
NoHistory | 0 | Нет истории изменений
FullHistory | 1 | Доступны как отмена, так и возврат
NoBack | 2 | Невозможно отменить
NoForward | 3 | Невозможно вернуть

See Also

SMath.Control Namespace


UnReDoType Enumeration

[image]

SMath Studio Class Libraries Documantation
UnReDoType Enumeration
See Also Send Feedback
Тип шага истории изменений

Namespace: SMath.Control
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public enum UnReDoType
Visual Basic
Public Enumeration UnReDoType
Visual C++
public enum class UnReDoType
F#
type UnReDoType

Members

Member name | Value | Description
Control | 0 | Изменения в свойствах элемента(ов)
ControlAdd | 1 | Элемент(ы) добавлены на лист
ControlRemove | 2 | Элемент(ы) удалены с листа

See Also

SMath.Control Namespace


SMath.Manager Namespace

[image]

SMath Studio Class Libraries Documantation
SMath.Manager Namespace
Send Feedback

[Missing <summary> documentation for "N:SMath.Manager"]

Classes

Class | Description
Public class | ActiveGrid
Public class Collection<(Of <(<'T>)>)> Obsolete.
Коллекция элементов произвольного типа
Public class Conversion<(Of <(<'T>)>)>
English: Parent class contains logic to convert string of math expression to the reverse polish notation (RPN).
Русский: Класс-родитель для перевода текстового выражения в постфиксную форму (ОПЗ).
Public class Converter
English: Class with convertion methods represented.
Русский: Класс, представляющий специфичные методы конвертации данных.
Public class Definition
English: Stores information about single definition.
Русский: Хранит информацию о конкретном определении.
Public class | DynamicLabel
Public class | EvaluationException
Public class Expression
English: Helpers methods to work with math expression represented in reverse polish notation.
Русский: Вспомогательные методы для работы с выражениями, записанными в виде постфиксной нотации.
Public class Function
Перечисление доступных встроенных функций
Public class | GlobalParams
Public class MathMethods
Вспомогательные математические методы
Public class | PluginInfo
Public class | Plugins
Public class Store
English: Evaluation context. Data type that stores all information about variables, arguments and functions definitions. Definitions represented as a stack.
Русский: Контекст вычисления. Тип данных, который хранит в себе информацию об объявленных функциях и переменных. В Store все объявления записываются по типу стэка, но есть особенности. В Store есть две коллекции: Share - публичная - это то, что приходит для вычисления вместе с заданием, т.е. это все объявления функций и переменных на листе ДО текущего выражения. А если в процессе вычисления текущего выражения встретится оператор присваивания (:=), то программа к Share добавляет новое вхождение, но так же она добавляет это же вхождение и в Local. Local - это только присвоения текущего выражения (они нужны, что б потом из них сформировать правильный Share для следующих выражений). Вообще Store имеет все методы, которые позволяют абстрагироваться от Share и Local: добавление новой переменной - AddDefinition или терминатора (заглушки) - AddTerminator (у каждого Definition есть признаки IsTerminator и IsFunction). Значение Terminator можно показать на примере дифференцирования. Например есть выражение a*x и необходимо продифференцировать его по x. Допустим также, что над текущим выражением обе эти переменные уже объявлены какими-то числовыми значениями. Чтобы заменить "а" на число, но не заменять "x", нам нужно добавить терминатор "x", но важно не забывать, что терминатры нужны только в процессе вычисления функции, т.е. если терминатор поставлен вручную, то он должен быть также вручную удалён, сразу после обработки текущей функции. Если продолжать аналогию, то терминатор в нашем примере важно удалить, что бы после дифференцирования подстановка "x" всё же состаялась и на выходе был численный ответ.
Public class Term
English: Expression component.
Русский: Компонента выражения.
Public class TermInfo
Information about the Term
Public class | UnitDefinition
Public class VariousItem
Класс-родитель элементов списка
Public class VariousList
Пользовательский элемент, список произвольных элементов

Structures

 | Structure | Description
Public structure | AssemblyInfo | Assembly Information structure
Public structure | Bracket | Доступные встроенные скобки программы
Public structure | Operator | Доступные встроенные операторы программы
Public structure | Symbol | Доступные встроенные символы программы

Interfaces

 | Interface | Description
Public interface | IPlugin | Base Interface for SMath Studio Plugins
Public interface | IPluginHandleEvaluation | Base Evaluation Interface for SMath Studio Plugins
Public interface | IPluginLowLevelEvaluation |

Enumerations

 | Enumeration | Description
Public enumeration | AnglesType | Тип угла
Public enumeration | AnswerType | Тип ответа (используется при вычислении корня по формуле Муавра)
Public enumeration | Error | Перечисление доступных ошибок программы
Public enumeration | FractionsType | Тип дроби
Public enumeration | FunctionSection | Function's section
Public enumeration | OptimizationType | English: Evaluation optimization type. Русский: Тип оптимизации вычисления.
Public enumeration | OSType |
Public enumeration | PlatformType |
Public enumeration | SysSettings | Тип отображения системы
Public enumeration | TermOrigin | English: The origin of the expression component (order based on the priorities). Русский: Происхождение компоненты выражения (порядок согласно приоритетам).
Public enumeration | TermType | English: Type of the expression component. Русский: Определение типа компоненты выражения.
Public enumeration | UnitType |


ActiveGrid Class

[image]

SMath Studio Class Libraries Documantation
ActiveGrid Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.ActiveGrid"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class ActiveGrid : Control
Visual Basic
Public Class ActiveGrid _
    Inherits Control
Visual C++
public ref class ActiveGrid : public Control
F#
type ActiveGrid =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
SMath.Manager..::..ActiveGrid

See Also

ActiveGrid Members
SMath.Manager Namespace


ActiveGrid Members

[image] [image]

SMath Studio Class Libraries Documantation
ActiveGrid Members
ActiveGrid Class Constructors Methods Properties See Also Send Feedback

The ActiveGrid type exposes the following members.

Constructors

 | Name | Description
Public method | ActiveGrid | Initializes a new instance of the ActiveGrid class

Methods

 | Name | Description
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)

Properties

 | Name | Description
Public property | ActionText |
Public property | FontSize |
Public property | StopOnStart |
Public property | TimerCounter |

See Also

ActiveGrid Class
SMath.Manager Namespace


ActiveGrid Constructor

[image]

SMath Studio Class Libraries Documantation
ActiveGrid Constructor
ActiveGrid Class See Also Send Feedback
Initializes a new instance of the ActiveGrid class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public ActiveGrid()
Visual Basic
Public Sub New
Visual C++
public:
ActiveGrid()
F#
new : unit -> ActiveGrid

See Also

ActiveGrid Class
SMath.Manager Namespace


ActiveGrid Methods

[image] [image]

SMath Studio Class Libraries Documantation
ActiveGrid Methods
ActiveGrid Class See Also Send Feedback

The ActiveGrid type exposes the following members.

Methods

 | Name | Description
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)

See Also

ActiveGrid Class
SMath.Manager Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..OnMouseDown Method
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.ActiveGrid.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.ActiveGrid.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

ActiveGrid Class
SMath.Manager Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..OnPaint Method
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.ActiveGrid.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.ActiveGrid.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

ActiveGrid Class
SMath.Manager Namespace


ActiveGrid Properties

[image] [image]

SMath Studio Class Libraries Documantation
ActiveGrid Properties
ActiveGrid Class See Also Send Feedback

The ActiveGrid type exposes the following members.

Properties

 | Name | Description
Public property | ActionText |
Public property | FontSize |
Public property | StopOnStart |
Public property | TimerCounter |

See Also

ActiveGrid Class
SMath.Manager Namespace


ActionText Property

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..ActionText Property
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.ActiveGrid.ActionText"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string ActionText { get; set; }
Visual Basic
Public Property ActionText As String
    Get
    Set
Visual C++
public:
property String^ ActionText {
    String^ get ();
    void set (String^ value);
}
F#
member ActionText : string with get, set

See Also

ActiveGrid Class
SMath.Manager Namespace


FontSize Property

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..FontSize Property
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.ActiveGrid.FontSize"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int FontSize { get; set; }
Visual Basic
Public Property FontSize As Integer
    Get
    Set
Visual C++
public:
property int FontSize {
    int get ();
    void set (int value);
}
F#
member FontSize : int with get, set

See Also

ActiveGrid Class
SMath.Manager Namespace


StopOnStart Property

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..StopOnStart Property
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.ActiveGrid.StopOnStart"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool StopOnStart { get; set; }
Visual Basic
Public Property StopOnStart As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnStart {
    bool get ();
    void set (bool value);
}
F#
member StopOnStart : bool with get, set

See Also

ActiveGrid Class
SMath.Manager Namespace


TimerCounter Property

[image]

SMath Studio Class Libraries Documantation
ActiveGrid..::..TimerCounter Property
ActiveGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.ActiveGrid.TimerCounter"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int TimerCounter { get; set; }
Visual Basic
Public Property TimerCounter As Integer
    Get
    Set
Visual C++
public:
property int TimerCounter {
    int get ();
    void set (int value);
}
F#
member TimerCounter : int with get, set

See Also

ActiveGrid Class
SMath.Manager Namespace


AnglesType Enumeration

[image]

SMath Studio Class Libraries Documantation
AnglesType Enumeration
See Also Send Feedback
Тип угла

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum AnglesType
Visual Basic
Public Enumeration AnglesType
Visual C++
public enum class AnglesType
F#
type AnglesType

Members

Member name | Value | Description
Rad | 0 | Радианы
Deg | 1 | Градусы

See Also

SMath.Manager Namespace


AnswerType Enumeration

[image]

SMath Studio Class Libraries Documantation
AnswerType Enumeration
See Also Send Feedback
Тип ответа (используется при вычислении корня по формуле Муавра)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum AnswerType
Visual Basic
Public Enumeration AnswerType
Visual C++
public enum class AnswerType
F#
type AnswerType

Members

Member name | Value | Description
All | 0 | Показывать все ответы
Real | 1 | Показывать только действительный ответы
Imaginary | 2 | Показывать только мнимые ответы
Single | 3 | Показать единственный ответ (первый действительный или, если действительного нет, первый по счёту)
Standart | 4 | Стандартно (показать первый ответ из списка)

See Also

SMath.Manager Namespace


AssemblyInfo Structure

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo Structure
Members See Also Send Feedback
Assembly Information structure

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public struct AssemblyInfo
Visual Basic
Public Structure AssemblyInfo
Visual C++
public value class AssemblyInfo
F#
[<SealedAttribute>]
type AssemblyInfo =  struct end

See Also

AssemblyInfo Members
SMath.Manager Namespace


AssemblyInfo Members

[image] [image]

SMath Studio Class Libraries Documantation
AssemblyInfo Members
AssemblyInfo Structure Constructors Properties See Also Send Feedback

The AssemblyInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AssemblyInfo(String, Version, Guid) | Plugin Info Constructor
Public method | AssemblyInfo(String, String, String, Version, Guid) | Plugin Info Constructor

Properties

 | Name | Description
Public property | Author | Plugin author
Public property | Description | Plugin description
Public property | PublicGuid | Plugin static GUID
Public property | Title | Plugin title
Public property | Version | Plugin Version

See Also

AssemblyInfo Structure
SMath.Manager Namespace


AssemblyInfo Constructor

[image] [image]

SMath Studio Class Libraries Documantation
AssemblyInfo Constructor
AssemblyInfo Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | AssemblyInfo(String, Version, Guid) | Plugin Info Constructor
Public method | AssemblyInfo(String, String, String, Version, Guid) | Plugin Info Constructor

See Also

AssemblyInfo Structure
AssemblyInfo Members
SMath.Manager Namespace


AssemblyInfo Constructor (String, Version, Guid)

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo Constructor (String, Version, Guid)
AssemblyInfo Structure See Also Send Feedback
Plugin Info Constructor

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public AssemblyInfo(
    string title,
    Version version,
    Guid publicGuid
)
Visual Basic
Public Sub New ( _
    title As String, _
    version As Version, _
    publicGuid As Guid _
)
Visual C++
public:
AssemblyInfo(
    String^ title,
    Version^ version,
    Guid publicGuid
)
F#
new :
        title:string *
        version:Version *
        publicGuid:Guid -> AssemblyInfo

Parameters

title
Type: System..::..String

[Missing <param name="title"/> documentation for "M:SMath.Manager.AssemblyInfo.#ctor(System.String,System.Version,System.Guid)"]

version
Type: System..::..Version
Plugin Version
publicGuid
Type: System..::..Guid
Plugin static GUID

See Also

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Constructor (String, String, String, Version, Guid)

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo Constructor (String, String, String, Version, Guid)
AssemblyInfo Structure See Also Send Feedback
Plugin Info Constructor

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public AssemblyInfo(
    string title,
    string description,
    string author,
    Version version,
    Guid publicGuid
)
Visual Basic
Public Sub New ( _
    title As String, _
    description As String, _
    author As String, _
    version As Version, _
    publicGuid As Guid _
)
Visual C++
public:
AssemblyInfo(
    String^ title,
    String^ description,
    String^ author,
    Version^ version,
    Guid publicGuid
)
F#
new :
        title:string *
        description:string *
        author:string *
        version:Version *
        publicGuid:Guid -> AssemblyInfo

Parameters

title
Type: System..::..String

[Missing <param name="title"/> documentation for "M:SMath.Manager.AssemblyInfo.#ctor(System.String,System.String,System.String,System.Version,System.Guid)"]

description
Type: System..::..String
Plugin description
author
Type: System..::..String
Plugin author
version
Type: System..::..Version
Plugin Version
publicGuid
Type: System..::..Guid
Plugin static GUID

See Also

AssemblyInfo Structure
AssemblyInfo Overload
SMath.Manager Namespace


AssemblyInfo Properties

[image] [image]

SMath Studio Class Libraries Documantation
AssemblyInfo Properties
AssemblyInfo Structure See Also Send Feedback

The AssemblyInfo type exposes the following members.

Properties

 | Name | Description
Public property | Author | Plugin author
Public property | Description | Plugin description
Public property | PublicGuid | Plugin static GUID
Public property | Title | Plugin title
Public property | Version | Plugin Version

See Also

AssemblyInfo Structure
SMath.Manager Namespace


Author Property

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo..::..Author Property
AssemblyInfo Structure See Also Send Feedback
Plugin author

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Author { get; }
Visual Basic
Public ReadOnly Property Author As String
    Get
Visual C++
public:
property String^ Author {
    String^ get ();
}
F#
member Author : string

See Also

AssemblyInfo Structure
SMath.Manager Namespace


Description Property

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo..::..Description Property
AssemblyInfo Structure See Also Send Feedback
Plugin description

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}
F#
member Description : string

See Also

AssemblyInfo Structure
SMath.Manager Namespace


PublicGuid Property

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo..::..PublicGuid Property
AssemblyInfo Structure See Also Send Feedback
Plugin static GUID

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Guid PublicGuid { get; }
Visual Basic
Public ReadOnly Property PublicGuid As Guid
    Get
Visual C++
public:
property Guid PublicGuid {
    Guid get ();
}
F#
member PublicGuid : Guid

See Also

AssemblyInfo Structure
SMath.Manager Namespace


Title Property

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo..::..Title Property
AssemblyInfo Structure See Also Send Feedback
Plugin title

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}
F#
member Title : string

See Also

AssemblyInfo Structure
SMath.Manager Namespace


Version Property

[image]

SMath Studio Class Libraries Documantation
AssemblyInfo..::..Version Property
AssemblyInfo Structure See Also Send Feedback
Plugin Version

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Version Version { get; }
Visual Basic
Public ReadOnly Property Version As Version
    Get
Visual C++
public:
property Version^ Version {
    Version^ get ();
}
F#
member Version : Version

See Also

AssemblyInfo Structure
SMath.Manager Namespace


Bracket Structure

[image]

SMath Studio Class Libraries Documantation
Bracket Structure
Members See Also Send Feedback
Доступные встроенные скобки программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public struct Bracket
Visual Basic
Public Structure Bracket
Visual C++
public value class Bracket
F#
[<SealedAttribute>]
type Bracket =  struct end

See Also

Bracket Members
SMath.Manager Namespace


Bracket Members

[image] [image]

SMath Studio Class Libraries Documantation
Bracket Members
Bracket Structure Fields See Also Send Feedback

The Bracket type exposes the following members.

Fields

Name | Description
LeftInvisible | Невидимая открывающая скобка
LeftVisible | Видимая открывающая скобка
RightInvisible | Невидимая закрывающая скобка
RightVisible | Видимая закрывающая скобка

See Also

Bracket Structure
SMath.Manager Namespace


Bracket Fields

[image] [image]

SMath Studio Class Libraries Documantation
Bracket Fields
Bracket Structure See Also Send Feedback

The Bracket type exposes the following members.

Fields

Name | Description
LeftInvisible | Невидимая открывающая скобка
LeftVisible | Видимая открывающая скобка
RightInvisible | Невидимая закрывающая скобка
RightVisible | Видимая закрывающая скобка

See Also

Bracket Structure
SMath.Manager Namespace


LeftInvisible Field

[image]

SMath Studio Class Libraries Documantation
Bracket..::..LeftInvisible Field
Bracket Structure See Also Send Feedback
Невидимая открывающая скобка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string LeftInvisible
Visual Basic
Public Const LeftInvisible As String
Visual C++
public:
literal String^ LeftInvisible
F#
static val mutable LeftInvisible: string

See Also

Bracket Structure
SMath.Manager Namespace


LeftVisible Field

[image]

SMath Studio Class Libraries Documantation
Bracket..::..LeftVisible Field
Bracket Structure See Also Send Feedback
Видимая открывающая скобка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string LeftVisible
Visual Basic
Public Const LeftVisible As String
Visual C++
public:
literal String^ LeftVisible
F#
static val mutable LeftVisible: string

See Also

Bracket Structure
SMath.Manager Namespace


RightInvisible Field

[image]

SMath Studio Class Libraries Documantation
Bracket..::..RightInvisible Field
Bracket Structure See Also Send Feedback
Невидимая закрывающая скобка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string RightInvisible
Visual Basic
Public Const RightInvisible As String
Visual C++
public:
literal String^ RightInvisible
F#
static val mutable RightInvisible: string

See Also

Bracket Structure
SMath.Manager Namespace


RightVisible Field

[image]

SMath Studio Class Libraries Documantation
Bracket..::..RightVisible Field
Bracket Structure See Also Send Feedback
Видимая закрывающая скобка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string RightVisible
Visual Basic
Public Const RightVisible As String
Visual C++
public:
literal String^ RightVisible
F#
static val mutable RightVisible: string

See Also

Bracket Structure
SMath.Manager Namespace


Collection(T) Class

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Коллекция элементов произвольного типа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
[ObsoleteAttribute("Use List<T> instead.")]
public class Collection<T>
Visual Basic
<ObsoleteAttribute("Use List<T> instead.")> _
Public Class Collection(Of T)
Visual C++
[ObsoleteAttribute(L"Use List<T> instead.")]
generic<typename T>
public ref class Collection
F#
[<ObsoleteAttribute("Use List<T> instead.")>]
type Collection<'T> =  class end

Type Parameters

T
Тип элементов коллекции

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Collection<(Of <(<'T>)>)>

See Also

Collection<(Of <(<'T>)>)> Members
SMath.Manager Namespace


Collection(T) Members

[image] [image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Members
Collection<(Of <(<'T>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback

The Collection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Collection<(Of <(<'T>)>)> | Конструктор класса

Methods

 | Name | Description
Public method | Add | Добавить элемент к списку имеющихся
Public method | AddRange | Добавить массив элементов
Public method | Clear | Очистить коллекцию
Public method | InsertInto | Вставить элемент в список перед элементом с индексом
Public method | MakeFirst | Сделать указанный элемент первым в списке
Public method | Pop | Возвращает последний добавленный в конец коллекции элемент и производит его удаление из коллекции
Public method | Remove | Удалить элемент из общего списка
Public method | RemoveAt | Удалить элемент из общего списка
Public method | RemoveRange | Удалить указанный диапазон элементов из списка
Public method | ToArray | Получить массив из коллекции

Fields

 | Name | Description
Protected field | items |

Properties

 | Name | Description
Public property | Count | Количество элементов в списке
Public property | Item | Возвращает указанный аргументом элемент

Events

 | Name | Description
Public event | ItemsChanged |

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Collection(T) Constructor

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Constructor
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Конструктор класса

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Collection()
Visual Basic
Public Sub New
Visual C++
public:
Collection()
F#
new : unit -> Collection

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Collection(T) Fields

[image] [image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Fields
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

The Collection<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | items |

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


items Field

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..items Field
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.Collection`1.items"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected T[] items
Visual Basic
Protected items As T()
Visual C++
protected:
array<T>^ items
F#
val mutable items: 'T[]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Collection(T) Methods

[image] [image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Methods
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

The Collection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Добавить элемент к списку имеющихся
Public method | AddRange | Добавить массив элементов
Public method | Clear | Очистить коллекцию
Public method | InsertInto | Вставить элемент в список перед элементом с индексом
Public method | MakeFirst | Сделать указанный элемент первым в списке
Public method | Pop | Возвращает последний добавленный в конец коллекции элемент и производит его удаление из коллекции
Public method | Remove | Удалить элемент из общего списка
Public method | RemoveAt | Удалить элемент из общего списка
Public method | RemoveRange | Удалить указанный диапазон элементов из списка
Public method | ToArray | Получить массив из коллекции

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Add Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Add Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Добавить элемент к списку имеющихся

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int Add(
    T value
)
Visual Basic
Public Function Add ( _
    value As T _
) As Integer
Visual C++
public:
int Add(
    T value
)
F#
member Add :
        value:'T -> int

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:SMath.Manager.Collection`1.Add(`0)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Collection`1.Add(`0)"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


AddRange Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..AddRange Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Добавить массив элементов

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void AddRange(
    T[] Items
)
Visual Basic
Public Sub AddRange ( _
    Items As T() _
)
Visual C++
public:
void AddRange(
    array<T>^ Items
)
F#
member AddRange :
        Items:'T[] -> unit

Parameters

Items
Type: array< T >[]()[][]

[Missing <param name="Items"/> documentation for "M:SMath.Manager.Collection`1.AddRange(`0[])"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Clear Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Clear Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Очистить коллекцию

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()
F#
member Clear : unit -> unit

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


InsertInto Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..InsertInto Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Вставить элемент в список перед элементом с индексом

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int InsertInto(
    int index,
    T item
)
Visual Basic
Public Function InsertInto ( _
    index As Integer, _
    item As T _
) As Integer
Visual C++
public:
int InsertInto(
    int index,
    T item
)
F#
member InsertInto :
        index:int *
        item:'T -> int

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Manager.Collection`1.InsertInto(System.Int32,`0)"]

item
Type: T

[Missing <param name="item"/> documentation for "M:SMath.Manager.Collection`1.InsertInto(System.Int32,`0)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Collection`1.InsertInto(System.Int32,`0)"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


MakeFirst Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..MakeFirst Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Сделать указанный элемент первым в списке

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void MakeFirst(
    int index
)
Visual Basic
Public Sub MakeFirst ( _
    index As Integer _
)
Visual C++
public:
void MakeFirst(
    int index
)
F#
member MakeFirst :
        index:int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Manager.Collection`1.MakeFirst(System.Int32)"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Pop Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Pop Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Возвращает последний добавленный в конец коллекции элемент и производит его удаление из коллекции

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public T Pop()
Visual Basic
Public Function Pop As T
Visual C++
public:
T Pop()
F#
member Pop : unit -> 'T

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Collection`1.Pop"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Remove Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Remove Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Удалить элемент из общего списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int Remove(
    T obj
)
Visual Basic
Public Function Remove ( _
    obj As T _
) As Integer
Visual C++
public:
int Remove(
    T obj
)
F#
member Remove :
        obj:'T -> int

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:SMath.Manager.Collection`1.Remove(`0)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Collection`1.Remove(`0)"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


RemoveAt Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..RemoveAt Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Удалить элемент из общего списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)
F#
member RemoveAt :
        index:int -> unit

Parameters

index
Type: System..::..Int32
Индекс элемента для удаления

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


RemoveRange Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..RemoveRange Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Удалить указанный диапазон элементов из списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void RemoveRange(
    int index,
    int noCount
)
Visual Basic
Public Sub RemoveRange ( _
    index As Integer, _
    noCount As Integer _
)
Visual C++
public:
void RemoveRange(
    int index,
    int noCount
)
F#
member RemoveRange :
        index:int *
        noCount:int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Manager.Collection`1.RemoveRange(System.Int32,System.Int32)"]

noCount
Type: System..::..Int32

[Missing <param name="noCount"/> documentation for "M:SMath.Manager.Collection`1.RemoveRange(System.Int32,System.Int32)"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


ToArray Method

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..ToArray Method
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Получить массив из коллекции

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public virtual T[] ToArray()
Visual Basic
Public Overridable Function ToArray As T()
Visual C++
public:
virtual array<T>^ ToArray()
F#
abstract ToArray : unit -> 'T[]
override ToArray : unit -> 'T[]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Collection`1.ToArray"]

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Collection(T) Properties

[image] [image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Properties
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

The Collection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Количество элементов в списке
Public property | Item | Возвращает указанный аргументом элемент

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Count Property

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Count Property
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Количество элементов в списке

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}
F#
member Count : int

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Item Property

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..Item Property
Collection<(Of <(<'T>)>)> Class See Also Send Feedback
Возвращает указанный аргументом элемент

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public T this[
    int index
] { get; set; }
Visual Basic
Public Property Item ( _
    index As Integer _
) As T
    Get
    Set
Visual C++
public:
property T Item[int index] {
    T get (int index);
    void set (int index, T value);
}
F#
member Item : 'T with get, set

Parameters

index
Type: System..::..Int32
Номер элемента в массиве

Return Value

Указанный аргументом элемент

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Collection(T) Events

[image] [image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)> Events
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

The Collection<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | ItemsChanged |

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


ItemsChanged Event

[image]

SMath Studio Class Libraries Documantation
Collection<(Of <(<'T>)>)>..::..ItemsChanged Event
Collection<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "E:SMath.Manager.Collection`1.ItemsChanged"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public event EventHandler ItemsChanged
Visual Basic
Public Event ItemsChanged As EventHandler
Visual C++
public:
 event EventHandler^ ItemsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
F#
member ItemsChanged : IEvent<EventHandler,
    EventArgs>

See Also

Collection<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Conversion(T) Class

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)> Class
Members See Also Send Feedback
English: Parent class contains logic to convert string of math expression to the reverse polish notation (RPN).
Русский: Класс-родитель для перевода текстового выражения в постфиксную форму (ОПЗ).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Conversion<T>
Visual Basic
Public Class Conversion(Of T)
Visual C++
generic<typename T>
public ref class Conversion
F#
type Conversion<'T> =  class end

Type Parameters

T
English: Expression component type to store the primitives in.
Русский: Тип компоненты выражения для хранения результата конвертации.

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Conversion<(Of <(<'T>)>)>

See Also

Conversion<(Of <(<'T>)>)> Members
SMath.Manager Namespace


Conversion(T) Members

[image] [image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)> Members
Conversion<(Of <(<'T>)>)> Class Constructors Methods Fields See Also Send Feedback

The Conversion<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Conversion<(Of <(<'T>)>)> | Initializes a new instance of the Conversion<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | CreateBracket | English: Creates Bracket. Русский: Создание скобки.
Protected method | CreateFunction | English: Creates a Function. Русский: Создание функции.
Protected method | CreateOperand | English: Creates Operand. Русский: Создание операнда.
Protected method | CreateOperator | English: Creates Operator. Русский: Создание оператора.
Protected method | PushFromStack(T) | English: Moving an expression component from the stack to result. Русский: Размещение элементов из стэка в результат.
Protected method | PushFromStack(T, T) | English: Preparing of the next stack element. Русский: Подготовка следующего элемента стэка.
Public method | ToPostfix | English: Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN). Русский: Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).

Fields

 | Name | Description
Protected field | result | English: Result stack. Русский: Результирующий стэк.
Protected field | stk | English: Stores information about a number of children. Русский: Хранит информацию о количесте зависимых элементов.

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Conversion(T) Constructor

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)> Constructor
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the Conversion<(Of <(<'T>)>)> class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Conversion()
Visual Basic
Public Sub New
Visual C++
public:
Conversion()
F#
new : unit -> Conversion

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Conversion(T) Fields

[image] [image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)> Fields
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback

The Conversion<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | result | English: Result stack. Русский: Результирующий стэк.
Protected field | stk | English: Stores information about a number of children. Русский: Хранит информацию о количесте зависимых элементов.

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


result Field

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..result Field
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Result stack.
Русский: Результирующий стэк.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected Stack<T> result
Visual Basic
Protected result As Stack(Of T)
Visual C++
protected:
Stack<T>^ result
F#
val mutable result: Stack<'T>

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


stk Field

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..stk Field
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Stores information about a number of children.
Русский: Хранит информацию о количесте зависимых элементов.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected Stack<int> stk
Visual Basic
Protected stk As Stack(Of Integer)
Visual C++
protected:
Stack<int>^ stk
F#
val mutable stk: Stack<int>

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Conversion(T) Methods

[image] [image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)> Methods
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback

The Conversion<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | CreateBracket | English: Creates Bracket. Русский: Создание скобки.
Protected method | CreateFunction | English: Creates a Function. Русский: Создание функции.
Protected method | CreateOperand | English: Creates Operand. Русский: Создание операнда.
Protected method | CreateOperator | English: Creates Operator. Русский: Создание оператора.
Protected method | PushFromStack(T) | English: Moving an expression component from the stack to result. Русский: Размещение элементов из стэка в результат.
Protected method | PushFromStack(T, T) | English: Preparing of the next stack element. Русский: Подготовка следующего элемента стэка.
Public method | ToPostfix | English: Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN). Русский: Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


CreateBracket Method

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..CreateBracket Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Creates Bracket.
Русский: Создание скобки.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual T CreateBracket(
    ref string value
)
Visual Basic
Protected Overridable Function CreateBracket ( _
    ByRef value As String _
) As T
Visual C++
protected:
virtual T CreateBracket(
    String^% value
)
F#
abstract CreateBracket :
        value:string byref -> 'T
override CreateBracket :
        value:string byref -> 'T

Parameters

value
Type: System..::..String %
English: Type of the Bracket.
Русский: Вид скобки.

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Conversion`1.CreateBracket(System.String@)"]

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


CreateFunction Method

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..CreateFunction Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Creates a Function.
Русский: Создание функции.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual T CreateFunction(
    ref string value
)
Visual Basic
Protected Overridable Function CreateFunction ( _
    ByRef value As String _
) As T
Visual C++
protected:
virtual T CreateFunction(
    String^% value
)
F#
abstract CreateFunction :
        value:string byref -> 'T
override CreateFunction :
        value:string byref -> 'T

Parameters

value
Type: System..::..String %
English: Name of a Function.
Русский: Название функции.

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Conversion`1.CreateFunction(System.String@)"]

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


CreateOperand Method

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..CreateOperand Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Creates Operand.
Русский: Создание операнда.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual T CreateOperand(
    ref string value
)
Visual Basic
Protected Overridable Function CreateOperand ( _
    ByRef value As String _
) As T
Visual C++
protected:
virtual T CreateOperand(
    String^% value
)
F#
abstract CreateOperand :
        value:string byref -> 'T
override CreateOperand :
        value:string byref -> 'T

Parameters

value
Type: System..::..String %
English: Text value of the Operand.
Русский: Текстовое значение операнда.

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Conversion`1.CreateOperand(System.String@)"]

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


CreateOperator Method

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..CreateOperator Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Creates Operator.
Русский: Создание оператора.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual T CreateOperator(
    ref string value,
    int child
)
Visual Basic
Protected Overridable Function CreateOperator ( _
    ByRef value As String, _
    child As Integer _
) As T
Visual C++
protected:
virtual T CreateOperator(
    String^% value,
    int child
)
F#
abstract CreateOperator :
        value:string byref *
        child:int -> 'T
override CreateOperator :
        value:string byref *
        child:int -> 'T

Parameters

value
Type: System..::..String %
English: Text value of the Operator.
Русский: Текстовое значение оператора.
child
Type: System..::..Int32
English: Number of children.
Русский: Количество зависимы элементов.

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Conversion`1.CreateOperator(System.String@,System.Int32)"]

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


PushFromStack Method

[image] [image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..PushFromStack Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | PushFromStack(T) | English: Moving an expression component from the stack to result. Русский: Размещение элементов из стэка в результат.
Protected method | PushFromStack(T, T) | English: Preparing of the next stack element. Русский: Подготовка следующего элемента стэка.

See Also

Conversion<(Of <(<'T>)>)> Class
Conversion<(Of <(<'T>)>)> Members
SMath.Manager Namespace


PushFromStack Method (T)

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..PushFromStack Method (T)
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Moving an expression component from the stack to result.
Русский: Размещение элементов из стэка в результат.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual void PushFromStack(
    T last
)
Visual Basic
Protected Overridable Sub PushFromStack ( _
    last As T _
)
Visual C++
protected:
virtual void PushFromStack(
    T last
)
F#
abstract PushFromStack :
        last:'T -> unit
override PushFromStack :
        last:'T -> unit

Parameters

last
Type: T

[Missing <param name="last"/> documentation for "M:SMath.Manager.Conversion`1.PushFromStack(`0)"]

See Also

Conversion<(Of <(<'T>)>)> Class
PushFromStack Overload
SMath.Manager Namespace


PushFromStack Method (T, T)

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..PushFromStack Method (T, T)
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Preparing of the next stack element.
Русский: Подготовка следующего элемента стэка.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected virtual int PushFromStack(
    T last,
    T prev
)
Visual Basic
Protected Overridable Function PushFromStack ( _
    last As T, _
    prev As T _
) As Integer
Visual C++
protected:
virtual int PushFromStack(
    T last,
    T prev
)
F#
abstract PushFromStack :
        last:'T *
        prev:'T -> int
override PushFromStack :
        last:'T *
        prev:'T -> int

Parameters

last
Type: T

[Missing <param name="last"/> documentation for "M:SMath.Manager.Conversion`1.PushFromStack(`0,`0)"]

prev
Type: T

[Missing <param name="prev"/> documentation for "M:SMath.Manager.Conversion`1.PushFromStack(`0,`0)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Conversion`1.PushFromStack(`0,`0)"]

See Also

Conversion<(Of <(<'T>)>)> Class
PushFromStack Overload
SMath.Manager Namespace


ToPostfix Method

[image]

SMath Studio Class Libraries Documantation
Conversion<(Of <(<'T>)>)>..::..ToPostfix Method
Conversion<(Of <(<'T>)>)> Class See Also Send Feedback
English: Converts math expression represented as a string to the array of expression components in reverse polish notation (RPN).
Русский: Переводит математическое выражение, записанное в виде строки, в массив компонент выражения в порядке обратной польской записи (ОПЗ).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Stack<T> ToPostfix(
    ref string value
)
Visual Basic
Public Function ToPostfix ( _
    ByRef value As String _
) As Stack(Of T)
Visual C++
public:
Stack<T>^ ToPostfix(
    String^% value
)
F#
member ToPostfix :
        value:string byref -> Stack<'T>

Parameters

value
Type: System..::..String %
English: String of the mathematical expression.
Русский: Строка математического выражения.

Return Value

English: Return an array of the expression components in RPN order.
Русский: Возвращает массив компонент выражения в порядке ОПЗ.

Remarks

English: Important to be sure that both delimiters - Decimal Symbol and Argument Separator - are correctly specified in the global params.
Русский: Важно убедиться, что оба разделителя - целой и дробной частей числа и аргументов функций - верно выставлены в глобальных параметрах программы.

See Also

Conversion<(Of <(<'T>)>)> Class
SMath.Manager Namespace


Converter Class

[image]

SMath Studio Class Libraries Documantation
Converter Class
Members See Also Send Feedback
English: Class with convertion methods represented.
Русский: Класс, представляющий специфичные методы конвертации данных.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Converter
Visual Basic
Public Class Converter
Visual C++
public ref class Converter
F#
type Converter =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Converter

See Also

Converter Members
SMath.Manager Namespace


Converter Members

[image] [image]

SMath Studio Class Libraries Documantation
Converter Members
Converter Class Constructors Methods See Also Send Feedback

The Converter type exposes the following members.

Constructors

 | Name | Description
Public method | Converter | Initializes a new instance of the Converter class

Methods

Name | Description
CorrectExpressionString | English: Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters. Русский: Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.
CorrectExpressionTerms | English: Modifies initial math expression represented as an array of Term in order to change Decimal Symbol delimiters. Русский: Модифицирует математическое выражение, представленное в виде массива Term, заменяя разделители целой и дробной частей числа.
ToString | English: Converts math expression from the array of Term to string. Русский: Переводит математическое выражение из массива Term в строку.
ToStringStandard | English: Converts math expression from the array of Term to string with standard Decimal Symbol and Function Arguments separators. Русский: Переводит математического выражения из массива Term в строку со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.
ToTerms | English: Converts math expression from the string to array of Term. Русский: Перевести математическое выражение из строки в массив Term.
ToTermsStandard | English: Converts math expression from the string to array of Term with standard Decimal Symbol and Function Arguments separators. Русский: Перевод математического выражения из строки в массив Term со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.

See Also

Converter Class
SMath.Manager Namespace


Converter Constructor

[image]

SMath Studio Class Libraries Documantation
Converter Constructor
Converter Class See Also Send Feedback
Initializes a new instance of the Converter class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Converter()
Visual Basic
Public Sub New
Visual C++
public:
Converter()
F#
new : unit -> Converter

See Also

Converter Class
SMath.Manager Namespace


Converter Methods

[image] [image]

SMath Studio Class Libraries Documantation
Converter Methods
Converter Class See Also Send Feedback

The Converter type exposes the following members.

Methods

Name | Description
CorrectExpressionString | English: Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters. Русский: Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.
CorrectExpressionTerms | English: Modifies initial math expression represented as an array of Term in order to change Decimal Symbol delimiters. Русский: Модифицирует математическое выражение, представленное в виде массива Term, заменяя разделители целой и дробной частей числа.
ToString | English: Converts math expression from the array of Term to string. Русский: Переводит математическое выражение из массива Term в строку.
ToStringStandard | English: Converts math expression from the array of Term to string with standard Decimal Symbol and Function Arguments separators. Русский: Переводит математического выражения из массива Term в строку со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.
ToTerms | English: Converts math expression from the string to array of Term. Русский: Перевести математическое выражение из строки в массив Term.
ToTermsStandard | English: Converts math expression from the string to array of Term with standard Decimal Symbol and Function Arguments separators. Русский: Перевод математического выражения из строки в массив Term со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.

See Also

Converter Class
SMath.Manager Namespace


CorrectExpressionString Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..CorrectExpressionString Method
Converter Class See Also Send Feedback
English: Modifies initial math expression represented as a string in order to change Decimal Symbol and Arguments Separators delimiters.
Русский: Модифицирует математическое выражение, представленное в виде строки, заменяя разделители целой и дробной частей числа и разделители аргументов функций.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string CorrectExpressionString(
    string value,
    char decimalSymbolFrom,
    char decimalSymbolTo,
    char argumentsSeparatorFrom,
    char argumentsSeparatorTo
)
Visual Basic
Public Shared Function CorrectExpressionString ( _
    value As String, _
    decimalSymbolFrom As Char, _
    decimalSymbolTo As Char, _
    argumentsSeparatorFrom As Char, _
    argumentsSeparatorTo As Char _
) As String
Visual C++
public:
static String^ CorrectExpressionString(
    String^ value,
    wchar_t decimalSymbolFrom,
    wchar_t decimalSymbolTo,
    wchar_t argumentsSeparatorFrom,
    wchar_t argumentsSeparatorTo
)
F#
static member CorrectExpressionString :
        value:string *
        decimalSymbolFrom:char *
        decimalSymbolTo:char *
        argumentsSeparatorFrom:char *
        argumentsSeparatorTo:char -> string

Parameters

value
Type: System..::..String
English: Initial math expression to modify.
Русский: Исходное математическое выражение для модификации.
decimalSymbolFrom
Type: System..::..Char
English: Decimal Symbol to remove.
Русский: Исходный разделитель целой и дробной частей числа (будет заменён).
decimalSymbolTo
Type: System..::..Char
English: Decimal Symbol to insert.
Русский: Искомый разделитель целой и дробной частей числа (будет вставлен).
argumentsSeparatorFrom
Type: System..::..Char
English: Arguments separator to remove.
Русский: Исходный разделитель аргументов функций (будет заменён).
argumentsSeparatorTo
Type: System..::..Char
English: Arguments separator to insert.
Русский: Искомый разделитель аргументов функций (будет вставлен).

Return Value

English: Returns string of mathematical expression with modified separators.
Русский: Возвращает строку математического выражения с модифицированными разделителями.

See Also

Converter Class
SMath.Manager Namespace


CorrectExpressionTerms Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..CorrectExpressionTerms Method
Converter Class See Also Send Feedback
English: Modifies initial math expression represented as an array of Term in order to change Decimal Symbol delimiters.
Русский: Модифицирует математическое выражение, представленное в виде массива Term, заменяя разделители целой и дробной частей числа.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void CorrectExpressionTerms(
    ref Term[] value,
    char decimalSymbolFrom,
    char decimalSymbolTo
)
Visual Basic
Public Shared Sub CorrectExpressionTerms ( _
    ByRef value As Term(), _
    decimalSymbolFrom As Char, _
    decimalSymbolTo As Char _
)
Visual C++
public:
static void CorrectExpressionTerms(
    array<Term^>^% value,
    wchar_t decimalSymbolFrom,
    wchar_t decimalSymbolTo
)
F#
static member CorrectExpressionTerms :
        value:Term[] byref *
        decimalSymbolFrom:char *
        decimalSymbolTo:char -> unit

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]%
English: Math expression to modify.
Русский: Математическое выражение для модификации.
decimalSymbolFrom
Type: System..::..Char
English: Decimal Symbol to remove.
Русский: Исходный разделитель целой и дробной частей числа (будет заменён).
decimalSymbolTo
Type: System..::..Char
English: Decimal Symbol to insert.
Русский: Искомый разделитель целой и дробной частей числа (будет вставлен).

See Also

Converter Class
SMath.Manager Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToString Method
Converter Class See Also Send Feedback
English: Converts math expression from the array of Term to string.
Русский: Переводит математическое выражение из массива Term в строку.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string ToString(
    Term[] value
)
Visual Basic
Public Shared Function ToString ( _
    value As Term() _
) As String
Visual C++
public:
static String^ ToString(
    array<Term^>^ value
)
F#
static member ToString :
        value:Term[] -> string

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Term array to perform convertion.
Русский: Массив Term для преобразования.

Return Value

English: Math expression represented as a string.
Русский: Математическое выражение, записанное в строку.

See Also

Converter Class
SMath.Manager Namespace


ToStringStandard Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToStringStandard Method
Converter Class See Also Send Feedback
English: Converts math expression from the array of Term to string with standard Decimal Symbol and Function Arguments separators.
Русский: Переводит математического выражения из массива Term в строку со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string ToStringStandard(
    Term[] value
)
Visual Basic
Public Shared Function ToStringStandard ( _
    value As Term() _
) As String
Visual C++
public:
static String^ ToStringStandard(
    array<Term^>^ value
)
F#
static member ToStringStandard :
        value:Term[] -> string

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Term array to perform convertion.
Русский: Массив Term для преобразования.

Return Value

English: Math expression represented as a string.
Русский: Математическое выражение, записанное в строку.

See Also

Converter Class
SMath.Manager Namespace


ToTerms Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToTerms Method
Converter Class See Also Send Feedback
English: Converts math expression from the string to array of Term.
Русский: Перевести математическое выражение из строки в массив Term.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[] ToTerms(
    string value
)
Visual Basic
Public Shared Function ToTerms ( _
    value As String _
) As Term()
Visual C++
public:
static array<Term^>^ ToTerms(
    String^ value
)
F#
static member ToTerms :
        value:string -> Term[]

Parameters

value
Type: System..::..String
English: String to convert.
Русский: Строка для преобразования.

Return Value

English: Math expression in RPN represented by the array of Term.
Русский: Математическое выражение в виде ОПЗ, представленная массивом Term.

See Also

Converter Class
SMath.Manager Namespace


ToTermsStandard Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToTermsStandard Method
Converter Class See Also Send Feedback
English: Converts math expression from the string to array of Term with standard Decimal Symbol and Function Arguments separators.
Русский: Перевод математического выражения из строки в массив Term со стандартными разделителями целой и дробной частей числа и разделителем аргументов функций.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[] ToTermsStandard(
    string value
)
Visual Basic
Public Shared Function ToTermsStandard ( _
    value As String _
) As Term()
Visual C++
public:
static array<Term^>^ ToTermsStandard(
    String^ value
)
F#
static member ToTermsStandard :
        value:string -> Term[]

Parameters

value
Type: System..::..String
English: String to convert.
Русский: Строка для преобразования.

Return Value

English: Math expression in RPN represented by the array of Term.
Русский: Математическое выражение в виде ОПЗ, представленная массивом Term.

See Also

Converter Class
SMath.Manager Namespace


Definition Class

[image]

SMath Studio Class Libraries Documantation
Definition Class
Members See Also Send Feedback
English: Stores information about single definition.
Русский: Хранит информацию о конкретном определении.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Definition
Visual Basic
Public Class Definition
Visual C++
public ref class Definition
F#
type Definition =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Definition

See Also

Definition Members
SMath.Manager Namespace


Definition Members

[image] [image]

SMath Studio Class Libraries Documantation
Definition Members
Definition Class Constructors Properties See Also Send Feedback

The Definition type exposes the following members.

Constructors

 | Name | Description
Public method | Definition | English: Definition of the function/variable. Русский: Конструктор определения переменной или функции.

Properties

 | Name | Description
Public property | Answer | English: Value of the Function or Variable. Русский: Значение функции или переменной.
Public property | IsFunction | English: Returns a type of the definition: Function (true) or Variable (false). Русский: Возвращает статус опеределния: функция (истина) или переменная (ложь).
Public property | IsInUse | English: Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions). Русский: Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).
Public property | IsTerminator | English: Returns true if this definition is Terminator. Русский: Возвращает истину, если определение является заглушкой.
Public property | Name | English: Name of the Function or Variable. Русский: Имя функции или переменной.
Public property | Variables | English: If function, then a list of variables should be defined. Русский: Список аргументов, если определяется функция.

See Also

Definition Class
SMath.Manager Namespace


Definition Constructor

[image]

SMath Studio Class Libraries Documantation
Definition Constructor
Definition Class See Also Send Feedback
English: Definition of the function/variable.
Русский: Конструктор определения переменной или функции.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Definition(
    string name,
    Term[] answer,
    Term[] variables
)
Visual Basic
Public Sub New ( _
    name As String, _
    answer As Term(), _
    variables As Term() _
)
Visual C++
public:
Definition(
    String^ name,
    array<Term^>^ answer,
    array<Term^>^ variables
)
F#
new :
        name:string *
        answer:Term[] *
        variables:Term[] -> Definition

Parameters

name
Type: System..::..String
English: Name of the function/variable.
Русский: Имя переменной или функции.
answer
Type: array< SMath.Manager..::..Term >[]()[][]
English: Value of the function/variable.
Русский: Значение переменной или функции.
variables
Type: array< SMath.Manager..::..Term >[]()[][]
English: If function, then a list of variables should be defined.
Русский: Список аргументов, если определяется функция.

See Also

Definition Class
SMath.Manager Namespace


Definition Properties

[image] [image]

SMath Studio Class Libraries Documantation
Definition Properties
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Properties

 | Name | Description
Public property | Answer | English: Value of the Function or Variable. Русский: Значение функции или переменной.
Public property | IsFunction | English: Returns a type of the definition: Function (true) or Variable (false). Русский: Возвращает статус опеределния: функция (истина) или переменная (ложь).
Public property | IsInUse | English: Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions). Русский: Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).
Public property | IsTerminator | English: Returns true if this definition is Terminator. Русский: Возвращает истину, если определение является заглушкой.
Public property | Name | English: Name of the Function or Variable. Русский: Имя функции или переменной.
Public property | Variables | English: If function, then a list of variables should be defined. Русский: Список аргументов, если определяется функция.

See Also

Definition Class
SMath.Manager Namespace


Answer Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..Answer Property
Definition Class See Also Send Feedback
English: Value of the Function or Variable.
Русский: Значение функции или переменной.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term[] Answer { get; set; }
Visual Basic
Public Property Answer As Term()
    Get
    Set
Visual C++
public:
property array<Term^>^ Answer {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
F#
member Answer : Term[] with get, set

See Also

Definition Class
SMath.Manager Namespace


IsFunction Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..IsFunction Property
Definition Class See Also Send Feedback
English: Returns a type of the definition: Function (true) or Variable (false).
Русский: Возвращает статус опеределния: функция (истина) или переменная (ложь).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool IsFunction { get; }
Visual Basic
Public ReadOnly Property IsFunction As Boolean
    Get
Visual C++
public:
property bool IsFunction {
    bool get ();
}
F#
member IsFunction : bool

See Also

Definition Class
SMath.Manager Namespace


IsInUse Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..IsInUse Property
Definition Class See Also Send Feedback
English: Returns true if the definition is already in use (can be used to prevent infinite loops while substitutions).
Русский: Возвращает истину, если определение уже используется в данный момент (помогает для предотвращения бесконечных циклов подстановки).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool IsInUse { get; set; }
Visual Basic
Public Property IsInUse As Boolean
    Get
    Set
Visual C++
public:
property bool IsInUse {
    bool get ();
    void set (bool value);
}
F#
member IsInUse : bool with get, set

See Also

Definition Class
SMath.Manager Namespace


IsTerminator Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..IsTerminator Property
Definition Class See Also Send Feedback
English: Returns true if this definition is Terminator.
Русский: Возвращает истину, если определение является заглушкой.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool IsTerminator { get; }
Visual Basic
Public ReadOnly Property IsTerminator As Boolean
    Get
Visual C++
public:
property bool IsTerminator {
    bool get ();
}
F#
member IsTerminator : bool

See Also

Definition Class
SMath.Manager Namespace


Name Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..Name Property
Definition Class See Also Send Feedback
English: Name of the Function or Variable.
Русский: Имя функции или переменной.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
F#
member Name : string with get, set

See Also

Definition Class
SMath.Manager Namespace


Variables Property

[image]

SMath Studio Class Libraries Documantation
Definition..::..Variables Property
Definition Class See Also Send Feedback
English: If function, then a list of variables should be defined.
Русский: Список аргументов, если определяется функция.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term[] Variables { get; set; }
Visual Basic
Public Property Variables As Term()
    Get
    Set
Visual C++
public:
property array<Term^>^ Variables {
    array<Term^>^ get ();
    void set (array<Term^>^ value);
}
F#
member Variables : Term[] with get, set

See Also

Definition Class
SMath.Manager Namespace


DynamicLabel Class

[image]

SMath Studio Class Libraries Documantation
DynamicLabel Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.DynamicLabel"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class DynamicLabel : Control
Visual Basic
Public Class DynamicLabel _
    Inherits Control
Visual C++
public ref class DynamicLabel : public Control
F#
type DynamicLabel =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
SMath.Manager..::..DynamicLabel

See Also

DynamicLabel Members
SMath.Manager Namespace


DynamicLabel Members

[image] [image]

SMath Studio Class Libraries Documantation
DynamicLabel Members
DynamicLabel Class Constructors Methods Properties See Also Send Feedback

The DynamicLabel type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicLabel | Initializes a new instance of the DynamicLabel class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the DynamicLabel and optionally releases the managed resources (Overrides Control..::..Dispose(Boolean).)
Protected method | OnHandleDestroyed | (Overrides Control..::..OnHandleDestroyed(EventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | (Overrides Control..::..OnResize(EventArgs).)
Protected method | OnTextChanged | (Overrides Control..::..OnTextChanged(EventArgs).)

Properties

 | Name | Description
Public property | Text | (Overrides Control..::..Text.)

See Also

DynamicLabel Class
SMath.Manager Namespace


DynamicLabel Constructor

[image]

SMath Studio Class Libraries Documantation
DynamicLabel Constructor
DynamicLabel Class See Also Send Feedback
Initializes a new instance of the DynamicLabel class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public DynamicLabel()
Visual Basic
Public Sub New
Visual C++
public:
DynamicLabel()
F#
new : unit -> DynamicLabel

See Also

DynamicLabel Class
SMath.Manager Namespace


DynamicLabel Methods

[image] [image]

SMath Studio Class Libraries Documantation
DynamicLabel Methods
DynamicLabel Class See Also Send Feedback

The DynamicLabel type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Control..::..Dispose(Boolean).)
Protected method | OnHandleDestroyed | (Overrides Control..::..OnHandleDestroyed(EventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | (Overrides Control..::..OnResize(EventArgs).)
Protected method | OnTextChanged | (Overrides Control..::..OnTextChanged(EventArgs).)

See Also

DynamicLabel Class
SMath.Manager Namespace


Dispose Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..Dispose Method
DynamicLabel Class See Also Send Feedback
Releases the unmanaged resources used by the DynamicLabel and optionally releases the managed resources

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override
F#
abstract Dispose :
        disposing:bool -> unit
override Dispose :
        disposing:bool -> unit

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

DynamicLabel Class
SMath.Manager Namespace


OnHandleDestroyed Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..OnHandleDestroyed Method
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.DynamicLabel.OnHandleDestroyed(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnHandleDestroyed(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnHandleDestroyed ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnHandleDestroyed(
    EventArgs^ e
) override
F#
abstract OnHandleDestroyed :
        e:EventArgs -> unit
override OnHandleDestroyed :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.DynamicLabel.OnHandleDestroyed(System.EventArgs)"]

See Also

DynamicLabel Class
SMath.Manager Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..OnPaint Method
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.DynamicLabel.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.DynamicLabel.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

DynamicLabel Class
SMath.Manager Namespace


OnPaintBackground Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..OnPaintBackground Method
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.DynamicLabel.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaintBackground(
    PaintEventArgs^ e
) override
F#
abstract OnPaintBackground :
        e:PaintEventArgs -> unit
override OnPaintBackground :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.DynamicLabel.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

See Also

DynamicLabel Class
SMath.Manager Namespace


OnResize Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..OnResize Method
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.DynamicLabel.OnResize(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override
F#
abstract OnResize :
        e:EventArgs -> unit
override OnResize :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.DynamicLabel.OnResize(System.EventArgs)"]

See Also

DynamicLabel Class
SMath.Manager Namespace


OnTextChanged Method

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..OnTextChanged Method
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.DynamicLabel.OnTextChanged(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnTextChanged(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnTextChanged ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnTextChanged(
    EventArgs^ e
) override
F#
abstract OnTextChanged :
        e:EventArgs -> unit
override OnTextChanged :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.DynamicLabel.OnTextChanged(System.EventArgs)"]

See Also

DynamicLabel Class
SMath.Manager Namespace


DynamicLabel Properties

[image] [image]

SMath Studio Class Libraries Documantation
DynamicLabel Properties
DynamicLabel Class See Also Send Feedback

The DynamicLabel type exposes the following members.

Properties

 | Name | Description
Public property | Text | (Overrides Control..::..Text.)

See Also

DynamicLabel Class
SMath.Manager Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
DynamicLabel..::..Text Property
DynamicLabel Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.DynamicLabel.Text"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public override string Text { get; set; }
Visual Basic
Public Overrides Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
F#
abstract Text : string with get, set
override Text : string with get, set

See Also

DynamicLabel Class
SMath.Manager Namespace


Error Enumeration

[image]

SMath Studio Class Libraries Documantation
Error Enumeration
See Also Send Feedback
Перечисление доступных ошибок программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum Error
Visual Basic
Public Enumeration Error
Visual C++
public enum class Error
F#
type Error

Members

Member name | Value | Description
NoError | -1 | Нет ошибки
EmptyElements | 0 | "Не все пустые элементы заполнены"
EmptyOperators | 1 | "Не все пустые операторы заполнены"
NotDefined | 2 | "- неопределено"
SystemsNotSupported | 3 | "Системы не поддерживаются"
ArgumentMustBeScalar | 4 | "Аргумент должен быть скаляром"
LimitsMustBeInteger | 5 | "Пределы функции должны быть целыми действительными числами"
TypeConversionError | 6 | "Ошибка приведения типов. Пожалуйста, свяжитесь с разработчиком программы с указанием вызвавшего данную ошибку примера"
ArgumentCanNotBeZero | 7 | "Аргумент нуля не существует"
NoResult | 8 | "Нет решения"
CriticalError | 9 | "Обнаружена критическая ошибка"
RestorationStarted | 10 | "Если восстановление пройдёт безуспешно, экстренное сохранение информации Вы найдёте в папке программы по адресу: "
Uncertainty | 11 | "Неопределённость"
ArgumentMustBePositiveInteger | 12 | "Аргумент должен быть целым положительным числом"
RoundingCoefficientError | 13 | "Коэффициент округления должен лежать в диапазоне от 0 до 15 включительно"
VariableOfIntegrationNotSpecified | 14 | "Переменная интегрирования не указана, либо указана не верно"
LimitsMustBeReal | 15 | "Пределы интегрирования должны быть действительными числами"
NoRealRoots | 16 | "Действительных корней нет"
InequalitiesNotSupported | 17 | "Неравенства не поддерживаются"
CanNotFindFile | 18 | "Невозможно найти файл:"
CanNotStartsWithNumber | 19 | "Названия параметров и функций не могут начинаться с числа. Пожалуйста, задайте другое имя"
ControlCanNotBeDisplayed | 20 | "Один или несколько элементов листа не удаётся отобразить"
XMCDFileCanNotBeFullyParsed | 21 | {0} ошибок обнаружено при разборе .xmcd файла. Данная версия программы не может полностью отобразить документ. Пожалуйста, проверьте доступные обновления программы, в противном случае отправьте файл разработчикам для будущей реализации.
RealPartMustBeMoreThanZero | 22 | Действительная часть аргумента должна быть больше нуля
XMCDFileCanNotBeFullySaved | 23 | {0} ошибок обнаружено при сохранении .xmcd файла. Установленная версия программы не может полностью сохранить документ в выбранном формате. Используйте формат файлов SMath Studio (*.sm) для сохранения всех данных листа.
DimensionsDifferent | 24 | "Размерность элементов различна"
ProcessingInterruptedByUser | 25 | "Вычисление прервано пользователем"
ArgumentMustBeVector | 26 | "Аргумент должен быть вектором"
FileRequiresNewerProgram | 27 | "Файл {0} был создан с помощью более поздней версии {1}: {2}."
FileRequiresNewerPlugin | 28 | "Файл {0} требует более позднюю версию дополнения {1}: {2} или старшую."
FileRequiresForPlugin | 29 | "Файл {0} требует, чтобы было установлено дополнение: {1} (версия: {2}; GUID: {3})."
AlertsOccuredOnFileOpen | 30 | "Ошибки произошли во время открытия файла {0}."
FileCanBeOpenedWithErrors | 31 | "Результат открытия файла может содержать ошибки. Вы всё равно хотите открыть файл {0}?"
PluginCannotBeEnabled | 32 | "Ошибка возникла при открытии стороннего дополнения. Дополнение отключено."
PluginRequiresNewerProgram | 33 | "Дополнение {0} требует более новой версии программы {1}: {2} или старшую."
PluginRequiresNewerPlugin | 34 | "Дополнение {0} требует наличия новой версии дополнительного установленного дополнения {1}: {2} или старшую."
PluginRequiresForPlugin | 35 | "Дополнение {0} требует наличия дополнительного установленного дополнения: {1} (версия: {2}; GUID: {3})."
AlertsOccuredOnPluginOpen | 36 | "Ошибки возникли при подключении дополнения {0}."
PluginCanBeOpenedWithErrors | 37 | "Используя данный плагин на листе могут возникнуть неожиданные ошибки визуализации и/или вычисления. Вы всё равно хотите активировать дополнение {0}?"
WrongDomainOrIpSpecified | 38 | "Wrong Domain name or IP adress specified."
WrongLoginNameSpecified | 39 | "Wrong Login name specified."
WrongPasswordSpecified | 40 | "Wrong password specified."
WrongSessionIdSpecified | 41 | "Wrong Session ID specified."
FunctionNotDefined | 42 | " - функция неопределена"
ResultIsAboveMaxAllowedPositiveNumber | 43 | "Значение вышло за пределы максимально-допустимого положительного числа"
ResultIsBelowMinAllowedNegativeNumber | 44 | "Значение вышло за пределы минимально-допустимого отрицательного числа"
ArgumentMustBeString | 45 | "Argument must be a string."
CanNotParseString | 46 | "Невозможно разобрать строку:"
WrongArguments | 47 | "Function has some invalid arguments."
ActionCouldNotBePerformedWithText | 48 | "Action could not be performed with text."
ResultIsAboveMaxAllowedForByte | 49 | "Значение вышло за пределы максимально-допустимого для байта"
FileHasWrongFormat | 50 | "File has wrong format. Data import cannot be performed."
FileIsEmpty | 51 | "File is empty. No data imported."
ResultIsAboveMaxAllowedWhenIncreasing | 52 | "Значение вышло за пределы максимально-допустимого при увеличении"
ResultIsBelowMinAllowedWhenDecreasing | 53 | "Значение вышло за пределы минимально-допустимого при уменьшении"
IncreaseMaximumNumberLength | 54 | "Необходимо увеличить количество значащих цифр ('Меню' >> 'Опции' >> 'Вычисления' >> 'Макс. длина чисел')"
VariablesShouldBeDefinedForArgumentFunctions | 55 | Нельзя передавать значения переменных функции-аргумента. / Variables should be defined for argument-functions.
NumeralSystemBaseError | 56 | "Основание системы счисления должно принимать значение от 1 до 37"
DivisionByZero | 57 | "Деление на ноль"
LogarithmOfZeroIsNotDefined | 58 | "Логарифм нуля не существует"
ArgumentMustBeRealNumber | 59 | "Аргумент должен быть действительным"
NumberOfRowsOrColumnsDoNotMatch | 60 | "Количество строк или столбцов первой матрицы не соответствует количеству строк или столбцов второй матрицы"
MatricesDoNotMatch | 61 | "Матрицы не соответственные"
DivisorMatrixMustBeSquare | 62 | "Матрица-делитель не квадратная"
CrossProductCanNotBeCalculated | 63 | "Векторное произведение доступно только для векторов, заданных тремя компонентами"
CanNotCalculate | 64 | "Не могу вычислить"
MatrixMustBeSquare | 65 | "Матрица не квадратная"
FactorialNotDefined | 66 | "Факториал существует только от натуральных чисел и нуля"
MatrixNoninvertible | 67 | "Не существует, матрица вырожденная (определитель матрицы равен нулю)"
ExampleIncorrect | 68 | "Выражение задано не верно"
ArgumentMustBeMatrixOrVector | 69 | "Аргумент не может быть скаляром"
CanNotSolve | 70 | "По заданным критериям ответ найти невозможно. Проверьте настройки программы ('Меню' >> 'Опции' >> 'Вычисления' >> 'Ответ (множества)')"
LogarithmCanNotBeZeroBase | 71 | "Ноль не может быть основанием логарифма"
LogarithmCanNotBeOneBase | 72 | "Единица не может быть основанием логарифма"
CanNotParseMatrix | 73 | "Клеточные матрицы не поддерживаются (нельзя вычислить матрицу, один или несколько элементов которой - матрицы)"
UnitsDontMatch | 74 | "Units don't match."
CanNotInsert | 75 | "Невозможно вставить"
CanNotParse | 76 | "формат не поддерживается"
SelectExpression | 77 | "Выделите разбираемое выражение или его часть"
ExportError | 78 | "Произошла ошибка при экспорте документа"
OperationCanNotBePerformedWithUnits | 79 | "Operation cannot be performed with units."
ArgumentDoesNotMatchToExpectedKind | 80 | Аргумент не соответствует требуемому виду. / Argument doesn't match to expected kind.
EquationTooLongForVisualisation | 81 | "Длина выражения слишком велика для корректного его отображения"
ResultPlacedToClipboard | 82 | "Ответ помещён в буфер обмена операционной системы"
HighlightVariable | 83 | "Выделите переменную"
AssignVariable | 84 | "Задайте переменную"
FileNotExists | 85 | Такой файл не существует
FillInFileName | 86 | Введите имя файла
FileAlreadyExistsContinue | 87 | Данный файл уже существует. Продолжить?
NoElementByIndex | 88 | Нельзя задать значение элемента, т.к. элемента с указанным индексом не существует.

See Also

SMath.Manager Namespace


EvaluationException Class

[image]

SMath Studio Class Libraries Documantation
EvaluationException Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.EvaluationException"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class EvaluationException : Exception
Visual Basic
Public Class EvaluationException _
    Inherits Exception
Visual C++
public ref class EvaluationException : public Exception
F#
type EvaluationException =
    class
        inherit Exception
    end

Inheritance Hierarchy

System..::..Object
System..::..Exception
SMath.Manager..::..EvaluationException
SMath.Math..::..ControlException
SMath.Math.Numeric..::..VariableNotDefinedException

See Also

EvaluationException Members
SMath.Manager Namespace


EvaluationException Members

[image] [image]

SMath Studio Class Libraries Documantation
EvaluationException Members
EvaluationException Class Constructors Methods Fields See Also Send Feedback

The EvaluationException type exposes the following members.

Constructors

 | Name | Description
Public method | EvaluationException(Error) |
Public method | EvaluationException(Error, Exception) |
Public method | EvaluationException(Error, Exception, String) |

Methods

Name | Description
GetErrorId |
GetErrorText |

Fields

 | Name | Description
Public field | ErrorId |

See Also

EvaluationException Class
SMath.Manager Namespace


EvaluationException Constructor

[image] [image]

SMath Studio Class Libraries Documantation
EvaluationException Constructor
EvaluationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EvaluationException(Error) | Initializes a new instance of the EvaluationException class
Public method | EvaluationException(Error, Exception) | Initializes a new instance of the EvaluationException class
Public method | EvaluationException(Error, Exception, String) | Initializes a new instance of the EvaluationException class

See Also

EvaluationException Class
EvaluationException Members
SMath.Manager Namespace


EvaluationException Constructor (Error)

[image]

SMath Studio Class Libraries Documantation
EvaluationException Constructor (Error)
EvaluationException Class See Also Send Feedback
Initializes a new instance of the EvaluationException class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public EvaluationException(
    Error ErrorId
)
Visual Basic
Public Sub New ( _
    ErrorId As Error _
)
Visual C++
public:
EvaluationException(
    Error ErrorId
)
F#
new :
        ErrorId:Error -> EvaluationException

Parameters

ErrorId
Type: SMath.Manager..::..Error

[Missing <param name="ErrorId"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error)"]

See Also

EvaluationException Class
EvaluationException Overload
SMath.Manager Namespace


EvaluationException Constructor (Error, Exception)

[image]

SMath Studio Class Libraries Documantation
EvaluationException Constructor (Error, Exception)
EvaluationException Class See Also Send Feedback
Initializes a new instance of the EvaluationException class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public EvaluationException(
    Error ErrorId,
    Exception InnerException
)
Visual Basic
Public Sub New ( _
    ErrorId As Error, _
    InnerException As Exception _
)
Visual C++
public:
EvaluationException(
    Error ErrorId,
    Exception^ InnerException
)
F#
new :
        ErrorId:Error *
        InnerException:Exception -> EvaluationException

Parameters

ErrorId
Type: SMath.Manager..::..Error

[Missing <param name="ErrorId"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error,System.Exception)"]

InnerException
Type: System..::..Exception

[Missing <param name="InnerException"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error,System.Exception)"]

See Also

EvaluationException Class
EvaluationException Overload
SMath.Manager Namespace


EvaluationException Constructor (Error, Exception, String)

[image]

SMath Studio Class Libraries Documantation
EvaluationException Constructor (Error, Exception, String)
EvaluationException Class See Also Send Feedback
Initializes a new instance of the EvaluationException class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public EvaluationException(
    Error ErrorId,
    Exception InnerException,
    string Message
)
Visual Basic
Public Sub New ( _
    ErrorId As Error, _
    InnerException As Exception, _
    Message As String _
)
Visual C++
public:
EvaluationException(
    Error ErrorId,
    Exception^ InnerException,
    String^ Message
)
F#
new :
        ErrorId:Error *
        InnerException:Exception *
        Message:string -> EvaluationException

Parameters

ErrorId
Type: SMath.Manager..::..Error

[Missing <param name="ErrorId"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error,System.Exception,System.String)"]

InnerException
Type: System..::..Exception

[Missing <param name="InnerException"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error,System.Exception,System.String)"]

Message
Type: System..::..String

[Missing <param name="Message"/> documentation for "M:SMath.Manager.EvaluationException.#ctor(SMath.Manager.Error,System.Exception,System.String)"]

See Also

EvaluationException Class
EvaluationException Overload
SMath.Manager Namespace


EvaluationException Fields

[image] [image]

SMath Studio Class Libraries Documantation
EvaluationException Fields
EvaluationException Class See Also Send Feedback

The EvaluationException type exposes the following members.

Fields

 | Name | Description
Public field | ErrorId |

See Also

EvaluationException Class
SMath.Manager Namespace


ErrorId Field

[image]

SMath Studio Class Libraries Documantation
EvaluationException..::..ErrorId Field
EvaluationException Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.EvaluationException.ErrorId"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Error ErrorId
Visual Basic
Public ErrorId As Error
Visual C++
public:
Error ErrorId
F#
val mutable ErrorId: Error

See Also

EvaluationException Class
SMath.Manager Namespace


EvaluationException Methods

[image] [image]

SMath Studio Class Libraries Documantation
EvaluationException Methods
EvaluationException Class See Also Send Feedback

The EvaluationException type exposes the following members.

Methods

Name | Description
GetErrorId |
GetErrorText |

See Also

EvaluationException Class
SMath.Manager Namespace


GetErrorId Method

[image]

SMath Studio Class Libraries Documantation
EvaluationException..::..GetErrorId Method
EvaluationException Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.EvaluationException.GetErrorId(System.Exception)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Error GetErrorId(
    Exception e
)
Visual Basic
Public Shared Function GetErrorId ( _
    e As Exception _
) As Error
Visual C++
public:
static Error GetErrorId(
    Exception^ e
)
F#
static member GetErrorId :
        e:Exception -> Error

Parameters

e
Type: System..::..Exception

[Missing <param name="e"/> documentation for "M:SMath.Manager.EvaluationException.GetErrorId(System.Exception)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.EvaluationException.GetErrorId(System.Exception)"]

See Also

EvaluationException Class
SMath.Manager Namespace


GetErrorText Method

[image]

SMath Studio Class Libraries Documantation
EvaluationException..::..GetErrorText Method
EvaluationException Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.EvaluationException.GetErrorText(SMath.Manager.Error)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string GetErrorText(
    Error inc
)
Visual Basic
Public Shared Function GetErrorText ( _
    inc As Error _
) As String
Visual C++
public:
static String^ GetErrorText(
    Error inc
)
F#
static member GetErrorText :
        inc:Error -> string

Parameters

inc
Type: SMath.Manager..::..Error

[Missing <param name="inc"/> documentation for "M:SMath.Manager.EvaluationException.GetErrorText(SMath.Manager.Error)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.EvaluationException.GetErrorText(SMath.Manager.Error)"]

See Also

EvaluationException Class
SMath.Manager Namespace


Expression Class

[image]

SMath Studio Class Libraries Documantation
Expression Class
Members See Also Send Feedback
English: Helpers methods to work with math expression represented in reverse polish notation.
Русский: Вспомогательные методы для работы с выражениями, записанными в виде постфиксной нотации.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Expression
Visual Basic
Public Class Expression
Visual C++
public ref class Expression
F#
type Expression =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Expression

See Also

Expression Members
SMath.Manager Namespace


Expression Members

[image] [image]

SMath Studio Class Libraries Documantation
Expression Members
Expression Class Constructors Methods See Also Send Feedback

The Expression type exposes the following members.

Constructors

 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class

Methods

Name | Description
IndexOf(array<Term>[]()[][], array<Term>[]()[][]) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.
IndexOf(array<Term>[]()[][], array<Term>[]()[][], Int32%) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.
Localizer(array<Term>[]()[][], Int32) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%, Int32) |
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32, Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.

See Also

Expression Class
SMath.Manager Namespace


Expression Constructor

[image]

SMath Studio Class Libraries Documantation
Expression Constructor
Expression Class See Also Send Feedback
Initializes a new instance of the Expression class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Expression()
Visual Basic
Public Sub New
Visual C++
public:
Expression()
F#
new : unit -> Expression

See Also

Expression Class
SMath.Manager Namespace


Expression Methods

[image] [image]

SMath Studio Class Libraries Documantation
Expression Methods
Expression Class See Also Send Feedback

Methods

Name | Description
IndexOf(array<Term>[]()[][], array<Term>[]()[][]) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.
IndexOf(array<Term>[]()[][], array<Term>[]()[][], Int32%) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.
Localizer(array<Term>[]()[][], Int32) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%, Int32) |
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32, Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.

See Also

Expression Class
SMath.Manager Namespace


IndexOf Method

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..IndexOf Method
Expression Class See Also Send Feedback

Overload List

Name | Description
IndexOf(array<Term>[]()[][], array<Term>[]()[][]) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.
IndexOf(array<Term>[]()[][], array<Term>[]()[][], Int32%) | English: Search of the elements in the math expression. Русский: Поиск элементов в математическом выражении.

See Also

Expression Class
Expression Members
SMath.Manager Namespace


IndexOf Method (Term[], Term[])

[image]

SMath Studio Class Libraries Documantation
Expression..::..IndexOf Method (array<Term>[]()[][], array<Term>[]()[][])
Expression Class See Also Send Feedback
English: Search of the elements in the math expression.
Русский: Поиск элементов в математическом выражении.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int IndexOf(
    Term[] source,
    Term[] values
)
Visual Basic
Public Shared Function IndexOf ( _
    source As Term(), _
    values As Term() _
) As Integer
Visual C++
public:
static int IndexOf(
    array<Term^>^ source,
    array<Term^>^ values
)
F#
static member IndexOf :
        source:Term[] *
        values:Term[] -> int

Parameters

source
Type: array< SMath.Manager..::..Term >[]()[][]
English: Source expression to search entries in.
Русский: Массив элементов, в котором будет осуществляться поиск.
values
Type: array< SMath.Manager..::..Term >[]()[][]
English: Array of the expression components to search.
Русский: Массив искомых элементов.

Return Value

English: Returns index of the first found entry in the expression.
Русский: Возвращает индекс первого встретившегося искомого элемента в выражении.

See Also

Expression Class
IndexOf Overload
SMath.Manager Namespace


IndexOf Method (Term[], Term[], Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..IndexOf Method (array<Term>[]()[][], array<Term>[]()[][], Int32%)
Expression Class See Also Send Feedback
English: Search of the elements in the math expression.
Русский: Поиск элементов в математическом выражении.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int IndexOf(
    Term[] source,
    Term[] values,
    out int searchIndex
)
Visual Basic
Public Shared Function IndexOf ( _
    source As Term(), _
    values As Term(), _
    <OutAttribute> ByRef searchIndex As Integer _
) As Integer
Visual C++
public:
static int IndexOf(
    array<Term^>^ source,
    array<Term^>^ values,
    [OutAttribute] int% searchIndex
)
F#
static member IndexOf :
        source:Term[] *
        values:Term[] *
        searchIndex:int byref -> int

Parameters

source
Type: array< SMath.Manager..::..Term >[]()[][]
English: Source expression to search entries in.
Русский: Массив элементов, в котором будет осуществляться поиск.
values
Type: array< SMath.Manager..::..Term >[]()[][]
English: Array of the expression components to search.
Русский: Массив искомых элементов.
searchIndex
Type: System..::..Int32 %
English: Returns an values-index of the found element.
Русский: Возвращает индекс найденного элемента.

Return Value

English: Returns index of the first found entry in the expression.
Русский: Возвращает индекс первого встретившегося искомого элемента в выражении.

See Also

Expression Class
IndexOf Overload
SMath.Manager Namespace


Localizer Method

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..Localizer Method
Expression Class See Also Send Feedback

Overload List

Name | Description
Localizer(array<Term>[]()[][], Int32) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%) | English: Splits expression on the array of arguments based on the parent element specified by index. Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.
Localizer(array<Term>[]()[][], Int32, Int32%, Int32) |

See Also

Expression Class
Expression Members
SMath.Manager Namespace


Localizer Method (Term[], Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..Localizer Method (array<Term>[]()[][], Int32)
Expression Class See Also Send Feedback
English: Splits expression on the array of arguments based on the parent element specified by index.
Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[][] Localizer(
    Term[] values,
    int index
)
Visual Basic
Public Shared Function Localizer ( _
    values As Term(), _
    index As Integer _
) As Term()()
Visual C++
public:
static array<array<Term^>^>^ Localizer(
    array<Term^>^ values,
    int index
)
F#
static member Localizer :
        values:Term[] *
        index:int -> Term[][]

Parameters

values
Type: array< SMath.Manager..::..Term >[]()[][]
English: Source expression to split.
Русский: Выражение для разбора.
index
Type: System..::..Int32
English: Root (parent) element index.
Русский: Индекс элемента-родителя.

Return Value

English: Array of the children elements.
Русский: Массив зависимых выражений.

See Also

Expression Class
Localizer Overload
SMath.Manager Namespace


Localizer Method (Term[], Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..Localizer Method (array<Term>[]()[][], Int32, Int32%)
Expression Class See Also Send Feedback
English: Splits expression on the array of arguments based on the parent element specified by index.
Русский: Разбиение выражения на составляющие элементы исключая родителя. Т.е. получение массива зависимых от указанного элемента подвыражений.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[][] Localizer(
    Term[] values,
    int index,
    out int globalrev
)
Visual Basic
Public Shared Function Localizer ( _
    values As Term(), _
    index As Integer, _
    <OutAttribute> ByRef globalrev As Integer _
) As Term()()
Visual C++
public:
static array<array<Term^>^>^ Localizer(
    array<Term^>^ values,
    int index,
    [OutAttribute] int% globalrev
)
F#
static member Localizer :
        values:Term[] *
        index:int *
        globalrev:int byref -> Term[][]

Parameters

values
Type: array< SMath.Manager..::..Term >[]()[][]
English: Source expression to split.
Русский: Выражение для разбора.
index
Type: System..::..Int32
English: Root (parent) element index.
Русский: Индекс элемента-родителя.
globalrev
Type: System..::..Int32 %
English: Summ of the children elements.
Русский: Суммарное количество элементов компонент, зависимых от радителя.

Return Value

English: Array of the children elements.
Русский: Массив зависимых выражений.

See Also

Expression Class
Localizer Overload
SMath.Manager Namespace


Localizer Method (Term[], Int32, Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..Localizer Method (array<Term>[]()[][], Int32, Int32%, Int32)
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[][] Localizer(
    Term[] values,
    int index,
    out int globalrev,
    int argsToReturn
)
Visual Basic
Public Shared Function Localizer ( _
    values As Term(), _
    index As Integer, _
    <OutAttribute> ByRef globalrev As Integer, _
    argsToReturn As Integer _
) As Term()()
Visual C++
public:
static array<array<Term^>^>^ Localizer(
    array<Term^>^ values,
    int index,
    [OutAttribute] int% globalrev,
    int argsToReturn
)
F#
static member Localizer :
        values:Term[] *
        index:int *
        globalrev:int byref *
        argsToReturn:int -> Term[][]

Parameters

values
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="values"/> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

globalrev
Type: System..::..Int32 %

[Missing <param name="globalrev"/> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

argsToReturn
Type: System..::..Int32

[Missing <param name="argsToReturn"/> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Expression.Localizer(SMath.Manager.Term[],System.Int32,System.Int32@,System.Int32)"]

See Also

Expression Class
Localizer Overload
SMath.Manager Namespace


Merge Method

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..Merge Method
Expression Class See Also Send Feedback

Overload List

Name | Description
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.
Merge(array<Term>[]()[][], array<Term>[]()[][], Int32, Int32) | English: Merging second expression into the first one in the specified position. Русский: Подстановка второго выражения в первое в указанном индексом элементе.

See Also

Expression Class
Expression Members
SMath.Manager Namespace


Merge Method (Term[], Term[], Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..Merge Method (array<Term>[]()[][], array<Term>[]()[][], Int32)
Expression Class See Also Send Feedback
English: Merging second expression into the first one in the specified position.
Русский: Подстановка второго выражения в первое в указанном индексом элементе.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[] Merge(
    Term[] source,
    Term[] insert,
    int position
)
Visual Basic
Public Shared Function Merge ( _
    source As Term(), _
    insert As Term(), _
    position As Integer _
) As Term()
Visual C++
public:
static array<Term^>^ Merge(
    array<Term^>^ source,
    array<Term^>^ insert,
    int position
)
F#
static member Merge :
        source:Term[] *
        insert:Term[] *
        position:int -> Term[]

Parameters

source
Type: array< SMath.Manager..::..Term >[]()[][]
English: Target expression array to insert the second one in.
Русский: Массив, в который будет произведена вставка.
insert
Type: array< SMath.Manager..::..Term >[]()[][]
English: Expression array to merge.
Русский: Массив, который будет вставлен в source.
position
Type: System..::..Int32
English: Index of the element where second expression will be merged to the target.
Русский: Индекс элемента выражения в который будет произведена вставка.

Return Value

English: Result of merging expressions.
Русский: Результат объединения массивов элементов математического выражения.

See Also

Expression Class
Merge Overload
SMath.Manager Namespace


Merge Method (Term[], Term[], Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
Expression..::..Merge Method (array<Term>[]()[][], array<Term>[]()[][], Int32, Int32)
Expression Class See Also Send Feedback
English: Merging second expression into the first one in the specified position.
Русский: Подстановка второго выражения в первое в указанном индексом элементе.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Term[] Merge(
    Term[] source,
    Term[] insert,
    int position,
    int globalrev
)
Visual Basic
Public Shared Function Merge ( _
    source As Term(), _
    insert As Term(), _
    position As Integer, _
    globalrev As Integer _
) As Term()
Visual C++
public:
static array<Term^>^ Merge(
    array<Term^>^ source,
    array<Term^>^ insert,
    int position,
    int globalrev
)
F#
static member Merge :
        source:Term[] *
        insert:Term[] *
        position:int *
        globalrev:int -> Term[]

Parameters

source
Type: array< SMath.Manager..::..Term >[]()[][]
English: Target expression array to insert the second one in.
Русский: Массив, в который будет произведена вставка.
insert
Type: array< SMath.Manager..::..Term >[]()[][]
English: Expression array to merge.
Русский: Массив, который будет вставлен в source.
position
Type: System..::..Int32
English: Index of the element where second expression will be merged to the target.
Русский: Индекс элемента выражения в который будет произведена вставка.
globalrev
Type: System..::..Int32
English: Number of elements to remove in place of the subexpression.
Русский: Количество элементов для удаления вместе вставки подвыражения.

Return Value

English: Result of merging expressions.
Русский: Результат объединения массивов элементов математического выражения.

See Also

Expression Class
Merge Overload
SMath.Manager Namespace


FractionsType Enumeration

[image]

SMath Studio Class Libraries Documantation
FractionsType Enumeration
See Also Send Feedback
Тип дроби

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum FractionsType
Visual Basic
Public Enumeration FractionsType
Visual C++
public enum class FractionsType
F#
type FractionsType

Members

Member name | Value | Description
None | 0 | Десятичная дробь
Fraction | 1 | Обыкновенная дробь
Auto | 2 | Определяется программой
Undefined | 3 | Неопределено

See Also

SMath.Manager Namespace


Function Class

[image]

SMath Studio Class Libraries Documantation
Function Class
Members See Also Send Feedback
Перечисление доступных встроенных функций

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Function
Visual Basic
Public Class Function
Visual C++
public ref class Function
F#
type Function =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Function

See Also

Function Members
SMath.Manager Namespace


Function Members

[image] [image]

SMath Studio Class Libraries Documantation
Function Members
Function Class Constructors Methods Properties See Also Send Feedback

The Function type exposes the following members.

Constructors

 | Name | Description
Public method | Function | Initializes a new instance of the Function class

Methods

Name | Description
Contains |

Properties

Name | Description
A2t | Перевод числа из алгебраического в тригонометрический
Abs | Модуль (абсолютное значение)
Ainterp | Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Alg | Алгебраическое дополнение
Arccos | Арккосинус
Arccosec | Арккосеканс
Arcctg | Арккотангенс
Arch | Гиперболический арккосинус
Arcsec | Арксеканс
Arcsin | Арксинус
Arctg | Арктангенс
Arcth | Гиперболический арккотангенс
Arg | Аргумент комплексного числа
Arsh | Гиперболический арксинус
Arth | Гиперболический арктангенс
Augment | Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов
Ch | Гиперболический косинус
Cinterp | Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Col | Столбец матрицы/вектора
Cols | Количество столбцов матрицы/вектора
Cos | Косинус
Cosec | Косеканс
CosecH | Гиперболический косеканс
CSort | Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания
Ctg | Котангенс
Cth | Гиперболический котангенс
Det | Детерминант (Определитель)
DFile | Безвозвратно удалить файл с математическим выражением, если такой существует
Diag | Возвращает матрицу на главной диагонали которой элементы вектора аргумента
Diff | Дифференцирование
Eigenvals | Собственные числа квадратной матрицы
El | Элемент матрицы/вектора
Eval | Переводит выражение представленное аналитически в численный вид
Exp | Экспонента
Expand | Упрощение
For | Цикл
Gamma | Функция вычисления функции Гамма
Graph | Посторение графика (не используется версиями выше (0.50.4)
Identity | Единичная матрица указанных размеров
If | Оператор ветвления
Im | Мнимая часть числа
Int | Интеграл
Invert | Обратное значение
Length | Количество элементов матрицы/вектора
Lg | Десятичный логарифм
Lim | Передел (программа умеет только отображать)
Line | Функция программирования - линия
Linterp | Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Ln | Натуральный логарифм
Log | Логарифм по основанию
Mat | Матрица
Matrix | Создание матрицы указанных аргументами размеров
Max | Максимальный элемент матрицы/вектора
Min | Минимальный элемент матрицы/вектора
Minor | Минор матрицы
Mod | Остаток от деления
Norm1 | Возвращает норму матрицы в пространстве L1
NormE | Возвращает евклидову норму матрицы
NormI | Возвращает равномерную норму матрицы
Nthroot | Корень произвольной степени
Numden | Получение числителя и знаменателя в виде вектор-столбца
Perc | Проценты
Pol2xy | Перевод координат из полярных в прямоугольные
Polyroots | Вычисление корней полинома
Product | Функция произведения
Random | Случайное число
Range | Функция создания массива по заданным параметрам
Rank | Ранг матрицы
Re | Действительная часть числа
Reverse | Изменяет порядок строк матрицы или элементов вектора на противоположный
RFile | Прочитать математическое выражение из файла, если такой существует
Round | Округление числа
Row | Строка матрицы/вектора
Rows | Количество строк матрицы/вектора
RSort | Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания
Sec | Секанс
Sech | Гиперболический секанс
Sh | Гиперболический синус
Sign | Сигнатура
Sin | Синус
Solve | Получение корней уравнения
Sort | Возвращает вектор с элементами, отсортированными в порядке возрастания
Sqrt | Квадратный корень
Stack | Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов
Submatrix | Получение матрицы указанных размеров из существующей
Sum | Функция суммирования
Switch | Функция выбора
Sys | Алгебраическая система
Tg | Тангенс
Th | Гиперболический тангенс
Tr | След матрицы
Transpose | Транспонирование матрицы/вектора
Trunc | Получение целой части числа
Vminor | Визуальное представление минора - без вычисления конечного определителя
WFile | Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением
While | Цикл типа while
Xy2pol | Перевод координат из прямоугольных к полярным

See Also

Function Class
SMath.Manager Namespace


Function Constructor

[image]

SMath Studio Class Libraries Documantation
Function Constructor
Function Class See Also Send Feedback
Initializes a new instance of the Function class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Function()
Visual Basic
Public Sub New
Visual C++
public:
Function()
F#
new : unit -> Function

See Also

Function Class
SMath.Manager Namespace


Function Methods

[image] [image]

SMath Studio Class Libraries Documantation
Function Methods
Function Class See Also Send Feedback

The Function type exposes the following members.

Methods

Name | Description
Contains |

See Also

Function Class
SMath.Manager Namespace


Contains Method

[image]

SMath Studio Class Libraries Documantation
Function..::..Contains Method
Function Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.Function.Contains(System.String)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool Contains(
    string name
)
Visual Basic
Public Shared Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
static bool Contains(
    String^ name
)
F#
static member Contains :
        name:string -> bool

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:SMath.Manager.Function.Contains(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Function.Contains(System.String)"]

See Also

Function Class
SMath.Manager Namespace


Function Properties

[image] [image]

SMath Studio Class Libraries Documantation
Function Properties
Function Class See Also Send Feedback

The Function type exposes the following members.

Properties

Name | Description
A2t | Перевод числа из алгебраического в тригонометрический
Abs | Модуль (абсолютное значение)
Ainterp | Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Alg | Алгебраическое дополнение
Arccos | Арккосинус
Arccosec | Арккосеканс
Arcctg | Арккотангенс
Arch | Гиперболический арккосинус
Arcsec | Арксеканс
Arcsin | Арксинус
Arctg | Арктангенс
Arcth | Гиперболический арккотангенс
Arg | Аргумент комплексного числа
Arsh | Гиперболический арксинус
Arth | Гиперболический арктангенс
Augment | Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов
Ch | Гиперболический косинус
Cinterp | Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Col | Столбец матрицы/вектора
Cols | Количество столбцов матрицы/вектора
Cos | Косинус
Cosec | Косеканс
CosecH | Гиперболический косеканс
CSort | Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания
Ctg | Котангенс
Cth | Гиперболический котангенс
Det | Детерминант (Определитель)
DFile | Безвозвратно удалить файл с математическим выражением, если такой существует
Diag | Возвращает матрицу на главной диагонали которой элементы вектора аргумента
Diff | Дифференцирование
Eigenvals | Собственные числа квадратной матрицы
El | Элемент матрицы/вектора
Eval | Переводит выражение представленное аналитически в численный вид
Exp | Экспонента
Expand | Упрощение
For | Цикл
Gamma | Функция вычисления функции Гамма
Graph | Посторение графика (не используется версиями выше (0.50.4)
Identity | Единичная матрица указанных размеров
If | Оператор ветвления
Im | Мнимая часть числа
Int | Интеграл
Invert | Обратное значение
Length | Количество элементов матрицы/вектора
Lg | Десятичный логарифм
Lim | Передел (программа умеет только отображать)
Line | Функция программирования - линия
Linterp | Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры
Ln | Натуральный логарифм
Log | Логарифм по основанию
Mat | Матрица
Matrix | Создание матрицы указанных аргументами размеров
Max | Максимальный элемент матрицы/вектора
Min | Минимальный элемент матрицы/вектора
Minor | Минор матрицы
Mod | Остаток от деления
Norm1 | Возвращает норму матрицы в пространстве L1
NormE | Возвращает евклидову норму матрицы
NormI | Возвращает равномерную норму матрицы
Nthroot | Корень произвольной степени
Numden | Получение числителя и знаменателя в виде вектор-столбца
Perc | Проценты
Pol2xy | Перевод координат из полярных в прямоугольные
Polyroots | Вычисление корней полинома
Product | Функция произведения
Random | Случайное число
Range | Функция создания массива по заданным параметрам
Rank | Ранг матрицы
Re | Действительная часть числа
Reverse | Изменяет порядок строк матрицы или элементов вектора на противоположный
RFile | Прочитать математическое выражение из файла, если такой существует
Round | Округление числа
Row | Строка матрицы/вектора
Rows | Количество строк матрицы/вектора
RSort | Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания
Sec | Секанс
Sech | Гиперболический секанс
Sh | Гиперболический синус
Sign | Сигнатура
Sin | Синус
Solve | Получение корней уравнения
Sort | Возвращает вектор с элементами, отсортированными в порядке возрастания
Sqrt | Квадратный корень
Stack | Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов
Submatrix | Получение матрицы указанных размеров из существующей
Sum | Функция суммирования
Switch | Функция выбора
Sys | Алгебраическая система
Tg | Тангенс
Th | Гиперболический тангенс
Tr | След матрицы
Transpose | Транспонирование матрицы/вектора
Trunc | Получение целой части числа
Vminor | Визуальное представление минора - без вычисления конечного определителя
WFile | Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением
While | Цикл типа while
Xy2pol | Перевод координат из прямоугольных к полярным

See Also

Function Class
SMath.Manager Namespace


A2t Property

[image]

SMath Studio Class Libraries Documantation
Function..::..A2t Property
Function Class See Also Send Feedback
Перевод числа из алгебраического в тригонометрический

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string A2t { get; }
Visual Basic
Public Shared ReadOnly Property A2t As String
    Get
Visual C++
public:
static property String^ A2t {
    String^ get ();
}
F#
static member A2t : string

See Also

Function Class
SMath.Manager Namespace


Abs Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Abs Property
Function Class See Also Send Feedback
Модуль (абсолютное значение)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Abs { get; }
Visual Basic
Public Shared ReadOnly Property Abs As String
    Get
Visual C++
public:
static property String^ Abs {
    String^ get ();
}
F#
static member Abs : string

See Also

Function Class
SMath.Manager Namespace


Ainterp Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Ainterp Property
Function Class See Also Send Feedback
Возвращает интерполированное сплайном Акимы значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Ainterp { get; }
Visual Basic
Public Shared ReadOnly Property Ainterp As String
    Get
Visual C++
public:
static property String^ Ainterp {
    String^ get ();
}
F#
static member Ainterp : string

See Also

Function Class
SMath.Manager Namespace


Alg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Alg Property
Function Class See Also Send Feedback
Алгебраическое дополнение

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Alg { get; }
Visual Basic
Public Shared ReadOnly Property Alg As String
    Get
Visual C++
public:
static property String^ Alg {
    String^ get ();
}
F#
static member Alg : string

See Also

Function Class
SMath.Manager Namespace


Arccos Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arccos Property
Function Class See Also Send Feedback
Арккосинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arccos { get; }
Visual Basic
Public Shared ReadOnly Property Arccos As String
    Get
Visual C++
public:
static property String^ Arccos {
    String^ get ();
}
F#
static member Arccos : string

See Also

Function Class
SMath.Manager Namespace


Arccosec Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arccosec Property
Function Class See Also Send Feedback
Арккосеканс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arccosec { get; }
Visual Basic
Public Shared ReadOnly Property Arccosec As String
    Get
Visual C++
public:
static property String^ Arccosec {
    String^ get ();
}
F#
static member Arccosec : string

See Also

Function Class
SMath.Manager Namespace


Arcctg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arcctg Property
Function Class See Also Send Feedback
Арккотангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arcctg { get; }
Visual Basic
Public Shared ReadOnly Property Arcctg As String
    Get
Visual C++
public:
static property String^ Arcctg {
    String^ get ();
}
F#
static member Arcctg : string

See Also

Function Class
SMath.Manager Namespace


Arch Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arch Property
Function Class See Also Send Feedback
Гиперболический арккосинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arch { get; }
Visual Basic
Public Shared ReadOnly Property Arch As String
    Get
Visual C++
public:
static property String^ Arch {
    String^ get ();
}
F#
static member Arch : string

See Also

Function Class
SMath.Manager Namespace


Arcsec Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arcsec Property
Function Class See Also Send Feedback
Арксеканс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arcsec { get; }
Visual Basic
Public Shared ReadOnly Property Arcsec As String
    Get
Visual C++
public:
static property String^ Arcsec {
    String^ get ();
}
F#
static member Arcsec : string

See Also

Function Class
SMath.Manager Namespace


Arcsin Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arcsin Property
Function Class See Also Send Feedback
Арксинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arcsin { get; }
Visual Basic
Public Shared ReadOnly Property Arcsin As String
    Get
Visual C++
public:
static property String^ Arcsin {
    String^ get ();
}
F#
static member Arcsin : string

See Also

Function Class
SMath.Manager Namespace


Arctg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arctg Property
Function Class See Also Send Feedback
Арктангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arctg { get; }
Visual Basic
Public Shared ReadOnly Property Arctg As String
    Get
Visual C++
public:
static property String^ Arctg {
    String^ get ();
}
F#
static member Arctg : string

See Also

Function Class
SMath.Manager Namespace


Arcth Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arcth Property
Function Class See Also Send Feedback
Гиперболический арккотангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arcth { get; }
Visual Basic
Public Shared ReadOnly Property Arcth As String
    Get
Visual C++
public:
static property String^ Arcth {
    String^ get ();
}
F#
static member Arcth : string

See Also

Function Class
SMath.Manager Namespace


Arg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arg Property
Function Class See Also Send Feedback
Аргумент комплексного числа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arg { get; }
Visual Basic
Public Shared ReadOnly Property Arg As String
    Get
Visual C++
public:
static property String^ Arg {
    String^ get ();
}
F#
static member Arg : string

See Also

Function Class
SMath.Manager Namespace


Arsh Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arsh Property
Function Class See Also Send Feedback
Гиперболический арксинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arsh { get; }
Visual Basic
Public Shared ReadOnly Property Arsh As String
    Get
Visual C++
public:
static property String^ Arsh {
    String^ get ();
}
F#
static member Arsh : string

See Also

Function Class
SMath.Manager Namespace


Arth Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Arth Property
Function Class See Also Send Feedback
Гиперболический арктангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Arth { get; }
Visual Basic
Public Shared ReadOnly Property Arth As String
    Get
Visual C++
public:
static property String^ Arth {
    String^ get ();
}
F#
static member Arth : string

See Also

Function Class
SMath.Manager Namespace


Augment Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Augment Property
Function Class See Also Send Feedback
Функция возвращает массив образованный последовательным размещением аргументов друг рядом с другом (слева на право). Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Augment { get; }
Visual Basic
Public Shared ReadOnly Property Augment As String
    Get
Visual C++
public:
static property String^ Augment {
    String^ get ();
}
F#
static member Augment : string

See Also

Function Class
SMath.Manager Namespace


Ch Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Ch Property
Function Class See Also Send Feedback
Гиперболический косинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Ch { get; }
Visual Basic
Public Shared ReadOnly Property Ch As String
    Get
Visual C++
public:
static property String^ Ch {
    String^ get ();
}
F#
static member Ch : string

See Also

Function Class
SMath.Manager Namespace


Cinterp Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Cinterp Property
Function Class See Also Send Feedback
Возвращает интерполированное кубическим сплайном значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Cinterp { get; }
Visual Basic
Public Shared ReadOnly Property Cinterp As String
    Get
Visual C++
public:
static property String^ Cinterp {
    String^ get ();
}
F#
static member Cinterp : string

See Also

Function Class
SMath.Manager Namespace


Col Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Col Property
Function Class See Also Send Feedback
Столбец матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Col { get; }
Visual Basic
Public Shared ReadOnly Property Col As String
    Get
Visual C++
public:
static property String^ Col {
    String^ get ();
}
F#
static member Col : string

See Also

Function Class
SMath.Manager Namespace


Cols Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Cols Property
Function Class See Also Send Feedback
Количество столбцов матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Cols { get; }
Visual Basic
Public Shared ReadOnly Property Cols As String
    Get
Visual C++
public:
static property String^ Cols {
    String^ get ();
}
F#
static member Cols : string

See Also

Function Class
SMath.Manager Namespace


Cos Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Cos Property
Function Class See Also Send Feedback
Косинус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Cos { get; }
Visual Basic
Public Shared ReadOnly Property Cos As String
    Get
Visual C++
public:
static property String^ Cos {
    String^ get ();
}
F#
static member Cos : string

See Also

Function Class
SMath.Manager Namespace


Cosec Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Cosec Property
Function Class See Also Send Feedback
Косеканс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Cosec { get; }
Visual Basic
Public Shared ReadOnly Property Cosec As String
    Get
Visual C++
public:
static property String^ Cosec {
    String^ get ();
}
F#
static member Cosec : string

See Also

Function Class
SMath.Manager Namespace


CosecH Property

[image]

SMath Studio Class Libraries Documantation
Function..::..CosecH Property
Function Class See Also Send Feedback
Гиперболический косеканс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string CosecH { get; }
Visual Basic
Public Shared ReadOnly Property CosecH As String
    Get
Visual C++
public:
static property String^ CosecH {
    String^ get ();
}
F#
static member CosecH : string

See Also

Function Class
SMath.Manager Namespace


CSort Property

[image]

SMath Studio Class Libraries Documantation
Function..::..CSort Property
Function Class See Also Send Feedback
Возвращает матрицу/вектор с элементами, отсортированными по указанному столбцу в порядке возрастания

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string CSort { get; }
Visual Basic
Public Shared ReadOnly Property CSort As String
    Get
Visual C++
public:
static property String^ CSort {
    String^ get ();
}
F#
static member CSort : string

See Also

Function Class
SMath.Manager Namespace


Ctg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Ctg Property
Function Class See Also Send Feedback
Котангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Ctg { get; }
Visual Basic
Public Shared ReadOnly Property Ctg As String
    Get
Visual C++
public:
static property String^ Ctg {
    String^ get ();
}
F#
static member Ctg : string

See Also

Function Class
SMath.Manager Namespace


Cth Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Cth Property
Function Class See Also Send Feedback
Гиперболический котангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Cth { get; }
Visual Basic
Public Shared ReadOnly Property Cth As String
    Get
Visual C++
public:
static property String^ Cth {
    String^ get ();
}
F#
static member Cth : string

See Also

Function Class
SMath.Manager Namespace


Det Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Det Property
Function Class See Also Send Feedback
Детерминант (Определитель)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Det { get; }
Visual Basic
Public Shared ReadOnly Property Det As String
    Get
Visual C++
public:
static property String^ Det {
    String^ get ();
}
F#
static member Det : string

See Also

Function Class
SMath.Manager Namespace


DFile Property

[image]

SMath Studio Class Libraries Documantation
Function..::..DFile Property
Function Class See Also Send Feedback
Безвозвратно удалить файл с математическим выражением, если такой существует

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string DFile { get; }
Visual Basic
Public Shared ReadOnly Property DFile As String
    Get
Visual C++
public:
static property String^ DFile {
    String^ get ();
}
F#
static member DFile : string

See Also

Function Class
SMath.Manager Namespace


Diag Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Diag Property
Function Class See Also Send Feedback
Возвращает матрицу на главной диагонали которой элементы вектора аргумента

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Diag { get; }
Visual Basic
Public Shared ReadOnly Property Diag As String
    Get
Visual C++
public:
static property String^ Diag {
    String^ get ();
}
F#
static member Diag : string

See Also

Function Class
SMath.Manager Namespace


Diff Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Diff Property
Function Class See Also Send Feedback
Дифференцирование

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Diff { get; }
Visual Basic
Public Shared ReadOnly Property Diff As String
    Get
Visual C++
public:
static property String^ Diff {
    String^ get ();
}
F#
static member Diff : string

See Also

Function Class
SMath.Manager Namespace


Eigenvals Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Eigenvals Property
Function Class See Also Send Feedback
Собственные числа квадратной матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Eigenvals { get; }
Visual Basic
Public Shared ReadOnly Property Eigenvals As String
    Get
Visual C++
public:
static property String^ Eigenvals {
    String^ get ();
}
F#
static member Eigenvals : string

See Also

Function Class
SMath.Manager Namespace


El Property

[image]

SMath Studio Class Libraries Documantation
Function..::..El Property
Function Class See Also Send Feedback
Элемент матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string El { get; }
Visual Basic
Public Shared ReadOnly Property El As String
    Get
Visual C++
public:
static property String^ El {
    String^ get ();
}
F#
static member El : string

See Also

Function Class
SMath.Manager Namespace


Eval Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Eval Property
Function Class See Also Send Feedback
Переводит выражение представленное аналитически в численный вид

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Eval { get; }
Visual Basic
Public Shared ReadOnly Property Eval As String
    Get
Visual C++
public:
static property String^ Eval {
    String^ get ();
}
F#
static member Eval : string

See Also

Function Class
SMath.Manager Namespace


Exp Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Exp Property
Function Class See Also Send Feedback
Экспонента

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Exp { get; }
Visual Basic
Public Shared ReadOnly Property Exp As String
    Get
Visual C++
public:
static property String^ Exp {
    String^ get ();
}
F#
static member Exp : string

See Also

Function Class
SMath.Manager Namespace


Expand Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Expand Property
Function Class See Also Send Feedback
Упрощение

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Expand { get; }
Visual Basic
Public Shared ReadOnly Property Expand As String
    Get
Visual C++
public:
static property String^ Expand {
    String^ get ();
}
F#
static member Expand : string

See Also

Function Class
SMath.Manager Namespace


For Property

[image]

SMath Studio Class Libraries Documantation
Function..::..For Property
Function Class See Also Send Feedback
Цикл

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string For { get; }
Visual Basic
Public Shared ReadOnly Property For As String
    Get
Visual C++
public:
static property String^ For {
    String^ get ();
}
F#
static member For : string

See Also

Function Class
SMath.Manager Namespace


Gamma Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Gamma Property
Function Class See Also Send Feedback
Функция вычисления функции Гамма

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Gamma { get; }
Visual Basic
Public Shared ReadOnly Property Gamma As String
    Get
Visual C++
public:
static property String^ Gamma {
    String^ get ();
}
F#
static member Gamma : string

See Also

Function Class
SMath.Manager Namespace


Graph Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Graph Property
Function Class See Also Send Feedback
Посторение графика (не используется версиями выше (0.50.4)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Graph { get; }
Visual Basic
Public Shared ReadOnly Property Graph As String
    Get
Visual C++
public:
static property String^ Graph {
    String^ get ();
}
F#
static member Graph : string

See Also

Function Class
SMath.Manager Namespace


Identity Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Identity Property
Function Class See Also Send Feedback
Единичная матрица указанных размеров

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Identity { get; }
Visual Basic
Public Shared ReadOnly Property Identity As String
    Get
Visual C++
public:
static property String^ Identity {
    String^ get ();
}
F#
static member Identity : string

See Also

Function Class
SMath.Manager Namespace


If Property

[image]

SMath Studio Class Libraries Documantation
Function..::..If Property
Function Class See Also Send Feedback
Оператор ветвления

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string If { get; }
Visual Basic
Public Shared ReadOnly Property If As String
    Get
Visual C++
public:
static property String^ If {
    String^ get ();
}
F#
static member If : string

See Also

Function Class
SMath.Manager Namespace


Im Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Im Property
Function Class See Also Send Feedback
Мнимая часть числа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Im { get; }
Visual Basic
Public Shared ReadOnly Property Im As String
    Get
Visual C++
public:
static property String^ Im {
    String^ get ();
}
F#
static member Im : string

See Also

Function Class
SMath.Manager Namespace


Int Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Int Property
Function Class See Also Send Feedback
Интеграл

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Int { get; }
Visual Basic
Public Shared ReadOnly Property Int As String
    Get
Visual C++
public:
static property String^ Int {
    String^ get ();
}
F#
static member Int : string

See Also

Function Class
SMath.Manager Namespace


Invert Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Invert Property
Function Class See Also Send Feedback
Обратное значение

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Invert { get; }
Visual Basic
Public Shared ReadOnly Property Invert As String
    Get
Visual C++
public:
static property String^ Invert {
    String^ get ();
}
F#
static member Invert : string

See Also

Function Class
SMath.Manager Namespace


Length Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Length Property
Function Class See Also Send Feedback
Количество элементов матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Length { get; }
Visual Basic
Public Shared ReadOnly Property Length As String
    Get
Visual C++
public:
static property String^ Length {
    String^ get ();
}
F#
static member Length : string

See Also

Function Class
SMath.Manager Namespace


Lg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Lg Property
Function Class See Also Send Feedback
Десятичный логарифм

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Lg { get; }
Visual Basic
Public Shared ReadOnly Property Lg As String
    Get
Visual C++
public:
static property String^ Lg {
    String^ get ();
}
F#
static member Lg : string

See Also

Function Class
SMath.Manager Namespace


Lim Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Lim Property
Function Class See Also Send Feedback
Передел (программа умеет только отображать)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Lim { get; }
Visual Basic
Public Shared ReadOnly Property Lim As String
    Get
Visual C++
public:
static property String^ Lim {
    String^ get ();
}
F#
static member Lim : string

See Also

Function Class
SMath.Manager Namespace


Line Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Line Property
Function Class See Also Send Feedback
Функция программирования - линия

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Line { get; }
Visual Basic
Public Shared ReadOnly Property Line As String
    Get
Visual C++
public:
static property String^ Line {
    String^ get ();
}
F#
static member Line : string

See Also

Function Class
SMath.Manager Namespace


Linterp Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Linterp Property
Function Class See Also Send Feedback
Возвращает линейно интерполированное значение в x для данных x-вектора и y-вектора. Вектора должны иметь одинаковые размеры

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Linterp { get; }
Visual Basic
Public Shared ReadOnly Property Linterp As String
    Get
Visual C++
public:
static property String^ Linterp {
    String^ get ();
}
F#
static member Linterp : string

See Also

Function Class
SMath.Manager Namespace


Ln Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Ln Property
Function Class See Also Send Feedback
Натуральный логарифм

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Ln { get; }
Visual Basic
Public Shared ReadOnly Property Ln As String
    Get
Visual C++
public:
static property String^ Ln {
    String^ get ();
}
F#
static member Ln : string

See Also

Function Class
SMath.Manager Namespace


Log Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Log Property
Function Class See Also Send Feedback
Логарифм по основанию

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Log { get; }
Visual Basic
Public Shared ReadOnly Property Log As String
    Get
Visual C++
public:
static property String^ Log {
    String^ get ();
}
F#
static member Log : string

See Also

Function Class
SMath.Manager Namespace


Mat Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Mat Property
Function Class See Also Send Feedback
Матрица

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Mat { get; }
Visual Basic
Public Shared ReadOnly Property Mat As String
    Get
Visual C++
public:
static property String^ Mat {
    String^ get ();
}
F#
static member Mat : string

See Also

Function Class
SMath.Manager Namespace


Matrix Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Matrix Property
Function Class See Also Send Feedback
Создание матрицы указанных аргументами размеров

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Matrix { get; }
Visual Basic
Public Shared ReadOnly Property Matrix As String
    Get
Visual C++
public:
static property String^ Matrix {
    String^ get ();
}
F#
static member Matrix : string

See Also

Function Class
SMath.Manager Namespace


Max Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Max Property
Function Class See Also Send Feedback
Максимальный элемент матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Max { get; }
Visual Basic
Public Shared ReadOnly Property Max As String
    Get
Visual C++
public:
static property String^ Max {
    String^ get ();
}
F#
static member Max : string

See Also

Function Class
SMath.Manager Namespace


Min Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Min Property
Function Class See Also Send Feedback
Минимальный элемент матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Min { get; }
Visual Basic
Public Shared ReadOnly Property Min As String
    Get
Visual C++
public:
static property String^ Min {
    String^ get ();
}
F#
static member Min : string

See Also

Function Class
SMath.Manager Namespace


Minor Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Minor Property
Function Class See Also Send Feedback
Минор матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Minor { get; }
Visual Basic
Public Shared ReadOnly Property Minor As String
    Get
Visual C++
public:
static property String^ Minor {
    String^ get ();
}
F#
static member Minor : string

See Also

Function Class
SMath.Manager Namespace


Mod Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Mod Property
Function Class See Also Send Feedback
Остаток от деления

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Mod { get; }
Visual Basic
Public Shared ReadOnly Property Mod As String
    Get
Visual C++
public:
static property String^ Mod {
    String^ get ();
}
F#
static member Mod : string

See Also

Function Class
SMath.Manager Namespace


Norm1 Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Norm1 Property
Function Class See Also Send Feedback
Возвращает норму матрицы в пространстве L1

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Norm1 { get; }
Visual Basic
Public Shared ReadOnly Property Norm1 As String
    Get
Visual C++
public:
static property String^ Norm1 {
    String^ get ();
}
F#
static member Norm1 : string

See Also

Function Class
SMath.Manager Namespace


NormE Property

[image]

SMath Studio Class Libraries Documantation
Function..::..NormE Property
Function Class See Also Send Feedback
Возвращает евклидову норму матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string NormE { get; }
Visual Basic
Public Shared ReadOnly Property NormE As String
    Get
Visual C++
public:
static property String^ NormE {
    String^ get ();
}
F#
static member NormE : string

See Also

Function Class
SMath.Manager Namespace


NormI Property

[image]

SMath Studio Class Libraries Documantation
Function..::..NormI Property
Function Class See Also Send Feedback
Возвращает равномерную норму матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string NormI { get; }
Visual Basic
Public Shared ReadOnly Property NormI As String
    Get
Visual C++
public:
static property String^ NormI {
    String^ get ();
}
F#
static member NormI : string

See Also

Function Class
SMath.Manager Namespace


Nthroot Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Nthroot Property
Function Class See Also Send Feedback
Корень произвольной степени

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Nthroot { get; }
Visual Basic
Public Shared ReadOnly Property Nthroot As String
    Get
Visual C++
public:
static property String^ Nthroot {
    String^ get ();
}
F#
static member Nthroot : string

See Also

Function Class
SMath.Manager Namespace


Numden Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Numden Property
Function Class See Also Send Feedback
Получение числителя и знаменателя в виде вектор-столбца

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Numden { get; }
Visual Basic
Public Shared ReadOnly Property Numden As String
    Get
Visual C++
public:
static property String^ Numden {
    String^ get ();
}
F#
static member Numden : string

See Also

Function Class
SMath.Manager Namespace


Perc Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Perc Property
Function Class See Also Send Feedback
Проценты

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Perc { get; }
Visual Basic
Public Shared ReadOnly Property Perc As String
    Get
Visual C++
public:
static property String^ Perc {
    String^ get ();
}
F#
static member Perc : string

See Also

Function Class
SMath.Manager Namespace


Pol2xy Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Pol2xy Property
Function Class See Also Send Feedback
Перевод координат из полярных в прямоугольные

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Pol2xy { get; }
Visual Basic
Public Shared ReadOnly Property Pol2xy As String
    Get
Visual C++
public:
static property String^ Pol2xy {
    String^ get ();
}
F#
static member Pol2xy : string

See Also

Function Class
SMath.Manager Namespace


Polyroots Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Polyroots Property
Function Class See Also Send Feedback
Вычисление корней полинома

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Polyroots { get; }
Visual Basic
Public Shared ReadOnly Property Polyroots As String
    Get
Visual C++
public:
static property String^ Polyroots {
    String^ get ();
}
F#
static member Polyroots : string

See Also

Function Class
SMath.Manager Namespace


Product Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Product Property
Function Class See Also Send Feedback
Функция произведения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Product { get; }
Visual Basic
Public Shared ReadOnly Property Product As String
    Get
Visual C++
public:
static property String^ Product {
    String^ get ();
}
F#
static member Product : string

See Also

Function Class
SMath.Manager Namespace


Random Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Random Property
Function Class See Also Send Feedback
Случайное число

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Random { get; }
Visual Basic
Public Shared ReadOnly Property Random As String
    Get
Visual C++
public:
static property String^ Random {
    String^ get ();
}
F#
static member Random : string

See Also

Function Class
SMath.Manager Namespace


Range Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Range Property
Function Class See Also Send Feedback
Функция создания массива по заданным параметрам

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Range { get; }
Visual Basic
Public Shared ReadOnly Property Range As String
    Get
Visual C++
public:
static property String^ Range {
    String^ get ();
}
F#
static member Range : string

See Also

Function Class
SMath.Manager Namespace


Rank Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Rank Property
Function Class See Also Send Feedback
Ранг матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Rank { get; }
Visual Basic
Public Shared ReadOnly Property Rank As String
    Get
Visual C++
public:
static property String^ Rank {
    String^ get ();
}
F#
static member Rank : string

See Also

Function Class
SMath.Manager Namespace


Re Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Re Property
Function Class See Also Send Feedback
Действительная часть числа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Re { get; }
Visual Basic
Public Shared ReadOnly Property Re As String
    Get
Visual C++
public:
static property String^ Re {
    String^ get ();
}
F#
static member Re : string

See Also

Function Class
SMath.Manager Namespace


Reverse Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Reverse Property
Function Class See Also Send Feedback
Изменяет порядок строк матрицы или элементов вектора на противоположный

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Reverse { get; }
Visual Basic
Public Shared ReadOnly Property Reverse As String
    Get
Visual C++
public:
static property String^ Reverse {
    String^ get ();
}
F#
static member Reverse : string

See Also

Function Class
SMath.Manager Namespace


RFile Property

[image]

SMath Studio Class Libraries Documantation
Function..::..RFile Property
Function Class See Also Send Feedback
Прочитать математическое выражение из файла, если такой существует

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string RFile { get; }
Visual Basic
Public Shared ReadOnly Property RFile As String
    Get
Visual C++
public:
static property String^ RFile {
    String^ get ();
}
F#
static member RFile : string

See Also

Function Class
SMath.Manager Namespace


Round Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Round Property
Function Class See Also Send Feedback
Округление числа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Round { get; }
Visual Basic
Public Shared ReadOnly Property Round As String
    Get
Visual C++
public:
static property String^ Round {
    String^ get ();
}
F#
static member Round : string

See Also

Function Class
SMath.Manager Namespace


Row Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Row Property
Function Class See Also Send Feedback
Строка матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Row { get; }
Visual Basic
Public Shared ReadOnly Property Row As String
    Get
Visual C++
public:
static property String^ Row {
    String^ get ();
}
F#
static member Row : string

See Also

Function Class
SMath.Manager Namespace


Rows Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Rows Property
Function Class See Also Send Feedback
Количество строк матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Rows { get; }
Visual Basic
Public Shared ReadOnly Property Rows As String
    Get
Visual C++
public:
static property String^ Rows {
    String^ get ();
}
F#
static member Rows : string

See Also

Function Class
SMath.Manager Namespace


RSort Property

[image]

SMath Studio Class Libraries Documantation
Function..::..RSort Property
Function Class See Also Send Feedback
Возвращает матрицу/вектор с элементами, отсортированными по указанной строке в порядке возрастания

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string RSort { get; }
Visual Basic
Public Shared ReadOnly Property RSort As String
    Get
Visual C++
public:
static property String^ RSort {
    String^ get ();
}
F#
static member RSort : string

See Also

Function Class
SMath.Manager Namespace


Sec Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sec Property
Function Class See Also Send Feedback
Секанс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sec { get; }
Visual Basic
Public Shared ReadOnly Property Sec As String
    Get
Visual C++
public:
static property String^ Sec {
    String^ get ();
}
F#
static member Sec : string

See Also

Function Class
SMath.Manager Namespace


Sech Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sech Property
Function Class See Also Send Feedback
Гиперболический секанс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sech { get; }
Visual Basic
Public Shared ReadOnly Property Sech As String
    Get
Visual C++
public:
static property String^ Sech {
    String^ get ();
}
F#
static member Sech : string

See Also

Function Class
SMath.Manager Namespace


Sh Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sh Property
Function Class See Also Send Feedback
Гиперболический синус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sh { get; }
Visual Basic
Public Shared ReadOnly Property Sh As String
    Get
Visual C++
public:
static property String^ Sh {
    String^ get ();
}
F#
static member Sh : string

See Also

Function Class
SMath.Manager Namespace


Sign Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sign Property
Function Class See Also Send Feedback
Сигнатура

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sign { get; }
Visual Basic
Public Shared ReadOnly Property Sign As String
    Get
Visual C++
public:
static property String^ Sign {
    String^ get ();
}
F#
static member Sign : string

See Also

Function Class
SMath.Manager Namespace


Sin Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sin Property
Function Class See Also Send Feedback
Синус

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sin { get; }
Visual Basic
Public Shared ReadOnly Property Sin As String
    Get
Visual C++
public:
static property String^ Sin {
    String^ get ();
}
F#
static member Sin : string

See Also

Function Class
SMath.Manager Namespace


Solve Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Solve Property
Function Class See Also Send Feedback
Получение корней уравнения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Solve { get; }
Visual Basic
Public Shared ReadOnly Property Solve As String
    Get
Visual C++
public:
static property String^ Solve {
    String^ get ();
}
F#
static member Solve : string

See Also

Function Class
SMath.Manager Namespace


Sort Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sort Property
Function Class See Also Send Feedback
Возвращает вектор с элементами, отсортированными в порядке возрастания

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sort { get; }
Visual Basic
Public Shared ReadOnly Property Sort As String
    Get
Visual C++
public:
static property String^ Sort {
    String^ get ();
}
F#
static member Sort : string

See Also

Function Class
SMath.Manager Namespace


Sqrt Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sqrt Property
Function Class See Also Send Feedback
Квадратный корень

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sqrt { get; }
Visual Basic
Public Shared ReadOnly Property Sqrt As String
    Get
Visual C++
public:
static property String^ Sqrt {
    String^ get ();
}
F#
static member Sqrt : string

See Also

Function Class
SMath.Manager Namespace


Stack Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Stack Property
Function Class See Also Send Feedback
Функция возвращает массив образованный последовательным размещением аргументов друг под другом. Аргументы могут быть скалярами, векторами или матрицами с одинаковым количеством столбцов

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Stack { get; }
Visual Basic
Public Shared ReadOnly Property Stack As String
    Get
Visual C++
public:
static property String^ Stack {
    String^ get ();
}
F#
static member Stack : string

See Also

Function Class
SMath.Manager Namespace


Submatrix Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Submatrix Property
Function Class See Also Send Feedback
Получение матрицы указанных размеров из существующей

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Submatrix { get; }
Visual Basic
Public Shared ReadOnly Property Submatrix As String
    Get
Visual C++
public:
static property String^ Submatrix {
    String^ get ();
}
F#
static member Submatrix : string

See Also

Function Class
SMath.Manager Namespace


Sum Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sum Property
Function Class See Also Send Feedback
Функция суммирования

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sum { get; }
Visual Basic
Public Shared ReadOnly Property Sum As String
    Get
Visual C++
public:
static property String^ Sum {
    String^ get ();
}
F#
static member Sum : string

See Also

Function Class
SMath.Manager Namespace


Switch Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Switch Property
Function Class See Also Send Feedback
Функция выбора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Switch { get; }
Visual Basic
Public Shared ReadOnly Property Switch As String
    Get
Visual C++
public:
static property String^ Switch {
    String^ get ();
}
F#
static member Switch : string

See Also

Function Class
SMath.Manager Namespace


Sys Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Sys Property
Function Class See Also Send Feedback
Алгебраическая система

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Sys { get; }
Visual Basic
Public Shared ReadOnly Property Sys As String
    Get
Visual C++
public:
static property String^ Sys {
    String^ get ();
}
F#
static member Sys : string

See Also

Function Class
SMath.Manager Namespace


Tg Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Tg Property
Function Class See Also Send Feedback
Тангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Tg { get; }
Visual Basic
Public Shared ReadOnly Property Tg As String
    Get
Visual C++
public:
static property String^ Tg {
    String^ get ();
}
F#
static member Tg : string

See Also

Function Class
SMath.Manager Namespace


Th Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Th Property
Function Class See Also Send Feedback
Гиперболический тангенс

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Th { get; }
Visual Basic
Public Shared ReadOnly Property Th As String
    Get
Visual C++
public:
static property String^ Th {
    String^ get ();
}
F#
static member Th : string

See Also

Function Class
SMath.Manager Namespace


Tr Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Tr Property
Function Class See Also Send Feedback
След матрицы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Tr { get; }
Visual Basic
Public Shared ReadOnly Property Tr As String
    Get
Visual C++
public:
static property String^ Tr {
    String^ get ();
}
F#
static member Tr : string

See Also

Function Class
SMath.Manager Namespace


Transpose Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Transpose Property
Function Class See Also Send Feedback
Транспонирование матрицы/вектора

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Transpose { get; }
Visual Basic
Public Shared ReadOnly Property Transpose As String
    Get
Visual C++
public:
static property String^ Transpose {
    String^ get ();
}
F#
static member Transpose : string

See Also

Function Class
SMath.Manager Namespace


Trunc Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Trunc Property
Function Class See Also Send Feedback
Получение целой части числа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Trunc { get; }
Visual Basic
Public Shared ReadOnly Property Trunc As String
    Get
Visual C++
public:
static property String^ Trunc {
    String^ get ();
}
F#
static member Trunc : string

See Also

Function Class
SMath.Manager Namespace


Vminor Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Vminor Property
Function Class See Also Send Feedback
Визуальное представление минора - без вычисления конечного определителя

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Vminor { get; }
Visual Basic
Public Shared ReadOnly Property Vminor As String
    Get
Visual C++
public:
static property String^ Vminor {
    String^ get ();
}
F#
static member Vminor : string

See Also

Function Class
SMath.Manager Namespace


WFile Property

[image]

SMath Studio Class Libraries Documantation
Function..::..WFile Property
Function Class See Also Send Feedback
Записать математическое выражение в файл. Если файл с указанным названием уже существует, функция перепишет его новым значением

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string WFile { get; }
Visual Basic
Public Shared ReadOnly Property WFile As String
    Get
Visual C++
public:
static property String^ WFile {
    String^ get ();
}
F#
static member WFile : string

See Also

Function Class
SMath.Manager Namespace


While Property

[image]

SMath Studio Class Libraries Documantation
Function..::..While Property
Function Class See Also Send Feedback
Цикл типа while

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string While { get; }
Visual Basic
Public Shared ReadOnly Property While As String
    Get
Visual C++
public:
static property String^ While {
    String^ get ();
}
F#
static member While : string

See Also

Function Class
SMath.Manager Namespace


Xy2pol Property

[image]

SMath Studio Class Libraries Documantation
Function..::..Xy2pol Property
Function Class See Also Send Feedback
Перевод координат из прямоугольных к полярным

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string Xy2pol { get; }
Visual Basic
Public Shared ReadOnly Property Xy2pol As String
    Get
Visual C++
public:
static property String^ Xy2pol {
    String^ get ();
}
F#
static member Xy2pol : string

See Also

Function Class
SMath.Manager Namespace


FunctionSection Enumeration

[image]

SMath Studio Class Libraries Documantation
FunctionSection Enumeration
See Also Send Feedback
Function's section

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
[FlagsAttribute]
public enum FunctionSection
Visual Basic
<FlagsAttribute> _
Public Enumeration FunctionSection
Visual C++
[FlagsAttribute]
public enum class FunctionSection
F#
[<FlagsAttribute>]
type FunctionSection

Members

Member name | Value | Description
Unknown | 0 | No section matches the function
MatricesAndVectors | 1 | Matrices and Vectors Section
ComplexNumbers | 2 | Complex Numbers Section
Trigonometric | 4 | Trigonometric Section
Hyperbolic | 8 | Hyperbolic Section
Programming | 16 | Programming Section
Strings | 32 | Strings Section
Files | 64 | Files Section

See Also

SMath.Manager Namespace


GlobalParams Class

[image]

SMath Studio Class Libraries Documantation
GlobalParams Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.GlobalParams"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class GlobalParams
Visual Basic
Public Class GlobalParams
Visual C++
public ref class GlobalParams
F#
type GlobalParams =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..GlobalParams

See Also

GlobalParams Members
SMath.Manager Namespace


GlobalParams Members

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams Members
GlobalParams Class Constructors Methods Fields Properties See Also Send Feedback

The GlobalParams type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalParams | Initializes a new instance of the GlobalParams class

Methods

Name | Description
ColorToWebColor | Converts .Net Color to Web Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.
DisposePlugins | Завершение работы дополнений
GetImageFromResources | Получение изображения из ресурсов библиотеки
Grider |
LoadAvailableLanguages()()()() | Загрузка списка доступных языковых файлов из директории программы
LoadAvailableLanguages(String) | Загрузка списка доступных языковых файлов из указанной директории
LoadPlugins | Загрузить дополнения из указанной директории
ParseLanguage(String, Boolean) | Выбор языка для загрузки из языкового файла
ParseLanguage(String, Boolean, String) | Выбор языка для загрузки из языкового файла
ScreenFactorAccept | Координата в контексте свойств разрешения экрана
SetFunctionType | Выбор типа именования функций
SetLanguage | Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но есои английские недоступен, то будет выбран первый же доступный язык.
WebColorToColor | Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.

Fields

Name | Description
AnglesTypeMath |
ansType_ISO |
ArgumentsSeparator |
ArgumentsSeparatorStandard |
ArgumentsSeparatorSystem |
AvailableLanguages |
buttonL |
CanvasGridSize |
ControlColors |
CurLang3Letter |
CurLangFull |
DecimalPlaces |
DecimalSymbolStandard |
DecimalSymbolSystem |
FatalErrors |
FontHeight |
FractionsTypeNumeric |
FunctionChildCounts |
FunctionNameGuid |
FunctionsType |
FunctionVisibility |
Info |
IntegralAccuracy |
InterfaceLanguage |
IsAltKeyPressed |
IsAutoReCalc |
IsCtrlKeyPressed |
IsDefinitionsOptimized |
IsDynamicAssistance |
IsShiftKeyPressed |
IsSmoothGraphics |
IsSmoothMoving |
IsWebApplication |
plugins |
pth |
ReleaseDate |
SessionHost |
SessionLogin |
SolveFromPoint |
SolveToPoint |
StringsErrors |
StringsFunctions |
StringsFunctionsDescription |
StringsGUI |
StringsMathBookContent |
StringsToolTip |
SystemItemsType |
TabPanelTitleHeight |
titleC |
titleF |
titleFC |
toolBt |
ttlCenter |
ttlLeft |
ttlRight |
TypeEURO |
TypeEUROGuid |
TypeWORLD |
TypeWorldGuid |

Properties

Name | Description
ApplicationPath | Директория, из которой происходит запуск программы
DecimalSymbol |
IsPortableVersion | Попытка определения того, запущена ли программа в Portable режиме
OS | Тип текущей клиентской операционной системы на которой выполняется программа
Platform | Тип текущей клиентской платформы на которой происходит выполнение программы
ScreenDpi | Получение плотности изображения на дисплее (точки на дюйм)
ScreenResolutionFactor | Отношение разрешения экрана к стандартному значению
ScrollBarWidth | Ширина верикальной каретки прокрутки
SettingsDirectory | Get the directory where all user specific parameters will store
Units |
UnitsSpecial |

See Also

GlobalParams Class
SMath.Manager Namespace


GlobalParams Constructor

[image]

SMath Studio Class Libraries Documantation
GlobalParams Constructor
GlobalParams Class See Also Send Feedback
Initializes a new instance of the GlobalParams class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public GlobalParams()
Visual Basic
Public Sub New
Visual C++
public:
GlobalParams()
F#
new : unit -> GlobalParams

See Also

GlobalParams Class
SMath.Manager Namespace


GlobalParams Fields

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams Fields
GlobalParams Class See Also Send Feedback

The GlobalParams type exposes the following members.

Fields

Name | Description
AnglesTypeMath |
ansType_ISO |
ArgumentsSeparator |
ArgumentsSeparatorStandard |
ArgumentsSeparatorSystem |
AvailableLanguages |
buttonL |
CanvasGridSize |
ControlColors |
CurLang3Letter |
CurLangFull |
DecimalPlaces |
DecimalSymbolStandard |
DecimalSymbolSystem |
FatalErrors |
FontHeight |
FractionsTypeNumeric |
FunctionChildCounts |
FunctionNameGuid |
FunctionsType |
FunctionVisibility |
Info |
IntegralAccuracy |
InterfaceLanguage |
IsAltKeyPressed |
IsAutoReCalc |
IsCtrlKeyPressed |
IsDefinitionsOptimized |
IsDynamicAssistance |
IsShiftKeyPressed |
IsSmoothGraphics |
IsSmoothMoving |
IsWebApplication |
plugins |
pth |
ReleaseDate |
SessionHost |
SessionLogin |
SolveFromPoint |
SolveToPoint |
StringsErrors |
StringsFunctions |
StringsFunctionsDescription |
StringsGUI |
StringsMathBookContent |
StringsToolTip |
SystemItemsType |
TabPanelTitleHeight |
titleC |
titleF |
titleFC |
toolBt |
ttlCenter |
ttlLeft |
ttlRight |
TypeEURO |
TypeEUROGuid |
TypeWORLD |
TypeWorldGuid |

See Also

GlobalParams Class
SMath.Manager Namespace


AnglesTypeMath Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..AnglesTypeMath Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.AnglesTypeMath"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static AnglesType AnglesTypeMath
Visual Basic
Public Shared AnglesTypeMath As AnglesType
Visual C++
public:
static AnglesType AnglesTypeMath
F#
static val mutable AnglesTypeMath: AnglesType

See Also

GlobalParams Class
SMath.Manager Namespace


ansType_ISO Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ansType_ISO Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ansType_ISO"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static AnswerType ansType_ISO
Visual Basic
Public Shared ansType_ISO As AnswerType
Visual C++
public:
static AnswerType ansType_ISO
F#
static val mutable ansType_ISO: AnswerType

See Also

GlobalParams Class
SMath.Manager Namespace


ArgumentsSeparator Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ArgumentsSeparator Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ArgumentsSeparator"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char ArgumentsSeparator
Visual Basic
Public Shared ArgumentsSeparator As Char
Visual C++
public:
static wchar_t ArgumentsSeparator
F#
static val mutable ArgumentsSeparator: char

See Also

GlobalParams Class
SMath.Manager Namespace


ArgumentsSeparatorStandard Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ArgumentsSeparatorStandard Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ArgumentsSeparatorStandard"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char ArgumentsSeparatorStandard
Visual Basic
Public Shared ArgumentsSeparatorStandard As Char
Visual C++
public:
static wchar_t ArgumentsSeparatorStandard
F#
static val mutable ArgumentsSeparatorStandard: char

See Also

GlobalParams Class
SMath.Manager Namespace


ArgumentsSeparatorSystem Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ArgumentsSeparatorSystem Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ArgumentsSeparatorSystem"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char ArgumentsSeparatorSystem
Visual Basic
Public Shared ArgumentsSeparatorSystem As Char
Visual C++
public:
static wchar_t ArgumentsSeparatorSystem
F#
static val mutable ArgumentsSeparatorSystem: char

See Also

GlobalParams Class
SMath.Manager Namespace


AvailableLanguages Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..AvailableLanguages Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.AvailableLanguages"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[,] AvailableLanguages
Visual Basic
Public Shared AvailableLanguages As String(,)
Visual C++
public:
static array<String^,2>^ AvailableLanguages
F#
static val mutable AvailableLanguages: string[,]

See Also

GlobalParams Class
SMath.Manager Namespace


buttonL Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..buttonL Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.buttonL"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Color buttonL
Visual Basic
Public Shared buttonL As Color
Visual C++
public:
static Color buttonL
F#
static val mutable buttonL: Color

See Also

GlobalParams Class
SMath.Manager Namespace


CanvasGridSize Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..CanvasGridSize Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.CanvasGridSize"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int CanvasGridSize
Visual Basic
Public Shared CanvasGridSize As Integer
Visual C++
public:
static int CanvasGridSize
F#
static val mutable CanvasGridSize: int

See Also

GlobalParams Class
SMath.Manager Namespace


ControlColors Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ControlColors Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ControlColors"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Color[] ControlColors
Visual Basic
Public Shared ControlColors As Color()
Visual C++
public:
static array<Color>^ ControlColors
F#
static val mutable ControlColors: Color[]

See Also

GlobalParams Class
SMath.Manager Namespace


CurLang3Letter Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..CurLang3Letter Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.CurLang3Letter"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string CurLang3Letter
Visual Basic
Public Shared CurLang3Letter As String
Visual C++
public:
static String^ CurLang3Letter
F#
static val mutable CurLang3Letter: string

See Also

GlobalParams Class
SMath.Manager Namespace


CurLangFull Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..CurLangFull Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.CurLangFull"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string CurLangFull
Visual Basic
Public Shared CurLangFull As String
Visual C++
public:
static String^ CurLangFull
F#
static val mutable CurLangFull: string

See Also

GlobalParams Class
SMath.Manager Namespace


DecimalPlaces Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..DecimalPlaces Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.DecimalPlaces"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int DecimalPlaces
Visual Basic
Public Shared DecimalPlaces As Integer
Visual C++
public:
static int DecimalPlaces
F#
static val mutable DecimalPlaces: int

See Also

GlobalParams Class
SMath.Manager Namespace


DecimalSymbolStandard Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..DecimalSymbolStandard Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.DecimalSymbolStandard"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char DecimalSymbolStandard
Visual Basic
Public Shared DecimalSymbolStandard As Char
Visual C++
public:
static wchar_t DecimalSymbolStandard
F#
static val mutable DecimalSymbolStandard: char

See Also

GlobalParams Class
SMath.Manager Namespace


DecimalSymbolSystem Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..DecimalSymbolSystem Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.DecimalSymbolSystem"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char DecimalSymbolSystem
Visual Basic
Public Shared DecimalSymbolSystem As Char
Visual C++
public:
static wchar_t DecimalSymbolSystem
F#
static val mutable DecimalSymbolSystem: char

See Also

GlobalParams Class
SMath.Manager Namespace


FatalErrors Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FatalErrors Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FatalErrors"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] FatalErrors
Visual Basic
Public Shared FatalErrors As String()
Visual C++
public:
static array<String^>^ FatalErrors
F#
static val mutable FatalErrors: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


FontHeight Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FontHeight Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FontHeight"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int FontHeight
Visual Basic
Public Shared FontHeight As Integer
Visual C++
public:
static int FontHeight
F#
static val mutable FontHeight: int

See Also

GlobalParams Class
SMath.Manager Namespace


FractionsTypeNumeric Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FractionsTypeNumeric Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FractionsTypeNumeric"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static FractionsType FractionsTypeNumeric
Visual Basic
Public Shared FractionsTypeNumeric As FractionsType
Visual C++
public:
static FractionsType FractionsTypeNumeric
F#
static val mutable FractionsTypeNumeric: FractionsType

See Also

GlobalParams Class
SMath.Manager Namespace


FunctionChildCounts Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FunctionChildCounts Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FunctionChildCounts"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int[] FunctionChildCounts
Visual Basic
Public Shared FunctionChildCounts As Integer()
Visual C++
public:
static array<int>^ FunctionChildCounts
F#
static val mutable FunctionChildCounts: int[]

See Also

GlobalParams Class
SMath.Manager Namespace


FunctionNameGuid Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FunctionNameGuid Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FunctionNameGuid"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Guid FunctionNameGuid
Visual Basic
Public Shared FunctionNameGuid As Guid
Visual C++
public:
static Guid FunctionNameGuid
F#
static val mutable FunctionNameGuid: Guid

See Also

GlobalParams Class
SMath.Manager Namespace


FunctionsType Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FunctionsType Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FunctionsType"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int FunctionsType
Visual Basic
Public Shared FunctionsType As Integer
Visual C++
public:
static int FunctionsType
F#
static val mutable FunctionsType: int

See Also

GlobalParams Class
SMath.Manager Namespace


FunctionVisibility Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..FunctionVisibility Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.FunctionVisibility"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int[] FunctionVisibility
Visual Basic
Public Shared FunctionVisibility As Integer()
Visual C++
public:
static array<int>^ FunctionVisibility
F#
static val mutable FunctionVisibility: int[]

See Also

GlobalParams Class
SMath.Manager Namespace


Info Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..Info Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.Info"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static readonly AssemblyInfo Info
Visual Basic
Public Shared ReadOnly Info As AssemblyInfo
Visual C++
public:
static initonly AssemblyInfo Info
F#
static val Info: AssemblyInfo

See Also

GlobalParams Class
SMath.Manager Namespace


IntegralAccuracy Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IntegralAccuracy Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IntegralAccuracy"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int IntegralAccuracy
Visual Basic
Public Shared IntegralAccuracy As Integer
Visual C++
public:
static int IntegralAccuracy
F#
static val mutable IntegralAccuracy: int

See Also

GlobalParams Class
SMath.Manager Namespace


InterfaceLanguage Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..InterfaceLanguage Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.InterfaceLanguage"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int InterfaceLanguage
Visual Basic
Public Shared InterfaceLanguage As Integer
Visual C++
public:
static int InterfaceLanguage
F#
static val mutable InterfaceLanguage: int

See Also

GlobalParams Class
SMath.Manager Namespace


IsAltKeyPressed Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsAltKeyPressed Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsAltKeyPressed"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsAltKeyPressed
Visual Basic
Public Shared IsAltKeyPressed As Boolean
Visual C++
public:
static bool IsAltKeyPressed
F#
static val mutable IsAltKeyPressed: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsAutoReCalc Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsAutoReCalc Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsAutoReCalc"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsAutoReCalc
Visual Basic
Public Shared IsAutoReCalc As Boolean
Visual C++
public:
static bool IsAutoReCalc
F#
static val mutable IsAutoReCalc: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsCtrlKeyPressed Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsCtrlKeyPressed Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsCtrlKeyPressed"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsCtrlKeyPressed
Visual Basic
Public Shared IsCtrlKeyPressed As Boolean
Visual C++
public:
static bool IsCtrlKeyPressed
F#
static val mutable IsCtrlKeyPressed: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsDefinitionsOptimized Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsDefinitionsOptimized Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsDefinitionsOptimized"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static OptimizationType IsDefinitionsOptimized
Visual Basic
Public Shared IsDefinitionsOptimized As OptimizationType
Visual C++
public:
static OptimizationType IsDefinitionsOptimized
F#
static val mutable IsDefinitionsOptimized: OptimizationType

See Also

GlobalParams Class
SMath.Manager Namespace


IsDynamicAssistance Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsDynamicAssistance Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsDynamicAssistance"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsDynamicAssistance
Visual Basic
Public Shared IsDynamicAssistance As Boolean
Visual C++
public:
static bool IsDynamicAssistance
F#
static val mutable IsDynamicAssistance: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsShiftKeyPressed Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsShiftKeyPressed Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsShiftKeyPressed"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsShiftKeyPressed
Visual Basic
Public Shared IsShiftKeyPressed As Boolean
Visual C++
public:
static bool IsShiftKeyPressed
F#
static val mutable IsShiftKeyPressed: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsSmoothGraphics Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsSmoothGraphics Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsSmoothGraphics"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsSmoothGraphics
Visual Basic
Public Shared IsSmoothGraphics As Boolean
Visual C++
public:
static bool IsSmoothGraphics
F#
static val mutable IsSmoothGraphics: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsSmoothMoving Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsSmoothMoving Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsSmoothMoving"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsSmoothMoving
Visual Basic
Public Shared IsSmoothMoving As Boolean
Visual C++
public:
static bool IsSmoothMoving
F#
static val mutable IsSmoothMoving: bool

See Also

GlobalParams Class
SMath.Manager Namespace


IsWebApplication Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsWebApplication Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.IsWebApplication"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsWebApplication
Visual Basic
Public Shared IsWebApplication As Boolean
Visual C++
public:
static bool IsWebApplication
F#
static val mutable IsWebApplication: bool

See Also

GlobalParams Class
SMath.Manager Namespace


plugins Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..plugins Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.plugins"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static List<PluginInfo> plugins
Visual Basic
Public Shared plugins As List(Of PluginInfo)
Visual C++
public:
static List<PluginInfo^>^ plugins
F#
static val mutable plugins: List<PluginInfo>

See Also

GlobalParams Class
SMath.Manager Namespace


pth Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..pth Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.pth"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string pth
Visual Basic
Public Shared pth As String
Visual C++
public:
static String^ pth
F#
static val mutable pth: string

See Also

GlobalParams Class
SMath.Manager Namespace


ReleaseDate Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ReleaseDate Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ReleaseDate"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static readonly DateTime ReleaseDate
Visual Basic
Public Shared ReadOnly ReleaseDate As DateTime
Visual C++
public:
static initonly DateTime ReleaseDate
F#
static val ReleaseDate: DateTime

See Also

GlobalParams Class
SMath.Manager Namespace


SessionHost Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SessionHost Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.SessionHost"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string SessionHost
Visual Basic
Public Shared SessionHost As String
Visual C++
public:
static String^ SessionHost
F#
static val mutable SessionHost: string

See Also

GlobalParams Class
SMath.Manager Namespace


SessionLogin Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SessionLogin Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.SessionLogin"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string SessionLogin
Visual Basic
Public Shared SessionLogin As String
Visual C++
public:
static String^ SessionLogin
F#
static val mutable SessionLogin: string

See Also

GlobalParams Class
SMath.Manager Namespace


SolveFromPoint Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SolveFromPoint Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.SolveFromPoint"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int SolveFromPoint
Visual Basic
Public Shared SolveFromPoint As Integer
Visual C++
public:
static int SolveFromPoint
F#
static val mutable SolveFromPoint: int

See Also

GlobalParams Class
SMath.Manager Namespace


SolveToPoint Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SolveToPoint Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.SolveToPoint"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int SolveToPoint
Visual Basic
Public Shared SolveToPoint As Integer
Visual C++
public:
static int SolveToPoint
F#
static val mutable SolveToPoint: int

See Also

GlobalParams Class
SMath.Manager Namespace


StringsErrors Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsErrors Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsErrors"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsErrors
Visual Basic
Public Shared StringsErrors As String()
Visual C++
public:
static array<String^>^ StringsErrors
F#
static val mutable StringsErrors: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


StringsFunctions Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsFunctions Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsFunctions"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsFunctions
Visual Basic
Public Shared StringsFunctions As String()
Visual C++
public:
static array<String^>^ StringsFunctions
F#
static val mutable StringsFunctions: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


StringsFunctionsDescription Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsFunctionsDescription Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsFunctionsDescription"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsFunctionsDescription
Visual Basic
Public Shared StringsFunctionsDescription As String()
Visual C++
public:
static array<String^>^ StringsFunctionsDescription
F#
static val mutable StringsFunctionsDescription: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


StringsGUI Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsGUI Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsGUI"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsGUI
Visual Basic
Public Shared StringsGUI As String()
Visual C++
public:
static array<String^>^ StringsGUI
F#
static val mutable StringsGUI: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


StringsMathBookContent Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsMathBookContent Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsMathBookContent"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsMathBookContent
Visual Basic
Public Shared StringsMathBookContent As String()
Visual C++
public:
static array<String^>^ StringsMathBookContent
F#
static val mutable StringsMathBookContent: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


StringsToolTip Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..StringsToolTip Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.StringsToolTip"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] StringsToolTip
Visual Basic
Public Shared StringsToolTip As String()
Visual C++
public:
static array<String^>^ StringsToolTip
F#
static val mutable StringsToolTip: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


SystemItemsType Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SystemItemsType Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.SystemItemsType"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static SysSettings SystemItemsType
Visual Basic
Public Shared SystemItemsType As SysSettings
Visual C++
public:
static SysSettings SystemItemsType
F#
static val mutable SystemItemsType: SysSettings

See Also

GlobalParams Class
SMath.Manager Namespace


TabPanelTitleHeight Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..TabPanelTitleHeight Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.TabPanelTitleHeight"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int TabPanelTitleHeight
Visual Basic
Public Shared TabPanelTitleHeight As Integer
Visual C++
public:
static int TabPanelTitleHeight
F#
static val mutable TabPanelTitleHeight: int

See Also

GlobalParams Class
SMath.Manager Namespace


titleC Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..titleC Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.titleC"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Color titleC
Visual Basic
Public Shared titleC As Color
Visual C++
public:
static Color titleC
F#
static val mutable titleC: Color

See Also

GlobalParams Class
SMath.Manager Namespace


titleF Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..titleF Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.titleF"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static float titleF
Visual Basic
Public Shared titleF As Single
Visual C++
public:
static float titleF
F#
static val mutable titleF: float32

See Also

GlobalParams Class
SMath.Manager Namespace


titleFC Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..titleFC Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.titleFC"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Color titleFC
Visual Basic
Public Shared titleFC As Color
Visual C++
public:
static Color titleFC
F#
static val mutable titleFC: Color

See Also

GlobalParams Class
SMath.Manager Namespace


toolBt Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..toolBt Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.toolBt"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Bitmap[] toolBt
Visual Basic
Public Shared toolBt As Bitmap()
Visual C++
public:
static array<Bitmap^>^ toolBt
F#
static val mutable toolBt: Bitmap[]

See Also

GlobalParams Class
SMath.Manager Namespace


ttlCenter Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ttlCenter Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ttlCenter"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Bitmap ttlCenter
Visual Basic
Public Shared ttlCenter As Bitmap
Visual C++
public:
static Bitmap^ ttlCenter
F#
static val mutable ttlCenter: Bitmap

See Also

GlobalParams Class
SMath.Manager Namespace


ttlLeft Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ttlLeft Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ttlLeft"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Bitmap ttlLeft
Visual Basic
Public Shared ttlLeft As Bitmap
Visual C++
public:
static Bitmap^ ttlLeft
F#
static val mutable ttlLeft: Bitmap

See Also

GlobalParams Class
SMath.Manager Namespace


ttlRight Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ttlRight Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.ttlRight"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Bitmap ttlRight
Visual Basic
Public Shared ttlRight As Bitmap
Visual C++
public:
static Bitmap^ ttlRight
F#
static val mutable ttlRight: Bitmap

See Also

GlobalParams Class
SMath.Manager Namespace


TypeEURO Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..TypeEURO Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.TypeEURO"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] TypeEURO
Visual Basic
Public Shared TypeEURO As String()
Visual C++
public:
static array<String^>^ TypeEURO
F#
static val mutable TypeEURO: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


TypeEUROGuid Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..TypeEUROGuid Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.TypeEUROGuid"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Guid TypeEUROGuid
Visual Basic
Public Shared TypeEUROGuid As Guid
Visual C++
public:
static Guid TypeEUROGuid
F#
static val mutable TypeEUROGuid: Guid

See Also

GlobalParams Class
SMath.Manager Namespace


TypeWORLD Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..TypeWORLD Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.TypeWORLD"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] TypeWORLD
Visual Basic
Public Shared TypeWORLD As String()
Visual C++
public:
static array<String^>^ TypeWORLD
F#
static val mutable TypeWORLD: string[]

See Also

GlobalParams Class
SMath.Manager Namespace


TypeWorldGuid Field

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..TypeWorldGuid Field
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.GlobalParams.TypeWorldGuid"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Guid TypeWorldGuid
Visual Basic
Public Shared TypeWorldGuid As Guid
Visual C++
public:
static Guid TypeWorldGuid
F#
static val mutable TypeWorldGuid: Guid

See Also

GlobalParams Class
SMath.Manager Namespace


GlobalParams Methods

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams Methods
GlobalParams Class See Also Send Feedback

The GlobalParams type exposes the following members.

Methods

Name | Description
ColorToWebColor | Converts .Net Color to Web Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.
DisposePlugins | Завершение работы дополнений
GetImageFromResources | Получение изображения из ресурсов библиотеки
Grider |
LoadAvailableLanguages()()()() | Загрузка списка доступных языковых файлов из директории программы
LoadAvailableLanguages(String) | Загрузка списка доступных языковых файлов из указанной директории
LoadPlugins | Загрузить дополнения из указанной директории
ParseLanguage(String, Boolean) | Выбор языка для загрузки из языкового файла
ParseLanguage(String, Boolean, String) | Выбор языка для загрузки из языкового файла
ScreenFactorAccept | Координата в контексте свойств разрешения экрана
SetFunctionType | Выбор типа именования функций
SetLanguage | Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но есои английские недоступен, то будет выбран первый же доступный язык.
WebColorToColor | Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.

See Also

GlobalParams Class
SMath.Manager Namespace


ColorToWebColor Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ColorToWebColor Method
GlobalParams Class See Also Send Feedback
Converts .Net Color to Web Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string ColorToWebColor(
    Color value
)
Visual Basic
Public Shared Function ColorToWebColor ( _
    value As Color _
) As String
Visual C++
public:
static String^ ColorToWebColor(
    Color value
)
F#
static member ColorToWebColor :
        value:Color -> string

Parameters

value
Type: System.Drawing..::..Color
Input Color

Return Value

String represents a Web Color

See Also

GlobalParams Class
SMath.Manager Namespace


DisposePlugins Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..DisposePlugins Method
GlobalParams Class See Also Send Feedback
Завершение работы дополнений

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void DisposePlugins()
Visual Basic
Public Shared Sub DisposePlugins
Visual C++
public:
static void DisposePlugins()
F#
static member DisposePlugins : unit -> unit

See Also

GlobalParams Class
SMath.Manager Namespace


GetImageFromResources Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..GetImageFromResources Method
GlobalParams Class See Also Send Feedback
Получение изображения из ресурсов библиотеки

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Bitmap GetImageFromResources(
    Assembly assembly,
    string resourceName
)
Visual Basic
Public Shared Function GetImageFromResources ( _
    assembly As Assembly, _
    resourceName As String _
) As Bitmap
Visual C++
public:
static Bitmap^ GetImageFromResources(
    Assembly^ assembly,
    String^ resourceName
)
F#
static member GetImageFromResources :
        assembly:Assembly *
        resourceName:string -> Bitmap

Parameters

assembly
Type: System.Reflection..::..Assembly

[Missing <param name="assembly"/> documentation for "M:SMath.Manager.GlobalParams.GetImageFromResources(System.Reflection.Assembly,System.String)"]

resourceName
Type: System..::..String

[Missing <param name="resourceName"/> documentation for "M:SMath.Manager.GlobalParams.GetImageFromResources(System.Reflection.Assembly,System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.GlobalParams.GetImageFromResources(System.Reflection.Assembly,System.String)"]

See Also

GlobalParams Class
SMath.Manager Namespace


Grider Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..Grider Method
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.GlobalParams.Grider(System.Int32)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int Grider(
    int value
)
Visual Basic
Public Shared Function Grider ( _
    value As Integer _
) As Integer
Visual C++
public:
static int Grider(
    int value
)
F#
static member Grider :
        value:int -> int

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Manager.GlobalParams.Grider(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.GlobalParams.Grider(System.Int32)"]

See Also

GlobalParams Class
SMath.Manager Namespace


LoadAvailableLanguages Method

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams..::..LoadAvailableLanguages Method
GlobalParams Class See Also Send Feedback

Overload List

Name | Description
LoadAvailableLanguages()()()() | Загрузка списка доступных языковых файлов из директории программы
LoadAvailableLanguages(String) | Загрузка списка доступных языковых файлов из указанной директории

See Also

GlobalParams Class
GlobalParams Members
SMath.Manager Namespace


LoadAvailableLanguages Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..LoadAvailableLanguages Method
GlobalParams Class See Also Send Feedback
Загрузка списка доступных языковых файлов из директории программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void LoadAvailableLanguages()
Visual Basic
Public Shared Sub LoadAvailableLanguages
Visual C++
public:
static void LoadAvailableLanguages()
F#
static member LoadAvailableLanguages : unit -> unit

See Also

GlobalParams Class
LoadAvailableLanguages Overload
SMath.Manager Namespace


LoadAvailableLanguages Method (String)

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..LoadAvailableLanguages Method (String)
GlobalParams Class See Also Send Feedback
Загрузка списка доступных языковых файлов из указанной директории

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void LoadAvailableLanguages(
    string path
)
Visual Basic
Public Shared Sub LoadAvailableLanguages ( _
    path As String _
)
Visual C++
public:
static void LoadAvailableLanguages(
    String^ path
)
F#
static member LoadAvailableLanguages :
        path:string -> unit

Parameters

path
Type: System..::..String
Директория с языковыми файлами

See Also

GlobalParams Class
LoadAvailableLanguages Overload
SMath.Manager Namespace


LoadPlugins Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..LoadPlugins Method
GlobalParams Class See Also Send Feedback
Загрузить дополнения из указанной директории

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void LoadPlugins(
    string path
)
Visual Basic
Public Shared Sub LoadPlugins ( _
    path As String _
)
Visual C++
public:
static void LoadPlugins(
    String^ path
)
F#
static member LoadPlugins :
        path:string -> unit

Parameters

path
Type: System..::..String
Директория с дополнениями

See Also

GlobalParams Class
SMath.Manager Namespace


ParseLanguage Method

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ParseLanguage Method
GlobalParams Class See Also Send Feedback

Overload List

Name | Description
ParseLanguage(String, Boolean) | Выбор языка для загрузки из языкового файла
ParseLanguage(String, Boolean, String) | Выбор языка для загрузки из языкового файла

See Also

GlobalParams Class
GlobalParams Members
SMath.Manager Namespace


ParseLanguage Method (String, Boolean)

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ParseLanguage Method (String, Boolean)
GlobalParams Class See Also Send Feedback
Выбор языка для загрузки из языкового файла

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void ParseLanguage(
    string country,
    bool fullload
)
Visual Basic
Public Shared Sub ParseLanguage ( _
    country As String, _
    fullload As Boolean _
)
Visual C++
public:
static void ParseLanguage(
    String^ country,
    bool fullload
)
F#
static member ParseLanguage :
        country:string *
        fullload:bool -> unit

Parameters

country
Type: System..::..String
Трёхбуквенное обозначение языка (регистр значения не имеет)
fullload
Type: System..::..Boolean
Если "ложь", то проходит только проверка защиты файла, в противном случае происходит полный разбор языкового файла и загрузка из него данных

See Also

GlobalParams Class
ParseLanguage Overload
SMath.Manager Namespace


ParseLanguage Method (String, Boolean, String)

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ParseLanguage Method (String, Boolean, String)
GlobalParams Class See Also Send Feedback
Выбор языка для загрузки из языкового файла

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void ParseLanguage(
    string country,
    bool fullload,
    string path
)
Visual Basic
Public Shared Sub ParseLanguage ( _
    country As String, _
    fullload As Boolean, _
    path As String _
)
Visual C++
public:
static void ParseLanguage(
    String^ country,
    bool fullload,
    String^ path
)
F#
static member ParseLanguage :
        country:string *
        fullload:bool *
        path:string -> unit

Parameters

country
Type: System..::..String
Трёхбуквенное обозначение языка (регистр значения не имеет)
fullload
Type: System..::..Boolean
Если "ложь", то проходит только проверка защиты файла, в противном случае происходит полный разбор языкового файла и загрузка из него данных
path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:SMath.Manager.GlobalParams.ParseLanguage(System.String,System.Boolean,System.String)"]

See Also

GlobalParams Class
ParseLanguage Overload
SMath.Manager Namespace


ScreenFactorAccept Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ScreenFactorAccept Method
GlobalParams Class See Also Send Feedback
Координата в контексте свойств разрешения экрана

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int ScreenFactorAccept(
    int value
)
Visual Basic
Public Shared Function ScreenFactorAccept ( _
    value As Integer _
) As Integer
Visual C++
public:
static int ScreenFactorAccept(
    int value
)
F#
static member ScreenFactorAccept :
        value:int -> int

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Manager.GlobalParams.ScreenFactorAccept(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.GlobalParams.ScreenFactorAccept(System.Int32)"]

See Also

GlobalParams Class
SMath.Manager Namespace


SetFunctionType Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SetFunctionType Method
GlobalParams Class See Also Send Feedback
Выбор типа именования функций

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void SetFunctionType(
    string value
)
Visual Basic
Public Shared Sub SetFunctionType ( _
    value As String _
)
Visual C++
public:
static void SetFunctionType(
    String^ value
)
F#
static member SetFunctionType :
        value:string -> unit

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Manager.GlobalParams.SetFunctionType(System.String)"]

See Also

GlobalParams Class
SMath.Manager Namespace


SetLanguage Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SetLanguage Method
GlobalParams Class See Also Send Feedback
Выбор языка интерфейса по трёхбуквенному обозначению языка. Если указанного языка нет в списке доступных, будет выбран английский язык, но есои английские недоступен, то будет выбран первый же доступный язык.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static void SetLanguage(
    string value
)
Visual Basic
Public Shared Sub SetLanguage ( _
    value As String _
)
Visual C++
public:
static void SetLanguage(
    String^ value
)
F#
static member SetLanguage :
        value:string -> unit

Parameters

value
Type: System..::..String
Трёхбуквенное обозначение языка по стандарту ISO 639-2

See Also

GlobalParams Class
SMath.Manager Namespace


WebColorToColor Method

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..WebColorToColor Method
GlobalParams Class See Also Send Feedback
Converts Web Color to .Net Color. Method created, because .Net Compact Framework doesn't support System.Drawing.ColorTranslator class.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int WebColorToColor(
    string value
)
Visual Basic
Public Shared Function WebColorToColor ( _
    value As String _
) As Integer
Visual C++
public:
static int WebColorToColor(
    String^ value
)
F#
static member WebColorToColor :
        value:string -> int

Parameters

value
Type: System..::..String
Input Web Color string

Return Value

.Net Color

See Also

GlobalParams Class
SMath.Manager Namespace


GlobalParams Properties

[image] [image]

SMath Studio Class Libraries Documantation
GlobalParams Properties
GlobalParams Class See Also Send Feedback

The GlobalParams type exposes the following members.

Properties

Name | Description
ApplicationPath | Директория, из которой происходит запуск программы
DecimalSymbol |
IsPortableVersion | Попытка определения того, запущена ли программа в Portable режиме
OS | Тип текущей клиентской операционной системы на которой выполняется программа
Platform | Тип текущей клиентской платформы на которой происходит выполнение программы
ScreenDpi | Получение плотности изображения на дисплее (точки на дюйм)
ScreenResolutionFactor | Отношение разрешения экрана к стандартному значению
ScrollBarWidth | Ширина верикальной каретки прокрутки
SettingsDirectory | Get the directory where all user specific parameters will store
Units |
UnitsSpecial |

See Also

GlobalParams Class
SMath.Manager Namespace


ApplicationPath Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ApplicationPath Property
GlobalParams Class See Also Send Feedback
Директория, из которой происходит запуск программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string ApplicationPath { get; }
Visual Basic
Public Shared ReadOnly Property ApplicationPath As String
    Get
Visual C++
public:
static property String^ ApplicationPath {
    String^ get ();
}
F#
static member ApplicationPath : string

See Also

GlobalParams Class
SMath.Manager Namespace


DecimalSymbol Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..DecimalSymbol Property
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.GlobalParams.DecimalSymbol"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static char DecimalSymbol { get; set; }
Visual Basic
Public Shared Property DecimalSymbol As Char
    Get
    Set
Visual C++
public:
static property wchar_t DecimalSymbol {
    wchar_t get ();
    void set (wchar_t value);
}
F#
static member DecimalSymbol : char with get, set

See Also

GlobalParams Class
SMath.Manager Namespace


IsPortableVersion Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..IsPortableVersion Property
GlobalParams Class See Also Send Feedback
Попытка определения того, запущена ли программа в Portable режиме

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsPortableVersion { get; }
Visual Basic
Public Shared ReadOnly Property IsPortableVersion As Boolean
    Get
Visual C++
public:
static property bool IsPortableVersion {
    bool get ();
}
F#
static member IsPortableVersion : bool

See Also

GlobalParams Class
SMath.Manager Namespace


OS Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..OS Property
GlobalParams Class See Also Send Feedback
Тип текущей клиентской операционной системы на которой выполняется программа

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static OSType OS { get; }
Visual Basic
Public Shared ReadOnly Property OS As OSType
    Get
Visual C++
public:
static property OSType OS {
    OSType get ();
}
F#
static member OS : OSType

See Also

GlobalParams Class
SMath.Manager Namespace


Platform Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..Platform Property
GlobalParams Class See Also Send Feedback
Тип текущей клиентской платформы на которой происходит выполнение программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static PlatformType Platform { get; set; }
Visual Basic
Public Shared Property Platform As PlatformType
    Get
    Set
Visual C++
public:
static property PlatformType Platform {
    PlatformType get ();
    void set (PlatformType value);
}
F#
static member Platform : PlatformType with get, set

See Also

GlobalParams Class
SMath.Manager Namespace


ScreenDpi Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ScreenDpi Property
GlobalParams Class See Also Send Feedback
Получение плотности изображения на дисплее (точки на дюйм)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static double ScreenDpi { get; }
Visual Basic
Public Shared ReadOnly Property ScreenDpi As Double
    Get
Visual C++
public:
static property double ScreenDpi {
    double get ();
}
F#
static member ScreenDpi : float

See Also

GlobalParams Class
SMath.Manager Namespace


ScreenResolutionFactor Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ScreenResolutionFactor Property
GlobalParams Class See Also Send Feedback
Отношение разрешения экрана к стандартному значению

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static double ScreenResolutionFactor { get; }
Visual Basic
Public Shared ReadOnly Property ScreenResolutionFactor As Double
    Get
Visual C++
public:
static property double ScreenResolutionFactor {
    double get ();
}
F#
static member ScreenResolutionFactor : float

See Also

GlobalParams Class
SMath.Manager Namespace


ScrollBarWidth Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..ScrollBarWidth Property
GlobalParams Class See Also Send Feedback
Ширина верикальной каретки прокрутки

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int ScrollBarWidth { get; set; }
Visual Basic
Public Shared Property ScrollBarWidth As Integer
    Get
    Set
Visual C++
public:
static property int ScrollBarWidth {
    int get ();
    void set (int value);
}
F#
static member ScrollBarWidth : int with get, set

See Also

GlobalParams Class
SMath.Manager Namespace


SettingsDirectory Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..SettingsDirectory Property
GlobalParams Class See Also Send Feedback
Get the directory where all user specific parameters will store

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string SettingsDirectory { get; }
Visual Basic
Public Shared ReadOnly Property SettingsDirectory As String
    Get
Visual C++
public:
static property String^ SettingsDirectory {
    String^ get ();
}
F#
static member SettingsDirectory : string

See Also

GlobalParams Class
SMath.Manager Namespace


Units Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..Units Property
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.GlobalParams.Units"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Dictionary<string, UnitDefinition> Units { get; }
Visual Basic
Public Shared ReadOnly Property Units As Dictionary(Of String, UnitDefinition)
    Get
Visual C++
public:
static property Dictionary<String^, UnitDefinition^>^ Units {
    Dictionary<String^, UnitDefinition^>^ get ();
}
F#
static member Units : Dictionary<string, UnitDefinition>

See Also

GlobalParams Class
SMath.Manager Namespace


UnitsSpecial Property

[image]

SMath Studio Class Libraries Documantation
GlobalParams..::..UnitsSpecial Property
GlobalParams Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.GlobalParams.UnitsSpecial"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static Dictionary<string, UnitDefinition> UnitsSpecial { get; }
Visual Basic
Public Shared ReadOnly Property UnitsSpecial As Dictionary(Of String, UnitDefinition)
    Get
Visual C++
public:
static property Dictionary<String^, UnitDefinition^>^ UnitsSpecial {
    Dictionary<String^, UnitDefinition^>^ get ();
}
F#
static member UnitsSpecial : Dictionary<string, UnitDefinition>

See Also

GlobalParams Class
SMath.Manager Namespace


IPlugin Interface

[image]

SMath Studio Class Libraries Documantation
IPlugin Interface
Members See Also Send Feedback
Base Interface for SMath Studio Plugins

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public interface IPlugin : IDisposable
Visual Basic
Public Interface IPlugin _
    Inherits IDisposable
Visual C++
public interface class IPlugin : IDisposable
F#
type IPlugin =
    interface
        interface IDisposable
    end

See Also

IPlugin Members
SMath.Manager Namespace


IPlugin Members

[image] [image]

SMath Studio Class Libraries Documantation
IPlugin Members
IPlugin Interface Methods Properties See Also Send Feedback

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize

Properties

 | Name | Description
Public property | Dependences | Plugin dependences

See Also

IPlugin Interface
SMath.Manager Namespace


IPlugin Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPlugin Methods
IPlugin Interface See Also Send Feedback

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize

See Also

IPlugin Interface
SMath.Manager Namespace


Initialize Method

[image]

SMath Studio Class Libraries Documantation
IPlugin..::..Initialize Method
IPlugin Interface See Also Send Feedback
Fires on plugin initialize

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
void Initialize()
Visual Basic
Sub Initialize
Visual C++
void Initialize()
F#
abstract Initialize : unit -> unit

See Also

IPlugin Interface
SMath.Manager Namespace


IPlugin Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPlugin Properties
IPlugin Interface See Also Send Feedback

The IPlugin type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences

See Also

IPlugin Interface
SMath.Manager Namespace


Dependences Property

[image]

SMath Studio Class Libraries Documantation
IPlugin..::..Dependences Property
IPlugin Interface See Also Send Feedback
Plugin dependences

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
AssemblyInfo[] Dependences { get; }
Visual Basic
ReadOnly Property Dependences As AssemblyInfo()
    Get
Visual C++
property array<AssemblyInfo>^ Dependences {
    array<AssemblyInfo>^ get ();
}
F#
abstract Dependences : AssemblyInfo[]

See Also

IPlugin Interface
SMath.Manager Namespace


IPluginHandleEvaluation Interface

[image]

SMath Studio Class Libraries Documantation
IPluginHandleEvaluation Interface
Members See Also Send Feedback
Base Evaluation Interface for SMath Studio Plugins

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public interface IPluginHandleEvaluation : IPlugin,
    IDisposable
Visual Basic
Public Interface IPluginHandleEvaluation _
    Inherits IPlugin, IDisposable
Visual C++
public interface class IPluginHandleEvaluation : IPlugin,
    IDisposable
F#
type IPluginHandleEvaluation =
    interface
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginHandleEvaluation Members
SMath.Manager Namespace


IPluginHandleEvaluation Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleEvaluation Members
IPluginHandleEvaluation Interface Methods Properties See Also Send Feedback

The IPluginHandleEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate

See Also

IPluginHandleEvaluation Interface
SMath.Manager Namespace


IPluginHandleEvaluation Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleEvaluation Methods
IPluginHandleEvaluation Interface See Also Send Feedback

The IPluginHandleEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

See Also

IPluginHandleEvaluation Interface
SMath.Manager Namespace


IPluginHandleEvaluation Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginHandleEvaluation Properties
IPluginHandleEvaluation Interface See Also Send Feedback

The IPluginHandleEvaluation type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate

See Also

IPluginHandleEvaluation Interface
SMath.Manager Namespace


TermsHandled Property

[image]

SMath Studio Class Libraries Documantation
IPluginHandleEvaluation..::..TermsHandled Property
IPluginHandleEvaluation Interface See Also Send Feedback
List of available terms, that plugin can evaluate

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
TermInfo[] TermsHandled { get; }
Visual Basic
ReadOnly Property TermsHandled As TermInfo()
    Get
Visual C++
property array<TermInfo^>^ TermsHandled {
    array<TermInfo^>^ get ();
}
F#
abstract TermsHandled : TermInfo[]

See Also

IPluginHandleEvaluation Interface
SMath.Manager Namespace


IPluginLowLevelEvaluation Interface

[image]

SMath Studio Class Libraries Documantation
IPluginLowLevelEvaluation Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.IPluginLowLevelEvaluation"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public interface IPluginLowLevelEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
Visual Basic
Public Interface IPluginLowLevelEvaluation _
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
Visual C++
public interface class IPluginLowLevelEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
F#
type IPluginLowLevelEvaluation =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginLowLevelEvaluation Members
SMath.Manager Namespace


IPluginLowLevelEvaluation Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginLowLevelEvaluation Members
IPluginLowLevelEvaluation Interface Methods Properties See Also Send Feedback

The IPluginLowLevelEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | ExpressionEvaluation | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginLowLevelEvaluation Interface
SMath.Manager Namespace


IPluginLowLevelEvaluation Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginLowLevelEvaluation Methods
IPluginLowLevelEvaluation Interface See Also Send Feedback

The IPluginLowLevelEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | ExpressionEvaluation | Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)

See Also

IPluginLowLevelEvaluation Interface
SMath.Manager Namespace


ExpressionEvaluation Method

[image]

SMath Studio Class Libraries Documantation
IPluginLowLevelEvaluation..::..ExpressionEvaluation Method
IPluginLowLevelEvaluation Interface See Also Send Feedback
Low level calculation of the expression. Should be used, when needed in mixed calculations: Symbolic and Numeric. This functions fires before others, so it can affect on the final result.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
bool ExpressionEvaluation(
    Term root,
    Term[][] args,
    ref Store store,
    ref Term[] result
)
Visual Basic
Function ExpressionEvaluation ( _
    root As Term, _
    args As Term()(), _
    ByRef store As Store, _
    ByRef result As Term() _
) As Boolean
Visual C++
bool ExpressionEvaluation(
    Term^ root,
    array<array<Term^>^>^ args,
    Store^% store,
    array<Term^>^% result
)
F#
abstract ExpressionEvaluation :
        root:Term *
        args:Term[][] *
        store:Store byref *
        result:Term[] byref -> bool

Parameters

root
Type: SMath.Manager..::..Term
Root Term of the expression
args
Type: array<array< SMath.Manager..::..Term >[]()[][]>[]()[][]
Arguments of the root element
store
Type: SMath.Manager..::..Store %
On page definitions (variables, functions and terminators)
result
Type: array< SMath.Manager..::..Term >[]()[][]%
Evaluation result

Return Value

Indicates success of evaluation

See Also

IPluginLowLevelEvaluation Interface
SMath.Manager Namespace


IPluginLowLevelEvaluation Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginLowLevelEvaluation Properties
IPluginLowLevelEvaluation Interface See Also Send Feedback

The IPluginLowLevelEvaluation type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginLowLevelEvaluation Interface
SMath.Manager Namespace


MathMethods Class

[image]

SMath Studio Class Libraries Documantation
MathMethods Class
Members See Also Send Feedback
Вспомогательные математические методы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class MathMethods
Visual Basic
Public Class MathMethods
Visual C++
public ref class MathMethods
F#
type MathMethods =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..MathMethods

See Also

MathMethods Members
SMath.Manager Namespace


MathMethods Members

[image] [image]

SMath Studio Class Libraries Documantation
MathMethods Members
MathMethods Class Constructors Methods See Also Send Feedback

The MathMethods type exposes the following members.

Constructors

 | Name | Description
Public method | MathMethods | Initializes a new instance of the MathMethods class

Methods

Name | Description
IntToFileSize | Конвертация размера файла в строку
IsNumber | Проверка строки на возможность конвертирования в число
IsParam | Русский: Проверка символа, является ли он элементом имени параметра или нет
LongNumber(Double) |
LongNumber(String) |
LongNumberSystem |
Priority | Русский: Определение приоритета математического примитива.
SetSystemSeparator |
SetUserSeparator |

See Also

MathMethods Class
SMath.Manager Namespace


MathMethods Constructor

[image]

SMath Studio Class Libraries Documantation
MathMethods Constructor
MathMethods Class See Also Send Feedback
Initializes a new instance of the MathMethods class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public MathMethods()
Visual Basic
Public Sub New
Visual C++
public:
MathMethods()
F#
new : unit -> MathMethods

See Also

MathMethods Class
SMath.Manager Namespace


MathMethods Methods

[image] [image]

SMath Studio Class Libraries Documantation
MathMethods Methods
MathMethods Class See Also Send Feedback

The MathMethods type exposes the following members.

Methods

Name | Description
IntToFileSize | Конвертация размера файла в строку
IsNumber | Проверка строки на возможность конвертирования в число
IsParam | Русский: Проверка символа, является ли он элементом имени параметра или нет
LongNumber(Double) |
LongNumber(String) |
LongNumberSystem |
Priority | Русский: Определение приоритета математического примитива.
SetSystemSeparator |
SetUserSeparator |

See Also

MathMethods Class
SMath.Manager Namespace


IntToFileSize Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..IntToFileSize Method
MathMethods Class See Also Send Feedback
Конвертация размера файла в строку

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string IntToFileSize(
    double s
)
Visual Basic
Public Shared Function IntToFileSize ( _
    s As Double _
) As String
Visual C++
public:
static String^ IntToFileSize(
    double s
)
F#
static member IntToFileSize :
        s:float -> string

Parameters

s
Type: System..::..Double
Размер файла

Return Value

Строковый вид записи размра файла

See Also

MathMethods Class
SMath.Manager Namespace


IsNumber Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..IsNumber Method
MathMethods Class See Also Send Feedback
Проверка строки на возможность конвертирования в число

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsNumber(
    string value
)
Visual Basic
Public Shared Function IsNumber ( _
    value As String _
) As Boolean
Visual C++
public:
static bool IsNumber(
    String^ value
)
F#
static member IsNumber :
        value:string -> bool

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Manager.MathMethods.IsNumber(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.IsNumber(System.String)"]

See Also

MathMethods Class
SMath.Manager Namespace


IsParam Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..IsParam Method
MathMethods Class See Also Send Feedback
Русский: Проверка символа, является ли он элементом имени параметра или нет

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool IsParam(
    ref char value
)
Visual Basic
Public Shared Function IsParam ( _
    ByRef value As Char _
) As Boolean
Visual C++
public:
static bool IsParam(
    wchar_t% value
)
F#
static member IsParam :
        value:char byref -> bool

Parameters

value
Type: System..::..Char %
Русский: Символ для проверки

Return Value

Русский: Результат проверки символа

See Also

MathMethods Class
SMath.Manager Namespace


LongNumber Method

[image] [image]

SMath Studio Class Libraries Documantation
MathMethods..::..LongNumber Method
MathMethods Class See Also Send Feedback

Overload List

Name | Description
LongNumber(Double) |
LongNumber(String) |

See Also

MathMethods Class
MathMethods Members
SMath.Manager Namespace


LongNumber Method (Double)

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..LongNumber Method (Double)
MathMethods Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.Double)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string LongNumber(
    double D
)
Visual Basic
Public Shared Function LongNumber ( _
    D As Double _
) As String
Visual C++
public:
static String^ LongNumber(
    double D
)
F#
static member LongNumber :
        D:float -> string

Parameters

D
Type: System..::..Double

[Missing <param name="D"/> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.Double)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.Double)"]

See Also

MathMethods Class
LongNumber Overload
SMath.Manager Namespace


LongNumber Method (String)

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..LongNumber Method (String)
MathMethods Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.String)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string LongNumber(
    string D
)
Visual Basic
Public Shared Function LongNumber ( _
    D As String _
) As String
Visual C++
public:
static String^ LongNumber(
    String^ D
)
F#
static member LongNumber :
        D:string -> string

Parameters

D
Type: System..::..String

[Missing <param name="D"/> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.LongNumber(System.String)"]

See Also

MathMethods Class
LongNumber Overload
SMath.Manager Namespace


LongNumberSystem Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..LongNumberSystem Method
MathMethods Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.MathMethods.LongNumberSystem(System.Double)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string LongNumberSystem(
    double D
)
Visual Basic
Public Shared Function LongNumberSystem ( _
    D As Double _
) As String
Visual C++
public:
static String^ LongNumberSystem(
    double D
)
F#
static member LongNumberSystem :
        D:float -> string

Parameters

D
Type: System..::..Double

[Missing <param name="D"/> documentation for "M:SMath.Manager.MathMethods.LongNumberSystem(System.Double)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.LongNumberSystem(System.Double)"]

See Also

MathMethods Class
SMath.Manager Namespace


Priority Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..Priority Method
MathMethods Class See Also Send Feedback
Русский: Определение приоритета математического примитива.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static int Priority(
    string value
)
Visual Basic
Public Shared Function Priority ( _
    value As String _
) As Integer
Visual C++
public:
static int Priority(
    String^ value
)
F#
static member Priority :
        value:string -> int

Parameters

value
Type: System..::..String
Русский: Текстовое представление примитива

Return Value

Русский: Приоритет математического примитива

See Also

MathMethods Class
SMath.Manager Namespace


SetSystemSeparator Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..SetSystemSeparator Method
MathMethods Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.MathMethods.SetSystemSeparator(System.String)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string SetSystemSeparator(
    string value
)
Visual Basic
Public Shared Function SetSystemSeparator ( _
    value As String _
) As String
Visual C++
public:
static String^ SetSystemSeparator(
    String^ value
)
F#
static member SetSystemSeparator :
        value:string -> string

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Manager.MathMethods.SetSystemSeparator(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.SetSystemSeparator(System.String)"]

See Also

MathMethods Class
SMath.Manager Namespace


SetUserSeparator Method

[image]

SMath Studio Class Libraries Documantation
MathMethods..::..SetUserSeparator Method
MathMethods Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.MathMethods.SetUserSeparator(System.String)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string SetUserSeparator(
    string value
)
Visual Basic
Public Shared Function SetUserSeparator ( _
    value As String _
) As String
Visual C++
public:
static String^ SetUserSeparator(
    String^ value
)
F#
static member SetUserSeparator :
        value:string -> string

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:SMath.Manager.MathMethods.SetUserSeparator(System.String)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.MathMethods.SetUserSeparator(System.String)"]

See Also

MathMethods Class
SMath.Manager Namespace


Operator Structure

[image]

SMath Studio Class Libraries Documantation
Operator Structure
Members See Also Send Feedback
Доступные встроенные операторы программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public struct Operator
Visual Basic
Public Structure Operator
Visual C++
public value class Operator
F#
[<SealedAttribute>]
type Operator =  struct end

See Also

Operator Members
SMath.Manager Namespace


Operator Members

[image] [image]

SMath Studio Class Libraries Documantation
Operator Members
Operator Structure Fields Properties See Also Send Feedback

The Operator type exposes the following members.

Fields

Name | Description
BooleanAnd | Булево "и"
BooleanEqual | Булево "равно"
BooleanLess | Булево "строго меньше"
BooleanLessOrEqual | Булево "меньше либо равно"
BooleanMore | Булево "строго больше"
BooleanMoreOrEqual | Булево "больше либо равно"
BooleanNot | Булево "не"
BooleanNotEqual | Булево "неравно"
BooleanOr | Булево "или"
BooleanXor | Булево "исключающее или"
Composition | Оператор сложения
Definition | Присвоение
DefinitionOld | Присвоение (старый)
Division | Оператор деления
EmptyOperator | Пустой оператор
Exponentiation | Возведение в степень
Factorial | Факториал
MinusPlus | Оператор "минус/плюс"
Multiplication | Оператор скалярного умножения
NumericEqual | Оператор численного вычисления
PlusMinus | Оператор "плюс/минус"
Substraction | Оператор вычитания
SymbolicEqual | Оператор символьного вычисления
UnitOperator | Оператор единиц измерения
VectorMultiplication | Оператор векторного умножения

Properties

Name | Description
GetArray | Получить массив всех поддерживаемых операторов программы

See Also

Operator Structure
SMath.Manager Namespace


Operator Fields

[image] [image]

SMath Studio Class Libraries Documantation
Operator Fields
Operator Structure See Also Send Feedback

The Operator type exposes the following members.

Fields

Name | Description
BooleanAnd | Булево "и"
BooleanEqual | Булево "равно"
BooleanLess | Булево "строго меньше"
BooleanLessOrEqual | Булево "меньше либо равно"
BooleanMore | Булево "строго больше"
BooleanMoreOrEqual | Булево "больше либо равно"
BooleanNot | Булево "не"
BooleanNotEqual | Булево "неравно"
BooleanOr | Булево "или"
BooleanXor | Булево "исключающее или"
Composition | Оператор сложения
Definition | Присвоение
DefinitionOld | Присвоение (старый)
Division | Оператор деления
EmptyOperator | Пустой оператор
Exponentiation | Возведение в степень
Factorial | Факториал
MinusPlus | Оператор "минус/плюс"
Multiplication | Оператор скалярного умножения
NumericEqual | Оператор численного вычисления
PlusMinus | Оператор "плюс/минус"
Substraction | Оператор вычитания
SymbolicEqual | Оператор символьного вычисления
UnitOperator | Оператор единиц измерения
VectorMultiplication | Оператор векторного умножения

See Also

Operator Structure
SMath.Manager Namespace


BooleanAnd Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanAnd Field
Operator Structure See Also Send Feedback
Булево "и"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanAnd
Visual Basic
Public Const BooleanAnd As String
Visual C++
public:
literal String^ BooleanAnd
F#
static val mutable BooleanAnd: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanEqual Field
Operator Structure See Also Send Feedback
Булево "равно"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanEqual
Visual Basic
Public Const BooleanEqual As String
Visual C++
public:
literal String^ BooleanEqual
F#
static val mutable BooleanEqual: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanLess Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanLess Field
Operator Structure See Also Send Feedback
Булево "строго меньше"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanLess
Visual Basic
Public Const BooleanLess As String
Visual C++
public:
literal String^ BooleanLess
F#
static val mutable BooleanLess: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanLessOrEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanLessOrEqual Field
Operator Structure See Also Send Feedback
Булево "меньше либо равно"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanLessOrEqual
Visual Basic
Public Const BooleanLessOrEqual As String
Visual C++
public:
literal String^ BooleanLessOrEqual
F#
static val mutable BooleanLessOrEqual: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanMore Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanMore Field
Operator Structure See Also Send Feedback
Булево "строго больше"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanMore
Visual Basic
Public Const BooleanMore As String
Visual C++
public:
literal String^ BooleanMore
F#
static val mutable BooleanMore: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanMoreOrEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanMoreOrEqual Field
Operator Structure See Also Send Feedback
Булево "больше либо равно"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanMoreOrEqual
Visual Basic
Public Const BooleanMoreOrEqual As String
Visual C++
public:
literal String^ BooleanMoreOrEqual
F#
static val mutable BooleanMoreOrEqual: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanNot Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanNot Field
Operator Structure See Also Send Feedback
Булево "не"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanNot
Visual Basic
Public Const BooleanNot As String
Visual C++
public:
literal String^ BooleanNot
F#
static val mutable BooleanNot: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanNotEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanNotEqual Field
Operator Structure See Also Send Feedback
Булево "неравно"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanNotEqual
Visual Basic
Public Const BooleanNotEqual As String
Visual C++
public:
literal String^ BooleanNotEqual
F#
static val mutable BooleanNotEqual: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanOr Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanOr Field
Operator Structure See Also Send Feedback
Булево "или"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanOr
Visual Basic
Public Const BooleanOr As String
Visual C++
public:
literal String^ BooleanOr
F#
static val mutable BooleanOr: string

See Also

Operator Structure
SMath.Manager Namespace


BooleanXor Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..BooleanXor Field
Operator Structure See Also Send Feedback
Булево "исключающее или"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string BooleanXor
Visual Basic
Public Const BooleanXor As String
Visual C++
public:
literal String^ BooleanXor
F#
static val mutable BooleanXor: string

See Also

Operator Structure
SMath.Manager Namespace


Composition Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Composition Field
Operator Structure See Also Send Feedback
Оператор сложения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Composition
Visual Basic
Public Const Composition As String
Visual C++
public:
literal String^ Composition
F#
static val mutable Composition: string

See Also

Operator Structure
SMath.Manager Namespace


Definition Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Definition Field
Operator Structure See Also Send Feedback
Присвоение

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Definition
Visual Basic
Public Const Definition As String
Visual C++
public:
literal String^ Definition
F#
static val mutable Definition: string

See Also

Operator Structure
SMath.Manager Namespace


DefinitionOld Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..DefinitionOld Field
Operator Structure See Also Send Feedback
Присвоение (старый)

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string DefinitionOld
Visual Basic
Public Const DefinitionOld As String
Visual C++
public:
literal String^ DefinitionOld
F#
static val mutable DefinitionOld: string

See Also

Operator Structure
SMath.Manager Namespace


Division Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Division Field
Operator Structure See Also Send Feedback
Оператор деления

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Division
Visual Basic
Public Const Division As String
Visual C++
public:
literal String^ Division
F#
static val mutable Division: string

See Also

Operator Structure
SMath.Manager Namespace


EmptyOperator Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..EmptyOperator Field
Operator Structure See Also Send Feedback
Пустой оператор

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string EmptyOperator
Visual Basic
Public Const EmptyOperator As String
Visual C++
public:
literal String^ EmptyOperator
F#
static val mutable EmptyOperator: string

See Also

Operator Structure
SMath.Manager Namespace


Exponentiation Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Exponentiation Field
Operator Structure See Also Send Feedback
Возведение в степень

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Exponentiation
Visual Basic
Public Const Exponentiation As String
Visual C++
public:
literal String^ Exponentiation
F#
static val mutable Exponentiation: string

See Also

Operator Structure
SMath.Manager Namespace


Factorial Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Factorial Field
Operator Structure See Also Send Feedback
Факториал

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Factorial
Visual Basic
Public Const Factorial As String
Visual C++
public:
literal String^ Factorial
F#
static val mutable Factorial: string

See Also

Operator Structure
SMath.Manager Namespace


MinusPlus Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..MinusPlus Field
Operator Structure See Also Send Feedback
Оператор "минус/плюс"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string MinusPlus
Visual Basic
Public Const MinusPlus As String
Visual C++
public:
literal String^ MinusPlus
F#
static val mutable MinusPlus: string

See Also

Operator Structure
SMath.Manager Namespace


Multiplication Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Multiplication Field
Operator Structure See Also Send Feedback
Оператор скалярного умножения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Multiplication
Visual Basic
Public Const Multiplication As String
Visual C++
public:
literal String^ Multiplication
F#
static val mutable Multiplication: string

See Also

Operator Structure
SMath.Manager Namespace


NumericEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..NumericEqual Field
Operator Structure See Also Send Feedback
Оператор численного вычисления

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string NumericEqual
Visual Basic
Public Const NumericEqual As String
Visual C++
public:
literal String^ NumericEqual
F#
static val mutable NumericEqual: string

See Also

Operator Structure
SMath.Manager Namespace


PlusMinus Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..PlusMinus Field
Operator Structure See Also Send Feedback
Оператор "плюс/минус"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string PlusMinus
Visual Basic
Public Const PlusMinus As String
Visual C++
public:
literal String^ PlusMinus
F#
static val mutable PlusMinus: string

See Also

Operator Structure
SMath.Manager Namespace


Substraction Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..Substraction Field
Operator Structure See Also Send Feedback
Оператор вычитания

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Substraction
Visual Basic
Public Const Substraction As String
Visual C++
public:
literal String^ Substraction
F#
static val mutable Substraction: string

See Also

Operator Structure
SMath.Manager Namespace


SymbolicEqual Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..SymbolicEqual Field
Operator Structure See Also Send Feedback
Оператор символьного вычисления

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string SymbolicEqual
Visual Basic
Public Const SymbolicEqual As String
Visual C++
public:
literal String^ SymbolicEqual
F#
static val mutable SymbolicEqual: string

See Also

Operator Structure
SMath.Manager Namespace


UnitOperator Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..UnitOperator Field
Operator Structure See Also Send Feedback
Оператор единиц измерения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string UnitOperator
Visual Basic
Public Const UnitOperator As String
Visual C++
public:
literal String^ UnitOperator
F#
static val mutable UnitOperator: string

See Also

Operator Structure
SMath.Manager Namespace


VectorMultiplication Field

[image]

SMath Studio Class Libraries Documantation
Operator..::..VectorMultiplication Field
Operator Structure See Also Send Feedback
Оператор векторного умножения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string VectorMultiplication
Visual Basic
Public Const VectorMultiplication As String
Visual C++
public:
literal String^ VectorMultiplication
F#
static val mutable VectorMultiplication: string

See Also

Operator Structure
SMath.Manager Namespace


Operator Properties

[image] [image]

SMath Studio Class Libraries Documantation
Operator Properties
Operator Structure See Also Send Feedback

The Operator type exposes the following members.

Properties

Name | Description
GetArray | Получить массив всех поддерживаемых операторов программы

See Also

Operator Structure
SMath.Manager Namespace


GetArray Property

[image]

SMath Studio Class Libraries Documantation
Operator..::..GetArray Property
Operator Structure See Also Send Feedback
Получить массив всех поддерживаемых операторов программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string[] GetArray { get; }
Visual Basic
Public Shared ReadOnly Property GetArray As String()
    Get
Visual C++
public:
static property array<String^>^ GetArray {
    array<String^>^ get ();
}
F#
static member GetArray : string[]

See Also

Operator Structure
SMath.Manager Namespace


OptimizationType Enumeration

[image]

SMath Studio Class Libraries Documantation
OptimizationType Enumeration
See Also Send Feedback
English: Evaluation optimization type.
Русский: Тип оптимизации вычисления.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum OptimizationType
Visual Basic
Public Enumeration OptimizationType
Visual C++
public enum class OptimizationType
F#
type OptimizationType

Members

Member name | Value | Description
None | 0 | English: Without optimization. Русский: Без оптимизации.
Symbolic | 1 | English: Symbolic optimization. Русский: Символьная оптимизация.
Numeric | 2 | English: Numeric optimization. Русский: Численная оптимизация.

See Also

SMath.Manager Namespace


OSType Enumeration

[image]

SMath Studio Class Libraries Documantation
OSType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.OSType"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum OSType
Visual Basic
Public Enumeration OSType
Visual C++
public enum class OSType
F#
type OSType

Members

Member name | Value | Description
NotDefined | 0 |
Windows | 1 |
Linux | 2 |

See Also

SMath.Manager Namespace


PlatformType Enumeration

[image]

SMath Studio Class Libraries Documantation
PlatformType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.PlatformType"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum PlatformType
Visual Basic
Public Enumeration PlatformType
Visual C++
public enum class PlatformType
F#
type PlatformType

Members

Member name | Value | Description
NotDefined | 0 |
PC | 1 |
PPC | 2 |
Smartphone | 3 |

See Also

SMath.Manager Namespace


PluginInfo Class

[image]

SMath Studio Class Libraries Documantation
PluginInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.PluginInfo"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class PluginInfo
Visual Basic
Public Class PluginInfo
Visual C++
public ref class PluginInfo
F#
type PluginInfo =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..PluginInfo

See Also

PluginInfo Members
SMath.Manager Namespace


PluginInfo Members

[image] [image]

SMath Studio Class Libraries Documantation
PluginInfo Members
PluginInfo Class Constructors Properties See Also Send Feedback

The PluginInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PluginInfo | Constructor of the Plugin Information class

Properties

 | Name | Description
Public property | Enabled | Defines if the Plugin is used by SMath Studio
Public property | Info | Plugin detailed information from assembly
Public property | Location | Full name of the Plugin main assembly file
Public property | Plugin | Plugin implementation

See Also

PluginInfo Class
SMath.Manager Namespace


PluginInfo Constructor

[image]

SMath Studio Class Libraries Documantation
PluginInfo Constructor
PluginInfo Class See Also Send Feedback
Constructor of the Plugin Information class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public PluginInfo(
    IPlugin plugin,
    AssemblyInfo info,
    string location
)
Visual Basic
Public Sub New ( _
    plugin As IPlugin, _
    info As AssemblyInfo, _
    location As String _
)
Visual C++
public:
PluginInfo(
    IPlugin^ plugin,
    AssemblyInfo info,
    String^ location
)
F#
new :
        plugin:IPlugin *
        info:AssemblyInfo *
        location:string -> PluginInfo

Parameters

plugin
Type: SMath.Manager..::..IPlugin
Plugin implementation
info
Type: SMath.Manager..::..AssemblyInfo
Plugin detailed information from assembly
location
Type: System..::..String
Full name of the Plugin main assembly file

See Also

PluginInfo Class
SMath.Manager Namespace


PluginInfo Properties

[image] [image]

SMath Studio Class Libraries Documantation
PluginInfo Properties
PluginInfo Class See Also Send Feedback

The PluginInfo type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Defines if the Plugin is used by SMath Studio
Public property | Info | Plugin detailed information from assembly
Public property | Location | Full name of the Plugin main assembly file
Public property | Plugin | Plugin implementation

See Also

PluginInfo Class
SMath.Manager Namespace


Enabled Property

[image]

SMath Studio Class Libraries Documantation
PluginInfo..::..Enabled Property
PluginInfo Class See Also Send Feedback
Defines if the Plugin is used by SMath Studio

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
F#
member Enabled : bool with get, set

See Also

PluginInfo Class
SMath.Manager Namespace


Info Property

[image]

SMath Studio Class Libraries Documantation
PluginInfo..::..Info Property
PluginInfo Class See Also Send Feedback
Plugin detailed information from assembly

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public AssemblyInfo Info { get; }
Visual Basic
Public ReadOnly Property Info As AssemblyInfo
    Get
Visual C++
public:
property AssemblyInfo Info {
    AssemblyInfo get ();
}
F#
member Info : AssemblyInfo

See Also

PluginInfo Class
SMath.Manager Namespace


Location Property

[image]

SMath Studio Class Libraries Documantation
PluginInfo..::..Location Property
PluginInfo Class See Also Send Feedback
Full name of the Plugin main assembly file

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Location { get; }
Visual Basic
Public ReadOnly Property Location As String
    Get
Visual C++
public:
property String^ Location {
    String^ get ();
}
F#
member Location : string

See Also

PluginInfo Class
SMath.Manager Namespace


Plugin Property

[image]

SMath Studio Class Libraries Documantation
PluginInfo..::..Plugin Property
PluginInfo Class See Also Send Feedback
Plugin implementation

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public IPlugin Plugin { get; }
Visual Basic
Public ReadOnly Property Plugin As IPlugin
    Get
Visual C++
public:
property IPlugin^ Plugin {
    IPlugin^ get ();
}
F#
member Plugin : IPlugin

See Also

PluginInfo Class
SMath.Manager Namespace


Plugins Class

[image]

SMath Studio Class Libraries Documantation
Plugins Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.Plugins"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Plugins
Visual Basic
Public Class Plugins
Visual C++
public ref class Plugins
F#
type Plugins =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Plugins

See Also

Plugins Members
SMath.Manager Namespace


Plugins Members

[image] [image]

SMath Studio Class Libraries Documantation
Plugins Members
Plugins Class Constructors Methods See Also Send Feedback

The Plugins type exposes the following members.

Constructors

 | Name | Description
Public method | Plugins | Initializes a new instance of the Plugins class

Methods

Name | Description
GetPluginsHash |
Load | Loads all available Plugins from the specific directory
LoadOne | Loads Plugin from the specific location

See Also

Plugins Class
SMath.Manager Namespace


Plugins Constructor

[image]

SMath Studio Class Libraries Documantation
Plugins Constructor
Plugins Class See Also Send Feedback
Initializes a new instance of the Plugins class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Plugins()
Visual Basic
Public Sub New
Visual C++
public:
Plugins()
F#
new : unit -> Plugins

See Also

Plugins Class
SMath.Manager Namespace


Plugins Methods

[image] [image]

SMath Studio Class Libraries Documantation
Plugins Methods
Plugins Class See Also Send Feedback

The Plugins type exposes the following members.

Methods

Name | Description
GetPluginsHash |
Load | Loads all available Plugins from the specific directory
LoadOne | Loads Plugin from the specific location

See Also

Plugins Class
SMath.Manager Namespace


GetPluginsHash Method

[image]

SMath Studio Class Libraries Documantation
Plugins..::..GetPluginsHash Method
Plugins Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.Plugins.GetPluginsHash"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static string GetPluginsHash()
Visual Basic
Public Shared Function GetPluginsHash As String
Visual C++
public:
static String^ GetPluginsHash()
F#
static member GetPluginsHash : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Manager.Plugins.GetPluginsHash"]

See Also

Plugins Class
SMath.Manager Namespace


Load Method

[image]

SMath Studio Class Libraries Documantation
Plugins..::..Load Method
Plugins Class See Also Send Feedback
Loads all available Plugins from the specific directory

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static List<PluginInfo> Load(
    string path
)
Visual Basic
Public Shared Function Load ( _
    path As String _
) As List(Of PluginInfo)
Visual C++
public:
static List<PluginInfo^>^ Load(
    String^ path
)
F#
static member Load :
        path:string -> List<PluginInfo>

Parameters

path
Type: System..::..String
Path to the plugins

Return Value

A list of plugins found

See Also

Plugins Class
SMath.Manager Namespace


LoadOne Method

[image]

SMath Studio Class Libraries Documantation
Plugins..::..LoadOne Method
Plugins Class See Also Send Feedback
Loads Plugin from the specific location

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static List<PluginInfo> LoadOne(
    string fileName
)
Visual Basic
Public Shared Function LoadOne ( _
    fileName As String _
) As List(Of PluginInfo)
Visual C++
public:
static List<PluginInfo^>^ LoadOne(
    String^ fileName
)
F#
static member LoadOne :
        fileName:string -> List<PluginInfo>

Parameters

fileName
Type: System..::..String
Full file name

Return Value

A list of plugins found

See Also

Plugins Class
SMath.Manager Namespace


Store Class

[image]

SMath Studio Class Libraries Documantation
Store Class
Members See Also Send Feedback
English: Evaluation context. Data type that stores all information about variables, arguments and functions definitions. Definitions represented as a stack.
Русский: Контекст вычисления. Тип данных, который хранит в себе информацию об объявленных функциях и переменных. В Store все объявления записываются по типу стэка, но есть особенности. В Store есть две коллекции: Share - публичная - это то, что приходит для вычисления вместе с заданием, т.е. это все объявления функций и переменных на листе ДО текущего выражения. А если в процессе вычисления текущего выражения встретится оператор присваивания (:=), то программа к Share добавляет новое вхождение, но так же она добавляет это же вхождение и в Local. Local - это только присвоения текущего выражения (они нужны, что б потом из них сформировать правильный Share для следующих выражений). Вообще Store имеет все методы, которые позволяют абстрагироваться от Share и Local: добавление новой переменной - AddDefinition или терминатора (заглушки) - AddTerminator (у каждого Definition есть признаки IsTerminator и IsFunction). Значение Terminator можно показать на примере дифференцирования. Например есть выражение a*x и необходимо продифференцировать его по x. Допустим также, что над текущим выражением обе эти переменные уже объявлены какими-то числовыми значениями. Чтобы заменить "а" на число, но не заменять "x", нам нужно добавить терминатор "x", но важно не забывать, что терминатры нужны только в процессе вычисления функции, т.е. если терминатор поставлен вручную, то он должен быть также вручную удалён, сразу после обработки текущей функции. Если продолжать аналогию, то терминатор в нашем примере важно удалить, что бы после дифференцирования подстановка "x" всё же состаялась и на выходе был численный ответ.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Store
Visual Basic
Public Class Store
Visual C++
public ref class Store
F#
type Store =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Store

See Also

Store Members
SMath.Manager Namespace


Store Members

[image] [image]

SMath Studio Class Libraries Documantation
Store Members
Store Class Constructors Methods Properties See Also Send Feedback

The Store type exposes the following members.

Constructors

 | Name | Description
Public method | Store | English: Constructor of context-class Store. Русский: Конструктор класса-контекста Store.

Methods

 | Name | Description
Public method | AddDefinition | English: Add new variable or function to the definitions list. Русский: Добавляет новую переменную или функцию к списку определений.
Public method | AddDependence | English: Add dependence from specific plugin. Русский: Добавление зависимости текущего вычисления от дополнения (плагина).
Public method | AddTerminator | English: Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition. Русский: Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.
Public method | RemoveAt | English: Removes Definition at the specific position of the shared list. Русский: Удаляет определение из публичного списка по указанноми индексу.
Public method | RemoveRange | English: Removes Definitions of the specific range of the shared list. Русский: Удаление определений из публичного списка в указанном диапазоне.

Properties

 | Name | Description
Public property | Count | English: Number of Shared definitions. Русский: Количество публичных определений.
Public property | Dependences | English: All plugin dependences for the current expression evaluation. Русский: Содержит список дополнений (плагинов), учавствовавших в процессе текущего вычисления.
Public property | Item | English: Returns a definition by the index from the shared definition collection. Русский: Возвращает определение по индексу из публичной коллекции присваиваний.
Public property | Local | English: Only definitions that was created by current expression. Русский: Содержит список определений, созданных в процессе текущего вычисления.
Public property | Optimize | English: Defines if right part of the definition should be optimized using Symbolic Library. Русский: Опеределяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.
Public property | Shared | English: All definitions for the current expression evaluation. Русский: Содержит список всех определений применительно к текущему вычислению.

See Also

Store Class
SMath.Manager Namespace


Store Constructor

[image]

SMath Studio Class Libraries Documantation
Store Constructor
Store Class See Also Send Feedback
English: Constructor of context-class Store.
Русский: Конструктор класса-контекста Store.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Store()
Visual Basic
Public Sub New
Visual C++
public:
Store()
F#
new : unit -> Store

See Also

Store Class
SMath.Manager Namespace


Store Methods

[image] [image]

SMath Studio Class Libraries Documantation
Store Methods
Store Class See Also Send Feedback

The Store type exposes the following members.

Methods

 | Name | Description
Public method | AddDefinition | English: Add new variable or function to the definitions list. Русский: Добавляет новую переменную или функцию к списку определений.
Public method | AddDependence | English: Add dependence from specific plugin. Русский: Добавление зависимости текущего вычисления от дополнения (плагина).
Public method | AddTerminator | English: Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition. Русский: Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.
Public method | RemoveAt | English: Removes Definition at the specific position of the shared list. Русский: Удаляет определение из публичного списка по указанноми индексу.
Public method | RemoveRange | English: Removes Definitions of the specific range of the shared list. Русский: Удаление определений из публичного списка в указанном диапазоне.

See Also

Store Class
SMath.Manager Namespace


AddDefinition Method

[image]

SMath Studio Class Libraries Documantation
Store..::..AddDefinition Method
Store Class See Also Send Feedback
English: Add new variable or function to the definitions list.
Русский: Добавляет новую переменную или функцию к списку определений.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void AddDefinition(
    string name,
    Term[] answer,
    Term[] variables
)
Visual Basic
Public Sub AddDefinition ( _
    name As String, _
    answer As Term(), _
    variables As Term() _
)
Visual C++
public:
void AddDefinition(
    String^ name,
    array<Term^>^ answer,
    array<Term^>^ variables
)
F#
member AddDefinition :
        name:string *
        answer:Term[] *
        variables:Term[] -> unit

Parameters

name
Type: System..::..String
English: Name of the new definition.
Русский: Имя компоненты для определения.
answer
Type: array< SMath.Manager..::..Term >[]()[][]
English: Answer, i.e. value of definition.
Русский: Результат, ассоциированный с компонентой.
variables
Type: array< SMath.Manager..::..Term >[]()[][]
English: If function, then a list of variables should be defined.
Русский: Если определяется функция, то должен быть указан список её аргументов.

See Also

Store Class
SMath.Manager Namespace


AddDependence Method

[image]

SMath Studio Class Libraries Documantation
Store..::..AddDependence Method
Store Class See Also Send Feedback
English: Add dependence from specific plugin.
Русский: Добавление зависимости текущего вычисления от дополнения (плагина).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void AddDependence(
    AssemblyInfo info
)
Visual Basic
Public Sub AddDependence ( _
    info As AssemblyInfo _
)
Visual C++
public:
void AddDependence(
    AssemblyInfo info
)
F#
member AddDependence :
        info:AssemblyInfo -> unit

Parameters

info
Type: SMath.Manager..::..AssemblyInfo
English: Plugin information.
Русский: Информация о дополнеии (плагине).

See Also

Store Class
SMath.Manager Namespace


AddTerminator Method

[image]

SMath Studio Class Libraries Documantation
Store..::..AddTerminator Method
Store Class See Also Send Feedback
English: Add a variable Terminator to the shared list of definitions. Substitution will break if stumble on the Terminator definition.
Русский: Добавляет заглушку (терминатор) в публичный список подстановок. Подстановка будет остановлена в процессе вычисления, если в стэке встретится заглушка.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void AddTerminator(
    Term term
)
Visual Basic
Public Sub AddTerminator ( _
    term As Term _
)
Visual C++
public:
void AddTerminator(
    Term^ term
)
F#
member AddTerminator :
        term:Term -> unit

Parameters

term
Type: SMath.Manager..::..Term
English: Terminator options.
Русский: Свойства заглушки.

See Also

Store Class
SMath.Manager Namespace


RemoveAt Method

[image]

SMath Studio Class Libraries Documantation
Store..::..RemoveAt Method
Store Class See Also Send Feedback
English: Removes Definition at the specific position of the shared list.
Русский: Удаляет определение из публичного списка по указанноми индексу.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)
F#
member RemoveAt :
        index:int -> unit

Parameters

index
Type: System..::..Int32
English: Position of the Definition to remove.
Русский: Позиция определения в списке.

See Also

Store Class
SMath.Manager Namespace


RemoveRange Method

[image]

SMath Studio Class Libraries Documantation
Store..::..RemoveRange Method
Store Class See Also Send Feedback
English: Removes Definitions of the specific range of the shared list.
Русский: Удаление определений из публичного списка в указанном диапазоне.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void RemoveRange(
    int index,
    int count
)
Visual Basic
Public Sub RemoveRange ( _
    index As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int index,
    int count
)
F#
member RemoveRange :
        index:int *
        count:int -> unit

Parameters

index
Type: System..::..Int32
English: Start index of the Definitions to remove.
Русский: Стартовая позиция в диапазоне определений.
count
Type: System..::..Int32
English: Count of the Definitions to remove.
Русский: Количество определений для удаления.

See Also

Store Class
SMath.Manager Namespace


Store Properties

[image] [image]

SMath Studio Class Libraries Documantation
Store Properties
Store Class See Also Send Feedback

The Store type exposes the following members.

Properties

 | Name | Description
Public property | Count | English: Number of Shared definitions. Русский: Количество публичных определений.
Public property | Dependences | English: All plugin dependences for the current expression evaluation. Русский: Содержит список дополнений (плагинов), учавствовавших в процессе текущего вычисления.
Public property | Item | English: Returns a definition by the index from the shared definition collection. Русский: Возвращает определение по индексу из публичной коллекции присваиваний.
Public property | Local | English: Only definitions that was created by current expression. Русский: Содержит список определений, созданных в процессе текущего вычисления.
Public property | Optimize | English: Defines if right part of the definition should be optimized using Symbolic Library. Русский: Опеределяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.
Public property | Shared | English: All definitions for the current expression evaluation. Русский: Содержит список всех определений применительно к текущему вычислению.

See Also

Store Class
SMath.Manager Namespace


Count Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Count Property
Store Class See Also Send Feedback
English: Number of Shared definitions.
Русский: Количество публичных определений.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}
F#
member Count : int

See Also

Store Class
SMath.Manager Namespace


Dependences Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Dependences Property
Store Class See Also Send Feedback
English: All plugin dependences for the current expression evaluation.
Русский: Содержит список дополнений (плагинов), учавствовавших в процессе текущего вычисления.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public List<AssemblyInfo> Dependences { get; }
Visual Basic
Public ReadOnly Property Dependences As List(Of AssemblyInfo)
    Get
Visual C++
public:
property List<AssemblyInfo>^ Dependences {
    List<AssemblyInfo>^ get ();
}
F#
member Dependences : List<AssemblyInfo>

See Also

Store Class
SMath.Manager Namespace


Item Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Item Property
Store Class See Also Send Feedback
English: Returns a definition by the index from the shared definition collection.
Русский: Возвращает определение по индексу из публичной коллекции присваиваний.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Definition this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    index As Integer _
) As Definition
    Get
Visual C++
public:
property Definition^ Item[int index] {
    Definition^ get (int index);
}
F#
member Item : Definition

Parameters

index
Type: System..::..Int32
English: Index of the definition.
Русский: Индекс определения.

Return Value

English: Definition by index.
Русский: Определение по индексу.

See Also

Store Class
SMath.Manager Namespace


Local Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Local Property
Store Class See Also Send Feedback
English: Only definitions that was created by current expression.
Русский: Содержит список определений, созданных в процессе текущего вычисления.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public List<Definition> Local { get; }
Visual Basic
Public ReadOnly Property Local As List(Of Definition)
    Get
Visual C++
public:
property List<Definition^>^ Local {
    List<Definition^>^ get ();
}
F#
member Local : List<Definition>

See Also

Store Class
SMath.Manager Namespace


Optimize Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Optimize Property
Store Class See Also Send Feedback
English: Defines if right part of the definition should be optimized using Symbolic Library.
Русский: Опеределяет тип оптимизации, который должен быть применён к правым частям выражений при присваивании.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public OptimizationType Optimize { get; set; }
Visual Basic
Public Property Optimize As OptimizationType
    Get
    Set
Visual C++
public:
property OptimizationType Optimize {
    OptimizationType get ();
    void set (OptimizationType value);
}
F#
member Optimize : OptimizationType with get, set

See Also

Store Class
SMath.Manager Namespace


Shared Property

[image]

SMath Studio Class Libraries Documantation
Store..::..Shared Property
Store Class See Also Send Feedback
English: All definitions for the current expression evaluation.
Русский: Содержит список всех определений применительно к текущему вычислению.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public List<Definition> Shared { get; }
Visual Basic
Public ReadOnly Property Shared As List(Of Definition)
    Get
Visual C++
public:
property List<Definition^>^ Shared {
    List<Definition^>^ get ();
}
F#
member Shared : List<Definition>

See Also

Store Class
SMath.Manager Namespace


Symbol Structure

[image]

SMath Studio Class Libraries Documantation
Symbol Structure
Members See Also Send Feedback
Доступные встроенные символы программы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public struct Symbol
Visual Basic
Public Structure Symbol
Visual C++
public value class Symbol
F#
[<SealedAttribute>]
type Symbol =  struct end

See Also

Symbol Members
SMath.Manager Namespace


Symbol Members

[image] [image]

SMath Studio Class Libraries Documantation
Symbol Members
Symbol Structure Fields See Also Send Feedback

The Symbol type exposes the following members.

Fields

Name | Description
EmptyOperand | Пустой (незаполненный) операнд
Infinity | Бесконечность

See Also

Symbol Structure
SMath.Manager Namespace


Symbol Fields

[image] [image]

SMath Studio Class Libraries Documantation
Symbol Fields
Symbol Structure See Also Send Feedback

The Symbol type exposes the following members.

Fields

Name | Description
EmptyOperand | Пустой (незаполненный) операнд
Infinity | Бесконечность

See Also

Symbol Structure
SMath.Manager Namespace


EmptyOperand Field

[image]

SMath Studio Class Libraries Documantation
Symbol..::..EmptyOperand Field
Symbol Structure See Also Send Feedback
Пустой (незаполненный) операнд

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string EmptyOperand
Visual Basic
Public Const EmptyOperand As String
Visual C++
public:
literal String^ EmptyOperand
F#
static val mutable EmptyOperand: string

See Also

Symbol Structure
SMath.Manager Namespace


Infinity Field

[image]

SMath Studio Class Libraries Documantation
Symbol..::..Infinity Field
Symbol Structure See Also Send Feedback
Бесконечность

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public const string Infinity
Visual Basic
Public Const Infinity As String
Visual C++
public:
literal String^ Infinity
F#
static val mutable Infinity: string

See Also

Symbol Structure
SMath.Manager Namespace


SysSettings Enumeration

[image]

SMath Studio Class Libraries Documantation
SysSettings Enumeration
See Also Send Feedback
Тип отображения системы

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum SysSettings
Visual Basic
Public Enumeration SysSettings
Visual C++
public enum class SysSettings
F#
type SysSettings

Members

Member name | Value | Description
None | 0 | Показывать все строки системы
UnRepeatable | 1 | Показывать только уникальные строки системы

See Also

SMath.Manager Namespace


Term Class

[image]

SMath Studio Class Libraries Documantation
Term Class
Members See Also Send Feedback
English: Expression component.
Русский: Компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class Term
Visual Basic
Public Class Term
Visual C++
public ref class Term
F#
type Term =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..Term

See Also

Term Members
SMath.Manager Namespace


Term Members

[image] [image]

SMath Studio Class Libraries Documantation
Term Members
Term Class Constructors Methods Operators Fields Properties See Also Send Feedback

The Term type exposes the following members.

Constructors

 | Name | Description
Public method | Term(Term) | English: Copying of the expression component. Русский: Копирование компонента выражения.
Public method | Term(String, TermType, Int32) | English: Constructor of the instance of an expression component. Русский: Создание компонента выражения.

Methods

 | Name | Description
Public method | Equals | English: Compares an object with a second one. Русский: Сравнивает текущий экзэмпляр компонента выражения со вторым объектом. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | English: Serves as a hash function for a particular type. Русский: Служит хэш-функцией для текущего типа. (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | English: Shows a string representation of current expression component. Русский: Показывает строковое представление текущего компонента выражения. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | English: Compares data of two Term instances. Русский: Сравнивает данные двух экземпляров Term.
Inequality | English: Compares data of two Term instances. Русский: Сравнивает данные двух экземпляров Term.

Fields

Name | Description
Empty | English: Empty instance of the expression component. Русский: Пустой экземпляр компоненты выражения.

Properties

Name Description
Public property ChildCount
English: Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Русский: Количество аргументов компонента выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property Text
English: Text value of the expression component.
Русский: Текстовая ценность компонента выражения.
Public property Type
English: Type of the expression component.
Русский: Определение типа компонента выражения.

See Also

Term Class
SMath.Manager Namespace


Term Constructor

[image] [image]

SMath Studio Class Libraries Documantation
Term Constructor
Term Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Term(Term) | English: Copying of the expression component. Русский: Копирование компонента выражения.
Public method | Term(String, TermType, Int32) | English: Constructor of the instance of an expression component. Русский: Создание компонента выражения.

See Also

Term Class
Term Members
SMath.Manager Namespace


Term Constructor (Term)

[image]

SMath Studio Class Libraries Documantation
Term Constructor (Term)
Term Class See Also Send Feedback
English: Copying of the expression component.
Русский: Копирование компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term(
    Term value
)
Visual Basic
Public Sub New ( _
    value As Term _
)
Visual C++
public:
Term(
    Term^ value
)
F#
new :
        value:Term -> Term

Parameters

value
Type: SMath.Manager..::..Term
English: Expression component.
Русский: Компонента выражения.

See Also

Term Class
Term Overload
SMath.Manager Namespace


Term Constructor (String, TermType, Int32)

[image]

SMath Studio Class Libraries Documantation
Term Constructor (String, TermType, Int32)
Term Class See Also Send Feedback
English: Constructor of the instance of an expression component.
Русский: Создание компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term(
    string text,
    TermType type,
    int childCount
)
Visual Basic
Public Sub New ( _
    text As String, _
    type As TermType, _
    childCount As Integer _
)
Visual C++
public:
Term(
    String^ text,
    TermType type,
    int childCount
)
F#
new :
        text:string *
        type:TermType *
        childCount:int -> Term

Parameters

text
Type: System..::..String
English: Text value of the expression component.
Русский: Текстовая ценность компонента выражения.
type
Type: SMath.Manager..::..TermType
English: Type of the expression component.
Русский: Определение типа компонента выражения.
childCount
Type: System..::..Int32
English: Number of children of the expression component.
Русский: Количество аргументов компонента выражения.

See Also

Term Class
Term Overload
SMath.Manager Namespace


Term Fields

[image] [image]

SMath Studio Class Libraries Documantation
Term Fields
Term Class See Also Send Feedback

The Term type exposes the following members.

Fields

Name | Description
Empty | English: Empty instance of the expression component. Русский: Пустой экземпляр компоненты выражения.

See Also

Term Class
SMath.Manager Namespace


Empty Field

[image]

SMath Studio Class Libraries Documantation
Term..::..Empty Field
Term Class See Also Send Feedback
English: Empty instance of the expression component.
Русский: Пустой экземпляр компоненты выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static readonly Term Empty
Visual Basic
Public Shared ReadOnly Empty As Term
Visual C++
public:
static initonly Term^ Empty
F#
static val Empty: Term

See Also

Term Class
SMath.Manager Namespace


Term Methods

[image] [image]

SMath Studio Class Libraries Documantation
Term Methods
Term Class See Also Send Feedback

The Term type exposes the following members.

Methods

 | Name | Description
Public method | Equals | English: Compares an object with a second one. Русский: Сравнивает текущий экзэмпляр компонента выражения со вторым объектом. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | English: Serves as a hash function for a particular type. Русский: Служит хэш-функцией для текущего типа. (Overrides Object..::..GetHashCode()()()().)
Public method | ToString | English: Shows a string representation of current expression component. Русский: Показывает строковое представление текущего компонента выражения. (Overrides Object..::..ToString()()()().)

See Also

Term Class
SMath.Manager Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
Term..::..Equals Method
Term Class See Also Send Feedback
English: Compares an object with a second one.
Русский: Сравнивает текущий экзэмпляр компонента выражения со вторым объектом.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object
English: Object to compare with the current expression component.
Русский: Объект для сравнения с текущим компонентом выражения.

Return Value

English: Returns true if data is equal and false otherwise.
Русский: Возвращает истину, если данные идентичны, и ложь в обратном случае.

See Also

Term Class
SMath.Manager Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
Term..::..GetHashCode Method
Term Class See Also Send Feedback
English: Serves as a hash function for a particular type.
Русский: Служит хэш-функцией для текущего типа.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

English: A hash code for the current Term.
Русский: Хэш-код текущего типа.

See Also

Term Class
SMath.Manager Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
Term..::..ToString Method
Term Class See Also Send Feedback
English: Shows a string representation of current expression component.
Русский: Показывает строковое представление текущего компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

English: Return a string representation of current expression component.
Русский: Возвращает строковое представление текущего компонента выражения.

See Also

Term Class
SMath.Manager Namespace


Term Operators

[image] [image]

SMath Studio Class Libraries Documantation
Term Operators
Term Class See Also Send Feedback

The Term type exposes the following members.

Operators

Name | Description
Equality | English: Compares data of two Term instances. Русский: Сравнивает данные двух экземпляров Term.
Inequality | English: Compares data of two Term instances. Русский: Сравнивает данные двух экземпляров Term.

See Also

Term Class
SMath.Manager Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
Term..::..Equality Operator
Term Class See Also Send Feedback
English: Compares data of two Term instances.
Русский: Сравнивает данные двух экземпляров Term.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool operator ==(
    Term c1,
    Term c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As Term, _
    c2 As Term _
) As Boolean
Visual C++
public:
static bool operator ==(
    Term^ c1,
    Term^ c2
)
F#
static let inline (=)
        c1:Term *
        c2:Term  : bool

Parameters

c1
Type: SMath.Manager..::..Term
English: First instance to compare.
Русский: Первый экземпляр для сравнения.
c2
Type: SMath.Manager..::..Term
English: Second instance to compare.
Русский: Второй экземпляр для сравнения.

Return Value

English: Returns true if data is equal and false otherwise.
Русский: Возвращает истину, если данные идентичны, и ложь в обратном случае.

See Also

Term Class
SMath.Manager Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
Term..::..Inequality Operator
Term Class See Also Send Feedback
English: Compares data of two Term instances.
Русский: Сравнивает данные двух экземпляров Term.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public static bool operator !=(
    Term c1,
    Term c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As Term, _
    c2 As Term _
) As Boolean
Visual C++
public:
static bool operator !=(
    Term^ c1,
    Term^ c2
)
F#
static let inline (<>)
        c1:Term *
        c2:Term  : bool

Parameters

c1
Type: SMath.Manager..::..Term
English: First instance to compare.
Русский: Первый экземпляр для сравнения.
c2
Type: SMath.Manager..::..Term
English: Second instance to compare.
Русский: Второй экземпляр для сравнения.

Return Value

English: Returns false if data is equal and true otherwise.
Русский: Возвращает ложь, если данные идентичны, и истину в обратном случае.

See Also

Term Class
SMath.Manager Namespace


Term Properties

[image] [image]

SMath Studio Class Libraries Documantation
Term Properties
Term Class See Also Send Feedback

The Term type exposes the following members.

Properties

Name Description
Public property ChildCount
English: Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Русский: Количество аргументов компонента выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.
Public property Text
English: Text value of the expression component.
Русский: Текстовая ценность компонента выражения.
Public property Type
English: Type of the expression component.
Русский: Определение типа компонента выражения.

See Also

Term Class
SMath.Manager Namespace


ChildCount Property

[image]

SMath Studio Class Libraries Documantation
Term..::..ChildCount Property
Term Class See Also Send Feedback
English: Number of children of the expression component. Can get values:
  • "0" - for the Operand;
  • "1" - for the Bracket;
  • "1" or "2" - for the Operator;
  • More then "1" or equal - for the Function.
Русский: Количество аргументов компонента выражения. Значения:
  • "0" - операнд;
  • "1" - скобка;
  • "1" или "2" - оператор;
  • От одного и более - функция.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int ChildCount { get; set; }
Visual Basic
Public Property ChildCount As Integer
    Get
    Set
Visual C++
public:
property int ChildCount {
    int get ();
    void set (int value);
}
F#
member ChildCount : int with get, set

See Also

Term Class
SMath.Manager Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
Term..::..Text Property
Term Class See Also Send Feedback
English: Text value of the expression component.
Русский: Текстовая ценность компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
F#
member Text : string with get, set

See Also

Term Class
SMath.Manager Namespace


Type Property

[image]

SMath Studio Class Libraries Documantation
Term..::..Type Property
Term Class See Also Send Feedback
English: Type of the expression component.
Русский: Определение типа компонента выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public TermType Type { get; set; }
Visual Basic
Public Property Type As TermType
    Get
    Set
Visual C++
public:
property TermType Type {
    TermType get ();
    void set (TermType value);
}
F#
member Type : TermType with get, set

See Also

Term Class
SMath.Manager Namespace


TermInfo Class

[image]

SMath Studio Class Libraries Documantation
TermInfo Class
Members See Also Send Feedback
Information about the Term

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class TermInfo
Visual Basic
Public Class TermInfo
Visual C++
public ref class TermInfo
F#
type TermInfo =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..TermInfo

See Also

TermInfo Members
SMath.Manager Namespace


TermInfo Members

[image] [image]

SMath Studio Class Libraries Documantation
TermInfo Members
TermInfo Class Constructors Methods Properties See Also Send Feedback

The TermInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TermInfo(String, TermType, Int32, String, FunctionSection, Boolean) |
Public method | TermInfo(Hashtable, Guid, TermType, Int32, String, FunctionSection, Boolean) |

Methods

 | Name | Description
Public method | GetName()()()() | Term's default name
Public method | GetName(Guid) | Term's name by GUID

Properties

 | Name | Description
Public property | ArgumentsCount | Number of Term's arguments
Public property | Description | Description of the Term
Public property | Section | Term's section
Public property | Type | Type of the Term
Public property | Visible | If Term is visible for user

See Also

TermInfo Class
SMath.Manager Namespace


TermInfo Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TermInfo Constructor
TermInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TermInfo(String, TermType, Int32, String, FunctionSection, Boolean) | Initializes a new instance of the TermInfo class
Public method | TermInfo(Hashtable, Guid, TermType, Int32, String, FunctionSection, Boolean) | Initializes a new instance of the TermInfo class

See Also

TermInfo Class
TermInfo Members
SMath.Manager Namespace


TermInfo Constructor (String, TermType, Int32, String, FunctionSection, Boolean)

[image]

SMath Studio Class Libraries Documantation
TermInfo Constructor (String, TermType, Int32, String, FunctionSection, Boolean)
TermInfo Class See Also Send Feedback
Initializes a new instance of the TermInfo class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public TermInfo(
    string name,
    TermType type,
    int argumentsCount,
    string description,
    FunctionSection section,
    bool visible
)
Visual Basic
Public Sub New ( _
    name As String, _
    type As TermType, _
    argumentsCount As Integer, _
    description As String, _
    section As FunctionSection, _
    visible As Boolean _
)
Visual C++
public:
TermInfo(
    String^ name,
    TermType type,
    int argumentsCount,
    String^ description,
    FunctionSection section,
    bool visible
)
F#
new :
        name:string *
        type:TermType *
        argumentsCount:int *
        description:string *
        section:FunctionSection *
        visible:bool -> TermInfo

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

type
Type: SMath.Manager..::..TermType

[Missing <param name="type"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

argumentsCount
Type: System..::..Int32

[Missing <param name="argumentsCount"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

section
Type: SMath.Manager..::..FunctionSection

[Missing <param name="section"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

visible
Type: System..::..Boolean

[Missing <param name="visible"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.String,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

See Also

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Constructor (Hashtable, Guid, TermType, Int32, String, FunctionSection, Boolean)

[image]

SMath Studio Class Libraries Documantation
TermInfo Constructor (Hashtable, Guid, TermType, Int32, String, FunctionSection, Boolean)
TermInfo Class See Also Send Feedback
Initializes a new instance of the TermInfo class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public TermInfo(
    Hashtable names,
    Guid defaultNameGuid,
    TermType type,
    int argumentsCount,
    string description,
    FunctionSection section,
    bool visible
)
Visual Basic
Public Sub New ( _
    names As Hashtable, _
    defaultNameGuid As Guid, _
    type As TermType, _
    argumentsCount As Integer, _
    description As String, _
    section As FunctionSection, _
    visible As Boolean _
)
Visual C++
public:
TermInfo(
    Hashtable^ names,
    Guid defaultNameGuid,
    TermType type,
    int argumentsCount,
    String^ description,
    FunctionSection section,
    bool visible
)
F#
new :
        names:Hashtable *
        defaultNameGuid:Guid *
        type:TermType *
        argumentsCount:int *
        description:string *
        section:FunctionSection *
        visible:bool -> TermInfo

Parameters

names
Type: System.Collections..::..Hashtable

[Missing <param name="names"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

defaultNameGuid
Type: System..::..Guid

[Missing <param name="defaultNameGuid"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

type
Type: SMath.Manager..::..TermType

[Missing <param name="type"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

argumentsCount
Type: System..::..Int32

[Missing <param name="argumentsCount"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

section
Type: SMath.Manager..::..FunctionSection

[Missing <param name="section"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

visible
Type: System..::..Boolean

[Missing <param name="visible"/> documentation for "M:SMath.Manager.TermInfo.#ctor(System.Collections.Hashtable,System.Guid,SMath.Manager.TermType,System.Int32,System.String,SMath.Manager.FunctionSection,System.Boolean)"]

See Also

TermInfo Class
TermInfo Overload
SMath.Manager Namespace


TermInfo Methods

[image] [image]

SMath Studio Class Libraries Documantation
TermInfo Methods
TermInfo Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetName()()()() | Term's default name
Public method | GetName(Guid) | Term's name by GUID

See Also

TermInfo Class
SMath.Manager Namespace


GetName Method

[image] [image]

SMath Studio Class Libraries Documantation
TermInfo..::..GetName Method
TermInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetName()()()() | Term's default name
Public method | GetName(Guid) | Term's name by GUID

See Also

TermInfo Class
TermInfo Members
SMath.Manager Namespace


GetName Method

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..GetName Method
TermInfo Class See Also Send Feedback
Term's default name

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()
F#
member GetName : unit -> string

Return Value

[Missing <returns> documentation for "M:SMath.Manager.TermInfo.GetName"]

See Also

TermInfo Class
GetName Overload
SMath.Manager Namespace


GetName Method (Guid)

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..GetName Method (Guid)
TermInfo Class See Also Send Feedback
Term's name by GUID

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string GetName(
    Guid publicGuid
)
Visual Basic
Public Function GetName ( _
    publicGuid As Guid _
) As String
Visual C++
public:
String^ GetName(
    Guid publicGuid
)
F#
member GetName :
        publicGuid:Guid -> string

Parameters

publicGuid
Type: System..::..Guid

[Missing <param name="publicGuid"/> documentation for "M:SMath.Manager.TermInfo.GetName(System.Guid)"]

Return Value

[Missing <returns> documentation for "M:SMath.Manager.TermInfo.GetName(System.Guid)"]

See Also

TermInfo Class
GetName Overload
SMath.Manager Namespace


TermInfo Properties

[image] [image]

SMath Studio Class Libraries Documantation
TermInfo Properties
TermInfo Class See Also Send Feedback

The TermInfo type exposes the following members.

Properties

 | Name | Description
Public property | ArgumentsCount | Number of Term's arguments
Public property | Description | Description of the Term
Public property | Section | Term's section
Public property | Type | Type of the Term
Public property | Visible | If Term is visible for user

See Also

TermInfo Class
SMath.Manager Namespace


ArgumentsCount Property

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..ArgumentsCount Property
TermInfo Class See Also Send Feedback
Number of Term's arguments

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int ArgumentsCount { get; }
Visual Basic
Public ReadOnly Property ArgumentsCount As Integer
    Get
Visual C++
public:
property int ArgumentsCount {
    int get ();
}
F#
member ArgumentsCount : int

See Also

TermInfo Class
SMath.Manager Namespace


Description Property

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..Description Property
TermInfo Class See Also Send Feedback
Description of the Term

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}
F#
member Description : string

See Also

TermInfo Class
SMath.Manager Namespace


Section Property

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..Section Property
TermInfo Class See Also Send Feedback
Term's section

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public FunctionSection Section { get; }
Visual Basic
Public ReadOnly Property Section As FunctionSection
    Get
Visual C++
public:
property FunctionSection Section {
    FunctionSection get ();
}
F#
member Section : FunctionSection

See Also

TermInfo Class
SMath.Manager Namespace


Type Property

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..Type Property
TermInfo Class See Also Send Feedback
Type of the Term

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public TermType Type { get; }
Visual Basic
Public ReadOnly Property Type As TermType
    Get
Visual C++
public:
property TermType Type {
    TermType get ();
}
F#
member Type : TermType

See Also

TermInfo Class
SMath.Manager Namespace


Visible Property

[image]

SMath Studio Class Libraries Documantation
TermInfo..::..Visible Property
TermInfo Class See Also Send Feedback
If Term is visible for user

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool Visible { get; }
Visual Basic
Public ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
property bool Visible {
    bool get ();
}
F#
member Visible : bool

See Also

TermInfo Class
SMath.Manager Namespace


TermOrigin Enumeration

[image]

SMath Studio Class Libraries Documantation
TermOrigin Enumeration
See Also Send Feedback
English: The origin of the expression component (order based on the priorities).
Русский: Происхождение компоненты выражения (порядок согласно приоритетам).

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum TermOrigin
Visual Basic
Public Enumeration TermOrigin
Visual C++
public enum class TermOrigin
F#
type TermOrigin

Members

Member name | Value | Description
Undefined | 0 | English: Origin is undefined. Русский: Происхождение неопределено.
BuiltIn | 1 | English: Built-in expression component. Русский: Встроенная компонента.
Plugin | 2 | English: Plugin-defined expression component. Русский: Компонента определённая в дополнении (плагине).
UserDefined | 3 | English: User-defined expression component. Русский: Компонента определённая пользователем.

See Also

SMath.Manager Namespace


TermType Enumeration

[image]

SMath Studio Class Libraries Documantation
TermType Enumeration
See Also Send Feedback
English: Type of the expression component.
Русский: Определение типа компоненты выражения.

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum TermType
Visual Basic
Public Enumeration TermType
Visual C++
public enum class TermType
F#
type TermType

Members

Member name | Value | Description
Operand | 1 | English: The operand can be represented by the number, parameter or variable. Русский: Операнд может быть как числом, так и параметром или переменной.
Operator | 2 | English: The operator may be unary or binary. Русский: Оператор может быть унарным или бинарным.
Function | 3 | English: The function. Русский: Функция.
Bracket | 4 | English: Brackets. Русский: Пользовательские скобки.

See Also

SMath.Manager Namespace


UnitDefinition Class

[image]

SMath Studio Class Libraries Documantation
UnitDefinition Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.UnitDefinition"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class UnitDefinition
Visual Basic
Public Class UnitDefinition
Visual C++
public ref class UnitDefinition
F#
type UnitDefinition =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..UnitDefinition

See Also

UnitDefinition Members
SMath.Manager Namespace


UnitDefinition Members

[image] [image]

SMath Studio Class Libraries Documantation
UnitDefinition Members
UnitDefinition Class Constructors Properties See Also Send Feedback

The UnitDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | UnitDefinition(String, String, String, UnitType) |
Public method | UnitDefinition(String, array<Term>[]()[][], array<Term>[]()[][], String, UnitType) |
Public method | UnitDefinition(String, String, String, UnitType, Boolean) |

Properties

 | Name | Description
Public property | BaseUnit |
Public property | ConvertFrom |
Public property | ConvertTo |
Public property | Description |
Public property | Relation |
Public property | Text |
Public property | Type |

See Also

UnitDefinition Class
SMath.Manager Namespace


UnitDefinition Constructor

[image] [image]

SMath Studio Class Libraries Documantation
UnitDefinition Constructor
UnitDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnitDefinition(String, String, String, UnitType) | Initializes a new instance of the UnitDefinition class
Public method | UnitDefinition(String, array<Term>[]()[][], array<Term>[]()[][], String, UnitType) | Initializes a new instance of the UnitDefinition class
Public method | UnitDefinition(String, String, String, UnitType, Boolean) | Initializes a new instance of the UnitDefinition class

See Also

UnitDefinition Class
UnitDefinition Members
SMath.Manager Namespace


UnitDefinition Constructor (String, String, String, UnitType)

[image]

SMath Studio Class Libraries Documantation
UnitDefinition Constructor (String, String, String, UnitType)
UnitDefinition Class See Also Send Feedback
Initializes a new instance of the UnitDefinition class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public UnitDefinition(
    string text,
    string relation,
    string description,
    UnitType type
)
Visual Basic
Public Sub New ( _
    text As String, _
    relation As String, _
    description As String, _
    type As UnitType _
)
Visual C++
public:
UnitDefinition(
    String^ text,
    String^ relation,
    String^ description,
    UnitType type
)
F#
new :
        text:string *
        relation:string *
        description:string *
        type:UnitType -> UnitDefinition

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType)"]

relation
Type: System..::..String

[Missing <param name="relation"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType)"]

type
Type: SMath.Manager..::..UnitType

[Missing <param name="type"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType)"]

See Also

UnitDefinition Class
UnitDefinition Overload
SMath.Manager Namespace


UnitDefinition Constructor (String, Term[], Term[], String, UnitType)

[image]

SMath Studio Class Libraries Documantation
UnitDefinition Constructor (String, array<Term>[]()[][], array<Term>[]()[][], String, UnitType)
UnitDefinition Class See Also Send Feedback
Initializes a new instance of the UnitDefinition class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public UnitDefinition(
    string text,
    Term[] convertFrom,
    Term[] convertTo,
    string description,
    UnitType type
)
Visual Basic
Public Sub New ( _
    text As String, _
    convertFrom As Term(), _
    convertTo As Term(), _
    description As String, _
    type As UnitType _
)
Visual C++
public:
UnitDefinition(
    String^ text,
    array<Term^>^ convertFrom,
    array<Term^>^ convertTo,
    String^ description,
    UnitType type
)
F#
new :
        text:string *
        convertFrom:Term[] *
        convertTo:Term[] *
        description:string *
        type:UnitType -> UnitDefinition

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,SMath.Manager.Term[],SMath.Manager.Term[],System.String,SMath.Manager.UnitType)"]

convertFrom
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="convertFrom"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,SMath.Manager.Term[],SMath.Manager.Term[],System.String,SMath.Manager.UnitType)"]

convertTo
Type: array< SMath.Manager..::..Term >[]()[][]

[Missing <param name="convertTo"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,SMath.Manager.Term[],SMath.Manager.Term[],System.String,SMath.Manager.UnitType)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,SMath.Manager.Term[],SMath.Manager.Term[],System.String,SMath.Manager.UnitType)"]

type
Type: SMath.Manager..::..UnitType

[Missing <param name="type"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,SMath.Manager.Term[],SMath.Manager.Term[],System.String,SMath.Manager.UnitType)"]

See Also

UnitDefinition Class
UnitDefinition Overload
SMath.Manager Namespace


UnitDefinition Constructor (String, String, String, UnitType, Boolean)

[image]

SMath Studio Class Libraries Documantation
UnitDefinition Constructor (String, String, String, UnitType, Boolean)
UnitDefinition Class See Also Send Feedback
Initializes a new instance of the UnitDefinition class

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public UnitDefinition(
    string text,
    string relation,
    string description,
    UnitType type,
    bool baseUnit
)
Visual Basic
Public Sub New ( _
    text As String, _
    relation As String, _
    description As String, _
    type As UnitType, _
    baseUnit As Boolean _
)
Visual C++
public:
UnitDefinition(
    String^ text,
    String^ relation,
    String^ description,
    UnitType type,
    bool baseUnit
)
F#
new :
        text:string *
        relation:string *
        description:string *
        type:UnitType *
        baseUnit:bool -> UnitDefinition

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType,System.Boolean)"]

relation
Type: System..::..String

[Missing <param name="relation"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType,System.Boolean)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType,System.Boolean)"]

type
Type: SMath.Manager..::..UnitType

[Missing <param name="type"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType,System.Boolean)"]

baseUnit
Type: System..::..Boolean

[Missing <param name="baseUnit"/> documentation for "M:SMath.Manager.UnitDefinition.#ctor(System.String,System.String,System.String,SMath.Manager.UnitType,System.Boolean)"]

See Also

UnitDefinition Class
UnitDefinition Overload
SMath.Manager Namespace


UnitDefinition Properties

[image] [image]

SMath Studio Class Libraries Documantation
UnitDefinition Properties
UnitDefinition Class See Also Send Feedback

The UnitDefinition type exposes the following members.

Properties

 | Name | Description
Public property | BaseUnit |
Public property | ConvertFrom |
Public property | ConvertTo |
Public property | Description |
Public property | Relation |
Public property | Text |
Public property | Type |

See Also

UnitDefinition Class
SMath.Manager Namespace


BaseUnit Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..BaseUnit Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.BaseUnit"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool BaseUnit { get; }
Visual Basic
Public ReadOnly Property BaseUnit As Boolean
    Get
Visual C++
public:
property bool BaseUnit {
    bool get ();
}
F#
member BaseUnit : bool

See Also

UnitDefinition Class
SMath.Manager Namespace


ConvertFrom Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..ConvertFrom Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.ConvertFrom"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term[] ConvertFrom { get; }
Visual Basic
Public ReadOnly Property ConvertFrom As Term()
    Get
Visual C++
public:
property array<Term^>^ ConvertFrom {
    array<Term^>^ get ();
}
F#
member ConvertFrom : Term[]

See Also

UnitDefinition Class
SMath.Manager Namespace


ConvertTo Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..ConvertTo Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.ConvertTo"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term[] ConvertTo { get; }
Visual Basic
Public ReadOnly Property ConvertTo As Term()
    Get
Visual C++
public:
property array<Term^>^ ConvertTo {
    array<Term^>^ get ();
}
F#
member ConvertTo : Term[]

See Also

UnitDefinition Class
SMath.Manager Namespace


Description Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..Description Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.Description"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}
F#
member Description : string

See Also

UnitDefinition Class
SMath.Manager Namespace


Relation Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..Relation Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.Relation"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Term[] Relation { get; }
Visual Basic
Public ReadOnly Property Relation As Term()
    Get
Visual C++
public:
property array<Term^>^ Relation {
    array<Term^>^ get ();
}
F#
member Relation : Term[]

See Also

UnitDefinition Class
SMath.Manager Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..Text Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.Text"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}
F#
member Text : string

See Also

UnitDefinition Class
SMath.Manager Namespace


Type Property

[image]

SMath Studio Class Libraries Documantation
UnitDefinition..::..Type Property
UnitDefinition Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Manager.UnitDefinition.Type"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public UnitType Type { get; }
Visual Basic
Public ReadOnly Property Type As UnitType
    Get
Visual C++
public:
property UnitType Type {
    UnitType get ();
}
F#
member Type : UnitType

See Also

UnitDefinition Class
SMath.Manager Namespace


UnitType Enumeration

[image]

SMath Studio Class Libraries Documantation
UnitType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Manager.UnitType"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public enum UnitType
Visual Basic
Public Enumeration UnitType
Visual C++
public enum class UnitType
F#
type UnitType

Members

Member name | Value | Description
All | 91 |
Acceleration | 250 |
Activity | 251 |
Angle | 252 |
Area | 253 |
Capacitance | 254 |
CatalyticActivity | 255 |
Charge | 256 |
Conductance | 257 |
Dose | 258 |
ElectricCurrent | 259 |
Energy | 260 |
FlowRate | 261 |
Force | 262 |
ForceDensity | 263 |
ForcePerLength | 264 |
Frequency | 265 |
Illuminance | 266 |
Inductance | 267 |
Information | 423 |
Length | 268 |
LuminousIntensity | 269 |
MagneticFieldStrength | 270 |
MagneticFlux | 271 |
MagneticFluxDensity | 272 |
Mass | 273 |
Money | 274 |
Permeability | 275 |
Permittivity | 276 |
Potential | 277 |
Power | 278 |
Pressure | 279 |
Resistance | 280 |
Resolution | 281 |
Substance | 282 |
Temperature | 283 |
Time | 284 |
Torgue | 285 |
Velocity | 286 |
ViscosityDynamic | 287 |
ViscosityKinematic | 288 |
Volume | 289 |

See Also

SMath.Manager Namespace


VariousItem Class

[image]

SMath Studio Class Libraries Documantation
VariousItem Class
Members See Also Send Feedback
Класс-родитель элементов списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class VariousItem
Visual Basic
Public Class VariousItem
Visual C++
public ref class VariousItem
F#
type VariousItem =  class end

Inheritance Hierarchy

System..::..Object
SMath.Manager..::..VariousItem

See Also

VariousItem Members
SMath.Manager Namespace


VariousItem Members

[image] [image]

SMath Studio Class Libraries Documantation
VariousItem Members
VariousItem Class Constructors Methods Fields Properties See Also Send Feedback

The VariousItem type exposes the following members.

Constructors

 | Name | Description
Public method | VariousItem()()()() | Конструктор элемента списка
Public method | VariousItem(String) | Конструктор элемента списка
Public method | VariousItem(String, Int32, Int32) | Конструктор элемента списка

Methods

 | Name | Description
Public method | OnPaint |

Fields

 | Name | Description
Protected field | leftMargin |
Protected field | mainFont | Общий для всех элементов-детей шрифт
Protected field | rightMargin |

Properties

 | Name | Description
Public property | Focused | Фокусировка элемента
Public property | Selected | Задать или получить статус выделенности элемента списка
Public property | Text | Текст элемента для отрисовки

See Also

VariousItem Class
SMath.Manager Namespace


VariousItem Constructor

[image] [image]

SMath Studio Class Libraries Documantation
VariousItem Constructor
VariousItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VariousItem()()()() | Конструктор элемента списка
Public method | VariousItem(String) | Конструктор элемента списка
Public method | VariousItem(String, Int32, Int32) | Конструктор элемента списка

See Also

VariousItem Class
VariousItem Members
SMath.Manager Namespace


VariousItem Constructor

[image]

SMath Studio Class Libraries Documantation
VariousItem Constructor
VariousItem Class See Also Send Feedback
Конструктор элемента списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public VariousItem()
Visual Basic
Public Sub New
Visual C++
public:
VariousItem()
F#
new : unit -> VariousItem

See Also

VariousItem Class
VariousItem Overload
SMath.Manager Namespace


VariousItem Constructor (String)

[image]

SMath Studio Class Libraries Documantation
VariousItem Constructor (String)
VariousItem Class See Also Send Feedback
Конструктор элемента списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public VariousItem(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
VariousItem(
    String^ text
)
F#
new :
        text:string -> VariousItem

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Manager.VariousItem.#ctor(System.String)"]

See Also

VariousItem Class
VariousItem Overload
SMath.Manager Namespace


VariousItem Constructor (String, Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
VariousItem Constructor (String, Int32, Int32)
VariousItem Class See Also Send Feedback
Конструктор элемента списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public VariousItem(
    string text,
    int leftMargin,
    int rightMargin
)
Visual Basic
Public Sub New ( _
    text As String, _
    leftMargin As Integer, _
    rightMargin As Integer _
)
Visual C++
public:
VariousItem(
    String^ text,
    int leftMargin,
    int rightMargin
)
F#
new :
        text:string *
        leftMargin:int *
        rightMargin:int -> VariousItem

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Manager.VariousItem.#ctor(System.String,System.Int32,System.Int32)"]

leftMargin
Type: System..::..Int32

[Missing <param name="leftMargin"/> documentation for "M:SMath.Manager.VariousItem.#ctor(System.String,System.Int32,System.Int32)"]

rightMargin
Type: System..::..Int32

[Missing <param name="rightMargin"/> documentation for "M:SMath.Manager.VariousItem.#ctor(System.String,System.Int32,System.Int32)"]

See Also

VariousItem Class
VariousItem Overload
SMath.Manager Namespace


VariousItem Fields

[image] [image]

SMath Studio Class Libraries Documantation
VariousItem Fields
VariousItem Class See Also Send Feedback

The VariousItem type exposes the following members.

Fields

 | Name | Description
Protected field | leftMargin |
Protected field | mainFont | Общий для всех элементов-детей шрифт
Protected field | rightMargin |

See Also

VariousItem Class
SMath.Manager Namespace


leftMargin Field

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..leftMargin Field
VariousItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.VariousItem.leftMargin"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected int leftMargin
Visual Basic
Protected leftMargin As Integer
Visual C++
protected:
int leftMargin
F#
val mutable leftMargin: int

See Also

VariousItem Class
SMath.Manager Namespace


mainFont Field

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..mainFont Field
VariousItem Class See Also Send Feedback
Общий для всех элементов-детей шрифт

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected Font mainFont
Visual Basic
Protected mainFont As Font
Visual C++
protected:
Font^ mainFont
F#
val mutable mainFont: Font

See Also

VariousItem Class
SMath.Manager Namespace


rightMargin Field

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..rightMargin Field
VariousItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Manager.VariousItem.rightMargin"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected int rightMargin
Visual Basic
Protected rightMargin As Integer
Visual C++
protected:
int rightMargin
F#
val mutable rightMargin: int

See Also

VariousItem Class
SMath.Manager Namespace


VariousItem Methods

[image] [image]

SMath Studio Class Libraries Documantation
VariousItem Methods
VariousItem Class See Also Send Feedback

The VariousItem type exposes the following members.

Methods

 | Name | Description
Public method | OnPaint |

See Also

VariousItem Class
SMath.Manager Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..OnPaint Method
VariousItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousItem.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public virtual void OnPaint(
    PaintEventArgs e
)
Visual Basic
Public Overridable Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
public:
virtual void OnPaint(
    PaintEventArgs^ e
)
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousItem.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

VariousItem Class
SMath.Manager Namespace


VariousItem Properties

[image] [image]

SMath Studio Class Libraries Documantation
VariousItem Properties
VariousItem Class See Also Send Feedback

The VariousItem type exposes the following members.

Properties

 | Name | Description
Public property | Focused | Фокусировка элемента
Public property | Selected | Задать или получить статус выделенности элемента списка
Public property | Text | Текст элемента для отрисовки

See Also

VariousItem Class
SMath.Manager Namespace


Focused Property

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..Focused Property
VariousItem Class See Also Send Feedback
Фокусировка элемента

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool Focused { get; set; }
Visual Basic
Public Property Focused As Boolean
    Get
    Set
Visual C++
public:
property bool Focused {
    bool get ();
    void set (bool value);
}
F#
member Focused : bool with get, set

See Also

VariousItem Class
SMath.Manager Namespace


Selected Property

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..Selected Property
VariousItem Class See Also Send Feedback
Задать или получить статус выделенности элемента списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
F#
member Selected : bool with get, set

See Also

VariousItem Class
SMath.Manager Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
VariousItem..::..Text Property
VariousItem Class See Also Send Feedback
Текст элемента для отрисовки

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public virtual string Text { get; set; }
Visual Basic
Public Overridable Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}
F#
abstract Text : string with get, set
override Text : string with get, set

See Also

VariousItem Class
SMath.Manager Namespace


VariousList Class

[image]

SMath Studio Class Libraries Documantation
VariousList Class
Members See Also Send Feedback
Пользовательский элемент, список произвольных элементов

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public class VariousList : Control
Visual Basic
Public Class VariousList _
    Inherits Control
Visual C++
public ref class VariousList : public Control
F#
type VariousList =
    class
        inherit Control
    end

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
SMath.Manager..::..VariousList

See Also

VariousList Members
SMath.Manager Namespace


VariousList Members

[image] [image]

SMath Studio Class Libraries Documantation
VariousList Members
VariousList Class Constructors Methods Properties Events See Also Send Feedback

The VariousList type exposes the following members.

Constructors

 | Name | Description
Public method | VariousList | Конструктор класса пользовательского элемента

Methods

 | Name | Description
Public method | GetCurrentScrollBarValue |
Public method | MakeFirst |
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Перехват отрисовки фона для обеспечения отрисовки контрола без "моргания" (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | (Overrides Control..::..OnResize(EventArgs).)
Public method | SendKey |
Public method | StartInvalidate |
Public method | StopInvalidate |

Properties

 | Name | Description
Public property | ItemHeight | Высота элементов списка
Public property | Items | Коллекция элементов контрола
Public property | SelectedIndex | Задать или получить индекс выделенного элемента списка

Events

 | Name | Description
Public event | DoubleClickOccured |
Public event | SelectedIndexChanged | Сигнализация об изменении выделения

See Also

VariousList Class
SMath.Manager Namespace


VariousList Constructor

[image]

SMath Studio Class Libraries Documantation
VariousList Constructor
VariousList Class See Also Send Feedback
Конструктор класса пользовательского элемента

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public VariousList()
Visual Basic
Public Sub New
Visual C++
public:
VariousList()
F#
new : unit -> VariousList

See Also

VariousList Class
SMath.Manager Namespace


VariousList Methods

[image] [image]

SMath Studio Class Libraries Documantation
VariousList Methods
VariousList Class See Also Send Feedback

The VariousList type exposes the following members.

Methods

 | Name | Description
Public method | GetCurrentScrollBarValue |
Public method | MakeFirst |
Protected method | OnGotFocus | (Overrides Control..::..OnGotFocus(EventArgs).)
Protected method | OnKeyDown | (Overrides Control..::..OnKeyDown(KeyEventArgs).)
Protected method | OnLostFocus | (Overrides Control..::..OnLostFocus(EventArgs).)
Protected method | OnMouseDown | (Overrides Control..::..OnMouseDown(MouseEventArgs).)
Protected method | OnMouseMove | (Overrides Control..::..OnMouseMove(MouseEventArgs).)
Protected method | OnMouseUp | (Overrides Control..::..OnMouseUp(MouseEventArgs).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | Перехват отрисовки фона для обеспечения отрисовки контрола без "моргания" (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Protected method | OnResize | (Overrides Control..::..OnResize(EventArgs).)
Public method | SendKey |
Public method | StartInvalidate |
Public method | StopInvalidate |

See Also

VariousList Class
SMath.Manager Namespace


GetCurrentScrollBarValue Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..GetCurrentScrollBarValue Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.GetCurrentScrollBarValue"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int GetCurrentScrollBarValue()
Visual Basic
Public Function GetCurrentScrollBarValue As Integer
Visual C++
public:
int GetCurrentScrollBarValue()
F#
member GetCurrentScrollBarValue : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Manager.VariousList.GetCurrentScrollBarValue"]

See Also

VariousList Class
SMath.Manager Namespace


MakeFirst Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..MakeFirst Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.MakeFirst(System.Int32)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void MakeFirst(
    int index
)
Visual Basic
Public Sub MakeFirst ( _
    index As Integer _
)
Visual C++
public:
void MakeFirst(
    int index
)
F#
member MakeFirst :
        index:int -> unit

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Manager.VariousList.MakeFirst(System.Int32)"]

See Also

VariousList Class
SMath.Manager Namespace


OnGotFocus Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnGotFocus Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnGotFocus(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnGotFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnGotFocus(
    EventArgs^ e
) override
F#
abstract OnGotFocus :
        e:EventArgs -> unit
override OnGotFocus :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnGotFocus(System.EventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnKeyDown Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnKeyDown Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnKeyDown(System.Windows.Forms.KeyEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override
F#
abstract OnKeyDown :
        e:KeyEventArgs -> unit
override OnKeyDown :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnKeyDown(System.Windows.Forms.KeyEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnLostFocus Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnLostFocus Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnLostFocus(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnLostFocus(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    EventArgs^ e
) override
F#
abstract OnLostFocus :
        e:EventArgs -> unit
override OnLostFocus :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnLostFocus(System.EventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnMouseDown Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnMouseDown Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
F#
abstract OnMouseDown :
        e:MouseEventArgs -> unit
override OnMouseDown :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnMouseDown(System.Windows.Forms.MouseEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnMouseMove Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnMouseMove Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
F#
abstract OnMouseMove :
        e:MouseEventArgs -> unit
override OnMouseMove :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnMouseMove(System.Windows.Forms.MouseEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnMouseUp Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnMouseUp Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
F#
abstract OnMouseUp :
        e:MouseEventArgs -> unit
override OnMouseUp :
        e:MouseEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnMouseUp(System.Windows.Forms.MouseEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnPaint Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnPaint Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnPaint(System.Windows.Forms.PaintEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
F#
abstract OnPaint :
        e:PaintEventArgs -> unit
override OnPaint :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnPaint(System.Windows.Forms.PaintEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnPaintBackground Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnPaintBackground Method
VariousList Class See Also Send Feedback
Перехват отрисовки фона для обеспечения отрисовки контрола без "моргания"

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)
Visual C++
protected:
virtual void OnPaintBackground(
    PaintEventArgs^ e
) override
F#
abstract OnPaintBackground :
        e:PaintEventArgs -> unit
override OnPaintBackground :
        e:PaintEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnPaintBackground(System.Windows.Forms.PaintEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


OnResize Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..OnResize Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.OnResize(System.EventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
protected override void OnResize(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnResize ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnResize(
    EventArgs^ e
) override
F#
abstract OnResize :
        e:EventArgs -> unit
override OnResize :
        e:EventArgs -> unit

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.OnResize(System.EventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


SendKey Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..SendKey Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.SendKey(System.Windows.Forms.KeyEventArgs)"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void SendKey(
    KeyEventArgs e
)
Visual Basic
Public Sub SendKey ( _
    e As KeyEventArgs _
)
Visual C++
public:
void SendKey(
    KeyEventArgs^ e
)
F#
member SendKey :
        e:KeyEventArgs -> unit

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

[Missing <param name="e"/> documentation for "M:SMath.Manager.VariousList.SendKey(System.Windows.Forms.KeyEventArgs)"]

See Also

VariousList Class
SMath.Manager Namespace


StartInvalidate Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..StartInvalidate Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.StartInvalidate"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void StartInvalidate()
Visual Basic
Public Sub StartInvalidate
Visual C++
public:
void StartInvalidate()
F#
member StartInvalidate : unit -> unit

See Also

VariousList Class
SMath.Manager Namespace


StopInvalidate Method

[image]

SMath Studio Class Libraries Documantation
VariousList..::..StopInvalidate Method
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Manager.VariousList.StopInvalidate"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public void StopInvalidate()
Visual Basic
Public Sub StopInvalidate
Visual C++
public:
void StopInvalidate()
F#
member StopInvalidate : unit -> unit

See Also

VariousList Class
SMath.Manager Namespace


VariousList Properties

[image] [image]

SMath Studio Class Libraries Documantation
VariousList Properties
VariousList Class See Also Send Feedback

The VariousList type exposes the following members.

Properties

 | Name | Description
Public property | ItemHeight | Высота элементов списка
Public property | Items | Коллекция элементов контрола
Public property | SelectedIndex | Задать или получить индекс выделенного элемента списка

See Also

VariousList Class
SMath.Manager Namespace


ItemHeight Property

[image]

SMath Studio Class Libraries Documantation
VariousList..::..ItemHeight Property
VariousList Class See Also Send Feedback
Высота элементов списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Integer
    Get
    Set
Visual C++
public:
property int ItemHeight {
    int get ();
    void set (int value);
}
F#
member ItemHeight : int with get, set

See Also

VariousList Class
SMath.Manager Namespace


Items Property

[image]

SMath Studio Class Libraries Documantation
VariousList..::..Items Property
VariousList Class See Also Send Feedback
Коллекция элементов контрола

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public Collection<VariousItem> Items { get; }
Visual Basic
Public ReadOnly Property Items As Collection(Of VariousItem)
    Get
Visual C++
public:
property Collection<VariousItem^>^ Items {
    Collection<VariousItem^>^ get ();
}
F#
member Items : Collection<VariousItem>

See Also

VariousList Class
SMath.Manager Namespace


SelectedIndex Property

[image]

SMath Studio Class Libraries Documantation
VariousList..::..SelectedIndex Property
VariousList Class See Also Send Feedback
Задать или получить индекс выделенного элемента списка

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}
F#
member SelectedIndex : int with get, set

See Also

VariousList Class
SMath.Manager Namespace


VariousList Events

[image] [image]

SMath Studio Class Libraries Documantation
VariousList Events
VariousList Class See Also Send Feedback

The VariousList type exposes the following members.

Events

 | Name | Description
Public event | DoubleClickOccured |
Public event | SelectedIndexChanged | Сигнализация об изменении выделения

See Also

VariousList Class
SMath.Manager Namespace


DoubleClickOccured Event

[image]

SMath Studio Class Libraries Documantation
VariousList..::..DoubleClickOccured Event
VariousList Class See Also Send Feedback

[Missing <summary> documentation for "E:SMath.Manager.VariousList.DoubleClickOccured"]

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public event EventHandler DoubleClickOccured
Visual Basic
Public Event DoubleClickOccured As EventHandler
Visual C++
public:
 event EventHandler^ DoubleClickOccured {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
F#
member DoubleClickOccured : IEvent<EventHandler,
    EventArgs>

See Also

VariousList Class
SMath.Manager Namespace


SelectedIndexChanged Event

[image]

SMath Studio Class Libraries Documantation
VariousList..::..SelectedIndexChanged Event
VariousList Class See Also Send Feedback
Сигнализация об изменении выделения

Namespace: SMath.Manager
Assembly: ioman (in ioman.dll) Version: 0.88.3855.30319

Syntax

C#
public event EventHandler SelectedIndexChanged
Visual Basic
Public Event SelectedIndexChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
F#
member SelectedIndexChanged : IEvent<EventHandler,
    EventArgs>

See Also

VariousList Class
SMath.Manager Namespace


SMath.Math Namespace

[image]

SMath Studio Class Libraries Documantation
SMath.Math Namespace
Send Feedback

[Missing <summary> documentation for "N:SMath.Math"]

Classes

 | Class | Description
Public class | ControlException | English: Internal Control exceptions class. Русский: Класс внутренних ошибок элементов листа.
Public class | Decision | English: Contains main evaluation and substitution methods to work with math expressions. Русский: Содержит основные методы для обработки и вычисления математических выражений.


ControlException Class

[image]

SMath Studio Class Libraries Documantation
ControlException Class
Members See Also Send Feedback
English: Internal Control exceptions class.
Русский: Класс внутренних ошибок элементов листа.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class ControlException : EvaluationException
Visual Basic
Public Class ControlException _
    Inherits EvaluationException
Visual C++
public ref class ControlException : public EvaluationException
F#
type ControlException =
    class
        inherit EvaluationException
    end

Inheritance Hierarchy

System..::..Object
System..::..Exception
SMath.Manager..::..EvaluationException
SMath.Math..::..ControlException

See Also

ControlException Members
SMath.Math Namespace


ControlException Members

[image] [image]

SMath Studio Class Libraries Documantation
ControlException Members
ControlException Class Constructors Fields See Also Send Feedback

The ControlException type exposes the following members.

Constructors

 | Name | Description
Public method | ControlException(Error, Int32, Term) |
Public method | ControlException(Error, Int32, Term, CommonControl) |

Fields

 | Name | Description
Public field | Control |
Public field | Element |
Public field | ErrorId | (Inherited from EvaluationException.)
Public field | Position |

See Also

ControlException Class
SMath.Math Namespace


ControlException Constructor

[image] [image]

SMath Studio Class Libraries Documantation
ControlException Constructor
ControlException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ControlException(Error, Int32, Term) | Initializes a new instance of the ControlException class
Public method | ControlException(Error, Int32, Term, CommonControl) | Initializes a new instance of the ControlException class

See Also

ControlException Class
ControlException Members
SMath.Math Namespace


ControlException Constructor (Error, Int32, Term)

[image]

SMath Studio Class Libraries Documantation
ControlException Constructor (Error, Int32, Term)
ControlException Class See Also Send Feedback
Initializes a new instance of the ControlException class

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public ControlException(
    Error ErrorId,
    int Position,
    Term Element
)
Visual Basic
Public Sub New ( _
    ErrorId As Error, _
    Position As Integer, _
    Element As Term _
)
Visual C++
public:
ControlException(
    Error ErrorId,
    int Position,
    Term^ Element
)
F#
new :
        ErrorId:Error *
        Position:int *
        Element:Term -> ControlException

Parameters

ErrorId
Type: SMath.Manager..::..Error

[Missing <param name="ErrorId"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term)"]

Position
Type: System..::..Int32

[Missing <param name="Position"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term)"]

Element
Type: SMath.Manager..::..Term

[Missing <param name="Element"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term)"]

See Also

ControlException Class
ControlException Overload
SMath.Math Namespace


ControlException Constructor (Error, Int32, Term, CommonControl)

[image]

SMath Studio Class Libraries Documantation
ControlException Constructor (Error, Int32, Term, CommonControl)
ControlException Class See Also Send Feedback
Initializes a new instance of the ControlException class

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public ControlException(
    Error ErrorId,
    int Position,
    Term Element,
    CommonControl Control
)
Visual Basic
Public Sub New ( _
    ErrorId As Error, _
    Position As Integer, _
    Element As Term, _
    Control As CommonControl _
)
Visual C++
public:
ControlException(
    Error ErrorId,
    int Position,
    Term^ Element,
    CommonControl^ Control
)
F#
new :
        ErrorId:Error *
        Position:int *
        Element:Term *
        Control:CommonControl -> ControlException

Parameters

ErrorId
Type: SMath.Manager..::..Error

[Missing <param name="ErrorId"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term,SMath.Control.CommonControl)"]

Position
Type: System..::..Int32

[Missing <param name="Position"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term,SMath.Control.CommonControl)"]

Element
Type: SMath.Manager..::..Term

[Missing <param name="Element"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term,SMath.Control.CommonControl)"]

Control
Type: SMath.Control..::..CommonControl

[Missing <param name="Control"/> documentation for "M:SMath.Math.ControlException.#ctor(SMath.Manager.Error,System.Int32,SMath.Manager.Term,SMath.Control.CommonControl)"]

See Also

ControlException Class
ControlException Overload
SMath.Math Namespace


ControlException Fields

[image] [image]

SMath Studio Class Libraries Documantation
ControlException Fields
ControlException Class See Also Send Feedback

The ControlException type exposes the following members.

Fields

 | Name | Description
Public field | Control |
Public field | Element |
Public field | ErrorId | (Inherited from EvaluationException.)
Public field | Position |

See Also

ControlException Class
SMath.Math Namespace


Control Field

[image]

SMath Studio Class Libraries Documantation
ControlException..::..Control Field
ControlException Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.ControlException.Control"]

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public CommonControl Control
Visual Basic
Public Control As CommonControl
Visual C++
public:
CommonControl^ Control
F#
val mutable Control: CommonControl

See Also

ControlException Class
SMath.Math Namespace


Element Field

[image]

SMath Studio Class Libraries Documantation
ControlException..::..Element Field
ControlException Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.ControlException.Element"]

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Term Element
Visual Basic
Public Element As Term
Visual C++
public:
Term^ Element
F#
val mutable Element: Term

See Also

ControlException Class
SMath.Math Namespace


Position Field

[image]

SMath Studio Class Libraries Documantation
ControlException..::..Position Field
ControlException Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.ControlException.Position"]

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public int Position
Visual Basic
Public Position As Integer
Visual C++
public:
int Position
F#
val mutable Position: int

See Also

ControlException Class
SMath.Math Namespace


Decision Class

[image]

SMath Studio Class Libraries Documantation
Decision Class
Members See Also Send Feedback
English: Contains main evaluation and substitution methods to work with math expressions.
Русский: Содержит основные методы для обработки и вычисления математических выражений.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public class Decision
Visual Basic
Public Class Decision
Visual C++
public ref class Decision
F#
type Decision =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math..::..Decision

See Also

Decision Members
SMath.Math Namespace


Decision Members

[image] [image]

SMath Studio Class Libraries Documantation
Decision Members
Decision Class Constructors Methods See Also Send Feedback

The Decision type exposes the following members.

Constructors

 | Name | Description
Public method | Decision | Initializes a new instance of the Decision class

Methods

Name | Description
AddDefinition | English: Adds a definition to current evaluation context. Русский: Добавляет определение к текущему контексту вычисления.
NumericCalculation | English: Numeric evaluation of math expression with all possible substitutions based on the evaluation context. Русский: Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
Preprocessing | English: Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plugins, where current term can be handled. Русский: Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.
SymbolicCalculation | English: Symbolic evaluation of math expression with all possible substitutions based on the evaluation context. Русский: Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

See Also

Decision Class
SMath.Math Namespace


Decision Constructor

[image]

SMath Studio Class Libraries Documantation
Decision Constructor
Decision Class See Also Send Feedback
Initializes a new instance of the Decision class

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public Decision()
Visual Basic
Public Sub New
Visual C++
public:
Decision()
F#
new : unit -> Decision

See Also

Decision Class
SMath.Math Namespace


Decision Methods

[image] [image]

SMath Studio Class Libraries Documantation
Decision Methods
Decision Class See Also Send Feedback

The Decision type exposes the following members.

Methods

Name | Description
AddDefinition | English: Adds a definition to current evaluation context. Русский: Добавляет определение к текущему контексту вычисления.
NumericCalculation | English: Numeric evaluation of math expression with all possible substitutions based on the evaluation context. Русский: Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.
Preprocessing | English: Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plugins, where current term can be handled. Русский: Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.
SymbolicCalculation | English: Symbolic evaluation of math expression with all possible substitutions based on the evaluation context. Русский: Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

See Also

Decision Class
SMath.Math Namespace


AddDefinition Method

[image]

SMath Studio Class Libraries Documantation
Decision..::..AddDefinition Method
Decision Class See Also Send Feedback
English: Adds a definition to current evaluation context.
Русский: Добавляет определение к текущему контексту вычисления.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static void AddDefinition(
    Term[] leftPart,
    Term[] rightPart,
    ref Store store
)
Visual Basic
Public Shared Sub AddDefinition ( _
    leftPart As Term(), _
    rightPart As Term(), _
    ByRef store As Store _
)
Visual C++
public:
static void AddDefinition(
    array<Term^>^ leftPart,
    array<Term^>^ rightPart,
    Store^% store
)
F#
static member AddDefinition :
        leftPart:Term[] *
        rightPart:Term[] *
        store:Store byref -> unit

Parameters

leftPart
Type: array< SMath.Manager..::..Term >[]()[][]
English: Left part of the expression to add.
Русский: Левая часть выражения для добавления.
rightPart
Type: array< SMath.Manager..::..Term >[]()[][]
English: Right part of the expression to add.
Русский: Правая часть выражения для добавления.
store
Type: SMath.Manager..::..Store %
English: Current evaluation context.
Русский: Текущий контекст вычисления.

Exceptions

Exception | Condition
SMath.Math..::..ControlException | English: Will thrown if definition cannot be accepted by current context of evaluation. Русский: Произойдёт если определение не может быть принято текущим контекстом вычисления.

See Also

Decision Class
SMath.Math Namespace


NumericCalculation Method

[image]

SMath Studio Class Libraries Documantation
Decision..::..NumericCalculation Method
Decision Class See Also Send Feedback
English: Numeric evaluation of math expression with all possible substitutions based on the evaluation context.
Русский: Численное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static TNumber NumericCalculation(
    Term[] value,
    ref Store store
)
Visual Basic
Public Shared Function NumericCalculation ( _
    value As Term(), _
    ByRef store As Store _
) As TNumber
Visual C++
public:
static TNumber^ NumericCalculation(
    array<Term^>^ value,
    Store^% store
)
F#
static member NumericCalculation :
        value:Term[] *
        store:Store byref -> TNumber

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Math expression to evaluate.
Русский: Математическое выражение для вычисления.
store
Type: SMath.Manager..::..Store %
English: Current evaluation context.
Русский: Текущий контекст вычисления.

Return Value

English: Result of the numeric evaluation.
Русский: Результат численного вычисления выражения.

See Also

Decision Class
SMath.Math Namespace


Preprocessing Method

[image]

SMath Studio Class Libraries Documantation
Decision..::..Preprocessing Method
Decision Class See Also Send Feedback
English: Input Term's array modification by substitution of defined on the page variables and functions. If no such substitution made method tries to use available plugins, where current term can be handled.
Русский: Модификация входящего массива элементов математического выражения подстановкой заданных на листе переменных и функций. В случае, когда соответствующей подстановки сделать невозможно производится опрос плагинов на предмет реализации у них данной единицы выражения.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static Term[] Preprocessing(
    Term[] value,
    ref Store store
)
Visual Basic
Public Shared Function Preprocessing ( _
    value As Term(), _
    ByRef store As Store _
) As Term()
Visual C++
public:
static array<Term^>^ Preprocessing(
    array<Term^>^ value,
    Store^% store
)
F#
static member Preprocessing :
        value:Term[] *
        store:Store byref -> Term[]

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Math expression to perform all kind of substitutions.
Русский: Математическое выражение для проведения всех возможных подстановок.
store
Type: SMath.Manager..::..Store %
English: Current evaluation context.
Русский: Текущий контекст вычисления.

Return Value

English: Substitutions result.
Русский: Результат подстановок.

See Also

Decision Class
SMath.Math Namespace


SymbolicCalculation Method

[image]

SMath Studio Class Libraries Documantation
Decision..::..SymbolicCalculation Method
Decision Class See Also Send Feedback
English: Symbolic evaluation of math expression with all possible substitutions based on the evaluation context.
Русский: Символьное вычисление математического выражения со всеми возможными подстановками, в зависимости от текущего контекста вычисления.

Namespace: SMath.Math
Assembly: canvas (in canvas.dll) Version: 0.88.3855.30321

Syntax

C#
public static Term[] SymbolicCalculation(
    Term[] value,
    ref Store store
)
Visual Basic
Public Shared Function SymbolicCalculation ( _
    value As Term(), _
    ByRef store As Store _
) As Term()
Visual C++
public:
static array<Term^>^ SymbolicCalculation(
    array<Term^>^ value,
    Store^% store
)
F#
static member SymbolicCalculation :
        value:Term[] *
        store:Store byref -> Term[]

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Math expression to evaluate.
Русский: Математическое выражение для вычисления.
store
Type: SMath.Manager..::..Store %
English: Current evaluation context.
Русский: Текущий контекст вычисления.

Return Value

English: Result of the symbolic evaluation.
Русский: Результат символьного вычисления выражения.

See Also

Decision Class
SMath.Math Namespace


SMath.Math.Numeric Namespace

[image]

SMath Studio Class Libraries Documantation
SMath.Math.Numeric Namespace
Send Feedback

[Missing <summary> documentation for "N:SMath.Math.Numeric"]

Classes

 | Class | Description
Public class | BaseEntry | English: Base class for the numeric components of math expression. Русский: Базовый класс для численных математических примитивов.
Public class | Constants |
Public class | Expression | English: Numeric evaluation methods. Русский: Численные методы вычислений.
Public class | TComplex |
Public class | TDouble |
Public class | TFraction |
Public class | TInfinity |
Public class | TMatrix |
Public class | TNumber | Менеджер численных математических примитивов.
Public class | TSystem |
Public class | VariableNotDefinedException |

Interfaces

 | Interface | Description
Public interface | IPluginMathNumericEvaluation | English: Interface for the numeric evaluation plugins. Русский: Интерфейс для дополнений (плагинов), организующих численное вычисление.

Enumerations

 | Enumeration | Description
Public enumeration | InfType |


BaseEntry Class

[image]

SMath Studio Class Libraries Documantation
BaseEntry Class
Members See Also Send Feedback
English: Base class for the numeric components of math expression.
Русский: Базовый класс для численных математических примитивов.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class BaseEntry
Visual Basic
Public Class BaseEntry
Visual C++
public ref class BaseEntry
F#
type BaseEntry =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TComplex
SMath.Math.Numeric..::..TDouble
SMath.Math.Numeric..::..TFraction
SMath.Math.Numeric..::..TInfinity
SMath.Math.Numeric..::..TMatrix
SMath.Math.Numeric..::..TSystem

See Also

BaseEntry Members
SMath.Math.Numeric Namespace


BaseEntry Members

[image] [image]

SMath Studio Class Libraries Documantation
BaseEntry Members
BaseEntry Class Constructors Methods Properties See Also Send Feedback

The BaseEntry type exposes the following members.

Constructors

 | Name | Description
Public method | BaseEntry | Initializes a new instance of the BaseEntry class

Methods

 | Name | Description
Public method | Clone | English: Copying of the expression component. Русский: Копирование математического примитива.
Public method | Com | English: Addition (composition) operation. Русский: Операция сложения.
Public method | Div | English: Division operation. Русский: Операция деления.
 | FireExceptionIfUnits | English: Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units. Русский: Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.
Public method | Mul | English: Multiplication operation. Русский: Операция умножения.
Public method | Pow | English: Exponentiation operation. Русский: Операция возведения в степень.
Public method | Sub | English: Subtruction operation. Русский: Операция вычитания.
Public method | ToDouble | English: Converts current expression component to Double value. Русский: Преобразование математического примитива к числу с плавающей запятой.
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32, FractionsType) | English: Converts math expression component to string with options. Русский: Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry Constructor

[image]

SMath Studio Class Libraries Documantation
BaseEntry Constructor
BaseEntry Class See Also Send Feedback
Initializes a new instance of the BaseEntry class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public BaseEntry()
Visual Basic
Public Sub New
Visual C++
public:
BaseEntry()
F#
new : unit -> BaseEntry

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


BaseEntry Methods

[image] [image]

SMath Studio Class Libraries Documantation
BaseEntry Methods
BaseEntry Class See Also Send Feedback

The BaseEntry type exposes the following members.

Methods

 | Name | Description
Public method | Clone | English: Copying of the expression component. Русский: Копирование математического примитива.
Public method | Com | English: Addition (composition) operation. Русский: Операция сложения.
Public method | Div | English: Division operation. Русский: Операция деления.
 | FireExceptionIfUnits | English: Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units. Русский: Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.
Public method | Mul | English: Multiplication operation. Русский: Операция умножения.
Public method | Pow | English: Exponentiation operation. Русский: Операция возведения в степень.
Public method | Sub | English: Subtruction operation. Русский: Операция вычитания.
Public method | ToDouble | English: Converts current expression component to Double value. Русский: Преобразование математического примитива к числу с плавающей запятой.
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32, FractionsType) | English: Converts math expression component to string with options. Русский: Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Clone Method
BaseEntry Class See Also Send Feedback
English: Copying of the expression component.
Русский: Копирование математического примитива.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Clone()
Visual Basic
Public Overridable Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone()
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

English: Returns a copy of current expression component.
Русский: Копия исходного математического примитива.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Com Method
BaseEntry Class See Also Send Feedback
English: Addition (composition) operation.
Русский: Операция сложения.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overridable Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
)
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry
English: Second operand.
Русский: Второй операнд.

Return Value

English: Addition (composition) result.
Русский: Результат сложения.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Div Method
BaseEntry Class See Also Send Feedback
English: Division operation.
Русский: Операция деления.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overridable Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
)
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry
English: Second operand (divisor).
Русский: Делитель.

Return Value

English: Division result.
Русский: Результат деления.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


FireExceptionIfUnits Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..FireExceptionIfUnits Method
BaseEntry Class See Also Send Feedback
English: Fires an Operation Can Not be Performed With Units exception if one or several of the specified expression components contains Units.
Русский: Проверка математических примитивов на присутствие в них единиц измерения. Если единицы измерения будут найдены, то вызовется ошибка вычисления с сообщением, что единицы измерения не могут быть использованы.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static void FireExceptionIfUnits(
    params BaseEntry[] args
)
Visual Basic
Public Shared Sub FireExceptionIfUnits ( _
    ParamArray args As BaseEntry() _
)
Visual C++
public:
static void FireExceptionIfUnits(
    ... array<BaseEntry^>^ args
)
F#
static member FireExceptionIfUnits :
        args:BaseEntry[] -> unit

Parameters

args
Type: array< SMath.Math.Numeric..::..BaseEntry >[]()[][]
English: List of the expression components to check.
Русский: Список математических примитивов для проверки.

Remarks

English: Expression components that contains Unit equal to 1 will not cause and exception.
Русский: Компоненты выражения, которые содержат единицу (1) в качестве единицы измерения, не будут вызывать ошибку.

Exceptions

Exception | Condition
SMath.Manager..::..EvaluationException | English: Thrown if one of the expression components contains Units. Русский: Возникает, если хотя бы один из переданных метаматических примитивов содержит единицы измерения.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Mul Method
BaseEntry Class See Also Send Feedback
English: Multiplication operation.
Русский: Операция умножения.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overridable Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
)
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry
English: Second operand.
Русский: Второй операнд.

Return Value

English: Multiplication result.
Русский: Результат умножения.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Pow Method
BaseEntry Class See Also Send Feedback
English: Exponentiation operation.
Русский: Операция возведения в степень.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overridable Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
)
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry
English: Second operand (index).
Русский: Показатель степени.

Return Value

English: Exponentiation result.
Русский: Результат возведения в степень.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Sub Method
BaseEntry Class See Also Send Feedback
English: Subtruction operation.
Русский: Операция вычитания.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overridable Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
)
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry
English: Second operand.
Русский: Второй операнд.

Return Value

English: Subtraction result.
Русский: Результат вычитания.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToDouble Method
BaseEntry Class See Also Send Feedback
English: Converts current expression component to Double value.
Русский: Преобразование математического примитива к числу с плавающей запятой.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual double ToDouble()
Visual Basic
Public Overridable Function ToDouble As Double
Visual C++
public:
virtual double ToDouble()
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

English: Returns Double.
Русский: Число с плавающей запятой.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToString Method
BaseEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Overrides Object..::..ToString()()()().)
Public method | ToString(Int32, FractionsType) | English: Converts math expression component to string with options. Русский: Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.

See Also

BaseEntry Class
BaseEntry Members
SMath.Math.Numeric Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToString Method
BaseEntry Class See Also Send Feedback
English: Converts math expression component to string.
Русский: Преобразование математического примитива в строку.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

English: Expression component represented as a string.
Русский: Математический примитив в виде строки.

See Also

BaseEntry Class
ToString Overload
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToString Method (Int32, FractionsType)
BaseEntry Class See Also Send Feedback
English: Converts math expression component to string with options.
Русский: Преобразование математического примитива в строку с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overridable Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
)
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32
English: Decimsl places of the result value.
Русский: Число значащих цифр после запятой.
fractionType
Type: SMath.Manager..::..FractionsType
English: Fraction type of the result value.
Русский: Тип дробей.

Return Value

English: Expression component represented as a string.
Русский: Строка с учётом заданного количества цифр после запятой.

See Also

BaseEntry Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToTerms Method
BaseEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов.
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

See Also

BaseEntry Class
BaseEntry Members
SMath.Math.Numeric Namespace


ToTerms Method

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToTerms Method
BaseEntry Class See Also Send Feedback
English: Converts current expression component to the array of Term in reverse polish notation (RPN).
Русский: Преобразование математического примитива в массив базовых примитивов.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual Term[] ToTerms()
Visual Basic
Public Overridable Function ToTerms As Term()
Visual C++
public:
virtual array<Term^>^ ToTerms()
F#
abstract ToTerms : unit -> Term[]
override ToTerms : unit -> Term[]

Return Value

English: Array of Term in RPN.
Русский: Массив базовых примитивов.

See Also

BaseEntry Class
ToTerms Overload
SMath.Math.Numeric Namespace


ToTerms Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..ToTerms Method (Int32, FractionsType)
BaseEntry Class See Also Send Feedback
English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options.
Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public virtual Term[] ToTerms(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overridable Function ToTerms ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As Term()
Visual C++
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    FractionsType fractionType
)
F#
abstract ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]
override ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]

Parameters

decimalPlaces
Type: System..::..Int32
English: Decimsl places of the result value.
Русский: Число значащих цифр после запятой.
fractionType
Type: SMath.Manager..::..FractionsType
English: Fraction type of the result value.
Русский: Тип дробей.

Return Value

English: Array of Term in RPN.
Русский: Массив базовых примитивов с учётом заданного количества цифр после запятой.

See Also

BaseEntry Class
ToTerms Overload
SMath.Math.Numeric Namespace


BaseEntry Properties

[image] [image]

SMath Studio Class Libraries Documantation
BaseEntry Properties
BaseEntry Class See Also Send Feedback

The BaseEntry type exposes the following members.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Units Property

[image]

SMath Studio Class Libraries Documantation
BaseEntry..::..Units Property
BaseEntry Class See Also Send Feedback
English: Unit of the expression component.
Русский: Размерность математического примитива.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public MItem Units { get; set; }
Visual Basic
Public Property Units As MItem
    Get
    Set
Visual C++
public:
property MItem^ Units {
    MItem^ get ();
    void set (MItem^ value);
}
F#
member Units : MItem with get, set

Remarks

English: Every instance of the class has a Unit defined inside and this Unit is equal to 1. This is a requirement for every numeric expression component.
Русский: Каждый экземпляр класса содержит в себе единицу измерения равную единице. Единица измерения является обязательным условием для каждого численного примитива.

See Also

BaseEntry Class
SMath.Math.Numeric Namespace


Constants Class

[image]

SMath Studio Class Libraries Documantation
Constants Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.Constants"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class Constants
Visual Basic
Public Class Constants
Visual C++
public ref class Constants
F#
type Constants =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..Constants

See Also

Constants Members
SMath.Math.Numeric Namespace


Constants Members

[image] [image]

SMath Studio Class Libraries Documantation
Constants Members
Constants Class Constructors Fields Properties See Also Send Feedback

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants | Initializes a new instance of the Constants class

Fields

Name | Description
random |

Properties

Name | Description
cp | PI/180
cpr |
ei | e^i

See Also

Constants Class
SMath.Math.Numeric Namespace


Constants Constructor

[image]

SMath Studio Class Libraries Documantation
Constants Constructor
Constants Class See Also Send Feedback
Initializes a new instance of the Constants class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public Constants()
Visual Basic
Public Sub New
Visual C++
public:
Constants()
F#
new : unit -> Constants

See Also

Constants Class
SMath.Math.Numeric Namespace


Constants Fields

[image] [image]

SMath Studio Class Libraries Documantation
Constants Fields
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Fields

Name | Description
random |

See Also

Constants Class
SMath.Math.Numeric Namespace


random Field

[image]

SMath Studio Class Libraries Documantation
Constants..::..random Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.Constants.random"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static Random random
Visual Basic
Public Shared random As Random
Visual C++
public:
static Random^ random
F#
static val mutable random: Random

See Also

Constants Class
SMath.Math.Numeric Namespace


Constants Properties

[image] [image]

SMath Studio Class Libraries Documantation
Constants Properties
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Properties

Name | Description
cp | PI/180
cpr |
ei | e^i

See Also

Constants Class
SMath.Math.Numeric Namespace


cp Property

[image]

SMath Studio Class Libraries Documantation
Constants..::..cp Property
Constants Class See Also Send Feedback
PI/180

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TDouble cp { get; }
Visual Basic
Public Shared ReadOnly Property cp As TDouble
    Get
Visual C++
public:
static property TDouble^ cp {
    TDouble^ get ();
}
F#
static member cp : TDouble

See Also

Constants Class
SMath.Math.Numeric Namespace


cpr Property

[image]

SMath Studio Class Libraries Documantation
Constants..::..cpr Property
Constants Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Math.Numeric.Constants.cpr"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TComplex cpr { get; }
Visual Basic
Public Shared ReadOnly Property cpr As TComplex
    Get
Visual C++
public:
static property TComplex^ cpr {
    TComplex^ get ();
}
F#
static member cpr : TComplex

See Also

Constants Class
SMath.Math.Numeric Namespace


ei Property

[image]

SMath Studio Class Libraries Documantation
Constants..::..ei Property
Constants Class See Also Send Feedback
e^i

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TComplex ei { get; }
Visual Basic
Public Shared ReadOnly Property ei As TComplex
    Get
Visual C++
public:
static property TComplex^ ei {
    TComplex^ get ();
}
F#
static member ei : TComplex

See Also

Constants Class
SMath.Math.Numeric Namespace


Expression Class

[image]

SMath Studio Class Libraries Documantation
Expression Class
Members See Also Send Feedback
English: Numeric evaluation methods.
Русский: Численные методы вычислений.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class Expression
Visual Basic
Public Class Expression
Visual C++
public ref class Expression
F#
type Expression =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..Expression

See Also

Expression Members
SMath.Math.Numeric Namespace


Expression Members

[image] [image]

SMath Studio Class Libraries Documantation
Expression Members
Expression Class Constructors Methods See Also Send Feedback

The Expression type exposes the following members.

Constructors

 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class

Methods

Name | Description
Calculate | English: Nymeric expression evaluation. Русский: Численное вычисление выражения.

See Also

Expression Class
SMath.Math.Numeric Namespace


Expression Constructor

[image]

SMath Studio Class Libraries Documantation
Expression Constructor
Expression Class See Also Send Feedback
Initializes a new instance of the Expression class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public Expression()
Visual Basic
Public Sub New
Visual C++
public:
Expression()
F#
new : unit -> Expression

See Also

Expression Class
SMath.Math.Numeric Namespace


Expression Methods

[image] [image]

SMath Studio Class Libraries Documantation
Expression Methods
Expression Class See Also Send Feedback

The Expression type exposes the following members.

Methods

Name | Description
Calculate | English: Nymeric expression evaluation. Русский: Численное вычисление выражения.

See Also

Expression Class
SMath.Math.Numeric Namespace


Calculate Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Calculate Method
Expression Class See Also Send Feedback
English: Nymeric expression evaluation.
Русский: Численное вычисление выражения.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber Calculate(
    Term[] value,
    Store store
)
Visual Basic
Public Shared Function Calculate ( _
    value As Term(), _
    store As Store _
) As TNumber
Visual C++
public:
static TNumber^ Calculate(
    array<Term^>^ value,
    Store^ store
)
F#
static member Calculate :
        value:Term[] *
        store:Store -> TNumber

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
English: Expression to ebaluate numerically.
Русский: Выражение для вычисления.
store
Type: SMath.Manager..::..Store
English: Current evaluation context.
Русский: Контекст выполнения вычисления.

Return Value

English: Result of the numeric evaluation.
Русский: Результат численного вычисления.

See Also

Expression Class
SMath.Math.Numeric Namespace


InfType Enumeration

[image]

SMath Studio Class Libraries Documantation
InfType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.InfType"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public enum InfType
Visual Basic
Public Enumeration InfType
Visual C++
public enum class InfType
F#
type InfType

Members

Member name | Value | Description
_inf | 0 |
val | 1 |
inf | 2 |

See Also

SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Interface

[image]

SMath Studio Class Libraries Documantation
IPluginMathNumericEvaluation Interface
Members See Also Send Feedback
English: Interface for the numeric evaluation plugins.
Русский: Интерфейс для дополнений (плагинов), организующих численное вычисление.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public interface IPluginMathNumericEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
Visual Basic
Public Interface IPluginMathNumericEvaluation _
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
Visual C++
public interface class IPluginMathNumericEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
F#
type IPluginMathNumericEvaluation =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginMathNumericEvaluation Members
SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathNumericEvaluation Members
IPluginMathNumericEvaluation Interface Methods Properties See Also Send Feedback

The IPluginMathNumericEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | NumericEvaluation | English: Numerical calculation of the element. Русский: Численное вычисление компонента выражения.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathNumericEvaluation Methods
IPluginMathNumericEvaluation Interface See Also Send Feedback

The IPluginMathNumericEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | NumericEvaluation | English: Numerical calculation of the element. Русский: Численное вычисление компонента выражения.

See Also

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


NumericEvaluation Method

[image]

SMath Studio Class Libraries Documantation
IPluginMathNumericEvaluation..::..NumericEvaluation Method
IPluginMathNumericEvaluation Interface See Also Send Feedback
English: Numerical calculation of the element.
Русский: Численное вычисление компонента выражения.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
bool NumericEvaluation(
    Term value,
    TNumber[] args,
    ref TNumber result
)
Visual Basic
Function NumericEvaluation ( _
    value As Term, _
    args As TNumber(), _
    ByRef result As TNumber _
) As Boolean
Visual C++
bool NumericEvaluation(
    Term^ value,
    array<TNumber^>^ args,
    TNumber^% result
)
F#
abstract NumericEvaluation :
        value:Term *
        args:TNumber[] *
        result:TNumber byref -> bool

Parameters

value
Type: SMath.Manager..::..Term
English: Term to evaluate.
Русский: Компонент выражения для вычисления.
args
Type: array< SMath.Math.Numeric..::..TNumber >[]()[][]
English: Arguments of the element.
Русский: Аргументы компонента выражения.
result
Type: SMath.Math.Numeric..::..TNumber %
English: Numeric evaluation result.
Русский: Результат численных вычислений.

Return Value

English: Indicates success of evaluation.
Русский: Возвращает статус результата вычисления.

See Also

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


IPluginMathNumericEvaluation Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathNumericEvaluation Properties
IPluginMathNumericEvaluation Interface See Also Send Feedback

The IPluginMathNumericEvaluation type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginMathNumericEvaluation Interface
SMath.Math.Numeric Namespace


TComplex Class

[image]

SMath Studio Class Libraries Documantation
TComplex Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TComplex : BaseEntry
Visual Basic
Public Class TComplex _
    Inherits BaseEntry
Visual C++
public ref class TComplex : public BaseEntry
F#
type TComplex =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TComplex

See Also

TComplex Members
SMath.Math.Numeric Namespace


TComplex Members

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Members
TComplex Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TComplex type exposes the following members.

Constructors

 | Name | Description
Public method | TComplex(TComplex) |
Public method | TComplex(Double, Double) |
Public method | TComplex(TDouble, TDouble) |
Public method | TComplex(TFraction, TFraction) |
Public method | TComplex(TInfinity, TInfinity) |

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Ln |
Public method | Log |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | pol2xy |
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | xy2pol()()()() |
Public method | xy2pol(TComplex) |

Operators

Name | Description
Addition |
Division |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TComplex) |
Inequality |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | Im |
Public field | Re |

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TComplex Class
SMath.Math.Numeric Namespace


TComplex Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Constructor
TComplex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TComplex(TComplex) | Initializes a new instance of the TComplex class
Public method | TComplex(Double, Double) | Initializes a new instance of the TComplex class
Public method | TComplex(TDouble, TDouble) | Initializes a new instance of the TComplex class
Public method | TComplex(TFraction, TFraction) | Initializes a new instance of the TComplex class
Public method | TComplex(TInfinity, TInfinity) | Initializes a new instance of the TComplex class

See Also

TComplex Class
TComplex Members
SMath.Math.Numeric Namespace


TComplex Constructor (TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex Constructor (TComplex)
TComplex Class See Also Send Feedback
Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex(
    TComplex value
)
Visual Basic
Public Sub New ( _
    value As TComplex _
)
Visual C++
public:
TComplex(
    TComplex^ value
)
F#
new :
        value:TComplex -> TComplex

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (Double, Double)

[image]

SMath Studio Class Libraries Documantation
TComplex Constructor (Double, Double)
TComplex Class See Also Send Feedback
Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex(
    double Re,
    double Im
)
Visual Basic
Public Sub New ( _
    Re As Double, _
    Im As Double _
)
Visual C++
public:
TComplex(
    double Re,
    double Im
)
F#
new :
        Re:float *
        Im:float -> TComplex

Parameters

Re
Type: System..::..Double

[Missing <param name="Re"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(System.Double,System.Double)"]

Im
Type: System..::..Double

[Missing <param name="Im"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(System.Double,System.Double)"]

See Also

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (TDouble, TDouble)

[image]

SMath Studio Class Libraries Documantation
TComplex Constructor (TDouble, TDouble)
TComplex Class See Also Send Feedback
Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex(
    TDouble Re,
    TDouble Im
)
Visual Basic
Public Sub New ( _
    Re As TDouble, _
    Im As TDouble _
)
Visual C++
public:
TComplex(
    TDouble^ Re,
    TDouble^ Im
)
F#
new :
        Re:TDouble *
        Im:TDouble -> TComplex

Parameters

Re
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="Re"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Im
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="Im"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TComplex Constructor (TFraction, TFraction)
TComplex Class See Also Send Feedback
Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex(
    TFraction Re,
    TFraction Im
)
Visual Basic
Public Sub New ( _
    Re As TFraction, _
    Im As TFraction _
)
Visual C++
public:
TComplex(
    TFraction^ Re,
    TFraction^ Im
)
F#
new :
        Re:TFraction *
        Im:TFraction -> TComplex

Parameters

Re
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="Re"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Im
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="Im"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Constructor (TInfinity, TInfinity)

[image]

SMath Studio Class Libraries Documantation
TComplex Constructor (TInfinity, TInfinity)
TComplex Class See Also Send Feedback
Initializes a new instance of the TComplex class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex(
    TInfinity Re,
    TInfinity Im
)
Visual Basic
Public Sub New ( _
    Re As TInfinity, _
    Im As TInfinity _
)
Visual C++
public:
TComplex(
    TInfinity^ Re,
    TInfinity^ Im
)
F#
new :
        Re:TInfinity *
        Im:TInfinity -> TComplex

Parameters

Re
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="Re"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Im
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="Im"/> documentation for "M:SMath.Math.Numeric.TComplex.#ctor(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TComplex Class
TComplex Overload
SMath.Math.Numeric Namespace


TComplex Fields

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Fields
TComplex Class See Also Send Feedback

The TComplex type exposes the following members.

Fields

 | Name | Description
Public field | Im |
Public field | Re |

See Also

TComplex Class
SMath.Math.Numeric Namespace


Im Field

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Im Field
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TComplex.Im"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity Im
Visual Basic
Public Im As TInfinity
Visual C++
public:
TInfinity^ Im
F#
val mutable Im: TInfinity

See Also

TComplex Class
SMath.Math.Numeric Namespace


Re Field

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Re Field
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TComplex.Re"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity Re
Visual Basic
Public Re As TInfinity
Visual C++
public:
TInfinity^ Re
F#
val mutable Re: TInfinity

See Also

TComplex Class
SMath.Math.Numeric Namespace


TComplex Methods

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Methods
TComplex Class See Also Send Feedback

The TComplex type exposes the following members.

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Ln |
Public method | Log |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | pol2xy |
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | xy2pol()()()() |
Public method | xy2pol(TComplex) |

See Also

TComplex Class
SMath.Math.Numeric Namespace


Abs Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Abs Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Abs"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Abs()
Visual Basic
Public Function Abs As Double
Visual C++
public:
double Abs()
F#
member Abs : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Abs"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ACos Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ACos Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ACos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACos()
Visual Basic
Public Function ACos As TNumber
Visual C++
public:
TNumber^ ACos()
F#
member ACos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ACos"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ACosH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ACosH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ACosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACosH()
Visual Basic
Public Function ACosH As TNumber
Visual C++
public:
TNumber^ ACosH()
F#
member ACosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ACosH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ACot Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ACot Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ACot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACot()
Visual Basic
Public Function ACot As TNumber
Visual C++
public:
TNumber^ ACot()
F#
member ACot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ACot"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ACotH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ACotH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ACotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACotH()
Visual Basic
Public Function ACotH As TNumber
Visual C++
public:
TNumber^ ACotH()
F#
member ACotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ACotH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Arg Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Arg Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Arg"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Arg()
Visual Basic
Public Function Arg As Double
Visual C++
public:
double Arg()
F#
member Arg : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Arg"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ASin Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ASin Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ASin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASin()
Visual Basic
Public Function ASin As TNumber
Visual C++
public:
TNumber^ ASin()
F#
member ASin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ASin"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ASinH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ASinH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ASinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASinH()
Visual Basic
Public Function ASinH As TNumber
Visual C++
public:
TNumber^ ASinH()
F#
member ASinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ASinH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ATan Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ATan Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ATan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATan()
Visual Basic
Public Function ATan As TNumber
Visual C++
public:
TNumber^ ATan()
F#
member ATan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ATan"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ATanH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ATanH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ATanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATanH()
Visual Basic
Public Function ATanH As TNumber
Visual C++
public:
TNumber^ ATanH()
F#
member ATanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ATanH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Clone Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Clone"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Com Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Cos Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Cos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cos()
Visual Basic
Public Function Cos As TNumber
Visual C++
public:
TNumber^ Cos()
F#
member Cos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Cos"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


CosH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..CosH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.CosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CosH()
Visual Basic
Public Function CosH As TNumber
Visual C++
public:
TNumber^ CosH()
F#
member CosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.CosH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Cot Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Cot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cot()
Visual Basic
Public Function Cot As TNumber
Visual C++
public:
TNumber^ Cot()
F#
member Cot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Cot"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


CotH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..CotH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.CotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CotH()
Visual Basic
Public Function CotH As TNumber
Visual C++
public:
TNumber^ CotH()
F#
member CotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.CotH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Div Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Equals Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TComplex.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Equals(System.Object)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..GetHashCode Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.GetHashCode"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Ln Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Ln Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Ln"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex Ln()
Visual Basic
Public Function Ln As TComplex
Visual C++
public:
TComplex^ Ln()
F#
member Ln : unit -> TComplex

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Ln"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Log Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Log Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Log(SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex Log(
    TComplex Base
)
Visual Basic
Public Function Log ( _
    Base As TComplex _
) As TComplex
Visual C++
public:
TComplex^ Log(
    TComplex^ Base
)
F#
member Log :
        Base:TComplex -> TComplex

Parameters

Base
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="Base"/> documentation for "M:SMath.Math.Numeric.TComplex.Log(SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Log(SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Mul Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


pol2xy Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..pol2xy Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.pol2xy(SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber pol2xy(
    TComplex value
)
Visual Basic
Public Function pol2xy ( _
    value As TComplex _
) As TNumber
Visual C++
public:
TNumber^ pol2xy(
    TComplex^ value
)
F#
member pol2xy :
        value:TComplex -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.pol2xy(SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.pol2xy(SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Pow Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Power Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Power(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TNumber value
)
Visual Basic
Public Function Power ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TNumber^ value
)
F#
member Power :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Power(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Power(SMath.Math.Numeric.TNumber)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Sin Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Sin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sin()
Visual Basic
Public Function Sin As TNumber
Visual C++
public:
TNumber^ Sin()
F#
member Sin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Sin"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


SinH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..SinH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.SinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber SinH()
Visual Basic
Public Function SinH As TNumber
Visual C++
public:
TNumber^ SinH()
F#
member SinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.SinH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Sub Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Tan Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.Tan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Tan()
Visual Basic
Public Function Tan As TNumber
Visual C++
public:
TNumber^ Tan()
F#
member Tan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.Tan"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


TanH Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..TanH Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.TanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber TanH()
Visual Basic
Public Function TanH As TNumber
Visual C++
public:
TNumber^ TanH()
F#
member TanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.TanH"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ToDouble Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ToDouble"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TComplex..::..ToString Method
TComplex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TComplex Class
TComplex Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TComplex..::..ToString Method (Int32, FractionsType)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TComplex.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TComplex.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TComplex Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TComplex..::..ToTerms Method
TComplex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TComplex Class
TComplex Members
SMath.Math.Numeric Namespace


xy2pol Method

[image] [image]

SMath Studio Class Libraries Documantation
TComplex..::..xy2pol Method
TComplex Class See Also Send Feedback

Overload List

 | Name | Description
Public method | xy2pol()()()() |
Public method | xy2pol(TComplex) |

See Also

TComplex Class
TComplex Members
SMath.Math.Numeric Namespace


xy2pol Method

[image]

SMath Studio Class Libraries Documantation
TComplex..::..xy2pol Method
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.xy2pol"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber xy2pol()
Visual Basic
Public Function xy2pol As TNumber
Visual C++
public:
TNumber^ xy2pol()
F#
member xy2pol : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.xy2pol"]

See Also

TComplex Class
xy2pol Overload
SMath.Math.Numeric Namespace


xy2pol Method (TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex..::..xy2pol Method (TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.xy2pol(SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber xy2pol(
    TComplex value
)
Visual Basic
Public Function xy2pol ( _
    value As TComplex _
) As TNumber
Visual C++
public:
TNumber^ xy2pol(
    TComplex^ value
)
F#
member xy2pol :
        value:TComplex -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.xy2pol(SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.xy2pol(SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
xy2pol Overload
SMath.Math.Numeric Namespace


TComplex Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Operators and Type Conversions
TComplex Class See Also Send Feedback

The TComplex type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TComplex) |
Inequality |
Multiply |
Subtraction |

See Also

TComplex Class
SMath.Math.Numeric Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Addition Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TComplex, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (+)
        c1:TComplex *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Division Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TComplex, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (/)
        c1:TComplex *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Equality Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Equality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TComplex, _
    c2 As TComplex _
) As Boolean
Visual C++
public:
static bool operator ==(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (=)
        c1:TComplex *
        c2:TComplex  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Equality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Equality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Equality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Implicit Conversion Operators

[image] [image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion Operators
TComplex Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TComplex) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TComplex) |

See Also

TComplex Class
TComplex Members
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion (Double to TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(System.Double)~SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TComplex (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TComplex
Visual C++
static implicit operator TComplex^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(System.Double)~SMath.Math.Numeric.TComplex"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(System.Double)~SMath.Math.Numeric.TComplex"]

See Also

TComplex Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TDouble to TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion (TDouble to TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TComplex (
    TDouble value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TDouble _
) As TComplex
Visual C++
static implicit operator TComplex^ (
    TDouble^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TComplex"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TComplex"]

See Also

TComplex Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TFraction to TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion (TFraction to TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TComplex (
    TFraction value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TFraction _
) As TComplex
Visual C++
static implicit operator TComplex^ (
    TFraction^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TComplex"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TComplex"]

See Also

TComplex Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TInfinity to TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion (TInfinity to TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TComplex (
    TInfinity value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TInfinity _
) As TComplex
Visual C++
static implicit operator TComplex^ (
    TInfinity^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TComplex"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TComplex"]

See Also

TComplex Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TNumber to TComplex)

[image]

SMath Studio Class Libraries Documantation
TComplex ImplicitWideningImplicitImplicitImplicit Conversion (TNumber to TComplex)
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TComplex"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TComplex (
    TNumber value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TNumber _
) As TComplex
Visual C++
static implicit operator TComplex^ (
    TNumber^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TComplex"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TComplex"]

See Also

TComplex Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Inequality Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Inequality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TComplex, _
    c2 As TComplex _
) As Boolean
Visual C++
public:
static bool operator !=(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (<>)
        c1:TComplex *
        c2:TComplex  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Inequality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Inequality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Inequality(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Multiply Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TComplex, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (*)
        c1:TComplex *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
TComplex..::..Subtraction Operator
TComplex Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TComplex.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TComplex c1,
    TComplex c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TComplex, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TComplex^ c1,
    TComplex^ c2
)
F#
static let inline (-)
        c1:TComplex *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TComplex.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TComplex.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TComplex)"]

See Also

TComplex Class
SMath.Math.Numeric Namespace


TComplex Properties

[image] [image]

SMath Studio Class Libraries Documantation
TComplex Properties
TComplex Class See Also Send Feedback

The TComplex type exposes the following members.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TComplex Class
SMath.Math.Numeric Namespace


TDouble Class

[image]

SMath Studio Class Libraries Documantation
TDouble Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TDouble : BaseEntry
Visual Basic
Public Class TDouble _
    Inherits BaseEntry
Visual C++
public ref class TDouble : public BaseEntry
F#
type TDouble =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TDouble

See Also

TDouble Members
SMath.Math.Numeric Namespace


TDouble Members

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Members
TDouble Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TDouble type exposes the following members.

Constructors

 | Name | Description
Public method | TDouble(Double) |
Public method | TDouble(String) |
Public method | TDouble(TDouble) |

Methods

 | Name | Description
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Identity |
Public method | Matrix |
Public method | Mod |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Random |
Public method | Sign |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TDouble) |
Inequality |
LessThan |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | isText |
Public field | Text |

Properties

 | Name | Description
Public property | D |
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TDouble Class
SMath.Math.Numeric Namespace


TDouble Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Constructor
TDouble Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TDouble(Double) | Initializes a new instance of the TDouble class
Public method | TDouble(String) | Initializes a new instance of the TDouble class
Public method | TDouble(TDouble) | Initializes a new instance of the TDouble class

See Also

TDouble Class
TDouble Members
SMath.Math.Numeric Namespace


TDouble Constructor (Double)

[image]

SMath Studio Class Libraries Documantation
TDouble Constructor (Double)
TDouble Class See Also Send Feedback
Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble(
    double D
)
Visual Basic
Public Sub New ( _
    D As Double _
)
Visual C++
public:
TDouble(
    double D
)
F#
new :
        D:float -> TDouble

Parameters

D
Type: System..::..Double

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TDouble.#ctor(System.Double)"]

See Also

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Constructor (String)

[image]

SMath Studio Class Libraries Documantation
TDouble Constructor (String)
TDouble Class See Also Send Feedback
Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)
Visual C++
public:
TDouble(
    String^ text
)
F#
new :
        text:string -> TDouble

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:SMath.Math.Numeric.TDouble.#ctor(System.String)"]

See Also

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Constructor (TDouble)

[image]

SMath Studio Class Libraries Documantation
TDouble Constructor (TDouble)
TDouble Class See Also Send Feedback
Initializes a new instance of the TDouble class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble(
    TDouble D
)
Visual Basic
Public Sub New ( _
    D As TDouble _
)
Visual C++
public:
TDouble(
    TDouble^ D
)
F#
new :
        D:TDouble -> TDouble

Parameters

D
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TDouble.#ctor(SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
TDouble Overload
SMath.Math.Numeric Namespace


TDouble Fields

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Fields
TDouble Class See Also Send Feedback

The TDouble type exposes the following members.

Fields

 | Name | Description
Public field | isText |
Public field | Text |

See Also

TDouble Class
SMath.Math.Numeric Namespace


isText Field

[image]

SMath Studio Class Libraries Documantation
TDouble..::..isText Field
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TDouble.isText"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public bool isText
Visual Basic
Public isText As Boolean
Visual C++
public:
bool isText
F#
val mutable isText: bool

See Also

TDouble Class
SMath.Math.Numeric Namespace


Text Field

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Text Field
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TDouble.Text"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public string Text
Visual Basic
Public Text As String
Visual C++
public:
String^ Text
F#
val mutable Text: string

See Also

TDouble Class
SMath.Math.Numeric Namespace


TDouble Methods

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Methods
TDouble Class See Also Send Feedback

The TDouble type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Identity |
Public method | Matrix |
Public method | Mod |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Random |
Public method | Sign |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TDouble Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Clone Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Clone"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Com Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Div Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Equals Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TDouble.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Equals(System.Object)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Factorial Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Factorial Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Factorial"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble Factorial()
Visual Basic
Public Function Factorial As TDouble
Visual C++
public:
TDouble^ Factorial()
F#
member Factorial : unit -> TDouble

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Factorial"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..GetHashCode Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.GetHashCode"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Identity Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Identity Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Identity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Identity()
Visual Basic
Public Function Identity As TMatrix
Visual C++
public:
TMatrix^ Identity()
F#
member Identity : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Identity"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Matrix Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Matrix Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Matrix(SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Matrix(
    TDouble value
)
Visual Basic
Public Function Matrix ( _
    value As TDouble _
) As TMatrix
Visual C++
public:
TMatrix^ Matrix(
    TDouble^ value
)
F#
member Matrix :
        value:TDouble -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Matrix(SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Matrix(SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Mod Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Mod Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Mod(SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Mod(
    TDouble value
)
Visual Basic
Public Function Mod ( _
    value As TDouble _
) As TNumber
Visual C++
public:
TNumber^ Mod(
    TDouble^ value
)
F#
member Mod :
        value:TDouble -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Mod(SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Mod(SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Mul Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Pow Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Power Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Power(SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble Power(
    TDouble value
)
Visual Basic
Public Function Power ( _
    value As TDouble _
) As TDouble
Visual C++
public:
TDouble^ Power(
    TDouble^ value
)
F#
member Power :
        value:TDouble -> TDouble

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Power(SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Power(SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Random Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Random Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Random"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble Random()
Visual Basic
Public Function Random As TDouble
Visual C++
public:
TDouble^ Random()
F#
member Random : unit -> TDouble

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Random"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Sign Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Sign Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Sign"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble Sign()
Visual Basic
Public Function Sign As TDouble
Visual C++
public:
TDouble^ Sign()
F#
member Sign : unit -> TDouble

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Sign"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Sub Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TDouble..::..ToDouble Method
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.ToDouble"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TDouble..::..ToString Method
TDouble Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TDouble Class
TDouble Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TDouble..::..ToString Method (Int32, FractionsType)
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TDouble.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TDouble.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TDouble Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TDouble..::..ToTerms Method
TDouble Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TDouble Class
TDouble Members
SMath.Math.Numeric Namespace


TDouble Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Operators and Type Conversions
TDouble Class See Also Send Feedback

The TDouble type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TDouble) |
Inequality |
LessThan |
Multiply |
Subtraction |

See Also

TDouble Class
SMath.Math.Numeric Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Addition Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TDouble operator +(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TDouble, _
    c2 As TDouble _
) As TDouble
Visual C++
public:
static TDouble^ operator +(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (+)
        c1:TDouble *
        c2:TDouble  : TDouble

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Division Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TFraction operator /(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TDouble, _
    c2 As TDouble _
) As TFraction
Visual C++
public:
static TFraction^ operator /(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (/)
        c1:TDouble *
        c2:TDouble  : TFraction

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Equality Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Equality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TDouble, _
    c2 As TDouble _
) As Boolean
Visual C++
public:
static bool operator ==(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (=)
        c1:TDouble *
        c2:TDouble  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Equality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Equality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Equality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


GreaterThan Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..GreaterThan Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_GreaterThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator >(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator > ( _
    c1 As TDouble, _
    c2 As TDouble _
) As Boolean
Visual C++
public:
static bool operator >(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (>)
        c1:TDouble *
        c2:TDouble  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_GreaterThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_GreaterThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_GreaterThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TDouble)

[image]

SMath Studio Class Libraries Documantation
TDouble ImplicitWideningImplicitImplicitImplicit Conversion (Double to TDouble)
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Implicit(System.Double)~SMath.Math.Numeric.TDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TDouble (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TDouble
Visual C++
static implicit operator TDouble^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Implicit(System.Double)~SMath.Math.Numeric.TDouble"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Implicit(System.Double)~SMath.Math.Numeric.TDouble"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Inequality Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Inequality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TDouble, _
    c2 As TDouble _
) As Boolean
Visual C++
public:
static bool operator !=(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (<>)
        c1:TDouble *
        c2:TDouble  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Inequality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Inequality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Inequality(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


LessThan Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..LessThan Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_LessThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator <(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator < ( _
    c1 As TDouble, _
    c2 As TDouble _
) As Boolean
Visual C++
public:
static bool operator <(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (<)
        c1:TDouble *
        c2:TDouble  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_LessThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_LessThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_LessThan(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Multiply Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TDouble operator *(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TDouble, _
    c2 As TDouble _
) As TDouble
Visual C++
public:
static TDouble^ operator *(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (*)
        c1:TDouble *
        c2:TDouble  : TDouble

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
TDouble..::..Subtraction Operator
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TDouble.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TDouble operator -(
    TDouble c1,
    TDouble c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TDouble, _
    c2 As TDouble _
) As TDouble
Visual C++
public:
static TDouble^ operator -(
    TDouble^ c1,
    TDouble^ c2
)
F#
static let inline (-)
        c1:TDouble *
        c2:TDouble  : TDouble

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TDouble.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TDouble.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TDouble Class
SMath.Math.Numeric Namespace


TDouble Properties

[image] [image]

SMath Studio Class Libraries Documantation
TDouble Properties
TDouble Class See Also Send Feedback

The TDouble type exposes the following members.

Properties

 | Name | Description
Public property | D |
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TDouble Class
SMath.Math.Numeric Namespace


D Property

[image]

SMath Studio Class Libraries Documantation
TDouble..::..D Property
TDouble Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Math.Numeric.TDouble.D"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double D { get; set; }
Visual Basic
Public Property D As Double
    Get
    Set
Visual C++
public:
property double D {
    double get ();
    void set (double value);
}
F#
member D : float with get, set

See Also

TDouble Class
SMath.Math.Numeric Namespace


TFraction Class

[image]

SMath Studio Class Libraries Documantation
TFraction Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TFraction"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TFraction : BaseEntry
Visual Basic
Public Class TFraction _
    Inherits BaseEntry
Visual C++
public ref class TFraction : public BaseEntry
F#
type TFraction =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TFraction

See Also

TFraction Members
SMath.Math.Numeric Namespace


TFraction Members

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Members
TFraction Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TFraction type exposes the following members.

Constructors

 | Name | Description
Public method | TFraction(Double) |
Public method | TFraction(TFraction) |
Public method | TFraction(TDouble, TDouble) |

Methods

 | Name | Description
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | Cot |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
 | MakeSimple |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Round |
Public method | Sin |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc |

Operators

Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(TDouble to TFraction) |
Inequality |
LessThan |
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |

Fields

 | Name | Description
Public field | den |
Public field | num |

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TFraction Class
SMath.Math.Numeric Namespace


TFraction Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Constructor
TFraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TFraction(Double) | Initializes a new instance of the TFraction class
Public method | TFraction(TFraction) | Initializes a new instance of the TFraction class
Public method | TFraction(TDouble, TDouble) | Initializes a new instance of the TFraction class

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


TFraction Constructor (Double)

[image]

SMath Studio Class Libraries Documantation
TFraction Constructor (Double)
TFraction Class See Also Send Feedback
Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TFraction(
    double D
)
Visual Basic
Public Sub New ( _
    D As Double _
)
Visual C++
public:
TFraction(
    double D
)
F#
new :
        D:float -> TFraction

Parameters

D
Type: System..::..Double

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TFraction.#ctor(System.Double)"]

See Also

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Constructor (TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction Constructor (TFraction)
TFraction Class See Also Send Feedback
Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TFraction(
    TFraction value
)
Visual Basic
Public Sub New ( _
    value As TFraction _
)
Visual C++
public:
TFraction(
    TFraction^ value
)
F#
new :
        value:TFraction -> TFraction

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.#ctor(SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Constructor (TDouble, TDouble)

[image]

SMath Studio Class Libraries Documantation
TFraction Constructor (TDouble, TDouble)
TFraction Class See Also Send Feedback
Initializes a new instance of the TFraction class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TFraction(
    TDouble num,
    TDouble den
)
Visual Basic
Public Sub New ( _
    num As TDouble, _
    den As TDouble _
)
Visual C++
public:
TFraction(
    TDouble^ num,
    TDouble^ den
)
F#
new :
        num:TDouble *
        den:TDouble -> TFraction

Parameters

num
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="num"/> documentation for "M:SMath.Math.Numeric.TFraction.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

den
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="den"/> documentation for "M:SMath.Math.Numeric.TFraction.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
TFraction Overload
SMath.Math.Numeric Namespace


TFraction Fields

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Fields
TFraction Class See Also Send Feedback

The TFraction type exposes the following members.

Fields

 | Name | Description
Public field | den |
Public field | num |

See Also

TFraction Class
SMath.Math.Numeric Namespace


den Field

[image]

SMath Studio Class Libraries Documantation
TFraction..::..den Field
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TFraction.den"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble den
Visual Basic
Public den As TDouble
Visual C++
public:
TDouble^ den
F#
val mutable den: TDouble

See Also

TFraction Class
SMath.Math.Numeric Namespace


num Field

[image]

SMath Studio Class Libraries Documantation
TFraction..::..num Field
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TFraction.num"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble num
Visual Basic
Public num As TDouble
Visual C++
public:
TDouble^ num
F#
val mutable num: TDouble

See Also

TFraction Class
SMath.Math.Numeric Namespace


TFraction Methods

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Methods
TFraction Class See Also Send Feedback

The TFraction type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | Cot |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
 | MakeSimple |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Round |
Public method | Sin |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)
Public method | Trunc |

See Also

TFraction Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Clone Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Clone"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Com Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Cos Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Cos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cos()
Visual Basic
Public Function Cos As TNumber
Visual C++
public:
TNumber^ Cos()
F#
member Cos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Cos"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Cot Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Cot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cot()
Visual Basic
Public Function Cot As TNumber
Visual C++
public:
TNumber^ Cot()
F#
member Cot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Cot"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Div Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Equals Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TFraction.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Equals(System.Object)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..GetHashCode Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.GetHashCode"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


MakeSimple Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..MakeSimple Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.MakeSimple(SMath.Math.Numeric.TDouble@,SMath.Math.Numeric.TDouble@)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static void MakeSimple(
    ref TDouble num,
    ref TDouble den
)
Visual Basic
Public Shared Sub MakeSimple ( _
    ByRef num As TDouble, _
    ByRef den As TDouble _
)
Visual C++
public:
static void MakeSimple(
    TDouble^% num,
    TDouble^% den
)
F#
static member MakeSimple :
        num:TDouble byref *
        den:TDouble byref -> unit

Parameters

num
Type: SMath.Math.Numeric..::..TDouble %

[Missing <param name="num"/> documentation for "M:SMath.Math.Numeric.TFraction.MakeSimple(SMath.Math.Numeric.TDouble@,SMath.Math.Numeric.TDouble@)"]

den
Type: SMath.Math.Numeric..::..TDouble %

[Missing <param name="den"/> documentation for "M:SMath.Math.Numeric.TFraction.MakeSimple(SMath.Math.Numeric.TDouble@,SMath.Math.Numeric.TDouble@)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Mul Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Pow Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Power Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Power(SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TFraction value
)
Visual Basic
Public Function Power ( _
    value As TFraction _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TFraction^ value
)
F#
member Power :
        value:TFraction -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Power(SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Power(SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Round Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Round Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Round(SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Round(
    TDouble value
)
Visual Basic
Public Function Round ( _
    value As TDouble _
) As Double
Visual C++
public:
double Round(
    TDouble^ value
)
F#
member Round :
        value:TDouble -> float

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Round(SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Round(SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Sin Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Sin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sin()
Visual Basic
Public Function Sin As TNumber
Visual C++
public:
TNumber^ Sin()
F#
member Sin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Sin"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Sub Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Tan Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Tan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Tan()
Visual Basic
Public Function Tan As TNumber
Visual C++
public:
TNumber^ Tan()
F#
member Tan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Tan"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..ToDouble Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.ToDouble"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..ToString Method
TFraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..ToString Method (Int32, FractionsType)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TFraction.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TFraction.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TFraction Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..ToTerms Method
TFraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


Trunc Method

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Trunc Method
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.Trunc"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Trunc()
Visual Basic
Public Function Trunc As Double
Visual C++
public:
double Trunc()
F#
member Trunc : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.Trunc"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


TFraction Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Operators and Type Conversions
TFraction Class See Also Send Feedback

The TFraction type exposes the following members.

Operators

Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(TDouble to TFraction) |
Inequality |
LessThan |
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |

See Also

TFraction Class
SMath.Math.Numeric Namespace


Addition Operator

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..Addition Operator
TFraction Class See Also Send Feedback

Overload List

Name | Description
Addition(TDouble, TFraction) |
Addition(TFraction, TDouble) |
Addition(TFraction, TFraction) |

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


Addition Operator (TDouble, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Addition Operator (TDouble, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TDouble c1,
    TFraction c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TDouble, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TDouble^ c1,
    TFraction^ c2
)
F#
static let inline (+)
        c1:TDouble *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


Addition Operator (TFraction, TDouble)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Addition Operator (TFraction, TDouble)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TFraction c1,
    TDouble c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TFraction, _
    c2 As TDouble _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TFraction^ c1,
    TDouble^ c2
)
F#
static let inline (+)
        c1:TFraction *
        c2:TDouble  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


Addition Operator (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Addition Operator (TFraction, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TFraction, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (+)
        c1:TFraction *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Addition(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Addition Overload
SMath.Math.Numeric Namespace


Division Operator

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..Division Operator
TFraction Class See Also Send Feedback

Overload List

Name | Description
Division(TDouble, TFraction) |
Division(TFraction, TDouble) |
Division(TFraction, TFraction) |

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


Division Operator (TDouble, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Division Operator (TDouble, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TDouble c1,
    TFraction c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TDouble, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TDouble^ c1,
    TFraction^ c2
)
F#
static let inline (/)
        c1:TDouble *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


Division Operator (TFraction, TDouble)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Division Operator (TFraction, TDouble)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TFraction c1,
    TDouble c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TFraction, _
    c2 As TDouble _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TFraction^ c1,
    TDouble^ c2
)
F#
static let inline (/)
        c1:TFraction *
        c2:TDouble  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


Division Operator (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Division Operator (TFraction, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TFraction, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (/)
        c1:TFraction *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Division(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Division Overload
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Equality Operator
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Equality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TFraction, _
    c2 As TFraction _
) As Boolean
Visual C++
public:
static bool operator ==(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (=)
        c1:TFraction *
        c2:TFraction  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Equality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Equality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Equality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


GreaterThan Operator

[image]

SMath Studio Class Libraries Documantation
TFraction..::..GreaterThan Operator
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_GreaterThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator >(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator > ( _
    c1 As TFraction, _
    c2 As TFraction _
) As Boolean
Visual C++
public:
static bool operator >(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (>)
        c1:TFraction *
        c2:TFraction  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_GreaterThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_GreaterThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_GreaterThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Implicit Conversion (TDouble to TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction ImplicitWideningImplicitImplicitImplicit Conversion (TDouble to TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TFraction"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TFraction (
    TDouble value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TDouble _
) As TFraction
Visual C++
static implicit operator TFraction^ (
    TDouble^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TFraction"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TFraction"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Inequality Operator
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Inequality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TFraction, _
    c2 As TFraction _
) As Boolean
Visual C++
public:
static bool operator !=(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (<>)
        c1:TFraction *
        c2:TFraction  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Inequality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Inequality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Inequality(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


LessThan Operator

[image]

SMath Studio Class Libraries Documantation
TFraction..::..LessThan Operator
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_LessThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator <(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator < ( _
    c1 As TFraction, _
    c2 As TFraction _
) As Boolean
Visual C++
public:
static bool operator <(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (<)
        c1:TFraction *
        c2:TFraction  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_LessThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_LessThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_LessThan(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
SMath.Math.Numeric Namespace


Multiply Operator

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..Multiply Operator
TFraction Class See Also Send Feedback

Overload List

Name | Description
Multiply(TDouble, TFraction) |
Multiply(TFraction, TDouble) |
Multiply(TFraction, TFraction) |

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


Multiply Operator (TDouble, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Multiply Operator (TDouble, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TDouble c1,
    TFraction c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TDouble, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TDouble^ c1,
    TFraction^ c2
)
F#
static let inline (*)
        c1:TDouble *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


Multiply Operator (TFraction, TDouble)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Multiply Operator (TFraction, TDouble)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TFraction c1,
    TDouble c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TFraction, _
    c2 As TDouble _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TFraction^ c1,
    TDouble^ c2
)
F#
static let inline (*)
        c1:TFraction *
        c2:TDouble  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


Multiply Operator (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Multiply Operator (TFraction, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TFraction, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (*)
        c1:TFraction *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Multiply(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Multiply Overload
SMath.Math.Numeric Namespace


Subtraction Operator

[image] [image]

SMath Studio Class Libraries Documantation
TFraction..::..Subtraction Operator
TFraction Class See Also Send Feedback

Overload List

Name | Description
Subtraction(TDouble, TFraction) |
Subtraction(TFraction, TDouble) |
Subtraction(TFraction, TFraction) |

See Also

TFraction Class
TFraction Members
SMath.Math.Numeric Namespace


Subtraction Operator (TDouble, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Subtraction Operator (TDouble, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TDouble c1,
    TFraction c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TDouble, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TDouble^ c1,
    TFraction^ c2
)
F#
static let inline (-)
        c1:TDouble *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


Subtraction Operator (TFraction, TDouble)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Subtraction Operator (TFraction, TDouble)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TFraction c1,
    TDouble c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TFraction, _
    c2 As TDouble _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TFraction^ c1,
    TDouble^ c2
)
F#
static let inline (-)
        c1:TFraction *
        c2:TDouble  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

c2
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TDouble)"]

See Also

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


Subtraction Operator (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TFraction..::..Subtraction Operator (TFraction, TFraction)
TFraction Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TFraction c1,
    TFraction c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TFraction, _
    c2 As TFraction _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TFraction^ c1,
    TFraction^ c2
)
F#
static let inline (-)
        c1:TFraction *
        c2:TFraction  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

c2
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TFraction.op_Subtraction(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TFraction Class
Subtraction Overload
SMath.Math.Numeric Namespace


TFraction Properties

[image] [image]

SMath Studio Class Libraries Documantation
TFraction Properties
TFraction Class See Also Send Feedback

The TFraction type exposes the following members.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TFraction Class
SMath.Math.Numeric Namespace


TInfinity Class

[image]

SMath Studio Class Libraries Documantation
TInfinity Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TInfinity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TInfinity : BaseEntry
Visual Basic
Public Class TInfinity _
    Inherits BaseEntry
Visual C++
public ref class TInfinity : public BaseEntry
F#
type TInfinity =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TInfinity

See Also

TInfinity Members
SMath.Math.Numeric Namespace


TInfinity Members

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Members
TInfinity Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TInfinity type exposes the following members.

Constructors

 | Name | Description
Public method | TInfinity(Double) |
Public method | TInfinity(InfType) |
Public method | TInfinity(TFraction) |
Public method | TInfinity(TInfinity) |

Methods

 | Name | Description
Public method | ACot |
Public method | ATan |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Ln |
Public method | Log |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TInfinity) |
Inequality |
LessThan |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | den |
Public field | inf |
 | multiZero |
Public field | num |

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Constructor
TInfinity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TInfinity(Double) | Initializes a new instance of the TInfinity class
Public method | TInfinity(InfType) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TFraction) | Initializes a new instance of the TInfinity class
Public method | TInfinity(TInfinity) | Initializes a new instance of the TInfinity class

See Also

TInfinity Class
TInfinity Members
SMath.Math.Numeric Namespace


TInfinity Constructor (Double)

[image]

SMath Studio Class Libraries Documantation
TInfinity Constructor (Double)
TInfinity Class See Also Send Feedback
Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity(
    double D
)
Visual Basic
Public Sub New ( _
    D As Double _
)
Visual C++
public:
TInfinity(
    double D
)
F#
new :
        D:float -> TInfinity

Parameters

D
Type: System..::..Double

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TInfinity.#ctor(System.Double)"]

See Also

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Constructor (InfType)

[image]

SMath Studio Class Libraries Documantation
TInfinity Constructor (InfType)
TInfinity Class See Also Send Feedback
Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity(
    InfType inf
)
Visual Basic
Public Sub New ( _
    inf As InfType _
)
Visual C++
public:
TInfinity(
    InfType inf
)
F#
new :
        inf:InfType -> TInfinity

Parameters

inf
Type: SMath.Math.Numeric..::..InfType

[Missing <param name="inf"/> documentation for "M:SMath.Math.Numeric.TInfinity.#ctor(SMath.Math.Numeric.InfType)"]

See Also

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Constructor (TFraction)

[image]

SMath Studio Class Libraries Documantation
TInfinity Constructor (TFraction)
TInfinity Class See Also Send Feedback
Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity(
    TFraction D
)
Visual Basic
Public Sub New ( _
    D As TFraction _
)
Visual C++
public:
TInfinity(
    TFraction^ D
)
F#
new :
        D:TFraction -> TInfinity

Parameters

D
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TInfinity.#ctor(SMath.Math.Numeric.TFraction)"]

See Also

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Constructor (TInfinity)

[image]

SMath Studio Class Libraries Documantation
TInfinity Constructor (TInfinity)
TInfinity Class See Also Send Feedback
Initializes a new instance of the TInfinity class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TInfinity(
    TInfinity D
)
Visual Basic
Public Sub New ( _
    D As TInfinity _
)
Visual C++
public:
TInfinity(
    TInfinity^ D
)
F#
new :
        D:TInfinity -> TInfinity

Parameters

D
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TInfinity.#ctor(SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
TInfinity Overload
SMath.Math.Numeric Namespace


TInfinity Fields

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Fields
TInfinity Class See Also Send Feedback

The TInfinity type exposes the following members.

Fields

 | Name | Description
Public field | den |
Public field | inf |
 | multiZero |
Public field | num |

See Also

TInfinity Class
SMath.Math.Numeric Namespace


den Field

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..den Field
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TInfinity.den"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble den
Visual Basic
Public den As TDouble
Visual C++
public:
TDouble^ den
F#
val mutable den: TDouble

See Also

TInfinity Class
SMath.Math.Numeric Namespace


inf Field

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..inf Field
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TInfinity.inf"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public InfType inf
Visual Basic
Public inf As InfType
Visual C++
public:
InfType inf
F#
val mutable inf: InfType

See Also

TInfinity Class
SMath.Math.Numeric Namespace


multiZero Field

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..multiZero Field
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TInfinity.multiZero"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool multiZero
Visual Basic
Public Shared multiZero As Boolean
Visual C++
public:
static bool multiZero
F#
static val mutable multiZero: bool

See Also

TInfinity Class
SMath.Math.Numeric Namespace


num Field

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..num Field
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TInfinity.num"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble num
Visual Basic
Public num As TDouble
Visual C++
public:
TDouble^ num
F#
val mutable num: TDouble

See Also

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Methods

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Methods
TInfinity Class See Also Send Feedback

The TInfinity type exposes the following members.

Methods

 | Name | Description
Public method | ACot |
Public method | ATan |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Ln |
Public method | Log |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TInfinity Class
SMath.Math.Numeric Namespace


ACot Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..ACot Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.ACot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACot()
Visual Basic
Public Function ACot As TNumber
Visual C++
public:
TNumber^ ACot()
F#
member ACot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.ACot"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


ATan Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..ATan Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.ATan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATan()
Visual Basic
Public Function ATan As TNumber
Visual C++
public:
TNumber^ ATan()
F#
member ATan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.ATan"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Clone Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Clone"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Com Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Cos Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Cos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cos()
Visual Basic
Public Function Cos As TNumber
Visual C++
public:
TNumber^ Cos()
F#
member Cos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Cos"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


CosH Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..CosH Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.CosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CosH()
Visual Basic
Public Function CosH As TNumber
Visual C++
public:
TNumber^ CosH()
F#
member CosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.CosH"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Cot Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Cot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cot()
Visual Basic
Public Function Cot As TNumber
Visual C++
public:
TNumber^ Cot()
F#
member Cot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Cot"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


CotH Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..CotH Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.CotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CotH()
Visual Basic
Public Function CotH As TNumber
Visual C++
public:
TNumber^ CotH()
F#
member CotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.CotH"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Div Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Equals Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TInfinity.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Equals(System.Object)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Factorial Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Factorial Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Factorial"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Factorial()
Visual Basic
Public Function Factorial As TNumber
Visual C++
public:
TNumber^ Factorial()
F#
member Factorial : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Factorial"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..GetHashCode Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.GetHashCode"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Ln Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Ln Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Ln"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Ln()
Visual Basic
Public Function Ln As TNumber
Visual C++
public:
TNumber^ Ln()
F#
member Ln : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Ln"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Log Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Log Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Log(SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Log(
    TInfinity Base
)
Visual Basic
Public Function Log ( _
    Base As TInfinity _
) As TNumber
Visual C++
public:
TNumber^ Log(
    TInfinity^ Base
)
F#
member Log :
        Base:TInfinity -> TNumber

Parameters

Base
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="Base"/> documentation for "M:SMath.Math.Numeric.TInfinity.Log(SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Log(SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Mul Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Pow Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Power Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Power(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TNumber value
)
Visual Basic
Public Function Power ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TNumber^ value
)
F#
member Power :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Power(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Power(SMath.Math.Numeric.TNumber)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Sign Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Sign Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Sign"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sign()
Visual Basic
Public Function Sign As TNumber
Visual C++
public:
TNumber^ Sign()
F#
member Sign : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Sign"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Sin Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Sin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sin()
Visual Basic
Public Function Sin As TNumber
Visual C++
public:
TNumber^ Sin()
F#
member Sin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Sin"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


SinH Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..SinH Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.SinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber SinH()
Visual Basic
Public Function SinH As TNumber
Visual C++
public:
TNumber^ SinH()
F#
member SinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.SinH"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Sub Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Tan Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.Tan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Tan()
Visual Basic
Public Function Tan As TNumber
Visual C++
public:
TNumber^ Tan()
F#
member Tan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.Tan"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


TanH Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..TanH Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.TanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber TanH()
Visual Basic
Public Function TanH As TNumber
Visual C++
public:
TNumber^ TanH()
F#
member TanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.TanH"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..ToDouble Method
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.ToDouble"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity..::..ToString Method
TInfinity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TInfinity Class
TInfinity Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..ToString Method (Int32, FractionsType)
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TInfinity.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TInfinity.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TInfinity Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity..::..ToTerms Method
TInfinity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | English: Converts current expression component to the array of Term in reverse polish notation (RPN) with options. Русский: Преобразование математического примитива в массив базовых примитивов с учётом заданного количества цифр после запятой. (Inherited from BaseEntry.)

See Also

TInfinity Class
TInfinity Members
SMath.Math.Numeric Namespace


TInfinity Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Operators and Type Conversions
TInfinity Class See Also Send Feedback

The TInfinity type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TInfinity) |
Inequality |
LessThan |
Multiply |
Subtraction |

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Addition Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Addition(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (+)
        c1:TInfinity *
        c2:TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Addition(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Addition(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Addition(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Division Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Division(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (/)
        c1:TInfinity *
        c2:TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Division(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Division(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Division(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Equality Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Equality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As Boolean
Visual C++
public:
static bool operator ==(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (=)
        c1:TInfinity *
        c2:TInfinity  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Equality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Equality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Equality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


GreaterThan Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..GreaterThan Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_GreaterThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator >(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator > ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As Boolean
Visual C++
public:
static bool operator >(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (>)
        c1:TInfinity *
        c2:TInfinity  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_GreaterThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_GreaterThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_GreaterThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Implicit Conversion Operators

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity ImplicitWideningImplicitImplicitImplicit Conversion Operators
TInfinity Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TInfinity) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TInfinity) |

See Also

TInfinity Class
TInfinity Members
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TInfinity)

[image]

SMath Studio Class Libraries Documantation
TInfinity ImplicitWideningImplicitImplicitImplicit Conversion (Double to TInfinity)
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(System.Double)~SMath.Math.Numeric.TInfinity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TInfinity (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TInfinity
Visual C++
static implicit operator TInfinity^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(System.Double)~SMath.Math.Numeric.TInfinity"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(System.Double)~SMath.Math.Numeric.TInfinity"]

See Also

TInfinity Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TDouble to TInfinity)

[image]

SMath Studio Class Libraries Documantation
TInfinity ImplicitWideningImplicitImplicitImplicit Conversion (TDouble to TInfinity)
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TInfinity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TInfinity (
    TDouble value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TDouble _
) As TInfinity
Visual C++
static implicit operator TInfinity^ (
    TDouble^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TInfinity"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TInfinity"]

See Also

TInfinity Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TFraction to TInfinity)

[image]

SMath Studio Class Libraries Documantation
TInfinity ImplicitWideningImplicitImplicitImplicit Conversion (TFraction to TInfinity)
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TInfinity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TInfinity (
    TFraction value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TFraction _
) As TInfinity
Visual C++
static implicit operator TInfinity^ (
    TFraction^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TInfinity"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TInfinity"]

See Also

TInfinity Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TNumber to TInfinity)

[image]

SMath Studio Class Libraries Documantation
TInfinity ImplicitWideningImplicitImplicitImplicit Conversion (TNumber to TInfinity)
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TInfinity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TInfinity (
    TNumber value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TNumber _
) As TInfinity
Visual C++
static implicit operator TInfinity^ (
    TNumber^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TInfinity"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TInfinity"]

See Also

TInfinity Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Inequality Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Inequality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As Boolean
Visual C++
public:
static bool operator !=(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (<>)
        c1:TInfinity *
        c2:TInfinity  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Inequality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Inequality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Inequality(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


LessThan Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..LessThan Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_LessThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator <(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator < ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As Boolean
Visual C++
public:
static bool operator <(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (<)
        c1:TInfinity *
        c2:TInfinity  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_LessThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_LessThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_LessThan(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Multiply Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Multiply(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (*)
        c1:TInfinity *
        c2:TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Multiply(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Multiply(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Multiply(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
TInfinity..::..Subtraction Operator
TInfinity Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TInfinity.op_Subtraction(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TInfinity c1,
    TInfinity c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TInfinity, _
    c2 As TInfinity _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TInfinity^ c1,
    TInfinity^ c2
)
F#
static let inline (-)
        c1:TInfinity *
        c2:TInfinity  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Subtraction(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

c2
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TInfinity.op_Subtraction(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TInfinity.op_Subtraction(SMath.Math.Numeric.TInfinity,SMath.Math.Numeric.TInfinity)"]

See Also

TInfinity Class
SMath.Math.Numeric Namespace


TInfinity Properties

[image] [image]

SMath Studio Class Libraries Documantation
TInfinity Properties
TInfinity Class See Also Send Feedback

The TInfinity type exposes the following members.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TInfinity Class
SMath.Math.Numeric Namespace


TMatrix Class

[image]

SMath Studio Class Libraries Documantation
TMatrix Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TMatrix : BaseEntry
Visual Basic
Public Class TMatrix _
    Inherits BaseEntry
Visual C++
public ref class TMatrix : public BaseEntry
F#
type TMatrix =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TMatrix

See Also

TMatrix Members
SMath.Math.Numeric Namespace


TMatrix Members

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Members
TMatrix Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TMatrix type exposes the following members.

Constructors

 | Name | Description
Public method | TMatrix(Double) |
Public method | TMatrix(TComplex) |
Public method | TMatrix(TDouble) |
Public method | TMatrix(TFraction) |
Public method | TMatrix(TInfinity) |
Public method | TMatrix(TNumber) |
Public method | TMatrix(array<TNumber,2>[,](,)[,][,]) |

Methods

 | Name | Description
Public method | Ainterp |
Public method | Alg |
Public method | buildakimaspline | Построение таблицы коэффициентов сплайна Акимы
Public method | buildcubicspline | Построение таблицы коэффициентов кубического сплайна
Public method | buildhermitespline | Построение таблицы коэффициентов сплайна Эрмита
Public method | buildlinearspline | Построение таблицы коэффициентов кусочно-линейного сплайна
Public method | Cinterp |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Col |
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
 | eigenpolyroots | Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.
Public method | El |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | FFT |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Norm1 | Вычислени l-нормы матрицы.
Public method | NormE | Вычислени нормы Фробениуса матрицы.
Public method | NormI | Вычислени m-нормы матрицы.
Public method | PolyRoots |
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | rmatrixlu |
Public method | rmatrixluinverse | Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.
Public method | rmatrixtrinverse |
Public method | Row |
Public method | RSort |
Public method | Sort |
Public method | splineinterpolation | Вычисление интерполирующего сплайна
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Submatrix |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)
Public method | Trace |
Public method | Transpose |
Public method | VMinor |
Public method | VMultiplication |

Operators

Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TMatrix) |
Inequality |
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |

Fields

 | Name | Description
 | lunb |
 | MachineEpsilon |
Public field | unit |

Properties

 | Name | Description
Public property | Item |
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Constructor
TMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TMatrix(Double) | Initializes a new instance of the TMatrix class
Public method | TMatrix(TComplex) | Initializes a new instance of the TMatrix class
Public method | TMatrix(TDouble) | Initializes a new instance of the TMatrix class
Public method | TMatrix(TFraction) | Initializes a new instance of the TMatrix class
Public method | TMatrix(TInfinity) | Initializes a new instance of the TMatrix class
Public method | TMatrix(TNumber) | Initializes a new instance of the TMatrix class
Public method | TMatrix(array<TNumber,2>[,](,)[,][,]) | Initializes a new instance of the TMatrix class

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


TMatrix Constructor (Double)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (Double)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    double value
)
Visual Basic
Public Sub New ( _
    value As Double _
)
Visual C++
public:
TMatrix(
    double value
)
F#
new :
        value:float -> TMatrix

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(System.Double)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TComplex)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (TComplex)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TComplex value
)
Visual Basic
Public Sub New ( _
    value As TComplex _
)
Visual C++
public:
TMatrix(
    TComplex^ value
)
F#
new :
        value:TComplex -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TComplex)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TDouble)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (TDouble)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TDouble value
)
Visual Basic
Public Sub New ( _
    value As TDouble _
)
Visual C++
public:
TMatrix(
    TDouble^ value
)
F#
new :
        value:TDouble -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TDouble)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TFraction)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (TFraction)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TFraction value
)
Visual Basic
Public Sub New ( _
    value As TFraction _
)
Visual C++
public:
TMatrix(
    TFraction^ value
)
F#
new :
        value:TFraction -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TFraction)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TInfinity)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (TInfinity)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TInfinity value
)
Visual Basic
Public Sub New ( _
    value As TInfinity _
)
Visual C++
public:
TMatrix(
    TInfinity^ value
)
F#
new :
        value:TInfinity -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TInfinity)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TNumber)

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (TNumber)
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TNumber value
)
Visual Basic
Public Sub New ( _
    value As TNumber _
)
Visual C++
public:
TMatrix(
    TNumber^ value
)
F#
new :
        value:TNumber -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TNumber)"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Constructor (TNumber[,])

[image]

SMath Studio Class Libraries Documantation
TMatrix Constructor (array<TNumber,2>[,](,)[,][,])
TMatrix Class See Also Send Feedback
Initializes a new instance of the TMatrix class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix(
    TNumber[,] unit
)
Visual Basic
Public Sub New ( _
    unit As TNumber(,) _
)
Visual C++
public:
TMatrix(
    array<TNumber^,2>^ unit
)
F#
new :
        unit:TNumber[,] -> TMatrix

Parameters

unit
Type: array< SMath.Math.Numeric..::..TNumber ,2>[,](,)[,][,]

[Missing <param name="unit"/> documentation for "M:SMath.Math.Numeric.TMatrix.#ctor(SMath.Math.Numeric.TNumber[0:,0:])"]

See Also

TMatrix Class
TMatrix Overload
SMath.Math.Numeric Namespace


TMatrix Fields

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Fields
TMatrix Class See Also Send Feedback

The TMatrix type exposes the following members.

Fields

 | Name | Description
 | lunb |
 | MachineEpsilon |
Public field | unit |

See Also

TMatrix Class
SMath.Math.Numeric Namespace


lunb Field

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..lunb Field
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TMatrix.lunb"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public const int lunb
Visual Basic
Public Const lunb As Integer
Visual C++
public:
literal int lunb
F#
static val mutable lunb: int

See Also

TMatrix Class
SMath.Math.Numeric Namespace


MachineEpsilon Field

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..MachineEpsilon Field
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TMatrix.MachineEpsilon"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public const double MachineEpsilon
Visual Basic
Public Const MachineEpsilon As Double
Visual C++
public:
literal double MachineEpsilon
F#
static val mutable MachineEpsilon: float

See Also

TMatrix Class
SMath.Math.Numeric Namespace


unit Field

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..unit Field
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TMatrix.unit"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber[,] unit
Visual Basic
Public unit As TNumber(,)
Visual C++
public:
array<TNumber^,2>^ unit
F#
val mutable unit: TNumber[,]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Methods

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Methods
TMatrix Class See Also Send Feedback

The TMatrix type exposes the following members.

Methods

 | Name | Description
Public method | Ainterp |
Public method | Alg |
Public method | buildakimaspline | Построение таблицы коэффициентов сплайна Акимы
Public method | buildcubicspline | Построение таблицы коэффициентов кубического сплайна
Public method | buildhermitespline | Построение таблицы коэффициентов сплайна Эрмита
Public method | buildlinearspline | Построение таблицы коэффициентов кусочно-линейного сплайна
Public method | Cinterp |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Col |
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
 | eigenpolyroots | Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.
Public method | El |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | FFT |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetInverse | Обращение матрицы общего вида.
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Norm1 | Вычислени l-нормы матрицы.
Public method | NormE | Вычислени нормы Фробениуса матрицы.
Public method | NormI | Вычислени m-нормы матрицы.
Public method | PolyRoots |
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | rmatrixlu |
Public method | rmatrixluinverse | Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.
Public method | rmatrixtrinverse |
Public method | Row |
Public method | RSort |
Public method | Sort |
Public method | splineinterpolation | Вычисление интерполирующего сплайна
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Submatrix |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)
Public method | Trace |
Public method | Transpose |
Public method | VMinor |
Public method | VMultiplication |

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Ainterp Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Ainterp Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Ainterp(System.Double[],System.Double[],System.Double)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Ainterp(
    double[] x,
    double[] y,
    double pnt
)
Visual Basic
Public Function Ainterp ( _
    x As Double(), _
    y As Double(), _
    pnt As Double _
) As Double
Visual C++
public:
double Ainterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
F#
member Ainterp :
        x:float[] *
        y:float[] *
        pnt:float -> float

Parameters

x
Type: array< System..::..Double >[]()[][]

[Missing <param name="x"/> documentation for "M:SMath.Math.Numeric.TMatrix.Ainterp(System.Double[],System.Double[],System.Double)"]

y
Type: array< System..::..Double >[]()[][]

[Missing <param name="y"/> documentation for "M:SMath.Math.Numeric.TMatrix.Ainterp(System.Double[],System.Double[],System.Double)"]

pnt
Type: System..::..Double

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TMatrix.Ainterp(System.Double[],System.Double[],System.Double)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Ainterp(System.Double[],System.Double[],System.Double)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Alg Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Alg Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Alg(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Alg(
    int row,
    int col
)
Visual Basic
Public Function Alg ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ Alg(
    int row,
    int col
)
F#
member Alg :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TMatrix.Alg(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TMatrix.Alg(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Alg(System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


buildakimaspline Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..buildakimaspline Method
TMatrix Class See Also Send Feedback
Построение таблицы коэффициентов сплайна Акимы

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public void buildakimaspline(
    double[] x,
    double[] y,
    int n,
    out double[] c
)
Visual Basic
Public Sub buildakimaspline ( _
    x As Double(), _
    y As Double(), _
    n As Integer, _
    <OutAttribute> ByRef c As Double() _
)
Visual C++
public:
void buildakimaspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    [OutAttribute] array<double>^% c
)
F#
member buildakimaspline :
        x:float[] *
        y:float[] *
        n:int *
        c:float[] byref -> unit

Parameters

x
Type: array< System..::..Double >[]()[][]
абсциссы, массив с нумерацией элементов [0..N-1]
y
Type: array< System..::..Double >[]()[][]
значения функции, массив с нумерацией элементов [0..N-1]
n
Type: System..::..Int32
число точек, N>=5
c
Type: array< System..::..Double >[]()[][]%
таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation

See Also

TMatrix Class
SMath.Math.Numeric Namespace


buildcubicspline Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..buildcubicspline Method
TMatrix Class See Also Send Feedback
Построение таблицы коэффициентов кубического сплайна

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public void buildcubicspline(
    double[] x,
    double[] y,
    int n,
    int boundltype,
    double boundl,
    int boundrtype,
    double boundr,
    out double[] c
)
Visual Basic
Public Sub buildcubicspline ( _
    x As Double(), _
    y As Double(), _
    n As Integer, _
    boundltype As Integer, _
    boundl As Double, _
    boundrtype As Integer, _
    boundr As Double, _
    <OutAttribute> ByRef c As Double() _
)
Visual C++
public:
void buildcubicspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    int boundltype,
    double boundl,
    int boundrtype,
    double boundr,
    [OutAttribute] array<double>^% c
)
F#
member buildcubicspline :
        x:float[] *
        y:float[] *
        n:int *
        boundltype:int *
        boundl:float *
        boundrtype:int *
        boundr:float *
        c:float[] byref -> unit

Parameters

x
Type: array< System..::..Double >[]()[][]
абсциссы, массив с нумерацией элементов [0..N-1]
y
Type: array< System..::..Double >[]()[][]
значения функции, массив с нумерацией элементов [0..N-1]
n
Type: System..::..Int32
число точек, N>=2
boundltype
Type: System..::..Int32
тип граничного условия (левая граница)
boundl
Type: System..::..Double
значение первой (или второй, в зависимости от BoundType) производной сплайна на левой границе
boundrtype
Type: System..::..Int32
тип граничного условия (правая граница)
boundr
Type: System..::..Double
значение первой (или второй, в зависимости от BoundType) производной сплайна на правой границе
c
Type: array< System..::..Double >[]()[][]%
таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation

See Also

TMatrix Class
SMath.Math.Numeric Namespace


buildhermitespline Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..buildhermitespline Method
TMatrix Class See Also Send Feedback
Построение таблицы коэффициентов сплайна Эрмита

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public void buildhermitespline(
    double[] x,
    double[] y,
    double[] d,
    int n,
    out double[] c
)
Visual Basic
Public Sub buildhermitespline ( _
    x As Double(), _
    y As Double(), _
    d As Double(), _
    n As Integer, _
    <OutAttribute> ByRef c As Double() _
)
Visual C++
public:
void buildhermitespline(
    array<double>^ x,
    array<double>^ y,
    array<double>^ d,
    int n,
    [OutAttribute] array<double>^% c
)
F#
member buildhermitespline :
        x:float[] *
        y:float[] *
        d:float[] *
        n:int *
        c:float[] byref -> unit

Parameters

x
Type: array< System..::..Double >[]()[][]
абсциссы, массив с нумерацией элементов [0..N-1]
y
Type: array< System..::..Double >[]()[][]
значения функции, массив с нумерацией элементов [0..N-1]
d
Type: array< System..::..Double >[]()[][]
значения производной, массив с нумерацией элементов [0..N-1]
n
Type: System..::..Int32
число точек, N>=2
c
Type: array< System..::..Double >[]()[][]%
таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation

See Also

TMatrix Class
SMath.Math.Numeric Namespace


buildlinearspline Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..buildlinearspline Method
TMatrix Class See Also Send Feedback
Построение таблицы коэффициентов кусочно-линейного сплайна

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public void buildlinearspline(
    double[] x,
    double[] y,
    int n,
    out double[] c
)
Visual Basic
Public Sub buildlinearspline ( _
    x As Double(), _
    y As Double(), _
    n As Integer, _
    <OutAttribute> ByRef c As Double() _
)
Visual C++
public:
void buildlinearspline(
    array<double>^ x,
    array<double>^ y,
    int n,
    [OutAttribute] array<double>^% c
)
F#
member buildlinearspline :
        x:float[] *
        y:float[] *
        n:int *
        c:float[] byref -> unit

Parameters

x
Type: array< System..::..Double >[]()[][]
абсциссы, массив с нумерацией элементов [0..N-1]
y
Type: array< System..::..Double >[]()[][]
значения функции, массив с нумерацией элементов [0..N-1]
n
Type: System..::..Int32
число точек, N>=2
c
Type: array< System..::..Double >[]()[][]%
таблица коэффициентов сплайна для использования в подпрограмме SplineInterpolation

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Cinterp Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Cinterp Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Cinterp(System.Double[],System.Double[],System.Double)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Cinterp(
    double[] x,
    double[] y,
    double pnt
)
Visual Basic
Public Function Cinterp ( _
    x As Double(), _
    y As Double(), _
    pnt As Double _
) As Double
Visual C++
public:
double Cinterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
F#
member Cinterp :
        x:float[] *
        y:float[] *
        pnt:float -> float

Parameters

x
Type: array< System..::..Double >[]()[][]

[Missing <param name="x"/> documentation for "M:SMath.Math.Numeric.TMatrix.Cinterp(System.Double[],System.Double[],System.Double)"]

y
Type: array< System..::..Double >[]()[][]

[Missing <param name="y"/> documentation for "M:SMath.Math.Numeric.TMatrix.Cinterp(System.Double[],System.Double[],System.Double)"]

pnt
Type: System..::..Double

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TMatrix.Cinterp(System.Double[],System.Double[],System.Double)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Cinterp(System.Double[],System.Double[],System.Double)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Clone Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Clone"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Col Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Col Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Col(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Col(
    int value
)
Visual Basic
Public Function Col ( _
    value As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ Col(
    int value
)
F#
member Col :
        value:int -> TMatrix

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Col(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Col(System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Com Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


CSort Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..CSort Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.CSort(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix CSort(
    int index
)
Visual Basic
Public Function CSort ( _
    index As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ CSort(
    int index
)
F#
member CSort :
        index:int -> TMatrix

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Math.Numeric.TMatrix.CSort(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.CSort(System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Determinant Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Determinant Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Determinant"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex Determinant()
Visual Basic
Public Function Determinant As TComplex
Visual C++
public:
TComplex^ Determinant()
F#
member Determinant : unit -> TComplex

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Determinant"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Diag Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Diag Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Diag"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Diag()
Visual Basic
Public Function Diag As TMatrix
Visual C++
public:
TMatrix^ Diag()
F#
member Diag : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Diag"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Div Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


eigenpolyroots Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..eigenpolyroots Method
TMatrix Class See Also Send Feedback
Поиск корней полинома методом собственных значений. Алгоритм ищет корни полинома путем поиска собственных значений его матрицы-компаньона.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool eigenpolyroots(
    double[] c,
    int n,
    out double[] wr,
    out double[] wi
)
Visual Basic
Public Shared Function eigenpolyroots ( _
    c As Double(), _
    n As Integer, _
    <OutAttribute> ByRef wr As Double(), _
    <OutAttribute> ByRef wi As Double() _
) As Boolean
Visual C++
public:
static bool eigenpolyroots(
    array<double>^ c,
    int n,
    [OutAttribute] array<double>^% wr,
    [OutAttribute] array<double>^% wi
)
F#
static member eigenpolyroots :
        c:float[] *
        n:int *
        wr:float[] byref *
        wi:float[] byref -> bool

Parameters

c
Type: array< System..::..Double >[]()[][]
массив коэффициентов полинома. Нумерация элементов от 0 до N. C[I] - коэффициент при X^I
n
Type: System..::..Int32
степень полинома. N>=1.
wr
Type: array< System..::..Double >[]()[][]%
массив вещественных частей корней полинома. Нумерация элементов от 1 до N.
wi
Type: array< System..::..Double >[]()[][]%
массив мнимых частей корней полинома. Нумерация элементов от 1 до N. При этом комплексно-сопряженные корни идут один за другим.

Return Value

True, если алгоритм поиска собственных значений сошелся. False, если алгоритм поиска собственных значений не сошелся.

See Also

TMatrix Class
SMath.Math.Numeric Namespace


El Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..El Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.El(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber El(
    int row,
    int col
)
Visual Basic
Public Function El ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ El(
    int row,
    int col
)
F#
member El :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TMatrix.El(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TMatrix.El(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.El(System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Equals Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TMatrix.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Equals(System.Object)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


FFT Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..FFT Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.FFT(System.Double[],System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix FFT(
    double[] dIn,
    int nn,
    int beginData
)
Visual Basic
Public Function FFT ( _
    dIn As Double(), _
    nn As Integer, _
    beginData As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ FFT(
    array<double>^ dIn,
    int nn,
    int beginData
)
F#
member FFT :
        dIn:float[] *
        nn:int *
        beginData:int -> TMatrix

Parameters

dIn
Type: array< System..::..Double >[]()[][]

[Missing <param name="dIn"/> documentation for "M:SMath.Math.Numeric.TMatrix.FFT(System.Double[],System.Int32,System.Int32)"]

nn
Type: System..::..Int32

[Missing <param name="nn"/> documentation for "M:SMath.Math.Numeric.TMatrix.FFT(System.Double[],System.Int32,System.Int32)"]

beginData
Type: System..::..Int32

[Missing <param name="beginData"/> documentation for "M:SMath.Math.Numeric.TMatrix.FFT(System.Double[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.FFT(System.Double[],System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..GetHashCode Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.GetHashCode"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


GetInverse Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..GetInverse Method
TMatrix Class See Also Send Feedback
Обращение матрицы общего вида.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix GetInverse()
Visual Basic
Public Function GetInverse As TMatrix
Visual C++
public:
TMatrix^ GetInverse()
F#
member GetInverse : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.GetInverse"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Im Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Im Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Im"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Im()
Visual Basic
Public Function Im As TMatrix
Visual C++
public:
TMatrix^ Im()
F#
member Im : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Im"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Length Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Length Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Length"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Length()
Visual Basic
Public Function Length As Double
Visual C++
public:
double Length()
F#
member Length : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Length"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Linterp Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Linterp Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Linterp(System.Double[],System.Double[],System.Double)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double Linterp(
    double[] x,
    double[] y,
    double pnt
)
Visual Basic
Public Function Linterp ( _
    x As Double(), _
    y As Double(), _
    pnt As Double _
) As Double
Visual C++
public:
double Linterp(
    array<double>^ x,
    array<double>^ y,
    double pnt
)
F#
member Linterp :
        x:float[] *
        y:float[] *
        pnt:float -> float

Parameters

x
Type: array< System..::..Double >[]()[][]

[Missing <param name="x"/> documentation for "M:SMath.Math.Numeric.TMatrix.Linterp(System.Double[],System.Double[],System.Double)"]

y
Type: array< System..::..Double >[]()[][]

[Missing <param name="y"/> documentation for "M:SMath.Math.Numeric.TMatrix.Linterp(System.Double[],System.Double[],System.Double)"]

pnt
Type: System..::..Double

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TMatrix.Linterp(System.Double[],System.Double[],System.Double)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Linterp(System.Double[],System.Double[],System.Double)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Max Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Max Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Max"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Max()
Visual Basic
Public Function Max As TNumber
Visual C++
public:
TNumber^ Max()
F#
member Max : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Max"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Min Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Min Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Min"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Min()
Visual Basic
Public Function Min As TNumber
Visual C++
public:
TNumber^ Min()
F#
member Min : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Min"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Minor Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Minor Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Minor(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Minor(
    int row,
    int col
)
Visual Basic
Public Function Minor ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ Minor(
    int row,
    int col
)
F#
member Minor :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TMatrix.Minor(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TMatrix.Minor(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Minor(System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Mul Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Norm1 Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Norm1 Method
TMatrix Class See Also Send Feedback
Вычислени l-нормы матрицы.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Norm1()
Visual Basic
Public Function Norm1 As TNumber
Visual C++
public:
TNumber^ Norm1()
F#
member Norm1 : unit -> TNumber

Return Value

Значение нормы.

See Also

TMatrix Class
SMath.Math.Numeric Namespace


NormE Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..NormE Method
TMatrix Class See Also Send Feedback
Вычислени нормы Фробениуса матрицы.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber NormE()
Visual Basic
Public Function NormE As TNumber
Visual C++
public:
TNumber^ NormE()
F#
member NormE : unit -> TNumber

Return Value

Значение нормы.

See Also

TMatrix Class
SMath.Math.Numeric Namespace


NormI Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..NormI Method
TMatrix Class See Also Send Feedback
Вычислени m-нормы матрицы.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber NormI()
Visual Basic
Public Function NormI As TNumber
Visual C++
public:
TNumber^ NormI()
F#
member NormI : unit -> TNumber

Return Value

Значение нормы.

See Also

TMatrix Class
SMath.Math.Numeric Namespace


PolyRoots Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..PolyRoots Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.PolyRoots"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix PolyRoots()
Visual Basic
Public Function PolyRoots As TMatrix
Visual C++
public:
TMatrix^ PolyRoots()
F#
member PolyRoots : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.PolyRoots"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Pow Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Power Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Power(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TNumber value
)
Visual Basic
Public Function Power ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TNumber^ value
)
F#
member Power :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Power(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Power(SMath.Math.Numeric.TNumber)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Rank Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Rank Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Rank"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TDouble Rank()
Visual Basic
Public Function Rank As TDouble
Visual C++
public:
TDouble^ Rank()
F#
member Rank : unit -> TDouble

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Rank"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Re Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Re Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Re"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Re()
Visual Basic
Public Function Re As TMatrix
Visual C++
public:
TMatrix^ Re()
F#
member Re : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Re"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Reverse Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Reverse Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Reverse"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Reverse()
Visual Basic
Public Function Reverse As TMatrix
Visual C++
public:
TMatrix^ Reverse()
F#
member Reverse : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Reverse"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


rmatrixlu Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..rmatrixlu Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixlu(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Int32,System.Int32[]@)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public void rmatrixlu(
    ref TComplex[,] a,
    int m,
    int n,
    ref int[] pivots
)
Visual Basic
Public Sub rmatrixlu ( _
    ByRef a As TComplex(,), _
    m As Integer, _
    n As Integer, _
    ByRef pivots As Integer() _
)
Visual C++
public:
void rmatrixlu(
    array<TComplex^,2>^% a,
    int m,
    int n,
    array<int>^% pivots
)
F#
member rmatrixlu :
        a:TComplex[,] byref *
        m:int *
        n:int *
        pivots:int[] byref -> unit

Parameters

a
Type: array< SMath.Math.Numeric..::..TComplex ,2>[,](,)[,][,]%

[Missing <param name="a"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixlu(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Int32,System.Int32[]@)"]

m
Type: System..::..Int32

[Missing <param name="m"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixlu(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Int32,System.Int32[]@)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixlu(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Int32,System.Int32[]@)"]

pivots
Type: array< System..::..Int32 >[]()[][]%

[Missing <param name="pivots"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixlu(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Int32,System.Int32[]@)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


rmatrixluinverse Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..rmatrixluinverse Method
TMatrix Class See Also Send Feedback
Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public bool rmatrixluinverse(
    ref TComplex[,] a,
    ref int[] pivots,
    int n
)
Visual Basic
Public Function rmatrixluinverse ( _
    ByRef a As TComplex(,), _
    ByRef pivots As Integer(), _
    n As Integer _
) As Boolean
Visual C++
public:
bool rmatrixluinverse(
    array<TComplex^,2>^% a,
    array<int>^% pivots,
    int n
)
F#
member rmatrixluinverse :
        a:TComplex[,] byref *
        pivots:int[] byref *
        n:int -> bool

Parameters

a
Type: array< SMath.Math.Numeric..::..TComplex ,2>[,](,)[,][,]%

[Missing <param name="a"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixluinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32[]@,System.Int32)"]

pivots
Type: array< System..::..Int32 >[]()[][]%

[Missing <param name="pivots"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixluinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32[]@,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixluinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32[]@,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixluinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32[]@,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


rmatrixtrinverse Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..rmatrixtrinverse Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public bool rmatrixtrinverse(
    ref TComplex[,] a,
    int n,
    bool isupper,
    bool isunittriangular
)
Visual Basic
Public Function rmatrixtrinverse ( _
    ByRef a As TComplex(,), _
    n As Integer, _
    isupper As Boolean, _
    isunittriangular As Boolean _
) As Boolean
Visual C++
public:
bool rmatrixtrinverse(
    array<TComplex^,2>^% a,
    int n,
    bool isupper,
    bool isunittriangular
)
F#
member rmatrixtrinverse :
        a:TComplex[,] byref *
        n:int *
        isupper:bool *
        isunittriangular:bool -> bool

Parameters

a
Type: array< SMath.Math.Numeric..::..TComplex ,2>[,](,)[,][,]%

[Missing <param name="a"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

isupper
Type: System..::..Boolean

[Missing <param name="isupper"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

isunittriangular
Type: System..::..Boolean

[Missing <param name="isunittriangular"/> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.rmatrixtrinverse(SMath.Math.Numeric.TComplex[0:,0:]@,System.Int32,System.Boolean,System.Boolean)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Row Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Row Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Row(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Row(
    int value
)
Visual Basic
Public Function Row ( _
    value As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ Row(
    int value
)
F#
member Row :
        value:int -> TMatrix

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Row(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Row(System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


RSort Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..RSort Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.RSort(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix RSort(
    int index
)
Visual Basic
Public Function RSort ( _
    index As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ RSort(
    int index
)
F#
member RSort :
        index:int -> TMatrix

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Math.Numeric.TMatrix.RSort(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.RSort(System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Sort Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Sort Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Sort"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Sort()
Visual Basic
Public Function Sort As TMatrix
Visual C++
public:
TMatrix^ Sort()
F#
member Sort : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Sort"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


splineinterpolation Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..splineinterpolation Method
TMatrix Class See Also Send Feedback
Вычисление интерполирующего сплайна

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public double splineinterpolation(
    ref double[] c,
    double x
)
Visual Basic
Public Function splineinterpolation ( _
    ByRef c As Double(), _
    x As Double _
) As Double
Visual C++
public:
double splineinterpolation(
    array<double>^% c,
    double x
)
F#
member splineinterpolation :
        c:float[] byref *
        x:float -> float

Parameters

c
Type: array< System..::..Double >[]()[][]%
массив коэффициентов, вычисленный подпрограммой для построения сплайна
x
Type: System..::..Double
точка, в которой вычисляется значение сплайна

Return Value

значение сплайна в точке X

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Sub Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Submatrix Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Submatrix Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
Visual Basic
Public Function Submatrix ( _
    startRow As Integer, _
    endRow As Integer, _
    startCol As Integer, _
    endCol As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
F#
member Submatrix :
        startRow:int *
        endRow:int *
        startCol:int *
        endCol:int -> TMatrix

Parameters

startRow
Type: System..::..Int32

[Missing <param name="startRow"/> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

endRow
Type: System..::..Int32

[Missing <param name="endRow"/> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

startCol
Type: System..::..Int32

[Missing <param name="startCol"/> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

endCol
Type: System..::..Int32

[Missing <param name="endCol"/> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..ToDouble Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.ToDouble"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..ToString Method
TMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..ToString Method (Int32, FractionsType)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TMatrix.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TMatrix.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TMatrix Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..ToTerms Method
TMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


ToTerms Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..ToTerms Method (Int32, FractionsType)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override Term[] ToTerms(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToTerms ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As Term()
Visual C++
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]
override ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TMatrix.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TMatrix.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

See Also

TMatrix Class
ToTerms Overload
SMath.Math.Numeric Namespace


Trace Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Trace Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Trace"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TComplex Trace()
Visual Basic
Public Function Trace As TComplex
Visual C++
public:
TComplex^ Trace()
F#
member Trace : unit -> TComplex

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Trace"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Transpose Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Transpose Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.Transpose"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Transpose()
Visual Basic
Public Function Transpose As TMatrix
Visual C++
public:
TMatrix^ Transpose()
F#
member Transpose : unit -> TMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.Transpose"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


VMinor Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..VMinor Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.VMinor(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix VMinor(
    int row,
    int col
)
Visual Basic
Public Function VMinor ( _
    row As Integer, _
    col As Integer _
) As TMatrix
Visual C++
public:
TMatrix^ VMinor(
    int row,
    int col
)
F#
member VMinor :
        row:int *
        col:int -> TMatrix

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TMatrix.VMinor(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TMatrix.VMinor(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.VMinor(System.Int32,System.Int32)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


VMultiplication Method

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..VMultiplication Method
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.VMultiplication(SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix VMultiplication(
    TMatrix value
)
Visual Basic
Public Function VMultiplication ( _
    value As TMatrix _
) As TMatrix
Visual C++
public:
TMatrix^ VMultiplication(
    TMatrix^ value
)
F#
member VMultiplication :
        value:TMatrix -> TMatrix

Parameters

value
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.VMultiplication(SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.VMultiplication(SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


TMatrix Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Operators and Type Conversions
TMatrix Class See Also Send Feedback

The TMatrix type exposes the following members.

Operators

Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TMatrix) |
Inequality |
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Addition Operator

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..Addition Operator
TMatrix Class See Also Send Feedback

Overload List

Name | Description
Addition(TComplex, TMatrix) |
Addition(TMatrix, TComplex) |
Addition(TMatrix, TMatrix) |

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


Addition Operator (TComplex, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Addition Operator (TComplex, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TComplex c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TComplex, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TComplex^ c1,
    TMatrix^ c2
)
F#
static let inline (+)
        c1:TComplex *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


Addition Operator (TMatrix, TComplex)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Addition Operator (TMatrix, TComplex)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TMatrix c1,
    TComplex c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TMatrix, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TMatrix^ c1,
    TComplex^ c2
)
F#
static let inline (+)
        c1:TMatrix *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

See Also

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


Addition Operator (TMatrix, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Addition Operator (TMatrix, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (+)
        c1:TMatrix *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Addition(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Addition Overload
SMath.Math.Numeric Namespace


Division Operator

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..Division Operator
TMatrix Class See Also Send Feedback

Overload List

Name | Description
Division(TComplex, TMatrix) |
Division(TMatrix, TComplex) |
Division(TMatrix, TMatrix) |

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


Division Operator (TComplex, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Division Operator (TComplex, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TComplex c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TComplex, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TComplex^ c1,
    TMatrix^ c2
)
F#
static let inline (/)
        c1:TComplex *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


Division Operator (TMatrix, TComplex)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Division Operator (TMatrix, TComplex)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TMatrix c1,
    TComplex c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TMatrix, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TMatrix^ c1,
    TComplex^ c2
)
F#
static let inline (/)
        c1:TMatrix *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

See Also

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


Division Operator (TMatrix, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Division Operator (TMatrix, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (/)
        c1:TMatrix *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Division(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Division Overload
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Equality Operator
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Equality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As Boolean
Visual C++
public:
static bool operator ==(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (=)
        c1:TMatrix *
        c2:TMatrix  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Equality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Equality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Equality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Implicit Conversion Operators

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion Operators
TMatrix Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TMatrix) |
ImplicitWideningImplicitImplicitImplicit(TNumber to TMatrix) |

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (Double to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(System.Double)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(System.Double)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(System.Double)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TComplex to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (TComplex to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    TComplex value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TComplex _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    TComplex^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TDouble to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (TDouble to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    TDouble value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TDouble _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    TDouble^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TFraction to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (TFraction to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    TFraction value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TFraction _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    TFraction^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TInfinity to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (TInfinity to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    TInfinity value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TInfinity _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    TInfinity^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TNumber to TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix ImplicitWideningImplicitImplicitImplicit Conversion (TNumber to TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TMatrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TMatrix (
    TNumber value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TNumber _
) As TMatrix
Visual C++
static implicit operator TMatrix^ (
    TNumber^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TMatrix"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Implicit(SMath.Math.Numeric.TNumber)~SMath.Math.Numeric.TMatrix"]

See Also

TMatrix Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Inequality Operator
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Inequality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As Boolean
Visual C++
public:
static bool operator !=(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (<>)
        c1:TMatrix *
        c2:TMatrix  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Inequality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Inequality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Inequality(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Multiply Operator

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..Multiply Operator
TMatrix Class See Also Send Feedback

Overload List

Name | Description
Multiply(TComplex, TMatrix) |
Multiply(TMatrix, TComplex) |
Multiply(TMatrix, TMatrix) |

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


Multiply Operator (TComplex, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Multiply Operator (TComplex, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TComplex c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TComplex, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TComplex^ c1,
    TMatrix^ c2
)
F#
static let inline (*)
        c1:TComplex *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


Multiply Operator (TMatrix, TComplex)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Multiply Operator (TMatrix, TComplex)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TMatrix c1,
    TComplex c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TMatrix, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TMatrix^ c1,
    TComplex^ c2
)
F#
static let inline (*)
        c1:TMatrix *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

See Also

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


Multiply Operator (TMatrix, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Multiply Operator (TMatrix, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (*)
        c1:TMatrix *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Multiply(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Multiply Overload
SMath.Math.Numeric Namespace


Subtraction Operator

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix..::..Subtraction Operator
TMatrix Class See Also Send Feedback

Overload List

Name | Description
Subtraction(TComplex, TMatrix) |
Subtraction(TMatrix, TComplex) |
Subtraction(TMatrix, TMatrix) |

See Also

TMatrix Class
TMatrix Members
SMath.Math.Numeric Namespace


Subtraction Operator (TComplex, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Subtraction Operator (TComplex, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TComplex c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TComplex, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TComplex^ c1,
    TMatrix^ c2
)
F#
static let inline (-)
        c1:TComplex *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TComplex,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


Subtraction Operator (TMatrix, TComplex)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Subtraction Operator (TMatrix, TComplex)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TMatrix c1,
    TComplex c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TMatrix, _
    c2 As TComplex _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TMatrix^ c1,
    TComplex^ c2
)
F#
static let inline (-)
        c1:TMatrix *
        c2:TComplex  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

c2
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TComplex)"]

See Also

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


Subtraction Operator (TMatrix, TMatrix)

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Subtraction Operator (TMatrix, TMatrix)
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TMatrix c1,
    TMatrix c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TMatrix, _
    c2 As TMatrix _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TMatrix^ c1,
    TMatrix^ c2
)
F#
static let inline (-)
        c1:TMatrix *
        c2:TMatrix  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

c2
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TMatrix.op_Subtraction(SMath.Math.Numeric.TMatrix,SMath.Math.Numeric.TMatrix)"]

See Also

TMatrix Class
Subtraction Overload
SMath.Math.Numeric Namespace


TMatrix Properties

[image] [image]

SMath Studio Class Libraries Documantation
TMatrix Properties
TMatrix Class See Also Send Feedback

The TMatrix type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TMatrix Class
SMath.Math.Numeric Namespace


Item Property

[image]

SMath Studio Class Libraries Documantation
TMatrix..::..Item Property
TMatrix Class See Also Send Feedback

[Missing <summary> documentation for "P:SMath.Math.Numeric.TMatrix.Item(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber this[
    int row,
    int col
] { get; set; }
Visual Basic
Public Property Item ( _
    row As Integer, _
    col As Integer _
) As TNumber
    Get
    Set
Visual C++
public:
property TNumber^ Item[int row, int col] {
    TNumber^ get (int row, int col);
    void set (int row, int col, TNumber^ value);
}
F#
member Item : TNumber with get, set

Parameters

row
Type: System..::..Int32
col
Type: System..::..Int32

See Also

TMatrix Class
SMath.Math.Numeric Namespace


TNumber Class

[image]

SMath Studio Class Libraries Documantation
TNumber Class
Members See Also Send Feedback
Менеджер численных математических примитивов.

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TNumber
Visual Basic
Public Class TNumber
Visual C++
public ref class TNumber
F#
type TNumber =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..TNumber

See Also

TNumber Members
SMath.Math.Numeric Namespace


TNumber Members

[image] [image]

SMath Studio Class Libraries Documantation
TNumber Members
TNumber Class Constructors Methods Operators Fields See Also Send Feedback

The TNumber type exposes the following members.

Constructors

 | Name | Description
Public method | TNumber()()()() |
Public method | TNumber(InfType) |
Public method | TNumber(TComplex) |
Public method | TNumber(TFraction) |
Public method | TNumber(TInfinity) |
Public method | TNumber(Double, Double) |
Public method | TNumber(TDouble, TDouble) |
Public method | TNumber(TFraction, TFraction) |

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosec |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Ainterp |
Public method | Alg |
Public method | Arg |
Public method | ASec |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Augment |
Public method | Cinterp |
Public method | Col |
Public method | Cols |
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | El(Int32) |
Public method | El(Int32, Int32) |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | FFT |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Identity |
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Ln |
Public method | Log |
Public method | Matrix |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mod |
Public method | Norm1 |
Public method | NormE |
Public method | NormI |
Public method | Numden |
Public method | pol2xy |
Public method | PolyRoots |
Public method | Polyroots2 |
Public method | Power |
Public method | Random |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | Round |
Public method | Row |
Public method | Rows |
Public method | RSort |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sort |
Public method | Stack |
Public method | Submatrix |
Public method | Tan |
Public method | TanH |
Public method | Trace |
Public method | Transpose |
Public method | Trunc |
Public method | VMinor |
Public method | VMultiplication |
Public method | xy2pol()()()() |
Public method | xy2pol(TNumber) |

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TNumber) |
ImplicitWideningImplicitImplicitImplicit(BaseEntry to TNumber) |
Inequality |
LessThan |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | obj |

See Also

TNumber Class
SMath.Math.Numeric Namespace


TNumber Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TNumber Constructor
TNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TNumber()()()() | Initializes a new instance of the TNumber class
Public method | TNumber(InfType) | Initializes a new instance of the TNumber class
Public method | TNumber(TComplex) | Initializes a new instance of the TNumber class
Public method | TNumber(TFraction) | Initializes a new instance of the TNumber class
Public method | TNumber(TInfinity) | Initializes a new instance of the TNumber class
Public method | TNumber(Double, Double) | Initializes a new instance of the TNumber class
Public method | TNumber(TDouble, TDouble) | Initializes a new instance of the TNumber class
Public method | TNumber(TFraction, TFraction) | Initializes a new instance of the TNumber class

See Also

TNumber Class
TNumber Members
SMath.Math.Numeric Namespace


TNumber Constructor

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber()
Visual Basic
Public Sub New
Visual C++
public:
TNumber()
F#
new : unit -> TNumber

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (InfType)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (InfType)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    InfType D
)
Visual Basic
Public Sub New ( _
    D As InfType _
)
Visual C++
public:
TNumber(
    InfType D
)
F#
new :
        D:InfType -> TNumber

Parameters

D
Type: SMath.Math.Numeric..::..InfType

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.InfType)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TComplex)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (TComplex)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    TComplex value
)
Visual Basic
Public Sub New ( _
    value As TComplex _
)
Visual C++
public:
TNumber(
    TComplex^ value
)
F#
new :
        value:TComplex -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TComplex)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TFraction)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (TFraction)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    TFraction D
)
Visual Basic
Public Sub New ( _
    D As TFraction _
)
Visual C++
public:
TNumber(
    TFraction^ D
)
F#
new :
        D:TFraction -> TNumber

Parameters

D
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="D"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TFraction)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TInfinity)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (TInfinity)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    TInfinity value
)
Visual Basic
Public Sub New ( _
    value As TInfinity _
)
Visual C++
public:
TNumber(
    TInfinity^ value
)
F#
new :
        value:TInfinity -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TInfinity)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (Double, Double)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (Double, Double)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    double num,
    double den
)
Visual Basic
Public Sub New ( _
    num As Double, _
    den As Double _
)
Visual C++
public:
TNumber(
    double num,
    double den
)
F#
new :
        num:float *
        den:float -> TNumber

Parameters

num
Type: System..::..Double

[Missing <param name="num"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(System.Double,System.Double)"]

den
Type: System..::..Double

[Missing <param name="den"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(System.Double,System.Double)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TDouble, TDouble)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (TDouble, TDouble)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    TDouble num,
    TDouble den
)
Visual Basic
Public Sub New ( _
    num As TDouble, _
    den As TDouble _
)
Visual C++
public:
TNumber(
    TDouble^ num,
    TDouble^ den
)
F#
new :
        num:TDouble *
        den:TDouble -> TNumber

Parameters

num
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="num"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

den
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="den"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TDouble,SMath.Math.Numeric.TDouble)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Constructor (TFraction, TFraction)

[image]

SMath Studio Class Libraries Documantation
TNumber Constructor (TFraction, TFraction)
TNumber Class See Also Send Feedback
Initializes a new instance of the TNumber class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber(
    TFraction Re,
    TFraction Im
)
Visual Basic
Public Sub New ( _
    Re As TFraction, _
    Im As TFraction _
)
Visual C++
public:
TNumber(
    TFraction^ Re,
    TFraction^ Im
)
F#
new :
        Re:TFraction *
        Im:TFraction -> TNumber

Parameters

Re
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="Re"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

Im
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="Im"/> documentation for "M:SMath.Math.Numeric.TNumber.#ctor(SMath.Math.Numeric.TFraction,SMath.Math.Numeric.TFraction)"]

See Also

TNumber Class
TNumber Overload
SMath.Math.Numeric Namespace


TNumber Fields

[image] [image]

SMath Studio Class Libraries Documantation
TNumber Fields
TNumber Class See Also Send Feedback

The TNumber type exposes the following members.

Fields

 | Name | Description
Public field | obj |

See Also

TNumber Class
SMath.Math.Numeric Namespace


obj Field

[image]

SMath Studio Class Libraries Documantation
TNumber..::..obj Field
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TNumber.obj"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public BaseEntry obj
Visual Basic
Public obj As BaseEntry
Visual C++
public:
BaseEntry^ obj
F#
val mutable obj: BaseEntry

See Also

TNumber Class
SMath.Math.Numeric Namespace


TNumber Methods

[image] [image]

SMath Studio Class Libraries Documantation
TNumber Methods
TNumber Class See Also Send Feedback

The TNumber type exposes the following members.

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosec |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Ainterp |
Public method | Alg |
Public method | Arg |
Public method | ASec |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Augment |
Public method | Cinterp |
Public method | Col |
Public method | Cols |
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | CSort |
Public method | Determinant |
Public method | Diag |
Public method | El(Int32) |
Public method | El(Int32, Int32) |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | FFT |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Identity |
Public method | Im |
Public method | Length |
Public method | Linterp |
Public method | Ln |
Public method | Log |
Public method | Matrix |
Public method | Max |
Public method | Min |
Public method | Minor |
Public method | Mod |
Public method | Norm1 |
Public method | NormE |
Public method | NormI |
Public method | Numden |
Public method | pol2xy |
Public method | PolyRoots |
Public method | Polyroots2 |
Public method | Power |
Public method | Random |
Public method | Rank |
Public method | Re |
Public method | Reverse |
Public method | Round |
Public method | Row |
Public method | Rows |
Public method | RSort |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sort |
Public method | Stack |
Public method | Submatrix |
Public method | Tan |
Public method | TanH |
Public method | Trace |
Public method | Transpose |
Public method | Trunc |
Public method | VMinor |
Public method | VMultiplication |
Public method | xy2pol()()()() |
Public method | xy2pol(TNumber) |

See Also

TNumber Class
SMath.Math.Numeric Namespace


Abs Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Abs Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Abs"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Abs()
Visual Basic
Public Function Abs As TNumber
Visual C++
public:
TNumber^ Abs()
F#
member Abs : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Abs"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ACos Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ACos Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ACos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACos()
Visual Basic
Public Function ACos As TNumber
Visual C++
public:
TNumber^ ACos()
F#
member ACos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ACos"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ACosec Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ACosec Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ACosec"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACosec()
Visual Basic
Public Function ACosec As TNumber
Visual C++
public:
TNumber^ ACosec()
F#
member ACosec : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ACosec"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ACosH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ACosH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ACosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACosH()
Visual Basic
Public Function ACosH As TNumber
Visual C++
public:
TNumber^ ACosH()
F#
member ACosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ACosH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ACot Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ACot Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ACot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACot()
Visual Basic
Public Function ACot As TNumber
Visual C++
public:
TNumber^ ACot()
F#
member ACot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ACot"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ACotH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ACotH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ACotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACotH()
Visual Basic
Public Function ACotH As TNumber
Visual C++
public:
TNumber^ ACotH()
F#
member ACotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ACotH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Ainterp Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Ainterp Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Ainterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Ainterp(
    TNumber c2,
    TNumber pnt
)
Visual Basic
Public Function Ainterp ( _
    c2 As TNumber, _
    pnt As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Ainterp(
    TNumber^ c2,
    TNumber^ pnt
)
F#
member Ainterp :
        c2:TNumber *
        pnt:TNumber -> TNumber

Parameters

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.Ainterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

pnt
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TNumber.Ainterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Ainterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Alg Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Alg Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Alg(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Alg(
    int row,
    int col
)
Visual Basic
Public Function Alg ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ Alg(
    int row,
    int col
)
F#
member Alg :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TNumber.Alg(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TNumber.Alg(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Alg(System.Int32,System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Arg Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Arg Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Arg"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Arg()
Visual Basic
Public Function Arg As TNumber
Visual C++
public:
TNumber^ Arg()
F#
member Arg : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Arg"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ASec Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ASec Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ASec"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASec()
Visual Basic
Public Function ASec As TNumber
Visual C++
public:
TNumber^ ASec()
F#
member ASec : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ASec"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ASin Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ASin Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ASin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASin()
Visual Basic
Public Function ASin As TNumber
Visual C++
public:
TNumber^ ASin()
F#
member ASin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ASin"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ASinH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ASinH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ASinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASinH()
Visual Basic
Public Function ASinH As TNumber
Visual C++
public:
TNumber^ ASinH()
F#
member ASinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ASinH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ATan Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ATan Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ATan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATan()
Visual Basic
Public Function ATan As TNumber
Visual C++
public:
TNumber^ ATan()
F#
member ATan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ATan"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


ATanH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..ATanH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.ATanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATanH()
Visual Basic
Public Function ATanH As TNumber
Visual C++
public:
TNumber^ ATanH()
F#
member ATanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.ATanH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Augment Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Augment Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Augment(SMath.Math.Numeric.TNumber[])"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Augment(
    TNumber[] value
)
Visual Basic
Public Function Augment ( _
    value As TNumber() _
) As TMatrix
Visual C++
public:
TMatrix^ Augment(
    array<TNumber^>^ value
)
F#
member Augment :
        value:TNumber[] -> TMatrix

Parameters

value
Type: array< SMath.Math.Numeric..::..TNumber >[]()[][]

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Augment(SMath.Math.Numeric.TNumber[])"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Augment(SMath.Math.Numeric.TNumber[])"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Cinterp Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Cinterp Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Cinterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cinterp(
    TNumber c2,
    TNumber pnt
)
Visual Basic
Public Function Cinterp ( _
    c2 As TNumber, _
    pnt As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Cinterp(
    TNumber^ c2,
    TNumber^ pnt
)
F#
member Cinterp :
        c2:TNumber *
        pnt:TNumber -> TNumber

Parameters

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.Cinterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

pnt
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TNumber.Cinterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Cinterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Col Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Col Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Col(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Col(
    int value
)
Visual Basic
Public Function Col ( _
    value As Integer _
) As TNumber
Visual C++
public:
TNumber^ Col(
    int value
)
F#
member Col :
        value:int -> TNumber

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Col(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Col(System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Cols Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Cols Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Cols"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cols()
Visual Basic
Public Function Cols As TNumber
Visual C++
public:
TNumber^ Cols()
F#
member Cols : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Cols"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Cos Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Cos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cos()
Visual Basic
Public Function Cos As TNumber
Visual C++
public:
TNumber^ Cos()
F#
member Cos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Cos"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


CosH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..CosH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.CosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CosH()
Visual Basic
Public Function CosH As TNumber
Visual C++
public:
TNumber^ CosH()
F#
member CosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.CosH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Cot Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Cot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cot()
Visual Basic
Public Function Cot As TNumber
Visual C++
public:
TNumber^ Cot()
F#
member Cot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Cot"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


CotH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..CotH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.CotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CotH()
Visual Basic
Public Function CotH As TNumber
Visual C++
public:
TNumber^ CotH()
F#
member CotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.CotH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


CSort Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..CSort Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.CSort(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CSort(
    TNumber ind
)
Visual Basic
Public Function CSort ( _
    ind As TNumber _
) As TNumber
Visual C++
public:
TNumber^ CSort(
    TNumber^ ind
)
F#
member CSort :
        ind:TNumber -> TNumber

Parameters

ind
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="ind"/> documentation for "M:SMath.Math.Numeric.TNumber.CSort(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.CSort(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Determinant Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Determinant Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Determinant"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Determinant()
Visual Basic
Public Function Determinant As TNumber
Visual C++
public:
TNumber^ Determinant()
F#
member Determinant : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Determinant"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Diag Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Diag Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Diag"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Diag()
Visual Basic
Public Function Diag As TNumber
Visual C++
public:
TNumber^ Diag()
F#
member Diag : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Diag"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


El Method

[image] [image]

SMath Studio Class Libraries Documantation
TNumber..::..El Method
TNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | El(Int32) |
Public method | El(Int32, Int32) |

See Also

TNumber Class
TNumber Members
SMath.Math.Numeric Namespace


El Method (Int32)

[image]

SMath Studio Class Libraries Documantation
TNumber..::..El Method (Int32)
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber El(
    int row
)
Visual Basic
Public Function El ( _
    row As Integer _
) As TNumber
Visual C++
public:
TNumber^ El(
    int row
)
F#
member El :
        row:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32)"]

See Also

TNumber Class
El Overload
SMath.Math.Numeric Namespace


El Method (Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
TNumber..::..El Method (Int32, Int32)
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber El(
    int row,
    int col
)
Visual Basic
Public Function El ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ El(
    int row,
    int col
)
F#
member El :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.El(System.Int32,System.Int32)"]

See Also

TNumber Class
El Overload
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Equals Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TNumber.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Equals(System.Object)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Factorial Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Factorial Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Factorial"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Factorial()
Visual Basic
Public Function Factorial As TNumber
Visual C++
public:
TNumber^ Factorial()
F#
member Factorial : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Factorial"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


FFT Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..FFT Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.FFT(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber FFT(
    TNumber c1
)
Visual Basic
Public Function FFT ( _
    c1 As TNumber _
) As TNumber
Visual C++
public:
TNumber^ FFT(
    TNumber^ c1
)
F#
member FFT :
        c1:TNumber -> TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.FFT(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.FFT(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..GetHashCode Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.GetHashCode"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Identity Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Identity Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Identity"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Identity()
Visual Basic
Public Function Identity As TNumber
Visual C++
public:
TNumber^ Identity()
F#
member Identity : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Identity"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Im Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Im Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Im"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Im()
Visual Basic
Public Function Im As TNumber
Visual C++
public:
TNumber^ Im()
F#
member Im : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Im"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Length Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Length Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Length"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Length()
Visual Basic
Public Function Length As TNumber
Visual C++
public:
TNumber^ Length()
F#
member Length : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Length"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Linterp Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Linterp Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Linterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Linterp(
    TNumber c2,
    TNumber pnt
)
Visual Basic
Public Function Linterp ( _
    c2 As TNumber, _
    pnt As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Linterp(
    TNumber^ c2,
    TNumber^ pnt
)
F#
member Linterp :
        c2:TNumber *
        pnt:TNumber -> TNumber

Parameters

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.Linterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

pnt
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="pnt"/> documentation for "M:SMath.Math.Numeric.TNumber.Linterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Linterp(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Ln Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Ln Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Ln"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Ln()
Visual Basic
Public Function Ln As TNumber
Visual C++
public:
TNumber^ Ln()
F#
member Ln : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Ln"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Log Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Log Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Log(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Log(
    TNumber Base
)
Visual Basic
Public Function Log ( _
    Base As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Log(
    TNumber^ Base
)
F#
member Log :
        Base:TNumber -> TNumber

Parameters

Base
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="Base"/> documentation for "M:SMath.Math.Numeric.TNumber.Log(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Log(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Matrix Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Matrix Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Matrix(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Matrix(
    TNumber value
)
Visual Basic
Public Function Matrix ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Matrix(
    TNumber^ value
)
F#
member Matrix :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Matrix(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Matrix(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Max Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Max Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Max"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Max()
Visual Basic
Public Function Max As TNumber
Visual C++
public:
TNumber^ Max()
F#
member Max : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Max"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Min Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Min Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Min"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Min()
Visual Basic
Public Function Min As TNumber
Visual C++
public:
TNumber^ Min()
F#
member Min : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Min"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Minor Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Minor Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Minor(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Minor(
    int row,
    int col
)
Visual Basic
Public Function Minor ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ Minor(
    int row,
    int col
)
F#
member Minor :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TNumber.Minor(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TNumber.Minor(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Minor(System.Int32,System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Mod Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Mod Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Mod(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Mod(
    TNumber value
)
Visual Basic
Public Function Mod ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Mod(
    TNumber^ value
)
F#
member Mod :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Mod(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Mod(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Norm1 Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Norm1 Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Norm1"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Norm1()
Visual Basic
Public Function Norm1 As TNumber
Visual C++
public:
TNumber^ Norm1()
F#
member Norm1 : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Norm1"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


NormE Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..NormE Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.NormE"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber NormE()
Visual Basic
Public Function NormE As TNumber
Visual C++
public:
TNumber^ NormE()
F#
member NormE : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.NormE"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


NormI Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..NormI Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.NormI"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber NormI()
Visual Basic
Public Function NormI As TNumber
Visual C++
public:
TNumber^ NormI()
F#
member NormI : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.NormI"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Numden Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Numden Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Numden"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Numden()
Visual Basic
Public Function Numden As TNumber
Visual C++
public:
TNumber^ Numden()
F#
member Numden : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Numden"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


pol2xy Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..pol2xy Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.pol2xy(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber pol2xy(
    TNumber value
)
Visual Basic
Public Function pol2xy ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ pol2xy(
    TNumber^ value
)
F#
member pol2xy :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.pol2xy(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.pol2xy(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


PolyRoots Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..PolyRoots Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.PolyRoots"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber PolyRoots()
Visual Basic
Public Function PolyRoots As TNumber
Visual C++
public:
TNumber^ PolyRoots()
F#
member PolyRoots : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.PolyRoots"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Polyroots2 Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Polyroots2 Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Polyroots2"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Polyroots2()
Visual Basic
Public Function Polyroots2 As TNumber
Visual C++
public:
TNumber^ Polyroots2()
F#
member Polyroots2 : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Polyroots2"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Power Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Power(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TNumber value
)
Visual Basic
Public Function Power ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TNumber^ value
)
F#
member Power :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Power(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Power(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Random Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Random Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Random"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Random()
Visual Basic
Public Function Random As TNumber
Visual C++
public:
TNumber^ Random()
F#
member Random : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Random"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Rank Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Rank Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Rank"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Rank()
Visual Basic
Public Function Rank As TNumber
Visual C++
public:
TNumber^ Rank()
F#
member Rank : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Rank"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Re Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Re Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Re"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Re()
Visual Basic
Public Function Re As TNumber
Visual C++
public:
TNumber^ Re()
F#
member Re : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Re"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Reverse Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Reverse Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Reverse"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Reverse()
Visual Basic
Public Function Reverse As TNumber
Visual C++
public:
TNumber^ Reverse()
F#
member Reverse : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Reverse"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Round Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Round Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Round(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Round(
    TNumber value
)
Visual Basic
Public Function Round ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ Round(
    TNumber^ value
)
F#
member Round :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Round(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Round(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Row Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Row Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Row(System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Row(
    int value
)
Visual Basic
Public Function Row ( _
    value As Integer _
) As TNumber
Visual C++
public:
TNumber^ Row(
    int value
)
F#
member Row :
        value:int -> TNumber

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Row(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Row(System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Rows Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Rows Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Rows"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Rows()
Visual Basic
Public Function Rows As TNumber
Visual C++
public:
TNumber^ Rows()
F#
member Rows : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Rows"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


RSort Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..RSort Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.RSort(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber RSort(
    TNumber ind
)
Visual Basic
Public Function RSort ( _
    ind As TNumber _
) As TNumber
Visual C++
public:
TNumber^ RSort(
    TNumber^ ind
)
F#
member RSort :
        ind:TNumber -> TNumber

Parameters

ind
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="ind"/> documentation for "M:SMath.Math.Numeric.TNumber.RSort(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.RSort(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Sign Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Sign Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Sign"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sign()
Visual Basic
Public Function Sign As TNumber
Visual C++
public:
TNumber^ Sign()
F#
member Sign : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Sign"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Sin Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Sin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sin()
Visual Basic
Public Function Sin As TNumber
Visual C++
public:
TNumber^ Sin()
F#
member Sin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Sin"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


SinH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..SinH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.SinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber SinH()
Visual Basic
Public Function SinH As TNumber
Visual C++
public:
TNumber^ SinH()
F#
member SinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.SinH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Sort Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Sort Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Sort"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sort()
Visual Basic
Public Function Sort As TNumber
Visual C++
public:
TNumber^ Sort()
F#
member Sort : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Sort"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Stack Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Stack Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Stack(SMath.Math.Numeric.TNumber[])"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TMatrix Stack(
    TNumber[] value
)
Visual Basic
Public Function Stack ( _
    value As TNumber() _
) As TMatrix
Visual C++
public:
TMatrix^ Stack(
    array<TNumber^>^ value
)
F#
member Stack :
        value:TNumber[] -> TMatrix

Parameters

value
Type: array< SMath.Math.Numeric..::..TNumber >[]()[][]

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.Stack(SMath.Math.Numeric.TNumber[])"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Stack(SMath.Math.Numeric.TNumber[])"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Submatrix Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Submatrix Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
Visual Basic
Public Function Submatrix ( _
    startRow As Integer, _
    endRow As Integer, _
    startCol As Integer, _
    endCol As Integer _
) As TNumber
Visual C++
public:
TNumber^ Submatrix(
    int startRow,
    int endRow,
    int startCol,
    int endCol
)
F#
member Submatrix :
        startRow:int *
        endRow:int *
        startCol:int *
        endCol:int -> TNumber

Parameters

startRow
Type: System..::..Int32

[Missing <param name="startRow"/> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

endRow
Type: System..::..Int32

[Missing <param name="endRow"/> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

startCol
Type: System..::..Int32

[Missing <param name="startCol"/> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

endCol
Type: System..::..Int32

[Missing <param name="endCol"/> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Submatrix(System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Tan Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Tan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Tan()
Visual Basic
Public Function Tan As TNumber
Visual C++
public:
TNumber^ Tan()
F#
member Tan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Tan"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


TanH Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..TanH Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.TanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber TanH()
Visual Basic
Public Function TanH As TNumber
Visual C++
public:
TNumber^ TanH()
F#
member TanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.TanH"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Trace Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Trace Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Trace"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Trace()
Visual Basic
Public Function Trace As TNumber
Visual C++
public:
TNumber^ Trace()
F#
member Trace : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Trace"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Transpose Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Transpose Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Transpose"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Transpose()
Visual Basic
Public Function Transpose As TNumber
Visual C++
public:
TNumber^ Transpose()
F#
member Transpose : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Transpose"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Trunc Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Trunc Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.Trunc"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Trunc()
Visual Basic
Public Function Trunc As TNumber
Visual C++
public:
TNumber^ Trunc()
F#
member Trunc : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.Trunc"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


VMinor Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..VMinor Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.VMinor(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber VMinor(
    int row,
    int col
)
Visual Basic
Public Function VMinor ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ VMinor(
    int row,
    int col
)
F#
member VMinor :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TNumber.VMinor(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TNumber.VMinor(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.VMinor(System.Int32,System.Int32)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


VMultiplication Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..VMultiplication Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.VMultiplication(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber VMultiplication(
    TNumber value
)
Visual Basic
Public Function VMultiplication ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ VMultiplication(
    TNumber^ value
)
F#
member VMultiplication :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.VMultiplication(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.VMultiplication(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


xy2pol Method

[image] [image]

SMath Studio Class Libraries Documantation
TNumber..::..xy2pol Method
TNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | xy2pol()()()() |
Public method | xy2pol(TNumber) |

See Also

TNumber Class
TNumber Members
SMath.Math.Numeric Namespace


xy2pol Method

[image]

SMath Studio Class Libraries Documantation
TNumber..::..xy2pol Method
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.xy2pol"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber xy2pol()
Visual Basic
Public Function xy2pol As TNumber
Visual C++
public:
TNumber^ xy2pol()
F#
member xy2pol : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.xy2pol"]

See Also

TNumber Class
xy2pol Overload
SMath.Math.Numeric Namespace


xy2pol Method (TNumber)

[image]

SMath Studio Class Libraries Documantation
TNumber..::..xy2pol Method (TNumber)
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.xy2pol(SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber xy2pol(
    TNumber value
)
Visual Basic
Public Function xy2pol ( _
    value As TNumber _
) As TNumber
Visual C++
public:
TNumber^ xy2pol(
    TNumber^ value
)
F#
member xy2pol :
        value:TNumber -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.xy2pol(SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.xy2pol(SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
xy2pol Overload
SMath.Math.Numeric Namespace


TNumber Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TNumber Operators and Type Conversions
TNumber Class See Also Send Feedback

The TNumber type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
ImplicitWideningImplicitImplicitImplicit(Double to TNumber) |
ImplicitWideningImplicitImplicitImplicit(BaseEntry to TNumber) |
Inequality |
LessThan |
Multiply |
Subtraction |

See Also

TNumber Class
SMath.Math.Numeric Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Addition Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Addition(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TNumber, _
    c2 As TNumber _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (+)
        c1:TNumber *
        c2:TNumber  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Addition(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Addition(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Addition(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Division Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Division(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TNumber, _
    c2 As TNumber _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (/)
        c1:TNumber *
        c2:TNumber  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Division(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Division(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Division(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Equality Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Equality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TNumber, _
    c2 As TNumber _
) As Boolean
Visual C++
public:
static bool operator ==(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (=)
        c1:TNumber *
        c2:TNumber  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Equality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Equality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Equality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


GreaterThan Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..GreaterThan Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_GreaterThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator >(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator > ( _
    c1 As TNumber, _
    c2 As TNumber _
) As Boolean
Visual C++
public:
static bool operator >(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (>)
        c1:TNumber *
        c2:TNumber  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_GreaterThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_GreaterThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_GreaterThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Implicit Conversion Operators

[image] [image]

SMath Studio Class Libraries Documantation
TNumber ImplicitWideningImplicitImplicitImplicit Conversion Operators
TNumber Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to TNumber) |
ImplicitWideningImplicitImplicitImplicit(BaseEntry to TNumber) |

See Also

TNumber Class
TNumber Members
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TNumber)

[image]

SMath Studio Class Libraries Documantation
TNumber ImplicitWideningImplicitImplicitImplicit Conversion (Double to TNumber)
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(System.Double)~SMath.Math.Numeric.TNumber"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TNumber (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TNumber
Visual C++
static implicit operator TNumber^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(System.Double)~SMath.Math.Numeric.TNumber"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(System.Double)~SMath.Math.Numeric.TNumber"]

See Also

TNumber Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (BaseEntry to TNumber)

[image]

SMath Studio Class Libraries Documantation
TNumber ImplicitWideningImplicitImplicitImplicit Conversion (BaseEntry to TNumber)
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(SMath.Math.Numeric.BaseEntry)~SMath.Math.Numeric.TNumber"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TNumber (
    BaseEntry value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As BaseEntry _
) As TNumber
Visual C++
static implicit operator TNumber^ (
    BaseEntry^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(SMath.Math.Numeric.BaseEntry)~SMath.Math.Numeric.TNumber"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Implicit(SMath.Math.Numeric.BaseEntry)~SMath.Math.Numeric.TNumber"]

See Also

TNumber Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Inequality Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Inequality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TNumber, _
    c2 As TNumber _
) As Boolean
Visual C++
public:
static bool operator !=(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (<>)
        c1:TNumber *
        c2:TNumber  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Inequality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Inequality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Inequality(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


LessThan Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..LessThan Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_LessThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator <(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator < ( _
    c1 As TNumber, _
    c2 As TNumber _
) As Boolean
Visual C++
public:
static bool operator <(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (<)
        c1:TNumber *
        c2:TNumber  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_LessThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_LessThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_LessThan(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Multiply Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Multiply(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TNumber, _
    c2 As TNumber _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (*)
        c1:TNumber *
        c2:TNumber  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Multiply(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Multiply(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Multiply(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
TNumber..::..Subtraction Operator
TNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TNumber.op_Subtraction(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TNumber c1,
    TNumber c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TNumber, _
    c2 As TNumber _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TNumber^ c1,
    TNumber^ c2
)
F#
static let inline (-)
        c1:TNumber *
        c2:TNumber  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Subtraction(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

c2
Type: SMath.Math.Numeric..::..TNumber

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TNumber.op_Subtraction(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TNumber.op_Subtraction(SMath.Math.Numeric.TNumber,SMath.Math.Numeric.TNumber)"]

See Also

TNumber Class
SMath.Math.Numeric Namespace


TSystem Class

[image]

SMath Studio Class Libraries Documantation
TSystem Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class TSystem : BaseEntry
Visual Basic
Public Class TSystem _
    Inherits BaseEntry
Visual C++
public ref class TSystem : public BaseEntry
F#
type TSystem =
    class
        inherit BaseEntry
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Numeric..::..BaseEntry
SMath.Math.Numeric..::..TSystem

See Also

TSystem Members
SMath.Math.Numeric Namespace


TSystem Members

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Members
TSystem Class Constructors Methods Operators Fields Properties See Also Send Feedback

The TSystem type exposes the following members.

Constructors

 | Name | Description
Public method | TSystem(Double) |
Public method | TSystem(TComplex) |
Public method | TSystem(TDouble) |
Public method | TSystem(TFraction) |
Public method | TSystem(TInfinity) |
Public method | TSystem(TMatrix) |
Public method | TSystem(array<TNumber>[]()[][]) |

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Determinant |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | El |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Im |
Public method | Ln |
Public method | Log |
Public method | MatrixToEI |
Public method | Max |
Public method | Min |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)
Public method | Trace |
Public method | Transpose |

Operators

Name | Description
Addition |
Division |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TSystem) |
Inequality |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | matrix |

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TSystem Class
SMath.Math.Numeric Namespace


TSystem Constructor

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Constructor
TSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TSystem(Double) | Initializes a new instance of the TSystem class
Public method | TSystem(TComplex) | Initializes a new instance of the TSystem class
Public method | TSystem(TDouble) | Initializes a new instance of the TSystem class
Public method | TSystem(TFraction) | Initializes a new instance of the TSystem class
Public method | TSystem(TInfinity) | Initializes a new instance of the TSystem class
Public method | TSystem(TMatrix) | Initializes a new instance of the TSystem class
Public method | TSystem(array<TNumber>[]()[][]) | Initializes a new instance of the TSystem class

See Also

TSystem Class
TSystem Members
SMath.Math.Numeric Namespace


TSystem Constructor (Double)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (Double)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    double value
)
Visual Basic
Public Sub New ( _
    value As Double _
)
Visual C++
public:
TSystem(
    double value
)
F#
new :
        value:float -> TSystem

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(System.Double)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TComplex)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (TComplex)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TComplex value
)
Visual Basic
Public Sub New ( _
    value As TComplex _
)
Visual C++
public:
TSystem(
    TComplex^ value
)
F#
new :
        value:TComplex -> TSystem

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TComplex)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TDouble)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (TDouble)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TDouble value
)
Visual Basic
Public Sub New ( _
    value As TDouble _
)
Visual C++
public:
TSystem(
    TDouble^ value
)
F#
new :
        value:TDouble -> TSystem

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TDouble)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TFraction)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (TFraction)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TFraction value
)
Visual Basic
Public Sub New ( _
    value As TFraction _
)
Visual C++
public:
TSystem(
    TFraction^ value
)
F#
new :
        value:TFraction -> TSystem

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TFraction)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TInfinity)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (TInfinity)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TInfinity value
)
Visual Basic
Public Sub New ( _
    value As TInfinity _
)
Visual C++
public:
TSystem(
    TInfinity^ value
)
F#
new :
        value:TInfinity -> TSystem

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TInfinity)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TMatrix)

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (TMatrix)
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TMatrix value
)
Visual Basic
Public Sub New ( _
    value As TMatrix _
)
Visual C++
public:
TSystem(
    TMatrix^ value
)
F#
new :
        value:TMatrix -> TSystem

Parameters

value
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TMatrix)"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Constructor (TNumber[])

[image]

SMath Studio Class Libraries Documantation
TSystem Constructor (array<TNumber>[]()[][])
TSystem Class See Also Send Feedback
Initializes a new instance of the TSystem class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TSystem(
    TNumber[] matrix
)
Visual Basic
Public Sub New ( _
    matrix As TNumber() _
)
Visual C++
public:
TSystem(
    array<TNumber^>^ matrix
)
F#
new :
        matrix:TNumber[] -> TSystem

Parameters

matrix
Type: array< SMath.Math.Numeric..::..TNumber >[]()[][]

[Missing <param name="matrix"/> documentation for "M:SMath.Math.Numeric.TSystem.#ctor(SMath.Math.Numeric.TNumber[])"]

See Also

TSystem Class
TSystem Overload
SMath.Math.Numeric Namespace


TSystem Fields

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Fields
TSystem Class See Also Send Feedback

The TSystem type exposes the following members.

Fields

 | Name | Description
Public field | matrix |

See Also

TSystem Class
SMath.Math.Numeric Namespace


matrix Field

[image]

SMath Studio Class Libraries Documantation
TSystem..::..matrix Field
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.TSystem.matrix"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber[] matrix
Visual Basic
Public matrix As TNumber()
Visual C++
public:
array<TNumber^>^ matrix
F#
val mutable matrix: TNumber[]

See Also

TSystem Class
SMath.Math.Numeric Namespace


TSystem Methods

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Methods
TSystem Class See Also Send Feedback

The TSystem type exposes the following members.

Methods

 | Name | Description
Public method | Abs |
Public method | ACos |
Public method | ACosH |
Public method | ACot |
Public method | ACotH |
Public method | Arg |
Public method | ASin |
Public method | ASinH |
Public method | ATan |
Public method | ATanH |
Public method | Clone | (Overrides BaseEntry..::..Clone()()()().)
Public method | Com | (Overrides BaseEntry..::..Com(BaseEntry).)
Public method | Cos |
Public method | CosH |
Public method | Cot |
Public method | CotH |
Public method | Determinant |
Public method | Div | (Overrides BaseEntry..::..Div(BaseEntry).)
Public method | El |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | Factorial |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | Im |
Public method | Ln |
Public method | Log |
Public method | MatrixToEI |
Public method | Max |
Public method | Min |
Public method | Mul | (Overrides BaseEntry..::..Mul(BaseEntry).)
Public method | Pow | (Overrides BaseEntry..::..Pow(BaseEntry).)
Public method | Power |
Public method | Rank |
Public method | Re |
Public method | Sign |
Public method | Sin |
Public method | SinH |
Public method | Sub | (Overrides BaseEntry..::..Sub(BaseEntry).)
Public method | Tan |
Public method | TanH |
Public method | ToDouble | (Overrides BaseEntry..::..ToDouble()()()().)
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)
Public method | Trace |
Public method | Transpose |

See Also

TSystem Class
SMath.Math.Numeric Namespace


Abs Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Abs Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Abs"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Abs()
Visual Basic
Public Function Abs As TNumber
Visual C++
public:
TNumber^ Abs()
F#
member Abs : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Abs"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ACos Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ACos Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ACos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACos()
Visual Basic
Public Function ACos As TNumber
Visual C++
public:
TNumber^ ACos()
F#
member ACos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ACos"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ACosH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ACosH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ACosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACosH()
Visual Basic
Public Function ACosH As TNumber
Visual C++
public:
TNumber^ ACosH()
F#
member ACosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ACosH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ACot Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ACot Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ACot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACot()
Visual Basic
Public Function ACot As TNumber
Visual C++
public:
TNumber^ ACot()
F#
member ACot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ACot"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ACotH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ACotH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ACotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ACotH()
Visual Basic
Public Function ACotH As TNumber
Visual C++
public:
TNumber^ ACotH()
F#
member ACotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ACotH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Arg Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Arg Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Arg"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Arg()
Visual Basic
Public Function Arg As TNumber
Visual C++
public:
TNumber^ Arg()
F#
member Arg : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Arg"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ASin Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ASin Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ASin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASin()
Visual Basic
Public Function ASin As TNumber
Visual C++
public:
TNumber^ ASin()
F#
member ASin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ASin"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ASinH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ASinH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ASinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ASinH()
Visual Basic
Public Function ASinH As TNumber
Visual C++
public:
TNumber^ ASinH()
F#
member ASinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ASinH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ATan Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ATan Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ATan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATan()
Visual Basic
Public Function ATan As TNumber
Visual C++
public:
TNumber^ ATan()
F#
member ATan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ATan"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ATanH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ATanH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ATanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber ATanH()
Visual Basic
Public Function ATanH As TNumber
Visual C++
public:
TNumber^ ATanH()
F#
member ATanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ATanH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Clone Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Clone Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Clone"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Clone()
Visual Basic
Public Overrides Function Clone As BaseEntry
Visual C++
public:
virtual BaseEntry^ Clone() override
F#
abstract Clone : unit -> BaseEntry
override Clone : unit -> BaseEntry

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Clone"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Com Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Com Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Com(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Com(
    BaseEntry value
)
Visual Basic
Public Overrides Function Com ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Com(
    BaseEntry^ value
) override
F#
abstract Com :
        value:BaseEntry -> BaseEntry
override Com :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Com(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Com(SMath.Math.Numeric.BaseEntry)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Cos Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Cos"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cos()
Visual Basic
Public Function Cos As TNumber
Visual C++
public:
TNumber^ Cos()
F#
member Cos : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Cos"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


CosH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..CosH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.CosH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CosH()
Visual Basic
Public Function CosH As TNumber
Visual C++
public:
TNumber^ CosH()
F#
member CosH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.CosH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Cot Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Cot"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Cot()
Visual Basic
Public Function Cot As TNumber
Visual C++
public:
TNumber^ Cot()
F#
member Cot : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Cot"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


CotH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..CotH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.CotH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber CotH()
Visual Basic
Public Function CotH As TNumber
Visual C++
public:
TNumber^ CotH()
F#
member CotH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.CotH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Determinant Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Determinant Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Determinant"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Determinant()
Visual Basic
Public Function Determinant As TNumber
Visual C++
public:
TNumber^ Determinant()
F#
member Determinant : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Determinant"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Div Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Div Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Div(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Div(
    BaseEntry value
)
Visual Basic
Public Overrides Function Div ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Div(
    BaseEntry^ value
) override
F#
abstract Div :
        value:BaseEntry -> BaseEntry
override Div :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Div(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Div(SMath.Math.Numeric.BaseEntry)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


El Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..El Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.El(System.Int32,System.Int32)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber El(
    int row,
    int col
)
Visual Basic
Public Function El ( _
    row As Integer, _
    col As Integer _
) As TNumber
Visual C++
public:
TNumber^ El(
    int row,
    int col
)
F#
member El :
        row:int *
        col:int -> TNumber

Parameters

row
Type: System..::..Int32

[Missing <param name="row"/> documentation for "M:SMath.Math.Numeric.TSystem.El(System.Int32,System.Int32)"]

col
Type: System..::..Int32

[Missing <param name="col"/> documentation for "M:SMath.Math.Numeric.TSystem.El(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.El(System.Int32,System.Int32)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Equals Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Equals(System.Object)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:SMath.Math.Numeric.TSystem.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Equals(System.Object)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Factorial Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Factorial Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Factorial"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Factorial()
Visual Basic
Public Function Factorial As TNumber
Visual C++
public:
TNumber^ Factorial()
F#
member Factorial : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Factorial"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..GetHashCode Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.GetHashCode"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.GetHashCode"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Im Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Im Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Im"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Im()
Visual Basic
Public Function Im As TNumber
Visual C++
public:
TNumber^ Im()
F#
member Im : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Im"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Ln Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Ln Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Ln"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Ln()
Visual Basic
Public Function Ln As TNumber
Visual C++
public:
TNumber^ Ln()
F#
member Ln : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Ln"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Log Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Log Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Log(SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Log(
    TSystem Base
)
Visual Basic
Public Function Log ( _
    Base As TSystem _
) As TNumber
Visual C++
public:
TNumber^ Log(
    TSystem^ Base
)
F#
member Log :
        Base:TSystem -> TNumber

Parameters

Base
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="Base"/> documentation for "M:SMath.Math.Numeric.TSystem.Log(SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Log(SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


MatrixToEI Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..MatrixToEI Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.MatrixToEI(SMath.Math.Numeric.TMatrix,System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public Term[] MatrixToEI(
    TMatrix value,
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Function MatrixToEI ( _
    value As TMatrix, _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As Term()
Visual C++
public:
array<Term^>^ MatrixToEI(
    TMatrix^ value,
    int decimalPlaces,
    FractionsType fractionType
)
F#
member MatrixToEI :
        value:TMatrix *
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]

Parameters

value
Type: SMath.Math.Numeric..::..TMatrix

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.MatrixToEI(SMath.Math.Numeric.TMatrix,System.Int32,SMath.Manager.FractionsType)"]

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TSystem.MatrixToEI(SMath.Math.Numeric.TMatrix,System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TSystem.MatrixToEI(SMath.Math.Numeric.TMatrix,System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.MatrixToEI(SMath.Math.Numeric.TMatrix,System.Int32,SMath.Manager.FractionsType)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Max Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Max Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Max"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Max()
Visual Basic
Public Function Max As TNumber
Visual C++
public:
TNumber^ Max()
F#
member Max : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Max"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Min Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Min Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Min"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Min()
Visual Basic
Public Function Min As TNumber
Visual C++
public:
TNumber^ Min()
F#
member Min : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Min"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Mul Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Mul Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Mul(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Mul(
    BaseEntry value
)
Visual Basic
Public Overrides Function Mul ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Mul(
    BaseEntry^ value
) override
F#
abstract Mul :
        value:BaseEntry -> BaseEntry
override Mul :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Mul(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Mul(SMath.Math.Numeric.BaseEntry)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Pow Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Pow Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Pow(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Pow(
    BaseEntry value
)
Visual Basic
Public Overrides Function Pow ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Pow(
    BaseEntry^ value
) override
F#
abstract Pow :
        value:BaseEntry -> BaseEntry
override Pow :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Pow(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Pow(SMath.Math.Numeric.BaseEntry)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Power Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Power Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Power(SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Power(
    TSystem value
)
Visual Basic
Public Function Power ( _
    value As TSystem _
) As TNumber
Visual C++
public:
TNumber^ Power(
    TSystem^ value
)
F#
member Power :
        value:TSystem -> TNumber

Parameters

value
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Power(SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Power(SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Rank Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Rank Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Rank"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Rank()
Visual Basic
Public Function Rank As TNumber
Visual C++
public:
TNumber^ Rank()
F#
member Rank : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Rank"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Re Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Re Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Re"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Re()
Visual Basic
Public Function Re As TNumber
Visual C++
public:
TNumber^ Re()
F#
member Re : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Re"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Sign Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Sign Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Sign"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sign()
Visual Basic
Public Function Sign As TNumber
Visual C++
public:
TNumber^ Sign()
F#
member Sign : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Sign"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Sin Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Sin"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Sin()
Visual Basic
Public Function Sin As TNumber
Visual C++
public:
TNumber^ Sin()
F#
member Sin : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Sin"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


SinH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..SinH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.SinH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber SinH()
Visual Basic
Public Function SinH As TNumber
Visual C++
public:
TNumber^ SinH()
F#
member SinH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.SinH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Sub Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Sub Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Sub(SMath.Math.Numeric.BaseEntry)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override BaseEntry Sub(
    BaseEntry value
)
Visual Basic
Public Overrides Function Sub ( _
    value As BaseEntry _
) As BaseEntry
Visual C++
public:
virtual BaseEntry^ Sub(
    BaseEntry^ value
) override
F#
abstract Sub :
        value:BaseEntry -> BaseEntry
override Sub :
        value:BaseEntry -> BaseEntry

Parameters

value
Type: SMath.Math.Numeric..::..BaseEntry

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.Sub(SMath.Math.Numeric.BaseEntry)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Sub(SMath.Math.Numeric.BaseEntry)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Tan Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Tan"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Tan()
Visual Basic
Public Function Tan As TNumber
Visual C++
public:
TNumber^ Tan()
F#
member Tan : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Tan"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


TanH Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..TanH Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.TanH"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber TanH()
Visual Basic
Public Function TanH As TNumber
Visual C++
public:
TNumber^ TanH()
F#
member TanH : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.TanH"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ToDouble Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ToDouble Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ToDouble"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override double ToDouble()
Visual Basic
Public Overrides Function ToDouble As Double
Visual C++
public:
virtual double ToDouble() override
F#
abstract ToDouble : unit -> float
override ToDouble : unit -> float

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ToDouble"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


ToString Method

[image] [image]

SMath Studio Class Libraries Documantation
TSystem..::..ToString Method
TSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | English: Converts math expression component to string. Русский: Преобразование математического примитива в строку. (Inherited from BaseEntry.)
Public method | ToString(Int32, FractionsType) | (Overrides BaseEntry..::..ToString(Int32, FractionsType).)

See Also

TSystem Class
TSystem Members
SMath.Math.Numeric Namespace


ToString Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ToString Method (Int32, FractionsType)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ToString(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override string ToString(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToString ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As String
Visual C++
public:
virtual String^ ToString(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string
override ToString :
        decimalPlaces:int *
        fractionType:FractionsType -> string

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TSystem.ToString(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TSystem.ToString(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ToString(System.Int32,SMath.Manager.FractionsType)"]

See Also

TSystem Class
ToString Overload
SMath.Math.Numeric Namespace


ToTerms Method

[image] [image]

SMath Studio Class Libraries Documantation
TSystem..::..ToTerms Method
TSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToTerms()()()() | English: Converts current expression component to the array of Term in reverse polish notation (RPN). Русский: Преобразование математического примитива в массив базовых примитивов. (Inherited from BaseEntry.)
Public method | ToTerms(Int32, FractionsType) | (Overrides BaseEntry..::..ToTerms(Int32, FractionsType).)

See Also

TSystem Class
TSystem Members
SMath.Math.Numeric Namespace


ToTerms Method (Int32, FractionsType)

[image]

SMath Studio Class Libraries Documantation
TSystem..::..ToTerms Method (Int32, FractionsType)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public override Term[] ToTerms(
    int decimalPlaces,
    FractionsType fractionType
)
Visual Basic
Public Overrides Function ToTerms ( _
    decimalPlaces As Integer, _
    fractionType As FractionsType _
) As Term()
Visual C++
public:
virtual array<Term^>^ ToTerms(
    int decimalPlaces,
    FractionsType fractionType
) override
F#
abstract ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]
override ToTerms :
        decimalPlaces:int *
        fractionType:FractionsType -> Term[]

Parameters

decimalPlaces
Type: System..::..Int32

[Missing <param name="decimalPlaces"/> documentation for "M:SMath.Math.Numeric.TSystem.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

fractionType
Type: SMath.Manager..::..FractionsType

[Missing <param name="fractionType"/> documentation for "M:SMath.Math.Numeric.TSystem.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.ToTerms(System.Int32,SMath.Manager.FractionsType)"]

See Also

TSystem Class
ToTerms Overload
SMath.Math.Numeric Namespace


Trace Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Trace Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Trace"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Trace()
Visual Basic
Public Function Trace As TNumber
Visual C++
public:
TNumber^ Trace()
F#
member Trace : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Trace"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Transpose Method

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Transpose Method
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.Transpose"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public TNumber Transpose()
Visual Basic
Public Function Transpose As TNumber
Visual C++
public:
TNumber^ Transpose()
F#
member Transpose : unit -> TNumber

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.Transpose"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


TSystem Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Operators and Type Conversions
TSystem Class See Also Send Feedback

The TSystem type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
ImplicitWideningImplicitImplicitImplicit(Double to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TSystem) |
Inequality |
Multiply |
Subtraction |

See Also

TSystem Class
SMath.Math.Numeric Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Addition Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Addition(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator +(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As TSystem, _
    c2 As TSystem _
) As TNumber
Visual C++
public:
static TNumber^ operator +(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (+)
        c1:TSystem *
        c2:TSystem  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Addition(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Addition(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Addition(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Division Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Division(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator /(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As TSystem, _
    c2 As TSystem _
) As TNumber
Visual C++
public:
static TNumber^ operator /(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (/)
        c1:TSystem *
        c2:TSystem  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Division(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Division(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Division(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Equality Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Equality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator ==(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As TSystem, _
    c2 As TSystem _
) As Boolean
Visual C++
public:
static bool operator ==(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (=)
        c1:TSystem *
        c2:TSystem  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Equality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Equality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Equality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Implicit Conversion Operators

[image] [image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion Operators
TSystem Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TComplex to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TDouble to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TFraction to TSystem) |
ImplicitWideningImplicitImplicitImplicit(TInfinity to TSystem) |

See Also

TSystem Class
TSystem Members
SMath.Math.Numeric Namespace


Implicit Conversion (Double to TSystem)

[image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion (Double to TSystem)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(System.Double)~SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TSystem (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As TSystem
Visual C++
static implicit operator TSystem^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(System.Double)~SMath.Math.Numeric.TSystem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(System.Double)~SMath.Math.Numeric.TSystem"]

See Also

TSystem Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TComplex to TSystem)

[image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion (TComplex to TSystem)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TSystem (
    TComplex value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TComplex _
) As TSystem
Visual C++
static implicit operator TSystem^ (
    TComplex^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TComplex

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TSystem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TComplex)~SMath.Math.Numeric.TSystem"]

See Also

TSystem Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TDouble to TSystem)

[image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion (TDouble to TSystem)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TSystem (
    TDouble value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TDouble _
) As TSystem
Visual C++
static implicit operator TSystem^ (
    TDouble^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TDouble

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TSystem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TDouble)~SMath.Math.Numeric.TSystem"]

See Also

TSystem Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TFraction to TSystem)

[image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion (TFraction to TSystem)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TSystem (
    TFraction value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TFraction _
) As TSystem
Visual C++
static implicit operator TSystem^ (
    TFraction^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TFraction

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TSystem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TFraction)~SMath.Math.Numeric.TSystem"]

See Also

TSystem Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Implicit Conversion (TInfinity to TSystem)

[image]

SMath Studio Class Libraries Documantation
TSystem ImplicitWideningImplicitImplicitImplicit Conversion (TInfinity to TSystem)
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TSystem"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static implicit operator TSystem (
    TInfinity value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As TInfinity _
) As TSystem
Visual C++
static implicit operator TSystem^ (
    TInfinity^ value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: SMath.Math.Numeric..::..TInfinity

[Missing <param name="value"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TSystem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Implicit(SMath.Math.Numeric.TInfinity)~SMath.Math.Numeric.TSystem"]

See Also

TSystem Class
ImplicitWideningImplicitImplicitImplicit Overload
SMath.Math.Numeric Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Inequality Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Inequality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static bool operator !=(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As TSystem, _
    c2 As TSystem _
) As Boolean
Visual C++
public:
static bool operator !=(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (<>)
        c1:TSystem *
        c2:TSystem  : bool

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Inequality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Inequality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Inequality(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Multiply Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Multiply(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator *(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As TSystem, _
    c2 As TSystem _
) As TNumber
Visual C++
public:
static TNumber^ operator *(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (*)
        c1:TSystem *
        c2:TSystem  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Multiply(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Multiply(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Multiply(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
TSystem..::..Subtraction Operator
TSystem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Numeric.TSystem.op_Subtraction(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public static TNumber operator -(
    TSystem c1,
    TSystem c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As TSystem, _
    c2 As TSystem _
) As TNumber
Visual C++
public:
static TNumber^ operator -(
    TSystem^ c1,
    TSystem^ c2
)
F#
static let inline (-)
        c1:TSystem *
        c2:TSystem  : TNumber

Parameters

c1
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Subtraction(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

c2
Type: SMath.Math.Numeric..::..TSystem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Numeric.TSystem.op_Subtraction(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Numeric.TSystem.op_Subtraction(SMath.Math.Numeric.TSystem,SMath.Math.Numeric.TSystem)"]

See Also

TSystem Class
SMath.Math.Numeric Namespace


TSystem Properties

[image] [image]

SMath Studio Class Libraries Documantation
TSystem Properties
TSystem Class See Also Send Feedback

The TSystem type exposes the following members.

Properties

 | Name | Description
Public property | Units | English: Unit of the expression component. Русский: Размерность математического примитива. (Inherited from BaseEntry.)

See Also

TSystem Class
SMath.Math.Numeric Namespace


VariableNotDefinedException Class

[image]

SMath Studio Class Libraries Documantation
VariableNotDefinedException Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Numeric.VariableNotDefinedException"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public class VariableNotDefinedException : EvaluationException
Visual Basic
Public Class VariableNotDefinedException _
    Inherits EvaluationException
Visual C++
public ref class VariableNotDefinedException : public EvaluationException
F#
type VariableNotDefinedException =
    class
        inherit EvaluationException
    end

Inheritance Hierarchy

System..::..Object
System..::..Exception
SMath.Manager..::..EvaluationException
SMath.Math.Numeric..::..VariableNotDefinedException

See Also

VariableNotDefinedException Members
SMath.Math.Numeric Namespace


VariableNotDefinedException Members

[image] [image]

SMath Studio Class Libraries Documantation
VariableNotDefinedException Members
VariableNotDefinedException Class Constructors Fields See Also Send Feedback

The VariableNotDefinedException type exposes the following members.

Constructors

 | Name | Description
Public method | VariableNotDefinedException | Initializes a new instance of the VariableNotDefinedException class

Fields

 | Name | Description
Public field | ErrorId | (Inherited from EvaluationException.)
Public field | Variable |

See Also

VariableNotDefinedException Class
SMath.Math.Numeric Namespace


VariableNotDefinedException Constructor

[image]

SMath Studio Class Libraries Documantation
VariableNotDefinedException Constructor
VariableNotDefinedException Class See Also Send Feedback
Initializes a new instance of the VariableNotDefinedException class

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public VariableNotDefinedException(
    string Variable,
    Exception InnerException
)
Visual Basic
Public Sub New ( _
    Variable As String, _
    InnerException As Exception _
)
Visual C++
public:
VariableNotDefinedException(
    String^ Variable,
    Exception^ InnerException
)
F#
new :
        Variable:string *
        InnerException:Exception -> VariableNotDefinedException

Parameters

Variable
Type: System..::..String

[Missing <param name="Variable"/> documentation for "M:SMath.Math.Numeric.VariableNotDefinedException.#ctor(System.String,System.Exception)"]

InnerException
Type: System..::..Exception

[Missing <param name="InnerException"/> documentation for "M:SMath.Math.Numeric.VariableNotDefinedException.#ctor(System.String,System.Exception)"]

See Also

VariableNotDefinedException Class
SMath.Math.Numeric Namespace


VariableNotDefinedException Fields

[image] [image]

SMath Studio Class Libraries Documantation
VariableNotDefinedException Fields
VariableNotDefinedException Class See Also Send Feedback

The VariableNotDefinedException type exposes the following members.

Fields

 | Name | Description
Public field | ErrorId | (Inherited from EvaluationException.)
Public field | Variable |

See Also

VariableNotDefinedException Class
SMath.Math.Numeric Namespace


Variable Field

[image]

SMath Studio Class Libraries Documantation
VariableNotDefinedException..::..Variable Field
VariableNotDefinedException Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Numeric.VariableNotDefinedException.Variable"]

Namespace: SMath.Math.Numeric
Assembly: NuLib (in NuLib.dll) Version: 1.54.3855.30320

Syntax

C#
public string Variable
Visual Basic
Public Variable As String
Visual C++
public:
String^ Variable
F#
val mutable Variable: string

See Also

VariableNotDefinedException Class
SMath.Math.Numeric Namespace


SMath.Math.Symbolic Namespace

[image]

SMath Studio Class Libraries Documantation
SMath.Math.Symbolic Namespace
Send Feedback

[Missing <summary> documentation for "N:SMath.Math.Symbolic"]

Classes

 | Class | Description
Public class | Constants |
Public class | Converter |
Public class | Expansion | Предварительная подготовка выражения к последующим упрощениям.
Public class | Expression |
Public class | Expression..::..RuleParams<(Of <(<'T>)>)> | Правило преобразования
Public class | MItem | Математическое выражение
Public class | MMatrix |

Interfaces

 | Interface | Description
Public interface | IPluginMathSymbolicEvaluation |

Enumerations

 | Enumeration | Description
Public enumeration | Expression..::..RuleType | Тип правила преобразования
Public enumeration | MItemBrackets | Представление математической скобки


Constants Class

[image]

SMath Studio Class Libraries Documantation
Constants Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Symbolic.Constants"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class Constants
Visual Basic
Public Class Constants
Visual C++
public ref class Constants
F#
type Constants =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..Constants

See Also

Constants Members
SMath.Math.Symbolic Namespace


Constants Members

[image] [image]

SMath Studio Class Libraries Documantation
Constants Members
Constants Class Constructors Fields See Also Send Feedback

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants | Initializes a new instance of the Constants class

Fields

Name | Description
One |
Zero |

See Also

Constants Class
SMath.Math.Symbolic Namespace


Constants Constructor

[image]

SMath Studio Class Libraries Documantation
Constants Constructor
Constants Class See Also Send Feedback
Initializes a new instance of the Constants class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Constants()
Visual Basic
Public Sub New
Visual C++
public:
Constants()
F#
new : unit -> Constants

See Also

Constants Class
SMath.Math.Symbolic Namespace


Constants Fields

[image] [image]

SMath Studio Class Libraries Documantation
Constants Fields
Constants Class See Also Send Feedback

The Constants type exposes the following members.

Fields

Name | Description
One |
Zero |

See Also

Constants Class
SMath.Math.Symbolic Namespace


One Field

[image]

SMath Studio Class Libraries Documantation
Constants..::..One Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.Constants.One"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static readonly MItem One
Visual Basic
Public Shared ReadOnly One As MItem
Visual C++
public:
static initonly MItem^ One
F#
static val One: MItem

See Also

Constants Class
SMath.Math.Symbolic Namespace


Zero Field

[image]

SMath Studio Class Libraries Documantation
Constants..::..Zero Field
Constants Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.Constants.Zero"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static readonly MItem Zero
Visual Basic
Public Shared ReadOnly Zero As MItem
Visual C++
public:
static initonly MItem^ Zero
F#
static val Zero: MItem

See Also

Constants Class
SMath.Math.Symbolic Namespace


Converter Class

[image]

SMath Studio Class Libraries Documantation
Converter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Symbolic.Converter"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class Converter
Visual Basic
Public Class Converter
Visual C++
public ref class Converter
F#
type Converter =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..Converter

See Also

Converter Members
SMath.Math.Symbolic Namespace


Converter Members

[image] [image]

SMath Studio Class Libraries Documantation
Converter Members
Converter Class Constructors Methods See Also Send Feedback

The Converter type exposes the following members.

Constructors

 | Name | Description
Public method | Converter | Initializes a new instance of the Converter class

Methods

Name | Description
ToMItem(String) | Конвертация из строки в MItem
ToMItem(array<Term>[]()[][]) | Конвертация из Term[] в MItem
ToString | Конвертация из MItem в строку

See Also

Converter Class
SMath.Math.Symbolic Namespace


Converter Constructor

[image]

SMath Studio Class Libraries Documantation
Converter Constructor
Converter Class See Also Send Feedback
Initializes a new instance of the Converter class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Converter()
Visual Basic
Public Sub New
Visual C++
public:
Converter()
F#
new : unit -> Converter

See Also

Converter Class
SMath.Math.Symbolic Namespace


Converter Methods

[image] [image]

SMath Studio Class Libraries Documantation
Converter Methods
Converter Class See Also Send Feedback

The Converter type exposes the following members.

Methods

Name | Description
ToMItem(String) | Конвертация из строки в MItem
ToMItem(array<Term>[]()[][]) | Конвертация из Term[] в MItem
ToString | Конвертация из MItem в строку

See Also

Converter Class
SMath.Math.Symbolic Namespace


ToMItem Method

[image] [image]

SMath Studio Class Libraries Documantation
Converter..::..ToMItem Method
Converter Class See Also Send Feedback

Overload List

Name | Description
ToMItem(String) | Конвертация из строки в MItem
ToMItem(array<Term>[]()[][]) | Конвертация из Term[] в MItem

See Also

Converter Class
Converter Members
SMath.Math.Symbolic Namespace


ToMItem Method (String)

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToMItem Method (String)
Converter Class See Also Send Feedback
Конвертация из строки в MItem

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ToMItem(
    string value
)
Visual Basic
Public Shared Function ToMItem ( _
    value As String _
) As MItem
Visual C++
public:
static MItem^ ToMItem(
    String^ value
)
F#
static member ToMItem :
        value:string -> MItem

Parameters

value
Type: System..::..String
Строка математического выражения

Return Value

Результат перевода выражения

See Also

Converter Class
ToMItem Overload
SMath.Math.Symbolic Namespace


ToMItem Method (Term[])

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToMItem Method (array<Term>[]()[][])
Converter Class See Also Send Feedback
Конвертация из Term[] в MItem

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ToMItem(
    Term[] value
)
Visual Basic
Public Shared Function ToMItem ( _
    value As Term() _
) As MItem
Visual C++
public:
static MItem^ ToMItem(
    array<Term^>^ value
)
F#
static member ToMItem :
        value:Term[] -> MItem

Parameters

value
Type: array< SMath.Manager..::..Term >[]()[][]
Массив элементов Term

Return Value

Результат перевода выражения

See Also

Converter Class
ToMItem Overload
SMath.Math.Symbolic Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
Converter..::..ToString Method
Converter Class See Also Send Feedback
Конвертация из MItem в строку

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static string ToString(
    MItem value
)
Visual Basic
Public Shared Function ToString ( _
    value As MItem _
) As String
Visual C++
public:
static String^ ToString(
    MItem^ value
)
F#
static member ToString :
        value:MItem -> string

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Mатематического выражения

Return Value

Результат перевода выражения

See Also

Converter Class
SMath.Math.Symbolic Namespace


Expansion Class

[image]

SMath Studio Class Libraries Documantation
Expansion Class
Members See Also Send Feedback
Предварительная подготовка выражения к последующим упрощениям.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public sealed class Expansion
Visual Basic
Public NotInheritable Class Expansion
Visual C++
public ref class Expansion sealed
F#
[<SealedAttribute>]
type Expansion =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..Expansion

See Also

Expansion Members
SMath.Math.Symbolic Namespace


Expansion Members

[image] [image]

SMath Studio Class Libraries Documantation
Expansion Members
Expansion Class Constructors Methods See Also Send Feedback

The Expansion type exposes the following members.

Constructors

 | Name | Description
Public method | Expansion | Initializes a new instance of the Expansion class

Methods

Name | Description
Expand | Разложение выражения на простейшие слагаемые.
Prepare | Первичное преобразование выражения перед упрощением

See Also

Expansion Class
SMath.Math.Symbolic Namespace


Expansion Constructor

[image]

SMath Studio Class Libraries Documantation
Expansion Constructor
Expansion Class See Also Send Feedback
Initializes a new instance of the Expansion class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Expansion()
Visual Basic
Public Sub New
Visual C++
public:
Expansion()
F#
new : unit -> Expansion

See Also

Expansion Class
SMath.Math.Symbolic Namespace


Expansion Methods

[image] [image]

SMath Studio Class Libraries Documantation
Expansion Methods
Expansion Class See Also Send Feedback

The Expansion type exposes the following members.

Methods

Name | Description
Expand | Разложение выражения на простейшие слагаемые.
Prepare | Первичное преобразование выражения перед упрощением

See Also

Expansion Class
SMath.Math.Symbolic Namespace


Expand Method

[image]

SMath Studio Class Libraries Documantation
Expansion..::..Expand Method
Expansion Class See Also Send Feedback
Разложение выражения на простейшие слагаемые.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Expand(
    ref MItem value
)
Visual Basic
Public Shared Function Expand ( _
    ByRef value As MItem _
) As MItem
Visual C++
public:
static MItem^ Expand(
    MItem^% value
)
F#
static member Expand :
        value:MItem byref -> MItem

Parameters

value
Type: SMath.Math.Symbolic..::..MItem %
Выражение для преобразований

Return Value

Разложенное на простейшие слагаемые выражение

See Also

Expansion Class
SMath.Math.Symbolic Namespace


Prepare Method

[image]

SMath Studio Class Libraries Documantation
Expansion..::..Prepare Method
Expansion Class See Also Send Feedback
Первичное преобразование выражения перед упрощением

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Prepare(
    ref MItem value
)
Visual Basic
Public Shared Function Prepare ( _
    ByRef value As MItem _
) As MItem
Visual C++
public:
static MItem^ Prepare(
    MItem^% value
)
F#
static member Prepare :
        value:MItem byref -> MItem

Parameters

value
Type: SMath.Math.Symbolic..::..MItem %
Выражение для преобразований

Return Value

Преобразованное выражение

See Also

Expansion Class
SMath.Math.Symbolic Namespace


Expression Class

[image]

SMath Studio Class Libraries Documantation
Expression Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Symbolic.Expression"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class Expression
Visual Basic
Public Class Expression
Visual C++
public ref class Expression
F#
type Expression =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..Expression

See Also

Expression Members
SMath.Math.Symbolic Namespace


Expression Members

[image] [image]

SMath Studio Class Libraries Documantation
Expression Members
Expression Class Constructors Methods Properties See Also Send Feedback

The Expression type exposes the following members.

Constructors

 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class

Methods

Name | Description
Abs | Абсолютное значение (модуль)
AcceptRule | Применения правила преобразования
ArcCos | Арккосинус
ArcCosec | Арккосеканс
ArcCtg | Арккотангенс
ArcSec | Арксеканс
ArcSin | Арксинус
ArcTg | Арктангенс
Augment |
Col |
Cols |
Cos | Косинус
Cosec | Косеканс
Cosech | Гиперболический косеканс
Cosh | Гиперболический косинус
Cot | Котангенс
Diag |
Differentiate | Дифференцирование математического выражения. Применяйте ТОЛЬКО в том случае, если выражение готово к операции, иначе используйте DifferentiateEx
DifferentiateEx | Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.
DirectActions | Применение правил преобразования математического выражения после основного упрощения
El(MItem, MItem) |
El(MItem, MItem, MItem) |
Exp | e^x
Identity |
InverseActions | Применение правил преобразования математического выражения до основного упрощения
Length |
Lg | Десятичный логарифм
Ln | Натуральный логарифм
Log | Логарифм по произвольному основанию
Matrix |
Mod | Остаток от деления
Nthroot | Корень произвольной степени
Numden |
Round |
Row |
Rows |
Sec | Секанс
Sech | Гиперболический секанс
Simplify | Упрощение математического выражения
SimplifyEx | Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и постпреобразованиями для максимально удобного вывода ответа.
Sin | Синус
Sinh | Гиперболический синус
Sqrt | Квадратный корень
Stack |
Submatrix |
Tan | Тангенс
Trunc | Целая часть числа

Properties

Name | Description
Rules | Список правил преобразований

See Also

Expression Class
SMath.Math.Symbolic Namespace


Expression Constructor

[image]

SMath Studio Class Libraries Documantation
Expression Constructor
Expression Class See Also Send Feedback
Initializes a new instance of the Expression class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Expression()
Visual Basic
Public Sub New
Visual C++
public:
Expression()
F#
new : unit -> Expression

See Also

Expression Class
SMath.Math.Symbolic Namespace


Expression Methods

[image] [image]

SMath Studio Class Libraries Documantation
Expression Methods
Expression Class See Also Send Feedback

The Expression type exposes the following members.

Methods

Name | Description
Abs | Абсолютное значение (модуль)
AcceptRule | Применения правила преобразования
ArcCos | Арккосинус
ArcCosec | Арккосеканс
ArcCtg | Арккотангенс
ArcSec | Арксеканс
ArcSin | Арксинус
ArcTg | Арктангенс
Augment |
Col |
Cols |
Cos | Косинус
Cosec | Косеканс
Cosech | Гиперболический косеканс
Cosh | Гиперболический косинус
Cot | Котангенс
Diag |
Differentiate | Дифференцирование математического выражения. Применяйте ТОЛЬКО в том случае, если выражение готово к операции, иначе используйте DifferentiateEx
DifferentiateEx | Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.
DirectActions | Применение правил преобразования математического выражения после основного упрощения
El(MItem, MItem) |
El(MItem, MItem, MItem) |
Exp | e^x
Identity |
InverseActions | Применение правил преобразования математического выражения до основного упрощения
Length |
Lg | Десятичный логарифм
Ln | Натуральный логарифм
Log | Логарифм по произвольному основанию
Matrix |
Mod | Остаток от деления
Nthroot | Корень произвольной степени
Numden |
Round |
Row |
Rows |
Sec | Секанс
Sech | Гиперболический секанс
Simplify | Упрощение математического выражения
SimplifyEx | Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и постпреобразованиями для максимально удобного вывода ответа.
Sin | Синус
Sinh | Гиперболический синус
Sqrt | Квадратный корень
Stack |
Submatrix |
Tan | Тангенс
Trunc | Целая часть числа

See Also

Expression Class
SMath.Math.Symbolic Namespace


Abs Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Abs Method
Expression Class See Also Send Feedback
Абсолютное значение (модуль)

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Abs(
    MItem item
)
Visual Basic
Public Shared Function Abs ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Abs(
    MItem^ item
)
F#
static member Abs :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Abs(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Abs(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


AcceptRule Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..AcceptRule Method
Expression Class See Also Send Feedback
Применения правила преобразования

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem AcceptRule(
    MItem item,
    MItem ruleIn,
    MItem ruleOut
)
Visual Basic
Public Shared Function AcceptRule ( _
    item As MItem, _
    ruleIn As MItem, _
    ruleOut As MItem _
) As MItem
Visual C++
public:
static MItem^ AcceptRule(
    MItem^ item,
    MItem^ ruleIn,
    MItem^ ruleOut
)
F#
static member AcceptRule :
        item:MItem *
        ruleIn:MItem *
        ruleOut:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem
Математическое выражение для преобразований
ruleIn
Type: SMath.Math.Symbolic..::..MItem
Левая часть равенства для проверки на соответствие
ruleOut
Type: SMath.Math.Symbolic..::..MItem
Правая часть равенства для составления итогового выражения

Return Value

Результат применения правила к математическому выражению

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcCos Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcCos Method
Expression Class See Also Send Feedback
Арккосинус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcCos(
    MItem item
)
Visual Basic
Public Shared Function ArcCos ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcCos(
    MItem^ item
)
F#
static member ArcCos :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcCos(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcCos(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcCosec Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcCosec Method
Expression Class See Also Send Feedback
Арккосеканс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcCosec(
    MItem item
)
Visual Basic
Public Shared Function ArcCosec ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcCosec(
    MItem^ item
)
F#
static member ArcCosec :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcCosec(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcCosec(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcCtg Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcCtg Method
Expression Class See Also Send Feedback
Арккотангенс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcCtg(
    MItem item
)
Visual Basic
Public Shared Function ArcCtg ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcCtg(
    MItem^ item
)
F#
static member ArcCtg :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcCtg(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcCtg(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcSec Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcSec Method
Expression Class See Also Send Feedback
Арксеканс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcSec(
    MItem item
)
Visual Basic
Public Shared Function ArcSec ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcSec(
    MItem^ item
)
F#
static member ArcSec :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcSec(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcSec(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcSin Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcSin Method
Expression Class See Also Send Feedback
Арксинус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcSin(
    MItem item
)
Visual Basic
Public Shared Function ArcSin ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcSin(
    MItem^ item
)
F#
static member ArcSin :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcSin(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcSin(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


ArcTg Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..ArcTg Method
Expression Class See Also Send Feedback
Арктангенс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem ArcTg(
    MItem item
)
Visual Basic
Public Shared Function ArcTg ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ ArcTg(
    MItem^ item
)
F#
static member ArcTg :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.ArcTg(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.ArcTg(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Augment Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Augment Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Augment(SMath.Math.Symbolic.MItem[])"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Augment(
    MItem[] items
)
Visual Basic
Public Shared Function Augment ( _
    items As MItem() _
) As MItem
Visual C++
public:
static MItem^ Augment(
    array<MItem^>^ items
)
F#
static member Augment :
        items:MItem[] -> MItem

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.Expression.Augment(SMath.Math.Symbolic.MItem[])"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Augment(SMath.Math.Symbolic.MItem[])"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Col Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Col Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Col(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Col(
    MItem item,
    MItem value
)
Visual Basic
Public Shared Function Col ( _
    item As MItem, _
    value As MItem _
) As MItem
Visual C++
public:
static MItem^ Col(
    MItem^ item,
    MItem^ value
)
F#
static member Col :
        item:MItem *
        value:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Col(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

value
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.Expression.Col(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Col(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cols Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cols Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Cols(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cols(
    MItem item
)
Visual Basic
Public Shared Function Cols ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cols(
    MItem^ item
)
F#
static member Cols :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cols(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cols(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cos Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cos Method
Expression Class See Also Send Feedback
Косинус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cos(
    MItem item
)
Visual Basic
Public Shared Function Cos ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cos(
    MItem^ item
)
F#
static member Cos :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cos(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cos(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cosec Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cosec Method
Expression Class See Also Send Feedback
Косеканс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cosec(
    MItem item
)
Visual Basic
Public Shared Function Cosec ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cosec(
    MItem^ item
)
F#
static member Cosec :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cosec(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cosec(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cosech Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cosech Method
Expression Class See Also Send Feedback
Гиперболический косеканс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cosech(
    MItem item
)
Visual Basic
Public Shared Function Cosech ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cosech(
    MItem^ item
)
F#
static member Cosech :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cosech(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cosech(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cosh Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cosh Method
Expression Class See Also Send Feedback
Гиперболический косинус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cosh(
    MItem item
)
Visual Basic
Public Shared Function Cosh ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cosh(
    MItem^ item
)
F#
static member Cosh :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cosh(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cosh(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Cot Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Cot Method
Expression Class See Also Send Feedback
Котангенс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Cot(
    MItem item
)
Visual Basic
Public Shared Function Cot ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Cot(
    MItem^ item
)
F#
static member Cot :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Cot(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Cot(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Diag Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Diag Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Diag(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Diag(
    MItem item
)
Visual Basic
Public Shared Function Diag ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Diag(
    MItem^ item
)
F#
static member Diag :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Diag(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Diag(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Differentiate Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Differentiate Method
Expression Class See Also Send Feedback
Дифференцирование математического выражения. Применяйте ТОЛЬКО в том случае, если выражение готово к операции, иначе используйте DifferentiateEx

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Differentiate(
    MItem item,
    MItem Variable
)
Visual Basic
Public Shared Function Differentiate ( _
    item As MItem, _
    Variable As MItem _
) As MItem
Visual C++
public:
static MItem^ Differentiate(
    MItem^ item,
    MItem^ Variable
)
F#
static member Differentiate :
        item:MItem *
        Variable:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Differentiate(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Variable
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="Variable"/> documentation for "M:SMath.Math.Symbolic.Expression.Differentiate(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Differentiate(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


DifferentiateEx Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..DifferentiateEx Method
Expression Class See Also Send Feedback
Дифференцирование математического выражения. Перед дифференцированием выражение проходит полную подготовку к этой операции.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem DifferentiateEx(
    MItem value,
    MItem Variable,
    Store store
)
Visual Basic
Public Shared Function DifferentiateEx ( _
    value As MItem, _
    Variable As MItem, _
    store As Store _
) As MItem
Visual C++
public:
static MItem^ DifferentiateEx(
    MItem^ value,
    MItem^ Variable,
    Store^ store
)
F#
static member DifferentiateEx :
        value:MItem *
        Variable:MItem *
        store:Store -> MItem

Parameters

value
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.Expression.DifferentiateEx(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

Variable
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="Variable"/> documentation for "M:SMath.Math.Symbolic.Expression.DifferentiateEx(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

store
Type: SMath.Manager..::..Store

[Missing <param name="store"/> documentation for "M:SMath.Math.Symbolic.Expression.DifferentiateEx(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.DifferentiateEx(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


DirectActions Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..DirectActions Method
Expression Class See Also Send Feedback
Применение правил преобразования математического выражения после основного упрощения

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem DirectActions(
    MItem item
)
Visual Basic
Public Shared Function DirectActions ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ DirectActions(
    MItem^ item
)
F#
static member DirectActions :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem
Выражение для преобразований

Return Value

Преобразованное выражение

See Also

Expression Class
SMath.Math.Symbolic Namespace


El Method

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..El Method
Expression Class See Also Send Feedback

Overload List

Name | Description
El(MItem, MItem) |
El(MItem, MItem, MItem) |

See Also

Expression Class
Expression Members
SMath.Math.Symbolic Namespace


El Method (MItem, MItem)

[image]

SMath Studio Class Libraries Documantation
Expression..::..El Method (MItem, MItem)
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem El(
    MItem item0,
    MItem item1
)
Visual Basic
Public Shared Function El ( _
    item0 As MItem, _
    item1 As MItem _
) As MItem
Visual C++
public:
static MItem^ El(
    MItem^ item0,
    MItem^ item1
)
F#
static member El :
        item0:MItem *
        item1:MItem -> MItem

Parameters

item0
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item0"/> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

item1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item1"/> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
El Overload
SMath.Math.Symbolic Namespace


El Method (MItem, MItem, MItem)

[image]

SMath Studio Class Libraries Documantation
Expression..::..El Method (MItem, MItem, MItem)
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem El(
    MItem item0,
    MItem item1,
    MItem item2
)
Visual Basic
Public Shared Function El ( _
    item0 As MItem, _
    item1 As MItem, _
    item2 As MItem _
) As MItem
Visual C++
public:
static MItem^ El(
    MItem^ item0,
    MItem^ item1,
    MItem^ item2
)
F#
static member El :
        item0:MItem *
        item1:MItem *
        item2:MItem -> MItem

Parameters

item0
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item0"/> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

item1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item1"/> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

item2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item2"/> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.El(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
El Overload
SMath.Math.Symbolic Namespace


Exp Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Exp Method
Expression Class See Also Send Feedback
e^x

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Exp(
    MItem item
)
Visual Basic
Public Shared Function Exp ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Exp(
    MItem^ item
)
F#
static member Exp :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Exp(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Exp(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Identity Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Identity Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Identity(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Identity(
    MItem item
)
Visual Basic
Public Shared Function Identity ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Identity(
    MItem^ item
)
F#
static member Identity :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Identity(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Identity(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


InverseActions Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..InverseActions Method
Expression Class See Also Send Feedback
Применение правил преобразования математического выражения до основного упрощения

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem InverseActions(
    MItem item
)
Visual Basic
Public Shared Function InverseActions ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ InverseActions(
    MItem^ item
)
F#
static member InverseActions :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem
Выражение для преобразований

Return Value

Преобразованное выражение

See Also

Expression Class
SMath.Math.Symbolic Namespace


Length Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Length Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Length(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Length(
    MItem item
)
Visual Basic
Public Shared Function Length ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Length(
    MItem^ item
)
F#
static member Length :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Length(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Length(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Lg Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Lg Method
Expression Class See Also Send Feedback
Десятичный логарифм

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Lg(
    MItem item
)
Visual Basic
Public Shared Function Lg ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Lg(
    MItem^ item
)
F#
static member Lg :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Lg(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Lg(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Ln Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Ln Method
Expression Class See Also Send Feedback
Натуральный логарифм

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Ln(
    MItem item
)
Visual Basic
Public Shared Function Ln ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Ln(
    MItem^ item
)
F#
static member Ln :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Ln(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Ln(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Log Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Log Method
Expression Class See Also Send Feedback
Логарифм по произвольному основанию

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Log(
    MItem item,
    MItem Base
)
Visual Basic
Public Shared Function Log ( _
    item As MItem, _
    Base As MItem _
) As MItem
Visual C++
public:
static MItem^ Log(
    MItem^ item,
    MItem^ Base
)
F#
static member Log :
        item:MItem *
        Base:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Log(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Base
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="Base"/> documentation for "M:SMath.Math.Symbolic.Expression.Log(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Log(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Matrix Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Matrix Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Matrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Matrix(
    MItem item1,
    MItem item2
)
Visual Basic
Public Shared Function Matrix ( _
    item1 As MItem, _
    item2 As MItem _
) As MItem
Visual C++
public:
static MItem^ Matrix(
    MItem^ item1,
    MItem^ item2
)
F#
static member Matrix :
        item1:MItem *
        item2:MItem -> MItem

Parameters

item1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item1"/> documentation for "M:SMath.Math.Symbolic.Expression.Matrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

item2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item2"/> documentation for "M:SMath.Math.Symbolic.Expression.Matrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Matrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Mod Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Mod Method
Expression Class See Also Send Feedback
Остаток от деления

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Mod(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Function Mod ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ Mod(
    MItem^ c1,
    MItem^ c2
)
F#
static member Mod :
        c1:MItem *
        c2:MItem -> MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.Expression.Mod(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.Expression.Mod(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Mod(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Nthroot Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Nthroot Method
Expression Class See Also Send Feedback
Корень произвольной степени

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Nthroot(
    MItem item1,
    MItem item2
)
Visual Basic
Public Shared Function Nthroot ( _
    item1 As MItem, _
    item2 As MItem _
) As MItem
Visual C++
public:
static MItem^ Nthroot(
    MItem^ item1,
    MItem^ item2
)
F#
static member Nthroot :
        item1:MItem *
        item2:MItem -> MItem

Parameters

item1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item1"/> documentation for "M:SMath.Math.Symbolic.Expression.Nthroot(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

item2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item2"/> documentation for "M:SMath.Math.Symbolic.Expression.Nthroot(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Nthroot(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Numden Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Numden Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Numden(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Numden(
    MItem item
)
Visual Basic
Public Shared Function Numden ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Numden(
    MItem^ item
)
F#
static member Numden :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Numden(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Numden(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Round Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Round Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Round(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Round(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Function Round ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ Round(
    MItem^ c1,
    MItem^ c2
)
F#
static member Round :
        c1:MItem *
        c2:MItem -> MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.Expression.Round(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.Expression.Round(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Round(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Row Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Row Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Row(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Row(
    MItem item,
    MItem value
)
Visual Basic
Public Shared Function Row ( _
    item As MItem, _
    value As MItem _
) As MItem
Visual C++
public:
static MItem^ Row(
    MItem^ item,
    MItem^ value
)
F#
static member Row :
        item:MItem *
        value:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Row(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

value
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.Expression.Row(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Row(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Rows Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Rows Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Rows(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Rows(
    MItem item
)
Visual Basic
Public Shared Function Rows ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Rows(
    MItem^ item
)
F#
static member Rows :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Rows(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Rows(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Sec Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Sec Method
Expression Class See Also Send Feedback
Секанс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Sec(
    MItem item
)
Visual Basic
Public Shared Function Sec ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Sec(
    MItem^ item
)
F#
static member Sec :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Sec(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Sec(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Sech Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Sech Method
Expression Class See Also Send Feedback
Гиперболический секанс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Sech(
    MItem item
)
Visual Basic
Public Shared Function Sech ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Sech(
    MItem^ item
)
F#
static member Sech :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Sech(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Sech(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Simplify Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Simplify Method
Expression Class See Also Send Feedback
Упрощение математического выражения

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Simplify(
    MItem item,
    Store store
)
Visual Basic
Public Shared Function Simplify ( _
    item As MItem, _
    store As Store _
) As MItem
Visual C++
public:
static MItem^ Simplify(
    MItem^ item,
    Store^ store
)
F#
static member Simplify :
        item:MItem *
        store:Store -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Simplify(SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

store
Type: SMath.Manager..::..Store

[Missing <param name="store"/> documentation for "M:SMath.Math.Symbolic.Expression.Simplify(SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Simplify(SMath.Math.Symbolic.MItem,SMath.Manager.Store)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


SimplifyEx Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..SimplifyEx Method
Expression Class See Also Send Feedback
Полное упрощение математического выражения с его подготовкой, предварительными преобразованиями, упрощением и постпреобразованиями для максимально удобного вывода ответа.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem SimplifyEx(
    MItem value,
    Store store
)
Visual Basic
Public Shared Function SimplifyEx ( _
    value As MItem, _
    store As Store _
) As MItem
Visual C++
public:
static MItem^ SimplifyEx(
    MItem^ value,
    Store^ store
)
F#
static member SimplifyEx :
        value:MItem *
        store:Store -> MItem

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Выражение для упрощений
store
Type: SMath.Manager..::..Store
Хранилище информации о выполняемом действии

Return Value

Результат преобразования выражения

See Also

Expression Class
SMath.Math.Symbolic Namespace


Sin Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Sin Method
Expression Class See Also Send Feedback
Синус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Sin(
    MItem item
)
Visual Basic
Public Shared Function Sin ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Sin(
    MItem^ item
)
F#
static member Sin :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Sin(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Sin(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Sinh Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Sinh Method
Expression Class See Also Send Feedback
Гиперболический синус

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Sinh(
    MItem item
)
Visual Basic
Public Shared Function Sinh ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Sinh(
    MItem^ item
)
F#
static member Sinh :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Sinh(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Sinh(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Sqrt Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Sqrt Method
Expression Class See Also Send Feedback
Квадратный корень

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Sqrt(
    MItem item
)
Visual Basic
Public Shared Function Sqrt ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Sqrt(
    MItem^ item
)
F#
static member Sqrt :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Sqrt(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Sqrt(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Stack Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Stack Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Stack(SMath.Math.Symbolic.MItem[])"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Stack(
    MItem[] items
)
Visual Basic
Public Shared Function Stack ( _
    items As MItem() _
) As MItem
Visual C++
public:
static MItem^ Stack(
    array<MItem^>^ items
)
F#
static member Stack :
        items:MItem[] -> MItem

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.Expression.Stack(SMath.Math.Symbolic.MItem[])"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Stack(SMath.Math.Symbolic.MItem[])"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Submatrix Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Submatrix Method
Expression Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Submatrix(
    MItem item,
    MItem startR,
    MItem endR,
    MItem startC,
    MItem endC
)
Visual Basic
Public Shared Function Submatrix ( _
    item As MItem, _
    startR As MItem, _
    endR As MItem, _
    startC As MItem, _
    endC As MItem _
) As MItem
Visual C++
public:
static MItem^ Submatrix(
    MItem^ item,
    MItem^ startR,
    MItem^ endR,
    MItem^ startC,
    MItem^ endC
)
F#
static member Submatrix :
        item:MItem *
        startR:MItem *
        endR:MItem *
        startC:MItem *
        endC:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

startR
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="startR"/> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

endR
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="endR"/> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

startC
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="startC"/> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

endC
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="endC"/> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Submatrix(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Tan Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Tan Method
Expression Class See Also Send Feedback
Тангенс

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Tan(
    MItem item
)
Visual Basic
Public Shared Function Tan ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Tan(
    MItem^ item
)
F#
static member Tan :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Tan(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Tan(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Trunc Method

[image]

SMath Studio Class Libraries Documantation
Expression..::..Trunc Method
Expression Class See Also Send Feedback
Целая часть числа

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Trunc(
    MItem item
)
Visual Basic
Public Shared Function Trunc ( _
    item As MItem _
) As MItem
Visual C++
public:
static MItem^ Trunc(
    MItem^ item
)
F#
static member Trunc :
        item:MItem -> MItem

Parameters

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.Expression.Trunc(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.Expression.Trunc(SMath.Math.Symbolic.MItem)"]

See Also

Expression Class
SMath.Math.Symbolic Namespace


Expression Properties

[image] [image]

SMath Studio Class Libraries Documantation
Expression Properties
Expression Class See Also Send Feedback

The Expression type exposes the following members.

Properties

Name | Description
Rules | Список правил преобразований

See Also

Expression Class
SMath.Math.Symbolic Namespace


Rules Property

[image]

SMath Studio Class Libraries Documantation
Expression..::..Rules Property
Expression Class See Also Send Feedback
Список правил преобразований

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static List<Expression..::..RuleParams<MItem>> Rules { get; }
Visual Basic
Public Shared ReadOnly Property Rules As List(Of Expression..::..RuleParams(Of MItem))
    Get
Visual C++
public:
static property List<Expression..::..RuleParams<MItem^>^>^ Rules {
    List<Expression..::..RuleParams<MItem^>^>^ get ();
}
F#
static member Rules : List<Expression..::..RuleParams<MItem>>

See Also

Expression Class
SMath.Math.Symbolic Namespace


Expression.RuleParams(T) Class

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)> Class
Expression Class Members See Also Send Feedback
Правило преобразования

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class RuleParams<T>
Visual Basic
Public Class RuleParams(Of T)
Visual C++
generic<typename T>
public ref class RuleParams
F#
type RuleParams<'T> =  class end

Type Parameters

T
Контейнер для хранения математических выражений

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..Expression..::..RuleParams<(Of <(<'T>)>)>

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Members
SMath.Math.Symbolic Namespace


Expression.RuleParams(T) Members

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)> Members
Expression..::..RuleParams<(Of <(<'T>)>)> Class Constructors Fields See Also Send Feedback

The Expression..::..RuleParams<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Expression..::..RuleParams<(Of <(<'T>)>)> | Конструктор правила преобразования

Fields

 | Name | Description
Public field | ruleIn | Левая часть равенства
Public field | ruleOut | Правая часть равенства
Public field | type | Тип преобразования

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


Expression.RuleParams(T) Constructor

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)> Constructor
Expression..::..RuleParams<(Of <(<'T>)>)> Class See Also Send Feedback
Конструктор правила преобразования

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public RuleParams(
    T ruleIn,
    T ruleOut,
    Expression..::..RuleType type
)
Visual Basic
Public Sub New ( _
    ruleIn As T, _
    ruleOut As T, _
    type As Expression..::..RuleType _
)
Visual C++
public:
RuleParams(
    T ruleIn,
    T ruleOut,
    Expression..::..RuleType type
)
F#
new :
        ruleIn:'T *
        ruleOut:'T *
        type:Expression..::..RuleType -> RuleParams

Parameters

ruleIn
Type: T
Левая часть равенства
ruleOut
Type: T
Правая часть равенства
type
Type: SMath.Math.Symbolic..::..Expression..::..RuleType
Тип преобразования

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


Expression.RuleParams(T) Fields

[image] [image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)> Fields
Expression..::..RuleParams<(Of <(<'T>)>)> Class See Also Send Feedback

The Expression..::..RuleParams<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Public field | ruleIn | Левая часть равенства
Public field | ruleOut | Правая часть равенства
Public field | type | Тип преобразования

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


ruleIn Field

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)>..::..ruleIn Field
Expression..::..RuleParams<(Of <(<'T>)>)> Class See Also Send Feedback
Левая часть равенства

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public T ruleIn
Visual Basic
Public ruleIn As T
Visual C++
public:
T ruleIn
F#
val mutable ruleIn: 'T

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


ruleOut Field

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)>..::..ruleOut Field
Expression..::..RuleParams<(Of <(<'T>)>)> Class See Also Send Feedback
Правая часть равенства

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public T ruleOut
Visual Basic
Public ruleOut As T
Visual C++
public:
T ruleOut
F#
val mutable ruleOut: 'T

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


type Field

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleParams<(Of <(<'T>)>)>..::..type Field
Expression..::..RuleParams<(Of <(<'T>)>)> Class See Also Send Feedback
Тип преобразования

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Expression..::..RuleType type
Visual Basic
Public type As Expression..::..RuleType
Visual C++
public:
Expression..::..RuleType type
F#
val mutable type: Expression..::..RuleType

See Also

Expression..::..RuleParams<(Of <(<'T>)>)> Class
SMath.Math.Symbolic Namespace


Expression.RuleType Enumeration

[image]

SMath Studio Class Libraries Documantation
Expression..::..RuleType Enumeration
Expression Class See Also Send Feedback
Тип правила преобразования

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public enum RuleType
Visual Basic
Public Enumeration RuleType
Visual C++
public enum class RuleType
F#
type RuleType

Members

Member name | Value | Description
Direct | 0 | Преобразование будет выполнено сразу после упрощения перед выводом ответа пользователю (прямой порядок)
Inverse | 1 | Преобразование будет выполнено до упрощения (обратный порядок)
Both | 2 | Преобразование применимо до (обратный порядок) и после (прямой порядок) упрощения.

See Also

SMath.Math.Symbolic Namespace


IPluginMathSymbolicEvaluation Interface

[image]

SMath Studio Class Libraries Documantation
IPluginMathSymbolicEvaluation Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Symbolic.IPluginMathSymbolicEvaluation"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public interface IPluginMathSymbolicEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
Visual Basic
Public Interface IPluginMathSymbolicEvaluation _
    Inherits IPluginHandleEvaluation, IPlugin, IDisposable
Visual C++
public interface class IPluginMathSymbolicEvaluation : IPluginHandleEvaluation,
    IPlugin, IDisposable
F#
type IPluginMathSymbolicEvaluation =
    interface
        interface IPluginHandleEvaluation
        interface IPlugin
        interface IDisposable
    end

See Also

IPluginMathSymbolicEvaluation Members
SMath.Math.Symbolic Namespace


IPluginMathSymbolicEvaluation Members

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathSymbolicEvaluation Members
IPluginMathSymbolicEvaluation Interface Methods Properties See Also Send Feedback

The IPluginMathSymbolicEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | SymbolicEvaluation | Symbolical calculation of the expression

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginMathSymbolicEvaluation Interface
SMath.Math.Symbolic Namespace


IPluginMathSymbolicEvaluation Methods

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathSymbolicEvaluation Methods
IPluginMathSymbolicEvaluation Interface See Also Send Feedback

The IPluginMathSymbolicEvaluation type exposes the following members.

Methods

 | Name | Description
Public method | Initialize | Fires on plugin initialize (Inherited from IPlugin.)
Public method | SymbolicEvaluation | Symbolical calculation of the expression

See Also

IPluginMathSymbolicEvaluation Interface
SMath.Math.Symbolic Namespace


SymbolicEvaluation Method

[image]

SMath Studio Class Libraries Documantation
IPluginMathSymbolicEvaluation..::..SymbolicEvaluation Method
IPluginMathSymbolicEvaluation Interface See Also Send Feedback
Symbolical calculation of the expression

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
bool SymbolicEvaluation(
    MItem value,
    ref MItem result
)
Visual Basic
Function SymbolicEvaluation ( _
    value As MItem, _
    ByRef result As MItem _
) As Boolean
Visual C++
bool SymbolicEvaluation(
    MItem^ value,
    MItem^% result
)
F#
abstract SymbolicEvaluation :
        value:MItem *
        result:MItem byref -> bool

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Root element to evaluate
result
Type: SMath.Math.Symbolic..::..MItem %
Evaluation result

Return Value

Indicates success of evaluation

See Also

IPluginMathSymbolicEvaluation Interface
SMath.Math.Symbolic Namespace


IPluginMathSymbolicEvaluation Properties

[image] [image]

SMath Studio Class Libraries Documantation
IPluginMathSymbolicEvaluation Properties
IPluginMathSymbolicEvaluation Interface See Also Send Feedback

The IPluginMathSymbolicEvaluation type exposes the following members.

Properties

 | Name | Description
Public property | Dependences | Plugin dependences (Inherited from IPlugin.)
Public property | TermsHandled | List of available terms, that plugin can evaluate (Inherited from IPluginHandleEvaluation.)

See Also

IPluginMathSymbolicEvaluation Interface
SMath.Math.Symbolic Namespace


MItem Class

[image]

SMath Studio Class Libraries Documantation
MItem Class
Members See Also Send Feedback
Математическое выражение

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class MItem
Visual Basic
Public Class MItem
Visual C++
public ref class MItem
F#
type MItem =  class end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..MItem
SMath.Math.Symbolic..::..MMatrix

See Also

MItem Members
SMath.Math.Symbolic Namespace


MItem Members

[image] [image]

SMath Studio Class Libraries Documantation
MItem Members
MItem Class Constructors Methods Operators Fields Properties See Also Send Feedback

The MItem type exposes the following members.

Constructors

 | Name | Description
Public method | MItem(String) | Конструктор математического элемента. Создание операнда. Входная строка может быть десятичным числом или переменной, может быть положительна (без указания знака) или отрицательна (с указанием минуса).
Public method | MItem(MItem) | Конструктор математического элемента. Использует содержимое существующего элемента
Public method | MItem(array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean) | Конструктор математического элемента

Methods

 | Name | Description
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) |
 | Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно.
 | Create(array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно. ВНИМАНИЕ: Все аргументы обязательны!
Public method | Equals | Проверка выражений на идентичность (Overrides Object..::..Equals(Object).)
Public method | FactorEqual | Сравнение элементов без учёта их свойства обратности.
Public method | GetDenumeratorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе)
Public method | GetVariablesList |
Public method | IsNumber | Метод определяющий является ли математический элемент числом или нет
 | ItemsAddRange |
 | ItemsInsertInto | Вставить элемент в список перед элементом с индексом
 | ItemsRemoveAt | Удалить элемент из общего списка
 | ItemsRemoveRange | Удалить указанный диапазон элементов из списка
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится непоэлементно - проверяются значения выражений, а не их идентичность в записи.
 | ToArrayCopy | Копировать элементы коллекции в масиив
Public method | ToNumber | Конвертирование элемента в число
Public method | ToString | Строковое представление математического выражения (Overrides Object..::..ToString()()()().)
Public method | ToTerms |

Operators

Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
ImplicitWideningImplicitImplicitImplicit(Double to MItem) |
Inequality |
Multiply |
Subtraction |
UnaryNegation |

Fields

 | Name | Description
Protected field | brackets |
Protected field | inverse |
Protected field | items |
Protected field | negative |
Protected field | origin |
Protected field | text |
Protected field | type |

Properties

 | Name | Description
Public property | Brackets | Необходимость скобки при записи выражения в виде текста.
Public property | Inverse | Флаг-нидикатор обратного элемента
Public property | Item | Элемент по его порядковому номеру
Public property | Items | Зависимые элементы текущего математического элемента
Public property | Negative | Знак математического элемента.
Public property | Origin | Происхождение математического элемента
Public property | Text | Текстовое представление элемента математического выражения.
Public property | Type | Тип элемента математического выражения.

See Also

MItem Class
SMath.Math.Symbolic Namespace


MItem Constructor

[image] [image]

SMath Studio Class Libraries Documantation
MItem Constructor
MItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MItem(String) | Конструктор математического элемента. Создание операнда. Входная строка может быть десятичным числом или переменной, может быть положительна (без указания знака) или отрицательна (с указанием минуса).
Public method | MItem(MItem) | Конструктор математического элемента. Использует содержимое существующего элемента
Public method | MItem(array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean) | Конструктор математического элемента

See Also

MItem Class
MItem Members
SMath.Math.Symbolic Namespace


MItem Constructor (String)

[image]

SMath Studio Class Libraries Documantation
MItem Constructor (String)
MItem Class See Also Send Feedback
Конструктор математического элемента. Создание операнда. Входная строка может быть десятичным числом или переменной, может быть положительна (без указания знака) или отрицательна (с указанием минуса).

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem(
    string Text
)
Visual Basic
Public Sub New ( _
    Text As String _
)
Visual C++
public:
MItem(
    String^ Text
)
F#
new :
        Text:string -> MItem

Parameters

Text
Type: System..::..String
Входная строка (только операнд)

See Also

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (MItem)

[image]

SMath Studio Class Libraries Documantation
MItem Constructor (MItem)
MItem Class See Also Send Feedback
Конструктор математического элемента. Использует содержимое существующего элемента

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem(
    MItem value
)
Visual Basic
Public Sub New ( _
    value As MItem _
)
Visual C++
public:
MItem(
    MItem^ value
)
F#
new :
        value:MItem -> MItem

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Математический элемент

See Also

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Constructor (MItem[], String, TermType, TermOrigin, Boolean, Boolean)

[image]

SMath Studio Class Libraries Documantation
MItem Constructor (array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean)
MItem Class See Also Send Feedback
Конструктор математического элемента

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem(
    MItem[] items,
    string Text,
    TermType Type,
    TermOrigin Origin,
    bool Negative,
    bool Inverse
)
Visual Basic
Public Sub New ( _
    items As MItem(), _
    Text As String, _
    Type As TermType, _
    Origin As TermOrigin, _
    Negative As Boolean, _
    Inverse As Boolean _
)
Visual C++
public:
MItem(
    array<MItem^>^ items,
    String^ Text,
    TermType Type,
    TermOrigin Origin,
    bool Negative,
    bool Inverse
)
F#
new :
        items:MItem[] *
        Text:string *
        Type:TermType *
        Origin:TermOrigin *
        Negative:bool *
        Inverse:bool -> MItem

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]
Зависимые элементы
Text
Type: System..::..String
Текстовое представление математического элемента
Type
Type: SMath.Manager..::..TermType
Тип математического элемента
Origin
Type: SMath.Manager..::..TermOrigin
Происхождение математического элемента
Negative
Type: System..::..Boolean
Знак математического элемента
Inverse
Type: System..::..Boolean
Флаг-нидикатор обратного элемента

See Also

MItem Class
MItem Overload
SMath.Math.Symbolic Namespace


MItem Fields

[image] [image]

SMath Studio Class Libraries Documantation
MItem Fields
MItem Class See Also Send Feedback

The MItem type exposes the following members.

Fields

 | Name | Description
Protected field | brackets |
Protected field | inverse |
Protected field | items |
Protected field | negative |
Protected field | origin |
Protected field | text |
Protected field | type |

See Also

MItem Class
SMath.Math.Symbolic Namespace


brackets Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..brackets Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.brackets"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected MItemBrackets brackets
Visual Basic
Protected brackets As MItemBrackets
Visual C++
protected:
MItemBrackets brackets
F#
val mutable brackets: MItemBrackets

See Also

MItem Class
SMath.Math.Symbolic Namespace


inverse Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..inverse Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.inverse"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected bool inverse
Visual Basic
Protected inverse As Boolean
Visual C++
protected:
bool inverse
F#
val mutable inverse: bool

See Also

MItem Class
SMath.Math.Symbolic Namespace


items Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..items Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.items"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected MItem[] items
Visual Basic
Protected items As MItem()
Visual C++
protected:
array<MItem^>^ items
F#
val mutable items: MItem[]

See Also

MItem Class
SMath.Math.Symbolic Namespace


negative Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..negative Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.negative"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected bool negative
Visual Basic
Protected negative As Boolean
Visual C++
protected:
bool negative
F#
val mutable negative: bool

See Also

MItem Class
SMath.Math.Symbolic Namespace


origin Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..origin Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.origin"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected TermOrigin origin
Visual Basic
Protected origin As TermOrigin
Visual C++
protected:
TermOrigin origin
F#
val mutable origin: TermOrigin

See Also

MItem Class
SMath.Math.Symbolic Namespace


text Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..text Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.text"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected string text
Visual Basic
Protected text As String
Visual C++
protected:
String^ text
F#
val mutable text: string

See Also

MItem Class
SMath.Math.Symbolic Namespace


type Field

[image]

SMath Studio Class Libraries Documantation
MItem..::..type Field
MItem Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MItem.type"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
protected TermType type
Visual Basic
Protected type As TermType
Visual C++
protected:
TermType type
F#
val mutable type: TermType

See Also

MItem Class
SMath.Math.Symbolic Namespace


MItem Methods

[image] [image]

SMath Studio Class Libraries Documantation
MItem Methods
MItem Class See Also Send Feedback

The MItem type exposes the following members.

Methods

 | Name | Description
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) |
 | Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно.
 | Create(array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно. ВНИМАНИЕ: Все аргументы обязательны!
Public method | Equals | Проверка выражений на идентичность (Overrides Object..::..Equals(Object).)
Public method | FactorEqual | Сравнение элементов без учёта их свойства обратности.
Public method | GetDenumeratorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе)
Public method | GetVariablesList |
Public method | IsNumber | Метод определяющий является ли математический элемент числом или нет
 | ItemsAddRange |
 | ItemsInsertInto | Вставить элемент в список перед элементом с индексом
 | ItemsRemoveAt | Удалить элемент из общего списка
 | ItemsRemoveRange | Удалить указанный диапазон элементов из списка
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится непоэлементно - проверяются значения выражений, а не их идентичность в записи.
 | ToArrayCopy | Копировать элементы коллекции в масиив
Public method | ToNumber | Конвертирование элемента в число
Public method | ToString | Строковое представление математического выражения (Overrides Object..::..ToString()()()().)
Public method | ToTerms |

See Also

MItem Class
SMath.Math.Symbolic Namespace


ContainsVariable Method

[image] [image]

SMath Studio Class Libraries Documantation
MItem..::..ContainsVariable Method
MItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) |

See Also

MItem Class
MItem Members
SMath.Math.Symbolic Namespace


ContainsVariable Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ContainsVariable Method
MItem Class See Also Send Feedback
Определяет, содержит ли выражение любую переменную

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool ContainsVariable()
Visual Basic
Public Function ContainsVariable As Boolean
Visual C++
public:
bool ContainsVariable()
F#
member ContainsVariable : unit -> bool

Return Value

Результат определения

See Also

MItem Class
ContainsVariable Overload
SMath.Math.Symbolic Namespace


ContainsVariable Method (List(MItem))

[image]

SMath Studio Class Libraries Documantation
MItem..::..ContainsVariable Method (List<(Of <(<'MItem>)>)>)
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.ContainsVariable(System.Collections.Generic.List{SMath.Math.Symbolic.MItem})"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool ContainsVariable(
    List<MItem> variables
)
Visual Basic
Public Function ContainsVariable ( _
    variables As List(Of MItem) _
) As Boolean
Visual C++
public:
bool ContainsVariable(
    List<MItem^>^ variables
)
F#
member ContainsVariable :
        variables:List<MItem> -> bool

Parameters

variables
Type: System.Collections.Generic..::..List <(Of <(<' MItem >)>)>

[Missing <param name="variables"/> documentation for "M:SMath.Math.Symbolic.MItem.ContainsVariable(System.Collections.Generic.List{SMath.Math.Symbolic.MItem})"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ContainsVariable(System.Collections.Generic.List{SMath.Math.Symbolic.MItem})"]

See Also

MItem Class
ContainsVariable Overload
SMath.Math.Symbolic Namespace


Create Method

[image] [image]

SMath Studio Class Libraries Documantation
MItem..::..Create Method
MItem Class See Also Send Feedback

Overload List

Name | Description
Create(MItem) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно.
Create(array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean) | Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно. ВНИМАНИЕ: Все аргументы обязательны!

See Also

MItem Class
MItem Members
SMath.Math.Symbolic Namespace


Create Method (MItem)

[image]

SMath Studio Class Libraries Documantation
MItem..::..Create Method (MItem)
MItem Class See Also Send Feedback
Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Create(
    MItem Item
)
Visual Basic
Public Shared Function Create ( _
    Item As MItem _
) As MItem
Visual C++
public:
static MItem^ Create(
    MItem^ Item
)
F#
static member Create :
        Item:MItem -> MItem

Parameters

Item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="Item"/> documentation for "M:SMath.Math.Symbolic.MItem.Create(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.Create(SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
Create Overload
SMath.Math.Symbolic Namespace


Create Method (MItem[], String, TermType, TermOrigin, Boolean, Boolean)

[image]

SMath Studio Class Libraries Documantation
MItem..::..Create Method (array<MItem>[]()[][], String, TermType, TermOrigin, Boolean, Boolean)
MItem Class See Also Send Feedback
Создание математического элемента в зависимости от его наполнения. Создаётся элемент класа-наследника от MItem если это возможно. ВНИМАНИЕ: Все аргументы обязательны!

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem Create(
    MItem[] Items,
    string Text,
    TermType Type,
    TermOrigin Origin,
    bool Negative,
    bool Inverse
)
Visual Basic
Public Shared Function Create ( _
    Items As MItem(), _
    Text As String, _
    Type As TermType, _
    Origin As TermOrigin, _
    Negative As Boolean, _
    Inverse As Boolean _
) As MItem
Visual C++
public:
static MItem^ Create(
    array<MItem^>^ Items,
    String^ Text,
    TermType Type,
    TermOrigin Origin,
    bool Negative,
    bool Inverse
)
F#
static member Create :
        Items:MItem[] *
        Text:string *
        Type:TermType *
        Origin:TermOrigin *
        Negative:bool *
        Inverse:bool -> MItem

Parameters

Items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]
Коллекция зависимых элементов
Text
Type: System..::..String
Текстовое представление математического элемента
Type
Type: SMath.Manager..::..TermType
Тип математического элемента
Origin
Type: SMath.Manager..::..TermOrigin
Происхождение математического элемента
Negative
Type: System..::..Boolean
Знак математического элемента
Inverse
Type: System..::..Boolean
Флаг-нидикатор обратного элемента

Return Value

Экземпляр математического элемента

See Also

MItem Class
Create Overload
SMath.Math.Symbolic Namespace


Equals Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..Equals Method
MItem Class See Also Send Feedback
Проверка выражений на идентичность

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
F#
abstract Equals :
        obj:Object -> bool
override Equals :
        obj:Object -> bool

Parameters

obj
Type: System..::..Object
Выражение для проверки

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.Equals(System.Object)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


FactorEqual Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..FactorEqual Method
MItem Class See Also Send Feedback
Сравнение элементов без учёта их свойства обратности.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool FactorEqual(
    MItem value
)
Visual Basic
Public Function FactorEqual ( _
    value As MItem _
) As Boolean
Visual C++
public:
bool FactorEqual(
    MItem^ value
)
F#
member FactorEqual :
        value:MItem -> bool

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Элемент для проверки на равенство

Return Value

Результат проверки

See Also

MItem Class
SMath.Math.Symbolic Namespace


GetDenumeratorList Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..GetDenumeratorList Method
MItem Class See Also Send Feedback
Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе)

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public List<MItem> GetDenumeratorList()
Visual Basic
Public Function GetDenumeratorList As List(Of MItem)
Visual C++
public:
List<MItem^>^ GetDenumeratorList()
F#
member GetDenumeratorList : unit -> List<MItem>

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.GetDenumeratorList"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


GetHashCode Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..GetHashCode Method
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.GetHashCode"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override
F#
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.GetHashCode"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


GetItemWithOptions Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..GetItemWithOptions Method
MItem Class See Also Send Feedback
Получение математического элемента без учёта его знака и/или обратности

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem GetItemWithOptions(
    bool unSigned,
    bool unInversed
)
Visual Basic
Public Function GetItemWithOptions ( _
    unSigned As Boolean, _
    unInversed As Boolean _
) As MItem
Visual C++
public:
MItem^ GetItemWithOptions(
    bool unSigned,
    bool unInversed
)
F#
member GetItemWithOptions :
        unSigned:bool *
        unInversed:bool -> MItem

Parameters

unSigned
Type: System..::..Boolean
Неучитывать знак
unInversed
Type: System..::..Boolean
Неучитывать обратность

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.GetItemWithOptions(System.Boolean,System.Boolean)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


GetNumeratorList Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..GetNumeratorList Method
MItem Class See Also Send Feedback
Получить все элементы положительной степени (элементы, находящиеся в числителе)

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public List<MItem> GetNumeratorList()
Visual Basic
Public Function GetNumeratorList As List(Of MItem)
Visual C++
public:
List<MItem^>^ GetNumeratorList()
F#
member GetNumeratorList : unit -> List<MItem>

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.GetNumeratorList"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


GetVariablesList Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..GetVariablesList Method
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.GetVariablesList(System.Collections.Generic.List{SMath.Math.Symbolic.MItem}@)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public void GetVariablesList(
    ref List<MItem> variables
)
Visual Basic
Public Sub GetVariablesList ( _
    ByRef variables As List(Of MItem) _
)
Visual C++
public:
void GetVariablesList(
    List<MItem^>^% variables
)
F#
member GetVariablesList :
        variables:List<MItem> byref -> unit

Parameters

variables
Type: System.Collections.Generic..::..List <(Of <(<' MItem >)>)>%

[Missing <param name="variables"/> documentation for "M:SMath.Math.Symbolic.MItem.GetVariablesList(System.Collections.Generic.List{SMath.Math.Symbolic.MItem}@)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


IsNumber Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..IsNumber Method
MItem Class See Also Send Feedback
Метод определяющий является ли математический элемент числом или нет

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool IsNumber()
Visual Basic
Public Function IsNumber As Boolean
Visual C++
public:
bool IsNumber()
F#
member IsNumber : unit -> bool

Return Value

Результат определения

See Also

MItem Class
SMath.Math.Symbolic Namespace


ItemsAddRange Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ItemsAddRange Method
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.ItemsAddRange(SMath.Math.Symbolic.MItem[],SMath.Math.Symbolic.MItem[])"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem[] ItemsAddRange(
    MItem[] c1,
    MItem[] c2
)
Visual Basic
Public Shared Function ItemsAddRange ( _
    c1 As MItem(), _
    c2 As MItem() _
) As MItem()
Visual C++
public:
static array<MItem^>^ ItemsAddRange(
    array<MItem^>^ c1,
    array<MItem^>^ c2
)
F#
static member ItemsAddRange :
        c1:MItem[] *
        c2:MItem[] -> MItem[]

Parameters

c1
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsAddRange(SMath.Math.Symbolic.MItem[],SMath.Math.Symbolic.MItem[])"]

c2
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsAddRange(SMath.Math.Symbolic.MItem[],SMath.Math.Symbolic.MItem[])"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ItemsAddRange(SMath.Math.Symbolic.MItem[],SMath.Math.Symbolic.MItem[])"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


ItemsInsertInto Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ItemsInsertInto Method
MItem Class See Also Send Feedback
Вставить элемент в список перед элементом с индексом

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem[] ItemsInsertInto(
    MItem[] items,
    int index,
    MItem item
)
Visual Basic
Public Shared Function ItemsInsertInto ( _
    items As MItem(), _
    index As Integer, _
    item As MItem _
) As MItem()
Visual C++
public:
static array<MItem^>^ ItemsInsertInto(
    array<MItem^>^ items,
    int index,
    MItem^ item
)
F#
static member ItemsInsertInto :
        items:MItem[] *
        index:int *
        item:MItem -> MItem[]

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsInsertInto(SMath.Math.Symbolic.MItem[],System.Int32,SMath.Math.Symbolic.MItem)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsInsertInto(SMath.Math.Symbolic.MItem[],System.Int32,SMath.Math.Symbolic.MItem)"]

item
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="item"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsInsertInto(SMath.Math.Symbolic.MItem[],System.Int32,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ItemsInsertInto(SMath.Math.Symbolic.MItem[],System.Int32,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


ItemsRemoveAt Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ItemsRemoveAt Method
MItem Class See Also Send Feedback
Удалить элемент из общего списка

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem[] ItemsRemoveAt(
    MItem[] items,
    int index
)
Visual Basic
Public Shared Function ItemsRemoveAt ( _
    items As MItem(), _
    index As Integer _
) As MItem()
Visual C++
public:
static array<MItem^>^ ItemsRemoveAt(
    array<MItem^>^ items,
    int index
)
F#
static member ItemsRemoveAt :
        items:MItem[] *
        index:int -> MItem[]

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveAt(SMath.Math.Symbolic.MItem[],System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveAt(SMath.Math.Symbolic.MItem[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveAt(SMath.Math.Symbolic.MItem[],System.Int32)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


ItemsRemoveRange Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ItemsRemoveRange Method
MItem Class See Also Send Feedback
Удалить указанный диапазон элементов из списка

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem[] ItemsRemoveRange(
    MItem[] items,
    int index,
    int noCount
)
Visual Basic
Public Shared Function ItemsRemoveRange ( _
    items As MItem(), _
    index As Integer, _
    noCount As Integer _
) As MItem()
Visual C++
public:
static array<MItem^>^ ItemsRemoveRange(
    array<MItem^>^ items,
    int index,
    int noCount
)
F#
static member ItemsRemoveRange :
        items:MItem[] *
        index:int *
        noCount:int -> MItem[]

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveRange(SMath.Math.Symbolic.MItem[],System.Int32,System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveRange(SMath.Math.Symbolic.MItem[],System.Int32,System.Int32)"]

noCount
Type: System..::..Int32

[Missing <param name="noCount"/> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveRange(SMath.Math.Symbolic.MItem[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ItemsRemoveRange(SMath.Math.Symbolic.MItem[],System.Int32,System.Int32)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


MathEqual Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..MathEqual Method
MItem Class See Also Send Feedback
Проверка математических выражений на равенство. Проверка производится непоэлементно - проверяются значения выражений, а не их идентичность в записи.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool MathEqual(
    MItem value
)
Visual Basic
Public Function MathEqual ( _
    value As MItem _
) As Boolean
Visual C++
public:
bool MathEqual(
    MItem^ value
)
F#
member MathEqual :
        value:MItem -> bool

Parameters

value
Type: SMath.Math.Symbolic..::..MItem
Выражение для проверки

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.MathEqual(SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


ToArrayCopy Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ToArrayCopy Method
MItem Class See Also Send Feedback
Копировать элементы коллекции в масиив

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem[] ToArrayCopy(
    List<MItem> c1
)
Visual Basic
Public Shared Function ToArrayCopy ( _
    c1 As List(Of MItem) _
) As MItem()
Visual C++
public:
static array<MItem^>^ ToArrayCopy(
    List<MItem^>^ c1
)
F#
static member ToArrayCopy :
        c1:List<MItem> -> MItem[]

Parameters

c1
Type: System.Collections.Generic..::..List <(Of <(<' MItem >)>)>

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.ToArrayCopy(System.Collections.Generic.List{SMath.Math.Symbolic.MItem})"]

Return Value

Результат копирования

See Also

MItem Class
SMath.Math.Symbolic Namespace


ToNumber Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ToNumber Method
MItem Class See Also Send Feedback
Конвертирование элемента в число

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public double ToNumber()
Visual Basic
Public Function ToNumber As Double
Visual C++
public:
double ToNumber()
F#
member ToNumber : unit -> float

Return Value

Число - результат конвертирования

See Also

MItem Class
SMath.Math.Symbolic Namespace


ToString Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ToString Method
MItem Class See Also Send Feedback
Строковое представление математического выражения

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override
F#
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Выражение, записанное в строку

See Also

MItem Class
SMath.Math.Symbolic Namespace


ToTerms Method

[image]

SMath Studio Class Libraries Documantation
MItem..::..ToTerms Method
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.ToTerms"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public Term[] ToTerms()
Visual Basic
Public Function ToTerms As Term()
Visual C++
public:
array<Term^>^ ToTerms()
F#
member ToTerms : unit -> Term[]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.ToTerms"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


MItem Operators and Type Conversions

[image] [image]

SMath Studio Class Libraries Documantation
MItem Operators and Type Conversions
MItem Class See Also Send Feedback

The MItem type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
ExclusiveOr |
ImplicitWideningImplicitImplicitImplicit(Double to MItem) |
Inequality |
Multiply |
Subtraction |
UnaryNegation |

See Also

MItem Class
SMath.Math.Symbolic Namespace


Addition Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Addition Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator +(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator +(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (+)
        c1:MItem *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Division Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Division Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Division(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator /(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator / ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator /(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (/)
        c1:MItem *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Division(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Division(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Division(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Equality Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Equality Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Equality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static bool operator ==(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As MItem, _
    c2 As MItem _
) As Boolean
Visual C++
public:
static bool operator ==(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (=)
        c1:MItem *
        c2:MItem  : bool

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Equality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Equality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Equality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


ExclusiveOr Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..ExclusiveOr Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_ExclusiveOr(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator ^(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator Xor ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator ^(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (^^^)
        c1:MItem *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_ExclusiveOr(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_ExclusiveOr(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_ExclusiveOr(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Implicit Conversion (Double to MItem)

[image]

SMath Studio Class Libraries Documantation
MItem ImplicitWideningImplicitImplicitImplicit Conversion (Double to MItem)
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Implicit(System.Double)~SMath.Math.Symbolic.MItem"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static implicit operator MItem (
    double value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As Double _
) As MItem
Visual C++
static implicit operator MItem^ (
    double value
)
F#
F# does not support the declaration of new casting operators.

Parameters

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Implicit(System.Double)~SMath.Math.Symbolic.MItem"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Implicit(System.Double)~SMath.Math.Symbolic.MItem"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Inequality Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Inequality Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Inequality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static bool operator !=(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As MItem, _
    c2 As MItem _
) As Boolean
Visual C++
public:
static bool operator !=(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (<>)
        c1:MItem *
        c2:MItem  : bool

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Inequality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Inequality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Inequality(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Multiply Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Multiply Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator *(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator * ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator *(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (*)
        c1:MItem *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


Subtraction Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..Subtraction Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_Subtraction(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator -(
    MItem c1,
    MItem c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As MItem, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator -(
    MItem^ c1,
    MItem^ c2
)
F#
static let inline (-)
        c1:MItem *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Subtraction(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MItem.op_Subtraction(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_Subtraction(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


UnaryNegation Operator

[image]

SMath Studio Class Libraries Documantation
MItem..::..UnaryNegation Operator
MItem Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MItem.op_UnaryNegation(SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator -(
    MItem c1
)
Visual Basic
Public Shared Operator - ( _
    c1 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator -(
    MItem^ c1
)
F#
static let inline (-)
        c1:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MItem.op_UnaryNegation(SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MItem.op_UnaryNegation(SMath.Math.Symbolic.MItem)"]

See Also

MItem Class
SMath.Math.Symbolic Namespace


MItem Properties

[image] [image]

SMath Studio Class Libraries Documantation
MItem Properties
MItem Class See Also Send Feedback

The MItem type exposes the following members.

Properties

 | Name | Description
Public property | Brackets | Необходимость скобки при записи выражения в виде текста.
Public property | Inverse | Флаг-нидикатор обратного элемента
Public property | Item | Элемент по его порядковому номеру
Public property | Items | Зависимые элементы текущего математического элемента
Public property | Negative | Знак математического элемента.
Public property | Origin | Происхождение математического элемента
Public property | Text | Текстовое представление элемента математического выражения.
Public property | Type | Тип элемента математического выражения.

See Also

MItem Class
SMath.Math.Symbolic Namespace


Brackets Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Brackets Property
MItem Class See Also Send Feedback
Необходимость скобки при записи выражения в виде текста.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItemBrackets Brackets { get; set; }
Visual Basic
Public Property Brackets As MItemBrackets
    Get
    Set
Visual C++
public:
property MItemBrackets Brackets {
    MItemBrackets get ();
    void set (MItemBrackets value);
}
F#
member Brackets : MItemBrackets with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Inverse Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Inverse Property
MItem Class See Also Send Feedback
Флаг-нидикатор обратного элемента

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool Inverse { get; set; }
Visual Basic
Public Property Inverse As Boolean
    Get
    Set
Visual C++
public:
property bool Inverse {
    bool get ();
    void set (bool value);
}
F#
member Inverse : bool with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Item Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Item Property
MItem Class See Also Send Feedback
Элемент по его порядковому номеру

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem this[
    int Index
] { get; set; }
Visual Basic
Public Property Item ( _
    Index As Integer _
) As MItem
    Get
    Set
Visual C++
public:
property MItem^ Item[int Index] {
    MItem^ get (int Index);
    void set (int Index, MItem^ value);
}
F#
member Item : MItem with get, set

Parameters

Index
Type: System..::..Int32
Порядковый номер элемента

Return Value

See Also

MItem Class
SMath.Math.Symbolic Namespace


Items Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Items Property
MItem Class See Also Send Feedback
Зависимые элементы текущего математического элемента

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem[] Items { get; set; }
Visual Basic
Public Property Items As MItem()
    Get
    Set
Visual C++
public:
property array<MItem^>^ Items {
    array<MItem^>^ get ();
    void set (array<MItem^>^ value);
}
F#
member Items : MItem[] with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Negative Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Negative Property
MItem Class See Also Send Feedback
Знак математического элемента.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool Negative { get; set; }
Visual Basic
Public Property Negative As Boolean
    Get
    Set
Visual C++
public:
property bool Negative {
    bool get ();
    void set (bool value);
}
F#
member Negative : bool with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Origin Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Origin Property
MItem Class See Also Send Feedback
Происхождение математического элемента

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public TermOrigin Origin { get; set; }
Visual Basic
Public Property Origin As TermOrigin
    Get
    Set
Visual C++
public:
property TermOrigin Origin {
    TermOrigin get ();
    void set (TermOrigin value);
}
F#
member Origin : TermOrigin with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Text Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Text Property
MItem Class See Also Send Feedback
Текстовое представление элемента математического выражения.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
F#
member Text : string with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


Type Property

[image]

SMath Studio Class Libraries Documantation
MItem..::..Type Property
MItem Class See Also Send Feedback
Тип элемента математического выражения.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public TermType Type { get; set; }
Visual Basic
Public Property Type As TermType
    Get
    Set
Visual C++
public:
property TermType Type {
    TermType get ();
    void set (TermType value);
}
F#
member Type : TermType with get, set

See Also

MItem Class
SMath.Math.Symbolic Namespace


MItemBrackets Enumeration

[image]

SMath Studio Class Libraries Documantation
MItemBrackets Enumeration
See Also Send Feedback
Представление математической скобки

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public enum MItemBrackets
Visual Basic
Public Enumeration MItemBrackets
Visual C++
public enum class MItemBrackets
F#
type MItemBrackets

Members

Member name | Value | Description
None | 0 | Нет математической скобки
Invisible | 1 | Невидимая математическая скобка
Visible | 2 | Видимая круглая математическая скобка

See Also

SMath.Math.Symbolic Namespace


MMatrix Class

[image]

SMath Studio Class Libraries Documantation
MMatrix Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:SMath.Math.Symbolic.MMatrix"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public class MMatrix : MItem
Visual Basic
Public Class MMatrix _
    Inherits MItem
Visual C++
public ref class MMatrix : public MItem
F#
type MMatrix =
    class
        inherit MItem
    end

Inheritance Hierarchy

System..::..Object
SMath.Math.Symbolic..::..MItem
SMath.Math.Symbolic..::..MMatrix

See Also

MMatrix Members
SMath.Math.Symbolic Namespace


MMatrix Members

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Members
MMatrix Class Constructors Methods Operators Fields Properties See Also Send Feedback

The MMatrix type exposes the following members.

Constructors

 | Name | Description
Public method | MMatrix(MItem) |
Public method | MMatrix(array<MItem>[]()[][], Boolean, Boolean) |
Public method | MMatrix(Boolean, Boolean, Int32, Int32) |

Methods

 | Name | Description
Public method | Alg | Алгебраическое дополнение матрицы
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную (Inherited from MItem.)
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) | (Inherited from MItem.)
Public method | Determinant | Детерминант (определитель) матрицы
Public method | Equals | Проверка выражений на идентичность (Inherited from MItem.)
Public method | FactorEqual | Сравнение элементов без учёта их свойства обратности. (Inherited from MItem.)
Public method | GetDenumeratorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе) (Inherited from MItem.)
Public method | GetHashCode | (Inherited from MItem.)
Public method | GetInverse | Обращение матрицы общего вида
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности (Inherited from MItem.)
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе) (Inherited from MItem.)
Public method | GetVariablesList | (Inherited from MItem.)
Public method | IsNumber | Метод определяющий является ли математический элемент числом или нет (Inherited from MItem.)
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится непоэлементно - проверяются значения выражений, а не их идентичность в записи. (Inherited from MItem.)
Public method | Minor | Минор матрицы
Public method | Rank | Ранг матрицы
Public method | rmatrixlu |
Public method | rmatrixluinverse | Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.
Public method | rmatrixtrinverse |
Public method | ToNumber | Конвертирование элемента в число (Inherited from MItem.)
Public method | ToString | Строковое представление математического выражения (Inherited from MItem.)
Public method | ToTerms | (Inherited from MItem.)
Public method | Trace | След матрицы
Public method | Transpose | Транспонирование матрицы
Public method | VMinor | Невычисленный минор матрицы (определитель)
Public method | VMultiplication |

Operators

Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |
ExclusiveOr |
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |

Fields

 | Name | Description
Protected field | brackets | (Inherited from MItem.)
Protected field | inverse | (Inherited from MItem.)
Protected field | items | (Inherited from MItem.)
 | lunb |
Protected field | negative | (Inherited from MItem.)
Protected field | origin | (Inherited from MItem.)
Protected field | text | (Inherited from MItem.)
Protected field | type | (Inherited from MItem.)

Properties

 | Name | Description
Public property | Brackets | Необходимость скобки при записи выражения в виде текста. (Inherited from MItem.)
Public property | Cols | Количество столбцов в матрице
Public property | Inverse | Флаг-нидикатор обратного элемента (Inherited from MItem.)
Public property | Item[([( Int32])]) | Элемент по его порядковому номеру (Inherited from MItem.)
Public property | Item[([( Int32, Int32])]) | Элемент матрицы, заданный по строке и столбцу
Public property | Items | Зависимые элементы текущего математического элемента (Inherited from MItem.)
Public property | Negative | Знак математического элемента. (Inherited from MItem.)
Public property | Origin | Происхождение математического элемента (Inherited from MItem.)
Public property | Rows | Количество строк в матрице
Public property | Text | Текстовое представление элемента математического выражения. (Inherited from MItem.)
Public property | Type | Тип элемента математического выражения. (Inherited from MItem.)

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Constructor

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Constructor
MMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MMatrix(MItem) | Initializes a new instance of the MMatrix class
Public method | MMatrix(array<MItem>[]()[][], Boolean, Boolean) | Initializes a new instance of the MMatrix class
Public method | MMatrix(Boolean, Boolean, Int32, Int32) | Initializes a new instance of the MMatrix class

See Also

MMatrix Class
MMatrix Members
SMath.Math.Symbolic Namespace


MMatrix Constructor (MItem)

[image]

SMath Studio Class Libraries Documantation
MMatrix Constructor (MItem)
MMatrix Class See Also Send Feedback
Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix(
    MItem value
)
Visual Basic
Public Sub New ( _
    value As MItem _
)
Visual C++
public:
MMatrix(
    MItem^ value
)
F#
new :
        value:MItem -> MMatrix

Parameters

value
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(SMath.Math.Symbolic.MItem)"]

See Also

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Constructor (MItem[], Boolean, Boolean)

[image]

SMath Studio Class Libraries Documantation
MMatrix Constructor (array<MItem>[]()[][], Boolean, Boolean)
MMatrix Class See Also Send Feedback
Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix(
    MItem[] items,
    bool negative,
    bool inverse
)
Visual Basic
Public Sub New ( _
    items As MItem(), _
    negative As Boolean, _
    inverse As Boolean _
)
Visual C++
public:
MMatrix(
    array<MItem^>^ items,
    bool negative,
    bool inverse
)
F#
new :
        items:MItem[] *
        negative:bool *
        inverse:bool -> MMatrix

Parameters

items
Type: array< SMath.Math.Symbolic..::..MItem >[]()[][]

[Missing <param name="items"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(SMath.Math.Symbolic.MItem[],System.Boolean,System.Boolean)"]

negative
Type: System..::..Boolean

[Missing <param name="negative"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(SMath.Math.Symbolic.MItem[],System.Boolean,System.Boolean)"]

inverse
Type: System..::..Boolean

[Missing <param name="inverse"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(SMath.Math.Symbolic.MItem[],System.Boolean,System.Boolean)"]

See Also

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Constructor (Boolean, Boolean, Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
MMatrix Constructor (Boolean, Boolean, Int32, Int32)
MMatrix Class See Also Send Feedback
Initializes a new instance of the MMatrix class

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix(
    bool negative,
    bool inverse,
    int rows,
    int cols
)
Visual Basic
Public Sub New ( _
    negative As Boolean, _
    inverse As Boolean, _
    rows As Integer, _
    cols As Integer _
)
Visual C++
public:
MMatrix(
    bool negative,
    bool inverse,
    int rows,
    int cols
)
F#
new :
        negative:bool *
        inverse:bool *
        rows:int *
        cols:int -> MMatrix

Parameters

negative
Type: System..::..Boolean

[Missing <param name="negative"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(System.Boolean,System.Boolean,System.Int32,System.Int32)"]

inverse
Type: System..::..Boolean

[Missing <param name="inverse"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(System.Boolean,System.Boolean,System.Int32,System.Int32)"]

rows
Type: System..::..Int32

[Missing <param name="rows"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(System.Boolean,System.Boolean,System.Int32,System.Int32)"]

cols
Type: System..::..Int32

[Missing <param name="cols"/> documentation for "M:SMath.Math.Symbolic.MMatrix.#ctor(System.Boolean,System.Boolean,System.Int32,System.Int32)"]

See Also

MMatrix Class
MMatrix Overload
SMath.Math.Symbolic Namespace


MMatrix Fields

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Fields
MMatrix Class See Also Send Feedback

The MMatrix type exposes the following members.

Fields

 | Name | Description
Protected field | brackets | (Inherited from MItem.)
Protected field | inverse | (Inherited from MItem.)
Protected field | items | (Inherited from MItem.)
 | lunb |
Protected field | negative | (Inherited from MItem.)
Protected field | origin | (Inherited from MItem.)
Protected field | text | (Inherited from MItem.)
Protected field | type | (Inherited from MItem.)

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


lunb Field

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..lunb Field
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "F:SMath.Math.Symbolic.MMatrix.lunb"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public const int lunb
Visual Basic
Public Const lunb As Integer
Visual C++
public:
literal int lunb
F#
static val mutable lunb: int

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Methods

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Methods
MMatrix Class See Also Send Feedback

The MMatrix type exposes the following members.

Methods

 | Name | Description
Public method | Alg | Алгебраическое дополнение матрицы
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную (Inherited from MItem.)
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) | (Inherited from MItem.)
Public method | Determinant | Детерминант (определитель) матрицы
Public method | Equals | Проверка выражений на идентичность (Inherited from MItem.)
Public method | FactorEqual | Сравнение элементов без учёта их свойства обратности. (Inherited from MItem.)
Public method | GetDenumeratorList | Получить все элементы отрицательной степени (элементы, находящиеся в знаменателе) (Inherited from MItem.)
Public method | GetHashCode | (Inherited from MItem.)
Public method | GetInverse | Обращение матрицы общего вида
Public method | GetItemWithOptions | Получение математического элемента без учёта его знака и/или обратности (Inherited from MItem.)
Public method | GetNumeratorList | Получить все элементы положительной степени (элементы, находящиеся в числителе) (Inherited from MItem.)
Public method | GetVariablesList | (Inherited from MItem.)
Public method | IsNumber | Метод определяющий является ли математический элемент числом или нет (Inherited from MItem.)
Public method | MathEqual | Проверка математических выражений на равенство. Проверка производится непоэлементно - проверяются значения выражений, а не их идентичность в записи. (Inherited from MItem.)
Public method | Minor | Минор матрицы
Public method | Rank | Ранг матрицы
Public method | rmatrixlu |
Public method | rmatrixluinverse | Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.
Public method | rmatrixtrinverse |
Public method | ToNumber | Конвертирование элемента в число (Inherited from MItem.)
Public method | ToString | Строковое представление математического выражения (Inherited from MItem.)
Public method | ToTerms | (Inherited from MItem.)
Public method | Trace | След матрицы
Public method | Transpose | Транспонирование матрицы
Public method | VMinor | Невычисленный минор матрицы (определитель)
Public method | VMultiplication |

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Alg Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Alg Method
MMatrix Class See Also Send Feedback
Алгебраическое дополнение матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem Alg(
    int row,
    int col
)
Visual Basic
Public Function Alg ( _
    row As Integer, _
    col As Integer _
) As MItem
Visual C++
public:
MItem^ Alg(
    int row,
    int col
)
F#
member Alg :
        row:int *
        col:int -> MItem

Parameters

row
Type: System..::..Int32
Номер строки
col
Type: System..::..Int32
Номер столбца

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.Alg(System.Int32,System.Int32)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


ContainsVariable Method

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix..::..ContainsVariable Method
MMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContainsVariable()()()() | Определяет, содержит ли выражение любую переменную (Inherited from MItem.)
Public method | ContainsVariable(List<(Of <<'(MItem>)>>)) | (Inherited from MItem.)

See Also

MMatrix Class
MMatrix Members
SMath.Math.Symbolic Namespace


Determinant Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Determinant Method
MMatrix Class See Also Send Feedback
Детерминант (определитель) матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem Determinant()
Visual Basic
Public Function Determinant As MItem
Visual C++
public:
MItem^ Determinant()
F#
member Determinant : unit -> MItem

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.Determinant"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


GetInverse Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..GetInverse Method
MMatrix Class See Also Send Feedback
Обращение матрицы общего вида

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix GetInverse()
Visual Basic
Public Function GetInverse As MMatrix
Visual C++
public:
MMatrix^ GetInverse()
F#
member GetInverse : unit -> MMatrix

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.GetInverse"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Minor Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Minor Method
MMatrix Class See Also Send Feedback
Минор матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem Minor(
    int row,
    int col
)
Visual Basic
Public Function Minor ( _
    row As Integer, _
    col As Integer _
) As MItem
Visual C++
public:
MItem^ Minor(
    int row,
    int col
)
F#
member Minor :
        row:int *
        col:int -> MItem

Parameters

row
Type: System..::..Int32
Номер строки
col
Type: System..::..Int32
Номер столбца

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.Minor(System.Int32,System.Int32)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Rank Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Rank Method
MMatrix Class See Also Send Feedback
Ранг матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem Rank()
Visual Basic
Public Function Rank As MItem
Visual C++
public:
MItem^ Rank()
F#
member Rank : unit -> MItem

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.Rank"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


rmatrixlu Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..rmatrixlu Method
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixlu(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Int32,System.Int32[]@)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public void rmatrixlu(
    ref MMatrix a,
    int m,
    int n,
    ref int[] pivots
)
Visual Basic
Public Sub rmatrixlu ( _
    ByRef a As MMatrix, _
    m As Integer, _
    n As Integer, _
    ByRef pivots As Integer() _
)
Visual C++
public:
void rmatrixlu(
    MMatrix^% a,
    int m,
    int n,
    array<int>^% pivots
)
F#
member rmatrixlu :
        a:MMatrix byref *
        m:int *
        n:int *
        pivots:int[] byref -> unit

Parameters

a
Type: SMath.Math.Symbolic..::..MMatrix %

[Missing <param name="a"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixlu(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Int32,System.Int32[]@)"]

m
Type: System..::..Int32

[Missing <param name="m"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixlu(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Int32,System.Int32[]@)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixlu(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Int32,System.Int32[]@)"]

pivots
Type: array< System..::..Int32 >[]()[][]%

[Missing <param name="pivots"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixlu(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Int32,System.Int32[]@)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


rmatrixluinverse Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..rmatrixluinverse Method
MMatrix Class See Also Send Feedback
Входные параметры: A - LU-разложение матрицы (результат работы подпрограммы RMatrixLU). Pivots - таблица перестановок, произведенных в ходе LU-разложения. (результат работы подпрограммы RMatrixLU). N - размерность матрицы Выходные параметры: A - матрица, обратная к исходной. Массив с нумерацией элементов [0..N-1, 0..N-1] Результат: True, если исходная матрица невырожденная. False, если исходная матрица вырожденная.

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool rmatrixluinverse(
    ref MMatrix a,
    ref int[] pivots,
    int n
)
Visual Basic
Public Function rmatrixluinverse ( _
    ByRef a As MMatrix, _
    ByRef pivots As Integer(), _
    n As Integer _
) As Boolean
Visual C++
public:
bool rmatrixluinverse(
    MMatrix^% a,
    array<int>^% pivots,
    int n
)
F#
member rmatrixluinverse :
        a:MMatrix byref *
        pivots:int[] byref *
        n:int -> bool

Parameters

a
Type: SMath.Math.Symbolic..::..MMatrix %

[Missing <param name="a"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixluinverse(SMath.Math.Symbolic.MMatrix@,System.Int32[]@,System.Int32)"]

pivots
Type: array< System..::..Int32 >[]()[][]%

[Missing <param name="pivots"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixluinverse(SMath.Math.Symbolic.MMatrix@,System.Int32[]@,System.Int32)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixluinverse(SMath.Math.Symbolic.MMatrix@,System.Int32[]@,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixluinverse(SMath.Math.Symbolic.MMatrix@,System.Int32[]@,System.Int32)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


rmatrixtrinverse Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..rmatrixtrinverse Method
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public bool rmatrixtrinverse(
    ref MMatrix a,
    int n,
    bool isupper,
    bool isunittriangular
)
Visual Basic
Public Function rmatrixtrinverse ( _
    ByRef a As MMatrix, _
    n As Integer, _
    isupper As Boolean, _
    isunittriangular As Boolean _
) As Boolean
Visual C++
public:
bool rmatrixtrinverse(
    MMatrix^% a,
    int n,
    bool isupper,
    bool isunittriangular
)
F#
member rmatrixtrinverse :
        a:MMatrix byref *
        n:int *
        isupper:bool *
        isunittriangular:bool -> bool

Parameters

a
Type: SMath.Math.Symbolic..::..MMatrix %

[Missing <param name="a"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

isupper
Type: System..::..Boolean

[Missing <param name="isupper"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

isunittriangular
Type: System..::..Boolean

[Missing <param name="isunittriangular"/> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.rmatrixtrinverse(SMath.Math.Symbolic.MMatrix@,System.Int32,System.Boolean,System.Boolean)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Trace Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Trace Method
MMatrix Class See Also Send Feedback
След матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem Trace()
Visual Basic
Public Function Trace As MItem
Visual C++
public:
MItem^ Trace()
F#
member Trace : unit -> MItem

Return Value

След матрицы

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Transpose Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Transpose Method
MMatrix Class See Also Send Feedback
Транспонирование матрицы

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix Transpose()
Visual Basic
Public Function Transpose As MMatrix
Visual C++
public:
MMatrix^ Transpose()
F#
member Transpose : unit -> MMatrix

Return Value

Транспонированная матрица

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


VMinor Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..VMinor Method
MMatrix Class See Also Send Feedback
Невычисленный минор матрицы (определитель)

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix VMinor(
    int row,
    int col
)
Visual Basic
Public Function VMinor ( _
    row As Integer, _
    col As Integer _
) As MMatrix
Visual C++
public:
MMatrix^ VMinor(
    int row,
    int col
)
F#
member VMinor :
        row:int *
        col:int -> MMatrix

Parameters

row
Type: System..::..Int32
Номер строки
col
Type: System..::..Int32
Номер столбца

Return Value

Определитель

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


VMultiplication Method

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..VMultiplication Method
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.VMultiplication(SMath.Math.Symbolic.MMatrix)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MMatrix VMultiplication(
    MMatrix value
)
Visual Basic
Public Function VMultiplication ( _
    value As MMatrix _
) As MMatrix
Visual C++
public:
MMatrix^ VMultiplication(
    MMatrix^ value
)
F#
member VMultiplication :
        value:MMatrix -> MMatrix

Parameters

value
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="value"/> documentation for "M:SMath.Math.Symbolic.MMatrix.VMultiplication(SMath.Math.Symbolic.MMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.VMultiplication(SMath.Math.Symbolic.MMatrix)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


MMatrix Operators

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Operators
MMatrix Class See Also Send Feedback

The MMatrix type exposes the following members.

Operators

Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |
ExclusiveOr |
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Addition Operator

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix..::..Addition Operator
MMatrix Class See Also Send Feedback

Overload List

Name | Description
Addition(MItem, MMatrix) |
Addition(MMatrix, MItem) |
Addition(MMatrix, MMatrix) |

See Also

MMatrix Class
MMatrix Members
SMath.Math.Symbolic Namespace


Addition Operator (MItem, MMatrix)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Addition Operator (MItem, MMatrix)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator +(
    MItem c1,
    MMatrix c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As MItem, _
    c2 As MMatrix _
) As MItem
Visual C++
public:
static MItem^ operator +(
    MItem^ c1,
    MMatrix^ c2
)
F#
static let inline (+)
        c1:MItem *
        c2:MMatrix  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

c2
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

See Also

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


Addition Operator (MMatrix, MItem)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Addition Operator (MMatrix, MItem)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator +(
    MMatrix c1,
    MItem c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As MMatrix, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator +(
    MMatrix^ c1,
    MItem^ c2
)
F#
static let inline (+)
        c1:MMatrix *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

See Also

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


Addition Operator (MMatrix, MMatrix)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Addition Operator (MMatrix, MMatrix)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator +(
    MMatrix c1,
    MMatrix c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As MMatrix, _
    c2 As MMatrix _
) As MItem
Visual C++
public:
static MItem^ operator +(
    MMatrix^ c1,
    MMatrix^ c2
)
F#
static let inline (+)
        c1:MMatrix *
        c2:MMatrix  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

c2
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Addition(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

See Also

MMatrix Class
Addition Overload
SMath.Math.Symbolic Namespace


ExclusiveOr Operator

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..ExclusiveOr Operator
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_ExclusiveOr(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator ^(
    MMatrix c1,
    MItem c2
)
Visual Basic
Public Shared Operator Xor ( _
    c1 As MMatrix, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator ^(
    MMatrix^ c1,
    MItem^ c2
)
F#
static let inline (^^^)
        c1:MMatrix *
        c2:MItem  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_ExclusiveOr(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_ExclusiveOr(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_ExclusiveOr(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Multiply Operator

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix..::..Multiply Operator
MMatrix Class See Also Send Feedback

Overload List

Name | Description
Multiply(MItem, MMatrix) |
Multiply(MMatrix, MItem) |
Multiply(MMatrix, MMatrix) |

See Also

MMatrix Class
MMatrix Members
SMath.Math.Symbolic Namespace


Multiply Operator (MItem, MMatrix)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Multiply Operator (MItem, MMatrix)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator *(
    MItem c1,
    MMatrix c22
)
Visual Basic
Public Shared Operator * ( _
    c1 As MItem, _
    c22 As MMatrix _
) As MItem
Visual C++
public:
static MItem^ operator *(
    MItem^ c1,
    MMatrix^ c22
)
F#
static let inline (*)
        c1:MItem *
        c22:MMatrix  : MItem

Parameters

c1
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c1"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

c22
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c22"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MItem,SMath.Math.Symbolic.MMatrix)"]

See Also

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


Multiply Operator (MMatrix, MItem)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Multiply Operator (MMatrix, MItem)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator *(
    MMatrix c11,
    MItem c2
)
Visual Basic
Public Shared Operator * ( _
    c11 As MMatrix, _
    c2 As MItem _
) As MItem
Visual C++
public:
static MItem^ operator *(
    MMatrix^ c11,
    MItem^ c2
)
F#
static let inline (*)
        c11:MMatrix *
        c2:MItem  : MItem

Parameters

c11
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c11"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

c2
Type: SMath.Math.Symbolic..::..MItem

[Missing <param name="c2"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MItem)"]

See Also

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


Multiply Operator (MMatrix, MMatrix)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Multiply Operator (MMatrix, MMatrix)
MMatrix Class See Also Send Feedback

[Missing <summary> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public static MItem operator *(
    MMatrix c11,
    MMatrix c22
)
Visual Basic
Public Shared Operator * ( _
    c11 As MMatrix, _
    c22 As MMatrix _
) As MItem
Visual C++
public:
static MItem^ operator *(
    MMatrix^ c11,
    MMatrix^ c22
)
F#
static let inline (*)
        c11:MMatrix *
        c22:MMatrix  : MItem

Parameters

c11
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c11"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

c22
Type: SMath.Math.Symbolic..::..MMatrix

[Missing <param name="c22"/> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

Return Value

[Missing <returns> documentation for "M:SMath.Math.Symbolic.MMatrix.op_Multiply(SMath.Math.Symbolic.MMatrix,SMath.Math.Symbolic.MMatrix)"]

See Also

MMatrix Class
Multiply Overload
SMath.Math.Symbolic Namespace


MMatrix Properties

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix Properties
MMatrix Class See Also Send Feedback

The MMatrix type exposes the following members.

Properties

 | Name | Description
Public property | Brackets | Необходимость скобки при записи выражения в виде текста. (Inherited from MItem.)
Public property | Cols | Количество столбцов в матрице
Public property | Inverse | Флаг-нидикатор обратного элемента (Inherited from MItem.)
Public property | Item[([( Int32])]) | Элемент по его порядковому номеру (Inherited from MItem.)
Public property | Item[([( Int32, Int32])]) | Элемент матрицы, заданный по строке и столбцу
Public property | Items | Зависимые элементы текущего математического элемента (Inherited from MItem.)
Public property | Negative | Знак математического элемента. (Inherited from MItem.)
Public property | Origin | Происхождение математического элемента (Inherited from MItem.)
Public property | Rows | Количество строк в матрице
Public property | Text | Текстовое представление элемента математического выражения. (Inherited from MItem.)
Public property | Type | Тип элемента математического выражения. (Inherited from MItem.)

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Cols Property

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Cols Property
MMatrix Class See Also Send Feedback
Количество столбцов в матрице

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public int Cols { get; }
Visual Basic
Public ReadOnly Property Cols As Integer
    Get
Visual C++
public:
property int Cols {
    int get ();
}
F#
member Cols : int

See Also

MMatrix Class
SMath.Math.Symbolic Namespace


Item Property

[image] [image]

SMath Studio Class Libraries Documantation
MMatrix..::..Item Property
MMatrix Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Элемент по его порядковому номеру (Inherited from MItem.)
Public property | Item[([( Int32, Int32])]) | Элемент матрицы, заданный по строке и столбцу

See Also

MMatrix Class
MMatrix Members
SMath.Math.Symbolic Namespace


Item Property (Int32, Int32)

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Item Property (Int32, Int32)
MMatrix Class See Also Send Feedback
Элемент матрицы, заданный по строке и столбцу

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public MItem this[
    int row,
    int col
] { get; set; }
Visual Basic
Public Property Item ( _
    row As Integer, _
    col As Integer _
) As MItem
    Get
    Set
Visual C++
public:
property MItem^ Item[int row, int col] {
    MItem^ get (int row, int col);
    void set (int row, int col, MItem^ value);
}
F#
member Item : MItem with get, set

Parameters

row
Type: System..::..Int32
Строка матрицы
col
Type: System..::..Int32
Столбец матрицы

Return Value

Элемент матрицы

See Also

MMatrix Class
Item Overload
SMath.Math.Symbolic Namespace


Rows Property

[image]

SMath Studio Class Libraries Documantation
MMatrix..::..Rows Property
MMatrix Class See Also Send Feedback
Количество строк в матрице

Namespace: SMath.Math.Symbolic
Assembly: SyLib (in SyLib.dll) Version: 1.21.3855.30320

Syntax

C#
public int Rows { get; }
Visual Basic
Public ReadOnly Property Rows As Integer
    Get
Visual C++
public:
property int Rows {
    int get ();
}
F#
member Rows : int

See Also

MMatrix Class
SMath.Math.Symbolic Namespace